$$INTRODUCTION$$ - %%projecttitle%%

OTA COM Type Library

Introduction

The Quality Center Open Test Architecture API is a COM library that enables you to integrate external applications with Quality Center. It is naturally and easily used with Microsoft Visual Basic, and the syntax and examples in this reference use Visual Basic. The examples in this project were developed with Microsoft Visual Basic 6.0 and are not necessarily valid under other development platforms.

For information about other implementation possibilities, see the Mercury Support Web Site Knowledge Base or consult your support representative.

If you have not already registered with the Mercury Support Web Site, you will need to do so on the Support Site. You will need the Maintenance Packing Number (MPN) which is included with the product shipment for a successful registration.

There are many ways to use Open Test Architecture programming to enhance site integration and customize Quality Center for your site. For example, you can:

  • Add OTA code within the Quality Center Workflow scripts to extend Workflow capabilities.
  • Create a custom test type.
  • Enhance Quality Center VAPI-XP tests.
  • Read information from a Quality Center project for use by an external tool or report generator, perhaps including sophisticated calculations on project data.
  • Synchronize two Quality Center projects. For example, get defects reported by contractors on a public server and add them to the development projects inside the firewall.
  • Synchronize customization data, such as custom lists, between projects on a site.
  • Write a custom test execution program with sophisticated logic.
  • Automatically format comment fields.
  • Integrate other site tools and data with Quality Center. For example, have all new hires added to the Quality Center site users by the same system that assigns email addresses, or have your project planning tool create new Quality Center projects, adding the planned project resources as Quality Center project users with group assignments in accordance with their roles in the project.
  • Integrate with other applications, such as Microsoft Excel and Word using the Microsoft Office Add-ins.
  • Use with QuickTest Professional to enhance integration with other products.

For other ideas and downloadable code segments, visit the Support Portal and explore the articles and downloads from Mercury Support and our customers. You will find useful material under Quality Center and TestDirector. When integrating with other Mercury products or using OTA from within other products, check the posts for the other product, as well.

 | Copyright 2002-2007 Mercury Interactive Corporation.
For additional examples and examples in C# and C++, see the Knowledge Base. | Documentation comments or suggestions? Please send feedback to SW-Doc@hp.com


$$GETTING_STARTED$$ - %%projecttitle%%

OTA COM Type Library

Getting Started

There are several ways to use the Quality Center Open Test Architecture API: by accessing the TDConnection object from the Workflow module or adding code to VAPI_XP tests, by using the QCUtil object in Quick Test Professional, by using add-ins that give access to the library from third party products, and by developing programs in a programming environment.

For more information about using the Open Test Architecture API from the Workflow module, see the Mercury Quality Center Administrator's Guide. For information about the QCUtil object, see the Quick Test Professional documentation. For information about add-ins, see the relevant Mercury Quality Center <Third party product name> Add-in Guide.

To use the Open Test Architecture API as a stand-alone tool, develop your own applications in a development environment that supports COM. You must download and register the COM library on every workstation that will communicate with the Quality Center server. You must have a reference to the library in your application development project.

The library, OTAClient.dll, is automatically downloaded to your workstation the first time you run Quality Center. Note that the OTAClient.dll is not backward compatible with versions prior to Quality Center 8.0.

To download the OTAClient.dll, access the Quality Center main page. Open your Web browser and type the URL given to you by your system administrator.

The library is downloaded when you run Quality Center by clicking the Quality Center link. Alternatively, click the Add-ins page link, select Mercury Quality Center Client Side Setup, and click Download Add-in.

The OTAClient.dll is downloaded to the following folder:
<installation drive>\Program Files\Common Files\Mercury Interactive\Quality Center

When you create your application development project, add the OTA COM Type Library to the project references.

The first action in any project is to create a connection. See the example for the TDConnection Object.


TDConnection Object

See Also

TDConnection Members

See Also OTA COM Type Library

OTA Object Model

Description

Overview of the major elements in the OTA Object Hierarchy.

This overview does not show the type of relationship between the elements. For example, TDConnection.ActionPermission is a reference to an ActionPermission object. These two code segments are functionally equivalent:
1)
Dim ActPer As ActionPermission
Set ActPer = tdc.ActionPermission
If ActPer.ActionEnabled("ac_add_bug") Then
2)
If tdc.ActionPermission("ac_add_bug") Then

However, this is not true of all objects. For example, factory objects do not directly refer the objects they manage. To get their objects, use AddItem, get an element from the list returned by NewList, or use Item.

The type of relationship between the elements may be different from object to object. For the details of how to get a reference to an object, see the help page for the specific source object.

Yellow symbols indicate that the object's children are shown where the object appears elsewhere in the diagram.

Object Model

See Also

TDConnection Members


%%phrase%%

OTA COM Type Library

Project Overview

Description

OTA COM Type Library

Classes

Class Module | Description
ActionPermission | Used to determine whether a specified action can be performed by users.
Alert | Notifications sent to the user.
AlertManager | Services for managing alerts.
AmarillusHash | Support for hash generation.
Attachment | Represents a single file or Internet address attached to a field object.
AttachmentFactory | Services for managing attachments of the current field object.
Auditable | Services to allow changes to an entity to be tracked.
AuditProperty | Represents a property associated with an AuditRecord.
AuditPropertyFactory | Services for managing AuditProperty objects.
AuditRecord | A data change that is tracked.
AuditRecordFactory | Services for managing AuditRecord objects.
BPComponent | An instance of a Component in a Business Process.
BPGroup | Support for grouping business components so that they iterate as a unit.
BPIteration | The design-time definition of a business process test iteration.
BPIterationParam | An instance of a business component parameter that belongs to a single iteration of the business process test.
BPParameter | An instance of a parameter in a business component.
BPStepParam | A step parameter for a manual run of the business process test.
BPStepParamFactory | Services for managing BPStepParam objects.
Bug | A defect.
BugFactory | Services for managing defect records.
BusinessProcess | Represents a single Business Process Test.
Command | Represents a database command.
Component | Represents a business component.
ComponentFactory | Services for managing business components.
ComponentFolder | Represents a business component folder.
ComponentFolderFactory | Services for managing the organization of business components.
ComponentParam | Services for managing Business Process Test parameters.
ComponentParamFactory | Services to manage component parameters.
ComponentStep | Represents a step in a business component.
ComponentStepFactory | Services to manage ComponentStep objects.
Condition | Represents a condition for a test to be executed.
ConditionFactory | Services for managing conditions for executing test instances in an test set.
CoverageEntity | Represents the association between a requirement and another entity that covers it.
CoverageFactory | Services for managing CoverageEntity objects.
Customization | Customization services, such as adding users to user groups, maintaining user-defined fields, configuring user access privileges.
CustomizationAction | Represents a type of user action such as adding or deleting a bug. Actions are listed in the AC_ACTION_NAME field of the Actions table.
CustomizationActions | The collection of all CustomizationAction objects.
CustomizationField | Services for customizing project fields.
CustomizationFields | The collection of all CustomizationField objects.
CustomizationList | Represents a user-defined list associated with a field.
CustomizationListNode | Represents a node in a list.
CustomizationLists | The collection of all CustomizationList objects.
CustomizationMailCondition | The configuration of a custom automatic mail notification.
CustomizationMailConditions | The collection of CustomizationMailCondition configurations for custom automatic mail notifications.
CustomizationModules | Services for managing the customization modules.
CustomizationPermissions | Properties that define the ability of user groups to add, remove, and modify entities.
CustomizationRBT | Customization of the RBT mechanism default values.
CustomizationRBTAnswer | A possible answer for a business implact or failure probablity question, used to assess a risk.
CustomizationRBTQuestion | A business impact or failure probability question, used to assess a risk.
CustomizationReqType | A Customization type of the requirement entity.
CustomizationTransitionRule | Represents a single transition rule.
CustomizationTransitionRules | A collection of CustomizationTransitionRule objects applied to a specific field and user group.
CustomizationTypedField | An association between a CustomizationField and an object of a class that implements ICustomizationType.
CustomizationTypes | A collection of Customization types of a specific entity. For example, the types of the requirement entity.
CustomizationUser | Represents a user for purposes of adding and removing the user to and from user groups.
CustomizationUsers | The collection of all CustomizationUser objects.
CustomizationUsersGroup | Represents a user group for purposes of adding and removing users.
CustomizationUsersGroups | The collection of all CustomizationUsersGroup objects.
Cycle | Represents a release cycle.
CycleFactory | Services for managing release cycles.
DesignStep | Represents a single design step in a test.
DesignStepFactory | Services for managing design steps in a Test object.
ExecEventActionParams | Actions to be taken after the completion of a test set run.
ExecEventInfo | The execution information of the scheduler. This object handles the actual, not the planned, information.
ExecEventNotifyByMailSettings | Represents the notification to be sent by e-mail after a test has completed its run.
ExecEventRestartActionParams | Information on actions to be taken during restart after completion of a test set.
ExecSettings | The information on the execution of a test set.
ExecutionStatus | Represents the execution status of the scheduler.
ExtendedStorage | Represents a storage structure used to transfer files between the server and client file system and delete files.
ExtendedStorageProxy | Represents the project repository. The implementation is either in the file system or database depending on the project configuration.
FactoryList | Create and maintain lists within entity factories. Use any factory object to create any number of list instances for objects in the factory.
FieldProperty | Properties for object fields.
FileData | Information about a folder or file.
Graph | Represents a graph built through a method.
GraphBuilder | Services for creating graphs.
GraphDefinition | Configuration information used to build a graph.
HierarchyFilter | Services for creation of a filtered list of field objects without SQL.
HierarchySupportList | Services to create and maintains lists of items and their parent objects.
History | Enables retrieval of a list of history records.
HistoryRecord | Represents a single change.
Host | Represents a single host server.
HostFactory | Services for managing host servers definitions.
HostGroup | Services for managing a group of host servers.
HostGroupFactory | Services for managing definitions of groups of host servers.
Link | Represents an association between a Bug and another entity.
LinkFactory | Services to manage Link objects.
List | Create and maintain lists. Use any factory object to create any number of list instances for objects in the factory.
Module | Represents a Quality Center module, such as Requirements, Defects, TestPlan, and so on.
MultiValue | Represents several values stored in a single field.
ProductInfo | Information about the current version.
ProjectProperties | Global project parameters and settings.
ProjectRepository | Represents the project repository when stored in the database. Not used if the repository is on the file system.
Recordset | Represents the entire set of records resulting from an executed command. At any given time, a Recordset object refers to a single record within the record set as the current record.
Release | Represents a Release.
ReleaseFactory | Services for managing releases.
ReleaseFolder | Represents a Release folder.
ReleaseFolderFactory | Services for managing release folders.
ReleaseManagementInfo | Represents a release or cycle.
Req | Represents a requirement for which testing must be performed.
ReqCoverageFactory | ReqCoverageFactory Class.
ReqFactory | Services for managing requirements.
ReqTraceFactory | Services for managing traceability associations between requirements.
ReqType | Represents a Requirement Type.
RTParam | A Business Process Test runtime parameter.
Rule | Represents a rule for generating an alert.
RuleManager | Services for managing the notification rules.
Run | Represents a test run.
RunFactory | Services for managing test runs.
SearchOptions | Options for controlling searches.
Settings | Represents users' settings in various user-defined categories.
Step | Represents a test step in a test run.
StepFactory | Services for managing test steps for a Run object.
StepParams | A collection of test parameters.
SubjectNode | Represents a subject folder in a Quality Center subject tree.
SysTreeNode | Represents a system folder, that is, a tree node in the TreeManager object.
TDConnection | Represents a single server connection.
TDField | Properties for a field.
TDFilter | Services for creation of a filtered list of field objects without SQL.
TDMailConditions | Services for managing automatic mail notifications.
Test | Represents a planning test.
TestExecStatus | Represents the execution status of the test currently running.
TestFactory | Services for managing tests.
TestSet | A group of tests designed to meet a specific testing goal.
TestSetFactory | Services for managing test sets.
TestSetFolder | Manages the tests and test sets included in a particular test set folder.
TestSetTreeManager | Manages the test set tree and its related test set folders.
TextParser | Utilities for handling parameters in a string.
Trace | Represents a traceability association between two requirements.
TreeManager | Represents the system tree, containing a subject tree and all hierarchical field trees.
TSScheduler | Responsible for executing selected automated tests.
TSTest | Represents a test instance, or execution test, in a test set.
TSTestFactory | Manages test instances (TSTest objects) in a test set.
VCS | Represents a Version Control System connection.
VersionItem | Represents specific version information.

Interfaces

Class Module | Description
IActionPermission | Services to manage user permissions for actions.
IAlert | Represents a notification sent to the user.
IAlertable | Services for managing auto-alerts.
IAlertable2 | Services for managing auto-alerts.
IAlertableEntityFactory | A factory implements this interface to indicate that it can instantiate objects that implement the IAlertable interface.
IAlertManager | Services for managing alerts.
IAmarillusHash | Support for hash generation.
IAttachment | Represents a single file or Internet address attached to a field object.
IAttachmentFactory | Services for managing attachments of the current field object.
IAuditable | Services to allow changes to an entity to be tracked.
IAuditProperty | Represents a property associated with an AuditRecord.
IAuditPropertyFactory | Services for managing AuditProperty objects.
IAuditRecord | A data change that is tracked.
IAuditRecordFactory | Services for managing AuditRecord objects.
IBaseFactory | Provides basic object basic factory services, such as adding and removing factory child objects and creating lists of child objects.
IBaseFactory2 | Provides basic object basic factory services, such as adding and removing factory child objects and creating lists of child objects.
IBaseFactoryEx | Enhances the IBaseFactory interface to support mailing.
IBaseField | Represents a basic data field or entity, such as an attachment.
IBaseField2 | Represents a basic data field or entity, such as an attachment.
IBaseField3 | Represents a basic data field or entity, such as an attachment.
IBaseFieldEx | Represents a basic data field or entity, such as an attachment. Use the properties and methods to perform field-related actions, such as setting and refreshing field values.
IBaseFieldExMail | Services to support mailing factory items.
IBPComponent | An instance of a Component in a Business Process.
IBPGroup | Support for grouping business components so that they iterate as a unit.
IBPIteration | The design-time definition of a business component iteration.
IBPIterationParam | An instance of a business component parameter that belongs to a single iteration.
IBPParam | An instance of a Component Parameter in a business component.
IBPStepParam | A step parameter for a manual run of the business process test.
IBug | Represents a defect.
IBugFactory | Services for managing defect records.
IBusinessProcess | Represents a single Business Process Test.
IColumnInfo | Represents column information for a Recordset.
ICommand | Represents a database command.
IComponent | Represents a business component.
IComponentFactory | Services for managing business components.
IComponentFolder | Represents a business component folder.
IComponentFolderFactory | Services for managing the organization of business components.
IComponentParam | Services for managing Business Process Test parameters.
IComponentStep | Represents a step in a business process test.
ICondition | Represents a condition for a test to be executed.
IConditionFactory | Services for managing conditions for executing test instances in an test set.
ICoverable | Represents an entity that covers a requirement.
ICoverableReq | Represents a requirement that is covered by another entity.
ICoverageEntity | Represents the association between a requirement and another entity that covers it.
ICoverageFactory | Services for managing CoverageEntity objects.
ICustomization | Services to perform customization tasks, such as adding users to user groups, defining user-defined fields, and defining user access privileges.
ICustomization2 | Services to perform customization tasks, such as adding users to user groups, defining user-defined fields, and defining user access privileges.
ICustomization3 | Customization services, such as adding users to user groups, maintaining user-defined fields, configuring user access privileges.
ICustomizationAction | Represents a type of user action such as adding or deleting a bug.
ICustomizationActions | The collection of all CustomizationAction objects.
ICustomizationField | Services for customizing project fields.
ICustomizationField2 | Services for customizing project fields.
ICustomizationFields | Services for managing the collection of all CustomizationField objects in the project.
ICustomizationList | Represents a user-defined list associated with a field.
ICustomizationListNode | Represents a node in a list.
ICustomizationLists | A collection of all CustomizationList objects in the project.
ICustomizationMailCondition | The configuration of a custom automatic mail notification.
ICustomizationMailConditions | The collection of configurations for custom automatic mail notifications.
ICustomizationModules | Services for managing the customization modules.
ICustomizationModules2 | Services for managing the customization modules.
ICustomizationModules3 | Services for managing the customization modules.
ICustomizationPermissions | Properties that define the ability of user groups to add, remove, and modify entities.
ICustomizationRBT | Customization of the RBT mechanism default values
ICustomizationRBTAnswer | A possible answer for a business implact or failure probablity question, used to assess a risk.
ICustomizationRBTQuestion | A business impact or failure probability question, used to assess a risk.
ICustomizationReqType | A Customization type of the requirement entity.
ICustomizationTransitionRule | Represents a single transition rule. A transition rule allows a change in value from a given source value to a given destination value.
ICustomizationTransitionRules | A collection of CustomizationTransitionRule objects applied to a specific field and user group.
ICustomizationType | Represents a Customization type of an entity.
ICustomizationTypedField | An association between a CustomizationField and an object of a class that implements ICustomizationType.
ICustomizationTypes | A collection of Customization types of a specific entity. For example, the types of the requirement entity.
ICustomizationUser | Represents a user for purposes of adding and removing the user to and from user groups.
ICustomizationUsers | Services for managing the collection of all CustomizationUser objects.
ICustomizationUsers2 | Services for managing the collection of all CustomizationUser objects.
ICustomizationUsersGroup | Represents a user group for purposes of adding and removing users.
ICustomizationUsersGroups | Services for managing the collection of all CustomizationUsersGroup objects.
ICustomizationUsersGroups2 | Services for managing the collection of all CustomizationUsersGroup objects.
ICycle | Represents a Cycle.
ICycleFactory | Services for managing release cycles.
IDesignStep | Represents a single design step in a test.
IExecEventInfo | The execution information of the scheduler. This object handles the actual, not the planned, information.
IExecEventNotifyByMailSettings | Represents the notification to be sent by e-mail after a test has completed its run.
IExecutionSettings | Information on the execution of a test set.
IExecutionStatus | Represents the execution status of the scheduler. The user can scan through each test in the scheduler.
IExtendedStorage | Represents a storage structure used to transfer files between the server and client file system and delete files.
IFactoryList | Services to create and maintains lists within entity factories. Use any factory object to create any number of list instances for objects in the factory.
IFieldProperty | Properties for a field.
IFieldProperty2 | Properties for object fields.
IFieldProperty3 | Properties for object fields.
IFileData | Information about a folder or file.
IFollowUpManager | Manages the user-defined follow-ups.
IGraph | Represents a graph built through a method.
IGraphBuilder | Services for creating graphs.
IGraphDefinition | Configuration information used to build a graph.
IHierarchyFilter | Services for creation of a filtered list of field objects without SQL.
IHierarchySupportList | Services to create and maintain lists of items and their parent objects.
IHistory | Supports retrieval of a list of history records for objects such as Test, Bug, Step, and others.
IHistoryRecord | Represents a single history change.
IHistoryRecord2 | Represents a single history change.
IHost | Represents a single host server. The ID of a host is its name.
IHostGroup | Services for managing a group of host servers.
IHostGroupFactory | Services for managing definitions of groups of host servers.
ILink | Represents an association between a Bug and another entity.
ILinkable | Services for managing links.
ILinkFactory | Services to manage Link objects.Services to manage Link objects.
IList | Services to create and maintain lists. Use any factory object to create any number of list instances for objects in the factory.
IMultiValue | Represents several values stored in a single field.
IObjectLockingSupport | Services to support locking objects.
IOnExecEventSchedulerActionParams | Handles the action parameter list.
IOnExecEventSchedulerRestartParams | Defines behavior after completion of a test set.
IParam | Services for managing parameters for a Command object.
IProductInfo | Information about the current version.
IRecordset | Represents the entire set of records resulting from an executed command. At any given time, the Recordset object refers to a single record within the record set as the current record.
IRelease | Represents a Release.
IReleaseFactory | Services for managing releases.
IReleaseFolder | Represents a Release Folder.
IReleaseFolderFactory | Services for managing release folders.
IReleaseManagementInfo | Represents a release or cycle.
IReq | Represents a requirement for which testing must be performed.
IReq2 | Represents a requirement for which testing must be performed.
IReqCoverageFactory | Services for managing requirement coverage.
IReqFactory | Services for managing requirements.
IReqFactory2 | Services for managing requirements.
IReqFactory3 | Services for managing requirements.
IReqTraceFactory | Services for managing traceability associations between requirements.
IReqType | Represents a Requirement Type.
IRule | Represents a rule for generating an alert.
IRule2 | Represents a rule for generating an alert.
IRuleManager | Services for managing the notification rules.
IRun | Represents a test run.
IRun2 | Represents a test run.
IRunFactory | Services for managing test runs.
ISearchableFactory | Services to support text searches in properties of objects managed by a factory.
ISearchOptions | Options for controlling searches.
ISequentialStream | The ISequentialStream interface supports simplified sequential access to stream objects. For more details, see Microsoft documentation.
ISettings | Represents users' settings in various user-defined categories.
ISettings2 | Represents users' settings in various user-defined categories.
IStep | Represents a test step in a test run.
IStep2 | Represents a test step in a test run.
IStepParams | A collection of test parameters.
IStream | Refer to Microsoft documentation.
IStringRepresentation | The string representation of the object.
ISubjectNode | Represents a subject folder in a Quality Center subject tree.
ISupportCopyPaste | Services for supporting copy and paste.
ISupportCopyPaste2 | Services for supporting copy and paste.
ISupportEntityTypes | Provides services for entities that support entity types.
ISupportRBTAnalysisChild | Represents RBT analysis capabilities for the Req coclass. Regarding the child Reqs affected by the analysis.
ISupportRBTAnalysisParent | Represents RBT analysis capabilities for the Req coclass. Regarding the parent of the analysis.
ISupportRBTAssessment | Represents RBT assessment capabilities for the Req coclass.
ISysTreeNode | Represents a system folder, which is a tree node in the TreeManager object.
ISysTreeNode2 | Represents a tree node.
ITableProperties | Description of a database table.
ITDConnection | Represents a single server connection.
ITDField | Represents a field with field system properties and other properties.
ITDFilter | Services for creation of a filtered list of field objects without SQL.
ITDFilter2 | Services for creation of a filtered list of field objects without SQL.
ITDMailConditions | Services for managing automatic mail notifications.
ITest | Represents a planning test.
ITestExecStatus | Represents the execution status of the test currently running.
ITestFactory | Services for managing tests.
ITestSet | Represents a series of tests to be run as a group to meet a specific testing goal.
ITestSetFactory | Services for managing test sets.
ITestSetFolder | Manages the tests and test sets included in one test set folder.
ITestSetFolder2 | Manages the tests and test sets included in one test set folder.
ITestSetFolder3 | Manages the tests and test sets included in one test set folder.
ITestSetTreeManager | Manages the test set tree and its related test set folders.
ITextParser | Utilities for handling parameters in a string.
ITrace | Represents a traceability association between two requirements.
ITreeManager | Represents the system tree, containing a subject tree and all hierarchical field trees.
ITSScheduler | Responsible for executing selected automated tests.
ITSTest | Represents a test instance, or execution test, in a test set.
ITSTest2 | Represents a test instance, or execution test, in a test set.
IVCS | Represents a Version Control System connection.
IVersionItem | Represents specific version information.

Public Enumerations

Enumeration | Description
tagALERT_TYPE |
tagBPPARAM_TYPE |
tagBPT_VERSION |
tagEXTENDED_STORAGE_DELETE |
tagEXTENDEDSTORAGE_ENTITY |
tagGRAPH_PROPERTIES |
tagMAIL_CONDITIONS_TYPE |
tagSEARCH_OPTIONS |
tagTDAPI_ATTACH | Attachment Flags.
tagTDAPI_ATTACH_SUBTYPE | Attachment Sub Type.
tagTDAPI_ATTACH_TYPE | Attachment Type.
tagTDAPI_BP_STEP_PARAM_TYPE |
tagTDAPI_COMPONENT_AUTO_TYPE | Components Automation Type Values.
tagTDAPI_CONDSTAT | Run condition statuses.
tagTDAPI_CONDTYPE | Execution flow condition type.
tagTDAPI_COPY_PASTE_MODES | Options for pasting design steps linked to tests where the linked tests already exist in the target project.
tagTDAPI_DATATYPES | Data types.
tagTDAPI_DIRECTORY |
tagTDAPI_ENTITIES | The entities for customization types.
tagTDAPI_ERRORCODES |
tagTDAPI_EUM_ORDER |
tagTDAPI_EXECUTIONEVENT |
tagTDAPI_EXECUTIONEVENTACTION |
tagTDAPI_EXECUTIONEVENTACTIONTARGET |
tagTDAPI_EXSTOR_DELMODE | Extended Storage file deletion flags. These can be used individually or combined with bitwise OR.
tagTDAPI_FDATA_TYPE |
tagTDAPI_FETCH_LEVEL |
tagTDAPI_FILTERORDER |
tagTDAPI_GET_EXTENSION_MODE |
tagTDAPI_GRANT_MODIFY |
tagTDAPI_GRAPH_TYPE |
tagTDAPI_LICENSE |
tagTDAPI_MODULE |
tagTDAPI_NODE_TYPE | Node Types.
tagTDAPI_NODEATTRIBUTE |
tagTDAPI_PARAM_IN_OUT_TYPE |
tagTDAPI_POS_ORDER | Position markers for a list or collection.
tagTDAPI_PREDEFINED_REQ_TYPES | IDs of the predefined requirement types.
tagTDAPI_PURGE_RUNS | The units by which to purge.
tagTDAPI_RBT_BI_LEVELS | RBT Business impact levels.
tagTDAPI_RBT_FP_LEVELS | RBT Failure probability levels.
tagTDAPI_RBT_REQUIREMENT_TYPE_RISK_ANALYSIS_TYPE | Risk-based testing Requirement Type Risk Analysis Type.
tagTDAPI_RBT_RISK_KINDS | RBT Risk kinds.
tagTDAPI_RBT_TESTING_LEVELS | RBT Testing levels.
tagTDAPI_REQ_TREE | Constants for the requirement tree.
tagTDAPI_REQMODE | Flags for requirement factory Find method. Can be combined with binary OR.
tagTDAPI_ROOTLIST |
tagTDAPI_RUN_PARAM_MODE | Parameter handling at run time.
tagTDAPI_SKIP | Interval flags for graphs and summation by interval methods.
tagTDAPI_STEP_CREATE | Step modification mode.
tagTDAPI_STEP_PARAM_TYPE |
tagTDAPI_TRACE_DIRECTION | Trace directions - 'TO' or 'FROM' this item.
tagTDAPI_TREETYPE |
tagTDLICENSE_CLIENT |
tagTDMAIL_FLAGS |
TDAPI_ATTACH | Attachment Flags.
TDAPI_ATTACH_SUBTYPE | Attachment Sub Type.
TDAPI_ATTACH_TYPE | Attachment Type.
TDAPI_COMPONENT_AUTO_TYPE | Components Automation Type Values.
TDAPI_CONDSTAT | Run condition statuses.
TDAPI_CONDTYPE | Execution flow condition type.
TDAPI_COPY_PASTE_MODES | Options for pasting design steps linked to tests where the linked tests already exist in the target project.
TDAPI_DATATYPES | Data types.
TDAPI_ENTITIES | The entities for customization types.
TDAPI_EXSTOR_DELMODE | Extended Storage file deletion flags. These can be used individually or combined with bitwise OR.
TDAPI_NODE_TYPE | Node Types.
TDAPI_POS_ORDER | Position markers for a list or collection.
TDAPI_PREDEFINED_REQ_TYPES | IDs of the predefined requirement types.
TDAPI_PURGE_RUNS | The units by which to purge.
TDAPI_RBT_BI_LEVELS | RBT Business impact levels.
TDAPI_RBT_FP_LEVELS | RBT Failure probability levels.
TDAPI_RBT_REQUIREMENT_TYPE_RISK_ANALYSIS_TYPE | Risk-based testing Requirement Type Risk Analysis Type.
TDAPI_RBT_RISK_KINDS | RBT Risk kinds.
TDAPI_RBT_TESTING_LEVELS | RBT Testing levels.
TDAPI_REQ_TREE | Constants for the requirement tree.
TDAPI_REQMODE | Flags for requirement factory Find method. Can be combined with binary OR.
TDAPI_RUN_PARAM_MODE | Parameter handling at run time.
TDAPI_SKIP | Interval flags for graphs and summation by interval methods.
TDAPI_STEP_CREATE | Step modification mode.
TDAPI_TRACE_DIRECTION | Trace directions - 'TO' or 'FROM' this item.

Public UDTs

UDT | Description
tagSTATSTG | For details of the tagSTATSTG structure, see Microsoft documentation.


Business Components Module

Description

The Business Components module business handles business process tests.

Caution: The Business Components module is newly introduced. It can be anticipated that changes will be introduced based on customer feedback. Therefore, Mercury Interactive does not expect that later versions of this module of the Open Test Architecture API will be backward compatible.

Principle Objects Used in Module

Class Module | Description
BPComponent | An instance of a Component in a Business Process.
BPGroup | Support for grouping business components so that they iterate as a unit.
BPIteration | The design-time definition of a business process test iteration.
BPIterationParam | An instance of a business component parameter that belongs to a single iteration of the business process test.
BPParameter | An instance of a parameter in a business component.
BPStepParam | A step parameter for a manual run of the business process test.
BPStepParamFactory | Services for managing BPStepParam objects.
BusinessProcess | Represents a single Business Process Test.
Component | Represents a business component.
ComponentFactory | Services for managing business components.
ComponentFolder | Represents a business component folder.
ComponentFolderFactory | Services for managing the organization of business components.
ComponentParam | Services for managing Business Process Test parameters.
ComponentParamFactory | Services to manage component parameters.
ComponentStep | Represents a step in a business component.
ComponentStepFactory | Services to manage ComponentStep objects.

See Also

TDConnection Members


Customization Module

Description

The Customization module handles meta-properties for a project. For example, it handles settings that affect individual users, groups of users, and user and group access rights. The module consists of a Customization object that has multiple children called customization categories, for example, rules, modules, types, lists and so on.

To use the Customization module, get the Customization object from TDConnection.Customization. Set the desired values of the child objects. When you are finished, call Customization.Commit. After the Commit, the customization object references in the application are not valid. To continue to make changes after a commit, get new references.

The changes take affect on your TDConnection you created immediately after the Commit. On other connections, the changes take effect at the next log-on to the project.

Principle Objects Used in Module

Object | Description
Customization | Customization services, such as adding users to user groups, maintaining user-defined fields, configuring user access privileges.
CustomizationAction | Represents a type of user action such as adding or deleting a bug. Actions are listed in the AC_ACTION_NAME field of the Actions table.
CustomizationActions | The collection of all CustomizationAction objects.
CustomizationField | Represents a user-defined field.
CustomizationFields | The collection of all CustomizationField objects.
CustomizationList | Represents a user-defined list associated with a field.
CustomizationListNode | Represents a node in a list.
CustomizationLists | The collection of all CustomizationList objects.
CustomizationMailCondition | The configuration of a custom automatic mail notification.
CustomizationMailConditions | The collection of CustomizationMailCondition configurations for custom automatic mail notifications.
CustomizationModules | Services for managing the customization modules.
CustomizationPermissions | Properties that define the ability of user groups to add, remove, and modify entities.
CustomizationReqType | A Customization type of the requirement entity.
CustomizationTransitionRule | Represents a single transition rule.
CustomizationTransitionRules | A collection of CustomizationTransitionRule objects applied to a specific field and user group.
CustomizationTypedField | An association between a CustomizationField and a CustomizationType.
CustomizationTypes | A collection of Customization types of a specific entity - e.g. all types of the requirement entity.
CustomizationUser | Represents a user for purposes of adding and removing the user to and from user groups.
CustomizationUsers | The collection of all CustomizationUser objects.
CustomizationUsersGroup | Represents a user group for purposes of adding and removing users.
CustomizationUsersGroups | The collection of all CustomizationUsersGroup objects.

See Also

TDConnection Members


Defects Module

Description

The Defects module handles the creating of Bug objects and their links to other entities.

Principle Objects Used in Module

Object | Description
Bug | A defect.
BugFactory | Services for managing defect records.
Link | Represents an association between a Bug and another entity.
LinkFactory | Services to manage Link objects.

See Also

TDConnection Members


Release Module

Description

The Release module handles release and release cycles.

Principle Objects Used in Module

Class Module | Description
Cycle | Represents a release cycle.
CycleFactory | Services for managing release cycles.
Release | Represents a Release.
ReleaseFactory | Services for managing releases.
ReleaseFolder | Represents a Release folder.
ReleaseFolderFactory | Services for managing release folders.
ReleaseManagementInfo | ReleaseManagementInfo Class

See Also

TDConnection Members


Requirements Module

Description

The Requirements module handles requirements and the coverage of requirements by other entities.

Principle Objects Used in Module

Object | Description
CustomizationReqType | A Customization type of the requirement entity.
Req | Represents a requirement for which testing must be performed.
ReqCoverageFactory | ReqCoverageFactory Class
ReqCoverageStatus | ReqCoverageStatus Class.
ReqFactory | Services for managing requirements.
ReqSummaryStatus | ReqSummaryStatus Class.
ReqTraceFactory | Traceability links factory.

See Also

TDConnection Members


Risk-Based Testing Module

Description

Risk-Based Testing deals with the analysis of risk and effort in testing.

Principle Objects Used

Class Module | Description
CustomizationRBT | Customization of the RBT mechanism default values
CustomizationRBTAnswer | A possible answer for a business implact or failure probablity question, used to assess a risk.
CustomizationRBTQuestion | A business impact or failure probability question, used to assess a risk.

See Also

TDConnection Members


Test Lab Module

Description

The Test Lab module handles the many activities involved in creating an test instance, TSTest, from the planning Test, organizing the instances into sets of tests to be run together, and running the test set.

Principle Objects Used in Module

Object | Description
Condition | Represents a condition for a test to be executed.
ConditionFactory | Services for managing conditions for executing test instances in an test set.
CoverageEntity | Represents the association between a requirement and another entity that covers it.
CoverageFactory | Services for managing CoverageEntity objects.
ExecEventActionParams | Actions to be taken after the completion of a test set run.
ExecEventInfo | The execution information of the scheduler. This object handles the actual, not the planned, information.
ExecEventNotifyByMailSettings | Represents the notification to be sent by e-mail after a test has completed its run.
ExecEventRestartActionParams | Information on actions to be taken during restart after completion of a test set.
ExecSettings | The information on the execution of a test set.
ExecutionStatus | Represents the execution status of the scheduler.
Host | Represents a single host server.
HostFactory | Services for managing host servers definitions.
HostGroup | Services for managing a group of host servers.
HostGroupFactory | Services for managing definitions of groups of host servers.
Run | Represents a test run.
RunFactory | Services for managing test runs.
Step | Represents a test step in a test run.
StepFactory | Services for managing test steps for a Run object.
StepParams | A collection of test parameters.
TestExecStatus | Represents the execution status of the test currently running.
TestSet | A group of tests designed to meet a specific testing goal.
TestSetFactory | Services for managing test sets.
TestSetFolder | Manages the tests and test sets included in a particular test set folder.
TestSetTreeManager | Manages the test set tree and its related test set folders.
TSScheduler | Responsible for executing selected automated tests.
TSTest | Represents a test instance, or execution test, in a test set.
TSTestFactory | Manages test instances (TSTest objects) in a test set.

See Also

TDConnection Members


Test Plan Module

Description

The Test Plan module handles creation of the design tests to be used in the creation of test instances in the Test Lab module.

Principle Objects Used in Module

Object | Description
CoverageEntity | Represents the association between a requirement and another entity that covers it.
CoverageFactory | Services for managing CoverageEntity objects.
DesignStepFactory | Services for managing design steps in a Test object.
SubjectNode | Represents a subject folder in a Quality Center subject tree.
SysTreeNode | Represents a system folder, that is, a tree node in the TreeManager object.
Test | Represents a planning test.
TestFactory | Services for managing tests.
TreeManager | Represents the system tree, containing a subject tree and all hierarchical field trees.

See Also

TDConnection Members


%%PageItemTitle%%

ActionPermission Members

ActionPermission Object

Description

Used to determine whether a specified action can be performed by users.

Remarks

Get an ActionPermission object from TDConnection.ActionPermission.

Example

Dim ActPer As ActionPermission

'tds is a TDConnection object
Set ActPer = tdc.ActionPermission

If ActPer.ActionEnabled("ac_add_bug") Then

' current user allowed to add bug
' .... your code here

Else
' current user not allowed to add bug
' .... your code here

End If

Public Properties

Public Property ActionEnabled Checks if the user has rights to perform the specified action.


%%PageItemTitle%%

ActionPermission Object

ActionIdentity

Specifies the action. To get the full list of actions at your site, see the

ACTIONS table using the Site Administrator UI.

The most common options are:

ac_add_bug, ac_add_common_settings, ac_add_cover, ac_add_cycle, ac_add_cyclefolder, ac_add_cycle_to_cyclefolder, ac_add_desstep, ac_add_folder, ac_add_private_settings, ac_add_r&d_comments, ac_add_req ac_add_reqfolder, ac_add_test, ac_add_test_to_testcycl, ac_change_password, ac_clear_history, ac_configure_mail, ac_copy_cycle, ac_copy_folder, ac_copy_cyclefolder, ac_create_rbr_files, ac_create_views, ac_create_wr_script, ac_customize_fields, ac_delete_bug, ac_delete_common_settings, ac_delete_cover, ac_delete_cycle, ac_delete_cycle_from_cyclefolder, ac_delete_cyclefolder, ac_delete_desstep, ac_delete_folder, ac_delete_private_settings, ac_delete_req, ac_delete_run, ac_delete_test, ac_delete_test_from_testcycl, ac_import_bugs_from_file, ac_import_bugs_from_mail, ac_import_bugs_settings, ac_import_wr_tests, ac_modify_bug, ac_modify_common_settings, ac_modify_cycle, ac_modify_desstep, ac_modify_folder, ac_modify_hosts, ac_modify_private_settings, ac_modify_req, ac_modify_reqfolder, ac_modify_run, ac_modify_test, ac_modify_test_in_testcycl, ac_move_folder, ac_move_cyclefolder, ac_remove_reqfolder, ac_reset_cycle, ac_run_auto_test, ac_run_manual_test, ac_send_all_qualified, ac_test_exec_params, ac_users, ac_wr_settings

ActionTarget

The object on which the specified action is performed, or the user performing the action.

To determine whether the action can be performed by the current user on a specific test or other object, the ActionTarget parameter value should be a reference to the object.

To determine whether the specified action can be performed by a specific user, the ActionTarget parameter value should be the user name (string).

See Also OTA COM Type Library

ActionEnabled Property

Description

Checks if the user has rights to perform the specified action.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ActionEnabled( _
   ByVal ActionIdentity As Variant, _
   Optional ByVal ActionTarget As Variant _
) As Boolean

Parameters

ActionIdentity

Specifies the action. To get the full list of actions at your site, see the

ACTIONS table using the Site Administrator UI.

The most common options are:

ac_add_bug, ac_add_common_settings, ac_add_cover, ac_add_cycle, ac_add_cyclefolder, ac_add_cycle_to_cyclefolder, ac_add_desstep, ac_add_folder, ac_add_private_settings, ac_add_r&d_comments, ac_add_req ac_add_reqfolder, ac_add_test, ac_add_test_to_testcycl, ac_change_password, ac_clear_history, ac_configure_mail, ac_copy_cycle, ac_copy_folder, ac_copy_cyclefolder, ac_create_rbr_files, ac_create_views, ac_create_wr_script, ac_customize_fields, ac_delete_bug, ac_delete_common_settings, ac_delete_cover, ac_delete_cycle, ac_delete_cycle_from_cyclefolder, ac_delete_cyclefolder, ac_delete_desstep, ac_delete_folder, ac_delete_private_settings, ac_delete_req, ac_delete_run, ac_delete_test, ac_delete_test_from_testcycl, ac_import_bugs_from_file, ac_import_bugs_from_mail, ac_import_bugs_settings, ac_import_wr_tests, ac_modify_bug, ac_modify_common_settings, ac_modify_cycle, ac_modify_desstep, ac_modify_folder, ac_modify_hosts, ac_modify_private_settings, ac_modify_req, ac_modify_reqfolder, ac_modify_run, ac_modify_test, ac_modify_test_in_testcycl, ac_move_folder, ac_move_cyclefolder, ac_remove_reqfolder, ac_reset_cycle, ac_run_auto_test, ac_run_manual_test, ac_send_all_qualified, ac_test_exec_params, ac_users, ac_wr_settings

ActionTarget

The object on which the specified action is performed, or the user performing the action.

To determine whether the action can be performed by the current user on a specific test or other object, the ActionTarget parameter value should be a reference to the object.

To determine whether the specified action can be performed by a specific user, the ActionTarget parameter value should be the user name (string).

See Also

ActionPermission Object


%%PageItemTitle%%

Alert Members

Alert Object

Description

Notifications sent to the user.

Remarks

The Alert object handles alerting users' changes in certain tables, tests, and so on, as configured. Alerts may also be user-defined follow-ups to remind the user regarding the object, sent at a pre-determined date.

Get an Alert object with TDConnection.AlertManager.

See also: The Rule Object

Public Properties

Public Property AlertDate | The date that the alert was generated, based on the database server clock.
Public Property AlertType | The type of alert generated: Alert or Follow-up.
Public Property Description | The description of the alert.
Public Property ID | The alert or follow-up ID.
Public Property Subject | A short summary appropriate to be used as subject line of the Alert e-mail.
Public Property Unread | If true, the alert or follow-up has not yet been read.


%%PageItemTitle%%

Alert Object

AlertDate Property

Description

The date that the alert was generated, based on the database server clock.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AlertDate() As Date

See Also

Alert Object


%%PageItemTitle%%

Alert Object

AlertType Property

Description

The type of alert generated: Alert or Follow-up.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AlertType() As Long

See Also

Alert Object


%%PageItemTitle%%

Alert Object

Description Property

Description

The description of the alert.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Description() As String

See Also

Alert Object


%%PageItemTitle%%

Alert Object

ID Property

Description

The alert or follow-up ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Long

See Also

Alert Object


%%PageItemTitle%%

Alert Object

Subject Property

Description

A short summary appropriate to be used as subject line of the Alert e-mail.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Subject() As String

See Also

Alert Object


%%PageItemTitle%%

Alert Object

Unread Property

Description

If true, the alert or follow-up has not yet been read.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Unread() As Boolean

See Also

Alert Object


%%PageItemTitle%%

AlertManager Members

AlertManager Object

Description

Services for managing alerts.

Remarks

Get an AlertManager object with TDConnection.AlertManager.

Public Methods

Public Method CleanAllAlerts | Removes all current alerts from the database.
Public Method DeleteAlert | Removes an alert or alerts related to the current object from the database.
Public Method DeleteAlertsByFilter | Removes alerts associated with objects of the specified type from the database if they match the filter.

Public Properties

Public Property Alert | Gets the Alert object for the alert with the specified ID.
Public Property AlertList | The list of user alerts.


%%PageItemTitle%%

AlertManager Object

CleanAllAlerts Method

Description

Removes all current alerts from the database.

Syntax

Public Sub CleanAllAlerts()

See Also

AlertManager Object


%%PageItemTitle%%

AlertManager Object

IDs
An Alert.ID or "[ALL]", "[TEST]", "[TESTCYCL]" or "[BUG]".
See Also OTA COM Type Library

DeleteAlert Method

Description

Removes an alert or alerts related to the current object from the database.

Syntax

Public Sub DeleteAlert( _
   ByVal IDs As Variant _
)

Parameters

IDs
An Alert.ID or "[ALL]", "[TEST]", "[TESTCYCL]" or "[BUG]".

See Also

AlertManager Object


%%PageItemTitle%%

AlertManager Object

EntityType
One of REQ, TEST, TESTCYCL, or BUG.
Filter
A TDFilter.Text to restrict the deletion to a subset of the user's visible alerts. To delete all visible alerts, pass an empty string.
See Also OTA COM Type Library

DeleteAlertsByFilter Method

Description

Removes alerts associated with objects of the specified type from the database if they match the filter.

Syntax

Public Sub DeleteAlertsByFilter( _
   ByVal EntityType As String, _
   ByVal Filter As String _
)

Parameters

EntityType
One of REQ, TEST, TESTCYCL, or BUG.
Filter
A TDFilter.Text to restrict the deletion to a subset of the user's visible alerts. To delete all visible alerts, pass an empty string.

Remarks

This function deletes all visible alerts of the specified entity type for which the current session user is the owner of the alert or follow-up. Alerts that are not visible because they are filtered by the this user's group data hiding are not deleted.

For more details on the entity types, see Req, Test, TESTCYCL (TestSet), and Bug.

See Also

AlertManager Object


%%PageItemTitle%%

AlertManager Object

ID
An Alert.ID.
See Also OTA COM Type Library

Alert Property

Description

Gets the Alert object for the alert with the specified ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alert( _
   ByVal ID As Long _
) As Object

Parameters

ID
An Alert.ID.

See Also

AlertManager Object


%%PageItemTitle%%

AlertManager Object

EntityType
One of: "ALL", "TEST", "TESTCYCL", or "BUG".
NeedRefresh
If True, refresh the local cache from the project database.
See Also OTA COM Type Library

AlertList Property

Description

The list of user alerts.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AlertList( _
   ByVal EntityType As String, _
   Optional ByVal NeedRefresh As Boolean = False _
) As List

Parameters

EntityType
One of: "ALL", "TEST", "TESTCYCL", or "BUG".
NeedRefresh
If True, refresh the local cache from the project database.

See Also

AlertManager Object


%%PageItemTitle%%

AmarillusHash Members

AmarillusHash Object

Description

Support for hash generation.

Public Methods

Public Method GenerateHash Gets a Hash generated from the input value.


%%PageItemTitle%%

AmarillusHash Object

Value
The source string for which to generate a hash code.
See Also OTA COM Type Library

GenerateHash Method

Description

Gets a Hash generated from the input value.

Syntax

Public Function GenerateHash( _
   ByVal Value As String _
) As String

Parameters

Value
The source string for which to generate a hash code.

See Also

AmarillusHash Object


%%PageItemTitle%%

Attachment Members

Attachment Object

Description

Represents a single file or Internet address attached to a field object.

Remarks

An Attachment object represents a single a file or Internet address attached to a field object and opened directly from Quality Center. For example, design documents, detailed defect descriptions, graphic files, and Web pages can be used as attachments.

Get an Attachment object through the Attachments property (attachment factory) of any object that implements IBaseFieldEx, SubjectNode.Attachments, or TestSetFolder.Attachments.

Interfaces

IBaseField2 | IBaseField3

Public Methods

Public Method Load | Downloads an attachment file to a client machine.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Rename | Renames the attachment on the server. The attachment must be uploaded before calling this method.
Public Method Save | Uploads a file to the server.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AttachmentStorage | The ExtendedStorage object of this attachment. Applies only to file attachments.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Data | If the attachment is a file, an array of bytes. If a reference to file, the path or URL.
Public Property Description | The attachment description.
Public Property DirectLink | The link or path to the attachment.
Public Property Field | The value of the specified field.
Public Property FileName | If a file, the file location. If a virtual file, the location for the attachment before it is uploaded to the server. If a URL, the link address.
Public Property FileSize | The attachment file size in bytes.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property LastModified | The last modified time.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The attachment name.
Public Property ServerFileName | The attachment file name on the server machine.
Public Property Type | The attachment type. Either File or URL.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

Attachment Object

synchronize
If true, program run waits for download to complete. Otherwise, download is asynchronous.
RootPath

Output string variable. After the method returns, the value is the path to which the file was downloaded on the client machine.

The RootPath variable cannot be used in VBScript. See the example below for how to get the path in VBScript.

See Also OTA COM Type Library

Load Method

Description

Downloads an attachment file to a client machine.

Syntax

Public Sub Load( _
   ByVal synchronize As Boolean, _
   ByRef RootPath As String _
)

Parameters

synchronize
If true, program run waits for download to complete. Otherwise, download is asynchronous.
RootPath

Output string variable. After the method returns, the value is the path to which the file was downloaded on the client machine.

The RootPath variable cannot be used in VBScript. See the example below for how to get the path in VBScript.

Example

The RootPath argument cannot be used in a VBScript. For applications that must be written in VBScript, such as VAPI-XP tests, pass an empty string.

[Visual Basic]

Sub Test_Main(Debug, CurrentTestSet, CurrentTest, CurrentRun)

  On Error Resume Next

  TDOutput.Clear

  Set BugFact = TDConnection.BugFactory
  Set theBug = BugFact.Item(21)
  Set AttachFact = theBug.Attachments
  Set theAttachCol = AttachFact.NewList("")
  Set theAttach = theAttachCol.Item(1)

  'This works in VB, but not in VBScript:
  'theAttach.Load True, LoadPath

  'In VBScript, use this:
  theAttach.Load True, ""
  tdoutput.Print theAttach.FileName

  ' To get the path in VBScript, extract if from
  ' the filename:
  theFileName = theAttach.FileName
  tdoutput.Print theFileName
  thePath = Left(theFileName, InstrRev(theFileName, "\")-1)
  tdoutput.Print thePath

  ' handle run-time errors
  If Err.Number <> 0 Then

    TDOutput.Print "Run-time error [" & Err.Number & "] : " & Err.Description

    ' update execution status in "Test" mode

    If Not Debug Then

      CurrentRun.Status = "Failed"

      CurrentTest.Status = "Failed"

    End If

  End If

End Sub

See Also

Attachment Object

Example

Updating an attachment | Downloading a file from an attachment object


%%PageItemTitle%%

Attachment Object

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Attachment Object


%%PageItemTitle%%

Attachment Object

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Attachment Object


%%PageItemTitle%%

Attachment Object

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Attachment Object


%%PageItemTitle%%

Attachment Object

NewName
The new name for the attachment.
See Also OTA COM Type Library

Rename Method

Description

Renames the attachment on the server. The attachment must be uploaded before calling this method.

Syntax

Public Sub Rename( _
   ByVal NewName As String _
)

Parameters

NewName
The new name for the attachment.

See Also

Attachment Object


%%PageItemTitle%%

Attachment Object

synchronize
If true, program run waits for upload to complete. Otherwise, upload is asynchronous.
See Also OTA COM Type Library

Save Method

Description

Uploads a file to the server.

Syntax

Public Sub Save( _
   ByVal synchronize As Boolean _
)

Parameters

synchronize
If true, program run waits for upload to complete. Otherwise, upload is asynchronous.

See Also

Attachment Object

Example

Updating an attachment


%%PageItemTitle%%

Attachment Object

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

Attachment Object


%%PageItemTitle%%

Attachment Object

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

Attachment Object


%%PageItemTitle%%

Attachment Object

AttachmentStorage Property

Description

The ExtendedStorage object of this attachment. Applies only to file attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AttachmentStorage() As Object

See Also

Attachment Object

Example

Downloading test files and attachments


%%PageItemTitle%%

Attachment Object

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

Attachment Object


%%PageItemTitle%%

Attachment Object

Data Property

Description

If the attachment is a file, an array of bytes. If a reference to file, the path or URL.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Data() As Variant

See Also

Attachment Object


%%PageItemTitle%%

Attachment Object

Description Property

Description

The attachment description.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Description() As String

See Also

Attachment Object


%%PageItemTitle%%

Attachment Object

DirectLink Property

Description

The link or path to the attachment.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DirectLink() As String

See Also

Attachment Object


%%PageItemTitle%%

Attachment Object

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName

The name of the field in the project database.

See Also

Attachment Object


%%PageItemTitle%%

Attachment Object

FileName Property

Description

If a file, the file location. If a virtual file, the location for the attachment before it is uploaded to the server. If a URL, the link address.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FileName() As String

See Also

Attachment Object


%%PageItemTitle%%

Attachment Object

FileSize Property

Description

The attachment file size in bytes.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FileSize() As Long

See Also

Attachment Object


%%PageItemTitle%%

Attachment Object

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

Attachment Object


%%PageItemTitle%%

Attachment Object

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

Attachment Object


%%PageItemTitle%%

Attachment Object

LastModified Property

Description

The last modified time.

Property type

Read-only property

Syntax (Visual Basic)

Public Property LastModified() As Date

See Also

Attachment Object


%%PageItemTitle%%

Attachment Object

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

Attachment Object


%%PageItemTitle%%

Attachment Object

ViewFormat

If 1 is passed, the return value is the name of the file that was attached. For example, SampleAttachment.txt.

If 0 is passed , the return value is a file name with a prefix indicating its item type and number as stored in the project database. For example, BUG_1_SampleAttachment.txt.

See Also OTA COM Type Library

Name Property

Description

The attachment name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name( _
   Optional ByVal ViewFormat As Long = 0 _
) As String

Parameters

ViewFormat

If 1 is passed, the return value is the name of the file that was attached. For example, SampleAttachment.txt.

If 0 is passed , the return value is a file name with a prefix indicating its item type and number as stored in the project database. For example, BUG_1_SampleAttachment.txt.

See Also

Attachment Object

Example

The effect of the ViewFormat argument


%%PageItemTitle%%

Attachment Object

ServerFileName Property

Description

The attachment file name on the server machine.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ServerFileName() As String

See Also

Attachment Object

Example

Adding attachments to a defect and mailing them


%%PageItemTitle%%

Attachment Object

Type Property

Description

The attachment type. Either File or URL.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Type() As Long

See Also

Attachment Object


%%PageItemTitle%%

Attachment Object

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

Attachment Object


%%PageItemTitle%%

IBaseField2 Members

IBaseField2 Interface

Description

Represents a basic data field or entity, such as an attachment.

Public Properties

Public Property AutoUnlock | Indicates whether to make the item changeable to other users automatically after a Refresh or Post.
Public Property FieldMultiValue | The MultiValue object of the specified field.


%%PageItemTitle%% $$Members$$

Attachment Object

IBaseField3 Implemented Interface Members

Methods

Public Implemented Method Post Writes all changed values to database.

See Also

Attachment Object


%%PageItemTitle%%

Attachment Object | IBaseField3 Implemented Interface

UndoOnFailure
See Also OTA COM Type Library

Post Implemented Method

Description

Writes all changed values to database.

Syntax

Public Sub Post( _
   Optional ByVal UndoOnFailure As Boolean = True _
)

Parameters

UndoOnFailure

See Also

Attachment Object | IBaseField3 Implemented Interface


%%PageItemTitle%%

AttachmentFactory Members

AttachmentFactory Object

Description

Services for managing attachments of the current field object.

Remarks

Get an AttachmentFactory from the Attachments Property of any object that implements IBaseFieldEx, SubjectNode.Attachments, or TestSetFolder.Attachments.

See also: The Attachment Object

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Interfaces

IBaseFactory2 | ISupportCopyPaste2

Example

Adding attachments to a defect and mailing them | Getting a reference to an implemented interface | Updating an attachment | Creating a new defect attachment | Deleting a test attachment | Downloading test files and attachments

Public Methods

Public Method AddItem | Creates a new item object.
Public Method FactoryProperties | Gets the owner type and key for the AttachmentFactory object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property AttachmentStorage | The ExtendedStorage object for downloading and uploading attachment files.
Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

AttachmentFactory Object

ItemData
When using IBaseFactory.AddItem with the AttachmentFactory, pass NULL for ItemData.

See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData
When using IBaseFactory.AddItem with the AttachmentFactory, pass NULL for ItemData.

Remarks

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

[Visual Basic]

Dim bgf As BugFactory
Dim bg As Bug
Dim attf As AttachmentFactory
Dim att As Attachment
Dim attList As List

' Get the factory object
 Set bgf = tdc.BugFactory
' Use defect #1
 Set bg = bgf.Item(1)
 Set attf = bg.Attachments

' Creating a new attachment
' Create virtual object, then populate the properties
 Set att = attf.AddItem(Null)
 att.FileName = Text1.Text
 att.Type = TDATT_INTERNET

' Saving the object with validity check
 att.Post

' Display the attachments
' Add the display-only items without a Post
 List1.Clear
 Set attList = attf.NewList("")
 For i = 1 To attList.Count

      Set att = attList.Item(i)
      List1.AddItem (att.Name)

 Next

See Also

AttachmentFactory Object

Example

Adding attachments to a defect and mailing them


%%PageItemTitle%%

AttachmentFactory Object

OwnerType
The owner object type.
OwnerKey
The ID of the object to which this factory belongs.
See Also OTA COM Type Library

FactoryProperties Method

Description

Gets the owner type and key for the AttachmentFactory object.

Syntax

Public Sub FactoryProperties( _
   ByRef OwnerType As String, _
   ByRef OwnerKey As Variant _
)

Parameters

OwnerType
The owner object type.
OwnerKey
The ID of the object to which this factory belongs.

Remarks

OwnerType is one of:

"ALL_LISTS" for Subject
"BUG" for Defect
"CYCL_FOLD" for Test Set Folder
"CYCLE" for Test Set
"DESSTEPS" for Design Step
"REQ" for Requirement
"RUN" for Run
"STEP" for Run Step
"TEST" for Test
"TESTCYCL" for Test in Test Set (Test Instance)

    See Also

    AttachmentFactory Object

    Example

    Downloading test files and attachments


%%PageItemTitle%%

AttachmentFactory Object

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

Remarks

In Quality Center version 9.2, if no sub-type is specified in the filter, only attachments with an emptly sub-type are returned. This behavior will be changed in later versions. Sub-types are specified with the tagTDAPI_ATTACH_SUBTYPE Enumeration.

See Also

AttachmentFactory Object


%%PageItemTitle%%

AttachmentFactory Object

ItemKey
An Attachment.ID, a reference to an Attachment Object , or a Variant array of Attachment.IDs.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey
An Attachment.ID, a reference to an Attachment Object , or a Variant array of Attachment.IDs.

See Also

AttachmentFactory Object

Example

Deleting a test attachment


%%PageItemTitle%%

AttachmentFactory Object

AttachmentStorage Property

Description

The ExtendedStorage object for downloading and uploading attachment files.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AttachmentStorage() As Object

See Also

AttachmentFactory Object


%%PageItemTitle%%

AttachmentFactory Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

AttachmentFactory Object


%%PageItemTitle%%

AttachmentFactory Object

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

AttachmentFactory Object


%%PageItemTitle%%

AttachmentFactory Object

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

AttachmentFactory Object


%%PageItemTitle%%

AttachmentFactory Object

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

AttachmentFactory Object


%%PageItemTitle%%

AttachmentFactory Object

ItemKey
The attachment ID (long ).

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey
The attachment ID (long ).

See Also

AttachmentFactory Object


%%PageItemTitle%%

IBaseFactory2 Members

IBaseFactory2 Interface

Description

Provides basic object basic factory services, such as adding and removing factory child objects and creating lists of child objects.

Example

Getting a reference to an implemented interface

Public Properties

Public Property GroupingManager | The GroupingManager for this factory.
Public Property GroupingSupported | Check whether the factory supports grouping.


%%PageItemTitle%%

ISupportCopyPaste2 Members

ISupportCopyPaste2 Interface

Description

Services for supporting copy and paste.

Remarks

When pasting a item to a context where the object's name already exists, the new object is renamed and the paste succeeds. An exception is thrown with error code tagTDAPI_ERRORCODES.TDOLE_REQ_EXISTS. This occurs, for example, when copying a Req and pasting it under the same parent requirement.

For the list of classes that support copy and paste, look in the index under "ISupportCopyPaste(n)", where n is the number of the most recent version.

Interfaces

ISupportCopyPaste

Public Properties

Public Property PasteToCurrentProject Checks if the paste target is in the same project from which the material was copied.


%%PageItemTitle%%

Auditable Members

Auditable Object

Description

Services to allow changes to an entity to be tracked.

Example

Getting an AuditRecordFactory for a specific object

Public Properties

Public Property AuditPropertyFactory | The AuditPropertyFactory object to handle AuditProperty objects for the changed object.
Public Property AuditRecordFactory | The AuditRecordFactory object to handle AuditRecords for the changed object.


%%PageItemTitle%%

Auditable Object

AuditPropertyFactory Property

Description

The AuditPropertyFactory object to handle AuditProperty objects for the changed object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AuditPropertyFactory() As Object

See Also

Auditable Object


%%PageItemTitle%%

Auditable Object

AuditRecordFactory Property

Description

The AuditRecordFactory object to handle AuditRecords for the changed object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AuditRecordFactory() As Object

See Also

Auditable Object


%%PageItemTitle%%

AuditProperty Members

AuditProperty Object

Description

Represents a property associated with an AuditRecord.

Remarks

An AuditProperty is associated with an AuditRecord Object.

Interfaces

IBaseField2 | IBaseField3

Example

Retrieving audit logs

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Action | The database activity that caused creation of this record. For example, INSERT, UPDATE, or DELETE.
Public Property ActionID | The ID of the associated AuditRecord object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property EntityID | The ID of the entity that changed.
Public Property EntityType | The type of the entity that changed. For example, BUG, REQ.
Public Property Field | The value of the specified field.
Public Property FieldName | The database definition name of field that was changed.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property NewValue | The new value after the change.
Public Property OldValue | The value before the change.
Public Property PropertyName | The custom label for the field that was changed.
Public Property SessionID | The Quality Center Session ID under which the action was performed.
Public Property TableName | The database table in which the change was recorded.
Public Property Time | The time stamp of the change according to the database server clock.
Public Property UserName | The username of the user who performed the action.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

AuditProperty Object

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

AuditProperty Object


%%PageItemTitle%%

AuditProperty Object

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

AuditProperty Object


%%PageItemTitle%%

AuditProperty Object

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

AuditProperty Object


%%PageItemTitle%%

AuditProperty Object

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

AuditProperty Object


%%PageItemTitle%%

AuditProperty Object

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

AuditProperty Object


%%PageItemTitle%%

AuditProperty Object

Action Property

Description

The database activity that caused creation of this record. For example, INSERT, UPDATE, or DELETE.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Action() As String

See Also

AuditProperty Object


%%PageItemTitle%%

AuditProperty Object

ActionID Property

Description

The ID of the associated AuditRecord object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ActionID() As Long

See Also

AuditProperty Object


%%PageItemTitle%%

AuditProperty Object

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

AuditProperty Object


%%PageItemTitle%%

AuditProperty Object

EntityID Property

Description

The ID of the entity that changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EntityID() As String

See Also

AuditProperty Object


%%PageItemTitle%%

AuditProperty Object

EntityType Property

Description

The type of the entity that changed. For example, BUG, REQ.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EntityType() As String

Remarks

For more information, see the Mercury Quality Center Database Reference.

See Also

AuditProperty Object


%%PageItemTitle%%

AuditProperty Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

AuditProperty Object


%%PageItemTitle%%

AuditProperty Object

FieldName Property

Description

The database definition name of field that was changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FieldName() As String

Remarks

For more information, see the Mercury Quality Center Database Reference.

See Also

AuditProperty Object


%%PageItemTitle%%

AuditProperty Object

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

AuditProperty Object


%%PageItemTitle%%

AuditProperty Object

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

AuditProperty Object


%%PageItemTitle%%

AuditProperty Object

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

AuditProperty Object


%%PageItemTitle%%

AuditProperty Object

NewValue Property

Description

The new value after the change.

Property type

Read-only property

Syntax (Visual Basic)

Public Property NewValue() As Variant

See Also

AuditProperty Object


%%PageItemTitle%%

AuditProperty Object

OldValue Property

Description

The value before the change.

Property type

Read-only property

Syntax (Visual Basic)

Public Property OldValue() As Variant

See Also

AuditProperty Object


%%PageItemTitle%%

AuditProperty Object

PropertyName Property

Description

The custom label for the field that was changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property PropertyName() As String

See Also

AuditProperty Object


%%PageItemTitle%%

AuditProperty Object

SessionID Property

Description

The Quality Center Session ID under which the action was performed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property SessionID() As Long

See Also

AuditProperty Object


%%PageItemTitle%%

AuditProperty Object

TableName Property

Description

The database table in which the change was recorded.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TableName() As String

Remarks

For more information, see the Mercury Quality Center Database Reference.

See Also

AuditProperty Object


%%PageItemTitle%%

AuditProperty Object

Time Property

Description

The time stamp of the change according to the database server clock.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Time() As String

See Also

AuditProperty Object


%%PageItemTitle%%

AuditProperty Object

UserName Property

Description

The username of the user who performed the action.

Property type

Read-only property

Syntax (Visual Basic)

Public Property UserName() As String

See Also

AuditProperty Object


%%PageItemTitle%%

AuditProperty Object

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

AuditProperty Object


%%PageItemTitle%%

IBaseField3 Members

IBaseField3 Interface

Description

Represents a basic data field or entity, such as an attachment.

Public Methods

Public Method Post Writes all changed values to database.


%%PageItemTitle%%

AuditPropertyFactory Members

AuditPropertyFactory Object

Description

Services for managing AuditProperty objects.

Remarks

Get a reference from AuditRecord.AuditPropertyFactory.

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Example

Retrieving audit logs | Retrieve audit properties

Public Methods

Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

AuditPropertyFactory Object

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

AuditPropertyFactory Object


%%PageItemTitle%%

AuditPropertyFactory Object

ItemKey
An AuditProperty.ID.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey
An AuditProperty.ID.

See Also

AuditPropertyFactory Object


%%PageItemTitle%%

AuditPropertyFactory Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

AuditPropertyFactory Object


%%PageItemTitle%%

AuditPropertyFactory Object

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

AuditPropertyFactory Object


%%PageItemTitle%%

AuditPropertyFactory Object

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

AuditPropertyFactory Object


%%PageItemTitle%%

AuditPropertyFactory Object

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

AuditPropertyFactory Object


%%PageItemTitle%%

AuditPropertyFactory Object

ItemKey
An AuditProperty.ID.

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey
An AuditProperty.ID.

See Also

AuditPropertyFactory Object


%%PageItemTitle%%

AuditRecord Members | AuditProperty Object

AuditRecord Object

Description

A data change that is tracked.

Remarks

Get an AuditRecord from an AuditRecordFactory Object.

Interfaces

IBaseField2 | IBaseField3

Example

Retrieving audit logs | Retrieve change audit records for defect status

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Action | The name of the action that caused the tracked change.
Public Property ActionID | The ID of the AuditRecord.
Public Property AuditPropertyFactory | The AuditPropertyFactory Object for the current AuditRecord.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Description | The description of the audited change.
Public Property EntityID | The ID of the entity that changed.
Public Property EntityType | The type of the entity that changed.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property SessionID | The Quality Center Session ID under which the action was performed.
Public Property Time | The time stamp of the change according to the database server clock.
Public Property UserName | The username of the user who performed the action.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

AuditRecord Object

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

AuditRecord Object


%%PageItemTitle%%

AuditRecord Object

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

AuditRecord Object


%%PageItemTitle%%

AuditRecord Object

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

AuditRecord Object


%%PageItemTitle%%

AuditRecord Object

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

AuditRecord Object


%%PageItemTitle%%

AuditRecord Object

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

AuditRecord Object


%%PageItemTitle%%

AuditRecord Object

Action Property

Description

The name of the action that caused the tracked change.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Action() As String

See Also

AuditRecord Object


%%PageItemTitle%%

AuditRecord Object

ActionID Property

Description

The ID of the AuditRecord.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ActionID() As Long

See Also

AuditRecord Object


%%PageItemTitle%%

AuditRecord Object

AuditPropertyFactory Property

Description

The AuditPropertyFactory Object for the current AuditRecord.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AuditPropertyFactory() As Object

See Also

AuditRecord Object


%%PageItemTitle%%

AuditRecord Object

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

AuditRecord Object


%%PageItemTitle%%

AuditRecord Object

Description Property

Description

The description of the audited change.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Description() As String

See Also

AuditRecord Object


%%PageItemTitle%%

AuditRecord Object

EntityID Property

Description

The ID of the entity that changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EntityID() As String

See Also

AuditRecord Object


%%PageItemTitle%%

AuditRecord Object

EntityType Property

Description

The type of the entity that changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EntityType() As String

Remarks

For more information, see the Mercury Quality Center Database Reference.

See Also

AuditRecord Object


%%PageItemTitle%%

AuditRecord Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

AuditRecord Object


%%PageItemTitle%%

AuditRecord Object

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

AuditRecord Object


%%PageItemTitle%%

AuditRecord Object

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

AuditRecord Object


%%PageItemTitle%%

AuditRecord Object

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

AuditRecord Object


%%PageItemTitle%%

AuditRecord Object

SessionID Property

Description

The Quality Center Session ID under which the action was performed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property SessionID() As Long

See Also

AuditRecord Object


%%PageItemTitle%%

AuditRecord Object

Time Property

Description

The time stamp of the change according to the database server clock.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Time() As String

See Also

AuditRecord Object


%%PageItemTitle%%

AuditRecord Object

UserName Property

Description

The username of the user who performed the action.

Property type

Read-only property

Syntax (Visual Basic)

Public Property UserName() As String

See Also

AuditRecord Object


%%PageItemTitle%%

AuditRecord Object

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

AuditRecord Object


%%PageItemTitle%% $$Members$$

AuditRecord Object

IBaseField3 Implemented Interface Members

Methods

Public Implemented Method Post Writes all changed values to database.

See Also

AuditRecord Object


%%PageItemTitle%%

AuditRecord Object | IBaseField3 Implemented Interface

UndoOnFailure
See Also OTA COM Type Library

Post Implemented Method

Description

Writes all changed values to database.

Syntax

Public Sub Post( _
   Optional ByVal UndoOnFailure As Boolean = True _
)

Parameters

UndoOnFailure

See Also

AuditRecord Object | IBaseField3 Implemented Interface


%%PageItemTitle%%

AuditRecordFactory Members

AuditRecordFactory Object

Description

Services for managing AuditRecord objects.

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Example

Getting an AuditRecordFactory for a specific object | Retrieving audit logs | Retrieve change audit records for defect status | Retrieve history for a requirement

Public Methods

Public Method NewList Creates a list of objects according to the specified filter.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

AuditRecordFactory Object

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

AuditRecordFactory Object


%%PageItemTitle%%

AuditRecordFactory Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

AuditRecordFactory Object


%%PageItemTitle%%

AuditRecordFactory Object

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

AuditRecordFactory Object


%%PageItemTitle%%

AuditRecordFactory Object

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

AuditRecordFactory Object


%%PageItemTitle%%

AuditRecordFactory Object

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

AuditRecordFactory Object


%%PageItemTitle%%

AuditRecordFactory Object

ItemKey
An AuditRecord.ID.

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey
An AuditRecord.ID.

See Also

AuditRecordFactory Object


%%PageItemTitle%%

BPComponent Members

BPComponent Object

Description

An instance of a Component in a Business Process.

Remarks

A BPComponent is an instance of a Component in a BusinessProcess. Adding a Component to a BusinessProcess twice creates two BPComponent objects. Adding the same Component to two different business processes also creates two BPComponent objects.

Get a BPComponent with BusinessProcess.AddBPComponent.

Save changes to the object with BusinessProcess.Save, using the BusinessProcess object of which this is a child object.

Example

Creating a complete Business Process Test (long example) | Creating a new BPComponent | Connecting an output parameter's value to an input parameter | Get business process test parameters

Public Methods

Public Method AddIteration | Adds an Iteration to the BPComponent.
Public Method DeleteIteration | Delete the specified BPIteration from the BPComponent.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property BPParams | The list of the BPComponents parameters.
Public Property Component | Get the Component object from which this BPComponent was created.
Public Property FailureCondition | Indicates the behavior of the business process test if this component fails.
Public Property Field | The value of the specified field.
Public Property Group | The BPGroup to which this component belongs.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Iterations | The list of the BPComponents Iterations.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The name of the component from which this BPComponent was created.
Public Property Order | The position of the BPComponent in the BusinessProcess (1-based).
Public Property Test | The parent business process test.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

BPComponent Object

AddIteration Method

Description

Adds an Iteration to the BPComponent.

Syntax

Public Function AddIteration() As Object

Return Type

The new BPIteration Object.

Remarks

BPIterationParams are not added automatically when an iteration is added. They must be added or the BusinessProcess test will not run. See BPIteration.AddParam.

Save any modifications to the returned object by calling BusinessProcess.Save.

See Also

BPComponent Object


%%PageItemTitle%%

BPComponent Object

pVal
A BPIteration Object.
See Also OTA COM Type Library

DeleteIteration Method

Description

Delete the specified BPIteration from the BPComponent.

Syntax

Public Sub DeleteIteration( _
   ByVal pVal As Object _
)

Parameters

pVal
A BPIteration Object.

See Also

BPComponent Object


%%PageItemTitle%%

BPComponent Object

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If the object is locked, no other user can change or delete it.

The object is unlocked on a Post or Refresh operation and when the connection is logged off the project.

See Also

BPComponent Object


%%PageItemTitle%%

BPComponent Object

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

BPComponent Object


%%PageItemTitle%%

BPComponent Object

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

BPComponent Object


%%PageItemTitle%%

BPComponent Object

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users.

See Also

BPComponent Object


%%PageItemTitle%%

BPComponent Object

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

BPComponent Object


%%PageItemTitle%%

BPComponent Object

BPParams Property

Description

The list of the BPComponents parameters.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BPParams() As List

See Also

BPComponent Object


%%PageItemTitle%%

BPComponent Object

Component Property

Description

Get the Component object from which this BPComponent was created.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Component() As Object

See Also

BPComponent Object


%%PageItemTitle%%

BPComponent Object

FailureCondition Property

Description

Indicates the behavior of the business process test if this component fails.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FailureCondition() As String

Remarks

If the BPComponent fails at runtime, "Exit" indicates that the entire BusinessProcess test terminates. "Continue" indicates that only this failed component terminates.

See Also

BPComponent Object


%%PageItemTitle%%

BPComponent Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

BPComponent Object


%%PageItemTitle%%

BPComponent Object

Group Property

Description

The BPGroup to which this component belongs.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Group() As Object

See Also

BPComponent Object


%%PageItemTitle%%

BPComponent Object

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

BPComponent Object


%%PageItemTitle%%

BPComponent Object

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

BPComponent Object


%%PageItemTitle%%

BPComponent Object

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

BPComponent Object


%%PageItemTitle%%

BPComponent Object

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

BPComponent Object


%%PageItemTitle%%

BPComponent Object

Iterations Property

Description

The list of the BPComponents Iterations.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Iterations() As List

See Also

BPComponent Object


%%PageItemTitle%%

BPComponent Object

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

BPComponent Object


%%PageItemTitle%%

BPComponent Object

Name Property

Description

The name of the component from which this BPComponent was created.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name() As String

See Also

BPComponent Object


%%PageItemTitle%%

BPComponent Object

Order Property

Description

The position of the BPComponent in the BusinessProcess (1-based).

Property type

Read-write property

Syntax (Visual Basic)

Public Property Order() As Long

See Also

BPComponent Object


%%PageItemTitle%%

BPComponent Object

Test Property

Description

The parent business process test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Test() As Object

See Also

BPComponent Object


%%PageItemTitle%%

BPComponent Object

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

BPComponent Object


%%PageItemTitle%%

BPGroup Members

BPGroup Object

Description

Support for grouping business components so that they iterate as a unit.

Remarks

Ensure that BPComponents added to the BPGroup are sequential and have the same number of iterations.

Get a BPGroup from BusinessProcess.AddGroup or BusinessProcess.GroupByID.

Save changes to the object with BusinessProcess.Save, using the BusinessProcess object of which this is a child object.

Example

Creating a complete Business Process Test (long example)

Public Methods

Public Method AddBPComponent | Adds the specified business component to the group.
Public Method BPComponents | The list of the BPComponents that belong to the group.
Public Method DeleteBPComponent | Removes the specified business component from the group.

Public Properties

Public Property ID The group ID.


%%PageItemTitle%%

BPGroup Object

pBPComponent
A BPComponent Object.
See Also OTA COM Type Library

AddBPComponent Method

Description

Adds the specified business component to the group.

Syntax

Public Sub AddBPComponent( _
   ByVal pBPComponent As Object _
)

Parameters

pBPComponent
A BPComponent Object.

See Also

BPGroup Object


%%PageItemTitle%%

BPGroup Object

BPComponents Method

Description

The list of the BPComponents that belong to the group.

Syntax

Public Function BPComponents() As List

Return Type

A list of BPComponent Objects.

See Also

BPGroup Object


%%PageItemTitle%%

BPGroup Object

pBPComponent
A BPComponent Object.
See Also OTA COM Type Library

DeleteBPComponent Method

Description

Removes the specified business component from the group.

Syntax

Public Sub DeleteBPComponent( _
   ByVal pBPComponent As Object _
)

Parameters

pBPComponent
A BPComponent Object.

See Also

BPGroup Object


%%PageItemTitle%%

BPGroup Object

ID Property

Description

The group ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Long

See Also

BPGroup Object


%%PageItemTitle%%

BPIteration Members

BPIteration Object

Description

The design-time definition of a business process test iteration.

Remarks

The object is created with BPComponent.AddIteration. Get a reference from the return value of BPComponent.AddIteration or from the list returned by BPComponent.Iterations.

When a Component is added to a BusinessProcess, one BPIteration is added automatically, together with BPIterationParams for all of the component’s parameters. This BPIteration does not have an Order. The test cannot be run until the order is set.

When additional iterations are added after the Component has been added, the BPIterationParams are not added automatically. They must be added in code or in the user interface for the BusinessProcess test to run.

Save changes to the object with BusinessProcess.Save, using the BusinessProcess object of which this is a child object.

Example

Creating a complete Business Process Test (long example) | Connecting an output parameter's value to an input parameter | Get business process test parameters

Public Methods

Public Method AddParam | Add the specified BPParameter Object to the iteration.
Public Method DeleteIterationParams | Delete all the parameters from the iteration.
Public Method DeleteParam | Delete the specified BPParameter from the iteration.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property BPComponent | The BPComponent object of which this an iteration.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property IterationParams | The list of BPIterationParam objects associated with this iteration.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Order | The 0-based execution position of this iteration in the set of iterations of this component.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

BPIteration Object

pVal
A BPParameter Object.
See Also OTA COM Type Library

AddParam Method

Description

Add the specified BPParameter Object to the iteration.

Syntax

Public Function AddParam( _
   ByVal pVal As Object _
) As Object

Parameters

pVal
A BPParameter Object.

Return Type

The new BPIterationParam Object.

Remarks

When a parameter is added in code, this function must be called in a loop to add the new parameter and a value to each BPIteration in the test.

When an iteration is added in code, this function must be called in a loop to add each BPParameter in the step to the new iteration.

If the new BPIterationParam is modified, call BusinessProcess.Save.

See Also

BPIteration Object


%%PageItemTitle%%

BPIteration Object

DeleteIterationParams Method

Description

Delete all the parameters from the iteration.

Syntax

Public Sub DeleteIterationParams()

See Also

BPIteration Object


%%PageItemTitle%%

BPIteration Object

pVal
A BPParameter Object.
See Also OTA COM Type Library

DeleteParam Method

Description

Delete the specified BPParameter from the iteration.

Syntax

Public Sub DeleteParam( _
   ByVal pVal As Object _
)

Parameters

pVal
A BPParameter Object.

Return Type

This function must be called in a loop to delete the parameter from each BPIteration in the test.

See Also

BPIteration Object


%%PageItemTitle%%

BPIteration Object

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

BPIteration Object


%%PageItemTitle%%

BPIteration Object

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

BPIteration Object


%%PageItemTitle%%

BPIteration Object

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

BPIteration Object


%%PageItemTitle%%

BPIteration Object

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

BPIteration Object


%%PageItemTitle%%

BPIteration Object

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

BPIteration Object


%%PageItemTitle%%

BPIteration Object

BPComponent Property

Description

The BPComponent object of which this an iteration.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BPComponent() As Object

See Also

BPIteration Object


%%PageItemTitle%%

BPIteration Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

BPIteration Object


%%PageItemTitle%%

BPIteration Object

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

BPIteration Object


%%PageItemTitle%%

BPIteration Object

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

BPIteration Object


%%PageItemTitle%%

BPIteration Object

IterationParams Property

Description

The list of BPIterationParam objects associated with this iteration.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IterationParams() As List

See Also

BPIteration Object


%%PageItemTitle%%

BPIteration Object

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

BPIteration Object


%%PageItemTitle%%

BPIteration Object

Order Property

Description

The 0-based execution position of this iteration in the set of iterations of this component.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Order() As Long

See Also

BPIteration Object


%%PageItemTitle%%

BPIteration Object

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

BPIteration Object


%%PageItemTitle%%

BPIterationParam Members

BPIterationParam Object

Description

An instance of a business component parameter that belongs to a single iteration of the business process test.

Remarks

BPIterationParams are not added automatically when iterations are added to a BPComponent. Add them in code or through the user interface to enable the BusinessProcess test to run.

Get a BPIterationParam object from BPIteration.AddParam or from the BPIteration.IterationParams list.

If the value of the parameter is not of the correct type, errors will occur in viewing and running the test.

Save changes to the object with BusinessProcess.Save, using the BusinessProcess object of which this is a child object.

Example

Creating a complete Business Process Test (long example) | Get business process test parameters

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property BPParameter | The BPParameter object of which this is an instance.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Value | The value of the parameter for this iteration.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

BPIterationParam Object

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

BPIterationParam Object


%%PageItemTitle%%

BPIterationParam Object

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

BPIterationParam Object


%%PageItemTitle%%

BPIterationParam Object

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

BPIterationParam Object


%%PageItemTitle%%

BPIterationParam Object

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

BPIterationParam Object


%%PageItemTitle%%

BPIterationParam Object

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

BPIterationParam Object


%%PageItemTitle%%

BPIterationParam Object

BPParameter Property

Description

The BPParameter object of which this is an instance.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BPParameter() As Object

See Also

BPIterationParam Object


%%PageItemTitle%%

BPIterationParam Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

BPIterationParam Object


%%PageItemTitle%%

BPIterationParam Object

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

BPIterationParam Object


%%PageItemTitle%%

BPIterationParam Object

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

BPIterationParam Object


%%PageItemTitle%%

BPIterationParam Object

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

BPIterationParam Object


%%PageItemTitle%%

BPIterationParam Object

Value Property

Description

The value of the parameter for this iteration.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Value() As String

Remarks

The value must be consistent with the BPParameter.Type of the object referenced by the BPParameter Property. If the value is not of the correct type, errors will be encountered when attempting to run the test.

See Also

BPIterationParam Object


%%PageItemTitle%%

BPIterationParam Object

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

BPIterationParam Object


%%PageItemTitle%%

BPParameter Members

BPParameter Object

Description

An instance of a parameter in a business component.

Remarks

A BPParameter is based on a ComponentParam. The BPParameters are added automatically to the BPComponent when it is created from the Component. Every ComponentParam in the Component becomes a BPParameter in the BPComponent. The default value is the value of the ComponentParam from which the BPParameter is created.

The value of a BPParameter is either a constant or the value of another BPParameter. BPParameter.Type is either CONSTANT or REF_BPPARAM, respectively.

If a CONSTANT, get the value from the ComponentParam.Value of the component returned by the ComponentParam Property of the BPParameter.

If the type is REF_BPPARAM, then the value is the output value of another BPParameter. Get the source BPParameter from the Reference Property, then get the source's constant value from its ComponentParam as described above: sourceBPParameter.ComponentParam.Value.

Get a BPParameter from the list returned by BPComponent.BPParams.

Save changes to the object with BusinessProcess.Save, using the BusinessProcess object of which this is a child object.

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property BPComponent | The BPComponent object to which this parameter belongs.
Public Property ComponentParam | The ComponentParam object from which this BPParam was created.
Public Property ComponentParamIsOut | Indicates if the ComponentParam from which this BPParam was created is an output parameter. If False, it is an input parameter.
Public Property ComponentParamName | The name of the ComponentParam object from which this BPParam was created.
Public Property ComponentParamOrder | The position of the ComponentParam object from which this BPParam was created.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Reference | The output BPParameter object that is the source of the value for this parameter.
Public Property Type | The parameter type.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

BPParameter Object

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

BPParameter Object


%%PageItemTitle%%

BPParameter Object

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

BPParameter Object


%%PageItemTitle%%

BPParameter Object

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

BPParameter Object


%%PageItemTitle%%

BPParameter Object

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

BPParameter Object


%%PageItemTitle%%

BPParameter Object

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

BPParameter Object


%%PageItemTitle%%

BPParameter Object

BPComponent Property

Description

The BPComponent object to which this parameter belongs.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BPComponent() As Object

See Also

BPParameter Object


%%PageItemTitle%%

BPParameter Object

ComponentParam Property

Description

The ComponentParam object from which this BPParam was created.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ComponentParam() As Object

See Also

BPParameter Object


%%PageItemTitle%%

BPParameter Object

ComponentParamIsOut Property

Description

Indicates if the ComponentParam from which this BPParam was created is an output parameter. If False, it is an input parameter.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ComponentParamIsOut() As Long

See Also

BPParameter Object


%%PageItemTitle%%

BPParameter Object

ComponentParamName Property

Description

The name of the ComponentParam object from which this BPParam was created.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ComponentParamName() As String

See Also

BPParameter Object


%%PageItemTitle%%

BPParameter Object

ComponentParamOrder Property

Description

The position of the ComponentParam object from which this BPParam was created.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ComponentParamOrder() As Long

See Also

BPParameter Object


%%PageItemTitle%%

BPParameter Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

BPParameter Object


%%PageItemTitle%%

BPParameter Object

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

BPParameter Object


%%PageItemTitle%%

BPParameter Object

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

BPParameter Object


%%PageItemTitle%%

BPParameter Object

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

BPParameter Object


%%PageItemTitle%%

BPParameter Object

Reference Property

Description

The output BPParameter object that is the source of the value for this parameter.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Reference() As Object

Remarks

If this input parameter gets its value from an output parameter, this is the source parameter. If the value of this BPParameter is a constant, the Reference property has no meaning.

When setting the Reference of the target BPParameter, ensure that there are no instances of BPIterationParam created from that target BPParameter. Note that when a Component is added to a BusinessProcess, one BPIteration is added automatically, together with BPIterationParams for all of the component’s parameters. Delete them in your code before setting the Reference. Failure to do so results in an error when attempting to view or run the test.

See Also

BPParameter Object


%%PageItemTitle%%

BPParameter Object

Type Property

Description

The parameter type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Type() As Long

See Also

BPParameter Object


%%PageItemTitle%%

BPParameter Object

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

BPParameter Object


%%PageItemTitle%%

BPStepParam Members

BPStepParam Object

Description

A step parameter for a manual run of the business process test.

Remarks

Get a BPStepParam with BPStepParamFactory.AddItem or from the list returned by BPStepParamFactory.NewList.

Save changes to the object with BusinessProcess.Save, using the BusinessProcess object of which this is a child object.

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The name of this parameter.
Public Property ReferencedParamID | The parameter ID of the referenced parameter.
Public Property StepID | The ID of the step in which this parameter occurs.
Public Property Type | The parameter type.
Public Property Value | The value of this parameter.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

BPStepParam Object

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

BPStepParam Object


%%PageItemTitle%%

BPStepParam Object

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

BPStepParam Object


%%PageItemTitle%%

BPStepParam Object

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

BPStepParam Object


%%PageItemTitle%%

BPStepParam Object

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

BPStepParam Object


%%PageItemTitle%%

BPStepParam Object

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

BPStepParam Object


%%PageItemTitle%%

BPStepParam Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

BPStepParam Object


%%PageItemTitle%%

BPStepParam Object

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

BPStepParam Object


%%PageItemTitle%%

BPStepParam Object

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

BPStepParam Object


%%PageItemTitle%%

BPStepParam Object

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

BPStepParam Object


%%PageItemTitle%%

BPStepParam Object

Name Property

Description

The name of this parameter.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

BPStepParam Object


%%PageItemTitle%%

BPStepParam Object

ReferencedParamID Property

Description

The parameter ID of the referenced parameter.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ReferencedParamID() As Long

Remarks

When this input parameter gets its value from an output parameter of a previous step, this is the ID of the output parameter that is the source of the value.

See Also

BPStepParam Object


%%PageItemTitle%%

BPStepParam Object

StepID Property

Description

The ID of the step in which this parameter occurs.

Property type

Read-only property

Syntax (Visual Basic)

Public Property StepID() As Long

See Also

BPStepParam Object


%%PageItemTitle%%

BPStepParam Object

Type Property

Description

The parameter type.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Type() As Long

See Also

BPStepParam Object


%%PageItemTitle%%

BPStepParam Object

Value Property

Description

The value of this parameter.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Value() As String

See Also

BPStepParam Object


%%PageItemTitle%%

BPStepParam Object

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

BPStepParam Object


%%PageItemTitle%%

BPStepParamFactory Members

BPStepParamFactory Object

Description

Services for managing BPStepParam objects.

Remarks

Get a BPStepParamFactory with Step.BPStepParamFactory or Run.BPStepParamFactory.

Save changes to the object with BusinessProcess.Save, using the BusinessProcess object of which this is a child object.

Interfaces

IBaseFactory2

Example

Getting a reference to an implemented interface

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

BPStepParamFactory Object

ItemData
When creating BPStepParam objects, pass NULL for ItemData.
See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData
When creating BPStepParam objects, pass NULL for ItemData.

See Also

BPStepParamFactory Object


%%PageItemTitle%%

BPStepParamFactory Object

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

BPStepParamFactory Object


%%PageItemTitle%%

BPStepParamFactory Object

ItemKey
A BPStepParam.ID.
See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey
A BPStepParam.ID.

See Also

BPStepParamFactory Object


%%PageItemTitle%%

BPStepParamFactory Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

BPStepParamFactory Object


%%PageItemTitle%%

BPStepParamFactory Object

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

BPStepParamFactory Object


%%PageItemTitle%%

BPStepParamFactory Object

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

BPStepParamFactory Object


%%PageItemTitle%%

BPStepParamFactory Object

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

BPStepParamFactory Object


%%PageItemTitle%%

BPStepParamFactory Object

ItemKey
A BPStepParam.ID.
See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey
A BPStepParam.ID.

See Also

BPStepParamFactory Object


%%PageItemTitle%%

Bug Members

Bug Object

Description

A defect.

Remarks

Get a Bug object from TDConnection.BugFactory.

Interfaces

IAlertable2 | IBaseField2 | IBaseField3 | IFollowUpManager | ILinkable

Example

Accessing members of Additional Implemented Interfaces | Filtering defect records | Getting the requirements associated with a Bug | Creating various entities and linking them | Creating defects and links between defects | Modify a link between defects | Removing a link between defects

Public Methods

Public Method FindSimilarBugs | Searches the defect summaries for similarities to this defect.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Mail | Mails the IBaseFieldExMail field item.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AssignedTo | The name of the user to whom the defect is assigned.
Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property DetectedBy | The name of the user who detected the defect.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Priority | The defect priority.
Public Property Project | The testing project to which the defect belongs.
Public Property Status | The defect status.
Public Property Summary | A short description of the defect.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

Bug Object

SimilarityRatio
Specifies the similarity ratio (0-100).
See Also OTA COM Type Library

FindSimilarBugs Method

Description

Searches the defect summaries for similarities to this defect.

Syntax

Public Function FindSimilarBugs( _
   Optional ByVal SimilarityRatio As Long = 10 _
) As List

Parameters

SimilarityRatio
Specifies the similarity ratio (0-100).

Return Type

A FactoryList of Bug objects.

Remarks

For more information on the similarity ratio, see 'Matching Defects' under 'Adding New Defects' in the Quality Center User's Guide.

See Also

Bug Object

Example

Matches go down as similarity ratio goes up


%%PageItemTitle%%

Bug Object

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Bug Object


%%PageItemTitle%%

Bug Object | tagTDMAIL_FLAGS Enumeration

SendTo

The recipient address or addresses. Addresses can be separated by a comma or a semicolon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also OTA COM Type Library

Mail Method

Description

Mails the IBaseFieldExMail field item.

Syntax

Public Sub Mail( _
   ByVal SendTo As String, _
   Optional ByVal SendCc As String = "", _
   Optional ByVal Option As Long = 0, _
   Optional ByVal Subject As String = "", _
   Optional ByVal Comment As String = "" _
)

Parameters

SendTo

The recipient address or addresses. Addresses can be separated by a comma or a semicolon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also

Bug Object | tagTDMAIL_FLAGS Enumeration

Example

Mailing a bug


%%PageItemTitle%%

Bug Object

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

Example

[Visual Basic]

Dim bfact As BugFactory
Dim mybug As Bug

'Get BugFactory from TDConnection
Set bfact = tdc.BugFactory
'Add 5 defects
For i = 1 To 5
   Set mybug = bfact.AddItem("Defect" & i)
   mybug.Summary = "Test" & i
   mybug.Status = "Open"
   mybug.Post
Next i

See Also

Bug Object

Example

Getting and setting bug properties


%%PageItemTitle%%

Bug Object

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Bug Object


%%PageItemTitle%%

Bug Object

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

Bug Object


%%PageItemTitle%%

Bug Object

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

Bug Object


%%PageItemTitle%%

Bug Object

AssignedTo Property

Description

The name of the user to whom the defect is assigned.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AssignedTo() As String

See Also

Bug Object

Example

Getting and setting bug properties


%%PageItemTitle%%

Bug Object

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

Bug Object

Example

Adding attachments to a defect and mailing them | Creating a new defect attachment | Downloading a file from an attachment object


%%PageItemTitle%%

Bug Object

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

Bug Object


%%PageItemTitle%%

Bug Object

DetectedBy Property

Description

The name of the user who detected the defect.

Property type

Read-write property

Syntax (Visual Basic)

Public Property DetectedBy() As String

See Also

Bug Object

Example

Getting and setting bug properties


%%PageItemTitle%%

Bug Object

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName

The name of the field in the project database.

Remarks

If the field name is "BG_SUBJECT", a SubjectNode Object is returned.

See Also

Bug Object

Example

Get the bug description


%%PageItemTitle%%

Bug Object

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

Bug Object


%%PageItemTitle%%

Bug Object

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

Bug Object


%%PageItemTitle%%

Bug Object

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

Bug Object


%%PageItemTitle%%

Bug Object

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

Bug Object


%%PageItemTitle%%

Bug Object

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

Bug Object


%%PageItemTitle%%

Bug Object

Priority Property

Description

The defect priority.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Priority() As String

Remarks

Most sites have priorities 1-Low, 2-Medium, 3-High, 4-Very High, and 5-Urgent.

To get the full list of priorities on your site look at the Priority list. See 'Customizing Project Lists' in the Mercury Quality Center Administrator's Guide.

See Also

Bug Object

Example

Getting and setting bug properties


%%PageItemTitle%%

Bug Object

Project Property

Description

The testing project to which the defect belongs.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Project() As String

Remarks

This is generally the name of the item you are testing: a software component, hardware item, network configuration, web site, and so on.

For a list of projects defined in your Quality Center project database, use TDConnection.ProjectsList or TDConnection.ProjectsListEx.

See Also

Bug Object

Example

Getting and setting bug properties


%%PageItemTitle%%

Bug Object

Status Property

Description

The defect status.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Status() As String

Remarks

Most sites have statuses New, Open, Rejected, Fixed, Reopen, and Closed.

To get the full list of statuses on your site look at the Bug Status list. See 'Customizing Project Lists' in the Mercury Quality Center Administrator's Guide.

Example

mybug.Status = "Fixed"
mybug.Post

See Also

Bug Object

Example

Getting and setting bug properties


%%PageItemTitle%%

Bug Object

Summary Property

Description

A short description of the defect.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Summary() As String

Example

myBug.Summary = "This feature doesn't work"
myBug.Post

See Also

Bug Object

Example

Getting and setting bug properties


%%PageItemTitle%%

Bug Object

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

Bug Object


%%PageItemTitle%%

IAlertable2 Members

IAlertable2 Interface

Description

Services for managing auto-alerts.

Public Methods

Public Method AddAlert | Adds a new alert to the specified entity.
Public Method CleanAllAlerts | Removes all current object alerts from the database.
Public Method DeleteAlert | Removes an alert or alerts associated with the current object from the database.
Public Method GetAlert | Gets the alert specified by the alert ID.
Public Method GetAlertList | Gets a list of all alerts associated with the object.
Public Method HasAlerts | Checks if any alerts are associated with the object.
Public Method HasNewAlerts | New, unread alerts are associated with the object.


%%PageItemTitle%% $$Members$$

Bug Object

IBaseField3 Implemented Interface Members

Methods

Public Implemented Method Post Writes all changed values to database.

See Also

Bug Object


%%PageItemTitle%%

Bug Object | IBaseField3 Implemented Interface

UndoOnFailure
See Also OTA COM Type Library

Post Implemented Method

Description

Writes all changed values to database.

Syntax

Public Sub Post( _
   Optional ByVal UndoOnFailure As Boolean = True _
)

Parameters

UndoOnFailure

See Also

Bug Object | IBaseField3 Implemented Interface


%%PageItemTitle%%

IFollowUpManager Members

IFollowUpManager Interface

Description

Manages the user-defined follow-ups.

Example

Check if test has alert | Set alert on test

Public Methods

Public Method CancelFollowUp | Removes the current entity's follow-up.
Public Method GetFollowUp | Gets the date and description for the follow-up associated with the current object.
Public Method HasFollowUp | Checks if the object has at least one follow-up associated with it.
Public Method IsFollowUpOverdue | Checks if the date of the unsent follow-up is earlier than the current database server date.
Public Method SetFollowUp | Sets an alert for follow-up for the current object.


%%PageItemTitle%%

ILinkable Members

ILinkable Interface

Description

Services for managing links.

Example

Creating links between defects

Public Properties

Public Property BugLinkFactory | The bug link factory that manages the links of the current object to its associated defects.
Public Property HasLinkage | Checks if the current object has at least one associated Bug.
Public Property HasOthersLinkage | Checks if the current Bug object has at least one associated object that is not another Bug object. Defined only for Bug objects.
Public Property LinkFactory | The link factory of the current defect object that enables viewing the links. Defined only for Bug objects.


%%PageItemTitle%%

BugFactory Members

BugFactory Object

Description

Services for managing defect records.

Remarks

Get a BugFactory object from TDConnection.BugFactory.

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Interfaces

IAlertableEntityFactory | IBaseFactory2 | ISearchableFactory | ISupportCopyPaste2

Example

Getting a reference to an implemented interface | Getting the list of design tests used in a test set | Creating links between defects

Public Methods

Public Method AddItem | Creates a new item object.
Public Method BuildAgeGraph | Creates a graph that shows the lifetime of defects.
Public Method BuildProgressGraph | Creates a graph showing status at specific points: either defect accumulation or time to fix (estimated or actual).
Public Method BuildSummaryGraph | Creates a summary graph either of the number of defects or the time to fix (estimated or actual).
Public Method BuildTrendGraph | Creates a graph that shows the history of changes to specific Defect fields for each time interval displayed.
Public Method FindSimilarBugs | Searches defect summaries and descriptions for matches to Pattern.
Public Method Mail | Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

BugFactory Object

ItemData
When creating defects, always pass Null as the ItemData argument.
See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData
When creating defects, always pass Null as the ItemData argument.

Return Type

A Bug Object.

See Also

BugFactory Object


%%PageItemTitle%%

BugFactory Object

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

The field whose values are summed for all entities in a group:
One of Run 'Duration', Defect 'Actual Fix Time', or Defect 'Estimated Fix Time'.
If the argument is not used, the resulting value is the count of the entities in the group.

MaxAge
The maximum age (in days) of defects included in the graph. A value of 0 signifies no age limit.
MaxCols

The maximum number of groups represented in the graph. Zero indicates no limit.

Filter

The TDFilter Object that sets the criteria for the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildAgeGraph Method

Description

Creates a graph that shows the lifetime of defects.

Syntax

Public Function BuildAgeGraph( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxAge As Long = 0, _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

The field whose values are summed for all entities in a group:
One of Run 'Duration', Defect 'Actual Fix Time', or Defect 'Estimated Fix Time'.
If the argument is not used, the resulting value is the count of the entities in the group.

MaxAge
The maximum age (in days) of defects included in the graph. A value of 0 signifies no age limit.
MaxCols

The maximum number of groups represented in the graph. Zero indicates no limit.

Filter

The TDFilter Object that sets the criteria for the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

BugFactory Object


%%PageItemTitle%%

BugFactory Object

GroupByField
A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.
SumOfField
The field whose values are summed for all entities in a group:
One of Run 'Duration', Defect 'Actual Fix Time', or Defect 'Estimated Fix Time'.
If the argument is not used, the resulting value is the count of the entities in the group.
ByHistory

Determines whether to use history information to create the graph. Possible values are:

TRUE - Use history information.

FALSE - Do not use history information.

MajorSkip
Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.
MinorSkip
Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.
MaxCols
The maximum number of groups represented in the graph. Zero indicates no limit.
Filter
The TDFilter Object that sets the criteria for the graph.
FRDate
Only items with a change date after this date are reflected in the graph.
ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildProgressGraph Method

Description

Creates a graph showing status at specific points: either defect accumulation or time to fix (estimated or actual).

Syntax

Public Function BuildProgressGraph( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal ByHistory As Boolean = True, _
   Optional ByVal MajorSkip As Long = 0, _
   Optional ByVal MinorSkip As Long = 1, _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField
A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.
SumOfField
The field whose values are summed for all entities in a group:
One of Run 'Duration', Defect 'Actual Fix Time', or Defect 'Estimated Fix Time'.
If the argument is not used, the resulting value is the count of the entities in the group.
ByHistory

Determines whether to use history information to create the graph. Possible values are:

TRUE - Use history information.

FALSE - Do not use history information.

MajorSkip
Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.
MinorSkip
Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.
MaxCols
The maximum number of groups represented in the graph. Zero indicates no limit.
Filter
The TDFilter Object that sets the criteria for the graph.
FRDate
Only items with a change date after this date are reflected in the graph.
ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

BugFactory Object


%%PageItemTitle%%

BugFactory Object

XAxisField
A database field representing the name of the graph x-axis.
GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

The field whose values are summed for all entities in a group:
One of Run 'Duration', Defect 'Actual Fix Time', or Defect 'Estimated Fix Time'.
If the argument is not used, the resulting value is the count of the entities in the group.

MaxCols

The maximum number of groups represented in the graph. Zero indicates no limit.

Filter

The TDFilter Object that sets the criteria for the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildSummaryGraph Method

Description

Creates a summary graph either of the number of defects or the time to fix (estimated or actual).

Syntax

Public Function BuildSummaryGraph( _
   Optional ByVal XAxisField As String = "", _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

XAxisField
A database field representing the name of the graph x-axis.
GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

The field whose values are summed for all entities in a group:
One of Run 'Duration', Defect 'Actual Fix Time', or Defect 'Estimated Fix Time'.
If the argument is not used, the resulting value is the count of the entities in the group.

MaxCols

The maximum number of groups represented in the graph. Zero indicates no limit.

Filter

The TDFilter Object that sets the criteria for the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

BugFactory Object


%%PageItemTitle%%

BugFactory Object

GroupByField
A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.
SumOfField
Not in use in BugFactory BuildTrendGraph.
MaxCols
The maximum number of groups represented in the graph. Zero indicates no limit.
Filter
The TDFilter Object that sets the criteria for the graph.
FRDate
Only items with a change date after this date are reflected in the graph.
ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildTrendGraph Method

Description

Creates a graph that shows the history of changes to specific Defect fields for each time interval displayed.

Syntax

Public Function BuildTrendGraph( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField
A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.
SumOfField
Not in use in BugFactory BuildTrendGraph.
MaxCols
The maximum number of groups represented in the graph. Zero indicates no limit.
Filter
The TDFilter Object that sets the criteria for the graph.
FRDate
Only items with a change date after this date are reflected in the graph.
ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

BugFactory Object


%%PageItemTitle%%

BugFactory Object

Pattern
The search text.
SimilarityRatio
Specifies the percentage of similarity (0-100).
See Also OTA COM Type Library

FindSimilarBugs Method

Description

Searches defect summaries and descriptions for matches to Pattern.

Syntax

Public Function FindSimilarBugs( _
   ByVal Pattern As String, _
   Optional ByVal SimilarityRatio As Long = 10 _
) As List

Parameters

Pattern
The search text.
SimilarityRatio
Specifies the percentage of similarity (0-100).

Return Type

A FactoryList of Bug objects.

Remarks

For more information on the similarity ratio, see 'Matching Defects' under 'Adding New Defects' in the Quality Center User's Guide.

See Also

BugFactory Object


%%PageItemTitle%%

BugFactory Object

Items

A list of IDs.

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also OTA COM Type Library

Mail Method

Description

Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.

Syntax

Public Sub Mail( _
   ByVal Items As Variant, _
   ByVal SendTo As String, _
   Optional ByVal SendCc As String = "", _
   Optional ByVal Option As Long = 0, _
   Optional ByVal Subject As String = "", _
   Optional ByVal Comment As String = "" _
)

Parameters

Items

A list of IDs.

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also

BugFactory Object


%%PageItemTitle%%

BugFactory Object

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

BugFactory Object


%%PageItemTitle%%

BugFactory Object

ItemKey
The defect ID (long), a reference to the Bug Object, or a variant array of defect IDs.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey
The defect ID (long), a reference to the Bug Object, or a variant array of defect IDs.

See Also

BugFactory Object


%%PageItemTitle%%

BugFactory Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

BugFactory Object


%%PageItemTitle%%

BugFactory Object

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

BugFactory Object

Example

Get Table Fields


%%PageItemTitle%%

BugFactory Object

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

BugFactory Object

Example

Filtering defect records


%%PageItemTitle%%

BugFactory Object

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

BugFactory Object


%%PageItemTitle%%

BugFactory Object

ItemKey
The defect ID (long).

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey
The defect ID (long).

See Also

BugFactory Object


%%PageItemTitle%%

IAlertableEntityFactory Members

IAlertableEntityFactory Interface

Description

A factory implements this interface to indicate that it can instantiate objects that implement the IAlertable interface.


%%PageItemTitle%%

ISearchableFactory Members

ISearchableFactory Interface

Description

Services to support text searches in properties of objects managed by a factory.

Example

Searching for tests that match a search string

Public Methods

Public Method CreateSearchOptions | Creates a new SearchOptions object.
Public Method IsSearchable | Checks if the Search method can be called by this factory.
Public Method Search | Gets a list of objects matching the search query.


%%PageItemTitle%%

BusinessProcess Members

BusinessProcess Object

Description

Represents a single Business Process Test.

Remarks

Get a BusinessProcess reference from a Test Object of Type BUSINESS-PROCESS. In VisualBasic, cast the Test to BusinessProcess. In C++, use the QueryInterface to get the reference.

BusinessProcess.Save saves modifications to all BP_xxx objects that belong to the test.

Interfaces

IBaseField2 | IBaseField3

Example

Casting an object reference to get a reference to an inner interface | Creating a complete Business Process Test (long example) | Creating an empty Business Process Test | Add component to test | Get business process test parameters

Public Methods

Public Method AddBPComponent | Adds the specified Component to the test.
Public Method AddGroup | Adds an empty group of components to the test.
Public Method AddRTParam | Adds a runtime parameter to the test.
Public Method CancelDownloadPictures | Cancels the download of the test component's pictures.
Public Method CoverRequirement | Adds the specified requirement to the list of requirements covered by this test.
Public Method DeleteBPComponent | Delete the specified BPComponent from the test.
Public Method DeleteGroup | Delete the specified BPGroup from the test.
Public Method DeleteRTParam | Delete the given RTParam from the test.
Public Method DownloadPictures | Download the snapshots attached to the components of the test to the clients cache.
Public Method DownloadPicturesProgress | Reports the status of DownloadPictures.
Public Method GetCoverList | Gets the list of all requirements covered by this test.
Public Method Load | Loads the BusinessProcess object and all of its dependencies into memory.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Mail | Mails the IBaseFieldExMail field item.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method RemoveCoverage | Removes a requirement from the list of requirements this test covers.
Public Method Save | Saves the BusinessProcess object and all of its dependencies.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property BPComponentByID | Gets a BPComponent from the test by its ID.
Public Property BPComponents | The list of BPComponents that belong to the test.
Public Property BPTHistory | The test's history object.
Public Property CheckoutPathIfExist | The checkout path for the test.
Public Property DesignStepFactory | The design steps factory for the current test.
Public Property DesStepsNum | The number of design steps in the test.
Public Property ExecDate | The test execution date and time.
Public Property ExecStatus | The test execution status.
Public Property ExtendedStorage | The Extended Storage object for the current test.
Public Property Field | The value of the specified field.
Public Property FullPath | The full file system path for the test.
Public Property GroupByID | Gets a BPGroup from the test by its ID.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property HasCoverage | Checks if the test covers at least one requirement.
Public Property HasParam | Checks if the test has at least one parameter.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property LastRun | The last Run object for this test.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The test name.
Public Property Params | The current test parameters.
Public Property RTParameters | The list of run time parameters for the test.
Public Property TemplateTest | Indicates if this test is a template test.
Public Property Type | The test type.
Public Property VCS | The VCS version control object for this test.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

BusinessProcess Object

pComponent
A Component Object.
See Also OTA COM Type Library

AddBPComponent Method

Description

Adds the specified Component to the test.

Syntax

Public Function AddBPComponent( _
   ByVal pComponent As Object _
) As Object

Parameters

pComponent
A Component Object.

Return Type

A reference to the new BPComponent Object.

Remarks

A BPComponent is an instance of a Component in a BusinessProcess. Adding a Component to a BusinessProcess twice creates two BPComponent objects. Adding the same Component to two different BusinessProcesss also creates two BPComponent objects.

AddBPComponent also creates one BPIteration and one BPIterationParam for each component parameter in that iteration.

Save any modifications to the returned BPComponent by calling BusinessProcess.Save.

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

AddGroup Method

Description

Adds an empty group of components to the test.

Syntax

Public Function AddGroup() As Object

Return Type

The new, empty BPGroup Object.

Remarks

Save any modifications to the returned group by calling BusinessProcess.Save.

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

AddRTParam Method

Description

Adds a runtime parameter to the test.

Syntax

Public Function AddRTParam() As Object

Return Type

A reference to the new RTParam Object.

Remarks

Save any modifications to the returned runtime parameter by calling BusinessProcess.Save.

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

CancelDownloadPictures Method

Description

Cancels the download of the test component's pictures.

Syntax

Public Sub CancelDownloadPictures()

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

Req
A Req.ID or Req object.
Order
For backward compatibity. Value is ignored.
Recursive

If True, the test is associated with the specified requirement and all of its descendent requirements. If False, the test is associated only with the specified requirement .

See Also OTA COM Type Library

CoverRequirement Method

Description

Adds the specified requirement to the list of requirements covered by this test.

Syntax

Public Function CoverRequirement( _
   ByVal Req As Variant, _
   ByVal Order As Long, _
   ByVal Recursive As Boolean _
) As Long

Parameters

Req
A Req.ID or Req object.
Order
For backward compatibity. Value is ignored.
Recursive

If True, the test is associated with the specified requirement and all of its descendent requirements. If False, the test is associated only with the specified requirement .

Return Type

Not in use. Ignore return value.

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

pBPComponent
A BPComponent Object.
See Also OTA COM Type Library

DeleteBPComponent Method

Description

Delete the specified BPComponent from the test.

Syntax

Public Sub DeleteBPComponent( _
   ByVal pBPComponent As Object _
)

Parameters

pBPComponent
A BPComponent Object.

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

pBPGroup
A BPGroup Object,
See Also OTA COM Type Library

DeleteGroup Method

Description

Delete the specified BPGroup from the test.

Syntax

Public Sub DeleteGroup( _
   ByVal pBPGroup As Object _
)

Parameters

pBPGroup
A BPGroup Object,

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

pRTParam
An RTParam Object.
See Also OTA COM Type Library

DeleteRTParam Method

Description

Delete the given RTParam from the test.

Syntax

Public Sub DeleteRTParam( _
   ByVal pRTParam As Object _
)

Parameters

pRTParam
An RTParam Object.

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

DownloadPictures Method

Description

Download the snapshots attached to the components of the test to the clients cache.

Syntax

Public Sub DownloadPictures()

Remarks

This method operates asynchronously.

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

Total
The total number of bytes to be downloaded.
Current
The number of bytes downloaded thus far.
See Also OTA COM Type Library

DownloadPicturesProgress Method

Description

Reports the status of DownloadPictures.

Syntax

Public Sub DownloadPicturesProgress( _
   ByRef Total As Long, _
   ByRef Current As Long _
)

Parameters

Total
The total number of bytes to be downloaded.
Current
The number of bytes downloaded thus far.

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

GetCoverList Method

Description

Gets the list of all requirements covered by this test.

Syntax

Public Function GetCoverList() As List

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

Load Method

Description

Loads the BusinessProcess object and all of its dependencies into memory.

Syntax

Public Sub Load()

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object | tagTDMAIL_FLAGS Enumeration

SendTo

The recipient address or addresses. Addresses can be separated by a comma or a semicolon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also OTA COM Type Library

Mail Method

Description

Mails the IBaseFieldExMail field item.

Syntax

Public Sub Mail( _
   ByVal SendTo As String, _
   Optional ByVal SendCc As String = "", _
   Optional ByVal Option As Long = 0, _
   Optional ByVal Subject As String = "", _
   Optional ByVal Comment As String = "" _
)

Parameters

SendTo

The recipient address or addresses. Addresses can be separated by a comma or a semicolon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also

BusinessProcess Object | tagTDMAIL_FLAGS Enumeration


%%PageItemTitle%%

BusinessProcess Object

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

Req
A Req.ID or Req object.
See Also OTA COM Type Library

RemoveCoverage Method

Description

Removes a requirement from the list of requirements this test covers.

Syntax

Public Sub RemoveCoverage( _
   ByVal Req As Variant _
)

Parameters

Req
A Req.ID or Req object.

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

Save Method

Description

Saves the BusinessProcess object and all of its dependencies.

Syntax

Public Sub Save()

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

nCompID
A BPComponent .ID.
See Also OTA COM Type Library

BPComponentByID Property

Description

Gets a BPComponent from the test by its ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BPComponentByID( _
   ByVal nCompID As Long _
) As Object

Parameters

nCompID
A BPComponent .ID.

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

BPComponents Property

Description

The list of BPComponents that belong to the test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BPComponents() As List

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

BPTHistory Property

Description

The test's history object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BPTHistory() As Object

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

CheckoutPathIfExist Property

Description

The checkout path for the test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property CheckoutPathIfExist() As String

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

DesignStepFactory Property

Description

The design steps factory for the current test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DesignStepFactory() As Object

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

DesStepsNum Property

Description

The number of design steps in the test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DesStepsNum() As Long

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

ExecDate Property

Description

The test execution date and time.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExecDate() As Date

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

ExecStatus Property

Description

The test execution status.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExecStatus() As String

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

ExtendedStorage Property

Description

The Extended Storage object for the current test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExtendedStorage() As Object

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

FullPath Property

Description

The full file system path for the test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FullPath() As String

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

nGroupID
A BPGroup Object.
See Also OTA COM Type Library

GroupByID Property

Description

Gets a BPGroup from the test by its ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property GroupByID( _
   ByVal nGroupID As Long _
) As Object

Parameters

nGroupID
A BPGroup Object.

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

HasCoverage Property

Description

Checks if the test covers at least one requirement.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasCoverage() As Boolean

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

HasParam Property

Description

Checks if the test has at least one parameter.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasParam() As Boolean

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

LastRun Property

Description

The last Run object for this test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property LastRun() As Object

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

Name Property

Description

The test name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

Params Property

Description

The current test parameters.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Params() As Object

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

RTParameters Property

Description

The list of run time parameters for the test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RTParameters() As List

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

TemplateTest Property

Description

Indicates if this test is a template test.

Property type

Read-write property

Syntax (Visual Basic)

Public Property TemplateTest() As Boolean

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

Type Property

Description

The test type.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Type() As String

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

VCS Property

Description

The VCS version control object for this test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property VCS() As Object

See Also

BusinessProcess Object


%%PageItemTitle%%

BusinessProcess Object

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

BusinessProcess Object


%%PageItemTitle%%

Command Members

Command Object

Description

Represents a database command.

Remarks

The Command object represents a database command. You can use a Command object to query the database and return records in a Recordset Object, to execute a bulk operation, and to manipulate the structure of the database.

The Command object is intrinsically unsafe because it bypasses all the business logic of Quality Center and acts directly on the database. It is included in the API to enable the user to solve unforeseen problems. Before determining that there is no other solution to your application problem, consult your Mercury service representative to investigate other options.

The use of the Command object for a simple Select statement that does not change the database is safe.

Because of the risk, use of the Command object is restricted. For information about security and rights to use the Command object, refer to the Mercury Quality Center Administrator's Guide.

Get a Command object from TDConnection.Command.

Example

Dim com As TDAPIOLELib.Command
Dim RecSet As TDAPIOLELib.Recordset

' Setting and executing the SQL
Set com = tdc.Command
com.CommandText = "select * from bug"
Set RecSet = com.Execute

' Displaying the 2nd column data
For i = 1 To RecSet.RecordCount
List1.AddItem (RecSet.FieldValue(2))
RecSet.Next
Next

Public Methods

Public Method AddParam | Adds new parameter to Command object.
Public Method Cancel | Cancels execution of the ExecuteQuery command.
Public Method DeleteParam | Deletes the specified parameter from Command object.
Public Method DeleteParams | Deletes all parameters from Command object.
Public Method Execute | Executes the command in the CommandText property.

Public Properties

Public Property AffectedRows | The number of table rows that were affected by the command.
Public Property CommandText | The text of the command.
Public Property Count | Number of parameters in current command.
Public Property IndexFields | A comma-separated list of index fields for a SELECT command.
Public Property ParamIndex | The parameter index by parameter name.
Public Property ParamName | The parameter name by parameter index. The index is 0-based.
Public Property ParamType | The data type of the specified parameter. The index is 0-based.
Public Property ParamValue | The parameter value.


%%PageItemTitle%%

Command Object

Name
The name of the new parameter.
InitialValue
The initial value.
See Also OTA COM Type Library

AddParam Method

Description

Adds new parameter to Command object.

Syntax

Public Sub AddParam( _
   ByVal Name As String, _
   ByVal InitialValue As Variant _
)

Parameters

Name
The name of the new parameter.
InitialValue
The initial value.

See Also

Command Object


%%PageItemTitle%%

Command Object

Cancel Method

Description

Cancels execution of the ExecuteQuery command.

Syntax

Public Sub Cancel()

See Also

Command Object


%%PageItemTitle%%

Command Object

Key
The parameter index or name. The index is 0-based.
See Also OTA COM Type Library

DeleteParam Method

Description

Deletes the specified parameter from Command object.

Syntax

Public Sub DeleteParam( _
   ByVal Key As Variant _
)

Parameters

Key
The parameter index or name. The index is 0-based.

See Also

Command Object


%%PageItemTitle%%

Command Object

DeleteParams Method

Description

Deletes all parameters from Command object.

Syntax

Public Sub DeleteParams()

See Also

Command Object


%%PageItemTitle%%

Command Object

Execute Method

Description

Executes the command in the CommandText property.

Syntax

Public Function Execute() As Object

Return Type

For a SELECT statement, returns a Recordset Object. Otherwise, returns nothing.

Remarks

After calling Execute with a select statement, the cursor is on the first record in the recordset.

See Also

Command Object

Example

Example of recordset properties and methods


%%PageItemTitle%%

Command Object

AffectedRows Property

Description

The number of table rows that were affected by the command.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AffectedRows() As Long

Remarks

Consult your Mercury service representative for guidance on use of the Command object to change data.

See Also

Command Object


%%PageItemTitle%%

Command Object

CommandText Property

Description

The text of the command.

Property type

Read-write property

Syntax (Visual Basic)

Public Property CommandText() As String

See Also

Command Object

Example

Example of recordset properties and methods


%%PageItemTitle%%

Command Object

Count Property

Description

Number of parameters in current command.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

Command Object


%%PageItemTitle%%

Command Object

IndexFields Property

Description

A comma-separated list of index fields for a SELECT command.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IndexFields() As String

See Also

Command Object


%%PageItemTitle%%

Command Object

Name
The parameter name.
See Also OTA COM Type Library

ParamIndex Property

Description

The parameter index by parameter name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ParamIndex( _
   ByVal Name As String _
) As Long

Parameters

Name
The parameter name.

See Also

Command Object


%%PageItemTitle%%

Command Object

Index
The parameter index.
See Also OTA COM Type Library

ParamName Property

Description

The parameter name by parameter index. The index is 0-based.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ParamName( _
   ByVal Index As Long _
) As String

Parameters

Index
The parameter index.

See Also

Command Object


%%PageItemTitle%%

Command Object

Index
The parameter index. The index is 0-based.
See Also OTA COM Type Library

ParamType Property

Description

The data type of the specified parameter. The index is 0-based.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ParamType( _
   ByVal Index As Long _
) As Long

Parameters

Index
The parameter index. The index is 0-based.

See Also

Command Object


%%PageItemTitle%%

Command Object

Key
The parameter index or name. The index is 0-based.
See Also OTA COM Type Library

ParamValue Property

Description

The parameter value.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ParamValue( _
   ByVal Key As Variant _
) As Variant

Parameters

Key
The parameter index or name. The index is 0-based.

See Also

Command Object


%%PageItemTitle%%

Component Members

Component Object

Description

Represents a business component.

Remarks

Get a Component with ComponentFactory.AddItem or ComponentFactory.NewList.

Interfaces

IBaseField | IBaseField2 | IBaseField3

Example

Creating a new component | Adding a parameter and step to a component

Public Methods

Public Method BusinessProcesses | The list of associated BusinessProcess objects.
Public Method DeletePicture | Deletes the snapshot.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property ApplicationAreaID | The Component's linked application area ID.
Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property ComponentParamFactory | The component parameter factory.
Public Property ComponentStepFactory | The ComponentStepFactory for this component
Public Property ExtendedStorage | The ExtendedStorage object for this component.
Public Property Field | The value of the specified field.
Public Property Folder | The component's folder.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property HasPicture | Indicates if the component has a snapshot.
Public Property HasScript | Checks if the component is associated with a test script.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property IsObsolete | Checks if the component has been marked deleted by a user but is still in use in a test.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The Component's name.
Public Property ScriptType | The test script type.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

Component Object

BusinessProcesses Method

Description

The list of associated BusinessProcess objects.

Syntax

Public Function BusinessProcesses() As List

Return Type

A list of references to BusinessProcess objects.

See Also

Component Object


%%PageItemTitle%%

Component Object

bsData
For future use. Pass an empty string.
See Also OTA COM Type Library

DeletePicture Method

Description

Deletes the snapshot.

Syntax

Public Sub DeletePicture( _
   ByVal bsData As String _
)

Parameters

bsData
For future use. Pass an empty string.

See Also

Component Object


%%PageItemTitle%%

Component Object

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Component Object


%%PageItemTitle%%

Component Object

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Component Object


%%PageItemTitle%%

Component Object

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Component Object


%%PageItemTitle%%

Component Object

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

Component Object


%%PageItemTitle%%

Component Object

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

Component Object


%%PageItemTitle%%

Component Object

ApplicationAreaID Property

Description

The Component's linked application area ID.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ApplicationAreaID() As Long

See Also

Component Object


%%PageItemTitle%%

Component Object

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

Component Object


%%PageItemTitle%%

Component Object

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

Component Object


%%PageItemTitle%%

Component Object

ComponentParamFactory Property

Description

The component parameter factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ComponentParamFactory() As Object

See Also

Component Object


%%PageItemTitle%%

Component Object

ComponentStepFactory Property

Description

The ComponentStepFactory for this component

Property type

Read-only property

Syntax (Visual Basic)

Public Property ComponentStepFactory() As Object

See Also

Component Object


%%PageItemTitle%%

Component Object

nEntityType
A graphic or a script, indicated with a value of the tagEXTENDEDSTORAGE_ENTITY Enumeration
See Also OTA COM Type Library

ExtendedStorage Property

Description

The ExtendedStorage object for this component.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExtendedStorage( _
   ByVal nEntityType As Long _
) As Object

Parameters

nEntityType
A graphic or a script, indicated with a value of the tagEXTENDEDSTORAGE_ENTITY Enumeration

See Also

Component Object


%%PageItemTitle%%

Component Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

Component Object


%%PageItemTitle%%

Component Object

Folder Property

Description

The component's folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Folder() As Object

See Also

Component Object


%%PageItemTitle%%

Component Object

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

Component Object


%%PageItemTitle%%

Component Object

HasPicture Property

Description

Indicates if the component has a snapshot.

Property type

Read-write property

Syntax (Visual Basic)

Public Property HasPicture() As Boolean

See Also

Component Object


%%PageItemTitle%%

Component Object

HasScript Property

Description

Checks if the component is associated with a test script.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasScript() As Boolean

See Also

Component Object


%%PageItemTitle%%

Component Object

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

Component Object


%%PageItemTitle%%

Component Object

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

Component Object


%%PageItemTitle%%

Component Object

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

Component Object


%%PageItemTitle%%

Component Object

IsObsolete Property

Description

Checks if the component has been marked deleted by a user but is still in use in a test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsObsolete() As Boolean

See Also

Component Object


%%PageItemTitle%%

Component Object

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

Component Object


%%PageItemTitle%%

Component Object

Name Property

Description

The Component's name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

Remarks

The name may not contain the characters \/, :, ", ?, ', <, >, |, *, %, !, {, or }.

See Also

Component Object


%%PageItemTitle%%

Component Object

ScriptType Property

Description

The test script type.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ScriptType() As String

Remarks

Examples of script types are MANUAL, QT-KW, QT-SCRIPTED, and WR-AUTOMATED. For the full list in your project, look at the CompType custom list in the Project Customization tool.

See Also

Component Object


%%PageItemTitle%%

Component Object

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

Component Object


%%PageItemTitle%%

IBaseField Members

IBaseField Interface

Description

Represents a basic data field or entity, such as an attachment.

Interface Remarks

IBaseField defines a basic data field or entity. Use the properties and methods in IBaseField to perform field-related actions, such as setting and refreshing field values. Examples of objects that implement IBaseField are: Attachment, Bug, Condition, DesignStep, Host, HostGroup, Req, Run, Step, SubjectNode, SysTreeNode, Test, TestSet, and TSTest.

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%% $$Members$$

Component Object

IBaseField3 Implemented Interface Members

Methods

Public Implemented Method Post Writes all changed values to database.

See Also

Component Object


%%PageItemTitle%%

Component Object | IBaseField3 Implemented Interface

UndoOnFailure
See Also OTA COM Type Library

Post Implemented Method

Description

Writes all changed values to database.

Syntax

Public Sub Post( _
   Optional ByVal UndoOnFailure As Boolean = True _
)

Parameters

UndoOnFailure

See Also

Component Object | IBaseField3 Implemented Interface


%%PageItemTitle%%

ComponentFactory Members

ComponentFactory Object

Description

Services for managing business components.

Remarks

Get a ComponentFactory from TDConnection.ComponentFactory or ComponentFolder.ComponentFactory.

Interfaces

IBaseFactory | IBaseFactory2 | ISearchableFactory | ISupportCopyPaste2

Example

Getting a reference to an implemented interface | Creating a new component | Add component to test

Public Methods

Public Method AddItem | Creates a new item object.
Public Method IsComponentNameValid | Checks if the specified name is a valid name for a business component.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

ComponentFactory Object

ItemData

There are three options for ItemData:

  • Null.
  • The ComponentFolder.ID for the parent object.
  • An array consisting of the following elements:

    (0) Parent ID - A ComponentFolder.ID (long. required).

    (1) Name - The Component name (string. optional).

See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData

There are three options for ItemData:

  • Null.
  • The ComponentFolder.ID for the parent object.
  • An array consisting of the following elements:

    (0) Parent ID - A ComponentFolder.ID (long. required).

    (1) Name - The Component name (string. optional).

See Also

ComponentFactory Object


%%PageItemTitle%%

ComponentFactory Object

bsName
The string to check if it is a valid name.
pbsErrorString
An error message listing the invalid characters.
See Also OTA COM Type Library

IsComponentNameValid Method

Description

Checks if the specified name is a valid name for a business component.

Syntax

Public Function IsComponentNameValid( _
   ByVal bsName As String, _
   ByRef pbsErrorString As String _
) As Boolean

Parameters

bsName
The string to check if it is a valid name.
pbsErrorString
An error message listing the invalid characters.

Return Type

True if the string is a valid name.

Remarks

The invalid characters are % * {} \\ | ' : "" / < and >.

See Also

ComponentFactory Object


%%PageItemTitle%%

ComponentFactory Object

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

ComponentFactory Object


%%PageItemTitle%%

ComponentFactory Object

ItemKey
A Component.ID.
See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey
A Component.ID.

See Also

ComponentFactory Object


%%PageItemTitle%%

ComponentFactory Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

ComponentFactory Object


%%PageItemTitle%%

ComponentFactory Object

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

ComponentFactory Object


%%PageItemTitle%%

ComponentFactory Object

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

ComponentFactory Object


%%PageItemTitle%%

ComponentFactory Object

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

ComponentFactory Object


%%PageItemTitle%%

ComponentFactory Object

ItemKey
A Component.ID.
See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey
A Component.ID.

See Also

ComponentFactory Object


%%PageItemTitle%%

IBaseFactory Members

IBaseFactory Interface

Description

Provides basic object basic factory services, such as adding and removing factory child objects and creating lists of child objects.

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

ComponentFolder Members

ComponentFolder Object

Description

Represents a business component folder.

Remarks

Get a ComponentFolder reference from Component.Folder.

If you obtain a ComponentFactory from a ComponentFolder using the ComponentFactory Property and create a new component using the factory, attach the new component to the parent folder by setting the new component's CO_FOLDER_ID field. See the example, Creating a new component.

Interfaces

IBaseField | IBaseField2 | IBaseField3

Example

Creating a new component | Finding a component folder by name and creating a new subfolder

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property ComponentFactory | The ComponentFactory object.
Public Property ComponentFolderFactory | The component's ComponentFolderFactory.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The component's folder name
Public Property Path | The component folder's path
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

ComponentFolder Object

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ComponentFolder Object


%%PageItemTitle%%

ComponentFolder Object

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ComponentFolder Object


%%PageItemTitle%%

ComponentFolder Object

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ComponentFolder Object


%%PageItemTitle%%

ComponentFolder Object

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

ComponentFolder Object


%%PageItemTitle%%

ComponentFolder Object

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

ComponentFolder Object


%%PageItemTitle%%

ComponentFolder Object

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

ComponentFolder Object


%%PageItemTitle%%

ComponentFolder Object

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

ComponentFolder Object


%%PageItemTitle%%

ComponentFolder Object

ComponentFactory Property

Description

The ComponentFactory object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ComponentFactory() As Object

See Also

ComponentFolder Object


%%PageItemTitle%%

ComponentFolder Object

ComponentFolderFactory Property

Description

The component's ComponentFolderFactory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ComponentFolderFactory() As Object

See Also

ComponentFolder Object


%%PageItemTitle%%

ComponentFolder Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

ComponentFolder Object


%%PageItemTitle%%

ComponentFolder Object

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

ComponentFolder Object


%%PageItemTitle%%

ComponentFolder Object

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

ComponentFolder Object


%%PageItemTitle%%

ComponentFolder Object

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

ComponentFolder Object


%%PageItemTitle%%

ComponentFolder Object

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

ComponentFolder Object


%%PageItemTitle%%

ComponentFolder Object

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

ComponentFolder Object


%%PageItemTitle%%

ComponentFolder Object

Name Property

Description

The component's folder name

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ComponentFolder Object


%%PageItemTitle%%

ComponentFolder Object

Path Property

Description

The component folder's path

Property type

Read-only property

Syntax (Visual Basic)

Public Property Path() As String

See Also

ComponentFolder Object


%%PageItemTitle%%

ComponentFolder Object

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

ComponentFolder Object


%%PageItemTitle%% $$Members$$

ComponentFolder Object

IBaseField3 Implemented Interface Members

Methods

Public Implemented Method Post Writes all changed values to database.

See Also

ComponentFolder Object


%%PageItemTitle%%

ComponentFolder Object | IBaseField3 Implemented Interface

UndoOnFailure
See Also OTA COM Type Library

Post Implemented Method

Description

Writes all changed values to database.

Syntax

Public Sub Post( _
   Optional ByVal UndoOnFailure As Boolean = True _
)

Parameters

UndoOnFailure

See Also

ComponentFolder Object | IBaseField3 Implemented Interface


%%PageItemTitle%%

ComponentFolderFactory Members

ComponentFolderFactory Object

Description

Services for managing the organization of business components.

Remarks

Get a reference to a ComponentFolderFactory from TDConnection.ComponentFolderFactory or ComponentFolder.ComponentFolderFactory.

Interfaces

IBaseFactory | IBaseFactory2 | ISupportCopyPaste2

Example

Getting a reference to an implemented interface | Finding a component folder by name and creating a new subfolder

Public Methods

Public Method AddItem | Creates a new item object.
Public Method FolderByPath | Gets a ComponentFolder by its path
Public Method FolderPath | Gets the path of the specified folder.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method Obsolete | Gets the Obsolete Components folder.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.
Public Method Root | Gets the business components root folder.
Public Method Templates | Gets the Templates folder (Quick Test only).

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

ComponentFolderFactory Object

ItemData

There are two options for ItemData:

  • Null.
  • ComponentFolder.ID for the parent folder.
See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData

There are two options for ItemData:

  • Null.
  • ComponentFolder.ID for the parent folder.

See Also

ComponentFolderFactory Object


%%PageItemTitle%%

ComponentFolderFactory Object

Path
The path of the requested folder.
See Also OTA COM Type Library

FolderByPath Method

Description

Gets a ComponentFolder by its path

Syntax

Public Function FolderByPath( _
   ByVal Path As String _
) As Object

Parameters

Path
The path of the requested folder.

Return Type

A ComponentFolder.

See Also

ComponentFolderFactory Object


%%PageItemTitle%%

ComponentFolderFactory Object

folderId
A ComponentFolder.ID.
See Also OTA COM Type Library

FolderPath Method

Description

Gets the path of the specified folder.

Syntax

Public Function FolderPath( _
   ByVal folderId As Long _
) As String

Parameters

folderId
A ComponentFolder.ID.

Return Type

The path of the specified folder.

See Also

ComponentFolderFactory Object


%%PageItemTitle%%

ComponentFolderFactory Object

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

ComponentFolderFactory Object


%%PageItemTitle%%

ComponentFolderFactory Object

Obsolete Method

Description

Gets the Obsolete Components folder.

Syntax

Public Function Obsolete() As Object

Return Value Details

A ComponentFolder.

See Also

ComponentFolderFactory Object


%%PageItemTitle%%

ComponentFolderFactory Object

ItemKey
A ComponentFolder.ID.
See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey
A ComponentFolder.ID.

See Also

ComponentFolderFactory Object


%%PageItemTitle%%

ComponentFolderFactory Object

Root Method

Description

Gets the business components root folder.

Syntax

Public Function Root() As Object

Return Type

A ComponentFolder.

See Also

ComponentFolderFactory Object


%%PageItemTitle%%

ComponentFolderFactory Object

Templates Method

Description

Gets the Templates folder (Quick Test only).

Syntax

Public Function Templates() As Object

Return Type

A ComponentFolder Object.

Remarks

The Templates folder is visible only in a QuickTest Professional software context. Therefore, this method is for use only with QuickTest applications that access the Open Test Architecture API. If used from other software contexts, the results are indeterminent or result in an exception.

See Also

ComponentFolderFactory Object


%%PageItemTitle%%

ComponentFolderFactory Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

ComponentFolderFactory Object


%%PageItemTitle%%

ComponentFolderFactory Object

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

ComponentFolderFactory Object


%%PageItemTitle%%

ComponentFolderFactory Object

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

ComponentFolderFactory Object


%%PageItemTitle%%

ComponentFolderFactory Object

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

ComponentFolderFactory Object


%%PageItemTitle%%

ComponentFolderFactory Object

ItemKey
A ComponentFolder.ID.
See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey
A ComponentFolder.ID.

See Also

ComponentFolderFactory Object


%%PageItemTitle%%

ComponentParam Members

ComponentParam Object

Description

Services for managing Business Process Test parameters.

Remarks

Get a ComponentParam from ComponentParamFactory.AddItem.

Interfaces

IBaseField | IBaseField2 | IBaseField3 | IBaseFieldEx

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Component | The Component containing the parameter.
Public Property Desc | The parameter description.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property IsOut | Indicates if this is an output parameter. If False, this is an input parameter.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The component parameter's name.
Public Property Order | The position of the parameter in the set of parameters of the same component.
Public Property Value | The parameter's default value.
Public Property ValueType | The parameter type. For example Date, String, number, etc.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

ComponentParam Object

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ComponentParam Object


%%PageItemTitle%%

ComponentParam Object

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ComponentParam Object


%%PageItemTitle%%

ComponentParam Object

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ComponentParam Object


%%PageItemTitle%%

ComponentParam Object

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

ComponentParam Object


%%PageItemTitle%%

ComponentParam Object

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

ComponentParam Object


%%PageItemTitle%%

ComponentParam Object

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

ComponentParam Object


%%PageItemTitle%%

ComponentParam Object

Component Property

Description

The Component containing the parameter.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Component() As Object

See Also

ComponentParam Object


%%PageItemTitle%%

ComponentParam Object

Desc Property

Description

The parameter description.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Desc() As String

See Also

ComponentParam Object


%%PageItemTitle%%

ComponentParam Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

ComponentParam Object


%%PageItemTitle%%

ComponentParam Object

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

ComponentParam Object


%%PageItemTitle%%

ComponentParam Object

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

ComponentParam Object


%%PageItemTitle%%

ComponentParam Object

IsOut Property

Description

Indicates if this is an output parameter. If False, this is an input parameter.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsOut() As Long

See Also

ComponentParam Object


%%PageItemTitle%%

ComponentParam Object

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

ComponentParam Object


%%PageItemTitle%%

ComponentParam Object

Name Property

Description

The component parameter's name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ComponentParam Object


%%PageItemTitle%%

ComponentParam Object

Order Property

Description

The position of the parameter in the set of parameters of the same component.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Order() As Long

See Also

ComponentParam Object


%%PageItemTitle%%

ComponentParam Object

Value Property

Description

The parameter's default value.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Value() As String

See Also

ComponentParam Object


%%PageItemTitle%%

ComponentParam Object

ValueType Property

Description

The parameter type. For example Date, String, number, etc.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ValueType() As String

See Also

ComponentParam Object


%%PageItemTitle%%

ComponentParam Object

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

ComponentParam Object


%%PageItemTitle%% $$Members$$

ComponentParam Object

IBaseField3 Implemented Interface Members

Methods

Public Implemented Method Post Writes all changed values to database.

See Also

ComponentParam Object


%%PageItemTitle%%

ComponentParam Object | IBaseField3 Implemented Interface

UndoOnFailure
See Also OTA COM Type Library

Post Implemented Method

Description

Writes all changed values to database.

Syntax

Public Sub Post( _
   Optional ByVal UndoOnFailure As Boolean = True _
)

Parameters

UndoOnFailure

See Also

ComponentParam Object | IBaseField3 Implemented Interface


%%PageItemTitle%%

IBaseFieldEx Members

IBaseFieldEx Interface

Description

Represents a basic data field or entity, such as an attachment. Use the properties and methods to perform field-related actions, such as setting and refreshing field values.

Interface Remarks

IBaseFieldEx is implemented by several classes, among them: DesignStep, HostGroup, Run, Step, TSTest, and TestSet.
IBaseField defines a basic data field or entity. Use the properties and methods in IBaseField to perform field-related actions, such as setting and refreshing field values. Examples of objects that implement IBaseField are: Attachment, Bug, Condition, DesignStep, Host, HostGroup, Req, Run, Step, SubjectNode, SysTreeNode, Test, TestSet, and TSTest.

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

ComponentParamFactory Members

ComponentParamFactory Object

Description

Services to manage component parameters.

Remarks

Get a ComponentParamFactory from Component.ComponentParamFactory.

Interfaces

IBaseFactory2 | ISupportCopyPaste2

Example

Getting a reference to an implemented interface | Adding a parameter and step to a component

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

ComponentParamFactory Object

ItemData
When creating ComponentParam objects, pass NULL for ItemData.
See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData
When creating ComponentParam objects, pass NULL for ItemData.

See Also

ComponentParamFactory Object


%%PageItemTitle%%

ComponentParamFactory Object

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

ComponentParamFactory Object


%%PageItemTitle%%

ComponentParamFactory Object

ItemKey

A ComponentParam.ID.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey

A ComponentParam.ID.

See Also

ComponentParamFactory Object


%%PageItemTitle%%

ComponentParamFactory Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

ComponentParamFactory Object


%%PageItemTitle%%

ComponentParamFactory Object

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

ComponentParamFactory Object


%%PageItemTitle%%

ComponentParamFactory Object

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

ComponentParamFactory Object


%%PageItemTitle%%

ComponentParamFactory Object

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

ComponentParamFactory Object


%%PageItemTitle%%

ComponentParamFactory Object

ItemKey

A ComponentParam.ID.

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey

A ComponentParam.ID.

See Also

ComponentParamFactory Object


%%PageItemTitle%%

ComponentStep Members

ComponentStep Object

Description

Represents a step in a business component.

Remarks

Get a ComponentStep with ComponentStepFactory.AddItem.

Interfaces

IBaseField | IBaseField2 | IBaseField3

Example

Adding a parameter and step to a component

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.
Public Method Validate | Validate the step.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Order | The 1-based position of the step in the order of execution of the steps of the component.
Public Property Parent | The parent Component
Public Property StepDescription | The description of the step.
Public Property StepExpectedResult | The expected result of the step.
Public Property StepName | The component step name.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

ComponentStep Object

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ComponentStep Object


%%PageItemTitle%%

ComponentStep Object

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ComponentStep Object


%%PageItemTitle%%

ComponentStep Object

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ComponentStep Object


%%PageItemTitle%%

ComponentStep Object

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

ComponentStep Object


%%PageItemTitle%%

ComponentStep Object

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

ComponentStep Object


%%PageItemTitle%%

ComponentStep Object

Validate Method

Description

Validate the step.

Syntax

Public Sub Validate()

Remarks

Validate throws an exception if the step is not valid. The exception message contains details of the error.

See Also

ComponentStep Object


%%PageItemTitle%%

ComponentStep Object

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

ComponentStep Object


%%PageItemTitle%%

ComponentStep Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

ComponentStep Object


%%PageItemTitle%%

ComponentStep Object

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

ComponentStep Object


%%PageItemTitle%%

ComponentStep Object

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

ComponentStep Object


%%PageItemTitle%%

ComponentStep Object

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

ComponentStep Object


%%PageItemTitle%%

ComponentStep Object

Order Property

Description

The 1-based position of the step in the order of execution of the steps of the component.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Order() As Long

See Also

ComponentStep Object


%%PageItemTitle%%

ComponentStep Object

Parent Property

Description

The parent Component

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As Object

See Also

ComponentStep Object


%%PageItemTitle%%

ComponentStep Object

StepDescription Property

Description

The description of the step.

Property type

Read-write property

Syntax (Visual Basic)

Public Property StepDescription() As String

Remarks

This field may specify a parameter. Parameters are enclosed in triple angle brackets: <<<param name>>>. It the parameter name is invalid, <<<param name>>> is replaced with <param name> when written to the project database.

The field is stored in an HTML format. To specify a field value of "My_text <<<param name>>> more_text", enter <html><body>My_text &lt;&lt;&lt;param name&gt;&gt;&gt; more_text</body></html>. Alternately, set TDConnection.IgnoreHtmlFormat = True and then pass the desired field value as plain text.

See Also

ComponentStep Object


%%PageItemTitle%%

ComponentStep Object

StepExpectedResult Property

Description

The expected result of the step.

Property type

Read-write property

Syntax (Visual Basic)

Public Property StepExpectedResult() As String

See Also

ComponentStep Object


%%PageItemTitle%%

ComponentStep Object

StepName Property

Description

The component step name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property StepName() As String

See Also

ComponentStep Object


%%PageItemTitle%%

ComponentStep Object

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

ComponentStep Object


%%PageItemTitle%% $$Members$$

ComponentStep Object

IBaseField3 Implemented Interface Members

Methods

Public Implemented Method Post Writes all changed values to database.

See Also

ComponentStep Object


%%PageItemTitle%%

ComponentStep Object | IBaseField3 Implemented Interface

UndoOnFailure
See Also OTA COM Type Library

Post Implemented Method

Description

Writes all changed values to database.

Syntax

Public Sub Post( _
   Optional ByVal UndoOnFailure As Boolean = True _
)

Parameters

UndoOnFailure

See Also

ComponentStep Object | IBaseField3 Implemented Interface


%%PageItemTitle%%

ComponentStepFactory Members

ComponentStepFactory Object

Description

Services to manage ComponentStep objects.

Remarks

Get a ComponentStepFactory from Component.ComponentStepFactory.

Interfaces

IBaseFactory | IBaseFactory2 | ISupportCopyPaste2

Example

Getting a reference to an implemented interface | Adding a parameter and step to a component

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

ComponentStepFactory Object

ItemData

There are three options for ItemData:

  • Null.
  • The step description
  • An array containing:

    The step description (required)

    The step order (long, optional)

See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData

There are three options for ItemData:

  • Null.
  • The step description
  • An array containing:

    The step description (required)

    The step order (long, optional)

Remarks

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

[Visual Basic]

Dim bgf As BugFactory
Dim bg As Bug
Dim attf As AttachmentFactory
Dim att As Attachment
Dim attList As List

' Get the factory object
 Set bgf = tdc.BugFactory
' Use defect #1
 Set bg = bgf.Item(1)
 Set attf = bg.Attachments

' Creating a new attachment
' Create virtual object, then populate the properties
 Set att = attf.AddItem(Null)
 att.FileName = Text1.Text
 att.Type = TDATT_INTERNET

' Saving the object with validity check
 att.Post

' Display the attachments
' Add the display-only items without a Post
 List1.Clear
 Set attList = attf.NewList("")
 For i = 1 To attList.Count

      Set att = attList.Item(i)
      List1.AddItem (att.Name)

 Next

See Also

ComponentStepFactory Object


%%PageItemTitle%%

ComponentStepFactory Object

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

ComponentStepFactory Object


%%PageItemTitle%%

ComponentStepFactory Object

ItemKey
A ComponentStep.ID, ComponentStep Object, a Variant Array of ComponentStepobjects, or a List of ComponentStep objects.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey
A ComponentStep.ID, ComponentStep Object, a Variant Array of ComponentStepobjects, or a List of ComponentStep objects.

See Also

ComponentStepFactory Object


%%PageItemTitle%%

ComponentStepFactory Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

ComponentStepFactory Object


%%PageItemTitle%%

ComponentStepFactory Object

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

ComponentStepFactory Object


%%PageItemTitle%%

ComponentStepFactory Object

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

ComponentStepFactory Object


%%PageItemTitle%%

ComponentStepFactory Object

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

ComponentStepFactory Object


%%PageItemTitle%%

ComponentStepFactory Object

ItemKey
A ComponentStep.ID.

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey
A ComponentStep.ID.

See Also

ComponentStepFactory Object


%%PageItemTitle%%

Condition Members

Condition Object

Description

Represents a condition for a test to be executed.

Remarks

Conditions are used to define dependencies between TSTests in the test set execution flow. They define when a particular test instance can be executed. The Source is a condition that must be fulfilled. The Target is a TSTest object.
If the execution condition is not based on time, the source is a TSTest which must run before the Target. The Target test instance either runs or does not run based on the result of the test: passed or failed.

Changes for the condition are saved in the project after calling the Save method of the ConditionFactory Object.

Get a Condition object from the ConditionFactory using AddItem, NewList, or Item.

Interfaces

IBaseField2 | IBaseField3

Public Properties

Public Property Description | The Condition description.
Public Property ID | The Condition ID.
Public Property Source | For a run condition, the source condition ID. For a time condition, a date-time string.
Public Property Target | The target test instance number of the condition.
Public Property Value | The Condition status value.


%%PageItemTitle%%

Condition Object

Description Property

Description

The Condition description.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Description() As String

Remarks

The user-entered comment.

See Also

Condition Object


%%PageItemTitle%%

Condition Object

ID Property

Description

The Condition ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

Condition Object


%%PageItemTitle%%

Condition Object

Source Property

Description

For a run condition, the source condition ID. For a time condition, a date-time string.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Source() As Variant

See Also

Condition Object


%%PageItemTitle%%

Condition Object

Target Property

Description

The target test instance number of the condition.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Target() As Variant

See Also

Condition Object


%%PageItemTitle%%

Condition Object

Value Property

Description

The Condition status value.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Value() As Variant

See Also

Condition Object


%%PageItemTitle%% $$Members$$

Condition Object

IBaseField3 Implemented Interface Members

Methods

Public Implemented Method Post Writes all changed values to database.

See Also

Condition Object


%%PageItemTitle%%

Condition Object | IBaseField3 Implemented Interface

UndoOnFailure
See Also OTA COM Type Library

Post Implemented Method

Description

Writes all changed values to database.

Syntax

Public Sub Post( _
   Optional ByVal UndoOnFailure As Boolean = True _
)

Parameters

UndoOnFailure

See Also

Condition Object | IBaseField3 Implemented Interface


%%PageItemTitle%%

ConditionFactory Members

ConditionFactory Object

Description

Services for managing conditions for executing test instances in an test set.

Remarks

You cannot save an individually selected condition. Use the Save method to save all changes to all conditions.

Get a ConditionFactory object from TestSet.ConditionFactory.

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Interfaces

IBaseFactory2 | ISupportCopyPaste2

Example

Getting a reference to an implemented interface

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.
Public Method Save | Saves all conditions.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

ConditionFactory Object

ItemData

There are two options for ItemData:

  • Null. Initially creating a virtual object with Null ensures that you cannot then Post until all required fields are initialized.
  • An array consisting of the following elements:

(0) Type - The condition type (long, required). 1 for run or 2 for time.

(1) Source - For a run condition, the source condition ID (long). For a time condition, the date-time string. (required)

(2) Target - The target condition ID (long, required).

(3) Value - The condition value. (required). For a time condition, the date-time string. For a run condition, either TDCOND_PASSED or TDCOND_FAILED.

(4) Desc - A description of the condition (string, optional).

See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData

There are two options for ItemData:

  • Null. Initially creating a virtual object with Null ensures that you cannot then Post until all required fields are initialized.
  • An array consisting of the following elements:

(0) Type - The condition type (long, required). 1 for run or 2 for time.

(1) Source - For a run condition, the source condition ID (long). For a time condition, the date-time string. (required)

(2) Target - The target condition ID (long, required).

(3) Value - The condition value. (required). For a time condition, the date-time string. For a run condition, either TDCOND_PASSED or TDCOND_FAILED.

(4) Desc - A description of the condition (string, optional).

Return Type

A Condition Object.

Remarks

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

[Visual Basic]

Dim bgf As BugFactory
Dim bg As Bug
Dim attf As AttachmentFactory
Dim att As Attachment
Dim attList As List

' Get the factory object
 Set bgf = tdc.BugFactory
' Use defect #1
 Set bg = bgf.Item(1)
 Set attf = bg.Attachments

' Creating a new attachment
' Create virtual object, then populate the properties
 Set att = attf.AddItem(Null)
 att.FileName = Text1.Text
 att.Type = TDATT_INTERNET

' Saving the object with validity check
 att.Post

' Display the attachments
' Add the display-only items without a Post
 List1.Clear
 Set attList = attf.NewList("")
 For i = 1 To attList.Count

      Set att = attList.Item(i)
      List1.AddItem (att.Name)

 Next

See Also

ConditionFactory Object


%%PageItemTitle%%

ConditionFactory Object

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

ConditionFactory Object


%%PageItemTitle%%

ConditionFactory Object

ItemKey
A Condition.ID (long), a reference to a Condition Object, or a variant array of Condition IDs.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey
A Condition.ID (long), a reference to a Condition Object, or a variant array of Condition IDs.

See Also

ConditionFactory Object


%%PageItemTitle%%

ConditionFactory Object

Save Method

Description

Saves all conditions.

Syntax

Public Sub Save()

See Also

ConditionFactory Object


%%PageItemTitle%%

ConditionFactory Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

ConditionFactory Object


%%PageItemTitle%%

ConditionFactory Object

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

ConditionFactory Object


%%PageItemTitle%%

ConditionFactory Object

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

ConditionFactory Object


%%PageItemTitle%%

ConditionFactory Object

ItemKey
A long integer.

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey
A long integer.

See Also

ConditionFactory Object


%%PageItemTitle%%

CoverageEntity Members

CoverageEntity Object

Description

Represents the association between a requirement and another entity that covers it.

Remarks

Get CoverageEntity objects from the list returned by CoverageFactory.NewList Method.

Interfaces

IBaseField2 | IBaseField3

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property CoverageType | The type of coverage. For example, Test or TSTest.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The name of the TargetEntity.
Public Property RequirementEntity | The Req object being covered.
Public Property Status | The execution result status of the TargetEntity.
Public Property TargetEntity | The entity object that covers the requirement.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

CoverageEntity Object

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

CoverageEntity Object


%%PageItemTitle%%

CoverageEntity Object

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

CoverageEntity Object


%%PageItemTitle%%

CoverageEntity Object

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

CoverageEntity Object


%%PageItemTitle%%

CoverageEntity Object

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

CoverageEntity Object


%%PageItemTitle%%

CoverageEntity Object

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

CoverageEntity Object


%%PageItemTitle%%

CoverageEntity Object

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

CoverageEntity Object


%%PageItemTitle%%

CoverageEntity Object

CoverageType Property

Description

The type of coverage. For example, Test or TSTest.

Property type

Read-only property

Syntax (Visual Basic)

Public Property CoverageType() As String

See Also

CoverageEntity Object


%%PageItemTitle%%

CoverageEntity Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

CoverageEntity Object


%%PageItemTitle%%

CoverageEntity Object

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

CoverageEntity Object


%%PageItemTitle%%

CoverageEntity Object

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

CoverageEntity Object


%%PageItemTitle%%

CoverageEntity Object

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

CoverageEntity Object


%%PageItemTitle%%

CoverageEntity Object

Name Property

Description

The name of the TargetEntity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name() As String

See Also

CoverageEntity Object


%%PageItemTitle%%

CoverageEntity Object

RequirementEntity Property

Description

The Req object being covered.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RequirementEntity() As Object

See Also

CoverageEntity Object


%%PageItemTitle%%

CoverageEntity Object

Status Property

Description

The execution result status of the TargetEntity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Status() As String

See Also

CoverageEntity Object


%%PageItemTitle%%

CoverageEntity Object

TargetEntity Property

Description

The entity object that covers the requirement.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TargetEntity() As Object

See Also

CoverageEntity Object


%%PageItemTitle%%

CoverageEntity Object

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

CoverageEntity Object


%%PageItemTitle%%

CoverageFactory Members

CoverageFactory Object

Description

Services for managing CoverageEntity objects.

Remarks

The reference to a CoverageFactory for a specific object is the ICoverable.CoverageFactory Property of the ICoverable Implemented Interface of the Test or TSTest object.

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Interfaces

IBaseFactory2

Example

Getting a reference to an implemented interface | Accessing members of Additional Implemented Interfaces

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

CoverageFactory Object

ItemData
Pass Null.

See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData
Pass Null.

Return Type

A CoverageEntity Object.

Remarks

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

[Visual Basic]

Dim bgf As BugFactory
Dim bg As Bug
Dim attf As AttachmentFactory
Dim att As Attachment
Dim attList As List

' Get the factory object
 Set bgf = tdc.BugFactory
' Use defect #1
 Set bg = bgf.Item(1)
 Set attf = bg.Attachments

' Creating a new attachment
' Create virtual object, then populate the properties
 Set att = attf.AddItem(Null)
 att.FileName = Text1.Text
 att.Type = TDATT_INTERNET

' Saving the object with validity check
 att.Post

' Display the attachments
' Add the display-only items without a Post
 List1.Clear
 Set attList = attf.NewList("")
 For i = 1 To attList.Count

      Set att = attList.Item(i)
      List1.AddItem (att.Name)

 Next

See Also

CoverageFactory Object


%%PageItemTitle%%

CoverageFactory Object

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

CoverageFactory Object


%%PageItemTitle%%

CoverageFactory Object

ItemKey
A CoverageEntity.ID, CoverageEntity Object, a Variant Array of CoverageEntity objects, or a List of CoverageEntity objects.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey
A CoverageEntity.ID, CoverageEntity Object, a Variant Array of CoverageEntity objects, or a List of CoverageEntity objects.

See Also

CoverageFactory Object


%%PageItemTitle%%

CoverageFactory Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

CoverageFactory Object


%%PageItemTitle%%

CoverageFactory Object

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

CoverageFactory Object


%%PageItemTitle%%

CoverageFactory Object

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

CoverageFactory Object


%%PageItemTitle%%

CoverageFactory Object

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

CoverageFactory Object


%%PageItemTitle%%

CoverageFactory Object

ItemKey
A Req.ID.

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey
A Req.ID.

See Also

CoverageFactory Object


%%PageItemTitle%%

Customization Members

Customization Object

Description

Customization services, such as adding users to user groups, maintaining user-defined fields, configuring user access privileges.

Example

Get a Customization object from TDConnection.Customization.

Example

Add a project user | Make a user-defined field searchable | Add a customization list | Add items to a custom list | Add a user defined field | Add a site user | Delete a customization list

Public Methods

Public Method Commit | Posts all customization data changes to the project database.
Public Method Load | Loads all customization data from the server into the client cache. This includes actions, fields, lists, modules, permissions, users, and user groups.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Rollback | Discards unsaved changes to properties and child objects.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Actions | The CustomizationActions object.
Public Property CustomizableEntitiesTables | Returns the list of the customizable entities' table names.
Public Property EntityDataTables | Returns the names of the data tables that have a user label defined as comma-separated pairs of table names and user labels.
Public Property ExtendedUDFSupport | Checks if the program can use the maximum allowable user-defined fields (99 user-defined fields and 3 memo fields).
Public Property Fields | The CustomizationFields object.
Public Property IsChanged | Checks if there has been at least one change to a property or child object that has not been saved.
Public Property IsLocked | Checks if object is locked.
Public Property Lists | The CustomizationLists object.
Public Property MailConditions | The CustomizationMailConditions Object.
Public Property Modules | The CustomizationModules object.
Public Property Permissions | The CustomizationPermissions object.
Public Property RBT | Returns the CustomizationRBT object.
Public Property Types | Returns the CustomizationTypes object.
Public Property Users | The CustomizationUsers object.
Public Property UsersGroups | The CustomizationUsersGroups object.


%%PageItemTitle%%

Customization Object

Commit Method

Description

Posts all customization data changes to the project database.

Syntax

Public Sub Commit()

See Also

Customization Object


%%PageItemTitle%%

Customization Object

Load Method

Description

Loads all customization data from the server into the client cache. This includes actions, fields, lists, modules, permissions, users, and user groups.

Syntax

Public Sub Load()

See Also

Customization Object


%%PageItemTitle%%

Customization Object

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Customization Object


%%PageItemTitle%%

Customization Object

Rollback Method

Description

Discards unsaved changes to properties and child objects.

Syntax

Public Sub Rollback()

See Also

Customization Object


%%PageItemTitle%%

Customization Object

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

Customization Object


%%PageItemTitle%%

Customization Object

Actions Property

Description

The CustomizationActions object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Actions() As Object

See Also

Customization Object


%%PageItemTitle%%

Customization Object

CustomizableEntitiesTables Property

Description

Returns the list of the customizable entities' table names.

Property type

Read-only property

Syntax (Visual Basic)

Public Property CustomizableEntitiesTables() As List

See Also

Customization Object


%%PageItemTitle%%

Customization Object

EntityDataTables Property

Description

Returns the names of the data tables that have a user label defined as comma-separated pairs of table names and user labels.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EntityDataTables() As String

See Also

Customization Object


%%PageItemTitle%%

Customization Object

ExtendedUDFSupport Property

Description

Checks if the program can use the maximum allowable user-defined fields (99 user-defined fields and 3 memo fields).

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExtendedUDFSupport() As Long

Remarks

UDF support is defined for Oracle and MS-SQL based projects. For other platforms, the return value is indeterminate.

See Also

Customization Object


%%PageItemTitle%%

Customization Object

Fields Property

Description

The CustomizationFields object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As Object

See Also

Customization Object


%%PageItemTitle%%

Customization Object

IsChanged Property

Description

Checks if there has been at least one change to a property or child object that has not been saved.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsChanged() As Boolean

See Also

Customization Object


%%PageItemTitle%%

Customization Object

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

Customization Object


%%PageItemTitle%%

Customization Object

Lists Property

Description

The CustomizationLists object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Lists() As Object

See Also

Customization Object


%%PageItemTitle%%

Customization Object

MailConditions Property

Description

The CustomizationMailConditions Object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property MailConditions() As Object

See Also

Customization Object


%%PageItemTitle%%

Customization Object

Modules Property

Description

The CustomizationModules object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modules() As Object

See Also

Customization Object


%%PageItemTitle%%

Customization Object

Permissions Property

Description

The CustomizationPermissions object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Permissions() As Object

See Also

Customization Object


%%PageItemTitle%%

Customization Object

RBT Property

Description

Returns the CustomizationRBT object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RBT() As Object

Get or Set Value Type

A CustomizationRBT Object.

See Also

Customization Object


%%PageItemTitle%%

Customization Object

Types Property

Description

Returns the CustomizationTypes object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Types() As Object

See Also

Customization Object


%%PageItemTitle%%

Customization Object

Users Property

Description

The CustomizationUsers object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Users() As Object

See Also

Customization Object

Example

Add a project user


%%PageItemTitle%%

Customization Object

UsersGroups Property

Description

The CustomizationUsersGroups object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property UsersGroups() As Object

See Also

Customization Object


%%PageItemTitle%%

CustomizationAction Members

CustomizationAction Object

Description

Represents a type of user action such as adding or deleting a bug. Actions are listed in the AC_ACTION_NAME field of the Actions table.

Remarks

For the list of actions, see the ACTIONS table in the Site Administration UI.

Get a CustomizationAction object from the CustomizationActions collection.

Example

Audit an action

Public Methods

Public Method AddGroup | Adds a user group to the list of user groups for which the current action is allowed.
Public Method RemoveGroup | Removes the specified user group from the list of groups for which the current action is allowed.

Public Properties

Public Property Groups | A list of the user groups for which the current action is allowed.
Public Property IsGroupPermited | Checks if the group specified by the Group parameter has permission to perform the current action.
Public Property IsOwnerGroup | Checks if the user group specified by the Group parameter is the owner of the current action.
Public Property IsUserPermited | Checks if the user specified by the User parameter is permitted to perform the current action.
Public Property Name | The name of the action.
Public Property OwnerGroup | The user group that owns the action.
Public Property Updated | Indicates if the object has been modified since last synchronized with server.


%%PageItemTitle%%

CustomizationAction Object

Group
The user group to be added. Pass either the name of the group or a CustomizationUsersGroup Object.
See Also OTA COM Type Library

AddGroup Method

Description

Adds a user group to the list of user groups for which the current action is allowed.

Syntax

Public Sub AddGroup( _
   ByVal Group As Variant _
)

Parameters

Group
The user group to be added. Pass either the name of the group or a CustomizationUsersGroup Object.

See Also

CustomizationAction Object


%%PageItemTitle%%

CustomizationAction Object

Group
The user group to be removed. Pass either the name of the group or a CustomizationUsersGroup Object.
See Also OTA COM Type Library

RemoveGroup Method

Description

Removes the specified user group from the list of groups for which the current action is allowed.

Syntax

Public Sub RemoveGroup( _
   ByVal Group As Variant _
)

Parameters

Group
The user group to be removed. Pass either the name of the group or a CustomizationUsersGroup Object.

See Also

CustomizationAction Object


%%PageItemTitle%%

CustomizationAction Object

Groups Property

Description

A list of the user groups for which the current action is allowed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Groups() As List

See Also

CustomizationAction Object


%%PageItemTitle%%

CustomizationAction Object

Group

Specify the group with either the name of the group or a CustomizationUsersGroup Object.

See Also OTA COM Type Library

IsGroupPermited Property

Description

Checks if the group specified by the Group parameter has permission to perform the current action.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsGroupPermited( _
   ByVal Group As Variant _
) As Boolean

Parameters

Group

Specify the group with either the name of the group or a CustomizationUsersGroup Object.

See Also

CustomizationAction Object

Example

CustomizationUsersGroup Object


%%PageItemTitle%%

CustomizationAction Object

Group

Specify the group with either the name of the group or a CustomizationUsersGroup Object.

See Also OTA COM Type Library

IsOwnerGroup Property

Description

Checks if the user group specified by the Group parameter is the owner of the current action.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsOwnerGroup( _
   ByVal Group As Variant _
) As Boolean

Parameters

Group

Specify the group with either the name of the group or a CustomizationUsersGroup Object.

See Also

CustomizationAction Object


%%PageItemTitle%%

CustomizationAction Object

User
The user's name or a CustomizationUser Object.
See Also OTA COM Type Library

IsUserPermited Property

Description

Checks if the user specified by the User parameter is permitted to perform the current action.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsUserPermited( _
   ByVal User As Variant _
) As Boolean

Parameters

User
The user's name or a CustomizationUser Object.

See Also

CustomizationAction Object


%%PageItemTitle%%

CustomizationAction Object

Name Property

Description

The name of the action.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name() As String

See Also

CustomizationAction Object


%%PageItemTitle%%

CustomizationAction Object

OwnerGroup Property

Description

The user group that owns the action.

Property type

Read-write property

Syntax (Visual Basic)

Public Property OwnerGroup() As Object

See Also

CustomizationAction Object


%%PageItemTitle%%

CustomizationAction Object

Updated Property

Description

Indicates if the object has been modified since last synchronized with server.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Updated() As Boolean

See Also

CustomizationAction Object


%%PageItemTitle%%

CustomizationActions Members

CustomizationActions Object

Description

The collection of all CustomizationAction objects.

Remarks

Get the CustomizationActions collection from the Customization Object.

Example

Audit an action

Public Properties

Public Property Action | The CustomizationAction object representing the action specified by Name.
Public Property Actions | The list of CustomizationAction objects.


%%PageItemTitle%%

CustomizationActions Object

Name

Specifies the action. To get the full list of actions at your site, see the ACTIONS table in the Site Administrator UI.

The most common options are:

ac_add_bug, ac_add_common_settings, ac_add_cover, ac_add_cycle, ac_add_cyclefolder, ac_add_cycle_to_cyclefolder, ac_add_desstep, ac_add_folder, ac_add_private_settings, ac_add_r&d_comments, ac_add_req ac_add_reqfolder, ac_add_test, ac_add_test_to_testcycl, ac_change_password, ac_clear_history, ac_configure_mail, ac_copy_cycle, ac_copy_folder, ac_copy_cyclefolder, ac_create_rbr_files, ac_create_views, ac_create_wr_script, ac_customize_fields, ac_delete_bug, ac_delete_common_settings, ac_delete_cover, ac_delete_cycle, ac_delete_cycle_from_cyclefolder, ac_delete_cyclefolder, ac_delete_desstep, ac_delete_folder, ac_delete_private_settings, ac_delete_req, ac_delete_run, ac_delete_test, ac_delete_test_from_testcycl, ac_import_bugs_from_file, ac_import_bugs_from_mail, ac_import_bugs_settings, ac_import_wr_tests, ac_modify_bug, ac_modify_common_settings, ac_modify_cycle, ac_modify_desstep, ac_modify_folder, ac_modify_hosts, ac_modify_private_settings, ac_modify_req, ac_modify_reqfolder, ac_modify_run, ac_modify_test, ac_modify_test_in_testcycl, ac_move_folder, ac_move_cyclefolder, ac_remove_reqfolder, ac_reset_cycle, ac_run_auto_test, ac_run_manual_test, ac_send_all_qualified, ac_test_exec_params, ac_users, ac_wr_settings

See Also OTA COM Type Library

Action Property

Description

The CustomizationAction object representing the action specified by Name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Action( _
   ByVal Name As String _
) As Object

Parameters

Name

Specifies the action. To get the full list of actions at your site, see the ACTIONS table in the Site Administrator UI.

The most common options are:

ac_add_bug, ac_add_common_settings, ac_add_cover, ac_add_cycle, ac_add_cyclefolder, ac_add_cycle_to_cyclefolder, ac_add_desstep, ac_add_folder, ac_add_private_settings, ac_add_r&d_comments, ac_add_req ac_add_reqfolder, ac_add_test, ac_add_test_to_testcycl, ac_change_password, ac_clear_history, ac_configure_mail, ac_copy_cycle, ac_copy_folder, ac_copy_cyclefolder, ac_create_rbr_files, ac_create_views, ac_create_wr_script, ac_customize_fields, ac_delete_bug, ac_delete_common_settings, ac_delete_cover, ac_delete_cycle, ac_delete_cycle_from_cyclefolder, ac_delete_cyclefolder, ac_delete_desstep, ac_delete_folder, ac_delete_private_settings, ac_delete_req, ac_delete_run, ac_delete_test, ac_delete_test_from_testcycl, ac_import_bugs_from_file, ac_import_bugs_from_mail, ac_import_bugs_settings, ac_import_wr_tests, ac_modify_bug, ac_modify_common_settings, ac_modify_cycle, ac_modify_desstep, ac_modify_folder, ac_modify_hosts, ac_modify_private_settings, ac_modify_req, ac_modify_reqfolder, ac_modify_run, ac_modify_test, ac_modify_test_in_testcycl, ac_move_folder, ac_move_cyclefolder, ac_remove_reqfolder, ac_reset_cycle, ac_run_auto_test, ac_run_manual_test, ac_send_all_qualified, ac_test_exec_params, ac_users, ac_wr_settings

See Also

CustomizationActions Object


%%PageItemTitle%%

CustomizationActions Object

Actions Property

Description

The list of CustomizationAction objects.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Actions() As List

See Also

CustomizationActions Object


%%PageItemTitle%%

CustomizationField Members

CustomizationField Object

Description

Services for customizing project fields.

Remarks

Get a CustomizationField object from the CustomizationFields Object.

Example

Make a user-defined field searchable | Add a user defined field

Public Properties

Public Property AuthorizedModifyForGroups | The list of groups whose members can modify this field.
Public Property AuthorizedOwnerSensibleForGroups | The list of CustomizationUsersGroup objects of the groups for which only the owner can modify the field.
Public Property AuthorizedVisibleForGroups | The list of CustomizationUsersGroup objects of the groups for which the field is visible in customization dialogs.
Public Property AuthorizedVisibleInNewBugForGroups | The list of CustomizationUsersGroup objects of the groups for which the field is visible in the new defect dialog.
Public Property CanMakeMultiValue | Checks if the field can be configured to store multiple values. If False, IsMultiValue cannot be set to True.
Public Property CanMakeSearchable | Checks if search can be enabled for the field.
Public Property ColumnName | The column name.
Public Property ColumnType | The database column type: char, date, memo, number, or time.
Public Property DefaultValue | The default value of the field.
Public Property EditMask | The input mask for string fields.
Public Property FieldSize | The size of the field in the database. For BLOB fields, the size is -1.
Public Property GrantModifyForGroup | Indicates whether members of the group can change the value of this field.
Public Property GrantModifyMask | The bit mask that indicates which user groups can modify the field.
Public Property IsActive | Indicates if the field is active. Inactive user-defined fields are not visible in the user interface.
Public Property IsByCode | Indicates if the field stores the Tree Node ID, rather than the passed value.
Public Property IsCanGroup | Indicates if items of this type can form groups with others of the same type.
Public Property IsCustomizable | Indicates if the field is displayed in the customization user interface.
Public Property IsEdit | Indicates if the field can be edited.
Public Property IsHistory | Indicates if change history is stored for the field.
Public Property IsMail | Indicates if Users on the list to be notified of changes are notified when this field is changed.
Public Property IsMultiValue | Indicates whether the field can store more than one value.
Public Property IsRequired | Checks if the field is required.
Public Property IsSearchable | Indicates whether the content of the field is searched by the Search method.
Public Property IsTransitionLogic | Indicates if the field has transition logic.
Public Property IsVerify | Indicates if the field requires verification.
Public Property IsVirtual | Checks if the field has a physical representation in the database. If True, there is no physical representation.
Public Property IsVisibleInNewBug | Indicates if the field is visible for the specified groups in a new defect form.
Public Property List | The CustomizationList assigned to the field.
Public Property NewCreated | Indicates if the field was created but not posted to the server.
Public Property OwnerSensibleForGroup | Indicates whether the field can be modified by the owner if the owner belongs to the specified group.
Public Property OwnerSensibleMask | The bit mask that indicates for which groups this field can be modified only by its owner.
Public Property RootId | If the field contains a list, the ID of the list root node. If not, RootId is NULL.
Public Property TableName | The name of the table that stores the active field.
Public Property Type | The Field type.
Public Property Updated | Indicates if the object has been modified since the last download from the server.
Public Property UserColumnType | The user column type: char, number, date, memo, or empty string.
Public Property UserLabel | A user-defined field label.
Public Property VersionControl | Indicates if the field is under version control.
Public Property VisibleForGroup | Indicates whether the field is visible in the New Defect dialog to the specified group.
Public Property VisibleForGroups | The bit mask that indicates which user groups can see this field.
Public Property VisibleInNewBugForGroup | Indicates whether the field is visible to the specified group in the new defect dialog.


%%PageItemTitle%%

CustomizationField Object

AuthorizedModifyForGroups Property

Description

The list of groups whose members can modify this field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AuthorizedModifyForGroups() As List

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

AuthorizedOwnerSensibleForGroups Property

Description

The list of CustomizationUsersGroup objects of the groups for which only the owner can modify the field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AuthorizedOwnerSensibleForGroups() As List

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

AuthorizedVisibleForGroups Property

Description

The list of CustomizationUsersGroup objects of the groups for which the field is visible in customization dialogs.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AuthorizedVisibleForGroups() As List

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

AuthorizedVisibleInNewBugForGroups Property

Description

The list of CustomizationUsersGroup objects of the groups for which the field is visible in the new defect dialog.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AuthorizedVisibleInNewBugForGroups() As List

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

CanMakeMultiValue Property

Description

Checks if the field can be configured to store multiple values. If False, IsMultiValue cannot be set to True.

Property type

Read-only property

Syntax (Visual Basic)

Public Property CanMakeMultiValue() As Boolean

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

CanMakeSearchable Property

Description

Checks if search can be enabled for the field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property CanMakeSearchable() As Boolean

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

ColumnName Property

Description

The column name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ColumnName() As String

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

ColumnType Property

Description

The database column type: char, date, memo, number, or time.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ColumnType() As String

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

DefaultValue Property

Description

The default value of the field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property DefaultValue() As String

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

EditMask Property

Description

The input mask for string fields.

Property type

Read-write property

Syntax (Visual Basic)

Public Property EditMask() As String

Remarks

When a user is prompted for data in the user interface, the edit mask is used to present the blank input in the required format.

For more information on input masks, see 'Defining Input Masks' under 'Customizing Project Entities' in the Mercury Quality Center Administrator's Guide.

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

FieldSize Property

Description

The size of the field in the database. For BLOB fields, the size is -1.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FieldSize() As Long

Remarks

FieldSize sets the maximum size of the data that can be stored in a user-defined field. Do not attempt to set the size to a value less than the size of the field as initially created in a new, empty project.

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

Group
The CustomizationUsersGroup.ID.
See Also OTA COM Type Library

GrantModifyForGroup Property

Description

Indicates whether members of the group can change the value of this field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property GrantModifyForGroup( _
   ByVal Group As Variant _
) As Boolean

Parameters

Group
The CustomizationUsersGroup.ID.

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

GrantModifyMask Property

Description

The bit mask that indicates which user groups can modify the field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property GrantModifyMask() As Long

Remarks

The least significant bit represents Group 0, the next bit represents Group 1, and so on. For example, if bit 0 is set, then the module is visible for members of the group where CustomizationUsersGroup.ID = 0.

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

IsActive Property

Description

Indicates if the field is active. Inactive user-defined fields are not visible in the user interface.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsActive() As Boolean

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

IsByCode Property

Description

Indicates if the field stores the Tree Node ID, rather than the passed value.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsByCode() As Boolean

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

IsCanGroup Property

Description

Indicates if items of this type can form groups with others of the same type.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsCanGroup() As Boolean

See Also

CustomizationField Object

Example

Using the GroupingItem Object


%%PageItemTitle%%

CustomizationField Object

IsCustomizable Property

Description

Indicates if the field is displayed in the customization user interface.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsCustomizable() As Boolean

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

IsEdit Property

Description

Indicates if the field can be edited.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsEdit() As Boolean

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

IsHistory Property

Description

Indicates if change history is stored for the field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsHistory() As Boolean

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

IsMail Property

Description

Indicates if Users on the list to be notified of changes are notified when this field is changed.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsMail() As Boolean

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

IsMultiValue Property

Description

Indicates whether the field can store more than one value.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsMultiValue() As Boolean

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

IsRequired Property

Description

Checks if the field is required.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsRequired() As Boolean

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

IsSearchable Property

Description

Indicates whether the content of the field is searched by the Search method.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsSearchable() As Boolean

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

IsTransitionLogic Property

Description

Indicates if the field has transition logic.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsTransitionLogic() As Boolean

Remarks

To access the transition rules, use Permissions to get a CustomizationPermissions object, and use CustomizationPermissions .TransitionRules to get the collection of rules.

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

IsVerify Property

Description

Indicates if the field requires verification.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsVerify() As Boolean

Remarks

In most cases, verification means that the value must exist in a project list, such as Status, All Projects, and so on.

Where there is no list attached to the field, verification depends on the nature of the field. For example, subject fields are generally verified by checking that the path exists.

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

IsVirtual Property

Description

Checks if the field has a physical representation in the database. If True, there is no physical representation.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsVirtual() As Boolean

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

IsVisibleInNewBug Property

Description

Indicates if the field is visible for the specified groups in a new defect form.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsVisibleInNewBug() As Long

Remarks

When the bit corresponding to the CustomizationUsersGroup.ID in the group mask is set, the field is visible to members of the group in the Add Defect dialog.

For example, if bit 0 is set, then the module is visible for members of the group where CustomizationUsersGroup.ID = 0.

This single property controls field visibility for all groups.

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

List Property

Description

The CustomizationList assigned to the field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property List() As Object

See Also

CustomizationField Object

Example

Get lists for custom fields


%%PageItemTitle%%

CustomizationField Object

NewCreated Property

Description

Indicates if the field was created but not posted to the server.

Property type

Read-write property

Syntax (Visual Basic)

Public Property NewCreated() As Boolean

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

Group
The CustomizationUsersGroup.ID.
See Also OTA COM Type Library

OwnerSensibleForGroup Property

Description

Indicates whether the field can be modified by the owner if the owner belongs to the specified group.

Property type

Read-write property

Syntax (Visual Basic)

Public Property OwnerSensibleForGroup( _
   ByVal Group As Variant _
) As Boolean

Parameters

Group
The CustomizationUsersGroup.ID.

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

RootId Property

Description

If the field contains a list, the ID of the list root node. If not, RootId is NULL.

Property type

Read-write property

Syntax (Visual Basic)

Public Property RootId() As Variant

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

TableName Property

Description

The name of the table that stores the active field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TableName() As String

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

Type Property

Description

The Field type.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Type() As Long

Get or Set Value Type

A value of the tagTDAPI_DATATYPES Enumeration.

Remarks

The type for fields that get values from a customizable list is TDOLE_TREENODE. This applies to all the lists in the customization model, for example, status lists, product, lists, release and cycle lists, and so on.

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

Updated Property

Description

Indicates if the object has been modified since the last download from the server.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Updated() As Boolean

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

UserColumnType Property

Description

The user column type: char, number, date, memo, or empty string.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserColumnType() As String

Remarks

This is not always the same as the Type. For example, a user may enter date or numerical information in a char database field.

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

UserLabel Property

Description

A user-defined field label.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserLabel() As String

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

VersionControl Property

Description

Indicates if the field is under version control.

Property type

Read-write property

Syntax (Visual Basic)

Public Property VersionControl() As Boolean

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

Group
The CustomizationUsersGroup.ID.
See Also OTA COM Type Library

VisibleForGroup Property

Description

Indicates whether the field is visible in the New Defect dialog to the specified group.

Property type

Read-write property

Syntax (Visual Basic)

Public Property VisibleForGroup( _
   ByVal Group As Variant _
) As Boolean

Parameters

Group
The CustomizationUsersGroup.ID.

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

Group
The CustomizationUsersGroup.ID.
See Also OTA COM Type Library

VisibleInNewBugForGroup Property

Description

Indicates whether the field is visible to the specified group in the new defect dialog.

Property type

Read-write property

Syntax (Visual Basic)

Public Property VisibleInNewBugForGroup( _
   ByVal Group As Variant _
) As Boolean

Parameters

Group
The CustomizationUsersGroup.ID.

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationFields Members

CustomizationFields Object

Description

The collection of all CustomizationField objects.

Remarks

Get the CustomizationFields collection from the Customization Object.

Example

Get lists for custom fields | Make a user-defined field searchable | Add a user defined field

Public Methods

Public Method AddActiveField | Finds the first free, inactive field in the specified table, signs the field as active, and returns the CustomizationFields object representing the field.
Public Method AddActiveMemoField | Creates a new memo field in a table.

Public Properties

Public Property Field | The customization field object for the specified database table and field.
Public Property FieldExists | Checks if the specified database field exists.
Public Property Fields | A list of all fields in the specified table.


%%PageItemTitle%%

CustomizationFields Object

TableName
The name of the table to which to add the field.
See Also OTA COM Type Library

AddActiveField Method

Description

Finds the first free, inactive field in the specified table, signs the field as active, and returns the CustomizationFields object representing the field.

Syntax

Public Function AddActiveField( _
   ByVal TableName As String _
) As Object

Parameters

TableName
The name of the table to which to add the field.

Return Type

A CustomizationField Object.

See Also

CustomizationFields Object


%%PageItemTitle%%

CustomizationFields Object

TableName
The name of the table to which to add the field.
See Also OTA COM Type Library

AddActiveMemoField Method

Description

Creates a new memo field in a table.

Syntax

Public Function AddActiveMemoField( _
   ByVal TableName As String _
) As Object

Parameters

TableName
The name of the table to which to add the field.

Return Type

A CustomizationField Object.

See Also

CustomizationFields Object


%%PageItemTitle%%

CustomizationFields Object

TableName
The name of the database table.
FieldName
The name of the field in the table.
See Also OTA COM Type Library

Field Property

Description

The customization field object for the specified database table and field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Field( _
   ByVal TableName As String, _
   ByVal FieldName As String _
) As Object

Parameters

TableName
The name of the database table.
FieldName
The name of the field in the table.

See Also

CustomizationFields Object


%%PageItemTitle%%

CustomizationFields Object

TableName
The name of the database table.
FieldName
The name of the field in the table.
See Also OTA COM Type Library

FieldExists Property

Description

Checks if the specified database field exists.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FieldExists( _
   ByVal TableName As String, _
   ByVal FieldName As String _
) As Boolean

Parameters

TableName
The name of the database table.
FieldName
The name of the field in the table.

See Also

CustomizationFields Object


%%PageItemTitle%%

CustomizationFields Object

TableName
The name of the database table.
See Also OTA COM Type Library

Fields Property

Description

A list of all fields in the specified table.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields( _
   Optional ByVal TableName As String = "" _
) As List

Parameters

TableName
The name of the database table.

Remarks

If an empty string is passed as TableName, returns a list of the fields in all tables.

See Also

CustomizationFields Object


%%PageItemTitle%%

CustomizationList Members

CustomizationList Object

Description

Represents a user-defined list associated with a field.

Remarks

For more information about the custom lists, see 'Customizing Project Lists' in the Mercury Quality Center Administrator's Guide.

Get a CustomizationList object from the CustomizationLists Object.

Example

Get lists for custom fields | Add items to a custom list

Public Methods

Public Method Find Finds a CustomizationListNode of the current list by the node name or ID.

Public Properties

Public Property Deleted | If true, the node is marked for deletion, but the deletion is not yet committed.
Public Property Name | The name of the list.
Public Property RootNode | The root CustomizationListNode of the current list.


%%PageItemTitle%%

CustomizationList Object

Val
The node name or ID.
See Also OTA COM Type Library

Find Method

Description

Finds a CustomizationListNode of the current list by the node name or ID.

Syntax

Public Function Find( _
   ByVal Val As Variant _
) As Object

Parameters

Val
The node name or ID.

Return Type

A CustomizationListNode Object.

See Also

CustomizationList Object


%%PageItemTitle%%

CustomizationList Object

Deleted Property

Description

If true, the node is marked for deletion, but the deletion is not yet committed.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Deleted() As Boolean

See Also

CustomizationList Object


%%PageItemTitle%%

CustomizationList Object

Name Property

Description

The name of the list.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name() As String

See Also

CustomizationList Object


%%PageItemTitle%%

CustomizationList Object

RootNode Property

Description

The root CustomizationListNode of the current list.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RootNode() As Object

See Also

CustomizationList Object


%%PageItemTitle%%

CustomizationListNode Members

CustomizationListNode Object

Description

Represents a node in a list.

Remarks

This object can represent the list root node or a child node within the list.

Get a CustomizationListNode object from the CustomizationList Object.

Example

Add items to a custom list

Public Methods

Public Method AddChild | Adds a new sub-node to the current node.
Public Method RemoveChild | Removes the specified sub-node from the current node.

Public Properties

Public Property CanAddChild | Checks if sub-nodes can be added to the current node.
Public Property Child | Gets the specified sub-node.
Public Property Children | The list of CustomizationListNode objects that are sub-nodes of the current node.
Public Property ChildrenCount | The number of sub-nodes under the node.
Public Property Deleted | If true, the node is marked for deletion, but the deletion is not yet committed.
Public Property Father | Gets the CustomizationListNode object representing the current node's parent node, or sets a new father, thereby moving the node.
Private Property ID | The current node ID.
Public Property List | The CustomizationList object that contains the current node.
Public Property Name | The current node name.
Public Property Order | The order number of the node within its siblings.
Public Property ReadOnly | Checks if the current node is read-only.
Public Property Updated | Indicates if the node was modified since it was loaded from the server.


%%PageItemTitle%%

CustomizationListNode Object

Node
Either the node name of the child or a CustomListNode object.
See Also OTA COM Type Library

AddChild Method

Description

Adds a new sub-node to the current node.

Syntax

Public Function AddChild( _
   ByVal Node As Variant _
) As Object

Parameters

Node
Either the node name of the child or a CustomListNode object.

Return Type

The CustomListNode object representing the new child.

See Also

CustomizationListNode Object


%%PageItemTitle%%

CustomizationListNode Object

Node
Either the node name of the child or a CustomListNode object.
See Also OTA COM Type Library

RemoveChild Method

Description

Removes the specified sub-node from the current node.

Syntax

Public Sub RemoveChild( _
   ByVal Node As Variant _
)

Parameters

Node
Either the node name of the child or a CustomListNode object.

See Also

CustomizationListNode Object


%%PageItemTitle%%

CustomizationListNode Object

CanAddChild Property

Description

Checks if sub-nodes can be added to the current node.

Property type

Read-only property

Syntax (Visual Basic)

Public Property CanAddChild() As Boolean

See Also

CustomizationListNode Object


%%PageItemTitle%%

CustomizationListNode Object

NodeName
The name of the child node.
See Also OTA COM Type Library

Child Property

Description

Gets the specified sub-node.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Child( _
   ByVal NodeName As String _
) As Object

Parameters

NodeName
The name of the child node.

See Also

CustomizationListNode Object


%%PageItemTitle%%

CustomizationListNode Object

Children Property

Description

The list of CustomizationListNode objects that are sub-nodes of the current node.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Children() As List

See Also

CustomizationListNode Object


%%PageItemTitle%%

CustomizationListNode Object

ChildrenCount Property

Description

The number of sub-nodes under the node.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ChildrenCount() As Long

See Also

CustomizationListNode Object


%%PageItemTitle%%

CustomizationListNode Object

Deleted Property

Description

If true, the node is marked for deletion, but the deletion is not yet committed.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Deleted() As Boolean

See Also

CustomizationListNode Object


%%PageItemTitle%%

CustomizationListNode Object

Father Property

Description

Gets the CustomizationListNode object representing the current node's parent node, or sets a new father, thereby moving the node.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Father() As Object

See Also

CustomizationListNode Object


%%PageItemTitle%%

CustomizationListNode Object

ID Property

Description

The current node ID.

Property type

Write-only property

Syntax (Visual Basic)

Private Property ID() As Long

See Also

CustomizationListNode Object


%%PageItemTitle%%

CustomizationListNode Object

List Property

Description

The CustomizationList object that contains the current node.

Property type

Read-only property

Syntax (Visual Basic)

Public Property List() As Object

See Also

CustomizationListNode Object


%%PageItemTitle%%

CustomizationListNode Object

Name Property

Description

The current node name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

CustomizationListNode Object


%%PageItemTitle%%

CustomizationListNode Object

Order Property

Description

The order number of the node within its siblings.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Order() As Long

Remarks

When the order of one node is set with this property, no adjustments are made to the positions of others. The application is responsible for ensuring that the orders of all nodes are as required, that no two nodes occupy the same position, and there are no empty positions.

When two or more nodes are assigned the same order, the actual order is undetermined.

See Also

CustomizationListNode Object


%%PageItemTitle%%

CustomizationListNode Object

ReadOnly Property

Description

Checks if the current node is read-only.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ReadOnly() As Boolean

See Also

CustomizationListNode Object


%%PageItemTitle%%

CustomizationListNode Object

Updated Property

Description

Indicates if the node was modified since it was loaded from the server.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Updated() As Boolean

See Also

CustomizationListNode Object


%%PageItemTitle%%

CustomizationLists Members | CustomizationList Object

CustomizationLists Object

Description

The collection of all CustomizationList objects.

Remarks

Get the CustomizationLists collection from the Customization Object.

Example

Add a customization list | Delete a customization list

Public Methods

Public Method AddList | Adds a new CustomizationList object.
Public Method RemoveList | Removes a CustomizationList object.

Public Properties

Public Property Count | The number of lists in the CustomizationLists object.
Public Property IsListExist | Checks if the specified customization list exists.
Public Property List | Gets the CustomizationList specified by name or ID.
Public Property ListByCount | Gets the CustomizationList specified by its index number.


%%PageItemTitle%%

CustomizationLists Object

Name
The name of the list to be added.
See Also OTA COM Type Library

AddList Method

Description

Adds a new CustomizationList object.

Syntax

Public Function AddList( _
   ByVal Name As String _
) As Object

Parameters

Name
The name of the list to be added.

Return Type

A CustomizationList Object.

See Also

CustomizationLists Object


%%PageItemTitle%%

CustomizationLists Object

Name
The name of the list to be removed.
See Also OTA COM Type Library

RemoveList Method

Description

Removes a CustomizationList object.

Syntax

Public Sub RemoveList( _
   ByVal Name As String _
)

Parameters

Name
The name of the list to be removed.

See Also

CustomizationLists Object


%%PageItemTitle%%

CustomizationLists Object

Count Property

Description

The number of lists in the CustomizationLists object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

CustomizationLists Object


%%PageItemTitle%%

CustomizationLists Object

ListName
The name of the list whose existence you want to check.
See Also OTA COM Type Library

IsListExist Property

Description

Checks if the specified customization list exists.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsListExist( _
   ByVal ListName As String _
) As Boolean

Parameters

ListName
The name of the list whose existence you want to check.

See Also

CustomizationLists Object


%%PageItemTitle%%

CustomizationLists Object

Param
The list name (string) or root ID (long).
See Also OTA COM Type Library

List Property

Description

Gets the CustomizationList specified by name or ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property List( _
   ByVal Param As Variant _
) As Object

Parameters

Param
The list name (string) or root ID (long).

See Also

CustomizationLists Object


%%PageItemTitle%%

CustomizationLists Object

Count
The index is 1-based.
See Also OTA COM Type Library

ListByCount Property

Description

Gets the CustomizationList specified by its index number.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ListByCount( _
   ByVal Count As Long _
) As Object

Parameters

Count
The index is 1-based.

See Also

CustomizationLists Object


%%PageItemTitle%%

CustomizationMailCondition Members

CustomizationMailCondition Object

Description

The configuration of a custom automatic mail notification.

Remarks

For more information about mail conditions, see 'Defining Mail Conditions' in the Mercury Quality Center Administrator's Guide.

Get a CustomizationMailCondition Object from the CustomizationMailConditions Object.

Public Properties

Public Property ConditionText | The filter to determine when the notification is sent.
Public Property ConditionType | The type of condition.
Public Property Deleted | Indicates if the condition has been removed, but the deletion has not been posted to the server.
Public Property Name | The name of the mail recipient or the field containing the name.
Public Property Updated | Indicates if the condition object has changed locally since last synchronized with the server.


%%PageItemTitle%%

CustomizationMailCondition Object

ConditionText Property

Description

The filter to determine when the notification is sent.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ConditionText() As String

Example

This example shows a condition for open defects of high priority.

[]

[Filter]{
TableName:BUG,
ColumnName:BG_PRIORITY,
LogicalFilter:"3-High Or \"4-Very High\" Or 5-Urgent",
VisualFilter:" 3-High  Or  \"4-Very High\"  Or  5-Urgent ",
NO_CASE:
}
{
TableName:BUG,
ColumnName:BG_STATUS,
LogicalFilter:"New Or Open Or Reopen",
VisualFilter:" New  Or  Open  Or  Reopen ",
NO_CASE:
}

See Also

CustomizationMailCondition Object


%%PageItemTitle%%

CustomizationMailCondition Object

ConditionType Property

Description

The type of condition.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ConditionType() As Long

See Also

CustomizationMailCondition Object


%%PageItemTitle%%

CustomizationMailCondition Object

Deleted Property

Description

Indicates if the condition has been removed, but the deletion has not been posted to the server.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Deleted() As Boolean

Remarks

As a property-get: Returns True if CustomizationMailConditions.RemoveCondition has been called for this object.

As a property-set: Marks the condition for deletion if set to True; acts as undo for removal if set to False.

See Also

CustomizationMailCondition Object


%%PageItemTitle%%

CustomizationMailCondition Object

Name Property

Description

The name of the mail recipient or the field containing the name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name() As String

Remarks

If the condition type is USER_MAIL_CONDITION, the condition name is the name of the user. If the type is FIELD_MAIL_CONDITION, the condition name is the name of the defect field containing the user name.

See Also

CustomizationMailCondition Object


%%PageItemTitle%%

CustomizationMailCondition Object

Updated Property

Description

Indicates if the condition object has changed locally since last synchronized with the server.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Updated() As Boolean

See Also

CustomizationMailCondition Object


%%PageItemTitle%%

CustomizationMailConditions Members

CustomizationMailConditions Object

Description

The collection of CustomizationMailCondition configurations for custom automatic mail notifications.

Remarks

Get the CustomizationMailConditions collection from the Customization Object.

Public Methods

Public Method AddCondition | Creates a new CustomizationMailCondition.
Public Method RemoveCondition | Deletes the specified CustomizationMailCondition.

Public Properties

Public Property Condition | Gets the CustomizationMailCondition specified by the name and type.
Public Property ConditionExist | Checks if the specified mail customization condition exists.
Public Property Conditions | Gets the list of CustomizationMailCondition objects.


%%PageItemTitle%%

CustomizationMailConditions Object

Name
The name of the new condition.
ConditionType
A value of the tagMAIL_CONDITIONS_TYPE Enumeration.
ConditionText
The actual condition. A string valid for a TDFilter.Text.
See Also OTA COM Type Library

AddCondition Method

Description

Creates a new CustomizationMailCondition.

Syntax

Public Function AddCondition( _
   ByVal Name As String, _
   ByVal ConditionType As Long, _
   ByVal ConditionText As String _
) As Object

Parameters

Name
The name of the new condition.
ConditionType
A value of the tagMAIL_CONDITIONS_TYPE Enumeration.
ConditionText
The actual condition. A string valid for a TDFilter.Text.

Return Type

A CustomizationMailCondition Object.

See Also

CustomizationMailConditions Object


%%PageItemTitle%%

CustomizationMailConditions Object

Name

The name of the new condition.

ConditionType

A value of the tagMAIL_CONDITIONS_TYPE Enumeration.

See Also OTA COM Type Library

RemoveCondition Method

Description

Deletes the specified CustomizationMailCondition.

Syntax

Public Sub RemoveCondition( _
   ByVal Name As String, _
   ByVal ConditionType As Long _
)

Parameters

Name

The name of the new condition.

ConditionType

A value of the tagMAIL_CONDITIONS_TYPE Enumeration.

See Also

CustomizationMailConditions Object


%%PageItemTitle%%

CustomizationMailConditions Object

Name
The name of the condition.
ConditionType
A value of the tagMAIL_CONDITIONS_TYPE Enumeration.
See Also OTA COM Type Library

Condition Property

Description

Gets the CustomizationMailCondition specified by the name and type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Condition( _
   ByVal Name As String, _
   ByVal ConditionType As Long _
) As Object

Parameters

Name
The name of the condition.
ConditionType
A value of the tagMAIL_CONDITIONS_TYPE Enumeration.

See Also

CustomizationMailConditions Object


%%PageItemTitle%%

CustomizationMailConditions Object

Name

The name of the new condition.

ConditionType

A value of the tagMAIL_CONDITIONS_TYPE Enumeration.

See Also OTA COM Type Library

ConditionExist Property

Description

Checks if the specified mail customization condition exists.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ConditionExist( _
   ByVal Name As String, _
   ByVal ConditionType As Long _
) As Boolean

Parameters

Name

The name of the new condition.

ConditionType

A value of the tagMAIL_CONDITIONS_TYPE Enumeration.

See Also

CustomizationMailConditions Object


%%PageItemTitle%%

CustomizationMailConditions Object

Conditions Property

Description

Gets the list of CustomizationMailCondition objects.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Conditions() As List

See Also

CustomizationMailConditions Object


%%PageItemTitle%%

CustomizationModules Members

CustomizationModules Object

Description

Services for managing the customization modules.

Remarks

Get the CustomizationModules object from the Customization Object.

Public Properties

Public Property Description | The Module Description
Public Property GUID | The Module's globally unique ID.
Public Property IsVisibleForGroup | Indicates if the specified module is visible in the UI to the specified user group.
Public Property Module | Returns the module specified by the module ID.
Public Property Modules | The list of project module IDs.
Public Property Name | The Module Name.
Public Property Visible | A bit-mask that indicates for which groups the module is visible in the user interface.
Public Property VisibleForGroups | The list of the user groups to which the specified module is visible in the UI.


%%PageItemTitle%%

CustomizationModules Object

ModuleID
The module type. A value of the tagTDAPI_MODULE Enumeration.
See Also OTA COM Type Library

Description Property

Description

The Module Description

Property type

Read-write property

Syntax (Visual Basic)

Public Property Description( _
   ByVal ModuleID As Long _
) As String

Parameters

ModuleID
The module type. A value of the tagTDAPI_MODULE Enumeration.

See Also

CustomizationModules Object


%%PageItemTitle%%

CustomizationModules Object

ModuleID
The module type. A value of the tagTDAPI_MODULE Enumeration.
See Also OTA COM Type Library

GUID Property

Description

The Module's globally unique ID.

Property type

Read-write property

Syntax (Visual Basic)

Public Property GUID( _
   ByVal ModuleID As Long _
) As String

Parameters

ModuleID
The module type. A value of the tagTDAPI_MODULE Enumeration.

See Also

CustomizationModules Object


%%PageItemTitle%%

CustomizationModules Object

ModuleID
The module type. A value of the tagTDAPI_MODULE Enumeration.
Group
The CustomizationUsersGroup.ID.
See Also OTA COM Type Library

IsVisibleForGroup Property

Description

Indicates if the specified module is visible in the UI to the specified user group.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsVisibleForGroup( _
   ByVal ModuleID As Long, _
   ByVal Group As Variant _
) As Boolean

Parameters

ModuleID
The module type. A value of the tagTDAPI_MODULE Enumeration.
Group
The CustomizationUsersGroup.ID.

See Also

CustomizationModules Object


%%PageItemTitle%%

CustomizationModules Object

ModuleID
A Module.ID.
See Also OTA COM Type Library

Module Property

Description

Returns the module specified by the module ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Module( _
   ByVal ModuleID As Long _
) As Module

Parameters

ModuleID
A Module.ID.

Get or Set Value Type

A Module Object.

See Also

CustomizationModules Object


%%PageItemTitle%%

CustomizationModules Object

Modules Property

Description

The list of project module IDs.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modules() As List

See Also

CustomizationModules Object


%%PageItemTitle%%

CustomizationModules Object

ModuleID
The module type. A value of the tagTDAPI_MODULE Enumeration.
See Also OTA COM Type Library

Name Property

Description

The Module Name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name( _
   ByVal ModuleID As Long _
) As String

Parameters

ModuleID
The module type. A value of the tagTDAPI_MODULE Enumeration.

See Also

CustomizationModules Object


%%PageItemTitle%%

CustomizationModules Object

ModuleID
The module type. A value of the tagTDAPI_MODULE Enumeration.
See Also OTA COM Type Library

Visible Property

Description

A bit-mask that indicates for which groups the module is visible in the user interface.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Visible( _
   ByVal ModuleID As Long _
) As Long

Parameters

ModuleID
The module type. A value of the tagTDAPI_MODULE Enumeration.

Remarks

Set bits represent groups for which the module is visible. For example, if bit 0 is set, then the module is visible for members of the group where CustomizationUsersGroup.ID = 0.

See Also

CustomizationModules Object


%%PageItemTitle%%

CustomizationModules Object

ModuleID
The module type. A value of the tagTDAPI_MODULE Enumeration.
See Also OTA COM Type Library

VisibleForGroups Property

Description

The list of the user groups to which the specified module is visible in the UI.

Property type

Read-only property

Syntax (Visual Basic)

Public Property VisibleForGroups( _
   ByVal ModuleID As Long _
) As List

Parameters

ModuleID
The module type. A value of the tagTDAPI_MODULE Enumeration.

See Also

CustomizationModules Object


%%PageItemTitle%%

CustomizationPermissions Members

CustomizationPermissions Object

Description

Properties that define the ability of user groups to add, remove, and modify entities.

Remarks

Get the CustomizationPermissions object from Customization .Permissions.

Public Properties

Public Property CanAddItem | Indicates if members of the specified group can add the specified type of entity.
Public Property CanAllowAttachment | Indicates if members owners of the specified group can handle the specified type of entity attachments.
Public Property CanModifyField | Indicates if members or owners of the specified group can modify the specified field.
Public Property CanModifyItem | Indicates if members of the specified group can modify the specified entity.
Public Property CanRemoveItem | Indicates if members or owners of the specified group can remove the specified type of entity.
Public Property CanUseOwnerSensible | Checks if the fields of the specified entity can be restricted for owner modifications only.
Public Property HasAttachmentField | Checks if the entity specified by the EntityName parameter can have attachments.
Public Property IsVisibleInNewBug | Indicates if the specified Bug field is visible for the specified group in a new defect form.
Public Property TransitionRules | The transition rules for the specified field and group.


%%PageItemTitle%%

CustomizationPermissions Object

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

Group

The name of the group or a CustomizationUsersGroup Object.

See Also OTA COM Type Library

CanAddItem Property

Description

Indicates if members of the specified group can add the specified type of entity.

Property type

Read-write property

Syntax (Visual Basic)

Public Property CanAddItem( _
   ByVal EntityName As String, _
   ByVal Group As Variant _
) As Boolean

Parameters

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

Group

The name of the group or a CustomizationUsersGroup Object.

See Also

CustomizationPermissions Object


%%PageItemTitle%%

CustomizationPermissions Object

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

Group

The name of the group or a CustomizationUsersGroup Object.

See Also OTA COM Type Library

CanAllowAttachment Property

Description

Indicates if members owners of the specified group can handle the specified type of entity attachments.

Property type

Read-write property

Syntax (Visual Basic)

Public Property CanAllowAttachment( _
   ByVal EntityName As String, _
   ByVal Group As Variant _
) As Long

Parameters

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

Group

The name of the group or a CustomizationUsersGroup Object.

See Also

CustomizationPermissions Object


%%PageItemTitle%%

CustomizationPermissions Object

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

Field

The name of the field or a CustomizationField Object.

Group

The name of the group or a CustomizationUsersGroup Object.

See Also OTA COM Type Library

CanModifyField Property

Description

Indicates if members or owners of the specified group can modify the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property CanModifyField( _
   ByVal EntityName As String, _
   ByVal Field As Variant, _
   ByVal Group As Variant _
) As Long

Parameters

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

Field

The name of the field or a CustomizationField Object.

Group

The name of the group or a CustomizationUsersGroup Object.

See Also

CustomizationPermissions Object


%%PageItemTitle%%

CustomizationPermissions Object

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

Group

The name of the group or a CustomizationUsersGroup Object.

See Also OTA COM Type Library

CanModifyItem Property

Description

Indicates if members of the specified group can modify the specified entity.

Property type

Read-write property

Syntax (Visual Basic)

Public Property CanModifyItem( _
   ByVal EntityName As String, _
   ByVal Group As Variant _
) As Boolean

Parameters

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

Group

The name of the group or a CustomizationUsersGroup Object.

See Also

CustomizationPermissions Object


%%PageItemTitle%%

CustomizationPermissions Object

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

Group

The name of the group or a CustomizationUsersGroup Object.

See Also OTA COM Type Library

CanRemoveItem Property

Description

Indicates if members or owners of the specified group can remove the specified type of entity.

Property type

Read-write property

Syntax (Visual Basic)

Public Property CanRemoveItem( _
   ByVal EntityName As String, _
   ByVal Group As Variant _
) As Long

Parameters

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

Group

The name of the group or a CustomizationUsersGroup Object.

See Also

CustomizationPermissions Object


%%PageItemTitle%%

CustomizationPermissions Object

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

See Also OTA COM Type Library

CanUseOwnerSensible Property

Description

Checks if the fields of the specified entity can be restricted for owner modifications only.

Property type

Read-only property

Syntax (Visual Basic)

Public Property CanUseOwnerSensible( _
   ByVal EntityName As String _
) As Boolean

Parameters

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

See Also

CustomizationPermissions Object


%%PageItemTitle%%

CustomizationPermissions Object

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

See Also OTA COM Type Library

HasAttachmentField Property

Description

Checks if the entity specified by the EntityName parameter can have attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachmentField( _
   ByVal EntityName As String _
) As Boolean

Parameters

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

Remarks

An entity can have attachments only if it has an attachment field. This property does not indicate if the entity actually has attachments, only that it can.

See Also

CustomizationPermissions Object


%%PageItemTitle%%

CustomizationPermissions Object

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

Field

The name of the field or a CustomizationField Object.

Group

The name of the group or a CustomizationUsersGroup Object.

See Also OTA COM Type Library

IsVisibleInNewBug Property

Description

Indicates if the specified Bug field is visible for the specified group in a new defect form.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsVisibleInNewBug( _
   ByVal EntityName As String, _
   ByVal Field As Variant, _
   ByVal Group As Variant _
) As Boolean

Parameters

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

Field

The name of the field or a CustomizationField Object.

Group

The name of the group or a CustomizationUsersGroup Object.

See Also

CustomizationPermissions Object


%%PageItemTitle%%

CustomizationPermissions Object

EntityName
One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS
Field
The name of the field or a CustomizationField Object.
Group
The name of the group or a CustomizationUsersGroup Object.
See Also OTA COM Type Library

TransitionRules Property

Description

The transition rules for the specified field and group.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TransitionRules( _
   ByVal EntityName As String, _
   ByVal Field As Variant, _
   ByVal Group As Variant _
) As Object

Parameters

EntityName
One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS
Field
The name of the field or a CustomizationField Object.
Group
The name of the group or a CustomizationUsersGroup Object.

See Also

CustomizationPermissions Object


%%PageItemTitle%%

CustomizationRBT Members

CustomizationRBT Object

Description

Customization of the RBT mechanism default values.

Remarks

Get a reference from Customization.RBT.

Public Methods

Public Method AddBIQuestion | Creates a new Business Impact question.
Public Method AddFPQuestion | Creates a new Failure Probability question.
Public Method CalcBILevelByAnswersWeight | Calculate the business impact level from the sum of all the answers' weights.
Public Method CalcFPLevelByAnswersWeight | Calculate failure probability level ffrom the sum of all the answers' weights.
Public Method DeleteBIQuestion | Deletes the specified Business Impact question.
Public Method DeleteFPQuestion | Deletes the specified Failure Probability question.
Public Method TranslateBILevel | Translate BI from TDAPI_RBT_BI_LEVELS to its name in the database.
Public Method TranslateFPLevel | Translate FP from TDAPI_RBT_FP_LEVELS to its name in the database.
Public Method TranslateTestingLevel | Translate TL from TDAPI_RBT_TESTING_LEVELS to it's name in the database.

Public Properties

Public Property BILevelRiskLowerThreshold | The lower threshold of Risk assessment for each Business Impact level.
Public Property BIQuestionByID | Returns the Business Impact Question that has the specified ID.
Public Property BIQuestions | The list of Business Impact questions.
Public Property DisplayedTimeUnits | The time unit display string for calculations results.
Public Property FPLevelRiskLowerThreshold | The lower threshold of Risk assessment for each Failure Probability level.
Public Property FPLevelTestingEffortInHours | Hours needed to test a requirement with the given Failure Probability.
Public Property FPQuestionByID | Returns the Failure Probability Question that has the specified ID.
Public Property FPQuestions | The list of Failure Probability questions.
Public Property TestingLevelPercentage | Testing level percentage (of the full testing level).
Public Property TestingPolicyMatrix | Risk testing level matrix
Public Property Updated | Indicates if the RBT Customization has been modified since the last synchronization with the database.


%%PageItemTitle%%

CustomizationRBT Object

AddBIQuestion Method

Description

Creates a new Business Impact question.

Syntax

Public Function AddBIQuestion() As Object

Return Type

A CustomizationRBTQuestion Object.

See Also

CustomizationRBT Object


%%PageItemTitle%%

CustomizationRBT Object

AddFPQuestion Method

Description

Creates a new Failure Probability question.

Syntax

Public Function AddFPQuestion() As Object

Return Type

A CustomizationRBTQuestion Object.

See Also

CustomizationRBT Object


%%PageItemTitle%%

CustomizationRBT Object

AnswersWeight
See Also OTA COM Type Library

CalcBILevelByAnswersWeight Method

Description

Calculate the business impact level from the sum of all the answers' weights.

Syntax

Public Function CalcBILevelByAnswersWeight( _
   ByVal AnswersWeight As Long _
) As Long

Parameters

AnswersWeight

See Also

CustomizationRBT Object


%%PageItemTitle%%

CustomizationRBT Object

AnswersWeight
See Also OTA COM Type Library

CalcFPLevelByAnswersWeight Method

Description

Calculate failure probability level ffrom the sum of all the answers' weights.

Syntax

Public Function CalcFPLevelByAnswersWeight( _
   ByVal AnswersWeight As Long _
) As Long

Parameters

AnswersWeight

See Also

CustomizationRBT Object


%%PageItemTitle%%

CustomizationRBT Object

ID
CustomizationRBTQuestion.ID.
See Also OTA COM Type Library

DeleteBIQuestion Method

Description

Deletes the specified Business Impact question.

Syntax

Public Sub DeleteBIQuestion( _
   ByVal ID As Long _
)

Parameters

ID
CustomizationRBTQuestion.ID.

See Also

CustomizationRBT Object


%%PageItemTitle%%

CustomizationRBT Object

ID
A CustomizationRBTQuestion.ID.
See Also OTA COM Type Library

DeleteFPQuestion Method

Description

Deletes the specified Failure Probability question.

Syntax

Public Sub DeleteFPQuestion( _
   ByVal ID As Long _
)

Parameters

ID
A CustomizationRBTQuestion.ID.

See Also

CustomizationRBT Object


%%PageItemTitle%%

CustomizationRBT Object

BILevelEnum
See Also OTA COM Type Library

TranslateBILevel Method

Description

Translate BI from TDAPI_RBT_BI_LEVELS to its name in the database.

Syntax

Public Function TranslateBILevel( _
   ByVal BILevelEnum As Long _
) As String

Parameters

BILevelEnum

See Also

CustomizationRBT Object


%%PageItemTitle%%

CustomizationRBT Object

FPLevelEnum
See Also OTA COM Type Library

TranslateFPLevel Method

Description

Translate FP from TDAPI_RBT_FP_LEVELS to its name in the database.

Syntax

Public Function TranslateFPLevel( _
   ByVal FPLevelEnum As Long _
) As String

Parameters

FPLevelEnum

See Also

CustomizationRBT Object


%%PageItemTitle%%

CustomizationRBT Object

TestingLevelEnum
See Also OTA COM Type Library

TranslateTestingLevel Method

Description

Translate TL from TDAPI_RBT_TESTING_LEVELS to it's name in the database.

Syntax

Public Function TranslateTestingLevel( _
   ByVal TestingLevelEnum As Long _
) As String

Parameters

TestingLevelEnum

See Also

CustomizationRBT Object


%%PageItemTitle%%

CustomizationRBT Object

BILevel
The business implact level.
See Also OTA COM Type Library

BILevelRiskLowerThreshold Property

Description

The lower threshold of Risk assessment for each Business Impact level.

Property type

Read-write property

Syntax (Visual Basic)

Public Property BILevelRiskLowerThreshold( _
   ByVal BILevel As Long _
) As Long

Parameters

BILevel
The business implact level.

See Also

CustomizationRBT Object


%%PageItemTitle%%

CustomizationRBT Object

ID
A CustomizationRBTQuestion.ID.
See Also OTA COM Type Library

BIQuestionByID Property

Description

Returns the Business Impact Question that has the specified ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BIQuestionByID( _
   ByVal ID As Long _
) As Object

Parameters

ID
A CustomizationRBTQuestion.ID.

See Also

CustomizationRBT Object


%%PageItemTitle%%

CustomizationRBT Object

BIQuestions Property

Description

The list of Business Impact questions.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BIQuestions() As List

See Also

CustomizationRBT Object


%%PageItemTitle%%

CustomizationRBT Object

DisplayedTimeUnits Property

Description

The time unit display string for calculations results.

Property type

Read-write property

Syntax (Visual Basic)

Public Property DisplayedTimeUnits() As String

See Also

CustomizationRBT Object


%%PageItemTitle%%

CustomizationRBT Object

FPLevel
The failure probability level.
See Also OTA COM Type Library

FPLevelRiskLowerThreshold Property

Description

The lower threshold of Risk assessment for each Failure Probability level.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FPLevelRiskLowerThreshold( _
   ByVal FPLevel As Long _
) As Long

Parameters

FPLevel
The failure probability level.

See Also

CustomizationRBT Object


%%PageItemTitle%%

CustomizationRBT Object

FPLevel
The failure probability level.
See Also OTA COM Type Library

FPLevelTestingEffortInHours Property

Description

Hours needed to test a requirement with the given Failure Probability.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FPLevelTestingEffortInHours( _
   ByVal FPLevel As Long _
) As Long

Parameters

FPLevel
The failure probability level.

See Also

CustomizationRBT Object


%%PageItemTitle%%

CustomizationRBT Object

ID
See Also OTA COM Type Library

FPQuestionByID Property

Description

Returns the Failure Probability Question that has the specified ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FPQuestionByID( _
   ByVal ID As Long _
) As Object

Parameters

ID

See Also

CustomizationRBT Object


%%PageItemTitle%%

CustomizationRBT Object

FPQuestions Property

Description

The list of Failure Probability questions.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FPQuestions() As List

See Also

CustomizationRBT Object


%%PageItemTitle%%

CustomizationRBT Object

TestingLevel
See Also OTA COM Type Library

TestingLevelPercentage Property

Description

Testing level percentage (of the full testing level).

Property type

Read-write property

Syntax (Visual Basic)

Public Property TestingLevelPercentage( _
   ByVal TestingLevel As Long _
) As Long

Parameters

TestingLevel

See Also

CustomizationRBT Object


%%PageItemTitle%%

CustomizationRBT Object

BILevel
The business implact level.
FPLevel
The failure probability level.
See Also OTA COM Type Library

TestingPolicyMatrix Property

Description

Risk testing level matrix

Property type

Read-write property

Syntax (Visual Basic)

Public Property TestingPolicyMatrix( _
   ByVal BILevel As Long, _
   ByVal FPLevel As Long _
) As Long

Parameters

BILevel
The business implact level.
FPLevel
The failure probability level.

See Also

CustomizationRBT Object


%%PageItemTitle%%

CustomizationRBT Object

Updated Property

Description

Indicates if the RBT Customization has been modified since the last synchronization with the database.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Updated() As Boolean

See Also

CustomizationRBT Object


%%PageItemTitle%%

CustomizationRBTAnswer Members

CustomizationRBTAnswer Object

Description

A possible answer for a business implact or failure probablity question, used to assess a risk.

Remarks

Get a CustomizationRBT answer object from CustomizationRBTQuestion.AnswerByID or from the list returned by CustomizationRBTQuestion.Answers

Public Properties

Public Property AnswerText | The answer's text.
Public Property AnswerWeight | The answer's weight.
Public Property ID | The CustomizationRBTAnswer unique ID.


%%PageItemTitle%%

CustomizationRBTAnswer Object

AnswerText Property

Description

The answer's text.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AnswerText() As String

See Also

CustomizationRBTAnswer Object


%%PageItemTitle%%

CustomizationRBTAnswer Object

AnswerWeight Property

Description

The answer's weight.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AnswerWeight() As Long

See Also

CustomizationRBTAnswer Object


%%PageItemTitle%%

CustomizationRBTAnswer Object

ID Property

Description

The CustomizationRBTAnswer unique ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Long

See Also

CustomizationRBTAnswer Object


%%PageItemTitle%%

CustomizationRBTQuestion Members

CustomizationRBTQuestion Object

Description

A business impact or failure probability question, used to assess a risk.

Remarks

Get a CustomizationRBTQuestion object from methods and properties of the CustomizationRBT Object.

Public Methods

Public Method AddAnswer | Adds a new possible answer. Returns the new answer as a CustomizationRBTAnswer object
Public Method DeleteAnswer | Deletes a possible answer specified by id.

Public Properties

Public Property AnswerByID | Returns the specified Answer.
Public Property Answers | The IList of CustomizationRBTAnswer objects of all possible answers for this question.
Public Property ID | The CustomizationRBTQuestion unique ID.
Public Property QuestionDescription | The question's description.
Public Property QuestionOrder | The (non unique) question's order of display in UI.
Public Property QuestionText | The question's text.


%%PageItemTitle%%

CustomizationRBTQuestion Object

AddAnswer Method

Description

Adds a new possible answer. Returns the new answer as a CustomizationRBTAnswer object

Syntax

Public Function AddAnswer() As Object

See Also

CustomizationRBTQuestion Object


%%PageItemTitle%%

CustomizationRBTQuestion Object

ID
See Also OTA COM Type Library

DeleteAnswer Method

Description

Deletes a possible answer specified by id.

Syntax

Public Sub DeleteAnswer( _
   ByVal ID As Long _
)

Parameters

ID

See Also

CustomizationRBTQuestion Object


%%PageItemTitle%%

CustomizationRBTQuestion Object

ID
A CustomizationRBTAnswer.ID.
See Also OTA COM Type Library

AnswerByID Property

Description

Returns the specified Answer.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AnswerByID( _
   ByVal ID As Long _
) As Object

Parameters

ID
A CustomizationRBTAnswer.ID.

Get or Set Value Type

A CustomizationRBTAnswer Object.

See Also

CustomizationRBTQuestion Object


%%PageItemTitle%%

CustomizationRBTQuestion Object

Answers Property

Description

The IList of CustomizationRBTAnswer objects of all possible answers for this question.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Answers() As List

Get or Set Value Type

A list of A CustomizationRBTAnswer Objects.

See Also

CustomizationRBTQuestion Object


%%PageItemTitle%%

CustomizationRBTQuestion Object

ID Property

Description

The CustomizationRBTQuestion unique ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Long

See Also

CustomizationRBTQuestion Object


%%PageItemTitle%%

CustomizationRBTQuestion Object

QuestionDescription Property

Description

The question's description.

Property type

Read-write property

Syntax (Visual Basic)

Public Property QuestionDescription() As String

See Also

CustomizationRBTQuestion Object


%%PageItemTitle%%

CustomizationRBTQuestion Object

QuestionOrder Property

Description

The (non unique) question's order of display in UI.

Property type

Read-write property

Syntax (Visual Basic)

Public Property QuestionOrder() As Long

See Also

CustomizationRBTQuestion Object


%%PageItemTitle%%

CustomizationRBTQuestion Object

QuestionText Property

Description

The question's text.

Property type

Read-write property

Syntax (Visual Basic)

Public Property QuestionText() As String

See Also

CustomizationRBTQuestion Object


%%PageItemTitle%%

CustomizationReqType Members

CustomizationReqType Object

Description

A Customization type of the requirement entity.

Remarks

Requirement types serve to categorize requirements. For example, types may include Business, Functional, Testing, and so on. For the list of types defined in your project, look at the Requirement Type custom list.

Get a reference to a CustomizationReqType with CustomizationTypes.GetEntityCustomizationType or from the list returned by CustomizationTypes.GetEntityCustomizationTypes.

Public Methods

Public Method AddField | Adds a new CustomizationTypedField.
Public Method RemoveField | Removes the CustomizationTypedField specified by FieldName from this type.

Public Properties

Public Property Field | Gets the CustomizationTypedField specified by FieldName.
Public Property Fields | The list of CustomizationTypedField objects for this type.
Public Property HasDirectCoverage | Indicates if this requirement type supports direct coverage by tests or test instances.
Public Property Icon | The bitmap stream for type icon.
Public Property ID | The CustomizationType ID.
Public Property Name | The CustomizationType name.
Public Property RiskAnalysisType | The Type of the RBT Risk Analysis that is applicable to this requirement.


%%PageItemTitle%%

CustomizationReqType Object

NewFieldName
The name of a field in the REQ table.
See Also OTA COM Type Library

AddField Method

Description

Adds a new CustomizationTypedField.

Syntax

Public Function AddField( _
   ByVal NewFieldName As String _
) As Object

Parameters

NewFieldName
The name of a field in the REQ table.

Remarks

When AddField is called, a CustomizationTypedField object is created that links the specified field back to the CustomizationReqType. After the call, the new CustomizationTypedField is in the list returned by the Fields property.

See Also

CustomizationReqType Object


%%PageItemTitle%%

CustomizationReqType Object

FieldName
The name of a field in the REQ table.
See Also OTA COM Type Library

RemoveField Method

Description

Removes the CustomizationTypedField specified by FieldName from this type.

Syntax

Public Sub RemoveField( _
   ByVal FieldName As String _
)

Parameters

FieldName
The name of a field in the REQ table.

See Also

CustomizationReqType Object


%%PageItemTitle%%

CustomizationReqType Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

Gets the CustomizationTypedField specified by FieldName.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Object

Parameters

FieldName
The name of the field in the project database.

See Also

CustomizationReqType Object


%%PageItemTitle%%

CustomizationReqType Object

Fields Property

Description

The list of CustomizationTypedField objects for this type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

CustomizationReqType Object


%%PageItemTitle%%

CustomizationReqType Object

HasDirectCoverage Property

Description

Indicates if this requirement type supports direct coverage by tests or test instances.

Property type

Read-write property

Syntax (Visual Basic)

Public Property HasDirectCoverage() As Boolean

See Also

CustomizationReqType Object


%%PageItemTitle%%

CustomizationReqType Object

Icon Property

Description

The bitmap stream for type icon.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Icon() As IStream

See Also

CustomizationReqType Object


%%PageItemTitle%%

CustomizationReqType Object

ID Property

Description

The CustomizationType ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Long

See Also

CustomizationReqType Object


%%PageItemTitle%%

CustomizationReqType Object

Name Property

Description

The CustomizationType name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

CustomizationReqType Object


%%PageItemTitle%%

CustomizationReqType Object

RiskAnalysisType Property

Description

The Type of the RBT Risk Analysis that is applicable to this requirement.

Property type

Read-write property

Syntax (Visual Basic)

Public Property RiskAnalysisType() As Long

Get or Set Value Type

A value of the tagTDAPI_RBT_REQUIREMENT_TYPE_RISK_ANALYSIS_TYPE Enumeration..

See Also

CustomizationReqType Object


%%PageItemTitle%%

CustomizationTransitionRule Members

CustomizationTransitionRule Object

Description

Represents a single transition rule.

Remarks

Defines a permitted change from a SourceValue to a DestinationValue. The group, entity, and field to which the values apply are taken from the CustomizationTransitionRules Object from which the reference to this CustomizationTransitionRule Object was obtained.

Public Properties

Public Property DestinationValue | The destination value of the transition rule, that is, the value after the change.
Public Property SourceValue | The source value of the transition rule, that is, the value before the change.
Public Property Updated | Indicates if the object has been modified since last synchronized with server.


%%PageItemTitle%%

CustomizationTransitionRule Object

DestinationValue Property

Description

The destination value of the transition rule, that is, the value after the change.

Property type

Read-write property

Syntax (Visual Basic)

Public Property DestinationValue() As String

See Also

CustomizationTransitionRule Object


%%PageItemTitle%%

CustomizationTransitionRule Object

SourceValue Property

Description

The source value of the transition rule, that is, the value before the change.

Property type

Read-write property

Syntax (Visual Basic)

Public Property SourceValue() As String

See Also

CustomizationTransitionRule Object


%%PageItemTitle%%

CustomizationTransitionRule Object

Updated Property

Description

Indicates if the object has been modified since last synchronized with server.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Updated() As Boolean

See Also

CustomizationTransitionRule Object


%%PageItemTitle%%

CustomizationTransitionRules Members | CustomizationTransitionRule Object

See Also OTA COM Type Library

CustomizationTransitionRules Object

Description

A collection of CustomizationTransitionRule objects applied to a specific field and user group.

Remarks

Get a CustomizationTransitionRules object from the CustomizationPermissions Object.

Public Methods

Public Method AddTransitionRule | Adds a new CustomizationTransitionRule to the current object.
Public Method RemoveTransitionRule | Removes the specified transition rule from the current object.

Public Properties

Public Property Count | The number of CustomizationTransitionRule objects contained by the current object.
Public Property EntityName | The location (database table) of the field to which the transition rules in the current object are attached.
Public Property Field | The CustomizationField object to which the transition rules in the current object are attached.
Public Property Group | The CustomizationUsersGroup object to which the transition rules in the current object are attached.
Public Property TransitionRule | The CustomizationTransitionRule specified by its position in the list of transition rules.
Public Property Updated | Indicates if the object has been modified since the last synchronization with database.


%%PageItemTitle%%

CustomizationTransitionRules Object

AddTransitionRule Method

Description

Adds a new CustomizationTransitionRule to the current object.

Syntax

Public Function AddTransitionRule() As Object

Return Type

The new CustomizationTransitionRule Object.

Remarks

The new transition rule created with this method is open: it is possible to change the field from any value to any other value. Thus, the rule has no effect until the source and destination values are set.
To define the source and destination values, set the SourceValue and DestinationValue of the new CustomizationTransitionRule object.

See Also

CustomizationTransitionRules Object


%%PageItemTitle%%

CustomizationTransitionRules Object

Rule
Either the position (zero-based) in the CustomTransitionRules collection, or a CustomizationTransitionRule Object.
See Also OTA COM Type Library

RemoveTransitionRule Method

Description

Removes the specified transition rule from the current object.

Syntax

Public Sub RemoveTransitionRule( _
   ByVal Rule As Variant _
)

Parameters

Rule
Either the position (zero-based) in the CustomTransitionRules collection, or a CustomizationTransitionRule Object.

See Also

CustomizationTransitionRules Object


%%PageItemTitle%%

CustomizationTransitionRules Object

Count Property

Description

The number of CustomizationTransitionRule objects contained by the current object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

CustomizationTransitionRules Object


%%PageItemTitle%%

CustomizationTransitionRules Object

EntityName Property

Description

The location (database table) of the field to which the transition rules in the current object are attached.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EntityName() As String

See Also

CustomizationTransitionRules Object


%%PageItemTitle%%

CustomizationTransitionRules Object

Field Property

Description

The CustomizationField object to which the transition rules in the current object are attached.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Field() As Object

See Also

CustomizationTransitionRules Object


%%PageItemTitle%%

CustomizationTransitionRules Object

Group Property

Description

The CustomizationUsersGroup object to which the transition rules in the current object are attached.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Group() As Object

See Also

CustomizationTransitionRules Object


%%PageItemTitle%%

CustomizationTransitionRules Object

Position
The position in the list of transition rules (1-based).
See Also OTA COM Type Library

TransitionRule Property

Description

The CustomizationTransitionRule specified by its position in the list of transition rules.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TransitionRule( _
   ByVal Position As Long _
) As Object

Parameters

Position
The position in the list of transition rules (1-based).

See Also

CustomizationTransitionRules Object


%%PageItemTitle%%

CustomizationTransitionRules Object

Updated Property

Description

Indicates if the object has been modified since the last synchronization with database.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Updated() As Boolean

See Also

CustomizationTransitionRules Object


%%PageItemTitle%%

CustomizationTypedField Members

CustomizationTypedField Object

Description

An association between a CustomizationField and an object of a class that implements ICustomizationType.

Remarks

Get a reference to CustomizationTypedField with the Field Property of an object of a class that implements ICustomizationType, for example, CustomizationReqType. You can also get a reference from the list returned by ICustomizationType.Fields.

Public Properties

Public Property Field | Gets the CustomizationField associated with this object.
Public Property IsRequired | Indicates whether the field is required for the specific type.
Public Property Type | Gets the CustomizationType associated with this object.


%%PageItemTitle%%

CustomizationTypedField Object

Field Property

Description

Gets the CustomizationField associated with this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Field() As Object

Get or Set Value Type

A CustomizationField Object.

See Also

CustomizationTypedField Object


%%PageItemTitle%%

CustomizationTypedField Object

IsRequired Property

Description

Indicates whether the field is required for the specific type.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsRequired() As Boolean

See Also

CustomizationTypedField Object


%%PageItemTitle%%

CustomizationTypedField Object

Type Property

Description

Gets the CustomizationType associated with this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Type() As Object

Get or Set Value Type

An ICustomizationType Reference.

See Also

CustomizationTypedField Object


%%PageItemTitle%%

CustomizationTypes Members

CustomizationTypes Object

Description

A collection of Customization types of a specific entity. For example, the types of the requirement entity.

Remarks

Get a CustomizationTypes reference from Customization.Types.

Public Methods

Public Method AddCustomizationType | Adds a new CustomizationType to the specified entity.
Public Method GetEntityCustomizationType | Gets the CustomizationType with the specified ID.
Public Method GetEntityCustomizationTypes | Gets the list of all CustomizationTypes for the specified entity.
Public Method RemoveCustomizationType | Removes the CustomizationType with the specified ID from the specified entity.


%%PageItemTitle%%

CustomizationTypes Object

EntityType
A value of the TDAPI_ENTITIES Enumeration.
Name
The name of the new type.
CreateAsTypeId
A ICustomizationType.ID. This is the ID of an object of a class that implements ICustomizationType, for example, a CustomizationReqType.ID.
See Also OTA COM Type Library

AddCustomizationType Method

Description

Adds a new CustomizationType to the specified entity.

Syntax

Public Function AddCustomizationType( _
   ByVal EntityType As Long, _
   ByVal Name As String, _
   ByVal CreateAsTypeId As Long _
) As Object

Parameters

EntityType
A value of the TDAPI_ENTITIES Enumeration.
Name
The name of the new type.
CreateAsTypeId
A ICustomizationType.ID. This is the ID of an object of a class that implements ICustomizationType, for example, a CustomizationReqType.ID.

Remarks

The new type is created as a copy of the type specified with CreateAsTypeId. You can then change the properties as appropriate.

See Also

CustomizationTypes Object


%%PageItemTitle%%

CustomizationTypes Object

EntityType
A value of the TDAPI_ENTITIES Enumeration.
CustomizationTypeId
A ICustomizationType.ID. This is the ID of an object of a class that implements ICustomizationType, for example, a CustomizationReqType.ID.
See Also OTA COM Type Library

GetEntityCustomizationType Method

Description

Gets the CustomizationType with the specified ID.

Syntax

Public Function GetEntityCustomizationType( _
   ByVal EntityType As Long, _
   ByVal CustomizationTypeId As Long _
) As Object

Parameters

EntityType
A value of the TDAPI_ENTITIES Enumeration.
CustomizationTypeId
A ICustomizationType.ID. This is the ID of an object of a class that implements ICustomizationType, for example, a CustomizationReqType.ID.

Return Type

A list of ICustomizationType Objects

See Also

CustomizationTypes Object


%%PageItemTitle%%

CustomizationTypes Object

EntityType

A value of the TDAPI_ENTITIES Enumeration.

See Also OTA COM Type Library

GetEntityCustomizationTypes Method

Description

Gets the list of all CustomizationTypes for the specified entity.

Syntax

Public Function GetEntityCustomizationTypes( _
   ByVal EntityType As Long _
) As List

Parameters

EntityType

A value of the TDAPI_ENTITIES Enumeration.

See Also

CustomizationTypes Object


%%PageItemTitle%%

CustomizationTypes Object

EntityType

A value of the TDAPI_ENTITIES Enumeration.

CustomizationTypeId

A ICustomizationType.ID. This is the ID of an object of a class that implements ICustomizationType, for example, a CustomizationReqType.ID.

See Also OTA COM Type Library

RemoveCustomizationType Method

Description

Removes the CustomizationType with the specified ID from the specified entity.

Syntax

Public Sub RemoveCustomizationType( _
   ByVal EntityType As Long, _
   ByVal CustomizationTypeId As Long _
)

Parameters

EntityType

A value of the TDAPI_ENTITIES Enumeration.

CustomizationTypeId

A ICustomizationType.ID. This is the ID of an object of a class that implements ICustomizationType, for example, a CustomizationReqType.ID.

Return Type

A list of ICustomizationType Objects

See Also

CustomizationTypes Object


%%PageItemTitle%%

CustomizationUser Members

CustomizationUser Object

Description

Represents a user for purposes of adding and removing the user to and from user groups.

Remarks

Get a CustomizationUser object with the CustomizationUsers Object.

Public Methods

Public Method AddToGroup | Adds this user to the specified user group.
Public Method GroupsList | The names of all the user groups to which this user belongs.
Public Method RemoveFromGroup | Removes this user from the specified user group.

Public Properties

Public Property Address | A text field that can be used to record user information as appropriate for the project.
Public Property Deleted | If true, this user is marked for deletion, but the deletion is not yet committed.
Public Property DomainAuthentication | The user credentials for LDAP authentication.
Public Property Email | The user's e-mail address.
Public Property FullName | The user's full name.
Public Property InGroup | Indicates if this user is a member of the specified group.
Public Property Name | A unique name by which to identify this user.
Public Property Password | Sets the user's password.
Public Property Phone | The user's telephone number.
Public Property Updated | Indicates if the user's data was updated since the last synchronization with the server.


%%PageItemTitle%%

CustomizationUser Object

Group
The name of the group or a CustomizationUsersGroup Object.
See Also OTA COM Type Library

AddToGroup Method

Description

Adds this user to the specified user group.

Syntax

Public Sub AddToGroup( _
   ByVal Group As Variant _
)

Parameters

Group
The name of the group or a CustomizationUsersGroup Object.

See Also

CustomizationUser Object


%%PageItemTitle%%

CustomizationUser Object

GroupsList Method

Description

The names of all the user groups to which this user belongs.

Syntax

Public Function GroupsList() As List

See Also

CustomizationUser Object


%%PageItemTitle%%

CustomizationUser Object

Group
The name of the group or a CustomizationUsersGroup Object.
See Also OTA COM Type Library

RemoveFromGroup Method

Description

Removes this user from the specified user group.

Syntax

Public Sub RemoveFromGroup( _
   ByVal Group As Variant _
)

Parameters

Group
The name of the group or a CustomizationUsersGroup Object.

See Also

CustomizationUser Object


%%PageItemTitle%%

CustomizationUser Object

Address Property

Description

A text field that can be used to record user information as appropriate for the project.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Address() As String

See Also

CustomizationUser Object


%%PageItemTitle%%

CustomizationUser Object

Deleted Property

Description

If true, this user is marked for deletion, but the deletion is not yet committed.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Deleted() As Boolean

See Also

CustomizationUser Object


%%PageItemTitle%%

CustomizationUser Object

DomainAuthentication Property

Description

The user credentials for LDAP authentication.

Property type

Read-write property

Syntax (Visual Basic)

Public Property DomainAuthentication() As String

See Also

CustomizationUser Object


%%PageItemTitle%%

CustomizationUser Object

Email Property

Description

The user's e-mail address.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Email() As String

See Also

CustomizationUser Object


%%PageItemTitle%%

CustomizationUser Object

FullName Property

Description

The user's full name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FullName() As String

See Also

CustomizationUser Object


%%PageItemTitle%%

CustomizationUser Object

GroupName
The name of the group or a CustomizationUsersGroup Object.
See Also OTA COM Type Library

InGroup Property

Description

Indicates if this user is a member of the specified group.

Property type

Read-write property

Syntax (Visual Basic)

Public Property InGroup( _
   ByVal GroupName As Variant _
) As Boolean

Parameters

GroupName
The name of the group or a CustomizationUsersGroup Object.

See Also

CustomizationUser Object


%%PageItemTitle%%

CustomizationUser Object

Name Property

Description

A unique name by which to identify this user.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name() As String

See Also

CustomizationUser Object


%%PageItemTitle%%

CustomizationUser Object

RHS
The password.
See Also OTA COM Type Library

Password Property

Description

Sets the user's password.

Property type

Write-only property

Syntax (Visual Basic)

Public Property Password( _
   ByVal RHS As String _
) As String

Parameters

RHS
The password.

Remarks

The password is entered literally. It is encoded automatically when sent from the workstation to the server.

See Also

CustomizationUser Object


%%PageItemTitle%%

CustomizationUser Object

Phone Property

Description

The user's telephone number.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Phone() As String

See Also

CustomizationUser Object


%%PageItemTitle%%

CustomizationUser Object

Updated Property

Description

Indicates if the user's data was updated since the last synchronization with the server.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Updated() As Boolean

See Also

CustomizationUser Object


%%PageItemTitle%%

CustomizationUsers Members

CustomizationUsers Object

Description

The collection of all CustomizationUser objects.

Remarks

Get the CustomizationUsers collection from the Customization Object.

Example

Add a site user

Public Methods

Public Method AddSiteAuthenticatedUser | Adds site user with credentials for LDAP authentication.
Public Method AddSiteUser | Creates a new site user and adds it to the current project.
Public Method AddUser | Adds an existing site user to the current project.
Public Method RemoveUser | Removes a user from the collection.
Public Method UserExistsInSite | Checks whether the specified site user exists.

Public Properties

Public Property User | The CustomizationUser object representing the specified user.
Public Property Users | The list of customization users.


%%PageItemTitle%%

CustomizationUsers Object

UserName
The name of the user to be added.
FullName
The full name of the user to be added.
Email
The e-mail address of the user to be added.
Description
A description of the user to be added
Phone
The phone number of the user to be added.
DomainAuthentication
The identifier of the user in an external User directory, for example the distinguished name in LDAP.
Group
The group to which the added user belongs. Pass either the group name or a CustomizationUsersGroup Object.
See Also OTA COM Type Library

AddSiteAuthenticatedUser Method

Description

Adds site user with credentials for LDAP authentication.

Syntax

Public Sub AddSiteAuthenticatedUser( _
   ByVal UserName As String, _
   ByVal FullName As String, _
   ByVal Email As String, _
   ByVal Description As String, _
   ByVal Phone As String, _
   ByVal DomainAuthentication As String, _
   ByVal Group As Variant _
)

Parameters

UserName
The name of the user to be added.
FullName
The full name of the user to be added.
Email
The e-mail address of the user to be added.
Description
A description of the user to be added
Phone
The phone number of the user to be added.
DomainAuthentication
The identifier of the user in an external User directory, for example the distinguished name in LDAP.
Group
The group to which the added user belongs. Pass either the group name or a CustomizationUsersGroup Object.

Remarks

This method creates a CustomizationUser object and adds it to the site and to the current project. The new user is only memory-resident until Customization.Commit is called.

See Also

CustomizationUsers Object


%%PageItemTitle%%

CustomizationUsers Object

UserName
The name of the user to be added.
FullName
The full name of the user to be added.
Email
The e-mail address of the user to be added.
Description
A description of the user to be added.
Phone
The phone number of the user to be added.
Group
The group to which the added user belongs. Pass either the group name or a CustomizationUsersGroup Object.
See Also OTA COM Type Library

AddSiteUser Method

Description

Creates a new site user and adds it to the current project.

Syntax

Public Sub AddSiteUser( _
   ByVal UserName As String, _
   ByVal FullName As String, _
   ByVal Email As String, _
   ByVal Description As String, _
   ByVal Phone As String, _
   ByVal Group As Variant _
)

Parameters

UserName
The name of the user to be added.
FullName
The full name of the user to be added.
Email
The e-mail address of the user to be added.
Description
A description of the user to be added.
Phone
The phone number of the user to be added.
Group
The group to which the added user belongs. Pass either the group name or a CustomizationUsersGroup Object.

Remarks

This method creates a CustomizationUser object and adds it to the site and to the current project. The new user is only memory-resident until Customization.Commit is called.

See Also

CustomizationUsers Object


%%PageItemTitle%%

CustomizationUsers Object

Name
The name of the user to be added.
See Also OTA COM Type Library

AddUser Method

Description

Adds an existing site user to the current project.

Syntax

Public Function AddUser( _
   ByVal Name As String _
) As Object

Parameters

Name
The name of the user to be added.

Return Type

A CustomizationUser object.

See Also

CustomizationUsers Object

Example

Add a project user to a group


%%PageItemTitle%%

CustomizationUsers Object

Name
The name of the user to be removed.
See Also OTA COM Type Library

RemoveUser Method

Description

Removes a user from the collection.

Syntax

Public Sub RemoveUser( _
   ByVal Name As String _
)

Parameters

Name
The name of the user to be removed.

Remarks

The deletion takes effect when Customization.Commit is called.

See Also

CustomizationUsers Object


%%PageItemTitle%%

CustomizationUsers Object

UserName
The user name defined in the Quality Center data base.
See Also OTA COM Type Library

UserExistsInSite Method

Description

Checks whether the specified site user exists.

Syntax

Public Function UserExistsInSite( _
   ByVal UserName As String _
) As Boolean

Parameters

UserName
The user name defined in the Quality Center data base.

See Also

CustomizationUsers Object


%%PageItemTitle%%

CustomizationUsers Object

Name
The user name.
See Also OTA COM Type Library

User Property

Description

The CustomizationUser object representing the specified user.

Property type

Read-only property

Syntax (Visual Basic)

Public Property User( _
   ByVal Name As String _
) As Object

Parameters

Name
The user name.

See Also

CustomizationUsers Object


%%PageItemTitle%%

CustomizationUsers Object

Users Property

Description

The list of customization users.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Users() As List

See Also

CustomizationUsers Object


%%PageItemTitle%%

CustomizationUsersGroup Members

CustomizationUsersGroup Object

Description

Represents a user group for purposes of adding and removing users.

Remarks

Get a CustomizationUsersGroup object from the CustomizationUsersGroups Object.

Example

Add a site user

Public Methods

Public Method AddUser | Adds a new user to the user group.
Public Method RemoveUser | Removes a user from the user group.
Public Method UsersList | A list of all members of the user group.

Public Properties

Public Property Deleted | If true, the object is marked for deletion, but the deletion has not been committed.
Public Property HideFilter | The data hiding filter for the entity specified by the FilterType parameter.
Public Property ID | The user group Id.
Public Property IsSystem | Checks if the user group is a built-in system user group.
Public Property Name | The user group name.
Public Property Updated | Indicates if the object has been modified since being downloaded from database.


%%PageItemTitle%%

CustomizationUsersGroup Object

User
The name of the user to be added or a CustomizationUser Object.
See Also OTA COM Type Library

AddUser Method

Description

Adds a new user to the user group.

Syntax

Public Sub AddUser( _
   ByVal User As Variant _
)

Parameters

User
The name of the user to be added or a CustomizationUser Object.

See Also

CustomizationUsersGroup Object


%%PageItemTitle%%

CustomizationUsersGroup Object

User
The name of the user to be removed or a CustomizationUser Object.
See Also OTA COM Type Library

RemoveUser Method

Description

Removes a user from the user group.

Syntax

Public Sub RemoveUser( _
   ByVal User As Variant _
)

Parameters

User
The name of the user to be removed or a CustomizationUser Object.

See Also

CustomizationUsersGroup Object


%%PageItemTitle%%

CustomizationUsersGroup Object

UsersList Method

Description

A list of all members of the user group.

Syntax

Public Function UsersList() As List

Return Type

A list of CustomizationUser Objects.

See Also

CustomizationUsersGroup Object


%%PageItemTitle%%

CustomizationUsersGroup Object

Deleted Property

Description

If true, the object is marked for deletion, but the deletion has not been committed.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Deleted() As Boolean

Remarks

Setting the property to true is equivalent to deleting it.

See Also

CustomizationUsersGroup Object


%%PageItemTitle%%

CustomizationUsersGroup Object

FilterType
BUG, REQ, TEST, or TESTCYCL
See Also OTA COM Type Library

HideFilter Property

Description

The data hiding filter for the entity specified by the FilterType parameter.

Property type

Read-write property

Syntax (Visual Basic)

Public Property HideFilter( _
   ByVal FilterType As String _
) As String

Parameters

FilterType
BUG, REQ, TEST, or TESTCYCL

Remarks

The data hide filter defines what data is visible for a specific group of users.
For example, if you set the HideFilter to be "BG_BUG_ID=1" for filter type "BUG", then only users belonging to the Viewer group will only be able to get the defect with Id=1.

See Also

CustomizationUsersGroup Object


%%PageItemTitle%%

CustomizationUsersGroup Object

ID Property

Description

The user group Id.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Long

See Also

CustomizationUsersGroup Object


%%PageItemTitle%%

CustomizationUsersGroup Object

IsSystem Property

Description

Checks if the user group is a built-in system user group.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsSystem() As Boolean

See Also

CustomizationUsersGroup Object


%%PageItemTitle%%

CustomizationUsersGroup Object

Name Property

Description

The user group name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

CustomizationUsersGroup Object


%%PageItemTitle%%

CustomizationUsersGroup Object

Updated Property

Description

Indicates if the object has been modified since being downloaded from database.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Updated() As Boolean

See Also

CustomizationUsersGroup Object


%%PageItemTitle%%

CustomizationUsersGroups Members

CustomizationUsersGroups Object

Description

The collection of all CustomizationUsersGroup objects.

Remarks

Get the CustomizationUsersGroups collection from the Customization Object.

Example

Add a site user

Public Methods

Public Method AddGroup | Adds a new CustomizationUsersGroup to the collection.
Public Method IsNameValid | Checks whether another group has the specified name.
Public Method RemoveGroup | Removes a CustomizationUsersGroup object.

Public Properties

Public Property Group | Gets the specified user group.
Public Property Groups | The list of CustomizationUsersGroup objects.


%%PageItemTitle%%

CustomizationUsersGroups Object

Name
The name of the group to be added.
See Also OTA COM Type Library

AddGroup Method

Description

Adds a new CustomizationUsersGroup to the collection.

Syntax

Public Function AddGroup( _
   ByVal Name As String _
) As Object

Parameters

Name
The name of the group to be added.

Return Type

The new CustomizationUsersGroup Object.

See Also

CustomizationUsersGroups Object


%%PageItemTitle%%

CustomizationUsersGroups Object

Name
The name to check.
GroupId
The CustomizationUsersGroup.ID of the group to which you wish to assign the Name parameter as the CustomizationUsersGroup.Name
See Also OTA COM Type Library

IsNameValid Method

Description

Checks whether another group has the specified name.

Syntax

Public Function IsNameValid( _
   ByVal Name As String, _
   ByVal GroupId As Long _
) As Boolean

Parameters

Name
The name to check.
GroupId
The CustomizationUsersGroup.ID of the group to which you wish to assign the Name parameter as the CustomizationUsersGroup.Name

Return Type

Returns True if no group other than the group specified has the specified name.

Remarks

This method is used when creating user groups programmatically to ensure that the group name is not already in use.

See Also

CustomizationUsersGroups Object


%%PageItemTitle%%

CustomizationUsersGroups Object

Name
The name of the group to be removed.
See Also OTA COM Type Library

RemoveGroup Method

Description

Removes a CustomizationUsersGroup object.

Syntax

Public Sub RemoveGroup( _
   ByVal Name As String _
)

Parameters

Name
The name of the group to be removed.

See Also

CustomizationUsersGroups Object


%%PageItemTitle%%

CustomizationUsersGroups Object

Name
The name of the group.
See Also OTA COM Type Library

Group Property

Description

Gets the specified user group.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Group( _
   ByVal Name As String _
) As Object

Parameters

Name
The name of the group.

See Also

CustomizationUsersGroups Object

Example

Add a project user to a group


%%PageItemTitle%%

CustomizationUsersGroups Object

Groups Property

Description

The list of CustomizationUsersGroup objects.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Groups() As List

See Also

CustomizationUsersGroups Object


%%PageItemTitle%%

Cycle Members

Cycle Object

Description

Represents a release cycle.

Remarks

Get a Cycle reference from a CycleFactory Object.

Interfaces

IBaseField2 | IBaseField3 | IStringRepresentation | ISysTreeNode2

Example

Find cycles that match a condition | Set the target release cycle of the descendents to that of the requirement | Remove requirement target release cycle | Set up release cycles

Public Methods

Public Method DaysLeft | Returns the number of days until the scheduled end of the cycle.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Mail | Mails the IBaseFieldExMail field item.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property EndDate | The cycle's end date.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The cycle's name.
Public Property Parent | The cycle's parent release.
Public Property ReleaseManagementInfo | Returns the cycle information.
Public Property StartDate | The cycle's start date.
Public Property Status | The cycle's status.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

Cycle Object

DaysLeft Method

Description

Returns the number of days until the scheduled end of the cycle.

Syntax

Public Function DaysLeft() As Long

See Also

Cycle Object


%%PageItemTitle%%

Cycle Object

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Cycle Object


%%PageItemTitle%%

Cycle Object

SendTo
SendCc
Option
Subject
Comment
See Also OTA COM Type Library

Mail Method

Description

Mails the IBaseFieldExMail field item.

Syntax

Public Sub Mail( _
   ByVal SendTo As String, _
   Optional ByVal SendCc As String = "", _
   Optional ByVal Option As Long = 0, _
   Optional ByVal Subject As String = "", _
   Optional ByVal Comment As String = "" _
)

Parameters

SendTo
SendCc
Option
Subject
Comment

See Also

Cycle Object


%%PageItemTitle%%

Cycle Object

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Cycle Object


%%PageItemTitle%%

Cycle Object

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Cycle Object


%%PageItemTitle%%

Cycle Object

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

Cycle Object


%%PageItemTitle%%

Cycle Object

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

Cycle Object


%%PageItemTitle%%

Cycle Object

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

Cycle Object


%%PageItemTitle%%

Cycle Object

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

Cycle Object


%%PageItemTitle%%

Cycle Object

EndDate Property

Description

The cycle's end date.

Property type

Read-write property

Syntax (Visual Basic)

Public Property EndDate() As Date

See Also

Cycle Object


%%PageItemTitle%%

Cycle Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

Cycle Object


%%PageItemTitle%%

Cycle Object

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

Cycle Object


%%PageItemTitle%%

Cycle Object

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

Cycle Object


%%PageItemTitle%%

Cycle Object

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

Cycle Object


%%PageItemTitle%%

Cycle Object

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

Cycle Object


%%PageItemTitle%%

Cycle Object

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

Cycle Object


%%PageItemTitle%%

Cycle Object

Name Property

Description

The cycle's name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

Cycle Object


%%PageItemTitle%%

Cycle Object

Parent Property

Description

The cycle's parent release.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As Object

See Also

Cycle Object


%%PageItemTitle%%

Cycle Object

ReleaseManagementInfo Property

Description

Returns the cycle information.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ReleaseManagementInfo() As Object

See Also

Cycle Object


%%PageItemTitle%%

Cycle Object

StartDate Property

Description

The cycle's start date.

Property type

Read-write property

Syntax (Visual Basic)

Public Property StartDate() As Date

See Also

Cycle Object


%%PageItemTitle%%

Cycle Object

Status Property

Description

The cycle's status.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Status() As String

See Also

Cycle Object


%%PageItemTitle%%

Cycle Object

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

Cycle Object


%%PageItemTitle%% $$Members$$

Cycle Object

IStringRepresentation Implemented Interface Members

Methods

Public Implemented Method ToString The string representation of the object.

See Also

Cycle Object


%%PageItemTitle%%

Cycle Object | IStringRepresentation Implemented Interface

ToString Implemented Method

Description

The string representation of the object.

Syntax

Public Function ToString() As String

See Also

Cycle Object | IStringRepresentation Implemented Interface


%%PageItemTitle%%

ISysTreeNode2 Members

ISysTreeNode2 Interface

Description

Represents a tree node.

Remarks

Get a SysTreeNode object from the TreeManager.

Public Methods

Public Method AddNode | Adds a new child node.
Public Method FindChildNode | Finds a child node by node name.
Public Method FindChildren | Finds node children according to specified search pattern.
Public Method NewList | Gets a list of the node's immediate children.
Public Method Post | Posts all changed values to the database.
Public Method Refresh | Reads the saved node data, overwriting values in memory.
Public Method RemoveNode | Deletes the specified node.

Public Properties

Public Property Attribute | Gets the node attribute.
Public Property Child | Gets a sub-folder of the current folder.
Public Property Count | The number of child nodes.
Public Property DepthType | The sub-tree depth type.
Public Property Father | The current folder's parent folder.
Public Property Name | The node name.
Public Property NodeID | The node ID number.
Public Property Path | The folder tree path starting from the tree root.
Public Property Type | The nodes's type.


%%PageItemTitle%%

CycleFactory Members

CycleFactory Object

Description

Services for managing release cycles.

Remarks

Get a CycleFactory from a ReleaseFactory or from DConnection.CycleFactory.

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Interfaces

IBaseFactory2 | ISearchableFactory | ISupportCopyPaste2

Example

Find cycles that match a condition | Set up release cycles

Public Methods

Public Method AddItem | Creates a new item object.
Public Method BuildCoverageGraph | Builds release cycle coverage graph.
Public Method Mail | Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

CycleFactory Object

ItemData
See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData

Remarks

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

[Visual Basic]

Dim bgf As BugFactory
Dim bg As Bug
Dim attf As AttachmentFactory
Dim att As Attachment
Dim attList As List

' Get the factory object
 Set bgf = tdc.BugFactory
' Use defect #1
 Set bg = bgf.Item(1)
 Set attf = bg.Attachments

' Creating a new attachment
' Create virtual object, then populate the properties
 Set att = attf.AddItem(Null)
 att.FileName = Text1.Text
 att.Type = TDATT_INTERNET

' Saving the object with validity check
 att.Post

' Display the attachments
' Add the display-only items without a Post
 List1.Clear
 Set attList = attf.NewList("")
 For i = 1 To attList.Count

      Set att = attList.Item(i)
      List1.AddItem (att.Name)

 Next

See Also

CycleFactory Object


%%PageItemTitle%%

CycleFactory Object

CycleID
See Also OTA COM Type Library

BuildCoverageGraph Method

Description

Builds release cycle coverage graph.

Syntax

Public Function BuildCoverageGraph( _
   ByVal CycleID As Long _
) As Object

Parameters

CycleID

See Also

CycleFactory Object


%%PageItemTitle%%

CycleFactory Object

Items

A list of IDs.

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also OTA COM Type Library

Mail Method

Description

Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.

Syntax

Public Sub Mail( _
   ByVal Items As Variant, _
   ByVal SendTo As String, _
   Optional ByVal SendCc As String = "", _
   Optional ByVal Option As Long = 0, _
   Optional ByVal Subject As String = "", _
   Optional ByVal Comment As String = "" _
)

Parameters

Items

A list of IDs.

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also

CycleFactory Object


%%PageItemTitle%%

CycleFactory Object

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

CycleFactory Object


%%PageItemTitle%%

CycleFactory Object

ItemKey
See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey

See Also

CycleFactory Object


%%PageItemTitle%%

CycleFactory Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

CycleFactory Object


%%PageItemTitle%%

CycleFactory Object

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

CycleFactory Object


%%PageItemTitle%%

CycleFactory Object

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

CycleFactory Object


%%PageItemTitle%%

CycleFactory Object

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

CycleFactory Object


%%PageItemTitle%%

CycleFactory Object

ItemKey
See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey

See Also

CycleFactory Object


%%PageItemTitle%% $$Members$$

CycleFactory Object

ISupportCopyPaste2 Implemented Interface Members

Properties

Public Implemented Property PasteToCurrentProject Checks if the paste target is in the same project from which the material was copied.

See Also

CycleFactory Object


%%PageItemTitle%%

CycleFactory Object | ISupportCopyPaste2 Implemented Interface

ClipboardData
See Also OTA COM Type Library

PasteToCurrentProject Implemented Property

Description

Checks if the paste target is in the same project from which the material was copied.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISupportCopyPaste2_PasteToCurrentProject( _
   ByVal ClipboardData As String _
) As Boolean

Parameters

ClipboardData

See Also

CycleFactory Object | ISupportCopyPaste2 Implemented Interface


%%PageItemTitle%%

DesignStep Members

DesignStep Object

Description

Represents a single design step in a test.

Remarks

Get a DesignStep object from the DesignStepFactory Object.

Interfaces

IBaseField2 | IBaseField3

Example

Creating various entities and linking them | Copy test

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property EvaluatedStepDescription | The design step description.
Public Property EvaluatedStepExpectedResult | The design step expected result string.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property LinkedParams | The linked test parameters.
Public Property LinkTest | A template test to be linked to the design step.
Public Property LinkTestID | The ID of the linked test.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Order | The order of the design step in the test procedure.
Public Property ParentTest | The test object to which the design step belongs.
Public Property StepDescription | The description of the design step.
Public Property StepExpectedResult | The expected results of the step.
Public Property StepName | The design step name.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

DesignStep Object

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

DesignStep Object


%%PageItemTitle%%

DesignStep Object

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

DesignStep Object


%%PageItemTitle%%

DesignStep Object

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

DesignStep Object


%%PageItemTitle%%

DesignStep Object

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

DesignStep Object


%%PageItemTitle%%

DesignStep Object

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

DesignStep Object


%%PageItemTitle%%

DesignStep Object

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

DesignStep Object


%%PageItemTitle%%

DesignStep Object

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

DesignStep Object


%%PageItemTitle%%

DesignStep Object

EvaluatedStepDescription Property

Description

The design step description.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EvaluatedStepDescription() As String

Remarks

If the description includes parameters, EvaluatedStepDescription returns the string after replacing the parameter markers with their value, if any. To get the string as entered, without evaluating the parameters, use StepDescription.

See Also

DesignStep Object


%%PageItemTitle%%

DesignStep Object

EvaluatedStepExpectedResult Property

Description

The design step expected result string.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EvaluatedStepExpectedResult() As String

Remarks

If the expected result includes parameters, EvaluatedStepExpectedResult returns the string after replacing the parameter markers with their value, if any. To get the string as entered, without evaluating the parameters, use StepExpectedResult Property.

See Also

DesignStep Object


%%PageItemTitle%%

DesignStep Object

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName

The name of the field in the project database.

See Also

DesignStep Object


%%PageItemTitle%%

DesignStep Object

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

DesignStep Object


%%PageItemTitle%%

DesignStep Object

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

DesignStep Object


%%PageItemTitle%%

DesignStep Object

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

DesignStep Object


%%PageItemTitle%%

DesignStep Object

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

DesignStep Object


%%PageItemTitle%%

DesignStep Object

LinkedParams Property

Description

The linked test parameters.

Property type

Read-only property

Syntax (Visual Basic)

Public Property LinkedParams() As Object

See Also

DesignStep Object


%%PageItemTitle%%

DesignStep Object

LinkTest Property

Description

A template test to be linked to the design step.

Property type

Read-write property

Syntax (Visual Basic)

Public Property LinkTest() As Variant

See Also

DesignStep Object


%%PageItemTitle%%

DesignStep Object

LinkTestID Property

Description

The ID of the linked test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property LinkTestID() As Long

See Also

DesignStep Object


%%PageItemTitle%%

DesignStep Object

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

DesignStep Object


%%PageItemTitle%%

DesignStep Object

Order Property

Description

The order of the design step in the test procedure.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Order() As Long

See Also

DesignStep Object


%%PageItemTitle%%

DesignStep Object

ParentTest Property

Description

The test object to which the design step belongs.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ParentTest() As Object

See Also

DesignStep Object


%%PageItemTitle%%

DesignStep Object

StepDescription Property

Description

The description of the design step.

Property type

Read-write property

Syntax (Visual Basic)

Public Property StepDescription() As String

Remarks

StepDescription returns the string as entered. If the description includes parameters, StepDescription returns the string with the parameter place markers. The markers are not replaced with values, as they are by EvaluatedStepDescription.

See Also

DesignStep Object


%%PageItemTitle%%

DesignStep Object

StepExpectedResult Property

Description

The expected results of the step.

Property type

Read-write property

Syntax (Visual Basic)

Public Property StepExpectedResult() As String

Remarks

StepExpectedResult returns the string as entered. If the expected result includes parameters, StepExpectedResult returns the string with the parameter place markers. The markers are not replaced with values, as they are by EvaluatedStepExpectedResult.

See Also

DesignStep Object


%%PageItemTitle%%

DesignStep Object

StepName Property

Description

The design step name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property StepName() As String

See Also

DesignStep Object


%%PageItemTitle%%

DesignStep Object

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

DesignStep Object


%%PageItemTitle%% $$Members$$

DesignStep Object

IBaseField3 Implemented Interface Members

Methods

Public Implemented Method Post Writes all changed values to database.

See Also

DesignStep Object


%%PageItemTitle%%

DesignStep Object | IBaseField3 Implemented Interface

UndoOnFailure
See Also OTA COM Type Library

Post Implemented Method

Description

Writes all changed values to database.

Syntax

Public Sub Post( _
   Optional ByVal UndoOnFailure As Boolean = True _
)

Parameters

UndoOnFailure

See Also

DesignStep Object | IBaseField3 Implemented Interface


%%PageItemTitle%%

DesignStepFactory Members | DesignStep Object | Test Object

DesignStepFactory Object

Description

Services for managing design steps in a Test object.

Remarks

Get a DesignStepFactory object from the Test Object.

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Interfaces

IBaseFactory2 | ISupportCopyPaste2

Example

Getting a reference to an implemented interface | Copy test

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

DesignStepFactory Object

ItemData
Pass NULL as ItemData when creating a design step.

See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData
Pass NULL as ItemData when creating a design step.

Remarks

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

[Visual Basic]

Dim bgf As BugFactory
Dim bg As Bug
Dim attf As AttachmentFactory
Dim att As Attachment
Dim attList As List

' Get the factory object
 Set bgf = tdc.BugFactory
' Use defect #1
 Set bg = bgf.Item(1)
 Set attf = bg.Attachments

' Creating a new attachment
' Create virtual object, then populate the properties
 Set att = attf.AddItem(Null)
 att.FileName = Text1.Text
 att.Type = TDATT_INTERNET

' Saving the object with validity check
 att.Post

' Display the attachments
' Add the display-only items without a Post
 List1.Clear
 Set attList = attf.NewList("")
 For i = 1 To attList.Count

      Set att = attList.Item(i)
      List1.AddItem (att.Name)

 Next

See Also

DesignStepFactory Object


%%PageItemTitle%%

DesignStepFactory Object

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

DesignStepFactory Object


%%PageItemTitle%%

DesignStepFactory Object

ItemKey
The DesignStep.ID (long), a reference to a DesignStep Object, or a Variant array of DesignStep.IDs.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey
The DesignStep.ID (long), a reference to a DesignStep Object, or a Variant array of DesignStep.IDs.

See Also

DesignStepFactory Object


%%PageItemTitle%%

DesignStepFactory Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

DesignStepFactory Object


%%PageItemTitle%%

DesignStepFactory Object

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

DesignStepFactory Object


%%PageItemTitle%%

DesignStepFactory Object

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

DesignStepFactory Object


%%PageItemTitle%%

DesignStepFactory Object

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

DesignStepFactory Object


%%PageItemTitle%%

DesignStepFactory Object

ItemKey
A long integer.

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey
A long integer.

See Also

DesignStepFactory Object


%%PageItemTitle%%

ExecEventActionParams Members

ExecEventActionParams Object

Description

Actions to be taken after the completion of a test set run.

Remarks

An ExecEventActionParams object can be returned from ExecSettings.OnExecEventSchedulerActionParams, depending on the input arguments.

Public Properties

Public Property OnExecEventSchedulerAction The action to be taken.


%%PageItemTitle%%

ExecEventActionParams Object

OnExecEventSchedulerAction Property

Description

The action to be taken.

Property type

Read-only property

Syntax (Visual Basic)

Public Property OnExecEventSchedulerAction() As Long

See Also

ExecEventActionParams Object


%%PageItemTitle%%

ExecEventInfo Members

ExecEventInfo Object

Description

The execution information of the scheduler. This object handles the actual, not the planned, information.

Remarks

Get the ExecEventInfo objects with the ExecutionStatus.EventsList Method.

Example

Getting status information when running a test set

Public Properties

Public Property EventDate | The Execution Event Date.
Public Property EventTime | The Execution Event Time.
Public Property EventType | The type of Execution Event.


%%PageItemTitle%%

ExecEventInfo Object

EventDate Property

Description

The Execution Event Date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EventDate() As String

See Also

ExecEventInfo Object


%%PageItemTitle%%

ExecEventInfo Object

EventTime Property

Description

The Execution Event Time.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EventTime() As String

See Also

ExecEventInfo Object


%%PageItemTitle%%

ExecEventInfo Object

EventType Property

Description

The type of Execution Event.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EventType() As Long

See Also

ExecEventInfo Object


%%PageItemTitle%%

ExecEventNotifyByMailSettings Members

ExecEventNotifyByMailSettings Object

Description

Represents the notification to be sent by e-mail after a test has completed its run.

Remarks

Get a ExecEventNotifyByMailSettings reference from TestSet.ExecEventNotifyByMailSettings

Public Methods

Public Method Save Uploads the notification settings to the server.

Public Properties

Public Property EMailTo | The recipients' e-mail addresses.
Public Property Enabled | Indicates if mail is enabled for the specified event type.
Public Property UserMessage | The message body of the e-mail.


%%PageItemTitle%%

ExecEventNotifyByMailSettings Object

AutoPost
If TRUE, the notification is updated immediately when the field is changed.
See Also OTA COM Type Library

Save Method

Description

Uploads the notification settings to the server.

Syntax

Public Sub Save( _
   Optional ByVal AutoPost As Boolean = True _
)

Parameters

AutoPost
If TRUE, the notification is updated immediately when the field is changed.

See Also

ExecEventNotifyByMailSettings Object


%%PageItemTitle%%

ExecEventNotifyByMailSettings Object

EMailTo Property

Description

The recipients' e-mail addresses.

Property type

Read-write property

Syntax (Visual Basic)

Public Property EMailTo() As String

See Also

ExecEventNotifyByMailSettings Object


%%PageItemTitle%%

ExecEventNotifyByMailSettings Object

EventType
The event type for which to enable the notification. A member of the tagTDAPI_EXECUTIONEVENT Enumeration
See Also OTA COM Type Library

Enabled Property

Description

Indicates if mail is enabled for the specified event type.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Enabled( _
   ByVal EventType As Long _
) As Boolean

Parameters

EventType
The event type for which to enable the notification. A member of the tagTDAPI_EXECUTIONEVENT Enumeration

See Also

ExecEventNotifyByMailSettings Object


%%PageItemTitle%%

ExecEventNotifyByMailSettings Object

UserMessage Property

Description

The message body of the e-mail.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserMessage() As String

See Also

ExecEventNotifyByMailSettings Object


%%PageItemTitle%%

ExecEventRestartActionParams Members

ExecEventRestartActionParams Object

Description

Information on actions to be taken during restart after completion of a test set.

Remarks

An ExecEventRestartActionParams object can be returned from ExecSettings.OnExecEventSchedulerActionParams, depending on the input arguments.

Public Properties

Public Property CleanupTest | The test ID of the test to run before each rerun.
Public Property NumberOfRetries | The number of retries if a test fails.
Public Property OnExecEventSchedulerAction | The action to be taken.


%%PageItemTitle%%

ExecEventRestartActionParams Object

CleanupTest Property

Description

The test ID of the test to run before each rerun.

Property type

Read-write property

Syntax (Visual Basic)

Public Property CleanupTest() As Variant

See Also

ExecEventRestartActionParams Object


%%PageItemTitle%%

ExecEventRestartActionParams Object

NumberOfRetries Property

Description

The number of retries if a test fails.

Property type

Read-write property

Syntax (Visual Basic)

Public Property NumberOfRetries() As Long

Remarks

If NumberOfRetries is zero, the CleanupTest executes once.

See Also

ExecEventRestartActionParams Object


%%PageItemTitle%%

ExecEventRestartActionParams Object

OnExecEventSchedulerAction Property

Description

The action to be taken.

Property type

Read-only property

Syntax (Visual Basic)

Public Property OnExecEventSchedulerAction() As Long

See Also

ExecEventRestartActionParams Object


%%PageItemTitle%%

ExecSettings Members

ExecSettings Object

Description

The information on the execution of a test set.

Remarks

Get an ExecSettings object from TSTest.ExecutionSettings or TestSet.ExecutionSettings.

Public Properties

Public Property OnExecEventSchedulerActionParams | The restart action parameters.
Public Property OnExecEventSchedulerActionType | The action type of the execution event.
Public Property PlannedExecutionDate | The planned test execution date.
Public Property PlannedExecutionTime | The planned test execution time.
Public Property PlannedRunDuration | The planned test run duration.


%%PageItemTitle%%

ExecSettings Object

EventType
A member of the tagTDAPI_EXECUTIONEVENT Enumeration.
See Also OTA COM Type Library

OnExecEventSchedulerActionParams Property

Description

The restart action parameters.

Property type

Read-only property

Syntax (Visual Basic)

Public Property OnExecEventSchedulerActionParams( _
   ByVal EventType As Long _
) As Object

Parameters

EventType
A member of the tagTDAPI_EXECUTIONEVENT Enumeration.

See Also

ExecSettings Object


%%PageItemTitle%%

ExecSettings Object

EventType
A member of the tagTDAPI_EXECUTIONEVENT Enumeration.
See Also OTA COM Type Library

OnExecEventSchedulerActionType Property

Description

The action type of the execution event.

Property type

Read-write property

Syntax (Visual Basic)

Public Property OnExecEventSchedulerActionType( _
   ByVal EventType As Long _
) As Long

Parameters

EventType
A member of the tagTDAPI_EXECUTIONEVENT Enumeration.

See Also

ExecSettings Object


%%PageItemTitle%%

ExecSettings Object

PlannedExecutionDate Property

Description

The planned test execution date.

Property type

Read-write property

Syntax (Visual Basic)

Public Property PlannedExecutionDate() As Variant

See Also

ExecSettings Object


%%PageItemTitle%%

ExecSettings Object

PlannedExecutionTime Property

Description

The planned test execution time.

Property type

Read-write property

Syntax (Visual Basic)

Public Property PlannedExecutionTime() As Variant

See Also

ExecSettings Object


%%PageItemTitle%%

ExecSettings Object

PlannedRunDuration Property

Description

The planned test run duration.

Property type

Read-write property

Syntax (Visual Basic)

Public Property PlannedRunDuration() As Variant

See Also

ExecSettings Object


%%PageItemTitle%%

ExecutionStatus Members

ExecutionStatus Collection

Description

Represents the execution status of the scheduler.

Remarks

Get an ExecutionStatus object from TSScheduler.ExecutionStatus.

Example

Getting status information when running a test set

Public Methods

Public Method EventsList | Gets the list of the execution events.
Public Method RefreshExecStatusInfo | Refreshes the execution status from the execution controller.

Public Properties

Public Property _NewEnum | Gets an ATL.IEnumOnSTLImpl enumerator for the TestExecStatus objects. For information on the ATL Class and IEnumOnSTLImpl, see Microsoft documentation.
Public Property Count | The number of status elements in the object.
Public Property Finished | Checks if execution is finished or still in progress.
Public Property Item | Gets a TestExecStatus object by index (1-based).


%%PageItemTitle%%

ExecutionStatus Collection

EventsList Method

Description

Gets the list of the execution events.

Syntax

Public Function EventsList() As List

Return Type

A list of the ExecEventInfo Objects of the events.

See Also

ExecutionStatus Collection


%%PageItemTitle%%

ExecutionStatus Collection

TestData
Either "all" or a comma-separated list of test IDs
Force
If True, refresh all requested tests. If False, refresh only those tests whose status has changed since the last call.
See Also OTA COM Type Library

RefreshExecStatusInfo Method

Description

Refreshes the execution status from the execution controller.

Syntax

Public Sub RefreshExecStatusInfo( _
   ByVal TestData As Variant, _
   ByVal Force As Boolean _
)

Parameters

TestData
Either "all" or a comma-separated list of test IDs
Force
If True, refresh all requested tests. If False, refresh only those tests whose status has changed since the last call.

See Also

ExecutionStatus Collection


%%PageItemTitle%%

ExecutionStatus Collection

_NewEnum Property

Description

Gets an ATL.IEnumOnSTLImpl enumerator for the TestExecStatus objects. For information on the ATL Class and IEnumOnSTLImpl, see Microsoft documentation.

Property type

Read-only property

Syntax (Visual Basic)

Public Property _NewEnum() As Unknown

See Also

ExecutionStatus Collection


%%PageItemTitle%%

ExecutionStatus Collection

Count Property

Description

The number of status elements in the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

ExecutionStatus Collection


%%PageItemTitle%%

ExecutionStatus Collection

Finished Property

Description

Checks if execution is finished or still in progress.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Finished() As Boolean

See Also

ExecutionStatus Collection


%%PageItemTitle%%

ExecutionStatus Collection

Index
Specifies the TestExecStatus object in the collection. Index is one-based.
See Also OTA COM Type Library

Item Property

Description

Gets a TestExecStatus object by index (1-based).

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal Index As Long _
) As Variant

Parameters

Index
Specifies the TestExecStatus object in the collection. Index is one-based.

See Also

ExecutionStatus Collection


%%PageItemTitle%%

ExtendedStorage Members

ExtendedStorage Object

Description

Represents a storage structure used to transfer files between the server and client file system and delete files.

Remarks

There are three implementations of storage handlers: ExtendedStorage, ExtendedStorageProxy, and ProjectRepository. They all implement the IExtendedStorage Interface. The Open Test Architecture infrastructure returns the handler object appropriate to the configuration of the servers and project on which the application is run.

The use of the handlers in your application is the same regardless of the implementation. Declare variables as type IExtendedStorage. For examples, see IExtendedStorage Interface and its methods and properties.

Get a storage handler object from AttachmentFactory.AttachmentStorage, Run.ExtendedStorage, Attachment.AttachmentStorage, Test.ExtendedStorage, or TestFactory.RepositoryStorage.

Note that a storage handler object obtained from an object will not necessarily handle only items belonging to that object. For example, if you get a storage object from a test attachment and then download all attachments:

Set TestAttachmentFactoryObj = aTestObject.Attachments
Set TestAttachStorage = TestAttachmentFactoryObj.AttachmentStorage
AttachDownLoadPath = TestAttachStorage.LoadEx("*.*", True, NullList, isFatalErr)

The result is to download all attachments in the project.

To avoid this, either specify a filter or use other methods. In the above example, you could replace the ExtendedStorage load with Attachment.Load.

The storage handler is also accessible from TDConnection.ExtendedStorage, but a reference obtained this way is disabled by the default security settings.

Public Methods

Public Method Cancel | Cancels the load or save action.
Public Method Delete | Deletes files locally or from the server.
Public Method GetLastError | Gets the last error that occurred during asynchronous load and save operations.
Public Method Load | Downloads the storage structure to the client file system.
Public Method LoadEx | Downloads the storage structure to the client file system.
Public Method Progress | Polls the progress of the last action (Load or Save).
Public Method Save | Uploads the storage structure to the server.
Public Method SaveEx | Uploads the storage structure to the server.

Public Properties

Public Property ActionFinished | Checks if the load or save action is finished.
Public Property ClientPath | The location on the client to which to download or from which to upload.
Public Property Root | The storage root.
Public Property ServerPath | The location on the server from which to download or to which to upload.


%%PageItemTitle%%

ExtendedStorage Object

Cancel Method

Description

Cancels the load or save action.

Syntax

Public Sub Cancel()

See Also

ExtendedStorage Object


%%PageItemTitle%%

ExtendedStorage Object

FSysFilter
A file system filter. If the filter begins with "-r", it is applied recursively to all sub-directories. If the filter is an empty string, all files with all subdirectories are downloaded to the client.
nDeleteType

The delete type, Local or remote. A member of the tagTDAPI_EXSTOR_DELMODE Enumeration .

See Also OTA COM Type Library

Delete Method

Description

Deletes files locally or from the server.

Syntax

Public Sub Delete( _
   ByVal FSysFilter As String, _
   ByVal nDeleteType As Long _
)

Parameters

FSysFilter
A file system filter. If the filter begins with "-r", it is applied recursively to all sub-directories. If the filter is an empty string, all files with all subdirectories are downloaded to the client.
nDeleteType

The delete type, Local or remote. A member of the tagTDAPI_EXSTOR_DELMODE Enumeration .

See Also

ExtendedStorage Object

Example

Operations on the test repository


%%PageItemTitle%%

ExtendedStorage Object

GetLastError Method

Description

Gets the last error that occurred during asynchronous load and save operations.

Syntax

Public Sub GetLastError()

Return Type

An HRESULT. The application-specific error is in the information code.

Remarks

Used for asynchronous operations where error handled can not be implemented.

For information on handling an HRESULT, see Microsoft documentation.

See Also

ExtendedStorage Object


%%PageItemTitle%%

ExtendedStorage Object

FSysFilter
A file system filter.
synchronize
If True, the download operation is synchronous.
See Also OTA COM Type Library

Load Method

Description

Downloads the storage structure to the client file system.

Syntax

Public Function Load( _
   Optional ByVal FSysFilter As String = "*.*", _
   Optional ByVal synchronize As Boolean = False _
) As String

Parameters

FSysFilter
A file system filter.
synchronize
If True, the download operation is synchronous.

Return Type

The path on the client machine to which the files were downloaded.

Remarks

If the filter is an empty string, all files with all subdirectories are uploaded to the server.

If a phrase in the filter begins with "-r", it is applied recursively to all sub-directories. If a phrase in the filter begins with -x, it indications exclusion.

For example, the filter "Austen.txt, -r Novels\*.* -x Emma.txt" returns the file Austen.txt and all files and folders under the Novels directory except Emma.txt.

If the operation is synchronous, the process begins and is not checked for status until the process is completed. If the operation is asynchronous, the Load method initiates the download immediately and continuously checks if the download is finished. Check the ActionFinished Property periodically, and use the GetLastError Method to see if the operation succeeded.

See Also

ExtendedStorage Object

Example

Downloading a defect attachment with Extended Storage | Operations on the test repository


%%PageItemTitle%%

ExtendedStorage Object

FSysFilter

A file system filter.

synchronize

If True, the download operation is synchronous.

pVal
NULL
pNonFatalErrorOccured
The error that occurred was non-fatal. This value is meaningful only for synchronous transfers.
See Also OTA COM Type Library

LoadEx Method

Description

Downloads the storage structure to the client file system.

Syntax

Public Function LoadEx( _
   ByVal FSysFilter As String, _
   ByVal synchronize As Boolean, _
   ByVal pVal As List, _
   ByRef pNonFatalErrorOccured As Boolean _
) As String

Parameters

FSysFilter

A file system filter.

synchronize

If True, the download operation is synchronous.

pVal
NULL
pNonFatalErrorOccured
The error that occurred was non-fatal. This value is meaningful only for synchronous transfers.

Return Type

The path on the client machine to which the files were downloaded.

Remarks

If the filter is an empty string, all files with all subdirectories are uploaded to the server.

If a phrase in the filter begins with "-r", it is applied recursively to all sub-directories. If a phrase in the filter begins with -x, it indications exclusion.

For example, the filter "Austen.txt, -r Novels\*.* -x Emma.txt" returns the file Austen.txt and all files and folders under the Novels directory except Emma.txt.

If the operation is synchronous, the process begins and is not checked for status until the process is completed. If the operation is asynchronous, the Load method initiates the download immediately and continuously checks if the download is finished. Check the ActionFinished Property periodically, and use the GetLastError Method to see if the operation succeeded.

See Also

ExtendedStorage Object

Example

Downloading test files and attachments


%%PageItemTitle%%

ExtendedStorage Object

Total
The total number of bytes to be transferred.
Current
The number of bytes transferred so far.
See Also OTA COM Type Library

Progress Method

Description

Polls the progress of the last action (Load or Save).

Syntax

Public Function Progress( _
   ByRef Total As Long, _
   ByRef Current As Long _
) As String

Parameters

Total
The total number of bytes to be transferred.
Current
The number of bytes transferred so far.

Return Type

Null

See Also

ExtendedStorage Object


%%PageItemTitle%%

ExtendedStorage Object

FSysFilter
A file system filter.
synchronize
If True, the upload operation is synchronous.
See Also OTA COM Type Library

Save Method

Description

Uploads the storage structure to the server.

Syntax

Public Sub Save( _
   Optional ByVal FSysFilter As String = "*.*", _
   Optional ByVal synchronize As Boolean = False _
)

Parameters

FSysFilter
A file system filter.
synchronize
If True, the upload operation is synchronous.

Remarks

If the filter is an empty string, all files with all subdirectories are uploaded to the server.

If a phrase in the filter begins with "-r", it is applied recursively to all sub-directories. If a phrase in the filter begins with -x, it indications exclusion.

For example, the filter "Austen.txt, -r Novels\*.* -x Emma.txt" returns the file Austen.txt and all files and folders under the Novels directory except Emma.txt.

If the operation is synchronous, the process begins and is not checked for status until the process is completed. If the operation is asynchronous, the function immediately begins the upload and continuously checks if the transfer is finished. Check the ActionFinished Property periodically, and use the GetLastError Method to see if the operation succeeded.

See Also

ExtendedStorage Object

Example

Creating a new defect attachment


%%PageItemTitle%%

ExtendedStorage Object

FSysFilter

A file system filter.

synchronize

If True, the upload operation is synchronous.

pVal
NULL
See Also OTA COM Type Library

SaveEx Method

Description

Uploads the storage structure to the server.

Syntax

Public Function SaveEx( _
   ByVal FSysFilter As String, _
   ByVal synchronize As Boolean, _
   ByVal pVal As List _
) As Boolean

Parameters

FSysFilter

A file system filter.

synchronize

If True, the upload operation is synchronous.

pVal
NULL

Return Type

The error that occurred was non-fatal (True or False). This value is meaningful only for synchronous transfers.

Remarks

If the filter is an empty string, all files with all subdirectories are uploaded to the server.

If a phrase in the filter begins with "-r", it is applied recursively to all sub-directories. If a phrase in the filter begins with -x, it indications exclusion.

For example, the filter "Austen.txt, -r Novels\*.* -x Emma.txt" returns the file Austen.txt and all files and folders under the Novels directory except Emma.txt.

If the operation is synchronous, the process begins and is not checked for status until the process is completed. If the operation is asynchronous, the function immediately begins the upload and continuously checks if the transfer is finished. Check the ActionFinished Property periodically, and use the GetLastError Method to see if the operation succeeded.

See Also

ExtendedStorage Object


%%PageItemTitle%%

ExtendedStorage Object

ActionFinished Property

Description

Checks if the load or save action is finished.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ActionFinished() As Long

See Also

ExtendedStorage Object


%%PageItemTitle%%

ExtendedStorage Object

ClientPath Property

Description

The location on the client to which to download or from which to upload.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ClientPath() As String

See Also

ExtendedStorage Object

Example

Downloading a defect attachment with Extended Storage


%%PageItemTitle%%

ExtendedStorage Object

Root Property

Description

The storage root.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Root() As Object

See Also

ExtendedStorage Object


%%PageItemTitle%%

ExtendedStorage Object

ServerPath Property

Description

The location on the server from which to download or to which to upload.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ServerPath() As String

See Also

ExtendedStorage Object


%%PageItemTitle%%

ExtendedStorageProxy Members

ExtendedStorageProxy Object

Description

Represents the project repository. The implementation is either in the file system or database depending on the project configuration.

Remarks

There are three implementations of storage handlers: ExtendedStorage, ExtendedStorageProxy, and ProjectRepository. They all implement the IExtendedStorage Interface. The Open Test Architecture infrastructure returns the handler object appropriate to the configuration of the servers and project on which the application is run.

The use of the handlers in your application is the same regardless of the implementation. Declare variables as type IExtendedStorage. For examples, see IExtendedStorage Interface and its methods and properties.

Get a storage handler object from AttachmentFactory.AttachmentStorage, Run.ExtendedStorage, Attachment.AttachmentStorage, Test.ExtendedStorage, or TestFactory.RepositoryStorage.

Note that a storage handler object obtained from an object will not necessarily handle only items belonging to that object. For example, if you get a storage object from a test attachment and then download all attachments:

Set TestAttachmentFactoryObj = aTestObject.Attachments
Set TestAttachStorage = TestAttachmentFactoryObj.AttachmentStorage
AttachDownLoadPath = TestAttachStorage.LoadEx("*.*", True, NullList, isFatalErr)

The result is to download all attachments in the project.

To avoid this, either specify a filter or use other methods. In the above example, you could replace the ExtendedStorage load with Attachment.Load.

The storage handler is also accessible from TDConnection.ExtendedStorage, but a reference obtained this way is disabled by the default security settings.

Public Methods

Public Method Cancel | Cancels the load or save action.
Public Method Delete | Deletes files locally or from the server.
Public Method GetLastError | Gets the last error that occurred during asynchronous load and save operations.
Public Method Load | Downloads the storage structure to the client file system.
Public Method LoadEx | Downloads the storage structure to the client file system.
Public Method Progress | Polls the progress of the last action (Load or Save).
Public Method Save | Uploads the storage structure to the server.
Public Method SaveEx | Uploads the storage structure to the server.

Public Properties

Public Property ActionFinished | Checks if the load or save action is finished.
Public Property ClientPath | The location on the client to which to download or from which to upload.
Public Property Root | The storage root.
Public Property ServerPath | The location on the server from which to download or to which to upload.


%%PageItemTitle%%

ExtendedStorageProxy Object

Cancel Method

Description

Cancels the load or save action.

Syntax

Public Sub Cancel()

See Also

ExtendedStorageProxy Object


%%PageItemTitle%%

ExtendedStorageProxy Object

FSysFilter

A file system filter. If the filter begins with "-r", it is applied recursively to all sub-directories. If the filter is an empty string, all files with all subdirectories are downloaded to the client.

nDeleteType

The delete type, Local or remote. A member of the tagTDAPI_EXSTOR_DELMODE Enumeration .

See Also OTA COM Type Library

Delete Method

Description

Deletes files locally or from the server.

Syntax

Public Sub Delete( _
   ByVal FSysFilter As String, _
   ByVal nDeleteType As Long _
)

Parameters

FSysFilter

A file system filter. If the filter begins with "-r", it is applied recursively to all sub-directories. If the filter is an empty string, all files with all subdirectories are downloaded to the client.

nDeleteType

The delete type, Local or remote. A member of the tagTDAPI_EXSTOR_DELMODE Enumeration .

See Also

ExtendedStorageProxy Object


%%PageItemTitle%%

ExtendedStorageProxy Object

GetLastError Method

Description

Gets the last error that occurred during asynchronous load and save operations.

Syntax

Public Sub GetLastError()

Return Type

An HRESULT. The application-specific error is in the information code.

Remarks

Used for asynchronous operations where error handled can not be implemented.

For information on handling an HRESULT, see Microsoft documentation.

See Also

ExtendedStorageProxy Object


%%PageItemTitle%%

ExtendedStorageProxy Object

FSysFilter

A file system filter.

synchronize

If True, the download operation is synchronous.

See Also OTA COM Type Library

Load Method

Description

Downloads the storage structure to the client file system.

Syntax

Public Function Load( _
   Optional ByVal FSysFilter As String = "*.*", _
   Optional ByVal synchronize As Boolean = False _
) As String

Parameters

FSysFilter

A file system filter.

synchronize

If True, the download operation is synchronous.

Return Type

The path on the client machine to which the files were downloaded.

Remarks

If the filter is an empty string, all files with all subdirectories are uploaded to the server.

If a phrase in the filter begins with "-r", it is applied recursively to all sub-directories. If a phrase in the filter begins with -x, it indications exclusion.

For example, the filter "Austen.txt, -r Novels\*.* -x Emma.txt" returns the file Austen.txt and all files and folders under the Novels directory except Emma.txt.

If the operation is synchronous, the process begins and is not checked for status until the process is completed. If the operation is asynchronous, the Load method initiates the download immediately and continuously checks if the download is finished. Check the ActionFinished Property periodically, and use the GetLastError Method to see if the operation succeeded.

See Also

ExtendedStorageProxy Object


%%PageItemTitle%%

ExtendedStorageProxy Object

FSysFilter

A file system filter.

synchronize

If True, the download operation is synchronous.

pVal

NULL

pNonFatalErrorOccured

The error that occurred was non-fatal. This value is meaningful only for synchronous transfers.

See Also OTA COM Type Library

LoadEx Method

Description

Downloads the storage structure to the client file system.

Syntax

Public Function LoadEx( _
   ByVal FSysFilter As String, _
   ByVal synchronize As Boolean, _
   ByVal pVal As List, _
   ByRef pNonFatalErrorOccured As Boolean _
) As String

Parameters

FSysFilter

A file system filter.

synchronize

If True, the download operation is synchronous.

pVal

NULL

pNonFatalErrorOccured

The error that occurred was non-fatal. This value is meaningful only for synchronous transfers.

Return Type

The path on the client machine to which the files were downloaded.

Remarks

If the filter is an empty string, all files with all subdirectories are uploaded to the server.

If a phrase in the filter begins with "-r", it is applied recursively to all sub-directories. If a phrase in the filter begins with -x, it indications exclusion.

For example, the filter "Austen.txt, -r Novels\*.* -x Emma.txt" returns the file Austen.txt and all files and folders under the Novels directory except Emma.txt.

If the operation is synchronous, the process begins and is not checked for status until the process is completed. If the operation is asynchronous, the Load method initiates the download immediately and continuously checks if the download is finished. Check the ActionFinished Property periodically, and use the GetLastError Method to see if the operation succeeded.

See Also

ExtendedStorageProxy Object


%%PageItemTitle%%

ExtendedStorageProxy Object

Total

The total number of bytes to be transferred.

Current

The number of bytes transferred so far.

See Also OTA COM Type Library

Progress Method

Description

Polls the progress of the last action (Load or Save).

Syntax

Public Function Progress( _
   ByRef Total As Long, _
   ByRef Current As Long _
) As String

Parameters

Total

The total number of bytes to be transferred.

Current

The number of bytes transferred so far.

Return Type

Null

See Also

ExtendedStorageProxy Object


%%PageItemTitle%%

ExtendedStorageProxy Object

FSysFilter

A file system filter.

synchronize

If True, the upload operation is synchronous.

See Also OTA COM Type Library

Save Method

Description

Uploads the storage structure to the server.

Syntax

Public Sub Save( _
   Optional ByVal FSysFilter As String = "*.*", _
   Optional ByVal synchronize As Boolean = False _
)

Parameters

FSysFilter

A file system filter.

synchronize

If True, the upload operation is synchronous.

Remarks

If the filter is an empty string, all files with all subdirectories are uploaded to the server.

If a phrase in the filter begins with "-r", it is applied recursively to all sub-directories. If a phrase in the filter begins with -x, it indications exclusion.

For example, the filter "Austen.txt, -r Novels\*.* -x Emma.txt" returns the file Austen.txt and all files and folders under the Novels directory except Emma.txt.

If the operation is synchronous, the process begins and is not checked for status until the process is completed. If the operation is asynchronous, the function immediately begins the upload and continuously checks if the transfer is finished. Check the ActionFinished Property periodically, and use the GetLastError Method to see if the operation succeeded.

See Also

ExtendedStorageProxy Object


%%PageItemTitle%%

ExtendedStorageProxy Object

FSysFilter

A file system filter.

synchronize

If True, the upload operation is synchronous.

pVal

NULL

See Also OTA COM Type Library

SaveEx Method

Description

Uploads the storage structure to the server.

Syntax

Public Function SaveEx( _
   ByVal FSysFilter As String, _
   ByVal synchronize As Boolean, _
   ByVal pVal As List _
) As Boolean

Parameters

FSysFilter

A file system filter.

synchronize

If True, the upload operation is synchronous.

pVal

NULL

Return Type

The error that occurred was non-fatal (True or False). This value is meaningful only for synchronous transfers.

Remarks

If the filter is an empty string, all files with all subdirectories are uploaded to the server.

If a phrase in the filter begins with "-r", it is applied recursively to all sub-directories. If a phrase in the filter begins with -x, it indications exclusion.

For example, the filter "Austen.txt, -r Novels\*.* -x Emma.txt" returns the file Austen.txt and all files and folders under the Novels directory except Emma.txt.

If the operation is synchronous, the process begins and is not checked for status until the process is completed. If the operation is asynchronous, the function immediately begins the upload and continuously checks if the transfer is finished. Check the ActionFinished Property periodically, and use the GetLastError Method to see if the operation succeeded.

See Also

ExtendedStorageProxy Object


%%PageItemTitle%%

ExtendedStorageProxy Object

ActionFinished Property

Description

Checks if the load or save action is finished.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ActionFinished() As Long

See Also

ExtendedStorageProxy Object


%%PageItemTitle%%

ExtendedStorageProxy Object

ClientPath Property

Description

The location on the client to which to download or from which to upload.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ClientPath() As String

See Also

ExtendedStorageProxy Object


%%PageItemTitle%%

ExtendedStorageProxy Object

Root Property

Description

The storage root.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Root() As Object

See Also

ExtendedStorageProxy Object


%%PageItemTitle%%

ExtendedStorageProxy Object

ServerPath Property

Description

The location on the server from which to download or to which to upload.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ServerPath() As String

See Also

ExtendedStorageProxy Object


%%PageItemTitle%%

FactoryList Members

FactoryList Collection

Description

Create and maintain lists within entity factories. Use any factory object to create any number of list instances for objects in the factory.

Remarks

Get a FactoryList from Bug.FindSimilarBugs or HierarchyFilter.NewList.

List objects are returned by the NewList method of factory objects and by many other methods and properties.

List numbering begins at one, for example, myList.Item(1).

Public Methods

Public Method Add | Adds a new item to the current list object.
Public Method IndexOfItem | Gets the index of the passed object.
Public Method Insert | Inserts a new item at the specified position.
Public Method Post | Posts changed data for all items in list.
Public Method Refresh | Reads saved list filter and data for all listed objects, overwriting values in memory.
Public Method Remove | Removes the specified item from the current list object.
Public Method Swap | Swaps the two list items specified by their positions.

Public Properties

Public Property _NewEnum | Gets an IEnumVARIANT enumerator. For information on the IEnumVARIANT, see Microsoft documentation.
Public Property Count | The number of items in the list.
Public Property Fields | Gets a list of fields available through this factory.
Public Property Item | Gets an item by index. The index is one-based.
Public Property Ratio | The similarity ratio for the specified item.


%%PageItemTitle%%

FactoryList Collection

vNew

A value or object reference to be added to the list.

See Also OTA COM Type Library

Add Method

Description

Adds a new item to the current list object.

Syntax

Public Sub Add( _
   ByVal vNew As Variant _
)

Parameters

vNew

A value or object reference to be added to the list.

See Also

FactoryList Collection


%%PageItemTitle%%

FactoryList Collection

Item
A reference to one of the objects in the list.
See Also OTA COM Type Library

IndexOfItem Method

Description

Gets the index of the passed object.

Syntax

Public Function IndexOfItem( _
   ByVal Item As Variant _
) As Long

Parameters

Item
A reference to one of the objects in the list.

See Also

FactoryList Collection


%%PageItemTitle%%

FactoryList Collection

Pos

The position into which to insert the item.

vNew

A value or object reference to be inserted in the list.

See Also OTA COM Type Library

Insert Method

Description

Inserts a new item at the specified position.

Syntax

Public Sub Insert( _
   ByVal Pos As Long, _
   ByVal vNew As Variant _
)

Parameters

Pos

The position into which to insert the item.

vNew

A value or object reference to be inserted in the list.

See Also

FactoryList Collection


%%PageItemTitle%%

FactoryList Collection

Post Method

Description

Posts changed data for all items in list.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

FactoryList Collection


%%PageItemTitle%%

FactoryList Collection

Refresh Method

Description

Reads saved list filter and data for all listed objects, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

FactoryList Collection


%%PageItemTitle%%

FactoryList Collection

Index

The position in the list of the item to be removed.

See Also OTA COM Type Library

Remove Method

Description

Removes the specified item from the current list object.

Syntax

Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index

The position in the list of the item to be removed.

See Also

FactoryList Collection


%%PageItemTitle%%

FactoryList Collection

Pos1

Put the item in this position in position Pos2.

Pos2

Put the item in this position in position Pos1.

See Also OTA COM Type Library

Swap Method

Description

Swaps the two list items specified by their positions.

Syntax

Public Sub Swap( _
   ByVal Pos1 As Long, _
   ByVal Pos2 As Long _
)

Parameters

Pos1

Put the item in this position in position Pos2.

Pos2

Put the item in this position in position Pos1.

See Also

FactoryList Collection


%%PageItemTitle%%

FactoryList Collection

_NewEnum Property

Description

Gets an IEnumVARIANT enumerator. For information on the IEnumVARIANT, see Microsoft documentation.

Property type

Read-only property

Syntax (Visual Basic)

Public Property _NewEnum() As Unknown

See Also

FactoryList Collection


%%PageItemTitle%%

FactoryList Collection

Count Property

Description

The number of items in the list.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

FactoryList Collection


%%PageItemTitle%%

FactoryList Collection

Fields Property

Description

Gets a list of fields available through this factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

FactoryList Collection


%%PageItemTitle%%

FactoryList Collection

Index

The index is 1 to Count.

See Also OTA COM Type Library

Item Property

Description

Gets an item by index. The index is one-based.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal Index As Long _
) As Variant

Parameters

Index

The index is 1 to Count.

See Also

FactoryList Collection


%%PageItemTitle%%

FactoryList Collection

Index
Index is 1 to Count.
See Also OTA COM Type Library

Ratio Property

Description

The similarity ratio for the specified item.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Ratio( _
   ByVal Index As Long _
) As Long

Parameters

Index
Index is 1 to Count.

Remarks

The Ratio method is meaningful when the list is acquired as a result of call to FindSimilarBug, otherwise it returns 0 (in VB) and an HRESULT of S_FALSE.

See Also

FactoryList Collection

Example

Getting the similarity ratio of lists created with FindSimilarBugs


%%PageItemTitle%%

FieldProperty Members

FieldProperty Object

Description

Properties for object fields.

Remarks

Get a FieldProperty object from TDField.Property.

Example

Compare TDField properties and FieldProperty properties

Public Methods

Public Method GetRequiredByType Checks if the field is required according to the requirement type.

Public Properties

Public Property DBColumnName | The database column name.
Public Property DBColumnType | The database column type.
Public Property DBTableName | The database table name.
Public Property EditMask | The input mask for string fields.
Public Property EditStyle | The user interface control type used to edit this field.
Public Property FieldSize | The size of the field in the database (-1 for BLOB fields).
Public Property IsActive | Checks if the field is can be displayed in the user interface.
Public Property IsByCode | Checks if the field saves the Tree Node ID (True), or the passed value (False).
Public Property IsCanFilter | Checks if the field is displayed in the filter dialog box.
Public Property IsCanGroup | Checks if items of this type can form groups with others of the same type.
Public Property IsCustomizable | Checks if the field is displayed in the customization UI.
Public Property IsEdit | Checks if the field can be edited.
Public Property IsHistory | Checks if change history is stored for the field.
Public Property IsKeepValue | Checks if the last value for the field is stored.
Public Property IsKey | Checks if this is a database key field.
Public Property IsMail | Checks if e-mail is sent to the users on the notification list when this field changes.
Public Property IsModify | Checks if the user currently logged on the TDConnection is permitted to modify this field.
Public Property IsMultiValue | Checks if the field can store multiple values.
Public Property IsRequired | Checks if this is a required field.
Public Property IsSearchable | Checks if the content of the field is searched by the Search method.
Public Property IsSystem | Checks if this is a predefined system field.
Public Property IsToSum | Checks if this field is summed for graphs.
Public Property IsVerify | Checks if the field requires verification.
Public Property IsVersionControl | Checks if the field is under version control.
Public Property IsVisibleInNewBug | Checks if the field is visible in the New Bug form.
Public Property ReadOnly | Checks if this is a read-only field.
Public Property Root | The tree root connected to the field.
Public Property UserColumnType | The user column type: char, number, date, memo, or empty string.
Public Property UserLabel | The user-defined label.


%%PageItemTitle%%

FieldProperty Object

GetRequiredByType Method

Description

Checks if the field is required according to the requirement type.

Syntax

Public Function GetRequiredByType() As Boolean

See Also

FieldProperty Object


%%PageItemTitle%%

FieldProperty Object

DBColumnName Property

Description

The database column name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DBColumnName() As String

See Also

FieldProperty Object


%%PageItemTitle%%

FieldProperty Object

DBColumnType Property

Description

The database column type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DBColumnType() As String

See Also

FieldProperty Object


%%PageItemTitle%%

FieldProperty Object

DBTableName Property

Description

The database table name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DBTableName() As String

See Also

FieldProperty Object


%%PageItemTitle%%

FieldProperty Object

EditMask Property

Description

The input mask for string fields.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EditMask() As String

Remarks

When a user is prompted for data in the user interface, the edit mask is used to present the blank input in the required format.

For more information on input masks, see 'Defining Input Masks' under 'Customizing Project Entities' in the Mercury Quality Center Administrator's Guide.

See Also

FieldProperty Object


%%PageItemTitle%%

FieldProperty Object

EditStyle Property

Description

The user interface control type used to edit this field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EditStyle() As String

See Also

FieldProperty Object


%%PageItemTitle%%

FieldProperty Object

FieldSize Property

Description

The size of the field in the database (-1 for BLOB fields).

Property type

Read-only property

Syntax (Visual Basic)

Public Property FieldSize() As Long

See Also

FieldProperty Object


%%PageItemTitle%%

FieldProperty Object

IsActive Property

Description

Checks if the field is can be displayed in the user interface.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsActive() As Boolean

See Also

FieldProperty Object


%%PageItemTitle%%

FieldProperty Object

IsByCode Property

Description

Checks if the field saves the Tree Node ID (True), or the passed value (False).

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsByCode() As Boolean

See Also

FieldProperty Object


%%PageItemTitle%%

FieldProperty Object

IsCanFilter Property

Description

Checks if the field is displayed in the filter dialog box.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsCanFilter() As Boolean

See Also

FieldProperty Object


%%PageItemTitle%%

FieldProperty Object

IsCanGroup Property

Description

Checks if items of this type can form groups with others of the same type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsCanGroup() As Boolean

See Also

FieldProperty Object

Example

Using the GroupingItem Object


%%PageItemTitle%%

FieldProperty Object

IsCustomizable Property

Description

Checks if the field is displayed in the customization UI.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsCustomizable() As Boolean

See Also

FieldProperty Object


%%PageItemTitle%%

FieldProperty Object

IsEdit Property

Description

Checks if the field can be edited.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsEdit() As Boolean

See Also

FieldProperty Object


%%PageItemTitle%%

FieldProperty Object

IsHistory Property

Description

Checks if change history is stored for the field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsHistory() As Boolean

See Also

FieldProperty Object


%%PageItemTitle%%

FieldProperty Object

IsKeepValue Property

Description

Checks if the last value for the field is stored.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsKeepValue() As Boolean

See Also

FieldProperty Object


%%PageItemTitle%%

FieldProperty Object

IsKey Property

Description

Checks if this is a database key field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsKey() As Boolean

See Also

FieldProperty Object


%%PageItemTitle%%

FieldProperty Object

IsMail Property

Description

Checks if e-mail is sent to the users on the notification list when this field changes.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsMail() As Boolean

See Also

FieldProperty Object


%%PageItemTitle%%

FieldProperty Object

IsModify Property

Description

Checks if the user currently logged on the TDConnection is permitted to modify this field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsModify() As Boolean

See Also

FieldProperty Object


%%PageItemTitle%%

FieldProperty Object

IsMultiValue Property

Description

Checks if the field can store multiple values.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsMultiValue() As Boolean

See Also

FieldProperty Object


%%PageItemTitle%%

FieldProperty Object

IsRequired Property

Description

Checks if this is a required field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsRequired() As Boolean

See Also

FieldProperty Object


%%PageItemTitle%%

FieldProperty Object

IsSearchable Property

Description

Checks if the content of the field is searched by the Search method.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsSearchable() As Boolean

See Also

FieldProperty Object


%%PageItemTitle%%

FieldProperty Object

IsSystem Property

Description

Checks if this is a predefined system field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsSystem() As Boolean

See Also

FieldProperty Object


%%PageItemTitle%%

FieldProperty Object

IsToSum Property

Description

Checks if this field is summed for graphs.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsToSum() As Boolean

See Also

FieldProperty Object


%%PageItemTitle%%

FieldProperty Object

IsVerify Property

Description

Checks if the field requires verification.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsVerify() As Boolean

See Also

FieldProperty Object


%%PageItemTitle%%

FieldProperty Object

IsVersionControl Property

Description

Checks if the field is under version control.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsVersionControl() As Boolean

See Also

FieldProperty Object


%%PageItemTitle%%

FieldProperty Object

IsVisibleInNewBug Property

Description

Checks if the field is visible in the New Bug form.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsVisibleInNewBug() As Boolean

See Also

FieldProperty Object


%%PageItemTitle%%

FieldProperty Object

ReadOnly Property

Description

Checks if this is a read-only field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ReadOnly() As Boolean

See Also

FieldProperty Object


%%PageItemTitle%%

FieldProperty Object

Root Property

Description

The tree root connected to the field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Root() As Object

See Also

FieldProperty Object


%%PageItemTitle%%

FieldProperty Object

UserColumnType Property

Description

The user column type: char, number, date, memo, or empty string.

Property type

Read-only property

Syntax (Visual Basic)

Public Property UserColumnType() As String

Remarks

The type of data a user enters in a field. This is not always the same as the DBColumnType. For example, a user may enter date or numerical information in a char database field.

See Also

FieldProperty Object


%%PageItemTitle%%

FieldProperty Object

UserLabel Property

Description

The user-defined label.

Property type

Read-only property

Syntax (Visual Basic)

Public Property UserLabel() As String

See Also

FieldProperty Object


%%PageItemTitle%%

FileData Members

FileData Object

Description

Information about a folder or file.

Remarks

A FileData object is returned by ExtendedStorage.Root.

Public Methods

Public Method Items | The folder's child items.
Public Method ModifyDate | The file's modify date.
Public Method Size | The file size in Kbytes.
Public Method Type | The type of object for which data is stored.

Public Properties

Public Property Name The file or folder name.


%%PageItemTitle%%

FileData Object

Items Method

Description

The folder's child items.

Syntax

Public Function Items() As List

See Also

FileData Object


%%PageItemTitle%%

FileData Object

ModifyDate Method

Description

The file's modify date.

Syntax

Public Function ModifyDate() As Date

See Also

FileData Object


%%PageItemTitle%%

FileData Object

Size Method

Description

The file size in Kbytes.

Syntax

Public Function Size() As Long

See Also

FileData Object


%%PageItemTitle%%

FileData Object

Type Method

Description

The type of object for which data is stored.

Syntax

Public Function Type() As Integer

Return Type

A value of the tagTDAPI_FDATA_TYPE Enumeration.

See Also

FileData Object


%%PageItemTitle%%

FileData Object

Name Property

Description

The file or folder name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name() As String

See Also

FileData Object


%%PageItemTitle%%

Graph Members

Graph Object

Description

Represents a graph built through a method.

Remarks

A Graph object is returned by the Build<graph type>Graph methods of factory objects.

Example

Build a summary graph

Public Methods

Public Method DrillDown | Drills down to graph data.
Public Method MultiDrillDown | Gets detailed information about a graph area consisting of four sets of coordinates.

Public Properties

Public Property ColCount | The number of columns.
Public Property ColName | Gets the name of the specified column. Column numbers are zero-based.
Public Property ColTotal | The sum of the values in the specified graph data column. The column number is zero-based.
Public Property Data | The data in the specified cell. Column and Row numbers are zero-based.
Public Property GraphTotal | The total number of items represented in the graph.
Public Property MaxValue | The maximum value in the graph.
Public Property RowCount | The number of rows.
Public Property RowName | Gets the row name of the specified row. Row numbers are zero-based.
Public Property RowTotal | The sum of the values in the specified graph data row. The row number is zero-based.
Public Property StartDate | The start date for the graph.


%%PageItemTitle%%

Graph Object

pAreas
The area of the graph to retrieve, base on its data grid view.
mAreas
No longer in use. Argument preserved for backward compatibility. Pass an Empty variant.
See Also OTA COM Type Library

DrillDown Method

Description

Drills down to graph data.

Syntax

Public Function DrillDown( _
   ByVal pAreas As Variant, _
   ByVal mAreas As Variant _
) As List

Parameters

pAreas
The area of the graph to retrieve, base on its data grid view.
mAreas
No longer in use. Argument preserved for backward compatibility. Pass an Empty variant.

Return Type

A list of objects representing the data in the specified cell of the graph. For example, in a defect graph, DrillDown returns a list of Bug objects.

Remarks

pAreas is a two-dimensional variant array representing lists of rectangular areas in data grid. The first array dimension size must be 4.
Such an array can be logically modeled as a table with four columns where each row represents one rectangular area. Each rectangular area is a set of four coordinates: TopLeftColNum, TopLeftRowNum, BottomRightColNum, and BottomRightRowNum.

See Also

Graph Object


%%PageItemTitle%%

Graph Object

Areas
The area of the graph to retrieve, based on its data grid view.
See Also OTA COM Type Library

MultiDrillDown Method

Description

Gets detailed information about a graph area consisting of four sets of coordinates.

Syntax

Public Function MultiDrillDown( _
   ByVal Areas As Variant _
) As List

Parameters

Areas
The area of the graph to retrieve, based on its data grid view.

Return Type

A list of objects representing the data in the specified cell of the graph. For example, in a defect graph, DrillDown returns a list of Bug objects.

Remarks

Areas is a two-dimensional variant array representing a list of rectangular areas in data grid. The first array dimension size must be 4.
Such an array can be logically modeled as a table with four columns where each row represents one rectangular area. Each rectangular area is a set of four coordinates: TopLeftColNum, TopLeftRowNum, BottomRightColNum, and BottomRightRowNum.

See Also

Graph Object


%%PageItemTitle%%

Graph Object

ColCount Property

Description

The number of columns.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ColCount() As Long

See Also

Graph Object


%%PageItemTitle%%

Graph Object

Col
The column number (zero-based).
See Also OTA COM Type Library

ColName Property

Description

Gets the name of the specified column. Column numbers are zero-based.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ColName( _
   ByVal Col As Long _
) As String

Parameters

Col
The column number (zero-based).

See Also

Graph Object


%%PageItemTitle%%

Graph Object

Col
The column number (zero-based).
See Also OTA COM Type Library

ColTotal Property

Description

The sum of the values in the specified graph data column. The column number is zero-based.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ColTotal( _
   ByVal Col As Long _
) As Long

Parameters

Col
The column number (zero-based).

See Also

Graph Object


%%PageItemTitle%%

Graph Object

Col
The column number (zero-based).
Row
The row number (zero-based).
See Also OTA COM Type Library

Data Property

Description

The data in the specified cell. Column and Row numbers are zero-based.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Data( _
   ByVal Col As Long, _
   ByVal Row As Long _
) As Long

Parameters

Col
The column number (zero-based).
Row
The row number (zero-based).

See Also

Graph Object


%%PageItemTitle%%

Graph Object

GraphTotal Property

Description

The total number of items represented in the graph.

Property type

Read-only property

Syntax (Visual Basic)

Public Property GraphTotal() As Long

See Also

Graph Object


%%PageItemTitle%%

Graph Object

MaxValue Property

Description

The maximum value in the graph.

Property type

Read-only property

Syntax (Visual Basic)

Public Property MaxValue() As Long

See Also

Graph Object


%%PageItemTitle%%

Graph Object

RowCount Property

Description

The number of rows.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RowCount() As Long

See Also

Graph Object


%%PageItemTitle%%

Graph Object

Row
The row number (zero-based).
See Also OTA COM Type Library

RowName Property

Description

Gets the row name of the specified row. Row numbers are zero-based.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RowName( _
   ByVal Row As Long _
) As String

Parameters

Row
The row number (zero-based).

See Also

Graph Object


%%PageItemTitle%%

Graph Object

Row
The row number (zero-based).
See Also OTA COM Type Library

RowTotal Property

Description

The sum of the values in the specified graph data row. The row number is zero-based.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RowTotal( _
   ByVal Row As Long _
) As Long

Parameters

Row
The row number (zero-based).

See Also

Graph Object


%%PageItemTitle%%

Graph Object

StartDate Property

Description

The start date for the graph.

Property type

Read-only property

Syntax (Visual Basic)

Public Property StartDate() As Date

See Also

Graph Object


%%PageItemTitle%%

GraphBuilder Members

GraphBuilder Object

Description

Services for creating graphs.

Remarks

The GraphBuilder for the connection is TDConnection.GraphBuilder.

Public Methods

Public Method BuildGraph | Build the graph.
Public Method BuildMultipleGraphs | Build several graphs.
Public Method CreateGraphDefinition | Create an IGraphDefinition object.


%%PageItemTitle%%

GraphBuilder Object

pGraphDef
A GraphDefinition Object.
See Also OTA COM Type Library

BuildGraph Method

Description

Build the graph.

Syntax

Public Function BuildGraph( _
   ByVal pGraphDef As Object _
) As Object

Parameters

pGraphDef
A GraphDefinition Object.

Return Type

A Graph Object.

See Also

GraphBuilder Object


%%PageItemTitle%%

GraphBuilder Object

GraphDefs
A Variant array of GraphDefinition Objects.
See Also OTA COM Type Library

BuildMultipleGraphs Method

Description

Build several graphs.

Syntax

Public Function BuildMultipleGraphs( _
   ByVal GraphDefs As Variant _
) As List

Parameters

GraphDefs
A Variant array of GraphDefinition Objects.

Return Type

A list of Graph Objects.

See Also

GraphBuilder Object


%%PageItemTitle%%

GraphBuilder Object

Module
A value of the tagTDAPI_MODULE Enumeration.
GraphType
A value of the tagTDAPI_GRAPH_TYPE Enumeration.
See Also OTA COM Type Library

CreateGraphDefinition Method

Description

Create an IGraphDefinition object.

Syntax

Public Function CreateGraphDefinition( _
   ByVal Module As Long, _
   ByVal GraphType As Long _
) As Object

Parameters

Module
A value of the tagTDAPI_MODULE Enumeration.
GraphType
A value of the tagTDAPI_GRAPH_TYPE Enumeration.

Return Type

A GraphDefinition Object.

See Also

GraphBuilder Object


%%PageItemTitle%%

GraphDefinition Members

GraphDefinition Object

Description

Configuration information used to build a graph.

Remarks

Get a GraphDefinition object from GraphBuilder.BuildMultipleGraphs.

Public Properties

Public Property Filter | The filter sets the criteria for which data are included in the graph.
Public Property Module | The module specified when the graph definition was created.
Public Property Property | The value of the specified property.
Public Property Type | The graph type


%%PageItemTitle%%

GraphDefinition Object

Filter Property

Description

The filter sets the criteria for which data are included in the graph.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

GraphDefinition Object


%%PageItemTitle%%

GraphDefinition Object

Module Property

Description

The module specified when the graph definition was created.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Module() As Long

See Also

GraphDefinition Object


%%PageItemTitle%%

GraphDefinition Object

Prop
A value of the tagGRAPH_PROPERTIES Enumeration.
See Also OTA COM Type Library

Property Property

Description

The value of the specified property.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Property( _
   ByVal Prop As Long _
) As Variant

Parameters

Prop
A value of the tagGRAPH_PROPERTIES Enumeration.

See Also

GraphDefinition Object


%%PageItemTitle%%

GraphDefinition Object

Type Property

Description

The graph type

Property type

Read-only property

Syntax (Visual Basic)

Public Property Type() As Long

See Also

GraphDefinition Object


%%PageItemTitle%%

HierarchyFilter Members

HierarchyFilter Object

Description

Services for creation of a filtered list of field objects without SQL.

Remarks

Get a TDFilter from the Filter property of any factory object except ReqFactory or from History.Filter.

A HierarchyFilter is a filter that can return the parents of items as well as the items themselves. Get a HierarchyFilter with ReqFactory.Filter.

A filter cannot handle OR conditions between different fields nor sort on a user-defined field.

A filter always has a primary filter on an entity and may also have a secondary filter, or XFilter, on a second entity. A filter without an XFilter specifies a list of the objects that meet all the criteria specified by setting the TDFilter.Filter or HierarchyFilter.Filter. A filter may have several Filter properties defined.

A filter with an XFilter specifies a list of all the objects of the first type that meet the Filter criteria, and that are associated with the objects of the second type that meet the criteria in the XFilter text. The XFilter text is set with the SetXFilter method or by setting the XFilter property .

For example, a TEST-TESTSET XFilter is a TDfilter derived from a Test factory. The first clause is created by setting the Filter to specify the desired tests. The XFilter is created by getting a second TDFilter from a TestSetFactory and setting the Filter property to specify the desired test sets. The text of this test set TDFilter is the XFilter text of primary test TDFilter.

The result is a list of tests that meet the TDFilter.Filter criteria and are associated with at least one of the test sets that meet the TDFilter.XFilter criteria.

The association between the entities can be direct, as in a links between requirements and defects, or it can be indirect. For example, TSTEST-REQ selects test instances (TSTEST) based on design tests (TEST) that cover requirements.

Example

Getting a filtered, sorted list of requirements | Getting a hierarchical list of requirements

Public Methods

Public Method Clear | Clears the current filter.
Public Method GetXFilter | Gets the cross filter specified by CrossEntities.
Public Method IsClear | Checks whether the filter is clear, including cross-filter settings
Public Method NewList | Creates a new list from current filter.
Public Method Refresh | Reads saved data and refreshes the fetched list according to the current filter, overwriting values in memory.
Public Method SetXFilter | Sets the filter for second entity, called a cross filter.

Public Properties

Public Property CaseSensitive | Indicates if the filter for the specified field is case sensitive. The default is False.
Public Property DataType | The filtered entity type.
Public Property Fields | The list of fields for the TDFilter's parent object.
Public Property Filter | The filter condition for the field specified by the FieldName.
Public Property KeepHierarchical | Indicates whether to include parent objects in list.
Public Property Order | The position of the specified field in the list of the sort fields. (zero-based)
Public Property OrderDirection | The sort order: TDOLE_ASCENDING or TDOLE_DESCENDING
Public Property Text | The full fields filter as text.
Public Property XFilter | The cross filter according to the entity type.


%%PageItemTitle%%

HierarchyFilter Object

Clear Method

Description

Clears the current filter.

Syntax

Public Sub Clear()

See Also

HierarchyFilter Object


%%PageItemTitle%%

HierarchyFilter Object

CrossEntities

Possible values: BUG-ALERT, BUG-REQ, BUG-TEST, BUG-TESTSET, REQ-ALERT, REQ-BUG, REQ-TEST, REQ-TO-FROM-REQ, RUN-BUG, TEST-ALERT, TEST-BUG, TEST-INSTANCE-ALERT, TEST-REQ, TEST-TESTSET, TEST-VER_CTRL, TESTCYCL-ALERT,
TESTSET-BUG, TESTSET-TEST, TSTEST-BUG, TSTEST-REQ, TSTEST-TEST-TEQ, and TSTEST-TSTEST-REQ.

Inclusive

Output variable.

If True, the filter specifies the set of objects where the conditions for the first entity and for the second entity are all true.

If False, the filter specifies the set of objects where the conditions for the first entity are true and the conditions for the second entity are not true.

See Also OTA COM Type Library

GetXFilter Method

Description

Gets the cross filter specified by CrossEntities.

Syntax

Public Function GetXFilter( _
   ByVal CrossEntities As String, _
   ByRef Inclusive As Boolean _
) As String

Parameters

CrossEntities

Possible values: BUG-ALERT, BUG-REQ, BUG-TEST, BUG-TESTSET, REQ-ALERT, REQ-BUG, REQ-TEST, REQ-TO-FROM-REQ, RUN-BUG, TEST-ALERT, TEST-BUG, TEST-INSTANCE-ALERT, TEST-REQ, TEST-TESTSET, TEST-VER_CTRL, TESTCYCL-ALERT,
TESTSET-BUG, TESTSET-TEST, TSTEST-BUG, TSTEST-REQ, TSTEST-TEST-TEQ, and TSTEST-TSTEST-REQ.

Inclusive

Output variable.

If True, the filter specifies the set of objects where the conditions for the first entity and for the second entity are all true.

If False, the filter specifies the set of objects where the conditions for the first entity are true and the conditions for the second entity are not true.

Return Type

The text representation of the filter.

See Also

HierarchyFilter Object


%%PageItemTitle%%

HierarchyFilter Object

IsClear Method

Description

Checks whether the filter is clear, including cross-filter settings

Syntax

Public Function IsClear() As Boolean

See Also

HierarchyFilter Object


%%PageItemTitle%%

HierarchyFilter Object

NewList Method

Description

Creates a new list from current filter.

Syntax

Public Function NewList() As List

Return Type

If KeepHierarchical is true, NewList returns a HierarchySupportList, retaining the parents of the items that meet the filter criteria as well as the items themselves.

If KeepHierarchical is False, NewList returns a FactoryList Object.

See Also

HierarchyFilter Object


%%PageItemTitle%%

HierarchyFilter Object

Refresh Method

Description

Reads saved data and refreshes the fetched list according to the current filter, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

HierarchyFilter Object


%%PageItemTitle%%

HierarchyFilter Object

CrossEntities

Possible values: BUG-ALERT, BUG-REQ, BUG-TEST, BUG-TESTSET, REQ-ALERT, REQ-BUG, REQ-TEST, REQ-TO-FROM-REQ, RUN-BUG, TEST-ALERT, TEST-BUG, TEST-INSTANCE-ALERT, TEST-REQ, TEST-TESTSET, TEST-VER_CTRL, TESTCYCL-ALERT,
TESTSET-BUG, TESTSET-TEST, TSTEST-BUG, TSTEST-REQ, TSTEST-TEST-TEQ, and TSTEST-TSTEST-REQ.

Inclusive

If True, the filter specifies the set of objects where the conditions for the first entity and for the second entity are all true.

If False, the filter specifies the set of objects where the conditions for the first entity are true and the conditions for the second entity are not true.

FilterText

A TDFilter.Text or a string that would be a valid TDFilter.Text

See Also OTA COM Type Library

SetXFilter Method

Description

Sets the filter for second entity, called a cross filter.

Syntax

Public Sub SetXFilter( _
   ByVal CrossEntities As String, _
   ByVal Inclusive As Boolean, _
   ByVal FilterText As String _
)

Parameters

CrossEntities

Possible values: BUG-ALERT, BUG-REQ, BUG-TEST, BUG-TESTSET, REQ-ALERT, REQ-BUG, REQ-TEST, REQ-TO-FROM-REQ, RUN-BUG, TEST-ALERT, TEST-BUG, TEST-INSTANCE-ALERT, TEST-REQ, TEST-TESTSET, TEST-VER_CTRL, TESTCYCL-ALERT,
TESTSET-BUG, TESTSET-TEST, TSTEST-BUG, TSTEST-REQ, TSTEST-TEST-TEQ, and TSTEST-TSTEST-REQ.

Inclusive

If True, the filter specifies the set of objects where the conditions for the first entity and for the second entity are all true.

If False, the filter specifies the set of objects where the conditions for the first entity are true and the conditions for the second entity are not true.

FilterText

A TDFilter.Text or a string that would be a valid TDFilter.Text

Remarks

The best way to ensure that the Filter text is valid, is to create a TDFilter with the cross-filter conditions, and use its Text property as this value.

See Also

HierarchyFilter Object


%%PageItemTitle%%

HierarchyFilter Object

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

CaseSensitive Property

Description

Indicates if the filter for the specified field is case sensitive. The default is False.

Property type

Read-write property

Syntax (Visual Basic)

Public Property CaseSensitive( _
   ByVal FieldName As String _
) As Boolean

Parameters

FieldName

The name of the field in the project database.

See Also

HierarchyFilter Object


%%PageItemTitle%%

HierarchyFilter Object

DataType Property

Description

The filtered entity type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DataType() As String

See Also

HierarchyFilter Object


%%PageItemTitle%%

HierarchyFilter Object

Fields Property

Description

The list of fields for the TDFilter's parent object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

Remarks

The list depends on the factory from which the TDFilter was created. For example, if the filter is created from a TestFactory, the field list will consist of the names of the Test fields: TS_ATTACHMENT, TS_CREATION_DATE, TS_DESCRIPTION, TS_RESPONSIBLE, TS_STATUS, TS_SUBJECT, TS_TEMPLATE, TS_TEST_ID, TS_NAME, and so on.

See Also

HierarchyFilter Object


%%PageItemTitle%%

HierarchyFilter Object

FieldName

The name of a field of the entity to which the filter is applied.

Only fields whose FieldProperty.IsCanFilter Property is true can be used.

See Also OTA COM Type Library

Filter Property

Description

The filter condition for the field specified by the FieldName.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Filter( _
   ByVal FieldName As String _
) As String

Parameters

FieldName

The name of a field of the entity to which the filter is applied.

Only fields whose FieldProperty.IsCanFilter Property is true can be used.

Remarks

Although the Filter property has the syntax of a single property, a TDFilter can have a collection of Filter properties, each on a different field. Set the Filter property for one field with each command.

A Filter setting is a value of the field, a value with an operator, or a set of values connected by operators.

The values can be constants, special tokens such as "[Today]", "[PreviousWeek]", or "[NextYear]", or folder names, such as "^Subject\LinkFolder^". Use the set filter dialog in the the relevant module of the Quality Center UI to explore the possibilities.

String values with spaces must be quoted, for example, TestFilter.Filter("TS_EXEC_STATUS") = """No Run"""

The value can be an expression with a wild card. For example, testsetFilter.Filter("CY_CYCLE") = "GS*" filters for all test sets whose names begin with "GS".

See Also

HierarchyFilter Object

Example

Getting a filtered, sorted list of requirements


%%PageItemTitle%%

HierarchyFilter Object

KeepHierarchical Property

Description

Indicates whether to include parent objects in list.

Property type

Read-write property

Syntax (Visual Basic)

Public Property KeepHierarchical() As Boolean

See Also

HierarchyFilter Object


%%PageItemTitle%%

HierarchyFilter Object

FieldName

The name of the database field whose sort priority is to be retrieved or set.

See Also OTA COM Type Library

Order Property

Description

The position of the specified field in the list of the sort fields. (zero-based)

Property type

Read-write property

Syntax (Visual Basic)

Public Property Order( _
   ByVal FieldName As String _
) As Long

Parameters

FieldName

The name of the database field whose sort priority is to be retrieved or set.

Remarks

When the order of one field is set with this property, no adjustments are made to the positions of other fields. The application is responsible for ensuring that the orders of all the fields are as required, that no two fields occupy the same position, and there are no empty positions.

When two or more fields are assigned the same order, the actual order is undetermined.

See Also

HierarchyFilter Object

Example

Getting a filtered, sorted list of requirements


%%PageItemTitle%%

HierarchyFilter Object

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

OrderDirection Property

Description

The sort order: TDOLE_ASCENDING or TDOLE_DESCENDING

Property type

Read-write property

Syntax (Visual Basic)

Public Property OrderDirection( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName

The name of the field in the project database.

See Also

HierarchyFilter Object


%%PageItemTitle%%

HierarchyFilter Object

Text Property

Description

The full fields filter as text.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Text() As String

Remarks

In most places where a string-type Filter argument is passed to a method that selects items, for example to create a filtered list, it is this Text property that is passed to the method.

This text is displayed in the Quality Center user interface above the grid when a filter is set.

See Also

HierarchyFilter Object


%%PageItemTitle%%

HierarchyFilter Object

CrossEntity

Possible values: BUG-ALERT, BUG-REQ, BUG-TEST, BUG-TESTSET, REQ-ALERT, REQ-BUG, REQ-TEST, REQ-TO-FROM-REQ, RUN-BUG, TEST-ALERT, TEST-BUG, TEST-INSTANCE-ALERT, TEST-REQ, TEST-TESTSET, TEST-VER_CTRL, TESTCYCL-ALERT,
TESTSET-BUG, TESTSET-TEST, TSTEST-BUG, TSTEST-REQ, TSTEST-TEST-TEQ, and TSTEST-TSTEST-REQ.

See Also OTA COM Type Library

XFilter Property

Description

The cross filter according to the entity type.

Property type

Read-write property

Syntax (Visual Basic)

Public Property XFilter( _
   ByVal CrossEntity As String _
) As String

Parameters

CrossEntity

Possible values: BUG-ALERT, BUG-REQ, BUG-TEST, BUG-TESTSET, REQ-ALERT, REQ-BUG, REQ-TEST, REQ-TO-FROM-REQ, RUN-BUG, TEST-ALERT, TEST-BUG, TEST-INSTANCE-ALERT, TEST-REQ, TEST-TESTSET, TEST-VER_CTRL, TESTCYCL-ALERT,
TESTSET-BUG, TESTSET-TEST, TSTEST-BUG, TSTEST-REQ, TSTEST-TEST-TEQ, and TSTEST-TSTEST-REQ.

Remarks

Setting this property is equivalent to calling SetXFilter with Inclusive = TRUE.

See Also

HierarchyFilter Object


%%PageItemTitle%%

HierarchySupportList Members

HierarchySupportList Collection

Description

Services to create and maintains lists of items and their parent objects.

Remarks

Get a HierarchySupportList from HierarchyFilter.NewList. HierarchySupportList is returned if HierarchyFilter.KeepHierarchical is true. Otherwise a FactoryList is returned.

In addition to the the items that would be included in the FactoryList, the HierarchySupportList includes the parent objects of those items.

Get a FactoryList from Bug.FindSimilarBugs or HierarchyFilter.NewList.

List objects are returned by the NewList method of factory objects and by many other methods and properties.

List numbering begins at one, for example, myList.Item(1).

Example

Getting a hierarchical list of requirements

Public Methods

Public Method Add | Adds a new item to the current list object.
Public Method IndexOfItem | Gets the index of the passed object.
Public Method Insert | Inserts a new item at the specified position.
Public Method Post | Posts changed data for all items in list.
Public Method Refresh | Reads saved list filter and data for all listed objects, overwriting values in memory.
Public Method Remove | Removes the specified item from the current list object.
Public Method Swap | Swaps the two list items specified by their positions.

Public Properties

Public Property _NewEnum | Gets an IEnumVARIANT enumerator. For information on the IEnumVARIANT, see Microsoft documentation.
Public Property Count | The number of items in the list.
Public Property Fields | Gets a list of fields available through this factory.
Public Property IsInFilter | Checks if the item matches the filter criteria of the list to which it belongs.
Public Property Item | Gets an item by index. The index is one-based.
Public Property Ratio | The similarity ratio for the specified item.


%%PageItemTitle%%

HierarchySupportList Collection

vNew

A value or object reference to be added to the list.

See Also OTA COM Type Library

Add Method

Description

Adds a new item to the current list object.

Syntax

Public Sub Add( _
   ByVal vNew As Variant _
)

Parameters

vNew

A value or object reference to be added to the list.

See Also

HierarchySupportList Collection


%%PageItemTitle%%

HierarchySupportList Collection

Item

A reference to one of the objects in the list.

See Also OTA COM Type Library

IndexOfItem Method

Description

Gets the index of the passed object.

Syntax

Public Function IndexOfItem( _
   ByVal Item As Variant _
) As Long

Parameters

Item

A reference to one of the objects in the list.

See Also

HierarchySupportList Collection


%%PageItemTitle%%

HierarchySupportList Collection

Pos

The position into which to insert the item.

vNew

A value or object reference to be inserted in the list.

See Also OTA COM Type Library

Insert Method

Description

Inserts a new item at the specified position.

Syntax

Public Sub Insert( _
   ByVal Pos As Long, _
   ByVal vNew As Variant _
)

Parameters

Pos

The position into which to insert the item.

vNew

A value or object reference to be inserted in the list.

See Also

HierarchySupportList Collection


%%PageItemTitle%%

HierarchySupportList Collection

Post Method

Description

Posts changed data for all items in list.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

HierarchySupportList Collection


%%PageItemTitle%%

HierarchySupportList Collection

Refresh Method

Description

Reads saved list filter and data for all listed objects, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

HierarchySupportList Collection


%%PageItemTitle%%

HierarchySupportList Collection

Index

The position in the list of the item to be removed.

See Also OTA COM Type Library

Remove Method

Description

Removes the specified item from the current list object.

Syntax

Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index

The position in the list of the item to be removed.

See Also

HierarchySupportList Collection


%%PageItemTitle%%

HierarchySupportList Collection

Pos1

Put the item in this position in position Pos2.

Pos2

Put the item in this position in position Pos1.

See Also OTA COM Type Library

Swap Method

Description

Swaps the two list items specified by their positions.

Syntax

Public Sub Swap( _
   ByVal Pos1 As Long, _
   ByVal Pos2 As Long _
)

Parameters

Pos1

Put the item in this position in position Pos2.

Pos2

Put the item in this position in position Pos1.

See Also

HierarchySupportList Collection


%%PageItemTitle%%

HierarchySupportList Collection

_NewEnum Property

Description

Gets an IEnumVARIANT enumerator. For information on the IEnumVARIANT, see Microsoft documentation.

Property type

Read-only property

Syntax (Visual Basic)

Public Property _NewEnum() As Unknown

See Also

HierarchySupportList Collection


%%PageItemTitle%%

HierarchySupportList Collection

Count Property

Description

The number of items in the list.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

HierarchySupportList Collection


%%PageItemTitle%%

HierarchySupportList Collection

Fields Property

Description

Gets a list of fields available through this factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

HierarchySupportList Collection


%%PageItemTitle%%

HierarchySupportList Collection

Index
The position in the list.
See Also OTA COM Type Library

IsInFilter Property

Description

Checks if the item matches the filter criteria of the list to which it belongs.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsInFilter( _
   ByVal Index As Long _
) As Boolean

Parameters

Index
The position in the list.

Remarks

An item may be in a HierarchySupportList even though it does not meet the filter criteria if it is the parent of an item that does meet the criteria.

See Also

HierarchySupportList Collection


%%PageItemTitle%%

HierarchySupportList Collection

Index

The index is 1 to Count.

See Also OTA COM Type Library

Item Property

Description

Gets an item by index. The index is one-based.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal Index As Long _
) As Variant

Parameters

Index

The index is 1 to Count.

See Also

HierarchySupportList Collection


%%PageItemTitle%%

HierarchySupportList Collection

Index

Index is 1 to Count.

See Also OTA COM Type Library

Ratio Property

Description

The similarity ratio for the specified item.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Ratio( _
   ByVal Index As Long _
) As Long

Parameters

Index

Index is 1 to Count.

Remarks

The Ratio method is meaningful when the list is acquired as a result of call to FindSimilarBug, otherwise it returns 0 (in VB) and an HRESULT of S_FALSE.

See Also

HierarchySupportList Collection


%%PageItemTitle%%

History Members

History Object

Description

Enables retrieval of a list of history records.

Remarks

Get a History object from the History property of any factory object that implements IBaseFactory, IBaseFactoryEx , or IBaseFieldEx.

You can also get a History object from entities that have a History property, such as Bug.History. For a complete list of objects with a History property, see History Property in the index.

Public Methods

Public Method ClearHistory | Clears the history records selected by the filter.
Public Method NewList | Gets filtered list of history data records.

Public Properties

Public Property Filter The filter object for the history item.


%%PageItemTitle%%

History Object

Filter
A TDFilter.Text that defines which history records will be deleted.
See Also OTA COM Type Library

ClearHistory Method

Description

Clears the history records selected by the filter.

Syntax

Public Sub ClearHistory( _
   Optional ByVal Filter As String = "" _
)

Parameters

Filter
A TDFilter.Text that defines which history records will be deleted.

See Also

History Object


%%PageItemTitle%%

History Object

Filter

A string containing one of the following:

  • Any field name. Get all history records for the current object in which the specified field was changed. The format for the string is [FieldName]<name>, for example, [FieldName]BG_STATUS.
  • An empty string. Get all history records for the current object.
See Also OTA COM Type Library

NewList Method

Description

Gets filtered list of history data records.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A string containing one of the following:

  • Any field name. Get all history records for the current object in which the specified field was changed. The format for the string is [FieldName]<name>, for example, [FieldName]BG_STATUS.
  • An empty string. Get all history records for the current object.

Return Type

A list of all HistoryRecord objects that match the search criteria. The list index is 1-based.

See Also

History Object


%%PageItemTitle%%

History Object

Filter Property

Description

The filter object for the history item.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

History Object


%%PageItemTitle%%

HistoryRecord Members

HistoryRecord Object

Description

Represents a single change.

Remarks

History record objects are the items in the list returned by History.NewList.

Public Properties

Public Property ChangeDate | The change date according to database server.
Public Property Changer | The name of the user who made the change.
Public Property FieldName | The name of the changed field.
Public Property ItemKey | The item key for the changed item.
Public Property NewValue | The value after the change.
Public Property OldValue | The value before the change.


%%PageItemTitle%%

HistoryRecord Object

ChangeDate Property

Description

The change date according to database server.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ChangeDate() As Date

See Also

HistoryRecord Object


%%PageItemTitle%%

HistoryRecord Object

Changer Property

Description

The name of the user who made the change.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Changer() As String

See Also

HistoryRecord Object


%%PageItemTitle%%

HistoryRecord Object

FieldName Property

Description

The name of the changed field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FieldName() As String

See Also

HistoryRecord Object


%%PageItemTitle%%

HistoryRecord Object

ItemKey Property

Description

The item key for the changed item.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ItemKey() As Variant

See Also

HistoryRecord Object


%%PageItemTitle%%

HistoryRecord Object

NewValue Property

Description

The value after the change.

Property type

Read-only property

Syntax (Visual Basic)

Public Property NewValue() As Variant

See Also

HistoryRecord Object


%%PageItemTitle%%

HistoryRecord Object

OldValue Property

Description

The value before the change.

Property type

Read-only property

Syntax (Visual Basic)

Public Property OldValue() As Variant

See Also

HistoryRecord Object


%%PageItemTitle%%

Host Members

Host Object

Description

Represents a single host server.

Remarks

Get a Host object from the HostFactory.

Interfaces

IBaseField2 | IBaseField3

Example

Getting and setting Host properties

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Description | A description of the host server.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The name of the host server.
Public Property RexServer | The remote execution server name as it appears on the LAN.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

Host Object

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Host Object


%%PageItemTitle%%

Host Object

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Host Object


%%PageItemTitle%%

Host Object

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Host Object


%%PageItemTitle%%

Host Object

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

Host Object


%%PageItemTitle%%

Host Object

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

Host Object


%%PageItemTitle%%

Host Object

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

Host Object


%%PageItemTitle%%

Host Object

Description Property

Description

A description of the host server.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Description() As String

See Also

Host Object


%%PageItemTitle%%

Host Object

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName

The name of the field in the project database.

See Also

Host Object


%%PageItemTitle%%

Host Object

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

Host Object


%%PageItemTitle%%

Host Object

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

Host Object


%%PageItemTitle%%

Host Object

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

Host Object


%%PageItemTitle%%

Host Object

Name Property

Description

The name of the host server.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name() As String

See Also

Host Object


%%PageItemTitle%%

Host Object

RexServer Property

Description

The remote execution server name as it appears on the LAN.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RexServer() As String

See Also

Host Object


%%PageItemTitle%%

Host Object

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

Host Object


%%PageItemTitle%% $$Members$$

Host Object

IBaseField3 Implemented Interface Members

Methods

Public Implemented Method Post Writes all changed values to database.

See Also

Host Object


%%PageItemTitle%%

Host Object | IBaseField3 Implemented Interface

UndoOnFailure
See Also OTA COM Type Library

Post Implemented Method

Description

Writes all changed values to database.

Syntax

Public Sub Post( _
   Optional ByVal UndoOnFailure As Boolean = True _
)

Parameters

UndoOnFailure

See Also

Host Object | IBaseField3 Implemented Interface


%%PageItemTitle%%

HostFactory Members

HostFactory Object

Description

Services for managing host servers definitions.

Remarks

The HostFactory for the connection is TDConnection.HostFactory.

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Interfaces

IBaseFactory2 | ISupportCopyPaste2

Example

Getting a reference to an implemented interface

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

HostFactory Object

ItemData
There are two options for ItemData:
  • Null. Creating a virtual object with Null ensures that you cannot then Post until all required fields are initialized.
  • An array consisting of the following elements:
    (0) Name - The name of the host (string, required).

    (1) Desc - A description of the host (string, optional).

    (2) Server - The host remote execution server as it appears on the LAN (string, optional).

    See Also OTA COM Type Library

    AddItem Method

    Description

    Creates a new item object.

    Syntax

    Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

    Parameters

    ItemData
    There are two options for ItemData:
    • Null. Creating a virtual object with Null ensures that you cannot then Post until all required fields are initialized.
    • An array consisting of the following elements:
      (0) Name - The name of the host (string, required).

      (1) Desc - A description of the host (string, optional).

      (2) Server - The host remote execution server as it appears on the LAN (string, optional).

      Remarks

      Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

      This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

      You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

      Example

      This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

      [Visual Basic]

      Dim bgf As BugFactory
      Dim bg As Bug
      Dim attf As AttachmentFactory
      Dim att As Attachment
      Dim attList As List

      ' Get the factory object
       Set bgf = tdc.BugFactory
      ' Use defect #1
       Set bg = bgf.Item(1)
       Set attf = bg.Attachments

      ' Creating a new attachment
      ' Create virtual object, then populate the properties
       Set att = attf.AddItem(Null)
       att.FileName = Text1.Text
       att.Type = TDATT_INTERNET

      ' Saving the object with validity check
       att.Post

      ' Display the attachments
      ' Add the display-only items without a Post
       List1.Clear
       Set attList = attf.NewList("")
       For i = 1 To attList.Count

            Set att = attList.Item(i)
            List1.AddItem (att.Name)

       Next

      See Also

      HostFactory Object


%%PageItemTitle%%

HostFactory Object

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

HostFactory Object


%%PageItemTitle%%

HostFactory Object

ItemKey
Either a Host Object, the host name, or a Variant Array of the names of the hosts to remove.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey
Either a Host Object, the host name, or a Variant Array of the names of the hosts to remove.

See Also

HostFactory Object


%%PageItemTitle%%

HostFactory Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

HostFactory Object


%%PageItemTitle%%

HostFactory Object

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

HostFactory Object


%%PageItemTitle%%

HostFactory Object

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

HostFactory Object


%%PageItemTitle%%

HostFactory Object

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

HostFactory Object


%%PageItemTitle%%

HostFactory Object

ItemKey
The name of the host.

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey
The name of the host.

See Also

HostFactory Object


%%PageItemTitle%%

HostGroup Members

HostGroup Object

Description

Services for managing a group of host servers.

Remarks

Get a HostGroup object from the HostGroupFactory.

Public Methods

Public Method AddHost | Adds a host to the group.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method NewList | Gets a list of all hosts in the group.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method RemoveHost | Removes the specified host from the group.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | Gets the host group name.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

HostGroup Object

Val

Either a Host Object, the host name, or a string array containing the names of the hosts to add.

See Also OTA COM Type Library

AddHost Method

Description

Adds a host to the group.

Syntax

Public Sub AddHost( _
   ByVal Val As Variant _
)

Parameters

Val

Either a Host Object, the host name, or a string array containing the names of the hosts to add.

See Also

HostGroup Object


%%PageItemTitle%%

HostGroup Object

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If the object is locked, no other user can change or delete it.

The object is unlocked on a Post or Refresh operation and when the connection is logged off the project.

See Also

HostGroup Object


%%PageItemTitle%%

HostGroup Object

NewList Method

Description

Gets a list of all hosts in the group.

Syntax

Public Function NewList() As List

See Also

HostGroup Object


%%PageItemTitle%%

HostGroup Object

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

HostGroup Object


%%PageItemTitle%%

HostGroup Object

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

HostGroup Object


%%PageItemTitle%%

HostGroup Object

Val

Either a Host Object, the host name, or a string array containing the names of the hosts to add.

See Also OTA COM Type Library

RemoveHost Method

Description

Removes the specified host from the group.

Syntax

Public Sub RemoveHost( _
   ByVal Val As Variant _
)

Parameters

Val

Either a Host Object, the host name, or a string array containing the names of the hosts to add.

See Also

HostGroup Object


%%PageItemTitle%%

HostGroup Object

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

HostGroup Object


%%PageItemTitle%%

HostGroup Object

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users.

See Also

HostGroup Object


%%PageItemTitle%%

HostGroup Object

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

HostGroup Object


%%PageItemTitle%%

HostGroup Object

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

HostGroup Object


%%PageItemTitle%%

HostGroup Object

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName

The name of the field in the project database.

See Also

HostGroup Object


%%PageItemTitle%%

HostGroup Object

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

HostGroup Object


%%PageItemTitle%%

HostGroup Object

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

HostGroup Object


%%PageItemTitle%%

HostGroup Object

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

HostGroup Object


%%PageItemTitle%%

HostGroup Object

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

HostGroup Object


%%PageItemTitle%%

HostGroup Object

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

HostGroup Object


%%PageItemTitle%%

HostGroup Object

Name Property

Description

Gets the host group name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name() As String

See Also

HostGroup Object


%%PageItemTitle%%

HostGroup Object

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

HostGroup Object


%%PageItemTitle%%

HostGroupFactory Members

HostGroupFactory Object

Description

Services for managing definitions of groups of host servers.

Remarks

The HostGroupFactory for the connection is TDConnection.HostGroupFactory.

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Interfaces

IBaseFactory2 | ISupportCopyPaste2

Example

Getting a reference to an implemented interface

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveHost | Removes host from all groups.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

HostGroupFactory Object

ItemData
The name of the group.

See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData
The name of the group.

Remarks

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

[Visual Basic]

Dim bgf As BugFactory
Dim bg As Bug
Dim attf As AttachmentFactory
Dim att As Attachment
Dim attList As List

' Get the factory object
 Set bgf = tdc.BugFactory
' Use defect #1
 Set bg = bgf.Item(1)
 Set attf = bg.Attachments

' Creating a new attachment
' Create virtual object, then populate the properties
 Set att = attf.AddItem(Null)
 att.FileName = Text1.Text
 att.Type = TDATT_INTERNET

' Saving the object with validity check
 att.Post

' Display the attachments
' Add the display-only items without a Post
 List1.Clear
 Set attList = attf.NewList("")
 For i = 1 To attList.Count

      Set att = attList.Item(i)
      List1.AddItem (att.Name)

 Next

See Also

HostGroupFactory Object


%%PageItemTitle%%

HostGroupFactory Object

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

HostGroupFactory Object


%%PageItemTitle%%

HostGroupFactory Object

Host
The name of the host.
See Also OTA COM Type Library

RemoveHost Method

Description

Removes host from all groups.

Syntax

Public Sub RemoveHost( _
   ByVal Host As Variant _
)

Parameters

Host
The name of the host.

See Also

HostGroupFactory Object


%%PageItemTitle%%

HostGroupFactory Object

ItemKey
Either a HostGroup Object, the host group name, or a Variant Array of the names of the host grops to remove.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey
Either a HostGroup Object, the host group name, or a Variant Array of the names of the host grops to remove.

See Also

HostGroupFactory Object


%%PageItemTitle%%

HostGroupFactory Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

HostGroupFactory Object


%%PageItemTitle%%

HostGroupFactory Object

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

HostGroupFactory Object


%%PageItemTitle%%

HostGroupFactory Object

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

HostGroupFactory Object


%%PageItemTitle%%

HostGroupFactory Object

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

HostGroupFactory Object


%%PageItemTitle%%

HostGroupFactory Object

ItemKey
The name of the group.

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey
The name of the group.

See Also

HostGroupFactory Object


%%PageItemTitle%%

Link Members

Link Object

Description

Represents an association between a Bug and another entity.

Remarks

Get a Link object from a LinkFactory.

Interfaces

IBaseField2 | IBaseField3

Example

Getting a list of links from a Test Set | Displaying links | Creating various entities and linking them | Modify a link between defects | Removing a link between defects

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Comment | The link summary comment.
Public Property CreatedBy | The user who created the link.
Public Property CreationDate | The link creation date.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property LinkedByEntity | The entity that initiated the link.
Public Property LinkType | The link type.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property SourceEntity | The source entity object of the link.
Public Property TargetEntity | The target entity object of the link.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

Link Object

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Link Object


%%PageItemTitle%%

Link Object

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Link Object


%%PageItemTitle%%

Link Object

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Link Object


%%PageItemTitle%%

Link Object

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

Link Object


%%PageItemTitle%%

Link Object

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

Link Object


%%PageItemTitle%%

Link Object

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

Link Object


%%PageItemTitle%%

Link Object

Comment Property

Description

The link summary comment.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comment() As String

See Also

Link Object


%%PageItemTitle%%

Link Object

CreatedBy Property

Description

The user who created the link.

Property type

Read-write property

Syntax (Visual Basic)

Public Property CreatedBy() As String

See Also

Link Object


%%PageItemTitle%%

Link Object

CreationDate Property

Description

The link creation date.

Property type

Read-write property

Syntax (Visual Basic)

Public Property CreationDate() As Date

See Also

Link Object


%%PageItemTitle%%

Link Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

Link Object


%%PageItemTitle%%

Link Object

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

Link Object


%%PageItemTitle%%

Link Object

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

Link Object


%%PageItemTitle%%

Link Object

LinkedByEntity Property

Description

The entity that initiated the link.

Property type

Read-only property

Syntax (Visual Basic)

Public Property LinkedByEntity() As Object

Remarks

With a Link from any entity other than a Bug to a Bug, the LinkedByEntity shows the entity that created the link. For example, a link between a Test and a Bug may have been created by a test instance, a run, or a step. Whichever object created the link between the Test and Bug will be the LinkedByEntity.

With a Link between two Bugs, this property has no meaning.

See Also

Link Object


%%PageItemTitle%%

Link Object

LinkType Property

Description

The link type.

Property type

Read-write property

Syntax (Visual Basic)

Public Property LinkType() As String

See Also

Link Object


%%PageItemTitle%%

Link Object

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

Link Object


%%PageItemTitle%%

Link Object

SourceEntity Property

Description

The source entity object of the link.

Property type

Read-only property

Syntax (Visual Basic)

Public Property SourceEntity() As Object

Remarks

SourceEntity and TargetEntity are not fixed attributes of an association. They reflect the point of view of the factory from which the Link Object is obtained. SourceEntity and TargetEntity will always be the same two objects for a given association. However, which is the source and which the target may change depending on the Link Object.

For example, when an association between a Test and a Bug is viewed from the Test side, that is, when the Link object is acquired from the BugLinkFactory of the Test, SourceEntity is the Test and TargetEntity is the Bug. If a Link object representing the same association is acquired from the LinkFactory of the Bug, SourceEntity is the Bug and TargetEntity is the Test.

See Also

Link Object


%%PageItemTitle%%

Link Object

TargetEntity Property

Description

The target entity object of the link.

Property type

Read-write property

Syntax (Visual Basic)

Public Property TargetEntity() As Object

Remarks

SourceEntity and TargetEntity are not fixed attributes of an association. They reflect the point of view of the factory from which the Link Object is obtained. SourceEntity and TargetEntity will always be the same two objects for a given association. However, which is the source and which the target may change depending on the Link Object.

For example, when an association between a Test and a Bug is viewed from the Test side, that is, when the Link object is acquired from the BugLinkFactory of the Test, SourceEntity is the Test and TargetEntity is the Bug. If a Link object representing the same association is acquired from the LinkFactory of the Bug, SourceEntity is the Bug and TargetEntity is the Test.

See Also

Link Object


%%PageItemTitle%%

Link Object

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

Link Object


%%PageItemTitle%% $$Members$$

Link Object

IBaseField3 Implemented Interface Members

Methods

Public Implemented Method Post Writes all changed values to database.

See Also

Link Object


%%PageItemTitle%%

Link Object | IBaseField3 Implemented Interface

UndoOnFailure
See Also OTA COM Type Library

Post Implemented Method

Description

Writes all changed values to database.

Syntax

Public Sub Post( _
   Optional ByVal UndoOnFailure As Boolean = True _
)

Parameters

UndoOnFailure

See Also

Link Object | IBaseField3 Implemented Interface


%%PageItemTitle%%

LinkFactory Members

LinkFactory Object

Description

Services to manage Link objects.

Remarks

Get a LinkFactory reference for creating lists, viewing properties, and adding and removing items from the BugLinkFactory Property property of the ILinkable implemented interface of any object that can be linked to a defect, such as Bug, Req, Run, Step, Test, TestSet, or TSTest.

Get a LinkFactory reference for creating lists and viewing properties from the LinkFactory Property of the ILinkable implemented interface of the Bug Object.

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Interfaces

IBaseFactory2

Example

Getting a list of links from a Test Set | Getting a reference to an implemented interface | Displaying links | Creating various entities and linking them | Creating links between defects

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property FullLinkage | Indicates that NewList returns child objects in addition to the current object.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

LinkFactory Object

ItemData

There are four options for ItemData:

  • The Bug.ID of the bug that will be the Link.TargetEntity of the link.
  • A Bug object.
  • An List of Bug.IDs that will all be targets.
  • Null. Initially creating a virtual object with Null ensures that you cannot then Post until all required fields are initialized.

See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData

There are four options for ItemData:

  • The Bug.ID of the bug that will be the Link.TargetEntity of the link.
  • A Bug object.
  • An List of Bug.IDs that will all be targets.
  • Null. Initially creating a virtual object with Null ensures that you cannot then Post until all required fields are initialized.

Return Type

A Link Object.

Remarks

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

[Visual Basic]

Dim bgf As BugFactory
Dim bg As Bug
Dim attf As AttachmentFactory
Dim att As Attachment
Dim attList As List

' Get the factory object
 Set bgf = tdc.BugFactory
' Use defect #1
 Set bg = bgf.Item(1)
 Set attf = bg.Attachments

' Creating a new attachment
' Create virtual object, then populate the properties
 Set att = attf.AddItem(Null)
 att.FileName = Text1.Text
 att.Type = TDATT_INTERNET

' Saving the object with validity check
 att.Post

' Display the attachments
' Add the display-only items without a Post
 List1.Clear
 Set attList = attf.NewList("")
 For i = 1 To attList.Count

      Set att = attList.Item(i)
      List1.AddItem (att.Name)

 Next

See Also

LinkFactory Object


%%PageItemTitle%%

LinkFactory Object

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

Remarks

For hierarchical lists, if FullLinkage is true, the returned list includes the child objects of the items that meet the filter criteria.

See Also

LinkFactory Object


%%PageItemTitle%%

LinkFactory Object

ItemKey
A Link.ID.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey
A Link.ID.

See Also

LinkFactory Object


%%PageItemTitle%%

LinkFactory Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

LinkFactory Object


%%PageItemTitle%%

LinkFactory Object

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

LinkFactory Object


%%PageItemTitle%%

LinkFactory Object

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

LinkFactory Object


%%PageItemTitle%%

LinkFactory Object

FullLinkage Property

Description

Indicates that NewList returns child objects in addition to the current object.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FullLinkage() As Boolean

Remarks

Meaningful only for hierarchical lists.

See Also

LinkFactory Object


%%PageItemTitle%%

LinkFactory Object

ItemKey
Summary
A Link.ID.

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey
Summary
A Link.ID.

See Also

LinkFactory Object


%%PageItemTitle%%

List Members

List Collection

Description

Create and maintain lists. Use any factory object to create any number of list instances for objects in the factory.

Remarks

List objects are returned by the NewList method of factory objects and by many other methods and properties.

List numbering begins at one, for example, myList.Item(1).

Public Methods

Public Method Add | Adds a new item to the current list object.
Public Method Insert | Inserts a new item at the specified position.
Public Method Remove | Removes the specified item from the current list object.
Public Method Swap | Swaps the two list items specified by their positions.

Public Properties

Public Property _NewEnum | Gets an IEnumVARIANT enumerator. For information on the IEnumVARIANT, see Microsoft documentation.
Public Property Count | The number of items in the list.
Public Property Item | Gets an item by index. The index is one-based.


%%PageItemTitle%%

List Collection

vNew
A value or object reference to be added to the list.
See Also OTA COM Type Library

Add Method

Description

Adds a new item to the current list object.

Syntax

Public Sub Add( _
   ByVal vNew As Variant _
)

Parameters

vNew
A value or object reference to be added to the list.

See Also

List Collection


%%PageItemTitle%%

List Collection

Pos
The position into which to insert the item.
vNew
A value or object reference to be inserted in the list.
See Also OTA COM Type Library

Insert Method

Description

Inserts a new item at the specified position.

Syntax

Public Sub Insert( _
   ByVal Pos As Long, _
   ByVal vNew As Variant _
)

Parameters

Pos
The position into which to insert the item.
vNew
A value or object reference to be inserted in the list.

See Also

List Collection


%%PageItemTitle%%

List Collection

Index
The position in the list of the item to be removed.
See Also OTA COM Type Library

Remove Method

Description

Removes the specified item from the current list object.

Syntax

Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
The position in the list of the item to be removed.

See Also

List Collection


%%PageItemTitle%%

List Collection

Pos1
Put the item in this position in position Pos2.
Pos2
Put the item in this position in position Pos1.
See Also OTA COM Type Library

Swap Method

Description

Swaps the two list items specified by their positions.

Syntax

Public Sub Swap( _
   ByVal Pos1 As Long, _
   ByVal Pos2 As Long _
)

Parameters

Pos1
Put the item in this position in position Pos2.
Pos2
Put the item in this position in position Pos1.

See Also

List Collection


%%PageItemTitle%%

List Collection

_NewEnum Property

Description

Gets an IEnumVARIANT enumerator. For information on the IEnumVARIANT, see Microsoft documentation.

Property type

Read-only property

Syntax (Visual Basic)

Public Property _NewEnum() As Unknown

See Also

List Collection


%%PageItemTitle%%

List Collection

Count Property

Description

The number of items in the list.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

List Collection

Example

Get Table Fields Count | Get Table Fields Count


%%PageItemTitle%%

List Collection

Index
The index is 1 to Count.
See Also OTA COM Type Library

Item Property

Description

Gets an item by index. The index is one-based.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal Index As Long _
) As Variant

Parameters

Index
The index is 1 to Count.

See Also

List Collection

Example

Get Table Fields first item


%%PageItemTitle%%

Module Members

Module Object

Description

Represents a Quality Center module, such as Requirements, Defects, TestPlan, and so on.

Remarks

Get a Module object from CustomizationModules.Module or from the list returned by CustomizationModules.Modules

Public Properties

Public Property Description | The module description.
Public Property GUID | The module GUID.
Public Property ID | The module ID.
Public Property Name | The module name.
Public Property NumericVisible | Updates visibility with numeric value for the specified user group.
Public Property Order | The module position in the framework sidebar.
Public Property Updated | Indicates if the object has been modified since being downloaded from database.
Public Property Visible | A bit-mask string that indicates for which groups the module is visible in the user interface.
Public Property VisibleForGroup | Updates visibility for the specified user group.


%%PageItemTitle%%

Module Object

Description Property

Description

The module description.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Description() As String

See Also

Module Object


%%PageItemTitle%%

Module Object

GUID Property

Description

The module GUID.

Property type

Read-write property

Syntax (Visual Basic)

Public Property GUID() As String

See Also

Module Object


%%PageItemTitle%%

Module Object

ID Property

Description

The module ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Long

See Also

Module Object


%%PageItemTitle%%

Module Object

Name Property

Description

The module name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

Module Object


%%PageItemTitle%%

Module Object

RHS
See Also OTA COM Type Library

NumericVisible Property

Description

Updates visibility with numeric value for the specified user group.

Property type

Write-only property

Syntax (Visual Basic)

Public Property NumericVisible( _
   ByVal RHS As Long _
) As Long

Parameters

RHS

See Also

Module Object


%%PageItemTitle%%

Module Object

Order Property

Description

The module position in the framework sidebar.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Order() As Long

See Also

Module Object


%%PageItemTitle%%

Module Object

Updated Property

Description

Indicates if the object has been modified since being downloaded from database.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Updated() As Boolean

See Also

Module Object


%%PageItemTitle%%

Module Object

Visible Property

Description

A bit-mask string that indicates for which groups the module is visible in the user interface.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Visible() As String

See Also

Module Object


%%PageItemTitle%%

Module Object

GroupId
RHS
See Also OTA COM Type Library

VisibleForGroup Property

Description

Updates visibility for the specified user group.

Property type

Write-only property

Syntax (Visual Basic)

Public Property VisibleForGroup( _
   ByVal GroupId As Long, _
   ByVal RHS As Boolean _
) As Boolean

Parameters

GroupId
RHS

See Also

Module Object


%%PageItemTitle%%

MultiValue Members

MultiValue Object

Description

Represents several values stored in a single field.

Remarks

The reference to a MultiValue object is the FieldMultiValue Property of the IBaseField2 Implemented Interface of the object.

Example

Accessing members of Additional Implemented Interfaces | Getting and assigning multiple values for a Bug record

Public Properties

Public Property List | List of values. Each item is the string representation of a single value.
Public Property Text | Text representation of values list. Items are separated with a semicolon.


%%PageItemTitle%%

MultiValue Object

List Property

Description

List of values. Each item is the string representation of a single value.

Property type

Read-write property

Syntax (Visual Basic)

Public Property List() As List

Remarks

After assigning values, use the MultiValue object to set the FieldMultiValue Property.

The values in the list are the same as those in Text Property, except they are presented as a list of individual strings rather than a single string.

See Also

MultiValue Object


%%PageItemTitle%%

MultiValue Object

Text Property

Description

Text representation of values list. Items are separated with a semicolon.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Text() As String

Remarks

After assigning values, use the MultiValue object to set the FieldMultiValue Property.

The value of Text is all the strings in the List Property, concatenated into a single string of semicolon-separated values.

See Also

MultiValue Object


%%PageItemTitle%%

ProductInfo Members

ProductInfo Object

Description

Information about the current version.

Remarks

Get a ProjectInfo reference from TDConnection.ProductInfo.

Public Properties

Public Property BPTVersion | The Business Process Test versions.
Public Property QCVersion | The build information for the installed version.


%%PageItemTitle%%

ProductInfo Object

BPTVersion Property

Description

The Business Process Test versions.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BPTVersion() As Long

See Also

ProductInfo Object


%%PageItemTitle%%

ProductInfo Object

pnMajorVersion
The release number.
pnMinorVersion
The intermediate release number.
See Also OTA COM Type Library

QCVersion Property

Description

The build information for the installed version.

Property type

Read-only property

Syntax (Visual Basic)

Public Property QCVersion( _
   ByRef pnMajorVersion As Long, _
   ByRef pnMinorVersion As Long _
) As Long

Parameters

pnMajorVersion
The release number.
pnMinorVersion
The intermediate release number.

See Also

ProductInfo Object


%%PageItemTitle%%

ProjectProperties Members

ProjectProperties Object

Description

Global project parameters and settings.

Remarks

The ProjectProperties for the connection is TDConnection.ProjectProperties.

Example

Print project properties

Public Properties

Public Property Count | The number of parameters in the project.
Public Property IsParam | Checks if a parameter of this name exists.
Public Property ParamName | Gets the parameter name.
Public Property ParamValue | The value of the parameter.


%%PageItemTitle%%

ProjectProperties Object

Count Property

Description

The number of parameters in the project.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

ProjectProperties Object


%%PageItemTitle%%

ProjectProperties Object

ParamName
The name of a project parameter
See Also OTA COM Type Library

IsParam Property

Description

Checks if a parameter of this name exists.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsParam( _
   ByVal ParamName As String _
) As Boolean

Parameters

ParamName
The name of a project parameter

See Also

ProjectProperties Object


%%PageItemTitle%%

ProjectProperties Object

ParamIndex
The index of the parameter in the list of project properties (zero-based).
See Also OTA COM Type Library

ParamName Property

Description

Gets the parameter name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ParamName( _
   ByVal ParamIndex As Long _
) As String

Parameters

ParamIndex
The index of the parameter in the list of project properties (zero-based).

See Also

ProjectProperties Object


%%PageItemTitle%%

ProjectProperties Object

vParam
Either the name of the parameter or the index of the parameter in the list of project properties (zero-based).
See Also OTA COM Type Library

ParamValue Property

Description

The value of the parameter.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ParamValue( _
   ByVal vParam As Variant _
) As String

Parameters

vParam
Either the name of the parameter or the index of the parameter in the list of project properties (zero-based).

See Also

ProjectProperties Object


%%PageItemTitle%%

ProjectRepository Members

ProjectRepository Object

Description

Represents the project repository when stored in the database. Not used if the repository is on the file system.

Remarks

There are three implementations of storage handlers: ExtendedStorage, ExtendedStorageProxy, and ProjectRepository. They all implement the IExtendedStorage Interface. The Open Test Architecture infrastructure returns the handler object appropriate to the configuration of the servers and project on which the application is run.

The use of the handlers in your application is the same regardless of the implementation. Declare variables as type IExtendedStorage. For examples, see IExtendedStorage Interface and its methods and properties.

Get a storage handler object from AttachmentFactory.AttachmentStorage, Run.ExtendedStorage, Attachment.AttachmentStorage, Test.ExtendedStorage, or TestFactory.RepositoryStorage.

Note that a storage handler object obtained from an object will not necessarily handle only items belonging to that object. For example, if you get a storage object from a test attachment and then download all attachments:

Set TestAttachmentFactoryObj = aTestObject.Attachments
Set TestAttachStorage = TestAttachmentFactoryObj.AttachmentStorage
AttachDownLoadPath = TestAttachStorage.LoadEx("*.*", True, NullList, isFatalErr)

The result is to download all attachments in the project.

To avoid this, either specify a filter or use other methods. In the above example, you could replace the ExtendedStorage load with Attachment.Load.

The storage handler is also accessible from TDConnection.ExtendedStorage, but a reference obtained this way is disabled by the default security settings.

Public Methods

Public Method Cancel | Cancels the load or save action.
Public Method Delete | Deletes files locally or from the server.
Public Method GetLastError | Gets the last error that occurred during asynchronous load and save operations.
Public Method Load | Downloads the storage structure to the client file system.
Public Method LoadEx | Downloads the storage structure to the client file system.
Public Method Progress | Polls the progress of the last action (Load or Save).
Public Method Save | Uploads the storage structure to the server.
Public Method SaveEx | Uploads the storage structure to the server.

Public Properties

Public Property ActionFinished | Checks if the load or save action is finished.
Public Property ClientPath | The location on the client to which to download or from which to upload.
Public Property Root | The storage root.
Public Property ServerPath | The location on the server from which to download or to which to upload.


%%PageItemTitle%%

ProjectRepository Object

Cancel Method

Description

Cancels the load or save action.

Syntax

Public Sub Cancel()

See Also

ProjectRepository Object


%%PageItemTitle%%

ProjectRepository Object

FSysFilter

A file system filter. If the filter begins with "-r", it is applied recursively to all sub-directories. If the filter is an empty string, all files with all subdirectories are downloaded to the client.

nDeleteType

The delete type, Local or remote. A member of the tagTDAPI_EXSTOR_DELMODE Enumeration .

See Also OTA COM Type Library

Delete Method

Description

Deletes files locally or from the server.

Syntax

Public Sub Delete( _
   ByVal FSysFilter As String, _
   ByVal nDeleteType As Long _
)

Parameters

FSysFilter

A file system filter. If the filter begins with "-r", it is applied recursively to all sub-directories. If the filter is an empty string, all files with all subdirectories are downloaded to the client.

nDeleteType

The delete type, Local or remote. A member of the tagTDAPI_EXSTOR_DELMODE Enumeration .

See Also

ProjectRepository Object


%%PageItemTitle%%

ProjectRepository Object

GetLastError Method

Description

Gets the last error that occurred during asynchronous load and save operations.

Syntax

Public Sub GetLastError()

Return Type

An HRESULT. The application-specific error is in the information code.

Remarks

Used for asynchronous operations where error handled can not be implemented.

For information on handling an HRESULT, see Microsoft documentation.

See Also

ProjectRepository Object


%%PageItemTitle%%

ProjectRepository Object

FSysFilter

A file system filter.

synchronize

If True, the download operation is synchronous.

See Also OTA COM Type Library

Load Method

Description

Downloads the storage structure to the client file system.

Syntax

Public Function Load( _
   Optional ByVal FSysFilter As String = "*.*", _
   Optional ByVal synchronize As Boolean = False _
) As String

Parameters

FSysFilter

A file system filter.

synchronize

If True, the download operation is synchronous.

Return Type

The path on the client machine to which the files were downloaded.

Remarks

If the filter is an empty string, all files with all subdirectories are uploaded to the server.

If a phrase in the filter begins with "-r", it is applied recursively to all sub-directories. If a phrase in the filter begins with -x, it indications exclusion.

For example, the filter "Austen.txt, -r Novels\*.* -x Emma.txt" returns the file Austen.txt and all files and folders under the Novels directory except Emma.txt.

If the operation is synchronous, the process begins and is not checked for status until the process is completed. If the operation is asynchronous, the Load method initiates the download immediately and continuously checks if the download is finished. Check the ActionFinished Property periodically, and use the GetLastError Method to see if the operation succeeded.

See Also

ProjectRepository Object


%%PageItemTitle%%

ProjectRepository Object

FSysFilter

A file system filter.

synchronize

If True, the download operation is synchronous.

pVal

NULL

pNonFatalErrorOccured

The error that occurred was non-fatal. This value is meaningful only for synchronous transfers.

See Also OTA COM Type Library

LoadEx Method

Description

Downloads the storage structure to the client file system.

Syntax

Public Function LoadEx( _
   ByVal FSysFilter As String, _
   ByVal synchronize As Boolean, _
   ByVal pVal As List, _
   ByRef pNonFatalErrorOccured As Boolean _
) As String

Parameters

FSysFilter

A file system filter.

synchronize

If True, the download operation is synchronous.

pVal

NULL

pNonFatalErrorOccured

The error that occurred was non-fatal. This value is meaningful only for synchronous transfers.

Return Type

The path on the client machine to which the files were downloaded.

Remarks

If the filter is an empty string, all files with all subdirectories are uploaded to the server.

If a phrase in the filter begins with "-r", it is applied recursively to all sub-directories. If a phrase in the filter begins with -x, it indications exclusion.

For example, the filter "Austen.txt, -r Novels\*.* -x Emma.txt" returns the file Austen.txt and all files and folders under the Novels directory except Emma.txt.

If the operation is synchronous, the process begins and is not checked for status until the process is completed. If the operation is asynchronous, the Load method initiates the download immediately and continuously checks if the download is finished. Check the ActionFinished Property periodically, and use the GetLastError Method to see if the operation succeeded.

See Also

ProjectRepository Object


%%PageItemTitle%%

ProjectRepository Object

Total

The total number of bytes to be transferred.

Current

The number of bytes transferred so far.

See Also OTA COM Type Library

Progress Method

Description

Polls the progress of the last action (Load or Save).

Syntax

Public Function Progress( _
   ByRef Total As Long, _
   ByRef Current As Long _
) As String

Parameters

Total

The total number of bytes to be transferred.

Current

The number of bytes transferred so far.

Return Type

Null

See Also

ProjectRepository Object


%%PageItemTitle%%

ProjectRepository Object

FSysFilter

A file system filter.

synchronize

If True, the upload operation is synchronous.

See Also OTA COM Type Library

Save Method

Description

Uploads the storage structure to the server.

Syntax

Public Sub Save( _
   Optional ByVal FSysFilter As String = "*.*", _
   Optional ByVal synchronize As Boolean = False _
)

Parameters

FSysFilter

A file system filter.

synchronize

If True, the upload operation is synchronous.

Remarks

If the filter is an empty string, all files with all subdirectories are uploaded to the server.

If a phrase in the filter begins with "-r", it is applied recursively to all sub-directories. If a phrase in the filter begins with -x, it indications exclusion.

For example, the filter "Austen.txt, -r Novels\*.* -x Emma.txt" returns the file Austen.txt and all files and folders under the Novels directory except Emma.txt.

If the operation is synchronous, the process begins and is not checked for status until the process is completed. If the operation is asynchronous, the function immediately begins the upload and continuously checks if the transfer is finished. Check the ActionFinished Property periodically, and use the GetLastError Method to see if the operation succeeded.

See Also

ProjectRepository Object


%%PageItemTitle%%

ProjectRepository Object

FSysFilter

A file system filter.

synchronize

If True, the upload operation is synchronous.

pVal

NULL

See Also OTA COM Type Library

SaveEx Method

Description

Uploads the storage structure to the server.

Syntax

Public Function SaveEx( _
   ByVal FSysFilter As String, _
   ByVal synchronize As Boolean, _
   ByVal pVal As List _
) As Boolean

Parameters

FSysFilter

A file system filter.

synchronize

If True, the upload operation is synchronous.

pVal

NULL

Return Type

The error that occurred was non-fatal (True or False). This value is meaningful only for synchronous transfers.

Remarks

If the filter is an empty string, all files with all subdirectories are uploaded to the server.

If a phrase in the filter begins with "-r", it is applied recursively to all sub-directories. If a phrase in the filter begins with -x, it indications exclusion.

For example, the filter "Austen.txt, -r Novels\*.* -x Emma.txt" returns the file Austen.txt and all files and folders under the Novels directory except Emma.txt.

If the operation is synchronous, the process begins and is not checked for status until the process is completed. If the operation is asynchronous, the function immediately begins the upload and continuously checks if the transfer is finished. Check the ActionFinished Property periodically, and use the GetLastError Method to see if the operation succeeded.

See Also

ProjectRepository Object


%%PageItemTitle%%

ProjectRepository Object

ActionFinished Property

Description

Checks if the load or save action is finished.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ActionFinished() As Long

See Also

ProjectRepository Object


%%PageItemTitle%%

ProjectRepository Object

ClientPath Property

Description

The location on the client to which to download or from which to upload.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ClientPath() As String

See Also

ProjectRepository Object


%%PageItemTitle%%

ProjectRepository Object

Root Property

Description

The storage root.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Root() As Object

See Also

ProjectRepository Object


%%PageItemTitle%%

ProjectRepository Object

ServerPath Property

Description

The location on the server from which to download or to which to upload.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ServerPath() As String

See Also

ProjectRepository Object


%%PageItemTitle%%

Recordset Members

Recordset Object

Description

Represents the entire set of records resulting from an executed command. At any given time, a Recordset object refers to a single record within the record set as the current record.

Remarks

A Recordset object is returned by Command.Execute.

The Position indicates the record to which the Recordset cursor points, the currently active record. The first record is numbered 0. The FieldValue refers to the values in the currently active record.

If there are no records in the Recordset, BOR and EOR BOR and EOR are true and the Position is 0.

Example

Example of recordset properties and methods

Public Methods

Public Method Clone | Creates a duplicate of this Recordset object.
Public Method First | Moves to the first record and makes it the current record.
Public Method Last | Moves to the last record and makes it the current record.
Public Method Next | Moves to the next record and makes it the current record.
Public Method Prev | Moves to the previous record and makes it the current record.
Public Method Refresh | Refreshes the Recordset, overwriting values in memory.

Public Properties

Public Property BOR | Checks if the record cursor is on the first record.
Public Property CacheSize | The number of records in the recordset that are cached locally in memory.
Public Property ColCount | Gets the number of columns in the current Recordset object.
Public Property ColIndex | Gets the index (zero-based) of a Recordset column specified by column name.
Public Property ColName | The name of the Recordset column specified by Index (zero-based).
Public Property ColSize | The physical size as defined in the database of the fields in the column specified by Index (zero-based).
Public Property ColType | The data type of column.
Public Property EOR | Checks if the record cursor is after the last record.
Public Property FieldValue | The value for the specified field.
Public Property Position | The current record position (0-based).
Public Property RecordCount | The number of records in the Recordset.


%%PageItemTitle%%

Recordset Object

Clone Method

Description

Creates a duplicate of this Recordset object.

Syntax

Public Function Clone() As Object

Return Type

The new Recordset object.

See Also

Recordset Object


%%PageItemTitle%%

Recordset Object

First Method

Description

Moves to the first record and makes it the current record.

Syntax

Public Sub First()

See Also

Recordset Object


%%PageItemTitle%%

Recordset Object

Last Method

Description

Moves to the last record and makes it the current record.

Syntax

Public Sub Last()

See Also

Recordset Object


%%PageItemTitle%%

Recordset Object

Next Method

Description

Moves to the next record and makes it the current record.

Syntax

Public Sub Next()

Remarks

If Next is called when the cursor is on the last record of the recordset, moving the cursor beyond the last record, EOR becomes True and an attempt to read data causes an error.

See Also

Recordset Object


%%PageItemTitle%%

Recordset Object

Prev Method

Description

Moves to the previous record and makes it the current record.

Syntax

Public Sub Prev()

Remarks

Calling Prev when the cursor is on the first record of the recordset has no effect. The first record continues to be active. Use the BOR Property to determine if the first record is current.

See Also

Recordset Object


%%PageItemTitle%%

Recordset Object

Range
For internal use only.
Low
For internal use only.
High
For internal use only.
See Also OTA COM Type Library

Refresh Method

Description

Refreshes the Recordset, overwriting values in memory.

Syntax

Public Sub Refresh( _
   Optional ByVal Range As Long = 0, _
   Optional ByVal Low As Long = 0, _
   Optional ByVal High As Long = 0 _
)

Parameters

Range
For internal use only.
Low
For internal use only.
High
For internal use only.

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Recordset Object


%%PageItemTitle%%

Recordset Object

BOR Property

Description

Checks if the record cursor is on the first record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BOR() As Boolean

Remarks

BOR (Beginning of Recordset) is true when the Recordset object is created by the Command.Execute call, after the First method is called, and when the first record is reached by calling Prev when the cursor was on the second record.

If BOR is true and EOR is false, the cursor is pointing to the first record. If both BOR and EOR are true, there are no records in the Recordset. The Position is 0 in both cases.

See Also

Recordset Object


%%PageItemTitle%%

Recordset Object

CacheSize Property

Description

The number of records in the recordset that are cached locally in memory.

Property type

Read-write property

Syntax (Visual Basic)

Public Property CacheSize() As Long

See Also

Recordset Object


%%PageItemTitle%%

Recordset Object

ColCount Property

Description

Gets the number of columns in the current Recordset object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ColCount() As Long

See Also

Recordset Object


%%PageItemTitle%%

Recordset Object

Name
The name of the column in the project database.
See Also OTA COM Type Library

ColIndex Property

Description

Gets the index (zero-based) of a Recordset column specified by column name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ColIndex( _
   ByVal Name As String _
) As Long

Parameters

Name
The name of the column in the project database.

See Also

Recordset Object


%%PageItemTitle%%

Recordset Object

Index
The index of the column (zero-based).
See Also OTA COM Type Library

ColName Property

Description

The name of the Recordset column specified by Index (zero-based).

Property type

Read-only property

Syntax (Visual Basic)

Public Property ColName( _
   ByVal Index As Long _
) As String

Parameters

Index
The index of the column (zero-based).

See Also

Recordset Object


%%PageItemTitle%%

Recordset Object

Index
The index of the column (zero-based).
See Also OTA COM Type Library

ColSize Property

Description

The physical size as defined in the database of the fields in the column specified by Index (zero-based).

Property type

Read-only property

Syntax (Visual Basic)

Public Property ColSize( _
   ByVal Index As Long _
) As Long

Parameters

Index
The index of the column (zero-based).

See Also

Recordset Object


%%PageItemTitle%%

Recordset Object

Index
The index of the column (zero-based).
See Also OTA COM Type Library

ColType Property

Description

The data type of column.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ColType( _
   ByVal Index As Long _
) As Long

Parameters

Index
The index of the column (zero-based).

See Also

Recordset Object


%%PageItemTitle%%

Recordset Object

EOR Property

Description

Checks if the record cursor is after the last record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EOR() As Boolean

Remarks

EOR (End of Recordset) is true if the cursor is pointing to a position past the end of the recordset or if the recordset is empty. For example, if the cursor is on the last record and Next is called, EOR becomes true.

When EOR is true, an exception is thrown on any attempt to read data from the recordset.

See Also

Recordset Object


%%PageItemTitle%%

Recordset Object

FieldKey
The column index (long) or column name.
See Also OTA COM Type Library

FieldValue Property

Description

The value for the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FieldValue( _
   ByVal FieldKey As Variant _
) As Variant

Parameters

FieldKey
The column index (long) or column name.

See Also

Recordset Object


%%PageItemTitle%%

Recordset Object

Position Property

Description

The current record position (0-based).

Property type

Read-write property

Syntax (Visual Basic)

Public Property Position() As Long

Remarks

Position is 0 when the cursor is on the first record or if the recordset is empty.

See Also

Recordset Object


%%PageItemTitle%%

Recordset Object

RecordCount Property

Description

The number of records in the Recordset.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RecordCount() As Long

See Also

Recordset Object


%%PageItemTitle%%

Release Members

Release Object

Description

Represents a Release.

Remarks

Get a Release reference from the ReleaseFactory or from Cycle.Parent.

Interfaces

IBaseField2 | IBaseField3 | IStringRepresentation | ISysTreeNode2

Example

Get releases under a specified folder that match a filter | Set target releases for requirement | Set up release cycles

Public Methods

Public Method DaysLeft | Returns the number of days until the scheduled release date.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Mail | Mails the IBaseFieldExMail field item.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property CycleFactory | The CycleFactory object for cycles of this release.
Public Property EndDate | The release's end date
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The release's name
Public Property Parent | The release's parent release folder
Public Property ReleaseManagementInfo | The release information.
Public Property StartDate | The release's start date
Public Property Status | The release's status
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

Release Object

DaysLeft Method

Description

Returns the number of days until the scheduled release date.

Syntax

Public Function DaysLeft() As Long

See Also

Release Object


%%PageItemTitle%%

Release Object

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Release Object


%%PageItemTitle%%

Release Object | tagTDMAIL_FLAGS Enumeration

SendTo

The recipient address or addresses. Addresses can be separated by a comma or a semicolon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also OTA COM Type Library

Mail Method

Description

Mails the IBaseFieldExMail field item.

Syntax

Public Sub Mail( _
   ByVal SendTo As String, _
   Optional ByVal SendCc As String = "", _
   Optional ByVal Option As Long = 0, _
   Optional ByVal Subject As String = "", _
   Optional ByVal Comment As String = "" _
)

Parameters

SendTo

The recipient address or addresses. Addresses can be separated by a comma or a semicolon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also

Release Object | tagTDMAIL_FLAGS Enumeration


%%PageItemTitle%%

Release Object

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Release Object


%%PageItemTitle%%

Release Object

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Release Object


%%PageItemTitle%%

Release Object

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

Release Object


%%PageItemTitle%%

Release Object

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

Release Object


%%PageItemTitle%%

Release Object

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

Release Object


%%PageItemTitle%%

Release Object

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

Release Object


%%PageItemTitle%%

Release Object

CycleFactory Property

Description

The CycleFactory object for cycles of this release.

Property type

Read-only property

Syntax (Visual Basic)

Public Property CycleFactory() As Object

See Also

Release Object


%%PageItemTitle%%

Release Object

EndDate Property

Description

The release's end date

Property type

Read-write property

Syntax (Visual Basic)

Public Property EndDate() As Date

See Also

Release Object


%%PageItemTitle%%

Release Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

Release Object


%%PageItemTitle%%

Release Object

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

Release Object


%%PageItemTitle%%

Release Object

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

Release Object


%%PageItemTitle%%

Release Object

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

Release Object


%%PageItemTitle%%

Release Object

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

Release Object


%%PageItemTitle%%

Release Object

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

Release Object


%%PageItemTitle%%

Release Object

Name Property

Description

The release's name

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

Release Object


%%PageItemTitle%%

Release Object

Parent Property

Description

The release's parent release folder

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As Object

See Also

Release Object


%%PageItemTitle%%

Release Object

ReleaseManagementInfo Property

Description

The release information.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ReleaseManagementInfo() As Object

See Also

Release Object


%%PageItemTitle%%

Release Object

StartDate Property

Description

The release's start date

Property type

Read-write property

Syntax (Visual Basic)

Public Property StartDate() As Date

See Also

Release Object


%%PageItemTitle%%

Release Object

Status Property

Description

The release's status

Property type

Read-write property

Syntax (Visual Basic)

Public Property Status() As String

See Also

Release Object


%%PageItemTitle%%

Release Object

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

Release Object


%%PageItemTitle%% $$Members$$

Release Object

IStringRepresentation Implemented Interface Members

Methods

Public Implemented Method ToString The string representation of the object.

See Also

Release Object


%%PageItemTitle%%

Release Object | IStringRepresentation Implemented Interface

ToString Implemented Method

Description

The string representation of the object.

Syntax

Public Function ToString() As String

See Also

Release Object | IStringRepresentation Implemented Interface


%%PageItemTitle%% $$Members$$

Release Object

ISysTreeNode2 Implemented Interface Members

Methods

Public Implemented Method AddNode | Adds a new child node.
Public Implemented Method FindChildNode | Finds a child node by node name.
Public Implemented Method FindChildren | Finds node children according to specified search pattern.
Public Implemented Method NewList | Gets a list of the node's immediate children.
Public Implemented Method Post | Posts all changed values to the database.
Public Implemented Method Refresh | Reads the saved node data, overwriting values in memory.
Public Implemented Method RemoveNode | Deletes the specified node.

Properties

Public Implemented Property Attribute | Gets the node attribute.
Public Implemented Property Child | Gets a sub-folder of the current folder.
Public Implemented Property Count | The number of child nodes.
Public Implemented Property DepthType | The sub-tree depth type.
Public Implemented Property Father | The current folder's parent folder.
Public Implemented Property Name | The node name.
Public Implemented Property NodeID | The node ID number.
Public Implemented Property Path | The folder tree path starting from the tree root.
Public Implemented Property Type | The nodes's type.

See Also

Release Object


%%PageItemTitle%%

Release Object | ISysTreeNode2 Implemented Interface

NodeName
See Also OTA COM Type Library

AddNode Implemented Method

Description

Adds a new child node.

Syntax

Public Function AddNode( _
   ByVal NodeName As String _
) As SysTreeNode

Parameters

NodeName

See Also

Release Object | ISysTreeNode2 Implemented Interface


%%PageItemTitle%%

Release Object | ISysTreeNode2 Implemented Interface

ChildName
See Also OTA COM Type Library

FindChildNode Implemented Method

Description

Finds a child node by node name.

Syntax

Public Function FindChildNode( _
   ByVal ChildName As String _
) As SysTreeNode

Parameters

ChildName

See Also

Release Object | ISysTreeNode2 Implemented Interface


%%PageItemTitle%%

Release Object | ISysTreeNode2 Implemented Interface

Pattern
MatchCase
Filter
See Also OTA COM Type Library

FindChildren Implemented Method

Description

Finds node children according to specified search pattern.

Syntax

Public Function FindChildren( _
   ByVal Pattern As String, _
   Optional ByVal MatchCase As Boolean = False, _
   Optional ByVal Filter As String = "" _
) As List

Parameters

Pattern
MatchCase
Filter

See Also

Release Object | ISysTreeNode2 Implemented Interface


%%PageItemTitle%%

Release Object | ISysTreeNode2 Implemented Interface

NewList Implemented Method

Description

Gets a list of the node's immediate children.

Syntax

Public Function NewList() As List

See Also

Release Object | ISysTreeNode2 Implemented Interface


%%PageItemTitle%%

Release Object | ISysTreeNode2 Implemented Interface

Post Implemented Method

Description

Posts all changed values to the database.

Syntax

Public Sub Post()

See Also

Release Object | ISysTreeNode2 Implemented Interface


%%PageItemTitle%%

Release Object | ISysTreeNode2 Implemented Interface

Refresh Implemented Method

Description

Reads the saved node data, overwriting values in memory.

Syntax

Public Sub Refresh()

See Also

Release Object | ISysTreeNode2 Implemented Interface


%%PageItemTitle%%

Release Object | ISysTreeNode2 Implemented Interface

Node
See Also OTA COM Type Library

RemoveNode Implemented Method

Description

Deletes the specified node.

Syntax

Public Sub RemoveNode( _
   ByVal Node As Variant _
)

Parameters

Node

See Also

Release Object | ISysTreeNode2 Implemented Interface


%%PageItemTitle%%

Release Object | ISysTreeNode2 Implemented Interface

Attribute Implemented Property

Description

Gets the node attribute.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISysTreeNode2_Attribute() As Long

See Also

Release Object | ISysTreeNode2 Implemented Interface


%%PageItemTitle%%

Release Object | ISysTreeNode2 Implemented Interface

Index
See Also OTA COM Type Library

Child Implemented Property

Description

Gets a sub-folder of the current folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISysTreeNode2_Child( _
   ByVal Index As Long _
) As SysTreeNode

Parameters

Index

See Also

Release Object | ISysTreeNode2 Implemented Interface


%%PageItemTitle%%

Release Object | ISysTreeNode2 Implemented Interface

Count Implemented Property

Description

The number of child nodes.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISysTreeNode2_Count() As Long

See Also

Release Object | ISysTreeNode2 Implemented Interface


%%PageItemTitle%%

Release Object | ISysTreeNode2 Implemented Interface

DepthType Implemented Property

Description

The sub-tree depth type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISysTreeNode2_DepthType() As Integer

See Also

Release Object | ISysTreeNode2 Implemented Interface


%%PageItemTitle%%

Release Object | ISysTreeNode2 Implemented Interface

Father Implemented Property

Description

The current folder's parent folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISysTreeNode2_Father() As SysTreeNode

See Also

Release Object | ISysTreeNode2 Implemented Interface


%%PageItemTitle%%

Release Object | ISysTreeNode2 Implemented Interface

Name Implemented Property

Description

The node name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ISysTreeNode2_Name() As String

See Also

Release Object | ISysTreeNode2 Implemented Interface


%%PageItemTitle%%

Release Object | ISysTreeNode2 Implemented Interface

NodeID Implemented Property

Description

The node ID number.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISysTreeNode2_NodeID() As Long

See Also

Release Object | ISysTreeNode2 Implemented Interface


%%PageItemTitle%%

Release Object | ISysTreeNode2 Implemented Interface

Path Implemented Property

Description

The folder tree path starting from the tree root.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISysTreeNode2_Path() As String

See Also

Release Object | ISysTreeNode2 Implemented Interface


%%PageItemTitle%%

Release Object | ISysTreeNode2 Implemented Interface

Type Implemented Property

Description

The nodes's type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISysTreeNode2_Type() As Long

See Also

Release Object | ISysTreeNode2 Implemented Interface


%%PageItemTitle%%

ReleaseFactory Members

ReleaseFactory Object

Description

Services for managing releases.

Remarks

Get a ReleaseFactory from TDConnection.ReleaseFactory Property or ReleaseFactory.

Interface Remarks

IBaseFactoryEx adds method Mail to IBaseFactory. It is implemented by several classes, such as BugFactory, ReqFactory, and TestFactory.
The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Interfaces

IBaseFactory2 | ISearchableFactory

Example

Get releases under a specified folder that match a filter | Set up release cycles

Public Methods

Public Method AddItem | Creates a new item object.
Public Method BuildCoverageGraph | Builds release coverage graph.
Public Method Mail | Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

ReleaseFactory Object

ItemData
See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData

Remarks

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

[Visual Basic]

Dim bgf As BugFactory
Dim bg As Bug
Dim attf As AttachmentFactory
Dim att As Attachment
Dim attList As List

' Get the factory object
 Set bgf = tdc.BugFactory
' Use defect #1
 Set bg = bgf.Item(1)
 Set attf = bg.Attachments

' Creating a new attachment
' Create virtual object, then populate the properties
 Set att = attf.AddItem(Null)
 att.FileName = Text1.Text
 att.Type = TDATT_INTERNET

' Saving the object with validity check
 att.Post

' Display the attachments
' Add the display-only items without a Post
 List1.Clear
 Set attList = attf.NewList("")
 For i = 1 To attList.Count

      Set att = attList.Item(i)
      List1.AddItem (att.Name)

 Next

See Also

ReleaseFactory Object


%%PageItemTitle%%

ReleaseFactory Object

ReleaseID
See Also OTA COM Type Library

BuildCoverageGraph Method

Description

Builds release coverage graph.

Syntax

Public Function BuildCoverageGraph( _
   ByVal ReleaseID As Long _
) As Object

Parameters

ReleaseID

See Also

ReleaseFactory Object


%%PageItemTitle%%

ReleaseFactory Object

Items

A list of IDs.

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also OTA COM Type Library

Mail Method

Description

Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.

Syntax

Public Sub Mail( _
   ByVal Items As Variant, _
   ByVal SendTo As String, _
   Optional ByVal SendCc As String = "", _
   Optional ByVal Option As Long = 0, _
   Optional ByVal Subject As String = "", _
   Optional ByVal Comment As String = "" _
)

Parameters

Items

A list of IDs.

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also

ReleaseFactory Object


%%PageItemTitle%%

ReleaseFactory Object

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

ReleaseFactory Object


%%PageItemTitle%%

ReleaseFactory Object

ItemKey
See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey

See Also

ReleaseFactory Object


%%PageItemTitle%%

ReleaseFactory Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

ReleaseFactory Object


%%PageItemTitle%%

ReleaseFactory Object

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

ReleaseFactory Object


%%PageItemTitle%%

ReleaseFactory Object

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

ReleaseFactory Object


%%PageItemTitle%%

ReleaseFactory Object

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

ReleaseFactory Object


%%PageItemTitle%%

ReleaseFactory Object

ItemKey
See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey

See Also

ReleaseFactory Object


%%PageItemTitle%%

ReleaseFolder Members

ReleaseFolder Object

Description

Represents a Release folder.

Remarks

Get a reference from the ReleaseFolderFactory.

Interfaces

IBaseField2 | IBaseField3 | IStringRepresentation | ISysTreeNode2

Example

Get releases under a specified folder that match a filter | Find release folders by parent ID | Set up release cycles

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Mail | Mails the IBaseFieldExMail field item.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The release folder's name
Public Property Parent | The release folder's parent release folder, or null if root
Public Property ReleaseFactory | The ReleaseFactory object for direct children releases.
Public Property ReleaseFolderFactory | The ReleaseFolderFactory object for direct children release folders.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

ReleaseFolder Object

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ReleaseFolder Object


%%PageItemTitle%%

ReleaseFolder Object | tagTDMAIL_FLAGS Enumeration

SendTo

The recipient address or addresses. Addresses can be separated by a comma or a semicolon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also OTA COM Type Library

Mail Method

Description

Mails the IBaseFieldExMail field item.

Syntax

Public Sub Mail( _
   ByVal SendTo As String, _
   Optional ByVal SendCc As String = "", _
   Optional ByVal Option As Long = 0, _
   Optional ByVal Subject As String = "", _
   Optional ByVal Comment As String = "" _
)

Parameters

SendTo

The recipient address or addresses. Addresses can be separated by a comma or a semicolon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also

ReleaseFolder Object | tagTDMAIL_FLAGS Enumeration


%%PageItemTitle%%

ReleaseFolder Object

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ReleaseFolder Object


%%PageItemTitle%%

ReleaseFolder Object

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ReleaseFolder Object


%%PageItemTitle%%

ReleaseFolder Object

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

ReleaseFolder Object


%%PageItemTitle%%

ReleaseFolder Object

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

ReleaseFolder Object


%%PageItemTitle%%

ReleaseFolder Object

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

ReleaseFolder Object


%%PageItemTitle%%

ReleaseFolder Object

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

ReleaseFolder Object


%%PageItemTitle%%

ReleaseFolder Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

ReleaseFolder Object


%%PageItemTitle%%

ReleaseFolder Object

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

ReleaseFolder Object


%%PageItemTitle%%

ReleaseFolder Object

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

ReleaseFolder Object


%%PageItemTitle%%

ReleaseFolder Object

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

ReleaseFolder Object


%%PageItemTitle%%

ReleaseFolder Object

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

ReleaseFolder Object


%%PageItemTitle%%

ReleaseFolder Object

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

ReleaseFolder Object


%%PageItemTitle%%

ReleaseFolder Object

Name Property

Description

The release folder's name

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ReleaseFolder Object


%%PageItemTitle%%

ReleaseFolder Object

Parent Property

Description

The release folder's parent release folder, or null if root

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As Object

See Also

ReleaseFolder Object


%%PageItemTitle%%

ReleaseFolder Object

ReleaseFactory Property

Description

The ReleaseFactory object for direct children releases.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ReleaseFactory() As Object

See Also

ReleaseFolder Object


%%PageItemTitle%%

ReleaseFolder Object

ReleaseFolderFactory Property

Description

The ReleaseFolderFactory object for direct children release folders.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ReleaseFolderFactory() As Object

See Also

ReleaseFolder Object


%%PageItemTitle%%

ReleaseFolder Object

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

ReleaseFolder Object


%%PageItemTitle%% $$Members$$

ReleaseFolder Object

IStringRepresentation Implemented Interface Members

Methods

Public Implemented Method ToString The string representation of the object.

See Also

ReleaseFolder Object


%%PageItemTitle%%

ReleaseFolder Object | IStringRepresentation Implemented Interface

See Also OTA COM Type Library

ToString Implemented Method

Description

The string representation of the object.

Syntax

Public Function ToString() As String

See Also

ReleaseFolder Object | IStringRepresentation Implemented Interface


%%PageItemTitle%% $$Members$$

ReleaseFolder Object

ISysTreeNode2 Implemented Interface Members

Methods

Public Implemented Method AddNode | Adds a new child node.
Public Implemented Method FindChildNode | Finds a child node by node name.
Public Implemented Method FindChildren | Finds node children according to specified search pattern.
Public Implemented Method NewList | Gets a list of the node's immediate children.
Public Implemented Method Post | Posts all changed values to the database.
Public Implemented Method Refresh | Reads the saved node data, overwriting values in memory.
Public Implemented Method RemoveNode | Deletes the specified node.

Properties

Public Implemented Property Attribute | Gets the node attribute.
Public Implemented Property Child | Gets a sub-folder of the current folder.
Public Implemented Property Count | The number of child nodes.
Public Implemented Property DepthType | The sub-tree depth type.
Public Implemented Property Father | The current folder's parent folder.
Public Implemented Property Name | The node name.
Public Implemented Property NodeID | The node ID number.
Public Implemented Property Path | The folder tree path starting from the tree root.
Public Implemented Property Type | The nodes's type.

See Also

ReleaseFolder Object


%%PageItemTitle%%

ReleaseFolder Object | ISysTreeNode2 Implemented Interface

NodeName
See Also OTA COM Type Library

AddNode Implemented Method

Description

Adds a new child node.

Syntax

Public Function AddNode( _
   ByVal NodeName As String _
) As SysTreeNode

Parameters

NodeName

See Also

ReleaseFolder Object | ISysTreeNode2 Implemented Interface


%%PageItemTitle%%

ReleaseFolder Object | ISysTreeNode2 Implemented Interface

ChildName
See Also OTA COM Type Library

FindChildNode Implemented Method

Description

Finds a child node by node name.

Syntax

Public Function FindChildNode( _
   ByVal ChildName As String _
) As SysTreeNode

Parameters

ChildName

See Also

ReleaseFolder Object | ISysTreeNode2 Implemented Interface


%%PageItemTitle%%

ReleaseFolder Object | ISysTreeNode2 Implemented Interface

Pattern
MatchCase
Filter
See Also OTA COM Type Library

FindChildren Implemented Method

Description

Finds node children according to specified search pattern.

Syntax

Public Function FindChildren( _
   ByVal Pattern As String, _
   Optional ByVal MatchCase As Boolean = False, _
   Optional ByVal Filter As String = "" _
) As List

Parameters

Pattern
MatchCase
Filter

See Also

ReleaseFolder Object | ISysTreeNode2 Implemented Interface


%%PageItemTitle%%

ReleaseFolder Object | ISysTreeNode2 Implemented Interface

NewList Implemented Method

Description

Gets a list of the node's immediate children.

Syntax

Public Function NewList() As List

See Also

ReleaseFolder Object | ISysTreeNode2 Implemented Interface


%%PageItemTitle%%

ReleaseFolder Object | ISysTreeNode2 Implemented Interface

Post Implemented Method

Description

Posts all changed values to the database.

Syntax

Public Sub Post()

See Also

ReleaseFolder Object | ISysTreeNode2 Implemented Interface


%%PageItemTitle%%

ReleaseFolder Object | ISysTreeNode2 Implemented Interface

Refresh Implemented Method

Description

Reads the saved node data, overwriting values in memory.

Syntax

Public Sub Refresh()

See Also

ReleaseFolder Object | ISysTreeNode2 Implemented Interface


%%PageItemTitle%%

ReleaseFolder Object | ISysTreeNode2 Implemented Interface

Node
See Also OTA COM Type Library

RemoveNode Implemented Method

Description

Deletes the specified node.

Syntax

Public Sub RemoveNode( _
   ByVal Node As Variant _
)

Parameters

Node

See Also

ReleaseFolder Object | ISysTreeNode2 Implemented Interface


%%PageItemTitle%%

ReleaseFolder Object | ISysTreeNode2 Implemented Interface

Attribute Implemented Property

Description

Gets the node attribute.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISysTreeNode2_Attribute() As Long

See Also

ReleaseFolder Object | ISysTreeNode2 Implemented Interface


%%PageItemTitle%%

ReleaseFolder Object | ISysTreeNode2 Implemented Interface

Index
See Also OTA COM Type Library

Child Implemented Property

Description

Gets a sub-folder of the current folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISysTreeNode2_Child( _
   ByVal Index As Long _
) As SysTreeNode

Parameters

Index

See Also

ReleaseFolder Object | ISysTreeNode2 Implemented Interface


%%PageItemTitle%%

ReleaseFolder Object | ISysTreeNode2 Implemented Interface

Count Implemented Property

Description

The number of child nodes.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISysTreeNode2_Count() As Long

See Also

ReleaseFolder Object | ISysTreeNode2 Implemented Interface


%%PageItemTitle%%

ReleaseFolder Object | ISysTreeNode2 Implemented Interface

DepthType Implemented Property

Description

The sub-tree depth type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISysTreeNode2_DepthType() As Integer

See Also

ReleaseFolder Object | ISysTreeNode2 Implemented Interface


%%PageItemTitle%%

ReleaseFolder Object | ISysTreeNode2 Implemented Interface

Father Implemented Property

Description

The current folder's parent folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISysTreeNode2_Father() As SysTreeNode

See Also

ReleaseFolder Object | ISysTreeNode2 Implemented Interface


%%PageItemTitle%%

ReleaseFolder Object | ISysTreeNode2 Implemented Interface

Name Implemented Property

Description

The node name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ISysTreeNode2_Name() As String

See Also

ReleaseFolder Object | ISysTreeNode2 Implemented Interface


%%PageItemTitle%%

ReleaseFolder Object | ISysTreeNode2 Implemented Interface

NodeID Implemented Property

Description

The node ID number.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISysTreeNode2_NodeID() As Long

See Also

ReleaseFolder Object | ISysTreeNode2 Implemented Interface


%%PageItemTitle%%

ReleaseFolder Object | ISysTreeNode2 Implemented Interface

Path Implemented Property

Description

The folder tree path starting from the tree root.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISysTreeNode2_Path() As String

See Also

ReleaseFolder Object | ISysTreeNode2 Implemented Interface


%%PageItemTitle%%

ReleaseFolder Object | ISysTreeNode2 Implemented Interface

Type Implemented Property

Description

The nodes's type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISysTreeNode2_Type() As Long

See Also

ReleaseFolder Object | ISysTreeNode2 Implemented Interface


%%PageItemTitle%%

ReleaseFolderFactory Members

ReleaseFolderFactory Object

Description

Services for managing release folders.

Remarks

The ReleaseFolderFactory for the connection is TDConnection.ReleaseFolderFactory

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Interfaces

IBaseFactory2 | ISearchableFactory

Example

Get releases under a specified folder that match a filter | Find release folders by parent ID | Set up release cycles

Public Methods

Public Method AddItem | Creates a new item object.
Public Method Mail | Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.
Public Property Root | Gets the root release folder labled 'Releases'.


%%PageItemTitle%%

ReleaseFolderFactory Object

ItemData

There are two options for ItemData:

  • Null. Creating a virtual ReleaseFolder object with Null ensures that you cannot then Post until the required fields are initialized.
  • An array consisting of the following two elements:

(0) ParentID - The ID of the Release Folder in which to create the new Release Folder (long, required).

(1) Name - The Release Folder name (string, required).

See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData

There are two options for ItemData:

  • Null. Creating a virtual ReleaseFolder object with Null ensures that you cannot then Post until the required fields are initialized.
  • An array consisting of the following two elements:

(0) ParentID - The ID of the Release Folder in which to create the new Release Folder (long, required).

(1) Name - The Release Folder name (string, required).

Remarks

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

[Visual Basic]

Dim bgf As BugFactory
Dim bg As Bug
Dim attf As AttachmentFactory
Dim att As Attachment
Dim attList As List

' Get the factory object
 Set bgf = tdc.BugFactory
' Use defect #1
 Set bg = bgf.Item(1)
 Set attf = bg.Attachments

' Creating a new attachment
' Create virtual object, then populate the properties
 Set att = attf.AddItem(Null)
 att.FileName = Text1.Text
 att.Type = TDATT_INTERNET

' Saving the object with validity check
 att.Post

' Display the attachments
' Add the display-only items without a Post
 List1.Clear
 Set attList = attf.NewList("")
 For i = 1 To attList.Count

      Set att = attList.Item(i)
      List1.AddItem (att.Name)

 Next

See Also

ReleaseFolderFactory Object


%%PageItemTitle%%

ReleaseFolderFactory Object

Items

A list of IDs.

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also OTA COM Type Library

Mail Method

Description

Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.

Syntax

Public Sub Mail( _
   ByVal Items As Variant, _
   ByVal SendTo As String, _
   Optional ByVal SendCc As String = "", _
   Optional ByVal Option As Long = 0, _
   Optional ByVal Subject As String = "", _
   Optional ByVal Comment As String = "" _
)

Parameters

Items

A list of IDs.

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also

ReleaseFolderFactory Object


%%PageItemTitle%%

ReleaseFolderFactory Object

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

ReleaseFolderFactory Object


%%PageItemTitle%%

ReleaseFolderFactory Object

ItemKey
The ReleaseFolder.ID, a reference to the ReleaseFolder Object, or a Variant Array of ReleaseFolder.IDs.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey
The ReleaseFolder.ID, a reference to the ReleaseFolder Object, or a Variant Array of ReleaseFolder.IDs.

See Also

ReleaseFolderFactory Object


%%PageItemTitle%%

ReleaseFolderFactory Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

ReleaseFolderFactory Object


%%PageItemTitle%%

ReleaseFolderFactory Object

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

ReleaseFolderFactory Object


%%PageItemTitle%%

ReleaseFolderFactory Object

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

ReleaseFolderFactory Object


%%PageItemTitle%%

ReleaseFolderFactory Object

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

ReleaseFolderFactory Object


%%PageItemTitle%%

ReleaseFolderFactory Object

ItemKey
The ReleaseFolder.ID

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey
The ReleaseFolder.ID

See Also

ReleaseFolderFactory Object


%%PageItemTitle%%

ReleaseFolderFactory Object

Root Property

Description

Gets the root release folder labled 'Releases'.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Root() As Object

See Also

ReleaseFolderFactory Object


%%PageItemTitle%%

ReleaseManagementInfo Members

ReleaseManagementInfo Object

Description

Represents a release or cycle.

Remarks

Get a reference from Release.ReleaseManagementInfo or Cycle.ReleaseManagementInfo.

Public Properties

Public Property DaysLeft | Returns the number of days remaining in the cycle or release.
Public Property Duration | Returns the duration of the cycle or release.
Public Property Started | Checks if the cycle or release has begun.
Public Property TotalTestInstances | Returns the total number of test instances in this cycle or release.
Public Property UnexecutedTestInstances | Returns the number of unexecuted test instances in this cycle or release.


%%PageItemTitle%%

ReleaseManagementInfo Object

DaysLeft Property

Description

Returns the number of days remaining in the cycle or release.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DaysLeft() As Long

See Also

ReleaseManagementInfo Object


%%PageItemTitle%%

ReleaseManagementInfo Object

Duration Property

Description

Returns the duration of the cycle or release.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Duration() As Long

See Also

ReleaseManagementInfo Object


%%PageItemTitle%%

ReleaseManagementInfo Object

Started Property

Description

Checks if the cycle or release has begun.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Started() As Boolean

See Also

ReleaseManagementInfo Object


%%PageItemTitle%%

ReleaseManagementInfo Object

TotalTestInstances Property

Description

Returns the total number of test instances in this cycle or release.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TotalTestInstances() As Long

See Also

ReleaseManagementInfo Object


%%PageItemTitle%%

ReleaseManagementInfo Object

UnexecutedTestInstances Property

Description

Returns the number of unexecuted test instances in this cycle or release.

Property type

Read-only property

Syntax (Visual Basic)

Public Property UnexecutedTestInstances() As Long

See Also

ReleaseManagementInfo Object


%%PageItemTitle%%

Req Members

Req Object

Description

Represents a requirement for which testing must be performed.

Remarks

Get a Req object from the ReqFactory.

Interfaces

IAlertable2 | IBaseField2 | IBaseField3 | ICoverableReq | IFollowUpManager | ILinkable | ISupportRBTAnalysisChild | ISupportRBTAnalysisParent | ISupportRBTAssessment

Example

Finding a unique requirement | Accessing members of Additional Implemented Interfaces | Getting the list of design tests used in a test set | Filter requirements by type | Find requirements modified in specified period | Add test plan folder to coverage | Add tests to requirement coverage | Copy a requirement | Set the target release cycle of the descendents to that of the requirement | Remove requirement target release cycle | Set target releases for requirement

Public Methods

Public Method AddCoverage | Assigns a test to cover this requirement.
Public Method AddCoverageByFilter | Adds the tests from the specified subject that match the input filter to the list of tests that cover the current requirement.
Public Method AddCoverageEx | Assigns all the tests in the specified subject folder to cover this current requirement.
Public Method get_Icon | Returns the bitmap stream for the requirement's type.
Public Method GetCoverageTestsByReqFilter | Returns the list of tests that cover the current requirement and, optionally, cover those of its children that match the requirement filter.
Public Method GetCoverList | Gets a list of the tests that cover this requirement.
Public Method GetCoverListByFilter | Gets the list of all tests that cover the current requirement and match the filter.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Mail | Mails the IBaseFieldExMail field item.
Public Method Move | Moves a requirement to being a child of a specified father in the requirements tree.
Public Method PopulateTargetCycleToChildren | Assigns the target cycle of the requirement as the target cycle of all child requirements, recursively down the folder tree.
Public Method PopulateTargetReleaseToChildren | Assigns the target release of the requirement as the target release of all child requirements, recursively down the folder tree.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method RemoveCoverage | Removes a test from the list of tests that cover this requirement.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property Author | The name of the requirement author.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Comment | The comment associated with this requirement.
Public Property Count | The number of direct children.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property HasCoverage | The requirement is covered by at least one test.
Public Property HasReqTraceability | Checks if the current requirement has at least one associated requirement in the specified direction.
Public Property HasRichContent | Checks if the object has rich content.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The Requirement name as seen in the tree.
Public Property Paragraph | The paragraph number or numeration of the requirement.
Public Property ParentId | The Requirement's parent ID.
Public Property Path | The path of the node containing this requirement.
Public Property Priority | The requirement priority.
Public Property Product | The product name for which the requirement is set.
Public Property ReqTraceFactory | The requirement link factory that manages the traceability links of the current requirement to its associated requirements in the specified direction.
Public Property RequirementType | Gets the interface for getting the requirement types.
Public Property Reviewed | The review status.
Public Property Status | The status of the tests that cover this requirement.
Public Property Type | The requirement type.
Public Property TypeId | The Requirement's type name.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

Req Object

TestId
The ID of the test assigned to the requirement.
Order

The position of the test in the requirement coverage list. Possible values are:

  • A number representing the position.
  • TDPOSITION_LAST [-4] - Indicates that the test is inserted last
See Also OTA COM Type Library

AddCoverage Method

Description

Assigns a test to cover this requirement.

Syntax

Public Function AddCoverage( _
   ByVal TestId As Long, _
   ByVal Order As Long _
) As Long

Parameters

TestId
The ID of the test assigned to the requirement.
Order

The position of the test in the requirement coverage list. Possible values are:

  • A number representing the position.
  • TDPOSITION_LAST [-4] - Indicates that the test is inserted last

Return Type

Zero on success, or -1 on error.

Remarks

The actual position of the test in the requirement coverage list.

See Also

Req Object

Example

Find a specified requirement in a specified folder | Add a test to the requirement coverage


%%PageItemTitle%%

Req Object

SubjectID
The ID of the folder in the test plan module.
Order
The desired position in the list of tests.
TestFilter
A TDFilter.Text that selects the tests to cover the requirement.
See Also OTA COM Type Library

AddCoverageByFilter Method

Description

Adds the tests from the specified subject that match the input filter to the list of tests that cover the current requirement.

Syntax

Public Function AddCoverageByFilter( _
   ByVal SubjectID As Long, _
   ByVal Order As Long, _
   ByVal TestFilter As String _
) As Long

Parameters

SubjectID
The ID of the folder in the test plan module.
Order
The desired position in the list of tests.
TestFilter
A TDFilter.Text that selects the tests to cover the requirement.

See Also

Req Object

Example

Find a specified requirement in a specified folder | Covering a requirement with selected tests in a folder | Getting a test subject node by the node path


%%PageItemTitle%%

Req Object

SubjectID
The ID of the subject folder containing the tests to be added to the requirement.
Order

The position of the first test in the folder in the requirement coverage list. Possible values are:

  • A number representing the position.
  • TDPOSITION_LAST [-4] - Indicates that the test is inserted last
See Also OTA COM Type Library

AddCoverageEx Method

Description

Assigns all the tests in the specified subject folder to cover this current requirement.

Syntax

Public Function AddCoverageEx( _
   ByVal SubjectID As Long, _
   ByVal Order As Long _
) As Long

Parameters

SubjectID
The ID of the subject folder containing the tests to be added to the requirement.
Order

The position of the first test in the folder in the requirement coverage list. Possible values are:

  • A number representing the position.
  • TDPOSITION_LAST [-4] - Indicates that the test is inserted last

Return Type

Zero on success, or -1 on error.

Remarks

The actual position of the first test in the folder in the requirement coverage list.

See Also

Req Object

Example

Find a specified requirement in a specified folder | Add all tests under a subject folder to the requirement coverage | Getting a test subject node by the node path


%%PageItemTitle%%

Req Object

get_Icon Method

Description

Returns the bitmap stream for the requirement's type.

Syntax

Public Function get_Icon() As IStream

See Also

Req Object


%%PageItemTitle%%

Req Object

ReqFilter
A TDFilter.Text that specifies which descendent requirements to include.
Recursive

If true, the filter is applied to this requirement and its descendent requirements.

If false, the filter is only applied to this requirement.

See Also OTA COM Type Library

GetCoverageTestsByReqFilter Method

Description

Returns the list of tests that cover the current requirement and, optionally, cover those of its children that match the requirement filter.

Syntax

Public Function GetCoverageTestsByReqFilter( _
   ByVal ReqFilter As String, _
   Optional ByVal Recursive As Boolean = False _
) As List

Parameters

ReqFilter
A TDFilter.Text that specifies which descendent requirements to include.
Recursive

If true, the filter is applied to this requirement and its descendent requirements.

If false, the filter is only applied to this requirement.

Return Type

A list of the Tests that cover the requirements that match the filter.

If no requirements, including this requirement, match the filter, an empty list is returned.

Remarks

To retrieve the list of all tests that cover this requirement , either set set the filter to an empty string or use GetCoverList.

See Also

Req Object


%%PageItemTitle%%

Req Object

Recursive
If TRUE, GetCoverList returns a list of coverage tests for current requirement and all its children. Otherwise, the method returns a list of coverage tests only for the current requirement.
See Also OTA COM Type Library

GetCoverList Method

Description

Gets a list of the tests that cover this requirement.

Syntax

Public Function GetCoverList( _
   Optional ByVal Recursive As Boolean = False _
) As List

Parameters

Recursive
If TRUE, GetCoverList returns a list of coverage tests for current requirement and all its children. Otherwise, the method returns a list of coverage tests only for the current requirement.

Return Type

A list of Test Objects.

See Also

Req Object

Example

Get the List of tests that cover a requirement


%%PageItemTitle%%

Req Object

TestFilter
A TDFilter.Text string.
Recursive
If TRUE, GetCoverList returns a list of coverage tests for current requirement and all its children. Otherwise, the method returns a list of coverage tests only for the current requirement.
See Also OTA COM Type Library

GetCoverListByFilter Method

Description

Gets the list of all tests that cover the current requirement and match the filter.

Syntax

Public Function GetCoverListByFilter( _
   ByVal TestFilter As String, _
   Optional ByVal Recursive As Boolean = False _
) As List

Parameters

TestFilter
A TDFilter.Text string.
Recursive
If TRUE, GetCoverList returns a list of coverage tests for current requirement and all its children. Otherwise, the method returns a list of coverage tests only for the current requirement.

See Also

Req Object

Example

Find a specified requirement in a specified folder | Get a List of all the covering tests that have not run | Getting a test subject node by the node path


%%PageItemTitle%%

Req Object

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Req Object


%%PageItemTitle%%

Req Object | tagTDMAIL_FLAGS Enumeration

SendTo

The recipient address or addresses. Addresses can be separated by a comma or a semicolon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also OTA COM Type Library

Mail Method

Description

Mails the IBaseFieldExMail field item.

Syntax

Public Sub Mail( _
   ByVal SendTo As String, _
   Optional ByVal SendCc As String = "", _
   Optional ByVal Option As Long = 0, _
   Optional ByVal Subject As String = "", _
   Optional ByVal Comment As String = "" _
)

Parameters

SendTo

The recipient address or addresses. Addresses can be separated by a comma or a semicolon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also

Req Object | tagTDMAIL_FLAGS Enumeration


%%PageItemTitle%%

Req Object

NewFatherId
The ID of the designated new father requirement.
NewOrder

The position of the requirement under the new parent. Possible values are:

  • A number representing the position.
  • TDPOSITION_LAST [-4] - Indicates that the test is inserted last
See Also OTA COM Type Library

Move Method

Description

Moves a requirement to being a child of a specified father in the requirements tree.

Syntax

Public Sub Move( _
   ByVal NewFatherId As Long, _
   ByVal NewOrder As Long _
)

Parameters

NewFatherId
The ID of the designated new father requirement.
NewOrder

The position of the requirement under the new parent. Possible values are:

  • A number representing the position.
  • TDPOSITION_LAST [-4] - Indicates that the test is inserted last

See Also

Req Object


%%PageItemTitle%%

Req Object

PopulateTargetCycleToChildren Method

Description

Assigns the target cycle of the requirement as the target cycle of all child requirements, recursively down the folder tree.

Syntax

Public Sub PopulateTargetCycleToChildren()

See Also

Req Object


%%PageItemTitle%%

Req Object

PopulateTargetReleaseToChildren Method

Description

Assigns the target release of the requirement as the target release of all child requirements, recursively down the folder tree.

Syntax

Public Sub PopulateTargetReleaseToChildren()

See Also

Req Object


%%PageItemTitle%%

Req Object

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Req Object


%%PageItemTitle%%

Req Object

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Req Object


%%PageItemTitle%%

Req Object

vTest
A Test Object or array of test objects.
Recursive
If TRUE, the specified coverage is removed for all the requirements under the current one. If FALSE, only the coverage at the current requirement is removed.
See Also OTA COM Type Library

RemoveCoverage Method

Description

Removes a test from the list of tests that cover this requirement.

Syntax

Public Sub RemoveCoverage( _
   ByVal vTest As Variant, _
   Optional ByVal Recursive As Boolean = False _
)

Parameters

vTest
A Test Object or array of test objects.
Recursive
If TRUE, the specified coverage is removed for all the requirements under the current one. If FALSE, only the coverage at the current requirement is removed.

See Also

Req Object

Example

Remove a test from the requirement coverage


%%PageItemTitle%%

Req Object

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

Req Object


%%PageItemTitle%%

Req Object

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

Req Object


%%PageItemTitle%%

Req Object

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

Req Object


%%PageItemTitle%%

Req Object

Author Property

Description

The name of the requirement author.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

Req Object


%%PageItemTitle%%

Req Object

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

Req Object


%%PageItemTitle%%

Req Object

Comment Property

Description

The comment associated with this requirement.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comment() As String

See Also

Req Object


%%PageItemTitle%%

Req Object

Count Property

Description

The number of direct children.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

Req Object


%%PageItemTitle%%

Req Object

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName

The name of the field in the project database.

Remarks

An attempt to get or set the value of a field not applicable to requirements of this type causes an exception. Get the list of applicable fields from CustomizationReqType.Fields.

See Also

Req Object


%%PageItemTitle%%

Req Object

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

Req Object


%%PageItemTitle%%

Req Object

HasCoverage Property

Description

The requirement is covered by at least one test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasCoverage() As Boolean

See Also

Req Object


%%PageItemTitle%%

Req Object

TraceDirection

A value of the TDAPI_TRACE_DIRECTION Enumeration.

See Also OTA COM Type Library

HasReqTraceability Property

Description

Checks if the current requirement has at least one associated requirement in the specified direction.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasReqTraceability( _
   ByVal TraceDirection As Long _
) As Boolean

Parameters

TraceDirection

A value of the TDAPI_TRACE_DIRECTION Enumeration.

See Also

Req Object


%%PageItemTitle%%

Req Object

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

Req Object


%%PageItemTitle%%

Req Object

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

Req Object


%%PageItemTitle%%

Req Object

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

Req Object


%%PageItemTitle%%

Req Object

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

Req Object


%%PageItemTitle%%

Req Object

Name Property

Description

The Requirement name as seen in the tree.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

Req Object


%%PageItemTitle%%

Req Object

Paragraph Property

Description

The paragraph number or numeration of the requirement.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Paragraph() As String

Remarks

To see the paragraph numbers in the user interface, choose menu item View > Numeration in the Requirement module.

The paragraph number is one node deeper than the Path.

See Also

Req Object

Example

Get requirement properties


%%PageItemTitle%%

Req Object

ParentId Property

Description

The Requirement's parent ID.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ParentId() As Long

Remarks

Set this property to place the requirement under another requirement in the hierarchy.

The default is -1, indicating a top-level requirement.

See Also

Req Object


%%PageItemTitle%%

Req Object

Path Property

Description

The path of the node containing this requirement.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Path() As String

Remarks

A path is a code consisting of letters like "AAA", "AAB" and so on. It is not visible in the user interface.

See Also

Req Object


%%PageItemTitle%%

Req Object

Priority Property

Description

The requirement priority.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Priority() As String

Remarks

For most sites, the priorities are from "1-Low" to "5-Urgent".

To get the full list of priorities in your project look at the Priority list. See 'Customizing Project Lists' in the Mercury Quality Center Administrator's Guide.

See Also

Req Object


%%PageItemTitle%%

Req Object

Product Property

Description

The product name for which the requirement is set.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Product() As String

See Also

Req Object


%%PageItemTitle%%

Req Object

TraceDirection

A value of the TDAPI_TRACE_DIRECTION Enumeration.

See Also OTA COM Type Library

ReqTraceFactory Property

Description

The requirement link factory that manages the traceability links of the current requirement to its associated requirements in the specified direction.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ReqTraceFactory( _
   ByVal TraceDirection As Long _
) As Object

Parameters

TraceDirection

A value of the TDAPI_TRACE_DIRECTION Enumeration.

See Also

Req Object


%%PageItemTitle%%

Req Object

RequirementType Property

Description

Gets the interface for getting the requirement types.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RequirementType() As Object

See Also

Req Object


%%PageItemTitle%%

Req Object

Reviewed Property

Description

The review status.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Reviewed() As String

Remarks

The review status can be any value configured in the project. Typical examples are Changed, Not Reviewed, and Reviewed.

For information about the Review Status list, see 'Customizing Project Lists' in the Mercury Quality Center Administrator's Guide.

See Also

Req Object


%%PageItemTitle%%

Req Object

Status Property

Description

The status of the tests that cover this requirement.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Status() As String

Remarks

The statuses of the covering tests are: Failed, No Run, Not Completed, or Passed.

If no tests cover this requirement, the value is Not Covered.

For information about the Status list, see 'Customizing Project Lists' in the Mercury Quality Center Administrator's Guide.

See Also

Req Object


%%PageItemTitle%%

Req Object

Type Property

Description

The requirement type.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Type() As String

Remarks

Obsolete. In previous versions:

The type can be any value configured in the project. Typical examples are Functional, Guideline, Quality, Standard, and System.

For information about the Requirement Type list, see 'Customizing Project Lists' in the Mercury Quality Center Administrator's Guide.

See Also

Req Object

Example

Get requirement properties


%%PageItemTitle%%

Req Object

TypeId Property

Description

The Requirement's type name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property TypeId() As String

See Also

Req Object


%%PageItemTitle%%

Req Object

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

Req Object


%%PageItemTitle%% $$Members$$

Req Object

IBaseField3 Implemented Interface Members

Methods

Public Implemented Method Post Writes all changed values to database.

See Also

Req Object


%%PageItemTitle%%

Req Object | IBaseField3 Implemented Interface

UndoOnFailure
See Also OTA COM Type Library

Post Implemented Method

Description

Writes all changed values to database.

Syntax

Public Sub Post( _
   Optional ByVal UndoOnFailure As Boolean = True _
)

Parameters

UndoOnFailure

See Also

Req Object | IBaseField3 Implemented Interface


%%PageItemTitle%%

ICoverableReq Members

ICoverableReq Interface

Description

Represents a requirement that is covered by another entity.

Example

Add test plan folder to coverage | Add tests to requirement coverage

Public Methods

Public Method AddSubjectToCoverage | Adds the tests from the specified subject that match the input filter to the list of tests that cover the current requirement.
Public Method AddTestInstanceToCoverage | Adds the test instance to the list of test instances that cover the current requirement.
Public Method AddTestsFromTestSetToCoverage | Adds the test instances from the specified test set that match the input filter to the list of test instances that cover the current requirement.
Public Method AddTestToCoverage | Adds the test to the list of tests that cover the current requirement.

Public Properties

Public Property RequirementCoverageFactory Get Requirement Coverage Factory


%%PageItemTitle%% $$Members$$

Req Object

ISupportRBTAnalysisChild Implemented Interface Members

Properties

Public Implemented Property AnalyzedTestingEffortInHours | The testing effort determined by the last analysis, in hours.
Public Implemented Property AnalyzedTestingLevel | The testing level determined by the last analysis, from 'RBT Testing Levels' in ALL_LISTS.
Public Implemented Property CustomTestingEffortInHours | The custom testing effort, in hours.
Public Implemented Property CustomTestingLevel | The custom testing level supplied, from 'RBT Testing Levels' in ALL_LISTS.
Public Implemented Property IgnoreInAnalysis | Should this requirement be excluded in RBT analysis?
Public Implemented Property ParentRequirementForRBTAnalysis | The parent requirement for the current RBT Analysis.
Public Implemented Property RnDEstimatedEffortInHours | The R&D effort, in hours.
Public Implemented Property UseCustomTLAndTE | Does this requirement have a custom Testing Level and Testing Effort?.

See Also

Req Object


%%PageItemTitle%%

Req Object | ISupportRBTAnalysisChild Implemented Interface

AnalyzedTestingEffortInHours Implemented Property

Description

The testing effort determined by the last analysis, in hours.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISupportRBTAnalysisChild_AnalyzedTestingEffortInHours() As Long

See Also

Req Object | ISupportRBTAnalysisChild Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAnalysisChild Implemented Interface

AnalyzedTestingLevel Implemented Property

Description

The testing level determined by the last analysis, from 'RBT Testing Levels' in ALL_LISTS.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISupportRBTAnalysisChild_AnalyzedTestingLevel() As String

See Also

Req Object | ISupportRBTAnalysisChild Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAnalysisChild Implemented Interface

CustomTestingEffortInHours Implemented Property

Description

The custom testing effort, in hours.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ISupportRBTAnalysisChild_CustomTestingEffortInHours() As Long

See Also

Req Object | ISupportRBTAnalysisChild Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAnalysisChild Implemented Interface

CustomTestingLevel Implemented Property

Description

The custom testing level supplied, from 'RBT Testing Levels' in ALL_LISTS.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ISupportRBTAnalysisChild_CustomTestingLevel() As String

See Also

Req Object | ISupportRBTAnalysisChild Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAnalysisChild Implemented Interface

IgnoreInAnalysis Implemented Property

Description

Should this requirement be excluded in RBT analysis?

Property type

Read-write property

Syntax (Visual Basic)

Public Property ISupportRBTAnalysisChild_IgnoreInAnalysis() As Boolean

See Also

Req Object | ISupportRBTAnalysisChild Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAnalysisChild Implemented Interface

ParentRequirementForRBTAnalysis Implemented Property

Description

The parent requirement for the current RBT Analysis.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISupportRBTAnalysisChild_ParentRequirementForRBTAnalysis() As Object

See Also

Req Object | ISupportRBTAnalysisChild Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAnalysisChild Implemented Interface

RnDEstimatedEffortInHours Implemented Property

Description

The R&D effort, in hours.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ISupportRBTAnalysisChild_RnDEstimatedEffortInHours() As Long

See Also

Req Object | ISupportRBTAnalysisChild Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAnalysisChild Implemented Interface

UseCustomTLAndTE Implemented Property

Description

Does this requirement have a custom Testing Level and Testing Effort?.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ISupportRBTAnalysisChild_UseCustomTLAndTE() As Boolean

See Also

Req Object | ISupportRBTAnalysisChild Implemented Interface


%%PageItemTitle%% $$Members$$

Req Object

ISupportRBTAnalysisParent Implemented Interface Members

Methods

Public Implemented Method AnalyzeAndSave | Do analysis, create analysis results and save testing levels to all children Reqs.
Public Implemented Method AnalyzeButDontSave | Do analysis, create analysis results, but do not save testing levels in children yet.
Public Implemented Method ApplyPolicyOnResultMatix | Use current policy matrix and re-apply it on the aggregated counts matrix to calculate total analyzed reqs duration in hours.
Public Implemented Method ResetPolicyToDefaults | Copy the policy from customization.

Properties

Public Implemented Property AnalysisFilter | The filter used for the Analysis.
Public Implemented Property AnalysisResultAggregatedRNDEffortsInHours | Time in hours it would take RnD to handle this requirement, as simple aggregative addition of RND efforts set in children that were visited in last analysis.
Public Implemented Property AnalysisResultAnalyzedDurationInHours | Time in hours it would take to test the reqs without CustomTestingLevel, i.e. the regular analyzed reqs, with this policy set in the related RBT Analysis setup.
Public Implemented Property AnalysisResultCountCustomizedRequirements | Count of all child requirements visited in last analysis that their Testing Efforts were customized (not set by analysis)
Public Implemented Property AnalysisResultCountIgnoredRequirements | Count of all child requirements ignored in last analysis
Public Implemented Property AnalysisResultCountNonCustomizedRequirements | For each possible risk (pair of BI and FP levels) - return the total Count of child requirements that were visited in last analysis and that are assessed to be in this Risk (Pair), and their Efforts were not customized
Public Implemented Property AnalysisResultCountUnanalyzableRequirements | Count of all child requirements visited in last analysis that could not be analyzed due to missing Assessment or incomplete custom effort
Public Implemented Property AnalysisResultCustomizedDurationInHours | Time in hours it would take to test the reqs with CustomTestingLevel with this policy set in the related RBT Analysis setup.
Public Implemented Property AnalysisResultLastAnalysisDate | The Date/Time of the last analysis done on this parent req
Public Implemented Property AvailableTimeInHours | Available hours for this RBT Analysis.
Public Implemented Property FPLevelTestingEffortInHours | Hours needed to test a requirement in the given Failure Probability.
Public Implemented Property IsAnalyzed | Is this Requirement (parent) RBT analyzed. Does it have valid result data
Public Implemented Property TestingEffortInHoursFromPolicyMatrix | Calculated Hours needed to test a requirement in the given Failure Probability and Business Impact, according to the current policy.
Public Implemented Property TestingLevelPercentage | Testing level percentage (of the full testing level).
Public Implemented Property TestingPolicyMatrix | Risk testing level matrix

See Also

Req Object


%%PageItemTitle%%

Req Object | ISupportRBTAnalysisParent Implemented Interface

AnalyzeAndSave Implemented Method

Description

Do analysis, create analysis results and save testing levels to all children Reqs.

Syntax

Public Sub AnalyzeAndSave()

See Also

Req Object | ISupportRBTAnalysisParent Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAnalysisParent Implemented Interface

AnalyzeButDontSave Implemented Method

Description

Do analysis, create analysis results, but do not save testing levels in children yet.

Syntax

Public Sub AnalyzeButDontSave()

See Also

Req Object | ISupportRBTAnalysisParent Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAnalysisParent Implemented Interface

ApplyPolicyOnResultMatix Implemented Method

Description

Use current policy matrix and re-apply it on the aggregated counts matrix to calculate total analyzed reqs duration in hours.

Syntax

Public Sub ApplyPolicyOnResultMatix()

See Also

Req Object | ISupportRBTAnalysisParent Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAnalysisParent Implemented Interface

ResetPolicyToDefaults Implemented Method

Description

Copy the policy from customization.

Syntax

Public Sub ResetPolicyToDefaults()

See Also

Req Object | ISupportRBTAnalysisParent Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAnalysisParent Implemented Interface

AnalysisFilter Implemented Property

Description

The filter used for the Analysis.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ISupportRBTAnalysisParent_AnalysisFilter() As String

See Also

Req Object | ISupportRBTAnalysisParent Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAnalysisParent Implemented Interface

AnalysisResultAggregatedRNDEffortsInHours Implemented Property

Description

Time in hours it would take RnD to handle this requirement, as simple aggregative addition of RND efforts set in children that were visited in last analysis.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISupportRBTAnalysisParent_AnalysisResultAggregatedRNDEffortsInHours() As Long

See Also

Req Object | ISupportRBTAnalysisParent Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAnalysisParent Implemented Interface

AnalysisResultAnalyzedDurationInHours Implemented Property

Description

Time in hours it would take to test the reqs without CustomTestingLevel, i.e. the regular analyzed reqs, with this policy set in the related RBT Analysis setup.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISupportRBTAnalysisParent_AnalysisResultAnalyzedDurationInHours() As Long

See Also

Req Object | ISupportRBTAnalysisParent Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAnalysisParent Implemented Interface

AnalysisResultCountCustomizedRequirements Implemented Property

Description

Count of all child requirements visited in last analysis that their Testing Efforts were customized (not set by analysis)

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISupportRBTAnalysisParent_AnalysisResultCountCustomizedRequirements() As Long

See Also

Req Object | ISupportRBTAnalysisParent Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAnalysisParent Implemented Interface

AnalysisResultCountIgnoredRequirements Implemented Property

Description

Count of all child requirements ignored in last analysis

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISupportRBTAnalysisParent_AnalysisResultCountIgnoredRequirements() As Long

See Also

Req Object | ISupportRBTAnalysisParent Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAnalysisParent Implemented Interface

BILevel
The business implact level.
FPLevel
The failure probability level.
See Also OTA COM Type Library

AnalysisResultCountNonCustomizedRequirements Implemented Property

Description

For each possible risk (pair of BI and FP levels) - return the total Count of child requirements that were visited in last analysis and that are assessed to be in this Risk (Pair), and their Efforts were not customized

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISupportRBTAnalysisParent_AnalysisResultCountNonCustomizedRequirements( _
   ByVal BILevel As Long, _
   ByVal FPLevel As Long _
) As Long

Parameters

BILevel
The business implact level.
FPLevel
The failure probability level.

See Also

Req Object | ISupportRBTAnalysisParent Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAnalysisParent Implemented Interface

AnalysisResultCountUnanalyzableRequirements Implemented Property

Description

Count of all child requirements visited in last analysis that could not be analyzed due to missing Assessment or incomplete custom effort

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISupportRBTAnalysisParent_AnalysisResultCountUnanalyzableRequirements() As Long

See Also

Req Object | ISupportRBTAnalysisParent Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAnalysisParent Implemented Interface

AnalysisResultCustomizedDurationInHours Implemented Property

Description

Time in hours it would take to test the reqs with CustomTestingLevel with this policy set in the related RBT Analysis setup.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISupportRBTAnalysisParent_AnalysisResultCustomizedDurationInHours() As Long

See Also

Req Object | ISupportRBTAnalysisParent Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAnalysisParent Implemented Interface

AnalysisResultLastAnalysisDate Implemented Property

Description

The Date/Time of the last analysis done on this parent req

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISupportRBTAnalysisParent_AnalysisResultLastAnalysisDate() As Date

See Also

Req Object | ISupportRBTAnalysisParent Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAnalysisParent Implemented Interface

AvailableTimeInHours Implemented Property

Description

Available hours for this RBT Analysis.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ISupportRBTAnalysisParent_AvailableTimeInHours() As Long

See Also

Req Object | ISupportRBTAnalysisParent Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAnalysisParent Implemented Interface

FPLevel
The failure probability level.
See Also OTA COM Type Library

FPLevelTestingEffortInHours Implemented Property

Description

Hours needed to test a requirement in the given Failure Probability.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ISupportRBTAnalysisParent_FPLevelTestingEffortInHours( _
   ByVal FPLevel As Long _
) As Long

Parameters

FPLevel
The failure probability level.

See Also

Req Object | ISupportRBTAnalysisParent Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAnalysisParent Implemented Interface

IsAnalyzed Implemented Property

Description

Is this Requirement (parent) RBT analyzed. Does it have valid result data

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISupportRBTAnalysisParent_IsAnalyzed() As Boolean

See Also

Req Object | ISupportRBTAnalysisParent Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAnalysisParent Implemented Interface

BILevel
The business implact level.
FPLevel
The failure probability level.
See Also OTA COM Type Library

TestingEffortInHoursFromPolicyMatrix Implemented Property

Description

Calculated Hours needed to test a requirement in the given Failure Probability and Business Impact, according to the current policy.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISupportRBTAnalysisParent_TestingEffortInHoursFromPolicyMatrix( _
   ByVal BILevel As Long, _
   ByVal FPLevel As Long _
) As Long

Parameters

BILevel
The business implact level.
FPLevel
The failure probability level.

See Also

Req Object | ISupportRBTAnalysisParent Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAnalysisParent Implemented Interface

TestingLevel
See Also OTA COM Type Library

TestingLevelPercentage Implemented Property

Description

Testing level percentage (of the full testing level).

Property type

Read-write property

Syntax (Visual Basic)

Public Property ISupportRBTAnalysisParent_TestingLevelPercentage( _
   ByVal TestingLevel As Long _
) As Long

Parameters

TestingLevel

See Also

Req Object | ISupportRBTAnalysisParent Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAnalysisParent Implemented Interface

BILevel
The business implact level.
FPLevel
The failure probability level.
See Also OTA COM Type Library

TestingPolicyMatrix Implemented Property

Description

Risk testing level matrix

Property type

Read-write property

Syntax (Visual Basic)

Public Property ISupportRBTAnalysisParent_TestingPolicyMatrix( _
   ByVal BILevel As Long, _
   ByVal FPLevel As Long _
) As Long

Parameters

BILevel
The business implact level.
FPLevel
The failure probability level.

See Also

Req Object | ISupportRBTAnalysisParent Implemented Interface


%%PageItemTitle%% $$Members$$

Req Object

ISupportRBTAssessment Implemented Interface Members

Methods

Public Implemented Method AssessBILevel | Assess the Business Impact risk level for this requirement, according to the answers provided.
Public Implemented Method AssessFPLevel | Assess the Failure Probability risk level for this requirement, according to the answers provided.

Properties

Public Implemented Property AssessedBILevel | Business Impact risk level for this requirement, from the last time we called AssessBILevel.
Public Implemented Property AssessedFPLevel | Failure Probability risk level for this requirement, from the last time we called AssessFPLevel.
Public Implemented Property BIChosenAnswerForQuestion | The chosen Answer to this Business Impact question for this requirement.
Public Implemented Property CustomBILevel | Custom Business Impact level, overrides the assessed level.
Public Implemented Property CustomFPLevel | Custom Failure Probability level, overrides the assessed level.
Public Implemented Property EffectiveBILevel | Effective Business Impact level.
Public Implemented Property EffectiveFPLevel | Effective Failure Probability level.
Public Implemented Property FPChosenAnswerForQuestion | The chosen Answer to this Failure Probability question for this requirement.
Public Implemented Property UseCustomBILevel | Does this requirement have a custom Business Impact level?.
Public Implemented Property UseCustomFPLevel | Does this requirement have a custom Failure Probability level?.

See Also

Req Object


%%PageItemTitle%%

Req Object | ISupportRBTAssessment Implemented Interface

AssessBILevel Implemented Method

Description

Assess the Business Impact risk level for this requirement, according to the answers provided.

Syntax

Public Sub AssessBILevel()

See Also

Req Object | ISupportRBTAssessment Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAssessment Implemented Interface

AssessFPLevel Implemented Method

Description

Assess the Failure Probability risk level for this requirement, according to the answers provided.

Syntax

Public Sub AssessFPLevel()

See Also

Req Object | ISupportRBTAssessment Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAssessment Implemented Interface

AssessedBILevel Implemented Property

Description

Business Impact risk level for this requirement, from the last time we called AssessBILevel.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISupportRBTAssessment_AssessedBILevel() As String

See Also

Req Object | ISupportRBTAssessment Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAssessment Implemented Interface

AssessedFPLevel Implemented Property

Description

Failure Probability risk level for this requirement, from the last time we called AssessFPLevel.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISupportRBTAssessment_AssessedFPLevel() As String

See Also

Req Object | ISupportRBTAssessment Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAssessment Implemented Interface

QuestionID
See Also OTA COM Type Library

BIChosenAnswerForQuestion Implemented Property

Description

The chosen Answer to this Business Impact question for this requirement.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ISupportRBTAssessment_BIChosenAnswerForQuestion( _
   ByVal QuestionID As Long _
) As Long

Parameters

QuestionID

See Also

Req Object | ISupportRBTAssessment Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAssessment Implemented Interface

CustomBILevel Implemented Property

Description

Custom Business Impact level, overrides the assessed level.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ISupportRBTAssessment_CustomBILevel() As String

See Also

Req Object | ISupportRBTAssessment Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAssessment Implemented Interface

CustomFPLevel Implemented Property

Description

Custom Failure Probability level, overrides the assessed level.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ISupportRBTAssessment_CustomFPLevel() As String

See Also

Req Object | ISupportRBTAssessment Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAssessment Implemented Interface

EffectiveBILevel Implemented Property

Description

Effective Business Impact level.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISupportRBTAssessment_EffectiveBILevel() As String

See Also

Req Object | ISupportRBTAssessment Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAssessment Implemented Interface

EffectiveFPLevel Implemented Property

Description

Effective Failure Probability level.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ISupportRBTAssessment_EffectiveFPLevel() As String

See Also

Req Object | ISupportRBTAssessment Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAssessment Implemented Interface

QuestionID
See Also OTA COM Type Library

FPChosenAnswerForQuestion Implemented Property

Description

The chosen Answer to this Failure Probability question for this requirement.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ISupportRBTAssessment_FPChosenAnswerForQuestion( _
   ByVal QuestionID As Long _
) As Long

Parameters

QuestionID

See Also

Req Object | ISupportRBTAssessment Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAssessment Implemented Interface

UseCustomBILevel Implemented Property

Description

Does this requirement have a custom Business Impact level?.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ISupportRBTAssessment_UseCustomBILevel() As Boolean

See Also

Req Object | ISupportRBTAssessment Implemented Interface


%%PageItemTitle%%

Req Object | ISupportRBTAssessment Implemented Interface

UseCustomFPLevel Implemented Property

Description

Does this requirement have a custom Failure Probability level?.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ISupportRBTAssessment_UseCustomFPLevel() As Boolean

See Also

Req Object | ISupportRBTAssessment Implemented Interface


%%PageItemTitle%%

ReqCoverageFactory Members

ReqCoverageFactory Object

Description

ReqCoverageFactory Class.

Remarks

A ReqCoverageFactory manages CoverageEntity Objects.

The reference to a ReqCoverageFactory for a specific requirement is the ICoverableReq.RequirementCoverageFactory Property of the ICoverableReq Implemented Interface of the Req object.

Interfaces

IBaseFactory2

Example

Getting a reference to an implemented interface | Accessing members of Additional Implemented Interfaces

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property FullCoverage | Indicates if the actions of the factory are applied recursively to requirement's children.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

ReqCoverageFactory Object

ItemData
A reference to the item that will cover the requirement. For example, a Test Object or a TSTest Object.
See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData
A reference to the item that will cover the requirement. For example, a Test Object or a TSTest Object.

Remarks

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

See Also

ReqCoverageFactory Object


%%PageItemTitle%%

ReqCoverageFactory Object

Filter
See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

Return Type

A list of A CoverageEntity Objects.

See Also

ReqCoverageFactory Object


%%PageItemTitle%%

ReqCoverageFactory Object

ItemKey
A reference to the object that will no longer cover the requirement. For example, a Test Object or a TSTest Object.
See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey
A reference to the object that will no longer cover the requirement. For example, a Test Object or a TSTest Object.

See Also

ReqCoverageFactory Object


%%PageItemTitle%%

ReqCoverageFactory Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

ReqCoverageFactory Object


%%PageItemTitle%%

ReqCoverageFactory Object

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

ReqCoverageFactory Object


%%PageItemTitle%%

ReqCoverageFactory Object

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

ReqCoverageFactory Object


%%PageItemTitle%%

ReqCoverageFactory Object

FullCoverage Property

Description

Indicates if the actions of the factory are applied recursively to requirement's children.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FullCoverage() As Boolean

See Also

ReqCoverageFactory Object


%%PageItemTitle%%

ReqCoverageFactory Object

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

ReqCoverageFactory Object


%%PageItemTitle%%

ReqCoverageFactory Object

ItemKey
A CoverageEntity.ID.
See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey
A CoverageEntity.ID.

See Also

ReqCoverageFactory Object


%%PageItemTitle%%

ReqFactory Members

ReqFactory Object

Description

Services for managing requirements.

Remarks

The ReqFactory for the connection is TDConnection.ReqFactory.

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Interfaces

IAlertableEntityFactory | IBaseFactory2 | ISearchableFactory | ISupportCopyPaste2

Example

Find a specified requirement in a specified folder | Getting a reference to an implemented interface | Getting those test instances that do, and those that do not, cover a requirement | Getting the list of design tests used in a test set | Find tests that do not cover any requirement | Find requirements modified in specified period | Copy a requirement

Public Methods

Public Method AddItem | Creates a new item object.
Public Method BuildPerfGraph | Builds Performance Graph.
Public Method BuildPerfGraphEx | Builds Performance Graph.
Public Method BuildProgressGraph | Builds Req progress graph.
Public Method BuildProgressGraphEx | Builds Requirement progress graph. Extends BuildProgressGraph with ability to display Null parent folders.
Public Method BuildSummaryGraph | Builds Req summary graph.
Public Method BuildSummaryGraphEx | Builds Req summary graph. Extends BuildSummaryGraph with ability to display Null parent folders.
Public Method BuildTrendGraph | Creates graph that shows the number of defect status changes over time.
Public Method BuildTrendGraphEx | Creates graph that shows the number of defect status changes over time.
Public Method Find | Gets a list of requirements containing the Pattern value in specified field.
Public Method GetChildrenList | Gets list of child requirements.
Public Method GetCoverageTestsByReqFilter | Returns the list of tests that cover the requirements that match the requirement filter.
Public Method GetFilteredChildrenList | Gets a filtered list of child requirements.
Public Method GetRequirementType | Returns the requirement customization type object specified by the type ID.
Public Method GetRequirementTypes | Returns the list of requirement customization types.
Public Method GetTracedList | Returns the list of requirements either traced directly from or directly to the specified requirement.
Public Method Mail | Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.
Public Method ReqTypeIdToName | Returns the name of the requirement type specified by the type ID.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

ReqFactory Object

ItemData

There are three options for ItemData:

  • Null. Creating a virtual Req object with Null ensures that you cannot then Post until all required fields are initialized.
  • The parent requirement ID (Variant).
  • An array consisting of the following elements:

(0) FatherID - The parent requirement ID (long or string, required).

(1) Order - The new requirement position in the children list (long, optional).

Order is either:

    • A number representing the requirement position.
    • TDPOSITION_LAST [-4] - Default. Indicates that the requirement is inserted last.

See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData

There are three options for ItemData:

  • Null. Creating a virtual Req object with Null ensures that you cannot then Post until all required fields are initialized.
  • The parent requirement ID (Variant).
  • An array consisting of the following elements:

(0) FatherID - The parent requirement ID (long or string, required).

(1) Order - The new requirement position in the children list (long, optional).

Order is either:

    • A number representing the requirement position.
    • TDPOSITION_LAST [-4] - Default. Indicates that the requirement is inserted last.

Remarks

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

[Visual Basic]

Dim bgf As BugFactory
Dim bg As Bug
Dim attf As AttachmentFactory
Dim att As Attachment
Dim attList As List

' Get the factory object
 Set bgf = tdc.BugFactory
' Use defect #1
 Set bg = bgf.Item(1)
 Set attf = bg.Attachments

' Creating a new attachment
' Create virtual object, then populate the properties
 Set att = attf.AddItem(Null)
 att.FileName = Text1.Text
 att.Type = TDATT_INTERNET

' Saving the object with validity check
 att.Post

' Display the attachments
' Add the display-only items without a Post
 List1.Clear
 Set attList = attf.NewList("")
 For i = 1 To attList.Count

      Set att = attList.Item(i)
      List1.AddItem (att.Name)

 Next

See Also

ReqFactory Object


%%PageItemTitle%%

ReqFactory Object

GroupByField
A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.
SumOfField
For internal use.
MaxCols
The maximum number of groups represented in the graph. A value of 0 signifies no limit.
Filter
A TDFilter Object that sets the filter criteria for the graph.
FRDate
Only items with a change date after this date are reflected in the graph.
ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildPerfGraph Method

Description

Builds Performance Graph.

Syntax

Public Function BuildPerfGraph( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField
A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.
SumOfField
For internal use.
MaxCols
The maximum number of groups represented in the graph. A value of 0 signifies no limit.
Filter
A TDFilter Object that sets the filter criteria for the graph.
FRDate
Only items with a change date after this date are reflected in the graph.
ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

ReqFactory Object


%%PageItemTitle%%

ReqFactory Object

GroupByField
A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.
SumOfField
For internal use.
MaxCols
The maximum number of groups represented in the graph. A value of 0 signifies no limit.
Filter
A TDFilter Object that sets the filter criteria for the graph.
FRDate
Only items with a change date after this date are reflected in the graph.
ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

ShowNullParents
Only for Requirements mode. A value of True allows parent folders, which have no test coverage, from being viewed during Cover Status queries.
See Also OTA COM Type Library

BuildPerfGraphEx Method

Description

Builds Performance Graph.

Syntax

Public Function BuildPerfGraphEx( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False, _
   Optional ByVal ShowNullParents As Boolean = False _
) As Object

Parameters

GroupByField
A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.
SumOfField
For internal use.
MaxCols
The maximum number of groups represented in the graph. A value of 0 signifies no limit.
Filter
A TDFilter Object that sets the filter criteria for the graph.
FRDate
Only items with a change date after this date are reflected in the graph.
ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

ShowNullParents
Only for Requirements mode. A value of True allows parent folders, which have no test coverage, from being viewed during Cover Status queries.

Return Type

A new Graph Object.

See Also

ReqFactory Object


%%PageItemTitle%%

ReqFactory Object

GroupByField
A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.
SumOfField
For internal use.
ByHistory

Determines whether to use history information to create the graph. Possible values are:

TRUE - Use history information.

FALSE - Do not use history information.

MajorSkip
Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.
MinorSkip
Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.
MaxCols
The maximum number of groups represented in the graph. A value of 0 signifies no limit.
Filter
A TDFilter Object that sets the filter criteria for the graph.
FRDate
Only items with a change date after this date are reflected in the graph.
ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildProgressGraph Method

Description

Builds Req progress graph.

Syntax

Public Function BuildProgressGraph( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal ByHistory As Boolean = True, _
   Optional ByVal MajorSkip As Long = 0, _
   Optional ByVal MinorSkip As Long = 1, _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField
A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.
SumOfField
For internal use.
ByHistory

Determines whether to use history information to create the graph. Possible values are:

TRUE - Use history information.

FALSE - Do not use history information.

MajorSkip
Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.
MinorSkip
Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.
MaxCols
The maximum number of groups represented in the graph. A value of 0 signifies no limit.
Filter
A TDFilter Object that sets the filter criteria for the graph.
FRDate
Only items with a change date after this date are reflected in the graph.
ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

ReqFactory Object


%%PageItemTitle%%

ReqFactory Object

GroupByField
A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.
SumOfField
For internal use.
ByHistory

Determines whether to use history information to create the graph. Possible values are:

TRUE - Use history information.

FALSE - Do not use history information.

MajorSkip
Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.
MinorSkip
Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.
MaxCols
The maximum number of groups represented in the graph. Zero indicates no limit.
Filter
The TDFilter Object that sets the criteria for the graph.
FRDate
Only items with a change date after this date are reflected in the graph.
ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

ShowNullParents
Only for Requirements mode. A value of True allows parent folders, which have no test coverage, from being viewed during Cover Status queries.
See Also OTA COM Type Library

BuildProgressGraphEx Method

Description

Builds Requirement progress graph. Extends BuildProgressGraph with ability to display Null parent folders.

Syntax

Public Function BuildProgressGraphEx( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal ByHistory As Boolean = True, _
   Optional ByVal MajorSkip As Long = 0, _
   Optional ByVal MinorSkip As Long = 1, _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False, _
   Optional ByVal ShowNullParents As Boolean = False _
) As Object

Parameters

GroupByField
A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.
SumOfField
For internal use.
ByHistory

Determines whether to use history information to create the graph. Possible values are:

TRUE - Use history information.

FALSE - Do not use history information.

MajorSkip
Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.
MinorSkip
Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.
MaxCols
The maximum number of groups represented in the graph. Zero indicates no limit.
Filter
The TDFilter Object that sets the criteria for the graph.
FRDate
Only items with a change date after this date are reflected in the graph.
ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

ShowNullParents
Only for Requirements mode. A value of True allows parent folders, which have no test coverage, from being viewed during Cover Status queries.

Return Type

A new Graph Object.

See Also

ReqFactory Object


%%PageItemTitle%%

ReqFactory Object

XAxisField
A database field representing the name of the graph x-axis.
GroupByField
A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.
SumOfField
For internal use.
MaxCols
The maximum number of groups represented in the graph. A value of 0 signifies no limit.
Filter
A TDFilter Object that sets the filter criteria for the graph.
ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildSummaryGraph Method

Description

Builds Req summary graph.

Syntax

Public Function BuildSummaryGraph( _
   Optional ByVal XAxisField As String = "", _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

XAxisField
A database field representing the name of the graph x-axis.
GroupByField
A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.
SumOfField
For internal use.
MaxCols
The maximum number of groups represented in the graph. A value of 0 signifies no limit.
Filter
A TDFilter Object that sets the filter criteria for the graph.
ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

ReqFactory Object


%%PageItemTitle%%

ReqFactory Object

XAxisField
A database field representing the name of the graph x-axis.
GroupByField
A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.
SumOfField
For internal use.
MaxCols
The maximum number of groups represented in the graph. A value of 0 signifies no limit.
Filter
A TDFilter Object that sets the filter criteria for the graph.
ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

ShowNullParents
Only for Requirements mode. A value of True allows parent folders, which have no test coverage, from being viewed during Cover Status queries.
See Also OTA COM Type Library

BuildSummaryGraphEx Method

Description

Builds Req summary graph. Extends BuildSummaryGraph with ability to display Null parent folders.

Syntax

Public Function BuildSummaryGraphEx( _
   Optional ByVal XAxisField As String = "", _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False, _
   Optional ByVal ShowNullParents As Boolean = False _
) As Object

Parameters

XAxisField
A database field representing the name of the graph x-axis.
GroupByField
A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.
SumOfField
For internal use.
MaxCols
The maximum number of groups represented in the graph. A value of 0 signifies no limit.
Filter
A TDFilter Object that sets the filter criteria for the graph.
ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

ShowNullParents
Only for Requirements mode. A value of True allows parent folders, which have no test coverage, from being viewed during Cover Status queries.

Return Type

A new Graph Object.

See Also

ReqFactory Object


%%PageItemTitle%%

ReqFactory Object

GroupByField
A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.
SumOfField
For internal use.
MaxCols
The maximum number of groups represented in the graph. A value of 0 signifies no limit.
Filter
A TDFilter Object that sets the filter criteria for the graph.
FRDate
Only items with a change date after this date are reflected in the graph.
ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildTrendGraph Method

Description

Creates graph that shows the number of defect status changes over time.

Syntax

Public Function BuildTrendGraph( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField
A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.
SumOfField
For internal use.
MaxCols
The maximum number of groups represented in the graph. A value of 0 signifies no limit.
Filter
A TDFilter Object that sets the filter criteria for the graph.
FRDate
Only items with a change date after this date are reflected in the graph.
ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

ReqFactory Object


%%PageItemTitle%%

ReqFactory Object

GroupByField
A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.
SumOfField
For internal use.
MaxCols
The maximum number of groups represented in the graph. A value of 0 signifies no limit.
Filter
A TDFilter Object that sets the filter criteria for the graph.
FRDate
Only items with a change date after this date are reflected in the graph.
ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

ShowNullParents
Only for Requirements mode. A value of True allows parent folders, which have no test coverage, from being viewed during Cover Status queries.
See Also OTA COM Type Library

BuildTrendGraphEx Method

Description

Creates graph that shows the number of defect status changes over time.

Syntax

Public Function BuildTrendGraphEx( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False, _
   Optional ByVal ShowNullParents As Boolean = False _
) As Object

Parameters

GroupByField
A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.
SumOfField
For internal use.
MaxCols
The maximum number of groups represented in the graph. A value of 0 signifies no limit.
Filter
A TDFilter Object that sets the filter criteria for the graph.
FRDate
Only items with a change date after this date are reflected in the graph.
ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

ShowNullParents
Only for Requirements mode. A value of True allows parent folders, which have no test coverage, from being viewed during Cover Status queries.

Return Type

A new Graph Object.

See Also

ReqFactory Object


%%PageItemTitle%%

ReqFactory Object

StartRootID
The ID of the root of the subtree from which to start the search.
FieldName
The name of the field to scan for the value.
Pattern
The search pattern. Regular expression are permitted in SQL format only.
mode
A search option. Use values from the tagTDAPI_REQMODE Enumeration.
Limit
The maximum number of matches to report.
See Also OTA COM Type Library

Find Method

Description

Gets a list of requirements containing the Pattern value in specified field.

Syntax

Public Function Find( _
   ByVal StartRootID As Long, _
   ByVal FieldName As String, _
   ByVal Pattern As String, _
   Optional ByVal mode As Long = 0, _
   Optional ByVal Limit As Long = 100 _
) As List

Parameters

StartRootID
The ID of the root of the subtree from which to start the search.
FieldName
The name of the field to scan for the value.
Pattern
The search pattern. Regular expression are permitted in SQL format only.
mode
A search option. Use values from the tagTDAPI_REQMODE Enumeration.
Limit
The maximum number of matches to report.

Return Type

A list with format "ID,NAME".

See Also

ReqFactory Object

Example

Find a specified requirement in a specified folder


%%PageItemTitle%%

ReqFactory Object

FatherID
The ID of the parent requirement.
See Also OTA COM Type Library

GetChildrenList Method

Description

Gets list of child requirements.

Syntax

Public Function GetChildrenList( _
   ByVal FatherID As Long _
) As List

Parameters

FatherID
The ID of the parent requirement.

Return Type

A list of Req Objects.

See Also

ReqFactory Object


%%PageItemTitle%%

ReqFactory Object

ReqFilter
A TDFilter.Text that specifies which requirements to include.
See Also OTA COM Type Library

GetCoverageTestsByReqFilter Method

Description

Returns the list of tests that cover the requirements that match the requirement filter.

Syntax

Public Function GetCoverageTestsByReqFilter( _
   ByVal ReqFilter As String _
) As List

Parameters

ReqFilter
A TDFilter.Text that specifies which requirements to include.

Return Type

A list of the Tests that cover the requirements that match the filter.

See Also

ReqFactory Object


%%PageItemTitle%%

ReqFactory Object

FatherID
The Req.ID of the requirement whose child requirements are to be retreived.
Filter
A TDFilter Object that provides criteria for the child requirements
See Also OTA COM Type Library

GetFilteredChildrenList Method

Description

Gets a filtered list of child requirements.

Syntax

Public Function GetFilteredChildrenList( _
   ByVal FatherID As Long, _
   Optional ByVal Filter As ITDFilter = 0 _
) As List

Parameters

FatherID
The Req.ID of the requirement whose child requirements are to be retreived.
Filter
A TDFilter Object that provides criteria for the child requirements

Return Type

A list of Req Objects.

Remarks

If no filter is passed, all child requirements are included in the list.

See Also

ReqFactory Object


%%PageItemTitle%%

ReqFactory Object

TypeId
The name of the requirement type as entered in the customization module of Quality Center.
See Also OTA COM Type Library

GetRequirementType Method

Description

Returns the requirement customization type object specified by the type ID.

Syntax

Public Function GetRequirementType( _
   ByVal TypeId As String _
) As Object

Parameters

TypeId
The name of the requirement type as entered in the customization module of Quality Center.

Return Type

A ReqType Object.

See Also

ReqFactory Object


%%PageItemTitle%%

ReqFactory Object

GetRequirementTypes Method

Description

Returns the list of requirement customization types.

Syntax

Public Function GetRequirementTypes() As List

Return Type

A list of ReqType Objects.

See Also

ReqFactory Object


%%PageItemTitle%%

ReqFactory Object

ReqID
A Req.ID.
TraceDirection
A value of the TDAPI_TRACE_DIRECTION Enumeration.
See Also OTA COM Type Library

GetTracedList Method

Description

Returns the list of requirements either traced directly from or directly to the specified requirement.

Syntax

Public Function GetTracedList( _
   ByVal ReqID As Long, _
   ByVal TraceDirection As Long _
) As List

Parameters

ReqID
A Req.ID.
TraceDirection
A value of the TDAPI_TRACE_DIRECTION Enumeration.

Return Type

A list of references to Req objects.

Remarks

If TraceDirection is TDOLE_TRACED_FROM, GetTracedList returns the requirements traced from the requirement specified with ReqID. That is, the specified requirement is the Trace.FromReq of the trace associations.

If TraceDirections is TDOLE_TRACED_TO, it returns the list of requirements that have a trace association where the specified requirement is the Trace.ToReq

See Also

ReqFactory Object


%%PageItemTitle%%

ReqFactory Object

Items

A list of IDs.

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also OTA COM Type Library

Mail Method

Description

Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.

Syntax

Public Sub Mail( _
   ByVal Items As Variant, _
   ByVal SendTo As String, _
   Optional ByVal SendCc As String = "", _
   Optional ByVal Option As Long = 0, _
   Optional ByVal Subject As String = "", _
   Optional ByVal Comment As String = "" _
)

Parameters

Items

A list of IDs.

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also

ReqFactory Object


%%PageItemTitle%%

ReqFactory Object

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

ReqFactory Object


%%PageItemTitle%%

ReqFactory Object

ItemKey
The requirement ID (long), a reference to the Req Object or a Variant array of Reg.IDs.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey
The requirement ID (long), a reference to the Req Object or a Variant array of Reg.IDs.

See Also

ReqFactory Object


%%PageItemTitle%%

ReqFactory Object

TypeId
A ReqType.ID.
See Also OTA COM Type Library

ReqTypeIdToName Method

Description

Returns the name of the requirement type specified by the type ID.

Syntax

Public Function ReqTypeIdToName( _
   ByVal TypeId As Long _
) As String

Parameters

TypeId
A ReqType.ID.

Return Type

The name of the type as entered in the customization module of Quality Center.

See Also

ReqFactory Object


%%PageItemTitle%%

ReqFactory Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

ReqFactory Object


%%PageItemTitle%%

ReqFactory Object

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

ReqFactory Object


%%PageItemTitle%%

ReqFactory Object

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

ReqFactory Object

Example

Getting a hierarchical list of requirements


%%PageItemTitle%%

ReqFactory Object

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

ReqFactory Object


%%PageItemTitle%%

ReqFactory Object

ItemKey
The requirement ID (long).

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey
The requirement ID (long).

See Also

ReqFactory Object


%%PageItemTitle%%

ReqTraceFactory Members

ReqTraceFactory Object

Description

Services for managing traceability associations between requirements.

Remarks

Get a reference to ReqTraceFactory from Req.ReqTraceFactory.

The factory manages Trace Objects.

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Interfaces

IBaseFactory2

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

ReqTraceFactory Object

ItemData
Either Null, a Req Object, or a Req.ID.

See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData
Either Null, a Req Object, or a Req.ID.

Return Type

A Trace Object.

Remarks

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

[Visual Basic]

Dim bgf As BugFactory
Dim bg As Bug
Dim attf As AttachmentFactory
Dim att As Attachment
Dim attList As List

' Get the factory object
 Set bgf = tdc.BugFactory
' Use defect #1
 Set bg = bgf.Item(1)
 Set attf = bg.Attachments

' Creating a new attachment
' Create virtual object, then populate the properties
 Set att = attf.AddItem(Null)
 att.FileName = Text1.Text
 att.Type = TDATT_INTERNET

' Saving the object with validity check
 att.Post

' Display the attachments
' Add the display-only items without a Post
 List1.Clear
 Set attList = attf.NewList("")
 For i = 1 To attList.Count

      Set att = attList.Item(i)
      List1.AddItem (att.Name)

 Next

See Also

ReqTraceFactory Object


%%PageItemTitle%%

ReqTraceFactory Object

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

ReqTraceFactory Object


%%PageItemTitle%%

ReqTraceFactory Object

ItemKey
A Trace.ID, a Trace Object, a variant array of Trace objects, or a List of Trace objects.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey
A Trace.ID, a Trace Object, a variant array of Trace objects, or a List of Trace objects.

See Also

ReqTraceFactory Object


%%PageItemTitle%%

ReqTraceFactory Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

ReqTraceFactory Object


%%PageItemTitle%%

ReqTraceFactory Object

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

ReqTraceFactory Object


%%PageItemTitle%%

ReqTraceFactory Object

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

ReqTraceFactory Object


%%PageItemTitle%%

ReqTraceFactory Object

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

ReqTraceFactory Object


%%PageItemTitle%%

ReqTraceFactory Object

ItemKey
A Trace.ID

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey
A Trace.ID

See Also

ReqTraceFactory Object


%%PageItemTitle%%

ReqType Members

ReqType Object

Description

Represents a Requirement Type.

Remarks

Get a reference to ReqType from Req.RequirementType.

Public Properties

Public Property HasDirectCoverage | Indicates if this requirement type supports direct coverage by tests or test instances.
Public Property Icon | The bitmap stream representing this type.
Public Property ID | The CustomizationType ID.
Public Property Name | The CustomizationType name.
Public Property RiskAnalysisType | The type of risk analysis that is applicable to this requirement.


%%PageItemTitle%%

ReqType Object

HasDirectCoverage Property

Description

Indicates if this requirement type supports direct coverage by tests or test instances.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasDirectCoverage() As Boolean

See Also

ReqType Object


%%PageItemTitle%%

ReqType Object

Icon Property

Description

The bitmap stream representing this type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Icon() As IStream

See Also

ReqType Object


%%PageItemTitle%%

ReqType Object

ID Property

Description

The CustomizationType ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Long

See Also

ReqType Object


%%PageItemTitle%%

ReqType Object

Name Property

Description

The CustomizationType name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ReqType Object


%%PageItemTitle%%

ReqType Object

RiskAnalysisType Property

Description

The type of risk analysis that is applicable to this requirement.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RiskAnalysisType() As Long

See Also

ReqType Object


%%PageItemTitle%%

RTParam Members

RTParam Object

Description

A Business Process Test runtime parameter.

Remarks

An RTParam may have a default Value. However, this value cannot be used while running a BusinessProcess test because the runtime values are specific to each iteration. Set the values in the QualityCenter user interface.

Get a reference from the list returned by BusinessProcess.RTParameters.

Example

Creating a complete Business Process Test (long example)

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Desc | The parameter description.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The component parameter's name.
Public Property Order | The position of the parameter in the set of parameters of the same component.
Public Property Value | The parameter's default value.
Public Property ValueType | The parameter type. For example Date, String, number, etc.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

RTParam Object

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

RTParam Object


%%PageItemTitle%%

RTParam Object

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

If the RTParam is created with BusinessProcess.AddRTParam, save any modifications by calling BusinessProcess.Save, rather than calling Post.

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

RTParam Object


%%PageItemTitle%%

RTParam Object

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

RTParam Object


%%PageItemTitle%%

RTParam Object

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

RTParam Object


%%PageItemTitle%%

RTParam Object

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

RTParam Object


%%PageItemTitle%%

RTParam Object

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

RTParam Object


%%PageItemTitle%%

RTParam Object

Desc Property

Description

The parameter description.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Desc() As String

See Also

RTParam Object


%%PageItemTitle%%

RTParam Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

RTParam Object


%%PageItemTitle%%

RTParam Object

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

RTParam Object


%%PageItemTitle%%

RTParam Object

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

RTParam Object


%%PageItemTitle%%

RTParam Object

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

RTParam Object


%%PageItemTitle%%

RTParam Object

Name Property

Description

The component parameter's name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

RTParam Object


%%PageItemTitle%%

RTParam Object

Order Property

Description

The position of the parameter in the set of parameters of the same component.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Order() As Long

See Also

RTParam Object


%%PageItemTitle%%

RTParam Object

Value Property

Description

The parameter's default value.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Value() As String

See Also

RTParam Object


%%PageItemTitle%%

RTParam Object

ValueType Property

Description

The parameter type. For example Date, String, number, etc.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ValueType() As String

See Also

RTParam Object


%%PageItemTitle%%

RTParam Object

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

RTParam Object


%%PageItemTitle%%

Rule Members

Rule Object

Description

Represents a rule for generating an alert.

Remarks

For more information on rules, see 'Setting Traceability Notification Rules' in the Mercury Quality Center Administrator's Guide.

Get a Rule object from the RuleManager.

Public Methods

Public Method Post Saves the changes to the Rules object to the server.

Public Properties

Public Property Description | The rule description.
Public Property ID | The rule ID.
Public Property IsActive | Indicates if the rule is active.
Public Property Recipient | Returns the user name of the recipient of the alert email.
Public Property ToMail | Indicates if the alert is to be sent by e-mail.


%%PageItemTitle%%

Rule Object

Post Method

Description

Saves the changes to the Rules object to the server.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Rule Object


%%PageItemTitle%%

Rule Object

Description Property

Description

The rule description.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Description() As String

Example

[]

<html><body>When a <b>requirement</b> changes,
notify the <b>Designer(s)</b> of the
associated <b>test(s)</b>.</body></html>

See Also

Rule Object


%%PageItemTitle%%

Rule Object

ID Property

Description

The rule ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Long

See Also

Rule Object


%%PageItemTitle%%

Rule Object

IsActive Property

Description

Indicates if the rule is active.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsActive() As Boolean

See Also

Rule Object


%%PageItemTitle%%

Rule Object

Recipient Property

Description

Returns the user name of the recipient of the alert email.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Recipient() As String

See Also

Rule Object


%%PageItemTitle%%

Rule Object

ToMail Property

Description

Indicates if the alert is to be sent by e-mail.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ToMail() As Boolean

See Also

Rule Object


%%PageItemTitle%%

RuleManager Members

RuleManager Object

Description

Services for managing the notification rules.

Remarks

For more information on rules, see 'Setting Traceability Notification Rules' in the Mercury Quality Center Administrator's Guide.

The RuleManager for the connection is TDConnection.Rules.

Public Methods

Public Method GetRule Gets a traceability notification rule by its ID.

Public Properties

Public Property Rules A list of all the Rule objects.


%%PageItemTitle%%

RuleManager Object

ID
A Rule.ID.
See Also OTA COM Type Library

GetRule Method

Description

Gets a traceability notification rule by its ID.

Syntax

Public Function GetRule( _
   ByVal ID As Long _
) As Object

Parameters

ID
A Rule.ID.

Return Type

A Rule Object.

See Also

RuleManager Object


%%PageItemTitle%%

RuleManager Object

NeedRefresh
If True, the rules in the local cache are reloaded from the project.
See Also OTA COM Type Library

Rules Property

Description

A list of all the Rule objects.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Rules( _
   Optional ByVal NeedRefresh As Boolean = False _
) As List

Parameters

NeedRefresh
If True, the rules in the local cache are reloaded from the project.

See Also

RuleManager Object


%%PageItemTitle%%

Run Members

Run Object

Description

Represents a test run.

Remarks

Get a Run object from the RunFactory.

Interfaces

IBaseField2 | IBaseField3 | ILinkable

Example

Creating various entities and linking them

Public Methods

Public Method CancelRun | Cancels the run.
Public Method CopyDesignSteps | Copies design steps into the test run of an executed test.
Public Method CopyStepsToTest | Copies all run execution steps, including new added steps, into the design steps of the corresponding planning test.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method ResolveStepsParameters | Updates the texts of the run's steps by resolving the parameter values at run time.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property BPStepParamFactory | The BPStepParamFactory for the current run.
Public Property ExtendedStorage | The ExtendedStorage object for the current run.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The run name.
Public Property Params | The step parameters of this run.
Public Property ResultLocation | The run result location, a UNC path.
Public Property Status | The run status.
Public Property StepFactory | The Step Factory for the current run.
Public Property TestId | The test ID of the test that has been run.
Public Property TestInstance | The number of this instance of the design test in the test set.
Public Property TestInstanceID | The ID of the test instance for the current run.
Public Property TestSetID | The ID of the test set to which the run belongs.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

Run Object

CancelRun Method

Description

Cancels the run.

Syntax

Public Sub CancelRun()

See Also

Run Object


%%PageItemTitle%%

Run Object

CopyDesignSteps Method

Description

Copies design steps into the test run of an executed test.

Syntax

Public Sub CopyDesignSteps()

Remarks

Call this method immediately after creating the Run object to fill the test run with copies of the design steps.

If design steps are not copied into the test run, the design steps are not displayed in the run.

See Also

Run Object


%%PageItemTitle%%

Run Object

CopyStepsToTest Method

Description

Copies all run execution steps, including new added steps, into the design steps of the corresponding planning test.

Syntax

Public Sub CopyStepsToTest()

See Also

Run Object


%%PageItemTitle%%

Run Object

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Run Object


%%PageItemTitle%%

Run Object

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Run Object


%%PageItemTitle%%

Run Object

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Run Object


%%PageItemTitle%%

Run Object

UpdateLocalCache
If True, the client cache is updated with the changed values.
See Also OTA COM Type Library

ResolveStepsParameters Method

Description

Updates the texts of the run's steps by resolving the parameter values at run time.

Syntax

Public Sub ResolveStepsParameters( _
   Optional ByVal UpdateLocalCache As Boolean = True _
)

Parameters

UpdateLocalCache
If True, the client cache is updated with the changed values.

See Also

Run Object


%%PageItemTitle%%

Run Object

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

Run Object


%%PageItemTitle%%

Run Object

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

Run Object


%%PageItemTitle%%

Run Object

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

Run Object


%%PageItemTitle%%

Run Object

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

Run Object


%%PageItemTitle%%

Run Object

BPStepParamFactory Property

Description

The BPStepParamFactory for the current run.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BPStepParamFactory() As Object

See Also

Run Object


%%PageItemTitle%%

Run Object

ExtendedStorage Property

Description

The ExtendedStorage object for the current run.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExtendedStorage() As Object

See Also

Run Object


%%PageItemTitle%%

Run Object

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName

The name of the field in the project database.

See Also

Run Object


%%PageItemTitle%%

Run Object

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

Run Object


%%PageItemTitle%%

Run Object

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

Run Object


%%PageItemTitle%%

Run Object

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

Run Object


%%PageItemTitle%%

Run Object

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

Run Object


%%PageItemTitle%%

Run Object

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

Run Object


%%PageItemTitle%%

Run Object

Name Property

Description

The run name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

Run Object


%%PageItemTitle%%

Run Object

SourceMode
A value of the tagTDAPI_RUN_PARAM_MODE Enumeration.
See Also OTA COM Type Library

Params Property

Description

The step parameters of this run.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Params( _
   ByVal SourceMode As Long _
) As Object

Parameters

SourceMode
A value of the tagTDAPI_RUN_PARAM_MODE Enumeration.

See Also

Run Object


%%PageItemTitle%%

Run Object

ResultLocation Property

Description

The run result location, a UNC path.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ResultLocation() As String

See Also

Run Object


%%PageItemTitle%%

Run Object

Status Property

Description

The run status.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Status() As String

Remarks

Common values of the Status list are:

  • NO_RUN - Default. The run is never executed.
  • NOT_COMPLETED - Execution of the run has not been completed.
  • FAILED - The run failed during test execution.
  • PASSED - The run passed during test execution.
  • N/A - The execution status for the run is not available.

You can also add a user-defined status. For more information, see 'Customizing Project Lists' in the Mercury Quality Center Administrator's Guide.

One way of using your custom status is to set the status in a Workflow script. For more information, see 'Setting up the Quality Center Workflow' in the Administrator's Guide.

See Also

Run Object


%%PageItemTitle%%

Run Object

StepFactory Property

Description

The Step Factory for the current run.

Property type

Read-only property

Syntax (Visual Basic)

Public Property StepFactory() As Object

See Also

Run Object


%%PageItemTitle%%

Run Object

TestId Property

Description

The test ID of the test that has been run.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestId() As Long

See Also

Run Object


%%PageItemTitle%%

Run Object

TestInstance Property

Description

The number of this instance of the design test in the test set.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestInstance() As Long

Remarks

For example, if a Test is used four times in a test set, Run.TestInstance is a number from 1 to 4, depending on which instance ran.

See Also

Run Object


%%PageItemTitle%%

Run Object

TestInstanceID Property

Description

The ID of the test instance for the current run.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestInstanceID() As Long

See Also

Run Object


%%PageItemTitle%%

Run Object

TestSetID Property

Description

The ID of the test set to which the run belongs.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestSetID() As Long

See Also

Run Object


%%PageItemTitle%%

Run Object

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

Run Object


%%PageItemTitle%% $$Members$$

Run Object

IBaseField3 Implemented Interface Members

Methods

Public Implemented Method Post Writes all changed values to database.

See Also

Run Object


%%PageItemTitle%%

Run Object | IBaseField3 Implemented Interface

UndoOnFailure
See Also OTA COM Type Library

Post Implemented Method

Description

Writes all changed values to database.

Syntax

Public Sub Post( _
   Optional ByVal UndoOnFailure As Boolean = True _
)

Parameters

UndoOnFailure

See Also

Run Object | IBaseField3 Implemented Interface


%%PageItemTitle%%

RunFactory Members

RunFactory Object

Description

Services for managing test runs.

Remarks

The RunFactory for the connection is TDConnection.RunFactory.

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Interfaces

IBaseFactory2 | ISupportCopyPaste2

Example

Getting a reference to an implemented interface

Public Methods

Public Method AddItem | Creates a new item object.
Public Method DeleteDuplicateRuns | Removes duplicate runs for the current test set. Removal is immediate without Post.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.
Public Property UniqueRunName | Gets the run name. The name is unique in the current test and test set.


%%PageItemTitle%%

RunFactory Object

ItemData

There are three options for ItemData:

  • Null. Creating a virtual Run object with Null ensures that you cannot then Post until the run name and all other required fields are initialized.
  • The name of the run (string).
  • An array consisting of the following elements:

    (0) Name - The name of the run (string. required).

    (1) Tester - The name of the user responsible (string. optional).

    (2) Location - The host name (string. optional). The default is the host name of the current machine.

See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData

There are three options for ItemData:

  • Null. Creating a virtual Run object with Null ensures that you cannot then Post until the run name and all other required fields are initialized.
  • The name of the run (string).
  • An array consisting of the following elements:

    (0) Name - The name of the run (string. required).

    (1) Tester - The name of the user responsible (string. optional).

    (2) Location - The host name (string. optional). The default is the host name of the current machine.

Return Type

A Run Object.

Remarks

Following a call to AddItem with an array of parameters, the Run table field RN_PATH contains the value from in the array location (2), Location, if it was passed. If array location (2) was an empty string (""), then field RN_PATH contains "a_b" where "a" is the RN_CYCLE_ID and "b" is the RN_RUN_ID. Field RN_HOST is always empty following a call AddItem.

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

[Visual Basic]

Dim bgf As BugFactory
Dim bg As Bug
Dim attf As AttachmentFactory
Dim att As Attachment
Dim attList As List

' Get the factory object
 Set bgf = tdc.BugFactory
' Use defect #1
 Set bg = bgf.Item(1)
 Set attf = bg.Attachments

' Creating a new attachment
' Create virtual object, then populate the properties
 Set att = attf.AddItem(Null)
 att.FileName = Text1.Text
 att.Type = TDATT_INTERNET

' Saving the object with validity check
 att.Post

' Display the attachments
' Add the display-only items without a Post
 List1.Clear
 Set attList = attf.NewList("")
 For i = 1 To attList.Count

      Set att = attList.Item(i)
      List1.AddItem (att.Name)

 Next

See Also

RunFactory Object


%%PageItemTitle%%

RunFactory Object

RunName
The name of the run.
See Also OTA COM Type Library

DeleteDuplicateRuns Method

Description

Removes duplicate runs for the current test set. Removal is immediate without Post.

Syntax

Public Sub DeleteDuplicateRuns( _
   ByVal RunName As String _
)

Parameters

RunName
The name of the run.

See Also

RunFactory Object


%%PageItemTitle%%

RunFactory Object

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

RunFactory Object


%%PageItemTitle%%

RunFactory Object

ItemKey
The Run.ID (long), a reference to the Run Object, or a Variant array of Run.IDs.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey
The Run.ID (long), a reference to the Run Object, or a Variant array of Run.IDs.

See Also

RunFactory Object


%%PageItemTitle%%

RunFactory Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

RunFactory Object


%%PageItemTitle%%

RunFactory Object

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

RunFactory Object


%%PageItemTitle%%

RunFactory Object

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

RunFactory Object


%%PageItemTitle%%

RunFactory Object

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

RunFactory Object


%%PageItemTitle%%

RunFactory Object

ItemKey
The run ID (long).

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey
The run ID (long).

See Also

RunFactory Object


%%PageItemTitle%%

RunFactory Object

UniqueRunName Property

Description

Gets the run name. The name is unique in the current test and test set.

Property type

Read-only property

Syntax (Visual Basic)

Public Property UniqueRunName() As String

See Also

RunFactory Object


%%PageItemTitle%%

SearchOptions Members

SearchOptions Object

Description

Options for controlling searches.

Remarks

The SearchOptions reference is returned from the CreateSearchOptions Method of the ISearchableFactory implemented interface of a factory object.

Public Properties

Public Property Filter | Get filter
Public Property Property | The search configuration flag.


%%PageItemTitle%%

SearchOptions Object

Filter Property

Description

Get filter

Property type

Read-write property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

SearchOptions Object


%%PageItemTitle%%

SearchOptions Object

Prop
A value of the tagSEARCH_OPTIONS Enumeration.
See Also OTA COM Type Library

Property Property

Description

The search configuration flag.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Property( _
   ByVal Prop As Long _
) As Variant

Parameters

Prop
A value of the tagSEARCH_OPTIONS Enumeration.

See Also

SearchOptions Object


%%PageItemTitle%%

Settings Members

Settings Object

Description

Represents users' settings in various user-defined categories.

Remarks

Settings are used by Quality Center to store various kinds of information, including user settings. They can also be used to store any application-specific data you wish.

Settings are organized by categories, analogous to settings folders. Each category can have any number of items. Each item has a value.

Begin use of the Settings object by using Open to restrict the scope to the desired category.

If the settings object is created using the UserSettings property of the TDConnection Object, the settings are only available to the user who saves them. If the object is created with the CommonSettings property, the settings are available to all users.

Public Methods

Public Method Close | Closes and updates the category.
Public Method DeleteCategory | Deletes the current settings folder.
Public Method DeleteValue | Deletes the specified item.
Public Method Open | Sets the category to be used in subsequent actions by the client.
Public Method Post | Posts the category to the server.
Public Method Refresh | Reads saved values, overwriting values in memory.

Public Properties

Public Property EnumItems | Returns the list of names of the setting's items.
Public Property IsSystem | Checks if the specified setting is built-in and read-only.
Public Property Value | The value of the specified item in the active category.


%%PageItemTitle%%

Settings Object

Close Method

Description

Closes and updates the category.

Syntax

Public Sub Close()

See Also

Settings Object


%%PageItemTitle%%

Settings Object

Category
The name of the category to delete.
See Also OTA COM Type Library

DeleteCategory Method

Description

Deletes the current settings folder.

Syntax

Public Sub DeleteCategory( _
   ByVal Category As String _
)

Parameters

Category
The name of the category to delete.

See Also

Settings Object


%%PageItemTitle%%

Settings Object

Name
The name of the entry to delete.
See Also OTA COM Type Library

DeleteValue Method

Description

Deletes the specified item.

Syntax

Public Sub DeleteValue( _
   ByVal Name As String _
)

Parameters

Name
The name of the entry to delete.

See Also

Settings Object


%%PageItemTitle%%

Settings Object

Category
The name of the category to open. The category name can not contain any of the characters: /\*?=<>|:".
See Also OTA COM Type Library

Open Method

Description

Sets the category to be used in subsequent actions by the client.

Syntax

Public Sub Open( _
   ByVal Category As String _
)

Parameters

Category
The name of the category to open. The category name can not contain any of the characters: /\*?=<>|:".

Remarks

This method sets the context locally for subseqent use of the Settings object. The method call does not result in any communications with the server.

The category can be built-in or a user-created category.

Warning: If open is not called, subsequent Settings object method calls will act on the root settings folder and all sub-folders (categories).

See Also

Settings Object


%%PageItemTitle%%

Settings Object

Post Method

Description

Posts the category to the server.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Settings Object


%%PageItemTitle%%

Settings Object

Category
The name of the category to refresh.
See Also OTA COM Type Library

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh( _
   ByVal Category As String _
)

Parameters

Category
The name of the category to refresh.

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Settings Object


%%PageItemTitle%%

Settings Object

EnumItems Property

Description

Returns the list of names of the setting's items.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EnumItems() As List

See Also

Settings Object

Example

Get the Property for a Specific Field


%%PageItemTitle%%

Settings Object

Name
The name of the setting item.
See Also OTA COM Type Library

IsSystem Property

Description

Checks if the specified setting is built-in and read-only.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsSystem( _
   ByVal Name As String _
) As Boolean

Parameters

Name
The name of the setting item.

Remarks

System settings cannot be changed by the user.

Settings created by the user are not system settings.

See Also

Settings Object


%%PageItemTitle%%

Settings Object

Name
The name of the item whose value to set or return.
See Also OTA COM Type Library

Value Property

Description

The value of the specified item in the active category.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Value( _
   ByVal Name As String _
) As String

Parameters

Name
The name of the item whose value to set or return.

Remarks

If the item has already been fetched, the value is returned from the local cache.

If ("*") is passed as the Name argument, all values are fetched into the local cache and an empty string is returned.

See Also

Settings Object


%%PageItemTitle%%

Step Members

Step Object

Description

Represents a test step in a test run.

Interfaces

IBaseField2 | IBaseField3 | ILinkable

Example

Get a Step object from the StepFactory.

Example

Creating various entities and linking them

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property BPStepParamFactory | The BPStepParamFactory for the current step.
Public Property DesignStepSource | The test ID of the test from which this step run originates.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The run step name.
Public Property Run | Gets the Run object handling this step.
Public Property Status | The run step status.
Public Property TestSource | The test ID of the test from which this step run originates.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

Step Object

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Step Object


%%PageItemTitle%%

Step Object

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Step Object


%%PageItemTitle%%

Step Object

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Step Object


%%PageItemTitle%%

Step Object

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

Step Object


%%PageItemTitle%%

Step Object

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

Step Object


%%PageItemTitle%%

Step Object

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

Step Object


%%PageItemTitle%%

Step Object

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

Step Object


%%PageItemTitle%%

Step Object

BPStepParamFactory Property

Description

The BPStepParamFactory for the current step.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BPStepParamFactory() As Object

See Also

Step Object


%%PageItemTitle%%

Step Object

DesignStepSource Property

Description

The test ID of the test from which this step run originates.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DesignStepSource() As Long

See Also

Step Object


%%PageItemTitle%%

Step Object

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName

The name of the field in the project database.

See Also

Step Object


%%PageItemTitle%%

Step Object

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

Step Object


%%PageItemTitle%%

Step Object

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

Step Object


%%PageItemTitle%%

Step Object

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

Step Object


%%PageItemTitle%%

Step Object

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

Step Object


%%PageItemTitle%%

Step Object

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

Step Object


%%PageItemTitle%%

Step Object

Name Property

Description

The run step name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

Step Object


%%PageItemTitle%%

Step Object

Run Property

Description

Gets the Run object handling this step.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Run() As Object

See Also

Step Object


%%PageItemTitle%%

Step Object

Status Property

Description

The run step status.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Status() As String

Remarks

You can create user-defined statuses by customizing the Status list. For more information, see 'Customizing Project Lists' in the Mercury Quality Center Administrator's Guide.

One way of using your custom status is to set the status in a workflow script. For more information, see 'Setting up the Quality Center Workflow' in the Mercury Quality Center Administrator's Guide.

See Also

Step Object


%%PageItemTitle%%

Step Object

TestSource Property

Description

The test ID of the test from which this step run originates.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestSource() As Long

See Also

Step Object


%%PageItemTitle%%

Step Object

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

Step Object


%%PageItemTitle%%

StepFactory Members

StepFactory Object

Description

Services for managing test steps for a Run object.

Remarks

Get a StepFactory object from Run.StepFactory.

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Interfaces

IBaseFactory2 | ISupportCopyPaste2

Example

Getting a reference to an implemented interface

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

StepFactory Object

ItemData

There are two options for ItemData:

  • Null. Creating a virtual Step object with Null ensures that you cannot then Post until all required fields are initialized.
  • An array consisting of the following elements:

(0) Name - The step name (string, required).

(1) Status - The step status (string, optional).

Possible values are:

    • NO_RUN - Default. The step is never executed.
    • NOT_COMPLETED - Execution of the step has not been completed.
    • FAILED - The step failed during test execution.
    • PASSED - The step passed during test execution.
    • N/A - The execution status for the step is not available.
    You can define additional status values.

(2) Desc - A description of the step (string, optional).

(3) Path - The file path of the step (string, optional).

(4) LineNum - The step line number (string, optional). The default value is "0."

See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData

There are two options for ItemData:

  • Null. Creating a virtual Step object with Null ensures that you cannot then Post until all required fields are initialized.
  • An array consisting of the following elements:

(0) Name - The step name (string, required).

(1) Status - The step status (string, optional).

Possible values are:

    • NO_RUN - Default. The step is never executed.
    • NOT_COMPLETED - Execution of the step has not been completed.
    • FAILED - The step failed during test execution.
    • PASSED - The step passed during test execution.
    • N/A - The execution status for the step is not available.
    You can define additional status values.

(2) Desc - A description of the step (string, optional).

(3) Path - The file path of the step (string, optional).

(4) LineNum - The step line number (string, optional). The default value is "0."

Remarks

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

[Visual Basic]

Dim bgf As BugFactory
Dim bg As Bug
Dim attf As AttachmentFactory
Dim att As Attachment
Dim attList As List

' Get the factory object
 Set bgf = tdc.BugFactory
' Use defect #1
 Set bg = bgf.Item(1)
 Set attf = bg.Attachments

' Creating a new attachment
' Create virtual object, then populate the properties
 Set att = attf.AddItem(Null)
 att.FileName = Text1.Text
 att.Type = TDATT_INTERNET

' Saving the object with validity check
 att.Post

' Display the attachments
' Add the display-only items without a Post
 List1.Clear
 Set attList = attf.NewList("")
 For i = 1 To attList.Count

      Set att = attList.Item(i)
      List1.AddItem (att.Name)

 Next

See Also

StepFactory Object


%%PageItemTitle%%

StepFactory Object

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

StepFactory Object


%%PageItemTitle%%

StepFactory Object

ItemKey
The Step.ID (long), a reference to the Step Object or a Variant array of Step.IDs.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey
The Step.ID (long), a reference to the Step Object or a Variant array of Step.IDs.

See Also

StepFactory Object


%%PageItemTitle%%

StepFactory Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

StepFactory Object


%%PageItemTitle%%

StepFactory Object

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

StepFactory Object


%%PageItemTitle%%

StepFactory Object

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

StepFactory Object


%%PageItemTitle%%

StepFactory Object

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

StepFactory Object


%%PageItemTitle%%

StepFactory Object

ItemKey
The step ID (long).

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey
The step ID (long).

See Also

StepFactory Object


%%PageItemTitle%%

StepParams Members | DesignStep Object | Test Object | TSTest Object | Run Object

See Also OTA COM Type Library

StepParams Object

Description

A collection of test parameters.

Remarks

A test parameter is a variable whose value is set at test run time. A step parameter object handles these variables.

Get a StepParams object from DesignStep.LinkedParams, Test.Params, TSTest.Params, or Run.Params.

Example

Get attributes of step parameters

Public Methods

Public Method AddParam | Adds a new parameter to the object.
Public Method ClearParam | Clears the parameter value by setting it to null.
Public Method DeleteParam | Deletes the specified parameter.
Public Method Refresh | Refreshes the data from the database, discarding changes.
Public Method Save | Uploads the parameter definitions to the database.

Public Properties

Public Property Count | The number of parameters for the object.
Public Property ParamExist | Checks if a parameter of this name exists.
Public Property ParamName | The name of the parameter in the specified position in the StepParams collection (zero-based).
Public Property ParamValue | The value of the specified parameter.
Public Property Type | Gets the parameter type: predefined, null, or regular.


%%PageItemTitle%%

StepParams Object

ParamName
The name of the new parameter.
ParamType
Always pass the string "Text".
See Also OTA COM Type Library

AddParam Method

Description

Adds a new parameter to the object.

Syntax

Public Sub AddParam( _
   ByVal ParamName As String, _
   ByVal ParamType As String _
)

Parameters

ParamName
The name of the new parameter.
ParamType
Always pass the string "Text".

See Also

StepParams Object


%%PageItemTitle%%

StepParams Object

vParam
Either the index (zero-based) in the StepParams collection, or the name of the parameter.
See Also OTA COM Type Library

ClearParam Method

Description

Clears the parameter value by setting it to null.

Syntax

Public Sub ClearParam( _
   ByVal vParam As Variant _
)

Parameters

vParam
Either the index (zero-based) in the StepParams collection, or the name of the parameter.

See Also

StepParams Object


%%PageItemTitle%%

StepParams Object

ParamName
The name of the parameter to delete.
See Also OTA COM Type Library

DeleteParam Method

Description

Deletes the specified parameter.

Syntax

Public Sub DeleteParam( _
   ByVal ParamName As String _
)

Parameters

ParamName
The name of the parameter to delete.

See Also

StepParams Object


%%PageItemTitle%%

StepParams Object

Refresh Method

Description

Refreshes the data from the database, discarding changes.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

StepParams Object


%%PageItemTitle%%

StepParams Object

Save Method

Description

Uploads the parameter definitions to the database.

Syntax

Public Sub Save()

See Also

StepParams Object


%%PageItemTitle%%

StepParams Object

Count Property

Description

The number of parameters for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

StepParams Object


%%PageItemTitle%%

StepParams Object

ParamName
The name of the parameter.
See Also OTA COM Type Library

ParamExist Property

Description

Checks if a parameter of this name exists.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ParamExist( _
   ByVal ParamName As String _
) As Boolean

Parameters

ParamName
The name of the parameter.

See Also

StepParams Object


%%PageItemTitle%%

StepParams Object

nPosition
The position (zero-based) of this parameter in the StepParams collection.
See Also OTA COM Type Library

ParamName Property

Description

The name of the parameter in the specified position in the StepParams collection (zero-based).

Property type

Read-only property

Syntax (Visual Basic)

Public Property ParamName( _
   ByVal nPosition As Long _
) As String

Parameters

nPosition
The position (zero-based) of this parameter in the StepParams collection.

See Also

StepParams Object


%%PageItemTitle%%

StepParams Object

vParam
Either the index (zero-based) in the StepParams collection, or the name of the parameter.
See Also OTA COM Type Library

ParamValue Property

Description

The value of the specified parameter.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ParamValue( _
   ByVal vParam As Variant _
) As String

Parameters

vParam
Either the index (zero-based) in the StepParams collection, or the name of the parameter.

See Also

StepParams Object


%%PageItemTitle%%

StepParams Object

vParam
Either the index (zero-based) in the StepParams collection, or the name of the parameter.
See Also OTA COM Type Library

Type Property

Description

Gets the parameter type: predefined, null, or regular.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Type( _
   ByVal vParam As Variant _
) As Long

Parameters

vParam
Either the index (zero-based) in the StepParams collection, or the name of the parameter.

See Also

StepParams Object


%%PageItemTitle%%

SubjectNode Members

SubjectNode Object

Description

Represents a subject folder in a Quality Center subject tree.

Remarks

The root subject node is TreeManager.RootList(TDOLE_SUBJECT).Item(1) or TreeManager.TreeRoot("Subject"). Get other subject node objects by walking the tree. See the example, "Getting subject nodes"

Interfaces

IBaseField2 | IBaseField3 | IObjectLockingSupport | ISupportCopyPaste2

Example

Getting subject nodes | Creating various entities and linking them | Add test plan folder to coverage | Add test | Copy test | Copy test plan folder | Delete a test plan folder | Get business process test parameters

Public Methods

Public Method AddNode | Adds a new child node.
Public Method FindChildNode | Finds a child node by node name.
Public Method FindChildren | Finds node children according to specified search pattern.
Public Method FindTests | Finds tests within the current subject folder whose name matches the specified text pattern.
Public Method Move | Moves the current tree mode to be under the specified parent.
Public Method NewList | Gets a list of the node's immediate children.
Public Method Post | Posts all changed values to the database.
Public Method Refresh | Reads the saved node data, overwriting values in memory.
Public Method RemoveSubjectNode | Removes the specified node from the subject tree.

Public Properties

Public Property Attachments | The AttachmentFactory for the subject folder.
Public Property Attribute | Gets the node attribute.
Public Property Child | Gets a sub-folder of the current folder.
Public Property Count | The number of child nodes.
Public Property DepthType | The sub-tree depth type.
Public Property Description | A description of the subject node.
Public Property Father | The current folder's parent folder.
Public Property HasAttachment | Checks if the SubjectNode has at least one attachment.
Public Property Name | The node name.
Public Property NodeID | The node ID number.
Public Property Path | The folder tree path starting from the tree root.
Public Property TestFactory | The TestFactory object for the subject folder.
Public Property ViewOrder | The position of the node in the tree as presented in the user interface.


%%PageItemTitle%%

SubjectNode Object

NodeName

The new folder name.

See Also OTA COM Type Library

AddNode Method

Description

Adds a new child node.

Syntax

Public Function AddNode( _
   ByVal NodeName As String _
) As SysTreeNode

Parameters

NodeName

The new folder name.

Return Type

A SysTreeNode Object.

See Also

SubjectNode Object


%%PageItemTitle%%

SubjectNode Object

ChildName

The folder name to find.

See Also OTA COM Type Library

FindChildNode Method

Description

Finds a child node by node name.

Syntax

Public Function FindChildNode( _
   ByVal ChildName As String _
) As SysTreeNode

Parameters

ChildName

The folder name to find.

Return Type

A SysTreeNode Object.

See Also

SubjectNode Object

Example

Getting a test subject node by the node path


%%PageItemTitle%%

SubjectNode Object

Pattern

The search string or pattern.

MatchCase

If True, the search is case-sensitive.

Filter

A logical filter. The filter can be retrieved from TDFilter.Text.

See Also OTA COM Type Library

FindChildren Method

Description

Finds node children according to specified search pattern.

Syntax

Public Function FindChildren( _
   ByVal Pattern As String, _
   Optional ByVal MatchCase As Boolean = False, _
   Optional ByVal Filter As String = "" _
) As List

Parameters

Pattern

The search string or pattern.

MatchCase

If True, the search is case-sensitive.

Filter

A logical filter. The filter can be retrieved from TDFilter.Text.

Return Type

A list of SysTreeNode objects that match the pattern and filter.

See Also

SubjectNode Object


%%PageItemTitle%%

SubjectNode Object

Pattern
Specifies the search text pattern.
MatchCase
If True, the search is case sensitive.
Filter
A logical filter to narrow the search. The filter can be retrieved from TDFilter.Text.
See Also OTA COM Type Library

FindTests Method

Description

Finds tests within the current subject folder whose name matches the specified text pattern.

Syntax

Public Function FindTests( _
   ByVal Pattern As String, _
   Optional ByVal MatchCase As Boolean = False, _
   Optional ByVal Filter As String = "" _
) As List

Parameters

Pattern
Specifies the search text pattern.
MatchCase
If True, the search is case sensitive.
Filter
A logical filter to narrow the search. The filter can be retrieved from TDFilter.Text.

Return Type

A list of Test Objects.

See Also

SubjectNode Object

Example

Get a test in a subject folder


%%PageItemTitle%%

SubjectNode Object

Parent
Either a SysTreeNode or Subject node. The argument can be a SysTreeNode Object, a SysTreeNode.NodeID, a SubjectNode Object, or a SubjectNode.NodeID .
See Also OTA COM Type Library

Move Method

Description

Moves the current tree mode to be under the specified parent.

Syntax

Public Sub Move( _
   ByVal Parent As Variant _
)

Parameters

Parent
Either a SysTreeNode or Subject node. The argument can be a SysTreeNode Object, a SysTreeNode.NodeID, a SubjectNode Object, or a SubjectNode.NodeID .

See Also

SubjectNode Object


%%PageItemTitle%%

SubjectNode Object

NewList Method

Description

Gets a list of the node's immediate children.

Syntax

Public Function NewList() As List

Return Type

A list of SysTreeNode objects in the first level below the current node.

Remarks

The list index is 1-based.

See Also

SubjectNode Object


%%PageItemTitle%%

SubjectNode Object

Post Method

Description

Posts all changed values to the database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

SubjectNode Object


%%PageItemTitle%%

SubjectNode Object

Refresh Method

Description

Reads the saved node data, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

SubjectNode Object


%%PageItemTitle%%

SubjectNode Object

Node
Either the SubjectNode Object, the node index in the child list returned by FindChildren, or the node name. The node name search is not recursive.
DeleteTests
If True, delete the tests under the node.
See Also OTA COM Type Library

RemoveSubjectNode Method

Description

Removes the specified node from the subject tree.

Syntax

Public Sub RemoveSubjectNode( _
   ByVal Node As Variant, _
   Optional ByVal DeleteTests As Boolean = False _
)

Parameters

Node
Either the SubjectNode Object, the node index in the child list returned by FindChildren, or the node name. The node name search is not recursive.
DeleteTests
If True, delete the tests under the node.

See Also

SubjectNode Object


%%PageItemTitle%%

SubjectNode Object

Attachments Property

Description

The AttachmentFactory for the subject folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

SubjectNode Object


%%PageItemTitle%%

SubjectNode Object

Attribute Property

Description

Gets the node attribute.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attribute() As Long

See Also

SubjectNode Object


%%PageItemTitle%%

SubjectNode Object

Index
The position in the list of child nodes is 1-based.

The index (1-based) represents the child level of the folder.

See Also OTA COM Type Library

Child Property

Description

Gets a sub-folder of the current folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Child( _
   ByVal Index As Long _
) As SysTreeNode

Parameters

Index
The position in the list of child nodes is 1-based.

The index (1-based) represents the child level of the folder.

See Also

SubjectNode Object


%%PageItemTitle%%

SubjectNode Object

Count Property

Description

The number of child nodes.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

SubjectNode Object


%%PageItemTitle%%

SubjectNode Object

DepthType Property

Description

The sub-tree depth type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DepthType() As Integer

See Also

SubjectNode Object


%%PageItemTitle%%

SubjectNode Object

Description Property

Description

A description of the subject node.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Description() As String

See Also

SubjectNode Object


%%PageItemTitle%%

SubjectNode Object

Father Property

Description

The current folder's parent folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Father() As SysTreeNode

See Also

SubjectNode Object


%%PageItemTitle%%

SubjectNode Object

HasAttachment Property

Description

Checks if the SubjectNode has at least one attachment.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

SubjectNode Object


%%PageItemTitle%%

SubjectNode Object

Name Property

Description

The node name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

SubjectNode Object


%%PageItemTitle%%

SubjectNode Object

NodeID Property

Description

The node ID number.

Property type

Read-only property

Syntax (Visual Basic)

Public Property NodeID() As Long

See Also

SubjectNode Object


%%PageItemTitle%%

SubjectNode Object

Path Property

Description

The folder tree path starting from the tree root.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Path() As String

See Also

SubjectNode Object


%%PageItemTitle%%

SubjectNode Object

TestFactory Property

Description

The TestFactory object for the subject folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestFactory() As Object

See Also

SubjectNode Object


%%PageItemTitle%%

SubjectNode Object

ViewOrder Property

Description

The position of the node in the tree as presented in the user interface.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ViewOrder() As Long

See Also

SubjectNode Object


%%PageItemTitle%% $$Members$$

SubjectNode Object

IBaseField3 Implemented Interface Members

Methods

Public Implemented Method Post Writes all changed values to database.

See Also

SubjectNode Object


%%PageItemTitle%%

SubjectNode Object | IBaseField3 Implemented Interface

UndoOnFailure
See Also OTA COM Type Library

Post Implemented Method

Description

Writes all changed values to database.

Syntax

Public Sub Post( _
   Optional ByVal UndoOnFailure As Boolean = True _
)

Parameters

UndoOnFailure

See Also

SubjectNode Object | IBaseField3 Implemented Interface


%%PageItemTitle%%

IObjectLockingSupport Members

IObjectLockingSupport Interface

Description

Services to support locking objects.

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property IsLocked Checks if object is locked.


%%PageItemTitle%%

SysTreeNode Members

SysTreeNode Object

Description

Represents a system folder, that is, a tree node in the TreeManager object.

Remarks

Get a SysTreeNode object from the TreeManager.

Interfaces

IBaseField2 | IBaseField3

Public Methods

Public Method AddNode | Adds a new child node.
Public Method FindChildNode | Finds a child node by node name.
Public Method FindChildren | Finds node children according to specified search pattern.
Public Method NewList | Gets a list of the node's immediate children.
Public Method Post | Posts all changed values to the database.
Public Method Refresh | Reads the saved node data, overwriting values in memory.
Public Method RemoveNode | Deletes the specified node.

Public Properties

Public Property Attribute | Gets the node attribute.
Public Property Child | Gets a sub-folder of the current folder.
Public Property Count | The number of child nodes.
Public Property DepthType | The sub-tree depth type.
Public Property Father | The current folder's parent folder.
Public Property Name | The node name.
Public Property NodeID | The node ID number.
Public Property Path | The folder tree path starting from the tree root.


%%PageItemTitle%%

SysTreeNode Object

NodeName
The new folder name.
See Also OTA COM Type Library

AddNode Method

Description

Adds a new child node.

Syntax

Public Function AddNode( _
   ByVal NodeName As String _
) As SysTreeNode

Parameters

NodeName
The new folder name.

Return Type

A SysTreeNode Object.

See Also

SysTreeNode Object


%%PageItemTitle%%

SysTreeNode Object

ChildName
The folder name to find.
See Also OTA COM Type Library

FindChildNode Method

Description

Finds a child node by node name.

Syntax

Public Function FindChildNode( _
   ByVal ChildName As String _
) As SysTreeNode

Parameters

ChildName
The folder name to find.

Return Type

A SysTreeNode Object.

See Also

SysTreeNode Object


%%PageItemTitle%%

SysTreeNode Object

Pattern
The search string or pattern.
MatchCase
If True, the search is case-sensitive.
Filter
A logical filter. The filter can be retrieved from TDFilter.Text.
See Also OTA COM Type Library

FindChildren Method

Description

Finds node children according to specified search pattern.

Syntax

Public Function FindChildren( _
   ByVal Pattern As String, _
   Optional ByVal MatchCase As Boolean = False, _
   Optional ByVal Filter As String = "" _
) As List

Parameters

Pattern
The search string or pattern.
MatchCase
If True, the search is case-sensitive.
Filter
A logical filter. The filter can be retrieved from TDFilter.Text.

Return Type

A list of SysTreeNode objects that match the pattern and filter.

See Also

SysTreeNode Object


%%PageItemTitle%%

SysTreeNode Object

NewList Method

Description

Gets a list of the node's immediate children.

Syntax

Public Function NewList() As List

Return Type

A list of SysTreeNode objects in the first level below the current node.

Remarks

The list index is 1-based.

See Also

SysTreeNode Object


%%PageItemTitle%%

SysTreeNode Object

Post Method

Description

Posts all changed values to the database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

SysTreeNode Object


%%PageItemTitle%%

SysTreeNode Object

Refresh Method

Description

Reads the saved node data, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

SysTreeNode Object


%%PageItemTitle%%

SysTreeNode Object

Node
The node name (string), index (long) of the folder, or the SysTreeNode object representing the folder.
See Also OTA COM Type Library

RemoveNode Method

Description

Deletes the specified node.

Syntax

Public Sub RemoveNode( _
   ByVal Node As Variant _
)

Parameters

Node
The node name (string), index (long) of the folder, or the SysTreeNode object representing the folder.

See Also

SysTreeNode Object


%%PageItemTitle%%

SysTreeNode Object

Attribute Property

Description

Gets the node attribute.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attribute() As Long

See Also

SysTreeNode Object


%%PageItemTitle%%

SysTreeNode Object

Index
The index (1-based) represents the child level of the folder.
See Also OTA COM Type Library

Child Property

Description

Gets a sub-folder of the current folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Child( _
   ByVal Index As Long _
) As SysTreeNode

Parameters

Index
The index (1-based) represents the child level of the folder.

See Also

SysTreeNode Object


%%PageItemTitle%%

SysTreeNode Object

Count Property

Description

The number of child nodes.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

SysTreeNode Object


%%PageItemTitle%%

SysTreeNode Object

DepthType Property

Description

The sub-tree depth type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DepthType() As Integer

See Also

SysTreeNode Object


%%PageItemTitle%%

SysTreeNode Object

Father Property

Description

The current folder's parent folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Father() As SysTreeNode

See Also

SysTreeNode Object


%%PageItemTitle%%

SysTreeNode Object

Name Property

Description

The node name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

SysTreeNode Object


%%PageItemTitle%%

SysTreeNode Object

NodeID Property

Description

The node ID number.

Property type

Read-only property

Syntax (Visual Basic)

Public Property NodeID() As Long

See Also

SysTreeNode Object


%%PageItemTitle%%

SysTreeNode Object

Path Property

Description

The folder tree path starting from the tree root.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Path() As String

See Also

SysTreeNode Object


%%PageItemTitle%% $$Members$$

SysTreeNode Object

IBaseField3 Implemented Interface Members

Methods

Public Implemented Method Post Writes all changed values to database.

See Also

SysTreeNode Object


%%PageItemTitle%%

SysTreeNode Object | IBaseField3 Implemented Interface

UndoOnFailure
See Also OTA COM Type Library

Post Implemented Method

Description

Writes all changed values to database.

Syntax

Public Sub Post( _
   Optional ByVal UndoOnFailure As Boolean = True _
)

Parameters

UndoOnFailure

See Also

SysTreeNode Object | IBaseField3 Implemented Interface


%%PageItemTitle%%

TDConnection Members

TDConnection Object

Description

Represents a single server connection.

Remarks

The TDConnection object is the object instantiated at the beginning of an Open Test Architecture application run. Nearly all other objects can be created from the TDConnection object or from objects created from the TDConnection object. A small number of utility objects are the only objects created without reference to the TDConnection object.

The first method to call with TDConnection is InitConnectionEx. After the connection is initialized, authenticate a user with Login.

Connect establishes a new project session for the logged-in user. Disconnect should be called at the end of each project session.

Before the application exits, call ReleaseConnection.

Public Methods

Public Method ChangePassword | Changes the password for the currently logged in user.
Public Method Connect | Connects the logged-in user to the specified project in the domain.
Public Method ConnectProject | Connects to the specified project.
Public Method ConnectProjectEx | Connects to the specified project in the specified domain.
Public Method Disconnect | Disconnects the user from the currently connected project.
Public Method DisconnectProject | Disconnects from the project.
Public Method GetLicenses | Allocates multiple licenses types according to the LicensesType parameter.
Public Method GetLicenseStatus | The license status for the specified client type.
Public Method GetTDParamsNames | Returns the names of the site's parameters.
Public Method GetTDVersion | The major and minor versions of the OTA API.
Public Method InitConnectionEx | Initializes the connection.
Public Method Login | Confirms that the user is authorized to use Quality Center. If authorized, the user is logged in and can connect to projects.
Public Method Logout | Terminates the user's session on this TDConnection.
Public Method PurgeRuns | Deletes the runs in this connection that match the input arguments.
Public Method ReleaseConnection | ReleaseConnection must be called for each call of an initialization method after finishing work with the Open Test Architecture API.
Public Method SendMail | Sends Mail.

Public Properties

Public Property ActionPermission | The ActionPermission object for this connection.
Public Property AlertManager | The AlertManager object for this connection.
Public Property ApplicationEntityFactory | The application entity factory object for this connection.
Public Property ApplicationEntityTreeManager | The application entity tree and related application entity folders factory for this connection.
Public Property AuditPropertyFactory | The global AuditProperty factory, not associated with a specific entity.
Public Property AuditRecordFactory | The global AuditRecord factory, not associated with a specific entity.
Public Property BugFactory | The Bug Factory object for this connection.
Public Property CheckoutRepository | The path of the checkout repository.
Public Property Command | The Command object for this connection.
Public Property CommonSettings | The Settings object for all users in this connection.
Public Property Connected | Checks if the Open Test Architecture API server connection is initialized.
Public Property Customization | The Customization object for this connection.
Public Property CycleFactory | The factory that manages cycles.
Public Property DBName | The name of the database.
Public Property DBType | The database type.
Public Property DirectoryPath | The path of the server side repository directory for the database repository type.
Public Property DomainName | The current domain.
Public Property DomainsList | The domain names for this site.
Public Property ExtendedStorage | The ExtendedStorage object for this connection.
Public Property Fields | A list of fields for the table specified in the DataType argument.
Public Property GraphBuilder | The GraphBuilder object for the connection.
Public Property HostFactory | The Hosts Factory object for this connection.
Public Property HostGroupFactory | The HostGroupFactory object for this connection.
Public Property IgnoreHtmlFormat | Indicates if formatted memo and description fields are returned as plain text without HTML tags.
Public Property IsSearchSupported | Checks if the search function is enabled for the project.
Public Property LoggedIn | Checks if a user is currently logged in on this TDConnection.
Public Property MailConditions | The TDMailConditions object for this connection.
Public Property ProductInfo | An IProductInfo reference pointing to the current build information.
Public Property ProjectConnected | Checks if the TDConnection is connected to a project.
Public Property ProjectName | The name of the connected project.
Public Property ProjectProperties | The ProjectProperties object for this connection.
Public Property ProjectsList | The projects that are available in the domain to which Quality Center is connected.
Public Property ProjectsListEx | The projects available within the specified domain.
Public Property ReleaseFactory | The factory that manages releases.
Public Property ReleaseFolderFactory | The factory that manages release folders.
Public Property ReportRole | The report role of the connected user.
Public Property ReqFactory | The ReqFactory object for this connection.
Public Property Rules | The RuleManager object for this connection.
Public Property RunFactory | The RunFactory object for this connection.
Public Property ServerName | The name of the connected Open Test Architecture API server.
Public Property ServerTime | The time and date of the currently connected database server.
Public Property ServerURL | The URL of the connected server.
Public Property ServiceChangeFactory | The service change factory object for this connection.
Public Property ServiceFactory | The service factory object for this connection.
Public Property ServiceFolderFactory | The service folder factory object for this connection.
Public Property ServiceGroupFactory | The service group factory object for this connection.
Public Property TDParams | Gets the value of the parameter whose name is specified by Request.
Public Property TestFactory | The Test Factory object for this connection.
Public Property TestRepository | The path of the tests directory of the connected project.
Public Property TestSetFactory | The Test Set Factory object for this connection.
Public Property TestSetTreeManager | The TestSetTreeManager object for this connection.
Public Property TextParam | The TextParser object.
Public Property TreeManager | The TreeManager object for the system tree.
Public Property TSTestFactory | The factory that manages test instances in test sets.
Public Property UserGroupsList | The names of the user groups of the currently connected project.
Public Property UserName | The user connected to the project.
Public Property UserSettings | The Settings object for the logged-on user.
Public Property UsersList | The names of the users of the currently connected project.
Public Property UsingProgress | Indicates if a progress bar is displayed.
Public Property VCS | The Version Control System (VCS) object for this connection.
Public Property VcsDbRepository | The path of the VCS database of the connected project.
Public Property VisibleDomains | The list of domain names that the current logged in user is permitted to view.
Public Property VisibleProjects | The list of projects in the specified domain that the current logged in user is allowed to connect to.


%%PageItemTitle%%

TDConnection Object

OldPassword
The current password before the change.
NewPassword
The new password.
See Also OTA COM Type Library

ChangePassword Method

Description

Changes the password for the currently logged in user.

Syntax

Public Sub ChangePassword( _
   ByVal OldPassword As String, _
   ByVal NewPassword As String _
)

Parameters

OldPassword
The current password before the change.
NewPassword
The new password.

See Also

TDConnection Object

Example

Changing the logged on user's password


%%PageItemTitle%%

TDConnection Object

DomainName
The logical group of projects in the Quality Center data base.
ProjectName
The name of the project in the Quality Center data base.
See Also OTA COM Type Library

Connect Method

Description

Connects the logged-in user to the specified project in the domain.

Syntax

Public Sub Connect( _
   ByVal DomainName As String, _
   ByVal ProjectName As String _
)

Parameters

DomainName
The logical group of projects in the Quality Center data base.
ProjectName
The name of the project in the Quality Center data base.

Remarks

Call Connect only if there is a logged-in user (LoggedIn is True). After a successful Connect, both the LoggedIn property and the Connected property are True.

See Also

TDConnection Object

Example

Connect and Log on


%%PageItemTitle%%

TDConnection Object

Disconnect Method

Description

Disconnects the user from the currently connected project.

Syntax

Public Sub Disconnect()

Remarks

Disconnect is called when the logged-in user is connected to a project. After Disconnect, the user is still authenticated on the server and can Connect to a different project without logging in again.

After the Disconnect call, LoggedIn is still True and Connected is False.

See Also

TDConnection Object

Example

Disconnect project and release connection


%%PageItemTitle%%

TDConnection Object

LicensesType
A bit mask composed of members of the tagTDLICENSE_CLIENT Enumeration combined with a bit-wise OR. Each bit set in the mask indicates that the description of the license of that type is to be returned in the output argument.
pVal
The output description of the licenses: Type code, approval status, and UID.
See Also OTA COM Type Library

GetLicenses Method

Description

Allocates multiple licenses types according to the LicensesType parameter.

Syntax

Public Sub GetLicenses( _
   ByVal LicensesType As Long, _
   ByRef pVal As String _
)

Parameters

LicensesType
A bit mask composed of members of the tagTDLICENSE_CLIENT Enumeration combined with a bit-wise OR. Each bit set in the mask indicates that the description of the license of that type is to be returned in the output argument.
pVal
The output description of the licenses: Type code, approval status, and UID.

Remarks

For details of the return string, see the example. Error codes in the return string are from the tagTDAPI_ERRORCODES Enumeration.

See Also

TDConnection Object

Example

Get licence descriptions


%%PageItemTitle%%

TDConnection Object

ClientType
A value of the tagTDAPI_LICENSE Enumeration.
InUse
The number of modules of the specified type currently in use.
Max
The maximum number of modules of the specified type that can be used simultaneously.
See Also OTA COM Type Library

GetLicenseStatus Method

Description

The license status for the specified client type.

Syntax

Public Sub GetLicenseStatus( _
   ByVal ClientType As Long, _
   ByRef InUse As Long, _
   ByRef Max As Long _
)

Parameters

ClientType
A value of the tagTDAPI_LICENSE Enumeration.
InUse
The number of modules of the specified type currently in use.
Max
The maximum number of modules of the specified type that can be used simultaneously.

See Also

TDConnection Object

Example

Get licence status


%%PageItemTitle%%

TDConnection Object

GetTDParamsNames Method

Description

Returns the names of the site's parameters.

Syntax

Public Function GetTDParamsNames() As List

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

pbsMajorVersion
The release number.
pbsBuildNum
The intermediate release number.
See Also OTA COM Type Library

GetTDVersion Method

Description

The major and minor versions of the OTA API.

Syntax

Public Sub GetTDVersion( _
   ByRef pbsMajorVersion As String, _
   ByRef pbsBuildNum As String _
)

Parameters

pbsMajorVersion
The release number.
pbsBuildNum
The intermediate release number.

See Also

TDConnection Object

Example

Get API Version


%%PageItemTitle%%

TDConnection Object

ServerName
The Quality Center URL: http://<server>[:port]/qcbin
See Also OTA COM Type Library

InitConnectionEx Method

Description

Initializes the connection.

Syntax

Public Sub InitConnectionEx( _
   ByVal ServerName As String _
)

Parameters

ServerName
The Quality Center URL: http://<server>[:port]/qcbin

Remarks

InitConnectionEx must be called before a user can be authenticated with Login.

See Also

TDConnection Object

Example

Connect and Log on


%%PageItemTitle%%

TDConnection Object

UserName
The Quality Center use name.
Password
The user's password.
See Also OTA COM Type Library

Login Method

Description

Confirms that the user is authorized to use Quality Center. If authorized, the user is logged in and can connect to projects.

Syntax

Public Sub Login( _
   ByVal UserName As String, _
   ByVal Password As String _
)

Parameters

UserName
The Quality Center use name.
Password
The user's password.

Remarks

Before authenticating a user with Login, connect to the server with InitConnectionEx.

After a successful call to Login, the user is authenticated on the server, but not connected to any project. Therefore, the LoggedIn Property is True and the Connected Property is False.

See Also

TDConnection Object

Example

Connect and Log on


%%PageItemTitle%%

TDConnection Object

Logout Method

Description

Terminates the user's session on this TDConnection.

Syntax

Public Sub Logout()

See Also

TDConnection Object

Example

Disconnect project and release connection


%%PageItemTitle%%

TDConnection Object

TestSetFilter
The filter specifying the test sets from which the runs should be deleted. The filter can be a list of cycle IDs like "1,5,78,14", a status like "CY_STATUS='Open'", or a TDFilter.Text.
KeepLast
The number of most recent test instance runs not to purge.
DateUnit

Either a date string, in which case runs before this date are purged, or a unit code used to interpret the unit count. A unit code is one of:

1 for Days
2 for Weeks
3 for Months
4 for Years

UnitCount
If DateUnit is not a date string, this is the number of units. For example, if DateUnit is 1 and UnitCount is 5, purge all runs older than 5 days.
StepsOnly
If True, purge only the steps, but not the runs. If False, purge both the runs and steps.
See Also OTA COM Type Library

PurgeRuns Method

Description

Deletes the runs in this connection that match the input arguments.

Syntax

Public Sub PurgeRuns( _
   ByVal TestSetFilter As String, _
   ByVal KeepLast As Long, _
   ByVal DateUnit As Variant, _
   ByVal UnitCount As Long, _
   ByVal StepsOnly As Boolean _
)

Parameters

TestSetFilter
The filter specifying the test sets from which the runs should be deleted. The filter can be a list of cycle IDs like "1,5,78,14", a status like "CY_STATUS='Open'", or a TDFilter.Text.
KeepLast
The number of most recent test instance runs not to purge.
DateUnit

Either a date string, in which case runs before this date are purged, or a unit code used to interpret the unit count. A unit code is one of:

1 for Days
2 for Weeks
3 for Months
4 for Years

UnitCount
If DateUnit is not a date string, this is the number of units. For example, if DateUnit is 1 and UnitCount is 5, purge all runs older than 5 days.
StepsOnly
If True, purge only the steps, but not the runs. If False, purge both the runs and steps.

Remarks

KeepLast overrides OlderThan. For example, if KeepLast is 10, OlderThan is 2 and UnitCount is 5, the meaning is "Purge all runs older than 5 weeks, but keep the last 10 runs for each test instance regardless of age".

See Also

TDConnection Object

Example

Purge runs from a single test set


%%PageItemTitle%%

TDConnection Object

ReleaseConnection Method

Description

ReleaseConnection must be called for each call of an initialization method after finishing work with the Open Test Architecture API.

Syntax

Public Sub ReleaseConnection()

See Also

TDConnection Object

Example

Disconnect project and release connection


%%PageItemTitle%%

TDConnection Object

SendTo
A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.
SendFrom
No longer in use. The actual "From" address is the email associated with the connected user. Pass an empty string ("").
Subject
The subject of the e-mail.
Message
The body of the e-mail.
attachArray
A Variant Array, each element of which is an Attachment.ServerFileName
bsFormat
The mail format, either "HTML", "TEXT" or any other string. Any string other than "HTML" is interpreted as text.
See Also OTA COM Type Library

SendMail Method

Description

Sends Mail.

Syntax

Public Sub SendMail( _
   ByVal SendTo As String, _
   Optional ByVal SendFrom As String = "", _
   Optional ByVal Subject As String = "", _
   Optional ByVal Message As String = "", _
   Optional ByVal attachArray As Variant, _
   Optional ByVal bsFormat As String = "" _
)

Parameters

SendTo
A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.
SendFrom
No longer in use. The actual "From" address is the email associated with the connected user. Pass an empty string ("").
Subject
The subject of the e-mail.
Message
The body of the e-mail.
attachArray
A Variant Array, each element of which is an Attachment.ServerFileName
bsFormat
The mail format, either "HTML", "TEXT" or any other string. Any string other than "HTML" is interpreted as text.

See Also

TDConnection Object

Example

Adding attachments to a defect and mailing them | Sending a simple email between users


%%PageItemTitle%%

TDConnection Object

ActionPermission Property

Description

The ActionPermission object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ActionPermission() As Object

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

AlertManager Property

Description

The AlertManager object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AlertManager() As Object

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

ApplicationEntityFactory Property

Description

The application entity factory object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ApplicationEntityFactory() As Object

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

ApplicationEntityTreeManager Property

Description

The application entity tree and related application entity folders factory for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ApplicationEntityTreeManager() As Object

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

AuditPropertyFactory Property

Description

The global AuditProperty factory, not associated with a specific entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AuditPropertyFactory() As Object

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

AuditRecordFactory Property

Description

The global AuditRecord factory, not associated with a specific entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AuditRecordFactory() As Object

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

BugFactory Property

Description

The Bug Factory object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BugFactory() As Object

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

CheckoutRepository Property

Description

The path of the checkout repository.

Property type

Read-only property

Syntax (Visual Basic)

Public Property CheckoutRepository() As String

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

Command Property

Description

The Command object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Command() As Object

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

CommonSettings Property

Description

The Settings object for all users in this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property CommonSettings() As Object

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

Connected Property

Description

Checks if the Open Test Architecture API server connection is initialized.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Connected() As Boolean

Remarks

Connected is True after a successful call to InitConnectionEx. It is False after a call to ReleaseConnection.

Note that Connected is the status of the connection to the server, not of the connection to a project. To check if a project is connected, use the ProjectConnected property.

See Also

TDConnection Object

Example

Connect and Log on | Disconnect project and release connection


%%PageItemTitle%%

TDConnection Object

Customization Property

Description

The Customization object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Customization() As Object

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

CycleFactory Property

Description

The factory that manages cycles.

Property type

Read-only property

Syntax (Visual Basic)

Public Property CycleFactory() As Object

Get or Set Value Type

A CycleFactory Object.

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

DBName Property

Description

The name of the database.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DBName() As String

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

DBType Property

Description

The database type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DBType() As String

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

nType
The database repository type, a value of the tagTDAPI_DIRECTORY Enumeration.
See Also OTA COM Type Library

DirectoryPath Property

Description

The path of the server side repository directory for the database repository type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DirectoryPath( _
   ByVal nType As Long _
) As String

Parameters

nType
The database repository type, a value of the tagTDAPI_DIRECTORY Enumeration.

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

DomainName Property

Description

The current domain.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DomainName() As String

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

ExtendedStorage Property

Description

The ExtendedStorage object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExtendedStorage() As Object

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

DataType
The name of a system table.
See Also OTA COM Type Library

Fields Property

Description

A list of fields for the table specified in the DataType argument.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields( _
   ByVal DataType As String _
) As List

Parameters

DataType
The name of a system table.

Remarks

Some possible values for DataType are:

"ALL_LISTS" for Subject
"BUG" for Defect
"CYCL_FOLD" for Test Set Folder
"CYCLE" for Test Set
"DESSTEPS" for Design Step
"REQ" for Requirement
"RUN" for Run
"STEP" for Run Step
"TEST" for Test
"TESTCYCL" for Test in Test Set (Test Instance)

For more possibilities, see the Quality Center Database Reference.

See Also

TDConnection Object

Example

Get list of fields in a table | Get the Property for a Specific Field


%%PageItemTitle%%

TDConnection Object

GraphBuilder Property

Description

The GraphBuilder object for the connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property GraphBuilder() As Object

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

HostFactory Property

Description

The Hosts Factory object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HostFactory() As Object

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

HostGroupFactory Property

Description

The HostGroupFactory object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HostGroupFactory() As Object

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

IgnoreHtmlFormat Property

Description

Indicates if formatted memo and description fields are returned as plain text without HTML tags.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IgnoreHtmlFormat() As Boolean

Remarks

This setting affects the behavior of other APIs that return formatted text fields.

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

IsSearchSupported Property

Description

Checks if the search function is enabled for the project.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsSearchSupported() As Boolean

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

LoggedIn Property

Description

Checks if a user is currently logged in on this TDConnection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property LoggedIn() As Boolean

Remarks

LoggedIn indicates if a user is authenticated on a connection that has been initialized. A reference to the LoggedIn property when Connected is False causes a run-time error.

See Also

TDConnection Object

Example

Connect and Log on | Disconnect project and release connection


%%PageItemTitle%%

TDConnection Object

MailConditions Property

Description

The TDMailConditions object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property MailConditions() As Object

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object | ProductInfo Object

ProductInfo Property

Description

An IProductInfo reference pointing to the current build information.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ProductInfo() As Object

See Also

TDConnection Object | ProductInfo Object


%%PageItemTitle%%

TDConnection Object

ProjectConnected Property

Description

Checks if the TDConnection is connected to a project.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ProjectConnected() As Boolean

Remarks

True after a success call to Connect and False after a call to Disconnect Method.

See Also

TDConnection Object

Example

Disconnect project and release connection


%%PageItemTitle%%

TDConnection Object

ProjectName Property

Description

The name of the connected project.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ProjectName() As String

Remarks

If no project is connected, the property is an empty string.

See Also

TDConnection Object

Example

Connect and Log on


%%PageItemTitle%%

TDConnection Object

ProjectProperties Property

Description

The ProjectProperties object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ProjectProperties() As Object

See Also

TDConnection Object

Example

Print project properties


%%PageItemTitle%%

TDConnection Object

ProjectsList Property

Description

The projects that are available in the domain to which Quality Center is connected.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ProjectsList() As List

See Also

TDConnection Object

Example

List the projects for a connection


%%PageItemTitle%%

TDConnection Object

ReleaseFactory Property

Description

The factory that manages releases.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ReleaseFactory() As Object

Get or Set Value Type

A ReleaseFactory Object.

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

ReleaseFolderFactory Property

Description

The factory that manages release folders.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ReleaseFolderFactory() As Object

Get or Set Value Type

A ReleaseFolderFactory Object.

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

ReportRole Property

Description

The report role of the connected user.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ReportRole() As String

Remarks

See the Advanced Reports Guide.

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

ReqFactory Property

Description

The ReqFactory object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ReqFactory() As Object

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

Rules Property

Description

The RuleManager object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Rules() As Object

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

RunFactory Property

Description

The RunFactory object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RunFactory() As Object

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

ServerName Property

Description

The name of the connected Open Test Architecture API server.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ServerName() As String

Remarks

If no server is connected, returns an empty string.

See Also

TDConnection Object

Example

Connect and Log on


%%PageItemTitle%%

TDConnection Object

ServerTime Property

Description

The time and date of the currently connected database server.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ServerTime() As Date

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

ServerURL Property

Description

The URL of the connected server.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ServerURL() As String

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

ServiceChangeFactory Property

Description

The service change factory object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ServiceChangeFactory() As Object

Remarks

This object is available only if the Service Oriented Architecture extension is enabled.

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

ServiceFactory Property

Description

The service factory object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ServiceFactory() As Object

Remarks

This object is available only if the Service Oriented Architecture extension is enabled.

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

ServiceFolderFactory Property

Description

The service folder factory object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ServiceFolderFactory() As Object

Remarks

This object is available only if the Service Oriented Architecture extension is enabled.

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

ServiceGroupFactory Property

Description

The service group factory object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ServiceGroupFactory() As Object

Remarks

This object is available only if the Service Oriented Architecture extension is enabled.

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

Request
The name of a parameter from the Site Configuration tab in the Site Administrator UI.
See Also OTA COM Type Library

TDParams Property

Description

Gets the value of the parameter whose name is specified by Request.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TDParams( _
   ByVal Request As String _
) As String

Parameters

Request
The name of a parameter from the Site Configuration tab in the Site Administrator UI.

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

TestFactory Property

Description

The Test Factory object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestFactory() As Object

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

TestRepository Property

Description

The path of the tests directory of the connected project.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestRepository() As String

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

TestSetFactory Property

Description

The Test Set Factory object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestSetFactory() As Object

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

TestSetTreeManager Property

Description

The TestSetTreeManager object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestSetTreeManager() As Object

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

TextParam Property

Description

The TextParser object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TextParam() As Object

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

TreeManager Property

Description

The TreeManager object for the system tree.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TreeManager() As Object

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

TSTestFactory Property

Description

The factory that manages test instances in test sets.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TSTestFactory() As Object

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

UserGroupsList Property

Description

The names of the user groups of the currently connected project.

Property type

Read-only property

Syntax (Visual Basic)

Public Property UserGroupsList() As List

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

UserName Property

Description

The user connected to the project.

Property type

Read-only property

Syntax (Visual Basic)

Public Property UserName() As String

See Also

TDConnection Object

Example

Changing the logged on user's password


%%PageItemTitle%%

TDConnection Object

UserSettings Property

Description

The Settings object for the logged-on user.

Property type

Read-only property

Syntax (Visual Basic)

Public Property UserSettings() As Object

See Also

TDConnection Object

Example

Get User Settings


%%PageItemTitle%%

TDConnection Object

UsersList Property

Description

The names of the users of the currently connected project.

Property type

Read-only property

Syntax (Visual Basic)

Public Property UsersList() As List

See Also

TDConnection Object

Example

List the users for a connection


%%PageItemTitle%%

TDConnection Object

UsingProgress Property

Description

Indicates if a progress bar is displayed.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UsingProgress() As Boolean

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

VCS Property

Description

The Version Control System (VCS) object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property VCS() As Object

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

VcsDbRepository Property

Description

The path of the VCS database of the connected project.

Property type

Read-only property

Syntax (Visual Basic)

Public Property VcsDbRepository() As String

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

VisibleDomains Property

Description

The list of domain names that the current logged in user is permitted to view.

Property type

Read-only property

Syntax (Visual Basic)

Public Property VisibleDomains() As List

Remarks

The user belongs to domains that contain projects to which the user belongs.

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

DomainName
The logical group of projects in the Quality Center data base.
See Also OTA COM Type Library

VisibleProjects Property

Description

The list of projects in the specified domain that the current logged in user is allowed to connect to.

Property type

Read-only property

Syntax (Visual Basic)

Public Property VisibleProjects( _
   ByVal DomainName As String _
) As List

Parameters

DomainName
The logical group of projects in the Quality Center data base.

See Also

TDConnection Object


%%PageItemTitle%%

TDField Members

TDField Object

Description

Properties for a field.

Remarks

Get a TDField object from the Fields property of any factory object or from TDConnection.Fields.

Example

Compare TDField properties and FieldProperty properties

Public Methods

Public Method IsValidValue Checks if the input value is valid for the field.

Public Properties

Public Property Name | The database name of the current field.
Public Property Property | The FieldProperty object associated with the current field.
Public Property Type | The field database type.


%%PageItemTitle%%

TDField Object

Value
The value to check.
pObject
Any object that implements the IBaseField Interface.
See Also OTA COM Type Library

IsValidValue Method

Description

Checks if the input value is valid for the field.

Syntax

Public Sub IsValidValue( _
   ByVal Value As Variant, _
   ByVal pObject As Object _
)

Parameters

Value
The value to check.
pObject
Any object that implements the IBaseField Interface.

Return Type

In Visual Basic, the value is returned in the error object's Number attribute . Check the value immediately after the call to IsValidValue, as any intervening call may change the error object. In other languages, check the HRESULT.

Possible values are:

  • S_OK - Valid value. Note that valid value does not necessary mean the value can be set. For example, a value for a key field may be valid, but you cannot write to a key field. Note that in Visual Basic, S_OK is returned as zero.
  • FIELD_E_VERIFIED - Invalid value.
  • TDOLE_NONODE - The value is rejected for any reason. For example, the field is linked to a list and the value is not in the list.

See Also

TDField Object

Example

Checking valid values for fields


%%PageItemTitle%%

TDField Object

Name Property

Description

The database name of the current field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name() As String

See Also

TDField Object


%%PageItemTitle%%

TDField Object

Property Property

Description

The FieldProperty object associated with the current field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Property() As Object

See Also

TDField Object


%%PageItemTitle%%

TDField Object

Type Property

Description

The field database type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Type() As Long

See Also

TDField Object


%%PageItemTitle%%

TDFilter Members

TDFilter Object

Description

Services for creation of a filtered list of field objects without SQL.

Remarks

Get a TDFilter from the Filter property of any factory object except ReqFactory or from History.Filter.

A HierarchyFilter is a filter that can return the parents of items as well as the items themselves. Get a HierarchyFilter with ReqFactory.Filter.

A filter cannot handle OR conditions between different fields nor sort on a user-defined field.

A filter always has a primary filter on an entity and may also have a secondary filter, or XFilter, on a second entity. A filter without an XFilter specifies a list of the objects that meet all the criteria specified by setting the TDFilter.Filter or HierarchyFilter.Filter. A filter may have several Filter properties defined.

A filter with an XFilter specifies a list of all the objects of the first type that meet the Filter criteria, and that are associated with the objects of the second type that meet the criteria in the XFilter text. The XFilter text is set with the SetXFilter method or by setting the XFilter property .

For example, a TEST-TESTSET XFilter is a TDfilter derived from a Test factory. The first clause is created by setting the Filter to specify the desired tests. The XFilter is created by getting a second TDFilter from a TestSetFactory and setting the Filter property to specify the desired test sets. The text of this test set TDFilter is the XFilter text of primary test TDFilter.

The result is a list of tests that meet the TDFilter.Filter criteria and are associated with at least one of the test sets that meet the TDFilter.XFilter criteria.

The association between the entities can be direct, as in a links between requirements and defects, or it can be indirect. For example, TSTEST-REQ selects test instances (TSTEST) based on design tests (TEST) that cover requirements.

Interfaces

ISupportEntityTypes

Example

Getting a filtered, sorted list of requirements | Filtering defect records | Getting those test instances that do, and those that do not, cover a requirement | Getting the list of design tests used in a test set | Filter requirements by type | Find cycles that match a condition | Get filtered releases under a specified folder | Find tests that are not in any test set | Find tests that do not cover any requirement | Find requirements modified in specified period

Public Methods

Public Method Clear | Clears the current filter.
Public Method GetXFilter | Gets the cross filter specified by CrossEntities.
Public Method IsClear | Checks whether the filter is clear, including cross-filter settings
Public Method NewList | Creates a new list from current filter.
Public Method Refresh | Reads saved data and refreshes the fetched list according to the current filter, overwriting values in memory.
Public Method SetXFilter | Sets the filter for second entity, called a cross filter.

Public Properties

Public Property CaseSensitive | Indicates if the filter for the specified field is case sensitive. The default is False.
Public Property DataType | The filtered entity type.
Public Property Fields | The list of fields for the TDFilter's parent object.
Public Property Filter | The filter condition for the field specified by the FieldName.
Public Property Order | The position of the specified field in the list of the sort fields. (zero-based)
Public Property OrderDirection | The sort order: TDOLE_ASCENDING or TDOLE_DESCENDING
Public Property Text | The full fields filter as text.
Public Property XFilter | The cross filter according to the entity type.


%%PageItemTitle%%

TDFilter Object

Clear Method

Description

Clears the current filter.

Syntax

Public Sub Clear()

See Also

TDFilter Object


%%PageItemTitle%%

TDFilter Object

CrossEntities

Possible values: BUG-ALERT, BUG-REQ, BUG-TEST, BUG-TESTSET, REQ-ALERT, REQ-BUG, REQ-TEST, REQ-TO-FROM-REQ, RUN-BUG, TEST-ALERT, TEST-BUG, TEST-INSTANCE-ALERT, TEST-REQ, TEST-TESTSET, TEST-VER_CTRL, TESTCYCL-ALERT,
TESTSET-BUG, TESTSET-TEST, TSTEST-BUG, TSTEST-REQ, TSTEST-TEST-TEQ, and TSTEST-TSTEST-REQ.

Inclusive

Output variable.

If True, the filter specifies the set of objects where the conditions for the first entity and for the second entity are all true.

If False, the filter specifies the set of objects where the conditions for the first entity are true and the conditions for the second entity are not true.

See Also OTA COM Type Library

GetXFilter Method

Description

Gets the cross filter specified by CrossEntities.

Syntax

Public Function GetXFilter( _
   ByVal CrossEntities As String, _
   ByRef Inclusive As Boolean _
) As String

Parameters

CrossEntities

Possible values: BUG-ALERT, BUG-REQ, BUG-TEST, BUG-TESTSET, REQ-ALERT, REQ-BUG, REQ-TEST, REQ-TO-FROM-REQ, RUN-BUG, TEST-ALERT, TEST-BUG, TEST-INSTANCE-ALERT, TEST-REQ, TEST-TESTSET, TEST-VER_CTRL, TESTCYCL-ALERT,
TESTSET-BUG, TESTSET-TEST, TSTEST-BUG, TSTEST-REQ, TSTEST-TEST-TEQ, and TSTEST-TSTEST-REQ.

Inclusive

Output variable.

If True, the filter specifies the set of objects where the conditions for the first entity and for the second entity are all true.

If False, the filter specifies the set of objects where the conditions for the first entity are true and the conditions for the second entity are not true.

Return Type

The text representation of the filter.

See Also

TDFilter Object

Example

Using GetXFilter


%%PageItemTitle%%

TDFilter Object

IsClear Method

Description

Checks whether the filter is clear, including cross-filter settings

Syntax

Public Function IsClear() As Boolean

See Also

TDFilter Object


%%PageItemTitle%%

TDFilter Object

NewList Method

Description

Creates a new list from current filter.

Syntax

Public Function NewList() As List

See Also

TDFilter Object

Example

Filtering defect records


%%PageItemTitle%%

TDFilter Object

Refresh Method

Description

Reads saved data and refreshes the fetched list according to the current filter, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

TDFilter Object


%%PageItemTitle%%

TDFilter Object

CrossEntities
Possible values: BUG-ALERT, BUG-REQ, BUG-TEST, BUG-TESTSET, REQ-ALERT, REQ-BUG, REQ-TEST, REQ-TO-FROM-REQ, RUN-BUG, TEST-ALERT, TEST-BUG, TEST-INSTANCE-ALERT, TEST-REQ, TEST-TESTSET, TEST-VER_CTRL, TESTCYCL-ALERT,
TESTSET-BUG, TESTSET-TEST, TSTEST-BUG, TSTEST-REQ, TSTEST-TEST-TEQ, and TSTEST-TSTEST-REQ.
Inclusive

If True, the filter specifies the set of objects where the conditions for the first entity and for the second entity are all true.

If False, the filter specifies the set of objects where the conditions for the first entity are true and the conditions for the second entity are not true.

FilterText
A TDFilter.Text or a string that would be a valid TDFilter.Text
See Also OTA COM Type Library

SetXFilter Method

Description

Sets the filter for second entity, called a cross filter.

Syntax

Public Sub SetXFilter( _
   ByVal CrossEntities As String, _
   ByVal Inclusive As Boolean, _
   ByVal FilterText As String _
)

Parameters

CrossEntities
Possible values: BUG-ALERT, BUG-REQ, BUG-TEST, BUG-TESTSET, REQ-ALERT, REQ-BUG, REQ-TEST, REQ-TO-FROM-REQ, RUN-BUG, TEST-ALERT, TEST-BUG, TEST-INSTANCE-ALERT, TEST-REQ, TEST-TESTSET, TEST-VER_CTRL, TESTCYCL-ALERT,
TESTSET-BUG, TESTSET-TEST, TSTEST-BUG, TSTEST-REQ, TSTEST-TEST-TEQ, and TSTEST-TSTEST-REQ.
Inclusive

If True, the filter specifies the set of objects where the conditions for the first entity and for the second entity are all true.

If False, the filter specifies the set of objects where the conditions for the first entity are true and the conditions for the second entity are not true.

FilterText
A TDFilter.Text or a string that would be a valid TDFilter.Text

Remarks

The best way to ensure that the Filter text is valid, is to create a TDFilter with the cross-filter conditions, and use its Text property as this value.

See Also

TDFilter Object

Example

Getting those test instances that do, and those that do not, cover a requirement | Getting the list of design tests used in a test set | Getting the list of design tests used in a test set


%%PageItemTitle%%

TDFilter Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

CaseSensitive Property

Description

Indicates if the filter for the specified field is case sensitive. The default is False.

Property type

Read-write property

Syntax (Visual Basic)

Public Property CaseSensitive( _
   ByVal FieldName As String _
) As Boolean

Parameters

FieldName
The name of the field in the project database.

See Also

TDFilter Object


%%PageItemTitle%%

TDFilter Object

DataType Property

Description

The filtered entity type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DataType() As String

See Also

TDFilter Object


%%PageItemTitle%%

TDFilter Object

Fields Property

Description

The list of fields for the TDFilter's parent object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

Remarks

The list depends on the factory from which the TDFilter was created. For example, if the filter is created from a TestFactory, the field list will consist of the names of the Test fields: TS_ATTACHMENT, TS_CREATION_DATE, TS_DESCRIPTION, TS_RESPONSIBLE, TS_STATUS, TS_SUBJECT, TS_TEMPLATE, TS_TEST_ID, TS_NAME, and so on.

See Also

TDFilter Object


%%PageItemTitle%%

TDFilter Object

FieldName

The name of a field of the entity to which the filter is applied.

Only fields whose FieldProperty.IsCanFilter Property is true can be used.

See Also OTA COM Type Library

Filter Property

Description

The filter condition for the field specified by the FieldName.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Filter( _
   ByVal FieldName As String _
) As String

Parameters

FieldName

The name of a field of the entity to which the filter is applied.

Only fields whose FieldProperty.IsCanFilter Property is true can be used.

Remarks

Although the Filter property has the syntax of a single property, a TDFilter can have a collection of Filter properties, each on a different field. Set the Filter property for one field with each command.

A Filter setting is a value of the field, a value with an operator, or a set of values connected by operators.

The values can be constants, special tokens such as "[Today]", "[PreviousWeek]", or "[NextYear]", or folder names, such as "^Subject\LinkFolder^". Use the set filter dialog in the the relevant module of the Quality Center UI to explore the possibilities.

String values with spaces must be quoted, for example, TestFilter.Filter("TS_EXEC_STATUS") = """No Run"""

The value can be an expression with a wild card. For example, testsetFilter.Filter("CY_CYCLE") = "GS*" filters for all test sets whose names begin with "GS".

See Also

TDFilter Object

Example

Getting a filtered, sorted list of requirements | Setting filters on multiple fields


%%PageItemTitle%%

TDFilter Object

FieldName
The name of the database field whose sort priority is to be retrieved or set.
See Also OTA COM Type Library

Order Property

Description

The position of the specified field in the list of the sort fields. (zero-based)

Property type

Read-write property

Syntax (Visual Basic)

Public Property Order( _
   ByVal FieldName As String _
) As Long

Parameters

FieldName
The name of the database field whose sort priority is to be retrieved or set.

Remarks

When the order of one field is set with this property, no adjustments are made to the positions of other fields. The application is responsible for ensuring that the orders of all the fields are as required, that no two fields occupy the same position, and there are no empty positions.

When two or more fields are assigned the same order, the actual order is undetermined.

See Also

TDFilter Object

Example

Getting a filtered, sorted list of requirements | Retrieving sorted requirements


%%PageItemTitle%%

TDFilter Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

OrderDirection Property

Description

The sort order: TDOLE_ASCENDING or TDOLE_DESCENDING

Property type

Read-write property

Syntax (Visual Basic)

Public Property OrderDirection( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

TDFilter Object

Example

Retrieving sorted requirements


%%PageItemTitle%%

TDFilter Object

Text Property

Description

The full fields filter as text.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Text() As String

Remarks

In most places where a string-type Filter argument is passed to a method that selects items, for example to create a filtered list, it is this Text property that is passed to the method.

This text is displayed in the Quality Center user interface above the grid when a filter is set.

See Also

TDFilter Object


%%PageItemTitle%%

TDFilter Object

CrossEntity
Possible values: BUG-ALERT, BUG-REQ, BUG-TEST, BUG-TESTSET, REQ-ALERT, REQ-BUG, REQ-TEST, REQ-TO-FROM-REQ, RUN-BUG, TEST-ALERT, TEST-BUG, TEST-INSTANCE-ALERT, TEST-REQ, TEST-TESTSET, TEST-VER_CTRL, TESTCYCL-ALERT,
TESTSET-BUG, TESTSET-TEST, TSTEST-BUG, TSTEST-REQ, TSTEST-TEST-TEQ, and TSTEST-TSTEST-REQ.
See Also OTA COM Type Library

XFilter Property

Description

The cross filter according to the entity type.

Property type

Read-write property

Syntax (Visual Basic)

Public Property XFilter( _
   ByVal CrossEntity As String _
) As String

Parameters

CrossEntity
Possible values: BUG-ALERT, BUG-REQ, BUG-TEST, BUG-TESTSET, REQ-ALERT, REQ-BUG, REQ-TEST, REQ-TO-FROM-REQ, RUN-BUG, TEST-ALERT, TEST-BUG, TEST-INSTANCE-ALERT, TEST-REQ, TEST-TESTSET, TEST-VER_CTRL, TESTCYCL-ALERT,
TESTSET-BUG, TESTSET-TEST, TSTEST-BUG, TSTEST-REQ, TSTEST-TEST-TEQ, and TSTEST-TSTEST-REQ.

Remarks

Setting this property is equivalent to calling SetXFilter with Inclusive = TRUE.

See Also

TDFilter Object

Example

Listing defects associated with a requirement and requirements associated with a defect


%%PageItemTitle%%

ISupportEntityTypes Members

ISupportEntityTypes Interface

Description

Provides services for entities that support entity types.

Public Methods

Public Method GetTypedFields | The list of fields for the given type.
Public Method IsFieldRelevantToType | Indicates whether the field is used in this type.
Public Method IsFieldRequiredInType | Indicates whether the field is required in this type.


%%PageItemTitle%%

TDMailConditions Members

TDMailConditions Object

Description

Services for managing automatic mail notifications.

Remarks

Automatic mail notification is sent when a defect changes and there is a mail condition defined for the change.
A condition consists of two parameters:

  • Mail recipient - specifies who will be receiving the notification
  • Defect matching rule - a filter string, generally a TDFilter.Text

There are two ways to specify a mail recipient: direct and indirect.
To specify a recipient directly, use the user name.
To specify a recipient indirectly, use the name of field that holds the user name. Indirect recipient specifications can only use the Detected By (BG_DETECTED_BY) and Assigned To (BG_RESPONSIBLE) fields.

The TDMailConditions object for the connection is TDConnection.MailConditions.

Public Methods

Public Method Close | Closes and updates Mail Condition.
Public Method DeleteCondition | Deletes the Mail Condition.
Public Method Load | Loads Mail Conditions.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Condition | The defect-matching rule.
Public Property IsLocked | Checks if object is locked.
Public Property ItemList | Gets the list of Mail Condition Users.


%%PageItemTitle%%

TDMailConditions Object

NeedToSave
If true, post changes to project when Close is called.
See Also OTA COM Type Library

Close Method

Description

Closes and updates Mail Condition.

Syntax

Public Sub Close( _
   ByVal NeedToSave As Boolean _
)

Parameters

NeedToSave
If true, post changes to project when Close is called.

See Also

TDMailConditions Object


%%PageItemTitle%%

TDMailConditions Object

Name
Either a user name or a field name.
IsUserCondition
Pass True if Name specifies a user name. Pass False if Name specifies a field.
See Also OTA COM Type Library

DeleteCondition Method

Description

Deletes the Mail Condition.

Syntax

Public Sub DeleteCondition( _
   ByVal Name As String, _
   ByVal IsUserCondition As Boolean _
)

Parameters

Name
Either a user name or a field name.
IsUserCondition
Pass True if Name specifies a user name. Pass False if Name specifies a field.

See Also

TDMailConditions Object


%%PageItemTitle%%

TDMailConditions Object

Load Method

Description

Loads Mail Conditions.

Syntax

Public Sub Load()

See Also

TDMailConditions Object


%%PageItemTitle%%

TDMailConditions Object

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

TDMailConditions Object


%%PageItemTitle%%

TDMailConditions Object

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

TDMailConditions Object


%%PageItemTitle%%

TDMailConditions Object

Name
The mail recipient.
IsUserCondition
Pass True if Name is a user name. Pass False if Name is the field containing the name.
See Also OTA COM Type Library

Condition Property

Description

The defect-matching rule.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Condition( _
   ByVal Name As String, _
   ByVal IsUserCondition As Boolean _
) As String

Parameters

Name
The mail recipient.
IsUserCondition
Pass True if Name is a user name. Pass False if Name is the field containing the name.

See Also

TDMailConditions Object


%%PageItemTitle%%

TDMailConditions Object

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

TDMailConditions Object


%%PageItemTitle%%

TDMailConditions Object

GetRealNames
If True, return only recipients specified directly in the conditions. If False, return all recipients, regardless of how specified.
See Also OTA COM Type Library

ItemList Property

Description

Gets the list of Mail Condition Users.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ItemList( _
   Optional ByVal GetRealNames As Boolean = False _
) As List

Parameters

GetRealNames
If True, return only recipients specified directly in the conditions. If False, return all recipients, regardless of how specified.

See Also

TDMailConditions Object


%%PageItemTitle%%

Test Members

Test Object

Description

Represents a planning test.

Interfaces

IAlertable2 | IBaseField2 | IBaseField3 | ICoverable | IFollowUpManager | ILinkable

Example

Get a test object from a TestFactory.

Example

Finding a unique test | Accessing members of Additional Implemented Interfaces | Get a test object with name and path | Deleting a test attachment | Downloading test files and attachments | Creating various entities and linking them | Find tests that do not cover any requirement | Add component to test | Add test | Check if test has alert | Copy test | Delete test | Get business process test parameters | Set alert on test | Unlock test

Public Methods

Public Method CoverRequirement | Adds the specified requirement to the list of requirements covered by this test.
Public Method GetCoverList | Gets the list of all requirements covered by this test.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Mail | Mails the IBaseFieldExMail field item.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method RemoveCoverage | Removes a requirement from the list of requirements this test covers.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property CheckoutPathIfExist | The checkout path for the test.
Public Property DesignStepFactory | The design steps factory for the current test.
Public Property DesStepsNum | The number of design steps in the test.
Public Property ExecDate | The test execution date and time.
Public Property ExecStatus | The test execution status.
Public Property ExtendedStorage | The Extended Storage object for the current test.
Public Property Field | The value of the specified field.
Public Property FullPath | The full file system path for the test.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property HasCoverage | Checks if the test covers at least one requirement.
Public Property HasParam | Checks if the test has at least one parameter.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property LastRun | The last Run object for this test.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The test name.
Public Property Params | The current test parameters.
Public Property TemplateTest | Indicates if this test is a template test.
Public Property Type | The test type.
Public Property VCS | The VCS version control object for this test.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

Test Object

Req
A requirement ID or a Req Object.
Order

Not in use. Pass TDAPI_POS_ORDER.TDPOSITION_LAST [-4] .

Recursive
If true, all child requirements will be covered by this test.
See Also OTA COM Type Library

CoverRequirement Method

Description

Adds the specified requirement to the list of requirements covered by this test.

Syntax

Public Function CoverRequirement( _
   ByVal Req As Variant, _
   ByVal Order As Long, _
   ByVal Recursive As Boolean _
) As Long

Parameters

Req
A requirement ID or a Req Object.
Order

Not in use. Pass TDAPI_POS_ORDER.TDPOSITION_LAST [-4] .

Recursive
If true, all child requirements will be covered by this test.

Return Type

Not in use. Ignore return value.

See Also

Test Object


%%PageItemTitle%%

Test Object

GetCoverList Method

Description

Gets the list of all requirements covered by this test.

Syntax

Public Function GetCoverList() As List

Return Type

A list of Req Objects.

See Also

Test Object


%%PageItemTitle%%

Test Object

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Test Object


%%PageItemTitle%%

Test Object

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also OTA COM Type Library

Mail Method

Description

Mails the IBaseFieldExMail field item.

Syntax

Public Sub Mail( _
   ByVal SendTo As String, _
   Optional ByVal SendCc As String = "", _
   Optional ByVal Option As Long = 0, _
   Optional ByVal Subject As String = "", _
   Optional ByVal Comment As String = "" _
)

Parameters

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also

Test Object


%%PageItemTitle%%

Test Object

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Test Object


%%PageItemTitle%%

Test Object

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Test Object


%%PageItemTitle%%

Test Object

Req
The Req Object representing the requirement that this test will no longer cover.
See Also OTA COM Type Library

RemoveCoverage Method

Description

Removes a requirement from the list of requirements this test covers.

Syntax

Public Sub RemoveCoverage( _
   ByVal Req As Variant _
)

Parameters

Req
The Req Object representing the requirement that this test will no longer cover.

See Also

Test Object


%%PageItemTitle%%

Test Object

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

Test Object


%%PageItemTitle%%

Test Object

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

Test Object


%%PageItemTitle%%

Test Object

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

Test Object

Example

Deleting a test attachment


%%PageItemTitle%%

Test Object

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

Test Object


%%PageItemTitle%%

Test Object

CheckoutPathIfExist Property

Description

The checkout path for the test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property CheckoutPathIfExist() As String

Remarks

If the project is not under version control or if the object is not checked out, then the checkout path is not defined. In that case, the method returns NULL.

See Also

Test Object


%%PageItemTitle%%

Test Object

DesignStepFactory Property

Description

The design steps factory for the current test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DesignStepFactory() As Object

See Also

Test Object


%%PageItemTitle%%

Test Object

DesStepsNum Property

Description

The number of design steps in the test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DesStepsNum() As Long

See Also

Test Object


%%PageItemTitle%%

Test Object

ExecDate Property

Description

The test execution date and time.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExecDate() As Date

See Also

Test Object


%%PageItemTitle%%

Test Object

ExecStatus Property

Description

The test execution status.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExecStatus() As String

See Also

Test Object


%%PageItemTitle%%

Test Object

ExtendedStorage Property

Description

The Extended Storage object for the current test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExtendedStorage() As Object

See Also

Test Object


%%PageItemTitle%%

Test Object

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName

The name of the field in the project database.

Remarks

If the field name is "TS_SUBJECT", a SubjectNode Object is returned.

See Also

Test Object


%%PageItemTitle%%

Test Object

FullPath Property

Description

The full file system path for the test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FullPath() As String

See Also

Test Object


%%PageItemTitle%%

Test Object

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

Test Object


%%PageItemTitle%%

Test Object

HasCoverage Property

Description

Checks if the test covers at least one requirement.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasCoverage() As Boolean

See Also

Test Object


%%PageItemTitle%%

Test Object

HasParam Property

Description

Checks if the test has at least one parameter.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasParam() As Boolean

See Also

Test Object


%%PageItemTitle%%

Test Object

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

Test Object


%%PageItemTitle%%

Test Object

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

Test Object


%%PageItemTitle%%

Test Object

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

Test Object


%%PageItemTitle%%

Test Object

LastRun Property

Description

The last Run object for this test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property LastRun() As Object

See Also

Test Object


%%PageItemTitle%%

Test Object

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

Test Object


%%PageItemTitle%%

Test Object

Name Property

Description

The test name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

Test Object


%%PageItemTitle%%

Test Object

Params Property

Description

The current test parameters.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Params() As Object

See Also

Test Object


%%PageItemTitle%%

Test Object

TemplateTest Property

Description

Indicates if this test is a template test.

Property type

Read-write property

Syntax (Visual Basic)

Public Property TemplateTest() As Boolean

See Also

Test Object


%%PageItemTitle%%

Test Object

Type Property

Description

The test type.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Type() As String

Remarks

The test type is either a native Quality Center type or a custom test type. Examples of native test types are BUSINESS-PROCESS, LR-SCENARIO, MANUAL, QUICKTEST_TEST, and SYSTEM-TEST.

See Also

Test Object


%%PageItemTitle%%

Test Object

VCS Property

Description

The VCS version control object for this test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property VCS() As Object

See Also

Test Object


%%PageItemTitle%%

Test Object

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

Test Object


%%PageItemTitle%% $$Members$$

Test Object

IBaseField3 Implemented Interface Members

Methods

Public Implemented Method Post Writes all changed values to database.

See Also

Test Object


%%PageItemTitle%%

Test Object | IBaseField3 Implemented Interface

UndoOnFailure
See Also OTA COM Type Library

Post Implemented Method

Description

Writes all changed values to database.

Syntax

Public Sub Post( _
   Optional ByVal UndoOnFailure As Boolean = True _
)

Parameters

UndoOnFailure

See Also

Test Object | IBaseField3 Implemented Interface


%%PageItemTitle%%

ICoverable Members

ICoverable Interface

Description

Represents an entity that covers a requirement.

Public Methods

Public Method CoverRequirementEx Adds the specified requirement to the list of requirements covered by this entity. Optionally, also adds child requirements.

Public Properties

Public Property CoverageFactory The CoverageFactory for the entity.


%%PageItemTitle%%

TestExecStatus Members

TestExecStatus Object

Description

Represents the execution status of the test currently running.

Remarks

This object contains properties only for the test currently running. The TSScheduler ExecutionStatus Property is a reference to an ExecutionStatus object for the whole running session. Iterate through the ExecutionStatus object to get the test execution status for each test, or use the ExecutionStatus.Item Property.

Example

Getting status information when running a test set

Public Properties

Public Property Message | The test execution message displayed in the Execution Controller grid.
Public Property Status | The test execution status.
Public Property TestId | The test Id.
Public Property TestInstance | The number of this instance of the design test in the test set.
Public Property TSTestId | The ID of the test instance for the current run.


%%PageItemTitle%%

TestExecStatus Object

Message Property

Description

The test execution message displayed in the Execution Controller grid.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Message() As String

See Also

TestExecStatus Object


%%PageItemTitle%%

TestExecStatus Object

Status Property

Description

The test execution status.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Status() As String

See Also

TestExecStatus Object


%%PageItemTitle%%

TestExecStatus Object

TestId Property

Description

The test Id.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestId() As Long

See Also

TestExecStatus Object


%%PageItemTitle%%

TestExecStatus Object

TestInstance Property

Description

The number of this instance of the design test in the test set.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestInstance() As Long

Remarks

For example, if a Test is used four times in a test set, TestInstance is a number from 1 to 4, depending on which instance is running.

See Also

TestExecStatus Object


%%PageItemTitle%%

TestExecStatus Object

TSTestId Property

Description

The ID of the test instance for the current run.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TSTestId() As Variant

See Also

TestExecStatus Object


%%PageItemTitle%%

TestFactory Members

TestFactory Object

Description

Services for managing tests.

Remarks

Get a TestFactory object from TDConnection.TestFactory or SubjectNode.TestFactory

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Interfaces

IAlertableEntityFactory | IBaseFactory2 | ISearchableFactory | ISupportCopyPaste2

Example

Getting a reference to an implemented interface | Find tests that are not in any test set | Find tests that do not cover any requirement | Add component to test | Add test | Check if test has alert | Copy test | Delete test | Get business process test parameters

Public Methods

Public Method AddItem | Creates a new item object.
Public Method BuildPerfGraph | Creates Performance Graph.
Public Method BuildProgressGraph | Creates graph showing number of tests in a test set executed over a period of time.
Public Method BuildProgressGraphEx | Creates graph showing number of tests in a test set executed over a period of time.
Public Method BuildSummaryGraph | Creates summary graph showing number of tests executed in a test set according to test and test run.
Public Method BuildTrendGraph | Creates graph that shows the number of defect status changes over time.
Public Method Mail | Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.
Public Property RepositoryStorage | An ExtendedStorage object connected by default to the test repository folder on the server side. Enables file system operations with a test repository.


%%PageItemTitle%%

TestFactory Object

ItemData

There are three options for ItemData:

  • Null. Initially creating a virtual Test object with Null ensures that you cannot then Post until all required fields are initialized.
  • The test name.
  • An array consisting of the following elements:

(0) Name - The test name (required).

(1) Type - The test type (string, optional). The possible test types are detailed in the table below.

(2) Tester - The name of the user that created the test (string, optional). The default value is the name of the user currently logged in (string, optional).

(3) SubjectID - The ID of the subject folder in which to create the test (long, optional).

See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData

There are three options for ItemData:

  • Null. Initially creating a virtual Test object with Null ensures that you cannot then Post until all required fields are initialized.
  • The test name.
  • An array consisting of the following elements:

(0) Name - The test name (required).

(1) Type - The test type (string, optional). The possible test types are detailed in the table below.

(2) Tester - The name of the user that created the test (string, optional). The default value is the name of the user currently logged in (string, optional).

(3) SubjectID - The ID of the subject folder in which to create the test (long, optional).

Return Type

A Test Object.

Remarks

Test Types
Test Type | Description
MANUAL | Default. A Quality Center manual test.
WR-AUTOMATED | A WinRunner automated test.
WR-BATCH | A WinRunner batch test.
LR-SCENARIO | A LoadRunner simulated environment test.
XR-AUTOMATED | An XRunner automated test.
QUICKTEST_TEST | An Astra QuickTest or QuickTest Professional test.
QTSAP-TESTCASE | A QuickTest Professional for MySAP.com Windows Client test.
VAPI-XP-TEST | A test to be performed by the Quality Center Visual API-XP test execution tool.
SYSTEM-TEST | A test involving system actions.
DB-TEST | A Vuser script test.

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

[Visual Basic]

Dim bgf As BugFactory
Dim bg As Bug
Dim attf As AttachmentFactory
Dim att As Attachment
Dim attList As List

' Get the factory object
 Set bgf = tdc.BugFactory
' Use defect #1
 Set bg = bgf.Item(1)
 Set attf = bg.Attachments

' Creating a new attachment
' Create virtual object, then populate the properties
 Set att = attf.AddItem(Null)
 att.FileName = Text1.Text
 att.Type = TDATT_INTERNET

' Saving the object with validity check
 att.Post

' Display the attachments
' Add the display-only items without a Post
 List1.Clear
 Set attList = attf.NewList("")
 For i = 1 To attList.Count

      Set att = attList.Item(i)
      List1.AddItem (att.Name)

 Next

See Also

TestFactory Object


%%PageItemTitle%%

TestFactory Object

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildPerfGraph Method

Description

Creates Performance Graph.

Syntax

Public Function BuildPerfGraph( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

TestFactory Object


%%PageItemTitle%%

TestFactory Object

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildProgressGraph Method

Description

Creates graph showing number of tests in a test set executed over a period of time.

Syntax

Public Function BuildProgressGraph( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MajorSkip As Long = 0, _
   Optional ByVal MinorSkip As Long = 1, _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

TestFactory Object


%%PageItemTitle%%

TestFactory Object

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

ByHistory

Determines whether to use history information to create the graph. Possible values are:

TRUE - Use history information.

FALSE - Do not use history information.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. Zero indicates no limit.

Filter

The TDFilter Object that sets the criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildProgressGraphEx Method

Description

Creates graph showing number of tests in a test set executed over a period of time.

Syntax

Public Function BuildProgressGraphEx( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal ByHistory As Boolean = True, _
   Optional ByVal MajorSkip As Long = 0, _
   Optional ByVal MinorSkip As Long = 1, _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

ByHistory

Determines whether to use history information to create the graph. Possible values are:

TRUE - Use history information.

FALSE - Do not use history information.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. Zero indicates no limit.

Filter

The TDFilter Object that sets the criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

TestFactory Object


%%PageItemTitle%%

TestFactory Object

XAxisField

A database field representing the name of the graph x-axis.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildSummaryGraph Method

Description

Creates summary graph showing number of tests executed in a test set according to test and test run.

Syntax

Public Function BuildSummaryGraph( _
   Optional ByVal XAxisField As String = "", _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

XAxisField

A database field representing the name of the graph x-axis.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

TestFactory Object


%%PageItemTitle%%

TestFactory Object

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildTrendGraph Method

Description

Creates graph that shows the number of defect status changes over time.

Syntax

Public Function BuildTrendGraph( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

TestFactory Object


%%PageItemTitle%%

TestFactory Object

Items

A list of IDs.

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also OTA COM Type Library

Mail Method

Description

Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.

Syntax

Public Sub Mail( _
   ByVal Items As Variant, _
   ByVal SendTo As String, _
   Optional ByVal SendCc As String = "", _
   Optional ByVal Option As Long = 0, _
   Optional ByVal Subject As String = "", _
   Optional ByVal Comment As String = "" _
)

Parameters

Items

A list of IDs.

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also

TestFactory Object


%%PageItemTitle%%

TestFactory Object

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

TestFactory Object


%%PageItemTitle%%

TestFactory Object

ItemKey
The Test.ID (long), a reference to the Test Object, or a Variant array of Test.IDs.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey
The Test.ID (long), a reference to the Test Object, or a Variant array of Test.IDs.

See Also

TestFactory Object


%%PageItemTitle%%

TestFactory Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

TestFactory Object


%%PageItemTitle%%

TestFactory Object

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

TestFactory Object


%%PageItemTitle%%

TestFactory Object

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

Remarks

When TS_SUBJECT is used as one of the filter fields, the subject is the full path to the test in the tree, including the root node. For example:

TestFilter.Filter("TS_SUBJECT") = "Subject\Folder1\Subfolder2"

See Also

TestFactory Object

Example

Get a test object with name and path


%%PageItemTitle%%

TestFactory Object

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

TestFactory Object


%%PageItemTitle%%

TestFactory Object

ItemKey
A long integer.

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey
A long integer.

See Also

TestFactory Object


%%PageItemTitle%%

TestFactory Object

RepositoryStorage Property

Description

An ExtendedStorage object connected by default to the test repository folder on the server side. Enables file system operations with a test repository.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RepositoryStorage() As Object

See Also

TestFactory Object

Example

Operations on the test repository


%%PageItemTitle%%

TestSet Members

TestSet Object

Description

A group of tests designed to meet a specific testing goal.

Remarks

Get a TestSet object from a TestSetFactory.

Interfaces

IBaseField2 | IBaseField3 | ILinkable

Example

Get attributes of TestSets and TSTests | Add test set | Copy test set | Move test set

Public Methods

Public Method BuildPerfGraph | Creates Performance Graph.
Public Method BuildProgressGraph | Builds test set progress graph.
Public Method BuildProgressGraphEx | Builds test set progress graph.
Public Method BuildSummaryGraph | Builds test set summary graph.
Public Method BuildTrendGraph | Creates graph that shows the test set changes over time.
Public Method CheckTestInstances | Gets information about the instances of the specified test in this test set.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method PurgeExecutions | Purges all the running executions within the test set.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method ResetTestSet | Sets the status of each test in the test set to 'No Run'.
Public Method StartExecution | Starts the execution controller.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property ConditionFactory | The condition factory object for the current test set.
Public Property ExecEventNotifyByMailSettings | Gets the execution mail notification settings for the current test set.
Public Property ExecutionSettings | Gets the execution settings for the test set.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The test set name.
Public Property Status | The test set status.
Public Property TestDefaultExecutionSettings | Gets default execution settings for tests.
Public Property TestSetFolder | The test set's parent node.
Public Property TSTestFactory | The factory object for the current test set.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

TestSet Object

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildPerfGraph Method

Description

Creates Performance Graph.

Syntax

Public Function BuildPerfGraph( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

TestSet Object


%%PageItemTitle%%

TestSet Object

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildProgressGraph Method

Description

Builds test set progress graph.

Syntax

Public Function BuildProgressGraph( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MajorSkip As Long = 0, _
   Optional ByVal MinorSkip As Long = 1, _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

TestSet Object


%%PageItemTitle%%

TestSet Object

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

ByHistory

Determines whether to use history information to create the graph. Possible values are:

TRUE - Use history information.

FALSE - Do not use history information.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. Zero indicates no limit.

Filter

The TDFilter Object that sets the criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildProgressGraphEx Method

Description

Builds test set progress graph.

Syntax

Public Function BuildProgressGraphEx( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal ByHistory As Boolean = True, _
   Optional ByVal MajorSkip As Long = 0, _
   Optional ByVal MinorSkip As Long = 1, _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

ByHistory

Determines whether to use history information to create the graph. Possible values are:

TRUE - Use history information.

FALSE - Do not use history information.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. Zero indicates no limit.

Filter

The TDFilter Object that sets the criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

TestSet Object


%%PageItemTitle%%

TestSet Object

XAxisField

A database field representing the name of the graph x-axis.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildSummaryGraph Method

Description

Builds test set summary graph.

Syntax

Public Function BuildSummaryGraph( _
   Optional ByVal XAxisField As String = "", _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

XAxisField

A database field representing the name of the graph x-axis.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

TestSet Object


%%PageItemTitle%%

TestSet Object

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildTrendGraph Method

Description

Creates graph that shows the test set changes over time.

Syntax

Public Function BuildTrendGraph( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

TestSet Object


%%PageItemTitle%%

TestSet Object

TestIDs
A Test.ID or a comma-separated list of IDs.
See Also OTA COM Type Library

CheckTestInstances Method

Description

Gets information about the instances of the specified test in this test set.

Syntax

Public Function CheckTestInstances( _
   ByVal TestIDs As String _
) As String

Parameters

TestIDs
A Test.ID or a comma-separated list of IDs.

Return Type

For each Test ID, an output line of format:

{NUM_OF_INSTANCES:<count>, TS_TEST_ID:<ID number>, TS_NAME:<name>, TS_TYPE:<type>, TS_STEPS:<step count>, TS_TEMPLATE:<template name> }

See Also

TestSet Object

Example

Get details of a particular test in a test set | Getting a test subject node by the node path


%%PageItemTitle%%

TestSet Object

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

TestSet Object


%%PageItemTitle%%

TestSet Object

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

TestSet Object


%%PageItemTitle%%

TestSet Object

PurgeExecutions Method

Description

Purges all the running executions within the test set.

Syntax

Public Sub PurgeExecutions()

See Also

TestSet Object


%%PageItemTitle%%

TestSet Object

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

TestSet Object


%%PageItemTitle%%

TestSet Object

DeleteRuns
If TRUE, the method deletes all runs for all tests in the test set.
See Also OTA COM Type Library

ResetTestSet Method

Description

Sets the status of each test in the test set to 'No Run'.

Syntax

Public Sub ResetTestSet( _
   ByVal DeleteRuns As Boolean _
)

Parameters

DeleteRuns
If TRUE, the method deletes all runs for all tests in the test set.

See Also

TestSet Object


%%PageItemTitle%%

TestSet Object

ServerName
The name of the host for the scheduler. If an empty string is passed, localhost is used.
See Also OTA COM Type Library

StartExecution Method

Description

Starts the execution controller.

Syntax

Public Function StartExecution( _
   ByVal ServerName As String _
) As Object

Parameters

ServerName
The name of the host for the scheduler. If an empty string is passed, localhost is used.

Return Type

A TSScheduler Object.

Remarks

The scheduler server is not necessarily the machine on which the tests will run, only the machine on which the scheduler runs. The remote test execution hosts can be set with properties of the TSScheduler Object.

The TSScheduler can perform only one run. If you want to perform more than one run, then after calling TSScheduler.Run, call this method again to get a new TSScheduler object.

See Also

TestSet Object

Example

Running the test instances in a test set locally, remotely, or as planned


%%PageItemTitle%%

TestSet Object

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

TestSet Object


%%PageItemTitle%%

TestSet Object

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

TestSet Object


%%PageItemTitle%%

TestSet Object

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

TestSet Object


%%PageItemTitle%%

TestSet Object

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

TestSet Object


%%PageItemTitle%%

TestSet Object

ConditionFactory Property

Description

The condition factory object for the current test set.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ConditionFactory() As Object

See Also

TestSet Object


%%PageItemTitle%%

TestSet Object

ExecEventNotifyByMailSettings Property

Description

Gets the execution mail notification settings for the current test set.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExecEventNotifyByMailSettings() As Object

See Also

TestSet Object


%%PageItemTitle%%

TestSet Object

ExecutionSettings Property

Description

Gets the execution settings for the test set.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExecutionSettings() As Object

See Also

TestSet Object


%%PageItemTitle%%

TestSet Object

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName

The name of the field in the project database.

See Also

TestSet Object


%%PageItemTitle%%

TestSet Object

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

TestSet Object


%%PageItemTitle%%

TestSet Object

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

TestSet Object


%%PageItemTitle%%

TestSet Object

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

TestSet Object


%%PageItemTitle%%

TestSet Object

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

TestSet Object


%%PageItemTitle%%

TestSet Object

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

TestSet Object


%%PageItemTitle%%

TestSet Object

Name Property

Description

The test set name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

TestSet Object


%%PageItemTitle%%

TestSet Object

Status Property

Description

The test set status.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Status() As String

Remarks

The status is a value from the project Status list :

  • NO_RUN - Default. The test was never executed.
  • NOT_COMPLETED - Execution of the test has not been completed.
  • FAILED - The test failed.
  • PASSED - The test passed.
  • N/A - The status is not available.

  • A user-defined status

You can create user-defined statuses by customizing the Status list. For more information, see 'Customizing Project Lists' in the Mercury Quality Center Administrator's Guide.

See Also

TestSet Object


%%PageItemTitle%%

TestSet Object

TestDefaultExecutionSettings Property

Description

Gets default execution settings for tests.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestDefaultExecutionSettings() As Object

See Also

TestSet Object


%%PageItemTitle%%

TestSet Object | TestSetFolder Object

TestSetFolder Property

Description

The test set's parent node.

Property type

Read-write property

Syntax (Visual Basic)

Public Property TestSetFolder() As Object

Remarks

Setting this property moves the test set to another folder.

See Also

TestSet Object | TestSetFolder Object


%%PageItemTitle%%

TestSet Object

TSTestFactory Property

Description

The factory object for the current test set.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TSTestFactory() As Object

See Also

TestSet Object


%%PageItemTitle%%

TestSet Object

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

TestSet Object


%%PageItemTitle%% $$Members$$

TestSet Object

IBaseField3 Implemented Interface Members

Methods

Public Implemented Method Post Writes all changed values to database.

See Also

TestSet Object


%%PageItemTitle%%

TestSet Object | IBaseField3 Implemented Interface

UndoOnFailure
See Also OTA COM Type Library

Post Implemented Method

Description

Writes all changed values to database.

Syntax

Public Sub Post( _
   Optional ByVal UndoOnFailure As Boolean = True _
)

Parameters

UndoOnFailure

See Also

TestSet Object | IBaseField3 Implemented Interface


%%PageItemTitle%%

TestSetFactory Members

TestSetFactory Object

Description

Services for managing test sets.

Remarks

The TestSetFactory for the connection is TDConnection.TestSetFactory.

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Interfaces

IBaseFactory2 | ISupportCopyPaste2

Example

Getting a reference to an implemented interface | Find tests that are not in any test set | Add test set | Copy test set | Move test set

Public Methods

Public Method AddItem | Creates a new item object.
Public Method BuildPerfGraph | Creates Performance Graph.
Public Method BuildProgressGraph | Creates graph showing number of tests in all test sets executed over a period of time.
Public Method BuildProgressGraphEx | Creates progress graph for specified test set.
Public Method BuildSummaryGraph | Creates a summary graph of test instances in a test set.
Public Method BuildTrendGraph | Creates graph showing the number of status changes over a time period.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

TestSetFactory Object

ItemData

There are three options for ItemData:

  • Null. Creating a virtual TestSet object with Null ensures that you cannot then Post until all required fields are initialized.
  • The test set name.
  • An array consisting of the following elements:

    (0) Name - The test set name (string, required).

    (1) Test set ID - The ID of the test set folder in which to create the test set (long, optional).

See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData

There are three options for ItemData:

  • Null. Creating a virtual TestSet object with Null ensures that you cannot then Post until all required fields are initialized.
  • The test set name.
  • An array consisting of the following elements:

    (0) Name - The test set name (string, required).

    (1) Test set ID - The ID of the test set folder in which to create the test set (long, optional).

Return Type

A TestSet Object.

Remarks

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

[Visual Basic]

Dim bgf As BugFactory
Dim bg As Bug
Dim attf As AttachmentFactory
Dim att As Attachment
Dim attList As List

' Get the factory object
 Set bgf = tdc.BugFactory
' Use defect #1
 Set bg = bgf.Item(1)
 Set attf = bg.Attachments

' Creating a new attachment
' Create virtual object, then populate the properties
 Set att = attf.AddItem(Null)
 att.FileName = Text1.Text
 att.Type = TDATT_INTERNET

' Saving the object with validity check
 att.Post

' Display the attachments
' Add the display-only items without a Post
 List1.Clear
 Set attList = attf.NewList("")
 For i = 1 To attList.Count

      Set att = attList.Item(i)
      List1.AddItem (att.Name)

 Next

See Also

TestSetFactory Object


%%PageItemTitle%%

TestSetFactory Object

TestSetID
The test set ID.
GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildPerfGraph Method

Description

Creates Performance Graph.

Syntax

Public Function BuildPerfGraph( _
   ByVal TestSetID As Long, _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

TestSetID
The test set ID.
GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

TestSetFactory Object


%%PageItemTitle%%

TestSetFactory Object

TestSetID
The test set ID.
GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildProgressGraph Method

Description

Creates graph showing number of tests in all test sets executed over a period of time.

Syntax

Public Function BuildProgressGraph( _
   ByVal TestSetID As Long, _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MajorSkip As Long = 0, _
   Optional ByVal MinorSkip As Long = 1, _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

TestSetID
The test set ID.
GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

TestSetFactory Object


%%PageItemTitle%%

TestSetFactory Object

TestSetID
The test set ID.
GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

ByHistory

Determines whether to use history information to create the graph. Possible values are:

TRUE - Use history information.

FALSE - Do not use history information.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. Zero indicates no limit.

Filter

The TDFilter Object that sets the criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildProgressGraphEx Method

Description

Creates progress graph for specified test set.

Syntax

Public Function BuildProgressGraphEx( _
   ByVal TestSetID As Long, _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal ByHistory As Boolean = True, _
   Optional ByVal MajorSkip As Long = 0, _
   Optional ByVal MinorSkip As Long = 1, _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

TestSetID
The test set ID.
GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

ByHistory

Determines whether to use history information to create the graph. Possible values are:

TRUE - Use history information.

FALSE - Do not use history information.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. Zero indicates no limit.

Filter

The TDFilter Object that sets the criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

TestSetFactory Object


%%PageItemTitle%%

TestSetFactory Object

TestSetID
The test set ID.
XAxisField

A database field representing the name of the graph x-axis.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildSummaryGraph Method

Description

Creates a summary graph of test instances in a test set.

Syntax

Public Function BuildSummaryGraph( _
   ByVal TestSetID As Long, _
   Optional ByVal XAxisField As String = "", _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

TestSetID
The test set ID.
XAxisField

A database field representing the name of the graph x-axis.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

TestSetFactory Object


%%PageItemTitle%%

TestSetFactory Object

TestSetID
The test set ID.
GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildTrendGraph Method

Description

Creates graph showing the number of status changes over a time period.

Syntax

Public Function BuildTrendGraph( _
   ByVal TestSetID As Long, _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

TestSetID
The test set ID.
GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

TestSetFactory Object


%%PageItemTitle%%

TestSetFactory Object

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

TestSetFactory Object


%%PageItemTitle%%

TestSetFactory Object

ItemKey
The TestSet.ID (long), a reference to the TestSet Object, or a Variant array of TestSet.IDs.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey
The TestSet.ID (long), a reference to the TestSet Object, or a Variant array of TestSet.IDs.

See Also

TestSetFactory Object


%%PageItemTitle%%

TestSetFactory Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

TestSetFactory Object


%%PageItemTitle%%

TestSetFactory Object

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

TestSetFactory Object


%%PageItemTitle%%

TestSetFactory Object

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

TestSetFactory Object


%%PageItemTitle%%

TestSetFactory Object

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

TestSetFactory Object


%%PageItemTitle%%

TestSetFactory Object

ItemKey
A TestSet.ID (long).

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey
A TestSet.ID (long).

See Also

TestSetFactory Object


%%PageItemTitle%%

TestSetFolder Members

TestSetFolder Object

Description

Manages the tests and test sets included in a particular test set folder.

Remarks

Get a TestSetFolder object from the TestSetTreeManager.

Interfaces

IObjectLockingSupport | ISupportCopyPaste2

Example

Find test instances | Add test set folder | Copy test set folder

Public Methods

Public Method AddNode | Adds a new child node.
Public Method AddNodeDisp | Adds a new child node.
Public Method FindChildNode | Finds a child node by node name.
Public Method FindChildren | Finds node children according to specified search pattern.
Public Method FindTestInstances | Gets the list of test instances in all test sets in given folder and its subfolders that match the specified pattern.
Public Method FindTestSets | Gets the list of test sets contained in the folder that match the specified pattern.
Public Method Move | Moves folder node under new father.
Public Method NewList | Gets a list of the node's immediate children.
Public Method Post | Posts all changed values to the database.
Public Method Refresh | Reads the saved node data, overwriting values in memory.
Public Method RemoveNode | Deletes the specified node.
Public Method RemoveNodeEx | Deletes a test set folder node.

Public Properties

Public Property Attachments | The folder's AttachmentFactory object.
Public Property Attribute | Gets the node attribute.
Public Property Child | Gets a sub-folder of the current folder.
Public Property Count | The number of child nodes.
Public Property DepthType | The sub-tree depth type.
Public Property Description | The test set folder description.
Public Property Father | The current folder's parent folder.
Public Property FatherDisp | The parent node.
Public Property FatherID | The unique parent ID.
Public Property FolderFields | Returns the list of fields of the test set folder.
Public Property HasAttachment | Checks if this folder has at least one attachment.
Public Property Name | The node name.
Public Property NodeID | The node ID number.
Public Property Path | The folder tree path starting from the tree root.
Public Property SubNodes | The list of child nodes.
Public Property TargetCycle | The cycle to which the folder is assigned.
Public Property TestSetFactory | Gets the TestSetFactory for the folder.
Public Property ViewOrder | The index of this folder in its parent's list of sub-nodes.


%%PageItemTitle%%

TestSetFolder Object

NodeName
The name of the folder to add.
See Also OTA COM Type Library

AddNode Method

Description

Adds a new child node.

Syntax

Public Function AddNode( _
   ByVal NodeName As String _
) As SysTreeNode

Parameters

NodeName
The name of the folder to add.

Return Type

A TestSetFolder.

See Also

TestSetFolder Object


%%PageItemTitle%%

TestSetFolder Object

NodeName
The name of the folder to add.
See Also OTA COM Type Library

AddNodeDisp Method

Description

Adds a new child node.

Syntax

Public Function AddNodeDisp( _
   ByVal NodeName As String _
) As Object

Parameters

NodeName
The name of the folder to add.

Return Type

A TestSetFolder object.

See Also

TestSetFolder Object


%%PageItemTitle%%

TestSetFolder Object

ChildName
The name of the child node.
See Also OTA COM Type Library

FindChildNode Method

Description

Finds a child node by node name.

Syntax

Public Function FindChildNode( _
   ByVal ChildName As String _
) As SysTreeNode

Parameters

ChildName
The name of the child node.

Return Type

A TestSetFolder.

See Also

TestSetFolder Object


%%PageItemTitle%%

TestSetFolder Object

Pattern
The search text pattern. Pass an empty string ("") to find all. The pattern is matched if it occcurs anywhere in the name. Do not use wildcards.
MatchCase
If TRUE, search is case-sensitive. MatchCase has no effect if the database manager is not case sensitive. For example, if the project is hosted on an MS-SQL database, this flag has no effect.
Filter
A TDFilter.Text to select the items to be returned.
See Also OTA COM Type Library

FindChildren Method

Description

Finds node children according to specified search pattern.

Syntax

Public Function FindChildren( _
   ByVal Pattern As String, _
   Optional ByVal MatchCase As Boolean = False, _
   Optional ByVal Filter As String = "" _
) As List

Parameters

Pattern
The search text pattern. Pass an empty string ("") to find all. The pattern is matched if it occcurs anywhere in the name. Do not use wildcards.
MatchCase
If TRUE, search is case-sensitive. MatchCase has no effect if the database manager is not case sensitive. For example, if the project is hosted on an MS-SQL database, this flag has no effect.
Filter
A TDFilter.Text to select the items to be returned.

Return Type

A list of TestSetFolder objects.

See Also

TestSetFolder Object


%%PageItemTitle%%

TestSetFolder Object

Pattern

The search text pattern. Pass an empty string ("") to find all. The pattern is matched if it occcurs anywhere in the name. Do not use wildcards.

MatchCase

If TRUE, search is case-sensitive. MatchCase has no effect if the database manager is not case sensitive. For example, if the project is hosted on an MS-SQL database, this flag has no effect.

Filter

A TDFilter.Text to select the items to be returned.

See Also OTA COM Type Library

FindTestInstances Method

Description

Gets the list of test instances in all test sets in given folder and its subfolders that match the specified pattern.

Syntax

Public Function FindTestInstances( _
   ByVal Pattern As String, _
   Optional ByVal MatchCase As Boolean = False, _
   Optional ByVal Filter As String = "" _
) As List

Parameters

Pattern

The search text pattern. Pass an empty string ("") to find all. The pattern is matched if it occcurs anywhere in the name. Do not use wildcards.

MatchCase

If TRUE, search is case-sensitive. MatchCase has no effect if the database manager is not case sensitive. For example, if the project is hosted on an MS-SQL database, this flag has no effect.

Filter

A TDFilter.Text to select the items to be returned.

Return Type

A list of TSTest Objects.

See Also

TestSetFolder Object

Example

Find test instances


%%PageItemTitle%%

TestSetFolder Object

Pattern

The search text pattern. Pass an empty string ("") to find all. The pattern is matched if it occcurs anywhere in the name. Do not use wildcards.

MatchCase

If TRUE, search is case-sensitive. MatchCase has no effect if the database manager is not case sensitive. For example, if the project is hosted on an MS-SQL database, this flag has no effect.

Filter

A TDFilter.Text to select the items to be returned.

See Also OTA COM Type Library

FindTestSets Method

Description

Gets the list of test sets contained in the folder that match the specified pattern.

Syntax

Public Function FindTestSets( _
   ByVal Pattern As String, _
   Optional ByVal MatchCase As Boolean = False, _
   Optional ByVal Filter As String = "" _
) As List

Parameters

Pattern

The search text pattern. Pass an empty string ("") to find all. The pattern is matched if it occcurs anywhere in the name. Do not use wildcards.

MatchCase

If TRUE, search is case-sensitive. MatchCase has no effect if the database manager is not case sensitive. For example, if the project is hosted on an MS-SQL database, this flag has no effect.

Filter

A TDFilter.Text to select the items to be returned.

Return Type

A list of TestSet Objects.

See Also

TestSetFolder Object

Example

Get a test set by name only | Get test sets with filter | Getting a test subject node by the node path


%%PageItemTitle%%

TestSetFolder Object

Father
Either a TestSetFolder object or NodeID.
See Also OTA COM Type Library

Move Method

Description

Moves folder node under new father.

Syntax

Public Sub Move( _
   ByVal Father As Variant _
)

Parameters

Father
Either a TestSetFolder object or NodeID.

See Also

TestSetFolder Object


%%PageItemTitle%%

TestSetFolder Object

NewList Method

Description

Gets a list of the node's immediate children.

Syntax

Public Function NewList() As List

Return Type

A list of TestSetFolder objects.

See Also

TestSetFolder Object


%%PageItemTitle%%

TestSetFolder Object

Post Method

Description

Posts all changed values to the database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

TestSetFolder Object


%%PageItemTitle%%

TestSetFolder Object

Refresh Method

Description

Reads the saved node data, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

TestSetFolder Object


%%PageItemTitle%%

TestSetFolder Object

Node
The folder to delete. One of: a TestSetFolder object; the name of TestSetFolder as returned by the Name property; or the index of the TestSetFolder in its parent's children list.
See Also OTA COM Type Library

RemoveNode Method

Description

Deletes the specified node.

Syntax

Public Sub RemoveNode( _
   ByVal Node As Variant _
)

Parameters

Node
The folder to delete. One of: a TestSetFolder object; the name of TestSetFolder as returned by the Name property; or the index of the TestSetFolder in its parent's children list.

See Also

TestSetFolder Object


%%PageItemTitle%%

TestSetFolder Object

Node
The folder to delete. One of: a TestSetFolder object; the name of TestSetFolder as returned by the Name property; or the index of the TestSetFolder in its parent's children list.
DeleteTestSets
If TRUE, delete the test sets with the folder.
See Also OTA COM Type Library

RemoveNodeEx Method

Description

Deletes a test set folder node.

Syntax

Public Sub RemoveNodeEx( _
   ByVal Node As Variant, _
   Optional ByVal DeleteTestSets As Boolean = False _
)

Parameters

Node
The folder to delete. One of: a TestSetFolder object; the name of TestSetFolder as returned by the Name property; or the index of the TestSetFolder in its parent's children list.
DeleteTestSets
If TRUE, delete the test sets with the folder.

See Also

TestSetFolder Object


%%PageItemTitle%%

TestSetFolder Object

Attachments Property

Description

The folder's AttachmentFactory object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

TestSetFolder Object


%%PageItemTitle%%

TestSetFolder Object

Attribute Property

Description

Gets the node attribute.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attribute() As Long

See Also

TestSetFolder Object


%%PageItemTitle%%

TestSetFolder Object

Index
The position in the list of the child folder to return.
See Also OTA COM Type Library

Child Property

Description

Gets a sub-folder of the current folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Child( _
   ByVal Index As Long _
) As SysTreeNode

Parameters

Index
The position in the list of the child folder to return.

See Also

TestSetFolder Object


%%PageItemTitle%%

TestSetFolder Object

Count Property

Description

The number of child nodes.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

TestSetFolder Object


%%PageItemTitle%%

TestSetFolder Object

DepthType Property

Description

The sub-tree depth type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DepthType() As Integer

See Also

TestSetFolder Object


%%PageItemTitle%%

TestSetFolder Object

Description Property

Description

The test set folder description.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Description() As String

See Also

TestSetFolder Object


%%PageItemTitle%%

TestSetFolder Object

Father Property

Description

The current folder's parent folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Father() As SysTreeNode

See Also

TestSetFolder Object


%%PageItemTitle%%

TestSetFolder Object

FatherDisp Property

Description

The parent node.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FatherDisp() As Object

See Also

TestSetFolder Object


%%PageItemTitle%%

TestSetFolder Object

FatherID Property

Description

The unique parent ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FatherID() As Long

See Also

TestSetFolder Object


%%PageItemTitle%%

TestSetFolder Object

FolderFields Property

Description

Returns the list of fields of the test set folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FolderFields() As List

See Also

TestSetFolder Object


%%PageItemTitle%%

TestSetFolder Object

HasAttachment Property

Description

Checks if this folder has at least one attachment.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

TestSetFolder Object


%%PageItemTitle%%

TestSetFolder Object

Name Property

Description

The node name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

TestSetFolder Object


%%PageItemTitle%%

TestSetFolder Object

NodeID Property

Description

The node ID number.

Property type

Read-only property

Syntax (Visual Basic)

Public Property NodeID() As Long

See Also

TestSetFolder Object


%%PageItemTitle%%

TestSetFolder Object

Path Property

Description

The folder tree path starting from the tree root.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Path() As String

See Also

TestSetFolder Object


%%PageItemTitle%%

TestSetFolder Object

SubNodes Property

Description

The list of child nodes.

Property type

Read-only property

Syntax (Visual Basic)

Public Property SubNodes() As List

See Also

TestSetFolder Object


%%PageItemTitle%%

TestSetFolder Object

TargetCycle Property

Description

The cycle to which the folder is assigned.

Property type

Read-write property

Syntax (Visual Basic)

Public Property TargetCycle() As Variant

Get or Set Value Type

A Cycle Object.

See Also

TestSetFolder Object


%%PageItemTitle%%

TestSetFolder Object

TestSetFactory Property

Description

Gets the TestSetFactory for the folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestSetFactory() As Object

Remarks

If the TestSetFolder object represents the root folder, attempting to get a TestSetFactory causes a run-time error.

See Also

TestSetFolder Object


%%PageItemTitle%%

TestSetFolder Object

ViewOrder Property

Description

The index of this folder in its parent's list of sub-nodes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ViewOrder() As Long

See Also

TestSetFolder Object


%%PageItemTitle%%

TestSetTreeManager Members

TestSetTreeManager Object

Description

Manages the test set tree and its related test set folders.

Remarks

The TestSetTreeManager for the connection is TDConnection.TestSetTreeManager

Interfaces

ISupportCopyPaste2

Example

Find test instances | Add test set folder | Copy test set folder

Public Properties

Public Property NodeById | Gets the test set tree node object corresponding to the specified node Id.
Public Property NodeByPath | Gets the test set tree node from the specified tree path.
Public Property Root | The test set tree root node.
Public Property Unattached | Gets an unattached folder.


%%PageItemTitle%%

TestSetTreeManager Object

NodeID
The ID of the node in the project database.
See Also OTA COM Type Library

NodeById Property

Description

Gets the test set tree node object corresponding to the specified node Id.

Property type

Read-only property

Syntax (Visual Basic)

Public Property NodeById( _
   ByVal NodeID As Long _
) As Object

Parameters

NodeID
The ID of the node in the project database.

See Also

TestSetTreeManager Object


%%PageItemTitle%%

TestSetTreeManager Object

Path
The folder tree path starting from the tree root. For example, "Root\OTA_Demo_TestSets".
See Also OTA COM Type Library

NodeByPath Property

Description

Gets the test set tree node from the specified tree path.

Property type

Read-only property

Syntax (Visual Basic)

Public Property NodeByPath( _
   ByVal Path As String _
) As Object

Parameters

Path
The folder tree path starting from the tree root. For example, "Root\OTA_Demo_TestSets".

See Also

TestSetTreeManager Object

Example

Get a test set folder | Get test sets folder with the path | Getting the list of design tests used in a test set | Getting a test subject node by the node path


%%PageItemTitle%%

TestSetTreeManager Object

Root Property

Description

The test set tree root node.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Root() As Object

See Also

TestSetTreeManager Object


%%PageItemTitle%%

TestSetTreeManager Object

Unattached Property

Description

Gets an unattached folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Unattached() As Object

See Also

TestSetTreeManager Object


%%PageItemTitle%%

TextParser Members

TextParser Object

Description

Utilities for handling parameters in a string.

Remarks

Get a TextParser object from TDConnection.TextParam.

Public Methods

Public Method ClearParam | Clear the parameter - Set its value to null.
Public Method EvaluateText | Converts the parameters to their values.
Public Method Initialize | Initialization is generally performed by the infrastructure. Use this method after confirming the need with Mercury Support.

Public Properties

Public Property Count | Gets the number of parameters.
Public Property ParamExist | Checks if a parameter with the specified name exists.
Public Property ParamName | Gets the parameter name.
Public Property ParamType | Gets the user-defined Parameter Type.
Public Property ParamValue | The parameter value.
Public Property Text | The text to be parsed.
Public Property Type | Gets the Parameter Type - predefined, null, or regular.


%%PageItemTitle%%

TextParser Object

vParam
Either the index (zero-based) in the collection, or the name of the parameter.
See Also OTA COM Type Library

ClearParam Method

Description

Clear the parameter - Set its value to null.

Syntax

Public Sub ClearParam( _
   ByVal vParam As Variant _
)

Parameters

vParam
Either the index (zero-based) in the collection, or the name of the parameter.

See Also

TextParser Object


%%PageItemTitle%%

TextParser Object

EvaluateText Method

Description

Converts the parameters to their values.

Syntax

Public Sub EvaluateText()

See Also

TextParser Object


%%PageItemTitle%%

TextParser Object

StartClose
The token that marks the start of a parameter.
EndClose
The token that marks the end of a parameter.
TypeClose
The token that marks a value to be replaced.
MaxLen
Not in use. The default is always used. -1 means there is no maximum length.
DefaultType
Not in use. Always "String"
See Also OTA COM Type Library

Initialize Method

Description

Initialization is generally performed by the infrastructure. Use this method after confirming the need with Mercury Support.

Syntax

Public Sub Initialize( _
   Optional ByVal StartClose As String = "<%", _
   Optional ByVal EndClose As String = "%>", _
   Optional ByVal TypeClose As String = "?", _
   Optional ByVal MaxLen As Long = -1, _
   Optional ByVal DefaultType As String = "string" _
)

Parameters

StartClose
The token that marks the start of a parameter.
EndClose
The token that marks the end of a parameter.
TypeClose
The token that marks a value to be replaced.
MaxLen
Not in use. The default is always used. -1 means there is no maximum length.
DefaultType
Not in use. Always "String"

Remarks

Several step parameters can be assigned to a step. The text parser is used to identify each parameter. By default, a parameter has format <?> .

See Also

TextParser Object


%%PageItemTitle%%

TextParser Object

Count Property

Description

Gets the number of parameters.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

TextParser Object


%%PageItemTitle%%

TextParser Object

ParamName
The name of the parameter.
See Also OTA COM Type Library

ParamExist Property

Description

Checks if a parameter with the specified name exists.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ParamExist( _
   ByVal ParamName As String _
) As Boolean

Parameters

ParamName
The name of the parameter.

See Also

TextParser Object


%%PageItemTitle%%

TextParser Object

nPosition
The index (zero-based) of parameter in the list of all parameters found in the Text.
See Also OTA COM Type Library

ParamName Property

Description

Gets the parameter name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ParamName( _
   ByVal nPosition As Long _
) As String

Parameters

nPosition
The index (zero-based) of parameter in the list of all parameters found in the Text.

See Also

TextParser Object


%%PageItemTitle%%

TextParser Object

vParam
Either the index (zero-based) in the collection, or the name of the parameter.
See Also OTA COM Type Library

ParamType Property

Description

Gets the user-defined Parameter Type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ParamType( _
   ByVal vParam As Variant _
) As String

Parameters

vParam
Either the index (zero-based) in the collection, or the name of the parameter.

See Also

TextParser Object


%%PageItemTitle%%

TextParser Object

vParam
Either the index (zero-based) in the collection, or the name of the parameter.
See Also OTA COM Type Library

ParamValue Property

Description

The parameter value.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ParamValue( _
   ByVal vParam As Variant _
) As String

Parameters

vParam
Either the index (zero-based) in the collection, or the name of the parameter.

See Also

TextParser Object


%%PageItemTitle%%

TextParser Object

Text Property

Description

The text to be parsed.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Text() As String

See Also

TextParser Object


%%PageItemTitle%%

TextParser Object

vParam
Either the index (zero-based) in the collection, or the name of the parameter.
See Also OTA COM Type Library

Type Property

Description

Gets the Parameter Type - predefined, null, or regular.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Type( _
   ByVal vParam As Variant _
) As Long

Parameters

vParam
Either the index (zero-based) in the collection, or the name of the parameter.

See Also

TextParser Object


%%PageItemTitle%%

Trace Members

Trace Object

Description

Represents a traceability association between two requirements.

Remarks

Get a Trace object from the ReqTraceFactory pointed to by the Req .ReqTraceFactory Property of a requirement.

When creating the Trace object with the AddItem method, the direction of the trace is specified. If the direction is from the Req whose factory is used, the the Trace is created with the initiating Req in the FromReq. If the direction is to the initiating Req, the Trace is created with the initiating Req in the ToReq Property.

After the Trace is created, set the TracedReq property to the second Req. When you set TracedReq, the Trace object sets either FromReq or ToReq to point to the second Req. Which property is set depends on the direction of the Trace.

Interfaces

IBaseField2 | IBaseField3

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Field | The value of the specified field.
Public Property FromReq | The requirement from which the association is defined.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property ToReq | The requirement to which the association is defined
Public Property TracedReq | The other requirement that the initiating requirement forms a trace with.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

Trace Object

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Trace Object


%%PageItemTitle%%

Trace Object

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Trace Object


%%PageItemTitle%%

Trace Object

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

Trace Object


%%PageItemTitle%%

Trace Object

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

Trace Object


%%PageItemTitle%%

Trace Object

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

Trace Object


%%PageItemTitle%%

Trace Object

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

Trace Object


%%PageItemTitle%%

Trace Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

Trace Object


%%PageItemTitle%%

Trace Object

FromReq Property

Description

The requirement from which the association is defined.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FromReq() As Object

See Also

Trace Object


%%PageItemTitle%%

Trace Object

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

Trace Object


%%PageItemTitle%%

Trace Object

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

Trace Object


%%PageItemTitle%%

Trace Object

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

Trace Object


%%PageItemTitle%%

Trace Object

ToReq Property

Description

The requirement to which the association is defined

Property type

Read-only property

Syntax (Visual Basic)

Public Property ToReq() As Object

See Also

Trace Object


%%PageItemTitle%%

Trace Object

RHS
A Req Object.
See Also OTA COM Type Library

TracedReq Property

Description

The other requirement that the initiating requirement forms a trace with.

Property type

Write-only property

Syntax (Visual Basic)

Public Property TracedReq( _
   ByVal RHS As Object _
) As Object

Parameters

RHS
A Req Object.

See Also

Trace Object


%%PageItemTitle%%

Trace Object

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

Trace Object


%%PageItemTitle%% $$Members$$

Trace Object

IBaseField3 Implemented Interface Members

Methods

Public Implemented Method Post Writes all changed values to database.

See Also

Trace Object


%%PageItemTitle%%

Trace Object | IBaseField3 Implemented Interface

UndoOnFailure
See Also OTA COM Type Library

Post Implemented Method

Description

Writes all changed values to database.

Syntax

Public Sub Post( _
   Optional ByVal UndoOnFailure As Boolean = True _
)

Parameters

UndoOnFailure

See Also

Trace Object | IBaseField3 Implemented Interface


%%PageItemTitle%%

TreeManager Members

TreeManager Object

Description

Represents the system tree, containing a subject tree and all hierarchical field trees.

Remarks

The TreeManager for the connection is TDConnection.TreeManager.

Interfaces

ISupportCopyPaste2

Example

Creating various entities and linking them | Add test | Copy test | Copy test plan folder | Delete a test plan folder | Get business process test parameters

Public Properties

Public Property NodeById | Gets the object having the specified node Id.
Public Property NodeByPath | Gets the node at the specified tree path.
Public Property NodePath | Gets the node path, slash separated.
Public Property RootList | Gets list of available trees in the specified range.
Public Property TreeRoot | The root node specified by the node name.


%%PageItemTitle%%

TreeManager Object

NodeID
The Node ID.
See Also OTA COM Type Library

NodeById Property

Description

Gets the object having the specified node Id.

Property type

Read-only property

Syntax (Visual Basic)

Public Property NodeById( _
   ByVal NodeID As Long _
) As Object

Parameters

NodeID
The Node ID.

See Also

TreeManager Object


%%PageItemTitle%%

TreeManager Object

Path
The tree path of the node (a string separated by slashes).
See Also OTA COM Type Library

NodeByPath Property

Description

Gets the node at the specified tree path.

Property type

Read-only property

Syntax (Visual Basic)

Public Property NodeByPath( _
   ByVal Path As String _
) As Object

Parameters

Path
The tree path of the node (a string separated by slashes).

See Also

TreeManager Object


%%PageItemTitle%%

TreeManager Object

NodeID
The Node ID.
See Also OTA COM Type Library

NodePath Property

Description

Gets the node path, slash separated.

Property type

Read-only property

Syntax (Visual Basic)

Public Property NodePath( _
   ByVal NodeID As Long _
) As String

Parameters

NodeID
The Node ID.

See Also

TreeManager Object


%%PageItemTitle%%

TreeManager Object

Val

One of the values TDOLE_ALL, TDOLE_SUBJECT, or TDOLE_NOT_SUBJECT, from tagTDAPI_ROOTLIST Enumeration.

See Also OTA COM Type Library

RootList Property

Description

Gets list of available trees in the specified range.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RootList( _
   Optional ByVal Val As Integer = 0 _
) As List

Parameters

Val

One of the values TDOLE_ALL, TDOLE_SUBJECT, or TDOLE_NOT_SUBJECT, from tagTDAPI_ROOTLIST Enumeration.

See Also

TreeManager Object

Example

Getting a test subject node by the node path


%%PageItemTitle%%

TreeManager Object

RootName
One of the values returned by RootList.
See Also OTA COM Type Library

TreeRoot Property

Description

The root node specified by the node name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TreeRoot( _
   ByVal RootName As String _
) As Object

Parameters

RootName
One of the values returned by RootList.

See Also

TreeManager Object

Example

Getting a root node object by name | Getting a test subject node by the node path


%%PageItemTitle%%

TSScheduler Members

TSScheduler Object

Description

Responsible for executing selected automated tests.

Remarks

A TSScheduler object is returned by TestSet.StartExecution.

Example

Running the test instances in a test set locally, remotely, or as planned

Public Methods

Public Method Run | Starts execution the test set or of the specified tests.
Public Method Stop | Stops execution of the test set or the specified tests.

Public Properties

Public Property ExecutionLog | The execution error or log message sent by the remote agent.
Public Property ExecutionStatus | The execution status object for the scheduler execution.
Public Property HostTimeOut | The time to wait for response before either sending test to another host in group or failing.
Public Property LogEnabled | Indicates if logging is enabled.
Public Property RunAllLocally | Indicates if all tests are to be run on the local host.
Public Property RunOnHost | The host on which to execute the test instance.
Public Property TdHostName | The host on which to run all tests in the current scheduler execution.


%%PageItemTitle%%

TSScheduler Object

TestData
A comma-separated list of the IDs (string) of the test instances to run, or a List of TSTest objects. If no value is passed, the entire test set is run.
See Also OTA COM Type Library

Run Method

Description

Starts execution the test set or of the specified tests.

Syntax

Public Sub Run( _
   Optional ByVal TestData As Variant _
)

Parameters

TestData
A comma-separated list of the IDs (string) of the test instances to run, or a List of TSTest objects. If no value is passed, the entire test set is run.

Remarks

A TSScheduler can perform only one run. If you want to perform more than one run, then after calling Run, call TestSet.StartExecution again to get a new TSScheduler object.

See Also

TSScheduler Object


%%PageItemTitle%%

TSScheduler Object

TestData
A comma-separated list of the IDs (string) of the test instances to stop. If no value is passed, all the test instances in the test set are stopped/
See Also OTA COM Type Library

Stop Method

Description

Stops execution of the test set or the specified tests.

Syntax

Public Sub Stop( _
   Optional ByVal TestData As Variant _
)

Parameters

TestData
A comma-separated list of the IDs (string) of the test instances to stop. If no value is passed, all the test instances in the test set are stopped/

See Also

TSScheduler Object


%%PageItemTitle%%

TSScheduler Object

ExecutionLog Property

Description

The execution error or log message sent by the remote agent.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExecutionLog() As String

See Also

TSScheduler Object


%%PageItemTitle%%

TSScheduler Object

ExecutionStatus Property

Description

The execution status object for the scheduler execution.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExecutionStatus() As Object

See Also

TSScheduler Object


%%PageItemTitle%%

TSScheduler Object

HostTimeOut Property

Description

The time to wait for response before either sending test to another host in group or failing.

Property type

Read-write property

Syntax (Visual Basic)

Public Property HostTimeOut() As Long

Remarks

If the host does not respond, at the end of the timeout an automated test is sent to another host from the same host group. If there are no other available hosts, the test fails.

See Also

TSScheduler Object


%%PageItemTitle%%

TSScheduler Object

LogEnabled Property

Description

Indicates if logging is enabled.

Property type

Read-write property

Syntax (Visual Basic)

Public Property LogEnabled() As Boolean

See Also

TSScheduler Object


%%PageItemTitle%%

TSScheduler Object

RunAllLocally Property

Description

Indicates if all tests are to be run on the local host.

Property type

Read-write property

Syntax (Visual Basic)

Public Property RunAllLocally() As Boolean

Remarks

To run all the test instances in the test set on the local host, set RunAllLocally = True.

If you specify a host for each test instances using RunOnHost, set RunAllLocally = False.

If you specify a remote host to run all the test instances using TdHostName, do not set RunAllLocally at all.

See Also

TSScheduler Object

Example

Running the test instances in a test set locally, remotely, or as planned


%%PageItemTitle%%

TSScheduler Object

TSTestId
The ID of the test instance (TSTest).
See Also OTA COM Type Library

RunOnHost Property

Description

The host on which to execute the test instance.

Property type

Read-write property

Syntax (Visual Basic)

Public Property RunOnHost( _
   ByVal TSTestId As Variant _
) As String

Parameters

TSTestId
The ID of the test instance (TSTest).

Remarks

Setting this value is required if no TSTest.HostName is empty and RunAllLocally is False.

If TSTest.HostName is set, setting RunOnHost overrides the setting for this run.

See Also

TSScheduler Object

Example

Running the test instances in a test set locally, remotely, or as planned


%%PageItemTitle%%

TSScheduler Object

TdHostName Property

Description

The host on which to run all tests in the current scheduler execution.

Property type

Read-write property

Syntax (Visual Basic)

Public Property TdHostName() As String

Remarks

Do not set the TDHostName if the test instances are to to run on the local host (RunAllLocally = True) or if hosts are going to be specified using RunOnHost.

If TDHostName is specified, do not set any value for RunAllLocally.

See Also

TSScheduler Object

Example

Running the test instances in a test set locally, remotely, or as planned


%%PageItemTitle%%

TSTest Members | TestSet Object | Test Object

TSTest Object

Description

Represents a test instance, or execution test, in a test set.

Remarks

A test instance represents a single use of a planning Test in a TestSet. It can be associated with one or more runs.

Get a TSTest object from a TSTestFactory.

Interface Remarks

IBaseFieldEx is implemented by several classes, among them: DesignStep, HostGroup, Run, Step, TSTest, and TestSet.
IBaseField defines a basic data field or entity. Use the properties and methods in IBaseField to perform field-related actions, such as setting and refreshing field values. Examples of objects that implement IBaseField are: Attachment, Bug, Condition, DesignStep, Host, HostGroup, Req, Run, Step, SubjectNode, SysTreeNode, Test, TestSet, and TSTest.

Interfaces

IAlertable2 | IBaseField2 | IBaseField3 | ICoverable | IFollowUpManager | ILinkable

Example

Get attributes of TestSets and TSTests | Accessing members of Additional Implemented Interfaces | Creating various entities and linking them | Find test instances | Delete test instance

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property ExecutionParams | The execution parameters for this test instance.
Public Property ExecutionSettings | The execution settings for this test instance.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property HasCoverage | Checks if the test instance covers at least one requirement.
Public Property HasSteps | Checks if the planning test specified by the Test property has design steps.
Public Property History | The History object for the object.
Public Property HostName | The name of the host planned to run this test instance.
Public Property ID | The item ID.
Public Property Instance | The instance number of this execution test, within the other instances of the same test.
Public Property IsLocked | Checks if object is locked.
Public Property LastRun | The Run object of the last run.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The name of this execution test. By convention, this is the test instance number and the test name.
Public Property Params | The step parameters for this execution test.
Public Property RunFactory | The Run Factory for this execution test.
Public Property Status | The execution test status.
Public Property Test | The planning test of which this execution test in an instance.
Public Property TestId | The ID of the design test of which this is an instance.
Public Property TestName | The name of the design test of which this is an instance.
Public Property TestSet | The test set to which the execution test belongs.
Public Property Type | The execution test type.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

TSTest Object

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

TSTest Object


%%PageItemTitle%%

TSTest Object

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

TSTest Object


%%PageItemTitle%%

TSTest Object

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

TSTest Object


%%PageItemTitle%%

TSTest Object

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

TSTest Object


%%PageItemTitle%%

TSTest Object

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

TSTest Object


%%PageItemTitle%%

TSTest Object

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

TSTest Object


%%PageItemTitle%%

TSTest Object

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

TSTest Object


%%PageItemTitle%%

TSTest Object

ExecutionParams Property

Description

The execution parameters for this test instance.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ExecutionParams() As String

See Also

TSTest Object


%%PageItemTitle%%

TSTest Object

ExecutionSettings Property

Description

The execution settings for this test instance.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExecutionSettings() As Object

See Also

TSTest Object


%%PageItemTitle%%

TSTest Object

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName

The name of the field in the project database.

See Also

TSTest Object


%%PageItemTitle%%

TSTest Object

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

TSTest Object


%%PageItemTitle%%

TSTest Object

HasCoverage Property

Description

Checks if the test instance covers at least one requirement.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasCoverage() As Boolean

See Also

TSTest Object


%%PageItemTitle%%

TSTest Object

HasSteps Property

Description

Checks if the planning test specified by the Test property has design steps.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasSteps() As Boolean

See Also

TSTest Object


%%PageItemTitle%%

TSTest Object

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

TSTest Object


%%PageItemTitle%%

TSTest Object

HostName Property

Description

The name of the host planned to run this test instance.

Property type

Read-write property

Syntax (Visual Basic)

Public Property HostName() As String

Remarks

The host on which the test instance actually runs can be set differently from the planned HostName when running the test, either from TestLab module in the UI or by setting TSScheduler.RunOnHost.

See Also

TSTest Object


%%PageItemTitle%%

TSTest Object

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

TSTest Object

Example

Get attributes of TestSets and TSTests


%%PageItemTitle%%

TSTest Object

Instance Property

Description

The instance number of this execution test, within the other instances of the same test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Instance() As Long

See Also

TSTest Object


%%PageItemTitle%%

TSTest Object

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

TSTest Object


%%PageItemTitle%%

TSTest Object

LastRun Property

Description

The Run object of the last run.

Property type

Read-only property

Syntax (Visual Basic)

Public Property LastRun() As Object

See Also

TSTest Object


%%PageItemTitle%%

TSTest Object

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

TSTest Object


%%PageItemTitle%%

TSTest Object

Name Property

Description

The name of this execution test. By convention, this is the test instance number and the test name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name() As String

See Also

TSTest Object


%%PageItemTitle%%

TSTest Object

Params Property

Description

The step parameters for this execution test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Params() As Object

See Also

TSTest Object


%%PageItemTitle%%

TSTest Object

RunFactory Property

Description

The Run Factory for this execution test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RunFactory() As Object

See Also

TSTest Object


%%PageItemTitle%%

TSTest Object

Status Property

Description

The execution test status.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Status() As String

Remarks

Common values of the Status list are:

  • NO_RUN - Default. The instance was never executed.
  • NOT_COMPLETED - Execution of the test instance has not been completed.
  • FAILED - The test instance failed during test execution.
  • PASSED - The test instance passed during test execution.
  • N/A - The execution status is not available.

You can also add a user-defined status. For more information, see 'Customizing Project Lists' in the Mercury Quality Center Administrator's Guide.

See Also

TSTest Object


%%PageItemTitle%%

TSTest Object

Test Property

Description

The planning test of which this execution test in an instance.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Test() As Object

See Also

TSTest Object


%%PageItemTitle%%

TSTest Object

TestId Property

Description

The ID of the design test of which this is an instance.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestId() As Variant

See Also

TSTest Object


%%PageItemTitle%%

TSTest Object

TestName Property

Description

The name of the design test of which this is an instance.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestName() As String

See Also

TSTest Object


%%PageItemTitle%%

TSTest Object

TestSet Property

Description

The test set to which the execution test belongs.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestSet() As Object

See Also

TSTest Object


%%PageItemTitle%%

TSTest Object

Type Property

Description

The execution test type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Type() As String

Remarks

Common test types are 'Manual', 'WR-Automated', 'VAPI', 'VAPI-XP'. Test types are delivered with Quality Center or are custom test types added at your site.
To get the full list of types in the project, look at the TestType list. See 'Customizing Project Lists' in the Mercury Quality Center Administrator's Guide.

See Also

TSTest Object


%%PageItemTitle%%

TSTest Object

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

TSTest Object


%%PageItemTitle%% $$Members$$

TSTest Object

IBaseField3 Implemented Interface Members

Methods

Public Implemented Method Post Writes all changed values to database.

See Also

TSTest Object


%%PageItemTitle%%

TSTest Object | IBaseField3 Implemented Interface

UndoOnFailure
See Also OTA COM Type Library

Post Implemented Method

Description

Writes all changed values to database.

Syntax

Public Sub Post( _
   Optional ByVal UndoOnFailure As Boolean = True _
)

Parameters

UndoOnFailure

See Also

TSTest Object | IBaseField3 Implemented Interface


%%PageItemTitle%%

TSTestFactory Members

TSTestFactory Object

Description

Manages test instances (TSTest objects) in a test set.

Remarks

Get a TSTestFactory object from TestSet.TSTestFactory.

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Interfaces

IAlertableEntityFactory | IBaseFactory2 | ISupportCopyPaste2

Example

Getting a reference to an implemented interface | Getting those test instances that do, and those that do not, cover a requirement | Delete test instance

Public Methods

Public Method AddItem | Adds one or more tests to the test set.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

TSTestFactory Object

ItemData

There are three options for ItemData:

  • Null. Initially creating a virtual object with Null ensures that you cannot then Post until all required fields are initialized.
  • A test ID (long or string)
  • An array of variants containing test IDs either as long values or as strings.
See Also OTA COM Type Library

AddItem Method

Description

Adds one or more tests to the test set.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData

There are three options for ItemData:

  • Null. Initially creating a virtual object with Null ensures that you cannot then Post until all required fields are initialized.
  • A test ID (long or string)
  • An array of variants containing test IDs either as long values or as strings.

Return Type

If either Null or a single test ID is passes, AddItem returns a TSTest Object. If an array of test IDs is passed, a List of TSTests is returned.

See Also

TSTestFactory Object


%%PageItemTitle%%

TSTestFactory Object

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

TSTestFactory Object


%%PageItemTitle%%

TSTestFactory Object

ItemKey
The TSTest.ID (long), a reference to the TSTest Object, or a Variant array of TSTest.IDs.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey
The TSTest.ID (long), a reference to the TSTest Object, or a Variant array of TSTest.IDs.

See Also

TSTestFactory Object


%%PageItemTitle%%

TSTestFactory Object

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

TSTestFactory Object


%%PageItemTitle%%

TSTestFactory Object

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

TSTestFactory Object


%%PageItemTitle%%

TSTestFactory Object

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

TSTestFactory Object


%%PageItemTitle%%

TSTestFactory Object

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

TSTestFactory Object


%%PageItemTitle%%

TSTestFactory Object

ItemKey
A TSTest.ID.

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey
A TSTest.ID.

See Also

TSTestFactory Object

Example

Get attributes of TestSets and TSTests


%%PageItemTitle%%

VCS Members

VCS Object

Description

Represents a Version Control System connection.

Remarks

Get a VCS object from TDConnection.VCS or Test.VCS.

Public Methods

Public Method AddObjectToVcs | Adds an object to the Version control database.
Public Method CheckIn | Checks in an object.
Public Method CheckInEx | Checks in an object.
Public Method CheckOut | Checks out an object
Public Method DeleteObjectFromVCS | Deletes the object from the Version Control database.
Public Method LockVcsObject | Changes VCS object status from GET to CHECK-OUT. The object must be in a GET status to use this method.
Public Method Refresh | Refreshes the VCS object from the server to the client, overwriting values in memory.
Public Method SetCurrentVersion | This method is potentially destructive. Use only if necessary and with care. Sets the VCS object current version.
Public Method UndoCheckout | Undoes the check out operation, falling back to the current version on the server.

Public Properties

Public Property CheckoutInfo | A reference to a VersionItem object, containing the checkout information of the current object.
Public Property CurrentVersion | The current object latest version.
Public Property IsCheckedOut | Checks if the object is in CHECKED-OUT or GET status.
Public Property IsLocked | Checks if object is locked by the version control system.
Public Property LockedBy | The name of the locking user.
Public Property Version | The version the current user is viewing.
Public Property VersionInfo | A reference to a VersionItem object containing information about a specific version, specified by the Version argument.
Public Property Versions | A list of version strings, representing all the versions in the object.
Public Property VersionsEx | A list of IVersionItem references for accessing the details of each version in the object. .


%%PageItemTitle%%

VCS Object

Version
Specifies the starting version number of the test.
Comments
Comments pertaining to the object version.
See Also OTA COM Type Library

AddObjectToVcs Method

Description

Adds an object to the Version control database.

Syntax

Public Sub AddObjectToVcs( _
   Optional ByVal Version As String = "1.1.1", _
   Optional ByVal Comments As String = "Object Created in VCS" _
)

Parameters

Version
Specifies the starting version number of the test.
Comments
Comments pertaining to the object version.

Remarks

When using an automated test, this method must be used after the test files are uploaded from the client to the server.

See Also

VCS Object


%%PageItemTitle%%

VCS Object

Version
The starting version number of the object.
Comments
Comment on the object version.
Remove
If True, delete the files from the file system.
It is recommended not to use this option.
SetCurrent
Sets the version you are currently working with as the current one.
It is recommended not to use this option.
See Also OTA COM Type Library

CheckIn Method

Description

Checks in an object.

Syntax

Public Sub CheckIn( _
   ByVal Version As String, _
   ByVal Comments As String, _
   Optional ByVal Remove As Boolean = True, _
   Optional ByVal SetCurrent As Boolean = True _
)

Parameters

Version
The starting version number of the object.
Comments
Comment on the object version.
Remove
If True, delete the files from the file system.
It is recommended not to use this option.
SetCurrent
Sets the version you are currently working with as the current one.
It is recommended not to use this option.

Remarks

This method can also be used in case of a conflict caused by a change in the StepParams value.

See Also

VCS Object


%%PageItemTitle%%

VCS Object

Version

The starting version number of the object.

Comments

Comment on the object version.

Remove

If True, delete the files from the file system.
It is recommended not to use this option.

SetCurrent

Sets the version you are currently working with as the current one.
It is recommended not to use this option.

ForceCheckin
If True, ignores conflict. Otherwise, checks for conflict.
Reserved
Not in use.
See Also OTA COM Type Library

CheckInEx Method

Description

Checks in an object.

Syntax

Public Sub CheckInEx( _
   ByVal Version As String, _
   ByVal Comments As String, _
   Optional ByVal Remove As Boolean = True, _
   Optional ByVal SetCurrent As Boolean = True, _
   Optional ByVal ForceCheckin As Boolean = False, _
   Optional ByVal Reserved As ULong = 0 _
)

Parameters

Version

The starting version number of the object.

Comments

Comment on the object version.

Remove

If True, delete the files from the file system.
It is recommended not to use this option.

SetCurrent

Sets the version you are currently working with as the current one.
It is recommended not to use this option.

ForceCheckin
If True, ignores conflict. Otherwise, checks for conflict.
Reserved
Not in use.

Remarks

This method can also be used in case of a conflict caused by a change in the StepParams value.

See Also

VCS Object


%%PageItemTitle%%

VCS Object

Version
The version number of the object. Pass an empty string to check out the latest version.
Comment
Comment pertaining to the object version.
Lock
If True, check out and lock the object. Otherwise, just get copy.
ReadOnly
If True, the checked out files will be read only.
It is recommended not to use this option.
Sync

For internal use.

See Also OTA COM Type Library

CheckOut Method

Description

Checks out an object

Syntax

Public Sub CheckOut( _
   ByVal Version As String, _
   ByVal Comment As String, _
   ByVal Lock As Boolean, _
   Optional ByVal ReadOnly As Boolean = False, _
   Optional ByVal Sync As Boolean = True _
)

Parameters

Version
The version number of the object. Pass an empty string to check out the latest version.
Comment
Comment pertaining to the object version.
Lock
If True, check out and lock the object. Otherwise, just get copy.
ReadOnly
If True, the checked out files will be read only.
It is recommended not to use this option.
Sync

For internal use.

See Also

VCS Object


%%PageItemTitle%%

VCS Object

DeleteObjectFromVCS Method

Description

Deletes the object from the Version Control database.

Syntax

Public Sub DeleteObjectFromVCS()

See Also

VCS Object


%%PageItemTitle%%

VCS Object

LockVcsObject Method

Description

Changes VCS object status from GET to CHECK-OUT. The object must be in a GET status to use this method.

Syntax

Public Sub LockVcsObject()

See Also

VCS Object


%%PageItemTitle%%

VCS Object

Refresh Method

Description

Refreshes the VCS object from the server to the client, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

VCS Object


%%PageItemTitle%%

VCS Object

Version
The version number to make current.
See Also OTA COM Type Library

SetCurrentVersion Method

Description

This method is potentially destructive. Use only if necessary and with care. Sets the VCS object current version.

Syntax

Public Sub SetCurrentVersion( _
   ByVal Version As String _
)

Parameters

Version
The version number to make current.

See Also

VCS Object


%%PageItemTitle%%

VCS Object

Remove
Always pass "True".
See Also OTA COM Type Library

UndoCheckout Method

Description

Undoes the check out operation, falling back to the current version on the server.

Syntax

Public Sub UndoCheckout( _
   ByVal Remove As Boolean _
)

Parameters

Remove
Always pass "True".

Remarks

The local copy of the file is removed when UndoCheckout is called.

See Also

VCS Object


%%PageItemTitle%%

VCS Object

CheckoutInfo Property

Description

A reference to a VersionItem object, containing the checkout information of the current object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property CheckoutInfo() As Object

See Also

VCS Object


%%PageItemTitle%%

VCS Object

CurrentVersion Property

Description

The current object latest version.

Property type

Read-only property

Syntax (Visual Basic)

Public Property CurrentVersion() As String

See Also

VCS Object


%%PageItemTitle%%

VCS Object

IsCheckedOut Property

Description

Checks if the object is in CHECKED-OUT or GET status.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsCheckedOut() As Boolean

See Also

VCS Object


%%PageItemTitle%%

VCS Object

IsLocked Property

Description

Checks if object is locked by the version control system.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

VCS Object


%%PageItemTitle%%

VCS Object

LockedBy Property

Description

The name of the locking user.

Property type

Read-only property

Syntax (Visual Basic)

Public Property LockedBy() As String

See Also

VCS Object


%%PageItemTitle%%

VCS Object

Version Property

Description

The version the current user is viewing.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Version() As String

See Also

VCS Object


%%PageItemTitle%%

VCS Object

Version
The version number of the object: <major version>.<minor version>.<build>.
See Also OTA COM Type Library

VersionInfo Property

Description

A reference to a VersionItem object containing information about a specific version, specified by the Version argument.

Property type

Read-only property

Syntax (Visual Basic)

Public Property VersionInfo( _
   ByVal Version As String _
) As Object

Parameters

Version
The version number of the object: <major version>.<minor version>.<build>.

See Also

VCS Object


%%PageItemTitle%%

VCS Object

Versions Property

Description

A list of version strings, representing all the versions in the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Versions() As List

See Also

VCS Object


%%PageItemTitle%%

VCS Object

VersionsEx Property

Description

A list of IVersionItem references for accessing the details of each version in the object. .

Property type

Read-only property

Syntax (Visual Basic)

Public Property VersionsEx() As List

See Also

VCS Object


%%PageItemTitle%%

VersionItem Members

VersionItem Object

Description

Represents specific version information.

Remarks

Get a list of VersionItem objects from VCS.VersionsEx.

Public Properties

Public Property Comments | The check-in comments.
Public Property Date | The check-in date.
Public Property IsLocked | Checks if the item is locked.
Public Property Time | The check-in time.
Public Property User | The user who performed the check-in.
Public Property Version | The version checked in.


%%PageItemTitle%%

VersionItem Object

Comments Property

Description

The check-in comments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

VersionItem Object


%%PageItemTitle%%

VersionItem Object

Date Property

Description

The check-in date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Date() As String

See Also

VersionItem Object


%%PageItemTitle%%

VersionItem Object

IsLocked Property

Description

Checks if the item is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

VersionItem Object


%%PageItemTitle%%

VersionItem Object

Time Property

Description

The check-in time.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Time() As String

See Also

VersionItem Object


%%PageItemTitle%%

VersionItem Object

User Property

Description

The user who performed the check-in.

Property type

Read-only property

Syntax (Visual Basic)

Public Property User() As String

See Also

VersionItem Object


%%PageItemTitle%%

VersionItem Object

Version Property

Description

The version checked in.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Version() As String

See Also

VersionItem Object


%%PageItemTitle%%

IActionPermission Members

IActionPermission Interface

Description

Services to manage user permissions for actions.

Remarks

Get an ActionPermission object from TDConnection.ActionPermission.

Example

Dim ActPer As ActionPermission

'tds is a TDConnection object
Set ActPer = tdc.ActionPermission

If ActPer.ActionEnabled("ac_add_bug") Then

' current user allowed to add bug
' .... your code here

Else
' current user not allowed to add bug
' .... your code here

End If

Public Properties

Public Property ActionEnabled Checks if the user has rights to perform the specified action.


%%PageItemTitle%%

IActionPermission Interface

ActionIdentity

Specifies the action. To get the full list of actions at your site, see the

ACTIONS table using the Site Administrator UI.

The most common options are:

ac_add_bug, ac_add_common_settings, ac_add_cover, ac_add_cycle, ac_add_cyclefolder, ac_add_cycle_to_cyclefolder, ac_add_desstep, ac_add_folder, ac_add_private_settings, ac_add_r&d_comments, ac_add_req ac_add_reqfolder, ac_add_test, ac_add_test_to_testcycl, ac_change_password, ac_clear_history, ac_configure_mail, ac_copy_cycle, ac_copy_folder, ac_copy_cyclefolder, ac_create_rbr_files, ac_create_views, ac_create_wr_script, ac_customize_fields, ac_delete_bug, ac_delete_common_settings, ac_delete_cover, ac_delete_cycle, ac_delete_cycle_from_cyclefolder, ac_delete_cyclefolder, ac_delete_desstep, ac_delete_folder, ac_delete_private_settings, ac_delete_req, ac_delete_run, ac_delete_test, ac_delete_test_from_testcycl, ac_import_bugs_from_file, ac_import_bugs_from_mail, ac_import_bugs_settings, ac_import_wr_tests, ac_modify_bug, ac_modify_common_settings, ac_modify_cycle, ac_modify_desstep, ac_modify_folder, ac_modify_hosts, ac_modify_private_settings, ac_modify_req, ac_modify_reqfolder, ac_modify_run, ac_modify_test, ac_modify_test_in_testcycl, ac_move_folder, ac_move_cyclefolder, ac_remove_reqfolder, ac_reset_cycle, ac_run_auto_test, ac_run_manual_test, ac_send_all_qualified, ac_test_exec_params, ac_users, ac_wr_settings

ActionTarget

The object on which the specified action is performed, or the user performing the action.

To determine whether the action can be performed by the current user on a specific test or other object, the ActionTarget parameter value should be a reference to the object.

To determine whether the specified action can be performed by a specific user, the ActionTarget parameter value should be the user name (string).

See Also OTA COM Type Library

ActionEnabled Property

Description

Checks if the user has rights to perform the specified action.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ActionEnabled( _
   ByVal ActionIdentity As Variant, _
   Optional ByVal ActionTarget As Variant _
) As Boolean

Parameters

ActionIdentity

Specifies the action. To get the full list of actions at your site, see the

ACTIONS table using the Site Administrator UI.

The most common options are:

ac_add_bug, ac_add_common_settings, ac_add_cover, ac_add_cycle, ac_add_cyclefolder, ac_add_cycle_to_cyclefolder, ac_add_desstep, ac_add_folder, ac_add_private_settings, ac_add_r&d_comments, ac_add_req ac_add_reqfolder, ac_add_test, ac_add_test_to_testcycl, ac_change_password, ac_clear_history, ac_configure_mail, ac_copy_cycle, ac_copy_folder, ac_copy_cyclefolder, ac_create_rbr_files, ac_create_views, ac_create_wr_script, ac_customize_fields, ac_delete_bug, ac_delete_common_settings, ac_delete_cover, ac_delete_cycle, ac_delete_cycle_from_cyclefolder, ac_delete_cyclefolder, ac_delete_desstep, ac_delete_folder, ac_delete_private_settings, ac_delete_req, ac_delete_run, ac_delete_test, ac_delete_test_from_testcycl, ac_import_bugs_from_file, ac_import_bugs_from_mail, ac_import_bugs_settings, ac_import_wr_tests, ac_modify_bug, ac_modify_common_settings, ac_modify_cycle, ac_modify_desstep, ac_modify_folder, ac_modify_hosts, ac_modify_private_settings, ac_modify_req, ac_modify_reqfolder, ac_modify_run, ac_modify_test, ac_modify_test_in_testcycl, ac_move_folder, ac_move_cyclefolder, ac_remove_reqfolder, ac_reset_cycle, ac_run_auto_test, ac_run_manual_test, ac_send_all_qualified, ac_test_exec_params, ac_users, ac_wr_settings

ActionTarget

The object on which the specified action is performed, or the user performing the action.

To determine whether the action can be performed by the current user on a specific test or other object, the ActionTarget parameter value should be a reference to the object.

To determine whether the specified action can be performed by a specific user, the ActionTarget parameter value should be the user name (string).

See Also

IActionPermission Interface


%%PageItemTitle%%

IAlert Members

IAlert Interface

Description

Represents a notification sent to the user.

Remarks

The Alert object handles alerting users' changes in certain tables, tests, and so on, as configured. Alerts may also be user-defined follow-ups to remind the user regarding the object, sent at a pre-determined date.

Get an Alert object with TDConnection.AlertManager.

See also: The Rule Object

Public Properties

Public Property AlertDate | The date that the alert was generated, based on the database server clock.
Public Property AlertType | The type of alert generated: Alert or Follow-up.
Public Property Description | The description of the alert.
Public Property ID | The alert or follow-up ID.
Public Property Subject | A short summary appropriate to be used as subject line of the Alert e-mail.
Public Property Unread | If true, the alert or follow-up has not yet been read.


%%PageItemTitle%%

IAlert Interface

AlertDate Property

Description

The date that the alert was generated, based on the database server clock.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AlertDate() As Date

See Also

IAlert Interface


%%PageItemTitle%%

IAlert Interface

AlertType Property

Description

The type of alert generated: Alert or Follow-up.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AlertType() As Long

See Also

IAlert Interface


%%PageItemTitle%%

IAlert Interface

Description Property

Description

The description of the alert.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Description() As String

See Also

IAlert Interface


%%PageItemTitle%%

IAlert Interface

ID Property

Description

The alert or follow-up ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Long

See Also

IAlert Interface


%%PageItemTitle%%

IAlert Interface

Subject Property

Description

A short summary appropriate to be used as subject line of the Alert e-mail.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Subject() As String

See Also

IAlert Interface


%%PageItemTitle%%

IAlert Interface

Unread Property

Description

If true, the alert or follow-up has not yet been read.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Unread() As Boolean

See Also

IAlert Interface


%%PageItemTitle%%

IAlertable Members

IAlertable Interface

Description

Services for managing auto-alerts.

Interface Remarks

IAlertable is implemented by the Bug, Req, Test, and TSTest objects.

Public Methods

Public Method CleanAllAlerts | Removes all current object alerts from the database.
Public Method DeleteAlert | Removes an alert or alerts associated with the current object from the database.
Public Method GetAlert | Gets the alert specified by the alert ID.
Public Method GetAlertList | Gets a list of all alerts associated with the object.
Public Method HasAlerts | Checks if any alerts are associated with the object.
Public Method HasNewAlerts | New, unread alerts are associated with the object.


%%PageItemTitle%%

IAlertable Interface

CleanAllAlerts Method

Description

Removes all current object alerts from the database.

Syntax

Public Sub CleanAllAlerts()

See Also

IAlertable Interface


%%PageItemTitle%%

IAlertable Interface

IDs

A comma separated list of alert ID numbers.

Or:

One of the following strings: [ALL], [BUG], [TEST], [REQ], or [TESTCYCL].

These strings indicate that ALL alerts will be deleted, or the alerts of the specified type will be deleted (Bug, Test, Req, or Test set).

See Also OTA COM Type Library

DeleteAlert Method

Description

Removes an alert or alerts associated with the current object from the database.

Syntax

Public Sub DeleteAlert( _
   ByVal IDs As Variant _
)

Parameters

IDs

A comma separated list of alert ID numbers.

Or:

One of the following strings: [ALL], [BUG], [TEST], [REQ], or [TESTCYCL].

These strings indicate that ALL alerts will be deleted, or the alerts of the specified type will be deleted (Bug, Test, Req, or Test set).

See Also

IAlertable Interface


%%PageItemTitle%%

IAlertable Interface

ID
The alert ID.
See Also OTA COM Type Library

GetAlert Method

Description

Gets the alert specified by the alert ID.

Syntax

Public Function GetAlert( _
   ByVal ID As Long _
) As Object

Parameters

ID
The alert ID.

Return Type

An IDispatch reference to an Alert object.

See Also

IAlertable Interface


%%PageItemTitle%%

IAlertable Interface

NeedRefresh
Pass True to refresh cache data from server.
See Also OTA COM Type Library

GetAlertList Method

Description

Gets a list of all alerts associated with the object.

Syntax

Public Function GetAlertList( _
   Optional ByVal NeedRefresh As Boolean = False _
) As List

Parameters

NeedRefresh
Pass True to refresh cache data from server.

Remarks

If NeedRefresh is "True", returns the list of IAlert references from the server. If "False", takes the data from the client cache.

See Also

IAlertable Interface


%%PageItemTitle%%

IAlertable Interface

HasAlerts Method

Description

Checks if any alerts are associated with the object.

Syntax

Public Function HasAlerts() As Boolean

See Also

IAlertable Interface


%%PageItemTitle%%

IAlertable Interface

HasNewAlerts Method

Description

New, unread alerts are associated with the object.

Syntax

Public Function HasNewAlerts() As Boolean

See Also

IAlertable Interface


%%PageItemTitle%%

IAlertable2 Interface

ChangedEntityType
The type of object the whose change triggered the Alert. One or BUG, REQ, TEST, or TESTSET.
ChangedEntityID
The ID of the object of the specified changed entity type.
alertSubject
A short summary appropriate to be used as subject line of the Alert e-mail.
alertDescription
The description of the alert.
See Also OTA COM Type Library

AddAlert Method

Description

Adds a new alert to the specified entity.

Syntax

Public Function AddAlert( _
   ByVal ChangedEntityType As String, _
   ByVal ChangedEntityID As Long, _
   ByVal alertSubject As String, _
   ByVal alertDescription As String _
) As Object

Parameters

ChangedEntityType
The type of object the whose change triggered the Alert. One or BUG, REQ, TEST, or TESTSET.
ChangedEntityID
The ID of the object of the specified changed entity type.
alertSubject
A short summary appropriate to be used as subject line of the Alert e-mail.
alertDescription
The description of the alert.

Return Type

The new Alert Object.

Remarks

If no object specified with ChangedEntityType.ID exists, a run-time error occurs.

See Also

IAlertable2 Interface


%%PageItemTitle%%

IAlertable2 Interface

CleanAllAlerts Method

Description

Removes all current object alerts from the database.

Syntax

Public Sub CleanAllAlerts()

See Also

IAlertable2 Interface


%%PageItemTitle%%

IAlertable2 Interface

IDs
See Also OTA COM Type Library

DeleteAlert Method

Description

Removes an alert or alerts associated with the current object from the database.

Syntax

Public Sub DeleteAlert( _
   ByVal IDs As Variant _
)

Parameters

IDs

See Also

IAlertable2 Interface


%%PageItemTitle%%

IAlertable2 Interface

ID
See Also OTA COM Type Library

GetAlert Method

Description

Gets the alert specified by the alert ID.

Syntax

Public Function GetAlert( _
   ByVal ID As Long _
) As Object

Parameters

ID

See Also

IAlertable2 Interface


%%PageItemTitle%%

IAlertable2 Interface

NeedRefresh
See Also OTA COM Type Library

GetAlertList Method

Description

Gets a list of all alerts associated with the object.

Syntax

Public Function GetAlertList( _
   Optional ByVal NeedRefresh As Boolean = False _
) As List

Parameters

NeedRefresh

See Also

IAlertable2 Interface


%%PageItemTitle%%

IAlertable2 Interface

HasAlerts Method

Description

Checks if any alerts are associated with the object.

Syntax

Public Function HasAlerts() As Boolean

See Also

IAlertable2 Interface


%%PageItemTitle%%

IAlertable2 Interface

HasNewAlerts Method

Description

New, unread alerts are associated with the object.

Syntax

Public Function HasNewAlerts() As Boolean

See Also

IAlertable2 Interface


%%PageItemTitle%%

IAlertManager Members

IAlertManager Interface

Description

Services for managing alerts.

Remarks

Get an AlertManager object with TDConnection.AlertManager.

Interface Remarks

The IAlertManager interface is common to the Bug, Test, and TSTest objects. The interface manages the addition, deletion, and returning of parameters for the alerts related to these objects.

Public Methods

Public Method CleanAllAlerts | Removes all current alerts from the database.
Public Method DeleteAlert | Removes an alert or alerts related to the current object from the database.

Public Properties

Public Property Alert | Gets the Alert object for the alert with the specified ID.
Public Property AlertList | The list of user alerts.


%%PageItemTitle%%

IAlertManager Interface

CleanAllAlerts Method

Description

Removes all current alerts from the database.

Syntax

Public Sub CleanAllAlerts()

See Also

IAlertManager Interface


%%PageItemTitle%%

IAlertManager Interface

IDs

An Alert.ID or "[ALL]", "[TEST]", "[TESTCYCL]" or "[BUG]".

See Also OTA COM Type Library

DeleteAlert Method

Description

Removes an alert or alerts related to the current object from the database.

Syntax

Public Sub DeleteAlert( _
   ByVal IDs As Variant _
)

Parameters

IDs

An Alert.ID or "[ALL]", "[TEST]", "[TESTCYCL]" or "[BUG]".

See Also

IAlertManager Interface


%%PageItemTitle%%

IAlertManager Interface

ID

An Alert.ID.

See Also OTA COM Type Library

Alert Property

Description

Gets the Alert object for the alert with the specified ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alert( _
   ByVal ID As Long _
) As Object

Parameters

ID

An Alert.ID.

See Also

IAlertManager Interface


%%PageItemTitle%%

IAlertManager Interface

EntityType

One of: "ALL", "TEST", "TESTCYCL", or "BUG".

NeedRefresh

If True, refresh the local cache from the project database.

See Also OTA COM Type Library

AlertList Property

Description

The list of user alerts.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AlertList( _
   ByVal EntityType As String, _
   Optional ByVal NeedRefresh As Boolean = False _
) As List

Parameters

EntityType

One of: "ALL", "TEST", "TESTCYCL", or "BUG".

NeedRefresh

If True, refresh the local cache from the project database.

See Also

IAlertManager Interface


%%PageItemTitle%%

IAmarillusHash Members

IAmarillusHash Interface

Description

Support for hash generation.

Public Methods

Public Method GenerateHash Gets a Hash generated from the input value.


%%PageItemTitle%%

IAmarillusHash Interface

Value

The source string for which to generate a hash code.

See Also OTA COM Type Library

GenerateHash Method

Description

Gets a Hash generated from the input value.

Syntax

Public Function GenerateHash( _
   ByVal Value As String _
) As String

Parameters

Value

The source string for which to generate a hash code.

See Also

IAmarillusHash Interface


%%PageItemTitle%%

IAttachment Members

IAttachment Interface

Description

Represents a single file or Internet address attached to a field object.

Remarks

An Attachment object represents a single a file or Internet address attached to a field object and opened directly from Quality Center. For example, design documents, detailed defect descriptions, graphic files, and Web pages can be used as attachments.

Get an Attachment object through the Attachments property (attachment factory) of any object that implements IBaseFieldEx, SubjectNode.Attachments, or TestSetFolder.Attachments.

Public Methods

Public Method Load | Downloads an attachment file to a client machine.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Rename | Renames the attachment on the server. The attachment must be uploaded before calling this method.
Public Method Save | Uploads a file to the server.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AttachmentStorage | The ExtendedStorage object of this attachment. Applies only to file attachments.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Data | If the attachment is a file, an array of bytes. If a reference to file, the path or URL.
Public Property Description | The attachment description.
Public Property DirectLink | The link or path to the attachment.
Public Property Field | The value of the specified field.
Public Property FileName | If a file, the file location. If a virtual file, the location for the attachment before it is uploaded to the server. If a URL, the link address.
Public Property FileSize | The attachment file size in bytes.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property LastModified | The last modified time.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The attachment name.
Public Property ServerFileName | The attachment file name on the server machine.
Public Property Type | The attachment type. Either File or URL.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

IAttachment Interface

synchronize

If true, program run waits for download to complete. Otherwise, download is asynchronous.

RootPath

Output string variable. After the method returns, the value is the path to which the file was downloaded on the client machine.

The RootPath variable cannot be used in VBScript. See the example below for how to get the path in VBScript.

See Also OTA COM Type Library

Load Method

Description

Downloads an attachment file to a client machine.

Syntax

Public Sub Load( _
   ByVal synchronize As Boolean, _
   ByRef RootPath As String _
)

Parameters

synchronize

If true, program run waits for download to complete. Otherwise, download is asynchronous.

RootPath

Output string variable. After the method returns, the value is the path to which the file was downloaded on the client machine.

The RootPath variable cannot be used in VBScript. See the example below for how to get the path in VBScript.

Example

The RootPath argument cannot be used in a VBScript. For applications that must be written in VBScript, such as VAPI-XP tests, pass an empty string.

[Visual Basic]

Sub Test_Main(Debug, CurrentTestSet, CurrentTest, CurrentRun)

  On Error Resume Next

  TDOutput.Clear

  Set BugFact = TDConnection.BugFactory
  Set theBug = BugFact.Item(21)
  Set AttachFact = theBug.Attachments
  Set theAttachCol = AttachFact.NewList("")
  Set theAttach = theAttachCol.Item(1)

  'This works in VB, but not in VBScript:
  'theAttach.Load True, LoadPath

  'In VBScript, use this:
  theAttach.Load True, ""
  tdoutput.Print theAttach.FileName

  ' To get the path in VBScript, extract if from
  ' the filename:
  theFileName = theAttach.FileName
  tdoutput.Print theFileName
  thePath = Left(theFileName, InstrRev(theFileName, "\")-1)
  tdoutput.Print thePath

  ' handle run-time errors
  If Err.Number <> 0 Then

    TDOutput.Print "Run-time error [" & Err.Number & "] : " & Err.Description

    ' update execution status in "Test" mode

    If Not Debug Then

      CurrentRun.Status = "Failed"

      CurrentTest.Status = "Failed"

    End If

  End If

End Sub

See Also

IAttachment Interface


%%PageItemTitle%%

IAttachment Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IAttachment Interface


%%PageItemTitle%%

IAttachment Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IAttachment Interface


%%PageItemTitle%%

IAttachment Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IAttachment Interface


%%PageItemTitle%%

IAttachment Interface

NewName

The new name for the attachment.

See Also OTA COM Type Library

Rename Method

Description

Renames the attachment on the server. The attachment must be uploaded before calling this method.

Syntax

Public Sub Rename( _
   ByVal NewName As String _
)

Parameters

NewName

The new name for the attachment.

See Also

IAttachment Interface


%%PageItemTitle%%

IAttachment Interface

synchronize

If true, program run waits for upload to complete. Otherwise, upload is asynchronous.

See Also OTA COM Type Library

Save Method

Description

Uploads a file to the server.

Syntax

Public Sub Save( _
   ByVal synchronize As Boolean _
)

Parameters

synchronize

If true, program run waits for upload to complete. Otherwise, upload is asynchronous.

See Also

IAttachment Interface


%%PageItemTitle%%

IAttachment Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

IAttachment Interface


%%PageItemTitle%%

IAttachment Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

IAttachment Interface


%%PageItemTitle%%

IAttachment Interface

AttachmentStorage Property

Description

The ExtendedStorage object of this attachment. Applies only to file attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AttachmentStorage() As Object

See Also

IAttachment Interface


%%PageItemTitle%%

IAttachment Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

IAttachment Interface


%%PageItemTitle%%

IAttachment Interface

Data Property

Description

If the attachment is a file, an array of bytes. If a reference to file, the path or URL.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Data() As Variant

See Also

IAttachment Interface


%%PageItemTitle%%

IAttachment Interface

Description Property

Description

The attachment description.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Description() As String

See Also

IAttachment Interface


%%PageItemTitle%%

IAttachment Interface

DirectLink Property

Description

The link or path to the attachment.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DirectLink() As String

See Also

IAttachment Interface


%%PageItemTitle%%

IAttachment Interface

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName

The name of the field in the project database.

See Also

IAttachment Interface


%%PageItemTitle%%

IAttachment Interface

FileName Property

Description

If a file, the file location. If a virtual file, the location for the attachment before it is uploaded to the server. If a URL, the link address.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FileName() As String

See Also

IAttachment Interface


%%PageItemTitle%%

IAttachment Interface

FileSize Property

Description

The attachment file size in bytes.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FileSize() As Long

See Also

IAttachment Interface


%%PageItemTitle%%

IAttachment Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

IAttachment Interface


%%PageItemTitle%%

IAttachment Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

IAttachment Interface


%%PageItemTitle%%

IAttachment Interface

LastModified Property

Description

The last modified time.

Property type

Read-only property

Syntax (Visual Basic)

Public Property LastModified() As Date

See Also

IAttachment Interface


%%PageItemTitle%%

IAttachment Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

IAttachment Interface


%%PageItemTitle%%

IAttachment Interface

ViewFormat

If 1 is passed, the return value is the name of the file that was attached. For example, SampleAttachment.txt.

If 0 is passed , the return value is a file name with a prefix indicating its item type and number as stored in the project database. For example, BUG_1_SampleAttachment.txt.

See Also OTA COM Type Library

Name Property

Description

The attachment name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name( _
   Optional ByVal ViewFormat As Long = 0 _
) As String

Parameters

ViewFormat

If 1 is passed, the return value is the name of the file that was attached. For example, SampleAttachment.txt.

If 0 is passed , the return value is a file name with a prefix indicating its item type and number as stored in the project database. For example, BUG_1_SampleAttachment.txt.

See Also

IAttachment Interface


%%PageItemTitle%%

IAttachment Interface

ServerFileName Property

Description

The attachment file name on the server machine.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ServerFileName() As String

See Also

IAttachment Interface


%%PageItemTitle%%

IAttachment Interface

Type Property

Description

The attachment type. Either File or URL.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Type() As Long

See Also

IAttachment Interface


%%PageItemTitle%%

IAttachment Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

IAttachment Interface


%%PageItemTitle%%

IAttachmentFactory Members

IAttachmentFactory Interface

Description

Services for managing attachments of the current field object.

Remarks

Get an AttachmentFactory from the Attachments Property of any object that implements IBaseFieldEx, SubjectNode.Attachments, or TestSetFolder.Attachments.

See also: The Attachment Object

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Public Methods

Public Method AddItem | Creates a new item object.
Public Method FactoryProperties | Gets the owner type and key for the AttachmentFactory object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property AttachmentStorage | The ExtendedStorage object for downloading and uploading attachment files.
Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

IAttachmentFactory Interface

ItemData

When using IBaseFactory.AddItem with the AttachmentFactory, pass NULL for ItemData.

See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData

When using IBaseFactory.AddItem with the AttachmentFactory, pass NULL for ItemData.

Remarks

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

[Visual Basic]

Dim bgf As BugFactory
Dim bg As Bug
Dim attf As AttachmentFactory
Dim att As Attachment
Dim attList As List

' Get the factory object
 Set bgf = tdc.BugFactory
' Use defect #1
 Set bg = bgf.Item(1)
 Set attf = bg.Attachments

' Creating a new attachment
' Create virtual object, then populate the properties
 Set att = attf.AddItem(Null)
 att.FileName = Text1.Text
 att.Type = TDATT_INTERNET

' Saving the object with validity check
 att.Post

' Display the attachments
' Add the display-only items without a Post
 List1.Clear
 Set attList = attf.NewList("")
 For i = 1 To attList.Count

      Set att = attList.Item(i)
      List1.AddItem (att.Name)

 Next

See Also

IAttachmentFactory Interface


%%PageItemTitle%%

IAttachmentFactory Interface

OwnerType

The owner object type.

OwnerKey

The ID of the object to which this factory belongs.

See Also OTA COM Type Library

FactoryProperties Method

Description

Gets the owner type and key for the AttachmentFactory object.

Syntax

Public Sub FactoryProperties( _
   ByRef OwnerType As String, _
   ByRef OwnerKey As Variant _
)

Parameters

OwnerType

The owner object type.

OwnerKey

The ID of the object to which this factory belongs.

Remarks

OwnerType is one of:

"ALL_LISTS" for Subject
"BUG" for Defect
"CYCL_FOLD" for Test Set Folder
"CYCLE" for Test Set
"DESSTEPS" for Design Step
"REQ" for Requirement
"RUN" for Run
"STEP" for Run Step
"TEST" for Test
"TESTCYCL" for Test in Test Set (Test Instance)

    See Also

    IAttachmentFactory Interface


%%PageItemTitle%%

IAttachmentFactory Interface

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

Remarks

In Quality Center version 9.2, if no sub-type is specified in the filter, only attachments with an emptly sub-type are returned. This behavior will be changed in later versions. Sub-types are specified with the tagTDAPI_ATTACH_SUBTYPE Enumeration.

See Also

IAttachmentFactory Interface


%%PageItemTitle%%

IAttachmentFactory Interface

ItemKey

An Attachment.ID, a reference to an Attachment Object , or a Variant array of Attachment.IDs.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey

An Attachment.ID, a reference to an Attachment Object , or a Variant array of Attachment.IDs.

See Also

IAttachmentFactory Interface


%%PageItemTitle%%

IAttachmentFactory Interface

AttachmentStorage Property

Description

The ExtendedStorage object for downloading and uploading attachment files.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AttachmentStorage() As Object

See Also

IAttachmentFactory Interface


%%PageItemTitle%%

IAttachmentFactory Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

IAttachmentFactory Interface


%%PageItemTitle%%

IAttachmentFactory Interface

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

IAttachmentFactory Interface


%%PageItemTitle%%

IAttachmentFactory Interface

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

IAttachmentFactory Interface


%%PageItemTitle%%

IAttachmentFactory Interface

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IAttachmentFactory Interface


%%PageItemTitle%%

IAttachmentFactory Interface

ItemKey

The attachment ID (long ).

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey

The attachment ID (long ).

See Also

IAttachmentFactory Interface


%%PageItemTitle%%

IAuditable Members

IAuditable Interface

Description

Services to allow changes to an entity to be tracked.

Public Properties

Public Property AuditPropertyFactory | The AuditPropertyFactory object to handle AuditProperty objects for the changed object.
Public Property AuditRecordFactory | The AuditRecordFactory object to handle AuditRecords for the changed object.


%%PageItemTitle%%

IAuditable Interface

AuditPropertyFactory Property

Description

The AuditPropertyFactory object to handle AuditProperty objects for the changed object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AuditPropertyFactory() As Object

See Also

IAuditable Interface


%%PageItemTitle%%

IAuditable Interface

AuditRecordFactory Property

Description

The AuditRecordFactory object to handle AuditRecords for the changed object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AuditRecordFactory() As Object

See Also

IAuditable Interface


%%PageItemTitle%%

IAuditProperty Members

IAuditProperty Interface

Description

Represents a property associated with an AuditRecord.

Remarks

An AuditProperty is associated with an AuditRecord Object.

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Action | The database activity that caused creation of this record. For example, INSERT, UPDATE, or DELETE.
Public Property ActionID | The ID of the associated AuditRecord object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property EntityID | The ID of the entity that changed.
Public Property EntityType | The type of the entity that changed. For example, BUG, REQ.
Public Property Field | The value of the specified field.
Public Property FieldName | The database definition name of field that was changed.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property NewValue | The new value after the change.
Public Property OldValue | The value before the change.
Public Property PropertyName | The custom label for the field that was changed.
Public Property SessionID | The Quality Center Session ID under which the action was performed.
Public Property TableName | The database table in which the change was recorded.
Public Property Time | The time stamp of the change according to the database server clock.
Public Property UserName | The username of the user who performed the action.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

IAuditProperty Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IAuditProperty Interface


%%PageItemTitle%%

IAuditProperty Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IAuditProperty Interface


%%PageItemTitle%%

IAuditProperty Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IAuditProperty Interface


%%PageItemTitle%%

IAuditProperty Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

IAuditProperty Interface


%%PageItemTitle%%

IAuditProperty Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

IAuditProperty Interface


%%PageItemTitle%%

IAuditProperty Interface

Action Property

Description

The database activity that caused creation of this record. For example, INSERT, UPDATE, or DELETE.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Action() As String

See Also

IAuditProperty Interface


%%PageItemTitle%%

IAuditProperty Interface

ActionID Property

Description

The ID of the associated AuditRecord object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ActionID() As Long

See Also

IAuditProperty Interface


%%PageItemTitle%%

IAuditProperty Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

IAuditProperty Interface


%%PageItemTitle%%

IAuditProperty Interface

EntityID Property

Description

The ID of the entity that changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EntityID() As String

See Also

IAuditProperty Interface


%%PageItemTitle%%

IAuditProperty Interface

EntityType Property

Description

The type of the entity that changed. For example, BUG, REQ.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EntityType() As String

Remarks

For more information, see the Mercury Quality Center Database Reference.

See Also

IAuditProperty Interface


%%PageItemTitle%%

IAuditProperty Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

IAuditProperty Interface


%%PageItemTitle%%

IAuditProperty Interface

FieldName Property

Description

The database definition name of field that was changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FieldName() As String

Remarks

For more information, see the Mercury Quality Center Database Reference.

See Also

IAuditProperty Interface


%%PageItemTitle%%

IAuditProperty Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

IAuditProperty Interface


%%PageItemTitle%%

IAuditProperty Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

IAuditProperty Interface


%%PageItemTitle%%

IAuditProperty Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

IAuditProperty Interface


%%PageItemTitle%%

IAuditProperty Interface

NewValue Property

Description

The new value after the change.

Property type

Read-only property

Syntax (Visual Basic)

Public Property NewValue() As Variant

See Also

IAuditProperty Interface


%%PageItemTitle%%

IAuditProperty Interface

OldValue Property

Description

The value before the change.

Property type

Read-only property

Syntax (Visual Basic)

Public Property OldValue() As Variant

See Also

IAuditProperty Interface


%%PageItemTitle%%

IAuditProperty Interface

PropertyName Property

Description

The custom label for the field that was changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property PropertyName() As String

See Also

IAuditProperty Interface


%%PageItemTitle%%

IAuditProperty Interface

SessionID Property

Description

The Quality Center Session ID under which the action was performed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property SessionID() As Long

See Also

IAuditProperty Interface


%%PageItemTitle%%

IAuditProperty Interface

TableName Property

Description

The database table in which the change was recorded.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TableName() As String

Remarks

For more information, see the Mercury Quality Center Database Reference.

See Also

IAuditProperty Interface


%%PageItemTitle%%

IAuditProperty Interface

Time Property

Description

The time stamp of the change according to the database server clock.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Time() As String

See Also

IAuditProperty Interface


%%PageItemTitle%%

IAuditProperty Interface

UserName Property

Description

The username of the user who performed the action.

Property type

Read-only property

Syntax (Visual Basic)

Public Property UserName() As String

See Also

IAuditProperty Interface


%%PageItemTitle%%

IAuditProperty Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

IAuditProperty Interface


%%PageItemTitle%%

IAuditPropertyFactory Members

IAuditPropertyFactory Interface

Description

Services for managing AuditProperty objects.

Remarks

Get a reference from AuditRecord.AuditPropertyFactory.

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Public Methods

Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

IAuditPropertyFactory Interface

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

IAuditPropertyFactory Interface


%%PageItemTitle%%

IAuditPropertyFactory Interface

ItemKey

An AuditProperty.ID.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey

An AuditProperty.ID.

See Also

IAuditPropertyFactory Interface


%%PageItemTitle%%

IAuditPropertyFactory Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

IAuditPropertyFactory Interface


%%PageItemTitle%%

IAuditPropertyFactory Interface

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

IAuditPropertyFactory Interface


%%PageItemTitle%%

IAuditPropertyFactory Interface

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

IAuditPropertyFactory Interface


%%PageItemTitle%%

IAuditPropertyFactory Interface

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IAuditPropertyFactory Interface


%%PageItemTitle%%

IAuditPropertyFactory Interface

ItemKey

An AuditProperty.ID.

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey

An AuditProperty.ID.

See Also

IAuditPropertyFactory Interface


%%PageItemTitle%%

IAuditRecord Members | AuditProperty Object

IAuditRecord Interface

Description

A data change that is tracked.

Remarks

Get an AuditRecord from an AuditRecordFactory Object.

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Action | The name of the action that caused the tracked change.
Public Property ActionID | The ID of the AuditRecord.
Public Property AuditPropertyFactory | The AuditPropertyFactory Object for the current AuditRecord.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Description | The description of the audited change.
Public Property EntityID | The ID of the entity that changed.
Public Property EntityType | The type of the entity that changed.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property SessionID | The Quality Center Session ID under which the action was performed.
Public Property Time | The time stamp of the change according to the database server clock.
Public Property UserName | The username of the user who performed the action.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

IAuditRecord Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IAuditRecord Interface


%%PageItemTitle%%

IAuditRecord Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IAuditRecord Interface


%%PageItemTitle%%

IAuditRecord Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IAuditRecord Interface


%%PageItemTitle%%

IAuditRecord Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

IAuditRecord Interface


%%PageItemTitle%%

IAuditRecord Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

IAuditRecord Interface


%%PageItemTitle%%

IAuditRecord Interface

Action Property

Description

The name of the action that caused the tracked change.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Action() As String

See Also

IAuditRecord Interface


%%PageItemTitle%%

IAuditRecord Interface

ActionID Property

Description

The ID of the AuditRecord.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ActionID() As Long

See Also

IAuditRecord Interface


%%PageItemTitle%%

IAuditRecord Interface

AuditPropertyFactory Property

Description

The AuditPropertyFactory Object for the current AuditRecord.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AuditPropertyFactory() As Object

See Also

IAuditRecord Interface


%%PageItemTitle%%

IAuditRecord Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

IAuditRecord Interface


%%PageItemTitle%%

IAuditRecord Interface

Description Property

Description

The description of the audited change.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Description() As String

See Also

IAuditRecord Interface


%%PageItemTitle%%

IAuditRecord Interface

EntityID Property

Description

The ID of the entity that changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EntityID() As String

See Also

IAuditRecord Interface


%%PageItemTitle%%

IAuditRecord Interface

EntityType Property

Description

The type of the entity that changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EntityType() As String

Remarks

For more information, see the Mercury Quality Center Database Reference.

See Also

IAuditRecord Interface


%%PageItemTitle%%

IAuditRecord Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

IAuditRecord Interface


%%PageItemTitle%%

IAuditRecord Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

IAuditRecord Interface


%%PageItemTitle%%

IAuditRecord Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

IAuditRecord Interface


%%PageItemTitle%%

IAuditRecord Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

IAuditRecord Interface


%%PageItemTitle%%

IAuditRecord Interface

SessionID Property

Description

The Quality Center Session ID under which the action was performed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property SessionID() As Long

See Also

IAuditRecord Interface


%%PageItemTitle%%

IAuditRecord Interface

Time Property

Description

The time stamp of the change according to the database server clock.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Time() As String

See Also

IAuditRecord Interface


%%PageItemTitle%%

IAuditRecord Interface

UserName Property

Description

The username of the user who performed the action.

Property type

Read-only property

Syntax (Visual Basic)

Public Property UserName() As String

See Also

IAuditRecord Interface


%%PageItemTitle%%

IAuditRecord Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

IAuditRecord Interface


%%PageItemTitle%%

IAuditRecordFactory Members

IAuditRecordFactory Interface

Description

Services for managing AuditRecord objects.

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Public Methods

Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

IAuditRecordFactory Interface

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

IAuditRecordFactory Interface


%%PageItemTitle%%

IAuditRecordFactory Interface

ItemKey

An AuditRecord.ID.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey

An AuditRecord.ID.

See Also

IAuditRecordFactory Interface


%%PageItemTitle%%

IAuditRecordFactory Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

IAuditRecordFactory Interface


%%PageItemTitle%%

IAuditRecordFactory Interface

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

IAuditRecordFactory Interface


%%PageItemTitle%%

IAuditRecordFactory Interface

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

IAuditRecordFactory Interface


%%PageItemTitle%%

IAuditRecordFactory Interface

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IAuditRecordFactory Interface


%%PageItemTitle%%

IAuditRecordFactory Interface

ItemKey

An AuditRecord.ID.

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey

An AuditRecord.ID.

See Also

IAuditRecordFactory Interface


%%PageItemTitle%%

IBaseFactory Interface

ItemData
See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData

Remarks

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

[Visual Basic]

Dim bgf As BugFactory
Dim bg As Bug
Dim attf As AttachmentFactory
Dim att As Attachment
Dim attList As List

' Get the factory object
 Set bgf = tdc.BugFactory
' Use defect #1
 Set bg = bgf.Item(1)
 Set attf = bg.Attachments

' Creating a new attachment
' Create virtual object, then populate the properties
 Set att = attf.AddItem(Null)
 att.FileName = Text1.Text
 att.Type = TDATT_INTERNET

' Saving the object with validity check
 att.Post

' Display the attachments
' Add the display-only items without a Post
 List1.Clear
 Set attList = attf.NewList("")
 For i = 1 To attList.Count

      Set att = attList.Item(i)
      List1.AddItem (att.Name)

 Next

See Also

IBaseFactory Interface


%%PageItemTitle%%

IBaseFactory Interface

Filter
A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.
See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter
A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

IBaseFactory Interface


%%PageItemTitle%%

IBaseFactory Interface

ItemKey
See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey

See Also

IBaseFactory Interface


%%PageItemTitle%%

IBaseFactory Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

IBaseFactory Interface


%%PageItemTitle%%

IBaseFactory Interface

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

IBaseFactory Interface

Example

Get Table Fields


%%PageItemTitle%%

IBaseFactory Interface

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

IBaseFactory Interface


%%PageItemTitle%%

IBaseFactory Interface

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IBaseFactory Interface


%%PageItemTitle%%

IBaseFactory Interface

ItemKey
See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey

See Also

IBaseFactory Interface


%%PageItemTitle%%

IBaseFactory2 Interface

GroupingManager Property

Description

The GroupingManager for this factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property GroupingManager() As Object

Remarks

Do not use attempt to get the GroupingManager unless GroupingSupported is True. If grouping is not supported, an error results.

See Also

IBaseFactory2 Interface


%%PageItemTitle%%

IBaseFactory2 Interface

GroupingSupported Property

Description

Check whether the factory supports grouping.

Property type

Read-only property

Syntax (Visual Basic)

Public Property GroupingSupported() As Boolean

See Also

IBaseFactory2 Interface


%%PageItemTitle%%

IBaseFactoryEx Members

IBaseFactoryEx Interface

Description

Enhances the IBaseFactory interface to support mailing.

Interface Remarks

IBaseFactoryEx adds method Mail to IBaseFactory. It is implemented by several classes, such as BugFactory, ReqFactory, and TestFactory.
The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Public Methods

Public Method AddItem | Creates a new item object.
Public Method Mail | Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

IBaseFactoryEx Interface

ItemData
See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData

Remarks

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

[Visual Basic]

Dim bgf As BugFactory
Dim bg As Bug
Dim attf As AttachmentFactory
Dim att As Attachment
Dim attList As List

' Get the factory object
 Set bgf = tdc.BugFactory
' Use defect #1
 Set bg = bgf.Item(1)
 Set attf = bg.Attachments

' Creating a new attachment
' Create virtual object, then populate the properties
 Set att = attf.AddItem(Null)
 att.FileName = Text1.Text
 att.Type = TDATT_INTERNET

' Saving the object with validity check
 att.Post

' Display the attachments
' Add the display-only items without a Post
 List1.Clear
 Set attList = attf.NewList("")
 For i = 1 To attList.Count

      Set att = attList.Item(i)
      List1.AddItem (att.Name)

 Next

See Also

IBaseFactoryEx Interface


%%PageItemTitle%%

IBaseFactoryEx Interface

Items

A list of IDs.

SendTo
A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.
SendCc
The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.
Option
The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.
Subject
The mail subject line.
Comment
A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.
See Also OTA COM Type Library

Mail Method

Description

Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.

Syntax

Public Sub Mail( _
   ByVal Items As Variant, _
   ByVal SendTo As String, _
   Optional ByVal SendCc As String = "", _
   Optional ByVal Option As Long = 0, _
   Optional ByVal Subject As String = "", _
   Optional ByVal Comment As String = "" _
)

Parameters

Items

A list of IDs.

SendTo
A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.
SendCc
The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.
Option
The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.
Subject
The mail subject line.
Comment
A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also

IBaseFactoryEx Interface


%%PageItemTitle%%

IBaseFactoryEx Interface

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

IBaseFactoryEx Interface


%%PageItemTitle%%

IBaseFactoryEx Interface

ItemKey
See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey

See Also

IBaseFactoryEx Interface


%%PageItemTitle%%

IBaseFactoryEx Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

IBaseFactoryEx Interface


%%PageItemTitle%%

IBaseFactoryEx Interface

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

IBaseFactoryEx Interface


%%PageItemTitle%%

IBaseFactoryEx Interface

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

IBaseFactoryEx Interface


%%PageItemTitle%%

IBaseFactoryEx Interface

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IBaseFactoryEx Interface


%%PageItemTitle%%

IBaseFactoryEx Interface

ItemKey
See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey

See Also

IBaseFactoryEx Interface


%%PageItemTitle%%

IBaseField Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IBaseField Interface


%%PageItemTitle%%

IBaseField Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IBaseField Interface


%%PageItemTitle%%

IBaseField Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IBaseField Interface


%%PageItemTitle%%

IBaseField Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

IBaseField Interface


%%PageItemTitle%%

IBaseField Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

IBaseField Interface


%%PageItemTitle%%

IBaseField Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

IBaseField Interface


%%PageItemTitle%%

IBaseField Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

IBaseField Interface


%%PageItemTitle%%

IBaseField Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

IBaseField Interface


%%PageItemTitle%%

IBaseField Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

IBaseField Interface


%%PageItemTitle%%

IBaseField Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

IBaseField Interface


%%PageItemTitle%%

IBaseField Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

IBaseField Interface


%%PageItemTitle%%

IBaseField2 Interface

AutoUnlock Property

Description

Indicates whether to make the item changeable to other users automatically after a Refresh or Post.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoUnlock() As Boolean

Remarks

Default value is True.

Example

[Visual Basic]

Dim tdBug As IBaseField2
Set tdBug = BugF.Item(1)
  tdBug.AutoUnlock = False
  tdBug.Field("BG_DETECTED_BY") = "admin"
  tdBug.Post

See Also

IBaseField2 Interface


%%PageItemTitle%%

IBaseField2 Interface

FieldName
The name of the field in the database.
See Also OTA COM Type Library

FieldMultiValue Property

Description

The MultiValue object of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FieldMultiValue( _
   ByVal FieldName As String _
) As MultiValue

Parameters

FieldName
The name of the field in the database.

Remarks

The validity of the input is checked against the list of possible values when this property is set.

See Also

IBaseField2 Interface

Example

Getting and assigning multiple values for a Bug record


%%PageItemTitle%%

IBaseField3 Interface

UndoOnFailure

If True, then all changes to the object in memory are rolled back if the Post fails.

If False, failure of the Post does not effect the values in memory.

See Also OTA COM Type Library

Post Method

Description

Writes all changed values to database.

Syntax

Public Sub Post( _
   Optional ByVal UndoOnFailure As Boolean = True _
)

Parameters

UndoOnFailure

If True, then all changes to the object in memory are rolled back if the Post fails.

If False, failure of the Post does not effect the values in memory.

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IBaseField3 Interface


%%PageItemTitle%%

IBaseFieldEx Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IBaseFieldEx Interface


%%PageItemTitle%%

IBaseFieldEx Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IBaseFieldEx Interface


%%PageItemTitle%%

IBaseFieldEx Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IBaseFieldEx Interface


%%PageItemTitle%%

IBaseFieldEx Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

IBaseFieldEx Interface


%%PageItemTitle%%

IBaseFieldEx Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

IBaseFieldEx Interface


%%PageItemTitle%%

IBaseFieldEx Interface

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

IBaseFieldEx Interface


%%PageItemTitle%%

IBaseFieldEx Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

IBaseFieldEx Interface


%%PageItemTitle%%

IBaseFieldEx Interface

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName

The name of the field in the project database.

See Also

IBaseFieldEx Interface


%%PageItemTitle%%

IBaseFieldEx Interface

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

IBaseFieldEx Interface


%%PageItemTitle%%

IBaseFieldEx Interface

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IBaseFieldEx Interface


%%PageItemTitle%%

IBaseFieldEx Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

IBaseFieldEx Interface


%%PageItemTitle%%

IBaseFieldEx Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

IBaseFieldEx Interface


%%PageItemTitle%%

IBaseFieldEx Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

IBaseFieldEx Interface


%%PageItemTitle%%

IBaseFieldEx Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

IBaseFieldEx Interface


%%PageItemTitle%%

IBaseFieldExMail Members

IBaseFieldExMail Interface

Description

Services to support mailing factory items.

Interface Remarks

IBaseField defines a basic data field or entity. Use the properties and methods in IBaseField to perform field-related actions, such as setting and refreshing field values. Examples of objects that implement IBaseField are: Attachment, Bug, Condition, DesignStep, Host, HostGroup, Req, Run, Step, SubjectNode, SysTreeNode, Test, TestSet, and TSTest.

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Mail | Mails the IBaseFieldExMail field item.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

IBaseFieldExMail Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IBaseFieldExMail Interface


%%PageItemTitle%%

IBaseFieldExMail Interface | tagTDMAIL_FLAGS Enumeration

SendTo
The recipient address or addresses. Addresses can be separated by a comma or a semicolon.
SendCc
The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.
Option
The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.
Subject
The mail subject line.
Comment
A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.
See Also OTA COM Type Library

Mail Method

Description

Mails the IBaseFieldExMail field item.

Syntax

Public Sub Mail( _
   ByVal SendTo As String, _
   Optional ByVal SendCc As String = "", _
   Optional ByVal Option As Long = 0, _
   Optional ByVal Subject As String = "", _
   Optional ByVal Comment As String = "" _
)

Parameters

SendTo
The recipient address or addresses. Addresses can be separated by a comma or a semicolon.
SendCc
The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.
Option
The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.
Subject
The mail subject line.
Comment
A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also

IBaseFieldExMail Interface | tagTDMAIL_FLAGS Enumeration


%%PageItemTitle%%

IBaseFieldExMail Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IBaseFieldExMail Interface


%%PageItemTitle%%

IBaseFieldExMail Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IBaseFieldExMail Interface


%%PageItemTitle%%

IBaseFieldExMail Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

IBaseFieldExMail Interface


%%PageItemTitle%%

IBaseFieldExMail Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

IBaseFieldExMail Interface


%%PageItemTitle%%

IBaseFieldExMail Interface

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

IBaseFieldExMail Interface


%%PageItemTitle%%

IBaseFieldExMail Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

IBaseFieldExMail Interface


%%PageItemTitle%%

IBaseFieldExMail Interface

FieldName
The name of the field in the project database.

The name of the field in the project database.

See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

The name of the field in the project database.

See Also

IBaseFieldExMail Interface


%%PageItemTitle%%

IBaseFieldExMail Interface

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

IBaseFieldExMail Interface


%%PageItemTitle%%

IBaseFieldExMail Interface

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IBaseFieldExMail Interface


%%PageItemTitle%%

IBaseFieldExMail Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

IBaseFieldExMail Interface


%%PageItemTitle%%

IBaseFieldExMail Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

IBaseFieldExMail Interface


%%PageItemTitle%%

IBaseFieldExMail Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

IBaseFieldExMail Interface


%%PageItemTitle%%

IBaseFieldExMail Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

IBaseFieldExMail Interface


%%PageItemTitle%%

IBPComponent Members

IBPComponent Interface

Description

An instance of a Component in a Business Process.

Remarks

A BPComponent is an instance of a Component in a BusinessProcess. Adding a Component to a BusinessProcess twice creates two BPComponent objects. Adding the same Component to two different business processes also creates two BPComponent objects.

Get a BPComponent with BusinessProcess.AddBPComponent.

Save changes to the object with BusinessProcess.Save, using the BusinessProcess object of which this is a child object.

Public Methods

Public Method AddIteration | Adds an Iteration to the BPComponent.
Public Method DeleteIteration | Delete the specified BPIteration from the BPComponent.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property BPParams | The list of the BPComponents parameters.
Public Property Component | Get the Component object from which this BPComponent was created.
Public Property FailureCondition | Indicates the behavior of the business process test if this component fails.
Public Property Field | The value of the specified field.
Public Property Group | The BPGroup to which this component belongs.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Iterations | The list of the BPComponents Iterations.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The name of the component from which this BPComponent was created.
Public Property Order | The position of the BPComponent in the BusinessProcess (1-based).
Public Property Test | The parent business process test.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

IBPComponent Interface

AddIteration Method

Description

Adds an Iteration to the BPComponent.

Syntax

Public Function AddIteration() As Object

Return Type

The new BPIteration Object.

Remarks

BPIterationParams are not added automatically when an iteration is added. They must be added or the BusinessProcess test will not run. See BPIteration.AddParam.

Save any modifications to the returned object by calling BusinessProcess.Save.

See Also

IBPComponent Interface


%%PageItemTitle%%

IBPComponent Interface

pVal

A BPIteration Object.

See Also OTA COM Type Library

DeleteIteration Method

Description

Delete the specified BPIteration from the BPComponent.

Syntax

Public Sub DeleteIteration( _
   ByVal pVal As Object _
)

Parameters

pVal

A BPIteration Object.

See Also

IBPComponent Interface


%%PageItemTitle%%

IBPComponent Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If the object is locked, no other user can change or delete it.

The object is unlocked on a Post or Refresh operation and when the connection is logged off the project.

See Also

IBPComponent Interface


%%PageItemTitle%%

IBPComponent Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IBPComponent Interface


%%PageItemTitle%%

IBPComponent Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

IBPComponent Interface


%%PageItemTitle%%

IBPComponent Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users.

See Also

IBPComponent Interface


%%PageItemTitle%%

IBPComponent Interface

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

IBPComponent Interface


%%PageItemTitle%%

IBPComponent Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

IBPComponent Interface


%%PageItemTitle%%

IBPComponent Interface

BPParams Property

Description

The list of the BPComponents parameters.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BPParams() As List

See Also

IBPComponent Interface


%%PageItemTitle%%

IBPComponent Interface

Component Property

Description

Get the Component object from which this BPComponent was created.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Component() As Object

See Also

IBPComponent Interface


%%PageItemTitle%%

IBPComponent Interface

FailureCondition Property

Description

Indicates the behavior of the business process test if this component fails.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FailureCondition() As String

Remarks

If the BPComponent fails at runtime, "Exit" indicates that the entire BusinessProcess test terminates. "Continue" indicates that only this failed component terminates.

See Also

IBPComponent Interface


%%PageItemTitle%%

IBPComponent Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

IBPComponent Interface


%%PageItemTitle%%

IBPComponent Interface

Group Property

Description

The BPGroup to which this component belongs.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Group() As Object

See Also

IBPComponent Interface


%%PageItemTitle%%

IBPComponent Interface

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

IBPComponent Interface


%%PageItemTitle%%

IBPComponent Interface

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IBPComponent Interface


%%PageItemTitle%%

IBPComponent Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

IBPComponent Interface


%%PageItemTitle%%

IBPComponent Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

IBPComponent Interface


%%PageItemTitle%%

IBPComponent Interface

Iterations Property

Description

The list of the BPComponents Iterations.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Iterations() As List

See Also

IBPComponent Interface


%%PageItemTitle%%

IBPComponent Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

IBPComponent Interface


%%PageItemTitle%%

IBPComponent Interface

Name Property

Description

The name of the component from which this BPComponent was created.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name() As String

See Also

IBPComponent Interface


%%PageItemTitle%%

IBPComponent Interface

Order Property

Description

The position of the BPComponent in the BusinessProcess (1-based).

Property type

Read-write property

Syntax (Visual Basic)

Public Property Order() As Long

See Also

IBPComponent Interface


%%PageItemTitle%%

IBPComponent Interface

Test Property

Description

The parent business process test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Test() As Object

See Also

IBPComponent Interface


%%PageItemTitle%%

IBPComponent Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

IBPComponent Interface


%%PageItemTitle%%

IBPGroup Members

IBPGroup Interface

Description

Support for grouping business components so that they iterate as a unit.

Remarks

Ensure that BPComponents added to the BPGroup are sequential and have the same number of iterations.

Get a BPGroup from BusinessProcess.AddGroup or BusinessProcess.GroupByID.

Save changes to the object with BusinessProcess.Save, using the BusinessProcess object of which this is a child object.

Public Methods

Public Method AddBPComponent | Adds the specified business component to the group.
Public Method BPComponents | The list of the BPComponents that belong to the group.
Public Method DeleteBPComponent | Removes the specified business component from the group.

Public Properties

Public Property ID The group ID.


%%PageItemTitle%%

IBPGroup Interface

pBPComponent

A BPComponent Object.

See Also OTA COM Type Library

AddBPComponent Method

Description

Adds the specified business component to the group.

Syntax

Public Sub AddBPComponent( _
   ByVal pBPComponent As Object _
)

Parameters

pBPComponent

A BPComponent Object.

See Also

IBPGroup Interface


%%PageItemTitle%%

IBPGroup Interface

BPComponents Method

Description

The list of the BPComponents that belong to the group.

Syntax

Public Function BPComponents() As List

Return Type

A list of BPComponent Objects.

See Also

IBPGroup Interface


%%PageItemTitle%%

IBPGroup Interface

pBPComponent

A BPComponent Object.

See Also OTA COM Type Library

DeleteBPComponent Method

Description

Removes the specified business component from the group.

Syntax

Public Sub DeleteBPComponent( _
   ByVal pBPComponent As Object _
)

Parameters

pBPComponent

A BPComponent Object.

See Also

IBPGroup Interface


%%PageItemTitle%%

IBPGroup Interface

ID Property

Description

The group ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Long

See Also

IBPGroup Interface


%%PageItemTitle%%

IBPIteration Members

IBPIteration Interface

Description

The design-time definition of a business component iteration.

Remarks

The object is created with BPComponent.AddIteration. Get a reference from the return value of BPComponent.AddIteration or from the list returned by BPComponent.Iterations.

When a Component is added to a BusinessProcess, one BPIteration is added automatically, together with BPIterationParams for all of the component’s parameters. This BPIteration does not have an Order. The test cannot be run until the order is set.

When additional iterations are added after the Component has been added, the BPIterationParams are not added automatically. They must be added in code or in the user interface for the BusinessProcess test to run.

Save changes to the object with BusinessProcess.Save, using the BusinessProcess object of which this is a child object.

Public Methods

Public Method AddParam | Add the specified BPParameter Object to the iteration.
Public Method DeleteIterationParams | Delete all the parameters from the iteration.
Public Method DeleteParam | Delete the specified BPParameter from the iteration.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property BPComponent | The BPComponent object of which this an iteration.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property IterationParams | The list of BPIterationParam objects associated with this iteration.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Order | The 0-based execution position of this iteration in the set of iterations of this component.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

IBPIteration Interface

pVal

A BPParameter Object.

See Also OTA COM Type Library

AddParam Method

Description

Add the specified BPParameter Object to the iteration.

Syntax

Public Function AddParam( _
   ByVal pVal As Object _
) As Object

Parameters

pVal

A BPParameter Object.

Return Type

The new BPIterationParam Object.

Remarks

When a parameter is added in code, this function must be called in a loop to add the new parameter and a value to each BPIteration in the test.

When an iteration is added in code, this function must be called in a loop to add each BPParameter in the step to the new iteration.

If the new BPIterationParam is modified, call BusinessProcess.Save.

See Also

IBPIteration Interface


%%PageItemTitle%%

IBPIteration Interface

DeleteIterationParams Method

Description

Delete all the parameters from the iteration.

Syntax

Public Sub DeleteIterationParams()

See Also

IBPIteration Interface


%%PageItemTitle%%

IBPIteration Interface

pVal

A BPParameter Object.

See Also OTA COM Type Library

DeleteParam Method

Description

Delete the specified BPParameter from the iteration.

Syntax

Public Sub DeleteParam( _
   ByVal pVal As Object _
)

Parameters

pVal

A BPParameter Object.

Return Type

This function must be called in a loop to delete the parameter from each BPIteration in the test.

See Also

IBPIteration Interface


%%PageItemTitle%%

IBPIteration Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IBPIteration Interface


%%PageItemTitle%%

IBPIteration Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IBPIteration Interface


%%PageItemTitle%%

IBPIteration Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

IBPIteration Interface


%%PageItemTitle%%

IBPIteration Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

IBPIteration Interface


%%PageItemTitle%%

IBPIteration Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

IBPIteration Interface


%%PageItemTitle%%

IBPIteration Interface

BPComponent Property

Description

The BPComponent object of which this an iteration.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BPComponent() As Object

See Also

IBPIteration Interface


%%PageItemTitle%%

IBPIteration Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

IBPIteration Interface


%%PageItemTitle%%

IBPIteration Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

IBPIteration Interface


%%PageItemTitle%%

IBPIteration Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

IBPIteration Interface


%%PageItemTitle%%

IBPIteration Interface

IterationParams Property

Description

The list of BPIterationParam objects associated with this iteration.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IterationParams() As List

See Also

IBPIteration Interface


%%PageItemTitle%%

IBPIteration Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

IBPIteration Interface


%%PageItemTitle%%

IBPIteration Interface

Order Property

Description

The 0-based execution position of this iteration in the set of iterations of this component.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Order() As Long

See Also

IBPIteration Interface


%%PageItemTitle%%

IBPIteration Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

IBPIteration Interface


%%PageItemTitle%%

IBPIterationParam Members

IBPIterationParam Interface

Description

An instance of a business component parameter that belongs to a single iteration.

Remarks

BPIterationParams are not added automatically when iterations are added to a BPComponent. Add them in code or through the user interface to enable the BusinessProcess test to run.

Get a BPIterationParam object from BPIteration.AddParam or from the BPIteration.IterationParams list.

If the value of the parameter is not of the correct type, errors will occur in viewing and running the test.

Save changes to the object with BusinessProcess.Save, using the BusinessProcess object of which this is a child object.

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property BPParameter | The BPParameter object of which this is an instance.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Value | The value of the parameter for this iteration.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

IBPIterationParam Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IBPIterationParam Interface


%%PageItemTitle%%

IBPIterationParam Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IBPIterationParam Interface


%%PageItemTitle%%

IBPIterationParam Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

IBPIterationParam Interface


%%PageItemTitle%%

IBPIterationParam Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

IBPIterationParam Interface


%%PageItemTitle%%

IBPIterationParam Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

IBPIterationParam Interface


%%PageItemTitle%%

IBPIterationParam Interface

BPParameter Property

Description

The BPParameter object of which this is an instance.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BPParameter() As Object

See Also

IBPIterationParam Interface


%%PageItemTitle%%

IBPIterationParam Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

IBPIterationParam Interface


%%PageItemTitle%%

IBPIterationParam Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

IBPIterationParam Interface


%%PageItemTitle%%

IBPIterationParam Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

IBPIterationParam Interface


%%PageItemTitle%%

IBPIterationParam Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

IBPIterationParam Interface


%%PageItemTitle%%

IBPIterationParam Interface

Value Property

Description

The value of the parameter for this iteration.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Value() As String

Remarks

The value must be consistent with the BPParameter.Type of the object referenced by the BPParameter Property. If the value is not of the correct type, errors will be encountered when attempting to run the test.

See Also

IBPIterationParam Interface


%%PageItemTitle%%

IBPIterationParam Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

IBPIterationParam Interface


%%PageItemTitle%%

IBPParam Members

IBPParam Interface

Description

An instance of a Component Parameter in a business component.

Remarks

A BPParameter is based on a ComponentParam. The BPParameters are added automatically to the BPComponent when it is created from the Component. Every ComponentParam in the Component becomes a BPParameter in the BPComponent. The default value is the value of the ComponentParam from which the BPParameter is created.

The value of a BPParameter is either a constant or the value of another BPParameter. BPParameter.Type is either CONSTANT or REF_BPPARAM, respectively.

If a CONSTANT, get the value from the ComponentParam.Value of the component returned by the ComponentParam Property of the BPParameter.

If the type is REF_BPPARAM, then the value is the output value of another BPParameter. Get the source BPParameter from the Reference Property, then get the source's constant value from its ComponentParam as described above: sourceBPParameter.ComponentParam.Value.

Get a BPParameter from the list returned by BPComponent.BPParams.

Save changes to the object with BusinessProcess.Save, using the BusinessProcess object of which this is a child object.

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property BPComponent | The BPComponent object to which this parameter belongs.
Public Property ComponentParam | The ComponentParam object from which this BPParam was created.
Public Property ComponentParamIsOut | Indicates if the ComponentParam from which this BPParam was created is an output parameter. If False, it is an input parameter.
Public Property ComponentParamName | The name of the ComponentParam object from which this BPParam was created.
Public Property ComponentParamOrder | The position of the ComponentParam object from which this BPParam was created.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Reference | The output BPParameter object that is the source of the value for this parameter.
Public Property Type | The parameter type.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

IBPParam Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IBPParam Interface


%%PageItemTitle%%

IBPParam Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IBPParam Interface


%%PageItemTitle%%

IBPParam Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

IBPParam Interface


%%PageItemTitle%%

IBPParam Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

IBPParam Interface


%%PageItemTitle%%

IBPParam Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

IBPParam Interface


%%PageItemTitle%%

IBPParam Interface

BPComponent Property

Description

The BPComponent object to which this parameter belongs.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BPComponent() As Object

See Also

IBPParam Interface


%%PageItemTitle%%

IBPParam Interface

ComponentParam Property

Description

The ComponentParam object from which this BPParam was created.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ComponentParam() As Object

See Also

IBPParam Interface


%%PageItemTitle%%

IBPParam Interface

ComponentParamIsOut Property

Description

Indicates if the ComponentParam from which this BPParam was created is an output parameter. If False, it is an input parameter.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ComponentParamIsOut() As Long

See Also

IBPParam Interface


%%PageItemTitle%%

IBPParam Interface

ComponentParamName Property

Description

The name of the ComponentParam object from which this BPParam was created.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ComponentParamName() As String

See Also

IBPParam Interface


%%PageItemTitle%%

IBPParam Interface

ComponentParamOrder Property

Description

The position of the ComponentParam object from which this BPParam was created.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ComponentParamOrder() As Long

See Also

IBPParam Interface


%%PageItemTitle%%

IBPParam Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

IBPParam Interface


%%PageItemTitle%%

IBPParam Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

IBPParam Interface


%%PageItemTitle%%

IBPParam Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

IBPParam Interface


%%PageItemTitle%%

IBPParam Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

IBPParam Interface


%%PageItemTitle%%

IBPParam Interface

Reference Property

Description

The output BPParameter object that is the source of the value for this parameter.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Reference() As Object

Remarks

If this input parameter gets its value from an output parameter, this is the source parameter. If the value of this BPParameter is a constant, the Reference property has no meaning.

When setting the Reference of the target BPParameter, ensure that there are no instances of BPIterationParam created from that target BPParameter. Note that when a Component is added to a BusinessProcess, one BPIteration is added automatically, together with BPIterationParams for all of the component’s parameters. Delete them in your code before setting the Reference. Failure to do so results in an error when attempting to view or run the test.

See Also

IBPParam Interface


%%PageItemTitle%%

IBPParam Interface

Type Property

Description

The parameter type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Type() As Long

See Also

IBPParam Interface


%%PageItemTitle%%

IBPParam Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

IBPParam Interface


%%PageItemTitle%%

IBPStepParam Members

IBPStepParam Interface

Description

A step parameter for a manual run of the business process test.

Remarks

Get a BPStepParam with BPStepParamFactory.AddItem or from the list returned by BPStepParamFactory.NewList.

Save changes to the object with BusinessProcess.Save, using the BusinessProcess object of which this is a child object.

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The name of this parameter.
Public Property ReferencedParamID | The parameter ID of the referenced parameter.
Public Property StepID | The ID of the step in which this parameter occurs.
Public Property Type | The parameter type.
Public Property Value | The value of this parameter.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

IBPStepParam Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IBPStepParam Interface


%%PageItemTitle%%

IBPStepParam Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IBPStepParam Interface


%%PageItemTitle%%

IBPStepParam Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

IBPStepParam Interface


%%PageItemTitle%%

IBPStepParam Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

IBPStepParam Interface


%%PageItemTitle%%

IBPStepParam Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

IBPStepParam Interface


%%PageItemTitle%%

IBPStepParam Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

IBPStepParam Interface


%%PageItemTitle%%

IBPStepParam Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

IBPStepParam Interface


%%PageItemTitle%%

IBPStepParam Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

IBPStepParam Interface


%%PageItemTitle%%

IBPStepParam Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

IBPStepParam Interface


%%PageItemTitle%%

IBPStepParam Interface

Name Property

Description

The name of this parameter.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

IBPStepParam Interface


%%PageItemTitle%%

IBPStepParam Interface

ReferencedParamID Property

Description

The parameter ID of the referenced parameter.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ReferencedParamID() As Long

Remarks

When this input parameter gets its value from an output parameter of a previous step, this is the ID of the output parameter that is the source of the value.

See Also

IBPStepParam Interface


%%PageItemTitle%%

IBPStepParam Interface

StepID Property

Description

The ID of the step in which this parameter occurs.

Property type

Read-only property

Syntax (Visual Basic)

Public Property StepID() As Long

See Also

IBPStepParam Interface


%%PageItemTitle%%

IBPStepParam Interface

Type Property

Description

The parameter type.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Type() As Long

See Also

IBPStepParam Interface


%%PageItemTitle%%

IBPStepParam Interface

Value Property

Description

The value of this parameter.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Value() As String

See Also

IBPStepParam Interface


%%PageItemTitle%%

IBPStepParam Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

IBPStepParam Interface


%%PageItemTitle%%

IBug Members

IBug Interface

Description

Represents a defect.

Remarks

Get a Bug object from TDConnection.BugFactory.

Public Methods

Public Method FindSimilarBugs | Searches the defect summaries for similarities to this defect.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Mail | Mails the IBaseFieldExMail field item.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AssignedTo | The name of the user to whom the defect is assigned.
Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property DetectedBy | The name of the user who detected the defect.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Priority | The defect priority.
Public Property Project | The testing project to which the defect belongs.
Public Property Status | The defect status.
Public Property Summary | A short description of the defect.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

IBug Interface

SimilarityRatio

Specifies the similarity ratio (0-100).

See Also OTA COM Type Library

FindSimilarBugs Method

Description

Searches the defect summaries for similarities to this defect.

Syntax

Public Function FindSimilarBugs( _
   Optional ByVal SimilarityRatio As Long = 10 _
) As List

Parameters

SimilarityRatio

Specifies the similarity ratio (0-100).

Return Type

A FactoryList of Bug objects.

Remarks

For more information on the similarity ratio, see 'Matching Defects' under 'Adding New Defects' in the Quality Center User's Guide.

See Also

IBug Interface


%%PageItemTitle%%

IBug Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IBug Interface


%%PageItemTitle%%

IBug Interface | tagTDMAIL_FLAGS Enumeration

SendTo

The recipient address or addresses. Addresses can be separated by a comma or a semicolon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also OTA COM Type Library

Mail Method

Description

Mails the IBaseFieldExMail field item.

Syntax

Public Sub Mail( _
   ByVal SendTo As String, _
   Optional ByVal SendCc As String = "", _
   Optional ByVal Option As Long = 0, _
   Optional ByVal Subject As String = "", _
   Optional ByVal Comment As String = "" _
)

Parameters

SendTo

The recipient address or addresses. Addresses can be separated by a comma or a semicolon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also

IBug Interface | tagTDMAIL_FLAGS Enumeration


%%PageItemTitle%%

IBug Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

Example

[Visual Basic]

Dim bfact As BugFactory
Dim mybug As Bug

'Get BugFactory from TDConnection
Set bfact = tdc.BugFactory
'Add 5 defects
For i = 1 To 5
   Set mybug = bfact.AddItem("Defect" & i)
   mybug.Summary = "Test" & i
   mybug.Status = "Open"
   mybug.Post
Next i

See Also

IBug Interface


%%PageItemTitle%%

IBug Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IBug Interface


%%PageItemTitle%%

IBug Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

IBug Interface


%%PageItemTitle%%

IBug Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

IBug Interface


%%PageItemTitle%%

IBug Interface

AssignedTo Property

Description

The name of the user to whom the defect is assigned.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AssignedTo() As String

See Also

IBug Interface


%%PageItemTitle%%

IBug Interface

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

IBug Interface


%%PageItemTitle%%

IBug Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

IBug Interface


%%PageItemTitle%%

IBug Interface

DetectedBy Property

Description

The name of the user who detected the defect.

Property type

Read-write property

Syntax (Visual Basic)

Public Property DetectedBy() As String

See Also

IBug Interface


%%PageItemTitle%%

IBug Interface

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName

The name of the field in the project database.

Remarks

If the field name is "BG_SUBJECT", a SubjectNode Object is returned.

See Also

IBug Interface


%%PageItemTitle%%

IBug Interface

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

IBug Interface


%%PageItemTitle%%

IBug Interface

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IBug Interface


%%PageItemTitle%%

IBug Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

IBug Interface


%%PageItemTitle%%

IBug Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

IBug Interface


%%PageItemTitle%%

IBug Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

IBug Interface


%%PageItemTitle%%

IBug Interface

Priority Property

Description

The defect priority.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Priority() As String

Remarks

Most sites have priorities 1-Low, 2-Medium, 3-High, 4-Very High, and 5-Urgent.

To get the full list of priorities on your site look at the Priority list. See 'Customizing Project Lists' in the Mercury Quality Center Administrator's Guide.

See Also

IBug Interface


%%PageItemTitle%%

IBug Interface

Project Property

Description

The testing project to which the defect belongs.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Project() As String

Remarks

This is generally the name of the item you are testing: a software component, hardware item, network configuration, web site, and so on.

For a list of projects defined in your Quality Center project database, use TDConnection.ProjectsList or TDConnection.ProjectsListEx.

See Also

IBug Interface


%%PageItemTitle%%

IBug Interface

Status Property

Description

The defect status.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Status() As String

Remarks

Most sites have statuses New, Open, Rejected, Fixed, Reopen, and Closed.

To get the full list of statuses on your site look at the Bug Status list. See 'Customizing Project Lists' in the Mercury Quality Center Administrator's Guide.

Example

mybug.Status = "Fixed"
mybug.Post

See Also

IBug Interface


%%PageItemTitle%%

IBug Interface

Summary Property

Description

A short description of the defect.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Summary() As String

Example

myBug.Summary = "This feature doesn't work"
myBug.Post

See Also

IBug Interface


%%PageItemTitle%%

IBug Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

IBug Interface


%%PageItemTitle%%

IBugFactory Members

IBugFactory Interface

Description

Services for managing defect records.

Remarks

Get a BugFactory object from TDConnection.BugFactory.

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Public Methods

Public Method AddItem | Creates a new item object.
Public Method BuildAgeGraph | Creates a graph that shows the lifetime of defects.
Public Method BuildProgressGraph | Creates a graph showing status at specific points: either defect accumulation or time to fix (estimated or actual).
Public Method BuildSummaryGraph | Creates a summary graph either of the number of defects or the time to fix (estimated or actual).
Public Method BuildTrendGraph | Creates a graph that shows the history of changes to specific Defect fields for each time interval displayed.
Public Method FindSimilarBugs | Searches defect summaries and descriptions for matches to Pattern.
Public Method Mail | Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

IBugFactory Interface

ItemData

When creating defects, always pass Null as the ItemData argument.

See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData

When creating defects, always pass Null as the ItemData argument.

Return Type

A Bug Object.

See Also

IBugFactory Interface


%%PageItemTitle%%

IBugFactory Interface

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

The field whose values are summed for all entities in a group:
One of Run 'Duration', Defect 'Actual Fix Time', or Defect 'Estimated Fix Time'.
If the argument is not used, the resulting value is the count of the entities in the group.

MaxAge

The maximum age (in days) of defects included in the graph. A value of 0 signifies no age limit.

MaxCols

The maximum number of groups represented in the graph. Zero indicates no limit.

Filter

The TDFilter Object that sets the criteria for the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildAgeGraph Method

Description

Creates a graph that shows the lifetime of defects.

Syntax

Public Function BuildAgeGraph( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxAge As Long = 0, _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

The field whose values are summed for all entities in a group:
One of Run 'Duration', Defect 'Actual Fix Time', or Defect 'Estimated Fix Time'.
If the argument is not used, the resulting value is the count of the entities in the group.

MaxAge

The maximum age (in days) of defects included in the graph. A value of 0 signifies no age limit.

MaxCols

The maximum number of groups represented in the graph. Zero indicates no limit.

Filter

The TDFilter Object that sets the criteria for the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

IBugFactory Interface


%%PageItemTitle%%

IBugFactory Interface

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

The field whose values are summed for all entities in a group:
One of Run 'Duration', Defect 'Actual Fix Time', or Defect 'Estimated Fix Time'.
If the argument is not used, the resulting value is the count of the entities in the group.

ByHistory

Determines whether to use history information to create the graph. Possible values are:

TRUE - Use history information.

FALSE - Do not use history information.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. Zero indicates no limit.

Filter

The TDFilter Object that sets the criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildProgressGraph Method

Description

Creates a graph showing status at specific points: either defect accumulation or time to fix (estimated or actual).

Syntax

Public Function BuildProgressGraph( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal ByHistory As Boolean = True, _
   Optional ByVal MajorSkip As Long = 0, _
   Optional ByVal MinorSkip As Long = 1, _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

The field whose values are summed for all entities in a group:
One of Run 'Duration', Defect 'Actual Fix Time', or Defect 'Estimated Fix Time'.
If the argument is not used, the resulting value is the count of the entities in the group.

ByHistory

Determines whether to use history information to create the graph. Possible values are:

TRUE - Use history information.

FALSE - Do not use history information.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. Zero indicates no limit.

Filter

The TDFilter Object that sets the criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

IBugFactory Interface


%%PageItemTitle%%

IBugFactory Interface

XAxisField

A database field representing the name of the graph x-axis.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

The field whose values are summed for all entities in a group:
One of Run 'Duration', Defect 'Actual Fix Time', or Defect 'Estimated Fix Time'.
If the argument is not used, the resulting value is the count of the entities in the group.

MaxCols

The maximum number of groups represented in the graph. Zero indicates no limit.

Filter

The TDFilter Object that sets the criteria for the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildSummaryGraph Method

Description

Creates a summary graph either of the number of defects or the time to fix (estimated or actual).

Syntax

Public Function BuildSummaryGraph( _
   Optional ByVal XAxisField As String = "", _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

XAxisField

A database field representing the name of the graph x-axis.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

The field whose values are summed for all entities in a group:
One of Run 'Duration', Defect 'Actual Fix Time', or Defect 'Estimated Fix Time'.
If the argument is not used, the resulting value is the count of the entities in the group.

MaxCols

The maximum number of groups represented in the graph. Zero indicates no limit.

Filter

The TDFilter Object that sets the criteria for the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

IBugFactory Interface


%%PageItemTitle%%

IBugFactory Interface

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

Not in use in BugFactory BuildTrendGraph.

MaxCols

The maximum number of groups represented in the graph. Zero indicates no limit.

Filter

The TDFilter Object that sets the criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildTrendGraph Method

Description

Creates a graph that shows the history of changes to specific Defect fields for each time interval displayed.

Syntax

Public Function BuildTrendGraph( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

Not in use in BugFactory BuildTrendGraph.

MaxCols

The maximum number of groups represented in the graph. Zero indicates no limit.

Filter

The TDFilter Object that sets the criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

IBugFactory Interface


%%PageItemTitle%%

IBugFactory Interface

Pattern

The search text.

SimilarityRatio

Specifies the percentage of similarity (0-100).

See Also OTA COM Type Library

FindSimilarBugs Method

Description

Searches defect summaries and descriptions for matches to Pattern.

Syntax

Public Function FindSimilarBugs( _
   ByVal Pattern As String, _
   Optional ByVal SimilarityRatio As Long = 10 _
) As List

Parameters

Pattern

The search text.

SimilarityRatio

Specifies the percentage of similarity (0-100).

Return Type

A FactoryList of Bug objects.

Remarks

For more information on the similarity ratio, see 'Matching Defects' under 'Adding New Defects' in the Quality Center User's Guide.

See Also

IBugFactory Interface


%%PageItemTitle%%

IBugFactory Interface

Items

A list of IDs.

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also OTA COM Type Library

Mail Method

Description

Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.

Syntax

Public Sub Mail( _
   ByVal Items As Variant, _
   ByVal SendTo As String, _
   Optional ByVal SendCc As String = "", _
   Optional ByVal Option As Long = 0, _
   Optional ByVal Subject As String = "", _
   Optional ByVal Comment As String = "" _
)

Parameters

Items

A list of IDs.

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also

IBugFactory Interface


%%PageItemTitle%%

IBugFactory Interface

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

IBugFactory Interface


%%PageItemTitle%%

IBugFactory Interface

ItemKey

The defect ID (long), a reference to the Bug Object, or a variant array of defect IDs.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey

The defect ID (long), a reference to the Bug Object, or a variant array of defect IDs.

See Also

IBugFactory Interface


%%PageItemTitle%%

IBugFactory Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

IBugFactory Interface


%%PageItemTitle%%

IBugFactory Interface

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

IBugFactory Interface


%%PageItemTitle%%

IBugFactory Interface

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

IBugFactory Interface


%%PageItemTitle%%

IBugFactory Interface

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IBugFactory Interface


%%PageItemTitle%%

IBugFactory Interface

ItemKey

The defect ID (long).

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey

The defect ID (long).

See Also

IBugFactory Interface


%%PageItemTitle%%

IBusinessProcess Members

IBusinessProcess Interface

Description

Represents a single Business Process Test.

Remarks

Get a BusinessProcess reference from a Test Object of Type BUSINESS-PROCESS. In VisualBasic, cast the Test to BusinessProcess. In C++, use the QueryInterface to get the reference.

BusinessProcess.Save saves modifications to all BP_xxx objects that belong to the test.

Example

Casting an object reference to get a reference to an inner interface

Public Methods

Public Method AddBPComponent | Adds the specified Component to the test.
Public Method AddGroup | Adds an empty group of components to the test.
Public Method AddRTParam | Adds a runtime parameter to the test.
Public Method CancelDownloadPictures | Cancels the download of the test component's pictures.
Public Method CoverRequirement | Adds the specified requirement to the list of requirements covered by this test.
Public Method DeleteBPComponent | Delete the specified BPComponent from the test.
Public Method DeleteGroup | Delete the specified BPGroup from the test.
Public Method DeleteRTParam | Delete the given RTParam from the test.
Public Method DownloadPictures | Download the snapshots attached to the components of the test to the clients cache.
Public Method DownloadPicturesProgress | Reports the status of DownloadPictures.
Public Method GetCoverList | Gets the list of all requirements covered by this test.
Public Method Load | Loads the BusinessProcess object and all of its dependencies into memory.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Mail | Mails the IBaseFieldExMail field item.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method RemoveCoverage | Removes a requirement from the list of requirements this test covers.
Public Method Save | Saves the BusinessProcess object and all of its dependencies.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property BPComponentByID | Gets a BPComponent from the test by its ID.
Public Property BPComponents | The list of BPComponents that belong to the test.
Public Property BPTHistory | The test's history object.
Public Property CheckoutPathIfExist | The checkout path for the test.
Public Property DesignStepFactory | The design steps factory for the current test.
Public Property DesStepsNum | The number of design steps in the test.
Public Property ExecDate | The test execution date and time.
Public Property ExecStatus | The test execution status.
Public Property ExtendedStorage | The Extended Storage object for the current test.
Public Property Field | The value of the specified field.
Public Property FullPath | The full file system path for the test.
Public Property GroupByID | Gets a BPGroup from the test by its ID.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property HasCoverage | Checks if the test covers at least one requirement.
Public Property HasParam | Checks if the test has at least one parameter.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property LastRun | The last Run object for this test.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The test name.
Public Property Params | The current test parameters.
Public Property RTParameters | The list of run time parameters for the test.
Public Property TemplateTest | Indicates if this test is a template test.
Public Property Type | The test type.
Public Property VCS | The VCS version control object for this test.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

IBusinessProcess Interface

pComponent

A Component Object.

See Also OTA COM Type Library

AddBPComponent Method

Description

Adds the specified Component to the test.

Syntax

Public Function AddBPComponent( _
   ByVal pComponent As Object _
) As Object

Parameters

pComponent

A Component Object.

Return Type

A reference to the new BPComponent Object.

Remarks

A BPComponent is an instance of a Component in a BusinessProcess. Adding a Component to a BusinessProcess twice creates two BPComponent objects. Adding the same Component to two different BusinessProcesss also creates two BPComponent objects.

AddBPComponent also creates one BPIteration and one BPIterationParam for each component parameter in that iteration.

Save any modifications to the returned BPComponent by calling BusinessProcess.Save.

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

AddGroup Method

Description

Adds an empty group of components to the test.

Syntax

Public Function AddGroup() As Object

Return Type

The new, empty BPGroup Object.

Remarks

Save any modifications to the returned group by calling BusinessProcess.Save.

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

AddRTParam Method

Description

Adds a runtime parameter to the test.

Syntax

Public Function AddRTParam() As Object

Return Type

A reference to the new RTParam Object.

Remarks

Save any modifications to the returned runtime parameter by calling BusinessProcess.Save.

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

CancelDownloadPictures Method

Description

Cancels the download of the test component's pictures.

Syntax

Public Sub CancelDownloadPictures()

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

Req

A Req.ID or Req object.

Order

For backward compatibity. Value is ignored.

Recursive

If True, the test is associated with the specified requirement and all of its descendent requirements. If False, the test is associated only with the specified requirement .

See Also OTA COM Type Library

CoverRequirement Method

Description

Adds the specified requirement to the list of requirements covered by this test.

Syntax

Public Function CoverRequirement( _
   ByVal Req As Variant, _
   ByVal Order As Long, _
   ByVal Recursive As Boolean _
) As Long

Parameters

Req

A Req.ID or Req object.

Order

For backward compatibity. Value is ignored.

Recursive

If True, the test is associated with the specified requirement and all of its descendent requirements. If False, the test is associated only with the specified requirement .

Return Type

Not in use. Ignore return value.

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

pBPComponent

A BPComponent Object.

See Also OTA COM Type Library

DeleteBPComponent Method

Description

Delete the specified BPComponent from the test.

Syntax

Public Sub DeleteBPComponent( _
   ByVal pBPComponent As Object _
)

Parameters

pBPComponent

A BPComponent Object.

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

pBPGroup

A BPGroup Object,

See Also OTA COM Type Library

DeleteGroup Method

Description

Delete the specified BPGroup from the test.

Syntax

Public Sub DeleteGroup( _
   ByVal pBPGroup As Object _
)

Parameters

pBPGroup

A BPGroup Object,

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

pRTParam

An RTParam Object.

See Also OTA COM Type Library

DeleteRTParam Method

Description

Delete the given RTParam from the test.

Syntax

Public Sub DeleteRTParam( _
   ByVal pRTParam As Object _
)

Parameters

pRTParam

An RTParam Object.

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

DownloadPictures Method

Description

Download the snapshots attached to the components of the test to the clients cache.

Syntax

Public Sub DownloadPictures()

Remarks

This method operates asynchronously.

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

Total

The total number of bytes to be downloaded.

Current

The number of bytes downloaded thus far.

See Also OTA COM Type Library

DownloadPicturesProgress Method

Description

Reports the status of DownloadPictures.

Syntax

Public Sub DownloadPicturesProgress( _
   ByRef Total As Long, _
   ByRef Current As Long _
)

Parameters

Total

The total number of bytes to be downloaded.

Current

The number of bytes downloaded thus far.

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

GetCoverList Method

Description

Gets the list of all requirements covered by this test.

Syntax

Public Function GetCoverList() As List

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

Load Method

Description

Loads the BusinessProcess object and all of its dependencies into memory.

Syntax

Public Sub Load()

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface | tagTDMAIL_FLAGS Enumeration

SendTo

The recipient address or addresses. Addresses can be separated by a comma or a semicolon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also OTA COM Type Library

Mail Method

Description

Mails the IBaseFieldExMail field item.

Syntax

Public Sub Mail( _
   ByVal SendTo As String, _
   Optional ByVal SendCc As String = "", _
   Optional ByVal Option As Long = 0, _
   Optional ByVal Subject As String = "", _
   Optional ByVal Comment As String = "" _
)

Parameters

SendTo

The recipient address or addresses. Addresses can be separated by a comma or a semicolon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also

IBusinessProcess Interface | tagTDMAIL_FLAGS Enumeration


%%PageItemTitle%%

IBusinessProcess Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

Req

A Req.ID or Req object.

See Also OTA COM Type Library

RemoveCoverage Method

Description

Removes a requirement from the list of requirements this test covers.

Syntax

Public Sub RemoveCoverage( _
   ByVal Req As Variant _
)

Parameters

Req

A Req.ID or Req object.

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

Save Method

Description

Saves the BusinessProcess object and all of its dependencies.

Syntax

Public Sub Save()

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

nCompID

A BPComponent .ID.

See Also OTA COM Type Library

BPComponentByID Property

Description

Gets a BPComponent from the test by its ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BPComponentByID( _
   ByVal nCompID As Long _
) As Object

Parameters

nCompID

A BPComponent .ID.

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

BPComponents Property

Description

The list of BPComponents that belong to the test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BPComponents() As List

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

BPTHistory Property

Description

The test's history object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BPTHistory() As Object

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

CheckoutPathIfExist Property

Description

The checkout path for the test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property CheckoutPathIfExist() As String

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

DesignStepFactory Property

Description

The design steps factory for the current test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DesignStepFactory() As Object

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

DesStepsNum Property

Description

The number of design steps in the test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DesStepsNum() As Long

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

ExecDate Property

Description

The test execution date and time.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExecDate() As Date

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

ExecStatus Property

Description

The test execution status.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExecStatus() As String

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

ExtendedStorage Property

Description

The Extended Storage object for the current test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExtendedStorage() As Object

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

FullPath Property

Description

The full file system path for the test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FullPath() As String

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

nGroupID

A BPGroup Object.

See Also OTA COM Type Library

GroupByID Property

Description

Gets a BPGroup from the test by its ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property GroupByID( _
   ByVal nGroupID As Long _
) As Object

Parameters

nGroupID

A BPGroup Object.

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

HasCoverage Property

Description

Checks if the test covers at least one requirement.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasCoverage() As Boolean

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

HasParam Property

Description

Checks if the test has at least one parameter.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasParam() As Boolean

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

LastRun Property

Description

The last Run object for this test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property LastRun() As Object

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

Name Property

Description

The test name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

Params Property

Description

The current test parameters.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Params() As Object

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

RTParameters Property

Description

The list of run time parameters for the test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RTParameters() As List

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

TemplateTest Property

Description

Indicates if this test is a template test.

Property type

Read-write property

Syntax (Visual Basic)

Public Property TemplateTest() As Boolean

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

Type Property

Description

The test type.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Type() As String

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

VCS Property

Description

The VCS version control object for this test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property VCS() As Object

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IBusinessProcess Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

IBusinessProcess Interface


%%PageItemTitle%%

IColumnInfo Members

IColumnInfo Interface

Description

Represents column information for a Recordset.

Public Properties

Public Property ColCount | Gets the number of columns in the current Recordset object.
Public Property ColIndex | Gets the index (zero-based) of a Recordset column specified by column name.
Public Property ColName | The name of the Recordset column specified by Index (zero-based).
Public Property ColSize | The physical size as defined in the database of the fields in the column specified by Index (zero-based).
Public Property ColType | The data type of column.


%%PageItemTitle%%

IColumnInfo Interface

ColCount Property

Description

Gets the number of columns in the current Recordset object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ColCount() As Long

See Also

IColumnInfo Interface


%%PageItemTitle%%

IColumnInfo Interface

Name
The name of the recordset column.
See Also OTA COM Type Library

ColIndex Property

Description

Gets the index (zero-based) of a Recordset column specified by column name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ColIndex( _
   ByVal Name As String _
) As Long

Parameters

Name
The name of the recordset column.

See Also

IColumnInfo Interface


%%PageItemTitle%%

IColumnInfo Interface

Index
The column number (zero-based).
See Also OTA COM Type Library

ColName Property

Description

The name of the Recordset column specified by Index (zero-based).

Property type

Read-only property

Syntax (Visual Basic)

Public Property ColName( _
   ByVal Index As Long _
) As String

Parameters

Index
The column number (zero-based).

See Also

IColumnInfo Interface


%%PageItemTitle%%

IColumnInfo Interface

Index
The column number (zero-based).
See Also OTA COM Type Library

ColSize Property

Description

The physical size as defined in the database of the fields in the column specified by Index (zero-based).

Property type

Read-only property

Syntax (Visual Basic)

Public Property ColSize( _
   ByVal Index As Long _
) As Long

Parameters

Index
The column number (zero-based).

See Also

IColumnInfo Interface


%%PageItemTitle%%

IColumnInfo Interface

Index
The column number (zero-based).
See Also OTA COM Type Library

ColType Property

Description

The data type of column.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ColType( _
   ByVal Index As Long _
) As Long

Parameters

Index
The column number (zero-based).

See Also

IColumnInfo Interface


%%PageItemTitle%%

ICommand Members

ICommand Interface

Description

Represents a database command.

Remarks

The Command object represents a database command. You can use a Command object to query the database and return records in a Recordset Object, to execute a bulk operation, and to manipulate the structure of the database.

The Command object is intrinsically unsafe because it bypasses all the business logic of Quality Center and acts directly on the database. It is included in the API to enable the user to solve unforeseen problems. Before determining that there is no other solution to your application problem, consult your Mercury service representative to investigate other options.

The use of the Command object for a simple Select statement that does not change the database is safe.

Because of the risk, use of the Command object is restricted. For information about security and rights to use the Command object, refer to the Mercury Quality Center Administrator's Guide.

Get a Command object from TDConnection.Command.

Example

Dim com As TDAPIOLELib.Command
Dim RecSet As TDAPIOLELib.Recordset

' Setting and executing the SQL
Set com = tdc.Command
com.CommandText = "select * from bug"
Set RecSet = com.Execute

' Displaying the 2nd column data
For i = 1 To RecSet.RecordCount
List1.AddItem (RecSet.FieldValue(2))
RecSet.Next
Next

Public Methods

Public Method AddParam | Adds new parameter to Command object.
Public Method DeleteParam | Deletes the specified parameter from Command object.
Public Method DeleteParams | Deletes all parameters from Command object.
Public Method Execute | Executes the command in the CommandText property.

Public Properties

Public Property AffectedRows | The number of table rows that were affected by the command.
Public Property CommandText | The text of the command.
Public Property Count | Number of parameters in current command.
Public Property IndexFields | A comma-separated list of index fields for a SELECT command.
Public Property ParamIndex | The parameter index by parameter name.
Public Property ParamName | The parameter name by parameter index. The index is 0-based.
Public Property ParamType | The data type of the specified parameter. The index is 0-based.
Public Property ParamValue | The parameter value.


%%PageItemTitle%%

ICommand Interface

Name

The name of the new parameter.

InitialValue

The initial value.

See Also OTA COM Type Library

AddParam Method

Description

Adds new parameter to Command object.

Syntax

Public Sub AddParam( _
   ByVal Name As String, _
   ByVal InitialValue As Variant _
)

Parameters

Name

The name of the new parameter.

InitialValue

The initial value.

See Also

ICommand Interface


%%PageItemTitle%%

ICommand Interface

Key

The parameter index or name. The index is 0-based.

See Also OTA COM Type Library

DeleteParam Method

Description

Deletes the specified parameter from Command object.

Syntax

Public Sub DeleteParam( _
   ByVal Key As Variant _
)

Parameters

Key

The parameter index or name. The index is 0-based.

See Also

ICommand Interface


%%PageItemTitle%%

ICommand Interface

DeleteParams Method

Description

Deletes all parameters from Command object.

Syntax

Public Sub DeleteParams()

See Also

ICommand Interface


%%PageItemTitle%%

ICommand Interface

Execute Method

Description

Executes the command in the CommandText property.

Syntax

Public Function Execute() As Object

Return Type

For a SELECT statement, returns a Recordset Object. Otherwise, returns nothing.

Remarks

After calling Execute with a select statement, the cursor is on the first record in the recordset.

See Also

ICommand Interface


%%PageItemTitle%%

ICommand Interface

AffectedRows Property

Description

The number of table rows that were affected by the command.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AffectedRows() As Long

Remarks

Consult your Mercury service representative for guidance on use of the Command object to change data.

See Also

ICommand Interface


%%PageItemTitle%%

ICommand Interface

CommandText Property

Description

The text of the command.

Property type

Read-write property

Syntax (Visual Basic)

Public Property CommandText() As String

See Also

ICommand Interface


%%PageItemTitle%%

ICommand Interface

Count Property

Description

Number of parameters in current command.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

ICommand Interface


%%PageItemTitle%%

ICommand Interface

IndexFields Property

Description

A comma-separated list of index fields for a SELECT command.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IndexFields() As String

See Also

ICommand Interface


%%PageItemTitle%%

ICommand Interface

Name

The parameter name.

See Also OTA COM Type Library

ParamIndex Property

Description

The parameter index by parameter name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ParamIndex( _
   ByVal Name As String _
) As Long

Parameters

Name

The parameter name.

See Also

ICommand Interface


%%PageItemTitle%%

ICommand Interface

Index

The parameter index.

See Also OTA COM Type Library

ParamName Property

Description

The parameter name by parameter index. The index is 0-based.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ParamName( _
   ByVal Index As Long _
) As String

Parameters

Index

The parameter index.

See Also

ICommand Interface


%%PageItemTitle%%

ICommand Interface

Index

The parameter index. The index is 0-based.

See Also OTA COM Type Library

ParamType Property

Description

The data type of the specified parameter. The index is 0-based.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ParamType( _
   ByVal Index As Long _
) As Long

Parameters

Index

The parameter index. The index is 0-based.

See Also

ICommand Interface


%%PageItemTitle%%

ICommand Interface

Key

The parameter index or name. The index is 0-based.

See Also OTA COM Type Library

ParamValue Property

Description

The parameter value.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ParamValue( _
   ByVal Key As Variant _
) As Variant

Parameters

Key

The parameter index or name. The index is 0-based.

See Also

ICommand Interface


%%PageItemTitle%%

IComponent Members

IComponent Interface

Description

Represents a business component.

Remarks

Get a Component with ComponentFactory.AddItem or ComponentFactory.NewList.

Public Methods

Public Method BusinessProcesses | The list of associated BusinessProcess objects.
Public Method DeletePicture | Deletes the snapshot.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property ApplicationAreaID | The Component's linked application area ID.
Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property ComponentParamFactory | The component parameter factory.
Public Property ComponentStepFactory | The ComponentStepFactory for this component
Public Property ExtendedStorage | The ExtendedStorage object for this component.
Public Property Field | The value of the specified field.
Public Property Folder | The component's folder.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property HasPicture | Indicates if the component has a snapshot.
Public Property HasScript | Checks if the component is associated with a test script.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property IsObsolete | Checks if the component has been marked deleted by a user but is still in use in a test.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The Component's name.
Public Property ScriptType | The test script type.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

IComponent Interface

BusinessProcesses Method

Description

The list of associated BusinessProcess objects.

Syntax

Public Function BusinessProcesses() As List

Return Type

A list of references to BusinessProcess objects.

See Also

IComponent Interface


%%PageItemTitle%%

IComponent Interface

bsData

For future use. Pass an empty string.

See Also OTA COM Type Library

DeletePicture Method

Description

Deletes the snapshot.

Syntax

Public Sub DeletePicture( _
   ByVal bsData As String _
)

Parameters

bsData

For future use. Pass an empty string.

See Also

IComponent Interface


%%PageItemTitle%%

IComponent Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IComponent Interface


%%PageItemTitle%%

IComponent Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IComponent Interface


%%PageItemTitle%%

IComponent Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IComponent Interface


%%PageItemTitle%%

IComponent Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

IComponent Interface


%%PageItemTitle%%

IComponent Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

IComponent Interface


%%PageItemTitle%%

IComponent Interface

ApplicationAreaID Property

Description

The Component's linked application area ID.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ApplicationAreaID() As Long

See Also

IComponent Interface


%%PageItemTitle%%

IComponent Interface

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

IComponent Interface


%%PageItemTitle%%

IComponent Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

IComponent Interface


%%PageItemTitle%%

IComponent Interface

ComponentParamFactory Property

Description

The component parameter factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ComponentParamFactory() As Object

See Also

IComponent Interface


%%PageItemTitle%%

IComponent Interface

ComponentStepFactory Property

Description

The ComponentStepFactory for this component

Property type

Read-only property

Syntax (Visual Basic)

Public Property ComponentStepFactory() As Object

See Also

IComponent Interface


%%PageItemTitle%%

IComponent Interface

nEntityType

A graphic or a script, indicated with a value of the tagEXTENDEDSTORAGE_ENTITY Enumeration

See Also OTA COM Type Library

ExtendedStorage Property

Description

The ExtendedStorage object for this component.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExtendedStorage( _
   ByVal nEntityType As Long _
) As Object

Parameters

nEntityType

A graphic or a script, indicated with a value of the tagEXTENDEDSTORAGE_ENTITY Enumeration

See Also

IComponent Interface


%%PageItemTitle%%

IComponent Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

IComponent Interface


%%PageItemTitle%%

IComponent Interface

Folder Property

Description

The component's folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Folder() As Object

See Also

IComponent Interface


%%PageItemTitle%%

IComponent Interface

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

IComponent Interface


%%PageItemTitle%%

IComponent Interface

HasPicture Property

Description

Indicates if the component has a snapshot.

Property type

Read-write property

Syntax (Visual Basic)

Public Property HasPicture() As Boolean

See Also

IComponent Interface


%%PageItemTitle%%

IComponent Interface

HasScript Property

Description

Checks if the component is associated with a test script.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasScript() As Boolean

See Also

IComponent Interface


%%PageItemTitle%%

IComponent Interface

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IComponent Interface


%%PageItemTitle%%

IComponent Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

IComponent Interface


%%PageItemTitle%%

IComponent Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

IComponent Interface


%%PageItemTitle%%

IComponent Interface

IsObsolete Property

Description

Checks if the component has been marked deleted by a user but is still in use in a test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsObsolete() As Boolean

See Also

IComponent Interface


%%PageItemTitle%%

IComponent Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

IComponent Interface


%%PageItemTitle%%

IComponent Interface

Name Property

Description

The Component's name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

Remarks

The name may not contain the characters \/, :, ", ?, ', <, >, |, *, %, !, {, or }.

See Also

IComponent Interface


%%PageItemTitle%%

IComponent Interface

ScriptType Property

Description

The test script type.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ScriptType() As String

Remarks

Examples of script types are MANUAL, QT-KW, QT-SCRIPTED, and WR-AUTOMATED. For the full list in your project, look at the CompType custom list in the Project Customization tool.

See Also

IComponent Interface


%%PageItemTitle%%

IComponent Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

IComponent Interface


%%PageItemTitle%%

IComponentFactory Members

IComponentFactory Interface

Description

Services for managing business components.

Remarks

Get a ComponentFactory from TDConnection.ComponentFactory or ComponentFolder.ComponentFactory.

Public Methods

Public Method AddItem | Creates a new item object.
Public Method IsComponentNameValid | Checks if the specified name is a valid name for a business component.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

IComponentFactory Interface

ItemData

There are three options for ItemData:

  • Null.
  • The ComponentFolder.ID for the parent object.
  • An array consisting of the following elements:

    (0) Parent ID - A ComponentFolder.ID (long. required).

    (1) Name - The Component name (string. optional).

See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData

There are three options for ItemData:

  • Null.
  • The ComponentFolder.ID for the parent object.
  • An array consisting of the following elements:

    (0) Parent ID - A ComponentFolder.ID (long. required).

    (1) Name - The Component name (string. optional).

See Also

IComponentFactory Interface


%%PageItemTitle%%

IComponentFactory Interface

bsName

The string to check if it is a valid name.

pbsErrorString

An error message listing the invalid characters.

See Also OTA COM Type Library

IsComponentNameValid Method

Description

Checks if the specified name is a valid name for a business component.

Syntax

Public Function IsComponentNameValid( _
   ByVal bsName As String, _
   ByRef pbsErrorString As String _
) As Boolean

Parameters

bsName

The string to check if it is a valid name.

pbsErrorString

An error message listing the invalid characters.

Return Type

True if the string is a valid name.

Remarks

The invalid characters are % * {} \\ | ' : "" / < and >.

See Also

IComponentFactory Interface


%%PageItemTitle%%

IComponentFactory Interface

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

IComponentFactory Interface


%%PageItemTitle%%

IComponentFactory Interface

ItemKey

A Component.ID.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey

A Component.ID.

See Also

IComponentFactory Interface


%%PageItemTitle%%

IComponentFactory Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

IComponentFactory Interface


%%PageItemTitle%%

IComponentFactory Interface

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

IComponentFactory Interface


%%PageItemTitle%%

IComponentFactory Interface

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

IComponentFactory Interface


%%PageItemTitle%%

IComponentFactory Interface

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IComponentFactory Interface


%%PageItemTitle%%

IComponentFactory Interface

ItemKey

A Component.ID.

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey

A Component.ID.

See Also

IComponentFactory Interface


%%PageItemTitle%%

IComponentFolder Members

IComponentFolder Interface

Description

Represents a business component folder.

Remarks

Get a ComponentFolder reference from Component.Folder.

If you obtain a ComponentFactory from a ComponentFolder using the ComponentFactory Property and create a new component using the factory, attach the new component to the parent folder by setting the new component's CO_FOLDER_ID field. See the example, Creating a new component.

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property ComponentFactory | The ComponentFactory object.
Public Property ComponentFolderFactory | The component's ComponentFolderFactory.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The component's folder name
Public Property Path | The component folder's path
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

IComponentFolder Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IComponentFolder Interface


%%PageItemTitle%%

IComponentFolder Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IComponentFolder Interface


%%PageItemTitle%%

IComponentFolder Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IComponentFolder Interface


%%PageItemTitle%%

IComponentFolder Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

IComponentFolder Interface


%%PageItemTitle%%

IComponentFolder Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

IComponentFolder Interface


%%PageItemTitle%%

IComponentFolder Interface

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

IComponentFolder Interface


%%PageItemTitle%%

IComponentFolder Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

IComponentFolder Interface


%%PageItemTitle%%

IComponentFolder Interface

ComponentFactory Property

Description

The ComponentFactory object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ComponentFactory() As Object

See Also

IComponentFolder Interface


%%PageItemTitle%%

IComponentFolder Interface

ComponentFolderFactory Property

Description

The component's ComponentFolderFactory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ComponentFolderFactory() As Object

See Also

IComponentFolder Interface


%%PageItemTitle%%

IComponentFolder Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

IComponentFolder Interface


%%PageItemTitle%%

IComponentFolder Interface

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

IComponentFolder Interface


%%PageItemTitle%%

IComponentFolder Interface

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IComponentFolder Interface


%%PageItemTitle%%

IComponentFolder Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

IComponentFolder Interface


%%PageItemTitle%%

IComponentFolder Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

IComponentFolder Interface


%%PageItemTitle%%

IComponentFolder Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

IComponentFolder Interface


%%PageItemTitle%%

IComponentFolder Interface

Name Property

Description

The component's folder name

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

IComponentFolder Interface


%%PageItemTitle%%

IComponentFolder Interface

Path Property

Description

The component folder's path

Property type

Read-only property

Syntax (Visual Basic)

Public Property Path() As String

See Also

IComponentFolder Interface


%%PageItemTitle%%

IComponentFolder Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

IComponentFolder Interface


%%PageItemTitle%%

IComponentFolderFactory Members

IComponentFolderFactory Interface

Description

Services for managing the organization of business components.

Remarks

Get a reference to a ComponentFolderFactory from TDConnection.ComponentFolderFactory or ComponentFolder.ComponentFolderFactory.

Public Methods

Public Method AddItem | Creates a new item object.
Public Method FolderByPath | Gets a ComponentFolder by its path
Public Method FolderPath | Gets the path of the specified folder.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method Obsolete | Gets the Obsolete Components folder.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.
Public Method Root | Gets the business components root folder.
Public Method Templates | Gets the Templates folder (Quick Test only).

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

IComponentFolderFactory Interface

ItemData

There are two options for ItemData:

  • Null.
  • ComponentFolder.ID for the parent folder.
See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData

There are two options for ItemData:

  • Null.
  • ComponentFolder.ID for the parent folder.

See Also

IComponentFolderFactory Interface


%%PageItemTitle%%

IComponentFolderFactory Interface

Path

The path of the requested folder.

See Also OTA COM Type Library

FolderByPath Method

Description

Gets a ComponentFolder by its path

Syntax

Public Function FolderByPath( _
   ByVal Path As String _
) As Object

Parameters

Path

The path of the requested folder.

Return Type

A ComponentFolder.

See Also

IComponentFolderFactory Interface


%%PageItemTitle%%

IComponentFolderFactory Interface

folderId

A ComponentFolder.ID.

See Also OTA COM Type Library

FolderPath Method

Description

Gets the path of the specified folder.

Syntax

Public Function FolderPath( _
   ByVal folderId As Long _
) As String

Parameters

folderId

A ComponentFolder.ID.

Return Type

The path of the specified folder.

See Also

IComponentFolderFactory Interface


%%PageItemTitle%%

IComponentFolderFactory Interface

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

IComponentFolderFactory Interface


%%PageItemTitle%%

IComponentFolderFactory Interface

Obsolete Method

Description

Gets the Obsolete Components folder.

Syntax

Public Function Obsolete() As Object

Return Value Details

A ComponentFolder.

See Also

IComponentFolderFactory Interface


%%PageItemTitle%%

IComponentFolderFactory Interface

ItemKey

A ComponentFolder.ID.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey

A ComponentFolder.ID.

See Also

IComponentFolderFactory Interface


%%PageItemTitle%%

IComponentFolderFactory Interface

Root Method

Description

Gets the business components root folder.

Syntax

Public Function Root() As Object

Return Type

A ComponentFolder.

See Also

IComponentFolderFactory Interface


%%PageItemTitle%%

IComponentFolderFactory Interface

Templates Method

Description

Gets the Templates folder (Quick Test only).

Syntax

Public Function Templates() As Object

Return Type

A ComponentFolder Object.

Remarks

The Templates folder is visible only in a QuickTest Professional software context. Therefore, this method is for use only with QuickTest applications that access the Open Test Architecture API. If used from other software contexts, the results are indeterminent or result in an exception.

See Also

IComponentFolderFactory Interface


%%PageItemTitle%%

IComponentFolderFactory Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

IComponentFolderFactory Interface


%%PageItemTitle%%

IComponentFolderFactory Interface

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

IComponentFolderFactory Interface


%%PageItemTitle%%

IComponentFolderFactory Interface

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

IComponentFolderFactory Interface


%%PageItemTitle%%

IComponentFolderFactory Interface

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IComponentFolderFactory Interface


%%PageItemTitle%%

IComponentFolderFactory Interface

ItemKey

A ComponentFolder.ID.

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey

A ComponentFolder.ID.

See Also

IComponentFolderFactory Interface


%%PageItemTitle%%

IComponentParam Members

IComponentParam Interface

Description

Services for managing Business Process Test parameters.

Remarks

Get a ComponentParam from ComponentParamFactory.AddItem.

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Component | The Component containing the parameter.
Public Property Desc | The parameter description.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property IsOut | Indicates if this is an output parameter. If False, this is an input parameter.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The component parameter's name.
Public Property Order | The position of the parameter in the set of parameters of the same component.
Public Property Value | The parameter's default value.
Public Property ValueType | The parameter type. For example Date, String, number, etc.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

IComponentParam Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IComponentParam Interface


%%PageItemTitle%%

IComponentParam Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IComponentParam Interface


%%PageItemTitle%%

IComponentParam Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IComponentParam Interface


%%PageItemTitle%%

IComponentParam Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

IComponentParam Interface


%%PageItemTitle%%

IComponentParam Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

IComponentParam Interface


%%PageItemTitle%%

IComponentParam Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

IComponentParam Interface


%%PageItemTitle%%

IComponentParam Interface

Component Property

Description

The Component containing the parameter.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Component() As Object

See Also

IComponentParam Interface


%%PageItemTitle%%

IComponentParam Interface

Desc Property

Description

The parameter description.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Desc() As String

See Also

IComponentParam Interface


%%PageItemTitle%%

IComponentParam Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

IComponentParam Interface


%%PageItemTitle%%

IComponentParam Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

IComponentParam Interface


%%PageItemTitle%%

IComponentParam Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

IComponentParam Interface


%%PageItemTitle%%

IComponentParam Interface

IsOut Property

Description

Indicates if this is an output parameter. If False, this is an input parameter.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsOut() As Long

See Also

IComponentParam Interface


%%PageItemTitle%%

IComponentParam Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

IComponentParam Interface


%%PageItemTitle%%

IComponentParam Interface

Name Property

Description

The component parameter's name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

IComponentParam Interface


%%PageItemTitle%%

IComponentParam Interface

Order Property

Description

The position of the parameter in the set of parameters of the same component.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Order() As Long

See Also

IComponentParam Interface


%%PageItemTitle%%

IComponentParam Interface

Value Property

Description

The parameter's default value.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Value() As String

See Also

IComponentParam Interface


%%PageItemTitle%%

IComponentParam Interface

ValueType Property

Description

The parameter type. For example Date, String, number, etc.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ValueType() As String

See Also

IComponentParam Interface


%%PageItemTitle%%

IComponentParam Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

IComponentParam Interface


%%PageItemTitle%%

IComponentStep Members

IComponentStep Interface

Description

Represents a step in a business process test.

Remarks

Get a ComponentStep with ComponentStepFactory.AddItem.

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.
Public Method Validate | Validate the step.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Order | The 1-based position of the step in the order of execution of the steps of the component.
Public Property Parent | The parent Component
Public Property StepDescription | The description of the step.
Public Property StepExpectedResult | The expected result of the step.
Public Property StepName | The component step name.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

IComponentStep Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IComponentStep Interface


%%PageItemTitle%%

IComponentStep Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IComponentStep Interface


%%PageItemTitle%%

IComponentStep Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IComponentStep Interface


%%PageItemTitle%%

IComponentStep Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

IComponentStep Interface


%%PageItemTitle%%

IComponentStep Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

IComponentStep Interface


%%PageItemTitle%%

IComponentStep Interface

Validate Method

Description

Validate the step.

Syntax

Public Sub Validate()

Remarks

Validate throws an exception if the step is not valid. The exception message contains details of the error.

See Also

IComponentStep Interface


%%PageItemTitle%%

IComponentStep Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

IComponentStep Interface


%%PageItemTitle%%

IComponentStep Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

IComponentStep Interface


%%PageItemTitle%%

IComponentStep Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

IComponentStep Interface


%%PageItemTitle%%

IComponentStep Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

IComponentStep Interface


%%PageItemTitle%%

IComponentStep Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

IComponentStep Interface


%%PageItemTitle%%

IComponentStep Interface

Order Property

Description

The 1-based position of the step in the order of execution of the steps of the component.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Order() As Long

See Also

IComponentStep Interface


%%PageItemTitle%%

IComponentStep Interface

Parent Property

Description

The parent Component

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As Object

See Also

IComponentStep Interface


%%PageItemTitle%%

IComponentStep Interface

StepDescription Property

Description

The description of the step.

Property type

Read-write property

Syntax (Visual Basic)

Public Property StepDescription() As String

Remarks

This field may specify a parameter. Parameters are enclosed in triple angle brackets: <<<param name>>>. It the parameter name is invalid, <<<param name>>> is replaced with <param name> when written to the project database.

The field is stored in an HTML format. To specify a field value of "My_text <<<param name>>> more_text", enter <html><body>My_text &lt;&lt;&lt;param name&gt;&gt;&gt; more_text</body></html>. Alternately, set TDConnection.IgnoreHtmlFormat = True and then pass the desired field value as plain text.

See Also

IComponentStep Interface


%%PageItemTitle%%

IComponentStep Interface

StepExpectedResult Property

Description

The expected result of the step.

Property type

Read-write property

Syntax (Visual Basic)

Public Property StepExpectedResult() As String

See Also

IComponentStep Interface


%%PageItemTitle%%

IComponentStep Interface

StepName Property

Description

The component step name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property StepName() As String

See Also

IComponentStep Interface


%%PageItemTitle%%

IComponentStep Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

IComponentStep Interface


%%PageItemTitle%%

ICondition Members

ICondition Interface

Description

Represents a condition for a test to be executed.

Remarks

Conditions are used to define dependencies between TSTests in the test set execution flow. They define when a particular test instance can be executed. The Source is a condition that must be fulfilled. The Target is a TSTest object.
If the execution condition is not based on time, the source is a TSTest which must run before the Target. The Target test instance either runs or does not run based on the result of the test: passed or failed.

Changes for the condition are saved in the project after calling the Save method of the ConditionFactory Object.

Get a Condition object from the ConditionFactory using AddItem, NewList, or Item.

Public Properties

Public Property Description | The Condition description.
Public Property ID | The Condition ID.
Public Property Source | For a run condition, the source condition ID. For a time condition, a date-time string.
Public Property Target | The target test instance number of the condition.
Public Property Value | The Condition status value.


%%PageItemTitle%%

ICondition Interface

Description Property

Description

The Condition description.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Description() As String

Remarks

The user-entered comment.

See Also

ICondition Interface


%%PageItemTitle%%

ICondition Interface

ID Property

Description

The Condition ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

ICondition Interface


%%PageItemTitle%%

ICondition Interface

Source Property

Description

For a run condition, the source condition ID. For a time condition, a date-time string.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Source() As Variant

See Also

ICondition Interface


%%PageItemTitle%%

ICondition Interface

Target Property

Description

The target test instance number of the condition.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Target() As Variant

See Also

ICondition Interface


%%PageItemTitle%%

ICondition Interface

Value Property

Description

The Condition status value.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Value() As Variant

See Also

ICondition Interface


%%PageItemTitle%%

IConditionFactory Members

IConditionFactory Interface

Description

Services for managing conditions for executing test instances in an test set.

Remarks

You cannot save an individually selected condition. Use the Save method to save all changes to all conditions.

Get a ConditionFactory object from TestSet.ConditionFactory.

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.
Public Method Save | Saves all conditions.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

IConditionFactory Interface

ItemData

There are two options for ItemData:

  • Null. Initially creating a virtual object with Null ensures that you cannot then Post until all required fields are initialized.
  • An array consisting of the following elements:

(0) Type - The condition type (long, required). 1 for run or 2 for time.

(1) Source - For a run condition, the source condition ID (long). For a time condition, the date-time string. (required)

(2) Target - The target condition ID (long, required).

(3) Value - The condition value. (required). For a time condition, the date-time string. For a run condition, either TDCOND_PASSED or TDCOND_FAILED.

(4) Desc - A description of the condition (string, optional).

See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData

There are two options for ItemData:

  • Null. Initially creating a virtual object with Null ensures that you cannot then Post until all required fields are initialized.
  • An array consisting of the following elements:

(0) Type - The condition type (long, required). 1 for run or 2 for time.

(1) Source - For a run condition, the source condition ID (long). For a time condition, the date-time string. (required)

(2) Target - The target condition ID (long, required).

(3) Value - The condition value. (required). For a time condition, the date-time string. For a run condition, either TDCOND_PASSED or TDCOND_FAILED.

(4) Desc - A description of the condition (string, optional).

Return Type

A Condition Object.

Remarks

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

[Visual Basic]

Dim bgf As BugFactory
Dim bg As Bug
Dim attf As AttachmentFactory
Dim att As Attachment
Dim attList As List

' Get the factory object
 Set bgf = tdc.BugFactory
' Use defect #1
 Set bg = bgf.Item(1)
 Set attf = bg.Attachments

' Creating a new attachment
' Create virtual object, then populate the properties
 Set att = attf.AddItem(Null)
 att.FileName = Text1.Text
 att.Type = TDATT_INTERNET

' Saving the object with validity check
 att.Post

' Display the attachments
' Add the display-only items without a Post
 List1.Clear
 Set attList = attf.NewList("")
 For i = 1 To attList.Count

      Set att = attList.Item(i)
      List1.AddItem (att.Name)

 Next

See Also

IConditionFactory Interface


%%PageItemTitle%%

IConditionFactory Interface

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

IConditionFactory Interface


%%PageItemTitle%%

IConditionFactory Interface

ItemKey

A Condition.ID (long), a reference to a Condition Object, or a variant array of Condition IDs.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey

A Condition.ID (long), a reference to a Condition Object, or a variant array of Condition IDs.

See Also

IConditionFactory Interface


%%PageItemTitle%%

IConditionFactory Interface

Save Method

Description

Saves all conditions.

Syntax

Public Sub Save()

See Also

IConditionFactory Interface


%%PageItemTitle%%

IConditionFactory Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

IConditionFactory Interface


%%PageItemTitle%%

IConditionFactory Interface

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

IConditionFactory Interface


%%PageItemTitle%%

IConditionFactory Interface

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

IConditionFactory Interface


%%PageItemTitle%%

IConditionFactory Interface

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IConditionFactory Interface


%%PageItemTitle%%

IConditionFactory Interface

ItemKey

A long integer.

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey

A long integer.

See Also

IConditionFactory Interface


%%PageItemTitle%%

ICoverable Interface

Req
A requirement ID (long) Req.ID or a Req object.
RequirementFilter
A logical filter specifying which child requirements will be added to coverage if the Recursive parameter is True. The filter can be a TDFilter.Text.
Recursive
If True, child requirements will be covered by this entity. If the RequirementFilter argument is not empty, only child requirements matching the filter are covered.
See Also OTA COM Type Library

CoverRequirementEx Method

Description

Adds the specified requirement to the list of requirements covered by this entity. Optionally, also adds child requirements.

Syntax

Public Sub CoverRequirementEx( _
   ByVal Req As Variant, _
   ByVal RequirementFilter As String, _
   ByVal Recursive As Boolean _
)

Parameters

Req
A requirement ID (long) Req.ID or a Req object.
RequirementFilter
A logical filter specifying which child requirements will be added to coverage if the Recursive parameter is True. The filter can be a TDFilter.Text.
Recursive
If True, child requirements will be covered by this entity. If the RequirementFilter argument is not empty, only child requirements matching the filter are covered.

See Also

ICoverable Interface


%%PageItemTitle%%

ICoverable Interface

CoverageFactory Property

Description

The CoverageFactory for the entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property CoverageFactory() As Object

See Also

ICoverable Interface


%%PageItemTitle%%

ICoverableReq Interface

SubjectID
A SubjectNode.NodeID.
TestFilter

A logical filter specifying which tests will cover the current requirement.

The filter can be a TDFilter.Text.

See Also OTA COM Type Library

AddSubjectToCoverage Method

Description

Adds the tests from the specified subject that match the input filter to the list of tests that cover the current requirement.

Syntax

Public Sub AddSubjectToCoverage( _
   ByVal SubjectID As Long, _
   ByVal TestFilter As String _
)

Parameters

SubjectID
A SubjectNode.NodeID.
TestFilter

A logical filter specifying which tests will cover the current requirement.

The filter can be a TDFilter.Text.

See Also

ICoverableReq Interface


%%PageItemTitle%%

ICoverableReq Interface

TestInstanceID
A TSTest.ID.
See Also OTA COM Type Library

AddTestInstanceToCoverage Method

Description

Adds the test instance to the list of test instances that cover the current requirement.

Syntax

Public Sub AddTestInstanceToCoverage( _
   ByVal TestInstanceID As Long _
)

Parameters

TestInstanceID
A TSTest.ID.

See Also

ICoverableReq Interface


%%PageItemTitle%%

ICoverableReq Interface

TestSetID
A TestSet.ID.
TestInstanceFilter

The filter which defines which test instances will cover the current requirement.

The filter can be a TDFilter.Text.

See Also OTA COM Type Library

AddTestsFromTestSetToCoverage Method

Description

Adds the test instances from the specified test set that match the input filter to the list of test instances that cover the current requirement.

Syntax

Public Sub AddTestsFromTestSetToCoverage( _
   ByVal TestSetID As Long, _
   ByVal TestInstanceFilter As String _
)

Parameters

TestSetID
A TestSet.ID.
TestInstanceFilter

The filter which defines which test instances will cover the current requirement.

The filter can be a TDFilter.Text.

See Also

ICoverableReq Interface


%%PageItemTitle%%

ICoverableReq Interface

TestId

A Test.ID.

See Also OTA COM Type Library

AddTestToCoverage Method

Description

Adds the test to the list of tests that cover the current requirement.

Syntax

Public Sub AddTestToCoverage( _
   ByVal TestId As Long _
)

Parameters

TestId

A Test.ID.

See Also

ICoverableReq Interface


%%PageItemTitle%%

ICoverableReq Interface

RequirementCoverageFactory Property

Description

Get Requirement Coverage Factory

Property type

Read-only property

Syntax (Visual Basic)

Public Property RequirementCoverageFactory() As Object

See Also

ICoverableReq Interface


%%PageItemTitle%%

ICoverageEntity Members

ICoverageEntity Interface

Description

Represents the association between a requirement and another entity that covers it.

Remarks

Get CoverageEntity objects from the list returned by CoverageFactory.NewList Method.

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property CoverageType | The type of coverage. For example, Test or TSTest.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The name of the TargetEntity.
Public Property RequirementEntity | The Req object being covered.
Public Property Status | The execution result status of the TargetEntity.
Public Property TargetEntity | The entity object that covers the requirement.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

ICoverageEntity Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ICoverageEntity Interface


%%PageItemTitle%%

ICoverageEntity Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ICoverageEntity Interface


%%PageItemTitle%%

ICoverageEntity Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ICoverageEntity Interface


%%PageItemTitle%%

ICoverageEntity Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

ICoverageEntity Interface


%%PageItemTitle%%

ICoverageEntity Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

ICoverageEntity Interface


%%PageItemTitle%%

ICoverageEntity Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

ICoverageEntity Interface


%%PageItemTitle%%

ICoverageEntity Interface

CoverageType Property

Description

The type of coverage. For example, Test or TSTest.

Property type

Read-only property

Syntax (Visual Basic)

Public Property CoverageType() As String

See Also

ICoverageEntity Interface


%%PageItemTitle%%

ICoverageEntity Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

ICoverageEntity Interface


%%PageItemTitle%%

ICoverageEntity Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

ICoverageEntity Interface


%%PageItemTitle%%

ICoverageEntity Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

ICoverageEntity Interface


%%PageItemTitle%%

ICoverageEntity Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

ICoverageEntity Interface


%%PageItemTitle%%

ICoverageEntity Interface

Name Property

Description

The name of the TargetEntity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ICoverageEntity Interface


%%PageItemTitle%%

ICoverageEntity Interface

RequirementEntity Property

Description

The Req object being covered.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RequirementEntity() As Object

See Also

ICoverageEntity Interface


%%PageItemTitle%%

ICoverageEntity Interface

Status Property

Description

The execution result status of the TargetEntity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Status() As String

See Also

ICoverageEntity Interface


%%PageItemTitle%%

ICoverageEntity Interface

TargetEntity Property

Description

The entity object that covers the requirement.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TargetEntity() As Object

See Also

ICoverageEntity Interface


%%PageItemTitle%%

ICoverageEntity Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

ICoverageEntity Interface


%%PageItemTitle%%

ICoverageFactory Members

ICoverageFactory Interface

Description

Services for managing CoverageEntity objects.

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

ICoverageFactory Interface

ItemData
See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData

Remarks

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

[Visual Basic]

Dim bgf As BugFactory
Dim bg As Bug
Dim attf As AttachmentFactory
Dim att As Attachment
Dim attList As List

' Get the factory object
 Set bgf = tdc.BugFactory
' Use defect #1
 Set bg = bgf.Item(1)
 Set attf = bg.Attachments

' Creating a new attachment
' Create virtual object, then populate the properties
 Set att = attf.AddItem(Null)
 att.FileName = Text1.Text
 att.Type = TDATT_INTERNET

' Saving the object with validity check
 att.Post

' Display the attachments
' Add the display-only items without a Post
 List1.Clear
 Set attList = attf.NewList("")
 For i = 1 To attList.Count

      Set att = attList.Item(i)
      List1.AddItem (att.Name)

 Next

See Also

ICoverageFactory Interface


%%PageItemTitle%%

ICoverageFactory Interface

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

ICoverageFactory Interface


%%PageItemTitle%%

ICoverageFactory Interface

ItemKey
See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey

See Also

ICoverageFactory Interface


%%PageItemTitle%%

ICoverageFactory Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

ICoverageFactory Interface


%%PageItemTitle%%

ICoverageFactory Interface

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

ICoverageFactory Interface


%%PageItemTitle%%

ICoverageFactory Interface

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

ICoverageFactory Interface


%%PageItemTitle%%

ICoverageFactory Interface

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

ICoverageFactory Interface


%%PageItemTitle%%

ICoverageFactory Interface

ItemKey
See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey

See Also

ICoverageFactory Interface


%%PageItemTitle%%

ICustomization Members

ICustomization Interface

Description

Services to perform customization tasks, such as adding users to user groups, defining user-defined fields, and defining user access privileges.

Example

Get a Customization object from TDConnection.Customization.

Public Methods

Public Method Commit | Posts all customization data changes to the project database.
Public Method Load | Loads all customization data from the server into the client cache. This includes actions, fields, lists, modules, permissions, users, and user groups.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Actions | The CustomizationActions object.
Public Property ExtendedUDFSupport | Checks if the program can use the maximum allowable user-defined fields (99 user-defined fields and 3 memo fields).
Public Property Fields | The CustomizationFields object.
Public Property IsLocked | Checks if object is locked.
Public Property Lists | The CustomizationLists object.
Public Property MailConditions | The CustomizationMailConditions Object.
Public Property Modules | The CustomizationModules object.
Public Property Permissions | The CustomizationPermissions object.
Public Property Users | The CustomizationUsers object.
Public Property UsersGroups | The CustomizationUsersGroups object.


%%PageItemTitle%%

ICustomization Interface

Commit Method

Description

Posts all customization data changes to the project database.

Syntax

Public Sub Commit()

See Also

ICustomization Interface


%%PageItemTitle%%

ICustomization Interface

Load Method

Description

Loads all customization data from the server into the client cache. This includes actions, fields, lists, modules, permissions, users, and user groups.

Syntax

Public Sub Load()

See Also

ICustomization Interface


%%PageItemTitle%%

ICustomization Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ICustomization Interface


%%PageItemTitle%%

ICustomization Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

ICustomization Interface


%%PageItemTitle%%

ICustomization Interface

Actions Property

Description

The CustomizationActions object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Actions() As Object

See Also

ICustomization Interface


%%PageItemTitle%%

ICustomization Interface

ExtendedUDFSupport Property

Description

Checks if the program can use the maximum allowable user-defined fields (99 user-defined fields and 3 memo fields).

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExtendedUDFSupport() As Long

Remarks

UDF support is defined for Oracle and MS-SQL based projects. For other platforms, the return value is indeterminate.

See Also

ICustomization Interface


%%PageItemTitle%%

ICustomization Interface

Fields Property

Description

The CustomizationFields object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As Object

See Also

ICustomization Interface


%%PageItemTitle%%

ICustomization Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

ICustomization Interface


%%PageItemTitle%%

ICustomization Interface

Lists Property

Description

The CustomizationLists object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Lists() As Object

See Also

ICustomization Interface


%%PageItemTitle%%

ICustomization Interface

MailConditions Property

Description

The CustomizationMailConditions Object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property MailConditions() As Object

See Also

ICustomization Interface


%%PageItemTitle%%

ICustomization Interface

Modules Property

Description

The CustomizationModules object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modules() As Object

See Also

ICustomization Interface


%%PageItemTitle%%

ICustomization Interface

Permissions Property

Description

The CustomizationPermissions object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Permissions() As Object

See Also

ICustomization Interface


%%PageItemTitle%%

ICustomization Interface

Users Property

Description

The CustomizationUsers object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Users() As Object

See Also

ICustomization Interface


%%PageItemTitle%%

ICustomization Interface

UsersGroups Property

Description

The CustomizationUsersGroups object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property UsersGroups() As Object

See Also

ICustomization Interface


%%PageItemTitle%%

ICustomization2 Members

ICustomization2 Interface

Description

Services to perform customization tasks, such as adding users to user groups, defining user-defined fields, and defining user access privileges.

Example

Get a Customization object from TDConnection.Customization.

Public Methods

Public Method Commit | Posts all customization data changes to the project database.
Public Method Load | Loads all customization data from the server into the client cache. This includes actions, fields, lists, modules, permissions, users, and user groups.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Rollback | Discards unsaved changes to properties and child objects.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Actions | The CustomizationActions object.
Public Property ExtendedUDFSupport | Checks if the program can use the maximum allowable user-defined fields (99 user-defined fields and 3 memo fields).
Public Property Fields | The CustomizationFields object.
Public Property IsChanged | Checks if there has been at least one change to a property or child object that has not been saved.
Public Property IsLocked | Checks if object is locked.
Public Property Lists | The CustomizationLists object.
Public Property MailConditions | The CustomizationMailConditions Object.
Public Property Modules | The CustomizationModules object.
Public Property Permissions | The CustomizationPermissions object.
Public Property Users | The CustomizationUsers object.
Public Property UsersGroups | The CustomizationUsersGroups object.


%%PageItemTitle%%

ICustomization2 Interface

Commit Method

Description

Posts all customization data changes to the project database.

Syntax

Public Sub Commit()

See Also

ICustomization2 Interface


%%PageItemTitle%%

ICustomization2 Interface

Load Method

Description

Loads all customization data from the server into the client cache. This includes actions, fields, lists, modules, permissions, users, and user groups.

Syntax

Public Sub Load()

See Also

ICustomization2 Interface


%%PageItemTitle%%

ICustomization2 Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ICustomization2 Interface


%%PageItemTitle%%

ICustomization2 Interface

Rollback Method

Description

Discards unsaved changes to properties and child objects.

Syntax

Public Sub Rollback()

Remarks

This method fetches the data of the current customization object and its derived lists and objects from the server, overwriting any changes made since the last commit.

See Also

ICustomization2 Interface


%%PageItemTitle%%

ICustomization2 Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

ICustomization2 Interface


%%PageItemTitle%%

ICustomization2 Interface

Actions Property

Description

The CustomizationActions object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Actions() As Object

See Also

ICustomization2 Interface


%%PageItemTitle%%

ICustomization2 Interface

ExtendedUDFSupport Property

Description

Checks if the program can use the maximum allowable user-defined fields (99 user-defined fields and 3 memo fields).

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExtendedUDFSupport() As Long

Remarks

UDF support is defined for Oracle and MS-SQL based projects. For other platforms, the return value is indeterminate.

See Also

ICustomization2 Interface


%%PageItemTitle%%

ICustomization2 Interface

Fields Property

Description

The CustomizationFields object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As Object

See Also

ICustomization2 Interface


%%PageItemTitle%%

ICustomization2 Interface

IsChanged Property

Description

Checks if there has been at least one change to a property or child object that has not been saved.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsChanged() As Boolean

See Also

ICustomization2 Interface


%%PageItemTitle%%

ICustomization2 Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

ICustomization2 Interface


%%PageItemTitle%%

ICustomization2 Interface

Lists Property

Description

The CustomizationLists object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Lists() As Object

See Also

ICustomization2 Interface


%%PageItemTitle%%

ICustomization2 Interface

MailConditions Property

Description

The CustomizationMailConditions Object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property MailConditions() As Object

See Also

ICustomization2 Interface


%%PageItemTitle%%

ICustomization2 Interface

Modules Property

Description

The CustomizationModules object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modules() As Object

See Also

ICustomization2 Interface


%%PageItemTitle%%

ICustomization2 Interface

Permissions Property

Description

The CustomizationPermissions object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Permissions() As Object

See Also

ICustomization2 Interface


%%PageItemTitle%%

ICustomization2 Interface

Users Property

Description

The CustomizationUsers object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Users() As Object

See Also

ICustomization2 Interface


%%PageItemTitle%%

ICustomization2 Interface

UsersGroups Property

Description

The CustomizationUsersGroups object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property UsersGroups() As Object

See Also

ICustomization2 Interface


%%PageItemTitle%%

ICustomization3 Members

ICustomization3 Interface

Description

Customization services, such as adding users to user groups, maintaining user-defined fields, configuring user access privileges.

Example

Get a Customization object from TDConnection.Customization.

Public Methods

Public Method Commit | Posts all customization data changes to the project database.
Public Method Load | Loads all customization data from the server into the client cache. This includes actions, fields, lists, modules, permissions, users, and user groups.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Rollback | Discards unsaved changes to properties and child objects.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Actions | The CustomizationActions object.
Public Property CustomizableEntitiesTables | Returns the list of the customizable entities' table names.
Public Property EntityDataTables | Returns the names of the data tables that have a user label defined as comma-separated pairs of table names and user labels.
Public Property ExtendedUDFSupport | Checks if the program can use the maximum allowable user-defined fields (99 user-defined fields and 3 memo fields).
Public Property Fields | The CustomizationFields object.
Public Property IsChanged | Checks if there has been at least one change to a property or child object that has not been saved.
Public Property IsLocked | Checks if object is locked.
Public Property Lists | The CustomizationLists object.
Public Property MailConditions | The CustomizationMailConditions Object.
Public Property Modules | The CustomizationModules object.
Public Property Permissions | The CustomizationPermissions object.
Public Property RBT | Returns the CustomizationRBT object.
Public Property Types | Returns the CustomizationTypes object.
Public Property Users | The CustomizationUsers object.
Public Property UsersGroups | The CustomizationUsersGroups object.


%%PageItemTitle%%

ICustomization3 Interface

Commit Method

Description

Posts all customization data changes to the project database.

Syntax

Public Sub Commit()

See Also

ICustomization3 Interface


%%PageItemTitle%%

ICustomization3 Interface

Load Method

Description

Loads all customization data from the server into the client cache. This includes actions, fields, lists, modules, permissions, users, and user groups.

Syntax

Public Sub Load()

See Also

ICustomization3 Interface


%%PageItemTitle%%

ICustomization3 Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ICustomization3 Interface


%%PageItemTitle%%

ICustomization3 Interface

Rollback Method

Description

Discards unsaved changes to properties and child objects.

Syntax

Public Sub Rollback()

See Also

ICustomization3 Interface


%%PageItemTitle%%

ICustomization3 Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

ICustomization3 Interface


%%PageItemTitle%%

ICustomization3 Interface

Actions Property

Description

The CustomizationActions object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Actions() As Object

See Also

ICustomization3 Interface


%%PageItemTitle%%

ICustomization3 Interface

CustomizableEntitiesTables Property

Description

Returns the list of the customizable entities' table names.

Property type

Read-only property

Syntax (Visual Basic)

Public Property CustomizableEntitiesTables() As List

See Also

ICustomization3 Interface


%%PageItemTitle%%

ICustomization3 Interface

EntityDataTables Property

Description

Returns the names of the data tables that have a user label defined as comma-separated pairs of table names and user labels.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EntityDataTables() As String

See Also

ICustomization3 Interface


%%PageItemTitle%%

ICustomization3 Interface

ExtendedUDFSupport Property

Description

Checks if the program can use the maximum allowable user-defined fields (99 user-defined fields and 3 memo fields).

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExtendedUDFSupport() As Long

Remarks

UDF support is defined for Oracle and MS-SQL based projects. For other platforms, the return value is indeterminate.

See Also

ICustomization3 Interface


%%PageItemTitle%%

ICustomization3 Interface

Fields Property

Description

The CustomizationFields object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As Object

See Also

ICustomization3 Interface


%%PageItemTitle%%

ICustomization3 Interface

IsChanged Property

Description

Checks if there has been at least one change to a property or child object that has not been saved.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsChanged() As Boolean

See Also

ICustomization3 Interface


%%PageItemTitle%%

ICustomization3 Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

ICustomization3 Interface


%%PageItemTitle%%

ICustomization3 Interface

Lists Property

Description

The CustomizationLists object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Lists() As Object

See Also

ICustomization3 Interface


%%PageItemTitle%%

ICustomization3 Interface

MailConditions Property

Description

The CustomizationMailConditions Object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property MailConditions() As Object

See Also

ICustomization3 Interface


%%PageItemTitle%%

ICustomization3 Interface

Modules Property

Description

The CustomizationModules object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modules() As Object

See Also

ICustomization3 Interface


%%PageItemTitle%%

ICustomization3 Interface

Permissions Property

Description

The CustomizationPermissions object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Permissions() As Object

See Also

ICustomization3 Interface


%%PageItemTitle%%

ICustomization3 Interface

RBT Property

Description

Returns the CustomizationRBT object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RBT() As Object

Get or Set Value Type

A CustomizationRBT Object.

See Also

ICustomization3 Interface


%%PageItemTitle%%

ICustomization3 Interface

Types Property

Description

Returns the CustomizationTypes object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Types() As Object

See Also

ICustomization3 Interface


%%PageItemTitle%%

ICustomization3 Interface

Users Property

Description

The CustomizationUsers object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Users() As Object

See Also

ICustomization3 Interface


%%PageItemTitle%%

ICustomization3 Interface

UsersGroups Property

Description

The CustomizationUsersGroups object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property UsersGroups() As Object

See Also

ICustomization3 Interface


%%PageItemTitle%%

ICustomizationAction Members

ICustomizationAction Interface

Description

Represents a type of user action such as adding or deleting a bug.

Remarks

For the list of actions, see the ACTIONS table in the Site Administration UI.

Get a CustomizationAction object from the CustomizationActions collection.

Public Methods

Public Method AddGroup | Adds a user group to the list of user groups for which the current action is allowed.
Public Method RemoveGroup | Removes the specified user group from the list of groups for which the current action is allowed.

Public Properties

Public Property Groups | A list of the user groups for which the current action is allowed.
Public Property IsGroupPermited | Checks if the group specified by the Group parameter has permission to perform the current action.
Public Property IsOwnerGroup | Checks if the user group specified by the Group parameter is the owner of the current action.
Public Property IsUserPermited | Checks if the user specified by the User parameter is permitted to perform the current action.
Public Property Name | The name of the action.
Public Property OwnerGroup | The user group that owns the action.
Public Property Updated | Indicates if the object has been modified since last synchronized with server.


%%PageItemTitle%%

ICustomizationAction Interface

Group

The user group to be added. Pass either the name of the group or a CustomizationUsersGroup Object.

See Also OTA COM Type Library

AddGroup Method

Description

Adds a user group to the list of user groups for which the current action is allowed.

Syntax

Public Sub AddGroup( _
   ByVal Group As Variant _
)

Parameters

Group

The user group to be added. Pass either the name of the group or a CustomizationUsersGroup Object.

See Also

ICustomizationAction Interface


%%PageItemTitle%%

ICustomizationAction Interface

Group

The user group to be removed. Pass either the name of the group or a CustomizationUsersGroup Object.

See Also OTA COM Type Library

RemoveGroup Method

Description

Removes the specified user group from the list of groups for which the current action is allowed.

Syntax

Public Sub RemoveGroup( _
   ByVal Group As Variant _
)

Parameters

Group

The user group to be removed. Pass either the name of the group or a CustomizationUsersGroup Object.

See Also

ICustomizationAction Interface


%%PageItemTitle%%

ICustomizationAction Interface

Groups Property

Description

A list of the user groups for which the current action is allowed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Groups() As List

See Also

ICustomizationAction Interface


%%PageItemTitle%%

ICustomizationAction Interface

Group

Specify the group with either the name of the group or a CustomizationUsersGroup Object.

See Also OTA COM Type Library

IsGroupPermited Property

Description

Checks if the group specified by the Group parameter has permission to perform the current action.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsGroupPermited( _
   ByVal Group As Variant _
) As Boolean

Parameters

Group

Specify the group with either the name of the group or a CustomizationUsersGroup Object.

See Also

ICustomizationAction Interface

Example

CustomizationUsersGroup Object


%%PageItemTitle%%

ICustomizationAction Interface

Group

Specify the group with either the name of the group or a CustomizationUsersGroup Object.

See Also OTA COM Type Library

IsOwnerGroup Property

Description

Checks if the user group specified by the Group parameter is the owner of the current action.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsOwnerGroup( _
   ByVal Group As Variant _
) As Boolean

Parameters

Group

Specify the group with either the name of the group or a CustomizationUsersGroup Object.

See Also

ICustomizationAction Interface


%%PageItemTitle%%

ICustomizationAction Interface

User

The user's name or a CustomizationUser Object.

See Also OTA COM Type Library

IsUserPermited Property

Description

Checks if the user specified by the User parameter is permitted to perform the current action.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsUserPermited( _
   ByVal User As Variant _
) As Boolean

Parameters

User

The user's name or a CustomizationUser Object.

See Also

ICustomizationAction Interface


%%PageItemTitle%%

ICustomizationAction Interface

Name Property

Description

The name of the action.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ICustomizationAction Interface


%%PageItemTitle%%

ICustomizationAction Interface

OwnerGroup Property

Description

The user group that owns the action.

Property type

Read-write property

Syntax (Visual Basic)

Public Property OwnerGroup() As Object

See Also

ICustomizationAction Interface


%%PageItemTitle%%

ICustomizationAction Interface

Updated Property

Description

Indicates if the object has been modified since last synchronized with server.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Updated() As Boolean

See Also

ICustomizationAction Interface


%%PageItemTitle%%

ICustomizationActions Members

ICustomizationActions Interface

Description

The collection of all CustomizationAction objects.

Remarks

Get the CustomizationActions collection from the Customization Object.

Public Properties

Public Property Action | The CustomizationAction object representing the action specified by Name.
Public Property Actions | The list of CustomizationAction objects.


%%PageItemTitle%%

ICustomizationActions Interface

Name

Specifies the action. To get the full list of actions at your site, see the ACTIONS table in the Site Administrator UI.

The most common options are:

ac_add_bug, ac_add_common_settings, ac_add_cover, ac_add_cycle, ac_add_cyclefolder, ac_add_cycle_to_cyclefolder, ac_add_desstep, ac_add_folder, ac_add_private_settings, ac_add_r&d_comments, ac_add_req ac_add_reqfolder, ac_add_test, ac_add_test_to_testcycl, ac_change_password, ac_clear_history, ac_configure_mail, ac_copy_cycle, ac_copy_folder, ac_copy_cyclefolder, ac_create_rbr_files, ac_create_views, ac_create_wr_script, ac_customize_fields, ac_delete_bug, ac_delete_common_settings, ac_delete_cover, ac_delete_cycle, ac_delete_cycle_from_cyclefolder, ac_delete_cyclefolder, ac_delete_desstep, ac_delete_folder, ac_delete_private_settings, ac_delete_req, ac_delete_run, ac_delete_test, ac_delete_test_from_testcycl, ac_import_bugs_from_file, ac_import_bugs_from_mail, ac_import_bugs_settings, ac_import_wr_tests, ac_modify_bug, ac_modify_common_settings, ac_modify_cycle, ac_modify_desstep, ac_modify_folder, ac_modify_hosts, ac_modify_private_settings, ac_modify_req, ac_modify_reqfolder, ac_modify_run, ac_modify_test, ac_modify_test_in_testcycl, ac_move_folder, ac_move_cyclefolder, ac_remove_reqfolder, ac_reset_cycle, ac_run_auto_test, ac_run_manual_test, ac_send_all_qualified, ac_test_exec_params, ac_users, ac_wr_settings

See Also OTA COM Type Library

Action Property

Description

The CustomizationAction object representing the action specified by Name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Action( _
   ByVal Name As String _
) As Object

Parameters

Name

Specifies the action. To get the full list of actions at your site, see the ACTIONS table in the Site Administrator UI.

The most common options are:

ac_add_bug, ac_add_common_settings, ac_add_cover, ac_add_cycle, ac_add_cyclefolder, ac_add_cycle_to_cyclefolder, ac_add_desstep, ac_add_folder, ac_add_private_settings, ac_add_r&d_comments, ac_add_req ac_add_reqfolder, ac_add_test, ac_add_test_to_testcycl, ac_change_password, ac_clear_history, ac_configure_mail, ac_copy_cycle, ac_copy_folder, ac_copy_cyclefolder, ac_create_rbr_files, ac_create_views, ac_create_wr_script, ac_customize_fields, ac_delete_bug, ac_delete_common_settings, ac_delete_cover, ac_delete_cycle, ac_delete_cycle_from_cyclefolder, ac_delete_cyclefolder, ac_delete_desstep, ac_delete_folder, ac_delete_private_settings, ac_delete_req, ac_delete_run, ac_delete_test, ac_delete_test_from_testcycl, ac_import_bugs_from_file, ac_import_bugs_from_mail, ac_import_bugs_settings, ac_import_wr_tests, ac_modify_bug, ac_modify_common_settings, ac_modify_cycle, ac_modify_desstep, ac_modify_folder, ac_modify_hosts, ac_modify_private_settings, ac_modify_req, ac_modify_reqfolder, ac_modify_run, ac_modify_test, ac_modify_test_in_testcycl, ac_move_folder, ac_move_cyclefolder, ac_remove_reqfolder, ac_reset_cycle, ac_run_auto_test, ac_run_manual_test, ac_send_all_qualified, ac_test_exec_params, ac_users, ac_wr_settings

See Also

ICustomizationActions Interface


%%PageItemTitle%%

ICustomizationActions Interface

Actions Property

Description

The list of CustomizationAction objects.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Actions() As List

See Also

ICustomizationActions Interface


%%PageItemTitle%%

ICustomizationField Members

ICustomizationField Interface

Description

Services for customizing project fields.

Remarks

Get a CustomizationField object from the CustomizationFields Object.

Public Properties

Public Property ColumnName | The column name.
Public Property ColumnType | The database column type: char, date, memo, number, or time.
Public Property DefaultValue | The default value of the field.
Public Property EditMask | The input mask for string fields.
Public Property FieldSize | The size of the field in the database. For BLOB fields, the size is -1.
Public Property GrantModifyMask | The bit mask that indicates which user groups can modify the field.
Public Property IsActive | Indicates if the field is active. Inactive user-defined fields are not visible in the user interface.
Public Property IsByCode | Indicates if the field stores the Tree Node ID, rather than the passed value.
Public Property IsCustomizable | Indicates if the field is displayed in the customization user interface.
Public Property IsEdit | Indicates if the field can be edited.
Public Property IsHistory | Indicates if change history is stored for the field.
Public Property IsMail | Indicates if Users on the list to be notified of changes are notified when this field is changed.
Public Property IsRequired | Checks if the field is required.
Public Property IsTransitionLogic | Indicates if the field has transition logic.
Public Property IsVerify | Indicates if the field requires verification.
Public Property IsVisibleInNewBug | Indicates if the field is visible for the specified groups in a new defect form.
Public Property List | The CustomizationList assigned to the field.
Public Property NewCreated | Indicates if the field was created but not posted to the server.
Public Property OwnerSensibleMask | The bit mask that indicates for which groups this field can be modified only by its owner.
Public Property RootId | If the field contains a list, the ID of the list root node. If not, RootId is NULL.
Public Property TableName | The name of the table that stores the active field.
Public Property Type | The Field type.
Public Property Updated | Indicates if the object has been modified since the last download from the server.
Public Property UserColumnType | The user column type: char, number, date, memo, or empty string.
Public Property UserLabel | A user-defined field label.
Public Property VersionControl | Indicates if the field is under version control.
Public Property VisibleForGroups | The bit mask that indicates which user groups can see this field.


%%PageItemTitle%%

ICustomizationField Interface

ColumnName Property

Description

The column name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ColumnName() As String

See Also

ICustomizationField Interface


%%PageItemTitle%%

ICustomizationField Interface

ColumnType Property

Description

The database column type: char, date, memo, number, or time.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ColumnType() As String

See Also

ICustomizationField Interface


%%PageItemTitle%%

ICustomizationField Interface

DefaultValue Property

Description

The default value of the field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property DefaultValue() As String

See Also

ICustomizationField Interface


%%PageItemTitle%%

ICustomizationField Interface

EditMask Property

Description

The input mask for string fields.

Property type

Read-write property

Syntax (Visual Basic)

Public Property EditMask() As String

Remarks

When a user is prompted for data in the user interface, the edit mask is used to present the blank input in the required format.

For more information on input masks, see 'Defining Input Masks' under 'Customizing Project Entities' in the Mercury Quality Center Administrator's Guide.

See Also

ICustomizationField Interface


%%PageItemTitle%%

ICustomizationField Interface

FieldSize Property

Description

The size of the field in the database. For BLOB fields, the size is -1.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FieldSize() As Long

Remarks

FieldSize sets the maximum size of the data that can be stored in a user-defined field. Do not attempt to set the size to a value less than the size of the field as initially created in a new, empty project.

See Also

ICustomizationField Interface


%%PageItemTitle%%

ICustomizationField Interface

GrantModifyMask Property

Description

The bit mask that indicates which user groups can modify the field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property GrantModifyMask() As Long

Remarks

The least significant bit represents Group 0, the next bit represents Group 1, and so on. For example, if bit 0 is set, then the module is visible for members of the group where CustomizationUsersGroup.ID = 0.

See Also

ICustomizationField Interface


%%PageItemTitle%%

ICustomizationField Interface

IsActive Property

Description

Indicates if the field is active. Inactive user-defined fields are not visible in the user interface.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsActive() As Boolean

See Also

ICustomizationField Interface


%%PageItemTitle%%

ICustomizationField Interface

IsByCode Property

Description

Indicates if the field stores the Tree Node ID, rather than the passed value.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsByCode() As Boolean

See Also

ICustomizationField Interface


%%PageItemTitle%%

ICustomizationField Interface

IsCustomizable Property

Description

Indicates if the field is displayed in the customization user interface.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsCustomizable() As Boolean

See Also

ICustomizationField Interface


%%PageItemTitle%%

ICustomizationField Interface

IsEdit Property

Description

Indicates if the field can be edited.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsEdit() As Boolean

See Also

ICustomizationField Interface


%%PageItemTitle%%

ICustomizationField Interface

IsHistory Property

Description

Indicates if change history is stored for the field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsHistory() As Boolean

See Also

ICustomizationField Interface


%%PageItemTitle%%

ICustomizationField Interface

IsMail Property

Description

Indicates if Users on the list to be notified of changes are notified when this field is changed.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsMail() As Boolean

See Also

ICustomizationField Interface


%%PageItemTitle%%

ICustomizationField Interface

IsRequired Property

Description

Checks if the field is required.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsRequired() As Boolean

See Also

ICustomizationField Interface


%%PageItemTitle%%

ICustomizationField Interface

IsTransitionLogic Property

Description

Indicates if the field has transition logic.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsTransitionLogic() As Boolean

Remarks

To access the transition rules, use Permissions to get a CustomizationPermissions object, and use CustomizationPermissions .TransitionRules to get the collection of rules.

See Also

ICustomizationField Interface


%%PageItemTitle%%

ICustomizationField Interface

IsVerify Property

Description

Indicates if the field requires verification.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsVerify() As Boolean

Remarks

In most cases, verification means that the value must exist in a project list, such as Status, All Projects, and so on.

Where there is no list attached to the field, verification depends on the nature of the field. For example, subject fields are generally verified by checking that the path exists.

See Also

ICustomizationField Interface


%%PageItemTitle%%

ICustomizationField Interface

IsVisibleInNewBug Property

Description

Indicates if the field is visible for the specified groups in a new defect form.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsVisibleInNewBug() As Long

Remarks

When the bit corresponding to the CustomizationUsersGroup.ID in the group mask is set, the field is visible to members of the group in the Add Defect dialog.

For example, if bit 0 is set, then the module is visible for members of the group where CustomizationUsersGroup.ID = 0.

This single property controls field visibility for all groups.

See Also

ICustomizationField Interface


%%PageItemTitle%%

ICustomizationField Interface

List Property

Description

The CustomizationList assigned to the field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property List() As Object

See Also

ICustomizationField Interface


%%PageItemTitle%%

ICustomizationField Interface

NewCreated Property

Description

Indicates if the field was created but not posted to the server.

Property type

Read-write property

Syntax (Visual Basic)

Public Property NewCreated() As Boolean

See Also

ICustomizationField Interface


%%PageItemTitle%%

ICustomizationField Interface

RootId Property

Description

If the field contains a list, the ID of the list root node. If not, RootId is NULL.

Property type

Read-write property

Syntax (Visual Basic)

Public Property RootId() As Variant

See Also

ICustomizationField Interface


%%PageItemTitle%%

ICustomizationField Interface

TableName Property

Description

The name of the table that stores the active field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TableName() As String

See Also

ICustomizationField Interface


%%PageItemTitle%%

ICustomizationField Interface

Type Property

Description

The Field type.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Type() As Long

Get or Set Value Type

A value of the tagTDAPI_DATATYPES Enumeration.

Remarks

The type for fields that get values from a customizable list is TDOLE_TREENODE. This applies to all the lists in the customization model, for example, status lists, product, lists, release and cycle lists, and so on.

See Also

ICustomizationField Interface


%%PageItemTitle%%

ICustomizationField Interface

Updated Property

Description

Indicates if the object has been modified since the last download from the server.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Updated() As Boolean

See Also

ICustomizationField Interface


%%PageItemTitle%%

ICustomizationField Interface

UserColumnType Property

Description

The user column type: char, number, date, memo, or empty string.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserColumnType() As String

Remarks

This is not always the same as the Type. For example, a user may enter date or numerical information in a char database field.

See Also

ICustomizationField Interface


%%PageItemTitle%%

ICustomizationField Interface

UserLabel Property

Description

A user-defined field label.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserLabel() As String

See Also

ICustomizationField Interface


%%PageItemTitle%%

ICustomizationField Interface

VersionControl Property

Description

Indicates if the field is under version control.

Property type

Read-write property

Syntax (Visual Basic)

Public Property VersionControl() As Boolean

See Also

ICustomizationField Interface


%%PageItemTitle%%

ICustomizationField2 Members

ICustomizationField2 Interface

Description

Services for customizing project fields.

Remarks

Get a CustomizationField object from the CustomizationFields Object.

Public Properties

Public Property AuthorizedModifyForGroups | The list of groups whose members can modify this field.
Public Property AuthorizedOwnerSensibleForGroups | The list of CustomizationUsersGroup objects of the groups for which only the owner can modify the field.
Public Property AuthorizedVisibleForGroups | The list of CustomizationUsersGroup objects of the groups for which the field is visible in customization dialogs.
Public Property AuthorizedVisibleInNewBugForGroups | The list of CustomizationUsersGroup objects of the groups for which the field is visible in the new defect dialog.
Public Property CanMakeMultiValue | Checks if the field can be configured to store multiple values. If False, IsMultiValue cannot be set to True.
Public Property CanMakeSearchable | Checks if search can be enabled for the field.
Public Property ColumnName | The column name.
Public Property ColumnType | The database column type: char, date, memo, number, or time.
Public Property DefaultValue | The default value of the field.
Public Property EditMask | The input mask for string fields.
Public Property FieldSize | The size of the field in the database. For BLOB fields, the size is -1.
Public Property GrantModifyForGroup | Indicates whether members of the group can change the value of this field.
Public Property GrantModifyMask | The bit mask that indicates which user groups can modify the field.
Public Property IsActive | Indicates if the field is active. Inactive user-defined fields are not visible in the user interface.
Public Property IsByCode | Indicates if the field stores the Tree Node ID, rather than the passed value.
Public Property IsCanGroup | Indicates if items of this type can form groups with others of the same type.
Public Property IsCustomizable | Indicates if the field is displayed in the customization user interface.
Public Property IsEdit | Indicates if the field can be edited.
Public Property IsHistory | Indicates if change history is stored for the field.
Public Property IsMail | Indicates if Users on the list to be notified of changes are notified when this field is changed.
Public Property IsMultiValue | Indicates whether the field can store more than one value.
Public Property IsRequired | Checks if the field is required.
Public Property IsSearchable | Indicates whether the content of the field is searched by the Search method.
Public Property IsTransitionLogic | Indicates if the field has transition logic.
Public Property IsVerify | Indicates if the field requires verification.
Public Property IsVirtual | Checks if the field has a physical representation in the database. If True, there is no physical representation.
Public Property IsVisibleInNewBug | Indicates if the field is visible for the specified groups in a new defect form.
Public Property List | The CustomizationList assigned to the field.
Public Property NewCreated | Indicates if the field was created but not posted to the server.
Public Property OwnerSensibleForGroup | Indicates whether the field can be modified by the owner if the owner belongs to the specified group.
Public Property OwnerSensibleMask | The bit mask that indicates for which groups this field can be modified only by its owner.
Public Property RootId | If the field contains a list, the ID of the list root node. If not, RootId is NULL.
Public Property TableName | The name of the table that stores the active field.
Public Property Type | The Field type.
Public Property Updated | Indicates if the object has been modified since the last download from the server.
Public Property UserColumnType | The user column type: char, number, date, memo, or empty string.
Public Property UserLabel | A user-defined field label.
Public Property VersionControl | Indicates if the field is under version control.
Public Property VisibleForGroup | Indicates whether the field is visible in the New Defect dialog to the specified group.
Public Property VisibleForGroups | The bit mask that indicates which user groups can see this field.
Public Property VisibleInNewBugForGroup | Indicates whether the field is visible to the specified group in the new defect dialog.


%%PageItemTitle%%

ICustomizationField2 Interface

AuthorizedModifyForGroups Property

Description

The list of groups whose members can modify this field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AuthorizedModifyForGroups() As List

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

AuthorizedOwnerSensibleForGroups Property

Description

The list of CustomizationUsersGroup objects of the groups for which only the owner can modify the field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AuthorizedOwnerSensibleForGroups() As List

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

AuthorizedVisibleForGroups Property

Description

The list of CustomizationUsersGroup objects of the groups for which the field is visible in customization dialogs.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AuthorizedVisibleForGroups() As List

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

AuthorizedVisibleInNewBugForGroups Property

Description

The list of CustomizationUsersGroup objects of the groups for which the field is visible in the new defect dialog.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AuthorizedVisibleInNewBugForGroups() As List

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

CanMakeMultiValue Property

Description

Checks if the field can be configured to store multiple values. If False, IsMultiValue cannot be set to True.

Property type

Read-only property

Syntax (Visual Basic)

Public Property CanMakeMultiValue() As Boolean

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

CanMakeSearchable Property

Description

Checks if search can be enabled for the field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property CanMakeSearchable() As Boolean

Remarks

If CanMakeSearchable is False, IsSearchable cannot be set to True.

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

ColumnName Property

Description

The column name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ColumnName() As String

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

ColumnType Property

Description

The database column type: char, date, memo, number, or time.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ColumnType() As String

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

DefaultValue Property

Description

The default value of the field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property DefaultValue() As String

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

EditMask Property

Description

The input mask for string fields.

Property type

Read-write property

Syntax (Visual Basic)

Public Property EditMask() As String

Remarks

When a user is prompted for data in the user interface, the edit mask is used to present the blank input in the required format.

For more information on input masks, see 'Defining Input Masks' under 'Customizing Project Entities' in the Mercury Quality Center Administrator's Guide.

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

FieldSize Property

Description

The size of the field in the database. For BLOB fields, the size is -1.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FieldSize() As Long

Remarks

FieldSize sets the maximum size of the data that can be stored in a user-defined field. Do not attempt to set the size to a value less than the size of the field as initially created in a new, empty project.

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

Group

The CustomizationUsersGroup.ID.

See Also OTA COM Type Library

GrantModifyForGroup Property

Description

Indicates whether members of the group can change the value of this field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property GrantModifyForGroup( _
   ByVal Group As Variant _
) As Boolean

Parameters

Group

The CustomizationUsersGroup.ID.

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

GrantModifyMask Property

Description

The bit mask that indicates which user groups can modify the field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property GrantModifyMask() As Long

Remarks

The least significant bit represents Group 0, the next bit represents Group 1, and so on. For example, if bit 0 is set, then the module is visible for members of the group where CustomizationUsersGroup.ID = 0.

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

IsActive Property

Description

Indicates if the field is active. Inactive user-defined fields are not visible in the user interface.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsActive() As Boolean

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

IsByCode Property

Description

Indicates if the field stores the Tree Node ID, rather than the passed value.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsByCode() As Boolean

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

IsCanGroup Property

Description

Indicates if items of this type can form groups with others of the same type.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsCanGroup() As Boolean

See Also

ICustomizationField2 Interface

Example

Using the GroupingItem Object


%%PageItemTitle%%

ICustomizationField2 Interface

IsCustomizable Property

Description

Indicates if the field is displayed in the customization user interface.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsCustomizable() As Boolean

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

IsEdit Property

Description

Indicates if the field can be edited.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsEdit() As Boolean

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

IsHistory Property

Description

Indicates if change history is stored for the field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsHistory() As Boolean

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

IsMail Property

Description

Indicates if Users on the list to be notified of changes are notified when this field is changed.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsMail() As Boolean

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

IsMultiValue Property

Description

Indicates whether the field can store more than one value.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsMultiValue() As Boolean

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

IsRequired Property

Description

Checks if the field is required.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsRequired() As Boolean

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

IsSearchable Property

Description

Indicates whether the content of the field is searched by the Search method.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsSearchable() As Boolean

Remarks

IsSearchable refers to the behavior of the ISearchableFactory.Search Method.

If CanMakeSearchable is False, IsSearchable cannot be set to True.

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

IsTransitionLogic Property

Description

Indicates if the field has transition logic.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsTransitionLogic() As Boolean

Remarks

To access the transition rules, use Permissions to get a CustomizationPermissions object, and use CustomizationPermissions .TransitionRules to get the collection of rules.

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

IsVerify Property

Description

Indicates if the field requires verification.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsVerify() As Boolean

Remarks

In most cases, verification means that the value must exist in a project list, such as Status, All Projects, and so on.

Where there is no list attached to the field, verification depends on the nature of the field. For example, subject fields are generally verified by checking that the path exists.

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

IsVirtual Property

Description

Checks if the field has a physical representation in the database. If True, there is no physical representation.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsVirtual() As Boolean

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

IsVisibleInNewBug Property

Description

Indicates if the field is visible for the specified groups in a new defect form.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsVisibleInNewBug() As Long

Remarks

When the bit corresponding to the CustomizationUsersGroup.ID in the group mask is set, the field is visible to members of the group in the Add Defect dialog.

For example, if bit 0 is set, then the module is visible for members of the group where CustomizationUsersGroup.ID = 0.

This single property controls field visibility for all groups.

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

List Property

Description

The CustomizationList assigned to the field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property List() As Object

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

NewCreated Property

Description

Indicates if the field was created but not posted to the server.

Property type

Read-write property

Syntax (Visual Basic)

Public Property NewCreated() As Boolean

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

Group

The CustomizationUsersGroup.ID.

See Also OTA COM Type Library

OwnerSensibleForGroup Property

Description

Indicates whether the field can be modified by the owner if the owner belongs to the specified group.

Property type

Read-write property

Syntax (Visual Basic)

Public Property OwnerSensibleForGroup( _
   ByVal Group As Variant _
) As Boolean

Parameters

Group

The CustomizationUsersGroup.ID.

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

RootId Property

Description

If the field contains a list, the ID of the list root node. If not, RootId is NULL.

Property type

Read-write property

Syntax (Visual Basic)

Public Property RootId() As Variant

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

TableName Property

Description

The name of the table that stores the active field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TableName() As String

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

Type Property

Description

The Field type.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Type() As Long

Get or Set Value Type

A value of the tagTDAPI_DATATYPES Enumeration.

Remarks

The type for fields that get values from a customizable list is TDOLE_TREENODE. This applies to all the lists in the customization model, for example, status lists, product, lists, release and cycle lists, and so on.

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

Updated Property

Description

Indicates if the object has been modified since the last download from the server.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Updated() As Boolean

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

UserColumnType Property

Description

The user column type: char, number, date, memo, or empty string.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserColumnType() As String

Remarks

This is not always the same as the Type. For example, a user may enter date or numerical information in a char database field.

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

UserLabel Property

Description

A user-defined field label.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserLabel() As String

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

VersionControl Property

Description

Indicates if the field is under version control.

Property type

Read-write property

Syntax (Visual Basic)

Public Property VersionControl() As Boolean

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

Group

The CustomizationUsersGroup.ID.

See Also OTA COM Type Library

VisibleForGroup Property

Description

Indicates whether the field is visible in the New Defect dialog to the specified group.

Property type

Read-write property

Syntax (Visual Basic)

Public Property VisibleForGroup( _
   ByVal Group As Variant _
) As Boolean

Parameters

Group

The CustomizationUsersGroup.ID.

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

Group

The CustomizationUsersGroup.ID.

See Also OTA COM Type Library

VisibleInNewBugForGroup Property

Description

Indicates whether the field is visible to the specified group in the new defect dialog.

Property type

Read-write property

Syntax (Visual Basic)

Public Property VisibleInNewBugForGroup( _
   ByVal Group As Variant _
) As Boolean

Parameters

Group

The CustomizationUsersGroup.ID.

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationFields Members

ICustomizationFields Interface

Description

Services for managing the collection of all CustomizationField objects in the project.

Remarks

Get the CustomizationFields collection from the Customization Object.

Public Methods

Public Method AddActiveField | Finds the first free, inactive field in the specified table, signs the field as active, and returns the CustomizationFields object representing the field.
Public Method AddActiveMemoField | Creates a new memo field in a table.

Public Properties

Public Property Field | The customization field object for the specified database table and field.
Public Property FieldExists | Checks if the specified database field exists.
Public Property Fields | A list of all fields in the specified table.


%%PageItemTitle%%

ICustomizationFields Interface

TableName

The name of the table to which to add the field.

See Also OTA COM Type Library

AddActiveField Method

Description

Finds the first free, inactive field in the specified table, signs the field as active, and returns the CustomizationFields object representing the field.

Syntax

Public Function AddActiveField( _
   ByVal TableName As String _
) As Object

Parameters

TableName

The name of the table to which to add the field.

Return Type

A CustomizationField Object.

See Also

ICustomizationFields Interface


%%PageItemTitle%%

ICustomizationFields Interface

TableName

The name of the table to which to add the field.

See Also OTA COM Type Library

AddActiveMemoField Method

Description

Creates a new memo field in a table.

Syntax

Public Function AddActiveMemoField( _
   ByVal TableName As String _
) As Object

Parameters

TableName

The name of the table to which to add the field.

Return Type

A CustomizationField Object.

See Also

ICustomizationFields Interface


%%PageItemTitle%%

ICustomizationFields Interface

TableName

The name of the database table.

FieldName

The name of the field in the table.

See Also OTA COM Type Library

Field Property

Description

The customization field object for the specified database table and field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Field( _
   ByVal TableName As String, _
   ByVal FieldName As String _
) As Object

Parameters

TableName

The name of the database table.

FieldName

The name of the field in the table.

See Also

ICustomizationFields Interface


%%PageItemTitle%%

ICustomizationFields Interface

TableName

The name of the database table.

FieldName

The name of the field in the table.

See Also OTA COM Type Library

FieldExists Property

Description

Checks if the specified database field exists.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FieldExists( _
   ByVal TableName As String, _
   ByVal FieldName As String _
) As Boolean

Parameters

TableName

The name of the database table.

FieldName

The name of the field in the table.

See Also

ICustomizationFields Interface


%%PageItemTitle%%

ICustomizationFields Interface

TableName

The name of the database table.

See Also OTA COM Type Library

Fields Property

Description

A list of all fields in the specified table.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields( _
   Optional ByVal TableName As String = "" _
) As List

Parameters

TableName

The name of the database table.

Remarks

If an empty string is passed as TableName, returns a list of the fields in all tables.

See Also

ICustomizationFields Interface


%%PageItemTitle%%

ICustomizationList Members

ICustomizationList Interface

Description

Represents a user-defined list associated with a field.

Remarks

For more information about the custom lists, see 'Customizing Project Lists' in the Mercury Quality Center Administrator's Guide.

Get a CustomizationList object from the CustomizationLists Object.

Public Methods

Public Method Find Finds a CustomizationListNode of the current list by the node name or ID.

Public Properties

Public Property Deleted | If true, the node is marked for deletion, but the deletion is not yet committed.
Public Property Name | The name of the list.
Public Property RootNode | The root CustomizationListNode of the current list.


%%PageItemTitle%%

ICustomizationList Interface

Val

The node name or ID.

See Also OTA COM Type Library

Find Method

Description

Finds a CustomizationListNode of the current list by the node name or ID.

Syntax

Public Function Find( _
   ByVal Val As Variant _
) As Object

Parameters

Val

The node name or ID.

Return Type

A CustomizationListNode Object.

See Also

ICustomizationList Interface


%%PageItemTitle%%

ICustomizationList Interface

Deleted Property

Description

If true, the node is marked for deletion, but the deletion is not yet committed.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Deleted() As Boolean

See Also

ICustomizationList Interface


%%PageItemTitle%%

ICustomizationList Interface

Name Property

Description

The name of the list.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ICustomizationList Interface


%%PageItemTitle%%

ICustomizationList Interface

RootNode Property

Description

The root CustomizationListNode of the current list.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RootNode() As Object

See Also

ICustomizationList Interface


%%PageItemTitle%%

ICustomizationListNode Members

ICustomizationListNode Interface

Description

Represents a node in a list.

Remarks

This object can represent the list root node or a child node within the list.

Get a CustomizationListNode object from the CustomizationList Object.

Public Methods

Public Method AddChild | Adds a new sub-node to the current node.
Public Method RemoveChild | Removes the specified sub-node from the current node.

Public Properties

Public Property CanAddChild | Checks if sub-nodes can be added to the current node.
Public Property Child | Gets the specified sub-node.
Public Property Children | The list of CustomizationListNode objects that are sub-nodes of the current node.
Public Property ChildrenCount | The number of sub-nodes under the node.
Public Property Deleted | If true, the node is marked for deletion, but the deletion is not yet committed.
Public Property Father | Gets the CustomizationListNode object representing the current node's parent node, or sets a new father, thereby moving the node.
Private Property ID | The current node ID.
Public Property List | The CustomizationList object that contains the current node.
Public Property Name | The current node name.
Public Property Order | The order number of the node within its siblings.
Public Property ReadOnly | Checks if the current node is read-only.
Public Property Updated | Indicates if the node was modified since it was loaded from the server.


%%PageItemTitle%%

ICustomizationListNode Interface

Node

Either the node name of the child or a CustomListNode object.

See Also OTA COM Type Library

AddChild Method

Description

Adds a new sub-node to the current node.

Syntax

Public Function AddChild( _
   ByVal Node As Variant _
) As Object

Parameters

Node

Either the node name of the child or a CustomListNode object.

Return Type

The CustomListNode object representing the new child.

See Also

ICustomizationListNode Interface


%%PageItemTitle%%

ICustomizationListNode Interface

Node

Either the node name of the child or a CustomListNode object.

See Also OTA COM Type Library

RemoveChild Method

Description

Removes the specified sub-node from the current node.

Syntax

Public Sub RemoveChild( _
   ByVal Node As Variant _
)

Parameters

Node

Either the node name of the child or a CustomListNode object.

See Also

ICustomizationListNode Interface


%%PageItemTitle%%

ICustomizationListNode Interface

CanAddChild Property

Description

Checks if sub-nodes can be added to the current node.

Property type

Read-only property

Syntax (Visual Basic)

Public Property CanAddChild() As Boolean

See Also

ICustomizationListNode Interface


%%PageItemTitle%%

ICustomizationListNode Interface

NodeName

The name of the child node.

See Also OTA COM Type Library

Child Property

Description

Gets the specified sub-node.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Child( _
   ByVal NodeName As String _
) As Object

Parameters

NodeName

The name of the child node.

See Also

ICustomizationListNode Interface


%%PageItemTitle%%

ICustomizationListNode Interface

Children Property

Description

The list of CustomizationListNode objects that are sub-nodes of the current node.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Children() As List

See Also

ICustomizationListNode Interface


%%PageItemTitle%%

ICustomizationListNode Interface

ChildrenCount Property

Description

The number of sub-nodes under the node.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ChildrenCount() As Long

See Also

ICustomizationListNode Interface


%%PageItemTitle%%

ICustomizationListNode Interface

Deleted Property

Description

If true, the node is marked for deletion, but the deletion is not yet committed.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Deleted() As Boolean

See Also

ICustomizationListNode Interface


%%PageItemTitle%%

ICustomizationListNode Interface

Father Property

Description

Gets the CustomizationListNode object representing the current node's parent node, or sets a new father, thereby moving the node.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Father() As Object

See Also

ICustomizationListNode Interface


%%PageItemTitle%%

ICustomizationListNode Interface

ID Property

Description

The current node ID.

Property type

Write-only property

Syntax (Visual Basic)

Private Property ID() As Long

See Also

ICustomizationListNode Interface


%%PageItemTitle%%

ICustomizationListNode Interface

List Property

Description

The CustomizationList object that contains the current node.

Property type

Read-only property

Syntax (Visual Basic)

Public Property List() As Object

See Also

ICustomizationListNode Interface


%%PageItemTitle%%

ICustomizationListNode Interface

Name Property

Description

The current node name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ICustomizationListNode Interface


%%PageItemTitle%%

ICustomizationListNode Interface

Order Property

Description

The order number of the node within its siblings.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Order() As Long

Remarks

When the order of one node is set with this property, no adjustments are made to the positions of others. The application is responsible for ensuring that the orders of all nodes are as required, that no two nodes occupy the same position, and there are no empty positions.

When two or more nodes are assigned the same order, the actual order is undetermined.

See Also

ICustomizationListNode Interface


%%PageItemTitle%%

ICustomizationListNode Interface

ReadOnly Property

Description

Checks if the current node is read-only.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ReadOnly() As Boolean

See Also

ICustomizationListNode Interface


%%PageItemTitle%%

ICustomizationListNode Interface

Updated Property

Description

Indicates if the node was modified since it was loaded from the server.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Updated() As Boolean

See Also

ICustomizationListNode Interface


%%PageItemTitle%%

ICustomizationLists Members | CustomizationList Object

ICustomizationLists Interface

Description

A collection of all CustomizationList objects in the project.

Remarks

Get the CustomizationLists collection from the Customization Object.

Public Methods

Public Method AddList | Adds a new CustomizationList object.
Public Method RemoveList | Removes a CustomizationList object.

Public Properties

Public Property Count | The number of lists in the CustomizationLists object.
Public Property IsListExist | Checks if the specified customization list exists.
Public Property List | Gets the CustomizationList specified by name or ID.
Public Property ListByCount | Gets the CustomizationList specified by its index number.


%%PageItemTitle%%

ICustomizationLists Interface

Name

The name of the list to be added.

See Also OTA COM Type Library

AddList Method

Description

Adds a new CustomizationList object.

Syntax

Public Function AddList( _
   ByVal Name As String _
) As Object

Parameters

Name

The name of the list to be added.

Return Type

A CustomizationList Object.

See Also

ICustomizationLists Interface


%%PageItemTitle%%

ICustomizationLists Interface

Name

The name of the list to be removed.

See Also OTA COM Type Library

RemoveList Method

Description

Removes a CustomizationList object.

Syntax

Public Sub RemoveList( _
   ByVal Name As String _
)

Parameters

Name

The name of the list to be removed.

See Also

ICustomizationLists Interface


%%PageItemTitle%%

ICustomizationLists Interface

Count Property

Description

The number of lists in the CustomizationLists object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

ICustomizationLists Interface


%%PageItemTitle%%

ICustomizationLists Interface

ListName

The name of the list whose existence you want to check.

See Also OTA COM Type Library

IsListExist Property

Description

Checks if the specified customization list exists.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsListExist( _
   ByVal ListName As String _
) As Boolean

Parameters

ListName

The name of the list whose existence you want to check.

See Also

ICustomizationLists Interface


%%PageItemTitle%%

ICustomizationLists Interface

Param

The list name (string) or root ID (long).

See Also OTA COM Type Library

List Property

Description

Gets the CustomizationList specified by name or ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property List( _
   ByVal Param As Variant _
) As Object

Parameters

Param

The list name (string) or root ID (long).

See Also

ICustomizationLists Interface


%%PageItemTitle%%

ICustomizationLists Interface

Count

The index is 1-based.

See Also OTA COM Type Library

ListByCount Property

Description

Gets the CustomizationList specified by its index number.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ListByCount( _
   ByVal Count As Long _
) As Object

Parameters

Count

The index is 1-based.

See Also

ICustomizationLists Interface


%%PageItemTitle%%

ICustomizationMailCondition Members

ICustomizationMailCondition Interface

Description

The configuration of a custom automatic mail notification.

Remarks

For more information about mail conditions, see 'Defining Mail Conditions' in the Mercury Quality Center Administrator's Guide.

Get a CustomizationMailCondition Object from the CustomizationMailConditions Object.

Public Properties

Public Property ConditionText | The filter to determine when the notification is sent.
Public Property ConditionType | The type of condition.
Public Property Deleted | Indicates if the condition has been removed, but the deletion has not been posted to the server.
Public Property Name | The name of the mail recipient or the field containing the name.
Public Property Updated | Indicates if the condition object has changed locally since last synchronized with the server.


%%PageItemTitle%%

ICustomizationMailCondition Interface

ConditionText Property

Description

The filter to determine when the notification is sent.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ConditionText() As String

Example

This example shows a condition for open defects of high priority.

[]

[Filter]{
TableName:BUG,
ColumnName:BG_PRIORITY,
LogicalFilter:"3-High Or \"4-Very High\" Or 5-Urgent",
VisualFilter:" 3-High  Or  \"4-Very High\"  Or  5-Urgent ",
NO_CASE:
}
{
TableName:BUG,
ColumnName:BG_STATUS,
LogicalFilter:"New Or Open Or Reopen",
VisualFilter:" New  Or  Open  Or  Reopen ",
NO_CASE:
}

See Also

ICustomizationMailCondition Interface


%%PageItemTitle%%

ICustomizationMailCondition Interface

ConditionType Property

Description

The type of condition.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ConditionType() As Long

See Also

ICustomizationMailCondition Interface


%%PageItemTitle%%

ICustomizationMailCondition Interface

Deleted Property

Description

Indicates if the condition has been removed, but the deletion has not been posted to the server.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Deleted() As Boolean

Remarks

As a property-get: Returns True if CustomizationMailConditions.RemoveCondition has been called for this object.

As a property-set: Marks the condition for deletion if set to True; acts as undo for removal if set to False.

See Also

ICustomizationMailCondition Interface


%%PageItemTitle%%

ICustomizationMailCondition Interface

Name Property

Description

The name of the mail recipient or the field containing the name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name() As String

Remarks

If the condition type is USER_MAIL_CONDITION, the condition name is the name of the user. If the type is FIELD_MAIL_CONDITION, the condition name is the name of the defect field containing the user name.

See Also

ICustomizationMailCondition Interface


%%PageItemTitle%%

ICustomizationMailCondition Interface

Updated Property

Description

Indicates if the condition object has changed locally since last synchronized with the server.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Updated() As Boolean

See Also

ICustomizationMailCondition Interface


%%PageItemTitle%%

ICustomizationMailConditions Members

ICustomizationMailConditions Interface

Description

The collection of configurations for custom automatic mail notifications.

Remarks

Get the CustomizationMailConditions collection from the Customization Object.

Public Methods

Public Method AddCondition | Creates a new CustomizationMailCondition.
Public Method RemoveCondition | Deletes the specified CustomizationMailCondition.

Public Properties

Public Property Condition | Gets the CustomizationMailCondition specified by the name and type.
Public Property ConditionExist | Checks if the specified mail customization condition exists.
Public Property Conditions | Gets the list of CustomizationMailCondition objects.


%%PageItemTitle%%

ICustomizationMailConditions Interface

Name

The name of the new condition.

ConditionType

A value of the tagMAIL_CONDITIONS_TYPE Enumeration.

ConditionText

The actual condition. A string valid for a TDFilter.Text.

See Also OTA COM Type Library

AddCondition Method

Description

Creates a new CustomizationMailCondition.

Syntax

Public Function AddCondition( _
   ByVal Name As String, _
   ByVal ConditionType As Long, _
   ByVal ConditionText As String _
) As Object

Parameters

Name

The name of the new condition.

ConditionType

A value of the tagMAIL_CONDITIONS_TYPE Enumeration.

ConditionText

The actual condition. A string valid for a TDFilter.Text.

Return Type

A CustomizationMailCondition Object.

See Also

ICustomizationMailConditions Interface


%%PageItemTitle%%

ICustomizationMailConditions Interface

Name

The name of the new condition.

ConditionType

A value of the tagMAIL_CONDITIONS_TYPE Enumeration.

See Also OTA COM Type Library

RemoveCondition Method

Description

Deletes the specified CustomizationMailCondition.

Syntax

Public Sub RemoveCondition( _
   ByVal Name As String, _
   ByVal ConditionType As Long _
)

Parameters

Name

The name of the new condition.

ConditionType

A value of the tagMAIL_CONDITIONS_TYPE Enumeration.

See Also

ICustomizationMailConditions Interface


%%PageItemTitle%%

ICustomizationMailConditions Interface

Name

The name of the condition.

ConditionType

A value of the tagMAIL_CONDITIONS_TYPE Enumeration.

See Also OTA COM Type Library

Condition Property

Description

Gets the CustomizationMailCondition specified by the name and type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Condition( _
   ByVal Name As String, _
   ByVal ConditionType As Long _
) As Object

Parameters

Name

The name of the condition.

ConditionType

A value of the tagMAIL_CONDITIONS_TYPE Enumeration.

See Also

ICustomizationMailConditions Interface


%%PageItemTitle%%

ICustomizationMailConditions Interface

Name

The name of the new condition.

ConditionType

A value of the tagMAIL_CONDITIONS_TYPE Enumeration.

See Also OTA COM Type Library

ConditionExist Property

Description

Checks if the specified mail customization condition exists.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ConditionExist( _
   ByVal Name As String, _
   ByVal ConditionType As Long _
) As Boolean

Parameters

Name

The name of the new condition.

ConditionType

A value of the tagMAIL_CONDITIONS_TYPE Enumeration.

See Also

ICustomizationMailConditions Interface


%%PageItemTitle%%

ICustomizationMailConditions Interface

Conditions Property

Description

Gets the list of CustomizationMailCondition objects.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Conditions() As List

See Also

ICustomizationMailConditions Interface


%%PageItemTitle%%

ICustomizationModules Members

ICustomizationModules Interface

Description

Services for managing the customization modules.

Remarks

Get the CustomizationModules object from the Customization Object.

Public Properties

Public Property Description | The Module Description
Public Property GUID | The Module's globally unique ID.
Public Property Name | The Module Name.
Public Property Visible | A bit-mask that indicates for which groups the module is visible in the user interface.


%%PageItemTitle%%

ICustomizationModules Interface

ModuleID

The module type. A value of the tagTDAPI_MODULE Enumeration.

See Also OTA COM Type Library

Description Property

Description

The Module Description

Property type

Read-write property

Syntax (Visual Basic)

Public Property Description( _
   ByVal ModuleID As Long _
) As String

Parameters

ModuleID

The module type. A value of the tagTDAPI_MODULE Enumeration.

See Also

ICustomizationModules Interface


%%PageItemTitle%%

ICustomizationModules Interface

ModuleID

The module type. A value of the tagTDAPI_MODULE Enumeration.

See Also OTA COM Type Library

GUID Property

Description

The Module's globally unique ID.

Property type

Read-write property

Syntax (Visual Basic)

Public Property GUID( _
   ByVal ModuleID As Long _
) As String

Parameters

ModuleID

The module type. A value of the tagTDAPI_MODULE Enumeration.

See Also

ICustomizationModules Interface


%%PageItemTitle%%

ICustomizationModules Interface

ModuleID

The module type. A value of the tagTDAPI_MODULE Enumeration.

See Also OTA COM Type Library

Name Property

Description

The Module Name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name( _
   ByVal ModuleID As Long _
) As String

Parameters

ModuleID

The module type. A value of the tagTDAPI_MODULE Enumeration.

See Also

ICustomizationModules Interface


%%PageItemTitle%%

ICustomizationModules Interface

ModuleID

The module type. A value of the tagTDAPI_MODULE Enumeration.

See Also OTA COM Type Library

Visible Property

Description

A bit-mask that indicates for which groups the module is visible in the user interface.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Visible( _
   ByVal ModuleID As Long _
) As Long

Parameters

ModuleID

The module type. A value of the tagTDAPI_MODULE Enumeration.

Remarks

Set bits represent groups for which the module is visible. For example, if bit 0 is set, then the module is visible for members of the group where CustomizationUsersGroup.ID = 0.

See Also

ICustomizationModules Interface


%%PageItemTitle%%

ICustomizationModules2 Members

ICustomizationModules2 Interface

Description

Services for managing the customization modules.

Remarks

Get the CustomizationModules object from the Customization Object.

Public Properties

Public Property Description | The Module Description
Public Property GUID | The Module's globally unique ID.
Public Property IsVisibleForGroup | Indicates if the specified module is visible in the UI to the specified user group.
Public Property Name | The Module Name.
Public Property Visible | A bit-mask that indicates for which groups the module is visible in the user interface.
Public Property VisibleForGroups | The list of the user groups to which the specified module is visible in the UI.


%%PageItemTitle%%

ICustomizationModules2 Interface

ModuleID

The module type. A value of the tagTDAPI_MODULE Enumeration.

See Also OTA COM Type Library

Description Property

Description

The Module Description

Property type

Read-write property

Syntax (Visual Basic)

Public Property Description( _
   ByVal ModuleID As Long _
) As String

Parameters

ModuleID

The module type. A value of the tagTDAPI_MODULE Enumeration.

See Also

ICustomizationModules2 Interface


%%PageItemTitle%%

ICustomizationModules2 Interface

ModuleID

The module type. A value of the tagTDAPI_MODULE Enumeration.

See Also OTA COM Type Library

GUID Property

Description

The Module's globally unique ID.

Property type

Read-write property

Syntax (Visual Basic)

Public Property GUID( _
   ByVal ModuleID As Long _
) As String

Parameters

ModuleID

The module type. A value of the tagTDAPI_MODULE Enumeration.

See Also

ICustomizationModules2 Interface


%%PageItemTitle%%

ICustomizationModules2 Interface

ModuleID

The module type. A value of the tagTDAPI_MODULE Enumeration.

Group

The CustomizationUsersGroup.ID.

See Also OTA COM Type Library

IsVisibleForGroup Property

Description

Indicates if the specified module is visible in the UI to the specified user group.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsVisibleForGroup( _
   ByVal ModuleID As Long, _
   ByVal Group As Variant _
) As Boolean

Parameters

ModuleID

The module type. A value of the tagTDAPI_MODULE Enumeration.

Group

The CustomizationUsersGroup.ID.

See Also

ICustomizationModules2 Interface


%%PageItemTitle%%

ICustomizationModules2 Interface

ModuleID

The module type. A value of the tagTDAPI_MODULE Enumeration.

See Also OTA COM Type Library

Name Property

Description

The Module Name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name( _
   ByVal ModuleID As Long _
) As String

Parameters

ModuleID

The module type. A value of the tagTDAPI_MODULE Enumeration.

See Also

ICustomizationModules2 Interface


%%PageItemTitle%%

ICustomizationModules2 Interface

ModuleID

The module type. A value of the tagTDAPI_MODULE Enumeration.

See Also OTA COM Type Library

Visible Property

Description

A bit-mask that indicates for which groups the module is visible in the user interface.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Visible( _
   ByVal ModuleID As Long _
) As Long

Parameters

ModuleID

The module type. A value of the tagTDAPI_MODULE Enumeration.

Remarks

Set bits represent groups for which the module is visible. For example, if bit 0 is set, then the module is visible for members of the group where CustomizationUsersGroup.ID = 0.

See Also

ICustomizationModules2 Interface


%%PageItemTitle%%

ICustomizationModules2 Interface

ModuleID

The module type. A value of the tagTDAPI_MODULE Enumeration.

See Also OTA COM Type Library

VisibleForGroups Property

Description

The list of the user groups to which the specified module is visible in the UI.

Property type

Read-only property

Syntax (Visual Basic)

Public Property VisibleForGroups( _
   ByVal ModuleID As Long _
) As List

Parameters

ModuleID

The module type. A value of the tagTDAPI_MODULE Enumeration.

See Also

ICustomizationModules2 Interface


%%PageItemTitle%%

ICustomizationModules3 Members

ICustomizationModules3 Interface

Description

Services for managing the customization modules.

Remarks

Get the CustomizationModules object from the Customization Object.

Public Properties

Public Property Description | The Module Description
Public Property GUID | The Module's globally unique ID.
Public Property IsVisibleForGroup | Indicates if the specified module is visible in the UI to the specified user group.
Public Property Module | Returns the module specified by the module ID.
Public Property Modules | The list of project module IDs.
Public Property Name | The Module Name.
Public Property Visible | A bit-mask that indicates for which groups the module is visible in the user interface.
Public Property VisibleForGroups | The list of the user groups to which the specified module is visible in the UI.


%%PageItemTitle%%

ICustomizationModules3 Interface

ModuleID

The module type. A value of the tagTDAPI_MODULE Enumeration.

See Also OTA COM Type Library

Description Property

Description

The Module Description

Property type

Read-write property

Syntax (Visual Basic)

Public Property Description( _
   ByVal ModuleID As Long _
) As String

Parameters

ModuleID

The module type. A value of the tagTDAPI_MODULE Enumeration.

See Also

ICustomizationModules3 Interface


%%PageItemTitle%%

ICustomizationModules3 Interface

ModuleID

The module type. A value of the tagTDAPI_MODULE Enumeration.

See Also OTA COM Type Library

GUID Property

Description

The Module's globally unique ID.

Property type

Read-write property

Syntax (Visual Basic)

Public Property GUID( _
   ByVal ModuleID As Long _
) As String

Parameters

ModuleID

The module type. A value of the tagTDAPI_MODULE Enumeration.

See Also

ICustomizationModules3 Interface


%%PageItemTitle%%

ICustomizationModules3 Interface

ModuleID

The module type. A value of the tagTDAPI_MODULE Enumeration.

Group

The CustomizationUsersGroup.ID.

See Also OTA COM Type Library

IsVisibleForGroup Property

Description

Indicates if the specified module is visible in the UI to the specified user group.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsVisibleForGroup( _
   ByVal ModuleID As Long, _
   ByVal Group As Variant _
) As Boolean

Parameters

ModuleID

The module type. A value of the tagTDAPI_MODULE Enumeration.

Group

The CustomizationUsersGroup.ID.

See Also

ICustomizationModules3 Interface


%%PageItemTitle%%

ICustomizationModules3 Interface

ModuleID

A Module.ID.

See Also OTA COM Type Library

Module Property

Description

Returns the module specified by the module ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Module( _
   ByVal ModuleID As Long _
) As Module

Parameters

ModuleID

A Module.ID.

Get or Set Value Type

A Module Object.

See Also

ICustomizationModules3 Interface


%%PageItemTitle%%

ICustomizationModules3 Interface

Modules Property

Description

The list of project module IDs.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modules() As List

See Also

ICustomizationModules3 Interface


%%PageItemTitle%%

ICustomizationModules3 Interface

ModuleID

The module type. A value of the tagTDAPI_MODULE Enumeration.

See Also OTA COM Type Library

Name Property

Description

The Module Name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name( _
   ByVal ModuleID As Long _
) As String

Parameters

ModuleID

The module type. A value of the tagTDAPI_MODULE Enumeration.

See Also

ICustomizationModules3 Interface


%%PageItemTitle%%

ICustomizationModules3 Interface

ModuleID

The module type. A value of the tagTDAPI_MODULE Enumeration.

See Also OTA COM Type Library

Visible Property

Description

A bit-mask that indicates for which groups the module is visible in the user interface.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Visible( _
   ByVal ModuleID As Long _
) As Long

Parameters

ModuleID

The module type. A value of the tagTDAPI_MODULE Enumeration.

Remarks

Set bits represent groups for which the module is visible. For example, if bit 0 is set, then the module is visible for members of the group where CustomizationUsersGroup.ID = 0.

See Also

ICustomizationModules3 Interface


%%PageItemTitle%%

ICustomizationModules3 Interface

ModuleID

The module type. A value of the tagTDAPI_MODULE Enumeration.

See Also OTA COM Type Library

VisibleForGroups Property

Description

The list of the user groups to which the specified module is visible in the UI.

Property type

Read-only property

Syntax (Visual Basic)

Public Property VisibleForGroups( _
   ByVal ModuleID As Long _
) As List

Parameters

ModuleID

The module type. A value of the tagTDAPI_MODULE Enumeration.

See Also

ICustomizationModules3 Interface


%%PageItemTitle%%

ICustomizationPermissions Members

ICustomizationPermissions Interface

Description

Properties that define the ability of user groups to add, remove, and modify entities.

Remarks

Get the CustomizationPermissions object from Customization .Permissions.

Public Properties

Public Property CanAddItem | Indicates if members of the specified group can add the specified type of entity.
Public Property CanAllowAttachment | Indicates if members owners of the specified group can handle the specified type of entity attachments.
Public Property CanModifyField | Indicates if members or owners of the specified group can modify the specified field.
Public Property CanModifyItem | Indicates if members of the specified group can modify the specified entity.
Public Property CanRemoveItem | Indicates if members or owners of the specified group can remove the specified type of entity.
Public Property CanUseOwnerSensible | Checks if the fields of the specified entity can be restricted for owner modifications only.
Public Property HasAttachmentField | Checks if the entity specified by the EntityName parameter can have attachments.
Public Property IsVisibleInNewBug | Indicates if the specified Bug field is visible for the specified group in a new defect form.
Public Property TransitionRules | The transition rules for the specified field and group.


%%PageItemTitle%%

ICustomizationPermissions Interface

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

Group

The name of the group or a CustomizationUsersGroup Object.

See Also OTA COM Type Library

CanAddItem Property

Description

Indicates if members of the specified group can add the specified type of entity.

Property type

Read-write property

Syntax (Visual Basic)

Public Property CanAddItem( _
   ByVal EntityName As String, _
   ByVal Group As Variant _
) As Boolean

Parameters

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

Group

The name of the group or a CustomizationUsersGroup Object.

See Also

ICustomizationPermissions Interface


%%PageItemTitle%%

ICustomizationPermissions Interface

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

Group

The name of the group or a CustomizationUsersGroup Object.

See Also OTA COM Type Library

CanAllowAttachment Property

Description

Indicates if members owners of the specified group can handle the specified type of entity attachments.

Property type

Read-write property

Syntax (Visual Basic)

Public Property CanAllowAttachment( _
   ByVal EntityName As String, _
   ByVal Group As Variant _
) As Long

Parameters

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

Group

The name of the group or a CustomizationUsersGroup Object.

See Also

ICustomizationPermissions Interface


%%PageItemTitle%%

ICustomizationPermissions Interface

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

Field

The name of the field or a CustomizationField Object.

Group

The name of the group or a CustomizationUsersGroup Object.

See Also OTA COM Type Library

CanModifyField Property

Description

Indicates if members or owners of the specified group can modify the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property CanModifyField( _
   ByVal EntityName As String, _
   ByVal Field As Variant, _
   ByVal Group As Variant _
) As Long

Parameters

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

Field

The name of the field or a CustomizationField Object.

Group

The name of the group or a CustomizationUsersGroup Object.

See Also

ICustomizationPermissions Interface


%%PageItemTitle%%

ICustomizationPermissions Interface

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

Group

The name of the group or a CustomizationUsersGroup Object.

See Also OTA COM Type Library

CanModifyItem Property

Description

Indicates if members of the specified group can modify the specified entity.

Property type

Read-write property

Syntax (Visual Basic)

Public Property CanModifyItem( _
   ByVal EntityName As String, _
   ByVal Group As Variant _
) As Boolean

Parameters

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

Group

The name of the group or a CustomizationUsersGroup Object.

See Also

ICustomizationPermissions Interface


%%PageItemTitle%%

ICustomizationPermissions Interface

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

Group

The name of the group or a CustomizationUsersGroup Object.

See Also OTA COM Type Library

CanRemoveItem Property

Description

Indicates if members or owners of the specified group can remove the specified type of entity.

Property type

Read-write property

Syntax (Visual Basic)

Public Property CanRemoveItem( _
   ByVal EntityName As String, _
   ByVal Group As Variant _
) As Long

Parameters

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

Group

The name of the group or a CustomizationUsersGroup Object.

See Also

ICustomizationPermissions Interface


%%PageItemTitle%%

ICustomizationPermissions Interface

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

See Also OTA COM Type Library

CanUseOwnerSensible Property

Description

Checks if the fields of the specified entity can be restricted for owner modifications only.

Property type

Read-only property

Syntax (Visual Basic)

Public Property CanUseOwnerSensible( _
   ByVal EntityName As String _
) As Boolean

Parameters

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

See Also

ICustomizationPermissions Interface


%%PageItemTitle%%

ICustomizationPermissions Interface

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

See Also OTA COM Type Library

HasAttachmentField Property

Description

Checks if the entity specified by the EntityName parameter can have attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachmentField( _
   ByVal EntityName As String _
) As Boolean

Parameters

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

Remarks

An entity can have attachments only if it has an attachment field. This property does not indicate if the entity actually has attachments, only that it can.

See Also

ICustomizationPermissions Interface


%%PageItemTitle%%

ICustomizationPermissions Interface

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

Field

The name of the field or a CustomizationField Object.

Group

The name of the group or a CustomizationUsersGroup Object.

See Also OTA COM Type Library

IsVisibleInNewBug Property

Description

Indicates if the specified Bug field is visible for the specified group in a new defect form.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsVisibleInNewBug( _
   ByVal EntityName As String, _
   ByVal Field As Variant, _
   ByVal Group As Variant _
) As Boolean

Parameters

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

Field

The name of the field or a CustomizationField Object.

Group

The name of the group or a CustomizationUsersGroup Object.

See Also

ICustomizationPermissions Interface


%%PageItemTitle%%

ICustomizationPermissions Interface

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

Field

The name of the field or a CustomizationField Object.

Group

The name of the group or a CustomizationUsersGroup Object.

See Also OTA COM Type Library

TransitionRules Property

Description

The transition rules for the specified field and group.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TransitionRules( _
   ByVal EntityName As String, _
   ByVal Field As Variant, _
   ByVal Group As Variant _
) As Object

Parameters

EntityName

One of : ALL_LISTS, BUG, CROS_REF, CYCLE, CYCL_FOLD, DESSTEPS, GROUPS, HISTORY, HOSTS, HOST_GROUP, HOST_IN_GROUP, MAILCOND, REQ, RUN, STEP, TEST, TESTCYCL, TRAN_RULES, or USERS

Field

The name of the field or a CustomizationField Object.

Group

The name of the group or a CustomizationUsersGroup Object.

See Also

ICustomizationPermissions Interface


%%PageItemTitle%%

ICustomizationRBT Members

ICustomizationRBT Interface

Description

Customization of the RBT mechanism default values

Public Methods

Public Method AddBIQuestion | Creates a new Business Impact question.
Public Method AddFPQuestion | Creates a new Failure Probability question.
Public Method CalcBILevelByAnswersWeight | Calculate the business impact level from the sum of all the answers' weights.
Public Method CalcFPLevelByAnswersWeight | Calculate failure probability level ffrom the sum of all the answers' weights.
Public Method DeleteBIQuestion | Deletes the specified Business Impact question.
Public Method DeleteFPQuestion | Deletes the specified Failure Probability question.
Public Method TranslateBILevel | Translate BI from TDAPI_RBT_BI_LEVELS to its name in the database.
Public Method TranslateFPLevel | Translate FP from TDAPI_RBT_FP_LEVELS to its name in the database.
Public Method TranslateTestingLevel | Translate TL from TDAPI_RBT_TESTING_LEVELS to it's name in the database.

Public Properties

Public Property BILevelRiskLowerThreshold | The lower threshold of Risk assessment for each Business Impact level.
Public Property BIQuestionByID | Returns the Business Impact Question that has the specified ID.
Public Property BIQuestions | The list of Business Impact questions.
Public Property DisplayedTimeUnits | The time unit display string for calculations results.
Public Property FPLevelRiskLowerThreshold | The lower threshold of Risk assessment for each Failure Probability level.
Public Property FPLevelTestingEffortInHours | Hours needed to test a requirement with the given Failure Probability.
Public Property FPQuestionByID | Returns the Failure Probability Question that has the specified ID.
Public Property FPQuestions | The list of Failure Probability questions.
Public Property TestingLevelPercentage | Testing level percentage (of the full testing level).
Public Property TestingPolicyMatrix | Risk testing level matrix
Public Property Updated | Indicates if the RBT Customization has been modified since the last synchronization with the database.


%%PageItemTitle%%

ICustomizationRBT Interface

AddBIQuestion Method

Description

Creates a new Business Impact question.

Syntax

Public Function AddBIQuestion() As Object

See Also

ICustomizationRBT Interface


%%PageItemTitle%%

ICustomizationRBT Interface

AddFPQuestion Method

Description

Creates a new Failure Probability question.

Syntax

Public Function AddFPQuestion() As Object

See Also

ICustomizationRBT Interface


%%PageItemTitle%%

ICustomizationRBT Interface

AnswersWeight
See Also OTA COM Type Library

CalcBILevelByAnswersWeight Method

Description

Calculate the business impact level from the sum of all the answers' weights.

Syntax

Public Function CalcBILevelByAnswersWeight( _
   ByVal AnswersWeight As Long _
) As Long

Parameters

AnswersWeight

See Also

ICustomizationRBT Interface


%%PageItemTitle%%

ICustomizationRBT Interface

AnswersWeight
See Also OTA COM Type Library

CalcFPLevelByAnswersWeight Method

Description

Calculate failure probability level ffrom the sum of all the answers' weights.

Syntax

Public Function CalcFPLevelByAnswersWeight( _
   ByVal AnswersWeight As Long _
) As Long

Parameters

AnswersWeight

See Also

ICustomizationRBT Interface


%%PageItemTitle%%

ICustomizationRBT Interface

ID
See Also OTA COM Type Library

DeleteBIQuestion Method

Description

Deletes the specified Business Impact question.

Syntax

Public Sub DeleteBIQuestion( _
   ByVal ID As Long _
)

Parameters

ID

See Also

ICustomizationRBT Interface


%%PageItemTitle%%

ICustomizationRBT Interface

ID
See Also OTA COM Type Library

DeleteFPQuestion Method

Description

Deletes the specified Failure Probability question.

Syntax

Public Sub DeleteFPQuestion( _
   ByVal ID As Long _
)

Parameters

ID

See Also

ICustomizationRBT Interface


%%PageItemTitle%%

ICustomizationRBT Interface

BILevelEnum
See Also OTA COM Type Library

TranslateBILevel Method

Description

Translate BI from TDAPI_RBT_BI_LEVELS to its name in the database.

Syntax

Public Function TranslateBILevel( _
   ByVal BILevelEnum As Long _
) As String

Parameters

BILevelEnum

See Also

ICustomizationRBT Interface


%%PageItemTitle%%

ICustomizationRBT Interface

FPLevelEnum
See Also OTA COM Type Library

TranslateFPLevel Method

Description

Translate FP from TDAPI_RBT_FP_LEVELS to its name in the database.

Syntax

Public Function TranslateFPLevel( _
   ByVal FPLevelEnum As Long _
) As String

Parameters

FPLevelEnum

See Also

ICustomizationRBT Interface


%%PageItemTitle%%

ICustomizationRBT Interface

TestingLevelEnum
See Also OTA COM Type Library

TranslateTestingLevel Method

Description

Translate TL from TDAPI_RBT_TESTING_LEVELS to it's name in the database.

Syntax

Public Function TranslateTestingLevel( _
   ByVal TestingLevelEnum As Long _
) As String

Parameters

TestingLevelEnum

See Also

ICustomizationRBT Interface


%%PageItemTitle%%

ICustomizationRBT Interface

BILevel
The business implact level.
See Also OTA COM Type Library

BILevelRiskLowerThreshold Property

Description

The lower threshold of Risk assessment for each Business Impact level.

Property type

Read-write property

Syntax (Visual Basic)

Public Property BILevelRiskLowerThreshold( _
   ByVal BILevel As Long _
) As Long

Parameters

BILevel
The business implact level.

See Also

ICustomizationRBT Interface


%%PageItemTitle%%

ICustomizationRBT Interface

ID
See Also OTA COM Type Library

BIQuestionByID Property

Description

Returns the Business Impact Question that has the specified ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BIQuestionByID( _
   ByVal ID As Long _
) As Object

Parameters

ID

See Also

ICustomizationRBT Interface


%%PageItemTitle%%

ICustomizationRBT Interface

BIQuestions Property

Description

The list of Business Impact questions.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BIQuestions() As List

See Also

ICustomizationRBT Interface


%%PageItemTitle%%

ICustomizationRBT Interface

DisplayedTimeUnits Property

Description

The time unit display string for calculations results.

Property type

Read-write property

Syntax (Visual Basic)

Public Property DisplayedTimeUnits() As String

See Also

ICustomizationRBT Interface


%%PageItemTitle%%

ICustomizationRBT Interface

FPLevel
The failure probability level.
See Also OTA COM Type Library

FPLevelRiskLowerThreshold Property

Description

The lower threshold of Risk assessment for each Failure Probability level.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FPLevelRiskLowerThreshold( _
   ByVal FPLevel As Long _
) As Long

Parameters

FPLevel
The failure probability level.

See Also

ICustomizationRBT Interface


%%PageItemTitle%%

ICustomizationRBT Interface

FPLevel
The failure probability level.
See Also OTA COM Type Library

FPLevelTestingEffortInHours Property

Description

Hours needed to test a requirement with the given Failure Probability.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FPLevelTestingEffortInHours( _
   ByVal FPLevel As Long _
) As Long

Parameters

FPLevel
The failure probability level.

See Also

ICustomizationRBT Interface


%%PageItemTitle%%

ICustomizationRBT Interface

ID
See Also OTA COM Type Library

FPQuestionByID Property

Description

Returns the Failure Probability Question that has the specified ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FPQuestionByID( _
   ByVal ID As Long _
) As Object

Parameters

ID

See Also

ICustomizationRBT Interface


%%PageItemTitle%%

ICustomizationRBT Interface

FPQuestions Property

Description

The list of Failure Probability questions.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FPQuestions() As List

See Also

ICustomizationRBT Interface


%%PageItemTitle%%

ICustomizationRBT Interface

TestingLevel
See Also OTA COM Type Library

TestingLevelPercentage Property

Description

Testing level percentage (of the full testing level).

Property type

Read-write property

Syntax (Visual Basic)

Public Property TestingLevelPercentage( _
   ByVal TestingLevel As Long _
) As Long

Parameters

TestingLevel

See Also

ICustomizationRBT Interface


%%PageItemTitle%%

ICustomizationRBT Interface

BILevel
The business implact level.
FPLevel
The failure probability level.
See Also OTA COM Type Library

TestingPolicyMatrix Property

Description

Risk testing level matrix

Property type

Read-write property

Syntax (Visual Basic)

Public Property TestingPolicyMatrix( _
   ByVal BILevel As Long, _
   ByVal FPLevel As Long _
) As Long

Parameters

BILevel
The business implact level.
FPLevel
The failure probability level.

See Also

ICustomizationRBT Interface


%%PageItemTitle%%

ICustomizationRBT Interface

Updated Property

Description

Indicates if the RBT Customization has been modified since the last synchronization with the database.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Updated() As Boolean

See Also

ICustomizationRBT Interface


%%PageItemTitle%%

ICustomizationRBTAnswer Members

ICustomizationRBTAnswer Interface

Description

A possible answer for a business implact or failure probablity question, used to assess a risk.

Public Properties

Public Property AnswerText | The answer's text.
Public Property AnswerWeight | The answer's weight.
Public Property ID | The CustomizationRBTAnswer unique ID.


%%PageItemTitle%%

ICustomizationRBTAnswer Interface

AnswerText Property

Description

The answer's text.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AnswerText() As String

See Also

ICustomizationRBTAnswer Interface


%%PageItemTitle%%

ICustomizationRBTAnswer Interface

AnswerWeight Property

Description

The answer's weight.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AnswerWeight() As Long

See Also

ICustomizationRBTAnswer Interface


%%PageItemTitle%%

ICustomizationRBTAnswer Interface

ID Property

Description

The CustomizationRBTAnswer unique ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Long

See Also

ICustomizationRBTAnswer Interface


%%PageItemTitle%%

ICustomizationRBTQuestion Members

ICustomizationRBTQuestion Interface

Description

A business impact or failure probability question, used to assess a risk.

Public Methods

Public Method AddAnswer | Adds a new possible answer. Returns the new answer as a CustomizationRBTAnswer object
Public Method DeleteAnswer | Deletes a possible answer specified by id.

Public Properties

Public Property AnswerByID | Returns the specified Answer.
Public Property Answers | The IList of CustomizationRBTAnswer objects of all possible answers for this question.
Public Property ID | The CustomizationRBTQuestion unique ID.
Public Property QuestionDescription | The question's description.
Public Property QuestionOrder | The (non unique) question's order of display in UI.
Public Property QuestionText | The question's text.


%%PageItemTitle%%

ICustomizationRBTQuestion Interface

AddAnswer Method

Description

Adds a new possible answer. Returns the new answer as a CustomizationRBTAnswer object

Syntax

Public Function AddAnswer() As Object

See Also

ICustomizationRBTQuestion Interface


%%PageItemTitle%%

ICustomizationRBTQuestion Interface

ID
See Also OTA COM Type Library

DeleteAnswer Method

Description

Deletes a possible answer specified by id.

Syntax

Public Sub DeleteAnswer( _
   ByVal ID As Long _
)

Parameters

ID

See Also

ICustomizationRBTQuestion Interface


%%PageItemTitle%%

ICustomizationRBTQuestion Interface

ID
See Also OTA COM Type Library

AnswerByID Property

Description

Returns the specified Answer.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AnswerByID( _
   ByVal ID As Long _
) As Object

Parameters

ID

See Also

ICustomizationRBTQuestion Interface


%%PageItemTitle%%

ICustomizationRBTQuestion Interface

Answers Property

Description

The IList of CustomizationRBTAnswer objects of all possible answers for this question.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Answers() As List

See Also

ICustomizationRBTQuestion Interface


%%PageItemTitle%%

ICustomizationRBTQuestion Interface

ID Property

Description

The CustomizationRBTQuestion unique ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Long

See Also

ICustomizationRBTQuestion Interface


%%PageItemTitle%%

ICustomizationRBTQuestion Interface

QuestionDescription Property

Description

The question's description.

Property type

Read-write property

Syntax (Visual Basic)

Public Property QuestionDescription() As String

See Also

ICustomizationRBTQuestion Interface


%%PageItemTitle%%

ICustomizationRBTQuestion Interface

QuestionOrder Property

Description

The (non unique) question's order of display in UI.

Property type

Read-write property

Syntax (Visual Basic)

Public Property QuestionOrder() As Long

See Also

ICustomizationRBTQuestion Interface


%%PageItemTitle%%

ICustomizationRBTQuestion Interface

QuestionText Property

Description

The question's text.

Property type

Read-write property

Syntax (Visual Basic)

Public Property QuestionText() As String

See Also

ICustomizationRBTQuestion Interface


%%PageItemTitle%%

ICustomizationReqType Members

ICustomizationReqType Interface

Description

A Customization type of the requirement entity.

Remarks

Requirement types serve to categorize requirements. For example, types may include Business, Functional, Testing, and so on. For the list of types defined in your project, look at the Requirement Type custom list.

Get a reference to a CustomizationReqType with CustomizationTypes.GetEntityCustomizationType or from the list returned by CustomizationTypes.GetEntityCustomizationTypes.

Public Methods

Public Method AddField | Adds a new CustomizationTypedField.
Public Method RemoveField | Removes the CustomizationTypedField specified by FieldName from this type.

Public Properties

Public Property Field | Gets the CustomizationTypedField specified by FieldName.
Public Property Fields | The list of CustomizationTypedField objects for this type.
Public Property HasDirectCoverage | Indicates if this requirement type supports direct coverage by tests or test instances.
Public Property Icon | The bitmap stream for type icon.
Public Property ID | The CustomizationType ID.
Public Property Name | The CustomizationType name.
Public Property RiskAnalysisType | The Type of the RBT Risk Analysis that is applicable to this requirement.


%%PageItemTitle%%

ICustomizationReqType Interface

NewFieldName

The name of a field in the REQ table.

See Also OTA COM Type Library

AddField Method

Description

Adds a new CustomizationTypedField.

Syntax

Public Function AddField( _
   ByVal NewFieldName As String _
) As Object

Parameters

NewFieldName

The name of a field in the REQ table.

Remarks

When AddField is called, a CustomizationTypedField object is created that links the specified field back to the CustomizationReqType. After the call, the new CustomizationTypedField is in the list returned by the Fields property.

See Also

ICustomizationReqType Interface


%%PageItemTitle%%

ICustomizationReqType Interface

FieldName

The name of a field in the REQ table.

See Also OTA COM Type Library

RemoveField Method

Description

Removes the CustomizationTypedField specified by FieldName from this type.

Syntax

Public Sub RemoveField( _
   ByVal FieldName As String _
)

Parameters

FieldName

The name of a field in the REQ table.

See Also

ICustomizationReqType Interface


%%PageItemTitle%%

ICustomizationReqType Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

Gets the CustomizationTypedField specified by FieldName.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Object

Parameters

FieldName
The name of the field in the project database.

See Also

ICustomizationReqType Interface


%%PageItemTitle%%

ICustomizationReqType Interface

Fields Property

Description

The list of CustomizationTypedField objects for this type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

ICustomizationReqType Interface


%%PageItemTitle%%

ICustomizationReqType Interface

HasDirectCoverage Property

Description

Indicates if this requirement type supports direct coverage by tests or test instances.

Property type

Read-write property

Syntax (Visual Basic)

Public Property HasDirectCoverage() As Boolean

See Also

ICustomizationReqType Interface


%%PageItemTitle%%

ICustomizationReqType Interface

Icon Property

Description

The bitmap stream for type icon.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Icon() As IStream

See Also

ICustomizationReqType Interface


%%PageItemTitle%%

ICustomizationReqType Interface

ID Property

Description

The CustomizationType ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Long

See Also

ICustomizationReqType Interface


%%PageItemTitle%%

ICustomizationReqType Interface

Name Property

Description

The CustomizationType name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ICustomizationReqType Interface


%%PageItemTitle%%

ICustomizationReqType Interface

RiskAnalysisType Property

Description

The Type of the RBT Risk Analysis that is applicable to this requirement.

Property type

Read-write property

Syntax (Visual Basic)

Public Property RiskAnalysisType() As Long

Get or Set Value Type

A value of the tagTDAPI_RBT_REQUIREMENT_TYPE_RISK_ANALYSIS_TYPE Enumeration..

See Also

ICustomizationReqType Interface


%%PageItemTitle%%

ICustomizationTransitionRule Members

ICustomizationTransitionRule Interface

Description

Represents a single transition rule. A transition rule allows a change in value from a given source value to a given destination value.

Remarks

Defines a permitted change from a SourceValue to a DestinationValue. The group, entity, and field to which the values apply are taken from the CustomizationTransitionRules Object from which the reference to this CustomizationTransitionRule Object was obtained.

Public Properties

Public Property DestinationValue | The destination value of the transition rule, that is, the value after the change.
Public Property SourceValue | The source value of the transition rule, that is, the value before the change.
Public Property Updated | Indicates if the object has been modified since last synchronized with server.


%%PageItemTitle%%

ICustomizationTransitionRule Interface

DestinationValue Property

Description

The destination value of the transition rule, that is, the value after the change.

Property type

Read-write property

Syntax (Visual Basic)

Public Property DestinationValue() As String

See Also

ICustomizationTransitionRule Interface


%%PageItemTitle%%

ICustomizationTransitionRule Interface

SourceValue Property

Description

The source value of the transition rule, that is, the value before the change.

Property type

Read-write property

Syntax (Visual Basic)

Public Property SourceValue() As String

See Also

ICustomizationTransitionRule Interface


%%PageItemTitle%%

ICustomizationTransitionRule Interface

Updated Property

Description

Indicates if the object has been modified since last synchronized with server.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Updated() As Boolean

See Also

ICustomizationTransitionRule Interface


%%PageItemTitle%%

ICustomizationTransitionRules Members | CustomizationTransitionRule Object

See Also OTA COM Type Library

ICustomizationTransitionRules Interface

Description

A collection of CustomizationTransitionRule objects applied to a specific field and user group.

Remarks

Get a CustomizationTransitionRules object from the CustomizationPermissions Object.

Public Methods

Public Method AddTransitionRule | Adds a new CustomizationTransitionRule to the current object.
Public Method RemoveTransitionRule | Removes the specified transition rule from the current object.

Public Properties

Public Property Count | The number of CustomizationTransitionRule objects contained by the current object.
Public Property EntityName | The location (database table) of the field to which the transition rules in the current object are attached.
Public Property Field | The CustomizationField object to which the transition rules in the current object are attached.
Public Property Group | The CustomizationUsersGroup object to which the transition rules in the current object are attached.
Public Property TransitionRule | The CustomizationTransitionRule specified by its position in the list of transition rules.
Public Property Updated | Indicates if the object has been modified since the last synchronization with database.


%%PageItemTitle%%

ICustomizationTransitionRules Interface

AddTransitionRule Method

Description

Adds a new CustomizationTransitionRule to the current object.

Syntax

Public Function AddTransitionRule() As Object

Return Type

The new CustomizationTransitionRule Object.

Remarks

The new transition rule created with this method is open: it is possible to change the field from any value to any other value. Thus, the rule has no effect until the source and destination values are set.
To define the source and destination values, set the SourceValue and DestinationValue of the new CustomizationTransitionRule object.

See Also

ICustomizationTransitionRules Interface


%%PageItemTitle%%

ICustomizationTransitionRules Interface

Rule

Either the position (zero-based) in the CustomTransitionRules collection, or a CustomizationTransitionRule Object.

See Also OTA COM Type Library

RemoveTransitionRule Method

Description

Removes the specified transition rule from the current object.

Syntax

Public Sub RemoveTransitionRule( _
   ByVal Rule As Variant _
)

Parameters

Rule

Either the position (zero-based) in the CustomTransitionRules collection, or a CustomizationTransitionRule Object.

See Also

ICustomizationTransitionRules Interface


%%PageItemTitle%%

ICustomizationTransitionRules Interface

Count Property

Description

The number of CustomizationTransitionRule objects contained by the current object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

ICustomizationTransitionRules Interface


%%PageItemTitle%%

ICustomizationTransitionRules Interface

EntityName Property

Description

The location (database table) of the field to which the transition rules in the current object are attached.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EntityName() As String

See Also

ICustomizationTransitionRules Interface


%%PageItemTitle%%

ICustomizationTransitionRules Interface

Field Property

Description

The CustomizationField object to which the transition rules in the current object are attached.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Field() As Object

See Also

ICustomizationTransitionRules Interface


%%PageItemTitle%%

ICustomizationTransitionRules Interface

Group Property

Description

The CustomizationUsersGroup object to which the transition rules in the current object are attached.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Group() As Object

See Also

ICustomizationTransitionRules Interface


%%PageItemTitle%%

ICustomizationTransitionRules Interface

Position

The position in the list of transition rules (1-based).

See Also OTA COM Type Library

TransitionRule Property

Description

The CustomizationTransitionRule specified by its position in the list of transition rules.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TransitionRule( _
   ByVal Position As Long _
) As Object

Parameters

Position

The position in the list of transition rules (1-based).

See Also

ICustomizationTransitionRules Interface


%%PageItemTitle%%

ICustomizationTransitionRules Interface

Updated Property

Description

Indicates if the object has been modified since the last synchronization with database.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Updated() As Boolean

See Also

ICustomizationTransitionRules Interface


%%PageItemTitle%%

ICustomizationType Members

ICustomizationType Interface

Description

Represents a Customization type of an entity.

Remarks

Customization types serve to categorize items of the entity type to which they apply. For example, requirement types may include Documentation, Software, Test, and so on. For the details of types defined in your project, look at the custom lists.

An example of a customization type is CustomizationReqType.

Public Methods

Public Method AddField | Adds a new CustomizationTypedField.
Public Method RemoveField | Removes the CustomizationTypedField specified by FieldName from this type.

Public Properties

Public Property Field | Gets the CustomizationTypedField specified by FieldName.
Public Property Fields | The list of CustomizationTypedField objects for this type.
Public Property Icon | The bitmap stream for type icon.
Public Property ID | The CustomizationType ID.
Public Property Name | The CustomizationType name.


%%PageItemTitle%%

ICustomizationType Interface

NewFieldName
The name of a field in the entity table.
See Also OTA COM Type Library

AddField Method

Description

Adds a new CustomizationTypedField.

Syntax

Public Function AddField( _
   ByVal NewFieldName As String _
) As Object

Parameters

NewFieldName
The name of a field in the entity table.

Return Type

When AddField is called, a CustomizationTypedField Object is created that links the specified field back to the customization type. After the call, the new CustomizationTypedField is in the list returned by the Fields property.

See Also

ICustomizationType Interface


%%PageItemTitle%%

ICustomizationType Interface

FieldName

The name of a field in the entity's table.

See Also OTA COM Type Library

RemoveField Method

Description

Removes the CustomizationTypedField specified by FieldName from this type.

Syntax

Public Sub RemoveField( _
   ByVal FieldName As String _
)

Parameters

FieldName

The name of a field in the entity's table.

See Also

ICustomizationType Interface


%%PageItemTitle%%

ICustomizationType Interface

FieldName

The name of a field in the entity's table.

See Also OTA COM Type Library

Field Property

Description

Gets the CustomizationTypedField specified by FieldName.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Object

Parameters

FieldName

The name of a field in the entity's table.

Get or Set Value Type

A CustomizationTypedField Object.

See Also

ICustomizationType Interface


%%PageItemTitle%%

ICustomizationType Interface

Fields Property

Description

The list of CustomizationTypedField objects for this type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

ICustomizationType Interface


%%PageItemTitle%%

ICustomizationType Interface

Icon Property

Description

The bitmap stream for type icon.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Icon() As IStream

See Also

ICustomizationType Interface


%%PageItemTitle%%

ICustomizationType Interface

ID Property

Description

The CustomizationType ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Long

See Also

ICustomizationType Interface


%%PageItemTitle%%

ICustomizationType Interface

Name Property

Description

The CustomizationType name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ICustomizationType Interface


%%PageItemTitle%%

ICustomizationTypedField Members

ICustomizationTypedField Interface

Description

An association between a CustomizationField and an object of a class that implements ICustomizationType.

Remarks

Get a reference to CustomizationTypedField with the Field Property of an object of a class that implements ICustomizationType, for example, CustomizationReqType. You can also get a reference from the list returned by ICustomizationType.Fields.

Public Properties

Public Property Field | Gets the CustomizationField associated with this object.
Public Property IsRequired | Indicates whether the field is required for the specific type.
Public Property Type | Gets the CustomizationType associated with this object.


%%PageItemTitle%%

ICustomizationTypedField Interface

Field Property

Description

Gets the CustomizationField associated with this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Field() As Object

Get or Set Value Type

A CustomizationField Object.

See Also

ICustomizationTypedField Interface


%%PageItemTitle%%

ICustomizationTypedField Interface

IsRequired Property

Description

Indicates whether the field is required for the specific type.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsRequired() As Boolean

See Also

ICustomizationTypedField Interface


%%PageItemTitle%%

ICustomizationTypedField Interface

Type Property

Description

Gets the CustomizationType associated with this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Type() As Object

Get or Set Value Type

An ICustomizationType Reference.

See Also

ICustomizationTypedField Interface


%%PageItemTitle%%

ICustomizationTypes Members

ICustomizationTypes Interface

Description

A collection of Customization types of a specific entity. For example, the types of the requirement entity.

Remarks

Get a CustomizationTypes reference from Customization.Types.

Public Methods

Public Method AddCustomizationType | Adds a new CustomizationType to the specified entity.
Public Method GetEntityCustomizationType | Gets the CustomizationType with the specified ID.
Public Method GetEntityCustomizationTypes | Gets the list of all CustomizationTypes for the specified entity.
Public Method RemoveCustomizationType | Removes the CustomizationType with the specified ID from the specified entity.


%%PageItemTitle%%

ICustomizationTypes Interface

EntityType

A value of the TDAPI_ENTITIES Enumeration.

Name

The name of the new type.

CreateAsTypeId

A ICustomizationType.ID. This is the ID of an object of a class that implements ICustomizationType, for example, a CustomizationReqType.ID.

See Also OTA COM Type Library

AddCustomizationType Method

Description

Adds a new CustomizationType to the specified entity.

Syntax

Public Function AddCustomizationType( _
   ByVal EntityType As Long, _
   ByVal Name As String, _
   ByVal CreateAsTypeId As Long _
) As Object

Parameters

EntityType

A value of the TDAPI_ENTITIES Enumeration.

Name

The name of the new type.

CreateAsTypeId

A ICustomizationType.ID. This is the ID of an object of a class that implements ICustomizationType, for example, a CustomizationReqType.ID.

Remarks

The new type is created as a copy of the type specified with CreateAsTypeId. You can then change the properties as appropriate.

See Also

ICustomizationTypes Interface


%%PageItemTitle%%

ICustomizationTypes Interface

EntityType

A value of the TDAPI_ENTITIES Enumeration.

CustomizationTypeId

A ICustomizationType.ID. This is the ID of an object of a class that implements ICustomizationType, for example, a CustomizationReqType.ID.

See Also OTA COM Type Library

GetEntityCustomizationType Method

Description

Gets the CustomizationType with the specified ID.

Syntax

Public Function GetEntityCustomizationType( _
   ByVal EntityType As Long, _
   ByVal CustomizationTypeId As Long _
) As Object

Parameters

EntityType

A value of the TDAPI_ENTITIES Enumeration.

CustomizationTypeId

A ICustomizationType.ID. This is the ID of an object of a class that implements ICustomizationType, for example, a CustomizationReqType.ID.

Return Type

A list of ICustomizationType Objects

See Also

ICustomizationTypes Interface


%%PageItemTitle%%

ICustomizationTypes Interface

EntityType

A value of the TDAPI_ENTITIES Enumeration.

See Also OTA COM Type Library

GetEntityCustomizationTypes Method

Description

Gets the list of all CustomizationTypes for the specified entity.

Syntax

Public Function GetEntityCustomizationTypes( _
   ByVal EntityType As Long _
) As List

Parameters

EntityType

A value of the TDAPI_ENTITIES Enumeration.

See Also

ICustomizationTypes Interface


%%PageItemTitle%%

ICustomizationTypes Interface

EntityType

A value of the TDAPI_ENTITIES Enumeration.

CustomizationTypeId

A ICustomizationType.ID. This is the ID of an object of a class that implements ICustomizationType, for example, a CustomizationReqType.ID.

See Also OTA COM Type Library

RemoveCustomizationType Method

Description

Removes the CustomizationType with the specified ID from the specified entity.

Syntax

Public Sub RemoveCustomizationType( _
   ByVal EntityType As Long, _
   ByVal CustomizationTypeId As Long _
)

Parameters

EntityType

A value of the TDAPI_ENTITIES Enumeration.

CustomizationTypeId

A ICustomizationType.ID. This is the ID of an object of a class that implements ICustomizationType, for example, a CustomizationReqType.ID.

Return Type

A list of ICustomizationType Objects

See Also

ICustomizationTypes Interface


%%PageItemTitle%%

ICustomizationUser Members

ICustomizationUser Interface

Description

Represents a user for purposes of adding and removing the user to and from user groups.

Remarks

Get a CustomizationUser object with the CustomizationUsers Object.

Public Methods

Public Method AddToGroup | Adds this user to the specified user group.
Public Method GroupsList | The names of all the user groups to which this user belongs.
Public Method RemoveFromGroup | Removes this user from the specified user group.

Public Properties

Public Property Address | A text field that can be used to record user information as appropriate for the project.
Public Property Deleted | If true, this user is marked for deletion, but the deletion is not yet committed.
Public Property DomainAuthentication | The user credentials for LDAP authentication.
Public Property Email | The user's e-mail address.
Public Property FullName | The user's full name.
Public Property InGroup | Indicates if this user is a member of the specified group.
Public Property Name | A unique name by which to identify this user.
Public Property Password | Sets the user's password.
Public Property Phone | The user's telephone number.
Public Property Updated | Indicates if the user's data was updated since the last synchronization with the server.


%%PageItemTitle%%

ICustomizationUser Interface

Group

The name of the group or a CustomizationUsersGroup Object.

See Also OTA COM Type Library

AddToGroup Method

Description

Adds this user to the specified user group.

Syntax

Public Sub AddToGroup( _
   ByVal Group As Variant _
)

Parameters

Group

The name of the group or a CustomizationUsersGroup Object.

See Also

ICustomizationUser Interface


%%PageItemTitle%%

ICustomizationUser Interface

GroupsList Method

Description

The names of all the user groups to which this user belongs.

Syntax

Public Function GroupsList() As List

See Also

ICustomizationUser Interface


%%PageItemTitle%%

ICustomizationUser Interface

Group

The name of the group or a CustomizationUsersGroup Object.

See Also OTA COM Type Library

RemoveFromGroup Method

Description

Removes this user from the specified user group.

Syntax

Public Sub RemoveFromGroup( _
   ByVal Group As Variant _
)

Parameters

Group

The name of the group or a CustomizationUsersGroup Object.

See Also

ICustomizationUser Interface


%%PageItemTitle%%

ICustomizationUser Interface

Address Property

Description

A text field that can be used to record user information as appropriate for the project.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Address() As String

See Also

ICustomizationUser Interface


%%PageItemTitle%%

ICustomizationUser Interface

Deleted Property

Description

If true, this user is marked for deletion, but the deletion is not yet committed.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Deleted() As Boolean

See Also

ICustomizationUser Interface


%%PageItemTitle%%

ICustomizationUser Interface

DomainAuthentication Property

Description

The user credentials for LDAP authentication.

Property type

Read-write property

Syntax (Visual Basic)

Public Property DomainAuthentication() As String

See Also

ICustomizationUser Interface


%%PageItemTitle%%

ICustomizationUser Interface

Email Property

Description

The user's e-mail address.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Email() As String

See Also

ICustomizationUser Interface


%%PageItemTitle%%

ICustomizationUser Interface

FullName Property

Description

The user's full name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FullName() As String

See Also

ICustomizationUser Interface


%%PageItemTitle%%

ICustomizationUser Interface

GroupName

The name of the group or a CustomizationUsersGroup Object.

See Also OTA COM Type Library

InGroup Property

Description

Indicates if this user is a member of the specified group.

Property type

Read-write property

Syntax (Visual Basic)

Public Property InGroup( _
   ByVal GroupName As Variant _
) As Boolean

Parameters

GroupName

The name of the group or a CustomizationUsersGroup Object.

See Also

ICustomizationUser Interface


%%PageItemTitle%%

ICustomizationUser Interface

Name Property

Description

A unique name by which to identify this user.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ICustomizationUser Interface


%%PageItemTitle%%

ICustomizationUser Interface

RHS

The password.

See Also OTA COM Type Library

Password Property

Description

Sets the user's password.

Property type

Write-only property

Syntax (Visual Basic)

Public Property Password( _
   ByVal RHS As String _
) As String

Parameters

RHS

The password.

Remarks

The password is entered literally. It is encoded automatically when sent from the workstation to the server.

See Also

ICustomizationUser Interface


%%PageItemTitle%%

ICustomizationUser Interface

Phone Property

Description

The user's telephone number.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Phone() As String

See Also

ICustomizationUser Interface


%%PageItemTitle%%

ICustomizationUser Interface

Updated Property

Description

Indicates if the user's data was updated since the last synchronization with the server.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Updated() As Boolean

See Also

ICustomizationUser Interface


%%PageItemTitle%%

ICustomizationUsers Members

ICustomizationUsers Interface

Description

Services for managing the collection of all CustomizationUser objects.

Remarks

Get the CustomizationUsers collection from the Customization Object.

Public Methods

Public Method AddSiteAuthenticatedUser | Adds site user with credentials for LDAP authentication.
Public Method AddSiteUser | Creates a new site user and adds it to the current project.
Public Method AddUser | Adds an existing site user to the current project.
Public Method RemoveUser | Removes a user from the collection.

Public Properties

Public Property User | The CustomizationUser object representing the specified user.
Public Property Users | The list of customization users.


%%PageItemTitle%%

ICustomizationUsers Interface

UserName

The name of the user to be added.

FullName

The full name of the user to be added.

Email

The e-mail address of the user to be added.

Description

A description of the user to be added

Phone

The phone number of the user to be added.

DomainAuthentication

The identifier of the user in an external User directory, for example the distinguished name in LDAP.

Group

The group to which the added user belongs. Pass either the group name or a CustomizationUsersGroup Object.

See Also OTA COM Type Library

AddSiteAuthenticatedUser Method

Description

Adds site user with credentials for LDAP authentication.

Syntax

Public Sub AddSiteAuthenticatedUser( _
   ByVal UserName As String, _
   ByVal FullName As String, _
   ByVal Email As String, _
   ByVal Description As String, _
   ByVal Phone As String, _
   ByVal DomainAuthentication As String, _
   ByVal Group As Variant _
)

Parameters

UserName

The name of the user to be added.

FullName

The full name of the user to be added.

Email

The e-mail address of the user to be added.

Description

A description of the user to be added

Phone

The phone number of the user to be added.

DomainAuthentication

The identifier of the user in an external User directory, for example the distinguished name in LDAP.

Group

The group to which the added user belongs. Pass either the group name or a CustomizationUsersGroup Object.

Remarks

This method creates a CustomizationUser object and adds it to the site and to the current project. The new user is only memory-resident until Customization.Commit is called.

See Also

ICustomizationUsers Interface


%%PageItemTitle%%

ICustomizationUsers Interface

UserName

The name of the user to be added.

FullName

The full name of the user to be added.

Email

The e-mail address of the user to be added.

Description

A description of the user to be added.

Phone

The phone number of the user to be added.

Group

The group to which the added user belongs. Pass either the group name or a CustomizationUsersGroup Object.

See Also OTA COM Type Library

AddSiteUser Method

Description

Creates a new site user and adds it to the current project.

Syntax

Public Sub AddSiteUser( _
   ByVal UserName As String, _
   ByVal FullName As String, _
   ByVal Email As String, _
   ByVal Description As String, _
   ByVal Phone As String, _
   ByVal Group As Variant _
)

Parameters

UserName

The name of the user to be added.

FullName

The full name of the user to be added.

Email

The e-mail address of the user to be added.

Description

A description of the user to be added.

Phone

The phone number of the user to be added.

Group

The group to which the added user belongs. Pass either the group name or a CustomizationUsersGroup Object.

Remarks

This method creates a CustomizationUser object and adds it to the site and to the current project. The new user is only memory-resident until Customization.Commit is called.

See Also

ICustomizationUsers Interface


%%PageItemTitle%%

ICustomizationUsers Interface

Name

The name of the user to be added.

See Also OTA COM Type Library

AddUser Method

Description

Adds an existing site user to the current project.

Syntax

Public Function AddUser( _
   ByVal Name As String _
) As Object

Parameters

Name

The name of the user to be added.

Return Type

A CustomizationUser object.

See Also

ICustomizationUsers Interface


%%PageItemTitle%%

ICustomizationUsers Interface

Name

The name of the user to be removed.

See Also OTA COM Type Library

RemoveUser Method

Description

Removes a user from the collection.

Syntax

Public Sub RemoveUser( _
   ByVal Name As String _
)

Parameters

Name

The name of the user to be removed.

Remarks

The deletion takes effect when Customization.Commit is called.

See Also

ICustomizationUsers Interface


%%PageItemTitle%%

ICustomizationUsers Interface

Name

The user name.

See Also OTA COM Type Library

User Property

Description

The CustomizationUser object representing the specified user.

Property type

Read-only property

Syntax (Visual Basic)

Public Property User( _
   ByVal Name As String _
) As Object

Parameters

Name

The user name.

See Also

ICustomizationUsers Interface


%%PageItemTitle%%

ICustomizationUsers Interface

Users Property

Description

The list of customization users.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Users() As List

See Also

ICustomizationUsers Interface


%%PageItemTitle%%

ICustomizationUsers2 Members

ICustomizationUsers2 Interface

Description

Services for managing the collection of all CustomizationUser objects.

Remarks

Get the CustomizationUsers collection from the Customization Object.

Public Methods

Public Method AddSiteAuthenticatedUser | Adds site user with credentials for LDAP authentication.
Public Method AddSiteUser | Creates a new site user and adds it to the current project.
Public Method AddUser | Adds an existing site user to the current project.
Public Method RemoveUser | Removes a user from the collection.
Public Method UserExistsInSite | Checks whether the specified site user exists.

Public Properties

Public Property User | The CustomizationUser object representing the specified user.
Public Property Users | The list of customization users.


%%PageItemTitle%%

ICustomizationUsers2 Interface

UserName

The name of the user to be added.

FullName

The full name of the user to be added.

Email

The e-mail address of the user to be added.

Description

A description of the user to be added

Phone

The phone number of the user to be added.

DomainAuthentication

The identifier of the user in an external User directory, for example the distinguished name in LDAP.

Group

The group to which the added user belongs. Pass either the group name or a CustomizationUsersGroup Object.

See Also OTA COM Type Library

AddSiteAuthenticatedUser Method

Description

Adds site user with credentials for LDAP authentication.

Syntax

Public Sub AddSiteAuthenticatedUser( _
   ByVal UserName As String, _
   ByVal FullName As String, _
   ByVal Email As String, _
   ByVal Description As String, _
   ByVal Phone As String, _
   ByVal DomainAuthentication As String, _
   ByVal Group As Variant _
)

Parameters

UserName

The name of the user to be added.

FullName

The full name of the user to be added.

Email

The e-mail address of the user to be added.

Description

A description of the user to be added

Phone

The phone number of the user to be added.

DomainAuthentication

The identifier of the user in an external User directory, for example the distinguished name in LDAP.

Group

The group to which the added user belongs. Pass either the group name or a CustomizationUsersGroup Object.

Remarks

This method creates a CustomizationUser object and adds it to the site and to the current project. The new user is only memory-resident until Customization.Commit is called.

See Also

ICustomizationUsers2 Interface


%%PageItemTitle%%

ICustomizationUsers2 Interface

UserName

The name of the user to be added.

FullName

The full name of the user to be added.

Email

The e-mail address of the user to be added.

Description

A description of the user to be added.

Phone

The phone number of the user to be added.

Group

The group to which the added user belongs. Pass either the group name or a CustomizationUsersGroup Object.

See Also OTA COM Type Library

AddSiteUser Method

Description

Creates a new site user and adds it to the current project.

Syntax

Public Sub AddSiteUser( _
   ByVal UserName As String, _
   ByVal FullName As String, _
   ByVal Email As String, _
   ByVal Description As String, _
   ByVal Phone As String, _
   ByVal Group As Variant _
)

Parameters

UserName

The name of the user to be added.

FullName

The full name of the user to be added.

Email

The e-mail address of the user to be added.

Description

A description of the user to be added.

Phone

The phone number of the user to be added.

Group

The group to which the added user belongs. Pass either the group name or a CustomizationUsersGroup Object.

Remarks

This method creates a CustomizationUser object and adds it to the site and to the current project. The new user is only memory-resident until Customization.Commit is called.

See Also

ICustomizationUsers2 Interface


%%PageItemTitle%%

ICustomizationUsers2 Interface

Name

The name of the user to be added.

See Also OTA COM Type Library

AddUser Method

Description

Adds an existing site user to the current project.

Syntax

Public Function AddUser( _
   ByVal Name As String _
) As Object

Parameters

Name

The name of the user to be added.

Return Type

A CustomizationUser object.

See Also

ICustomizationUsers2 Interface


%%PageItemTitle%%

ICustomizationUsers2 Interface

Name

The name of the user to be removed.

See Also OTA COM Type Library

RemoveUser Method

Description

Removes a user from the collection.

Syntax

Public Sub RemoveUser( _
   ByVal Name As String _
)

Parameters

Name

The name of the user to be removed.

Remarks

The deletion takes effect when Customization.Commit is called.

See Also

ICustomizationUsers2 Interface


%%PageItemTitle%%

ICustomizationUsers2 Interface

UserName
The user name defined in the Quality Center data base.
See Also OTA COM Type Library

UserExistsInSite Method

Description

Checks whether the specified site user exists.

Syntax

Public Function UserExistsInSite( _
   ByVal UserName As String _
) As Boolean

Parameters

UserName
The user name defined in the Quality Center data base.

See Also

ICustomizationUsers2 Interface


%%PageItemTitle%%

ICustomizationUsers2 Interface

Name

The user name.

See Also OTA COM Type Library

User Property

Description

The CustomizationUser object representing the specified user.

Property type

Read-only property

Syntax (Visual Basic)

Public Property User( _
   ByVal Name As String _
) As Object

Parameters

Name

The user name.

See Also

ICustomizationUsers2 Interface


%%PageItemTitle%%

ICustomizationUsers2 Interface

Users Property

Description

The list of customization users.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Users() As List

See Also

ICustomizationUsers2 Interface


%%PageItemTitle%%

ICustomizationUsersGroup Members

ICustomizationUsersGroup Interface

Description

Represents a user group for purposes of adding and removing users.

Remarks

Get a CustomizationUsersGroup object from the CustomizationUsersGroups Object.

Public Methods

Public Method AddUser | Adds a new user to the user group.
Public Method RemoveUser | Removes a user from the user group.
Public Method UsersList | A list of all members of the user group.

Public Properties

Public Property Deleted | If true, the object is marked for deletion, but the deletion has not been committed.
Public Property HideFilter | The data hiding filter for the entity specified by the FilterType parameter.
Public Property ID | The user group Id.
Public Property IsSystem | Checks if the user group is a built-in system user group.
Public Property Name | The user group name.
Public Property Updated | Indicates if the object has been modified since being downloaded from database.


%%PageItemTitle%%

ICustomizationUsersGroup Interface

User

The name of the user to be added or a CustomizationUser Object.

See Also OTA COM Type Library

AddUser Method

Description

Adds a new user to the user group.

Syntax

Public Sub AddUser( _
   ByVal User As Variant _
)

Parameters

User

The name of the user to be added or a CustomizationUser Object.

See Also

ICustomizationUsersGroup Interface


%%PageItemTitle%%

ICustomizationUsersGroup Interface

User

The name of the user to be removed or a CustomizationUser Object.

See Also OTA COM Type Library

RemoveUser Method

Description

Removes a user from the user group.

Syntax

Public Sub RemoveUser( _
   ByVal User As Variant _
)

Parameters

User

The name of the user to be removed or a CustomizationUser Object.

See Also

ICustomizationUsersGroup Interface


%%PageItemTitle%%

ICustomizationUsersGroup Interface

UsersList Method

Description

A list of all members of the user group.

Syntax

Public Function UsersList() As List

Return Type

A list of CustomizationUser Objects.

See Also

ICustomizationUsersGroup Interface


%%PageItemTitle%%

ICustomizationUsersGroup Interface

Deleted Property

Description

If true, the object is marked for deletion, but the deletion has not been committed.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Deleted() As Boolean

Remarks

Setting the property to true is equivalent to deleting it.

See Also

ICustomizationUsersGroup Interface


%%PageItemTitle%%

ICustomizationUsersGroup Interface

FilterType

BUG, REQ, TEST, or TESTCYCL

See Also OTA COM Type Library

HideFilter Property

Description

The data hiding filter for the entity specified by the FilterType parameter.

Property type

Read-write property

Syntax (Visual Basic)

Public Property HideFilter( _
   ByVal FilterType As String _
) As String

Parameters

FilterType

BUG, REQ, TEST, or TESTCYCL

Remarks

The data hide filter defines what data is visible for a specific group of users.
For example, if you set the HideFilter to be "BG_BUG_ID=1" for filter type "BUG", then only users belonging to the Viewer group will only be able to get the defect with Id=1.

See Also

ICustomizationUsersGroup Interface


%%PageItemTitle%%

ICustomizationUsersGroup Interface

ID Property

Description

The user group Id.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Long

See Also

ICustomizationUsersGroup Interface


%%PageItemTitle%%

ICustomizationUsersGroup Interface

IsSystem Property

Description

Checks if the user group is a built-in system user group.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsSystem() As Boolean

See Also

ICustomizationUsersGroup Interface


%%PageItemTitle%%

ICustomizationUsersGroup Interface

Name Property

Description

The user group name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ICustomizationUsersGroup Interface


%%PageItemTitle%%

ICustomizationUsersGroup Interface

Updated Property

Description

Indicates if the object has been modified since being downloaded from database.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Updated() As Boolean

See Also

ICustomizationUsersGroup Interface


%%PageItemTitle%%

ICustomizationUsersGroups Members

ICustomizationUsersGroups Interface

Description

Services for managing the collection of all CustomizationUsersGroup objects.

Remarks

Get the CustomizationUsersGroups collection from the Customization Object.

Public Methods

Public Method AddGroup | Adds a new CustomizationUsersGroup to the collection.
Public Method RemoveGroup | Removes a CustomizationUsersGroup object.

Public Properties

Public Property Group | Gets the specified user group.
Public Property Groups | The list of CustomizationUsersGroup objects.


%%PageItemTitle%%

ICustomizationUsersGroups Interface

Name

The name of the group to be added.

See Also OTA COM Type Library

AddGroup Method

Description

Adds a new CustomizationUsersGroup to the collection.

Syntax

Public Function AddGroup( _
   ByVal Name As String _
) As Object

Parameters

Name

The name of the group to be added.

Return Type

The new CustomizationUsersGroup Object.

See Also

ICustomizationUsersGroups Interface


%%PageItemTitle%%

ICustomizationUsersGroups Interface

Name

The name of the group to be removed.

See Also OTA COM Type Library

RemoveGroup Method

Description

Removes a CustomizationUsersGroup object.

Syntax

Public Sub RemoveGroup( _
   ByVal Name As String _
)

Parameters

Name

The name of the group to be removed.

See Also

ICustomizationUsersGroups Interface


%%PageItemTitle%%

ICustomizationUsersGroups Interface

Name

The name of the group.

See Also OTA COM Type Library

Group Property

Description

Gets the specified user group.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Group( _
   ByVal Name As String _
) As Object

Parameters

Name

The name of the group.

See Also

ICustomizationUsersGroups Interface


%%PageItemTitle%%

ICustomizationUsersGroups Interface

Groups Property

Description

The list of CustomizationUsersGroup objects.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Groups() As List

See Also

ICustomizationUsersGroups Interface


%%PageItemTitle%%

ICustomizationUsersGroups2 Members

ICustomizationUsersGroups2 Interface

Description

Services for managing the collection of all CustomizationUsersGroup objects.

Remarks

Get the CustomizationUsersGroups collection from the Customization Object.

Public Methods

Public Method AddGroup | Adds a new CustomizationUsersGroup to the collection.
Public Method IsNameValid | Checks whether another group has the specified name.
Public Method RemoveGroup | Removes a CustomizationUsersGroup object.

Public Properties

Public Property Group | Gets the specified user group.
Public Property Groups | The list of CustomizationUsersGroup objects.


%%PageItemTitle%%

ICustomizationUsersGroups2 Interface

Name

The name of the group to be added.

See Also OTA COM Type Library

AddGroup Method

Description

Adds a new CustomizationUsersGroup to the collection.

Syntax

Public Function AddGroup( _
   ByVal Name As String _
) As Object

Parameters

Name

The name of the group to be added.

Return Type

The new CustomizationUsersGroup Object.

See Also

ICustomizationUsersGroups2 Interface


%%PageItemTitle%%

ICustomizationUsersGroups2 Interface

Name

The name to check.

GroupId

The CustomizationUsersGroup.ID of the group to which you wish to assign the Name parameter as the CustomizationUsersGroup.Name

See Also OTA COM Type Library

IsNameValid Method

Description

Checks whether another group has the specified name.

Syntax

Public Function IsNameValid( _
   ByVal Name As String, _
   ByVal GroupId As Long _
) As Boolean

Parameters

Name

The name to check.

GroupId

The CustomizationUsersGroup.ID of the group to which you wish to assign the Name parameter as the CustomizationUsersGroup.Name

Return Type

Returns True if no group other than the group specified has the specified name.

Remarks

This method is used when creating user groups programmatically to ensure that the group name is not already in use.

See Also

ICustomizationUsersGroups2 Interface


%%PageItemTitle%%

ICustomizationUsersGroups2 Interface

Name

The name of the group to be removed.

See Also OTA COM Type Library

RemoveGroup Method

Description

Removes a CustomizationUsersGroup object.

Syntax

Public Sub RemoveGroup( _
   ByVal Name As String _
)

Parameters

Name

The name of the group to be removed.

See Also

ICustomizationUsersGroups2 Interface


%%PageItemTitle%%

ICustomizationUsersGroups2 Interface

Name

The name of the group.

See Also OTA COM Type Library

Group Property

Description

Gets the specified user group.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Group( _
   ByVal Name As String _
) As Object

Parameters

Name

The name of the group.

See Also

ICustomizationUsersGroups2 Interface


%%PageItemTitle%%

ICustomizationUsersGroups2 Interface

Groups Property

Description

The list of CustomizationUsersGroup objects.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Groups() As List

See Also

ICustomizationUsersGroups2 Interface


%%PageItemTitle%%

ICycle Members

ICycle Interface

Description

Represents a Cycle.

Public Methods

Public Method DaysLeft | Returns the number of days until the scheduled end of the cycle.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Mail | Mails the IBaseFieldExMail field item.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property EndDate | The cycle's end date.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The cycle's name.
Public Property Parent | The cycle's parent release.
Public Property ReleaseManagementInfo | Returns the cycle information.
Public Property StartDate | The cycle's start date.
Public Property Status | The cycle's status.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

ICycle Interface

DaysLeft Method

Description

Returns the number of days until the scheduled end of the cycle.

Syntax

Public Function DaysLeft() As Long

See Also

ICycle Interface


%%PageItemTitle%%

ICycle Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ICycle Interface


%%PageItemTitle%%

ICycle Interface

SendTo
SendCc
Option
Subject
Comment
See Also OTA COM Type Library

Mail Method

Description

Mails the IBaseFieldExMail field item.

Syntax

Public Sub Mail( _
   ByVal SendTo As String, _
   Optional ByVal SendCc As String = "", _
   Optional ByVal Option As Long = 0, _
   Optional ByVal Subject As String = "", _
   Optional ByVal Comment As String = "" _
)

Parameters

SendTo
SendCc
Option
Subject
Comment

See Also

ICycle Interface


%%PageItemTitle%%

ICycle Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ICycle Interface


%%PageItemTitle%%

ICycle Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ICycle Interface


%%PageItemTitle%%

ICycle Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

ICycle Interface


%%PageItemTitle%%

ICycle Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

ICycle Interface


%%PageItemTitle%%

ICycle Interface

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

ICycle Interface


%%PageItemTitle%%

ICycle Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

ICycle Interface


%%PageItemTitle%%

ICycle Interface

EndDate Property

Description

The cycle's end date.

Property type

Read-write property

Syntax (Visual Basic)

Public Property EndDate() As Date

See Also

ICycle Interface


%%PageItemTitle%%

ICycle Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

ICycle Interface


%%PageItemTitle%%

ICycle Interface

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

ICycle Interface


%%PageItemTitle%%

ICycle Interface

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

ICycle Interface


%%PageItemTitle%%

ICycle Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

ICycle Interface


%%PageItemTitle%%

ICycle Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

ICycle Interface


%%PageItemTitle%%

ICycle Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

ICycle Interface


%%PageItemTitle%%

ICycle Interface

Name Property

Description

The cycle's name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ICycle Interface


%%PageItemTitle%%

ICycle Interface

Parent Property

Description

The cycle's parent release.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As Object

See Also

ICycle Interface


%%PageItemTitle%%

ICycle Interface

ReleaseManagementInfo Property

Description

Returns the cycle information.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ReleaseManagementInfo() As Object

See Also

ICycle Interface


%%PageItemTitle%%

ICycle Interface

StartDate Property

Description

The cycle's start date.

Property type

Read-write property

Syntax (Visual Basic)

Public Property StartDate() As Date

See Also

ICycle Interface


%%PageItemTitle%%

ICycle Interface

Status Property

Description

The cycle's status.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Status() As String

See Also

ICycle Interface


%%PageItemTitle%%

ICycle Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

ICycle Interface


%%PageItemTitle%%

ICycleFactory Members

ICycleFactory Interface

Description

Services for managing release cycles.

Remarks

Get a CycleFactory from a ReleaseFactory or from DConnection.CycleFactory.

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Public Methods

Public Method AddItem | Creates a new item object.
Public Method BuildCoverageGraph | Builds release cycle coverage graph.
Public Method Mail | Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

ICycleFactory Interface

ItemData
See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData

Remarks

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

[Visual Basic]

Dim bgf As BugFactory
Dim bg As Bug
Dim attf As AttachmentFactory
Dim att As Attachment
Dim attList As List

' Get the factory object
 Set bgf = tdc.BugFactory
' Use defect #1
 Set bg = bgf.Item(1)
 Set attf = bg.Attachments

' Creating a new attachment
' Create virtual object, then populate the properties
 Set att = attf.AddItem(Null)
 att.FileName = Text1.Text
 att.Type = TDATT_INTERNET

' Saving the object with validity check
 att.Post

' Display the attachments
' Add the display-only items without a Post
 List1.Clear
 Set attList = attf.NewList("")
 For i = 1 To attList.Count

      Set att = attList.Item(i)
      List1.AddItem (att.Name)

 Next

See Also

ICycleFactory Interface


%%PageItemTitle%%

ICycleFactory Interface

CycleID
See Also OTA COM Type Library

BuildCoverageGraph Method

Description

Builds release cycle coverage graph.

Syntax

Public Function BuildCoverageGraph( _
   ByVal CycleID As Long _
) As Object

Parameters

CycleID

See Also

ICycleFactory Interface


%%PageItemTitle%%

ICycleFactory Interface

Items

A list of IDs.

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also OTA COM Type Library

Mail Method

Description

Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.

Syntax

Public Sub Mail( _
   ByVal Items As Variant, _
   ByVal SendTo As String, _
   Optional ByVal SendCc As String = "", _
   Optional ByVal Option As Long = 0, _
   Optional ByVal Subject As String = "", _
   Optional ByVal Comment As String = "" _
)

Parameters

Items

A list of IDs.

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also

ICycleFactory Interface


%%PageItemTitle%%

ICycleFactory Interface

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

ICycleFactory Interface


%%PageItemTitle%%

ICycleFactory Interface

ItemKey
See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey

See Also

ICycleFactory Interface


%%PageItemTitle%%

ICycleFactory Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

ICycleFactory Interface


%%PageItemTitle%%

ICycleFactory Interface

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

ICycleFactory Interface


%%PageItemTitle%%

ICycleFactory Interface

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

ICycleFactory Interface


%%PageItemTitle%%

ICycleFactory Interface

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

ICycleFactory Interface


%%PageItemTitle%%

ICycleFactory Interface

ItemKey
See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey

See Also

ICycleFactory Interface


%%PageItemTitle%%

IDesignStep Members

IDesignStep Interface

Description

Represents a single design step in a test.

Remarks

Get a DesignStep object from the DesignStepFactory Object.

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property EvaluatedStepDescription | The design step description.
Public Property EvaluatedStepExpectedResult | The design step expected result string.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property LinkedParams | The linked test parameters.
Public Property LinkTest | A template test to be linked to the design step.
Public Property LinkTestID | The ID of the linked test.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Order | The order of the design step in the test procedure.
Public Property ParentTest | The test object to which the design step belongs.
Public Property StepDescription | The description of the design step.
Public Property StepExpectedResult | The expected results of the step.
Public Property StepName | The design step name.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

IDesignStep Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IDesignStep Interface


%%PageItemTitle%%

IDesignStep Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IDesignStep Interface


%%PageItemTitle%%

IDesignStep Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IDesignStep Interface


%%PageItemTitle%%

IDesignStep Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

IDesignStep Interface


%%PageItemTitle%%

IDesignStep Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

IDesignStep Interface


%%PageItemTitle%%

IDesignStep Interface

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

IDesignStep Interface


%%PageItemTitle%%

IDesignStep Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

IDesignStep Interface


%%PageItemTitle%%

IDesignStep Interface

EvaluatedStepDescription Property

Description

The design step description.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EvaluatedStepDescription() As String

Remarks

If the description includes parameters, EvaluatedStepDescription returns the string after replacing the parameter markers with their value, if any. To get the string as entered, without evaluating the parameters, use StepDescription.

See Also

IDesignStep Interface


%%PageItemTitle%%

IDesignStep Interface

EvaluatedStepExpectedResult Property

Description

The design step expected result string.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EvaluatedStepExpectedResult() As String

Remarks

If the expected result includes parameters, EvaluatedStepExpectedResult returns the string after replacing the parameter markers with their value, if any. To get the string as entered, without evaluating the parameters, use StepExpectedResult Property.

See Also

IDesignStep Interface


%%PageItemTitle%%

IDesignStep Interface

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName

The name of the field in the project database.

See Also

IDesignStep Interface


%%PageItemTitle%%

IDesignStep Interface

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

IDesignStep Interface


%%PageItemTitle%%

IDesignStep Interface

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IDesignStep Interface


%%PageItemTitle%%

IDesignStep Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

IDesignStep Interface


%%PageItemTitle%%

IDesignStep Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

IDesignStep Interface


%%PageItemTitle%%

IDesignStep Interface

LinkedParams Property

Description

The linked test parameters.

Property type

Read-only property

Syntax (Visual Basic)

Public Property LinkedParams() As Object

See Also

IDesignStep Interface


%%PageItemTitle%%

IDesignStep Interface

LinkTest Property

Description

A template test to be linked to the design step.

Property type

Read-write property

Syntax (Visual Basic)

Public Property LinkTest() As Variant

See Also

IDesignStep Interface


%%PageItemTitle%%

IDesignStep Interface

LinkTestID Property

Description

The ID of the linked test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property LinkTestID() As Long

See Also

IDesignStep Interface


%%PageItemTitle%%

IDesignStep Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

IDesignStep Interface


%%PageItemTitle%%

IDesignStep Interface

Order Property

Description

The order of the design step in the test procedure.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Order() As Long

See Also

IDesignStep Interface


%%PageItemTitle%%

IDesignStep Interface

ParentTest Property

Description

The test object to which the design step belongs.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ParentTest() As Object

See Also

IDesignStep Interface


%%PageItemTitle%%

IDesignStep Interface

StepDescription Property

Description

The description of the design step.

Property type

Read-write property

Syntax (Visual Basic)

Public Property StepDescription() As String

Remarks

StepDescription returns the string as entered. If the description includes parameters, StepDescription returns the string with the parameter place markers. The markers are not replaced with values, as they are by EvaluatedStepDescription.

See Also

IDesignStep Interface


%%PageItemTitle%%

IDesignStep Interface

StepExpectedResult Property

Description

The expected results of the step.

Property type

Read-write property

Syntax (Visual Basic)

Public Property StepExpectedResult() As String

Remarks

StepExpectedResult returns the string as entered. If the expected result includes parameters, StepExpectedResult returns the string with the parameter place markers. The markers are not replaced with values, as they are by EvaluatedStepExpectedResult.

See Also

IDesignStep Interface


%%PageItemTitle%%

IDesignStep Interface

StepName Property

Description

The design step name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property StepName() As String

See Also

IDesignStep Interface


%%PageItemTitle%%

IDesignStep Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

IDesignStep Interface


%%PageItemTitle%%

IExecEventInfo Members

IExecEventInfo Interface

Description

The execution information of the scheduler. This object handles the actual, not the planned, information.

Remarks

Get the ExecEventInfo objects with the ExecutionStatus.EventsList Method.

Public Properties

Public Property EventDate | The Execution Event Date.
Public Property EventTime | The Execution Event Time.
Public Property EventType | The type of Execution Event.


%%PageItemTitle%%

IExecEventInfo Interface

EventDate Property

Description

The Execution Event Date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EventDate() As String

See Also

IExecEventInfo Interface


%%PageItemTitle%%

IExecEventInfo Interface

EventTime Property

Description

The Execution Event Time.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EventTime() As String

See Also

IExecEventInfo Interface


%%PageItemTitle%%

IExecEventInfo Interface

EventType Property

Description

The type of Execution Event.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EventType() As Long

See Also

IExecEventInfo Interface


%%PageItemTitle%%

IExecEventNotifyByMailSettings Members

IExecEventNotifyByMailSettings Interface

Description

Represents the notification to be sent by e-mail after a test has completed its run.

Remarks

Get a ExecEventNotifyByMailSettings reference from TestSet.ExecEventNotifyByMailSettings

Public Methods

Public Method Save Uploads the notification settings to the server.

Public Properties

Public Property EMailTo | The recipients' e-mail addresses.
Public Property Enabled | Indicates if mail is enabled for the specified event type.
Public Property UserMessage | The message body of the e-mail.


%%PageItemTitle%%

IExecEventNotifyByMailSettings Interface

AutoPost

If TRUE, the notification is updated immediately when the field is changed.

See Also OTA COM Type Library

Save Method

Description

Uploads the notification settings to the server.

Syntax

Public Sub Save( _
   Optional ByVal AutoPost As Boolean = True _
)

Parameters

AutoPost

If TRUE, the notification is updated immediately when the field is changed.

See Also

IExecEventNotifyByMailSettings Interface


%%PageItemTitle%%

IExecEventNotifyByMailSettings Interface

EMailTo Property

Description

The recipients' e-mail addresses.

Property type

Read-write property

Syntax (Visual Basic)

Public Property EMailTo() As String

See Also

IExecEventNotifyByMailSettings Interface


%%PageItemTitle%%

IExecEventNotifyByMailSettings Interface

EventType

The event type for which to enable the notification. A member of the tagTDAPI_EXECUTIONEVENT Enumeration

See Also OTA COM Type Library

Enabled Property

Description

Indicates if mail is enabled for the specified event type.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Enabled( _
   ByVal EventType As Long _
) As Boolean

Parameters

EventType

The event type for which to enable the notification. A member of the tagTDAPI_EXECUTIONEVENT Enumeration

See Also

IExecEventNotifyByMailSettings Interface


%%PageItemTitle%%

IExecEventNotifyByMailSettings Interface

UserMessage Property

Description

The message body of the e-mail.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserMessage() As String

See Also

IExecEventNotifyByMailSettings Interface


%%PageItemTitle%%

IExecutionSettings Members

IExecutionSettings Interface

Description

Information on the execution of a test set.

Remarks

Get an ExecSettings object from TSTest.ExecutionSettings or TestSet.ExecutionSettings.

Public Properties

Public Property OnExecEventSchedulerActionParams | The restart action parameters.
Public Property OnExecEventSchedulerActionType | The action type of the execution event.
Public Property PlannedExecutionDate | The planned test execution date.
Public Property PlannedExecutionTime | The planned test execution time.
Public Property PlannedRunDuration | The planned test run duration.


%%PageItemTitle%%

IExecutionSettings Interface

EventType

A member of the tagTDAPI_EXECUTIONEVENT Enumeration.

See Also OTA COM Type Library

OnExecEventSchedulerActionParams Property

Description

The restart action parameters.

Property type

Read-only property

Syntax (Visual Basic)

Public Property OnExecEventSchedulerActionParams( _
   ByVal EventType As Long _
) As Object

Parameters

EventType

A member of the tagTDAPI_EXECUTIONEVENT Enumeration.

See Also

IExecutionSettings Interface


%%PageItemTitle%%

IExecutionSettings Interface

EventType

A member of the tagTDAPI_EXECUTIONEVENT Enumeration.

See Also OTA COM Type Library

OnExecEventSchedulerActionType Property

Description

The action type of the execution event.

Property type

Read-write property

Syntax (Visual Basic)

Public Property OnExecEventSchedulerActionType( _
   ByVal EventType As Long _
) As Long

Parameters

EventType

A member of the tagTDAPI_EXECUTIONEVENT Enumeration.

See Also

IExecutionSettings Interface


%%PageItemTitle%%

IExecutionSettings Interface

PlannedExecutionDate Property

Description

The planned test execution date.

Property type

Read-write property

Syntax (Visual Basic)

Public Property PlannedExecutionDate() As Variant

See Also

IExecutionSettings Interface


%%PageItemTitle%%

IExecutionSettings Interface

PlannedExecutionTime Property

Description

The planned test execution time.

Property type

Read-write property

Syntax (Visual Basic)

Public Property PlannedExecutionTime() As Variant

See Also

IExecutionSettings Interface


%%PageItemTitle%%

IExecutionSettings Interface

PlannedRunDuration Property

Description

The planned test run duration.

Property type

Read-write property

Syntax (Visual Basic)

Public Property PlannedRunDuration() As Variant

See Also

IExecutionSettings Interface


%%PageItemTitle%%

IExecutionStatus Members

IExecutionStatus Collection

Description

Represents the execution status of the scheduler. The user can scan through each test in the scheduler.

Remarks

Get an ExecutionStatus object from TSScheduler.ExecutionStatus.

Public Methods

Public Method EventsList | Gets the list of the execution events.
Public Method RefreshExecStatusInfo | Refreshes the execution status from the execution controller.

Public Properties

Public Property _NewEnum | Gets an ATL.IEnumOnSTLImpl enumerator for the TestExecStatus objects. For information on the ATL Class and IEnumOnSTLImpl, see Microsoft documentation.
Public Property Count | The number of status elements in the object.
Public Property Finished | Checks if execution is finished or still in progress.
Public Property Item | Gets a TestExecStatus object by index (1-based).


%%PageItemTitle%%

IExecutionStatus Collection

EventsList Method

Description

Gets the list of the execution events.

Syntax

Public Function EventsList() As List

Return Type

A list of the ExecEventInfo Objects of the events.

See Also

IExecutionStatus Collection


%%PageItemTitle%%

IExecutionStatus Collection

TestData

Either "all" or a comma-separated list of test IDs

Force

If True, refresh all requested tests. If False, refresh only those tests whose status has changed since the last call.

See Also OTA COM Type Library

RefreshExecStatusInfo Method

Description

Refreshes the execution status from the execution controller.

Syntax

Public Sub RefreshExecStatusInfo( _
   ByVal TestData As Variant, _
   ByVal Force As Boolean _
)

Parameters

TestData

Either "all" or a comma-separated list of test IDs

Force

If True, refresh all requested tests. If False, refresh only those tests whose status has changed since the last call.

See Also

IExecutionStatus Collection


%%PageItemTitle%%

IExecutionStatus Collection

_NewEnum Property

Description

Gets an ATL.IEnumOnSTLImpl enumerator for the TestExecStatus objects. For information on the ATL Class and IEnumOnSTLImpl, see Microsoft documentation.

Property type

Read-only property

Syntax (Visual Basic)

Public Property _NewEnum() As Unknown

See Also

IExecutionStatus Collection


%%PageItemTitle%%

IExecutionStatus Collection

Count Property

Description

The number of status elements in the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

IExecutionStatus Collection


%%PageItemTitle%%

IExecutionStatus Collection

Finished Property

Description

Checks if execution is finished or still in progress.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Finished() As Boolean

See Also

IExecutionStatus Collection


%%PageItemTitle%%

IExecutionStatus Collection

Index

Specifies the TestExecStatus object in the collection. Index is one-based.

See Also OTA COM Type Library

Item Property

Description

Gets a TestExecStatus object by index (1-based).

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal Index As Long _
) As Variant

Parameters

Index

Specifies the TestExecStatus object in the collection. Index is one-based.

See Also

IExecutionStatus Collection


%%PageItemTitle%%

IExtendedStorage Members

IExtendedStorage Interface

Description

Represents a storage structure used to transfer files between the server and client file system and delete files.

Remarks

There are three implementations of storage handlers: ExtendedStorage, ExtendedStorageProxy, and ProjectRepository. They all implement the IExtendedStorage Interface. The Open Test Architecture infrastructure returns the handler object appropriate to the configuration of the servers and project on which the application is run.

The use of the handlers in your application is the same regardless of the implementation. Declare variables as type IExtendedStorage. For examples, see IExtendedStorage Interface and its methods and properties.

Get a storage handler object from AttachmentFactory.AttachmentStorage, Run.ExtendedStorage, Attachment.AttachmentStorage, Test.ExtendedStorage, or TestFactory.RepositoryStorage.

Note that a storage handler object obtained from an object will not necessarily handle only items belonging to that object. For example, if you get a storage object from a test attachment and then download all attachments:

Set TestAttachmentFactoryObj = aTestObject.Attachments
Set TestAttachStorage = TestAttachmentFactoryObj.AttachmentStorage
AttachDownLoadPath = TestAttachStorage.LoadEx("*.*", True, NullList, isFatalErr)

The result is to download all attachments in the project.

To avoid this, either specify a filter or use other methods. In the above example, you could replace the ExtendedStorage load with Attachment.Load.

The storage handler is also accessible from TDConnection.ExtendedStorage, but a reference obtained this way is disabled by the default security settings.

Public Methods

Public Method Cancel | Cancels the load or save action.
Public Method Delete | Deletes files locally or from the server.
Public Method GetLastError | Gets the last error that occurred during asynchronous load and save operations.
Public Method Load | Downloads the storage structure to the client file system.
Public Method LoadEx | Downloads the storage structure to the client file system.
Public Method Progress | Polls the progress of the last action (Load or Save).
Public Method Save | Uploads the storage structure to the server.
Public Method SaveEx | Uploads the storage structure to the server.

Public Properties

Public Property ActionFinished | Checks if the load or save action is finished.
Public Property ClientPath | The location on the client to which to download or from which to upload.
Public Property Root | The storage root.
Public Property ServerPath | The location on the server from which to download or to which to upload.


%%PageItemTitle%%

IExtendedStorage Interface

Cancel Method

Description

Cancels the load or save action.

Syntax

Public Sub Cancel()

See Also

IExtendedStorage Interface


%%PageItemTitle%%

IExtendedStorage Interface

FSysFilter

A file system filter. If the filter begins with "-r", it is applied recursively to all sub-directories. If the filter is an empty string, all files with all subdirectories are downloaded to the client.

nDeleteType

The delete type, Local or remote. A member of the tagTDAPI_EXSTOR_DELMODE Enumeration .

See Also OTA COM Type Library

Delete Method

Description

Deletes files locally or from the server.

Syntax

Public Sub Delete( _
   ByVal FSysFilter As String, _
   ByVal nDeleteType As Long _
)

Parameters

FSysFilter

A file system filter. If the filter begins with "-r", it is applied recursively to all sub-directories. If the filter is an empty string, all files with all subdirectories are downloaded to the client.

nDeleteType

The delete type, Local or remote. A member of the tagTDAPI_EXSTOR_DELMODE Enumeration .

See Also

IExtendedStorage Interface

Example

Operations on the test repository


%%PageItemTitle%%

IExtendedStorage Interface

GetLastError Method

Description

Gets the last error that occurred during asynchronous load and save operations.

Syntax

Public Sub GetLastError()

Return Type

An HRESULT. The application-specific error is in the information code.

Remarks

Used for asynchronous operations where error handled can not be implemented.

For information on handling an HRESULT, see Microsoft documentation.

See Also

IExtendedStorage Interface


%%PageItemTitle%%

IExtendedStorage Interface

FSysFilter

A file system filter.

synchronize

If True, the download operation is synchronous.

See Also OTA COM Type Library

Load Method

Description

Downloads the storage structure to the client file system.

Syntax

Public Function Load( _
   Optional ByVal FSysFilter As String = "*.*", _
   Optional ByVal synchronize As Boolean = False _
) As String

Parameters

FSysFilter

A file system filter.

synchronize

If True, the download operation is synchronous.

Return Type

The path on the client machine to which the files were downloaded.

Remarks

If the filter is an empty string, all files with all subdirectories are uploaded to the server.

If a phrase in the filter begins with "-r", it is applied recursively to all sub-directories. If a phrase in the filter begins with -x, it indications exclusion.

For example, the filter "Austen.txt, -r Novels\*.* -x Emma.txt" returns the file Austen.txt and all files and folders under the Novels directory except Emma.txt.

If the operation is synchronous, the process begins and is not checked for status until the process is completed. If the operation is asynchronous, the Load method initiates the download immediately and continuously checks if the download is finished. Check the ActionFinished Property periodically, and use the GetLastError Method to see if the operation succeeded.

See Also

IExtendedStorage Interface

Example

Downloading a defect attachment with Extended Storage | Operations on the test repository


%%PageItemTitle%%

IExtendedStorage Interface

FSysFilter

A file system filter.

synchronize

If True, the download operation is synchronous.

pVal

NULL

pNonFatalErrorOccured

The error that occurred was non-fatal. This value is meaningful only for synchronous transfers.

See Also OTA COM Type Library

LoadEx Method

Description

Downloads the storage structure to the client file system.

Syntax

Public Function LoadEx( _
   ByVal FSysFilter As String, _
   ByVal synchronize As Boolean, _
   ByVal pVal As List, _
   ByRef pNonFatalErrorOccured As Boolean _
) As String

Parameters

FSysFilter

A file system filter.

synchronize

If True, the download operation is synchronous.

pVal

NULL

pNonFatalErrorOccured

The error that occurred was non-fatal. This value is meaningful only for synchronous transfers.

Return Type

The path on the client machine to which the files were downloaded.

Remarks

If the filter is an empty string, all files with all subdirectories are uploaded to the server.

If a phrase in the filter begins with "-r", it is applied recursively to all sub-directories. If a phrase in the filter begins with -x, it indications exclusion.

For example, the filter "Austen.txt, -r Novels\*.* -x Emma.txt" returns the file Austen.txt and all files and folders under the Novels directory except Emma.txt.

If the operation is synchronous, the process begins and is not checked for status until the process is completed. If the operation is asynchronous, the Load method initiates the download immediately and continuously checks if the download is finished. Check the ActionFinished Property periodically, and use the GetLastError Method to see if the operation succeeded.

See Also

IExtendedStorage Interface

Example

Downloading test files and attachments


%%PageItemTitle%%

IExtendedStorage Interface

Total

The total number of bytes to be transferred.

Current

The number of bytes transferred so far.

See Also OTA COM Type Library

Progress Method

Description

Polls the progress of the last action (Load or Save).

Syntax

Public Function Progress( _
   ByRef Total As Long, _
   ByRef Current As Long _
) As String

Parameters

Total

The total number of bytes to be transferred.

Current

The number of bytes transferred so far.

Return Type

Null

See Also

IExtendedStorage Interface


%%PageItemTitle%%

IExtendedStorage Interface

FSysFilter

A file system filter.

synchronize

If True, the upload operation is synchronous.

See Also OTA COM Type Library

Save Method

Description

Uploads the storage structure to the server.

Syntax

Public Sub Save( _
   Optional ByVal FSysFilter As String = "*.*", _
   Optional ByVal synchronize As Boolean = False _
)

Parameters

FSysFilter

A file system filter.

synchronize

If True, the upload operation is synchronous.

Remarks

If the filter is an empty string, all files with all subdirectories are uploaded to the server.

If a phrase in the filter begins with "-r", it is applied recursively to all sub-directories. If a phrase in the filter begins with -x, it indications exclusion.

For example, the filter "Austen.txt, -r Novels\*.* -x Emma.txt" returns the file Austen.txt and all files and folders under the Novels directory except Emma.txt.

If the operation is synchronous, the process begins and is not checked for status until the process is completed. If the operation is asynchronous, the function immediately begins the upload and continuously checks if the transfer is finished. Check the ActionFinished Property periodically, and use the GetLastError Method to see if the operation succeeded.

See Also

IExtendedStorage Interface

Example

Creating a new defect attachment


%%PageItemTitle%%

IExtendedStorage Interface

FSysFilter

A file system filter.

synchronize

If True, the upload operation is synchronous.

pVal

NULL

See Also OTA COM Type Library

SaveEx Method

Description

Uploads the storage structure to the server.

Syntax

Public Function SaveEx( _
   ByVal FSysFilter As String, _
   ByVal synchronize As Boolean, _
   ByVal pVal As List _
) As Boolean

Parameters

FSysFilter

A file system filter.

synchronize

If True, the upload operation is synchronous.

pVal

NULL

Return Type

The error that occurred was non-fatal (True or False). This value is meaningful only for synchronous transfers.

Remarks

If the filter is an empty string, all files with all subdirectories are uploaded to the server.

If a phrase in the filter begins with "-r", it is applied recursively to all sub-directories. If a phrase in the filter begins with -x, it indications exclusion.

For example, the filter "Austen.txt, -r Novels\*.* -x Emma.txt" returns the file Austen.txt and all files and folders under the Novels directory except Emma.txt.

If the operation is synchronous, the process begins and is not checked for status until the process is completed. If the operation is asynchronous, the function immediately begins the upload and continuously checks if the transfer is finished. Check the ActionFinished Property periodically, and use the GetLastError Method to see if the operation succeeded.

See Also

IExtendedStorage Interface


%%PageItemTitle%%

IExtendedStorage Interface

ActionFinished Property

Description

Checks if the load or save action is finished.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ActionFinished() As Long

See Also

IExtendedStorage Interface


%%PageItemTitle%%

IExtendedStorage Interface

ClientPath Property

Description

The location on the client to which to download or from which to upload.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ClientPath() As String

See Also

IExtendedStorage Interface

Example

Downloading a defect attachment with Extended Storage


%%PageItemTitle%%

IExtendedStorage Interface

Root Property

Description

The storage root.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Root() As Object

See Also

IExtendedStorage Interface


%%PageItemTitle%%

IExtendedStorage Interface

ServerPath Property

Description

The location on the server from which to download or to which to upload.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ServerPath() As String

See Also

IExtendedStorage Interface


%%PageItemTitle%%

IFactoryList Members

IFactoryList Collection

Description

Services to create and maintains lists within entity factories. Use any factory object to create any number of list instances for objects in the factory.

Remarks

Get a FactoryList from Bug.FindSimilarBugs or HierarchyFilter.NewList.

List objects are returned by the NewList method of factory objects and by many other methods and properties.

List numbering begins at one, for example, myList.Item(1).

Public Methods

Public Method Add | Adds a new item to the current list object.
Public Method IndexOfItem | Gets the index of the passed object.
Public Method Insert | Inserts a new item at the specified position.
Public Method Post | Posts changed data for all items in list.
Public Method Refresh | Reads saved list filter and data for all listed objects, overwriting values in memory.
Public Method Remove | Removes the specified item from the current list object.
Public Method Swap | Swaps the two list items specified by their positions.

Public Properties

Public Property _NewEnum | Gets an IEnumVARIANT enumerator. For information on the IEnumVARIANT, see Microsoft documentation.
Public Property Count | The number of items in the list.
Public Property Fields | Gets a list of fields available through this factory.
Public Property Item | Gets an item by index. The index is one-based.
Public Property Ratio | The similarity ratio for the specified item.


%%PageItemTitle%%

IFactoryList Collection

vNew

A value or object reference to be added to the list.

See Also OTA COM Type Library

Add Method

Description

Adds a new item to the current list object.

Syntax

Public Sub Add( _
   ByVal vNew As Variant _
)

Parameters

vNew

A value or object reference to be added to the list.

See Also

IFactoryList Collection


%%PageItemTitle%%

IFactoryList Collection

Item

A reference to one of the objects in the list.

See Also OTA COM Type Library

IndexOfItem Method

Description

Gets the index of the passed object.

Syntax

Public Function IndexOfItem( _
   ByVal Item As Variant _
) As Long

Parameters

Item

A reference to one of the objects in the list.

See Also

IFactoryList Collection


%%PageItemTitle%%

IFactoryList Collection

Pos

The position into which to insert the item.

vNew

A value or object reference to be inserted in the list.

See Also OTA COM Type Library

Insert Method

Description

Inserts a new item at the specified position.

Syntax

Public Sub Insert( _
   ByVal Pos As Long, _
   ByVal vNew As Variant _
)

Parameters

Pos

The position into which to insert the item.

vNew

A value or object reference to be inserted in the list.

See Also

IFactoryList Collection


%%PageItemTitle%%

IFactoryList Collection

Post Method

Description

Posts changed data for all items in list.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IFactoryList Collection


%%PageItemTitle%%

IFactoryList Collection

Refresh Method

Description

Reads saved list filter and data for all listed objects, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IFactoryList Collection


%%PageItemTitle%%

IFactoryList Collection

Index

The position in the list of the item to be removed.

See Also OTA COM Type Library

Remove Method

Description

Removes the specified item from the current list object.

Syntax

Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index

The position in the list of the item to be removed.

See Also

IFactoryList Collection


%%PageItemTitle%%

IFactoryList Collection

Pos1

Put the item in this position in position Pos2.

Pos2

Put the item in this position in position Pos1.

See Also OTA COM Type Library

Swap Method

Description

Swaps the two list items specified by their positions.

Syntax

Public Sub Swap( _
   ByVal Pos1 As Long, _
   ByVal Pos2 As Long _
)

Parameters

Pos1

Put the item in this position in position Pos2.

Pos2

Put the item in this position in position Pos1.

See Also

IFactoryList Collection


%%PageItemTitle%%

IFactoryList Collection

_NewEnum Property

Description

Gets an IEnumVARIANT enumerator. For information on the IEnumVARIANT, see Microsoft documentation.

Property type

Read-only property

Syntax (Visual Basic)

Public Property _NewEnum() As Unknown

See Also

IFactoryList Collection


%%PageItemTitle%%

IFactoryList Collection

Count Property

Description

The number of items in the list.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

IFactoryList Collection


%%PageItemTitle%%

IFactoryList Collection

Fields Property

Description

Gets a list of fields available through this factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

IFactoryList Collection


%%PageItemTitle%%

IFactoryList Collection

Index
Index is from 1 to Count.

The index is 1 to Count.

See Also OTA COM Type Library

Item Property

Description

Gets an item by index. The index is one-based.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal Index As Long _
) As Variant

Parameters

Index
Index is from 1 to Count.

The index is 1 to Count.

See Also

IFactoryList Collection


%%PageItemTitle%%

IFactoryList Collection

Index
Index starts at zero

Index is 1 to Count.

See Also OTA COM Type Library

Ratio Property

Description

The similarity ratio for the specified item.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Ratio( _
   ByVal Index As Long _
) As Long

Parameters

Index
Index starts at zero

Index is 1 to Count.

Remarks

The Ratio method is meaningful when the list is acquired as a result of call to FindSimilarBug, otherwise it returns 0 (in VB) and an HRESULT of S_FALSE.

See Also

IFactoryList Collection


%%PageItemTitle%%

IFieldProperty Members

IFieldProperty Interface

Description

Properties for a field.

Remarks

Get a FieldProperty object from TDField.Property.

Public Properties

Public Property DBColumnName | The database column name.
Public Property DBColumnType | The database column type.
Public Property DBTableName | The database table name.
Public Property EditMask | The input mask for string fields.
Public Property EditStyle | The user interface control type used to edit this field.
Public Property FieldSize | The size of the field in the database (-1 for BLOB fields).
Public Property IsActive | Checks if the field is can be displayed in the user interface.
Public Property IsByCode | Checks if the field saves the Tree Node ID (True), or the passed value (False).
Public Property IsCanFilter | Checks if the field is displayed in the filter dialog box.
Public Property IsCustomizable | Checks if the field is displayed in the customization UI.
Public Property IsEdit | Checks if the field can be edited.
Public Property IsHistory | Checks if change history is stored for the field.
Public Property IsKeepValue | Checks if the last value for the field is stored.
Public Property IsKey | Checks if this is a database key field.
Public Property IsMail | Checks if e-mail is sent to the users on the notification list when this field changes.
Public Property IsModify | Checks if the user currently logged on the TDConnection is permitted to modify this field.
Public Property IsRequired | Checks if this is a required field.
Public Property IsSystem | Checks if this is a predefined system field.
Public Property IsToSum | Checks if this field is summed for graphs.
Public Property IsVerify | Checks if the field requires verification.
Public Property IsVersionControl | Checks if the field is under version control.
Public Property IsVisibleInNewBug | Checks if the field is visible in the New Bug form.
Public Property ReadOnly | Checks if this is a read-only field.
Public Property Root | The tree root connected to the field.
Public Property UserColumnType | The user column type: char, number, date, memo, or empty string.
Public Property UserLabel | The user-defined label.


%%PageItemTitle%%

IFieldProperty Interface

DBColumnName Property

Description

The database column name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DBColumnName() As String

See Also

IFieldProperty Interface


%%PageItemTitle%%

IFieldProperty Interface

DBColumnType Property

Description

The database column type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DBColumnType() As String

See Also

IFieldProperty Interface


%%PageItemTitle%%

IFieldProperty Interface

DBTableName Property

Description

The database table name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DBTableName() As String

See Also

IFieldProperty Interface


%%PageItemTitle%%

IFieldProperty Interface

EditMask Property

Description

The input mask for string fields.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EditMask() As String

Remarks

When a user is prompted for data in the user interface, the edit mask is used to present the blank input in the required format.

For more information on input masks, see 'Defining Input Masks' under 'Customizing Project Entities' in the Mercury Quality Center Administrator's Guide.

See Also

IFieldProperty Interface


%%PageItemTitle%%

IFieldProperty Interface

EditStyle Property

Description

The user interface control type used to edit this field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EditStyle() As String

See Also

IFieldProperty Interface


%%PageItemTitle%%

IFieldProperty Interface

FieldSize Property

Description

The size of the field in the database (-1 for BLOB fields).

Property type

Read-only property

Syntax (Visual Basic)

Public Property FieldSize() As Long

See Also

IFieldProperty Interface


%%PageItemTitle%%

IFieldProperty Interface

IsActive Property

Description

Checks if the field is can be displayed in the user interface.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsActive() As Boolean

See Also

IFieldProperty Interface


%%PageItemTitle%%

IFieldProperty Interface

IsByCode Property

Description

Checks if the field saves the Tree Node ID (True), or the passed value (False).

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsByCode() As Boolean

See Also

IFieldProperty Interface


%%PageItemTitle%%

IFieldProperty Interface

IsCanFilter Property

Description

Checks if the field is displayed in the filter dialog box.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsCanFilter() As Boolean

See Also

IFieldProperty Interface


%%PageItemTitle%%

IFieldProperty Interface

IsCustomizable Property

Description

Checks if the field is displayed in the customization UI.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsCustomizable() As Boolean

See Also

IFieldProperty Interface


%%PageItemTitle%%

IFieldProperty Interface

IsEdit Property

Description

Checks if the field can be edited.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsEdit() As Boolean

See Also

IFieldProperty Interface


%%PageItemTitle%%

IFieldProperty Interface

IsHistory Property

Description

Checks if change history is stored for the field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsHistory() As Boolean

See Also

IFieldProperty Interface


%%PageItemTitle%%

IFieldProperty Interface

IsKeepValue Property

Description

Checks if the last value for the field is stored.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsKeepValue() As Boolean

See Also

IFieldProperty Interface


%%PageItemTitle%%

IFieldProperty Interface

IsKey Property

Description

Checks if this is a database key field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsKey() As Boolean

See Also

IFieldProperty Interface


%%PageItemTitle%%

IFieldProperty Interface

IsMail Property

Description

Checks if e-mail is sent to the users on the notification list when this field changes.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsMail() As Boolean

See Also

IFieldProperty Interface


%%PageItemTitle%%

IFieldProperty Interface

IsModify Property

Description

Checks if the user currently logged on the TDConnection is permitted to modify this field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsModify() As Boolean

See Also

IFieldProperty Interface


%%PageItemTitle%%

IFieldProperty Interface

IsRequired Property

Description

Checks if this is a required field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsRequired() As Boolean

See Also

IFieldProperty Interface


%%PageItemTitle%%

IFieldProperty Interface

IsSystem Property

Description

Checks if this is a predefined system field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsSystem() As Boolean

See Also

IFieldProperty Interface


%%PageItemTitle%%

IFieldProperty Interface

IsToSum Property

Description

Checks if this field is summed for graphs.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsToSum() As Boolean

See Also

IFieldProperty Interface


%%PageItemTitle%%

IFieldProperty Interface

IsVerify Property

Description

Checks if the field requires verification.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsVerify() As Boolean

See Also

IFieldProperty Interface


%%PageItemTitle%%

IFieldProperty Interface

IsVersionControl Property

Description

Checks if the field is under version control.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsVersionControl() As Boolean

See Also

IFieldProperty Interface


%%PageItemTitle%%

IFieldProperty Interface

IsVisibleInNewBug Property

Description

Checks if the field is visible in the New Bug form.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsVisibleInNewBug() As Boolean

See Also

IFieldProperty Interface


%%PageItemTitle%%

IFieldProperty Interface

ReadOnly Property

Description

Checks if this is a read-only field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ReadOnly() As Boolean

See Also

IFieldProperty Interface


%%PageItemTitle%%

IFieldProperty Interface

Root Property

Description

The tree root connected to the field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Root() As Object

See Also

IFieldProperty Interface


%%PageItemTitle%%

IFieldProperty Interface

UserColumnType Property

Description

The user column type: char, number, date, memo, or empty string.

Property type

Read-only property

Syntax (Visual Basic)

Public Property UserColumnType() As String

Remarks

The type of data a user enters in a field. This is not always the same as the DBColumnType. For example, a user may enter date or numerical information in a char database field.

See Also

IFieldProperty Interface


%%PageItemTitle%%

IFieldProperty Interface

UserLabel Property

Description

The user-defined label.

Property type

Read-only property

Syntax (Visual Basic)

Public Property UserLabel() As String

See Also

IFieldProperty Interface


%%PageItemTitle%%

IFieldProperty2 Members

IFieldProperty2 Interface

Description

Properties for object fields.

Remarks

Get a FieldProperty object from TDField.Property.

Public Properties

Public Property DBColumnName | The database column name.
Public Property DBColumnType | The database column type.
Public Property DBTableName | The database table name.
Public Property EditMask | The input mask for string fields.
Public Property EditStyle | The user interface control type used to edit this field.
Public Property FieldSize | The size of the field in the database (-1 for BLOB fields).
Public Property IsActive | Checks if the field is can be displayed in the user interface.
Public Property IsByCode | Checks if the field saves the Tree Node ID (True), or the passed value (False).
Public Property IsCanFilter | Checks if the field is displayed in the filter dialog box.
Public Property IsCanGroup | Checks if items of this type can form groups with others of the same type.
Public Property IsCustomizable | Checks if the field is displayed in the customization UI.
Public Property IsEdit | Checks if the field can be edited.
Public Property IsHistory | Checks if change history is stored for the field.
Public Property IsKeepValue | Checks if the last value for the field is stored.
Public Property IsKey | Checks if this is a database key field.
Public Property IsMail | Checks if e-mail is sent to the users on the notification list when this field changes.
Public Property IsModify | Checks if the user currently logged on the TDConnection is permitted to modify this field.
Public Property IsMultiValue | Checks if the field can store multiple values.
Public Property IsRequired | Checks if this is a required field.
Public Property IsSearchable | Checks if the content of the field is searched by the Search method.
Public Property IsSystem | Checks if this is a predefined system field.
Public Property IsToSum | Checks if this field is summed for graphs.
Public Property IsVerify | Checks if the field requires verification.
Public Property IsVersionControl | Checks if the field is under version control.
Public Property IsVisibleInNewBug | Checks if the field is visible in the New Bug form.
Public Property ReadOnly | Checks if this is a read-only field.
Public Property Root | The tree root connected to the field.
Public Property UserColumnType | The user column type: char, number, date, memo, or empty string.
Public Property UserLabel | The user-defined label.


%%PageItemTitle%%

IFieldProperty2 Interface

DBColumnName Property

Description

The database column name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DBColumnName() As String

See Also

IFieldProperty2 Interface


%%PageItemTitle%%

IFieldProperty2 Interface

DBColumnType Property

Description

The database column type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DBColumnType() As String

See Also

IFieldProperty2 Interface


%%PageItemTitle%%

IFieldProperty2 Interface

DBTableName Property

Description

The database table name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DBTableName() As String

See Also

IFieldProperty2 Interface


%%PageItemTitle%%

IFieldProperty2 Interface

EditMask Property

Description

The input mask for string fields.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EditMask() As String

Remarks

When a user is prompted for data in the user interface, the edit mask is used to present the blank input in the required format.

For more information on input masks, see 'Defining Input Masks' under 'Customizing Project Entities' in the Mercury Quality Center Administrator's Guide.

See Also

IFieldProperty2 Interface


%%PageItemTitle%%

IFieldProperty2 Interface

EditStyle Property

Description

The user interface control type used to edit this field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EditStyle() As String

See Also

IFieldProperty2 Interface


%%PageItemTitle%%

IFieldProperty2 Interface

FieldSize Property

Description

The size of the field in the database (-1 for BLOB fields).

Property type

Read-only property

Syntax (Visual Basic)

Public Property FieldSize() As Long

See Also

IFieldProperty2 Interface


%%PageItemTitle%%

IFieldProperty2 Interface

IsActive Property

Description

Checks if the field is can be displayed in the user interface.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsActive() As Boolean

See Also

IFieldProperty2 Interface


%%PageItemTitle%%

IFieldProperty2 Interface

IsByCode Property

Description

Checks if the field saves the Tree Node ID (True), or the passed value (False).

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsByCode() As Boolean

See Also

IFieldProperty2 Interface


%%PageItemTitle%%

IFieldProperty2 Interface

IsCanFilter Property

Description

Checks if the field is displayed in the filter dialog box.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsCanFilter() As Boolean

See Also

IFieldProperty2 Interface


%%PageItemTitle%%

IFieldProperty2 Interface

IsCanGroup Property

Description

Checks if items of this type can form groups with others of the same type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsCanGroup() As Boolean

See Also

IFieldProperty2 Interface

Example

Using the GroupingItem Object


%%PageItemTitle%%

IFieldProperty2 Interface

IsCustomizable Property

Description

Checks if the field is displayed in the customization UI.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsCustomizable() As Boolean

See Also

IFieldProperty2 Interface


%%PageItemTitle%%

IFieldProperty2 Interface

IsEdit Property

Description

Checks if the field can be edited.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsEdit() As Boolean

See Also

IFieldProperty2 Interface


%%PageItemTitle%%

IFieldProperty2 Interface

IsHistory Property

Description

Checks if change history is stored for the field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsHistory() As Boolean

See Also

IFieldProperty2 Interface


%%PageItemTitle%%

IFieldProperty2 Interface

IsKeepValue Property

Description

Checks if the last value for the field is stored.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsKeepValue() As Boolean

See Also

IFieldProperty2 Interface


%%PageItemTitle%%

IFieldProperty2 Interface

IsKey Property

Description

Checks if this is a database key field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsKey() As Boolean

See Also

IFieldProperty2 Interface


%%PageItemTitle%%

IFieldProperty2 Interface

IsMail Property

Description

Checks if e-mail is sent to the users on the notification list when this field changes.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsMail() As Boolean

See Also

IFieldProperty2 Interface


%%PageItemTitle%%

IFieldProperty2 Interface

IsModify Property

Description

Checks if the user currently logged on the TDConnection is permitted to modify this field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsModify() As Boolean

See Also

IFieldProperty2 Interface


%%PageItemTitle%%

IFieldProperty2 Interface | MultiValue Object

IsMultiValue Property

Description

Checks if the field can store multiple values.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsMultiValue() As Boolean

See Also

IFieldProperty2 Interface | MultiValue Object


%%PageItemTitle%%

IFieldProperty2 Interface

IsRequired Property

Description

Checks if this is a required field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsRequired() As Boolean

See Also

IFieldProperty2 Interface


%%PageItemTitle%%

IFieldProperty2 Interface

IsSearchable Property

Description

Checks if the content of the field is searched by the Search method.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsSearchable() As Boolean

Remarks

IsSearchable refers to the behavior of the ISearchableFactory.Search Method.

See Also

IFieldProperty2 Interface


%%PageItemTitle%%

IFieldProperty2 Interface

IsSystem Property

Description

Checks if this is a predefined system field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsSystem() As Boolean

See Also

IFieldProperty2 Interface


%%PageItemTitle%%

IFieldProperty2 Interface

IsToSum Property

Description

Checks if this field is summed for graphs.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsToSum() As Boolean

See Also

IFieldProperty2 Interface


%%PageItemTitle%%

IFieldProperty2 Interface

IsVerify Property

Description

Checks if the field requires verification.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsVerify() As Boolean

See Also

IFieldProperty2 Interface


%%PageItemTitle%%

IFieldProperty2 Interface

IsVersionControl Property

Description

Checks if the field is under version control.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsVersionControl() As Boolean

See Also

IFieldProperty2 Interface


%%PageItemTitle%%

IFieldProperty2 Interface

IsVisibleInNewBug Property

Description

Checks if the field is visible in the New Bug form.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsVisibleInNewBug() As Boolean

See Also

IFieldProperty2 Interface


%%PageItemTitle%%

IFieldProperty2 Interface

ReadOnly Property

Description

Checks if this is a read-only field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ReadOnly() As Boolean

See Also

IFieldProperty2 Interface


%%PageItemTitle%%

IFieldProperty2 Interface

Root Property

Description

The tree root connected to the field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Root() As Object

See Also

IFieldProperty2 Interface


%%PageItemTitle%%

IFieldProperty2 Interface

UserColumnType Property

Description

The user column type: char, number, date, memo, or empty string.

Property type

Read-only property

Syntax (Visual Basic)

Public Property UserColumnType() As String

Remarks

The type of data a user enters in a field. This is not always the same as the DBColumnType. For example, a user may enter date or numerical information in a char database field.

See Also

IFieldProperty2 Interface


%%PageItemTitle%%

IFieldProperty2 Interface

UserLabel Property

Description

The user-defined label.

Property type

Read-only property

Syntax (Visual Basic)

Public Property UserLabel() As String

See Also

IFieldProperty2 Interface


%%PageItemTitle%%

IFieldProperty3 Members

IFieldProperty3 Interface

Description

Properties for object fields.

Remarks

Get a FieldProperty object from TDField.Property.

Public Methods

Public Method GetRequiredByType Checks if the field is required according to the requirement type.

Public Properties

Public Property DBColumnName | The database column name.
Public Property DBColumnType | The database column type.
Public Property DBTableName | The database table name.
Public Property EditMask | The input mask for string fields.
Public Property EditStyle | The user interface control type used to edit this field.
Public Property FieldSize | The size of the field in the database (-1 for BLOB fields).
Public Property IsActive | Checks if the field is can be displayed in the user interface.
Public Property IsByCode | Checks if the field saves the Tree Node ID (True), or the passed value (False).
Public Property IsCanFilter | Checks if the field is displayed in the filter dialog box.
Public Property IsCanGroup | Checks if items of this type can form groups with others of the same type.
Public Property IsCustomizable | Checks if the field is displayed in the customization UI.
Public Property IsEdit | Checks if the field can be edited.
Public Property IsHistory | Checks if change history is stored for the field.
Public Property IsKeepValue | Checks if the last value for the field is stored.
Public Property IsKey | Checks if this is a database key field.
Public Property IsMail | Checks if e-mail is sent to the users on the notification list when this field changes.
Public Property IsModify | Checks if the user currently logged on the TDConnection is permitted to modify this field.
Public Property IsMultiValue | Checks if the field can store multiple values.
Public Property IsRequired | Checks if this is a required field.
Public Property IsSearchable | Checks if the content of the field is searched by the Search method.
Public Property IsSystem | Checks if this is a predefined system field.
Public Property IsToSum | Checks if this field is summed for graphs.
Public Property IsVerify | Checks if the field requires verification.
Public Property IsVersionControl | Checks if the field is under version control.
Public Property IsVisibleInNewBug | Checks if the field is visible in the New Bug form.
Public Property ReadOnly | Checks if this is a read-only field.
Public Property Root | The tree root connected to the field.
Public Property UserColumnType | The user column type: char, number, date, memo, or empty string.
Public Property UserLabel | The user-defined label.


%%PageItemTitle%%

IFieldProperty3 Interface

GetRequiredByType Method

Description

Checks if the field is required according to the requirement type.

Syntax

Public Function GetRequiredByType() As Boolean

See Also

IFieldProperty3 Interface


%%PageItemTitle%%

IFieldProperty3 Interface

DBColumnName Property

Description

The database column name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DBColumnName() As String

See Also

IFieldProperty3 Interface


%%PageItemTitle%%

IFieldProperty3 Interface

DBColumnType Property

Description

The database column type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DBColumnType() As String

See Also

IFieldProperty3 Interface


%%PageItemTitle%%

IFieldProperty3 Interface

DBTableName Property

Description

The database table name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DBTableName() As String

See Also

IFieldProperty3 Interface


%%PageItemTitle%%

IFieldProperty3 Interface

EditMask Property

Description

The input mask for string fields.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EditMask() As String

Remarks

When a user is prompted for data in the user interface, the edit mask is used to present the blank input in the required format.

For more information on input masks, see 'Defining Input Masks' under 'Customizing Project Entities' in the Mercury Quality Center Administrator's Guide.

See Also

IFieldProperty3 Interface


%%PageItemTitle%%

IFieldProperty3 Interface

EditStyle Property

Description

The user interface control type used to edit this field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EditStyle() As String

See Also

IFieldProperty3 Interface


%%PageItemTitle%%

IFieldProperty3 Interface

FieldSize Property

Description

The size of the field in the database (-1 for BLOB fields).

Property type

Read-only property

Syntax (Visual Basic)

Public Property FieldSize() As Long

See Also

IFieldProperty3 Interface


%%PageItemTitle%%

IFieldProperty3 Interface

IsActive Property

Description

Checks if the field is can be displayed in the user interface.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsActive() As Boolean

See Also

IFieldProperty3 Interface


%%PageItemTitle%%

IFieldProperty3 Interface

IsByCode Property

Description

Checks if the field saves the Tree Node ID (True), or the passed value (False).

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsByCode() As Boolean

See Also

IFieldProperty3 Interface


%%PageItemTitle%%

IFieldProperty3 Interface

IsCanFilter Property

Description

Checks if the field is displayed in the filter dialog box.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsCanFilter() As Boolean

See Also

IFieldProperty3 Interface


%%PageItemTitle%%

IFieldProperty3 Interface

IsCanGroup Property

Description

Checks if items of this type can form groups with others of the same type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsCanGroup() As Boolean

See Also

IFieldProperty3 Interface


%%PageItemTitle%%

IFieldProperty3 Interface

IsCustomizable Property

Description

Checks if the field is displayed in the customization UI.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsCustomizable() As Boolean

See Also

IFieldProperty3 Interface


%%PageItemTitle%%

IFieldProperty3 Interface

IsEdit Property

Description

Checks if the field can be edited.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsEdit() As Boolean

See Also

IFieldProperty3 Interface


%%PageItemTitle%%

IFieldProperty3 Interface

IsHistory Property

Description

Checks if change history is stored for the field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsHistory() As Boolean

See Also

IFieldProperty3 Interface


%%PageItemTitle%%

IFieldProperty3 Interface

IsKeepValue Property

Description

Checks if the last value for the field is stored.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsKeepValue() As Boolean

See Also

IFieldProperty3 Interface


%%PageItemTitle%%

IFieldProperty3 Interface

IsKey Property

Description

Checks if this is a database key field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsKey() As Boolean

See Also

IFieldProperty3 Interface


%%PageItemTitle%%

IFieldProperty3 Interface

IsMail Property

Description

Checks if e-mail is sent to the users on the notification list when this field changes.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsMail() As Boolean

See Also

IFieldProperty3 Interface


%%PageItemTitle%%

IFieldProperty3 Interface

IsModify Property

Description

Checks if the user currently logged on the TDConnection is permitted to modify this field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsModify() As Boolean

See Also

IFieldProperty3 Interface


%%PageItemTitle%%

IFieldProperty3 Interface

IsMultiValue Property

Description

Checks if the field can store multiple values.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsMultiValue() As Boolean

See Also

IFieldProperty3 Interface


%%PageItemTitle%%

IFieldProperty3 Interface

IsRequired Property

Description

Checks if this is a required field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsRequired() As Boolean

See Also

IFieldProperty3 Interface


%%PageItemTitle%%

IFieldProperty3 Interface

IsSearchable Property

Description

Checks if the content of the field is searched by the Search method.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsSearchable() As Boolean

See Also

IFieldProperty3 Interface


%%PageItemTitle%%

IFieldProperty3 Interface

IsSystem Property

Description

Checks if this is a predefined system field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsSystem() As Boolean

See Also

IFieldProperty3 Interface


%%PageItemTitle%%

IFieldProperty3 Interface

IsToSum Property

Description

Checks if this field is summed for graphs.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsToSum() As Boolean

See Also

IFieldProperty3 Interface


%%PageItemTitle%%

IFieldProperty3 Interface

IsVerify Property

Description

Checks if the field requires verification.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsVerify() As Boolean

See Also

IFieldProperty3 Interface


%%PageItemTitle%%

IFieldProperty3 Interface

IsVersionControl Property

Description

Checks if the field is under version control.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsVersionControl() As Boolean

See Also

IFieldProperty3 Interface


%%PageItemTitle%%

IFieldProperty3 Interface

IsVisibleInNewBug Property

Description

Checks if the field is visible in the New Bug form.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsVisibleInNewBug() As Boolean

See Also

IFieldProperty3 Interface


%%PageItemTitle%%

IFieldProperty3 Interface

ReadOnly Property

Description

Checks if this is a read-only field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ReadOnly() As Boolean

See Also

IFieldProperty3 Interface


%%PageItemTitle%%

IFieldProperty3 Interface

Root Property

Description

The tree root connected to the field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Root() As Object

See Also

IFieldProperty3 Interface


%%PageItemTitle%%

IFieldProperty3 Interface

UserColumnType Property

Description

The user column type: char, number, date, memo, or empty string.

Property type

Read-only property

Syntax (Visual Basic)

Public Property UserColumnType() As String

Remarks

The type of data a user enters in a field. This is not always the same as the DBColumnType. For example, a user may enter date or numerical information in a char database field.

See Also

IFieldProperty3 Interface


%%PageItemTitle%%

IFieldProperty3 Interface

UserLabel Property

Description

The user-defined label.

Property type

Read-only property

Syntax (Visual Basic)

Public Property UserLabel() As String

See Also

IFieldProperty3 Interface


%%PageItemTitle%%

IFileData Members

IFileData Interface

Description

Information about a folder or file.

Remarks

A FileData object is returned by ExtendedStorage.Root.

Public Methods

Public Method Items | The folder's child items.
Public Method ModifyDate | The file's modify date.
Public Method Size | The file size in Kbytes.
Public Method Type | The type of object for which data is stored.

Public Properties

Public Property Name The file or folder name.


%%PageItemTitle%%

IFileData Interface

Items Method

Description

The folder's child items.

Syntax

Public Function Items() As List

Remarks

Not applicable to files.

See Also

IFileData Interface


%%PageItemTitle%%

IFileData Interface

ModifyDate Method

Description

The file's modify date.

Syntax

Public Function ModifyDate() As Date

Remarks

Not applicable to folders.

See Also

IFileData Interface


%%PageItemTitle%%

IFileData Interface

Size Method

Description

The file size in Kbytes.

Syntax

Public Function Size() As Long

Remarks

Not applicable to folders.

See Also

IFileData Interface


%%PageItemTitle%%

IFileData Interface

Type Method

Description

The type of object for which data is stored.

Syntax

Public Function Type() As Integer

Return Type

A file or folder code.
A value of the tagTDAPI_FDATA_TYPE Enumeration.

See Also

IFileData Interface


%%PageItemTitle%%

IFileData Interface

Name Property

Description

The file or folder name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name() As String

See Also

IFileData Interface


%%PageItemTitle%%

IFollowUpManager Interface

CancelFollowUp Method

Description

Removes the current entity's follow-up.

Syntax

Public Sub CancelFollowUp()

See Also

IFollowUpManager Interface


%%PageItemTitle%%

IFollowUpManager Interface

FollowUpDate
The date the follow-up is configured to activate.
Description
The description of the follow-up.
See Also OTA COM Type Library

GetFollowUp Method

Description

Gets the date and description for the follow-up associated with the current object.

Syntax

Public Sub GetFollowUp( _
   ByRef FollowUpDate As Date, _
   ByRef Description As String _
)

Parameters

FollowUpDate
The date the follow-up is configured to activate.
Description
The description of the follow-up.

See Also

IFollowUpManager Interface


%%PageItemTitle%%

IFollowUpManager Interface

HasFollowUp Method

Description

Checks if the object has at least one follow-up associated with it.

Syntax

Public Function HasFollowUp() As Boolean

See Also

IFollowUpManager Interface


%%PageItemTitle%%

IFollowUpManager Interface

IsFollowUpOverdue Method

Description

Checks if the date of the unsent follow-up is earlier than the current database server date.

Syntax

Public Function IsFollowUpOverdue() As Boolean

See Also

IFollowUpManager Interface


%%PageItemTitle%%

IFollowUpManager Interface

FollowUpDate
The date the follow-up is configured to activate.
Description
The description of the follow-up.
See Also OTA COM Type Library

SetFollowUp Method

Description

Sets an alert for follow-up for the current object.

Syntax

Public Sub SetFollowUp( _
   ByVal FollowUpDate As Date, _
   ByVal Description As String _
)

Parameters

FollowUpDate
The date the follow-up is configured to activate.
Description
The description of the follow-up.

See Also

IFollowUpManager Interface


%%PageItemTitle%%

IGraph Members

IGraph Interface

Description

Represents a graph built through a method.

Remarks

A Graph object is returned by the Build<graph type>Graph methods of factory objects.

Public Methods

Public Method DrillDown | Drills down to graph data.
Public Method MultiDrillDown | Gets detailed information about a graph area consisting of four sets of coordinates.

Public Properties

Public Property ColCount | The number of columns.
Public Property ColName | Gets the name of the specified column. Column numbers are zero-based.
Public Property ColTotal | The sum of the values in the specified graph data column. The column number is zero-based.
Public Property Data | The data in the specified cell. Column and Row numbers are zero-based.
Public Property GraphTotal | The total number of items represented in the graph.
Public Property MaxValue | The maximum value in the graph.
Public Property RowCount | The number of rows.
Public Property RowName | Gets the row name of the specified row. Row numbers are zero-based.
Public Property RowTotal | The sum of the values in the specified graph data row. The row number is zero-based.
Public Property StartDate | The start date for the graph.


%%PageItemTitle%%

IGraph Interface

pAreas

The area of the graph to retrieve, base on its data grid view.

mAreas

No longer in use. Argument preserved for backward compatibility. Pass an Empty variant.

See Also OTA COM Type Library

DrillDown Method

Description

Drills down to graph data.

Syntax

Public Function DrillDown( _
   ByVal pAreas As Variant, _
   ByVal mAreas As Variant _
) As List

Parameters

pAreas

The area of the graph to retrieve, base on its data grid view.

mAreas

No longer in use. Argument preserved for backward compatibility. Pass an Empty variant.

Return Type

A list of objects representing the data in the specified cell of the graph. For example, in a defect graph, DrillDown returns a list of Bug objects.

Remarks

pAreas is a two-dimensional variant array representing lists of rectangular areas in data grid. The first array dimension size must be 4.
Such an array can be logically modeled as a table with four columns where each row represents one rectangular area. Each rectangular area is a set of four coordinates: TopLeftColNum, TopLeftRowNum, BottomRightColNum, and BottomRightRowNum.

See Also

IGraph Interface


%%PageItemTitle%%

IGraph Interface

Areas

The area of the graph to retrieve, based on its data grid view.

See Also OTA COM Type Library

MultiDrillDown Method

Description

Gets detailed information about a graph area consisting of four sets of coordinates.

Syntax

Public Function MultiDrillDown( _
   ByVal Areas As Variant _
) As List

Parameters

Areas

The area of the graph to retrieve, based on its data grid view.

Return Type

A list of objects representing the data in the specified cell of the graph. For example, in a defect graph, DrillDown returns a list of Bug objects.

Remarks

Areas is a two-dimensional variant array representing a list of rectangular areas in data grid. The first array dimension size must be 4.
Such an array can be logically modeled as a table with four columns where each row represents one rectangular area. Each rectangular area is a set of four coordinates: TopLeftColNum, TopLeftRowNum, BottomRightColNum, and BottomRightRowNum.

See Also

IGraph Interface


%%PageItemTitle%%

IGraph Interface

ColCount Property

Description

The number of columns.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ColCount() As Long

See Also

IGraph Interface


%%PageItemTitle%%

IGraph Interface

Col

The column number (zero-based).

See Also OTA COM Type Library

ColName Property

Description

Gets the name of the specified column. Column numbers are zero-based.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ColName( _
   ByVal Col As Long _
) As String

Parameters

Col

The column number (zero-based).

See Also

IGraph Interface


%%PageItemTitle%%

IGraph Interface

Col

The column number (zero-based).

See Also OTA COM Type Library

ColTotal Property

Description

The sum of the values in the specified graph data column. The column number is zero-based.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ColTotal( _
   ByVal Col As Long _
) As Long

Parameters

Col

The column number (zero-based).

See Also

IGraph Interface


%%PageItemTitle%%

IGraph Interface

Col

The column number (zero-based).

Row

The row number (zero-based).

See Also OTA COM Type Library

Data Property

Description

The data in the specified cell. Column and Row numbers are zero-based.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Data( _
   ByVal Col As Long, _
   ByVal Row As Long _
) As Long

Parameters

Col

The column number (zero-based).

Row

The row number (zero-based).

See Also

IGraph Interface


%%PageItemTitle%%

IGraph Interface

GraphTotal Property

Description

The total number of items represented in the graph.

Property type

Read-only property

Syntax (Visual Basic)

Public Property GraphTotal() As Long

See Also

IGraph Interface


%%PageItemTitle%%

IGraph Interface

MaxValue Property

Description

The maximum value in the graph.

Property type

Read-only property

Syntax (Visual Basic)

Public Property MaxValue() As Long

See Also

IGraph Interface


%%PageItemTitle%%

IGraph Interface

RowCount Property

Description

The number of rows.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RowCount() As Long

See Also

IGraph Interface


%%PageItemTitle%%

IGraph Interface

Row

The row number (zero-based).

See Also OTA COM Type Library

RowName Property

Description

Gets the row name of the specified row. Row numbers are zero-based.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RowName( _
   ByVal Row As Long _
) As String

Parameters

Row

The row number (zero-based).

See Also

IGraph Interface


%%PageItemTitle%%

IGraph Interface

Row

The row number (zero-based).

See Also OTA COM Type Library

RowTotal Property

Description

The sum of the values in the specified graph data row. The row number is zero-based.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RowTotal( _
   ByVal Row As Long _
) As Long

Parameters

Row

The row number (zero-based).

See Also

IGraph Interface


%%PageItemTitle%%

IGraph Interface

StartDate Property

Description

The start date for the graph.

Property type

Read-only property

Syntax (Visual Basic)

Public Property StartDate() As Date

See Also

IGraph Interface


%%PageItemTitle%%

IGraphBuilder Members

IGraphBuilder Interface

Description

Services for creating graphs.

Remarks

The GraphBuilder for the connection is TDConnection.GraphBuilder.

Public Methods

Public Method BuildGraph | Build the graph.
Public Method BuildMultipleGraphs | Build several graphs.
Public Method CreateGraphDefinition | Create an IGraphDefinition object.


%%PageItemTitle%%

IGraphBuilder Interface

pGraphDef

A GraphDefinition Object.

See Also OTA COM Type Library

BuildGraph Method

Description

Build the graph.

Syntax

Public Function BuildGraph( _
   ByVal pGraphDef As Object _
) As Object

Parameters

pGraphDef

A GraphDefinition Object.

Return Type

A Graph Object.

See Also

IGraphBuilder Interface


%%PageItemTitle%%

IGraphBuilder Interface

GraphDefs

A Variant array of GraphDefinition Objects.

See Also OTA COM Type Library

BuildMultipleGraphs Method

Description

Build several graphs.

Syntax

Public Function BuildMultipleGraphs( _
   ByVal GraphDefs As Variant _
) As List

Parameters

GraphDefs

A Variant array of GraphDefinition Objects.

Return Type

A list of Graph Objects.

See Also

IGraphBuilder Interface


%%PageItemTitle%%

IGraphBuilder Interface

Module

A value of the tagTDAPI_MODULE Enumeration.

GraphType

A value of the tagTDAPI_GRAPH_TYPE Enumeration.

See Also OTA COM Type Library

CreateGraphDefinition Method

Description

Create an IGraphDefinition object.

Syntax

Public Function CreateGraphDefinition( _
   ByVal Module As Long, _
   ByVal GraphType As Long _
) As Object

Parameters

Module

A value of the tagTDAPI_MODULE Enumeration.

GraphType

A value of the tagTDAPI_GRAPH_TYPE Enumeration.

Return Type

A GraphDefinition Object.

See Also

IGraphBuilder Interface


%%PageItemTitle%%

IGraphDefinition Members

IGraphDefinition Interface

Description

Configuration information used to build a graph.

Remarks

Get a GraphDefinition object from GraphBuilder.BuildMultipleGraphs.

Public Properties

Public Property Filter | The filter sets the criteria for which data are included in the graph.
Public Property Module | The module specified when the graph definition was created.
Public Property Property | The value of the specified property.
Public Property Type | The graph type


%%PageItemTitle%%

IGraphDefinition Interface

Filter Property

Description

The filter sets the criteria for which data are included in the graph.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

IGraphDefinition Interface


%%PageItemTitle%%

IGraphDefinition Interface

Module Property

Description

The module specified when the graph definition was created.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Module() As Long

See Also

IGraphDefinition Interface


%%PageItemTitle%%

IGraphDefinition Interface

Prop

A value of the tagGRAPH_PROPERTIES Enumeration.

See Also OTA COM Type Library

Property Property

Description

The value of the specified property.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Property( _
   ByVal Prop As Long _
) As Variant

Parameters

Prop

A value of the tagGRAPH_PROPERTIES Enumeration.

See Also

IGraphDefinition Interface


%%PageItemTitle%%

IGraphDefinition Interface

Type Property

Description

The graph type

Property type

Read-only property

Syntax (Visual Basic)

Public Property Type() As Long

See Also

IGraphDefinition Interface


%%PageItemTitle%%

IHierarchyFilter Members

IHierarchyFilter Interface

Description

Services for creation of a filtered list of field objects without SQL.

Remarks

Get a TDFilter from the Filter property of any factory object except ReqFactory or from History.Filter.

A HierarchyFilter is a filter that can return the parents of items as well as the items themselves. Get a HierarchyFilter with ReqFactory.Filter.

A filter cannot handle OR conditions between different fields nor sort on a user-defined field.

A filter always has a primary filter on an entity and may also have a secondary filter, or XFilter, on a second entity. A filter without an XFilter specifies a list of the objects that meet all the criteria specified by setting the TDFilter.Filter or HierarchyFilter.Filter. A filter may have several Filter properties defined.

A filter with an XFilter specifies a list of all the objects of the first type that meet the Filter criteria, and that are associated with the objects of the second type that meet the criteria in the XFilter text. The XFilter text is set with the SetXFilter method or by setting the XFilter property .

For example, a TEST-TESTSET XFilter is a TDfilter derived from a Test factory. The first clause is created by setting the Filter to specify the desired tests. The XFilter is created by getting a second TDFilter from a TestSetFactory and setting the Filter property to specify the desired test sets. The text of this test set TDFilter is the XFilter text of primary test TDFilter.

The result is a list of tests that meet the TDFilter.Filter criteria and are associated with at least one of the test sets that meet the TDFilter.XFilter criteria.

The association between the entities can be direct, as in a links between requirements and defects, or it can be indirect. For example, TSTEST-REQ selects test instances (TSTEST) based on design tests (TEST) that cover requirements.

Example

Getting a filtered, sorted list of requirements | Getting a hierarchical list of requirements

Public Methods

Public Method Clear | Clears the current filter.
Public Method GetXFilter | Gets the cross filter specified by CrossEntities.
Public Method IsClear | Checks whether the filter is clear, including cross-filter settings
Public Method NewList | Creates a new list from current filter.
Public Method Refresh | Reads saved data and refreshes the fetched list according to the current filter, overwriting values in memory.
Public Method SetXFilter | Sets the filter for second entity, called a cross filter.

Public Properties

Public Property CaseSensitive | Indicates if the filter for the specified field is case sensitive. The default is False.
Public Property DataType | The filtered entity type.
Public Property Fields | The list of fields for the TDFilter's parent object.
Public Property Filter | The filter condition for the field specified by the FieldName.
Public Property KeepHierarchical | Indicates whether to include parent objects in list.
Public Property Order | The position of the specified field in the list of the sort fields. (zero-based)
Public Property OrderDirection | The sort order: TDOLE_ASCENDING or TDOLE_DESCENDING
Public Property Text | The full fields filter as text.
Public Property XFilter | The cross filter according to the entity type.


%%PageItemTitle%%

IHierarchyFilter Interface

Clear Method

Description

Clears the current filter.

Syntax

Public Sub Clear()

See Also

IHierarchyFilter Interface


%%PageItemTitle%%

IHierarchyFilter Interface

CrossEntities

Possible values: BUG-ALERT, BUG-REQ, BUG-TEST, BUG-TESTSET, REQ-ALERT, REQ-BUG, REQ-TEST, REQ-TO-FROM-REQ, RUN-BUG, TEST-ALERT, TEST-BUG, TEST-INSTANCE-ALERT, TEST-REQ, TEST-TESTSET, TEST-VER_CTRL, TESTCYCL-ALERT,
TESTSET-BUG, TESTSET-TEST, TSTEST-BUG, TSTEST-REQ, TSTEST-TEST-TEQ, and TSTEST-TSTEST-REQ.

Inclusive

Output variable.

If True, the filter specifies the set of objects where the conditions for the first entity and for the second entity are all true.

If False, the filter specifies the set of objects where the conditions for the first entity are true and the conditions for the second entity are not true.

See Also OTA COM Type Library

GetXFilter Method

Description

Gets the cross filter specified by CrossEntities.

Syntax

Public Function GetXFilter( _
   ByVal CrossEntities As String, _
   ByRef Inclusive As Boolean _
) As String

Parameters

CrossEntities

Possible values: BUG-ALERT, BUG-REQ, BUG-TEST, BUG-TESTSET, REQ-ALERT, REQ-BUG, REQ-TEST, REQ-TO-FROM-REQ, RUN-BUG, TEST-ALERT, TEST-BUG, TEST-INSTANCE-ALERT, TEST-REQ, TEST-TESTSET, TEST-VER_CTRL, TESTCYCL-ALERT,
TESTSET-BUG, TESTSET-TEST, TSTEST-BUG, TSTEST-REQ, TSTEST-TEST-TEQ, and TSTEST-TSTEST-REQ.

Inclusive

Output variable.

If True, the filter specifies the set of objects where the conditions for the first entity and for the second entity are all true.

If False, the filter specifies the set of objects where the conditions for the first entity are true and the conditions for the second entity are not true.

Return Type

The text representation of the filter.

See Also

IHierarchyFilter Interface


%%PageItemTitle%%

IHierarchyFilter Interface

IsClear Method

Description

Checks whether the filter is clear, including cross-filter settings

Syntax

Public Function IsClear() As Boolean

See Also

IHierarchyFilter Interface


%%PageItemTitle%%

IHierarchyFilter Interface

NewList Method

Description

Creates a new list from current filter.

Syntax

Public Function NewList() As List

Return Type

If KeepHierarchical is true, NewList returns a HierarchySupportList, retaining the parents of the items that meet the filter criteria as well as the items themselves.

If KeepHierarchical is False, NewList returns a FactoryList Object.

See Also

IHierarchyFilter Interface


%%PageItemTitle%%

IHierarchyFilter Interface

Refresh Method

Description

Reads saved data and refreshes the fetched list according to the current filter, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IHierarchyFilter Interface


%%PageItemTitle%%

IHierarchyFilter Interface

CrossEntities

Possible values: BUG-ALERT, BUG-REQ, BUG-TEST, BUG-TESTSET, REQ-ALERT, REQ-BUG, REQ-TEST, REQ-TO-FROM-REQ, RUN-BUG, TEST-ALERT, TEST-BUG, TEST-INSTANCE-ALERT, TEST-REQ, TEST-TESTSET, TEST-VER_CTRL, TESTCYCL-ALERT,
TESTSET-BUG, TESTSET-TEST, TSTEST-BUG, TSTEST-REQ, TSTEST-TEST-TEQ, and TSTEST-TSTEST-REQ.

Inclusive

If True, the filter specifies the set of objects where the conditions for the first entity and for the second entity are all true.

If False, the filter specifies the set of objects where the conditions for the first entity are true and the conditions for the second entity are not true.

FilterText

A TDFilter.Text or a string that would be a valid TDFilter.Text

See Also OTA COM Type Library

SetXFilter Method

Description

Sets the filter for second entity, called a cross filter.

Syntax

Public Sub SetXFilter( _
   ByVal CrossEntities As String, _
   ByVal Inclusive As Boolean, _
   ByVal FilterText As String _
)

Parameters

CrossEntities

Possible values: BUG-ALERT, BUG-REQ, BUG-TEST, BUG-TESTSET, REQ-ALERT, REQ-BUG, REQ-TEST, REQ-TO-FROM-REQ, RUN-BUG, TEST-ALERT, TEST-BUG, TEST-INSTANCE-ALERT, TEST-REQ, TEST-TESTSET, TEST-VER_CTRL, TESTCYCL-ALERT,
TESTSET-BUG, TESTSET-TEST, TSTEST-BUG, TSTEST-REQ, TSTEST-TEST-TEQ, and TSTEST-TSTEST-REQ.

Inclusive

If True, the filter specifies the set of objects where the conditions for the first entity and for the second entity are all true.

If False, the filter specifies the set of objects where the conditions for the first entity are true and the conditions for the second entity are not true.

FilterText

A TDFilter.Text or a string that would be a valid TDFilter.Text

Remarks

The best way to ensure that the Filter text is valid, is to create a TDFilter with the cross-filter conditions, and use its Text property as this value.

See Also

IHierarchyFilter Interface


%%PageItemTitle%%

IHierarchyFilter Interface

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

CaseSensitive Property

Description

Indicates if the filter for the specified field is case sensitive. The default is False.

Property type

Read-write property

Syntax (Visual Basic)

Public Property CaseSensitive( _
   ByVal FieldName As String _
) As Boolean

Parameters

FieldName

The name of the field in the project database.

See Also

IHierarchyFilter Interface


%%PageItemTitle%%

IHierarchyFilter Interface

DataType Property

Description

The filtered entity type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DataType() As String

See Also

IHierarchyFilter Interface


%%PageItemTitle%%

IHierarchyFilter Interface

Fields Property

Description

The list of fields for the TDFilter's parent object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

Remarks

The list depends on the factory from which the TDFilter was created. For example, if the filter is created from a TestFactory, the field list will consist of the names of the Test fields: TS_ATTACHMENT, TS_CREATION_DATE, TS_DESCRIPTION, TS_RESPONSIBLE, TS_STATUS, TS_SUBJECT, TS_TEMPLATE, TS_TEST_ID, TS_NAME, and so on.

See Also

IHierarchyFilter Interface


%%PageItemTitle%%

IHierarchyFilter Interface

FieldName

The name of a field of the entity to which the filter is applied.

Only fields whose FieldProperty.IsCanFilter Property is true can be used.

See Also OTA COM Type Library

Filter Property

Description

The filter condition for the field specified by the FieldName.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Filter( _
   ByVal FieldName As String _
) As String

Parameters

FieldName

The name of a field of the entity to which the filter is applied.

Only fields whose FieldProperty.IsCanFilter Property is true can be used.

Remarks

Although the Filter property has the syntax of a single property, a TDFilter can have a collection of Filter properties, each on a different field. Set the Filter property for one field with each command.

A Filter setting is a value of the field, a value with an operator, or a set of values connected by operators.

The values can be constants, special tokens such as "[Today]", "[PreviousWeek]", or "[NextYear]", or folder names, such as "^Subject\LinkFolder^". Use the set filter dialog in the the relevant module of the Quality Center UI to explore the possibilities.

String values with spaces must be quoted, for example, TestFilter.Filter("TS_EXEC_STATUS") = """No Run"""

The value can be an expression with a wild card. For example, testsetFilter.Filter("CY_CYCLE") = "GS*" filters for all test sets whose names begin with "GS".

See Also

IHierarchyFilter Interface

Example

Getting a filtered,sorted list of requirements


%%PageItemTitle%%

IHierarchyFilter Interface

KeepHierarchical Property

Description

Indicates whether to include parent objects in list.

Property type

Read-write property

Syntax (Visual Basic)

Public Property KeepHierarchical() As Boolean

See Also

IHierarchyFilter Interface


%%PageItemTitle%%

IHierarchyFilter Interface

FieldName

The name of the database field whose sort priority is to be retrieved or set.

See Also OTA COM Type Library

Order Property

Description

The position of the specified field in the list of the sort fields. (zero-based)

Property type

Read-write property

Syntax (Visual Basic)

Public Property Order( _
   ByVal FieldName As String _
) As Long

Parameters

FieldName

The name of the database field whose sort priority is to be retrieved or set.

Remarks

When the order of one field is set with this property, no adjustments are made to the positions of other fields. The application is responsible for ensuring that the orders of all the fields are as required, that no two fields occupy the same position, and there are no empty positions.

When two or more fields are assigned the same order, the actual order is undetermined.

See Also

IHierarchyFilter Interface

Example

Getting a filtered, sorted list of requirements


%%PageItemTitle%%

IHierarchyFilter Interface

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

OrderDirection Property

Description

The sort order: TDOLE_ASCENDING or TDOLE_DESCENDING

Property type

Read-write property

Syntax (Visual Basic)

Public Property OrderDirection( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName

The name of the field in the project database.

See Also

IHierarchyFilter Interface


%%PageItemTitle%%

IHierarchyFilter Interface

Text Property

Description

The full fields filter as text.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Text() As String

Remarks

In most places where a string-type Filter argument is passed to a method that selects items, for example to create a filtered list, it is this Text property that is passed to the method.

This text is displayed in the Quality Center user interface above the grid when a filter is set.

See Also

IHierarchyFilter Interface


%%PageItemTitle%%

IHierarchyFilter Interface

CrossEntity

Possible values: BUG-ALERT, BUG-REQ, BUG-TEST, BUG-TESTSET, REQ-ALERT, REQ-BUG, REQ-TEST, REQ-TO-FROM-REQ, RUN-BUG, TEST-ALERT, TEST-BUG, TEST-INSTANCE-ALERT, TEST-REQ, TEST-TESTSET, TEST-VER_CTRL, TESTCYCL-ALERT,
TESTSET-BUG, TESTSET-TEST, TSTEST-BUG, TSTEST-REQ, TSTEST-TEST-TEQ, and TSTEST-TSTEST-REQ.

See Also OTA COM Type Library

XFilter Property

Description

The cross filter according to the entity type.

Property type

Read-write property

Syntax (Visual Basic)

Public Property XFilter( _
   ByVal CrossEntity As String _
) As String

Parameters

CrossEntity

Possible values: BUG-ALERT, BUG-REQ, BUG-TEST, BUG-TESTSET, REQ-ALERT, REQ-BUG, REQ-TEST, REQ-TO-FROM-REQ, RUN-BUG, TEST-ALERT, TEST-BUG, TEST-INSTANCE-ALERT, TEST-REQ, TEST-TESTSET, TEST-VER_CTRL, TESTCYCL-ALERT,
TESTSET-BUG, TESTSET-TEST, TSTEST-BUG, TSTEST-REQ, TSTEST-TEST-TEQ, and TSTEST-TSTEST-REQ.

Remarks

Setting this property is equivalent to calling SetXFilter with Inclusive = TRUE.

See Also

IHierarchyFilter Interface


%%PageItemTitle%%

IHierarchySupportList Members

IHierarchySupportList Collection

Description

Services to create and maintain lists of items and their parent objects.

Remarks

Get a HierarchySupportList from HierarchyFilter.NewList. HierarchySupportList is returned if HierarchyFilter.KeepHierarchical is true. Otherwise a FactoryList is returned.

In addition to the the items that would be included in the FactoryList, the HierarchySupportList includes the parent objects of those items.

Get a FactoryList from Bug.FindSimilarBugs or HierarchyFilter.NewList.

List objects are returned by the NewList method of factory objects and by many other methods and properties.

List numbering begins at one, for example, myList.Item(1).

Example

Getting a hierarchical list of requirements

Public Methods

Public Method Add | Adds a new item to the current list object.
Public Method IndexOfItem | Gets the index of the passed object.
Public Method Insert | Inserts a new item at the specified position.
Public Method Post | Posts changed data for all items in list.
Public Method Refresh | Reads saved list filter and data for all listed objects, overwriting values in memory.
Public Method Remove | Removes the specified item from the current list object.
Public Method Swap | Swaps the two list items specified by their positions.

Public Properties

Public Property _NewEnum | Gets an IEnumVARIANT enumerator. For information on the IEnumVARIANT, see Microsoft documentation.
Public Property Count | The number of items in the list.
Public Property Fields | Gets a list of fields available through this factory.
Public Property IsInFilter | Checks if the item matches the filter criteria of the list to which it belongs.
Public Property Item | Gets an item by index. The index is one-based.
Public Property Ratio | The similarity ratio for the specified item.


%%PageItemTitle%%

IHierarchySupportList Collection

vNew

A value or object reference to be added to the list.

See Also OTA COM Type Library

Add Method

Description

Adds a new item to the current list object.

Syntax

Public Sub Add( _
   ByVal vNew As Variant _
)

Parameters

vNew

A value or object reference to be added to the list.

See Also

IHierarchySupportList Collection


%%PageItemTitle%%

IHierarchySupportList Collection

Item

A reference to one of the objects in the list.

See Also OTA COM Type Library

IndexOfItem Method

Description

Gets the index of the passed object.

Syntax

Public Function IndexOfItem( _
   ByVal Item As Variant _
) As Long

Parameters

Item

A reference to one of the objects in the list.

See Also

IHierarchySupportList Collection


%%PageItemTitle%%

IHierarchySupportList Collection

Pos

The position into which to insert the item.

vNew

A value or object reference to be inserted in the list.

See Also OTA COM Type Library

Insert Method

Description

Inserts a new item at the specified position.

Syntax

Public Sub Insert( _
   ByVal Pos As Long, _
   ByVal vNew As Variant _
)

Parameters

Pos

The position into which to insert the item.

vNew

A value or object reference to be inserted in the list.

See Also

IHierarchySupportList Collection


%%PageItemTitle%%

IHierarchySupportList Collection

Post Method

Description

Posts changed data for all items in list.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IHierarchySupportList Collection


%%PageItemTitle%%

IHierarchySupportList Collection

Refresh Method

Description

Reads saved list filter and data for all listed objects, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IHierarchySupportList Collection


%%PageItemTitle%%

IHierarchySupportList Collection

Index

The position in the list of the item to be removed.

See Also OTA COM Type Library

Remove Method

Description

Removes the specified item from the current list object.

Syntax

Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index

The position in the list of the item to be removed.

See Also

IHierarchySupportList Collection


%%PageItemTitle%%

IHierarchySupportList Collection

Pos1

Put the item in this position in position Pos2.

Pos2

Put the item in this position in position Pos1.

See Also OTA COM Type Library

Swap Method

Description

Swaps the two list items specified by their positions.

Syntax

Public Sub Swap( _
   ByVal Pos1 As Long, _
   ByVal Pos2 As Long _
)

Parameters

Pos1

Put the item in this position in position Pos2.

Pos2

Put the item in this position in position Pos1.

See Also

IHierarchySupportList Collection


%%PageItemTitle%%

IHierarchySupportList Collection

_NewEnum Property

Description

Gets an IEnumVARIANT enumerator. For information on the IEnumVARIANT, see Microsoft documentation.

Property type

Read-only property

Syntax (Visual Basic)

Public Property _NewEnum() As Unknown

See Also

IHierarchySupportList Collection


%%PageItemTitle%%

IHierarchySupportList Collection

Count Property

Description

The number of items in the list.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

IHierarchySupportList Collection


%%PageItemTitle%%

IHierarchySupportList Collection

Fields Property

Description

Gets a list of fields available through this factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

IHierarchySupportList Collection


%%PageItemTitle%%

IHierarchySupportList Collection

Index

The position in the list.

See Also OTA COM Type Library

IsInFilter Property

Description

Checks if the item matches the filter criteria of the list to which it belongs.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsInFilter( _
   ByVal Index As Long _
) As Boolean

Parameters

Index

The position in the list.

Remarks

An item may be in a HierarchySupportList even though it does not meet the filter criteria if it is the parent of an item that does meet the criteria.

See Also

IHierarchySupportList Collection


%%PageItemTitle%%

IHierarchySupportList Collection

Index

The index is 1 to Count.

See Also OTA COM Type Library

Item Property

Description

Gets an item by index. The index is one-based.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal Index As Long _
) As Variant

Parameters

Index

The index is 1 to Count.

See Also

IHierarchySupportList Collection


%%PageItemTitle%%

IHierarchySupportList Collection

Index

Index is 1 to Count.

See Also OTA COM Type Library

Ratio Property

Description

The similarity ratio for the specified item.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Ratio( _
   ByVal Index As Long _
) As Long

Parameters

Index

Index is 1 to Count.

Remarks

The Ratio method is meaningful when the list is acquired as a result of call to FindSimilarBug, otherwise it returns 0 (in VB) and an HRESULT of S_FALSE.

See Also

IHierarchySupportList Collection


%%PageItemTitle%%

IHistory Members

IHistory Interface

Description

Supports retrieval of a list of history records for objects such as Test, Bug, Step, and others.

Remarks

Get a History object from the History property of any factory object that implements IBaseFactory, IBaseFactoryEx , or IBaseFieldEx.

You can also get a History object from entities that have a History property, such as Bug.History. For a complete list of objects with a History property, see History Property in the index.

Public Methods

Public Method ClearHistory | Clears the history records selected by the filter.
Public Method NewList | Gets filtered list of history data records.

Public Properties

Public Property Filter The filter object for the history item.


%%PageItemTitle%%

IHistory Interface

Filter

A TDFilter.Text that defines which history records will be deleted.

See Also OTA COM Type Library

ClearHistory Method

Description

Clears the history records selected by the filter.

Syntax

Public Sub ClearHistory( _
   Optional ByVal Filter As String = "" _
)

Parameters

Filter

A TDFilter.Text that defines which history records will be deleted.

See Also

IHistory Interface


%%PageItemTitle%%

IHistory Interface

Filter

A string containing one of the following:

  • Any field name. Get all history records for the current object in which the specified field was changed. The format for the string is [FieldName]<name>, for example, [FieldName]BG_STATUS.
  • An empty string. Get all history records for the current object.
See Also OTA COM Type Library

NewList Method

Description

Gets filtered list of history data records.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A string containing one of the following:

  • Any field name. Get all history records for the current object in which the specified field was changed. The format for the string is [FieldName]<name>, for example, [FieldName]BG_STATUS.
  • An empty string. Get all history records for the current object.

Return Type

A list of all HistoryRecord objects that match the search criteria. The list index is 1-based.

See Also

IHistory Interface


%%PageItemTitle%%

IHistory Interface

Filter Property

Description

The filter object for the history item.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

IHistory Interface


%%PageItemTitle%%

IHistoryRecord Members

IHistoryRecord Interface

Description

Represents a single history change.

Remarks

History record objects are the items in the list returned by History.NewList.

Public Properties

Public Property ChangeDate | The change date according to database server.
Public Property Changer | The name of the user who made the change.
Public Property FieldName | The name of the changed field.
Public Property ItemKey | The item key for the changed item.
Public Property NewValue | The value after the change.


%%PageItemTitle%%

IHistoryRecord Interface

ChangeDate Property

Description

The change date according to database server.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ChangeDate() As Date

See Also

IHistoryRecord Interface


%%PageItemTitle%%

IHistoryRecord Interface

Changer Property

Description

The name of the user who made the change.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Changer() As String

See Also

IHistoryRecord Interface


%%PageItemTitle%%

IHistoryRecord Interface

FieldName Property

Description

The name of the changed field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FieldName() As String

See Also

IHistoryRecord Interface


%%PageItemTitle%%

IHistoryRecord Interface

ItemKey Property

Description

The item key for the changed item.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ItemKey() As Variant

See Also

IHistoryRecord Interface


%%PageItemTitle%%

IHistoryRecord Interface

NewValue Property

Description

The value after the change.

Property type

Read-only property

Syntax (Visual Basic)

Public Property NewValue() As Variant

See Also

IHistoryRecord Interface


%%PageItemTitle%%

IHistoryRecord2 Members

IHistoryRecord2 Interface

Description

Represents a single history change.

Remarks

History record objects are the items in the list returned by History.NewList.

Public Properties

Public Property ChangeDate | The change date according to database server.
Public Property Changer | The name of the user who made the change.
Public Property FieldName | The name of the changed field.
Public Property ItemKey | The item key for the changed item.
Public Property NewValue | The value after the change.
Public Property OldValue | The value before the change.


%%PageItemTitle%%

IHistoryRecord2 Interface

ChangeDate Property

Description

The change date according to database server.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ChangeDate() As Date

See Also

IHistoryRecord2 Interface


%%PageItemTitle%%

IHistoryRecord2 Interface

Changer Property

Description

The name of the user who made the change.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Changer() As String

See Also

IHistoryRecord2 Interface


%%PageItemTitle%%

IHistoryRecord2 Interface

FieldName Property

Description

The name of the changed field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FieldName() As String

See Also

IHistoryRecord2 Interface


%%PageItemTitle%%

IHistoryRecord2 Interface

ItemKey Property

Description

The item key for the changed item.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ItemKey() As Variant

See Also

IHistoryRecord2 Interface


%%PageItemTitle%%

IHistoryRecord2 Interface

NewValue Property

Description

The value after the change.

Property type

Read-only property

Syntax (Visual Basic)

Public Property NewValue() As Variant

See Also

IHistoryRecord2 Interface


%%PageItemTitle%%

IHistoryRecord2 Interface

OldValue Property

Description

The value before the change.

Property type

Read-only property

Syntax (Visual Basic)

Public Property OldValue() As Variant

See Also

IHistoryRecord2 Interface


%%PageItemTitle%%

IHost Members

IHost Interface

Description

Represents a single host server. The ID of a host is its name.

Remarks

Get a Host object from the HostFactory.

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Description | A description of the host server.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The name of the host server.
Public Property RexServer | The remote execution server name as it appears on the LAN.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

IHost Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IHost Interface


%%PageItemTitle%%

IHost Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IHost Interface


%%PageItemTitle%%

IHost Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IHost Interface


%%PageItemTitle%%

IHost Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

IHost Interface


%%PageItemTitle%%

IHost Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

IHost Interface


%%PageItemTitle%%

IHost Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

IHost Interface


%%PageItemTitle%%

IHost Interface

Description Property

Description

A description of the host server.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Description() As String

See Also

IHost Interface


%%PageItemTitle%%

IHost Interface

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName

The name of the field in the project database.

See Also

IHost Interface


%%PageItemTitle%%

IHost Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

IHost Interface


%%PageItemTitle%%

IHost Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

IHost Interface


%%PageItemTitle%%

IHost Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

IHost Interface


%%PageItemTitle%%

IHost Interface

Name Property

Description

The name of the host server.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name() As String

See Also

IHost Interface


%%PageItemTitle%%

IHost Interface

RexServer Property

Description

The remote execution server name as it appears on the LAN.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RexServer() As String

See Also

IHost Interface


%%PageItemTitle%%

IHost Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

IHost Interface


%%PageItemTitle%%

IHostGroup Members

IHostGroup Interface

Description

Services for managing a group of host servers.

Remarks

Get a HostGroup object from the HostGroupFactory.

Public Methods

Public Method AddHost | Adds a host to the group.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method NewList | Gets a list of all hosts in the group.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method RemoveHost | Removes the specified host from the group.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | Gets the host group name.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

IHostGroup Interface

Val

Either a Host Object, the host name, or a string array containing the names of the hosts to add.

See Also OTA COM Type Library

AddHost Method

Description

Adds a host to the group.

Syntax

Public Sub AddHost( _
   ByVal Val As Variant _
)

Parameters

Val

Either a Host Object, the host name, or a string array containing the names of the hosts to add.

See Also

IHostGroup Interface


%%PageItemTitle%%

IHostGroup Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If the object is locked, no other user can change or delete it.

The object is unlocked on a Post or Refresh operation and when the connection is logged off the project.

See Also

IHostGroup Interface


%%PageItemTitle%%

IHostGroup Interface

NewList Method

Description

Gets a list of all hosts in the group.

Syntax

Public Function NewList() As List

See Also

IHostGroup Interface


%%PageItemTitle%%

IHostGroup Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IHostGroup Interface


%%PageItemTitle%%

IHostGroup Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IHostGroup Interface


%%PageItemTitle%%

IHostGroup Interface

Val

Either a Host Object, the host name, or a string array containing the names of the hosts to add.

See Also OTA COM Type Library

RemoveHost Method

Description

Removes the specified host from the group.

Syntax

Public Sub RemoveHost( _
   ByVal Val As Variant _
)

Parameters

Val

Either a Host Object, the host name, or a string array containing the names of the hosts to add.

See Also

IHostGroup Interface


%%PageItemTitle%%

IHostGroup Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

IHostGroup Interface


%%PageItemTitle%%

IHostGroup Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users.

See Also

IHostGroup Interface


%%PageItemTitle%%

IHostGroup Interface

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

IHostGroup Interface


%%PageItemTitle%%

IHostGroup Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

IHostGroup Interface


%%PageItemTitle%%

IHostGroup Interface

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName

The name of the field in the project database.

See Also

IHostGroup Interface


%%PageItemTitle%%

IHostGroup Interface

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

IHostGroup Interface


%%PageItemTitle%%

IHostGroup Interface

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IHostGroup Interface


%%PageItemTitle%%

IHostGroup Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

IHostGroup Interface


%%PageItemTitle%%

IHostGroup Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

IHostGroup Interface


%%PageItemTitle%%

IHostGroup Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

IHostGroup Interface


%%PageItemTitle%%

IHostGroup Interface

Name Property

Description

Gets the host group name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name() As String

See Also

IHostGroup Interface


%%PageItemTitle%%

IHostGroup Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

IHostGroup Interface


%%PageItemTitle%%

IHostGroupFactory Members

IHostGroupFactory Interface

Description

Services for managing definitions of groups of host servers.

Remarks

The HostGroupFactory for the connection is TDConnection.HostGroupFactory.

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveHost | Removes host from all groups.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

IHostGroupFactory Interface

ItemData

The name of the group.

See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData

The name of the group.

Remarks

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

[Visual Basic]

Dim bgf As BugFactory
Dim bg As Bug
Dim attf As AttachmentFactory
Dim att As Attachment
Dim attList As List

' Get the factory object
 Set bgf = tdc.BugFactory
' Use defect #1
 Set bg = bgf.Item(1)
 Set attf = bg.Attachments

' Creating a new attachment
' Create virtual object, then populate the properties
 Set att = attf.AddItem(Null)
 att.FileName = Text1.Text
 att.Type = TDATT_INTERNET

' Saving the object with validity check
 att.Post

' Display the attachments
' Add the display-only items without a Post
 List1.Clear
 Set attList = attf.NewList("")
 For i = 1 To attList.Count

      Set att = attList.Item(i)
      List1.AddItem (att.Name)

 Next

See Also

IHostGroupFactory Interface


%%PageItemTitle%%

IHostGroupFactory Interface

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

IHostGroupFactory Interface


%%PageItemTitle%%

IHostGroupFactory Interface

Host

The name of the host.

See Also OTA COM Type Library

RemoveHost Method

Description

Removes host from all groups.

Syntax

Public Sub RemoveHost( _
   ByVal Host As Variant _
)

Parameters

Host

The name of the host.

See Also

IHostGroupFactory Interface


%%PageItemTitle%%

IHostGroupFactory Interface

ItemKey

Either a HostGroup Object, the host group name, or a Variant Array of the names of the host grops to remove.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey

Either a HostGroup Object, the host group name, or a Variant Array of the names of the host grops to remove.

See Also

IHostGroupFactory Interface


%%PageItemTitle%%

IHostGroupFactory Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

IHostGroupFactory Interface


%%PageItemTitle%%

IHostGroupFactory Interface

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

IHostGroupFactory Interface


%%PageItemTitle%%

IHostGroupFactory Interface

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

IHostGroupFactory Interface


%%PageItemTitle%%

IHostGroupFactory Interface

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IHostGroupFactory Interface


%%PageItemTitle%%

IHostGroupFactory Interface

ItemKey

The name of the group.

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey

The name of the group.

See Also

IHostGroupFactory Interface


%%PageItemTitle%%

ILink Members

ILink Interface

Description

Represents an association between a Bug and another entity.

Remarks

Get a Link object from a LinkFactory.

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Comment | The link summary comment.
Public Property CreatedBy | The user who created the link.
Public Property CreationDate | The link creation date.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property LinkedByEntity | The entity that initiated the link.
Public Property LinkType | The link type.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property SourceEntity | The source entity object of the link.
Public Property TargetEntity | The target entity object of the link.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

ILink Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ILink Interface


%%PageItemTitle%%

ILink Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ILink Interface


%%PageItemTitle%%

ILink Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ILink Interface


%%PageItemTitle%%

ILink Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

ILink Interface


%%PageItemTitle%%

ILink Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

ILink Interface


%%PageItemTitle%%

ILink Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

ILink Interface


%%PageItemTitle%%

ILink Interface

Comment Property

Description

The link summary comment.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comment() As String

See Also

ILink Interface


%%PageItemTitle%%

ILink Interface

CreatedBy Property

Description

The user who created the link.

Property type

Read-write property

Syntax (Visual Basic)

Public Property CreatedBy() As String

See Also

ILink Interface


%%PageItemTitle%%

ILink Interface

CreationDate Property

Description

The link creation date.

Property type

Read-write property

Syntax (Visual Basic)

Public Property CreationDate() As Date

See Also

ILink Interface


%%PageItemTitle%%

ILink Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

ILink Interface


%%PageItemTitle%%

ILink Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

ILink Interface


%%PageItemTitle%%

ILink Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

ILink Interface


%%PageItemTitle%%

ILink Interface

LinkedByEntity Property

Description

The entity that initiated the link.

Property type

Read-only property

Syntax (Visual Basic)

Public Property LinkedByEntity() As Object

Remarks

With a Link from any entity other than a Bug to a Bug, the LinkedByEntity shows the entity that created the link. For example, a link between a Test and a Bug may have been created by a test instance, a run, or a step. Whichever object created the link between the Test and Bug will be the LinkedByEntity.

With a Link between two Bugs, this property has no meaning.

See Also

ILink Interface


%%PageItemTitle%%

ILink Interface

LinkType Property

Description

The link type.

Property type

Read-write property

Syntax (Visual Basic)

Public Property LinkType() As String

See Also

ILink Interface


%%PageItemTitle%%

ILink Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

ILink Interface


%%PageItemTitle%%

ILink Interface

SourceEntity Property

Description

The source entity object of the link.

Property type

Read-only property

Syntax (Visual Basic)

Public Property SourceEntity() As Object

Remarks

SourceEntity and TargetEntity are not fixed attributes of an association. They reflect the point of view of the factory from which the Link Object is obtained. SourceEntity and TargetEntity will always be the same two objects for a given association. However, which is the source and which the target may change depending on the Link Object.

For example, when an association between a Test and a Bug is viewed from the Test side, that is, when the Link object is acquired from the BugLinkFactory of the Test, SourceEntity is the Test and TargetEntity is the Bug. If a Link object representing the same association is acquired from the LinkFactory of the Bug, SourceEntity is the Bug and TargetEntity is the Test.

See Also

ILink Interface


%%PageItemTitle%%

ILink Interface

TargetEntity Property

Description

The target entity object of the link.

Property type

Read-write property

Syntax (Visual Basic)

Public Property TargetEntity() As Object

Remarks

SourceEntity and TargetEntity are not fixed attributes of an association. They reflect the point of view of the factory from which the Link Object is obtained. SourceEntity and TargetEntity will always be the same two objects for a given association. However, which is the source and which the target may change depending on the Link Object.

For example, when an association between a Test and a Bug is viewed from the Test side, that is, when the Link object is acquired from the BugLinkFactory of the Test, SourceEntity is the Test and TargetEntity is the Bug. If a Link object representing the same association is acquired from the LinkFactory of the Bug, SourceEntity is the Bug and TargetEntity is the Test.

See Also

ILink Interface


%%PageItemTitle%%

ILink Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

ILink Interface


%%PageItemTitle%%

ILinkable Interface

BugLinkFactory Property

Description

The bug link factory that manages the links of the current object to its associated defects.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BugLinkFactory() As Object

See Also

ILinkable Interface

Example

Displaying links | Creating various entities and linking them


%%PageItemTitle%%

ILinkable Interface

HasLinkage Property

Description

Checks if the current object has at least one associated Bug.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasLinkage() As Boolean

See Also

ILinkable Interface


%%PageItemTitle%%

ILinkable Interface

HasOthersLinkage Property

Description

Checks if the current Bug object has at least one associated object that is not another Bug object. Defined only for Bug objects.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasOthersLinkage() As Boolean

See Also

ILinkable Interface


%%PageItemTitle%%

ILinkable Interface

LinkFactory Property

Description

The link factory of the current defect object that enables viewing the links. Defined only for Bug objects.

Property type

Read-only property

Syntax (Visual Basic)

Public Property LinkFactory() As Object

Remarks

LinkFactory cannot be used to create new items.

See Also

ILinkable Interface


%%PageItemTitle%%

ILinkFactory Members

ILinkFactory Interface

Description

Services to manage Link objects.

Services to manage Link objects.

Remarks

Get a LinkFactory reference for creating lists, viewing properties, and adding and removing items from the BugLinkFactory Property property of the ILinkable implemented interface of any object that can be linked to a defect, such as Bug, Req, Run, Step, Test, TestSet, or TSTest.

Get a LinkFactory reference for creating lists and viewing properties from the LinkFactory Property of the ILinkable implemented interface of the Bug Object.

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property FullLinkage | Indicates that NewList returns child objects in addition to the current object.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

ILinkFactory Interface

ItemData

There are four options for ItemData:

  • The Bug.ID of the bug that will be the Link.TargetEntity of the link.
  • A Bug object.
  • An List of Bug.IDs that will all be targets.
  • Null. Initially creating a virtual object with Null ensures that you cannot then Post until all required fields are initialized.

See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData

There are four options for ItemData:

  • The Bug.ID of the bug that will be the Link.TargetEntity of the link.
  • A Bug object.
  • An List of Bug.IDs that will all be targets.
  • Null. Initially creating a virtual object with Null ensures that you cannot then Post until all required fields are initialized.

Return Type

A Link Object.

Remarks

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

[Visual Basic]

Dim bgf As BugFactory
Dim bg As Bug
Dim attf As AttachmentFactory
Dim att As Attachment
Dim attList As List

' Get the factory object
 Set bgf = tdc.BugFactory
' Use defect #1
 Set bg = bgf.Item(1)
 Set attf = bg.Attachments

' Creating a new attachment
' Create virtual object, then populate the properties
 Set att = attf.AddItem(Null)
 att.FileName = Text1.Text
 att.Type = TDATT_INTERNET

' Saving the object with validity check
 att.Post

' Display the attachments
' Add the display-only items without a Post
 List1.Clear
 Set attList = attf.NewList("")
 For i = 1 To attList.Count

      Set att = attList.Item(i)
      List1.AddItem (att.Name)

 Next

See Also

ILinkFactory Interface


%%PageItemTitle%%

ILinkFactory Interface

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

Remarks

For hierarchical lists, if FullLinkage is true, the returned list includes the child objects of the items that meet the filter criteria.

See Also

ILinkFactory Interface


%%PageItemTitle%%

ILinkFactory Interface

ItemKey

A Link.ID.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey

A Link.ID.

See Also

ILinkFactory Interface


%%PageItemTitle%%

ILinkFactory Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

ILinkFactory Interface


%%PageItemTitle%%

ILinkFactory Interface

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

ILinkFactory Interface


%%PageItemTitle%%

ILinkFactory Interface

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

ILinkFactory Interface


%%PageItemTitle%%

ILinkFactory Interface

FullLinkage Property

Description

Indicates that NewList returns child objects in addition to the current object.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FullLinkage() As Boolean

Remarks

Meaningful only for hierarchical lists.

See Also

ILinkFactory Interface


%%PageItemTitle%%

ILinkFactory Interface

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

Remarks

Inherited property not applicable to LinkFactory.

See Also

ILinkFactory Interface


%%PageItemTitle%%

ILinkFactory Interface

ItemKey

Summary
A Link.ID.

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey

Summary
A Link.ID.

See Also

ILinkFactory Interface


%%PageItemTitle%%

IList Members

IList Collection

Description

Services to create and maintain lists. Use any factory object to create any number of list instances for objects in the factory.

Remarks

List objects are returned by the NewList method of factory objects and by many other methods and properties.

List numbering begins at one, for example, myList.Item(1).

Public Methods

Public Method Add | Adds a new item to the current list object.
Public Method Insert | Inserts a new item at the specified position.
Public Method Remove | Removes the specified item from the current list object.
Public Method Swap | Swaps the two list items specified by their positions.

Public Properties

Public Property _NewEnum | Gets an IEnumVARIANT enumerator. For information on the IEnumVARIANT, see Microsoft documentation.
Public Property Count | The number of items in the list.
Public Property Item | Gets an item by index. The index is one-based.


%%PageItemTitle%%

IList Collection

vNew
A reference to the object to be added.

A value or object reference to be added to the list.

See Also OTA COM Type Library

Add Method

Description

Adds a new item to the current list object.

Syntax

Public Sub Add( _
   ByVal vNew As Variant _
)

Parameters

vNew
A reference to the object to be added.

A value or object reference to be added to the list.

See Also

IList Collection


%%PageItemTitle%%

IList Collection

Pos
The position in the list where the item is to be inserted.

The position into which to insert the item.

vNew
A reference to the object to be added.

A value or object reference to be inserted in the list.

See Also OTA COM Type Library

Insert Method

Description

Inserts a new item at the specified position.

Syntax

Public Sub Insert( _
   ByVal Pos As Long, _
   ByVal vNew As Variant _
)

Parameters

Pos
The position in the list where the item is to be inserted.

The position into which to insert the item.

vNew
A reference to the object to be added.

A value or object reference to be inserted in the list.

See Also

IList Collection


%%PageItemTitle%%

IList Collection

Index
The index of the item to be removed.

The position in the list of the item to be removed.

See Also OTA COM Type Library

Remove Method

Description

Removes the specified item from the current list object.

Syntax

Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
The index of the item to be removed.

The position in the list of the item to be removed.

See Also

IList Collection


%%PageItemTitle%%

IList Collection

Pos1
The position of the first element to be swapped with the second element.

Put the item in this position in position Pos2.

Pos2
The position of the second element to be swapped with the first element.

Put the item in this position in position Pos1.

See Also OTA COM Type Library

Swap Method

Description

Swaps the two list items specified by their positions.

Syntax

Public Sub Swap( _
   ByVal Pos1 As Long, _
   ByVal Pos2 As Long _
)

Parameters

Pos1
The position of the first element to be swapped with the second element.

Put the item in this position in position Pos2.

Pos2
The position of the second element to be swapped with the first element.

Put the item in this position in position Pos1.

See Also

IList Collection


%%PageItemTitle%%

IList Collection

_NewEnum Property

Description

Gets an IEnumVARIANT enumerator. For information on the IEnumVARIANT, see Microsoft documentation.

Property type

Read-only property

Syntax (Visual Basic)

Public Property _NewEnum() As Unknown

See Also

IList Collection


%%PageItemTitle%%

IList Collection

Count Property

Description

The number of items in the list.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

IList Collection


%%PageItemTitle%%

IList Collection

Index

The index is 1 to Count.

See Also OTA COM Type Library

Item Property

Description

Gets an item by index. The index is one-based.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal Index As Long _
) As Variant

Parameters

Index

The index is 1 to Count.

See Also

IList Collection


%%PageItemTitle%%

IMultiValue Members

IMultiValue Interface

Description

Represents several values stored in a single field.

Remarks

The reference to a MultiValue object is the FieldMultiValue Property of the IBaseField2 Implemented Interface of the object.

Example

Getting and assigning multiple values for a Bug record

Public Properties

Public Property List | List of values. Each item is the string representation of a single value.
Public Property Text | Text representation of values list. Items are separated with a semicolon.


%%PageItemTitle%%

IMultiValue Interface

List Property

Description

List of values. Each item is the string representation of a single value.

Property type

Read-write property

Syntax (Visual Basic)

Public Property List() As List

Remarks

After assigning values, use the MultiValue object to set the FieldMultiValue Property.

The values in the list are the same as those in Text Property, except they are presented as a list of individual strings rather than a single string.

See Also

IMultiValue Interface


%%PageItemTitle%%

IMultiValue Interface

Text Property

Description

Text representation of values list. Items are separated with a semicolon.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Text() As String

Remarks

After assigning values, use the MultiValue object to set the FieldMultiValue Property.

The value of Text is all the strings in the List Property, concatenated into a single string of semicolon-separated values.

See Also

IMultiValue Interface


%%PageItemTitle%%

IObjectLockingSupport Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IObjectLockingSupport Interface


%%PageItemTitle%%

IObjectLockingSupport Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

IObjectLockingSupport Interface


%%PageItemTitle%%

IObjectLockingSupport Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

IObjectLockingSupport Interface


%%PageItemTitle%%

IOnExecEventSchedulerActionParams Members

IOnExecEventSchedulerActionParams Interface

Description

Handles the action parameter list.

Remarks

An IOnExecEventSchedulerActionParam reference can be returned from ExecSettings.OnExecEventSchedulerActionParams, depending on the input arguments.

Public Properties

Public Property OnExecEventSchedulerAction The action to be taken.


%%PageItemTitle%%

IOnExecEventSchedulerActionParams Interface

OnExecEventSchedulerAction Property

Description

The action to be taken.

Property type

Read-only property

Syntax (Visual Basic)

Public Property OnExecEventSchedulerAction() As Long

See Also

IOnExecEventSchedulerActionParams Interface


%%PageItemTitle%%

IOnExecEventSchedulerRestartParams Members

IOnExecEventSchedulerRestartParams Interface

Description

Defines behavior after completion of a test set.

Remarks

An IOnExecEventSchedulerActionParam reference can be returned from ExecSettings.OnExecEventSchedulerActionParams, depending on the input arguments.

Public Properties

Public Property CleanupTest | The test ID of the test to run before each rerun.
Public Property NumberOfRetries | The number of retries if a test fails.
Public Property OnExecEventSchedulerAction | The action to be taken.


%%PageItemTitle%%

IOnExecEventSchedulerRestartParams Interface

CleanupTest Property

Description

The test ID of the test to run before each rerun.

Property type

Read-write property

Syntax (Visual Basic)

Public Property CleanupTest() As Variant

See Also

IOnExecEventSchedulerRestartParams Interface


%%PageItemTitle%%

IOnExecEventSchedulerRestartParams Interface

NumberOfRetries Property

Description

The number of retries if a test fails.

Property type

Read-write property

Syntax (Visual Basic)

Public Property NumberOfRetries() As Long

See Also

IOnExecEventSchedulerRestartParams Interface


%%PageItemTitle%%

IOnExecEventSchedulerRestartParams Interface

OnExecEventSchedulerAction Property

Description

The action to be taken.

Property type

Read-only property

Syntax (Visual Basic)

Public Property OnExecEventSchedulerAction() As Long

See Also

IOnExecEventSchedulerRestartParams Interface


%%PageItemTitle%%

IParam Members

IParam Interface

Description

Services for managing parameters for a Command object.

Public Methods

Public Method AddParam | Adds new parameter to Command object.
Public Method DeleteParam | Deletes the specified parameter from Command object.
Public Method DeleteParams | Deletes all parameters from Command object.

Public Properties

Public Property Count | Number of parameters in current command.
Public Property ParamIndex | The parameter index by parameter name.
Public Property ParamName | The parameter name by parameter index. The index is 0-based.
Public Property ParamType | The data type of the specified parameter. The index is 0-based.
Public Property ParamValue | The parameter value.


%%PageItemTitle%%

IParam Interface

Name

The name of the new parameter.

InitialValue

The initial value.

See Also OTA COM Type Library

AddParam Method

Description

Adds new parameter to Command object.

Syntax

Public Sub AddParam( _
   ByVal Name As String, _
   ByVal InitialValue As Variant _
)

Parameters

Name

The name of the new parameter.

InitialValue

The initial value.

See Also

IParam Interface


%%PageItemTitle%%

IParam Interface

Key

The parameter index or name. The index is 0-based.

See Also OTA COM Type Library

DeleteParam Method

Description

Deletes the specified parameter from Command object.

Syntax

Public Sub DeleteParam( _
   ByVal Key As Variant _
)

Parameters

Key

The parameter index or name. The index is 0-based.

See Also

IParam Interface


%%PageItemTitle%%

IParam Interface

DeleteParams Method

Description

Deletes all parameters from Command object.

Syntax

Public Sub DeleteParams()

See Also

IParam Interface


%%PageItemTitle%%

IParam Interface

Count Property

Description

Number of parameters in current command.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

IParam Interface


%%PageItemTitle%%

IParam Interface

Name

The parameter name.

See Also OTA COM Type Library

ParamIndex Property

Description

The parameter index by parameter name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ParamIndex( _
   ByVal Name As String _
) As Long

Parameters

Name

The parameter name.

See Also

IParam Interface


%%PageItemTitle%%

IParam Interface

Index

The parameter index.

See Also OTA COM Type Library

ParamName Property

Description

The parameter name by parameter index. The index is 0-based.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ParamName( _
   ByVal Index As Long _
) As String

Parameters

Index

The parameter index.

See Also

IParam Interface


%%PageItemTitle%%

IParam Interface

Index

The parameter index. The index is 0-based.

See Also OTA COM Type Library

ParamType Property

Description

The data type of the specified parameter. The index is 0-based.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ParamType( _
   ByVal Index As Long _
) As Long

Parameters

Index

The parameter index. The index is 0-based.

See Also

IParam Interface


%%PageItemTitle%%

IParam Interface

Key

The parameter index or name. The index is 0-based.

See Also OTA COM Type Library

ParamValue Property

Description

The parameter value.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ParamValue( _
   ByVal Key As Variant _
) As Variant

Parameters

Key

The parameter index or name. The index is 0-based.

See Also

IParam Interface


%%PageItemTitle%%

IProductInfo Members

IProductInfo Interface

Description

Information about the current version.

Remarks

Get a ProjectInfo reference from TDConnection.ProductInfo.

Public Properties

Public Property BPTVersion | The Business Process Test versions.
Public Property QCVersion | The build information for the installed version.


%%PageItemTitle%%

IProductInfo Interface

BPTVersion Property

Description

The Business Process Test versions.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BPTVersion() As Long

See Also

IProductInfo Interface


%%PageItemTitle%%

IProductInfo Interface

pnMajorVersion

The release number.

pnMinorVersion

The intermediate release number.

See Also OTA COM Type Library

QCVersion Property

Description

The build information for the installed version.

Property type

Read-only property

Syntax (Visual Basic)

Public Property QCVersion( _
   ByRef pnMajorVersion As Long, _
   ByRef pnMinorVersion As Long _
) As Long

Parameters

pnMajorVersion

The release number.

pnMinorVersion

The intermediate release number.

See Also

IProductInfo Interface


%%PageItemTitle%%

IRecordset Members

IRecordset Interface

Description

Represents the entire set of records resulting from an executed command. At any given time, the Recordset object refers to a single record within the record set as the current record.

Remarks

A Recordset object is returned by Command.Execute.

The Position indicates the record to which the Recordset cursor points, the currently active record. The first record is numbered 0. The FieldValue refers to the values in the currently active record.

If there are no records in the Recordset, BOR and EOR BOR and EOR are true and the Position is 0.

Public Methods

Public Method Clone | Creates a duplicate of this Recordset object.
Public Method First | Moves to the first record and makes it the current record.
Public Method Last | Moves to the last record and makes it the current record.
Public Method Next | Moves to the next record and makes it the current record.
Public Method Prev | Moves to the previous record and makes it the current record.
Public Method Refresh | Refreshes the Recordset, overwriting values in memory.

Public Properties

Public Property BOR | Checks if the record cursor is on the first record.
Public Property CacheSize | The number of records in the recordset that are cached locally in memory.
Public Property ColCount | Gets the number of columns in the current Recordset object.
Public Property ColIndex | Gets the index (zero-based) of a Recordset column specified by column name.
Public Property ColName | The name of the Recordset column specified by Index (zero-based).
Public Property ColSize | The physical size as defined in the database of the fields in the column specified by Index (zero-based).
Public Property ColType | The data type of column.
Public Property EOR | Checks if the record cursor is after the last record.
Public Property FieldValue | The value for the specified field.
Public Property Position | The current record position (0-based).
Public Property RecordCount | The number of records in the Recordset.


%%PageItemTitle%%

IRecordset Interface

Clone Method

Description

Creates a duplicate of this Recordset object.

Syntax

Public Function Clone() As Object

Return Type

The new Recordset object.

See Also

IRecordset Interface


%%PageItemTitle%%

IRecordset Interface

First Method

Description

Moves to the first record and makes it the current record.

Syntax

Public Sub First()

See Also

IRecordset Interface


%%PageItemTitle%%

IRecordset Interface

Last Method

Description

Moves to the last record and makes it the current record.

Syntax

Public Sub Last()

See Also

IRecordset Interface


%%PageItemTitle%%

IRecordset Interface

Next Method

Description

Moves to the next record and makes it the current record.

Syntax

Public Sub Next()

Remarks

If Next is called when the cursor is on the last record of the recordset, moving the cursor beyond the last record, EOR becomes True and an attempt to read data causes an error.

See Also

IRecordset Interface


%%PageItemTitle%%

IRecordset Interface

Prev Method

Description

Moves to the previous record and makes it the current record.

Syntax

Public Sub Prev()

Remarks

Calling Prev when the cursor is on the first record of the recordset has no effect. The first record continues to be active. Use the BOR Property to determine if the first record is current.

See Also

IRecordset Interface


%%PageItemTitle%%

IRecordset Interface

Range

For internal use only.

Low

For internal use only.

High

For internal use only.

See Also OTA COM Type Library

Refresh Method

Description

Refreshes the Recordset, overwriting values in memory.

Syntax

Public Sub Refresh( _
   Optional ByVal Range As Long = 0, _
   Optional ByVal Low As Long = 0, _
   Optional ByVal High As Long = 0 _
)

Parameters

Range

For internal use only.

Low

For internal use only.

High

For internal use only.

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IRecordset Interface


%%PageItemTitle%%

IRecordset Interface

BOR Property

Description

Checks if the record cursor is on the first record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BOR() As Boolean

Remarks

BOR (Beginning of Recordset) is true when the Recordset object is created by the Command.Execute call, after the First method is called, and when the first record is reached by calling Prev when the cursor was on the second record.

If BOR is true and EOR is false, the cursor is pointing to the first record. If both BOR and EOR are true, there are no records in the Recordset. The Position is 0 in both cases.

See Also

IRecordset Interface


%%PageItemTitle%%

IRecordset Interface

CacheSize Property

Description

The number of records in the recordset that are cached locally in memory.

Property type

Read-write property

Syntax (Visual Basic)

Public Property CacheSize() As Long

See Also

IRecordset Interface


%%PageItemTitle%%

IRecordset Interface

ColCount Property

Description

Gets the number of columns in the current Recordset object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ColCount() As Long

See Also

IRecordset Interface


%%PageItemTitle%%

IRecordset Interface

Name

The name of the column in the project database.

See Also OTA COM Type Library

ColIndex Property

Description

Gets the index (zero-based) of a Recordset column specified by column name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ColIndex( _
   ByVal Name As String _
) As Long

Parameters

Name

The name of the column in the project database.

See Also

IRecordset Interface


%%PageItemTitle%%

IRecordset Interface

Index

The index of the column (zero-based).

See Also OTA COM Type Library

ColName Property

Description

The name of the Recordset column specified by Index (zero-based).

Property type

Read-only property

Syntax (Visual Basic)

Public Property ColName( _
   ByVal Index As Long _
) As String

Parameters

Index

The index of the column (zero-based).

See Also

IRecordset Interface


%%PageItemTitle%%

IRecordset Interface

Index

The index of the column (zero-based).

See Also OTA COM Type Library

ColSize Property

Description

The physical size as defined in the database of the fields in the column specified by Index (zero-based).

Property type

Read-only property

Syntax (Visual Basic)

Public Property ColSize( _
   ByVal Index As Long _
) As Long

Parameters

Index

The index of the column (zero-based).

See Also

IRecordset Interface


%%PageItemTitle%%

IRecordset Interface

Index

The index of the column (zero-based).

See Also OTA COM Type Library

ColType Property

Description

The data type of column.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ColType( _
   ByVal Index As Long _
) As Long

Parameters

Index

The index of the column (zero-based).

See Also

IRecordset Interface


%%PageItemTitle%%

IRecordset Interface

EOR Property

Description

Checks if the record cursor is after the last record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EOR() As Boolean

Remarks

EOR (End of Recordset) is true if the cursor is pointing to a position past the end of the recordset or if the recordset is empty. For example, if the cursor is on the last record and Next is called, EOR becomes true.

When EOR is true, an exception is thrown on any attempt to read data from the recordset.

See Also

IRecordset Interface


%%PageItemTitle%%

IRecordset Interface

FieldKey

The column index (long) or column name.

See Also OTA COM Type Library

FieldValue Property

Description

The value for the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FieldValue( _
   ByVal FieldKey As Variant _
) As Variant

Parameters

FieldKey

The column index (long) or column name.

See Also

IRecordset Interface


%%PageItemTitle%%

IRecordset Interface

Position Property

Description

The current record position (0-based).

Property type

Read-write property

Syntax (Visual Basic)

Public Property Position() As Long

Remarks

Position is 0 when the cursor is on the first record or if the recordset is empty.

See Also

IRecordset Interface


%%PageItemTitle%%

IRecordset Interface

RecordCount Property

Description

The number of records in the Recordset.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RecordCount() As Long

See Also

IRecordset Interface


%%PageItemTitle%%

IRelease Members

IRelease Interface

Description

Represents a Release.

Remarks

Get a Release reference from the ReleaseFactory or from Cycle.Parent.

Public Methods

Public Method DaysLeft | Returns the number of days until the scheduled release date.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Mail | Mails the IBaseFieldExMail field item.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property CycleFactory | The CycleFactory object for cycles of this release.
Public Property EndDate | The release's end date
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The release's name
Public Property Parent | The release's parent release folder
Public Property ReleaseManagementInfo | The release information.
Public Property StartDate | The release's start date
Public Property Status | The release's status
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

IRelease Interface

DaysLeft Method

Description

Returns the number of days until the scheduled release date.

Syntax

Public Function DaysLeft() As Long

See Also

IRelease Interface


%%PageItemTitle%%

IRelease Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IRelease Interface


%%PageItemTitle%%

IRelease Interface | tagTDMAIL_FLAGS Enumeration

SendTo

The recipient address or addresses. Addresses can be separated by a comma or a semicolon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also OTA COM Type Library

Mail Method

Description

Mails the IBaseFieldExMail field item.

Syntax

Public Sub Mail( _
   ByVal SendTo As String, _
   Optional ByVal SendCc As String = "", _
   Optional ByVal Option As Long = 0, _
   Optional ByVal Subject As String = "", _
   Optional ByVal Comment As String = "" _
)

Parameters

SendTo

The recipient address or addresses. Addresses can be separated by a comma or a semicolon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also

IRelease Interface | tagTDMAIL_FLAGS Enumeration


%%PageItemTitle%%

IRelease Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IRelease Interface


%%PageItemTitle%%

IRelease Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IRelease Interface


%%PageItemTitle%%

IRelease Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

IRelease Interface


%%PageItemTitle%%

IRelease Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

IRelease Interface


%%PageItemTitle%%

IRelease Interface

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

IRelease Interface


%%PageItemTitle%%

IRelease Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

IRelease Interface


%%PageItemTitle%%

IRelease Interface

CycleFactory Property

Description

The CycleFactory object for cycles of this release.

Property type

Read-only property

Syntax (Visual Basic)

Public Property CycleFactory() As Object

See Also

IRelease Interface


%%PageItemTitle%%

IRelease Interface

EndDate Property

Description

The release's end date

Property type

Read-write property

Syntax (Visual Basic)

Public Property EndDate() As Date

See Also

IRelease Interface


%%PageItemTitle%%

IRelease Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

IRelease Interface


%%PageItemTitle%%

IRelease Interface

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

IRelease Interface


%%PageItemTitle%%

IRelease Interface

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IRelease Interface


%%PageItemTitle%%

IRelease Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

IRelease Interface


%%PageItemTitle%%

IRelease Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

IRelease Interface


%%PageItemTitle%%

IRelease Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

IRelease Interface


%%PageItemTitle%%

IRelease Interface

Name Property

Description

The release's name

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

IRelease Interface


%%PageItemTitle%%

IRelease Interface

Parent Property

Description

The release's parent release folder

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As Object

See Also

IRelease Interface


%%PageItemTitle%%

IRelease Interface

ReleaseManagementInfo Property

Description

The release information.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ReleaseManagementInfo() As Object

See Also

IRelease Interface


%%PageItemTitle%%

IRelease Interface

StartDate Property

Description

The release's start date

Property type

Read-write property

Syntax (Visual Basic)

Public Property StartDate() As Date

See Also

IRelease Interface


%%PageItemTitle%%

IRelease Interface

Status Property

Description

The release's status

Property type

Read-write property

Syntax (Visual Basic)

Public Property Status() As String

See Also

IRelease Interface


%%PageItemTitle%%

IRelease Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

IRelease Interface


%%PageItemTitle%%

IReleaseFactory Members

IReleaseFactory Interface

Description

Services for managing releases.

Remarks

Get a ReleaseFactory from TDConnection.ReleaseFactory Property or ReleaseFactory.

Interface Remarks

IBaseFactoryEx adds method Mail to IBaseFactory. It is implemented by several classes, such as BugFactory, ReqFactory, and TestFactory.
The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Public Methods

Public Method AddItem | Creates a new item object.
Public Method BuildCoverageGraph | Builds release coverage graph.
Public Method Mail | Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

IReleaseFactory Interface

ItemData
See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData

Remarks

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

[Visual Basic]

Dim bgf As BugFactory
Dim bg As Bug
Dim attf As AttachmentFactory
Dim att As Attachment
Dim attList As List

' Get the factory object
 Set bgf = tdc.BugFactory
' Use defect #1
 Set bg = bgf.Item(1)
 Set attf = bg.Attachments

' Creating a new attachment
' Create virtual object, then populate the properties
 Set att = attf.AddItem(Null)
 att.FileName = Text1.Text
 att.Type = TDATT_INTERNET

' Saving the object with validity check
 att.Post

' Display the attachments
' Add the display-only items without a Post
 List1.Clear
 Set attList = attf.NewList("")
 For i = 1 To attList.Count

      Set att = attList.Item(i)
      List1.AddItem (att.Name)

 Next

See Also

IReleaseFactory Interface


%%PageItemTitle%%

IReleaseFactory Interface

ReleaseID
See Also OTA COM Type Library

BuildCoverageGraph Method

Description

Builds release coverage graph.

Syntax

Public Function BuildCoverageGraph( _
   ByVal ReleaseID As Long _
) As Object

Parameters

ReleaseID

See Also

IReleaseFactory Interface


%%PageItemTitle%%

IReleaseFactory Interface

Items

A list of IDs.

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also OTA COM Type Library

Mail Method

Description

Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.

Syntax

Public Sub Mail( _
   ByVal Items As Variant, _
   ByVal SendTo As String, _
   Optional ByVal SendCc As String = "", _
   Optional ByVal Option As Long = 0, _
   Optional ByVal Subject As String = "", _
   Optional ByVal Comment As String = "" _
)

Parameters

Items

A list of IDs.

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also

IReleaseFactory Interface


%%PageItemTitle%%

IReleaseFactory Interface

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

IReleaseFactory Interface


%%PageItemTitle%%

IReleaseFactory Interface

ItemKey
See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey

See Also

IReleaseFactory Interface


%%PageItemTitle%%

IReleaseFactory Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

IReleaseFactory Interface


%%PageItemTitle%%

IReleaseFactory Interface

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

IReleaseFactory Interface


%%PageItemTitle%%

IReleaseFactory Interface

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

IReleaseFactory Interface


%%PageItemTitle%%

IReleaseFactory Interface

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IReleaseFactory Interface


%%PageItemTitle%%

IReleaseFactory Interface

ItemKey
See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey

See Also

IReleaseFactory Interface


%%PageItemTitle%%

IReleaseFolder Members

IReleaseFolder Interface

Description

Represents a Release Folder.

Remarks

Get a reference from the ReleaseFolderFactory.

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Mail | Mails the IBaseFieldExMail field item.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The release folder's name
Public Property Parent | The release folder's parent release folder, or null if root
Public Property ReleaseFactory | The ReleaseFactory object for direct children releases.
Public Property ReleaseFolderFactory | The ReleaseFolderFactory object for direct children release folders.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

IReleaseFolder Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IReleaseFolder Interface


%%PageItemTitle%%

IReleaseFolder Interface | tagTDMAIL_FLAGS Enumeration

SendTo

The recipient address or addresses. Addresses can be separated by a comma or a semicolon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also OTA COM Type Library

Mail Method

Description

Mails the IBaseFieldExMail field item.

Syntax

Public Sub Mail( _
   ByVal SendTo As String, _
   Optional ByVal SendCc As String = "", _
   Optional ByVal Option As Long = 0, _
   Optional ByVal Subject As String = "", _
   Optional ByVal Comment As String = "" _
)

Parameters

SendTo

The recipient address or addresses. Addresses can be separated by a comma or a semicolon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also

IReleaseFolder Interface | tagTDMAIL_FLAGS Enumeration


%%PageItemTitle%%

IReleaseFolder Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IReleaseFolder Interface


%%PageItemTitle%%

IReleaseFolder Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IReleaseFolder Interface


%%PageItemTitle%%

IReleaseFolder Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

IReleaseFolder Interface


%%PageItemTitle%%

IReleaseFolder Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

IReleaseFolder Interface


%%PageItemTitle%%

IReleaseFolder Interface

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

IReleaseFolder Interface


%%PageItemTitle%%

IReleaseFolder Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

IReleaseFolder Interface


%%PageItemTitle%%

IReleaseFolder Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

IReleaseFolder Interface


%%PageItemTitle%%

IReleaseFolder Interface

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

IReleaseFolder Interface


%%PageItemTitle%%

IReleaseFolder Interface

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IReleaseFolder Interface


%%PageItemTitle%%

IReleaseFolder Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

IReleaseFolder Interface


%%PageItemTitle%%

IReleaseFolder Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

IReleaseFolder Interface


%%PageItemTitle%%

IReleaseFolder Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

IReleaseFolder Interface


%%PageItemTitle%%

IReleaseFolder Interface

Name Property

Description

The release folder's name

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

IReleaseFolder Interface


%%PageItemTitle%%

IReleaseFolder Interface

Parent Property

Description

The release folder's parent release folder, or null if root

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As Object

See Also

IReleaseFolder Interface


%%PageItemTitle%%

IReleaseFolder Interface

ReleaseFactory Property

Description

The ReleaseFactory object for direct children releases.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ReleaseFactory() As Object

See Also

IReleaseFolder Interface


%%PageItemTitle%%

IReleaseFolder Interface

ReleaseFolderFactory Property

Description

The ReleaseFolderFactory object for direct children release folders.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ReleaseFolderFactory() As Object

See Also

IReleaseFolder Interface


%%PageItemTitle%%

IReleaseFolder Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

IReleaseFolder Interface


%%PageItemTitle%%

IReleaseFolderFactory Members

IReleaseFolderFactory Interface

Description

Services for managing release folders.

Remarks

The ReleaseFolderFactory for the connection is TDConnection.ReleaseFolderFactory

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Public Methods

Public Method AddItem | Creates a new item object.
Public Method Mail | Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.
Public Property Root | Gets the root release folder labled 'Releases'.


%%PageItemTitle%%

IReleaseFolderFactory Interface

ItemData

There are two options for ItemData:

  • Null. Creating a virtual ReleaseFolder object with Null ensures that you cannot then Post until the required fields are initialized.
  • An array consisting of the following two elements:

(0) ParentID - The ID of the Release Folder in which to create the new Release Folder (long, required).

(1) Name - The Release Folder name (string, required).

See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData

There are two options for ItemData:

  • Null. Creating a virtual ReleaseFolder object with Null ensures that you cannot then Post until the required fields are initialized.
  • An array consisting of the following two elements:

(0) ParentID - The ID of the Release Folder in which to create the new Release Folder (long, required).

(1) Name - The Release Folder name (string, required).

Remarks

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

[Visual Basic]

Dim bgf As BugFactory
Dim bg As Bug
Dim attf As AttachmentFactory
Dim att As Attachment
Dim attList As List

' Get the factory object
 Set bgf = tdc.BugFactory
' Use defect #1
 Set bg = bgf.Item(1)
 Set attf = bg.Attachments

' Creating a new attachment
' Create virtual object, then populate the properties
 Set att = attf.AddItem(Null)
 att.FileName = Text1.Text
 att.Type = TDATT_INTERNET

' Saving the object with validity check
 att.Post

' Display the attachments
' Add the display-only items without a Post
 List1.Clear
 Set attList = attf.NewList("")
 For i = 1 To attList.Count

      Set att = attList.Item(i)
      List1.AddItem (att.Name)

 Next

See Also

IReleaseFolderFactory Interface


%%PageItemTitle%%

IReleaseFolderFactory Interface

Items

A list of IDs.

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also OTA COM Type Library

Mail Method

Description

Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.

Syntax

Public Sub Mail( _
   ByVal Items As Variant, _
   ByVal SendTo As String, _
   Optional ByVal SendCc As String = "", _
   Optional ByVal Option As Long = 0, _
   Optional ByVal Subject As String = "", _
   Optional ByVal Comment As String = "" _
)

Parameters

Items

A list of IDs.

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also

IReleaseFolderFactory Interface


%%PageItemTitle%%

IReleaseFolderFactory Interface

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

IReleaseFolderFactory Interface


%%PageItemTitle%%

IReleaseFolderFactory Interface

ItemKey

The ReleaseFolder.ID, a reference to the ReleaseFolder Object, or a Variant Array of ReleaseFolder.IDs.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey

The ReleaseFolder.ID, a reference to the ReleaseFolder Object, or a Variant Array of ReleaseFolder.IDs.

See Also

IReleaseFolderFactory Interface


%%PageItemTitle%%

IReleaseFolderFactory Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

IReleaseFolderFactory Interface


%%PageItemTitle%%

IReleaseFolderFactory Interface

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

IReleaseFolderFactory Interface


%%PageItemTitle%%

IReleaseFolderFactory Interface

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

IReleaseFolderFactory Interface


%%PageItemTitle%%

IReleaseFolderFactory Interface

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IReleaseFolderFactory Interface


%%PageItemTitle%%

IReleaseFolderFactory Interface

ItemKey

The ReleaseFolder.ID

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey

The ReleaseFolder.ID

See Also

IReleaseFolderFactory Interface


%%PageItemTitle%%

IReleaseFolderFactory Interface

Root Property

Description

Gets the root release folder labled 'Releases'.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Root() As Object

See Also

IReleaseFolderFactory Interface


%%PageItemTitle%%

IReleaseManagementInfo Members

IReleaseManagementInfo Interface

Description

Represents a release or cycle.

Public Properties

Public Property DaysLeft | Returns the number of days remaining in the cycle or release.
Public Property Duration | Returns the duration of the cycle or release.
Public Property Started | Checks if the cycle or release has begun.
Public Property TotalTestInstances | Returns the total number of test instances in this cycle or release.
Public Property UnexecutedTestInstances | Returns the number of unexecuted test instances in this cycle or release.


%%PageItemTitle%%

IReleaseManagementInfo Interface

DaysLeft Property

Description

Returns the number of days remaining in the cycle or release.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DaysLeft() As Long

See Also

IReleaseManagementInfo Interface


%%PageItemTitle%%

IReleaseManagementInfo Interface

Duration Property

Description

Returns the duration of the cycle or release.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Duration() As Long

See Also

IReleaseManagementInfo Interface


%%PageItemTitle%%

IReleaseManagementInfo Interface

Started Property

Description

Checks if the cycle or release has begun.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Started() As Boolean

See Also

IReleaseManagementInfo Interface


%%PageItemTitle%%

IReleaseManagementInfo Interface

TotalTestInstances Property

Description

Returns the total number of test instances in this cycle or release.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TotalTestInstances() As Long

See Also

IReleaseManagementInfo Interface


%%PageItemTitle%%

IReleaseManagementInfo Interface

UnexecutedTestInstances Property

Description

Returns the number of unexecuted test instances in this cycle or release.

Property type

Read-only property

Syntax (Visual Basic)

Public Property UnexecutedTestInstances() As Long

See Also

IReleaseManagementInfo Interface


%%PageItemTitle%%

IReq Members

IReq Interface

Description

Represents a requirement for which testing must be performed.

Remarks

Get a Req object from the ReqFactory.

Public Methods

Public Method AddCoverage | Assigns a test to cover this requirement.
Public Method AddCoverageByFilter | Adds the tests from the specified subject that match the input filter to the list of tests that cover the current requirement.
Public Method AddCoverageEx | Assigns all the tests in the specified subject folder to cover this current requirement.
Public Method GetCoverList | Gets a list of the tests that cover this requirement.
Public Method GetCoverListByFilter | Gets the list of all tests that cover the current requirement and match the filter.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Mail | Mails the IBaseFieldExMail field item.
Public Method Move | Moves a requirement to being a child of a specified father in the requirements tree.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method RemoveCoverage | Removes a test from the list of tests that cover this requirement.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property Author | The name of the requirement author.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Comment | The comment associated with this requirement.
Public Property Count | The number of direct children.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property HasCoverage | The requirement is covered by at least one test.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The Requirement name as seen in the tree.
Public Property Paragraph | The paragraph number or numeration of the requirement.
Public Property Path | The path of the node containing this requirement.
Public Property Priority | The requirement priority.
Public Property Product | The product name for which the requirement is set.
Public Property Reviewed | The review status.
Public Property Status | The status of the tests that cover this requirement.
Public Property Type | The requirement type.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

IReq Interface

TestId

The ID of the test assigned to the requirement.

Order

The position of the test in the requirement coverage list. Possible values are:

  • A number representing the position.
  • TDPOSITION_LAST [-4] - Indicates that the test is inserted last
See Also OTA COM Type Library

AddCoverage Method

Description

Assigns a test to cover this requirement.

Syntax

Public Function AddCoverage( _
   ByVal TestId As Long, _
   ByVal Order As Long _
) As Long

Parameters

TestId

The ID of the test assigned to the requirement.

Order

The position of the test in the requirement coverage list. Possible values are:

  • A number representing the position.
  • TDPOSITION_LAST [-4] - Indicates that the test is inserted last

Return Type

Zero on success, or -1 on error.

Remarks

The actual position of the test in the requirement coverage list.

See Also

IReq Interface


%%PageItemTitle%%

IReq Interface

SubjectID

The ID of the folder in the test plan module.

Order

The desired position in the list of tests.

TestFilter

A TDFilter.Text that selects the tests to cover the requirement.

See Also OTA COM Type Library

AddCoverageByFilter Method

Description

Adds the tests from the specified subject that match the input filter to the list of tests that cover the current requirement.

Syntax

Public Function AddCoverageByFilter( _
   ByVal SubjectID As Long, _
   ByVal Order As Long, _
   ByVal TestFilter As String _
) As Long

Parameters

SubjectID

The ID of the folder in the test plan module.

Order

The desired position in the list of tests.

TestFilter

A TDFilter.Text that selects the tests to cover the requirement.

See Also

IReq Interface


%%PageItemTitle%%

IReq Interface

SubjectID

The ID of the subject folder containing the tests to be added to the requirement.

Order

The position of the first test in the folder in the requirement coverage list. Possible values are:

  • A number representing the position.
  • TDPOSITION_LAST [-4] - Indicates that the test is inserted last
See Also OTA COM Type Library

AddCoverageEx Method

Description

Assigns all the tests in the specified subject folder to cover this current requirement.

Syntax

Public Function AddCoverageEx( _
   ByVal SubjectID As Long, _
   ByVal Order As Long _
) As Long

Parameters

SubjectID

The ID of the subject folder containing the tests to be added to the requirement.

Order

The position of the first test in the folder in the requirement coverage list. Possible values are:

  • A number representing the position.
  • TDPOSITION_LAST [-4] - Indicates that the test is inserted last

Return Type

Zero on success, or -1 on error.

Remarks

The actual position of the first test in the folder in the requirement coverage list.

See Also

IReq Interface


%%PageItemTitle%%

IReq Interface

Recursive

If TRUE, GetCoverList returns a list of coverage tests for current requirement and all its children. Otherwise, the method returns a list of coverage tests only for the current requirement.

See Also OTA COM Type Library

GetCoverList Method

Description

Gets a list of the tests that cover this requirement.

Syntax

Public Function GetCoverList( _
   Optional ByVal Recursive As Boolean = False _
) As List

Parameters

Recursive

If TRUE, GetCoverList returns a list of coverage tests for current requirement and all its children. Otherwise, the method returns a list of coverage tests only for the current requirement.

Return Type

A list of Test Objects.

See Also

IReq Interface


%%PageItemTitle%%

IReq Interface

TestFilter

A TDFilter.Text string.

Recursive

If TRUE, GetCoverList returns a list of coverage tests for current requirement and all its children. Otherwise, the method returns a list of coverage tests only for the current requirement.

See Also OTA COM Type Library

GetCoverListByFilter Method

Description

Gets the list of all tests that cover the current requirement and match the filter.

Syntax

Public Function GetCoverListByFilter( _
   ByVal TestFilter As String, _
   Optional ByVal Recursive As Boolean = False _
) As List

Parameters

TestFilter

A TDFilter.Text string.

Recursive

If TRUE, GetCoverList returns a list of coverage tests for current requirement and all its children. Otherwise, the method returns a list of coverage tests only for the current requirement.

See Also

IReq Interface


%%PageItemTitle%%

IReq Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IReq Interface


%%PageItemTitle%%

IReq Interface | tagTDMAIL_FLAGS Enumeration

SendTo

The recipient address or addresses. Addresses can be separated by a comma or a semicolon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also OTA COM Type Library

Mail Method

Description

Mails the IBaseFieldExMail field item.

Syntax

Public Sub Mail( _
   ByVal SendTo As String, _
   Optional ByVal SendCc As String = "", _
   Optional ByVal Option As Long = 0, _
   Optional ByVal Subject As String = "", _
   Optional ByVal Comment As String = "" _
)

Parameters

SendTo

The recipient address or addresses. Addresses can be separated by a comma or a semicolon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also

IReq Interface | tagTDMAIL_FLAGS Enumeration


%%PageItemTitle%%

IReq Interface

NewFatherId

The ID of the designated new father requirement.

NewOrder

The position of the requirement under the new parent. Possible values are:

  • A number representing the position.
  • TDPOSITION_LAST [-4] - Indicates that the test is inserted last
See Also OTA COM Type Library

Move Method

Description

Moves a requirement to being a child of a specified father in the requirements tree.

Syntax

Public Sub Move( _
   ByVal NewFatherId As Long, _
   ByVal NewOrder As Long _
)

Parameters

NewFatherId

The ID of the designated new father requirement.

NewOrder

The position of the requirement under the new parent. Possible values are:

  • A number representing the position.
  • TDPOSITION_LAST [-4] - Indicates that the test is inserted last

See Also

IReq Interface


%%PageItemTitle%%

IReq Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IReq Interface


%%PageItemTitle%%

IReq Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IReq Interface


%%PageItemTitle%%

IReq Interface

vTest

A Test Object or array of test objects.

Recursive

If TRUE, the specified coverage is removed for all the requirements under the current one. If FALSE, only the coverage at the current requirement is removed.

See Also OTA COM Type Library

RemoveCoverage Method

Description

Removes a test from the list of tests that cover this requirement.

Syntax

Public Sub RemoveCoverage( _
   ByVal vTest As Variant, _
   Optional ByVal Recursive As Boolean = False _
)

Parameters

vTest

A Test Object or array of test objects.

Recursive

If TRUE, the specified coverage is removed for all the requirements under the current one. If FALSE, only the coverage at the current requirement is removed.

See Also

IReq Interface


%%PageItemTitle%%

IReq Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

IReq Interface


%%PageItemTitle%%

IReq Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

IReq Interface


%%PageItemTitle%%

IReq Interface

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

IReq Interface


%%PageItemTitle%%

IReq Interface

Author Property

Description

The name of the requirement author.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

IReq Interface


%%PageItemTitle%%

IReq Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

IReq Interface


%%PageItemTitle%%

IReq Interface

Comment Property

Description

The comment associated with this requirement.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comment() As String

See Also

IReq Interface


%%PageItemTitle%%

IReq Interface

Count Property

Description

The number of direct children.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

IReq Interface


%%PageItemTitle%%

IReq Interface

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName

The name of the field in the project database.

Remarks

An attempt to get or set the value of a field not applicable to requirements of this type causes an exception. Get the list of applicable fields from CustomizationReqType.Fields.

See Also

IReq Interface


%%PageItemTitle%%

IReq Interface

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

IReq Interface


%%PageItemTitle%%

IReq Interface

HasCoverage Property

Description

The requirement is covered by at least one test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasCoverage() As Boolean

See Also

IReq Interface


%%PageItemTitle%%

IReq Interface

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IReq Interface


%%PageItemTitle%%

IReq Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

IReq Interface


%%PageItemTitle%%

IReq Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

IReq Interface


%%PageItemTitle%%

IReq Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

IReq Interface


%%PageItemTitle%%

IReq Interface

Name Property

Description

The Requirement name as seen in the tree.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

IReq Interface


%%PageItemTitle%%

IReq Interface

Paragraph Property

Description

The paragraph number or numeration of the requirement.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Paragraph() As String

Remarks

To see the paragraph numbers in the user interface, choose menu item View > Numeration in the Requirement module.

The paragraph number is one node deeper than the Path.

See Also

IReq Interface


%%PageItemTitle%%

IReq Interface

Path Property

Description

The path of the node containing this requirement.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Path() As String

Remarks

A path is a code consisting of letters like "AAA", "AAB" and so on. It is not visible in the user interface.

See Also

IReq Interface


%%PageItemTitle%%

IReq Interface

Priority Property

Description

The requirement priority.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Priority() As String

Remarks

For most sites, the priorities are from "1-Low" to "5-Urgent".

To get the full list of priorities in your project look at the Priority list. See 'Customizing Project Lists' in the Mercury Quality Center Administrator's Guide.

See Also

IReq Interface


%%PageItemTitle%%

IReq Interface

Product Property

Description

The product name for which the requirement is set.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Product() As String

See Also

IReq Interface


%%PageItemTitle%%

IReq Interface

Reviewed Property

Description

The review status.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Reviewed() As String

Remarks

The review status can be any value configured in the project. Typical examples are Changed, Not Reviewed, and Reviewed.

For information about the Review Status list, see 'Customizing Project Lists' in the Mercury Quality Center Administrator's Guide.

See Also

IReq Interface


%%PageItemTitle%%

IReq Interface

Status Property

Description

The status of the tests that cover this requirement.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Status() As String

Remarks

The statuses of the covering tests are: Failed, No Run, Not Completed, or Passed.

If no tests cover this requirement, the value is Not Covered.

For information about the Status list, see 'Customizing Project Lists' in the Mercury Quality Center Administrator's Guide.

See Also

IReq Interface


%%PageItemTitle%%

IReq Interface

Type Property

Description

The requirement type.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Type() As String

Remarks

Obsolete. In previous versions:

The type can be any value configured in the project. Typical examples are Functional, Guideline, Quality, Standard, and System.

For information about the Requirement Type list, see 'Customizing Project Lists' in the Mercury Quality Center Administrator's Guide.

See Also

IReq Interface


%%PageItemTitle%%

IReq Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

IReq Interface


%%PageItemTitle%%

IReq2 Members

IReq2 Interface

Description

Represents a requirement for which testing must be performed.

Remarks

Get a Req object from the ReqFactory.

Public Methods

Public Method AddCoverage | Assigns a test to cover this requirement.
Public Method AddCoverageByFilter | Adds the tests from the specified subject that match the input filter to the list of tests that cover the current requirement.
Public Method AddCoverageEx | Assigns all the tests in the specified subject folder to cover this current requirement.
Public Method get_Icon | Returns the bitmap stream for the requirement's type.
Public Method GetCoverageTestsByReqFilter | Returns the list of tests that cover the current requirement and, optionally, cover those of its children that match the requirement filter.
Public Method GetCoverList | Gets a list of the tests that cover this requirement.
Public Method GetCoverListByFilter | Gets the list of all tests that cover the current requirement and match the filter.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Mail | Mails the IBaseFieldExMail field item.
Public Method Move | Moves a requirement to being a child of a specified father in the requirements tree.
Public Method PopulateTargetCycleToChildren | Assigns the target cycle of the requirement as the target cycle of all child requirements, recursively down the folder tree.
Public Method PopulateTargetReleaseToChildren | Assigns the target release of the requirement as the target release of all child requirements, recursively down the folder tree.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method RemoveCoverage | Removes a test from the list of tests that cover this requirement.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property Author | The name of the requirement author.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Comment | The comment associated with this requirement.
Public Property Count | The number of direct children.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property HasCoverage | The requirement is covered by at least one test.
Public Property HasReqTraceability | Checks if the current requirement has at least one associated requirement in the specified direction.
Public Property HasRichContent | Checks if the object has rich content.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The Requirement name as seen in the tree.
Public Property Paragraph | The paragraph number or numeration of the requirement.
Public Property ParentId | The Requirement's parent ID.
Public Property Path | The path of the node containing this requirement.
Public Property Priority | The requirement priority.
Public Property Product | The product name for which the requirement is set.
Public Property ReqTraceFactory | The requirement link factory that manages the traceability links of the current requirement to its associated requirements in the specified direction.
Public Property RequirementType | Gets the interface for getting the requirement types.
Public Property Reviewed | The review status.
Public Property Status | The status of the tests that cover this requirement.
Public Property Type | The requirement type.
Public Property TypeId | The Requirement's type name.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

IReq2 Interface

TestId

The ID of the test assigned to the requirement.

Order

The position of the test in the requirement coverage list. Possible values are:

  • A number representing the position.
  • TDPOSITION_LAST [-4] - Indicates that the test is inserted last
See Also OTA COM Type Library

AddCoverage Method

Description

Assigns a test to cover this requirement.

Syntax

Public Function AddCoverage( _
   ByVal TestId As Long, _
   ByVal Order As Long _
) As Long

Parameters

TestId

The ID of the test assigned to the requirement.

Order

The position of the test in the requirement coverage list. Possible values are:

  • A number representing the position.
  • TDPOSITION_LAST [-4] - Indicates that the test is inserted last

Return Type

Zero on success, or -1 on error.

Remarks

The actual position of the test in the requirement coverage list.

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

SubjectID

The ID of the folder in the test plan module.

Order

The desired position in the list of tests.

TestFilter

A TDFilter.Text that selects the tests to cover the requirement.

See Also OTA COM Type Library

AddCoverageByFilter Method

Description

Adds the tests from the specified subject that match the input filter to the list of tests that cover the current requirement.

Syntax

Public Function AddCoverageByFilter( _
   ByVal SubjectID As Long, _
   ByVal Order As Long, _
   ByVal TestFilter As String _
) As Long

Parameters

SubjectID

The ID of the folder in the test plan module.

Order

The desired position in the list of tests.

TestFilter

A TDFilter.Text that selects the tests to cover the requirement.

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

SubjectID

The ID of the subject folder containing the tests to be added to the requirement.

Order

The position of the first test in the folder in the requirement coverage list. Possible values are:

  • A number representing the position.
  • TDPOSITION_LAST [-4] - Indicates that the test is inserted last
See Also OTA COM Type Library

AddCoverageEx Method

Description

Assigns all the tests in the specified subject folder to cover this current requirement.

Syntax

Public Function AddCoverageEx( _
   ByVal SubjectID As Long, _
   ByVal Order As Long _
) As Long

Parameters

SubjectID

The ID of the subject folder containing the tests to be added to the requirement.

Order

The position of the first test in the folder in the requirement coverage list. Possible values are:

  • A number representing the position.
  • TDPOSITION_LAST [-4] - Indicates that the test is inserted last

Return Type

Zero on success, or -1 on error.

Remarks

The actual position of the first test in the folder in the requirement coverage list.

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

get_Icon Method

Description

Returns the bitmap stream for the requirement's type.

Syntax

Public Function get_Icon() As IStream

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

ReqFilter

A TDFilter.Text that specifies which descendent requirements to include.

Recursive

If true, the filter is applied to this requirement and its descendent requirements.

If false, the filter is only applied to this requirement.

See Also OTA COM Type Library

GetCoverageTestsByReqFilter Method

Description

Returns the list of tests that cover the current requirement and, optionally, cover those of its children that match the requirement filter.

Syntax

Public Function GetCoverageTestsByReqFilter( _
   ByVal ReqFilter As String, _
   Optional ByVal Recursive As Boolean = False _
) As List

Parameters

ReqFilter

A TDFilter.Text that specifies which descendent requirements to include.

Recursive

If true, the filter is applied to this requirement and its descendent requirements.

If false, the filter is only applied to this requirement.

Return Type

A list of the Tests that cover the requirements that match the filter.

If no requirements, including this requirement, match the filter, an empty list is returned.

Remarks

To retrieve the list of all tests that cover this requirement , either set set the filter to an empty string or use GetCoverList.

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

Recursive

If TRUE, GetCoverList returns a list of coverage tests for current requirement and all its children. Otherwise, the method returns a list of coverage tests only for the current requirement.

See Also OTA COM Type Library

GetCoverList Method

Description

Gets a list of the tests that cover this requirement.

Syntax

Public Function GetCoverList( _
   Optional ByVal Recursive As Boolean = False _
) As List

Parameters

Recursive

If TRUE, GetCoverList returns a list of coverage tests for current requirement and all its children. Otherwise, the method returns a list of coverage tests only for the current requirement.

Return Type

A list of Test Objects.

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

TestFilter

A TDFilter.Text string.

Recursive

If TRUE, GetCoverList returns a list of coverage tests for current requirement and all its children. Otherwise, the method returns a list of coverage tests only for the current requirement.

See Also OTA COM Type Library

GetCoverListByFilter Method

Description

Gets the list of all tests that cover the current requirement and match the filter.

Syntax

Public Function GetCoverListByFilter( _
   ByVal TestFilter As String, _
   Optional ByVal Recursive As Boolean = False _
) As List

Parameters

TestFilter

A TDFilter.Text string.

Recursive

If TRUE, GetCoverList returns a list of coverage tests for current requirement and all its children. Otherwise, the method returns a list of coverage tests only for the current requirement.

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface | tagTDMAIL_FLAGS Enumeration

SendTo

The recipient address or addresses. Addresses can be separated by a comma or a semicolon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also OTA COM Type Library

Mail Method

Description

Mails the IBaseFieldExMail field item.

Syntax

Public Sub Mail( _
   ByVal SendTo As String, _
   Optional ByVal SendCc As String = "", _
   Optional ByVal Option As Long = 0, _
   Optional ByVal Subject As String = "", _
   Optional ByVal Comment As String = "" _
)

Parameters

SendTo

The recipient address or addresses. Addresses can be separated by a comma or a semicolon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also

IReq2 Interface | tagTDMAIL_FLAGS Enumeration


%%PageItemTitle%%

IReq2 Interface

NewFatherId

The ID of the designated new father requirement.

NewOrder

The position of the requirement under the new parent. Possible values are:

  • A number representing the position.
  • TDPOSITION_LAST [-4] - Indicates that the test is inserted last
See Also OTA COM Type Library

Move Method

Description

Moves a requirement to being a child of a specified father in the requirements tree.

Syntax

Public Sub Move( _
   ByVal NewFatherId As Long, _
   ByVal NewOrder As Long _
)

Parameters

NewFatherId

The ID of the designated new father requirement.

NewOrder

The position of the requirement under the new parent. Possible values are:

  • A number representing the position.
  • TDPOSITION_LAST [-4] - Indicates that the test is inserted last

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

PopulateTargetCycleToChildren Method

Description

Assigns the target cycle of the requirement as the target cycle of all child requirements, recursively down the folder tree.

Syntax

Public Sub PopulateTargetCycleToChildren()

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

PopulateTargetReleaseToChildren Method

Description

Assigns the target release of the requirement as the target release of all child requirements, recursively down the folder tree.

Syntax

Public Sub PopulateTargetReleaseToChildren()

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

vTest

A Test Object or array of test objects.

Recursive

If TRUE, the specified coverage is removed for all the requirements under the current one. If FALSE, only the coverage at the current requirement is removed.

See Also OTA COM Type Library

RemoveCoverage Method

Description

Removes a test from the list of tests that cover this requirement.

Syntax

Public Sub RemoveCoverage( _
   ByVal vTest As Variant, _
   Optional ByVal Recursive As Boolean = False _
)

Parameters

vTest

A Test Object or array of test objects.

Recursive

If TRUE, the specified coverage is removed for all the requirements under the current one. If FALSE, only the coverage at the current requirement is removed.

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

Author Property

Description

The name of the requirement author.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

Comment Property

Description

The comment associated with this requirement.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comment() As String

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

Count Property

Description

The number of direct children.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName

The name of the field in the project database.

Remarks

An attempt to get or set the value of a field not applicable to requirements of this type causes an exception. Get the list of applicable fields from CustomizationReqType.Fields.

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

HasCoverage Property

Description

The requirement is covered by at least one test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasCoverage() As Boolean

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

TraceDirection

A value of the TDAPI_TRACE_DIRECTION Enumeration.

See Also OTA COM Type Library

HasReqTraceability Property

Description

Checks if the current requirement has at least one associated requirement in the specified direction.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasReqTraceability( _
   ByVal TraceDirection As Long _
) As Boolean

Parameters

TraceDirection

A value of the TDAPI_TRACE_DIRECTION Enumeration.

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

Name Property

Description

The Requirement name as seen in the tree.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

Paragraph Property

Description

The paragraph number or numeration of the requirement.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Paragraph() As String

Remarks

To see the paragraph numbers in the user interface, choose menu item View > Numeration in the Requirement module.

The paragraph number is one node deeper than the Path.

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

ParentId Property

Description

The Requirement's parent ID.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ParentId() As Long

Remarks

Set this property to place the requirement under another requirement in the hierarchy.

The default is -1, indicating a top-level requirement.

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

Path Property

Description

The path of the node containing this requirement.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Path() As String

Remarks

A path is a code consisting of letters like "AAA", "AAB" and so on. It is not visible in the user interface.

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

Priority Property

Description

The requirement priority.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Priority() As String

Remarks

For most sites, the priorities are from "1-Low" to "5-Urgent".

To get the full list of priorities in your project look at the Priority list. See 'Customizing Project Lists' in the Mercury Quality Center Administrator's Guide.

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

Product Property

Description

The product name for which the requirement is set.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Product() As String

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

TraceDirection

A value of the TDAPI_TRACE_DIRECTION Enumeration.

See Also OTA COM Type Library

ReqTraceFactory Property

Description

The requirement link factory that manages the traceability links of the current requirement to its associated requirements in the specified direction.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ReqTraceFactory( _
   ByVal TraceDirection As Long _
) As Object

Parameters

TraceDirection

A value of the TDAPI_TRACE_DIRECTION Enumeration.

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

RequirementType Property

Description

Gets the interface for getting the requirement types.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RequirementType() As Object

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

Reviewed Property

Description

The review status.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Reviewed() As String

Remarks

The review status can be any value configured in the project. Typical examples are Changed, Not Reviewed, and Reviewed.

For information about the Review Status list, see 'Customizing Project Lists' in the Mercury Quality Center Administrator's Guide.

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

Status Property

Description

The status of the tests that cover this requirement.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Status() As String

Remarks

The statuses of the covering tests are: Failed, No Run, Not Completed, or Passed.

If no tests cover this requirement, the value is Not Covered.

For information about the Status list, see 'Customizing Project Lists' in the Mercury Quality Center Administrator's Guide.

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

Type Property

Description

The requirement type.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Type() As String

Remarks

Obsolete. In previous versions:

The type can be any value configured in the project. Typical examples are Functional, Guideline, Quality, Standard, and System.

For information about the Requirement Type list, see 'Customizing Project Lists' in the Mercury Quality Center Administrator's Guide.

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

TypeId Property

Description

The Requirement's type name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property TypeId() As String

See Also

IReq2 Interface


%%PageItemTitle%%

IReq2 Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

IReq2 Interface


%%PageItemTitle%%

IReqCoverageFactory Members

IReqCoverageFactory Interface

Description

Services for managing requirement coverage.

Remarks

A ReqCoverageFactory manages CoverageEntity Objects.

The reference to a ReqCoverageFactory for a specific requirement is the ICoverableReq.RequirementCoverageFactory Property of the ICoverableReq Implemented Interface of the Req object.

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property FullCoverage | Indicates if the actions of the factory are applied recursively to requirement's children.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

IReqCoverageFactory Interface

ItemData

A reference to the item that will cover the requirement. For example, a Test Object or a TSTest Object.

See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData

A reference to the item that will cover the requirement. For example, a Test Object or a TSTest Object.

Remarks

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

See Also

IReqCoverageFactory Interface


%%PageItemTitle%%

IReqCoverageFactory Interface

Filter
See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

Return Type

A list of A CoverageEntity Objects.

See Also

IReqCoverageFactory Interface


%%PageItemTitle%%

IReqCoverageFactory Interface

ItemKey

A reference to the object that will no longer cover the requirement. For example, a Test Object or a TSTest Object.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey

A reference to the object that will no longer cover the requirement. For example, a Test Object or a TSTest Object.

See Also

IReqCoverageFactory Interface


%%PageItemTitle%%

IReqCoverageFactory Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

IReqCoverageFactory Interface


%%PageItemTitle%%

IReqCoverageFactory Interface

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

IReqCoverageFactory Interface


%%PageItemTitle%%

IReqCoverageFactory Interface

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

IReqCoverageFactory Interface


%%PageItemTitle%%

IReqCoverageFactory Interface

FullCoverage Property

Description

Indicates if the actions of the factory are applied recursively to requirement's children.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FullCoverage() As Boolean

See Also

IReqCoverageFactory Interface


%%PageItemTitle%%

IReqCoverageFactory Interface

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IReqCoverageFactory Interface


%%PageItemTitle%%

IReqCoverageFactory Interface

ItemKey

A CoverageEntity.ID.

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey

A CoverageEntity.ID.

See Also

IReqCoverageFactory Interface


%%PageItemTitle%%

IReqFactory Members

IReqFactory Interface

Description

Services for managing requirements.

Remarks

The ReqFactory for the connection is TDConnection.ReqFactory.

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Public Methods

Public Method AddItem | Creates a new item object.
Public Method BuildPerfGraph | Builds Performance Graph.
Public Method BuildPerfGraphEx | Builds Performance Graph.
Public Method BuildProgressGraph | Builds Req progress graph.
Public Method BuildProgressGraphEx | Builds Requirement progress graph. Extends BuildProgressGraph with ability to display Null parent folders.
Public Method BuildSummaryGraph | Builds Req summary graph.
Public Method BuildSummaryGraphEx | Builds Req summary graph. Extends BuildSummaryGraph with ability to display Null parent folders.
Public Method BuildTrendGraph | Creates graph that shows the number of defect status changes over time.
Public Method BuildTrendGraphEx | Creates graph that shows the number of defect status changes over time.
Public Method Find | Gets a list of requirements containing the Pattern value in specified field.
Public Method GetChildrenList | Gets list of child requirements.
Public Method Mail | Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

IReqFactory Interface

ItemData
See discussion below.

There are three options for ItemData:

  • Null. Creating a virtual Req object with Null ensures that you cannot then Post until all required fields are initialized.
  • The parent requirement ID (Variant).
  • An array consisting of the following elements:

(0) FatherID - The parent requirement ID (long or string, required).

(1) Order - The new requirement position in the children list (long, optional).

Order is either:

    • A number representing the requirement position.
    • TDPOSITION_LAST [-4] - Default. Indicates that the requirement is inserted last.

See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData
See discussion below.

There are three options for ItemData:

  • Null. Creating a virtual Req object with Null ensures that you cannot then Post until all required fields are initialized.
  • The parent requirement ID (Variant).
  • An array consisting of the following elements:

(0) FatherID - The parent requirement ID (long or string, required).

(1) Order - The new requirement position in the children list (long, optional).

Order is either:

    • A number representing the requirement position.
    • TDPOSITION_LAST [-4] - Default. Indicates that the requirement is inserted last.

Remarks

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

[Visual Basic]

Dim bgf As BugFactory
Dim bg As Bug
Dim attf As AttachmentFactory
Dim att As Attachment
Dim attList As List

' Get the factory object
 Set bgf = tdc.BugFactory
' Use defect #1
 Set bg = bgf.Item(1)
 Set attf = bg.Attachments

' Creating a new attachment
' Create virtual object, then populate the properties
 Set att = attf.AddItem(Null)
 att.FileName = Text1.Text
 att.Type = TDATT_INTERNET

' Saving the object with validity check
 att.Post

' Display the attachments
' Add the display-only items without a Post
 List1.Clear
 Set attList = attf.NewList("")
 For i = 1 To attList.Count

      Set att = attList.Item(i)
      List1.AddItem (att.Name)

 Next

See Also

IReqFactory Interface


%%PageItemTitle%%

IReqFactory Interface

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildPerfGraph Method

Description

Builds Performance Graph.

Syntax

Public Function BuildPerfGraph( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

IReqFactory Interface


%%PageItemTitle%%

IReqFactory Interface

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

ShowNullParents

Only for Requirements mode. A value of True allows parent folders, which have no test coverage, from being viewed during Cover Status queries.

See Also OTA COM Type Library

BuildPerfGraphEx Method

Description

Builds Performance Graph.

Syntax

Public Function BuildPerfGraphEx( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False, _
   Optional ByVal ShowNullParents As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

ShowNullParents

Only for Requirements mode. A value of True allows parent folders, which have no test coverage, from being viewed during Cover Status queries.

Return Type

A new Graph Object.

See Also

IReqFactory Interface


%%PageItemTitle%%

IReqFactory Interface

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

ByHistory

Determines whether to use history information to create the graph. Possible values are:

TRUE - Use history information.

FALSE - Do not use history information.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildProgressGraph Method

Description

Builds Req progress graph.

Syntax

Public Function BuildProgressGraph( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal ByHistory As Boolean = True, _
   Optional ByVal MajorSkip As Long = 0, _
   Optional ByVal MinorSkip As Long = 1, _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

ByHistory

Determines whether to use history information to create the graph. Possible values are:

TRUE - Use history information.

FALSE - Do not use history information.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

IReqFactory Interface


%%PageItemTitle%%

IReqFactory Interface

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

ByHistory

Determines whether to use history information to create the graph. Possible values are:

TRUE - Use history information.

FALSE - Do not use history information.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. Zero indicates no limit.

Filter

The TDFilter Object that sets the criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

ShowNullParents

Only for Requirements mode. A value of True allows parent folders, which have no test coverage, from being viewed during Cover Status queries.

See Also OTA COM Type Library

BuildProgressGraphEx Method

Description

Builds Requirement progress graph. Extends BuildProgressGraph with ability to display Null parent folders.

Syntax

Public Function BuildProgressGraphEx( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal ByHistory As Boolean = True, _
   Optional ByVal MajorSkip As Long = 0, _
   Optional ByVal MinorSkip As Long = 1, _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False, _
   Optional ByVal ShowNullParents As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

ByHistory

Determines whether to use history information to create the graph. Possible values are:

TRUE - Use history information.

FALSE - Do not use history information.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. Zero indicates no limit.

Filter

The TDFilter Object that sets the criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

ShowNullParents

Only for Requirements mode. A value of True allows parent folders, which have no test coverage, from being viewed during Cover Status queries.

Return Type

A new Graph Object.

See Also

IReqFactory Interface


%%PageItemTitle%%

IReqFactory Interface

XAxisField

A database field representing the name of the graph x-axis.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildSummaryGraph Method

Description

Builds Req summary graph.

Syntax

Public Function BuildSummaryGraph( _
   Optional ByVal XAxisField As String = "", _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

XAxisField

A database field representing the name of the graph x-axis.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

IReqFactory Interface


%%PageItemTitle%%

IReqFactory Interface

XAxisField

A database field representing the name of the graph x-axis.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

ShowNullParents

Only for Requirements mode. A value of True allows parent folders, which have no test coverage, from being viewed during Cover Status queries.

See Also OTA COM Type Library

BuildSummaryGraphEx Method

Description

Builds Req summary graph. Extends BuildSummaryGraph with ability to display Null parent folders.

Syntax

Public Function BuildSummaryGraphEx( _
   Optional ByVal XAxisField As String = "", _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False, _
   Optional ByVal ShowNullParents As Boolean = False _
) As Object

Parameters

XAxisField

A database field representing the name of the graph x-axis.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

ShowNullParents

Only for Requirements mode. A value of True allows parent folders, which have no test coverage, from being viewed during Cover Status queries.

Return Type

A new Graph Object.

See Also

IReqFactory Interface


%%PageItemTitle%%

IReqFactory Interface

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildTrendGraph Method

Description

Creates graph that shows the number of defect status changes over time.

Syntax

Public Function BuildTrendGraph( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

IReqFactory Interface


%%PageItemTitle%%

IReqFactory Interface

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

ShowNullParents

Only for Requirements mode. A value of True allows parent folders, which have no test coverage, from being viewed during Cover Status queries.

See Also OTA COM Type Library

BuildTrendGraphEx Method

Description

Creates graph that shows the number of defect status changes over time.

Syntax

Public Function BuildTrendGraphEx( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False, _
   Optional ByVal ShowNullParents As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

ShowNullParents

Only for Requirements mode. A value of True allows parent folders, which have no test coverage, from being viewed during Cover Status queries.

Return Type

A new Graph Object.

See Also

IReqFactory Interface


%%PageItemTitle%%

IReqFactory Interface

StartRootID

The ID of the root of the subtree from which to start the search.

FieldName

The name of the field to scan for the value.

Pattern

The search pattern. Regular expression are permitted in SQL format only.

mode

A search option. Use values from the tagTDAPI_REQMODE Enumeration.

Limit

The maximum number of matches to report.

See Also OTA COM Type Library

Find Method

Description

Gets a list of requirements containing the Pattern value in specified field.

Syntax

Public Function Find( _
   ByVal StartRootID As Long, _
   ByVal FieldName As String, _
   ByVal Pattern As String, _
   Optional ByVal mode As Long = 0, _
   Optional ByVal Limit As Long = 100 _
) As List

Parameters

StartRootID

The ID of the root of the subtree from which to start the search.

FieldName

The name of the field to scan for the value.

Pattern

The search pattern. Regular expression are permitted in SQL format only.

mode

A search option. Use values from the tagTDAPI_REQMODE Enumeration.

Limit

The maximum number of matches to report.

Return Type

A list with format "ID,NAME".

See Also

IReqFactory Interface


%%PageItemTitle%%

IReqFactory Interface

FatherID

The ID of the parent requirement.

See Also OTA COM Type Library

GetChildrenList Method

Description

Gets list of child requirements.

Syntax

Public Function GetChildrenList( _
   ByVal FatherID As Long _
) As List

Parameters

FatherID

The ID of the parent requirement.

Return Type

A list of Req Objects.

See Also

IReqFactory Interface


%%PageItemTitle%%

IReqFactory Interface

Items

A list of IDs.

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also OTA COM Type Library

Mail Method

Description

Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.

Syntax

Public Sub Mail( _
   ByVal Items As Variant, _
   ByVal SendTo As String, _
   Optional ByVal SendCc As String = "", _
   Optional ByVal Option As Long = 0, _
   Optional ByVal Subject As String = "", _
   Optional ByVal Comment As String = "" _
)

Parameters

Items

A list of IDs.

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also

IReqFactory Interface


%%PageItemTitle%%

IReqFactory Interface

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

IReqFactory Interface


%%PageItemTitle%%

IReqFactory Interface

ItemKey

The requirement ID (long), a reference to the Req Object or a Variant array of Reg.IDs.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey

The requirement ID (long), a reference to the Req Object or a Variant array of Reg.IDs.

See Also

IReqFactory Interface


%%PageItemTitle%%

IReqFactory Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

IReqFactory Interface


%%PageItemTitle%%

IReqFactory Interface

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

IReqFactory Interface


%%PageItemTitle%%

IReqFactory Interface

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

IReqFactory Interface

Example

Getting a hierarchical list of requirements


%%PageItemTitle%%

IReqFactory Interface

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IReqFactory Interface


%%PageItemTitle%%

IReqFactory Interface

ItemKey

The requirement ID (long).

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey

The requirement ID (long).

See Also

IReqFactory Interface


%%PageItemTitle%%

IReqFactory2 Members

IReqFactory2 Interface

Description

Services for managing requirements.

Remarks

The ReqFactory for the connection is TDConnection.ReqFactory.

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Public Methods

Public Method AddItem | Creates a new item object.
Public Method BuildPerfGraph | Builds Performance Graph.
Public Method BuildPerfGraphEx | Builds Performance Graph.
Public Method BuildProgressGraph | Builds Req progress graph.
Public Method BuildProgressGraphEx | Builds Requirement progress graph. Extends BuildProgressGraph with ability to display Null parent folders.
Public Method BuildSummaryGraph | Builds Req summary graph.
Public Method BuildSummaryGraphEx | Builds Req summary graph. Extends BuildSummaryGraph with ability to display Null parent folders.
Public Method BuildTrendGraph | Creates graph that shows the number of defect status changes over time.
Public Method BuildTrendGraphEx | Creates graph that shows the number of defect status changes over time.
Public Method Find | Gets a list of requirements containing the Pattern value in specified field.
Public Method GetChildrenList | Gets list of child requirements.
Public Method GetFilteredChildrenList | Gets a filtered list of child requirements.
Public Method Mail | Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

IReqFactory2 Interface

ItemData

There are three options for ItemData:

  • Null. Creating a virtual Req object with Null ensures that you cannot then Post until all required fields are initialized.
  • The parent requirement ID (Variant).
  • An array consisting of the following elements:

(0) FatherID - The parent requirement ID (long or string, required).

(1) Order - The new requirement position in the children list (long, optional).

Order is either:

    • A number representing the requirement position.
    • TDPOSITION_LAST [-4] - Default. Indicates that the requirement is inserted last.

See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData

There are three options for ItemData:

  • Null. Creating a virtual Req object with Null ensures that you cannot then Post until all required fields are initialized.
  • The parent requirement ID (Variant).
  • An array consisting of the following elements:

(0) FatherID - The parent requirement ID (long or string, required).

(1) Order - The new requirement position in the children list (long, optional).

Order is either:

    • A number representing the requirement position.
    • TDPOSITION_LAST [-4] - Default. Indicates that the requirement is inserted last.

Remarks

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

[Visual Basic]

Dim bgf As BugFactory
Dim bg As Bug
Dim attf As AttachmentFactory
Dim att As Attachment
Dim attList As List

' Get the factory object
 Set bgf = tdc.BugFactory
' Use defect #1
 Set bg = bgf.Item(1)
 Set attf = bg.Attachments

' Creating a new attachment
' Create virtual object, then populate the properties
 Set att = attf.AddItem(Null)
 att.FileName = Text1.Text
 att.Type = TDATT_INTERNET

' Saving the object with validity check
 att.Post

' Display the attachments
' Add the display-only items without a Post
 List1.Clear
 Set attList = attf.NewList("")
 For i = 1 To attList.Count

      Set att = attList.Item(i)
      List1.AddItem (att.Name)

 Next

See Also

IReqFactory2 Interface


%%PageItemTitle%%

IReqFactory2 Interface

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildPerfGraph Method

Description

Builds Performance Graph.

Syntax

Public Function BuildPerfGraph( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

IReqFactory2 Interface


%%PageItemTitle%%

IReqFactory2 Interface

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

ShowNullParents

Only for Requirements mode. A value of True allows parent folders, which have no test coverage, from being viewed during Cover Status queries.

See Also OTA COM Type Library

BuildPerfGraphEx Method

Description

Builds Performance Graph.

Syntax

Public Function BuildPerfGraphEx( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False, _
   Optional ByVal ShowNullParents As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

ShowNullParents

Only for Requirements mode. A value of True allows parent folders, which have no test coverage, from being viewed during Cover Status queries.

Return Type

A new Graph Object.

See Also

IReqFactory2 Interface


%%PageItemTitle%%

IReqFactory2 Interface

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

ByHistory

Determines whether to use history information to create the graph. Possible values are:

TRUE - Use history information.

FALSE - Do not use history information.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildProgressGraph Method

Description

Builds Req progress graph.

Syntax

Public Function BuildProgressGraph( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal ByHistory As Boolean = True, _
   Optional ByVal MajorSkip As Long = 0, _
   Optional ByVal MinorSkip As Long = 1, _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

ByHistory

Determines whether to use history information to create the graph. Possible values are:

TRUE - Use history information.

FALSE - Do not use history information.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

IReqFactory2 Interface


%%PageItemTitle%%

IReqFactory2 Interface

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

ByHistory

Determines whether to use history information to create the graph. Possible values are:

TRUE - Use history information.

FALSE - Do not use history information.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. Zero indicates no limit.

Filter

The TDFilter Object that sets the criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

ShowNullParents

Only for Requirements mode. A value of True allows parent folders, which have no test coverage, from being viewed during Cover Status queries.

See Also OTA COM Type Library

BuildProgressGraphEx Method

Description

Builds Requirement progress graph. Extends BuildProgressGraph with ability to display Null parent folders.

Syntax

Public Function BuildProgressGraphEx( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal ByHistory As Boolean = True, _
   Optional ByVal MajorSkip As Long = 0, _
   Optional ByVal MinorSkip As Long = 1, _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False, _
   Optional ByVal ShowNullParents As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

ByHistory

Determines whether to use history information to create the graph. Possible values are:

TRUE - Use history information.

FALSE - Do not use history information.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. Zero indicates no limit.

Filter

The TDFilter Object that sets the criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

ShowNullParents

Only for Requirements mode. A value of True allows parent folders, which have no test coverage, from being viewed during Cover Status queries.

Return Type

A new Graph Object.

See Also

IReqFactory2 Interface


%%PageItemTitle%%

IReqFactory2 Interface

XAxisField

A database field representing the name of the graph x-axis.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildSummaryGraph Method

Description

Builds Req summary graph.

Syntax

Public Function BuildSummaryGraph( _
   Optional ByVal XAxisField As String = "", _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

XAxisField

A database field representing the name of the graph x-axis.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

IReqFactory2 Interface


%%PageItemTitle%%

IReqFactory2 Interface

XAxisField

A database field representing the name of the graph x-axis.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

ShowNullParents

Only for Requirements mode. A value of True allows parent folders, which have no test coverage, from being viewed during Cover Status queries.

See Also OTA COM Type Library

BuildSummaryGraphEx Method

Description

Builds Req summary graph. Extends BuildSummaryGraph with ability to display Null parent folders.

Syntax

Public Function BuildSummaryGraphEx( _
   Optional ByVal XAxisField As String = "", _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False, _
   Optional ByVal ShowNullParents As Boolean = False _
) As Object

Parameters

XAxisField

A database field representing the name of the graph x-axis.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

ShowNullParents

Only for Requirements mode. A value of True allows parent folders, which have no test coverage, from being viewed during Cover Status queries.

Return Type

A new Graph Object.

See Also

IReqFactory2 Interface


%%PageItemTitle%%

IReqFactory2 Interface

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildTrendGraph Method

Description

Creates graph that shows the number of defect status changes over time.

Syntax

Public Function BuildTrendGraph( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

IReqFactory2 Interface


%%PageItemTitle%%

IReqFactory2 Interface

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

ShowNullParents

Only for Requirements mode. A value of True allows parent folders, which have no test coverage, from being viewed during Cover Status queries.

See Also OTA COM Type Library

BuildTrendGraphEx Method

Description

Creates graph that shows the number of defect status changes over time.

Syntax

Public Function BuildTrendGraphEx( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False, _
   Optional ByVal ShowNullParents As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

ShowNullParents

Only for Requirements mode. A value of True allows parent folders, which have no test coverage, from being viewed during Cover Status queries.

Return Type

A new Graph Object.

See Also

IReqFactory2 Interface


%%PageItemTitle%%

IReqFactory2 Interface

StartRootID

The ID of the root of the subtree from which to start the search.

FieldName

The name of the field to scan for the value.

Pattern

The search pattern. Regular expression are permitted in SQL format only.

mode

A search option. Use values from the tagTDAPI_REQMODE Enumeration.

Limit

The maximum number of matches to report.

See Also OTA COM Type Library

Find Method

Description

Gets a list of requirements containing the Pattern value in specified field.

Syntax

Public Function Find( _
   ByVal StartRootID As Long, _
   ByVal FieldName As String, _
   ByVal Pattern As String, _
   Optional ByVal mode As Long = 0, _
   Optional ByVal Limit As Long = 100 _
) As List

Parameters

StartRootID

The ID of the root of the subtree from which to start the search.

FieldName

The name of the field to scan for the value.

Pattern

The search pattern. Regular expression are permitted in SQL format only.

mode

A search option. Use values from the tagTDAPI_REQMODE Enumeration.

Limit

The maximum number of matches to report.

Return Type

A list with format "ID,NAME".

See Also

IReqFactory2 Interface


%%PageItemTitle%%

IReqFactory2 Interface

FatherID

The ID of the parent requirement.

See Also OTA COM Type Library

GetChildrenList Method

Description

Gets list of child requirements.

Syntax

Public Function GetChildrenList( _
   ByVal FatherID As Long _
) As List

Parameters

FatherID

The ID of the parent requirement.

Return Type

A list of Req Objects.

See Also

IReqFactory2 Interface


%%PageItemTitle%%

IReqFactory2 Interface

FatherID

The Req.ID of the requirement whose child requirements are to be retreived.

Filter

A TDFilter Object that provides criteria for the child requirements

See Also OTA COM Type Library

GetFilteredChildrenList Method

Description

Gets a filtered list of child requirements.

Syntax

Public Function GetFilteredChildrenList( _
   ByVal FatherID As Long, _
   Optional ByVal Filter As ITDFilter = 0 _
) As List

Parameters

FatherID

The Req.ID of the requirement whose child requirements are to be retreived.

Filter

A TDFilter Object that provides criteria for the child requirements

Return Type

A list of Req Objects.

Remarks

If no filter is passed, all child requirements are included in the list.

See Also

IReqFactory2 Interface


%%PageItemTitle%%

IReqFactory2 Interface

Items

A list of IDs.

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also OTA COM Type Library

Mail Method

Description

Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.

Syntax

Public Sub Mail( _
   ByVal Items As Variant, _
   ByVal SendTo As String, _
   Optional ByVal SendCc As String = "", _
   Optional ByVal Option As Long = 0, _
   Optional ByVal Subject As String = "", _
   Optional ByVal Comment As String = "" _
)

Parameters

Items

A list of IDs.

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also

IReqFactory2 Interface


%%PageItemTitle%%

IReqFactory2 Interface

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

IReqFactory2 Interface


%%PageItemTitle%%

IReqFactory2 Interface

ItemKey

The requirement ID (long), a reference to the Req Object or a Variant array of Reg.IDs.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey

The requirement ID (long), a reference to the Req Object or a Variant array of Reg.IDs.

See Also

IReqFactory2 Interface


%%PageItemTitle%%

IReqFactory2 Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

IReqFactory2 Interface


%%PageItemTitle%%

IReqFactory2 Interface

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

IReqFactory2 Interface


%%PageItemTitle%%

IReqFactory2 Interface

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

IReqFactory2 Interface


%%PageItemTitle%%

IReqFactory2 Interface

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IReqFactory2 Interface


%%PageItemTitle%%

IReqFactory2 Interface

ItemKey

The requirement ID (long).

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey

The requirement ID (long).

See Also

IReqFactory2 Interface


%%PageItemTitle%%

IReqFactory3 Members

IReqFactory3 Interface

Description

Services for managing requirements.

Remarks

The ReqFactory for the connection is TDConnection.ReqFactory.

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Public Methods

Public Method AddItem | Creates a new item object.
Public Method BuildPerfGraph | Builds Performance Graph.
Public Method BuildPerfGraphEx | Builds Performance Graph.
Public Method BuildProgressGraph | Builds Req progress graph.
Public Method BuildProgressGraphEx | Builds Requirement progress graph. Extends BuildProgressGraph with ability to display Null parent folders.
Public Method BuildSummaryGraph | Builds Req summary graph.
Public Method BuildSummaryGraphEx | Builds Req summary graph. Extends BuildSummaryGraph with ability to display Null parent folders.
Public Method BuildTrendGraph | Creates graph that shows the number of defect status changes over time.
Public Method BuildTrendGraphEx | Creates graph that shows the number of defect status changes over time.
Public Method Find | Gets a list of requirements containing the Pattern value in specified field.
Public Method GetChildrenList | Gets list of child requirements.
Public Method GetCoverageTestsByReqFilter | Returns the list of tests that cover the requirements that match the requirement filter.
Public Method GetFilteredChildrenList | Gets a filtered list of child requirements.
Public Method GetRequirementType | Returns the requirement customization type object specified by the type ID.
Public Method GetRequirementTypes | Returns the list of requirement customization types.
Public Method GetTracedList | Returns the list of requirements either traced directly from or directly to the specified requirement.
Public Method Mail | Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.
Public Method ReqTypeIdToName | Returns the name of the requirement type specified by the type ID.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

IReqFactory3 Interface

ItemData

There are three options for ItemData:

  • Null. Creating a virtual Req object with Null ensures that you cannot then Post until all required fields are initialized.
  • The parent requirement ID (Variant).
  • An array consisting of the following elements:

(0) FatherID - The parent requirement ID (long or string, required).

(1) Order - The new requirement position in the children list (long, optional).

Order is either:

    • A number representing the requirement position.
    • TDPOSITION_LAST [-4] - Default. Indicates that the requirement is inserted last.

See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData

There are three options for ItemData:

  • Null. Creating a virtual Req object with Null ensures that you cannot then Post until all required fields are initialized.
  • The parent requirement ID (Variant).
  • An array consisting of the following elements:

(0) FatherID - The parent requirement ID (long or string, required).

(1) Order - The new requirement position in the children list (long, optional).

Order is either:

    • A number representing the requirement position.
    • TDPOSITION_LAST [-4] - Default. Indicates that the requirement is inserted last.

Remarks

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

[Visual Basic]

Dim bgf As BugFactory
Dim bg As Bug
Dim attf As AttachmentFactory
Dim att As Attachment
Dim attList As List

' Get the factory object
 Set bgf = tdc.BugFactory
' Use defect #1
 Set bg = bgf.Item(1)
 Set attf = bg.Attachments

' Creating a new attachment
' Create virtual object, then populate the properties
 Set att = attf.AddItem(Null)
 att.FileName = Text1.Text
 att.Type = TDATT_INTERNET

' Saving the object with validity check
 att.Post

' Display the attachments
' Add the display-only items without a Post
 List1.Clear
 Set attList = attf.NewList("")
 For i = 1 To attList.Count

      Set att = attList.Item(i)
      List1.AddItem (att.Name)

 Next

See Also

IReqFactory3 Interface


%%PageItemTitle%%

IReqFactory3 Interface

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildPerfGraph Method

Description

Builds Performance Graph.

Syntax

Public Function BuildPerfGraph( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

IReqFactory3 Interface


%%PageItemTitle%%

IReqFactory3 Interface

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

ShowNullParents

Only for Requirements mode. A value of True allows parent folders, which have no test coverage, from being viewed during Cover Status queries.

See Also OTA COM Type Library

BuildPerfGraphEx Method

Description

Builds Performance Graph.

Syntax

Public Function BuildPerfGraphEx( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False, _
   Optional ByVal ShowNullParents As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

ShowNullParents

Only for Requirements mode. A value of True allows parent folders, which have no test coverage, from being viewed during Cover Status queries.

Return Type

A new Graph Object.

See Also

IReqFactory3 Interface


%%PageItemTitle%%

IReqFactory3 Interface

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

ByHistory

Determines whether to use history information to create the graph. Possible values are:

TRUE - Use history information.

FALSE - Do not use history information.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildProgressGraph Method

Description

Builds Req progress graph.

Syntax

Public Function BuildProgressGraph( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal ByHistory As Boolean = True, _
   Optional ByVal MajorSkip As Long = 0, _
   Optional ByVal MinorSkip As Long = 1, _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

ByHistory

Determines whether to use history information to create the graph. Possible values are:

TRUE - Use history information.

FALSE - Do not use history information.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

IReqFactory3 Interface


%%PageItemTitle%%

IReqFactory3 Interface

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

ByHistory

Determines whether to use history information to create the graph. Possible values are:

TRUE - Use history information.

FALSE - Do not use history information.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. Zero indicates no limit.

Filter

The TDFilter Object that sets the criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

ShowNullParents

Only for Requirements mode. A value of True allows parent folders, which have no test coverage, from being viewed during Cover Status queries.

See Also OTA COM Type Library

BuildProgressGraphEx Method

Description

Builds Requirement progress graph. Extends BuildProgressGraph with ability to display Null parent folders.

Syntax

Public Function BuildProgressGraphEx( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal ByHistory As Boolean = True, _
   Optional ByVal MajorSkip As Long = 0, _
   Optional ByVal MinorSkip As Long = 1, _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False, _
   Optional ByVal ShowNullParents As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

ByHistory

Determines whether to use history information to create the graph. Possible values are:

TRUE - Use history information.

FALSE - Do not use history information.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. Zero indicates no limit.

Filter

The TDFilter Object that sets the criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

ShowNullParents

Only for Requirements mode. A value of True allows parent folders, which have no test coverage, from being viewed during Cover Status queries.

Return Type

A new Graph Object.

See Also

IReqFactory3 Interface


%%PageItemTitle%%

IReqFactory3 Interface

XAxisField

A database field representing the name of the graph x-axis.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildSummaryGraph Method

Description

Builds Req summary graph.

Syntax

Public Function BuildSummaryGraph( _
   Optional ByVal XAxisField As String = "", _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

XAxisField

A database field representing the name of the graph x-axis.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

IReqFactory3 Interface


%%PageItemTitle%%

IReqFactory3 Interface

XAxisField

A database field representing the name of the graph x-axis.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

ShowNullParents

Only for Requirements mode. A value of True allows parent folders, which have no test coverage, from being viewed during Cover Status queries.

See Also OTA COM Type Library

BuildSummaryGraphEx Method

Description

Builds Req summary graph. Extends BuildSummaryGraph with ability to display Null parent folders.

Syntax

Public Function BuildSummaryGraphEx( _
   Optional ByVal XAxisField As String = "", _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False, _
   Optional ByVal ShowNullParents As Boolean = False _
) As Object

Parameters

XAxisField

A database field representing the name of the graph x-axis.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

ShowNullParents

Only for Requirements mode. A value of True allows parent folders, which have no test coverage, from being viewed during Cover Status queries.

Return Type

A new Graph Object.

See Also

IReqFactory3 Interface


%%PageItemTitle%%

IReqFactory3 Interface

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildTrendGraph Method

Description

Creates graph that shows the number of defect status changes over time.

Syntax

Public Function BuildTrendGraph( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

IReqFactory3 Interface


%%PageItemTitle%%

IReqFactory3 Interface

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

ShowNullParents

Only for Requirements mode. A value of True allows parent folders, which have no test coverage, from being viewed during Cover Status queries.

See Also OTA COM Type Library

BuildTrendGraphEx Method

Description

Creates graph that shows the number of defect status changes over time.

Syntax

Public Function BuildTrendGraphEx( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False, _
   Optional ByVal ShowNullParents As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

ShowNullParents

Only for Requirements mode. A value of True allows parent folders, which have no test coverage, from being viewed during Cover Status queries.

Return Type

A new Graph Object.

See Also

IReqFactory3 Interface


%%PageItemTitle%%

IReqFactory3 Interface

StartRootID

The ID of the root of the subtree from which to start the search.

FieldName

The name of the field to scan for the value.

Pattern

The search pattern. Regular expression are permitted in SQL format only.

mode

A search option. Use values from the tagTDAPI_REQMODE Enumeration.

Limit

The maximum number of matches to report.

See Also OTA COM Type Library

Find Method

Description

Gets a list of requirements containing the Pattern value in specified field.

Syntax

Public Function Find( _
   ByVal StartRootID As Long, _
   ByVal FieldName As String, _
   ByVal Pattern As String, _
   Optional ByVal mode As Long = 0, _
   Optional ByVal Limit As Long = 100 _
) As List

Parameters

StartRootID

The ID of the root of the subtree from which to start the search.

FieldName

The name of the field to scan for the value.

Pattern

The search pattern. Regular expression are permitted in SQL format only.

mode

A search option. Use values from the tagTDAPI_REQMODE Enumeration.

Limit

The maximum number of matches to report.

Return Type

A list with format "ID,NAME".

See Also

IReqFactory3 Interface


%%PageItemTitle%%

IReqFactory3 Interface

FatherID

The ID of the parent requirement.

See Also OTA COM Type Library

GetChildrenList Method

Description

Gets list of child requirements.

Syntax

Public Function GetChildrenList( _
   ByVal FatherID As Long _
) As List

Parameters

FatherID

The ID of the parent requirement.

Return Type

A list of Req Objects.

See Also

IReqFactory3 Interface


%%PageItemTitle%%

IReqFactory3 Interface

ReqFilter

A TDFilter.Text that specifies which requirements to include.

See Also OTA COM Type Library

GetCoverageTestsByReqFilter Method

Description

Returns the list of tests that cover the requirements that match the requirement filter.

Syntax

Public Function GetCoverageTestsByReqFilter( _
   ByVal ReqFilter As String _
) As List

Parameters

ReqFilter

A TDFilter.Text that specifies which requirements to include.

Return Type

A list of the Tests that cover the requirements that match the filter.

See Also

IReqFactory3 Interface


%%PageItemTitle%%

IReqFactory3 Interface

FatherID

The Req.ID of the requirement whose child requirements are to be retreived.

Filter

A TDFilter Object that provides criteria for the child requirements

See Also OTA COM Type Library

GetFilteredChildrenList Method

Description

Gets a filtered list of child requirements.

Syntax

Public Function GetFilteredChildrenList( _
   ByVal FatherID As Long, _
   Optional ByVal Filter As ITDFilter = 0 _
) As List

Parameters

FatherID

The Req.ID of the requirement whose child requirements are to be retreived.

Filter

A TDFilter Object that provides criteria for the child requirements

Return Type

A list of Req Objects.

Remarks

If no filter is passed, all child requirements are included in the list.

See Also

IReqFactory3 Interface


%%PageItemTitle%%

IReqFactory3 Interface

TypeId

The name of the requirement type as entered in the customization module of Quality Center.

See Also OTA COM Type Library

GetRequirementType Method

Description

Returns the requirement customization type object specified by the type ID.

Syntax

Public Function GetRequirementType( _
   ByVal TypeId As String _
) As Object

Parameters

TypeId

The name of the requirement type as entered in the customization module of Quality Center.

Return Type

A ReqType Object.

See Also

IReqFactory3 Interface


%%PageItemTitle%%

IReqFactory3 Interface

GetRequirementTypes Method

Description

Returns the list of requirement customization types.

Syntax

Public Function GetRequirementTypes() As List

Return Type

A list of ReqType Objects.

See Also

IReqFactory3 Interface


%%PageItemTitle%%

IReqFactory3 Interface

ReqID

A Req.ID.

TraceDirection

A value of the TDAPI_TRACE_DIRECTION Enumeration.

See Also OTA COM Type Library

GetTracedList Method

Description

Returns the list of requirements either traced directly from or directly to the specified requirement.

Syntax

Public Function GetTracedList( _
   ByVal ReqID As Long, _
   ByVal TraceDirection As Long _
) As List

Parameters

ReqID

A Req.ID.

TraceDirection

A value of the TDAPI_TRACE_DIRECTION Enumeration.

Return Type

A list of references to Req objects.

Remarks

If TraceDirection is TDOLE_TRACED_FROM, GetTracedList returns the requirements traced from the requirement specified with ReqID. That is, the specified requirement is the Trace.FromReq of the trace associations.

If TraceDirections is TDOLE_TRACED_TO, it returns the list of requirements that have a trace association where the specified requirement is the Trace.ToReq

See Also

IReqFactory3 Interface


%%PageItemTitle%%

IReqFactory3 Interface

Items

A list of IDs.

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also OTA COM Type Library

Mail Method

Description

Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.

Syntax

Public Sub Mail( _
   ByVal Items As Variant, _
   ByVal SendTo As String, _
   Optional ByVal SendCc As String = "", _
   Optional ByVal Option As Long = 0, _
   Optional ByVal Subject As String = "", _
   Optional ByVal Comment As String = "" _
)

Parameters

Items

A list of IDs.

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also

IReqFactory3 Interface


%%PageItemTitle%%

IReqFactory3 Interface

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

IReqFactory3 Interface


%%PageItemTitle%%

IReqFactory3 Interface

ItemKey

The requirement ID (long), a reference to the Req Object or a Variant array of Reg.IDs.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey

The requirement ID (long), a reference to the Req Object or a Variant array of Reg.IDs.

See Also

IReqFactory3 Interface


%%PageItemTitle%%

IReqFactory3 Interface

TypeId

A ReqType.ID.

See Also OTA COM Type Library

ReqTypeIdToName Method

Description

Returns the name of the requirement type specified by the type ID.

Syntax

Public Function ReqTypeIdToName( _
   ByVal TypeId As Long _
) As String

Parameters

TypeId

A ReqType.ID.

Return Type

The name of the type as entered in the customization module of Quality Center.

See Also

IReqFactory3 Interface


%%PageItemTitle%%

IReqFactory3 Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

IReqFactory3 Interface


%%PageItemTitle%%

IReqFactory3 Interface

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

IReqFactory3 Interface


%%PageItemTitle%%

IReqFactory3 Interface

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

IReqFactory3 Interface


%%PageItemTitle%%

IReqFactory3 Interface

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IReqFactory3 Interface


%%PageItemTitle%%

IReqFactory3 Interface

ItemKey

The requirement ID (long).

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey

The requirement ID (long).

See Also

IReqFactory3 Interface


%%PageItemTitle%%

IReqTraceFactory Members

IReqTraceFactory Interface

Description

Services for managing traceability associations between requirements.

Remarks

Get a reference to ReqTraceFactory from Req.ReqTraceFactory.

The factory manages Trace Objects.

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

IReqTraceFactory Interface

ItemData

Either Null, a Req Object, or a Req.ID.

See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData

Either Null, a Req Object, or a Req.ID.

Return Type

A Trace Object.

Remarks

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

[Visual Basic]

Dim bgf As BugFactory
Dim bg As Bug
Dim attf As AttachmentFactory
Dim att As Attachment
Dim attList As List

' Get the factory object
 Set bgf = tdc.BugFactory
' Use defect #1
 Set bg = bgf.Item(1)
 Set attf = bg.Attachments

' Creating a new attachment
' Create virtual object, then populate the properties
 Set att = attf.AddItem(Null)
 att.FileName = Text1.Text
 att.Type = TDATT_INTERNET

' Saving the object with validity check
 att.Post

' Display the attachments
' Add the display-only items without a Post
 List1.Clear
 Set attList = attf.NewList("")
 For i = 1 To attList.Count

      Set att = attList.Item(i)
      List1.AddItem (att.Name)

 Next

See Also

IReqTraceFactory Interface


%%PageItemTitle%%

IReqTraceFactory Interface

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

IReqTraceFactory Interface


%%PageItemTitle%%

IReqTraceFactory Interface

ItemKey

A Trace.ID, a Trace Object, a variant array of Trace objects, or a List of Trace objects.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey

A Trace.ID, a Trace Object, a variant array of Trace objects, or a List of Trace objects.

See Also

IReqTraceFactory Interface


%%PageItemTitle%%

IReqTraceFactory Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

IReqTraceFactory Interface


%%PageItemTitle%%

IReqTraceFactory Interface

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

IReqTraceFactory Interface


%%PageItemTitle%%

IReqTraceFactory Interface

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

IReqTraceFactory Interface


%%PageItemTitle%%

IReqTraceFactory Interface

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IReqTraceFactory Interface


%%PageItemTitle%%

IReqTraceFactory Interface

ItemKey

A Trace.ID

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey

A Trace.ID

See Also

IReqTraceFactory Interface


%%PageItemTitle%%

IReqType Members

IReqType Interface

Description

Represents a Requirement Type.

Public Properties

Public Property HasDirectCoverage | Indicates if this requirement type supports direct coverage by tests or test instances.
Public Property Icon | The bitmap stream representing this type.
Public Property ID | The CustomizationType ID.
Public Property Name | The CustomizationType name.
Public Property RiskAnalysisType | The type of risk analysis that is applicable to this requirement.


%%PageItemTitle%%

IReqType Interface

HasDirectCoverage Property

Description

Indicates if this requirement type supports direct coverage by tests or test instances.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasDirectCoverage() As Boolean

See Also

IReqType Interface


%%PageItemTitle%%

IReqType Interface

Icon Property

Description

The bitmap stream representing this type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Icon() As IStream

See Also

IReqType Interface


%%PageItemTitle%%

IReqType Interface

ID Property

Description

The CustomizationType ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Long

See Also

IReqType Interface


%%PageItemTitle%%

IReqType Interface

Name Property

Description

The CustomizationType name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name() As String

See Also

IReqType Interface


%%PageItemTitle%%

IReqType Interface

RiskAnalysisType Property

Description

The type of risk analysis that is applicable to this requirement.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RiskAnalysisType() As Long

See Also

IReqType Interface


%%PageItemTitle%%

IRule Members

IRule Interface

Description

Represents a rule for generating an alert.

Remarks

For more information on rules, see 'Setting Traceability Notification Rules' in the Mercury Quality Center Administrator's Guide.

Get a Rule object from the RuleManager.

Public Methods

Public Method Post Saves the changes to the Rules object to the server.

Public Properties

Public Property Description | The rule description.
Public Property ID | The rule ID.
Public Property IsActive | Indicates if the rule is active.
Public Property ToMail | Indicates if the alert is to be sent by e-mail.


%%PageItemTitle%%

IRule Interface

Post Method

Description

Saves the changes to the Rules object to the server.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IRule Interface


%%PageItemTitle%%

IRule Interface

Description Property

Description

The rule description.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Description() As String

Example

[]

<html><body>When a <b>requirement</b> changes,
notify the <b>Designer(s)</b> of the
associated <b>test(s)</b>.</body></html>

See Also

IRule Interface


%%PageItemTitle%%

IRule Interface

ID Property

Description

The rule ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Long

See Also

IRule Interface


%%PageItemTitle%%

IRule Interface

IsActive Property

Description

Indicates if the rule is active.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsActive() As Boolean

See Also

IRule Interface


%%PageItemTitle%%

IRule Interface

ToMail Property

Description

Indicates if the alert is to be sent by e-mail.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ToMail() As Boolean

See Also

IRule Interface


%%PageItemTitle%%

IRule2 Members

IRule2 Interface

Description

Represents a rule for generating an alert.

Public Methods

Public Method Post Saves the changes to the Rules object to the server.

Public Properties

Public Property Description | The rule description.
Public Property ID | The rule ID.
Public Property IsActive | Indicates if the rule is active.
Public Property Recipient | Returns the user name of the recipient of the alert email.
Public Property ToMail | Indicates if the alert is to be sent by e-mail.


%%PageItemTitle%%

IRule2 Interface

Post Method

Description

Saves the changes to the Rules object to the server.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IRule2 Interface


%%PageItemTitle%%

IRule2 Interface

Description Property

Description

The rule description.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Description() As String

See Also

IRule2 Interface


%%PageItemTitle%%

IRule2 Interface

ID Property

Description

The rule ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Long

See Also

IRule2 Interface


%%PageItemTitle%%

IRule2 Interface

IsActive Property

Description

Indicates if the rule is active.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsActive() As Boolean

See Also

IRule2 Interface


%%PageItemTitle%%

IRule2 Interface

Recipient Property

Description

Returns the user name of the recipient of the alert email.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Recipient() As String

See Also

IRule2 Interface


%%PageItemTitle%%

IRule2 Interface

ToMail Property

Description

Indicates if the alert is to be sent by e-mail.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ToMail() As Boolean

See Also

IRule2 Interface


%%PageItemTitle%%

IRuleManager Members

IRuleManager Interface

Description

Services for managing the notification rules.

Remarks

For more information on rules, see 'Setting Traceability Notification Rules' in the Mercury Quality Center Administrator's Guide.

The RuleManager for the connection is TDConnection.Rules.

Public Methods

Public Method GetRule Gets a traceability notification rule by its ID.

Public Properties

Public Property Rules A list of all the Rule objects.


%%PageItemTitle%%

IRuleManager Interface

ID

A Rule.ID.

See Also OTA COM Type Library

GetRule Method

Description

Gets a traceability notification rule by its ID.

Syntax

Public Function GetRule( _
   ByVal ID As Long _
) As Object

Parameters

ID

A Rule.ID.

Return Type

A Rule Object.

See Also

IRuleManager Interface


%%PageItemTitle%%

IRuleManager Interface

NeedRefresh

If True, the rules in the local cache are reloaded from the project.

See Also OTA COM Type Library

Rules Property

Description

A list of all the Rule objects.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Rules( _
   Optional ByVal NeedRefresh As Boolean = False _
) As List

Parameters

NeedRefresh

If True, the rules in the local cache are reloaded from the project.

See Also

IRuleManager Interface


%%PageItemTitle%%

IRun Members

IRun Interface

Description

Represents a test run.

Remarks

Get a Run object from the RunFactory.

Public Methods

Public Method CancelRun | Cancels the run.
Public Method CopyDesignSteps | Copies design steps into the test run of an executed test.
Public Method CopyStepsToTest | Copies all run execution steps, including new added steps, into the design steps of the corresponding planning test.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method ResolveStepsParameters | Updates the texts of the run's steps by resolving the parameter values at run time.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property ExtendedStorage | The ExtendedStorage object for the current run.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The run name.
Public Property Params | The step parameters of this run.
Public Property ResultLocation | The run result location, a UNC path.
Public Property Status | The run status.
Public Property StepFactory | The Step Factory for the current run.
Public Property TestId | The test ID of the test that has been run.
Public Property TestInstance | The number of this instance of the design test in the test set.
Public Property TestSetID | The ID of the test set to which the run belongs.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

IRun Interface

CancelRun Method

Description

Cancels the run.

Syntax

Public Sub CancelRun()

See Also

IRun Interface


%%PageItemTitle%%

IRun Interface

CopyDesignSteps Method

Description

Copies design steps into the test run of an executed test.

Syntax

Public Sub CopyDesignSteps()

Remarks

Call this method immediately after creating the Run object to fill the test run with copies of the design steps.

If design steps are not copied into the test run, the design steps are not displayed in the run.

See Also

IRun Interface


%%PageItemTitle%%

IRun Interface

CopyStepsToTest Method

Description

Copies all run execution steps, including new added steps, into the design steps of the corresponding planning test.

Syntax

Public Sub CopyStepsToTest()

See Also

IRun Interface


%%PageItemTitle%%

IRun Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IRun Interface


%%PageItemTitle%%

IRun Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IRun Interface


%%PageItemTitle%%

IRun Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IRun Interface


%%PageItemTitle%%

IRun Interface

UpdateLocalCache

If True, the client cache is updated with the changed values.

See Also OTA COM Type Library

ResolveStepsParameters Method

Description

Updates the texts of the run's steps by resolving the parameter values at run time.

Syntax

Public Sub ResolveStepsParameters( _
   Optional ByVal UpdateLocalCache As Boolean = True _
)

Parameters

UpdateLocalCache

If True, the client cache is updated with the changed values.

See Also

IRun Interface


%%PageItemTitle%%

IRun Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

IRun Interface


%%PageItemTitle%%

IRun Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

IRun Interface


%%PageItemTitle%%

IRun Interface

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

IRun Interface


%%PageItemTitle%%

IRun Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

IRun Interface


%%PageItemTitle%%

IRun Interface

ExtendedStorage Property

Description

The ExtendedStorage object for the current run.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExtendedStorage() As Object

See Also

IRun Interface


%%PageItemTitle%%

IRun Interface

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName

The name of the field in the project database.

See Also

IRun Interface


%%PageItemTitle%%

IRun Interface

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

IRun Interface


%%PageItemTitle%%

IRun Interface

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IRun Interface


%%PageItemTitle%%

IRun Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

IRun Interface


%%PageItemTitle%%

IRun Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

IRun Interface


%%PageItemTitle%%

IRun Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

IRun Interface


%%PageItemTitle%%

IRun Interface

Name Property

Description

The run name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

IRun Interface


%%PageItemTitle%%

IRun Interface

SourceMode

A value of the tagTDAPI_RUN_PARAM_MODE Enumeration.

See Also OTA COM Type Library

Params Property

Description

The step parameters of this run.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Params( _
   ByVal SourceMode As Long _
) As Object

Parameters

SourceMode

A value of the tagTDAPI_RUN_PARAM_MODE Enumeration.

See Also

IRun Interface


%%PageItemTitle%%

IRun Interface

ResultLocation Property

Description

The run result location, a UNC path.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ResultLocation() As String

See Also

IRun Interface


%%PageItemTitle%%

IRun Interface

Status Property

Description

The run status.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Status() As String

Remarks

Common values of the Status list are:

  • NO_RUN - Default. The run is never executed.
  • NOT_COMPLETED - Execution of the run has not been completed.
  • FAILED - The run failed during test execution.
  • PASSED - The run passed during test execution.
  • N/A - The execution status for the run is not available.

You can also add a user-defined status. For more information, see 'Customizing Project Lists' in the Mercury Quality Center Administrator's Guide.

One way of using your custom status is to set the status in a Workflow script. For more information, see 'Setting up the Quality Center Workflow' in the Administrator's Guide.

See Also

IRun Interface


%%PageItemTitle%%

IRun Interface

StepFactory Property

Description

The Step Factory for the current run.

Property type

Read-only property

Syntax (Visual Basic)

Public Property StepFactory() As Object

See Also

IRun Interface


%%PageItemTitle%%

IRun Interface

TestId Property

Description

The test ID of the test that has been run.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestId() As Long

See Also

IRun Interface


%%PageItemTitle%%

IRun Interface

TestInstance Property

Description

The number of this instance of the design test in the test set.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestInstance() As Long

Remarks

For example, if a Test is used four times in a test set, Run.TestInstance is a number from 1 to 4, depending on which instance ran.

See Also

IRun Interface


%%PageItemTitle%%

IRun Interface

TestSetID Property

Description

The ID of the test set to which the run belongs.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestSetID() As Long

See Also

IRun Interface


%%PageItemTitle%%

IRun Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

IRun Interface


%%PageItemTitle%%

IRun2 Members

IRun2 Interface

Description

Represents a test run.

Remarks

Get a Run object from the RunFactory.

Public Methods

Public Method CancelRun | Cancels the run.
Public Method CopyDesignSteps | Copies design steps into the test run of an executed test.
Public Method CopyStepsToTest | Copies all run execution steps, including new added steps, into the design steps of the corresponding planning test.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method ResolveStepsParameters | Updates the texts of the run's steps by resolving the parameter values at run time.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property BPStepParamFactory | The BPStepParamFactory for the current run.
Public Property ExtendedStorage | The ExtendedStorage object for the current run.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The run name.
Public Property Params | The step parameters of this run.
Public Property ResultLocation | The run result location, a UNC path.
Public Property Status | The run status.
Public Property StepFactory | The Step Factory for the current run.
Public Property TestId | The test ID of the test that has been run.
Public Property TestInstance | The number of this instance of the design test in the test set.
Public Property TestInstanceID | The ID of the test instance for the current run.
Public Property TestSetID | The ID of the test set to which the run belongs.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

IRun2 Interface

CancelRun Method

Description

Cancels the run.

Syntax

Public Sub CancelRun()

See Also

IRun2 Interface


%%PageItemTitle%%

IRun2 Interface

CopyDesignSteps Method

Description

Copies design steps into the test run of an executed test.

Syntax

Public Sub CopyDesignSteps()

Remarks

Call this method immediately after creating the Run object to fill the test run with copies of the design steps.

If design steps are not copied into the test run, the design steps are not displayed in the run.

See Also

IRun2 Interface


%%PageItemTitle%%

IRun2 Interface

CopyStepsToTest Method

Description

Copies all run execution steps, including new added steps, into the design steps of the corresponding planning test.

Syntax

Public Sub CopyStepsToTest()

See Also

IRun2 Interface


%%PageItemTitle%%

IRun2 Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IRun2 Interface


%%PageItemTitle%%

IRun2 Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IRun2 Interface


%%PageItemTitle%%

IRun2 Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IRun2 Interface


%%PageItemTitle%%

IRun2 Interface

UpdateLocalCache

If True, the client cache is updated with the changed values.

See Also OTA COM Type Library

ResolveStepsParameters Method

Description

Updates the texts of the run's steps by resolving the parameter values at run time.

Syntax

Public Sub ResolveStepsParameters( _
   Optional ByVal UpdateLocalCache As Boolean = True _
)

Parameters

UpdateLocalCache

If True, the client cache is updated with the changed values.

See Also

IRun2 Interface


%%PageItemTitle%%

IRun2 Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

IRun2 Interface


%%PageItemTitle%%

IRun2 Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

IRun2 Interface


%%PageItemTitle%%

IRun2 Interface

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

IRun2 Interface


%%PageItemTitle%%

IRun2 Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

IRun2 Interface


%%PageItemTitle%%

IRun2 Interface

BPStepParamFactory Property

Description

The BPStepParamFactory for the current run.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BPStepParamFactory() As Object

See Also

IRun2 Interface


%%PageItemTitle%%

IRun2 Interface

ExtendedStorage Property

Description

The ExtendedStorage object for the current run.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExtendedStorage() As Object

See Also

IRun2 Interface


%%PageItemTitle%%

IRun2 Interface

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName

The name of the field in the project database.

See Also

IRun2 Interface


%%PageItemTitle%%

IRun2 Interface

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

IRun2 Interface


%%PageItemTitle%%

IRun2 Interface

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IRun2 Interface


%%PageItemTitle%%

IRun2 Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

IRun2 Interface


%%PageItemTitle%%

IRun2 Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

IRun2 Interface


%%PageItemTitle%%

IRun2 Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

IRun2 Interface


%%PageItemTitle%%

IRun2 Interface

Name Property

Description

The run name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

IRun2 Interface


%%PageItemTitle%%

IRun2 Interface

SourceMode

A value of the tagTDAPI_RUN_PARAM_MODE Enumeration.

See Also OTA COM Type Library

Params Property

Description

The step parameters of this run.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Params( _
   ByVal SourceMode As Long _
) As Object

Parameters

SourceMode

A value of the tagTDAPI_RUN_PARAM_MODE Enumeration.

See Also

IRun2 Interface


%%PageItemTitle%%

IRun2 Interface

ResultLocation Property

Description

The run result location, a UNC path.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ResultLocation() As String

See Also

IRun2 Interface


%%PageItemTitle%%

IRun2 Interface

Status Property

Description

The run status.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Status() As String

Remarks

Common values of the Status list are:

  • NO_RUN - Default. The run is never executed.
  • NOT_COMPLETED - Execution of the run has not been completed.
  • FAILED - The run failed during test execution.
  • PASSED - The run passed during test execution.
  • N/A - The execution status for the run is not available.

You can also add a user-defined status. For more information, see 'Customizing Project Lists' in the Mercury Quality Center Administrator's Guide.

One way of using your custom status is to set the status in a Workflow script. For more information, see 'Setting up the Quality Center Workflow' in the Administrator's Guide.

See Also

IRun2 Interface


%%PageItemTitle%%

IRun2 Interface

StepFactory Property

Description

The Step Factory for the current run.

Property type

Read-only property

Syntax (Visual Basic)

Public Property StepFactory() As Object

See Also

IRun2 Interface


%%PageItemTitle%%

IRun2 Interface

TestId Property

Description

The test ID of the test that has been run.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestId() As Long

See Also

IRun2 Interface


%%PageItemTitle%%

IRun2 Interface

TestInstance Property

Description

The number of this instance of the design test in the test set.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestInstance() As Long

Remarks

For example, if a Test is used four times in a test set, Run.TestInstance is a number from 1 to 4, depending on which instance ran.

See Also

IRun2 Interface


%%PageItemTitle%%

IRun2 Interface

TestInstanceID Property

Description

The ID of the test instance for the current run.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestInstanceID() As Long

See Also

IRun2 Interface


%%PageItemTitle%%

IRun2 Interface

TestSetID Property

Description

The ID of the test set to which the run belongs.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestSetID() As Long

See Also

IRun2 Interface


%%PageItemTitle%%

IRun2 Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

IRun2 Interface


%%PageItemTitle%%

IRunFactory Members

IRunFactory Interface

Description

Services for managing test runs.

Remarks

The RunFactory for the connection is TDConnection.RunFactory.

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Public Methods

Public Method AddItem | Creates a new item object.
Public Method DeleteDuplicateRuns | Removes duplicate runs for the current test set. Removal is immediate without Post.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.
Public Property UniqueRunName | Gets the run name. The name is unique in the current test and test set.


%%PageItemTitle%%

IRunFactory Interface

ItemData
See discussion below.

There are three options for ItemData:

  • Null. Creating a virtual Run object with Null ensures that you cannot then Post until the run name and all other required fields are initialized.
  • The name of the run (string).
  • An array consisting of the following elements:

    (0) Name - The name of the run (string. required).

    (1) Tester - The name of the user responsible (string. optional).

    (2) Location - The host name (string. optional). The default is the host name of the current machine.

See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData
See discussion below.

There are three options for ItemData:

  • Null. Creating a virtual Run object with Null ensures that you cannot then Post until the run name and all other required fields are initialized.
  • The name of the run (string).
  • An array consisting of the following elements:

    (0) Name - The name of the run (string. required).

    (1) Tester - The name of the user responsible (string. optional).

    (2) Location - The host name (string. optional). The default is the host name of the current machine.

Return Type

A Run Object.

Remarks

Following a call to AddItem with an array of parameters, the Run table field RN_PATH contains the value from in the array location (2), Location, if it was passed. If array location (2) was an empty string (""), then field RN_PATH contains "a_b" where "a" is the RN_CYCLE_ID and "b" is the RN_RUN_ID. Field RN_HOST is always empty following a call AddItem.

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

[Visual Basic]

Dim bgf As BugFactory
Dim bg As Bug
Dim attf As AttachmentFactory
Dim att As Attachment
Dim attList As List

' Get the factory object
 Set bgf = tdc.BugFactory
' Use defect #1
 Set bg = bgf.Item(1)
 Set attf = bg.Attachments

' Creating a new attachment
' Create virtual object, then populate the properties
 Set att = attf.AddItem(Null)
 att.FileName = Text1.Text
 att.Type = TDATT_INTERNET

' Saving the object with validity check
 att.Post

' Display the attachments
' Add the display-only items without a Post
 List1.Clear
 Set attList = attf.NewList("")
 For i = 1 To attList.Count

      Set att = attList.Item(i)
      List1.AddItem (att.Name)

 Next

See Also

IRunFactory Interface


%%PageItemTitle%%

IRunFactory Interface

RunName

The name of the run.

See Also OTA COM Type Library

DeleteDuplicateRuns Method

Description

Removes duplicate runs for the current test set. Removal is immediate without Post.

Syntax

Public Sub DeleteDuplicateRuns( _
   ByVal RunName As String _
)

Parameters

RunName

The name of the run.

See Also

IRunFactory Interface


%%PageItemTitle%%

IRunFactory Interface

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

IRunFactory Interface


%%PageItemTitle%%

IRunFactory Interface

ItemKey

The Run.ID (long), a reference to the Run Object, or a Variant array of Run.IDs.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey

The Run.ID (long), a reference to the Run Object, or a Variant array of Run.IDs.

See Also

IRunFactory Interface


%%PageItemTitle%%

IRunFactory Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

IRunFactory Interface


%%PageItemTitle%%

IRunFactory Interface

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

IRunFactory Interface


%%PageItemTitle%%

IRunFactory Interface

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

IRunFactory Interface


%%PageItemTitle%%

IRunFactory Interface

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IRunFactory Interface


%%PageItemTitle%%

IRunFactory Interface

ItemKey

The run ID (long).

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey

The run ID (long).

See Also

IRunFactory Interface


%%PageItemTitle%%

IRunFactory Interface

UniqueRunName Property

Description

Gets the run name. The name is unique in the current test and test set.

Property type

Read-only property

Syntax (Visual Basic)

Public Property UniqueRunName() As String

See Also

IRunFactory Interface


%%PageItemTitle%%

ISearchableFactory Interface

CreateSearchOptions Method

Description

Creates a new SearchOptions object.

Syntax

Public Function CreateSearchOptions() As Object

Return Type

A SearchOptions Object.

See Also

ISearchableFactory Interface


%%PageItemTitle%%

ISearchableFactory Interface

IsSearchable Method

Description

Checks if the Search method can be called by this factory.

Syntax

Public Function IsSearchable() As Boolean

See Also

ISearchableFactory Interface


%%PageItemTitle%%

ISearchableFactory Interface

Query
The text for which to search in the objects managed by the factory.
pSearchOptions
A SearchOptions Object.
See Also OTA COM Type Library

Search Method

Description

Gets a list of objects matching the search query.

Syntax

Public Function Search( _
   ByVal Query As String, _
   ByVal pSearchOptions As Object _
) As List

Parameters

Query
The text for which to search in the objects managed by the factory.
pSearchOptions
A SearchOptions Object.

Return Type

A list of references to the matching objects.

See Also

ISearchableFactory Interface


%%PageItemTitle%%

ISearchOptions Members

ISearchOptions Interface

Description

Options for controlling searches.

Remarks

The SearchOptions reference is returned from the CreateSearchOptions Method of the ISearchableFactory implemented interface of a factory object.

Public Properties

Public Property Filter | Get filter
Public Property Property | The search configuration flag.


%%PageItemTitle%%

ISearchOptions Interface

Filter Property

Description

Get filter

Property type

Read-write property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

ISearchOptions Interface


%%PageItemTitle%%

ISearchOptions Interface

Prop

A value of the tagSEARCH_OPTIONS Enumeration.

See Also OTA COM Type Library

Property Property

Description

The search configuration flag.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Property( _
   ByVal Prop As Long _
) As Variant

Parameters

Prop

A value of the tagSEARCH_OPTIONS Enumeration.

See Also

ISearchOptions Interface


%%PageItemTitle%%

ISequentialStream Members

ISequentialStream Interface

Description

The ISequentialStream interface supports simplified sequential access to stream objects. For more details, see Microsoft documentation.

Interfaces

IUnknown

Public Methods

Public Method RemoteRead | See Microsoft documentation.
Public Method RemoteWrite | See Microsoft documentation.


%%PageItemTitle%%

ISequentialStream Interface

pv
cb
pcbRead
See Also OTA COM Type Library

RemoteRead Method

Description

See Microsoft documentation.

Syntax

Public Sub RemoteRead( _
   ByRef pv As Byte, _
   ByVal cb As ULong, _
   ByRef pcbRead As ULong _
)

Parameters

pv
cb
pcbRead

See Also

ISequentialStream Interface


%%PageItemTitle%%

ISequentialStream Interface

pv
cb
pcbWritten
See Also OTA COM Type Library

RemoteWrite Method

Description

See Microsoft documentation.

Syntax

Public Sub RemoteWrite( _
   ByRef pv As Byte, _
   ByVal cb As ULong, _
   ByRef pcbWritten As ULong _
)

Parameters

pv
cb
pcbWritten

See Also

ISequentialStream Interface


%%PageItemTitle%%

ISettings Members

ISettings Interface

Description

Represents users' settings in various user-defined categories.

Remarks

Settings are used by Quality Center to store various kinds of information, including user settings. They can also be used to store any application-specific data you wish.

Settings are organized by categories, analogous to settings folders. Each category can have any number of items. Each item has a value.

Begin use of the Settings object by using Open to restrict the scope to the desired category.

If the settings object is created using the UserSettings property of the TDConnection Object, the settings are only available to the user who saves them. If the object is created with the CommonSettings property, the settings are available to all users.

Example

Custom user setting

Public Methods

Public Method Close | Closes and updates the category.
Public Method DeleteCategory | Deletes the current settings folder.
Public Method DeleteValue | Deletes the specified item.
Public Method Open | Sets the category to be used in subsequent actions by the client.
Public Method Post | Posts the category to the server.
Public Method Refresh | Reads saved values, overwriting values in memory.

Public Properties

Public Property EnumItems | Returns the list of names of the setting's items.
Public Property Value | The value of the specified item in the active category.


%%PageItemTitle%%

ISettings Interface

Close Method

Description

Closes and updates the category.

Syntax

Public Sub Close()

See Also

ISettings Interface


%%PageItemTitle%%

ISettings Interface

Category

The name of the category to delete.

See Also OTA COM Type Library

DeleteCategory Method

Description

Deletes the current settings folder.

Syntax

Public Sub DeleteCategory( _
   ByVal Category As String _
)

Parameters

Category

The name of the category to delete.

See Also

ISettings Interface


%%PageItemTitle%%

ISettings Interface

Name

The name of the entry to delete.

See Also OTA COM Type Library

DeleteValue Method

Description

Deletes the specified item.

Syntax

Public Sub DeleteValue( _
   ByVal Name As String _
)

Parameters

Name

The name of the entry to delete.

See Also

ISettings Interface


%%PageItemTitle%%

ISettings Interface

Category

The name of the category to open. The category name can not contain any of the characters: /\*?=<>|:".

See Also OTA COM Type Library

Open Method

Description

Sets the category to be used in subsequent actions by the client.

Syntax

Public Sub Open( _
   ByVal Category As String _
)

Parameters

Category

The name of the category to open. The category name can not contain any of the characters: /\*?=<>|:".

Remarks

This method sets the context locally for subseqent use of the Settings object. The method call does not result in any communications with the server.

The category can be built-in or a user-created category.

Warning: If open is not called, subsequent Settings object method calls will act on the root settings folder and all sub-folders (categories).

See Also

ISettings Interface


%%PageItemTitle%%

ISettings Interface

Post Method

Description

Posts the category to the server.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ISettings Interface


%%PageItemTitle%%

ISettings Interface

Category

The name of the category to refresh.

See Also OTA COM Type Library

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh( _
   ByVal Category As String _
)

Parameters

Category

The name of the category to refresh.

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ISettings Interface


%%PageItemTitle%%

ISettings Interface

EnumItems Property

Description

Returns the list of names of the setting's items.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EnumItems() As List

See Also

ISettings Interface


%%PageItemTitle%%

ISettings Interface

Name

The name of the item whose value to set or return.

See Also OTA COM Type Library

Value Property

Description

The value of the specified item in the active category.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Value( _
   ByVal Name As String _
) As String

Parameters

Name

The name of the item whose value to set or return.

Remarks

If the item has already been fetched, the value is returned from the local cache.

If ("*") is passed as the Name argument, all values are fetched into the local cache and an empty string is returned.

See Also

ISettings Interface


%%PageItemTitle%%

ISettings2 Members

ISettings2 Interface

Description

Represents users' settings in various user-defined categories.

Remarks

Settings are used by Quality Center to store various kinds of information, including user settings. They can also be used to store any application-specific data you wish.

Settings are organized by categories, analogous to settings folders. Each category can have any number of items. Each item has a value.

Begin use of the Settings object by using Open to restrict the scope to the desired category.

If the settings object is created using the UserSettings property of the TDConnection Object, the settings are only available to the user who saves them. If the object is created with the CommonSettings property, the settings are available to all users.

Public Methods

Public Method Close | Closes and updates the category.
Public Method DeleteCategory | Deletes the current settings folder.
Public Method DeleteValue | Deletes the specified item.
Public Method Open | Sets the category to be used in subsequent actions by the client.
Public Method Post | Posts the category to the server.
Public Method Refresh | Reads saved values, overwriting values in memory.

Public Properties

Public Property EnumItems | Returns the list of names of the setting's items.
Public Property IsSystem | Checks if the specified setting is built-in and read-only.
Public Property Value | The value of the specified item in the active category.


%%PageItemTitle%%

ISettings2 Interface

Close Method

Description

Closes and updates the category.

Syntax

Public Sub Close()

See Also

ISettings2 Interface


%%PageItemTitle%%

ISettings2 Interface

Category

The name of the category to delete.

See Also OTA COM Type Library

DeleteCategory Method

Description

Deletes the current settings folder.

Syntax

Public Sub DeleteCategory( _
   ByVal Category As String _
)

Parameters

Category

The name of the category to delete.

See Also

ISettings2 Interface


%%PageItemTitle%%

ISettings2 Interface

Name

The name of the entry to delete.

See Also OTA COM Type Library

DeleteValue Method

Description

Deletes the specified item.

Syntax

Public Sub DeleteValue( _
   ByVal Name As String _
)

Parameters

Name

The name of the entry to delete.

See Also

ISettings2 Interface


%%PageItemTitle%%

ISettings2 Interface

Category

The name of the category to open. The category name can not contain any of the characters: /\*?=<>|:".

See Also OTA COM Type Library

Open Method

Description

Sets the category to be used in subsequent actions by the client.

Syntax

Public Sub Open( _
   ByVal Category As String _
)

Parameters

Category

The name of the category to open. The category name can not contain any of the characters: /\*?=<>|:".

Remarks

This method sets the context locally for subseqent use of the Settings object. The method call does not result in any communications with the server.

The category can be built-in or a user-created category.

Warning: If open is not called, subsequent Settings object method calls will act on the root settings folder and all sub-folders (categories).

See Also

ISettings2 Interface


%%PageItemTitle%%

ISettings2 Interface

Post Method

Description

Posts the category to the server.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ISettings2 Interface


%%PageItemTitle%%

ISettings2 Interface

Category

The name of the category to refresh.

See Also OTA COM Type Library

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh( _
   ByVal Category As String _
)

Parameters

Category

The name of the category to refresh.

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ISettings2 Interface


%%PageItemTitle%%

ISettings2 Interface

EnumItems Property

Description

Returns the list of names of the setting's items.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EnumItems() As List

See Also

ISettings2 Interface


%%PageItemTitle%%

ISettings2 Interface

Name

The name of the setting item.

See Also OTA COM Type Library

IsSystem Property

Description

Checks if the specified setting is built-in and read-only.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsSystem( _
   ByVal Name As String _
) As Boolean

Parameters

Name

The name of the setting item.

Remarks

System settings cannot be changed by the user.

Settings created by the user are not system settings.

See Also

ISettings2 Interface


%%PageItemTitle%%

ISettings2 Interface

Name

The name of the item whose value to set or return.

See Also OTA COM Type Library

Value Property

Description

The value of the specified item in the active category.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Value( _
   ByVal Name As String _
) As String

Parameters

Name

The name of the item whose value to set or return.

Remarks

If the item has already been fetched, the value is returned from the local cache.

If ("*") is passed as the Name argument, all values are fetched into the local cache and an empty string is returned.

See Also

ISettings2 Interface


%%PageItemTitle%%

IStep Members

IStep Interface

Description

Represents a test step in a test run.

Example

Get a Step object from the StepFactory.

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property DesignStepSource | The test ID of the test from which this step run originates.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The run step name.
Public Property Status | The run step status.
Public Property TestSource | The test ID of the test from which this step run originates.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

IStep Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IStep Interface


%%PageItemTitle%%

IStep Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IStep Interface


%%PageItemTitle%%

IStep Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IStep Interface


%%PageItemTitle%%

IStep Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

IStep Interface


%%PageItemTitle%%

IStep Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

IStep Interface


%%PageItemTitle%%

IStep Interface

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

IStep Interface


%%PageItemTitle%%

IStep Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

IStep Interface


%%PageItemTitle%%

IStep Interface

DesignStepSource Property

Description

The test ID of the test from which this step run originates.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DesignStepSource() As Long

See Also

IStep Interface


%%PageItemTitle%%

IStep Interface

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName

The name of the field in the project database.

See Also

IStep Interface


%%PageItemTitle%%

IStep Interface

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

IStep Interface


%%PageItemTitle%%

IStep Interface

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IStep Interface


%%PageItemTitle%%

IStep Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

IStep Interface


%%PageItemTitle%%

IStep Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

IStep Interface


%%PageItemTitle%%

IStep Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

IStep Interface


%%PageItemTitle%%

IStep Interface

Name Property

Description

The run step name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

IStep Interface


%%PageItemTitle%%

IStep Interface

Status Property

Description

The run step status.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Status() As String

Remarks

You can create user-defined statuses by customizing the Status list. For more information, see 'Customizing Project Lists' in the Mercury Quality Center Administrator's Guide.

One way of using your custom status is to set the status in a workflow script. For more information, see 'Setting up the Quality Center Workflow' in the Mercury Quality Center Administrator's Guide.

See Also

IStep Interface


%%PageItemTitle%%

IStep Interface

TestSource Property

Description

The test ID of the test from which this step run originates.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestSource() As Long

See Also

IStep Interface


%%PageItemTitle%%

IStep Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

IStep Interface


%%PageItemTitle%%

IStep2 Members

IStep2 Interface

Description

Represents a test step in a test run.

Example

Get a Step object from the StepFactory.

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property BPStepParamFactory | The BPStepParamFactory for the current step.
Public Property DesignStepSource | The test ID of the test from which this step run originates.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The run step name.
Public Property Run | Gets the Run object handling this step.
Public Property Status | The run step status.
Public Property TestSource | The test ID of the test from which this step run originates.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

IStep2 Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IStep2 Interface


%%PageItemTitle%%

IStep2 Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IStep2 Interface


%%PageItemTitle%%

IStep2 Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IStep2 Interface


%%PageItemTitle%%

IStep2 Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

IStep2 Interface


%%PageItemTitle%%

IStep2 Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

IStep2 Interface


%%PageItemTitle%%

IStep2 Interface

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

IStep2 Interface


%%PageItemTitle%%

IStep2 Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

IStep2 Interface


%%PageItemTitle%%

IStep2 Interface

BPStepParamFactory Property

Description

The BPStepParamFactory for the current step.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BPStepParamFactory() As Object

See Also

IStep2 Interface


%%PageItemTitle%%

IStep2 Interface

DesignStepSource Property

Description

The test ID of the test from which this step run originates.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DesignStepSource() As Long

See Also

IStep2 Interface


%%PageItemTitle%%

IStep2 Interface

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName

The name of the field in the project database.

See Also

IStep2 Interface


%%PageItemTitle%%

IStep2 Interface

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

IStep2 Interface


%%PageItemTitle%%

IStep2 Interface

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

IStep2 Interface


%%PageItemTitle%%

IStep2 Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

IStep2 Interface


%%PageItemTitle%%

IStep2 Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

IStep2 Interface


%%PageItemTitle%%

IStep2 Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

IStep2 Interface


%%PageItemTitle%%

IStep2 Interface

Name Property

Description

The run step name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

IStep2 Interface


%%PageItemTitle%%

IStep2 Interface

Run Property

Description

Gets the Run object handling this step.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Run() As Object

See Also

IStep2 Interface


%%PageItemTitle%%

IStep2 Interface

Status Property

Description

The run step status.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Status() As String

Remarks

You can create user-defined statuses by customizing the Status list. For more information, see 'Customizing Project Lists' in the Mercury Quality Center Administrator's Guide.

One way of using your custom status is to set the status in a workflow script. For more information, see 'Setting up the Quality Center Workflow' in the Mercury Quality Center Administrator's Guide.

See Also

IStep2 Interface


%%PageItemTitle%%

IStep2 Interface

TestSource Property

Description

The test ID of the test from which this step run originates.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestSource() As Long

See Also

IStep2 Interface


%%PageItemTitle%%

IStep2 Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

IStep2 Interface


%%PageItemTitle%%

IStepParams Members | DesignStep Object | Test Object | TSTest Object | Run Object

See Also OTA COM Type Library

IStepParams Interface

Description

A collection of test parameters.

Remarks

A test parameter is a variable whose value is set at test run time. A step parameter object handles these variables.

Get a StepParams object from DesignStep.LinkedParams, Test.Params, TSTest.Params, or Run.Params.

Public Methods

Public Method AddParam | Adds a new parameter to the object.
Public Method ClearParam | Clears the parameter value by setting it to null.
Public Method DeleteParam | Deletes the specified parameter.
Public Method Refresh | Refreshes the data from the database, discarding changes.
Public Method Save | Uploads the parameter definitions to the database.

Public Properties

Public Property Count | The number of parameters for the object.
Public Property ParamExist | Checks if a parameter of this name exists.
Public Property ParamName | The name of the parameter in the specified position in the StepParams collection (zero-based).
Public Property ParamValue | The value of the specified parameter.
Public Property Type | Gets the parameter type: predefined, null, or regular.


%%PageItemTitle%%

IStepParams Interface

ParamName

The name of the new parameter.

ParamType

Always pass the string "Text".

See Also OTA COM Type Library

AddParam Method

Description

Adds a new parameter to the object.

Syntax

Public Sub AddParam( _
   ByVal ParamName As String, _
   ByVal ParamType As String _
)

Parameters

ParamName

The name of the new parameter.

ParamType

Always pass the string "Text".

See Also

IStepParams Interface


%%PageItemTitle%%

IStepParams Interface

vParam

Either the index (zero-based) in the StepParams collection, or the name of the parameter.

See Also OTA COM Type Library

ClearParam Method

Description

Clears the parameter value by setting it to null.

Syntax

Public Sub ClearParam( _
   ByVal vParam As Variant _
)

Parameters

vParam

Either the index (zero-based) in the StepParams collection, or the name of the parameter.

See Also

IStepParams Interface


%%PageItemTitle%%

IStepParams Interface

ParamName

The name of the parameter to delete.

See Also OTA COM Type Library

DeleteParam Method

Description

Deletes the specified parameter.

Syntax

Public Sub DeleteParam( _
   ByVal ParamName As String _
)

Parameters

ParamName

The name of the parameter to delete.

See Also

IStepParams Interface


%%PageItemTitle%%

IStepParams Interface

Refresh Method

Description

Refreshes the data from the database, discarding changes.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IStepParams Interface


%%PageItemTitle%%

IStepParams Interface

Save Method

Description

Uploads the parameter definitions to the database.

Syntax

Public Sub Save()

See Also

IStepParams Interface


%%PageItemTitle%%

IStepParams Interface

Count Property

Description

The number of parameters for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

IStepParams Interface


%%PageItemTitle%%

IStepParams Interface

ParamName

The name of the parameter.

See Also OTA COM Type Library

ParamExist Property

Description

Checks if a parameter of this name exists.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ParamExist( _
   ByVal ParamName As String _
) As Boolean

Parameters

ParamName

The name of the parameter.

See Also

IStepParams Interface


%%PageItemTitle%%

IStepParams Interface

nPosition

The position (zero-based) of this parameter in the StepParams collection.

See Also OTA COM Type Library

ParamName Property

Description

The name of the parameter in the specified position in the StepParams collection (zero-based).

Property type

Read-only property

Syntax (Visual Basic)

Public Property ParamName( _
   ByVal nPosition As Long _
) As String

Parameters

nPosition

The position (zero-based) of this parameter in the StepParams collection.

See Also

IStepParams Interface


%%PageItemTitle%%

IStepParams Interface

vParam

Either the index (zero-based) in the StepParams collection, or the name of the parameter.

See Also OTA COM Type Library

ParamValue Property

Description

The value of the specified parameter.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ParamValue( _
   ByVal vParam As Variant _
) As String

Parameters

vParam

Either the index (zero-based) in the StepParams collection, or the name of the parameter.

See Also

IStepParams Interface


%%PageItemTitle%%

IStepParams Interface

vParam

Either the index (zero-based) in the StepParams collection, or the name of the parameter.

See Also OTA COM Type Library

Type Property

Description

Gets the parameter type: predefined, null, or regular.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Type( _
   ByVal vParam As Variant _
) As Long

Parameters

vParam

Either the index (zero-based) in the StepParams collection, or the name of the parameter.

See Also

IStepParams Interface


%%PageItemTitle%%

IStream Members

IStream Interface

Description

Refer to Microsoft documentation.

Interfaces

ISequentialStream

Public Methods

Public Method Clone
Public Method Commit
Public Method LockRegion
Public Method RemoteCopyTo
Public Method RemoteSeek
Public Method Revert
Public Method SetSize
Public Method Stat
Public Method UnlockRegion


%%PageItemTitle%%

IStream Interface

ppstm
See Also OTA COM Type Library

Clone Method

Syntax

Public Sub Clone( _
   ByVal ppstm As IStream _
)

Parameters

ppstm

See Also

IStream Interface


%%PageItemTitle%%

IStream Interface

grfCommitFlags
See Also OTA COM Type Library

Commit Method

Syntax

Public Sub Commit( _
   ByVal grfCommitFlags As ULong _
)

Parameters

grfCommitFlags

See Also

IStream Interface


%%PageItemTitle%%

IStream Interface

libOffset
cb
dwLockType
See Also OTA COM Type Library

LockRegion Method

Syntax

Public Sub LockRegion( _
   ByRef libOffset As ULARGE_INTEGER, _
   ByRef cb As ULARGE_INTEGER, _
   ByVal dwLockType As ULong _
)

Parameters

libOffset
cb
dwLockType

See Also

IStream Interface


%%PageItemTitle%%

IStream Interface

pstm
cb
pcbRead
pcbWritten
See Also OTA COM Type Library

RemoteCopyTo Method

Syntax

Public Sub RemoteCopyTo( _
   ByVal pstm As IStream, _
   ByRef cb As ULARGE_INTEGER, _
   ByRef pcbRead As ULARGE_INTEGER, _
   ByRef pcbWritten As ULARGE_INTEGER _
)

Parameters

pstm
cb
pcbRead
pcbWritten

See Also

IStream Interface


%%PageItemTitle%%

IStream Interface

dlibMove
dwOrigin
plibNewPosition
See Also OTA COM Type Library

RemoteSeek Method

Syntax

Public Sub RemoteSeek( _
   ByRef dlibMove As LARGE_INTEGER, _
   ByVal dwOrigin As ULong, _
   ByRef plibNewPosition As ULARGE_INTEGER _
)

Parameters

dlibMove
dwOrigin
plibNewPosition

See Also

IStream Interface


%%PageItemTitle%%

IStream Interface

Revert Method

Syntax

Public Sub Revert()

See Also

IStream Interface


%%PageItemTitle%%

IStream Interface

libNewSize
See Also OTA COM Type Library

SetSize Method

Syntax

Public Sub SetSize( _
   ByRef libNewSize As ULARGE_INTEGER _
)

Parameters

libNewSize

See Also

IStream Interface


%%PageItemTitle%%

IStream Interface

pstatstg
grfStatFlag
See Also OTA COM Type Library

Stat Method

Syntax

Public Sub Stat( _
   ByRef pstatstg As tagSTATSTG, _
   ByVal grfStatFlag As ULong _
)

Parameters

pstatstg
grfStatFlag

See Also

IStream Interface


%%PageItemTitle%%

IStream Interface

libOffset
cb
dwLockType
See Also OTA COM Type Library

UnlockRegion Method

Syntax

Public Sub UnlockRegion( _
   ByRef libOffset As ULARGE_INTEGER, _
   ByRef cb As ULARGE_INTEGER, _
   ByVal dwLockType As ULong _
)

Parameters

libOffset
cb
dwLockType

See Also

IStream Interface


%%PageItemTitle%%

IStringRepresentation Members

IStringRepresentation Interface

Description

The string representation of the object.

Public Methods

Public Method ToString The string representation of the object.


%%PageItemTitle%%

IStringRepresentation Interface

ToString Method

Description

The string representation of the object.

Syntax

Public Function ToString() As String

See Also

IStringRepresentation Interface


%%PageItemTitle%%

ISubjectNode Members

ISubjectNode Interface

Description

Represents a subject folder in a Quality Center subject tree.

Remarks

The root subject node is TreeManager.RootList(TDOLE_SUBJECT).Item(1) or TreeManager.TreeRoot("Subject"). Get other subject node objects by walking the tree. See the example, "Getting subject nodes"

Public Methods

Public Method AddNode | Adds a new child node.
Public Method FindChildNode | Finds a child node by node name.
Public Method FindChildren | Finds node children according to specified search pattern.
Public Method FindTests | Finds tests within the current subject folder whose name matches the specified text pattern.
Public Method Move | Moves the current tree mode to be under the specified parent.
Public Method NewList | Gets a list of the node's immediate children.
Public Method Post | Posts all changed values to the database.
Public Method Refresh | Reads the saved node data, overwriting values in memory.
Public Method RemoveSubjectNode | Removes the specified node from the subject tree.

Public Properties

Public Property Attachments | The AttachmentFactory for the subject folder.
Public Property Attribute | Gets the node attribute.
Public Property Child | Gets a sub-folder of the current folder.
Public Property Count | The number of child nodes.
Public Property DepthType | The sub-tree depth type.
Public Property Description | A description of the subject node.
Public Property Father | The current folder's parent folder.
Public Property HasAttachment | Checks if the SubjectNode has at least one attachment.
Public Property Name | The node name.
Public Property NodeID | The node ID number.
Public Property Path | The folder tree path starting from the tree root.
Public Property TestFactory | The TestFactory object for the subject folder.
Public Property ViewOrder | The position of the node in the tree as presented in the user interface.


%%PageItemTitle%%

ISubjectNode Interface

NodeName

The new folder name.

See Also OTA COM Type Library

AddNode Method

Description

Adds a new child node.

Syntax

Public Function AddNode( _
   ByVal NodeName As String _
) As SysTreeNode

Parameters

NodeName

The new folder name.

Return Type

A SysTreeNode Object.

See Also

ISubjectNode Interface


%%PageItemTitle%%

ISubjectNode Interface

ChildName

The folder name to find.

See Also OTA COM Type Library

FindChildNode Method

Description

Finds a child node by node name.

Syntax

Public Function FindChildNode( _
   ByVal ChildName As String _
) As SysTreeNode

Parameters

ChildName

The folder name to find.

Return Type

A SysTreeNode Object.

See Also

ISubjectNode Interface


%%PageItemTitle%%

ISubjectNode Interface

Pattern

The search string or pattern.

MatchCase

If True, the search is case-sensitive.

Filter

A logical filter. The filter can be retrieved from TDFilter.Text.

See Also OTA COM Type Library

FindChildren Method

Description

Finds node children according to specified search pattern.

Syntax

Public Function FindChildren( _
   ByVal Pattern As String, _
   Optional ByVal MatchCase As Boolean = False, _
   Optional ByVal Filter As String = "" _
) As List

Parameters

Pattern

The search string or pattern.

MatchCase

If True, the search is case-sensitive.

Filter

A logical filter. The filter can be retrieved from TDFilter.Text.

Return Type

A list of SysTreeNode objects that match the pattern and filter.

See Also

ISubjectNode Interface


%%PageItemTitle%%

ISubjectNode Interface

Pattern

Specifies the search text pattern.

MatchCase

If True, the search is case sensitive.

Filter

A logical filter to narrow the search. The filter can be retrieved from TDFilter.Text.

See Also OTA COM Type Library

FindTests Method

Description

Finds tests within the current subject folder whose name matches the specified text pattern.

Syntax

Public Function FindTests( _
   ByVal Pattern As String, _
   Optional ByVal MatchCase As Boolean = False, _
   Optional ByVal Filter As String = "" _
) As List

Parameters

Pattern

Specifies the search text pattern.

MatchCase

If True, the search is case sensitive.

Filter

A logical filter to narrow the search. The filter can be retrieved from TDFilter.Text.

Return Type

A list of Test Objects.

See Also

ISubjectNode Interface


%%PageItemTitle%%

ISubjectNode Interface

Parent

Either a SysTreeNode or Subject node. The argument can be a SysTreeNode Object, a SysTreeNode.NodeID, a SubjectNode Object, or a SubjectNode.NodeID .

See Also OTA COM Type Library

Move Method

Description

Moves the current tree mode to be under the specified parent.

Syntax

Public Sub Move( _
   ByVal Parent As Variant _
)

Parameters

Parent

Either a SysTreeNode or Subject node. The argument can be a SysTreeNode Object, a SysTreeNode.NodeID, a SubjectNode Object, or a SubjectNode.NodeID .

See Also

ISubjectNode Interface


%%PageItemTitle%%

ISubjectNode Interface

NewList Method

Description

Gets a list of the node's immediate children.

Syntax

Public Function NewList() As List

Return Type

A list of SysTreeNode objects in the first level below the current node.

Remarks

The list index is 1-based.

See Also

ISubjectNode Interface


%%PageItemTitle%%

ISubjectNode Interface

Post Method

Description

Posts all changed values to the database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ISubjectNode Interface


%%PageItemTitle%%

ISubjectNode Interface

Refresh Method

Description

Reads the saved node data, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ISubjectNode Interface


%%PageItemTitle%%

ISubjectNode Interface

Node

Either the SubjectNode Object, the node index in the child list returned by FindChildren, or the node name. The node name search is not recursive.

DeleteTests

If True, delete the tests under the node.

See Also OTA COM Type Library

RemoveSubjectNode Method

Description

Removes the specified node from the subject tree.

Syntax

Public Sub RemoveSubjectNode( _
   ByVal Node As Variant, _
   Optional ByVal DeleteTests As Boolean = False _
)

Parameters

Node

Either the SubjectNode Object, the node index in the child list returned by FindChildren, or the node name. The node name search is not recursive.

DeleteTests

If True, delete the tests under the node.

See Also

ISubjectNode Interface


%%PageItemTitle%%

ISubjectNode Interface

Attachments Property

Description

The AttachmentFactory for the subject folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

ISubjectNode Interface


%%PageItemTitle%%

ISubjectNode Interface

Attribute Property

Description

Gets the node attribute.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attribute() As Long

See Also

ISubjectNode Interface


%%PageItemTitle%%

ISubjectNode Interface

Index

The position in the list of child nodes is 1-based.

The index (1-based) represents the child level of the folder.

See Also OTA COM Type Library

Child Property

Description

Gets a sub-folder of the current folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Child( _
   ByVal Index As Long _
) As SysTreeNode

Parameters

Index

The position in the list of child nodes is 1-based.

The index (1-based) represents the child level of the folder.

See Also

ISubjectNode Interface


%%PageItemTitle%%

ISubjectNode Interface

Count Property

Description

The number of child nodes.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

ISubjectNode Interface


%%PageItemTitle%%

ISubjectNode Interface

DepthType Property

Description

The sub-tree depth type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DepthType() As Integer

See Also

ISubjectNode Interface


%%PageItemTitle%%

ISubjectNode Interface

Description Property

Description

A description of the subject node.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Description() As String

See Also

ISubjectNode Interface


%%PageItemTitle%%

ISubjectNode Interface

Father Property

Description

The current folder's parent folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Father() As SysTreeNode

See Also

ISubjectNode Interface


%%PageItemTitle%%

ISubjectNode Interface

HasAttachment Property

Description

Checks if the SubjectNode has at least one attachment.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

ISubjectNode Interface


%%PageItemTitle%%

ISubjectNode Interface

Name Property

Description

The node name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ISubjectNode Interface


%%PageItemTitle%%

ISubjectNode Interface

NodeID Property

Description

The node ID number.

Property type

Read-only property

Syntax (Visual Basic)

Public Property NodeID() As Long

See Also

ISubjectNode Interface


%%PageItemTitle%%

ISubjectNode Interface

Path Property

Description

The folder tree path starting from the tree root.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Path() As String

See Also

ISubjectNode Interface


%%PageItemTitle%%

ISubjectNode Interface

TestFactory Property

Description

The TestFactory object for the subject folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestFactory() As Object

See Also

ISubjectNode Interface


%%PageItemTitle%%

ISubjectNode Interface

ViewOrder Property

Description

The position of the node in the tree as presented in the user interface.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ViewOrder() As Long

See Also

ISubjectNode Interface


%%PageItemTitle%%

ISupportCopyPaste Members

ISupportCopyPaste Interface

Description

Services for supporting copy and paste.

Remarks

When pasting a item to a context where the object's name already exists, the new object is renamed and the paste succeeds. An exception is thrown with error code tagTDAPI_ERRORCODES.TDOLE_REQ_EXISTS. This occurs, for example, when copying a Req and pasting it under the same parent requirement.

For the list of classes that support copy and paste, look in the index under "ISupportCopyPaste(n)", where n is the number of the most recent version.

Example

Copy a requirement | Copy-paste: Copy a defect | Copy test | Copy test plan folder | Copy test set | Copy test set folder

Public Methods

Public Method CopyToClipBoard | Copies data into clipboard.
Public Method PasteFromClipBoard | Pastes data from clipboard.


%%PageItemTitle%%

ISupportCopyPaste Interface

IDSFilter
Either comma separated list of ID numbers or a TDFilter.Text that qualifies the items to be copied.
mode
Unused
Path
Use when copying a folder. The path of the folder.
See Also OTA COM Type Library

CopyToClipBoard Method

Description

Copies data into clipboard.

Syntax

Public Function CopyToClipBoard( _
   ByVal IDSFilter As String, _
   Optional ByVal mode As Long = 0, _
   Optional ByVal Path As String = "" _
) As String

Parameters

IDSFilter
Either comma separated list of ID numbers or a TDFilter.Text that qualifies the items to be copied.
mode
Unused
Path
Use when copying a folder. The path of the folder.

Return Type

The data copied to the clipboard.

See Also

ISupportCopyPaste Interface


%%PageItemTitle%%

ISupportCopyPaste Interface

ClipboardData
The data returned from CopyToClipboard.
TargetID
The ID of the folder into which the data is to be pasted.
mode
A value of the tagTDAPI_COPY_PASTE_MODES Enumeration.
OrderID
The position into which the item is to be pasted. Pass 1 to create the first child item, 2 for the second child, and so on.
See Also OTA COM Type Library

PasteFromClipBoard Method

Description

Pastes data from clipboard.

Syntax

Public Sub PasteFromClipBoard( _
   ByVal ClipboardData As String, _
   Optional ByVal TargetID As String = "", _
   Optional ByVal mode As Long = 0, _
   Optional ByVal OrderID As Long = -1 _
)

Parameters

ClipboardData
The data returned from CopyToClipboard.
TargetID
The ID of the folder into which the data is to be pasted.
mode
A value of the tagTDAPI_COPY_PASTE_MODES Enumeration.
OrderID
The position into which the item is to be pasted. Pass 1 to create the first child item, 2 for the second child, and so on.

See Also

ISupportCopyPaste Interface


%%PageItemTitle%%

ISupportCopyPaste2 Interface

ClipboardData
The data returned from CopyToClipboard.
See Also OTA COM Type Library

PasteToCurrentProject Property

Description

Checks if the paste target is in the same project from which the material was copied.

Property type

Read-only property

Syntax (Visual Basic)

Public Property PasteToCurrentProject( _
   ByVal ClipboardData As String _
) As Boolean

Parameters

ClipboardData
The data returned from CopyToClipboard.

Remarks

The clipboard data contains the connection information for the source project. The current connection is learned from the calling context. If the two connections refer to the same project, PasteToCurrentProject returns TRUE.

See Also

ISupportCopyPaste2 Interface


%%PageItemTitle%%

ISupportEntityTypes Interface

TypeId
The name of the type as entered in the customization module of Quality Center.
See Also OTA COM Type Library

GetTypedFields Method

Description

The list of fields for the given type.

Syntax

Public Function GetTypedFields( _
   ByVal TypeId As String _
) As List

Parameters

TypeId
The name of the type as entered in the customization module of Quality Center.

Return Type

The list of related fields.

See Also

ISupportEntityTypes Interface


%%PageItemTitle%%

ISupportEntityTypes Interface

Field
The field name.
TypeId

The name of the type as entered in the customization module of Quality Center.

See Also OTA COM Type Library

IsFieldRelevantToType Method

Description

Indicates whether the field is used in this type.

Syntax

Public Function IsFieldRelevantToType( _
   ByVal Field As String, _
   ByVal TypeId As String _
) As Boolean

Parameters

Field
The field name.
TypeId

The name of the type as entered in the customization module of Quality Center.

Return Type

The list of related fields.

See Also

ISupportEntityTypes Interface


%%PageItemTitle%%

ISupportEntityTypes Interface

Field
TypeId

The name of the type as entered in the customization module of Quality Center.

See Also OTA COM Type Library

IsFieldRequiredInType Method

Description

Indicates whether the field is required in this type.

Syntax

Public Function IsFieldRequiredInType( _
   ByVal Field As String, _
   ByVal TypeId As String _
) As Boolean

Parameters

Field
TypeId

The name of the type as entered in the customization module of Quality Center.

Return Type

The list of related fields.

See Also

ISupportEntityTypes Interface


%%PageItemTitle%%

ISupportRBTAnalysisChild Members

ISupportRBTAnalysisChild Interface

Description

Represents RBT analysis capabilities for the Req coclass. Regarding the child Reqs affected by the analysis.

Public Properties

Public Property AnalyzedTestingEffortInHours | The testing effort determined by the last analysis, in hours.
Public Property AnalyzedTestingLevel | The testing level determined by the last analysis, from 'RBT Testing Levels' in ALL_LISTS.
Public Property CustomTestingEffortInHours | The custom testing effort, in hours.
Public Property CustomTestingLevel | The custom testing level supplied, from 'RBT Testing Levels' in ALL_LISTS.
Public Property IgnoreInAnalysis | Should this requirement be excluded in RBT analysis?
Public Property ParentRequirementForRBTAnalysis | The parent requirement for the current RBT Analysis.
Public Property RnDEstimatedEffortInHours | The R&D effort, in hours.
Public Property UseCustomTLAndTE | Does this requirement have a custom Testing Level and Testing Effort?.


%%PageItemTitle%%

ISupportRBTAnalysisChild Interface

AnalyzedTestingEffortInHours Property

Description

The testing effort determined by the last analysis, in hours.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AnalyzedTestingEffortInHours() As Long

See Also

ISupportRBTAnalysisChild Interface


%%PageItemTitle%%

ISupportRBTAnalysisChild Interface

AnalyzedTestingLevel Property

Description

The testing level determined by the last analysis, from 'RBT Testing Levels' in ALL_LISTS.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AnalyzedTestingLevel() As String

See Also

ISupportRBTAnalysisChild Interface


%%PageItemTitle%%

ISupportRBTAnalysisChild Interface

CustomTestingEffortInHours Property

Description

The custom testing effort, in hours.

Property type

Read-write property

Syntax (Visual Basic)

Public Property CustomTestingEffortInHours() As Long

Remarks

The CustomTestingEffortInHours and CustomTestingLevel properties for this requirement affect RBT analysis only if UseCustomTLAndTE is true.

See Also

ISupportRBTAnalysisChild Interface


%%PageItemTitle%%

ISupportRBTAnalysisChild Interface

CustomTestingLevel Property

Description

The custom testing level supplied, from 'RBT Testing Levels' in ALL_LISTS.

Property type

Read-write property

Syntax (Visual Basic)

Public Property CustomTestingLevel() As String

Remarks

The CustomTestingEffortInHours and CustomTestingLevel properties for this requirement affect RBT analysis only if UseCustomTLAndTE is true.

See Also

ISupportRBTAnalysisChild Interface


%%PageItemTitle%%

ISupportRBTAnalysisChild Interface

IgnoreInAnalysis Property

Description

Should this requirement be excluded in RBT analysis?

Property type

Read-write property

Syntax (Visual Basic)

Public Property IgnoreInAnalysis() As Boolean

See Also

ISupportRBTAnalysisChild Interface


%%PageItemTitle%%

ISupportRBTAnalysisChild Interface

ParentRequirementForRBTAnalysis Property

Description

The parent requirement for the current RBT Analysis.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ParentRequirementForRBTAnalysis() As Object

See Also

ISupportRBTAnalysisChild Interface


%%PageItemTitle%%

ISupportRBTAnalysisChild Interface

RnDEstimatedEffortInHours Property

Description

The R&D effort, in hours.

Property type

Read-write property

Syntax (Visual Basic)

Public Property RnDEstimatedEffortInHours() As Long

See Also

ISupportRBTAnalysisChild Interface


%%PageItemTitle%%

ISupportRBTAnalysisChild Interface

UseCustomTLAndTE Property

Description

Does this requirement have a custom Testing Level and Testing Effort?.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UseCustomTLAndTE() As Boolean

Remarks

The CustomTestingEffortInHours and CustomTestingLevel properties for this requirement affect RBT analysis only if UseCustomTLAndTE is true.

See Also

ISupportRBTAnalysisChild Interface


%%PageItemTitle%%

ISupportRBTAnalysisParent Members

ISupportRBTAnalysisParent Interface

Description

Represents RBT analysis capabilities for the Req coclass. Regarding the parent of the analysis.

Public Methods

Public Method AnalyzeAndSave | Do analysis, create analysis results and save testing levels to all children Reqs.
Public Method AnalyzeButDontSave | Do analysis, create analysis results, but do not save testing levels in children yet.
Public Method ApplyPolicyOnResultMatix | Use current policy matrix and re-apply it on the aggregated counts matrix to calculate total analyzed reqs duration in hours.
Public Method ResetPolicyToDefaults | Copy the policy from customization.

Public Properties

Public Property AnalysisFilter | The filter used for the Analysis.
Public Property AnalysisResultAggregatedRNDEffortsInHours | Time in hours it would take RnD to handle this requirement, as simple aggregative addition of RND efforts set in children that were visited in last analysis.
Public Property AnalysisResultAnalyzedDurationInHours | Time in hours it would take to test the reqs without CustomTestingLevel, i.e. the regular analyzed reqs, with this policy set in the related RBT Analysis setup.
Public Property AnalysisResultCountCustomizedRequirements | Count of all child requirements visited in last analysis that their Testing Efforts were customized (not set by analysis)
Public Property AnalysisResultCountIgnoredRequirements | Count of all child requirements ignored in last analysis
Public Property AnalysisResultCountNonCustomizedRequirements | For each possible risk (pair of BI and FP levels) - return the total Count of child requirements that were visited in last analysis and that are assessed to be in this Risk (Pair), and their Efforts were not customized
Public Property AnalysisResultCountUnanalyzableRequirements | Count of all child requirements visited in last analysis that could not be analyzed due to missing Assessment or incomplete custom effort
Public Property AnalysisResultCustomizedDurationInHours | Time in hours it would take to test the reqs with CustomTestingLevel with this policy set in the related RBT Analysis setup.
Public Property AnalysisResultLastAnalysisDate | The Date/Time of the last analysis done on this parent req
Public Property AvailableTimeInHours | Available hours for this RBT Analysis.
Public Property FPLevelTestingEffortInHours | Hours needed to test a requirement in the given Failure Probability.
Public Property IsAnalyzed | Is this Requirement (parent) RBT analyzed. Does it have valid result data
Public Property TestingEffortInHoursFromPolicyMatrix | Calculated Hours needed to test a requirement in the given Failure Probability and Business Impact, according to the current policy.
Public Property TestingLevelPercentage | Testing level percentage (of the full testing level).
Public Property TestingPolicyMatrix | Risk testing level matrix


%%PageItemTitle%%

ISupportRBTAnalysisParent Interface

AnalyzeAndSave Method

Description

Do analysis, create analysis results and save testing levels to all children Reqs.

Syntax

Public Sub AnalyzeAndSave()

See Also

ISupportRBTAnalysisParent Interface


%%PageItemTitle%%

ISupportRBTAnalysisParent Interface

AnalyzeButDontSave Method

Description

Do analysis, create analysis results, but do not save testing levels in children yet.

Syntax

Public Sub AnalyzeButDontSave()

See Also

ISupportRBTAnalysisParent Interface


%%PageItemTitle%%

ISupportRBTAnalysisParent Interface

ApplyPolicyOnResultMatix Method

Description

Use current policy matrix and re-apply it on the aggregated counts matrix to calculate total analyzed reqs duration in hours.

Syntax

Public Sub ApplyPolicyOnResultMatix()

See Also

ISupportRBTAnalysisParent Interface


%%PageItemTitle%%

ISupportRBTAnalysisParent Interface

ResetPolicyToDefaults Method

Description

Copy the policy from customization.

Syntax

Public Sub ResetPolicyToDefaults()

See Also

ISupportRBTAnalysisParent Interface


%%PageItemTitle%%

ISupportRBTAnalysisParent Interface

AnalysisFilter Property

Description

The filter used for the Analysis.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AnalysisFilter() As String

See Also

ISupportRBTAnalysisParent Interface


%%PageItemTitle%%

ISupportRBTAnalysisParent Interface

AnalysisResultAggregatedRNDEffortsInHours Property

Description

Time in hours it would take RnD to handle this requirement, as simple aggregative addition of RND efforts set in children that were visited in last analysis.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AnalysisResultAggregatedRNDEffortsInHours() As Long

See Also

ISupportRBTAnalysisParent Interface


%%PageItemTitle%%

ISupportRBTAnalysisParent Interface

AnalysisResultAnalyzedDurationInHours Property

Description

Time in hours it would take to test the reqs without CustomTestingLevel, i.e. the regular analyzed reqs, with this policy set in the related RBT Analysis setup.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AnalysisResultAnalyzedDurationInHours() As Long

See Also

ISupportRBTAnalysisParent Interface


%%PageItemTitle%%

ISupportRBTAnalysisParent Interface

AnalysisResultCountCustomizedRequirements Property

Description

Count of all child requirements visited in last analysis that their Testing Efforts were customized (not set by analysis)

Property type

Read-only property

Syntax (Visual Basic)

Public Property AnalysisResultCountCustomizedRequirements() As Long

See Also

ISupportRBTAnalysisParent Interface


%%PageItemTitle%%

ISupportRBTAnalysisParent Interface

AnalysisResultCountIgnoredRequirements Property

Description

Count of all child requirements ignored in last analysis

Property type

Read-only property

Syntax (Visual Basic)

Public Property AnalysisResultCountIgnoredRequirements() As Long

See Also

ISupportRBTAnalysisParent Interface


%%PageItemTitle%%

ISupportRBTAnalysisParent Interface

BILevel
The business implact level.
FPLevel
The failure probability level.
See Also OTA COM Type Library

AnalysisResultCountNonCustomizedRequirements Property

Description

For each possible risk (pair of BI and FP levels) - return the total Count of child requirements that were visited in last analysis and that are assessed to be in this Risk (Pair), and their Efforts were not customized

Property type

Read-only property

Syntax (Visual Basic)

Public Property AnalysisResultCountNonCustomizedRequirements( _
   ByVal BILevel As Long, _
   ByVal FPLevel As Long _
) As Long

Parameters

BILevel
The business implact level.
FPLevel
The failure probability level.

See Also

ISupportRBTAnalysisParent Interface


%%PageItemTitle%%

ISupportRBTAnalysisParent Interface

AnalysisResultCountUnanalyzableRequirements Property

Description

Count of all child requirements visited in last analysis that could not be analyzed due to missing Assessment or incomplete custom effort

Property type

Read-only property

Syntax (Visual Basic)

Public Property AnalysisResultCountUnanalyzableRequirements() As Long

See Also

ISupportRBTAnalysisParent Interface


%%PageItemTitle%%

ISupportRBTAnalysisParent Interface

AnalysisResultCustomizedDurationInHours Property

Description

Time in hours it would take to test the reqs with CustomTestingLevel with this policy set in the related RBT Analysis setup.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AnalysisResultCustomizedDurationInHours() As Long

See Also

ISupportRBTAnalysisParent Interface


%%PageItemTitle%%

ISupportRBTAnalysisParent Interface

AnalysisResultLastAnalysisDate Property

Description

The Date/Time of the last analysis done on this parent req

Property type

Read-only property

Syntax (Visual Basic)

Public Property AnalysisResultLastAnalysisDate() As Date

See Also

ISupportRBTAnalysisParent Interface


%%PageItemTitle%%

ISupportRBTAnalysisParent Interface

AvailableTimeInHours Property

Description

Available hours for this RBT Analysis.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AvailableTimeInHours() As Long

See Also

ISupportRBTAnalysisParent Interface


%%PageItemTitle%%

ISupportRBTAnalysisParent Interface

FPLevel
The failure probability level.
See Also OTA COM Type Library

FPLevelTestingEffortInHours Property

Description

Hours needed to test a requirement in the given Failure Probability.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FPLevelTestingEffortInHours( _
   ByVal FPLevel As Long _
) As Long

Parameters

FPLevel
The failure probability level.

Remarks

This setting overrides the corresponding value from CustomizationRBT.

See Also

ISupportRBTAnalysisParent Interface


%%PageItemTitle%%

ISupportRBTAnalysisParent Interface

IsAnalyzed Property

Description

Is this Requirement (parent) RBT analyzed. Does it have valid result data

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsAnalyzed() As Boolean

See Also

ISupportRBTAnalysisParent Interface


%%PageItemTitle%%

ISupportRBTAnalysisParent Interface

BILevel
The business implact level.
FPLevel
The failure probability level.
See Also OTA COM Type Library

TestingEffortInHoursFromPolicyMatrix Property

Description

Calculated Hours needed to test a requirement in the given Failure Probability and Business Impact, according to the current policy.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestingEffortInHoursFromPolicyMatrix( _
   ByVal BILevel As Long, _
   ByVal FPLevel As Long _
) As Long

Parameters

BILevel
The business implact level.
FPLevel
The failure probability level.

Remarks

This setting overrides the corresponding value from CustomizationRBT.

See Also

ISupportRBTAnalysisParent Interface


%%PageItemTitle%%

ISupportRBTAnalysisParent Interface

TestingLevel
See Also OTA COM Type Library

TestingLevelPercentage Property

Description

Testing level percentage (of the full testing level).

Property type

Read-write property

Syntax (Visual Basic)

Public Property TestingLevelPercentage( _
   ByVal TestingLevel As Long _
) As Long

Parameters

TestingLevel

Remarks

This setting overrides the corresponding value from CustomizationRBT.

See Also

ISupportRBTAnalysisParent Interface


%%PageItemTitle%%

ISupportRBTAnalysisParent Interface

BILevel
The business implact level.
FPLevel
The failure probability level.
See Also OTA COM Type Library

TestingPolicyMatrix Property

Description

Risk testing level matrix

Property type

Read-write property

Syntax (Visual Basic)

Public Property TestingPolicyMatrix( _
   ByVal BILevel As Long, _
   ByVal FPLevel As Long _
) As Long

Parameters

BILevel
The business implact level.
FPLevel
The failure probability level.

Remarks

This setting overrides the corresponding value from CustomizationRBT.

See Also

ISupportRBTAnalysisParent Interface


%%PageItemTitle%%

ISupportRBTAssessment Members

ISupportRBTAssessment Interface

Description

Represents RBT assessment capabilities for the Req coclass.

Public Methods

Public Method AssessBILevel | Assess the Business Impact risk level for this requirement, according to the answers provided.
Public Method AssessFPLevel | Assess the Failure Probability risk level for this requirement, according to the answers provided.

Public Properties

Public Property AssessedBILevel | Business Impact risk level for this requirement, from the last time we called AssessBILevel.
Public Property AssessedFPLevel | Failure Probability risk level for this requirement, from the last time we called AssessFPLevel.
Public Property BIChosenAnswerForQuestion | The chosen Answer to this Business Impact question for this requirement.
Public Property CustomBILevel | Custom Business Impact level, overrides the assessed level.
Public Property CustomFPLevel | Custom Failure Probability level, overrides the assessed level.
Public Property EffectiveBILevel | Effective Business Impact level.
Public Property EffectiveFPLevel | Effective Failure Probability level.
Public Property FPChosenAnswerForQuestion | The chosen Answer to this Failure Probability question for this requirement.
Public Property UseCustomBILevel | Does this requirement have a custom Business Impact level?.
Public Property UseCustomFPLevel | Does this requirement have a custom Failure Probability level?.


%%PageItemTitle%%

ISupportRBTAssessment Interface

AssessBILevel Method

Description

Assess the Business Impact risk level for this requirement, according to the answers provided.

Syntax

Public Sub AssessBILevel()

See Also

ISupportRBTAssessment Interface


%%PageItemTitle%%

ISupportRBTAssessment Interface

AssessFPLevel Method

Description

Assess the Failure Probability risk level for this requirement, according to the answers provided.

Syntax

Public Sub AssessFPLevel()

See Also

ISupportRBTAssessment Interface


%%PageItemTitle%%

ISupportRBTAssessment Interface

AssessedBILevel Property

Description

Business Impact risk level for this requirement, from the last time we called AssessBILevel.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AssessedBILevel() As String

See Also

ISupportRBTAssessment Interface


%%PageItemTitle%%

ISupportRBTAssessment Interface

AssessedFPLevel Property

Description

Failure Probability risk level for this requirement, from the last time we called AssessFPLevel.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AssessedFPLevel() As String

See Also

ISupportRBTAssessment Interface


%%PageItemTitle%%

ISupportRBTAssessment Interface

QuestionID
See Also OTA COM Type Library

BIChosenAnswerForQuestion Property

Description

The chosen Answer to this Business Impact question for this requirement.

Property type

Read-write property

Syntax (Visual Basic)

Public Property BIChosenAnswerForQuestion( _
   ByVal QuestionID As Long _
) As Long

Parameters

QuestionID

See Also

ISupportRBTAssessment Interface


%%PageItemTitle%%

ISupportRBTAssessment Interface

CustomBILevel Property

Description

Custom Business Impact level, overrides the assessed level.

Property type

Read-write property

Syntax (Visual Basic)

Public Property CustomBILevel() As String

See Also

ISupportRBTAssessment Interface


%%PageItemTitle%%

ISupportRBTAssessment Interface

CustomFPLevel Property

Description

Custom Failure Probability level, overrides the assessed level.

Property type

Read-write property

Syntax (Visual Basic)

Public Property CustomFPLevel() As String

See Also

ISupportRBTAssessment Interface


%%PageItemTitle%%

ISupportRBTAssessment Interface

EffectiveBILevel Property

Description

Effective Business Impact level.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EffectiveBILevel() As String

Get or Set Value Type

Either the the AssessedBILevel or the CustomBILevel, depending on the value of UseCustomBILevel.

See Also

ISupportRBTAssessment Interface


%%PageItemTitle%%

ISupportRBTAssessment Interface

EffectiveFPLevel Property

Description

Effective Failure Probability level.

Property type

Read-only property

Syntax (Visual Basic)

Public Property EffectiveFPLevel() As String

Get or Set Value Type

Either the AssessedFPLevel or the CustomFPLevel, depending on the value of UseCustomFPLevel.

See Also

ISupportRBTAssessment Interface


%%PageItemTitle%%

ISupportRBTAssessment Interface

QuestionID
See Also OTA COM Type Library

FPChosenAnswerForQuestion Property

Description

The chosen Answer to this Failure Probability question for this requirement.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FPChosenAnswerForQuestion( _
   ByVal QuestionID As Long _
) As Long

Parameters

QuestionID

See Also

ISupportRBTAssessment Interface


%%PageItemTitle%%

ISupportRBTAssessment Interface

UseCustomBILevel Property

Description

Does this requirement have a custom Business Impact level?.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UseCustomBILevel() As Boolean

See Also

ISupportRBTAssessment Interface


%%PageItemTitle%%

ISupportRBTAssessment Interface

UseCustomFPLevel Property

Description

Does this requirement have a custom Failure Probability level?.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UseCustomFPLevel() As Boolean

See Also

ISupportRBTAssessment Interface


%%PageItemTitle%%

ISysTreeNode Members

ISysTreeNode Interface

Description

Represents a system folder, which is a tree node in the TreeManager object.

Remarks

Get a SysTreeNode object from the TreeManager.

Public Methods

Public Method AddNode | Adds a new child node.
Public Method FindChildNode | Finds a child node by node name.
Public Method FindChildren | Finds node children according to specified search pattern.
Public Method NewList | Gets a list of the node's immediate children.
Public Method Post | Posts all changed values to the database.
Public Method Refresh | Reads the saved node data, overwriting values in memory.
Public Method RemoveNode | Deletes the specified node.

Public Properties

Public Property Attribute | Gets the node attribute.
Public Property Child | Gets a sub-folder of the current folder.
Public Property Count | The number of child nodes.
Public Property DepthType | The sub-tree depth type.
Public Property Father | The current folder's parent folder.
Public Property Name | The node name.
Public Property NodeID | The node ID number.
Public Property Path | The folder tree path starting from the tree root.


%%PageItemTitle%%

ISysTreeNode Interface

NodeName

The new folder name.

See Also OTA COM Type Library

AddNode Method

Description

Adds a new child node.

Syntax

Public Function AddNode( _
   ByVal NodeName As String _
) As SysTreeNode

Parameters

NodeName

The new folder name.

Return Type

A SysTreeNode Object.

See Also

ISysTreeNode Interface


%%PageItemTitle%%

ISysTreeNode Interface

ChildName

The folder name to find.

See Also OTA COM Type Library

FindChildNode Method

Description

Finds a child node by node name.

Syntax

Public Function FindChildNode( _
   ByVal ChildName As String _
) As SysTreeNode

Parameters

ChildName

The folder name to find.

Return Type

A SysTreeNode Object.

See Also

ISysTreeNode Interface


%%PageItemTitle%%

ISysTreeNode Interface

Pattern

The search string or pattern.

MatchCase

If True, the search is case-sensitive.

Filter

A logical filter. The filter can be retrieved from TDFilter.Text.

See Also OTA COM Type Library

FindChildren Method

Description

Finds node children according to specified search pattern.

Syntax

Public Function FindChildren( _
   ByVal Pattern As String, _
   Optional ByVal MatchCase As Boolean = False, _
   Optional ByVal Filter As String = "" _
) As List

Parameters

Pattern

The search string or pattern.

MatchCase

If True, the search is case-sensitive.

Filter

A logical filter. The filter can be retrieved from TDFilter.Text.

Return Type

A list of SysTreeNode objects that match the pattern and filter.

See Also

ISysTreeNode Interface


%%PageItemTitle%%

ISysTreeNode Interface

NewList Method

Description

Gets a list of the node's immediate children.

Syntax

Public Function NewList() As List

Return Type

A list of SysTreeNode objects in the first level below the current node.

Remarks

The list index is 1-based.

See Also

ISysTreeNode Interface


%%PageItemTitle%%

ISysTreeNode Interface

Post Method

Description

Posts all changed values to the database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ISysTreeNode Interface


%%PageItemTitle%%

ISysTreeNode Interface

Refresh Method

Description

Reads the saved node data, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ISysTreeNode Interface


%%PageItemTitle%%

ISysTreeNode Interface

Node

The node name (string), index (long) of the folder, or the SysTreeNode object representing the folder.

See Also OTA COM Type Library

RemoveNode Method

Description

Deletes the specified node.

Syntax

Public Sub RemoveNode( _
   ByVal Node As Variant _
)

Parameters

Node

The node name (string), index (long) of the folder, or the SysTreeNode object representing the folder.

See Also

ISysTreeNode Interface


%%PageItemTitle%%

ISysTreeNode Interface

Attribute Property

Description

Gets the node attribute.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attribute() As Long

See Also

ISysTreeNode Interface


%%PageItemTitle%%

ISysTreeNode Interface

Index

The index (1-based) represents the child level of the folder.

See Also OTA COM Type Library

Child Property

Description

Gets a sub-folder of the current folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Child( _
   ByVal Index As Long _
) As SysTreeNode

Parameters

Index

The index (1-based) represents the child level of the folder.

See Also

ISysTreeNode Interface


%%PageItemTitle%%

ISysTreeNode Interface

Count Property

Description

The number of child nodes.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

ISysTreeNode Interface


%%PageItemTitle%%

ISysTreeNode Interface

DepthType Property

Description

The sub-tree depth type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DepthType() As Integer

See Also

ISysTreeNode Interface


%%PageItemTitle%%

ISysTreeNode Interface

Father Property

Description

The current folder's parent folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Father() As SysTreeNode

See Also

ISysTreeNode Interface


%%PageItemTitle%%

ISysTreeNode Interface

Name Property

Description

The node name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ISysTreeNode Interface


%%PageItemTitle%%

ISysTreeNode Interface

NodeID Property

Description

The node ID number.

Property type

Read-only property

Syntax (Visual Basic)

Public Property NodeID() As Long

See Also

ISysTreeNode Interface


%%PageItemTitle%%

ISysTreeNode Interface

Path Property

Description

The folder tree path starting from the tree root.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Path() As String

See Also

ISysTreeNode Interface


%%PageItemTitle%%

ISysTreeNode2 Interface

NodeName

The new folder name.

See Also OTA COM Type Library

AddNode Method

Description

Adds a new child node.

Syntax

Public Function AddNode( _
   ByVal NodeName As String _
) As SysTreeNode

Parameters

NodeName

The new folder name.

Return Type

A SysTreeNode Object.

See Also

ISysTreeNode2 Interface


%%PageItemTitle%%

ISysTreeNode2 Interface

ChildName

The folder name to find.

See Also OTA COM Type Library

FindChildNode Method

Description

Finds a child node by node name.

Syntax

Public Function FindChildNode( _
   ByVal ChildName As String _
) As SysTreeNode

Parameters

ChildName

The folder name to find.

Return Type

A SysTreeNode Object.

See Also

ISysTreeNode2 Interface


%%PageItemTitle%%

ISysTreeNode2 Interface

Pattern

The search string or pattern.

MatchCase

If True, the search is case-sensitive.

Filter

A logical filter. The filter can be retrieved from TDFilter.Text.

See Also OTA COM Type Library

FindChildren Method

Description

Finds node children according to specified search pattern.

Syntax

Public Function FindChildren( _
   ByVal Pattern As String, _
   Optional ByVal MatchCase As Boolean = False, _
   Optional ByVal Filter As String = "" _
) As List

Parameters

Pattern

The search string or pattern.

MatchCase

If True, the search is case-sensitive.

Filter

A logical filter. The filter can be retrieved from TDFilter.Text.

Return Type

A list of SysTreeNode objects that match the pattern and filter.

See Also

ISysTreeNode2 Interface


%%PageItemTitle%%

ISysTreeNode2 Interface

NewList Method

Description

Gets a list of the node's immediate children.

Syntax

Public Function NewList() As List

Return Type

A list of SysTreeNode objects in the first level below the current node.

Remarks

The list index is 1-based.

See Also

ISysTreeNode2 Interface


%%PageItemTitle%%

ISysTreeNode2 Interface

Post Method

Description

Posts all changed values to the database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ISysTreeNode2 Interface


%%PageItemTitle%%

ISysTreeNode2 Interface

Refresh Method

Description

Reads the saved node data, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ISysTreeNode2 Interface


%%PageItemTitle%%

ISysTreeNode2 Interface

Node

The node name (string), index (long) of the folder, or the SysTreeNode object representing the folder.

See Also OTA COM Type Library

RemoveNode Method

Description

Deletes the specified node.

Syntax

Public Sub RemoveNode( _
   ByVal Node As Variant _
)

Parameters

Node

The node name (string), index (long) of the folder, or the SysTreeNode object representing the folder.

See Also

ISysTreeNode2 Interface


%%PageItemTitle%%

ISysTreeNode2 Interface

Attribute Property

Description

Gets the node attribute.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attribute() As Long

See Also

ISysTreeNode2 Interface


%%PageItemTitle%%

ISysTreeNode2 Interface

Index

The index (1-based) represents the child level of the folder.

See Also OTA COM Type Library

Child Property

Description

Gets a sub-folder of the current folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Child( _
   ByVal Index As Long _
) As SysTreeNode

Parameters

Index

The index (1-based) represents the child level of the folder.

See Also

ISysTreeNode2 Interface


%%PageItemTitle%%

ISysTreeNode2 Interface

Count Property

Description

The number of child nodes.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

ISysTreeNode2 Interface


%%PageItemTitle%%

ISysTreeNode2 Interface

DepthType Property

Description

The sub-tree depth type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DepthType() As Integer

See Also

ISysTreeNode2 Interface


%%PageItemTitle%%

ISysTreeNode2 Interface

Father Property

Description

The current folder's parent folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Father() As SysTreeNode

See Also

ISysTreeNode2 Interface


%%PageItemTitle%%

ISysTreeNode2 Interface

Name Property

Description

The node name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ISysTreeNode2 Interface


%%PageItemTitle%%

ISysTreeNode2 Interface

NodeID Property

Description

The node ID number.

Property type

Read-only property

Syntax (Visual Basic)

Public Property NodeID() As Long

See Also

ISysTreeNode2 Interface


%%PageItemTitle%%

ISysTreeNode2 Interface

Path Property

Description

The folder tree path starting from the tree root.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Path() As String

See Also

ISysTreeNode2 Interface


%%PageItemTitle%%

ISysTreeNode2 Interface

Type Property

Description

The nodes's type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Type() As Long

Get or Set Value Type

A value of the TDAPI_NODE_TYPE Enumeration.

See Also

ISysTreeNode2 Interface


%%PageItemTitle%%

ITableProperties Members

ITableProperties Interface

Description

Description of a database table.

Public Properties

Public Property Name | The DB name of the table.
Public Property UserLabel | The display name of the table.


%%PageItemTitle%%

ITableProperties Interface

Name Property

Description

The DB name of the table.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ITableProperties Interface


%%PageItemTitle%%

ITableProperties Interface

UserLabel Property

Description

The display name of the table.

Property type

Read-only property

Syntax (Visual Basic)

Public Property UserLabel() As String

See Also

ITableProperties Interface


%%PageItemTitle%%

ITDConnection Members

ITDConnection Interface

Description

Represents a single server connection.

Remarks

The TDConnection object is the object instantiated at the beginning of an Open Test Architecture application run. Nearly all other objects can be created from the TDConnection object or from objects created from the TDConnection object. A small number of utility objects are the only objects created without reference to the TDConnection object.

The first method to call with TDConnection is InitConnectionEx. After the connection is initialized, authenticate a user with Login.

Connect establishes a new project session for the logged-in user. Disconnect should be called at the end of each project session.

Before the application exits, call ReleaseConnection.

Example

A: Getting Started - A simple filter | A: Getting Started - Find tests that are not in any test set | A: Getting Started - Find tests that do not cover any requirement | A: Getting Started - Formatting time for use in filter | Customization: Add a customization list | A: Getting Started - Creating a new defect | Links: Adding a defect to a link | Alerts: Adding a follow-up flag to a defect | Alerts: Check if a defect has a follow-up | Alerts: Check values of follow-up | Copy-paste: Copy a defect | A: Getting Started - Delete a defect | A: Getting Started - Delete a defect | Links: Get link from defect to test | Links: Get link from defect to test | Links: Link a defect to a Run test step | Links: Removing a link between defects

Public Methods

Public Method ChangePassword | Changes the password for the currently logged in user.
Public Method ConnectProject | Connects to the specified project.
Public Method ConnectProjectEx | Connects to the specified project in the specified domain.
Public Method DisconnectProject | Disconnects from the project.
Public Method GetLicenses | Allocates multiple licenses types according to the LicensesType parameter.
Public Method GetLicenseStatus | The license status for the specified client type.
Public Method GetTDVersion | The major and minor versions of the OTA API.
Public Method InitConnectionEx | Initializes the connection.
Public Method PurgeRuns | Deletes the runs in this connection that match the input arguments.
Public Method ReleaseConnection | ReleaseConnection must be called for each call of an initialization method after finishing work with the Open Test Architecture API.
Public Method SendMail | Sends Mail.

Public Properties

Public Property ActionPermission | The ActionPermission object for this connection.
Public Property AlertManager | The AlertManager object for this connection.
Public Property BugFactory | The Bug Factory object for this connection.
Public Property CheckoutRepository | The path of the checkout repository.
Public Property Command | The Command object for this connection.
Public Property CommonSettings | The Settings object for all users in this connection.
Public Property Connected | Checks if the Open Test Architecture API server connection is initialized.
Public Property Customization | The Customization object for this connection.
Public Property DBName | The name of the database.
Public Property DBType | The database type.
Public Property DirectoryPath | The path of the server side repository directory for the database repository type.
Public Property DomainName | The current domain.
Public Property DomainsList | The domain names for this site.
Public Property ExtendedStorage | The ExtendedStorage object for this connection.
Public Property Fields | A list of fields for the table specified in the DataType argument.
Public Property HostFactory | The Hosts Factory object for this connection.
Public Property HostGroupFactory | The HostGroupFactory object for this connection.
Public Property IgnoreHtmlFormat | Indicates if formatted memo and description fields are returned as plain text without HTML tags.
Public Property MailConditions | The TDMailConditions object for this connection.
Public Property ProjectConnected | Checks if the TDConnection is connected to a project.
Public Property ProjectName | The name of the connected project.
Public Property ProjectProperties | The ProjectProperties object for this connection.
Public Property ProjectsList | The projects that are available in the domain to which Quality Center is connected.
Public Property ProjectsListEx | The projects available within the specified domain.
Public Property ReportRole | The report role of the connected user.
Public Property ReqFactory | The ReqFactory object for this connection.
Public Property Rules | The RuleManager object for this connection.
Public Property RunFactory | The RunFactory object for this connection.
Public Property ServerName | The name of the connected Open Test Architecture API server.
Public Property ServerTime | The time and date of the currently connected database server.
Public Property ServerURL | The URL of the connected server.
Public Property TDParams | Gets the value of the parameter whose name is specified by Request.
Public Property TestFactory | The Test Factory object for this connection.
Public Property TestRepository | The path of the tests directory of the connected project.
Public Property TestSetFactory | The Test Set Factory object for this connection.
Public Property TestSetTreeManager | The TestSetTreeManager object for this connection.
Public Property TextParam | The TextParser object.
Public Property TreeManager | The TreeManager object for the system tree.
Public Property UserGroupsList | The names of the user groups of the currently connected project.
Public Property UserName | The user connected to the project.
Public Property UserSettings | The Settings object for the logged-on user.
Public Property UsersList | The names of the users of the currently connected project.
Public Property UsingProgress | Indicates if a progress bar is displayed.
Public Property VCS | The Version Control System (VCS) object for this connection.
Public Property VcsDbRepository | The path of the VCS database of the connected project.


%%PageItemTitle%%

ITDConnection Interface

OldPassword

The current password before the change.

NewPassword

The new password.

See Also OTA COM Type Library

ChangePassword Method

Description

Changes the password for the currently logged in user.

Syntax

Public Sub ChangePassword( _
   ByVal OldPassword As String, _
   ByVal NewPassword As String _
)

Parameters

OldPassword

The current password before the change.

NewPassword

The new password.

See Also

ITDConnection Interface


%%PageItemTitle%%

ITDConnection Interface

LicensesType

A bit mask composed of members of the tagTDLICENSE_CLIENT Enumeration combined with a bit-wise OR. Each bit set in the mask indicates that the description of the license of that type is to be returned in the output argument.

pVal

The output description of the licenses: Type code, approval status, and UID.

See Also OTA COM Type Library

GetLicenses Method

Description

Allocates multiple licenses types according to the LicensesType parameter.

Syntax

Public Sub GetLicenses( _
   ByVal LicensesType As Long, _
   ByRef pVal As String _
)

Parameters

LicensesType

A bit mask composed of members of the tagTDLICENSE_CLIENT Enumeration combined with a bit-wise OR. Each bit set in the mask indicates that the description of the license of that type is to be returned in the output argument.

pVal

The output description of the licenses: Type code, approval status, and UID.

Remarks

For details of the return string, see the example. Error codes in the return string are from the tagTDAPI_ERRORCODES Enumeration.

See Also

ITDConnection Interface


%%PageItemTitle%%

ITDConnection Interface

ClientType

A value of the tagTDAPI_LICENSE Enumeration.

InUse

The number of modules of the specified type currently in use.

Max

The maximum number of modules of the specified type that can be used simultaneously.

See Also OTA COM Type Library

GetLicenseStatus Method

Description

The license status for the specified client type.

Syntax

Public Sub GetLicenseStatus( _
   ByVal ClientType As Long, _
   ByRef InUse As Long, _
   ByRef Max As Long _
)

Parameters

ClientType

A value of the tagTDAPI_LICENSE Enumeration.

InUse

The number of modules of the specified type currently in use.

Max

The maximum number of modules of the specified type that can be used simultaneously.

See Also

ITDConnection Interface


%%PageItemTitle%%

ITDConnection Interface

pbsMajorVersion

The release number.

pbsBuildNum

The intermediate release number.

See Also OTA COM Type Library

GetTDVersion Method

Description

The major and minor versions of the OTA API.

Syntax

Public Sub GetTDVersion( _
   ByRef pbsMajorVersion As String, _
   ByRef pbsBuildNum As String _
)

Parameters

pbsMajorVersion

The release number.

pbsBuildNum

The intermediate release number.

See Also

ITDConnection Interface


%%PageItemTitle%%

ITDConnection Interface

ServerName

The Quality Center URL: http://<server>[:port]/qcbin

See Also OTA COM Type Library

InitConnectionEx Method

Description

Initializes the connection.

Syntax

Public Sub InitConnectionEx( _
   ByVal ServerName As String _
)

Parameters

ServerName

The Quality Center URL: http://<server>[:port]/qcbin

Remarks

InitConnectionEx must be called before a user can be authenticated with Login.

See Also

ITDConnection Interface


%%PageItemTitle%%

ITDConnection Interface

TestSetFilter

The filter specifying the test sets from which the runs should be deleted. The filter can be a list of cycle IDs like "1,5,78,14", a status like "CY_STATUS='Open'", or a TDFilter.Text.

KeepLast

The number of most recent test instance runs not to purge.

DateUnit

Either a date string, in which case runs before this date are purged, or a unit code used to interpret the unit count. A unit code is one of:

1 for Days
2 for Weeks
3 for Months
4 for Years

UnitCount

If DateUnit is not a date string, this is the number of units. For example, if DateUnit is 1 and UnitCount is 5, purge all runs older than 5 days.

StepsOnly

If True, purge only the steps, but not the runs. If False, purge both the runs and steps.

See Also OTA COM Type Library

PurgeRuns Method

Description

Deletes the runs in this connection that match the input arguments.

Syntax

Public Sub PurgeRuns( _
   ByVal TestSetFilter As String, _
   ByVal KeepLast As Long, _
   ByVal DateUnit As Variant, _
   ByVal UnitCount As Long, _
   ByVal StepsOnly As Boolean _
)

Parameters

TestSetFilter

The filter specifying the test sets from which the runs should be deleted. The filter can be a list of cycle IDs like "1,5,78,14", a status like "CY_STATUS='Open'", or a TDFilter.Text.

KeepLast

The number of most recent test instance runs not to purge.

DateUnit

Either a date string, in which case runs before this date are purged, or a unit code used to interpret the unit count. A unit code is one of:

1 for Days
2 for Weeks
3 for Months
4 for Years

UnitCount

If DateUnit is not a date string, this is the number of units. For example, if DateUnit is 1 and UnitCount is 5, purge all runs older than 5 days.

StepsOnly

If True, purge only the steps, but not the runs. If False, purge both the runs and steps.

Remarks

KeepLast overrides OlderThan. For example, if KeepLast is 10, OlderThan is 2 and UnitCount is 5, the meaning is "Purge all runs older than 5 weeks, but keep the last 10 runs for each test instance regardless of age".

See Also

ITDConnection Interface


%%PageItemTitle%%

ITDConnection Interface

ReleaseConnection Method

Description

ReleaseConnection must be called for each call of an initialization method after finishing work with the Open Test Architecture API.

Syntax

Public Sub ReleaseConnection()

See Also

ITDConnection Interface


%%PageItemTitle%%

ITDConnection Interface

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendFrom

No longer in use. The actual "From" address is the email associated with the connected user. Pass an empty string ("").

Subject

The subject of the e-mail.

Message

The body of the e-mail.

attachArray

A Variant Array, each element of which is an Attachment.ServerFileName

bsFormat

The mail format, either "HTML", "TEXT" or any other string. Any string other than "HTML" is interpreted as text.

See Also OTA COM Type Library

SendMail Method

Description

Sends Mail.

Syntax

Public Sub SendMail( _
   ByVal SendTo As String, _
   Optional ByVal SendFrom As String = "", _
   Optional ByVal Subject As String = "", _
   Optional ByVal Message As String = "", _
   Optional ByVal attachArray As Variant, _
   Optional ByVal bsFormat As String = "" _
)

Parameters

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendFrom

No longer in use. The actual "From" address is the email associated with the connected user. Pass an empty string ("").

Subject

The subject of the e-mail.

Message

The body of the e-mail.

attachArray

A Variant Array, each element of which is an Attachment.ServerFileName

bsFormat

The mail format, either "HTML", "TEXT" or any other string. Any string other than "HTML" is interpreted as text.

See Also

ITDConnection Interface


%%PageItemTitle%%

ITDConnection Interface | ActionPermission Object

ActionPermission Property

Description

The ActionPermission object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ActionPermission() As Object

See Also

ITDConnection Interface | ActionPermission Object


%%PageItemTitle%%

ITDConnection Interface | AlertManager Object

AlertManager Property

Description

The AlertManager object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property AlertManager() As Object

See Also

ITDConnection Interface | AlertManager Object


%%PageItemTitle%%

ITDConnection Interface | BugFactory Object

BugFactory Property

Description

The Bug Factory object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BugFactory() As Object

See Also

ITDConnection Interface | BugFactory Object


%%PageItemTitle%%

ITDConnection Interface

CheckoutRepository Property

Description

The path of the checkout repository.

Property type

Read-only property

Syntax (Visual Basic)

Public Property CheckoutRepository() As String

See Also

ITDConnection Interface


%%PageItemTitle%%

ITDConnection Interface | Command Object

Command Property

Description

The Command object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Command() As Object

See Also

ITDConnection Interface | Command Object


%%PageItemTitle%%

ITDConnection Interface | Settings Object

CommonSettings Property

Description

The Settings object for all users in this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property CommonSettings() As Object

See Also

ITDConnection Interface | Settings Object


%%PageItemTitle%%

ITDConnection Interface

Connected Property

Description

Checks if the Open Test Architecture API server connection is initialized.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Connected() As Boolean

Remarks

Connected is True after a successful call to InitConnectionEx. It is False after a call to ReleaseConnection.

Note that Connected is the status of the connection to the server, not of the connection to a project. To check if a project is connected, use the ProjectConnected property.

See Also

ITDConnection Interface


%%PageItemTitle%%

ITDConnection Interface

Customization Property

Description

The Customization object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Customization() As Object

See Also

ITDConnection Interface

Example

Customization Object


%%PageItemTitle%%

ITDConnection Interface

DBName Property

Description

The name of the database.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DBName() As String

See Also

ITDConnection Interface


%%PageItemTitle%%

ITDConnection Interface

DBType Property

Description

The database type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DBType() As String

See Also

ITDConnection Interface


%%PageItemTitle%%

ITDConnection Interface

nType

The database repository type, a value of the tagTDAPI_DIRECTORY Enumeration.

See Also OTA COM Type Library

DirectoryPath Property

Description

The path of the server side repository directory for the database repository type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DirectoryPath( _
   ByVal nType As Long _
) As String

Parameters

nType

The database repository type, a value of the tagTDAPI_DIRECTORY Enumeration.

See Also

ITDConnection Interface


%%PageItemTitle%%

ITDConnection Interface

DomainName Property

Description

The current domain.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DomainName() As String

See Also

ITDConnection Interface


%%PageItemTitle%%

ITDConnection Interface | ExtendedStorage Object

ExtendedStorage Property

Description

The ExtendedStorage object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExtendedStorage() As Object

Remarks

For general file storage by third party tools.

See Also

ITDConnection Interface | ExtendedStorage Object


%%PageItemTitle%%

ITDConnection Interface

DataType

The name of a system table.

See Also OTA COM Type Library

Fields Property

Description

A list of fields for the table specified in the DataType argument.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields( _
   ByVal DataType As String _
) As List

Parameters

DataType

The name of a system table.

Remarks

Some possible values for DataType are:

"ALL_LISTS" for Subject
"BUG" for Defect
"CYCL_FOLD" for Test Set Folder
"CYCLE" for Test Set
"DESSTEPS" for Design Step
"REQ" for Requirement
"RUN" for Run
"STEP" for Run Step
"TEST" for Test
"TESTCYCL" for Test in Test Set (Test Instance)

For more possibilities, see the Quality Center Database Reference.

See Also

ITDConnection Interface


%%PageItemTitle%%

ITDConnection Interface | HostFactory Object

HostFactory Property

Description

The Hosts Factory object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HostFactory() As Object

See Also

ITDConnection Interface | HostFactory Object


%%PageItemTitle%%

ITDConnection Interface | HostGroupFactory Object

HostGroupFactory Property

Description

The HostGroupFactory object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HostGroupFactory() As Object

See Also

ITDConnection Interface | HostGroupFactory Object


%%PageItemTitle%%

ITDConnection Interface

IgnoreHtmlFormat Property

Description

Indicates if formatted memo and description fields are returned as plain text without HTML tags.

Property type

Read-write property

Syntax (Visual Basic)

Public Property IgnoreHtmlFormat() As Boolean

Remarks

This setting affects the behavior of other APIs that return formatted text fields.

See Also

ITDConnection Interface


%%PageItemTitle%%

ITDConnection Interface | tHostGroupFactory Object

MailConditions Property

Description

The TDMailConditions object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property MailConditions() As Object

See Also

ITDConnection Interface | tHostGroupFactory Object


%%PageItemTitle%%

ITDConnection Interface

ProjectConnected Property

Description

Checks if the TDConnection is connected to a project.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ProjectConnected() As Boolean

Remarks

True after a success call to Connect and False after a call to Disconnect Method.

See Also

ITDConnection Interface


%%PageItemTitle%%

ITDConnection Interface

ProjectName Property

Description

The name of the connected project.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ProjectName() As String

Remarks

If no project is connected, the property is an empty string.

See Also

ITDConnection Interface


%%PageItemTitle%%

ITDConnection Interface | [New Link]

See Also OTA COM Type Library

ProjectProperties Property

Description

The ProjectProperties object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ProjectProperties() As Object

See Also

ITDConnection Interface | [New Link]


%%PageItemTitle%%

ITDConnection Interface

ProjectsList Property

Description

The projects that are available in the domain to which Quality Center is connected.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ProjectsList() As List

See Also

ITDConnection Interface


%%PageItemTitle%%

ITDConnection Interface

ReportRole Property

Description

The report role of the connected user.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ReportRole() As String

Remarks

See the Advanced Reports Guide.

See Also

ITDConnection Interface


%%PageItemTitle%%

ITDConnection Interface | ReqFactory Object

ReqFactory Property

Description

The ReqFactory object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ReqFactory() As Object

See Also

ITDConnection Interface | ReqFactory Object


%%PageItemTitle%%

ITDConnection Interface | RuleManager Object

Rules Property

Description

The RuleManager object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Rules() As Object

See Also

ITDConnection Interface | RuleManager Object


%%PageItemTitle%%

ITDConnection Interface | RunFactory Object

RunFactory Property

Description

The RunFactory object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RunFactory() As Object

See Also

ITDConnection Interface | RunFactory Object


%%PageItemTitle%%

ITDConnection Interface

ServerName Property

Description

The name of the connected Open Test Architecture API server.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ServerName() As String

Remarks

If no server is connected, returns an empty string.

See Also

ITDConnection Interface


%%PageItemTitle%%

ITDConnection Interface

ServerTime Property

Description

The time and date of the currently connected database server.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ServerTime() As Date

See Also

ITDConnection Interface


%%PageItemTitle%%

ITDConnection Interface

ServerURL Property

Description

The URL of the connected server.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ServerURL() As String

See Also

ITDConnection Interface


%%PageItemTitle%%

ITDConnection Interface

Request

The name of a parameter from the Site Configuration tab in the Site Administrator UI.

See Also OTA COM Type Library

TDParams Property

Description

Gets the value of the parameter whose name is specified by Request.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TDParams( _
   ByVal Request As String _
) As String

Parameters

Request

The name of a parameter from the Site Configuration tab in the Site Administrator UI.

See Also

ITDConnection Interface


%%PageItemTitle%%

ITDConnection Interface | TestFactory Object

TestFactory Property

Description

The Test Factory object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestFactory() As Object

See Also

ITDConnection Interface | TestFactory Object


%%PageItemTitle%%

ITDConnection Interface

TestRepository Property

Description

The path of the tests directory of the connected project.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestRepository() As String

See Also

ITDConnection Interface


%%PageItemTitle%%

ITDConnection Interface | TestSetFactory Object

TestSetFactory Property

Description

The Test Set Factory object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestSetFactory() As Object

See Also

ITDConnection Interface | TestSetFactory Object


%%PageItemTitle%%

ITDConnection Interface | TestSetTreeManager Object

TestSetTreeManager Property

Description

The TestSetTreeManager object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestSetTreeManager() As Object

See Also

ITDConnection Interface | TestSetTreeManager Object


%%PageItemTitle%%

ITDConnection Interface

TextParam Property

Description

The TextParser object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TextParam() As Object

See Also

ITDConnection Interface


%%PageItemTitle%%

ITDConnection Interface | TreeManager Object

TreeManager Property

Description

The TreeManager object for the system tree.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TreeManager() As Object

See Also

ITDConnection Interface | TreeManager Object


%%PageItemTitle%%

ITDConnection Interface

UserGroupsList Property

Description

The names of the user groups of the currently connected project.

Property type

Read-only property

Syntax (Visual Basic)

Public Property UserGroupsList() As List

See Also

ITDConnection Interface


%%PageItemTitle%%

ITDConnection Interface

UserName Property

Description

The user connected to the project.

Property type

Read-only property

Syntax (Visual Basic)

Public Property UserName() As String

See Also

ITDConnection Interface


%%PageItemTitle%%

ITDConnection Interface | Settings Object

UserSettings Property

Description

The Settings object for the logged-on user.

Property type

Read-only property

Syntax (Visual Basic)

Public Property UserSettings() As Object

See Also

ITDConnection Interface | Settings Object


%%PageItemTitle%%

ITDConnection Interface

UsersList Property

Description

The names of the users of the currently connected project.

Property type

Read-only property

Syntax (Visual Basic)

Public Property UsersList() As List

See Also

ITDConnection Interface


%%PageItemTitle%%

ITDConnection Interface

UsingProgress Property

Description

Indicates if a progress bar is displayed.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UsingProgress() As Boolean

See Also

ITDConnection Interface


%%PageItemTitle%%

ITDConnection Interface | VCS Object

VCS Property

Description

The Version Control System (VCS) object for this connection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property VCS() As Object

See Also

ITDConnection Interface | VCS Object


%%PageItemTitle%%

ITDConnection Interface

VcsDbRepository Property

Description

The path of the VCS database of the connected project.

Property type

Read-only property

Syntax (Visual Basic)

Public Property VcsDbRepository() As String

See Also

ITDConnection Interface


%%PageItemTitle%%

ITDField Members

ITDField Interface

Description

Represents a field with field system properties and other properties.

Remarks

Get a TDField object from the Fields property of any factory object or from TDConnection.Fields.

Public Methods

Public Method IsValidValue Checks if the input value is valid for the field.

Public Properties

Public Property Name | The database name of the current field.
Public Property Property | The FieldProperty object associated with the current field.
Public Property Type | The field database type.


%%PageItemTitle%%

ITDField Interface

Value

The value to check.

pObject

Any object that implements the IBaseField Interface.

See Also OTA COM Type Library

IsValidValue Method

Description

Checks if the input value is valid for the field.

Syntax

Public Sub IsValidValue( _
   ByVal Value As Variant, _
   ByVal pObject As Object _
)

Parameters

Value

The value to check.

pObject

Any object that implements the IBaseField Interface.

Return Type

In Visual Basic, the value is returned in the error object's Number attribute . Check the value immediately after the call to IsValidValue, as any intervening call may change the error object. In other languages, check the HRESULT.

Possible values are:

  • S_OK - Valid value. Note that valid value does not necessary mean the value can be set. For example, a value for a key field may be valid, but you cannot write to a key field. Note that in Visual Basic, S_OK is returned as zero.
  • FIELD_E_VERIFIED - Invalid value.
  • TDOLE_NONODE - The value is rejected for any reason. For example, the field is linked to a list and the value is not in the list.

See Also

ITDField Interface


%%PageItemTitle%%

ITDField Interface

Name Property

Description

The database name of the current field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ITDField Interface


%%PageItemTitle%%

ITDField Interface

Property Property

Description

The FieldProperty object associated with the current field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Property() As Object

See Also

ITDField Interface


%%PageItemTitle%%

ITDField Interface

Type Property

Description

The field database type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Type() As Long

See Also

ITDField Interface


%%PageItemTitle%%

ITDFilter Members

ITDFilter Interface

Description

Services for creation of a filtered list of field objects without SQL.

Remarks

Get a TDFilter from the Filter property of any factory object except ReqFactory or from History.Filter.

A HierarchyFilter is a filter that can return the parents of items as well as the items themselves. Get a HierarchyFilter with ReqFactory.Filter.

A filter cannot handle OR conditions between different fields nor sort on a user-defined field.

A filter always has a primary filter on an entity and may also have a secondary filter, or XFilter, on a second entity. A filter without an XFilter specifies a list of the objects that meet all the criteria specified by setting the TDFilter.Filter or HierarchyFilter.Filter. A filter may have several Filter properties defined.

A filter with an XFilter specifies a list of all the objects of the first type that meet the Filter criteria, and that are associated with the objects of the second type that meet the criteria in the XFilter text. The XFilter text is set with the SetXFilter method or by setting the XFilter property .

For example, a TEST-TESTSET XFilter is a TDfilter derived from a Test factory. The first clause is created by setting the Filter to specify the desired tests. The XFilter is created by getting a second TDFilter from a TestSetFactory and setting the Filter property to specify the desired test sets. The text of this test set TDFilter is the XFilter text of primary test TDFilter.

The result is a list of tests that meet the TDFilter.Filter criteria and are associated with at least one of the test sets that meet the TDFilter.XFilter criteria.

The association between the entities can be direct, as in a links between requirements and defects, or it can be indirect. For example, TSTEST-REQ selects test instances (TSTEST) based on design tests (TEST) that cover requirements.

Example

Getting a filtered, sorted list of requirements

Public Methods

Public Method Clear | Clears the current filter.
Public Method NewList | Creates a new list from current filter.
Public Method Refresh | Reads saved data and refreshes the fetched list according to the current filter, overwriting values in memory.

Public Properties

Public Property CaseSensitive | Indicates if the filter for the specified field is case sensitive. The default is False.
Public Property DataType | The filtered entity type.
Public Property Fields | The list of fields for the TDFilter's parent object.
Public Property Filter | The filter condition for the field specified by the FieldName.
Public Property Order | The position of the specified field in the list of the sort fields. (zero-based)
Public Property OrderDirection | The sort order: TDOLE_ASCENDING or TDOLE_DESCENDING
Public Property Text | The full fields filter as text.
Public Property XFilter | The cross filter according to the entity type.


%%PageItemTitle%%

ITDFilter Interface

Clear Method

Description

Clears the current filter.

Syntax

Public Sub Clear()

See Also

ITDFilter Interface


%%PageItemTitle%%

ITDFilter Interface

NewList Method

Description

Creates a new list from current filter.

Syntax

Public Function NewList() As List

See Also

ITDFilter Interface


%%PageItemTitle%%

ITDFilter Interface

Refresh Method

Description

Reads saved data and refreshes the fetched list according to the current filter, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ITDFilter Interface


%%PageItemTitle%%

ITDFilter Interface

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

CaseSensitive Property

Description

Indicates if the filter for the specified field is case sensitive. The default is False.

Property type

Read-write property

Syntax (Visual Basic)

Public Property CaseSensitive( _
   ByVal FieldName As String _
) As Boolean

Parameters

FieldName

The name of the field in the project database.

See Also

ITDFilter Interface


%%PageItemTitle%%

ITDFilter Interface

DataType Property

Description

The filtered entity type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DataType() As String

See Also

ITDFilter Interface


%%PageItemTitle%%

ITDFilter Interface

Fields Property

Description

The list of fields for the TDFilter's parent object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

Remarks

The list depends on the factory from which the TDFilter was created. For example, if the filter is created from a TestFactory, the field list will consist of the names of the Test fields: TS_ATTACHMENT, TS_CREATION_DATE, TS_DESCRIPTION, TS_RESPONSIBLE, TS_STATUS, TS_SUBJECT, TS_TEMPLATE, TS_TEST_ID, TS_NAME, and so on.

See Also

ITDFilter Interface


%%PageItemTitle%%

ITDFilter Interface

FieldName

The name of a field of the entity to which the filter is applied.

Only fields whose FieldProperty.IsCanFilter Property is true can be used.

See Also OTA COM Type Library

Filter Property

Description

The filter condition for the field specified by the FieldName.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Filter( _
   ByVal FieldName As String _
) As String

Parameters

FieldName

The name of a field of the entity to which the filter is applied.

Only fields whose FieldProperty.IsCanFilter Property is true can be used.

Remarks

Although the Filter property has the syntax of a single property, a TDFilter can have a collection of Filter properties, each on a different field. Set the Filter property for one field with each command.

A Filter setting is a value of the field, a value with an operator, or a set of values connected by operators.

The values can be constants, special tokens such as "[Today]", "[PreviousWeek]", or "[NextYear]", or folder names, such as "^Subject\LinkFolder^". Use the set filter dialog in the the relevant module of the Quality Center UI to explore the possibilities.

String values with spaces must be quoted, for example, TestFilter.Filter("TS_EXEC_STATUS") = """No Run"""

The value can be an expression with a wild card. For example, testsetFilter.Filter("CY_CYCLE") = "GS*" filters for all test sets whose names begin with "GS".

See Also

ITDFilter Interface

Example

Getting a filtered,sorted list of requirements


%%PageItemTitle%%

ITDFilter Interface

FieldName

The name of the database field whose sort priority is to be retrieved or set.

See Also OTA COM Type Library

Order Property

Description

The position of the specified field in the list of the sort fields. (zero-based)

Property type

Read-write property

Syntax (Visual Basic)

Public Property Order( _
   ByVal FieldName As String _
) As Long

Parameters

FieldName

The name of the database field whose sort priority is to be retrieved or set.

Remarks

When the order of one field is set with this property, no adjustments are made to the positions of other fields. The application is responsible for ensuring that the orders of all the fields are as required, that no two fields occupy the same position, and there are no empty positions.

When two or more fields are assigned the same order, the actual order is undetermined.

See Also

ITDFilter Interface

Example

Getting a filtered, sorted list of requirements


%%PageItemTitle%%

ITDFilter Interface

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

OrderDirection Property

Description

The sort order: TDOLE_ASCENDING or TDOLE_DESCENDING

Property type

Read-write property

Syntax (Visual Basic)

Public Property OrderDirection( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName

The name of the field in the project database.

See Also

ITDFilter Interface


%%PageItemTitle%%

ITDFilter Interface

Text Property

Description

The full fields filter as text.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Text() As String

Remarks

In most places where a string-type Filter argument is passed to a method that selects items, for example to create a filtered list, it is this Text property that is passed to the method.

This text is displayed in the Quality Center user interface above the grid when a filter is set.

See Also

ITDFilter Interface


%%PageItemTitle%%

ITDFilter Interface

CrossEntity

Possible values: BUG-ALERT, BUG-REQ, BUG-TEST, BUG-TESTSET, REQ-ALERT, REQ-BUG, REQ-TEST, REQ-TO-FROM-REQ, RUN-BUG, TEST-ALERT, TEST-BUG, TEST-INSTANCE-ALERT, TEST-REQ, TEST-TESTSET, TEST-VER_CTRL, TESTCYCL-ALERT,
TESTSET-BUG, TESTSET-TEST, TSTEST-BUG, TSTEST-REQ, TSTEST-TEST-TEQ, and TSTEST-TSTEST-REQ.

See Also OTA COM Type Library

XFilter Property

Description

The cross filter according to the entity type.

Property type

Read-write property

Syntax (Visual Basic)

Public Property XFilter( _
   ByVal CrossEntity As String _
) As String

Parameters

CrossEntity

Possible values: BUG-ALERT, BUG-REQ, BUG-TEST, BUG-TESTSET, REQ-ALERT, REQ-BUG, REQ-TEST, REQ-TO-FROM-REQ, RUN-BUG, TEST-ALERT, TEST-BUG, TEST-INSTANCE-ALERT, TEST-REQ, TEST-TESTSET, TEST-VER_CTRL, TESTCYCL-ALERT,
TESTSET-BUG, TESTSET-TEST, TSTEST-BUG, TSTEST-REQ, TSTEST-TEST-TEQ, and TSTEST-TSTEST-REQ.

Remarks

Setting this property is equivalent to calling SetXFilter with Inclusive = TRUE.

See Also

ITDFilter Interface


%%PageItemTitle%%

ITDFilter2 Members

ITDFilter2 Interface

Description

Services for creation of a filtered list of field objects without SQL.

Remarks

Get a TDFilter from the Filter property of any factory object except ReqFactory or from History.Filter.

A HierarchyFilter is a filter that can return the parents of items as well as the items themselves. Get a HierarchyFilter with ReqFactory.Filter.

A filter cannot handle OR conditions between different fields nor sort on a user-defined field.

A filter always has a primary filter on an entity and may also have a secondary filter, or XFilter, on a second entity. A filter without an XFilter specifies a list of the objects that meet all the criteria specified by setting the TDFilter.Filter or HierarchyFilter.Filter. A filter may have several Filter properties defined.

A filter with an XFilter specifies a list of all the objects of the first type that meet the Filter criteria, and that are associated with the objects of the second type that meet the criteria in the XFilter text. The XFilter text is set with the SetXFilter method or by setting the XFilter property .

For example, a TEST-TESTSET XFilter is a TDfilter derived from a Test factory. The first clause is created by setting the Filter to specify the desired tests. The XFilter is created by getting a second TDFilter from a TestSetFactory and setting the Filter property to specify the desired test sets. The text of this test set TDFilter is the XFilter text of primary test TDFilter.

The result is a list of tests that meet the TDFilter.Filter criteria and are associated with at least one of the test sets that meet the TDFilter.XFilter criteria.

The association between the entities can be direct, as in a links between requirements and defects, or it can be indirect. For example, TSTEST-REQ selects test instances (TSTEST) based on design tests (TEST) that cover requirements.

Public Methods

Public Method Clear | Clears the current filter.
Public Method GetXFilter | Gets the cross filter specified by CrossEntities.
Public Method IsClear | Checks whether the filter is clear, including cross-filter settings
Public Method NewList | Creates a new list from current filter.
Public Method Refresh | Reads saved data and refreshes the fetched list according to the current filter, overwriting values in memory.
Public Method SetXFilter | Sets the filter for second entity, called a cross filter.

Public Properties

Public Property CaseSensitive | Indicates if the filter for the specified field is case sensitive. The default is False.
Public Property DataType | The filtered entity type.
Public Property Fields | The list of fields for the TDFilter's parent object.
Public Property Filter | The filter condition for the field specified by the FieldName.
Public Property Order | The position of the specified field in the list of the sort fields. (zero-based)
Public Property OrderDirection | The sort order: TDOLE_ASCENDING or TDOLE_DESCENDING
Public Property Text | The full fields filter as text.
Public Property XFilter | The cross filter according to the entity type.


%%PageItemTitle%%

ITDFilter2 Interface

Clear Method

Description

Clears the current filter.

Syntax

Public Sub Clear()

See Also

ITDFilter2 Interface


%%PageItemTitle%%

ITDFilter2 Interface

CrossEntities

Possible values: BUG-ALERT, BUG-REQ, BUG-TEST, BUG-TESTSET, REQ-ALERT, REQ-BUG, REQ-TEST, REQ-TO-FROM-REQ, RUN-BUG, TEST-ALERT, TEST-BUG, TEST-INSTANCE-ALERT, TEST-REQ, TEST-TESTSET, TEST-VER_CTRL, TESTCYCL-ALERT,
TESTSET-BUG, TESTSET-TEST, TSTEST-BUG, TSTEST-REQ, TSTEST-TEST-TEQ, and TSTEST-TSTEST-REQ.

Inclusive

Output variable.

If True, the filter specifies the set of objects where the conditions for the first entity and for the second entity are all true.

If False, the filter specifies the set of objects where the conditions for the first entity are true and the conditions for the second entity are not true.

See Also OTA COM Type Library

GetXFilter Method

Description

Gets the cross filter specified by CrossEntities.

Syntax

Public Function GetXFilter( _
   ByVal CrossEntities As String, _
   ByRef Inclusive As Boolean _
) As String

Parameters

CrossEntities

Possible values: BUG-ALERT, BUG-REQ, BUG-TEST, BUG-TESTSET, REQ-ALERT, REQ-BUG, REQ-TEST, REQ-TO-FROM-REQ, RUN-BUG, TEST-ALERT, TEST-BUG, TEST-INSTANCE-ALERT, TEST-REQ, TEST-TESTSET, TEST-VER_CTRL, TESTCYCL-ALERT,
TESTSET-BUG, TESTSET-TEST, TSTEST-BUG, TSTEST-REQ, TSTEST-TEST-TEQ, and TSTEST-TSTEST-REQ.

Inclusive

Output variable.

If True, the filter specifies the set of objects where the conditions for the first entity and for the second entity are all true.

If False, the filter specifies the set of objects where the conditions for the first entity are true and the conditions for the second entity are not true.

Return Type

The text representation of the filter.

See Also

ITDFilter2 Interface


%%PageItemTitle%%

ITDFilter2 Interface

IsClear Method

Description

Checks whether the filter is clear, including cross-filter settings

Syntax

Public Function IsClear() As Boolean

See Also

ITDFilter2 Interface


%%PageItemTitle%%

ITDFilter2 Interface

NewList Method

Description

Creates a new list from current filter.

Syntax

Public Function NewList() As List

See Also

ITDFilter2 Interface


%%PageItemTitle%%

ITDFilter2 Interface

Refresh Method

Description

Reads saved data and refreshes the fetched list according to the current filter, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ITDFilter2 Interface


%%PageItemTitle%%

ITDFilter2 Interface

CrossEntities

Possible values: BUG-ALERT, BUG-REQ, BUG-TEST, BUG-TESTSET, REQ-ALERT, REQ-BUG, REQ-TEST, REQ-TO-FROM-REQ, RUN-BUG, TEST-ALERT, TEST-BUG, TEST-INSTANCE-ALERT, TEST-REQ, TEST-TESTSET, TEST-VER_CTRL, TESTCYCL-ALERT,
TESTSET-BUG, TESTSET-TEST, TSTEST-BUG, TSTEST-REQ, TSTEST-TEST-TEQ, and TSTEST-TSTEST-REQ.

Inclusive

If True, the filter specifies the set of objects where the conditions for the first entity and for the second entity are all true.

If False, the filter specifies the set of objects where the conditions for the first entity are true and the conditions for the second entity are not true.

FilterText

A TDFilter.Text or a string that would be a valid TDFilter.Text

See Also OTA COM Type Library

SetXFilter Method

Description

Sets the filter for second entity, called a cross filter.

Syntax

Public Sub SetXFilter( _
   ByVal CrossEntities As String, _
   ByVal Inclusive As Boolean, _
   ByVal FilterText As String _
)

Parameters

CrossEntities

Possible values: BUG-ALERT, BUG-REQ, BUG-TEST, BUG-TESTSET, REQ-ALERT, REQ-BUG, REQ-TEST, REQ-TO-FROM-REQ, RUN-BUG, TEST-ALERT, TEST-BUG, TEST-INSTANCE-ALERT, TEST-REQ, TEST-TESTSET, TEST-VER_CTRL, TESTCYCL-ALERT,
TESTSET-BUG, TESTSET-TEST, TSTEST-BUG, TSTEST-REQ, TSTEST-TEST-TEQ, and TSTEST-TSTEST-REQ.

Inclusive

If True, the filter specifies the set of objects where the conditions for the first entity and for the second entity are all true.

If False, the filter specifies the set of objects where the conditions for the first entity are true and the conditions for the second entity are not true.

FilterText

A TDFilter.Text or a string that would be a valid TDFilter.Text

Remarks

The best way to ensure that the Filter text is valid, is to create a TDFilter with the cross-filter conditions, and use its Text property as this value.

See Also

ITDFilter2 Interface


%%PageItemTitle%%

ITDFilter2 Interface

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

CaseSensitive Property

Description

Indicates if the filter for the specified field is case sensitive. The default is False.

Property type

Read-write property

Syntax (Visual Basic)

Public Property CaseSensitive( _
   ByVal FieldName As String _
) As Boolean

Parameters

FieldName

The name of the field in the project database.

See Also

ITDFilter2 Interface


%%PageItemTitle%%

ITDFilter2 Interface

DataType Property

Description

The filtered entity type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DataType() As String

See Also

ITDFilter2 Interface


%%PageItemTitle%%

ITDFilter2 Interface

Fields Property

Description

The list of fields for the TDFilter's parent object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

Remarks

The list depends on the factory from which the TDFilter was created. For example, if the filter is created from a TestFactory, the field list will consist of the names of the Test fields: TS_ATTACHMENT, TS_CREATION_DATE, TS_DESCRIPTION, TS_RESPONSIBLE, TS_STATUS, TS_SUBJECT, TS_TEMPLATE, TS_TEST_ID, TS_NAME, and so on.

See Also

ITDFilter2 Interface


%%PageItemTitle%%

ITDFilter2 Interface

FieldName

The name of a field of the entity to which the filter is applied.

Only fields whose FieldProperty.IsCanFilter Property is true can be used.

See Also OTA COM Type Library

Filter Property

Description

The filter condition for the field specified by the FieldName.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Filter( _
   ByVal FieldName As String _
) As String

Parameters

FieldName

The name of a field of the entity to which the filter is applied.

Only fields whose FieldProperty.IsCanFilter Property is true can be used.

Remarks

Although the Filter property has the syntax of a single property, a TDFilter can have a collection of Filter properties, each on a different field. Set the Filter property for one field with each command.

A Filter setting is a value of the field, a value with an operator, or a set of values connected by operators.

The values can be constants, special tokens such as "[Today]", "[PreviousWeek]", or "[NextYear]", or folder names, such as "^Subject\LinkFolder^". Use the set filter dialog in the the relevant module of the Quality Center UI to explore the possibilities.

String values with spaces must be quoted, for example, TestFilter.Filter("TS_EXEC_STATUS") = """No Run"""

The value can be an expression with a wild card. For example, testsetFilter.Filter("CY_CYCLE") = "GS*" filters for all test sets whose names begin with "GS".

See Also

ITDFilter2 Interface


%%PageItemTitle%%

ITDFilter2 Interface

FieldName

The name of the database field whose sort priority is to be retrieved or set.

See Also OTA COM Type Library

Order Property

Description

The position of the specified field in the list of the sort fields. (zero-based)

Property type

Read-write property

Syntax (Visual Basic)

Public Property Order( _
   ByVal FieldName As String _
) As Long

Parameters

FieldName

The name of the database field whose sort priority is to be retrieved or set.

Remarks

When the order of one field is set with this property, no adjustments are made to the positions of other fields. The application is responsible for ensuring that the orders of all the fields are as required, that no two fields occupy the same position, and there are no empty positions.

When two or more fields are assigned the same order, the actual order is undetermined.

See Also

ITDFilter2 Interface


%%PageItemTitle%%

ITDFilter2 Interface

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

OrderDirection Property

Description

The sort order: TDOLE_ASCENDING or TDOLE_DESCENDING

Property type

Read-write property

Syntax (Visual Basic)

Public Property OrderDirection( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName

The name of the field in the project database.

See Also

ITDFilter2 Interface


%%PageItemTitle%%

ITDFilter2 Interface

Text Property

Description

The full fields filter as text.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Text() As String

Remarks

In most places where a string-type Filter argument is passed to a method that selects items, for example to create a filtered list, it is this Text property that is passed to the method.

This text is displayed in the Quality Center user interface above the grid when a filter is set.

See Also

ITDFilter2 Interface


%%PageItemTitle%%

ITDFilter2 Interface

CrossEntity

Possible values: BUG-ALERT, BUG-REQ, BUG-TEST, BUG-TESTSET, REQ-ALERT, REQ-BUG, REQ-TEST, REQ-TO-FROM-REQ, RUN-BUG, TEST-ALERT, TEST-BUG, TEST-INSTANCE-ALERT, TEST-REQ, TEST-TESTSET, TEST-VER_CTRL, TESTCYCL-ALERT,
TESTSET-BUG, TESTSET-TEST, TSTEST-BUG, TSTEST-REQ, TSTEST-TEST-TEQ, and TSTEST-TSTEST-REQ.

See Also OTA COM Type Library

XFilter Property

Description

The cross filter according to the entity type.

Property type

Read-write property

Syntax (Visual Basic)

Public Property XFilter( _
   ByVal CrossEntity As String _
) As String

Parameters

CrossEntity

Possible values: BUG-ALERT, BUG-REQ, BUG-TEST, BUG-TESTSET, REQ-ALERT, REQ-BUG, REQ-TEST, REQ-TO-FROM-REQ, RUN-BUG, TEST-ALERT, TEST-BUG, TEST-INSTANCE-ALERT, TEST-REQ, TEST-TESTSET, TEST-VER_CTRL, TESTCYCL-ALERT,
TESTSET-BUG, TESTSET-TEST, TSTEST-BUG, TSTEST-REQ, TSTEST-TEST-TEQ, and TSTEST-TSTEST-REQ.

Remarks

Setting this property is equivalent to calling SetXFilter with Inclusive = TRUE.

See Also

ITDFilter2 Interface


%%PageItemTitle%%

ITDMailConditions Members

ITDMailConditions Interface

Description

Services for managing automatic mail notifications.

Remarks

Automatic mail notification is sent when a defect changes and there is a mail condition defined for the change.
A condition consists of two parameters:

  • Mail recipient - specifies who will be receiving the notification
  • Defect matching rule - a filter string, generally a TDFilter.Text

There are two ways to specify a mail recipient: direct and indirect.
To specify a recipient directly, use the user name.
To specify a recipient indirectly, use the name of field that holds the user name. Indirect recipient specifications can only use the Detected By (BG_DETECTED_BY) and Assigned To (BG_RESPONSIBLE) fields.

The TDMailConditions object for the connection is TDConnection.MailConditions.

Public Methods

Public Method Close | Closes and updates Mail Condition.
Public Method DeleteCondition | Deletes the Mail Condition.
Public Method Load | Loads Mail Conditions.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Condition | The defect-matching rule.
Public Property IsLocked | Checks if object is locked.
Public Property ItemList | Gets the list of Mail Condition Users.


%%PageItemTitle%%

ITDMailConditions Interface

NeedToSave

If true, post changes to project when Close is called.

See Also OTA COM Type Library

Close Method

Description

Closes and updates Mail Condition.

Syntax

Public Sub Close( _
   ByVal NeedToSave As Boolean _
)

Parameters

NeedToSave

If true, post changes to project when Close is called.

See Also

ITDMailConditions Interface


%%PageItemTitle%%

ITDMailConditions Interface

Name

Either a user name or a field name.

IsUserCondition

Pass True if Name specifies a user name. Pass False if Name specifies a field.

See Also OTA COM Type Library

DeleteCondition Method

Description

Deletes the Mail Condition.

Syntax

Public Sub DeleteCondition( _
   ByVal Name As String, _
   ByVal IsUserCondition As Boolean _
)

Parameters

Name

Either a user name or a field name.

IsUserCondition

Pass True if Name specifies a user name. Pass False if Name specifies a field.

See Also

ITDMailConditions Interface


%%PageItemTitle%%

ITDMailConditions Interface

Load Method

Description

Loads Mail Conditions.

Syntax

Public Sub Load()

See Also

ITDMailConditions Interface


%%PageItemTitle%%

ITDMailConditions Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ITDMailConditions Interface


%%PageItemTitle%%

ITDMailConditions Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

ITDMailConditions Interface


%%PageItemTitle%%

ITDMailConditions Interface

Name

The mail recipient.

IsUserCondition

Pass True if Name is a user name. Pass False if Name is the field containing the name.

See Also OTA COM Type Library

Condition Property

Description

The defect-matching rule.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Condition( _
   ByVal Name As String, _
   ByVal IsUserCondition As Boolean _
) As String

Parameters

Name

The mail recipient.

IsUserCondition

Pass True if Name is a user name. Pass False if Name is the field containing the name.

See Also

ITDMailConditions Interface


%%PageItemTitle%%

ITDMailConditions Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

ITDMailConditions Interface


%%PageItemTitle%%

ITDMailConditions Interface

GetRealNames

If True, return only recipients specified directly in the conditions. If False, return all recipients, regardless of how specified.

See Also OTA COM Type Library

ItemList Property

Description

Gets the list of Mail Condition Users.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ItemList( _
   Optional ByVal GetRealNames As Boolean = False _
) As List

Parameters

GetRealNames

If True, return only recipients specified directly in the conditions. If False, return all recipients, regardless of how specified.

See Also

ITDMailConditions Interface


%%PageItemTitle%%

ITest Members

ITest Interface

Description

Represents a planning test.

Example

Get a test object from a TestFactory.

Public Methods

Public Method CoverRequirement | Adds the specified requirement to the list of requirements covered by this test.
Public Method GetCoverList | Gets the list of all requirements covered by this test.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Mail | Mails the IBaseFieldExMail field item.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method RemoveCoverage | Removes a requirement from the list of requirements this test covers.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property CheckoutPathIfExist | The checkout path for the test.
Public Property DesignStepFactory | The design steps factory for the current test.
Public Property DesStepsNum | The number of design steps in the test.
Public Property ExecDate | The test execution date and time.
Public Property ExecStatus | The test execution status.
Public Property ExtendedStorage | The Extended Storage object for the current test.
Public Property Field | The value of the specified field.
Public Property FullPath | The full file system path for the test.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property HasCoverage | Checks if the test covers at least one requirement.
Public Property HasParam | Checks if the test has at least one parameter.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property LastRun | The last Run object for this test.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The test name.
Public Property Params | The current test parameters.
Public Property TemplateTest | Indicates if this test is a template test.
Public Property Type | The test type.
Public Property VCS | The VCS version control object for this test.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

ITest Interface

Req

A requirement ID or a Req Object.

Order

Not in use. Pass TDAPI_POS_ORDER.TDPOSITION_LAST [-4] .

Recursive

If true, all child requirements will be covered by this test.

See Also OTA COM Type Library

CoverRequirement Method

Description

Adds the specified requirement to the list of requirements covered by this test.

Syntax

Public Function CoverRequirement( _
   ByVal Req As Variant, _
   ByVal Order As Long, _
   ByVal Recursive As Boolean _
) As Long

Parameters

Req

A requirement ID or a Req Object.

Order

Not in use. Pass TDAPI_POS_ORDER.TDPOSITION_LAST [-4] .

Recursive

If true, all child requirements will be covered by this test.

Return Type

Not in use. Ignore return value.

See Also

ITest Interface


%%PageItemTitle%%

ITest Interface

GetCoverList Method

Description

Gets the list of all requirements covered by this test.

Syntax

Public Function GetCoverList() As List

Return Type

A list of Req Objects.

See Also

ITest Interface


%%PageItemTitle%%

ITest Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ITest Interface


%%PageItemTitle%%

ITest Interface

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also OTA COM Type Library

Mail Method

Description

Mails the IBaseFieldExMail field item.

Syntax

Public Sub Mail( _
   ByVal SendTo As String, _
   Optional ByVal SendCc As String = "", _
   Optional ByVal Option As Long = 0, _
   Optional ByVal Subject As String = "", _
   Optional ByVal Comment As String = "" _
)

Parameters

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also

ITest Interface


%%PageItemTitle%%

ITest Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ITest Interface


%%PageItemTitle%%

ITest Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ITest Interface


%%PageItemTitle%%

ITest Interface

Req

The Req Object representing the requirement that this test will no longer cover.

See Also OTA COM Type Library

RemoveCoverage Method

Description

Removes a requirement from the list of requirements this test covers.

Syntax

Public Sub RemoveCoverage( _
   ByVal Req As Variant _
)

Parameters

Req

The Req Object representing the requirement that this test will no longer cover.

See Also

ITest Interface


%%PageItemTitle%%

ITest Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

ITest Interface


%%PageItemTitle%%

ITest Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

ITest Interface


%%PageItemTitle%%

ITest Interface

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

ITest Interface


%%PageItemTitle%%

ITest Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

ITest Interface


%%PageItemTitle%%

ITest Interface

CheckoutPathIfExist Property

Description

The checkout path for the test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property CheckoutPathIfExist() As String

Remarks

If the project is not under version control or if the object is not checked out, then the checkout path is not defined. In that case, the method returns NULL.

See Also

ITest Interface


%%PageItemTitle%%

ITest Interface

DesignStepFactory Property

Description

The design steps factory for the current test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DesignStepFactory() As Object

See Also

ITest Interface


%%PageItemTitle%%

ITest Interface

DesStepsNum Property

Description

The number of design steps in the test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DesStepsNum() As Long

See Also

ITest Interface


%%PageItemTitle%%

ITest Interface

ExecDate Property

Description

The test execution date and time.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExecDate() As Date

See Also

ITest Interface


%%PageItemTitle%%

ITest Interface

ExecStatus Property

Description

The test execution status.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExecStatus() As String

See Also

ITest Interface


%%PageItemTitle%%

ITest Interface

ExtendedStorage Property

Description

The Extended Storage object for the current test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExtendedStorage() As Object

See Also

ITest Interface


%%PageItemTitle%%

ITest Interface

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName

The name of the field in the project database.

Remarks

If the field name is "TS_SUBJECT", a SubjectNode Object is returned.

See Also

ITest Interface


%%PageItemTitle%%

ITest Interface

FullPath Property

Description

The full file system path for the test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FullPath() As String

See Also

ITest Interface


%%PageItemTitle%%

ITest Interface

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

ITest Interface


%%PageItemTitle%%

ITest Interface

HasCoverage Property

Description

Checks if the test covers at least one requirement.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasCoverage() As Boolean

See Also

ITest Interface


%%PageItemTitle%%

ITest Interface

HasParam Property

Description

Checks if the test has at least one parameter.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasParam() As Boolean

See Also

ITest Interface


%%PageItemTitle%%

ITest Interface

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

ITest Interface


%%PageItemTitle%%

ITest Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

ITest Interface


%%PageItemTitle%%

ITest Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

ITest Interface


%%PageItemTitle%%

ITest Interface

LastRun Property

Description

The last Run object for this test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property LastRun() As Object

See Also

ITest Interface


%%PageItemTitle%%

ITest Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

ITest Interface


%%PageItemTitle%%

ITest Interface

Name Property

Description

The test name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ITest Interface


%%PageItemTitle%%

ITest Interface

Params Property

Description

The current test parameters.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Params() As Object

See Also

ITest Interface


%%PageItemTitle%%

ITest Interface

TemplateTest Property

Description

Indicates if this test is a template test.

Property type

Read-write property

Syntax (Visual Basic)

Public Property TemplateTest() As Boolean

See Also

ITest Interface


%%PageItemTitle%%

ITest Interface

Type Property

Description

The test type.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Type() As String

Remarks

The test type is either a native Quality Center type or a custom test type. Examples of native test types are BUSINESS-PROCESS, LR-SCENARIO, MANUAL, QUICKTEST_TEST, and SYSTEM-TEST.

See Also

ITest Interface


%%PageItemTitle%%

ITest Interface

VCS Property

Description

The VCS version control object for this test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property VCS() As Object

See Also

ITest Interface


%%PageItemTitle%%

ITest Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

ITest Interface


%%PageItemTitle%%

ITestExecStatus Members

ITestExecStatus Interface

Description

Represents the execution status of the test currently running.

Remarks

This object contains properties only for the test currently running. The TSScheduler ExecutionStatus Property is a reference to an ExecutionStatus object for the whole running session. Iterate through the ExecutionStatus object to get the test execution status for each test, or use the ExecutionStatus.Item Property.

Public Properties

Public Property Message | The test execution message displayed in the Execution Controller grid.
Public Property Status | The test execution status.
Public Property TestId | The test Id.
Public Property TestInstance | The number of this instance of the design test in the test set.
Public Property TSTestId | The ID of the test instance for the current run.


%%PageItemTitle%%

ITestExecStatus Interface

Message Property

Description

The test execution message displayed in the Execution Controller grid.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Message() As String

See Also

ITestExecStatus Interface


%%PageItemTitle%%

ITestExecStatus Interface

Status Property

Description

The test execution status.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Status() As String

See Also

ITestExecStatus Interface


%%PageItemTitle%%

ITestExecStatus Interface

TestId Property

Description

The test Id.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestId() As Long

See Also

ITestExecStatus Interface


%%PageItemTitle%%

ITestExecStatus Interface

TestInstance Property

Description

The number of this instance of the design test in the test set.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestInstance() As Long

Remarks

For example, if a Test is used four times in a test set, TestInstance is a number from 1 to 4, depending on which instance is running.

See Also

ITestExecStatus Interface


%%PageItemTitle%%

ITestExecStatus Interface

TSTestId Property

Description

The ID of the test instance for the current run.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TSTestId() As Variant

See Also

ITestExecStatus Interface


%%PageItemTitle%%

ITestFactory Members

ITestFactory Interface

Description

Services for managing tests.

Remarks

Get a TestFactory object from TDConnection.TestFactory or SubjectNode.TestFactory

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Public Methods

Public Method AddItem | Creates a new item object.
Public Method BuildPerfGraph | Creates Performance Graph.
Public Method BuildProgressGraph | Creates graph showing number of tests in a test set executed over a period of time.
Public Method BuildProgressGraphEx | Creates graph showing number of tests in a test set executed over a period of time.
Public Method BuildSummaryGraph | Creates summary graph showing number of tests executed in a test set according to test and test run.
Public Method BuildTrendGraph | Creates graph that shows the number of defect status changes over time.
Public Method Mail | Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.
Public Property RepositoryStorage | An ExtendedStorage object connected by default to the test repository folder on the server side. Enables file system operations with a test repository.


%%PageItemTitle%%

ITestFactory Interface

ItemData

There are three options for ItemData:

  • Null. Initially creating a virtual Test object with Null ensures that you cannot then Post until all required fields are initialized.
  • The test name.
  • An array consisting of the following elements:

(0) Name - The test name (required).

(1) Type - The test type (string, optional). The possible test types are detailed in the table below.

(2) Tester - The name of the user that created the test (string, optional). The default value is the name of the user currently logged in (string, optional).

(3) SubjectID - The ID of the subject folder in which to create the test (long, optional).

See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData

There are three options for ItemData:

  • Null. Initially creating a virtual Test object with Null ensures that you cannot then Post until all required fields are initialized.
  • The test name.
  • An array consisting of the following elements:

(0) Name - The test name (required).

(1) Type - The test type (string, optional). The possible test types are detailed in the table below.

(2) Tester - The name of the user that created the test (string, optional). The default value is the name of the user currently logged in (string, optional).

(3) SubjectID - The ID of the subject folder in which to create the test (long, optional).

Return Type

A Test Object.

Remarks

Test Types
Test Type | Description
MANUAL | Default. A Quality Center manual test.
WR-AUTOMATED | A WinRunner automated test.
WR-BATCH | A WinRunner batch test.
LR-SCENARIO | A LoadRunner simulated environment test.
XR-AUTOMATED | An XRunner automated test.
QUICKTEST_TEST | An Astra QuickTest or QuickTest Professional test.
QTSAP-TESTCASE | A QuickTest Professional for MySAP.com Windows Client test.
VAPI-XP-TEST | A test to be performed by the Quality Center Visual API-XP test execution tool.
SYSTEM-TEST | A test involving system actions.
DB-TEST | A Vuser script test.

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

[Visual Basic]

Dim bgf As BugFactory
Dim bg As Bug
Dim attf As AttachmentFactory
Dim att As Attachment
Dim attList As List

' Get the factory object
 Set bgf = tdc.BugFactory
' Use defect #1
 Set bg = bgf.Item(1)
 Set attf = bg.Attachments

' Creating a new attachment
' Create virtual object, then populate the properties
 Set att = attf.AddItem(Null)
 att.FileName = Text1.Text
 att.Type = TDATT_INTERNET

' Saving the object with validity check
 att.Post

' Display the attachments
' Add the display-only items without a Post
 List1.Clear
 Set attList = attf.NewList("")
 For i = 1 To attList.Count

      Set att = attList.Item(i)
      List1.AddItem (att.Name)

 Next

See Also

ITestFactory Interface


%%PageItemTitle%%

ITestFactory Interface

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildPerfGraph Method

Description

Creates Performance Graph.

Syntax

Public Function BuildPerfGraph( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

ITestFactory Interface


%%PageItemTitle%%

ITestFactory Interface

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildProgressGraph Method

Description

Creates graph showing number of tests in a test set executed over a period of time.

Syntax

Public Function BuildProgressGraph( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MajorSkip As Long = 0, _
   Optional ByVal MinorSkip As Long = 1, _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

ITestFactory Interface


%%PageItemTitle%%

ITestFactory Interface

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

ByHistory

Determines whether to use history information to create the graph. Possible values are:

TRUE - Use history information.

FALSE - Do not use history information.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. Zero indicates no limit.

Filter

The TDFilter Object that sets the criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildProgressGraphEx Method

Description

Creates graph showing number of tests in a test set executed over a period of time.

Syntax

Public Function BuildProgressGraphEx( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal ByHistory As Boolean = True, _
   Optional ByVal MajorSkip As Long = 0, _
   Optional ByVal MinorSkip As Long = 1, _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

ByHistory

Determines whether to use history information to create the graph. Possible values are:

TRUE - Use history information.

FALSE - Do not use history information.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. Zero indicates no limit.

Filter

The TDFilter Object that sets the criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

ITestFactory Interface


%%PageItemTitle%%

ITestFactory Interface

XAxisField

A database field representing the name of the graph x-axis.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildSummaryGraph Method

Description

Creates summary graph showing number of tests executed in a test set according to test and test run.

Syntax

Public Function BuildSummaryGraph( _
   Optional ByVal XAxisField As String = "", _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

XAxisField

A database field representing the name of the graph x-axis.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

ITestFactory Interface


%%PageItemTitle%%

ITestFactory Interface

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildTrendGraph Method

Description

Creates graph that shows the number of defect status changes over time.

Syntax

Public Function BuildTrendGraph( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

ITestFactory Interface


%%PageItemTitle%%

ITestFactory Interface

Items

A list of IDs.

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also OTA COM Type Library

Mail Method

Description

Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.

Syntax

Public Sub Mail( _
   ByVal Items As Variant, _
   ByVal SendTo As String, _
   Optional ByVal SendCc As String = "", _
   Optional ByVal Option As Long = 0, _
   Optional ByVal Subject As String = "", _
   Optional ByVal Comment As String = "" _
)

Parameters

Items

A list of IDs.

SendTo

A Quality Center user name, an e-mail address (not necessarily a Quality Center user), or a list of e-mail addresses.
Addresses can be separated by a comma or a semi-colon.

SendCc

The recipients of a carbon copy of the mail. Addresses can be separated by a comma or a semicolon.

Option

The mailing options binary mask.
Create the mask using values of TDMAIL_FLAGS.

Subject

The mail subject line.

Comment

A comment on the sent e-mail. If the TDMAIL_COMMENT_AS_BODY option is set, this will be sent as the message body.

See Also

ITestFactory Interface


%%PageItemTitle%%

ITestFactory Interface

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

ITestFactory Interface


%%PageItemTitle%%

ITestFactory Interface

ItemKey

The Test.ID (long), a reference to the Test Object, or a Variant array of Test.IDs.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey

The Test.ID (long), a reference to the Test Object, or a Variant array of Test.IDs.

See Also

ITestFactory Interface


%%PageItemTitle%%

ITestFactory Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

ITestFactory Interface


%%PageItemTitle%%

ITestFactory Interface

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

ITestFactory Interface


%%PageItemTitle%%

ITestFactory Interface

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

Remarks

When TS_SUBJECT is used as one of the filter fields, the subject is the full path to the test in the tree, including the root node. For example:

TestFilter.Filter("TS_SUBJECT") = "Subject\Folder1\Subfolder2"

See Also

ITestFactory Interface


%%PageItemTitle%%

ITestFactory Interface

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

ITestFactory Interface


%%PageItemTitle%%

ITestFactory Interface

ItemKey

A long integer.

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey

A long integer.

See Also

ITestFactory Interface


%%PageItemTitle%%

ITestFactory Interface

RepositoryStorage Property

Description

An ExtendedStorage object connected by default to the test repository folder on the server side. Enables file system operations with a test repository.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RepositoryStorage() As Object

See Also

ITestFactory Interface


%%PageItemTitle%%

ITestSet Members

ITestSet Interface

Description

Represents a series of tests to be run as a group to meet a specific testing goal.

Remarks

Get a TestSet object from a TestSetFactory.

Public Methods

Public Method BuildPerfGraph | Creates Performance Graph.
Public Method BuildProgressGraph | Builds test set progress graph.
Public Method BuildProgressGraphEx | Builds test set progress graph.
Public Method BuildSummaryGraph | Builds test set summary graph.
Public Method BuildTrendGraph | Creates graph that shows the test set changes over time.
Public Method CheckTestInstances | Gets information about the instances of the specified test in this test set.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method PurgeExecutions | Purges all the running executions within the test set.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method ResetTestSet | Sets the status of each test in the test set to 'No Run'.
Public Method StartExecution | Starts the execution controller.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property ConditionFactory | The condition factory object for the current test set.
Public Property ExecEventNotifyByMailSettings | Gets the execution mail notification settings for the current test set.
Public Property ExecutionSettings | Gets the execution settings for the test set.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The test set name.
Public Property Status | The test set status.
Public Property TestDefaultExecutionSettings | Gets default execution settings for tests.
Public Property TestSetFolder | The test set's parent node.
Public Property TSTestFactory | The factory object for the current test set.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

ITestSet Interface

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildPerfGraph Method

Description

Creates Performance Graph.

Syntax

Public Function BuildPerfGraph( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

ITestSet Interface


%%PageItemTitle%%

ITestSet Interface

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildProgressGraph Method

Description

Builds test set progress graph.

Syntax

Public Function BuildProgressGraph( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MajorSkip As Long = 0, _
   Optional ByVal MinorSkip As Long = 1, _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

ITestSet Interface


%%PageItemTitle%%

ITestSet Interface

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

ByHistory

Determines whether to use history information to create the graph. Possible values are:

TRUE - Use history information.

FALSE - Do not use history information.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. Zero indicates no limit.

Filter

The TDFilter Object that sets the criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildProgressGraphEx Method

Description

Builds test set progress graph.

Syntax

Public Function BuildProgressGraphEx( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal ByHistory As Boolean = True, _
   Optional ByVal MajorSkip As Long = 0, _
   Optional ByVal MinorSkip As Long = 1, _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

ByHistory

Determines whether to use history information to create the graph. Possible values are:

TRUE - Use history information.

FALSE - Do not use history information.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. Zero indicates no limit.

Filter

The TDFilter Object that sets the criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

ITestSet Interface


%%PageItemTitle%%

ITestSet Interface

XAxisField

A database field representing the name of the graph x-axis.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildSummaryGraph Method

Description

Builds test set summary graph.

Syntax

Public Function BuildSummaryGraph( _
   Optional ByVal XAxisField As String = "", _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

XAxisField

A database field representing the name of the graph x-axis.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

ITestSet Interface


%%PageItemTitle%%

ITestSet Interface

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildTrendGraph Method

Description

Creates graph that shows the test set changes over time.

Syntax

Public Function BuildTrendGraph( _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

ITestSet Interface


%%PageItemTitle%%

ITestSet Interface

TestIDs

A Test.ID or a comma-separated list of IDs.

See Also OTA COM Type Library

CheckTestInstances Method

Description

Gets information about the instances of the specified test in this test set.

Syntax

Public Function CheckTestInstances( _
   ByVal TestIDs As String _
) As String

Parameters

TestIDs

A Test.ID or a comma-separated list of IDs.

Return Type

For each Test ID, an output line of format:

{NUM_OF_INSTANCES:<count>, TS_TEST_ID:<ID number>, TS_NAME:<name>, TS_TYPE:<type>, TS_STEPS:<step count>, TS_TEMPLATE:<template name> }

See Also

ITestSet Interface


%%PageItemTitle%%

ITestSet Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ITestSet Interface


%%PageItemTitle%%

ITestSet Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ITestSet Interface


%%PageItemTitle%%

ITestSet Interface

PurgeExecutions Method

Description

Purges all the running executions within the test set.

Syntax

Public Sub PurgeExecutions()

See Also

ITestSet Interface


%%PageItemTitle%%

ITestSet Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ITestSet Interface


%%PageItemTitle%%

ITestSet Interface

DeleteRuns

If TRUE, the method deletes all runs for all tests in the test set.

See Also OTA COM Type Library

ResetTestSet Method

Description

Sets the status of each test in the test set to 'No Run'.

Syntax

Public Sub ResetTestSet( _
   ByVal DeleteRuns As Boolean _
)

Parameters

DeleteRuns

If TRUE, the method deletes all runs for all tests in the test set.

See Also

ITestSet Interface


%%PageItemTitle%%

ITestSet Interface

ServerName

The name of the host for the scheduler. If an empty string is passed, localhost is used.

See Also OTA COM Type Library

StartExecution Method

Description

Starts the execution controller.

Syntax

Public Function StartExecution( _
   ByVal ServerName As String _
) As Object

Parameters

ServerName

The name of the host for the scheduler. If an empty string is passed, localhost is used.

Return Type

A TSScheduler Object.

Remarks

The scheduler server is not necessarily the machine on which the tests will run, only the machine on which the scheduler runs. The remote test execution hosts can be set with properties of the TSScheduler Object.

The TSScheduler can perform only one run. If you want to perform more than one run, then after calling TSScheduler.Run, call this method again to get a new TSScheduler object.

See Also

ITestSet Interface


%%PageItemTitle%%

ITestSet Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

ITestSet Interface


%%PageItemTitle%%

ITestSet Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

ITestSet Interface


%%PageItemTitle%%

ITestSet Interface

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

ITestSet Interface


%%PageItemTitle%%

ITestSet Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

ITestSet Interface


%%PageItemTitle%%

ITestSet Interface

ConditionFactory Property

Description

The condition factory object for the current test set.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ConditionFactory() As Object

See Also

ITestSet Interface


%%PageItemTitle%%

ITestSet Interface

ExecEventNotifyByMailSettings Property

Description

Gets the execution mail notification settings for the current test set.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExecEventNotifyByMailSettings() As Object

See Also

ITestSet Interface


%%PageItemTitle%%

ITestSet Interface

ExecutionSettings Property

Description

Gets the execution settings for the test set.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExecutionSettings() As Object

See Also

ITestSet Interface


%%PageItemTitle%%

ITestSet Interface

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName

The name of the field in the project database.

See Also

ITestSet Interface


%%PageItemTitle%%

ITestSet Interface

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

ITestSet Interface


%%PageItemTitle%%

ITestSet Interface

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

ITestSet Interface


%%PageItemTitle%%

ITestSet Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

ITestSet Interface


%%PageItemTitle%%

ITestSet Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

ITestSet Interface


%%PageItemTitle%%

ITestSet Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

ITestSet Interface


%%PageItemTitle%%

ITestSet Interface

Name Property

Description

The test set name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ITestSet Interface


%%PageItemTitle%%

ITestSet Interface

Status Property

Description

The test set status.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Status() As String

Remarks

The status is a value from the project Status list :

  • NO_RUN - Default. The test was never executed.
  • NOT_COMPLETED - Execution of the test has not been completed.
  • FAILED - The test failed.
  • PASSED - The test passed.
  • N/A - The status is not available.

  • A user-defined status

You can create user-defined statuses by customizing the Status list. For more information, see 'Customizing Project Lists' in the Mercury Quality Center Administrator's Guide.

See Also

ITestSet Interface


%%PageItemTitle%%

ITestSet Interface

TestDefaultExecutionSettings Property

Description

Gets default execution settings for tests.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestDefaultExecutionSettings() As Object

See Also

ITestSet Interface


%%PageItemTitle%%

ITestSet Interface | TestSetFolder Object

TestSetFolder Property

Description

The test set's parent node.

Property type

Read-write property

Syntax (Visual Basic)

Public Property TestSetFolder() As Object

Remarks

Setting this property moves the test set to another folder.

See Also

ITestSet Interface | TestSetFolder Object


%%PageItemTitle%%

ITestSet Interface

TSTestFactory Property

Description

The factory object for the current test set.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TSTestFactory() As Object

See Also

ITestSet Interface


%%PageItemTitle%%

ITestSet Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

ITestSet Interface


%%PageItemTitle%%

ITestSetFactory Members

ITestSetFactory Interface

Description

Services for managing test sets.

Remarks

The TestSetFactory for the connection is TDConnection.TestSetFactory.

Interface Remarks

The IBaseFactory Interface defines basic factory behaviors, such as adding and removing factory child objects (entities), and creating lists of child objects. IBaseFactory is implemented directly by many factory objects, such as AttachmentFactory, ConditionFactory, DesignStepFactory, HostFactory, HostGroupFactory, RunFactory, StepFactory, TSTestFactory, TestSetFactory. It is implemented indirectly by objects that implement IBaseFactoryEx.

Public Methods

Public Method AddItem | Creates a new item object.
Public Method BuildPerfGraph | Creates Performance Graph.
Public Method BuildProgressGraph | Creates graph showing number of tests in all test sets executed over a period of time.
Public Method BuildProgressGraphEx | Creates progress graph for specified test set.
Public Method BuildSummaryGraph | Creates a summary graph of test instances in a test set.
Public Method BuildTrendGraph | Creates graph showing the number of status changes over a time period.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.


%%PageItemTitle%%

ITestSetFactory Interface

ItemData

There are three options for ItemData:

  • Null. Creating a virtual TestSet object with Null ensures that you cannot then Post until all required fields are initialized.
  • The test set name.
  • An array consisting of the following elements:

    (0) Name - The test set name (string, required).

    (1) Test set ID - The ID of the test set folder in which to create the test set (long, optional).

See Also OTA COM Type Library

AddItem Method

Description

Creates a new item object.

Syntax

Public Function AddItem( _
   ByVal ItemData As Variant _
) As Object

Parameters

ItemData

There are three options for ItemData:

  • Null. Creating a virtual TestSet object with Null ensures that you cannot then Post until all required fields are initialized.
  • The test set name.
  • An array consisting of the following elements:

    (0) Name - The test set name (string, required).

    (1) Test set ID - The ID of the test set folder in which to create the test set (long, optional).

Return Type

A TestSet Object.

Remarks

Passing NULL as the ItemData argument creates a virtual object, one that does not appear in the project database. After creating the item, use the relevant object properties to fill the object, then use the Post method to save the object in the database.

This is the recommended technique for creating most objects that will be saved in the database. Exceptions are noted where appropriate in the specific factory object descriptions.

You can also pass an ItemData argument identifying the item to be added. When this syntax is used, no check is performed on whether all required fields have been initialized. This is safe when the item is never going to be added to the database, as in populating a list for display.

Example

This example uses a BugFactory object to illustrate the use of IBaseFactory.AddItem

[Visual Basic]

Dim bgf As BugFactory
Dim bg As Bug
Dim attf As AttachmentFactory
Dim att As Attachment
Dim attList As List

' Get the factory object
 Set bgf = tdc.BugFactory
' Use defect #1
 Set bg = bgf.Item(1)
 Set attf = bg.Attachments

' Creating a new attachment
' Create virtual object, then populate the properties
 Set att = attf.AddItem(Null)
 att.FileName = Text1.Text
 att.Type = TDATT_INTERNET

' Saving the object with validity check
 att.Post

' Display the attachments
' Add the display-only items without a Post
 List1.Clear
 Set attList = attf.NewList("")
 For i = 1 To attList.Count

      Set att = attList.Item(i)
      List1.AddItem (att.Name)

 Next

See Also

ITestSetFactory Interface


%%PageItemTitle%%

ITestSetFactory Interface

TestSetID

The test set ID.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildPerfGraph Method

Description

Creates Performance Graph.

Syntax

Public Function BuildPerfGraph( _
   ByVal TestSetID As Long, _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

TestSetID

The test set ID.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

ITestSetFactory Interface


%%PageItemTitle%%

ITestSetFactory Interface

TestSetID

The test set ID.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildProgressGraph Method

Description

Creates graph showing number of tests in all test sets executed over a period of time.

Syntax

Public Function BuildProgressGraph( _
   ByVal TestSetID As Long, _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MajorSkip As Long = 0, _
   Optional ByVal MinorSkip As Long = 1, _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

TestSetID

The test set ID.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

ITestSetFactory Interface


%%PageItemTitle%%

ITestSetFactory Interface

TestSetID

The test set ID.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

ByHistory

Determines whether to use history information to create the graph. Possible values are:

TRUE - Use history information.

FALSE - Do not use history information.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. Zero indicates no limit.

Filter

The TDFilter Object that sets the criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildProgressGraphEx Method

Description

Creates progress graph for specified test set.

Syntax

Public Function BuildProgressGraphEx( _
   ByVal TestSetID As Long, _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal ByHistory As Boolean = True, _
   Optional ByVal MajorSkip As Long = 0, _
   Optional ByVal MinorSkip As Long = 1, _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

TestSetID

The test set ID.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

ByHistory

Determines whether to use history information to create the graph. Possible values are:

TRUE - Use history information.

FALSE - Do not use history information.

MajorSkip

Determines the interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MinorSkip

Determines the second level interval type shown in the graph. Use the values of tagTDAPI_SKIP Enumeration.

MaxCols

The maximum number of groups represented in the graph. Zero indicates no limit.

Filter

The TDFilter Object that sets the criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

TRUE - The graph is refreshed.

FALSE - The graph is not refreshed

ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

ITestSetFactory Interface


%%PageItemTitle%%

ITestSetFactory Interface

TestSetID

The test set ID.

XAxisField

A database field representing the name of the graph x-axis.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildSummaryGraph Method

Description

Creates a summary graph of test instances in a test set.

Syntax

Public Function BuildSummaryGraph( _
   ByVal TestSetID As Long, _
   Optional ByVal XAxisField As String = "", _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

TestSetID

The test set ID.

XAxisField

A database field representing the name of the graph x-axis.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

ITestSetFactory Interface


%%PageItemTitle%%

ITestSetFactory Interface

TestSetID

The test set ID.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

See Also OTA COM Type Library

BuildTrendGraph Method

Description

Creates graph showing the number of status changes over a time period.

Syntax

Public Function BuildTrendGraph( _
   ByVal TestSetID As Long, _
   Optional ByVal GroupByField As String = "", _
   Optional ByVal SumOfField As String = "", _
   Optional ByVal MaxCols As Long = 0, _
   Optional ByVal Filter As Variant, _
   Optional ByVal FRDate As Variant, _
   Optional ByVal ForceRefresh As Boolean = False, _
   Optional ByVal ShowFullPath As Boolean = False _
) As Object

Parameters

TestSetID

The test set ID.

GroupByField

A database field representing the name of the graph y-axis. All data in the graph is grouped according to this parameter.

SumOfField

For internal use.

MaxCols

The maximum number of groups represented in the graph. A value of 0 signifies no limit.

Filter

A TDFilter Object that sets the filter criteria for the graph.

FRDate

Only items with a change date after this date are reflected in the graph.

ForceRefresh

Determines whether or not to refresh graph data on the server side. Possible values are:

  • TRUE - The graph is refreshed.
  • FALSE - The graph is not refreshed
ShowFullPath

Group instances by name or show individually based on location (path), in the created graph.

A value of True shows the full path of each instance, thus treating them as unique.

Return Type

A new Graph Object.

See Also

ITestSetFactory Interface


%%PageItemTitle%%

ITestSetFactory Interface

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

See Also OTA COM Type Library

NewList Method

Description

Creates a list of objects according to the specified filter.

Syntax

Public Function NewList( _
   ByVal Filter As String _
) As List

Parameters

Filter

A TDFilter.Text defining the criteria for filtering items in the factory. If an empty string is passed, the returned list contains all the child items of the current factory object.

Return Type

A reference to the list created. The list index is 1-based.

See Also

ITestSetFactory Interface


%%PageItemTitle%%

ITestSetFactory Interface

ItemKey

The TestSet.ID (long), a reference to the TestSet Object, or a Variant array of TestSet.IDs.

See Also OTA COM Type Library

RemoveItem Method

Description

Removes item from the database. Removal takes place immediately, without a Post.

Syntax

Public Sub RemoveItem( _
   ByVal ItemKey As Variant _
)

Parameters

ItemKey

The TestSet.ID (long), a reference to the TestSet Object, or a Variant array of TestSet.IDs.

See Also

ITestSetFactory Interface


%%PageItemTitle%%

ITestSetFactory Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

FetchLevel Property

Description

The Fetch level for a field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FetchLevel( _
   ByVal FieldName As String _
) As Integer

Parameters

FieldName
The name of the field in the project database.

See Also

ITestSetFactory Interface


%%PageItemTitle%%

ITestSetFactory Interface

Fields Property

Description

The list of all available fields for the entity managed by the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Fields() As List

See Also

ITestSetFactory Interface


%%PageItemTitle%%

ITestSetFactory Interface

Filter Property

Description

The TDFilter object for the factory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Filter() As Object

See Also

ITestSetFactory Interface


%%PageItemTitle%%

ITestSetFactory Interface

History Property

Description

The History object for this entity.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

ITestSetFactory Interface


%%PageItemTitle%%

ITestSetFactory Interface

ItemKey

A TestSet.ID (long).

See Also OTA COM Type Library

Item Property

Description

Gets an object managed by the factory by its key.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByVal ItemKey As Variant _
) As Object

Parameters

ItemKey

A TestSet.ID (long).

See Also

ITestSetFactory Interface


%%PageItemTitle%%

ITestSetFolder Members

ITestSetFolder Interface

Description

Manages the tests and test sets included in one test set folder.

Remarks

Get a TestSetFolder object from the TestSetTreeManager.

Public Methods

Public Method AddNode | Adds a new child node.
Public Method AddNodeDisp | Adds a new child node.
Public Method FindChildNode | Finds a child node by node name.
Public Method FindChildren | Finds node children according to specified search pattern.
Public Method FindTestSets | Gets the list of test sets contained in the folder that match the specified pattern.
Public Method Move | Moves folder node under new father.
Public Method NewList | Gets a list of the node's immediate children.
Public Method Post | Posts all changed values to the database.
Public Method Refresh | Reads the saved node data, overwriting values in memory.
Public Method RemoveNode | Deletes the specified node.
Public Method RemoveNodeEx | Deletes a test set folder node.

Public Properties

Public Property Attachments | The folder's AttachmentFactory object.
Public Property Attribute | Gets the node attribute.
Public Property Child | Gets a sub-folder of the current folder.
Public Property Count | The number of child nodes.
Public Property DepthType | The sub-tree depth type.
Public Property Description | The test set folder description.
Public Property Father | The current folder's parent folder.
Public Property FatherDisp | The parent node.
Public Property FatherID | The unique parent ID.
Public Property HasAttachment | Checks if this folder has at least one attachment.
Public Property Name | The node name.
Public Property NodeID | The node ID number.
Public Property Path | The folder tree path starting from the tree root.
Public Property SubNodes | The list of child nodes.
Public Property TestSetFactory | Gets the TestSetFactory for the folder.
Public Property ViewOrder | The index of this folder in its parent's list of sub-nodes.


%%PageItemTitle%%

ITestSetFolder Interface

NodeName

The name of the folder to add.

See Also OTA COM Type Library

AddNode Method

Description

Adds a new child node.

Syntax

Public Function AddNode( _
   ByVal NodeName As String _
) As SysTreeNode

Parameters

NodeName

The name of the folder to add.

Return Type

A TestSetFolder.

See Also

ITestSetFolder Interface


%%PageItemTitle%%

ITestSetFolder Interface

NodeName

The name of the folder to add.

See Also OTA COM Type Library

AddNodeDisp Method

Description

Adds a new child node.

Syntax

Public Function AddNodeDisp( _
   ByVal NodeName As String _
) As Object

Parameters

NodeName

The name of the folder to add.

Return Type

A TestSetFolder object.

See Also

ITestSetFolder Interface


%%PageItemTitle%%

ITestSetFolder Interface

ChildName

The name of the child node.

See Also OTA COM Type Library

FindChildNode Method

Description

Finds a child node by node name.

Syntax

Public Function FindChildNode( _
   ByVal ChildName As String _
) As SysTreeNode

Parameters

ChildName

The name of the child node.

Return Type

A TestSetFolder.

See Also

ITestSetFolder Interface


%%PageItemTitle%%

ITestSetFolder Interface

Pattern

The search text pattern. Pass an empty string ("") to find all. The pattern is matched if it occcurs anywhere in the name. Do not use wildcards.

MatchCase

If TRUE, search is case-sensitive. MatchCase has no effect if the database manager is not case sensitive. For example, if the project is hosted on an MS-SQL database, this flag has no effect.

Filter

A TDFilter.Text to select the items to be returned.

See Also OTA COM Type Library

FindChildren Method

Description

Finds node children according to specified search pattern.

Syntax

Public Function FindChildren( _
   ByVal Pattern As String, _
   Optional ByVal MatchCase As Boolean = False, _
   Optional ByVal Filter As String = "" _
) As List

Parameters

Pattern

The search text pattern. Pass an empty string ("") to find all. The pattern is matched if it occcurs anywhere in the name. Do not use wildcards.

MatchCase

If TRUE, search is case-sensitive. MatchCase has no effect if the database manager is not case sensitive. For example, if the project is hosted on an MS-SQL database, this flag has no effect.

Filter

A TDFilter.Text to select the items to be returned.

Return Type

A list of TestSetFolder objects.

See Also

ITestSetFolder Interface


%%PageItemTitle%%

ITestSetFolder Interface

Pattern

The search text pattern. Pass an empty string ("") to find all. The pattern is matched if it occcurs anywhere in the name. Do not use wildcards.

MatchCase

If TRUE, search is case-sensitive. MatchCase has no effect if the database manager is not case sensitive. For example, if the project is hosted on an MS-SQL database, this flag has no effect.

Filter

A TDFilter.Text to select the items to be returned.

See Also OTA COM Type Library

FindTestSets Method

Description

Gets the list of test sets contained in the folder that match the specified pattern.

Syntax

Public Function FindTestSets( _
   ByVal Pattern As String, _
   Optional ByVal MatchCase As Boolean = False, _
   Optional ByVal Filter As String = "" _
) As List

Parameters

Pattern

The search text pattern. Pass an empty string ("") to find all. The pattern is matched if it occcurs anywhere in the name. Do not use wildcards.

MatchCase

If TRUE, search is case-sensitive. MatchCase has no effect if the database manager is not case sensitive. For example, if the project is hosted on an MS-SQL database, this flag has no effect.

Filter

A TDFilter.Text to select the items to be returned.

Return Type

A list of TestSet Objects.

See Also

ITestSetFolder Interface


%%PageItemTitle%%

ITestSetFolder Interface

Father

Either a TestSetFolder object or NodeID.

See Also OTA COM Type Library

Move Method

Description

Moves folder node under new father.

Syntax

Public Sub Move( _
   ByVal Father As Variant _
)

Parameters

Father

Either a TestSetFolder object or NodeID.

See Also

ITestSetFolder Interface


%%PageItemTitle%%

ITestSetFolder Interface

NewList Method

Description

Gets a list of the node's immediate children.

Syntax

Public Function NewList() As List

Return Type

A list of TestSetFolder objects.

See Also

ITestSetFolder Interface


%%PageItemTitle%%

ITestSetFolder Interface

Post Method

Description

Posts all changed values to the database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ITestSetFolder Interface


%%PageItemTitle%%

ITestSetFolder Interface

Refresh Method

Description

Reads the saved node data, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ITestSetFolder Interface


%%PageItemTitle%%

ITestSetFolder Interface

Node

The folder to delete. One of: a TestSetFolder object; the name of TestSetFolder as returned by the Name property; or the index of the TestSetFolder in its parent's children list.

See Also OTA COM Type Library

RemoveNode Method

Description

Deletes the specified node.

Syntax

Public Sub RemoveNode( _
   ByVal Node As Variant _
)

Parameters

Node

The folder to delete. One of: a TestSetFolder object; the name of TestSetFolder as returned by the Name property; or the index of the TestSetFolder in its parent's children list.

See Also

ITestSetFolder Interface


%%PageItemTitle%%

ITestSetFolder Interface

Node

The folder to delete. One of: a TestSetFolder object; the name of TestSetFolder as returned by the Name property; or the index of the TestSetFolder in its parent's children list.

DeleteTestSets

If TRUE, delete the test sets with the folder.

See Also OTA COM Type Library

RemoveNodeEx Method

Description

Deletes a test set folder node.

Syntax

Public Sub RemoveNodeEx( _
   ByVal Node As Variant, _
   Optional ByVal DeleteTestSets As Boolean = False _
)

Parameters

Node

The folder to delete. One of: a TestSetFolder object; the name of TestSetFolder as returned by the Name property; or the index of the TestSetFolder in its parent's children list.

DeleteTestSets

If TRUE, delete the test sets with the folder.

See Also

ITestSetFolder Interface


%%PageItemTitle%%

ITestSetFolder Interface

Attachments Property

Description

The folder's AttachmentFactory object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

ITestSetFolder Interface


%%PageItemTitle%%

ITestSetFolder Interface

Attribute Property

Description

Gets the node attribute.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attribute() As Long

See Also

ITestSetFolder Interface


%%PageItemTitle%%

ITestSetFolder Interface

Index

The position in the list of the child folder to return.

See Also OTA COM Type Library

Child Property

Description

Gets a sub-folder of the current folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Child( _
   ByVal Index As Long _
) As SysTreeNode

Parameters

Index

The position in the list of the child folder to return.

See Also

ITestSetFolder Interface


%%PageItemTitle%%

ITestSetFolder Interface

Count Property

Description

The number of child nodes.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

ITestSetFolder Interface


%%PageItemTitle%%

ITestSetFolder Interface

DepthType Property

Description

The sub-tree depth type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DepthType() As Integer

See Also

ITestSetFolder Interface


%%PageItemTitle%%

ITestSetFolder Interface

Description Property

Description

The test set folder description.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Description() As String

See Also

ITestSetFolder Interface


%%PageItemTitle%%

ITestSetFolder Interface

Father Property

Description

The current folder's parent folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Father() As SysTreeNode

See Also

ITestSetFolder Interface


%%PageItemTitle%%

ITestSetFolder Interface

FatherDisp Property

Description

The parent node.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FatherDisp() As Object

See Also

ITestSetFolder Interface


%%PageItemTitle%%

ITestSetFolder Interface

FatherID Property

Description

The unique parent ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FatherID() As Long

See Also

ITestSetFolder Interface


%%PageItemTitle%%

ITestSetFolder Interface

HasAttachment Property

Description

Checks if this folder has at least one attachment.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

ITestSetFolder Interface


%%PageItemTitle%%

ITestSetFolder Interface

Name Property

Description

The node name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ITestSetFolder Interface


%%PageItemTitle%%

ITestSetFolder Interface

NodeID Property

Description

The node ID number.

Property type

Read-only property

Syntax (Visual Basic)

Public Property NodeID() As Long

See Also

ITestSetFolder Interface


%%PageItemTitle%%

ITestSetFolder Interface

Path Property

Description

The folder tree path starting from the tree root.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Path() As String

See Also

ITestSetFolder Interface


%%PageItemTitle%%

ITestSetFolder Interface

SubNodes Property

Description

The list of child nodes.

Property type

Read-only property

Syntax (Visual Basic)

Public Property SubNodes() As List

See Also

ITestSetFolder Interface


%%PageItemTitle%%

ITestSetFolder Interface

TestSetFactory Property

Description

Gets the TestSetFactory for the folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestSetFactory() As Object

Remarks

If the TestSetFolder object represents the root folder, attempting to get a TestSetFactory causes a run-time error.

See Also

ITestSetFolder Interface


%%PageItemTitle%%

ITestSetFolder Interface

ViewOrder Property

Description

The index of this folder in its parent's list of sub-nodes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ViewOrder() As Long

See Also

ITestSetFolder Interface


%%PageItemTitle%%

ITestSetFolder2 Members

ITestSetFolder2 Interface

Description

Manages the tests and test sets included in one test set folder.

Remarks

Get a TestSetFolder object from the TestSetTreeManager.

Public Methods

Public Method AddNode | Adds a new child node.
Public Method AddNodeDisp | Adds a new child node.
Public Method FindChildNode | Finds a child node by node name.
Public Method FindChildren | Finds node children according to specified search pattern.
Public Method FindTestInstances | Gets the list of test instances in all test sets in given folder and its subfolders that match the specified pattern.
Public Method FindTestSets | Gets the list of test sets contained in the folder that match the specified pattern.
Public Method Move | Moves folder node under new father.
Public Method NewList | Gets a list of the node's immediate children.
Public Method Post | Posts all changed values to the database.
Public Method Refresh | Reads the saved node data, overwriting values in memory.
Public Method RemoveNode | Deletes the specified node.
Public Method RemoveNodeEx | Deletes a test set folder node.

Public Properties

Public Property Attachments | The folder's AttachmentFactory object.
Public Property Attribute | Gets the node attribute.
Public Property Child | Gets a sub-folder of the current folder.
Public Property Count | The number of child nodes.
Public Property DepthType | The sub-tree depth type.
Public Property Description | The test set folder description.
Public Property Father | The current folder's parent folder.
Public Property FatherDisp | The parent node.
Public Property FatherID | The unique parent ID.
Public Property HasAttachment | Checks if this folder has at least one attachment.
Public Property Name | The node name.
Public Property NodeID | The node ID number.
Public Property Path | The folder tree path starting from the tree root.
Public Property SubNodes | The list of child nodes.
Public Property TestSetFactory | Gets the TestSetFactory for the folder.
Public Property ViewOrder | The index of this folder in its parent's list of sub-nodes.


%%PageItemTitle%%

ITestSetFolder2 Interface

NodeName

The name of the folder to add.

See Also OTA COM Type Library

AddNode Method

Description

Adds a new child node.

Syntax

Public Function AddNode( _
   ByVal NodeName As String _
) As SysTreeNode

Parameters

NodeName

The name of the folder to add.

Return Type

A TestSetFolder.

See Also

ITestSetFolder2 Interface


%%PageItemTitle%%

ITestSetFolder2 Interface

NodeName

The name of the folder to add.

See Also OTA COM Type Library

AddNodeDisp Method

Description

Adds a new child node.

Syntax

Public Function AddNodeDisp( _
   ByVal NodeName As String _
) As Object

Parameters

NodeName

The name of the folder to add.

Return Type

A TestSetFolder object.

See Also

ITestSetFolder2 Interface


%%PageItemTitle%%

ITestSetFolder2 Interface

ChildName

The name of the child node.

See Also OTA COM Type Library

FindChildNode Method

Description

Finds a child node by node name.

Syntax

Public Function FindChildNode( _
   ByVal ChildName As String _
) As SysTreeNode

Parameters

ChildName

The name of the child node.

Return Type

A TestSetFolder.

See Also

ITestSetFolder2 Interface


%%PageItemTitle%%

ITestSetFolder2 Interface

Pattern

The search text pattern. Pass an empty string ("") to find all. The pattern is matched if it occcurs anywhere in the name. Do not use wildcards.

MatchCase

If TRUE, search is case-sensitive. MatchCase has no effect if the database manager is not case sensitive. For example, if the project is hosted on an MS-SQL database, this flag has no effect.

Filter

A TDFilter.Text to select the items to be returned.

See Also OTA COM Type Library

FindChildren Method

Description

Finds node children according to specified search pattern.

Syntax

Public Function FindChildren( _
   ByVal Pattern As String, _
   Optional ByVal MatchCase As Boolean = False, _
   Optional ByVal Filter As String = "" _
) As List

Parameters

Pattern

The search text pattern. Pass an empty string ("") to find all. The pattern is matched if it occcurs anywhere in the name. Do not use wildcards.

MatchCase

If TRUE, search is case-sensitive. MatchCase has no effect if the database manager is not case sensitive. For example, if the project is hosted on an MS-SQL database, this flag has no effect.

Filter

A TDFilter.Text to select the items to be returned.

Return Type

A list of TestSetFolder objects.

See Also

ITestSetFolder2 Interface


%%PageItemTitle%%

ITestSetFolder2 Interface

Pattern

The search text pattern. Pass an empty string ("") to find all. The pattern is matched if it occcurs anywhere in the name. Do not use wildcards.

MatchCase

If TRUE, search is case-sensitive. MatchCase has no effect if the database manager is not case sensitive. For example, if the project is hosted on an MS-SQL database, this flag has no effect.

Filter

A TDFilter.Text to select the items to be returned.

See Also OTA COM Type Library

FindTestInstances Method

Description

Gets the list of test instances in all test sets in given folder and its subfolders that match the specified pattern.

Syntax

Public Function FindTestInstances( _
   ByVal Pattern As String, _
   Optional ByVal MatchCase As Boolean = False, _
   Optional ByVal Filter As String = "" _
) As List

Parameters

Pattern

The search text pattern. Pass an empty string ("") to find all. The pattern is matched if it occcurs anywhere in the name. Do not use wildcards.

MatchCase

If TRUE, search is case-sensitive. MatchCase has no effect if the database manager is not case sensitive. For example, if the project is hosted on an MS-SQL database, this flag has no effect.

Filter

A TDFilter.Text to select the items to be returned.

Return Type

A list of TSTest Objects.

See Also

ITestSetFolder2 Interface


%%PageItemTitle%%

ITestSetFolder2 Interface

Pattern

The search text pattern. Pass an empty string ("") to find all. The pattern is matched if it occcurs anywhere in the name. Do not use wildcards.

MatchCase

If TRUE, search is case-sensitive. MatchCase has no effect if the database manager is not case sensitive. For example, if the project is hosted on an MS-SQL database, this flag has no effect.

Filter

A TDFilter.Text to select the items to be returned.

See Also OTA COM Type Library

FindTestSets Method

Description

Gets the list of test sets contained in the folder that match the specified pattern.

Syntax

Public Function FindTestSets( _
   ByVal Pattern As String, _
   Optional ByVal MatchCase As Boolean = False, _
   Optional ByVal Filter As String = "" _
) As List

Parameters

Pattern

The search text pattern. Pass an empty string ("") to find all. The pattern is matched if it occcurs anywhere in the name. Do not use wildcards.

MatchCase

If TRUE, search is case-sensitive. MatchCase has no effect if the database manager is not case sensitive. For example, if the project is hosted on an MS-SQL database, this flag has no effect.

Filter

A TDFilter.Text to select the items to be returned.

Return Type

A list of TestSet Objects.

See Also

ITestSetFolder2 Interface


%%PageItemTitle%%

ITestSetFolder2 Interface

Father

Either a TestSetFolder object or NodeID.

See Also OTA COM Type Library

Move Method

Description

Moves folder node under new father.

Syntax

Public Sub Move( _
   ByVal Father As Variant _
)

Parameters

Father

Either a TestSetFolder object or NodeID.

See Also

ITestSetFolder2 Interface


%%PageItemTitle%%

ITestSetFolder2 Interface

NewList Method

Description

Gets a list of the node's immediate children.

Syntax

Public Function NewList() As List

Return Type

A list of TestSetFolder objects.

See Also

ITestSetFolder2 Interface


%%PageItemTitle%%

ITestSetFolder2 Interface

Post Method

Description

Posts all changed values to the database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ITestSetFolder2 Interface


%%PageItemTitle%%

ITestSetFolder2 Interface

Refresh Method

Description

Reads the saved node data, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ITestSetFolder2 Interface


%%PageItemTitle%%

ITestSetFolder2 Interface

Node

The folder to delete. One of: a TestSetFolder object; the name of TestSetFolder as returned by the Name property; or the index of the TestSetFolder in its parent's children list.

See Also OTA COM Type Library

RemoveNode Method

Description

Deletes the specified node.

Syntax

Public Sub RemoveNode( _
   ByVal Node As Variant _
)

Parameters

Node

The folder to delete. One of: a TestSetFolder object; the name of TestSetFolder as returned by the Name property; or the index of the TestSetFolder in its parent's children list.

See Also

ITestSetFolder2 Interface


%%PageItemTitle%%

ITestSetFolder2 Interface

Node

The folder to delete. One of: a TestSetFolder object; the name of TestSetFolder as returned by the Name property; or the index of the TestSetFolder in its parent's children list.

DeleteTestSets

If TRUE, delete the test sets with the folder.

See Also OTA COM Type Library

RemoveNodeEx Method

Description

Deletes a test set folder node.

Syntax

Public Sub RemoveNodeEx( _
   ByVal Node As Variant, _
   Optional ByVal DeleteTestSets As Boolean = False _
)

Parameters

Node

The folder to delete. One of: a TestSetFolder object; the name of TestSetFolder as returned by the Name property; or the index of the TestSetFolder in its parent's children list.

DeleteTestSets

If TRUE, delete the test sets with the folder.

See Also

ITestSetFolder2 Interface


%%PageItemTitle%%

ITestSetFolder2 Interface

Attachments Property

Description

The folder's AttachmentFactory object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

ITestSetFolder2 Interface


%%PageItemTitle%%

ITestSetFolder2 Interface

Attribute Property

Description

Gets the node attribute.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attribute() As Long

See Also

ITestSetFolder2 Interface


%%PageItemTitle%%

ITestSetFolder2 Interface

Index

The position in the list of the child folder to return.

See Also OTA COM Type Library

Child Property

Description

Gets a sub-folder of the current folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Child( _
   ByVal Index As Long _
) As SysTreeNode

Parameters

Index

The position in the list of the child folder to return.

See Also

ITestSetFolder2 Interface


%%PageItemTitle%%

ITestSetFolder2 Interface

Count Property

Description

The number of child nodes.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

ITestSetFolder2 Interface


%%PageItemTitle%%

ITestSetFolder2 Interface

DepthType Property

Description

The sub-tree depth type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DepthType() As Integer

See Also

ITestSetFolder2 Interface


%%PageItemTitle%%

ITestSetFolder2 Interface

Description Property

Description

The test set folder description.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Description() As String

See Also

ITestSetFolder2 Interface


%%PageItemTitle%%

ITestSetFolder2 Interface

Father Property

Description

The current folder's parent folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Father() As SysTreeNode

See Also

ITestSetFolder2 Interface


%%PageItemTitle%%

ITestSetFolder2 Interface

FatherDisp Property

Description

The parent node.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FatherDisp() As Object

See Also

ITestSetFolder2 Interface


%%PageItemTitle%%

ITestSetFolder2 Interface

FatherID Property

Description

The unique parent ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FatherID() As Long

See Also

ITestSetFolder2 Interface


%%PageItemTitle%%

ITestSetFolder2 Interface

HasAttachment Property

Description

Checks if this folder has at least one attachment.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

ITestSetFolder2 Interface


%%PageItemTitle%%

ITestSetFolder2 Interface

Name Property

Description

The node name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ITestSetFolder2 Interface


%%PageItemTitle%%

ITestSetFolder2 Interface

NodeID Property

Description

The node ID number.

Property type

Read-only property

Syntax (Visual Basic)

Public Property NodeID() As Long

See Also

ITestSetFolder2 Interface


%%PageItemTitle%%

ITestSetFolder2 Interface

Path Property

Description

The folder tree path starting from the tree root.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Path() As String

See Also

ITestSetFolder2 Interface


%%PageItemTitle%%

ITestSetFolder2 Interface

SubNodes Property

Description

The list of child nodes.

Property type

Read-only property

Syntax (Visual Basic)

Public Property SubNodes() As List

See Also

ITestSetFolder2 Interface


%%PageItemTitle%%

ITestSetFolder2 Interface

TestSetFactory Property

Description

Gets the TestSetFactory for the folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestSetFactory() As Object

Remarks

If the TestSetFolder object represents the root folder, attempting to get a TestSetFactory causes a run-time error.

See Also

ITestSetFolder2 Interface


%%PageItemTitle%%

ITestSetFolder2 Interface

ViewOrder Property

Description

The index of this folder in its parent's list of sub-nodes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ViewOrder() As Long

See Also

ITestSetFolder2 Interface


%%PageItemTitle%%

ITestSetFolder3 Members

ITestSetFolder3 Interface

Description

Manages the tests and test sets included in one test set folder.

Remarks

Get a TestSetFolder object from the TestSetTreeManager.

Public Methods

Public Method AddNode | Adds a new child node.
Public Method AddNodeDisp | Adds a new child node.
Public Method FindChildNode | Finds a child node by node name.
Public Method FindChildren | Finds node children according to specified search pattern.
Public Method FindTestInstances | Gets the list of test instances in all test sets in given folder and its subfolders that match the specified pattern.
Public Method FindTestSets | Gets the list of test sets contained in the folder that match the specified pattern.
Public Method Move | Moves folder node under new father.
Public Method NewList | Gets a list of the node's immediate children.
Public Method Post | Posts all changed values to the database.
Public Method Refresh | Reads the saved node data, overwriting values in memory.
Public Method RemoveNode | Deletes the specified node.
Public Method RemoveNodeEx | Deletes a test set folder node.

Public Properties

Public Property Attachments | The folder's AttachmentFactory object.
Public Property Attribute | Gets the node attribute.
Public Property Child | Gets a sub-folder of the current folder.
Public Property Count | The number of child nodes.
Public Property DepthType | The sub-tree depth type.
Public Property Description | The test set folder description.
Public Property Father | The current folder's parent folder.
Public Property FatherDisp | The parent node.
Public Property FatherID | The unique parent ID.
Public Property FolderFields | Returns the list of fields of the test set folder.
Public Property HasAttachment | Checks if this folder has at least one attachment.
Public Property Name | The node name.
Public Property NodeID | The node ID number.
Public Property Path | The folder tree path starting from the tree root.
Public Property SubNodes | The list of child nodes.
Public Property TargetCycle | The cycle to which the folder is assigned.
Public Property TestSetFactory | Gets the TestSetFactory for the folder.
Public Property ViewOrder | The index of this folder in its parent's list of sub-nodes.


%%PageItemTitle%%

ITestSetFolder3 Interface

NodeName

The name of the folder to add.

See Also OTA COM Type Library

AddNode Method

Description

Adds a new child node.

Syntax

Public Function AddNode( _
   ByVal NodeName As String _
) As SysTreeNode

Parameters

NodeName

The name of the folder to add.

Return Type

A TestSetFolder.

See Also

ITestSetFolder3 Interface


%%PageItemTitle%%

ITestSetFolder3 Interface

NodeName

The name of the folder to add.

See Also OTA COM Type Library

AddNodeDisp Method

Description

Adds a new child node.

Syntax

Public Function AddNodeDisp( _
   ByVal NodeName As String _
) As Object

Parameters

NodeName

The name of the folder to add.

Return Type

A TestSetFolder object.

See Also

ITestSetFolder3 Interface


%%PageItemTitle%%

ITestSetFolder3 Interface

ChildName

The name of the child node.

See Also OTA COM Type Library

FindChildNode Method

Description

Finds a child node by node name.

Syntax

Public Function FindChildNode( _
   ByVal ChildName As String _
) As SysTreeNode

Parameters

ChildName

The name of the child node.

Return Type

A TestSetFolder.

See Also

ITestSetFolder3 Interface


%%PageItemTitle%%

ITestSetFolder3 Interface

Pattern

The search text pattern. Pass an empty string ("") to find all. The pattern is matched if it occcurs anywhere in the name. Do not use wildcards.

MatchCase

If TRUE, search is case-sensitive. MatchCase has no effect if the database manager is not case sensitive. For example, if the project is hosted on an MS-SQL database, this flag has no effect.

Filter

A TDFilter.Text to select the items to be returned.

See Also OTA COM Type Library

FindChildren Method

Description

Finds node children according to specified search pattern.

Syntax

Public Function FindChildren( _
   ByVal Pattern As String, _
   Optional ByVal MatchCase As Boolean = False, _
   Optional ByVal Filter As String = "" _
) As List

Parameters

Pattern

The search text pattern. Pass an empty string ("") to find all. The pattern is matched if it occcurs anywhere in the name. Do not use wildcards.

MatchCase

If TRUE, search is case-sensitive. MatchCase has no effect if the database manager is not case sensitive. For example, if the project is hosted on an MS-SQL database, this flag has no effect.

Filter

A TDFilter.Text to select the items to be returned.

Return Type

A list of TestSetFolder objects.

See Also

ITestSetFolder3 Interface


%%PageItemTitle%%

ITestSetFolder3 Interface

Pattern

The search text pattern. Pass an empty string ("") to find all. The pattern is matched if it occcurs anywhere in the name. Do not use wildcards.

MatchCase

If TRUE, search is case-sensitive. MatchCase has no effect if the database manager is not case sensitive. For example, if the project is hosted on an MS-SQL database, this flag has no effect.

Filter

A TDFilter.Text to select the items to be returned.

See Also OTA COM Type Library

FindTestInstances Method

Description

Gets the list of test instances in all test sets in given folder and its subfolders that match the specified pattern.

Syntax

Public Function FindTestInstances( _
   ByVal Pattern As String, _
   Optional ByVal MatchCase As Boolean = False, _
   Optional ByVal Filter As String = "" _
) As List

Parameters

Pattern

The search text pattern. Pass an empty string ("") to find all. The pattern is matched if it occcurs anywhere in the name. Do not use wildcards.

MatchCase

If TRUE, search is case-sensitive. MatchCase has no effect if the database manager is not case sensitive. For example, if the project is hosted on an MS-SQL database, this flag has no effect.

Filter

A TDFilter.Text to select the items to be returned.

Return Type

A list of TSTest Objects.

See Also

ITestSetFolder3 Interface


%%PageItemTitle%%

ITestSetFolder3 Interface

Pattern

The search text pattern. Pass an empty string ("") to find all. The pattern is matched if it occcurs anywhere in the name. Do not use wildcards.

MatchCase

If TRUE, search is case-sensitive. MatchCase has no effect if the database manager is not case sensitive. For example, if the project is hosted on an MS-SQL database, this flag has no effect.

Filter

A TDFilter.Text to select the items to be returned.

See Also OTA COM Type Library

FindTestSets Method

Description

Gets the list of test sets contained in the folder that match the specified pattern.

Syntax

Public Function FindTestSets( _
   ByVal Pattern As String, _
   Optional ByVal MatchCase As Boolean = False, _
   Optional ByVal Filter As String = "" _
) As List

Parameters

Pattern

The search text pattern. Pass an empty string ("") to find all. The pattern is matched if it occcurs anywhere in the name. Do not use wildcards.

MatchCase

If TRUE, search is case-sensitive. MatchCase has no effect if the database manager is not case sensitive. For example, if the project is hosted on an MS-SQL database, this flag has no effect.

Filter

A TDFilter.Text to select the items to be returned.

Return Type

A list of TestSet Objects.

See Also

ITestSetFolder3 Interface


%%PageItemTitle%%

ITestSetFolder3 Interface

Father

Either a TestSetFolder object or NodeID.

See Also OTA COM Type Library

Move Method

Description

Moves folder node under new father.

Syntax

Public Sub Move( _
   ByVal Father As Variant _
)

Parameters

Father

Either a TestSetFolder object or NodeID.

See Also

ITestSetFolder3 Interface


%%PageItemTitle%%

ITestSetFolder3 Interface

NewList Method

Description

Gets a list of the node's immediate children.

Syntax

Public Function NewList() As List

Return Type

A list of TestSetFolder objects.

See Also

ITestSetFolder3 Interface


%%PageItemTitle%%

ITestSetFolder3 Interface

Post Method

Description

Posts all changed values to the database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ITestSetFolder3 Interface


%%PageItemTitle%%

ITestSetFolder3 Interface

Refresh Method

Description

Reads the saved node data, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ITestSetFolder3 Interface


%%PageItemTitle%%

ITestSetFolder3 Interface

Node

The folder to delete. One of: a TestSetFolder object; the name of TestSetFolder as returned by the Name property; or the index of the TestSetFolder in its parent's children list.

See Also OTA COM Type Library

RemoveNode Method

Description

Deletes the specified node.

Syntax

Public Sub RemoveNode( _
   ByVal Node As Variant _
)

Parameters

Node

The folder to delete. One of: a TestSetFolder object; the name of TestSetFolder as returned by the Name property; or the index of the TestSetFolder in its parent's children list.

See Also

ITestSetFolder3 Interface


%%PageItemTitle%%

ITestSetFolder3 Interface

Node

The folder to delete. One of: a TestSetFolder object; the name of TestSetFolder as returned by the Name property; or the index of the TestSetFolder in its parent's children list.

DeleteTestSets

If TRUE, delete the test sets with the folder.

See Also OTA COM Type Library

RemoveNodeEx Method

Description

Deletes a test set folder node.

Syntax

Public Sub RemoveNodeEx( _
   ByVal Node As Variant, _
   Optional ByVal DeleteTestSets As Boolean = False _
)

Parameters

Node

The folder to delete. One of: a TestSetFolder object; the name of TestSetFolder as returned by the Name property; or the index of the TestSetFolder in its parent's children list.

DeleteTestSets

If TRUE, delete the test sets with the folder.

See Also

ITestSetFolder3 Interface


%%PageItemTitle%%

ITestSetFolder3 Interface

Attachments Property

Description

The folder's AttachmentFactory object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

ITestSetFolder3 Interface


%%PageItemTitle%%

ITestSetFolder3 Interface

Attribute Property

Description

Gets the node attribute.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attribute() As Long

See Also

ITestSetFolder3 Interface


%%PageItemTitle%%

ITestSetFolder3 Interface

Index

The position in the list of the child folder to return.

See Also OTA COM Type Library

Child Property

Description

Gets a sub-folder of the current folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Child( _
   ByVal Index As Long _
) As SysTreeNode

Parameters

Index

The position in the list of the child folder to return.

See Also

ITestSetFolder3 Interface


%%PageItemTitle%%

ITestSetFolder3 Interface

Count Property

Description

The number of child nodes.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

ITestSetFolder3 Interface


%%PageItemTitle%%

ITestSetFolder3 Interface

DepthType Property

Description

The sub-tree depth type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DepthType() As Integer

See Also

ITestSetFolder3 Interface


%%PageItemTitle%%

ITestSetFolder3 Interface

Description Property

Description

The test set folder description.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Description() As String

See Also

ITestSetFolder3 Interface


%%PageItemTitle%%

ITestSetFolder3 Interface

Father Property

Description

The current folder's parent folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Father() As SysTreeNode

See Also

ITestSetFolder3 Interface


%%PageItemTitle%%

ITestSetFolder3 Interface

FatherDisp Property

Description

The parent node.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FatherDisp() As Object

See Also

ITestSetFolder3 Interface


%%PageItemTitle%%

ITestSetFolder3 Interface

FatherID Property

Description

The unique parent ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FatherID() As Long

See Also

ITestSetFolder3 Interface


%%PageItemTitle%%

ITestSetFolder3 Interface

FolderFields Property

Description

Returns the list of fields of the test set folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FolderFields() As List

See Also

ITestSetFolder3 Interface


%%PageItemTitle%%

ITestSetFolder3 Interface

HasAttachment Property

Description

Checks if this folder has at least one attachment.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

ITestSetFolder3 Interface


%%PageItemTitle%%

ITestSetFolder3 Interface

Name Property

Description

The node name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ITestSetFolder3 Interface


%%PageItemTitle%%

ITestSetFolder3 Interface

NodeID Property

Description

The node ID number.

Property type

Read-only property

Syntax (Visual Basic)

Public Property NodeID() As Long

See Also

ITestSetFolder3 Interface


%%PageItemTitle%%

ITestSetFolder3 Interface

Path Property

Description

The folder tree path starting from the tree root.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Path() As String

See Also

ITestSetFolder3 Interface


%%PageItemTitle%%

ITestSetFolder3 Interface

SubNodes Property

Description

The list of child nodes.

Property type

Read-only property

Syntax (Visual Basic)

Public Property SubNodes() As List

See Also

ITestSetFolder3 Interface


%%PageItemTitle%%

ITestSetFolder3 Interface

TargetCycle Property

Description

The cycle to which the folder is assigned.

Property type

Read-write property

Syntax (Visual Basic)

Public Property TargetCycle() As Variant

Get or Set Value Type

A Cycle Object.

See Also

ITestSetFolder3 Interface


%%PageItemTitle%%

ITestSetFolder3 Interface

TestSetFactory Property

Description

Gets the TestSetFactory for the folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestSetFactory() As Object

Remarks

If the TestSetFolder object represents the root folder, attempting to get a TestSetFactory causes a run-time error.

See Also

ITestSetFolder3 Interface


%%PageItemTitle%%

ITestSetFolder3 Interface

ViewOrder Property

Description

The index of this folder in its parent's list of sub-nodes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ViewOrder() As Long

See Also

ITestSetFolder3 Interface


%%PageItemTitle%%

ITestSetTreeManager Members

ITestSetTreeManager Interface

Description

Manages the test set tree and its related test set folders.

Remarks

The TestSetTreeManager for the connection is TDConnection.TestSetTreeManager

Public Properties

Public Property NodeById | Gets the test set tree node object corresponding to the specified node Id.
Public Property NodeByPath | Gets the test set tree node from the specified tree path.
Public Property Root | The test set tree root node.
Public Property Unattached | Gets an unattached folder.


%%PageItemTitle%%

ITestSetTreeManager Interface

NodeID

The ID of the node in the project database.

See Also OTA COM Type Library

NodeById Property

Description

Gets the test set tree node object corresponding to the specified node Id.

Property type

Read-only property

Syntax (Visual Basic)

Public Property NodeById( _
   ByVal NodeID As Long _
) As Object

Parameters

NodeID

The ID of the node in the project database.

See Also

ITestSetTreeManager Interface


%%PageItemTitle%%

ITestSetTreeManager Interface

Path

The folder tree path starting from the tree root. For example, "Root\OTA_Demo_TestSets".

See Also OTA COM Type Library

NodeByPath Property

Description

Gets the test set tree node from the specified tree path.

Property type

Read-only property

Syntax (Visual Basic)

Public Property NodeByPath( _
   ByVal Path As String _
) As Object

Parameters

Path

The folder tree path starting from the tree root. For example, "Root\OTA_Demo_TestSets".

See Also

ITestSetTreeManager Interface


%%PageItemTitle%%

ITestSetTreeManager Interface

Root Property

Description

The test set tree root node.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Root() As Object

See Also

ITestSetTreeManager Interface


%%PageItemTitle%%

ITestSetTreeManager Interface

Unattached Property

Description

Gets an unattached folder.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Unattached() As Object

See Also

ITestSetTreeManager Interface


%%PageItemTitle%%

ITextParser Members

ITextParser Interface

Description

Utilities for handling parameters in a string.

Remarks

Get a TextParser object from TDConnection.TextParam.

Public Methods

Public Method ClearParam | Clear the parameter - Set its value to null.
Public Method EvaluateText | Converts the parameters to their values.
Public Method Initialize | Initialization is generally performed by the infrastructure. Use this method after confirming the need with Mercury Support.

Public Properties

Public Property Count | Gets the number of parameters.
Public Property ParamExist | Checks if a parameter with the specified name exists.
Public Property ParamName | Gets the parameter name.
Public Property ParamType | Gets the user-defined Parameter Type.
Public Property ParamValue | The parameter value.
Public Property Text | The text to be parsed.
Public Property Type | Gets the Parameter Type - predefined, null, or regular.


%%PageItemTitle%%

ITextParser Interface

vParam

Either the index (zero-based) in the collection, or the name of the parameter.

See Also OTA COM Type Library

ClearParam Method

Description

Clear the parameter - Set its value to null.

Syntax

Public Sub ClearParam( _
   ByVal vParam As Variant _
)

Parameters

vParam

Either the index (zero-based) in the collection, or the name of the parameter.

See Also

ITextParser Interface


%%PageItemTitle%%

ITextParser Interface

EvaluateText Method

Description

Converts the parameters to their values.

Syntax

Public Sub EvaluateText()

See Also

ITextParser Interface


%%PageItemTitle%%

ITextParser Interface

StartClose

The token that marks the start of a parameter.

EndClose

The token that marks the end of a parameter.

TypeClose

The token that marks a value to be replaced.

MaxLen

Not in use. The default is always used. -1 means there is no maximum length.

DefaultType

Not in use. Always "String"

See Also OTA COM Type Library

Initialize Method

Description

Initialization is generally performed by the infrastructure. Use this method after confirming the need with Mercury Support.

Syntax

Public Sub Initialize( _
   Optional ByVal StartClose As String = "<%", _
   Optional ByVal EndClose As String = "%>", _
   Optional ByVal TypeClose As String = "?", _
   Optional ByVal MaxLen As Long = -1, _
   Optional ByVal DefaultType As String = "string" _
)

Parameters

StartClose

The token that marks the start of a parameter.

EndClose

The token that marks the end of a parameter.

TypeClose

The token that marks a value to be replaced.

MaxLen

Not in use. The default is always used. -1 means there is no maximum length.

DefaultType

Not in use. Always "String"

Remarks

Several step parameters can be assigned to a step. The text parser is used to identify each parameter. By default, a parameter has format <?> .

See Also

ITextParser Interface


%%PageItemTitle%%

ITextParser Interface

Count Property

Description

Gets the number of parameters.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

ITextParser Interface


%%PageItemTitle%%

ITextParser Interface

ParamName

The name of the parameter.

See Also OTA COM Type Library

ParamExist Property

Description

Checks if a parameter with the specified name exists.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ParamExist( _
   ByVal ParamName As String _
) As Boolean

Parameters

ParamName

The name of the parameter.

See Also

ITextParser Interface


%%PageItemTitle%%

ITextParser Interface

nPosition

The index (zero-based) of parameter in the list of all parameters found in the Text.

See Also OTA COM Type Library

ParamName Property

Description

Gets the parameter name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ParamName( _
   ByVal nPosition As Long _
) As String

Parameters

nPosition

The index (zero-based) of parameter in the list of all parameters found in the Text.

See Also

ITextParser Interface


%%PageItemTitle%%

ITextParser Interface

vParam

Either the index (zero-based) in the collection, or the name of the parameter.

See Also OTA COM Type Library

ParamType Property

Description

Gets the user-defined Parameter Type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ParamType( _
   ByVal vParam As Variant _
) As String

Parameters

vParam

Either the index (zero-based) in the collection, or the name of the parameter.

See Also

ITextParser Interface


%%PageItemTitle%%

ITextParser Interface

vParam

Either the index (zero-based) in the collection, or the name of the parameter.

See Also OTA COM Type Library

ParamValue Property

Description

The parameter value.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ParamValue( _
   ByVal vParam As Variant _
) As String

Parameters

vParam

Either the index (zero-based) in the collection, or the name of the parameter.

See Also

ITextParser Interface


%%PageItemTitle%%

ITextParser Interface

Text Property

Description

The text to be parsed.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Text() As String

See Also

ITextParser Interface


%%PageItemTitle%%

ITextParser Interface

vParam

Either the index (zero-based) in the collection, or the name of the parameter.

See Also OTA COM Type Library

Type Property

Description

Gets the Parameter Type - predefined, null, or regular.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Type( _
   ByVal vParam As Variant _
) As Long

Parameters

vParam

Either the index (zero-based) in the collection, or the name of the parameter.

See Also

ITextParser Interface


%%PageItemTitle%%

ITrace Members

ITrace Interface

Description

Represents a traceability association between two requirements.

Remarks

Get a Trace object from the ReqTraceFactory pointed to by the Req .ReqTraceFactory Property of a requirement.

When creating the Trace object with the AddItem method, the direction of the trace is specified. If the direction is from the Req whose factory is used, the the Trace is created with the initiating Req in the FromReq. If the direction is to the initiating Req, the Trace is created with the initiating Req in the ToReq Property.

After the Trace is created, set the TracedReq property to the second Req. When you set TracedReq, the Trace object sets either FromReq or ToReq to point to the second Req. Which property is set depends on the direction of the Trace.

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Field | The value of the specified field.
Public Property FromReq | The requirement from which the association is defined.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property ToReq | The requirement to which the association is defined
Public Property TracedReq | The other requirement that the initiating requirement forms a trace with.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

ITrace Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ITrace Interface


%%PageItemTitle%%

ITrace Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ITrace Interface


%%PageItemTitle%%

ITrace Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ITrace Interface


%%PageItemTitle%%

ITrace Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

ITrace Interface


%%PageItemTitle%%

ITrace Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

ITrace Interface


%%PageItemTitle%%

ITrace Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

ITrace Interface


%%PageItemTitle%%

ITrace Interface

FieldName
The name of the field in the project database.
See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName
The name of the field in the project database.

See Also

ITrace Interface


%%PageItemTitle%%

ITrace Interface

FromReq Property

Description

The requirement from which the association is defined.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FromReq() As Object

See Also

ITrace Interface


%%PageItemTitle%%

ITrace Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

ITrace Interface


%%PageItemTitle%%

ITrace Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

ITrace Interface


%%PageItemTitle%%

ITrace Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

ITrace Interface


%%PageItemTitle%%

ITrace Interface

ToReq Property

Description

The requirement to which the association is defined

Property type

Read-only property

Syntax (Visual Basic)

Public Property ToReq() As Object

See Also

ITrace Interface


%%PageItemTitle%%

ITrace Interface

RHS

A Req Object.

See Also OTA COM Type Library

TracedReq Property

Description

The other requirement that the initiating requirement forms a trace with.

Property type

Write-only property

Syntax (Visual Basic)

Public Property TracedReq( _
   ByVal RHS As Object _
) As Object

Parameters

RHS

A Req Object.

See Also

ITrace Interface


%%PageItemTitle%%

ITrace Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

ITrace Interface


%%PageItemTitle%%

ITreeManager Members

ITreeManager Interface

Description

Represents the system tree, containing a subject tree and all hierarchical field trees.

Remarks

The TreeManager for the connection is TDConnection.TreeManager.

Public Properties

Public Property NodeById | Gets the object having the specified node Id.
Public Property NodeByPath | Gets the node at the specified tree path.
Public Property NodePath | Gets the node path, slash separated.
Public Property RootList | Gets list of available trees in the specified range.
Public Property TreeRoot | The root node specified by the node name.


%%PageItemTitle%%

ITreeManager Interface

NodeID

The Node ID.

See Also OTA COM Type Library

NodeById Property

Description

Gets the object having the specified node Id.

Property type

Read-only property

Syntax (Visual Basic)

Public Property NodeById( _
   ByVal NodeID As Long _
) As Object

Parameters

NodeID

The Node ID.

See Also

ITreeManager Interface


%%PageItemTitle%%

ITreeManager Interface

Path

The tree path of the node (a string separated by slashes).

See Also OTA COM Type Library

NodeByPath Property

Description

Gets the node at the specified tree path.

Property type

Read-only property

Syntax (Visual Basic)

Public Property NodeByPath( _
   ByVal Path As String _
) As Object

Parameters

Path

The tree path of the node (a string separated by slashes).

See Also

ITreeManager Interface


%%PageItemTitle%%

ITreeManager Interface

NodeID

The Node ID.

See Also OTA COM Type Library

NodePath Property

Description

Gets the node path, slash separated.

Property type

Read-only property

Syntax (Visual Basic)

Public Property NodePath( _
   ByVal NodeID As Long _
) As String

Parameters

NodeID

The Node ID.

See Also

ITreeManager Interface


%%PageItemTitle%%

ITreeManager Interface

Val

One of the values TDOLE_ALL, TDOLE_SUBJECT, or TDOLE_NOT_SUBJECT, from tagTDAPI_ROOTLIST Enumeration.

See Also OTA COM Type Library

RootList Property

Description

Gets list of available trees in the specified range.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RootList( _
   Optional ByVal Val As Integer = 0 _
) As List

Parameters

Val

One of the values TDOLE_ALL, TDOLE_SUBJECT, or TDOLE_NOT_SUBJECT, from tagTDAPI_ROOTLIST Enumeration.

See Also

ITreeManager Interface


%%PageItemTitle%%

ITreeManager Interface

RootName

One of the values returned by RootList.

See Also OTA COM Type Library

TreeRoot Property

Description

The root node specified by the node name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TreeRoot( _
   ByVal RootName As String _
) As Object

Parameters

RootName

One of the values returned by RootList.

See Also

ITreeManager Interface


%%PageItemTitle%%

ITSScheduler Members

ITSScheduler Interface

Description

Responsible for executing selected automated tests.

Remarks

A TSScheduler object is returned by TestSet.StartExecution.

Public Methods

Public Method Run | Starts execution the test set or of the specified tests.
Public Method Stop | Stops execution of the test set or the specified tests.

Public Properties

Public Property ExecutionLog | The execution error or log message sent by the remote agent.
Public Property ExecutionStatus | The execution status object for the scheduler execution.
Public Property HostTimeOut | The time to wait for response before either sending test to another host in group or failing.
Public Property LogEnabled | Indicates if logging is enabled.
Public Property RunAllLocally | Indicates if all tests are to be run on the local host.
Public Property RunOnHost | The host on which to execute the test instance.
Public Property TdHostName | The host on which to run all tests in the current scheduler execution.


%%PageItemTitle%%

ITSScheduler Interface

TestData

A comma-separated list of the IDs (string) of the test instances to run, or a List of TSTest objects. If no value is passed, the entire test set is run.

See Also OTA COM Type Library

Run Method

Description

Starts execution the test set or of the specified tests.

Syntax

Public Sub Run( _
   Optional ByVal TestData As Variant _
)

Parameters

TestData

A comma-separated list of the IDs (string) of the test instances to run, or a List of TSTest objects. If no value is passed, the entire test set is run.

Remarks

A TSScheduler can perform only one run. If you want to perform more than one run, then after calling Run, call TestSet.StartExecution again to get a new TSScheduler object.

See Also

ITSScheduler Interface


%%PageItemTitle%%

ITSScheduler Interface

TestData

A comma-separated list of the IDs (string) of the test instances to stop. If no value is passed, all the test instances in the test set are stopped/

See Also OTA COM Type Library

Stop Method

Description

Stops execution of the test set or the specified tests.

Syntax

Public Sub Stop( _
   Optional ByVal TestData As Variant _
)

Parameters

TestData

A comma-separated list of the IDs (string) of the test instances to stop. If no value is passed, all the test instances in the test set are stopped/

See Also

ITSScheduler Interface


%%PageItemTitle%%

ITSScheduler Interface

ExecutionLog Property

Description

The execution error or log message sent by the remote agent.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExecutionLog() As String

See Also

ITSScheduler Interface


%%PageItemTitle%%

ITSScheduler Interface

ExecutionStatus Property

Description

The execution status object for the scheduler execution.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExecutionStatus() As Object

See Also

ITSScheduler Interface


%%PageItemTitle%%

ITSScheduler Interface

HostTimeOut Property

Description

The time to wait for response before either sending test to another host in group or failing.

Property type

Read-write property

Syntax (Visual Basic)

Public Property HostTimeOut() As Long

Remarks

If the host does not respond, at the end of the timeout an automated test is sent to another host from the same host group. If there are no other available hosts, the test fails.

See Also

ITSScheduler Interface


%%PageItemTitle%%

ITSScheduler Interface

LogEnabled Property

Description

Indicates if logging is enabled.

Property type

Read-write property

Syntax (Visual Basic)

Public Property LogEnabled() As Boolean

See Also

ITSScheduler Interface


%%PageItemTitle%%

ITSScheduler Interface

RunAllLocally Property

Description

Indicates if all tests are to be run on the local host.

Property type

Read-write property

Syntax (Visual Basic)

Public Property RunAllLocally() As Boolean

Remarks

To run all the test instances in the test set on the local host, set RunAllLocally = True.

If you specify a host for each test instances using RunOnHost, set RunAllLocally = False.

If you specify a remote host to run all the test instances using TdHostName, do not set RunAllLocally at all.

See Also

ITSScheduler Interface


%%PageItemTitle%%

ITSScheduler Interface

TSTestId

The ID of the test instance (TSTest).

See Also OTA COM Type Library

RunOnHost Property

Description

The host on which to execute the test instance.

Property type

Read-write property

Syntax (Visual Basic)

Public Property RunOnHost( _
   ByVal TSTestId As Variant _
) As String

Parameters

TSTestId

The ID of the test instance (TSTest).

Remarks

Setting this value is required if no TSTest.HostName is empty and RunAllLocally is False.

If TSTest.HostName is set, setting RunOnHost overrides the setting for this run.

See Also

ITSScheduler Interface


%%PageItemTitle%%

ITSScheduler Interface

TdHostName Property

Description

The host on which to run all tests in the current scheduler execution.

Property type

Read-write property

Syntax (Visual Basic)

Public Property TdHostName() As String

Remarks

Do not set the TDHostName if the test instances are to to run on the local host (RunAllLocally = True) or if hosts are going to be specified using RunOnHost.

If TDHostName is specified, do not set any value for RunAllLocally.

See Also

ITSScheduler Interface


%%PageItemTitle%%

ITSTest Members | TestSet Object | Test Object

ITSTest Interface

Description

Represents a test instance, or execution test, in a test set.

Remarks

A test instance represents a single use of a planning Test in a TestSet. It can be associated with one or more runs.

Get a TSTest object from a TSTestFactory.

Interface Remarks

IBaseFieldEx is implemented by several classes, among them: DesignStep, HostGroup, Run, Step, TSTest, and TestSet.
IBaseField defines a basic data field or entity. Use the properties and methods in IBaseField to perform field-related actions, such as setting and refreshing field values. Examples of objects that implement IBaseField are: Attachment, Bug, Condition, DesignStep, Host, HostGroup, Req, Run, Step, SubjectNode, SysTreeNode, Test, TestSet, and TSTest.

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property ExecutionParams | The execution parameters for this test instance.
Public Property ExecutionSettings | The execution settings for this test instance.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property HasSteps | Checks if the planning test specified by the Test property has design steps.
Public Property History | The History object for the object.
Public Property HostName | The name of the host planned to run this test instance.
Public Property ID | The item ID.
Public Property Instance | The instance number of this execution test, within the other instances of the same test.
Public Property IsLocked | Checks if object is locked.
Public Property LastRun | The Run object of the last run.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The name of this execution test. By convention, this is the test instance number and the test name.
Public Property Params | The step parameters for this execution test.
Public Property RunFactory | The Run Factory for this execution test.
Public Property Status | The execution test status.
Public Property Test | The planning test of which this execution test in an instance.
Public Property TestId | The ID of the design test of which this is an instance.
Public Property TestName | The name of the design test of which this is an instance.
Public Property TestSet | The test set to which the execution test belongs.
Public Property Type | The execution test type.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

ITSTest Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ITSTest Interface


%%PageItemTitle%%

ITSTest Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ITSTest Interface


%%PageItemTitle%%

ITSTest Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ITSTest Interface


%%PageItemTitle%%

ITSTest Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

ITSTest Interface


%%PageItemTitle%%

ITSTest Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

ITSTest Interface


%%PageItemTitle%%

ITSTest Interface

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

ITSTest Interface


%%PageItemTitle%%

ITSTest Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

ITSTest Interface


%%PageItemTitle%%

ITSTest Interface

ExecutionParams Property

Description

The execution parameters for this test instance.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ExecutionParams() As String

See Also

ITSTest Interface


%%PageItemTitle%%

ITSTest Interface

ExecutionSettings Property

Description

The execution settings for this test instance.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExecutionSettings() As Object

See Also

ITSTest Interface


%%PageItemTitle%%

ITSTest Interface

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName

The name of the field in the project database.

See Also

ITSTest Interface


%%PageItemTitle%%

ITSTest Interface

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

ITSTest Interface


%%PageItemTitle%%

ITSTest Interface

HasSteps Property

Description

Checks if the planning test specified by the Test property has design steps.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasSteps() As Boolean

See Also

ITSTest Interface


%%PageItemTitle%%

ITSTest Interface

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

ITSTest Interface


%%PageItemTitle%%

ITSTest Interface

HostName Property

Description

The name of the host planned to run this test instance.

Property type

Read-write property

Syntax (Visual Basic)

Public Property HostName() As String

Remarks

The host on which the test instance actually runs can be set differently from the planned HostName when running the test, either from TestLab module in the UI or by setting TSScheduler.RunOnHost.

See Also

ITSTest Interface


%%PageItemTitle%%

ITSTest Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

ITSTest Interface


%%PageItemTitle%%

ITSTest Interface

Instance Property

Description

The instance number of this execution test, within the other instances of the same test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Instance() As Long

See Also

ITSTest Interface


%%PageItemTitle%%

ITSTest Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

ITSTest Interface


%%PageItemTitle%%

ITSTest Interface

LastRun Property

Description

The Run object of the last run.

Property type

Read-only property

Syntax (Visual Basic)

Public Property LastRun() As Object

See Also

ITSTest Interface


%%PageItemTitle%%

ITSTest Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

ITSTest Interface


%%PageItemTitle%%

ITSTest Interface

Name Property

Description

The name of this execution test. By convention, this is the test instance number and the test name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ITSTest Interface


%%PageItemTitle%%

ITSTest Interface

Params Property

Description

The step parameters for this execution test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Params() As Object

See Also

ITSTest Interface


%%PageItemTitle%%

ITSTest Interface

RunFactory Property

Description

The Run Factory for this execution test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RunFactory() As Object

See Also

ITSTest Interface


%%PageItemTitle%%

ITSTest Interface

Status Property

Description

The execution test status.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Status() As String

Remarks

Common values of the Status list are:

  • NO_RUN - Default. The instance was never executed.
  • NOT_COMPLETED - Execution of the test instance has not been completed.
  • FAILED - The test instance failed during test execution.
  • PASSED - The test instance passed during test execution.
  • N/A - The execution status is not available.

You can also add a user-defined status. For more information, see 'Customizing Project Lists' in the Mercury Quality Center Administrator's Guide.

See Also

ITSTest Interface


%%PageItemTitle%%

ITSTest Interface

Test Property

Description

The planning test of which this execution test in an instance.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Test() As Object

See Also

ITSTest Interface


%%PageItemTitle%%

ITSTest Interface

TestId Property

Description

The ID of the design test of which this is an instance.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestId() As Variant

See Also

ITSTest Interface


%%PageItemTitle%%

ITSTest Interface

TestName Property

Description

The name of the design test of which this is an instance.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestName() As String

See Also

ITSTest Interface


%%PageItemTitle%%

ITSTest Interface

TestSet Property

Description

The test set to which the execution test belongs.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestSet() As Object

See Also

ITSTest Interface


%%PageItemTitle%%

ITSTest Interface

Type Property

Description

The execution test type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Type() As String

Remarks

Common test types are 'Manual', 'WR-Automated', 'VAPI', 'VAPI-XP'. Test types are delivered with Quality Center or are custom test types added at your site.
To get the full list of types in the project, look at the TestType list. See 'Customizing Project Lists' in the Mercury Quality Center Administrator's Guide.

See Also

ITSTest Interface


%%PageItemTitle%%

ITSTest Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

ITSTest Interface


%%PageItemTitle%%

ITSTest2 Members | TestSet Object | Test Object

ITSTest2 Interface

Description

Represents a test instance, or execution test, in a test set.

Remarks

A test instance represents a single use of a planning Test in a TestSet. It can be associated with one or more runs.

Get a TSTest object from a TSTestFactory.

Interface Remarks

IBaseFieldEx is implemented by several classes, among them: DesignStep, HostGroup, Run, Step, TSTest, and TestSet.
IBaseField defines a basic data field or entity. Use the properties and methods in IBaseField to perform field-related actions, such as setting and refreshing field values. Examples of objects that implement IBaseField are: Attachment, Bug, Condition, DesignStep, Host, HostGroup, Req, Run, Step, SubjectNode, SysTreeNode, Test, TestSet, and TSTest.

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property ExecutionParams | The execution parameters for this test instance.
Public Property ExecutionSettings | The execution settings for this test instance.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property HasCoverage | Checks if the test instance covers at least one requirement.
Public Property HasSteps | Checks if the planning test specified by the Test property has design steps.
Public Property History | The History object for the object.
Public Property HostName | The name of the host planned to run this test instance.
Public Property ID | The item ID.
Public Property Instance | The instance number of this execution test, within the other instances of the same test.
Public Property IsLocked | Checks if object is locked.
Public Property LastRun | The Run object of the last run.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The name of this execution test. By convention, this is the test instance number and the test name.
Public Property Params | The step parameters for this execution test.
Public Property RunFactory | The Run Factory for this execution test.
Public Property Status | The execution test status.
Public Property Test | The planning test of which this execution test in an instance.
Public Property TestId | The ID of the design test of which this is an instance.
Public Property TestName | The name of the design test of which this is an instance.
Public Property TestSet | The test set to which the execution test belongs.
Public Property Type | The execution test type.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.


%%PageItemTitle%%

ITSTest2 Interface

LockObject Method

Description

Locks the object. Returns True if lock successful.

Syntax

Public Function LockObject() As Boolean

Remarks

If an object is locked, no other user can change or delete it.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post or Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ITSTest2 Interface


%%PageItemTitle%%

ITSTest2 Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ITSTest2 Interface


%%PageItemTitle%%

ITSTest2 Interface

Refresh Method

Description

Reads saved values, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

ITSTest2 Interface


%%PageItemTitle%%

ITSTest2 Interface

Undo Method

Description

Undoes changes to field values that have not been posted.

Syntax

Public Sub Undo()

See Also

ITSTest2 Interface


%%PageItemTitle%%

ITSTest2 Interface

UnLockObject Method

Description

Unlocks the object.

Syntax

Public Sub UnLockObject()

Remarks

Releases a locked object for editing or deletion by other users. See comments on LockObject for more details.

See Also

ITSTest2 Interface


%%PageItemTitle%%

ITSTest2 Interface

Attachments Property

Description

The Attachment factory for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attachments() As Object

See Also

ITSTest2 Interface


%%PageItemTitle%%

ITSTest2 Interface

AutoPost Property

Description

If true, the database is updated immediately when the field value changes.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoPost() As Boolean

See Also

ITSTest2 Interface


%%PageItemTitle%%

ITSTest2 Interface

ExecutionParams Property

Description

The execution parameters for this test instance.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ExecutionParams() As String

See Also

ITSTest2 Interface


%%PageItemTitle%%

ITSTest2 Interface

ExecutionSettings Property

Description

The execution settings for this test instance.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExecutionSettings() As Object

See Also

ITSTest2 Interface


%%PageItemTitle%%

ITSTest2 Interface

FieldName

The name of the field in the project database.

See Also OTA COM Type Library

Field Property

Description

The value of the specified field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Field( _
   ByVal FieldName As String _
) As Variant

Parameters

FieldName

The name of the field in the project database.

See Also

ITSTest2 Interface


%%PageItemTitle%%

ITSTest2 Interface

HasAttachment Property

Description

Checks if the object has one or more attachments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasAttachment() As Boolean

See Also

ITSTest2 Interface


%%PageItemTitle%%

ITSTest2 Interface

HasCoverage Property

Description

Checks if the test instance covers at least one requirement.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasCoverage() As Boolean

See Also

ITSTest2 Interface


%%PageItemTitle%%

ITSTest2 Interface

HasSteps Property

Description

Checks if the planning test specified by the Test property has design steps.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasSteps() As Boolean

See Also

ITSTest2 Interface


%%PageItemTitle%%

ITSTest2 Interface

History Property

Description

The History object for the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property History() As Object

See Also

ITSTest2 Interface


%%PageItemTitle%%

ITSTest2 Interface

HostName Property

Description

The name of the host planned to run this test instance.

Property type

Read-write property

Syntax (Visual Basic)

Public Property HostName() As String

Remarks

The host on which the test instance actually runs can be set differently from the planned HostName when running the test, either from TestLab module in the UI or by setting TSScheduler.RunOnHost.

See Also

ITSTest2 Interface


%%PageItemTitle%%

ITSTest2 Interface

ID Property

Description

The item ID.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As Variant

See Also

ITSTest2 Interface


%%PageItemTitle%%

ITSTest2 Interface

Instance Property

Description

The instance number of this execution test, within the other instances of the same test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Instance() As Long

See Also

ITSTest2 Interface


%%PageItemTitle%%

ITSTest2 Interface

IsLocked Property

Description

Checks if object is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

ITSTest2 Interface


%%PageItemTitle%%

ITSTest2 Interface

LastRun Property

Description

The Run object of the last run.

Property type

Read-only property

Syntax (Visual Basic)

Public Property LastRun() As Object

See Also

ITSTest2 Interface


%%PageItemTitle%%

ITSTest2 Interface

Modified Property

Description

Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Modified() As Boolean

See Also

ITSTest2 Interface


%%PageItemTitle%%

ITSTest2 Interface

Name Property

Description

The name of this execution test. By convention, this is the test instance number and the test name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ITSTest2 Interface


%%PageItemTitle%%

ITSTest2 Interface

Params Property

Description

The step parameters for this execution test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Params() As Object

See Also

ITSTest2 Interface


%%PageItemTitle%%

ITSTest2 Interface

RunFactory Property

Description

The Run Factory for this execution test.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RunFactory() As Object

See Also

ITSTest2 Interface


%%PageItemTitle%%

ITSTest2 Interface

Status Property

Description

The execution test status.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Status() As String

Remarks

Common values of the Status list are:

  • NO_RUN - Default. The instance was never executed.
  • NOT_COMPLETED - Execution of the test instance has not been completed.
  • FAILED - The test instance failed during test execution.
  • PASSED - The test instance passed during test execution.
  • N/A - The execution status is not available.

You can also add a user-defined status. For more information, see 'Customizing Project Lists' in the Mercury Quality Center Administrator's Guide.

See Also

ITSTest2 Interface


%%PageItemTitle%%

ITSTest2 Interface

Test Property

Description

The planning test of which this execution test in an instance.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Test() As Object

See Also

ITSTest2 Interface


%%PageItemTitle%%

ITSTest2 Interface

TestId Property

Description

The ID of the design test of which this is an instance.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestId() As Variant

See Also

ITSTest2 Interface


%%PageItemTitle%%

ITSTest2 Interface

TestName Property

Description

The name of the design test of which this is an instance.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestName() As String

See Also

ITSTest2 Interface


%%PageItemTitle%%

ITSTest2 Interface

TestSet Property

Description

The test set to which the execution test belongs.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TestSet() As Object

See Also

ITSTest2 Interface


%%PageItemTitle%%

ITSTest2 Interface

Type Property

Description

The execution test type.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Type() As String

Remarks

Common test types are 'Manual', 'WR-Automated', 'VAPI', 'VAPI-XP'. Test types are delivered with Quality Center or are custom test types added at your site.
To get the full list of types in the project, look at the TestType list. See 'Customizing Project Lists' in the Mercury Quality Center Administrator's Guide.

See Also

ITSTest2 Interface


%%PageItemTitle%%

ITSTest2 Interface

Virtual Property

Description

Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Virtual() As Boolean

See Also

ITSTest2 Interface


%%PageItemTitle%%

IVCS Members

IVCS Interface

Description

Represents a Version Control System connection.

Remarks

Get a VCS object from TDConnection.VCS or Test.VCS.

Public Methods

Public Method AddObjectToVcs | Adds an object to the Version control database.
Public Method CheckIn | Checks in an object.
Public Method CheckInEx | Checks in an object.
Public Method CheckOut | Checks out an object
Public Method DeleteObjectFromVCS | Deletes the object from the Version Control database.
Public Method LockVcsObject | Changes VCS object status from GET to CHECK-OUT. The object must be in a GET status to use this method.
Public Method Refresh | Refreshes the VCS object from the server to the client, overwriting values in memory.
Public Method SetCurrentVersion | This method is potentially destructive. Use only if necessary and with care. Sets the VCS object current version.
Public Method UndoCheckout | Undoes the check out operation, falling back to the current version on the server.

Public Properties

Public Property CheckoutInfo | A reference to a VersionItem object, containing the checkout information of the current object.
Public Property CurrentVersion | The current object latest version.
Public Property IsCheckedOut | Checks if the object is in CHECKED-OUT or GET status.
Public Property IsLocked | Checks if object is locked by the version control system.
Public Property LockedBy | The name of the locking user.
Public Property Version | The version the current user is viewing.
Public Property VersionInfo | A reference to a VersionItem object containing information about a specific version, specified by the Version argument.
Public Property Versions | A list of version strings, representing all the versions in the object.
Public Property VersionsEx | A list of IVersionItem references for accessing the details of each version in the object. .


%%PageItemTitle%%

IVCS Interface

Version

Specifies the starting version number of the test.

Comments

Comments pertaining to the object version.

See Also OTA COM Type Library

AddObjectToVcs Method

Description

Adds an object to the Version control database.

Syntax

Public Sub AddObjectToVcs( _
   Optional ByVal Version As String = "1.1.1", _
   Optional ByVal Comments As String = "Object Created in VCS" _
)

Parameters

Version

Specifies the starting version number of the test.

Comments

Comments pertaining to the object version.

Remarks

When using an automated test, this method must be used after the test files are uploaded from the client to the server.

See Also

IVCS Interface


%%PageItemTitle%%

IVCS Interface

Version

The starting version number of the object.

Comments

Comment on the object version.

Remove

If True, delete the files from the file system.
It is recommended not to use this option.

SetCurrent

Sets the version you are currently working with as the current one.
It is recommended not to use this option.

See Also OTA COM Type Library

CheckIn Method

Description

Checks in an object.

Syntax

Public Sub CheckIn( _
   ByVal Version As String, _
   ByVal Comments As String, _
   Optional ByVal Remove As Boolean = True, _
   Optional ByVal SetCurrent As Boolean = True _
)

Parameters

Version

The starting version number of the object.

Comments

Comment on the object version.

Remove

If True, delete the files from the file system.
It is recommended not to use this option.

SetCurrent

Sets the version you are currently working with as the current one.
It is recommended not to use this option.

Remarks

This method can also be used in case of a conflict caused by a change in the StepParams value.

See Also

IVCS Interface


%%PageItemTitle%%

IVCS Interface

Version

The starting version number of the object.

Comments

Comment on the object version.

Remove

If True, delete the files from the file system.
It is recommended not to use this option.

SetCurrent

Sets the version you are currently working with as the current one.
It is recommended not to use this option.

ForceCheckin

If True, ignores conflict. Otherwise, checks for conflict.

Reserved

Not in use.

See Also OTA COM Type Library

CheckInEx Method

Description

Checks in an object.

Syntax

Public Sub CheckInEx( _
   ByVal Version As String, _
   ByVal Comments As String, _
   Optional ByVal Remove As Boolean = True, _
   Optional ByVal SetCurrent As Boolean = True, _
   Optional ByVal ForceCheckin As Boolean = False, _
   Optional ByVal Reserved As ULong = 0 _
)

Parameters

Version

The starting version number of the object.

Comments

Comment on the object version.

Remove

If True, delete the files from the file system.
It is recommended not to use this option.

SetCurrent

Sets the version you are currently working with as the current one.
It is recommended not to use this option.

ForceCheckin

If True, ignores conflict. Otherwise, checks for conflict.

Reserved

Not in use.

Remarks

This method can also be used in case of a conflict caused by a change in the StepParams value.

See Also

IVCS Interface


%%PageItemTitle%%

IVCS Interface

Version

The version number of the object. Pass an empty string to check out the latest version.

Comment

Comment pertaining to the object version.

Lock

If True, check out and lock the object. Otherwise, just get copy.

ReadOnly

If True, the checked out files will be read only.
It is recommended not to use this option.

Sync

For internal use.

See Also OTA COM Type Library

CheckOut Method

Description

Checks out an object

Syntax

Public Sub CheckOut( _
   ByVal Version As String, _
   ByVal Comment As String, _
   ByVal Lock As Boolean, _
   Optional ByVal ReadOnly As Boolean = False, _
   Optional ByVal Sync As Boolean = True _
)

Parameters

Version

The version number of the object. Pass an empty string to check out the latest version.

Comment

Comment pertaining to the object version.

Lock

If True, check out and lock the object. Otherwise, just get copy.

ReadOnly

If True, the checked out files will be read only.
It is recommended not to use this option.

Sync

For internal use.

See Also

IVCS Interface


%%PageItemTitle%%

IVCS Interface

DeleteObjectFromVCS Method

Description

Deletes the object from the Version Control database.

Syntax

Public Sub DeleteObjectFromVCS()

See Also

IVCS Interface


%%PageItemTitle%%

IVCS Interface

LockVcsObject Method

Description

Changes VCS object status from GET to CHECK-OUT. The object must be in a GET status to use this method.

Syntax

Public Sub LockVcsObject()

See Also

IVCS Interface


%%PageItemTitle%%

IVCS Interface

Refresh Method

Description

Refreshes the VCS object from the server to the client, overwriting values in memory.

Syntax

Public Sub Refresh()

Remarks

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Refresh operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IVCS Interface


%%PageItemTitle%%

IVCS Interface

Version

The version number to make current.

See Also OTA COM Type Library

SetCurrentVersion Method

Description

This method is potentially destructive. Use only if necessary and with care. Sets the VCS object current version.

Syntax

Public Sub SetCurrentVersion( _
   ByVal Version As String _
)

Parameters

Version

The version number to make current.

See Also

IVCS Interface


%%PageItemTitle%%

IVCS Interface

Remove

Always pass "True".

See Also OTA COM Type Library

UndoCheckout Method

Description

Undoes the check out operation, falling back to the current version on the server.

Syntax

Public Sub UndoCheckout( _
   ByVal Remove As Boolean _
)

Parameters

Remove

Always pass "True".

Remarks

The local copy of the file is removed when UndoCheckout is called.

See Also

IVCS Interface


%%PageItemTitle%%

IVCS Interface

CheckoutInfo Property

Description

A reference to a VersionItem object, containing the checkout information of the current object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property CheckoutInfo() As Object

See Also

IVCS Interface


%%PageItemTitle%%

IVCS Interface

CurrentVersion Property

Description

The current object latest version.

Property type

Read-only property

Syntax (Visual Basic)

Public Property CurrentVersion() As String

See Also

IVCS Interface


%%PageItemTitle%%

IVCS Interface

IsCheckedOut Property

Description

Checks if the object is in CHECKED-OUT or GET status.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsCheckedOut() As Boolean

See Also

IVCS Interface


%%PageItemTitle%%

IVCS Interface

IsLocked Property

Description

Checks if object is locked by the version control system.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

IVCS Interface


%%PageItemTitle%%

IVCS Interface

LockedBy Property

Description

The name of the locking user.

Property type

Read-only property

Syntax (Visual Basic)

Public Property LockedBy() As String

See Also

IVCS Interface


%%PageItemTitle%%

IVCS Interface

Version Property

Description

The version the current user is viewing.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Version() As String

See Also

IVCS Interface


%%PageItemTitle%%

IVCS Interface

Version

The version number of the object: <major version>.<minor version>.<build>.

See Also OTA COM Type Library

VersionInfo Property

Description

A reference to a VersionItem object containing information about a specific version, specified by the Version argument.

Property type

Read-only property

Syntax (Visual Basic)

Public Property VersionInfo( _
   ByVal Version As String _
) As Object

Parameters

Version

The version number of the object: <major version>.<minor version>.<build>.

See Also

IVCS Interface


%%PageItemTitle%%

IVCS Interface

Versions Property

Description

A list of version strings, representing all the versions in the object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Versions() As List

See Also

IVCS Interface


%%PageItemTitle%%

IVCS Interface

VersionsEx Property

Description

A list of IVersionItem references for accessing the details of each version in the object. .

Property type

Read-only property

Syntax (Visual Basic)

Public Property VersionsEx() As List

See Also

IVCS Interface


%%PageItemTitle%%

IVersionItem Members

IVersionItem Interface

Description

Represents specific version information.

Remarks

Get a list of VersionItem objects from VCS.VersionsEx.

Public Properties

Public Property Comments | The check-in comments.
Public Property Date | The check-in date.
Public Property IsLocked | Checks if the item is locked.
Public Property Time | The check-in time.
Public Property User | The user who performed the check-in.
Public Property Version | The version checked in.


%%PageItemTitle%%

IVersionItem Interface

Comments Property

Description

The check-in comments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

IVersionItem Interface


%%PageItemTitle%%

IVersionItem Interface

Date Property

Description

The check-in date.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Date() As String

See Also

IVersionItem Interface


%%PageItemTitle%%

IVersionItem Interface

IsLocked Property

Description

Checks if the item is locked.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsLocked() As Boolean

Remarks

IsLocked is set by the LockObject method and is reset by the UnlockObject method.

If the object has an AutoUnlock property and the property is set to True, IsLocked is also reset by a Post or Refresh operation.

See Also

IVersionItem Interface


%%PageItemTitle%%

IVersionItem Interface

Time Property

Description

The check-in time.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Time() As String

See Also

IVersionItem Interface


%%PageItemTitle%%

IVersionItem Interface

User Property

Description

The user who performed the check-in.

Property type

Read-only property

Syntax (Visual Basic)

Public Property User() As String

See Also

IVersionItem Interface


%%PageItemTitle%%

IVersionItem Interface

Version Property

Description

The version checked in.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Version() As String

See Also

IVersionItem Interface


%%PageItemTitle%%

OTA COM Type Library

tagALERT_TYPE Enumeration

Members

Member | Value | Description
ALERT_TYPE_TRACEABILITY_ALERT | 0 (Ox0) | Traceability system alert.
ALERT_TYPE_FOLLOWUP | 1 (Ox1) | Follow Up - reminder.
ALERT_TYPE_COMMON | 2 (Ox2) | Traceability common system alert.


%%PageItemTitle%%

OTA COM Type Library

tagBPPARAM_TYPE Enumeration

Members

Member | Value | Description
BPPARAM_TYPE_CONSTANT | 0 (Ox0) | Constant parameter value.
BPPARAM_TYPE_REFERENCE | 1 (Ox1) | The value is from an output BPParameter of a previous action.
BPPARAM_TYPE_RUNTIME | 2 (Ox2) | Run time parameter value.


%%PageItemTitle%%

OTA COM Type Library

tagBPT_VERSION Enumeration

Members

Member | Value | Description
BPT_VERSION_3 | 3 (Ox3) | Starting on QC 8.2 SP1
BPT_VERSION_4 | 4 (Ox4) | QC 9.0


%%PageItemTitle%%

OTA COM Type Library

tagEXTENDED_STORAGE_DELETE Enumeration

Members

Member | Value | Description
NO_DELETE | 0 (Ox0) |
DELETE_CLIENT | 1 (Ox1) |
DELETE_SERVER | 2 (Ox2) |
DELETE_BOTH | 3 (Ox3) |


%%PageItemTitle%%

OTA COM Type Library

tagEXTENDEDSTORAGE_ENTITY Enumeration

Members

Member | Value | Description
EXTENDEDSTORAGE_ENTITY_SCRIPT | 0 (Ox0) | Extended storage of the script.
EXTENDEDSTORAGE_ENTITY_PICTURE | 1 (Ox1) | Extended storage of the picture.


%%PageItemTitle%%

OTA COM Type Library

tagGRAPH_PROPERTIES Enumeration

Members

Member | Value | Description
GRAPH_XAXIS | 0 (Ox0) | Name of the field to use as X axis for summary graph.
GRAPH_GROUP_BY | 1 (Ox1) | Name of the field to group by.
GRAPH_SUM_OF | 2 (Ox2) | Name of the field to sum the values of (instead of displaying entities' count.
GRAPH_START_DATE | 3 (Ox3) | Starting date for trend and progress graphs.
GRAPH_SHOW_NOT_COVERED_PARENTS | 4 (Ox4) | In requirements module, if true, not-covered parent requirements are included as well.
GRAPH_TEST_SET_ID | 5 (Ox5) | In test lab module, defines the ID of the test set to build graph for.
GRAPH_XAXIS_SHOW_FULL_PATH | 8 (Ox8) | In test plan and test lab modules, defines whether XAxis subject or test set full paths should be displayed.
GRAPH_GROUP_BY_SHOW_FULL_PATH | 9 (Ox9) | In test plan and test lab modules, defines whether Group By subject or test set full paths should be displayed.
GRAPH_CYCLE | 10 (OxA) | In test requirment module, set the cycle for the coverage graph.
GRAPH_RELEASE | 11 (OxB) | In test requirment module, set the release for the coverage graph.


%%PageItemTitle%%

OTA COM Type Library

tagMAIL_CONDITIONS_TYPE Enumeration

Members

Member | Value | Description
USER_MAIL_CONDITION | 0 (Ox0) | User mail condition.
FIELD_MAIL_CONDITION | 1 (Ox1) | Field mail condition.


%%PageItemTitle%%

OTA COM Type Library

tagSEARCH_OPTIONS Enumeration

Members

Member | Value | Description
SEARCH_IN_STEPS | 0 (Ox0) | When searching for tests, indicates whether to search in tests themselves or in their design steps.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_ATTACH Enumeration

Description

Attachment Flags.

Members

Member | Value | Description
TDATT_COPY | 1 (Ox1) | Synchronous upload or download.
TDATT_MOVE | 2 (Ox2) | Move attachment.
TDATT_LINK | 3 (Ox3) | Create URL attachment.
TDATT_COPY_ASINCHRONE | 4 (Ox4) | Asynchronous upload or download.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_ATTACH_SUBTYPE Enumeration

Description

Attachment Sub Type.

Members

Member | Value | Description
TDATT_NONE | 0 (Ox0) | Empty subtype.
TDATT_RICH_CONTENT | 1 (Ox1) | Rich content attachment.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_ATTACH_TYPE Enumeration

Description

Attachment Type.

Members

Member | Value | Description
TDATT_FILE | 1 (Ox1) | File attachment.
TDATT_INTERNET | 2 (Ox2) | URL attachment.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_BP_STEP_PARAM_TYPE Enumeration

Members

Member | Value | Description
BP_STEP_PARAM_IN | 0 (Ox0) | Input Parameter.
BP_STEP_PARAM_OUT | 1 (Ox1) | Output Parameter.
BP_STEP_PARAM_RUNTIME | 2 (Ox2) | Runtime Parameter.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_COMPONENT_AUTO_TYPE Enumeration

Description

Components Automation Type Values.

Members

Member | Value | Description
MANUAL | 1 (Ox1) | Manual AutoType.
KW | 2 (Ox2) | QTP's KeyWord AutoType.
SCRIPTED | 3 (Ox3) | Scripted AutoType.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_CONDSTAT Enumeration

Description

Run condition statuses.

Members

Member | Value | Description
TDCOND_FINISHED | 1 (Ox1) | The run finished.
TDCOND_PASSED | 2 (Ox2) | The run finished successfully.
TDCOND_FAILED | 3 (Ox3) | FAILED condition status.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_CONDTYPE Enumeration

Description

Execution flow condition type.

Members

Member | Value | Description
TDCOND_RUN | 1 (Ox1) | The condition is a run status.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_COPY_PASTE_MODES Enumeration

Description

Options for pasting design steps linked to tests where the linked tests already exist in the target project.

Members

Member | Value | Description
COPY_PASTE_NO_LINKED_TEST_MODE | 0 (Ox0) | Do not copy the linked tests.
COPY_PASTE_USE_LINKED_TEST_MODE | 1 (Ox1) | Link the design steps to the existing tests.
COPY_PASTE_CREATE_LINKED_TEST_MODE | 2 (Ox2) | Create new copies of the linked tests.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_DATATYPES Enumeration

Description

Data types.

Members

Member | Value | Description
TDOLE_LONG | 0 (Ox0) | Long integer.
TDOLE_ULONG | 1 (Ox1) | Unsigned long integer.
TDOLE_FLOAT | 2 (Ox2) | Floating point number.
TDOLE_STRING | 3 (Ox3) | String.
TDOLE_MEMO | 4 (Ox4) | Memo.
TDOLE_DATE | 5 (Ox5) | Date.
TDOLE_TIMESTAMP | 6 (Ox6) | Time stamp.
TDOLE_TREENODE | 7 (Ox7) | General tree node.
TDOLE_USER_LIST | 8 (Ox8) | List of users.
TDOLE_TESTSET_LIST | 9 (Ox9) | List of test sets.
TDOLE_HOST_LIST | 10 (OxA) | List of hosts.
TDOLE_SUBJECT_TREENODE | 11 (OxB) | Subject tree node.
TDOLE_TESTSET_FOLDER | 12 (OxC) | Test set folders tree node.
TDOLE_REQUIREMENT_TREENODE | 13 (OxD) | Requirements tree node.
TDOLE_REQUIREMENT_TYPE_ID | 14 (OxE) | Requirement type ID.
TDOLE_RELEASE_SINGLE_TREENODE | 15 (OxF) | Release single-value tree node.
TDOLE_RELEASE_MULTI_TREENODE | 16 (Ox10) | Release multi-value tree node.
TDOLE_RELEASECYCLE_SINGLE_TREENODE | 17 (Ox11) | ReleaseCycle single-value tree node.
TDOLE_RELEASECYCLE_MULTI_TREENODE | 18 (Ox12) | ReleaseCycle multi-value tree node.
TDOLE_APPLICATION_ENTITY_FOLDER | 19 (Ox13) | Application entity folders tree node.
TDOLE_CHANGE_ENTITY_FOLDER | 20 (Ox14) | Change entity folders tree node.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_DIRECTORY Enumeration

Members

Member | Value | Description
TDOLE_PROGECT_DIRECTORY | 0 (Ox0) | The main project directory.
TDOLE_PROJECT_DIRECTORY | 0 (Ox0) | The main project directory.
TDOLE_BIN_DIRECTORY | 1 (Ox1) | The General Bin directory.
TDOLE_TEST_DIRECTORY | 2 (Ox2) | The test repository directory.
TDOLE_ATTACH_DIRECTORY | 3 (Ox3) | The Attachment Repository.
TDOLE_USER_DIRECTORIES | 4 (Ox4) | The User Directories List.
TDOLE_SHARED_DIRECTORY | 128 (Ox80) | The shared path of the directories.
TDOLE_CHECKOUT_DIRECTORY | 8 (Ox8) | The checkout repository directory.
TDOLE_VIEW_DIRECTORY | 16 (Ox10) | The checkout repository directory.
TDOLE_VCSDB_DIRECTORY | 32 (Ox20) | The vcsDb repository directory.
TDOLE_SITE_REPOS_DIRECTORY | 64 (Ox40) | The TD root repository directory.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_ENTITIES Enumeration

Description

The entities for customization types.

Members

Member | Value | Description
ENTITY_REQUIREMENT | 0 (Ox0) | Customization for requirements.
ENTITY_BUG | 1 (Ox1) | Not supported in Quality Center 9.2


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_ERRORCODES Enumeration

Remarks

The Quality Center API handles errors as OLE exceptions. To get the Quality Center error, subtract the Visual Basic vbObjectError constant from the error number, as shown in the example below.

Example

This example shows handling of errors on user login. If the error is an illegal password, the login dialog is displayed again. If a different error has occurred, the appropriate error message is displayed.

[Visual Basic]

Private Sub Login(ProjectName As String, User As String, _
        &Password As String)

    On Error GoTo CheckError

    ‘tdc is a TDConnection object
    tdc.ConnectProject ProjectName, User, Password
    Exit Sub

CheckError:
    if (Err.Number - vbObjectError) = _
        TDAPIOLELib.TDOLE_ILLEGALPASSWORD Then
            LoginForm.Show 1
    Else
        MsgBox "Error: " & Err.Description, vbCritical
    End If
End Sub

Members

Member | Value | Description
TDOLE_OBJNOTINITIALIZED | 1001 (Ox3E9) | Quality Center server object not initialized.
TDOLE_GENERROR | 1002 (Ox3EA) | General error.
TDOLE_NOCONFIGFILE | 1003 (Ox3EB) | The BDE configuration file not found.
TDOLE_ILLEGALPASSWORD | 1004 (Ox3EC) | Wrong user name or password.
TDOLE_ILLEGALDBNAME | 1005 (Ox3ED) | Wrong Quality Center project name.
TDOLE_NODBDIR | 1006 (Ox3EE) | The Quality Center project directory was not found.
TDOLE_NOTESTDIR | 1007 (Ox3EF) | The Test Repository was not found.
TDOLE_DBLIMIT | 1008 (Ox3F0) | The maximum number of projects is open.
TDOLE_DBVERMISMATCH | 1009 (Ox3F1) | Project version mismatch.
TDOLE_NO_IDAPI_DLL | 1010 (Ox3F2) | No BDE is installed.
TDOLE_RECNOTFOUND | 1011 (Ox3F3) | No record matches the key value.
TDOLE_NOFIELD | 1012 (Ox3F4) | The specified field does not exist.
TDOLE_NOTAUTOTEST | 1013 (Ox3F5) | The test is not an automated test.
TDOLE_NODIRECTORY | 1014 (Ox3F6) | The specified directory does not exist.
TDOLE_ATEOF | 1015 (Ox3F7) | The end of the table has been reached.
TDOLE_ATBOF | 1016 (Ox3F8) | The beginning of the table has been reached.
TDOLE_INVALIDATTRNAME | 1017 (Ox3F9) | The specified attribute does not exist.
TDOLE_ILLEGALSUBJECTPATH | 1018 (Ox3FA) | The specified subject path does not exist.
TDOLE_MANUALTEST | 1019 (Ox3FB) | The specified test type is not an automatic test.
TDOLE_CHANGED | 1020 (Ox3FC) | The API has changed.
TDOLE_DBNOTCONNECTED | 1021 (Ox3FD) | The API is not connected to a project.
TDOLE_INVALIDNODEID | 1022 (Ox3FE) | The specified node ID is invalid.
TDOLE_NONODE | 1023 (Ox3FF) | The specified node does not exist.
TDOLE_CANNTOPENTESTTB | 1024 (Ox400) | Cannot open Test table.
TDOLE_CANNTOPENSTEPTB | 1025 (Ox401) | Cannot open Step table.
TDOLE_CANNTOPENRUNTB | 1026 (Ox402) | Cannot open Run table.
TDOLE_CANNTOPENTESTCYCLTB | 1027 (Ox403) | Cannot open Testcycle table.
TDOLE_CANNTOPENCYCLETB | 1028 (Ox404) | Cannot open Cycle table.
TDOLE_CANNTOPENDESSTEPTB | 1029 (Ox405) | Cannot open Dessteps table.
TDOLE_CANNTOPENHISTTB | 1030 (Ox406) | Cannot open History table.
TDOLE_CANNTBUILDTREE | 1031 (Ox407) | Cannot build the test plan tree.
TDOLE_NOASSOCIATEDROOT | 1032 (Ox408) | No associated tree root.
TDOLE_VCS_NOVCS | 1033 (Ox409) | VCS support is not installed on the Quality Center server side.
TDOLE_VCS_NOTVCSDB | 1034 (Ox40A) | The Quality Center project is not connected to the VCS database.
TDOLE_VCS_CANNOTLOGIN | 1035 (Ox40B) | Cannot log into the VCS database.
TDOLE_VCS_NOTINVCSDB | 1036 (Ox40C) | The test is not in the VCS database.
TDOLE_VCS_LOCKEDMETEST | 1037 (Ox40D) | The test is locked by the current user.
TDOLE_VCS_LOCKEDTEST | 1038 (Ox40E) | The test is locked by another user.
TDOLE_VCS_NOTCONNECTED | 1039 (Ox40F) | Not connected to the VCS database.
TDOLE_VCS_NOTCHECKEDOUT | 1040 (Ox410) | The test is not checked out.
TDOLE_VCS_NOTLOCKED | 1041 (Ox411) | The test is not locked.
TDOLE_VCS_NOTDEFVERFILE | 1042 (Ox412) | There is no version file defined for the test type.
TDOLE_FAILED_TO_SET_CUR_VER | 1043 (Ox413) | Failed to set the working version of the test.
TDOLE_FAILED_TO_GET_CUR_VER | 1044 (Ox414) | Failed to get the working version of the test.
TDOLE_MAIL_NO_ERROR | 1045 (Ox415) | No error encountered.
TDOLE_NO_MAIL_DLL | 1046 (Ox416) | The mail DLL was not found.
TDOLE_MAIL_NO_TO_FIELD | 1047 (Ox417) | The wrong 'To:' address.
TDOLE_MAIL_ERR_PARSING_PARAMS | 1048 (Ox418) | The mail format is incorrect.
TDOLE_MAIL_GENERROR | 1049 (Ox419) | General mail error.
TDOLE_MAIL_LOGIN_FAILURE | 1050 (Ox41A) | The mailbox login is incorrect.
TDOLE_MAIL_ERR_SENDING | 1051 (Ox41B) | Failure sending mail.
TDOLE_MAIL_BAD_FROM_FIELD | 1052 (Ox41C) | The 'From' parameter is invalid.
TDOLE_WARNING_FROM_NOT_FOUND | 1053 (Ox41D) | The 'From' parameter is missing.
TDOLE_MAIL_WARNING_BAD_OR_EMPTY_USER_OR_USERGROUP | 1410 (Ox582) | One or more e-mail addresses are invalid.
TDOLE_NOABSOLUTEPATH | 1054 (Ox41E) | No absolute path.
TDOLE_TEST_EXISTS | 1055 (Ox41F) | The test exists.
TDOLE_LICENSE_DENIED | 1056 (Ox420) | No license to access this module.
TDOLE_LICENSE_OVERFLOW_ALERT | 1057 (Ox421) | No license to access this module.
TDOLE_LICENSE_NOT_INITILIZED | 1058 (Ox422) | No license to access this module.
TDOLE_LICENSE_GENERROR | 1059 (Ox423) | Failed to extract license status.
TDOLE_LICENSE_KEY_EXPIRED | 1060 (Ox424) | License expired.
TDOLE_LICENSE_DOMAIN_NOT_FOUND | 1061 (Ox425) | Invalid license.
TDOLE_LICENSE_MUID_NOT_FOUND | 1062 (Ox426) | Invalid license.
TDOLE_VCS_VERSIONEXISTS | 1063 (Ox427) | The version already exists.
TDOLE_VCS_VERSIONNOTEXISTS | 1064 (Ox428) | Required version does not exist in the version control.
TDOLE_BAD_REQUEST | 1065 (Ox429) | Invalid request format.
TDOLE_BAD_ATT_STREAM | 1066 (Ox42A) | Attachment stream is invalid.
TDOLE_RECCOVER_EXISTS | 1068 (Ox42C) | Duplicate requirement coverage.
TDOLE_ERROR_FILESYSTEM | 1069 (Ox42D) | File system error.
TDOLE_ERROR_PATH_NOT_FOUND | 1070 (Ox42E) | File system path is not valid.
TDAPI_ERROR_PATH_PERMISSION | 1071 (Ox42F) | File system permission error.
TDAPI_DISCONNECTED_BY_ADMIN | 1077 (Ox435) | The project was disconnected by the administrator.
TDAPI_FAILED_TO_RECONNECT | 1078 (Ox436) | Cannot connect to the project.
TDOLE_DUPLICATENODENAME | 1080 (Ox438) | Duplicate SysTreeNode name.
TDOLE_MAIL_ERROR_BAD_ENTITY | 1081 (Ox439) | Cannot find entity by e-mail.
TDOLE_CYCLE_EXISTS | 1082 (Ox43A) | Duplicate TestSet name.
TDOLE_BAD_FILTER_START | 1100 (Ox44C) | Invalid filter.
TDOLE_BAD_FILTER_1 | 1101 (Ox44D) | Invalid filter.
TDOLE_BAD_FILTER_2 | 1102 (Ox44E) | Invalid filter.
TDOLE_BAD_FILTER_3 | 1103 (Ox44F) | Invalid filter.
TDOLE_BAD_FILTER_4 | 1104 (Ox450) | Invalid filter.
TDOLE_BAD_FILTER_5 | 1105 (Ox451) | Invalid filter.
TDOLE_BAD_FILTER_6 | 1106 (Ox452) | Invalid filter.
TDOLE_BAD_FILTER_7 | 1107 (Ox453) | Invalid filter.
TDOLE_BAD_FILTER_END | 1110 (Ox456) | Invalid filter.
TDOLE_TESTS_ALREADY_RUN | 1111 (Ox457) | The test has been executed by another user.
TDOLE_E_CREATE_LOG_FILE | 1112 (Ox458) | Cannot create log file.
TDOLE_E_START_RUNS | 1113 (Ox459) | Cannot execute test.
TDOLE_ILLEGALUSERNAME | 1152 (Ox480) | Wrong user name.
TDOLE_REQUEST_CANCELLED | 1153 (Ox481) | Request has been cancelled.
TDOLE_RESPONSE_TAMPERED | 1154 (Ox482) | Response has been tampered.
TDOLE_DB_TABLE_NAME | 2000 (Ox7D0) | No table exists by the specific name.
TDOLE_REQ_EXISTS | 2055 (Ox807) | Duplicate requirement name - requirement was created.
TDAPI_REQ_EXISTS_ABORT | 2056 (Ox808) | Duplicate requirement name - requirement was not created.
TDAPI_REQ_VIOLATION_OF_TYPE_HIER_RULES | 2060 (Ox80C) | Violation of requirements tree hierarchical rules.
TDAPI_TEXT_SEARCH_INDEX_MISSING | 2205 (Ox89D) | Columns marked as searchable are not indexed in database.
TDAPI_QUERY_VALIDATION_FAILED_TOO_MANY_STATEMENTS | 2210 (Ox8A2) | Too many SQL statements.
TDAPI_QUERY_VALIDATION_FAILED_BLACK_LIST_EXISTS | 2211 (Ox8A3) | Word from black list appears in SQL.
TDAPI_QUERY_VALIDATION_FAILED_NOT_SELECT_STATEMENT | 2212 (Ox8A4) | Not a SELECT statement.
TDOLE_TESTSET_FOLDER_EXISTS | 3055 (OxBEF) | Duplicate TestSet folder name.
TDOLE_COMPONENT_EXISTS | 7001 (Ox1B59) | Component exists.
TDOLE_COMPONENT_FOLDER_EXISTS | 7002 (Ox1B5A) | Component folder exists.
TDOLE_COMPONENT_PARAM_EXISTS | 7003 (Ox1B5B) | Component parameter exists.
COMPONENT_E_CREATE | 7004 (Ox1B5C) | Error creating component.
COMPONENTFOLDER_E_CREATE | 7005 (Ox1B5D) | Error creating component folder.
COMPONENTPARAM_E_CREATE | 7006 (Ox1B5E) | Error creating component parameter.
TDOLE_E_NON_PROJECT_SPECIFIC_BPT | 7007 (Ox1B5F) | Non-project-specific business process test.
COMPONENTSTEP_E_CREATE | 7008 (Ox1B60) |
TDOLE_E_BPT_ITERATIONS_MISMATCH | 7009 (Ox1B61) | Business process test iterations mismatch.
TDOLE_E_BPT_COMPONENT_STEP_VALIDATION_FAILED | 7010 (Ox1B62) | Business process test component step validation failed.
IMPEXP_RESOURCE_DOESNT_EXIST | 7100 (Ox1BBC) | Import/Export resource does not exist.
TDOLE_E_REMOVE_TYPE_VALIDATION_FAILED | 7200 (Ox1C20) | Cannot remove type.
TDOLE_FAIL_TO_REMOVE_TYPE_COVERAGE | 7201 (Ox1C21) | Failed to remove coverage from requirement type.
TDOLE_RELEASE_FOLDER_EXISTS | 8004 (Ox1F44) | Release folder exists.
TDOLE_RELEASE_EXISTS | 8005 (Ox1F45) | Release exists.
TDOLE_RELEASECYCLE_EXISTS | 8006 (Ox1F46) | ReleaseCycle exists.
TDOLE_SERVER_LOCKS_REMOVED | 10700 (Ox29CC) | Server locks removed.
TDOLE_FAILED_LOCK_REMOVE | 10710 (Ox29D6) | Failed to unlock object.
TDOLE_OBJECT_LOCKED | 10720 (Ox29E0) | Object locked by another user.
TDOLE_WRONG_ADMIN_PWD | 10730 (Ox29EA) | Wrong administrator password.
TDOLE_ADMIN_NOT_CONNECTED | 10740 (Ox29F4) | User is not connected as an administrator.
TDAPI_OBJECT_NOT_EXISTS | 10750 (Ox29FE) | No object exists.
TDOLE_UNEXPECTED | 5000 (Ox1388) | An unexpected error has occurred.
TDOLE_INTERNAL | 5010 (Ox1392) | An Internal error has occurred.
TDOLE_DATA_CORRUPTION | 5020 (Ox139C) | Data is corrupted.
TDOLE_CALL_ORDER | 5021 (Ox139D) | Cannot update Step parameter value.
TDOLE_INVALID_PARAM | 5100 (Ox13EC) | Invalid TD parameter.
TDOLE_INVALID_PARAM_TYPE | 5101 (Ox13ED) | Invalid TD parameter type.
TDOLE_INVALID_PARAM_RANGE | 5102 (Ox13EE) | Invalid TD parameter range.
TDOLE_INVALID_PARAM_NUM | 5103 (Ox13EF) | Invalid TD parameter number.
TDOLE_INVALID_PARAM_FORMAT | 5104 (Ox13F0) | Invalid TD parameter format.
TDOLE_INVALID_PARAM_ENUM | 5105 (Ox13F1) | Invalid TD parameter list.
TDOLE_E_INITIALIZE | 5200 (Ox1450) | Customization objects not initialized.
TDOLE_INVALID_REQUEST | 5210 (Ox145A) | Invalid request.
TDOLE_INVALID_INPROCESS | 5220 (Ox1464) | Statistic object is not initialized.
TDOLE_INVALID_OBJECT | 6000 (Ox1770) | Invalid object has been passed.
TDOLE_INVALID_OBJECT_KEY | 6001 (Ox1771) | No object exists.
TDOLE_OBJECT_DELETED | 6002 (Ox1772) | Object was deleted by another user.
TDOLE_OBJECT_NOT_INITIALIZED | 6003 (Ox1773) | Object is not initialized.
TDOLE_VIRTUAL_FATHER | 6010 (Ox177A) | No post allowed for object that has a virtual parent.
TDOLE_VIRTUAL | 6020 (Ox1784) | Cannot get Run Factory for virtual TSTest.
TDOLE_NOT_VIRTUAL | 6030 (Ox178E) | Object not virtual.
TDOLE_FIELD_ONLY_FOR_VIRTUAL | 6032 (Ox1790) | Field exists in the virtual object only.
TDOLE_VIRTUAL_FIELD | 6040 (Ox1798) | The field is read-only.
TDOLE_E_PERMISSION | 6100 (Ox17D4) | There is no permission to proceed with this action.
TDOLE_E_CHACHE | 6700 (Ox1A2C) | Failed to cache object.
PARAM_E_WRONG_NUM | 1200 (Ox4B0) | The wrong number of parameters for the defined statement.
PARAM_E_NOT_FOUND | 1201 (Ox4B1) | The necessary parameter was not found.
PARAM_E_INVALID | 1202 (Ox4B2) | Invalid parameter value.
LIST_E_EMPTY | 1220 (Ox4C4) | The created list is empty.
LIST_E_FILTER | 1221 (Ox4C5) | Bad list filter.
COL_E_NOT_FOUND | 1240 (Ox4D8) | The specified column does not exist.
BUG_E_NOT_FOUND | 1260 (Ox4EC) | The specified bug does not exist.
BUG_E_DELETE | 1261 (Ox4ED) | Failure to delete bug.
BUG_E_CREATE | 1262 (Ox4EE) | Failure to create log.
TEST_E_NOT_FOUND | 1280 (Ox500) | The specified test does not exist.
TEST_E_CREATE | 1281 (Ox501) | Failure to create a new test.
TEST_E_DELETE | 1282 (Ox502) | Failure to delete test.
TEST_E_COV_DELETE | 1283 (Ox503) | Failed to delete requirement coverage by test.
TEST_E_REPOSITORY | 1284 (Ox504) | Invalid test path.
TEST_E_TEMPLATE_TYPE | 1285 (Ox505) | Cannot change test type.
TDAPI_E_LINK_TEST_CIRCLUATION | 1287 (Ox507) | Cannot link to test since this will create a circular reference.
FIELD_E_NO_PERMISSION | 1300 (Ox514) | No permission to modify the field.
FIELD_E_SYS_FIELD | 1301 (Ox515) | The field is a system field.
FIELD_E_NOT_ACTIVE | 1302 (Ox516) | The field is not an active field.
FIELD_E_IS_KEY | 1303 (Ox517) | The field is a database key field.
FIELD_E_NO_EDIT | 1304 (Ox518) | The field is a read-only field.
FIELD_E_VERIFIED | 1305 (Ox519) | Field verification failure.
FIELD_E_TRANSITION | 1306 (Ox51A) | Error in field defined transition logic.
FIELD_E_REQUIRED | 1307 (Ox51B) | The field is a required field.
FIELD_INVALID | 1308 (Ox51C) | Invalid field value.
USER_E_NOT_FOUND | 1320 (Ox528) | The specified user does not exist.
USER_E_CREATE | 1321 (Ox529) | Failure to create user.
USER_E_DELETE | 1322 (Ox52A) | Failure to delete user.
USER_E_IN_GROUP | 1323 (Ox52B) | Failure to add user into group.
USER_E_NOT_IN_GROUP | 1324 (Ox52C) | User does not exist in the group.
FILTER_E_NOVALUE | 1340 (Ox53C) | No filter value is defined.
FILTER_E_INVALIDVALUE | 1341 (Ox53D) | The defined filter value is invalid.
FILTER_E_INVALIDNAME | 1342 (Ox53E) | The filter condition name is invalid.
FILTER_S_DATE_COMPLEX | 1343 (Ox53F) | Invalid date.
FILTER_S_LIST_BY_CODE | 1344 (Ox540) | Invalid system node path.
FILTER_E_INVALIDPATH_ATTR | 1345 (Ox541) |
REQ_E_NOT_FOUND | 1360 (Ox550) | The specified requirement does not exist.
REQ_E_INVALIDORDER | 1361 (Ox551) | The requirement order is invalid.
REQ_E_INVALIDFATHERID | 1362 (Ox552) | The father ID is invalid.
REQ_E_INVALIDTYPE | 1363 (Ox553) | The requirement type is invalid.
REQ_E_CREATE | 1364 (Ox554) | Failed to create a new requirement.
REQ_E_INVALIDMODE | 1365 (Ox555) | The mode flag is invalid for the requirement options: copy, remove and find.
REQ_E_DELETE | 1366 (Ox556) | Failed to remove the specified requirement.
TESTSET_E_NOT_FOUND | 1380 (Ox564) | The test set does not exist.
TESTSET_E_CREATE | 1381 (Ox565) | Failure to create TestSet.
TESTSET_E_DELETE | 1382 (Ox566) | Failure to delete TestSet.
TESTSET_E_DELETE_DEFAULT | 1383 (Ox567) | Failure to delete default' TestSet.
TSTEST_E_NOT_FOUND | 1400 (Ox578) | The test instance does not exist.
TSTEST_E_DELETE | 1401 (Ox579) | Failed to remove the specified test instance.
TSTEST_E_CREATE | 1402 (Ox57A) | Failure to create test in TestSet.
ITEM_E_NOT_FOUND | 1420 (Ox58C) | The item does not exist.
ITEM_E_NO_ADD | 1421 (Ox58D) | No permission to create a new item.
ITEM_E_NO_REMOVE | 1422 (Ox58E) | No permission to remove an item.
COND_E_NOT_FOUND | 1440 (Ox5A0) | The condition does not exist.
COND_E_CREATE | 1441 (Ox5A1) | Failed to create a new condition.
COND_E_INVALIDTYPE | 1442 (Ox5A2) | The condition type is invalid.
ATT_E_NOT_FOUND | 1460 (Ox5B4) | The attachment does not exist.
ATT_E_CREATE | 1461 (Ox5B5) | Failed to create attachment.
ATT_E_INVALID_REQUEST | 1463 (Ox5B7) | Invalid request for attachment.
ATT_E_RENAME | 1464 (Ox5B8) | Failed to rename attachment.
ATT_E_OBJECT_HAS_ATTACHMENT | 1465 (Ox5B9) | Object cannot have an attachment.
USERSGROUP_E_NOT_FOUND | 1480 (Ox5C8) | The specified user group does not exist.
USERSGROUP_E_SYSTEM | 1481 (Ox5C9) | Users group system error.
USERSGROUP_E_CREATE | 1482 (Ox5CA) | Failed to create user group.
DESSTEP_E_NOT_FOUND | 1500 (Ox5DC) | The specified design step does not exist.
DESSTEP_E_CREATE | 1501 (Ox5DD) | Failed to create design step.
DESSTEP_E_DELETE | 1502 (Ox5DE) | Failed to remove the specified design step.
TREE_E_NOT_FOUND | 1520 (Ox5F0) | Tree node not found.
TREE_E_CREATE | 1521 (Ox5F1) | Cannot create Tree node.
TREE_E_DELETE | 1522 (Ox5F2) | Cannot remove Tree node.
TREE_E_RENAME | 1523 (Ox5F3) | Cannot rename Tree node.
RUN_E_NOT_FOUND | 1540 (Ox604) | Run does not exist.
RUN_E_CREATE | 1541 (Ox605) | Failed to create Run.
RUN_E_DELETE | 1542 (Ox606) | Failed to delete Run.
STEP_E_NOT_FOUND | 1560 (Ox618) | Step does not exist.
STEP_E_CREATE | 1561 (Ox619) | Failed to create Step.
STEP_E_DELETE | 1562 (Ox61A) | Failed to delete Step.
STEP_E_COPY_STEPS_OF_RUN | 1563 (Ox61B) | No permission to modify design steps - steps won't be copied to the corresponding test.
EXSTORAGE_CANCEL | 1580 (Ox62C) | The extended storage action has been canceled.
EXSTORAGE_OCCIPIED | 1581 (Ox62D) | Extended Storage is currently busy.
EXSTORAGE_INVALID_FILTER | 1582 (Ox62E) | Filter is invalid.
EXSTORAGE_IO_OPERATION_DISABLED | 1584 (Ox630) | Extended Storage IO operation disabled.
EXSTORAGE_INVALID_PATH | 1585 (Ox631) | The Extended Storage path is not valid.
EXSTORAGE_CANT_CREATE | 1586 (Ox632) | Cannot create one of the following objects: path, file or ES object itself.
EXSTORAGE_INTERNET | 1587 (Ox633) | Internet connection specific error.
EXSTORAGE_EMPTY_SERVER_PATH | 1588 (Ox634) | Server path is empty.
EXSTORAGE_EMPTY_ClIENT_PATH | 1589 (Ox635) | Client path is empty.
EXSTORAGE_ERROR_SERVER_PATH | 1590 (Ox636) | Server path does not exist.
EXSTORAGE_ERROR_PERMISSION | 1591 (Ox637) | Extended storage access permission error.
SERVER_NOT_CONNECTED | 1600 (Ox640) | Server is not connected.
HOST_E_DELETE | 1620 (Ox654) | Failed to delete host.
HOST_E_NOT_FOUND | 1621 (Ox655) | Host does not exist.
HOSTGROUP_E_NOT_FOUND | 1640 (Ox668) | Host group does not exist.
COPY_SUBJECT_E_TO_ITSELF | 1660 (Ox67C) | Cannot paste subject to itself.
TDOLE_NODE_EXISTS | 1661 (Ox67D) | Duplicate Tree node name.
TDOLE_ANSWERLESS_QUESTION_FOUND | 1680 (Ox690) | Found a question without answers.
TDOLE_QUESTION_WITH_DUPLICATE_ANSWERS_FOUND | 1681 (Ox691) | Found a question with duplicate answers.
TDOLE_CAN_NOT_COMNMIT_RBT_CUSTOMIZATION | 1682 (Ox692) | Can not Commit RBT customizations due to failed validators.
TDOLE_WARNING_NO_ALERTS_CLEARED | 1690 (Ox69A) | No alert could be cleared.
TDOLE_WARNING_SOME_ALERTS_NOT_CLEARED | 1691 (Ox69B) | Some of the alerts could not be cleared.
TDOLE_WARNING_ALERT_NOT_CLEARED | 1692 (Ox69C) | The alert could not be cleared.
GRAPH_DATA_EMPTY | 1700 (Ox6A4) | No graph data exists.
TDAPI_GRAPH_RELEASE_CYCLE_DATE_MISSING | 1701 (Ox6A5) | Cannot create release coverage progress graph. One or more cycles are missing a start date.
EVENT_ERR_DISABLE | 1800 (Ox708) | The operation has been prevented by the error handler.
MAILCONDITION_E_NOT_FOUND | 1850 (Ox73A) | Mail condition does not exist.
TDPARAM_NOT_FOUND | 1900 (Ox76C) | No TD parameter exists.
TDOLE_DIFFERENT_UDFS | 1950 (Ox79E) | Method is disabled by the event handler.
LINK_E_CREATE | 1970 (Ox7B2) | Failure to create a new link.
TDAPI_E_LINK_EXISTS | 1971 (Ox7B3) | Those entities are already linked.
TDAPI_E_DEFECT_LINKED_TO_ITSELF | 1972 (Ox7B4) | Cannot link a defect to itself.
TDOLE_CAN_UPDATE_UDFS | 1076 (Ox434) | Cannot update user-defined field customization.
TDOLE_CORRUPTED_DATA_HIDING | 9001 (Ox2329) | Failure in data hiding filter for login.
TDOLE_NOT_LOGGED_IN | 30001 (Ox7531) | Attempt to connect to project when no user logged in.
TDOLE_LOGIN_INPUT_PROPERTY_DOES_NOT_EXIST | 30002 (Ox7532) | The input property does not exist.
TDOLE_LOGIN_INPUT_VALUE_EXCEED_MAX_LENGTH | 30003 (Ox7533) | The input string is too long.
TDOLE_LOGIN_INPUT_MANDATORY_PROPERTY_MISSING | 30004 (Ox7534) | Missing required property.
TDOLE_APP_ENTITY_FOLDER_EXISTS | 50055 (OxC387) | Duplicate Application Entity folder name.
TDOLE_CHANGE_ENTITY_FOLDER_EXISTS | 50056 (OxC388) | Duplicate Change Entity folder name.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_EUM_ORDER Enumeration

Members

Member | Value | Description
TDOLE_LAST_ORDER | -4 (OxFFFFFFFC) | Set object order to be last in its list.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_EXECUTIONEVENT Enumeration

Members

Member | Value | Description
EXECEVENT_TESTFAIL | 1 (Ox1) | Test Has Failed.
EXECEVENT_TESTSETFINISH | 2 (Ox2) | Test Set Finished.
EXECEVENT_ENVIRONMENTFAIL | 3 (Ox3) | Environmental Failure.
EXECEVENT_RUNTIMEDOUT | 4 (Ox4) | Execution continued longer than allowed.
EXECEVENT_MANUAL_LAUNCH | 5 (Ox5) | Test should be launched manually.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_EXECUTIONEVENTACTION Enumeration

Members

Member | Value | Description
EXECEVENTACTION_DEFAULT | 0 (Ox0) | Do Nothing.
EXECEVENTACTION_DONOTHING | 1 (Ox1) | Do Nothing.
EXECEVENTACTION_STOP | 2 (Ox2) | Stop Test or TestSet.
EXECEVENTACTION_RESTART | 3 (Ox3) | Restart Test or TestSet.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_EXECUTIONEVENTACTIONTARGET Enumeration

Members

Member | Value | Description
EXECEVENTACTIONTARGET_TEST | 1 (Ox1) | Perform action (Stop or Restart) on Test.
EXECEVENTACTIONTARGET_TESTSET | 2 (Ox2) | Perform action (Stop or Restart) on TestSet.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_EXSTOR_DELMODE Enumeration

Description

Extended Storage file deletion flags. These can be used individually or combined with bitwise OR.

Members

Member | Value | Description
TDOLE_DELETE_LOCAL | 1 (Ox1) | Delete local file(s).
TDOLE_DELETE_REMOTE | 2 (Ox2) | Delete remote file(s).


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_FDATA_TYPE Enumeration

Members

Member | Value | Description
TDOLE_FOLDER | 0 (Ox0) |
TDOLE_FILE | 1 (Ox1) |


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_FETCH_LEVEL Enumeration

Members

Member | Value | Description
TDOLE_FIRST_LEVEL | 0 (Ox0) | Active and system fields.
TDOLE_SECOND_LEVEL | 1 (Ox1) | Memo fields.
TDOLE_THIRD_LEVEL | 2 (Ox2) | User-defined fields.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_FILTERORDER Enumeration

Members

Member | Value | Description
TDOLE_ASCENDING | 0 (Ox0) |
TDOLE_DESCENDING | 1 (Ox1) |


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_GET_EXTENSION_MODE Enumeration

Members

Member | Value | Description
GET_EXTENSION_MODE_ALL | 0 (Ox0) | Get All extensions registered to server.
GET_EXTENSION_MODE_ENABLED | 1 (Ox1) | Get extensions that are Enabled to project.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_GRANT_MODIFY Enumeration

Members

Member | Value | Description
GRANT_MODIFY_PERMIT | 0 (Ox0) |
GRANT_MODIFY_DENY | 1 (Ox1) |
GRANT_MODIFY_BY_OWNER_ONLY | 2 (Ox2) |


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_GRAPH_TYPE Enumeration

Members

Member | Value | Description
GRAPH_SUMMARY | 0 (Ox0) | Summary.
GRAPH_AGE | 1 (Ox1) | Age.
GRAPH_PROGRESS | 2 (Ox2) | Progress.
GRAPH_TREND | 3 (Ox3) | Trend.
GRAPH_COVERAGE | 5 (Ox5) | Coverage.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_LICENSE Enumeration

Members

Member | Value | Description
LIC_DEFECT | 1 (Ox1) | Defect License.
LIC_TEST_LAB | 2 (Ox2) | Test Lab License.
LIC_REQUIREMENT | 3 (Ox3) | Requirement License.
LIC_OTA_CLIENT | 4 (Ox4) | OTA Client License.
LIC_COLLABORATION | 6 (Ox6) | Collaboration License.
LIC_DASHBOARD | 12 (OxC) | Dashboard License.
LIC_COMPONENTS | 13 (OxD) | Components License.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_MODULE Enumeration

Members

Member | Value | Description
MODULE_DEFECT | 0 (Ox0) | Defect Module.
MODULE_TEST_PLANNING | 1 (Ox1) | Test Planning Module.
MODULE_TEST_EXECUTION | 2 (Ox2) | Test Execution Module.
MODULE_REQUIREMENT | 3 (Ox3) | Requirement Module.
MODULE_COLLABORATION | 4 (Ox4) | Collaboration Module.
MODULE_DASHBOARD | 5 (Ox5) | Dashboard Module.
MODULE_COMPONENTS | 6 (Ox6) | Components Module.
MODULE_RELEASE | 7 (Ox7) | Releases Module.
MODULE_RELEASE_CYCLE | 8 (Ox8) | Releases Module.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_NODE_TYPE Enumeration

Description

Node Types.

Members

Member | Value | Description
NODE_TYPE_UNDEFINED | 0 (Ox0) | Undefined node type.
NODE_TYPE_RELEASE_FOLDER | 1 (Ox1) | Release folder node type.
NODE_TYPE_RELEASE | 2 (Ox2) | Release node type.
NODE_TYPE_RELEASECYCLE | 3 (Ox3) | ReleaseCycle node type.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_NODEATTRIBUTE Enumeration

Members

Member | Value | Description
TDOLE_NODE_SYSTEM | 0 (Ox0) | System folder. The folder cannot be modified, and sub-folders cannot be added or removed.
TDOLE_NODE_READONLY | 1 (Ox1) | Read-only folder. Only the add and delete sub-folders operations are enabled.
TDOLE_NODE_CHANGEABLE | 2 (Ox2) | Changeable folder. All operations are enabled except delete.
TDOLE_NODE_FULLACCESS | 3 (Ox3) | Full access folder. All operations are enabled.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_PARAM_IN_OUT_TYPE Enumeration

Members

Member | Value | Description
PARAM_INOUT_UNDEFINED | 0 (Ox0) | Input/Output Undefined.
PARAM_IN | 1 (Ox1) | Input Parameter.
PARAM_OUT | 2 (Ox2) | Output Parameter.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_POS_ORDER Enumeration

Description

Position markers for a list or collection.

Members

Member | Value | Description
TDPOSITION_LAST | -4 (OxFFFFFFFC) | Marker for the last position in a list or collection.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_PREDEFINED_REQ_TYPES Enumeration

Description

IDs of the predefined requirement types.

Members

Member | Value | Description
REQ_TYPE_UNDEFINED | 0 (Ox0) | Undefined requirement type.
REQ_TYPE_FOLDER | 1 (Ox1) | Requirement folder.
REQ_TYPE_GROUP | 2 (Ox2) | Requirement group.
REQ_TYPE_FUNCTIONAL | 3 (Ox3) | Functional requirement.
REQ_TYPE_BUSINESS | 4 (Ox4) | Business process requirement.
REQ_TYPE_TESTING | 5 (Ox5) | Testing requirement.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_PURGE_RUNS Enumeration

Description

The units by which to purge.

Members

Member | Value | Description
TDDAY_PURGE | 1 (Ox1) | Purge by number of days.
TDWEEK_PURGE | 2 (Ox2) | Purge by number of weeks.
TDMONTH_PURGE | 3 (Ox3) | Purge by number of months.
TDYEAR_PURGE | 4 (Ox4) | Purge by number of years.
TDDATE_PURGE | 5 (Ox5) | Purge by date.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_RBT_BI_LEVELS Enumeration

Description

RBT Business impact levels.

Members

Member | Value | Description
RBT_BI_LEVEL_A | 1 (Ox1) | Business impact level A - the highest impact.
RBT_BI_LEVEL_B | 2 (Ox2) | Business impact level B - medium impact.
RBT_BI_LEVEL_C | 3 (Ox3) | Business impact level C - the lowest impact.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_RBT_FP_LEVELS Enumeration

Description

RBT Failure probability levels.

Members

Member | Value | Description
RBT_FP_LEVEL_1 | 1 (Ox1) | Failure probability 1 - most complex, and most likely to fail.
RBT_FP_LEVEL_2 | 2 (Ox2) | Failure probability 2 - medium complexity.
RBT_FP_LEVEL_3 | 3 (Ox3) | Failure probability 3 - least complex, and least likely to fail.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_RBT_REQUIREMENT_TYPE_RISK_ANALYSIS_TYPE Enumeration

Description

Risk-based testing Requirement Type Risk Analysis Type.

Members

Member | Value | Description
REQUIREMENT_TYPE_RISK_ANALYSIS_TYPE_NONE | 0 (Ox0) | Risk-based testing does not apply to requirements of this type.
REQUIREMENT_TYPE_RISK_ANALYSIS_TYPE_ASSESS | 1 (Ox1) | The risk for requirements of this type can be Assessed, but not Analyzed.
REQUIREMENT_TYPE_RISK_ANALYSIS_TYPE_ANALYSIS | 2 (Ox2) | The risk for requirements of this type can be Analyzed, but not Assessed.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_RBT_RISK_KINDS Enumeration

Description

RBT Risk kinds.

Members

Member | Value | Description
RBT_RISK_KIND_BI | 1 (Ox1) | Business Impact.
RBT_RISK_KIND_FP | 2 (Ox2) | Failure probability.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_RBT_TESTING_LEVELS Enumeration

Description

RBT Testing levels.

Members

Member | Value | Description
RBT_TESTING_LEVEL_FULL | 1 (Ox1) | Full Testing level - perform all possible tests.
RBT_TESTING_LEVEL_PARTIAL | 2 (Ox2) | Partial Testing level - perform sub-set of tests.
RBT_TESTING_LEVEL_SANITY | 3 (Ox3) | Sanity Testing level - perform only sanity tests.
RBT_TESTING_LEVEL_NONE | 4 (Ox4) | None Testing level - do not perform any tests.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_REQ_TREE Enumeration

Description

Constants for the requirement tree.

Members

Member | Value | Description
REQ_ROOT_FOLDER_ID | 0 (Ox0) | The ID of the requirement root folder in the requirements module.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_REQMODE Enumeration

Description

Flags for requirement factory Find method. Can be combined with binary OR.

Members

Member | Value | Description
TDREQMODE_REC | 1 (Ox1) | Not in use.
TDREQMODE_SMART | 2 (Ox2) | Case sensitive search.
TDREQMODE_REM_REM_ALL | 4 (Ox4) | Not in use.
TDREQMODE_FIND_START_WITH | 8 (Ox8) | Requirement name starts with pattern.
TDREQMODE_FIND_EXACT | 16 (Ox10) | Requirement name exactly matches pattern.
TDREQMODE_FIND_ANYWHERE | 32 (Ox20) | Search for pattern anywhere in requirement name.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_ROOTLIST Enumeration

Members

Member | Value | Description
TDOLE_ALL | 0 (Ox0) | All tree roots. A root is a record where AL_FATHER_ID = 0.
TDOLE_SUBJECT | 1 (Ox1) | Only the subject tree node.
TDOLE_NOT_SUBJECT | 2 (Ox2) | All tree roots except the subject root. This includes all customization lists.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_RUN_PARAM_MODE Enumeration

Description

Parameter handling at run time.

Members

Member | Value | Description
PARAM_SOURCE_PRE_RUN | 1 (Ox1) | Insert parameters before run.
PARAM_SOURCE_STEPS | 2 (Ox2) | Insert parameters during the run (when steps are being created).


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_SKIP Enumeration

Description

Interval flags for graphs and summation by interval methods.

Members

Member | Value | Description
TDOLE_SKIP_DAYS | 0 (Ox0) |
TDOLE_SKIP_WEEKS | 1 (Ox1) |
TDOLE_SKIP_MONTHS | 2 (Ox2) |
TDOLE_SKIP_YEARS | 3 (Ox3) |


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_STEP_CREATE Enumeration

Description

Step modification mode.

Members

Member | Value | Description
TDOLE_STEP_CREATE | 0 (Ox0) | Create mode.
TDOLE_STEP_UPDATE | 2 (Ox2) | Update mode.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_STEP_PARAM_TYPE Enumeration

Members

Member | Value | Description
STEP_PARAM_PREDEF | 1 (Ox1) | Pre-defined parameter.
STEP_PARAM_NULL | 2 (Ox2) | The parameter currently has null value.
STEP_PARAM_VALUE | 3 (Ox3) | Parameter with an attached value.
STEP_PARAM_BASE | 4 (Ox4) | Parameter with an attached value to the base object.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_TRACE_DIRECTION Enumeration

Description

Trace directions - 'TO' or 'FROM' this item.

Members

Member | Value | Description
TDOLE_TRACED_FROM | 0 (Ox0) | Traced from this item.
TDOLE_TRACED_TO | 1 (Ox1) | Traced to this item.


%%PageItemTitle%%

OTA COM Type Library

tagTDAPI_TREETYPE Enumeration

Members

Member | Value | Description
TDOLE_LEAF_TYPE | 0 (Ox0) | The folder is a tree leaf, and has no sub-folders.
TDOLE_LIST_TYPE | 1 (Ox1) | The folder has only one level of sub-folders.
TDOLE_TREE_TYPE | 2 (Ox2) | The folder has more than one level of sub-folders.


%%PageItemTitle%%

OTA COM Type Library

tagTDLICENSE_CLIENT Enumeration

Members

Member | Value | Description
TDLICENSE_BUG | 1 (Ox1) | BUG Client License.
TDLICENSE_LAB | 2 (Ox2) | Lab Client License.
TDLICENSE_REQ | 4 (Ox4) | Requirements Client License.
TDLICENSE_OTA_CLIENT | 8 (Ox8) | OTA Client License.
TDLICENSE_COLLAB | 32 (Ox20) | Collaboration Client License.
TDLICENSE_DASHBOARD | 2048 (Ox800) | Dashboard Client License.
TDLICENSE_COMPONENTS | 4096 (Ox1000) | Components Client License.


%%PageItemTitle%%

OTA COM Type Library

tagTDMAIL_FLAGS Enumeration

Members

Member | Value | Description
TDMAIL_ATTACHMENT | 1 (Ox1) | Send the entity's attachments.
TDMAIL_HISTORY | 2 (Ox2) | Include the entity's history.
TDMAIL_TEXT | 4 (Ox4) | Send mail as plain test.
TDMAIL_DES_STEP | 8 (Ox8) | Include design steps.
TDMAIL_COVER_TEST | 16 (Ox10) | Include test coverage. Applies only to requirements
TDMAIL_SINGLEMAIL | 32 (Ox20) | Single Mail.(obsolete - included for backward compatibility)
TDMAIL_COMMENT_AS_BODY | 64 (Ox40) | Use the Comment argument of the Mail method as the message body. (Used by UI when sending custom e-mail.)
TDMAIL_TRACE_REQ | 128 (Ox80) | Include traced requirements.


%%PageItemTitle%%

OTA COM Type Library

TDAPI_ATTACH Enumeration

Description

Attachment Flags.

Members

Member | Value | Description
TDATT_COPY | 1 (Ox1) | Synchronous upload or download.
TDATT_MOVE | 2 (Ox2) | Move attachment.
TDATT_LINK | 3 (Ox3) | Create URL attachment.
TDATT_COPY_ASINCHRONE | 4 (Ox4) | Asynchronous upload or download.


%%PageItemTitle%%

OTA COM Type Library

TDAPI_ATTACH_SUBTYPE Enumeration

Description

Attachment Sub Type.

Members

Member | Value | Description
TDATT_NONE | 0 (Ox0) | Empty subtype.
TDATT_RICH_CONTENT | 1 (Ox1) | Rich content attachment.


%%PageItemTitle%%

OTA COM Type Library

TDAPI_ATTACH_TYPE Enumeration

Description

Attachment Type.

Members

Member | Value | Description
TDATT_FILE | 1 (Ox1) | File attachment.
TDATT_INTERNET | 2 (Ox2) | URL attachment.


%%PageItemTitle%%

OTA COM Type Library

TDAPI_COMPONENT_AUTO_TYPE Enumeration

Description

Components Automation Type Values.

Members

Member | Value | Description
MANUAL | 1 (Ox1) | Manual AutoType.
KW | 2 (Ox2) | QTP's KeyWord AutoType.
SCRIPTED | 3 (Ox3) | Scripted AutoType.


%%PageItemTitle%%

OTA COM Type Library

TDAPI_CONDSTAT Enumeration

Description

Run condition statuses.

Members

Member | Value | Description
TDCOND_FINISHED | 1 (Ox1) | The run finished.
TDCOND_PASSED | 2 (Ox2) | The run finished successfully.
TDCOND_FAILED | 3 (Ox3) | FAILED condition status.


%%PageItemTitle%%

OTA COM Type Library

TDAPI_CONDTYPE Enumeration

Description

Execution flow condition type.

Members

Member | Value | Description
TDCOND_RUN | 1 (Ox1) | The condition is a run status.


%%PageItemTitle%%

OTA COM Type Library

TDAPI_COPY_PASTE_MODES Enumeration

Description

Options for pasting design steps linked to tests where the linked tests already exist in the target project.

Members

Member | Value | Description
COPY_PASTE_NO_LINKED_TEST_MODE | 0 (Ox0) | Do not copy the linked tests.
COPY_PASTE_USE_LINKED_TEST_MODE | 1 (Ox1) | Link the design steps to the existing tests.
COPY_PASTE_CREATE_LINKED_TEST_MODE | 2 (Ox2) | Create new copies of the linked tests.


%%PageItemTitle%%

OTA COM Type Library

TDAPI_DATATYPES Enumeration

Description

Data types.

Members

Member | Value | Description
TDOLE_LONG | 0 (Ox0) | Long integer.
TDOLE_ULONG | 1 (Ox1) | Unsigned long integer.
TDOLE_FLOAT | 2 (Ox2) | Floating point number.
TDOLE_STRING | 3 (Ox3) | String.
TDOLE_MEMO | 4 (Ox4) | Memo.
TDOLE_DATE | 5 (Ox5) | Date.
TDOLE_TIMESTAMP | 6 (Ox6) | Time stamp.
TDOLE_TREENODE | 7 (Ox7) | General tree node.
TDOLE_USER_LIST | 8 (Ox8) | List of users.
TDOLE_TESTSET_LIST | 9 (Ox9) | List of test sets.
TDOLE_HOST_LIST | 10 (OxA) | List of hosts.
TDOLE_SUBJECT_TREENODE | 11 (OxB) | Subject tree node.
TDOLE_TESTSET_FOLDER | 12 (OxC) | Test set folders tree node.
TDOLE_REQUIREMENT_TREENODE | 13 (OxD) | Requirements tree node.
TDOLE_REQUIREMENT_TYPE_ID | 14 (OxE) | Requirement type ID.
TDOLE_RELEASE_SINGLE_TREENODE | 15 (OxF) | Release single-value tree node.
TDOLE_RELEASE_MULTI_TREENODE | 16 (Ox10) | Release multi-value tree node.
TDOLE_RELEASECYCLE_SINGLE_TREENODE | 17 (Ox11) | ReleaseCycle single-value tree node.
TDOLE_RELEASECYCLE_MULTI_TREENODE | 18 (Ox12) | ReleaseCycle multi-value tree node.
TDOLE_APPLICATION_ENTITY_FOLDER | 19 (Ox13) | Application entity folders tree node.
TDOLE_CHANGE_ENTITY_FOLDER | 20 (Ox14) | Change entity folders tree node.


%%PageItemTitle%%

OTA COM Type Library

TDAPI_ENTITIES Enumeration

Description

The entities for customization types.

Members

Member | Value | Description
ENTITY_REQUIREMENT | 0 (Ox0) | Customization for requirements.
ENTITY_BUG | 1 (Ox1) | Not supported in Quality Center 9.2


%%PageItemTitle%%

OTA COM Type Library

TDAPI_EXSTOR_DELMODE Enumeration

Description

Extended Storage file deletion flags. These can be used individually or combined with bitwise OR.

Members

Member | Value | Description
TDOLE_DELETE_LOCAL | 1 (Ox1) | Delete local file(s).
TDOLE_DELETE_REMOTE | 2 (Ox2) | Delete remote file(s).


%%PageItemTitle%%

OTA COM Type Library

TDAPI_NODE_TYPE Enumeration

Description

Node Types.

Members

Member | Value | Description
NODE_TYPE_UNDEFINED | 0 (Ox0) | Undefined node type.
NODE_TYPE_RELEASE_FOLDER | 1 (Ox1) | Release folder node type.
NODE_TYPE_RELEASE | 2 (Ox2) | Release node type.
NODE_TYPE_RELEASECYCLE | 3 (Ox3) | ReleaseCycle node type.


%%PageItemTitle%%

OTA COM Type Library

TDAPI_POS_ORDER Enumeration

Description

Position markers for a list or collection.

Members

Member | Value | Description
TDPOSITION_LAST | -4 (OxFFFFFFFC) | Marker for the last position in a list or collection.


%%PageItemTitle%%

OTA COM Type Library

TDAPI_PREDEFINED_REQ_TYPES Enumeration

Description

IDs of the predefined requirement types.

Members

Member | Value | Description
REQ_TYPE_UNDEFINED | 0 (Ox0) | Undefined requirement type.
REQ_TYPE_FOLDER | 1 (Ox1) | Requirement folder.
REQ_TYPE_GROUP | 2 (Ox2) | Requirement group.
REQ_TYPE_FUNCTIONAL | 3 (Ox3) | Functional requirement.
REQ_TYPE_BUSINESS | 4 (Ox4) | Business process requirement.
REQ_TYPE_TESTING | 5 (Ox5) | Testing requirement.


%%PageItemTitle%%

OTA COM Type Library

TDAPI_PURGE_RUNS Enumeration

Description

The units by which to purge.

Members

Member | Value | Description
TDDAY_PURGE | 1 (Ox1) | Purge by number of days.
TDWEEK_PURGE | 2 (Ox2) | Purge by number of weeks.
TDMONTH_PURGE | 3 (Ox3) | Purge by number of months.
TDYEAR_PURGE | 4 (Ox4) | Purge by number of years.
TDDATE_PURGE | 5 (Ox5) | Purge by date.


%%PageItemTitle%%

OTA COM Type Library

TDAPI_RBT_BI_LEVELS Enumeration

Description

RBT Business impact levels.

Members

Member | Value | Description
RBT_BI_LEVEL_A | 1 (Ox1) | Business impact level A - the highest impact.
RBT_BI_LEVEL_B | 2 (Ox2) | Business impact level B - medium impact.
RBT_BI_LEVEL_C | 3 (Ox3) | Business impact level C - the lowest impact.


%%PageItemTitle%%

OTA COM Type Library

TDAPI_RBT_FP_LEVELS Enumeration

Description

RBT Failure probability levels.

Members

Member | Value | Description
RBT_FP_LEVEL_1 | 1 (Ox1) | Failure probability 1 - most complex, and most likely to fail.
RBT_FP_LEVEL_2 | 2 (Ox2) | Failure probability 2 - medium complexity.
RBT_FP_LEVEL_3 | 3 (Ox3) | Failure probability 3 - least complex, and least likely to fail.


%%PageItemTitle%%

OTA COM Type Library

TDAPI_RBT_REQUIREMENT_TYPE_RISK_ANALYSIS_TYPE Enumeration

Description

Risk-based testing Requirement Type Risk Analysis Type.

Members

Member | Value | Description
REQUIREMENT_TYPE_RISK_ANALYSIS_TYPE_NONE | 0 (Ox0) | Risk-based testing does not apply to requirements of this type.
REQUIREMENT_TYPE_RISK_ANALYSIS_TYPE_ASSESS | 1 (Ox1) | The risk for requirements of this type can be Assessed, but not Analyzed.
REQUIREMENT_TYPE_RISK_ANALYSIS_TYPE_ANALYSIS | 2 (Ox2) | The risk for requirements of this type can be Analyzed, but not Assessed.


%%PageItemTitle%%

OTA COM Type Library

TDAPI_RBT_RISK_KINDS Enumeration

Description

RBT Risk kinds.

Members

Member | Value | Description
RBT_RISK_KIND_BI | 1 (Ox1) | Business Impact.
RBT_RISK_KIND_FP | 2 (Ox2) | Failure probability.


%%PageItemTitle%%

OTA COM Type Library

TDAPI_RBT_TESTING_LEVELS Enumeration

Description

RBT Testing levels.

Members

Member | Value | Description
RBT_TESTING_LEVEL_FULL | 1 (Ox1) | Full Testing level - perform all possible tests.
RBT_TESTING_LEVEL_PARTIAL | 2 (Ox2) | Partial Testing level - perform sub-set of tests.
RBT_TESTING_LEVEL_SANITY | 3 (Ox3) | Sanity Testing level - perform only sanity tests.
RBT_TESTING_LEVEL_NONE | 4 (Ox4) | None Testing level - do not perform any tests.


%%PageItemTitle%%

OTA COM Type Library

TDAPI_REQ_TREE Enumeration

Description

Constants for the requirement tree.

Members

Member | Value | Description
REQ_ROOT_FOLDER_ID | 0 (Ox0) | The ID of the requirement root folder in the requirements module.


%%PageItemTitle%%

OTA COM Type Library

TDAPI_REQMODE Enumeration

Description

Flags for requirement factory Find method. Can be combined with binary OR.

Members

Member | Value | Description
TDREQMODE_REC | 1 (Ox1) | Not in use.
TDREQMODE_SMART | 2 (Ox2) | Case sensitive search.
TDREQMODE_REM_REM_ALL | 4 (Ox4) | Not in use.
TDREQMODE_FIND_START_WITH | 8 (Ox8) | Requirement name starts with pattern.
TDREQMODE_FIND_EXACT | 16 (Ox10) | Requirement name exactly matches pattern.
TDREQMODE_FIND_ANYWHERE | 32 (Ox20) | Search for pattern anywhere in requirement name.


%%PageItemTitle%%

OTA COM Type Library

TDAPI_RUN_PARAM_MODE Enumeration

Description

Parameter handling at run time.

Members

Member | Value | Description
PARAM_SOURCE_PRE_RUN | 1 (Ox1) | Insert parameters before run.
PARAM_SOURCE_STEPS | 2 (Ox2) | Insert parameters during the run (when steps are being created).


%%PageItemTitle%%

OTA COM Type Library

TDAPI_SKIP Enumeration

Description

Interval flags for graphs and summation by interval methods.

Members

Member | Value | Description
TDOLE_SKIP_DAYS | 0 (Ox0) |
TDOLE_SKIP_WEEKS | 1 (Ox1) |
TDOLE_SKIP_MONTHS | 2 (Ox2) |
TDOLE_SKIP_YEARS | 3 (Ox3) |


%%PageItemTitle%%

OTA COM Type Library

TDAPI_STEP_CREATE Enumeration

Description

Step modification mode.

Members

Member | Value | Description
TDOLE_STEP_CREATE | 0 (Ox0) | Create mode.
TDOLE_STEP_UPDATE | 2 (Ox2) | Update mode.


%%PageItemTitle%%

OTA COM Type Library

TDAPI_TRACE_DIRECTION Enumeration

Description

Trace directions - 'TO' or 'FROM' this item.

Members

Member | Value | Description
TDOLE_TRACED_FROM | 0 (Ox0) | Traced from this item.
TDOLE_TRACED_TO | 1 (Ox1) | Traced to this item.


%%PageItemTitle%%

OTA COM Type Library

tagSTATSTG UDT

Description

For details of the tagSTATSTG structure, see Microsoft documentation.

UDT Members

Member | Type | Description
pwcsName | String | See Microsoft documentation.
Type | ULong | See Microsoft documentation.
cbSize | ULARGE_INTEGER | See Microsoft documentation.
mtime | FILETIME | See Microsoft documentation.
ctime | FILETIME | See Microsoft documentation.
atime | FILETIME | See Microsoft documentation.
grfMode | ULong | See Microsoft documentation.
grfLocksSupported | ULong | See Microsoft documentation.
clsid | GUID | See Microsoft documentation.
grfStateBits | ULong | See Microsoft documentation.
Reserved | ULong | See Microsoft documentation.


Copyright Page

Legal Notices

HP Quality Center API Function Reference Version 9.2

Warranty

The only warranties for HP products and services are set forth in the express warranty statements accompanying such products and services. Nothing herein should be construed as constituting an additional warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend

Confidential computer software. Valid license from HP required for possession, use or copying. Consistent with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard commercial license.

Third-Party Web Sites

HP provides links to external third-party Web sites to help you find supplemental information. Site content and availability may change without notice. HP makes no representations or warranties whatsoever as to site content or availability.

Copyright Notices

© 2003 - 2007 Mercury Interactive Corporation, All rights reserved

Trademark Notices

Intel®is a trademark or registered trademarks of Intel Corporation or its subsidiaries in the United States and other countries.
Java™ is a US trademark of Sun Microsystems, Inc.
Microsoft® and Windows® are U.S. registered trademarks of Microsoft Corporation.
Oracle® is a registered US trademark of Oracle Corporation, Redwood City, California.
UNIX® is a registered trademark of The Open Group.

If you have any comments or suggestions regarding this document, please send them by e-mail to SW-Doc@hp.com.


%%PageItemTitle%% $$Members$$

ActionPermission Overview

ActionPermission Object Members

Public Properties

Public Property ActionEnabled Checks if the user has rights to perform the specified action.

See Also

ActionPermission Overview


%%PageItemTitle%% $$Members$$

Alert Overview

Alert Object Members

Public Properties

Public Property AlertDate | The date that the alert was generated, based on the database server clock.
Public Property AlertType | The type of alert generated: Alert or Follow-up.
Public Property Description | The description of the alert.
Public Property ID | The alert or follow-up ID.
Public Property Subject | A short summary appropriate to be used as subject line of the Alert e-mail.
Public Property Unread | If true, the alert or follow-up has not yet been read.

See Also

Alert Overview


%%PageItemTitle%% $$Members$$

AlertManager Overview

AlertManager Object Members

Public Methods

Public Method CleanAllAlerts | Removes all current alerts from the database.
Public Method DeleteAlert | Removes an alert or alerts related to the current object from the database.
Public Method DeleteAlertsByFilter | Removes alerts associated with objects of the specified type from the database if they match the filter.

Public Properties

Public Property Alert | Gets the Alert object for the alert with the specified ID.
Public Property AlertList | The list of user alerts.

See Also

AlertManager Overview


%%PageItemTitle%% $$Members$$

AmarillusHash Overview

AmarillusHash Object Members

Public Methods

Public Method GenerateHash Gets a Hash generated from the input value.

See Also

AmarillusHash Overview


%%PageItemTitle%% $$Members$$

Attachment Overview

Attachment Object Members

Public Methods

Public Method Load | Downloads an attachment file to a client machine.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Rename | Renames the attachment on the server. The attachment must be uploaded before calling this method.
Public Method Save | Uploads a file to the server.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AttachmentStorage | The ExtendedStorage object of this attachment. Applies only to file attachments.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Data | If the attachment is a file, an array of bytes. If a reference to file, the path or URL.
Public Property Description | The attachment description.
Public Property DirectLink | The link or path to the attachment.
Public Property Field | The value of the specified field.
Public Property FileName | If a file, the file location. If a virtual file, the location for the attachment before it is uploaded to the server. If a URL, the link address.
Public Property FileSize | The attachment file size in bytes.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property LastModified | The last modified time.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The attachment name.
Public Property ServerFileName | The attachment file name on the server machine.
Public Property Type | The attachment type. Either File or URL.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

Attachment Overview


%%PageItemTitle%% $$Members$$

AttachmentFactory Overview

AttachmentFactory Object Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method FactoryProperties | Gets the owner type and key for the AttachmentFactory object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property AttachmentStorage | The ExtendedStorage object for downloading and uploading attachment files.
Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

AttachmentFactory Overview


%%ItemTitle%%

OTA COM Type Library

Adding attachments to a defect and mailing them

Source code

Sub AttachFileAndMail()
' This example shows how to check if a defect has attachments,
' how to add attachments to a defect, and how to mail
' all the attachments of a given defect.
    Dim attachFact As AttachmentFactory
    Dim theAttachment As Attachment
    Dim attachList As list
    Dim BugFact As BugFactory
    Dim theBug As Bug
    Dim AttachmentList() As Variant
    Dim HasAttachs As Boolean
On Error GoTo AttachFileAndMailErr
' Get an arbitrary defect for this example.
' To find a particular defect, use
' BugFactory.FindSimilarBugs or Bug.FindSimilarBugs
    'tdc is the global TDConnection object.
    Set BugFact = tdc.BugFactory
    Set theBug = BugFact.Item(1)
'------------------------------------------------------
' Use Bug.Attachments to get the attachment
' factory for the defect
    Set attachFact = theBug.Attachments
' For demonstration purposes, print the
' names of existing attachments
    Set attachList = attachFact.NewList("")
    For Each theAttachment In attachList
        Debug.Print "The Attachment.FileName is " _
            & theAttachment.FileName
    Next
 'For this example, guarantee that there are
 'attachments to email by attaching files if
 'there aren't already attachments.
 'To run the example, ensure that your workstation has files:
 '"D:\temp\err.log" and "D:\temp\output.txt"
    HasAttachs = theBug.HasAttachment
    If HasAttachs Then Debug.Print vbCrLf & "----------------------------------"
    If Not HasAttachs Then
        Set theAttachment = attachFact.AddItem(Null)
        theAttachment.FileName = "D:\temp\err.log"
        theAttachment.Type = TDATT_FILE
        theAttachment.Post
'-------------------------------------------------------------
' Use AttachmentFactory.AddItem to create the new project entry.
        Set theAttachment = attachFact.AddItem(Null)
        theAttachment.FileName = "D:\temp\output.txt"
        theAttachment.Type = TDATT_FILE
        theAttachment.Post
    End If
' Populate a Variant Array of Server File Names
' for use in the SendMail method.
    Set attachList = attachFact.NewList("")
    'Count starts at one and Variant Array size
    ' starts at zero (but see Option Base in the Visual
    ' Basic help), so array size is Count minus one.
    ReDim Preserve AttachmentList(attachList.Count - 1)
    Dim i%
    i = LBound(AttachmentList)
'-------------------------------------------------------------
' Use Attachment.ServerFileName to specify the attachment.
    For Each theAttachment In attachList
        AttachmentList(i) = theAttachment.ServerFileName
        i = i + 1
    Next
    Debug.Print vbCrLf & "----------------------------------"
' Array is populated. Let's see what we have:
    Dim fName
    For Each fName In AttachmentList
        Debug.Print "The AttachmentList element is " & fName
    Next
'-------------------------------------------------------------
' User TDConnection.SendMail to
' send the attachments
    tdc.SendMail "steves,alex_qc", "", _
        "TestMail TDConnection.SendMail with attachments", _
        "TDConnection.SendMail: This is a test", AttachmentList
Exit Sub
AttachFileAndMailErr:
ErrHandler err, "AttachFileAndMail"
End Sub


%%ItemTitle%%

OTA COM Type Library

Creating a new defect attachment

Source code

Public Sub UploadDefectAttachment()
' This routine adds file "D:\temp\A\SampleAttachment.txt"
' as an attachment to a defect. The file must exist
' at that path before running the routine
    Dim BugFact As BugFactory
    Dim bugObj As Bug
    Dim attachFact As AttachmentFactory
    Dim attachObj As Attachment
    Dim ExStrg As IExtendedStorage
    Dim rc
'Get the bug factory from the TDConnection
    'tdc is the global TDConnection object.
    Set BugFact = tdc.BugFactory
'Get a bug object
'To see how to get this specific bug without knowing the ID,
' See example
'"Downloading a defect attachment with Extended Storage"
' for ExtendedStorage.Load
    Set bugObj = BugFact.Item(2)
'-----------------------------------------
'Use Bug.Attachments to
'get the bug attachment factory
    Set attachFact = bugObj.Attachments
'Add a new extended storage object,an attachment
' named SampleAttachment.txt
    Set attachObj = attachFact.AddItem("SampleAttachment.txt")
'Modify the attachment description
    attachObj.Description = "Bug Sample Attachment"
'Update the attachment record in the project database
    attachObj.Post
'Get the bug attachmeent extended storage object
    Set ExStrg = attachObj.AttachmentStorage
'Specify the location of the file to upload.
    ExStrg.ClientPath = "D:\temp\A"
'-----------------------------------------
'Use IExtendedStorage.Save to
'upload the file
    ExStrg.Save "SampleAttachment.txt", True
    ExStrg.GetLastError
    Debug.Print err.Description
End Sub


%%ItemTitle%%

OTA COM Type Library

Deleting a test attachment

Source code

Public Sub DeleteTestAttachment(theTest As TDAPIOLELib.test, _
    AttachmentName As String)
' This routine deletes the attachment of the test
' that best matches the AttachmentName.
' Attachment name may contain the wildcard "*"
' To see how to get a test object with the name
' and path, see the Test Object example,
' "Get a test object with name and path"
    Dim TestAttachFact As AttachmentFactory
    Dim attachList As list, TAttach As Attachment
    Dim theAttachment As Attachment
    Dim AttachFilter As TDFilter
    Dim FileName As String
'---------------------------------------------
' Use Test.Attachments to get the AttachmentFactory
    Set TestAttachFact = theTest.Attachments
'-------------------------
' Get the filter to find AttachmentName
    Set AttachFilter = TestAttachFact.Filter
' Because the server files are concatenations
' of "Test_#_" and the file name as seen
' in the UI, the name must start with "*"
    AttachmentName = Trim(AttachmentName)
    Dim pos%
    pos = InStr(1, AttachmentName, "*")
    If pos = 1 Then
        AttachFilter.Filter("CR_REFERENCE") = _
            AttachmentName
    Else
        AttachFilter.Filter("CR_REFERENCE") = _
            "*" & AttachmentName
    End If
'-------------------------
' Find the attachment
    Set attachList = _
        TestAttachFact.NewList(AttachFilter.Text)
' There may be more that one match for *AttachmentName.
' For example, Test_99_AttachmentName and
' Test_99_SomeMoreChars_AttachmentName.
' For this example, we take the shortest Name
' as the best match.
    Dim minLength As Integer
    minLength = 32000
    For Each TAttach In attachList
        With TAttach
            If Len(.Name) < minLength Then
                minLength = Len(.Name)
                Set theAttachment = TAttach
            End If
        End With
    Next
'-------------------------
' If the item is found, use the AttachmentFactory
' to delete it.
    If theAttachment Is Nothing Then
        MsgBox "Attachment " & AttachmentName & " not found"
    Else
        Dim msg$, rc
        msg = "Do you want to delete" _
            & vbCrLf & theAttachment.Name _
            & vbCrLf & " from test " _
            & vbCrLf & theTest.Name _
            & "(ID " & theTest.ID & ")?"
        rc = MsgBox(msg, vbYesNo)
        If rc = vbYes Then
'-----------------------------------------------------
' Use AttachmentFactory.RemoveItem to delete the item
            TestAttachFact.RemoveItem (theAttachment.ID)
        End If
    End If
End Sub


%%ItemTitle%%

OTA COM Type Library

Downloading test files and attachments

Source code

Public Sub TestFilesAndAttachments(theTest As TDAPIOLELib.test)
' This routine gets a test object and
' first downloads the script files and then the attachments.
' The debug outputs are based on test:
' "OTA_DEMO_SUBJECT\OTA_SUBJECT_level1\OTA_SUB_1.2\SimpleVAPI-XP"
    Dim TestAttachFact As AttachmentFactory
    Dim attachList As list, TAttach As Attachment
    Dim TestAttachStorage As IExtendedStorage
    Dim TestStorage As IExtendedStorage
    Dim TestDownLoadPath As String, AttachDownLoadPath$
    Dim isFatalErr As Boolean
    Dim OwnerType As String, OwnerKey As Variant
'---------------------------------------
' Get the test storage
    Dim NullList As list
    Set TestStorage = theTest.ExtendedStorage
    TestStorage.ClientPath = _
        "d:\" & theTest.Name & "\testStorage"
'-------------------------------------------------------
' Use IExtendedStorage.LoadEx to get the test files.
    TestDownLoadPath = _
        TestStorage.LoadEx("", True, NullList, isFatalErr)
    Debug.Print "Fatal error = " & CStr(isFatalErr)
    'Fatal error = False
    Debug.Print "The test download path: " & TestDownLoadPath
' The test download path: d:\SimpleVAPI-XP\testStorage
' For this test, the files downloaded by
' TestStorage.LoadEx are:
' script.vbs
' test.sr
'---------------------------------------
' Get the Attachments
    Set TestAttachFact = theTest.Attachments
    TestAttachFact.FactoryProperties OwnerType, OwnerKey
    Debug.Print "OwnerType = " & OwnerType & ", " _
        & "OwnerKey = " & OwnerKey; ""
' OwnerType = TEST, OwnerKey = 98
'
'----------------------------
' Get the list of attachments and go through
' the list, downloading one at a time.
    Set attachList = TestAttachFact.NewList("")
    For Each TAttach In attachList
      With TAttach
        Debug.Print "----------------------------"
        Debug.Print "Download attachment" & vbCrLf
        Debug.Print "Before setting path"
        Debug.Print "The attachment name: " & .Name
        Debug.Print "The attachment server name: " & .ServerFileName
        Debug.Print "The filename: " & .FileName
'
' Before setting path
' The attachment Name: TEST_98_SampleAttachment.txt
' The attachment server name: C:\Program Files\Mercury Interactive\Quality Center\repository\qc\Default\Steve_85_Doc\Attach\TEST_98_SampleAttachment.txt
' The filename: C:\DOCUME~1\steves\LOCALS~1\Temp\TD_80\423af35f\Attach\TEST98\TEST_98_SampleAttachment.txt
'----------------------------------------------------
' Use Attachment.AttachmentStorage to get the
' extended storage object.
        Set TestAttachStorage = .AttachmentStorage
        TestAttachStorage.ClientPath = _
            "d:\" & theTest.Name & "\attachStorage"
'----------------------------------------------------
' Use Attachment.Load to download the attachment files.
        TAttach.Load True, AttachDownLoadPath
' Note that the Attachment.FileName property changes as a result
' of setting the IExtendedStorage.ClientPath
        Debug.Print vbCrLf & "After download"
        Debug.Print "Down load path: " & AttachDownLoadPath
        Debug.Print "The filename: " & .FileName
' After download
' Down load path: d:\SimpleVAPI-XP\attachStorage
' The filename: d:\SimpleVAPI-XP\attachStorage\TEST_98_SampleAttachment.txt
      End With
    Next TAttach
End Sub


%%ItemTitle%%

OTA COM Type Library

Getting a reference to an implemented interface

Source code

Private Sub GetIBaseFact2Ref()
' This example shows how to get access to properties or methods of an
' implemented interface. The case shown is getting an IBaseFactory2 reference
' from a BugFactory object, but the technique is the same for any implemented
' interface.
'
' Declare a variable to hold the reference for the interface
    Dim bf As IBaseFactory2
'
' By assigning the implementing object reference to the
' IBaseFactory2 type variable, the type is cast to that of the
' implemented interface. The new variable is a reference to the
' IBaseFactory2 interface within the parent object.
    'tdc is the global TDConnection object.
    Set bf = tdc.BugFactory
'
' Now access the properties of the implemented interface.
' Get an IBaseFactory2.GroupingManager reference.
    Dim gm As GroupingManager
    Set gm = bf.GroupingManager
'
'------------------------------
' Application code
' Use the GroupingManager reference
    gm.Group("BG_SEVERITY") = 1
    gm.Group("BG_PRIORITY") = 2
    ' etc.
'------------------------------
End Sub


%%PageItemTitle%% $$Members$$

AttachmentFactory Object

IBaseFactory2 Implemented Interface Members

See Also

AttachmentFactory Object


%%PageItemTitle%% $$Members$$

AttachmentFactory Object

ISupportCopyPaste2 Implemented Interface Members

See Also

AttachmentFactory Object


%%ItemTitle%%

OTA COM Type Library

Updating an attachment

Source code

Public Sub NewVersionOfDefectAttachment(bugNum As Long)
' This routine downloads an attachment, makes a
' change and uploads the amended file.
    Dim BugFact As BugFactory
    Dim bugObj As Bug
    Dim attachFact As AttachmentFactory
    Dim attachObj As Attachment
    Dim FilePath As String, AttachmentName$
    Dim rc
    On Error GoTo NewVersionErr
' Get the bug factory from the TDConnection
    'tdc is the global TDConnection object.
    Set BugFact = tdc.BugFactory
' Get a bug object
' To see how to get a specific bug without knowing the ID,
' See example
' "Downloading a defect attachment with Extended Storage"
' for ExtendedStorage.Load
    Set bugObj = BugFact.Item(bugNum)
' Get the bug attachment factory
    Set attachFact = bugObj.Attachments
    Dim lst As TDAPIOLELib.list
    Set lst = attachFact.NewList("")
' Find SampleAttachment.txt
    Dim pos%, zeroName$, oneName$
    For Each attachObj In lst
        'For documentation purposes, demonstrate the effect of
        ' the ViewFormat argument to Attachment.Name:
        zeroName = attachObj.Name(0)
        oneName = attachObj.Name(1)
        Debug.Print "0: " & zeroName & " 1: " & oneName
        '0: BUG_1_SampleAttachment.txt 1: SampleAttachment.txt
        'Wasn't that interesting? And now, back to the main
        ' theme of this example.
        pos = InStr(attachObj.Name, "SampleAttachment.txt")
        If pos > 0 Then
            AttachmentName = attachObj.Name
Debug.Print _
"The attachment name for SampleAttachment.txt is " & AttachmentName
' Output: The attachment name for SampleAttachment.txt is SampleAttachment.txt
            Exit For
        End If
    Next
    Set lst = Nothing
'-----------------------------------------
'Use Attachment.Load to
' get a local copy of the file
    attachObj.Load True, FilePath
    Debug.Print "FilePath = " & FilePath
' Append the file name to the path
    FilePath = FilePath & "\" & AttachmentName
' Make a change in the file
    Open FilePath For Append As #1
    Print #1, vbCrLf & "This is the emended version"
    Close #1
'-----------------------------------------
'Use Attachment.Save to
' Save the emended version
    attachObj.Save True
' Modify the attachment description
    attachObj.Description = "Emended Bug 1 Sample Attachment"
' Update the description in the project database
    attachObj.Post
Exit Sub
NewVersionErr:
    ErrHandler err, "NewVersionOfDefectAttachment"
End Sub


%%PageItemTitle%% $$Members$$

Attachment Object

IBaseField2 Implemented Interface Members

See Also

Attachment Object


%%ItemTitle%%

OTA COM Type Library

Downloading a file from an attachment object

Source code

Public Sub AttachmentDownLoad()
'This routine takes a bug attachment and downloads the file
' using the Attachment object.
    Dim BugFact As BugFactory
    Dim bugObj As Bug
    Dim attachFact As AttachmentFactory
    Dim attachObj As Attachment
    Dim attachList As list
    Dim LoadPath As String
'Get any defect with at least one attachment
    'tdc is the global TDConnection object.
    Set BugFact = tdc.BugFactory
    Set bugObj = BugFact.Item(1)
    Debug.Print bugObj.Summary
    'Amended: The list of flights is given even when past date set as Departing date
'Get an attachment
    Set attachFact = bugObj.Attachments
    Set attachList = attachFact.NewList("")
    Set attachObj = attachList.Item(1)
    Debug.Print attachObj.FileName
    'C:\DOCUME~1\steves\LOCALS~1\Temp\TD_80\423af35f\Attach\BUG1\BUG_1_err.log
        '
'Put a value in LoadPath to demonstrate that it is not used.
    LoadPath = "c:\temp"
'-----------------------------------------
'Use Attachment.Load to
'Download the attachment
    attachObj.Load True, LoadPath
'Output the actual download location
    Debug.Print LoadPath
    'C:\DOCUME~1\steves\LOCALS~1\Temp\TD_80\423af35f\Attach\BUG1
End Sub


%%ItemTitle%%

OTA COM Type Library

The effect of the ViewFormat argument

Source code

Public Sub NewVersionOfDefectAttachment(bugNum As Long)
' This routine downloads an attachment, makes a
' change and uploads the amended file.
    Dim BugFact As BugFactory
    Dim bugObj As Bug
    Dim attachFact As AttachmentFactory
    Dim attachObj As Attachment
    Dim FilePath As String, AttachmentName$
    Dim rc
    On Error GoTo NewVersionErr
' Get the bug factory from the TDConnection
    'tdc is the global TDConnection object.
    Set BugFact = tdc.BugFactory
' Get a bug object
' To see how to get a specific bug without knowing the ID,
' See example
' "Downloading a defect attachment with Extended Storage"
' for ExtendedStorage.Load
    Set bugObj = BugFact.Item(bugNum)
' Get the bug attachment factory
    Set attachFact = bugObj.Attachments
    Dim lst As TDAPIOLELib.list
    Set lst = attachFact.NewList("")
' Find SampleAttachment.txt
    Dim pos%, zeroName$, oneName$
    For Each attachObj In lst
        'For documentation purposes, demonstrate the effect of
        ' the ViewFormat argument to Attachment.Name:
        zeroName = attachObj.Name(0)
        oneName = attachObj.Name(1)
        Debug.Print "0: " & zeroName & " 1: " & oneName
        '0: BUG_1_SampleAttachment.txt 1: SampleAttachment.txt
        'Wasn't that interesting? And now, back to the main
        ' theme of this example.
        pos = InStr(attachObj.Name, "SampleAttachment.txt")
        If pos > 0 Then
            AttachmentName = attachObj.Name
Debug.Print _
"The attachment name for SampleAttachment.txt is " & AttachmentName
' Output: The attachment name for SampleAttachment.txt is SampleAttachment.txt
            Exit For
        End If
    Next
    Set lst = Nothing
'-----------------------------------------
'Use Attachment.Load to
' get a local copy of the file
    attachObj.Load True, FilePath
    Debug.Print "FilePath = " & FilePath
' Append the file name to the path
    FilePath = FilePath & "\" & AttachmentName
' Make a change in the file
    Open FilePath For Append As #1
    Print #1, vbCrLf & "This is the emended version"
    Close #1
'-----------------------------------------
'Use Attachment.Save to
' Save the emended version
    attachObj.Save True
' Modify the attachment description
    attachObj.Description = "Emended Bug 1 Sample Attachment"
' Update the description in the project database
    attachObj.Post
Exit Sub
NewVersionErr:
    ErrHandler err, "NewVersionOfDefectAttachment"
End Sub


%%PageItemTitle%% $$Members$$

Auditable Overview

Auditable Object Members

Public Properties

Public Property AuditPropertyFactory | The AuditPropertyFactory object to handle AuditProperty objects for the changed object.
Public Property AuditRecordFactory | The AuditRecordFactory object to handle AuditRecords for the changed object.

See Also

Auditable Overview


%%ItemTitle%%

OTA COM Type Library

Getting an AuditRecordFactory for a specific object

Source code

Public Sub GetReqHistory(theReq As Req)
'Get requirement history
        Dim currAuditable As IAuditable
'Cast the requirement object passed to the routine
' to an IAuditable reference
        Set currAuditable = theReq
        Dim AuditRecF As AuditRecordFactory
'The AuditRecordFactory handles records of the original object
        Set AuditRecF = currAuditable.AuditRecordFactory
        Dim recsList As TDAPIOLELib.list
        Set recsList = AuditRecF.NewList("")
        Debug.Print theReq.ID, theReq.Name
        Dim j As Integer, k As Integer
'Output the Audit Log Records
        For j = 1 To recsList.Count
            Dim AuditRec As AuditRecord
            Dim username As String
            Dim theDate As Date
            Set AuditRec = recsList.Item(j)
            username = AuditRec.username
            theDate = AuditRec.Time
            Debug.Print "----------------------------------"
            Debug.Print "EntityID = " & AuditRec.EntityID & ", ActionID = " & AuditRec.actionID; ""
            Debug.Print "User = " & username & ", Action Time = " & theDate & ""
'Output the Audit Properties
            Dim AuditPropF As AuditPropertyFactory
            Set AuditPropF = AuditRec.AuditPropertyFactory
            Dim propsList As TDAPIOLELib.list
            Set propsList = AuditPropF.NewList("")
            Dim oldValue As String, newValue$, msg$
            msg = "Old Value New Value"
            Debug.Print msg
            For k = 1 To propsList.Count
                Dim AuditProp As AuditProperty
                Set AuditProp = propsList.Item(k)
                oldValue = AuditProp.oldValue
                oldValue = """" & oldValue & """"
                Do While Len(oldValue) < 15
                    oldValue = oldValue & " "
                Loop
                newValue = AuditProp.newValue
                newValue = """" & newValue & """"
                Do While Len(newValue) < 15
                    newValue = newValue & " "
                Loop
                Dim aID As Long, cTime As Date
                cTime = AuditProp.Time
                aID = AuditProp.actionID
                msg = oldValue & newValue & "ActionID = " & CStr(aID) & ", TimeStamp = " & CStr(cTime)
                Debug.Print msg
            Next k
        Next j
End Sub


%%PageItemTitle%% $$Members$$

AuditProperty Overview

AuditProperty Object Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Action | The database activity that caused creation of this record. For example, INSERT, UPDATE, or DELETE.
Public Property ActionID | The ID of the associated AuditRecord object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property EntityID | The ID of the entity that changed.
Public Property EntityType | The type of the entity that changed. For example, BUG, REQ.
Public Property Field | The value of the specified field.
Public Property FieldName | The database definition name of field that was changed.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property NewValue | The new value after the change.
Public Property OldValue | The value before the change.
Public Property PropertyName | The custom label for the field that was changed.
Public Property SessionID | The Quality Center Session ID under which the action was performed.
Public Property TableName | The database table in which the change was recorded.
Public Property Time | The time stamp of the change according to the database server clock.
Public Property UserName | The username of the user who performed the action.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

AuditProperty Overview


%%PageItemTitle%% $$Members$$

AuditPropertyFactory Overview

AuditPropertyFactory Object Members

Public Methods

Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

AuditPropertyFactory Overview


%%ItemTitle%%

OTA COM Type Library

Retrieve audit properties

Source code

Public Sub GetAuditProperties()
    Dim lst As TDAPIOLELib.list
    Dim apf As AuditPropertyFactory
    Dim TestFilter As TDAPIOLELib.TDFilter
    Set apf = tdc.AuditPropertyFactory
    Set TestFilter = apf.filter
    ' The field that was changed.
    TestFilter.filter("AP_FIELD_NAME") = "BG_STATUS"
    Set lst = TestFilter.NewList
    Dim j%
    For j = 1 To lst.Count
        Dim ap As AuditProperty
        Dim propsActionId
        Dim FieldName
        Dim TableName
        Dim oldVal
        Dim newVal
        Set ap = lst.Item(j)
        propsActionId = ap.actionID
        FieldName = ap.FieldName
        TableName = ap.TableName
        oldVal = ap.oldValue
        newVal = ap.newValue
        Debug.Print ap.actionID & ", " & ap.TableName & ", " & ap.FieldName & ", " & ap.oldValue & ", " & ap.newValue
    Next j
End Sub


%%ItemTitle%%

OTA COM Type Library

Retrieving audit logs

Source code

Public Sub GetAuditLogs()
'Get all audit logs
    Dim TstFilterList As TDAPIOLELib.list
    Dim AuditRecF As AuditRecordFactory
'tdc is a TDConnection object. The user is authenticated and
' connected to a project before this routine is run.
    Set AuditRecF = tdc.AuditRecordFactory
    Dim TestFilter As TDAPIOLELib.TDFilter
'Get list of audit records on changes in defect status
    Set TestFilter = AuditRecF.Filter
    TestFilter.Filter("AU_ENTITY_TYPE") = "BUG"
    TestFilter.Filter("AP_FIELD_NAME") = "BG_STATUS"
    Set TstFilterList = TestFilter.NewList
                     '
    Dim actionID As Long, i&, j&
    Dim msg As String, oldVal$, newVal$
    Dim oldDate As Date, newDate As Date
    Dim AuditRec As AuditRecord
    Dim AuditPropF As AuditPropertyFactory
    Dim propList As TDAPIOLELib.list
'Get the audit records
    For i = 1 To TstFilterList.Count
        Set AuditRec = TstFilterList.Item(i)
        With AuditRec
            actionID = .actionID
            msg = "SessionID: " & .SessionID & vbCrLf
            msg = msg & "Action: " & .action & vbCrLf
            msg = msg & "Entity Type: " & .EntityType & " (" & .EntityID & ")" & vbCrLf
            msg = msg & "Description: """ & .Description & """"
        End With
        MsgBox msg
'Get the audit property records
        Set AuditPropF = AuditRec.AuditPropertyFactory
        Set propList = AuditPropF.NewList("")
        If propList.Count = 0 Then
            MsgBox "No properties for action " & Str(actionID)
        End If
        For j = 1 To propList.Count
            Dim ap As AuditProperty
            Set ap = propList.Item(j)
            With ap
                msg = "Action ID: " & Str(actionID) & vbCrLf
                msg = msg & "Field: " & .TableName & "." & .FieldName & vbCrLf
                msg = msg & "FieldName: " & .FieldName & vbCrLf
                'propsActionId = ap.actionID
                Dim xx
                xx = ap.oldValue
            End With
            If IsDate(xx) Then
                oldDate = xx: oldVal = ""
            Else
                oldVal = xx: oldDate = Now
            End If
            Dim yy
            yy = ap.newValue
            If IsDate(yy) Then
                newDate = yy: newVal = ""
            Else
                newVal = yy: newDate = Now
            End If
            msg = msg & "Old Value = """ & oldVal & """, New Value = """ & newVal & """" & vbCrLf
            msg = msg & "OldDate = " & oldDate & ", NewDate = " & newDate
            MsgBox msg
        Next j
    Next i
End Sub


%%PageItemTitle%% $$Members$$

AuditProperty Object

IBaseField2 Implemented Interface Members

See Also

AuditProperty Object


%%PageItemTitle%% $$Members$$

AuditProperty Object

IBaseField3 Implemented Interface Members

See Also

AuditProperty Object


%%PageItemTitle%% $$Members$$

AuditRecord Overview | AuditProperty Object

AuditRecord Object Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Action | The name of the action that caused the tracked change.
Public Property ActionID | The ID of the AuditRecord.
Public Property AuditPropertyFactory | The AuditPropertyFactory Object for the current AuditRecord.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Description | The description of the audited change.
Public Property EntityID | The ID of the entity that changed.
Public Property EntityType | The type of the entity that changed.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property SessionID | The Quality Center Session ID under which the action was performed.
Public Property Time | The time stamp of the change according to the database server clock.
Public Property UserName | The username of the user who performed the action.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

AuditRecord Overview | AuditProperty Object


%%PageItemTitle%% $$Members$$

AuditRecordFactory Overview

AuditRecordFactory Object Members

Public Methods

Public Method NewList Creates a list of objects according to the specified filter.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

AuditRecordFactory Overview


%%ItemTitle%%

OTA COM Type Library

Retrieve change audit records for defect status

Source code

Public Sub GetAuditRecs()
' Retrieve change audit records for defect status
    Dim lst As TDAPIOLELib.list
    Dim lst1 As TDAPIOLELib.list
    Dim arf As AuditRecordFactory
    Set arf = tdc.AuditRecordFactory
    Dim TestFilter As TDAPIOLELib.TDFilter
    Set TestFilter = arf.filter
    ' The name of the project database table in _
        which the change occurred.
    TestFilter.filter("AU_ENTITY_TYPE") = "BUG"
    ' The field that was changed.
    TestFilter.filter("AP_FIELD_NAME") = "BG_STATUS"
    Set lst1 = TestFilter.NewList
    Dim sessionID&, propsActionId&, actionID As Long
    Dim entityType$, entityID$, TableName$, action As String
    Dim oldVal$, newVal$, FieldName As String
    Dim oldDate As Date, newDate As Date
    Dim i%
    For i = 1 To lst1.Count
        Dim ar As AuditRecord
        Dim apf As AuditPropertyFactory
        Dim propList As TDAPIOLELib.list
        Dim desc As String
        Set ar = lst1.Item(i)
        actionID = ar.actionID
        sessionID = ar.sessionID
        action = ar.action
        entityType = ar.entityType
        entityID = ar.entityID
        desc = ar.Description
        Debug.Print "sessionID " & sessionID & "Action " & action & vbCrLf & " type " & entityType & vbCrLf & " description " & desc
        Set apf = ar.AuditPropertyFactory
        Set propList = apf.NewList("")
        If propList.Count = 0 Then
            MsgBox "No properties for action " & Str(actionID)
        End If
        Dim j%
        For j = 1 To propList.Count
            Dim ap As AuditProperty
            Set ap = propList.Item(j)
            propsActionId = ap.actionID
            FieldName = ap.FieldName
            TableName = ap.TableName
            Dim xx
            xx = ap.oldValue
            If IsDate(xx) Then
                oldDate = xx
                oldVal = ""
            Else
                oldVal = xx
                oldDate = Now
            End If
            Dim yy
            yy = ap.newValue
            If IsDate(yy) Then
                newDate = yy
                newVal = ""
            Else
                newVal = yy
                newDate = Now
            End If
            Debug.Print Str(actionID) & " field " & FieldName & " old " & oldVal & " new " & newVal & " oldDate " & oldDate & " newDate " & newDate
        Next j
    Next i
End Sub


%%ItemTitle%%

OTA COM Type Library

Retrieve history for a requirement

Source code

Private Sub GeReqHistory()
'Get requirement history
    If Len(EntityID_Text) > 0 Then
        Dim reqid As Integer
        reqid = CInt(EntityID_Text)
        Dim reqFactory As TDAPIOLELib.reqFactory
        Set reqFactory = tdc.reqFactory
        Dim ReqList As TDAPIOLELib.list
        Set ReqList = reqFactory.NewList("")
        Dim i As Integer
        Dim j As Integer
        Dim k As Integer
        For i = 1 To ReqList.Count
            Dim currAuditable As IAuditable
            Dim currReq As req
            Set currReq = ReqList.Item(i)
            If currReq.ID = reqid Then
                Set currAuditable = ReqList.Item(i)
                Dim arf As AuditRecordFactory
                Set arf = currAuditable.AuditRecordFactory
                Dim recsList As TDAPIOLELib.list
                Set recsList = arf.NewList("")
                For j = 1 To recsList.Count
                    Dim ar As AuditRecord
                    Dim username As String
                    Dim thedate As Date
                    Set ar = recsList.Item(j)
                    username = ar.username
                    Do While Len(username) < 10
                        username = username & " "
                    Loop
                    thedate = ar.Time
                    Dim apf As AuditPropertyFactory
                    Set apf = ar.AuditPropertyFactory
                    Dim propsList As TDAPIOLELib.list
                    Set propsList = apf.NewList("")
                    Dim FieldName As String
                    Dim TableName As String
                    Dim oldValue As String
                    Dim newValue As String
                    For k = 1 To propsList.Count
                        Dim ap As AuditProperty
                        Set ap = propsList.Item(k)
                        oldValue = ap.oldValue
                        Do While Len(oldValue) < 15
                            oldValue = oldValue & " "
                        Loop
                        newValue = ap.newValue
                        Do While Len(newValue) < 15
                            newValue = newValue & " "
                        Loop
                    Next k
                Next j
            End If
        Next i
        EntityID_Text = ""
    Else
        MsgBox "Please insert entity id"
    End If
End Sub


%%PageItemTitle%% $$Members$$

AuditRecord Object

IBaseField2 Implemented Interface Members

See Also

AuditRecord Object


%%PageItemTitle%% $$Members$$

BPComponent Overview

BPComponent Object Members

Public Methods

Public Method AddIteration | Adds an Iteration to the BPComponent.
Public Method DeleteIteration | Delete the specified BPIteration from the BPComponent.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property BPParams | The list of the BPComponents parameters.
Public Property Component | Get the Component object from which this BPComponent was created.
Public Property FailureCondition | Indicates the behavior of the business process test if this component fails.
Public Property Field | The value of the specified field.
Public Property Group | The BPGroup to which this component belongs.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Iterations | The list of the BPComponents Iterations.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The name of the component from which this BPComponent was created.
Public Property Order | The position of the BPComponent in the BusinessProcess (1-based).
Public Property Test | The parent business process test.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

BPComponent Overview


%%ItemTitle%%

OTA COM Type Library

Connecting an output parameter's value to an input parameter

Source code

Public Sub AddReference(myBPComponent As BPComponent, targetItem As Long, _
    sourceBPComp As BPComponent, sourceItem As Long)
    Dim myTempIteration As BPIteration
' Connect an output parameter, the parameter with index "sourceItem"
' from the BPParams collection of the source BPComponent, to
' the input parameter with index "targetItem" of
' the BPParams collection of the target BPComponent.
' This makes the value of the input parameter at runtime
' equal to the output parameter's value.
'
    ' Before the connection can be created, delete any BPIterationParams
    ' currently associated with the input parameter.
    For Each myTempIteration In myBPComponent.Iterations
        myTempIteration.DeleteParam myTempIteration.IterationParams.Item(targetItem)
    Next myTempIteration
    'Connect the output paramter to the input parameter.
    myBPComponent.BPParams.Item(targetItem).Reference = _
        sourceBPComp.BPParams.Item(sourceItem)
End Sub


%%ItemTitle%%

OTA COM Type Library

Creating a complete Business Process Test (long example)

Source code

Private Sub CreateBPTest(oTest As Test, _
    oComponent As Component)
' This example creates a complete Business Process Test,
' with BPComponents, groups, iterations and values.
' For demonstration purposes, we create three BPComponents by
' adding the same Component three times. In production code, of
' course, you may add different Components.
    Dim myBPTest As BusinessProcess
    Dim myBPComponent1 As BPComponent
    Dim myBPComponent2 As BPComponent
    Dim myBPComponent3 As BPComponent
    Dim myBPGroup As BPGroup
    Dim myTempIteration As BPIteration
    Dim myTempIterationParam As BPIterationParam
'Cast the input test to a BPTest and add the component three times.
' VisualBasic calls QueryInterface transparently to make this cast.
' Each addition creates another BPComponent object.
    Set myBPTest = oTest
    Set myBPComponent1 = myBPTest.AddBPComponent(oComponent)
    myBPComponent1.Order = 2
    myBPComponent1.FailureCondition = "Continue"
    ' Adding a component to a Business Process Test automatically
    ' adds an iteration and a BPIterationParam for each ComponentParam.
    ' The parameters will be handled explicitly later in this routine,
    ' so at this point, delete the parameters that were
    ' added automatically.
    myBPComponent1.Iterations.Item(1).DeleteIterationParams
    myBPComponent1.Iterations.Item(1).Order = 0
    Set myBPComponent2 = myBPTest.AddBPComponent(oComponent)
    myBPComponent2.Order = 1
    myBPComponent2.FailureCondition = "Exit"
    myBPComponent2.Iterations.Item(1).DeleteIterationParams
    myBPComponent2.Iterations.Item(1).Order = 0
    Set myBPComponent3 = myBPTest.AddBPComponent(oComponent)
    myBPComponent3.Order = 3
    myBPComponent3.FailureCondition = "Exit"
    myBPComponent3.Iterations.Item(1).DeleteIterationParams
    myBPComponent3.Iterations.Item(1).Order = 0
'Add the second and third BPComponents to a group.
    Set myBPGroup = myBPTest.AddGroup
    myBPGroup.AddBPComponent myBPComponent3
    myBPGroup.AddBPComponent myBPComponent1
'Add iterations
' Add the same number of iterations to
' BPComponents of the same group, and add the Order values.
    Set myTempIteration = myBPComponent1.AddIteration
    myTempIteration.Order = 1
    Set myTempIteration = myBPComponent1.AddIteration
    myTempIteration.Order = 2
    Set myTempIteration = myBPComponent2.AddIteration
    myTempIteration.Order = 1
    Set myTempIteration = myBPComponent2.AddIteration
    myTempIteration.Order = 2
    Set myTempIteration = myBPComponent3.AddIteration
    myTempIteration.Order = 1
    Set myTempIteration = myBPComponent3.AddIteration
    myTempIteration.Order = 2
' Add a run time parameter to the test
    Dim myRTParam As RTParam
    Set myRTParam = myBPTest.AddRTParam
    myRTParam.Name = "RunTimeParam"
    myRTParam.ValueType = "String"
'Handle group.
'For each component in the group, for each iteration in the component:
    ' Set the value of the input parameters to the parameter's name
    ' concatenated to the component's index + iteration's index + parameter's index.
    Dim myTempBPParam As BPParameter
    Dim myTempBPComponent As BPComponent
    Dim compIdx, iterIdx, paramIdx As Integer
    compIdx = 1: iterIdx = 1: paramIdx = 1
    For Each myTempBPComponent In myBPGroup.BPComponents
        For Each myTempIteration In myTempBPComponent.Iterations
            For Each myTempBPParam In myTempBPComponent.BPParams
                Set myTempIterationParam = myTempIteration.AddParam(myTempBPParam)
                ' If input
                If myTempBPParam.ComponentParamIsOut = 0 Then
                    ' To make this a reference to a run-time parameter,
                    ' set the value to the name of the source run-time parameter
                    ' enclosed in curly brackets.
                    If compIdx = 2 And iterIdx = 1 And paramIdx = 1 Then
                        myTempIterationParam.Value = "{" & myRTParam.Name & "}"
                    Else
                        ' If a constant value, set the value without curly brackets.
                        myTempIterationParam.Value = _
                            myTempBPParam.ComponentParamName & _
                            "_" & compIdx & _
                            "_" & iterIdx & _
                            "_" & paramIdx
                    End If
                End If
                paramIdx = paramIdx + 1
            Next myTempBPParam
            paramIdx = 1
            iterIdx = iterIdx + 1
        Next myTempIteration
        paramIdx = 1
        iterIdx = 1
        compIdx = compIdx + 1
    Next myTempBPComponent
'Handle the BPComponent that is not in the above group.
' Add parameters to the iterations of myBPComponent2,
' which is not in the group and therefore not handled
' in the above loop.
    For Each myTempIteration In myBPComponent2.Iterations
        For Each myTempBPParam In myBPComponent2.BPParams
            myTempIteration.AddParam myTempBPParam
        Next myTempBPParam
    Next myTempIteration
' Connect an output parameter, myBPComponent2.BPParams.Item(3)to
' an input parameter myBPComponent1.BPParams.Item(1).
' This makes the value of the input parameter at runtime
' equal to the output parameter's value.
'
    ' Before the connection can be created, delete any BPIterationParams
    ' currently associated with the input parameter.
    For Each myTempIteration In myBPComponent1.Iterations
        myTempIteration.DeleteParam myTempIteration.IterationParams.Item(1)
    Next myTempIteration
    ' Connect the output paramter to the input parameter.
    ' This connection applies to all iterations.
    myBPComponent1.BPParams.Item(1).Reference = myBPComponent2.BPParams.Item(3)
' Save the Business Process Test
    myBPTest.Save
End Sub


%%ItemTitle%%

OTA COM Type Library

Creating a new BPComponent

Source code

Private Function AddBPComponent(oTest As Test, _
    oComponent As Component, _
    Optional ContinueOnErr As String = "Continue", _
    Optional NumIterations As Integer = 1, _
    Optional ComponentOrder As Integer = 1) _
    As BPComponent
' Add the input component to the input test
' and set the properties.
    Dim myBPTest As BusinessProcess
    Dim myBPComponent As BPComponent
' Cast the test object to a BPTest and add the component.
    Set myBPTest = oTest
    ' Adding the component to the Business Process test
    ' creates the new BPComponent
    Set myBPComponent = myBPTest.AddBPComponent(oComponent)
' Set the properties
    ' Set the execution order of this component instance
    myBPComponent.Order = ComponentOrder
    ' Should the parent test fail if this component fails?
    myBPComponent.FailureCondition = ContinueOnErr
    myBPComponent.Iterations.Item(1).Order = 0
'Create the iterations
    Dim i As Integer
    Dim myTempBPParam As BPParameter
    Dim myTempIteration As BPIteration
    For i = 1 To NumIterations - 1
        Set myTempIteration = myBPComponent.AddIteration
        myTempIteration.Order = i
        ' Add the parameters to the iteration
        For Each myTempBPParam In myBPComponent.BPParams
            myTempIteration.AddParam myTempBPParam
        Next myTempBPParam
    Next i
' Return the BPComponent
    myBPTest.Save
    Set AddBPComponent = myBPComponent
End Function


%%ItemTitle%%

OTA COM Type Library

Get business process test parameters

Source code

Public Sub GetBPTestParams()
'Get business process test parameters
    Dim objTestFactory As testFactory
    Dim objTest As Test
    Dim BPTest As BusinessProcess
    Dim components As list
    Dim Component As BPComponent
    Dim params As list, tList As list
    Dim iterations As list
    Dim iteration As BPIteration
    Set objTestFactory = tdc.testFactory
    Set tList = objTestFactory.NewList("")
    'Get any Business Process test
    Dim tst As Test
    For Each tst In tList
        Debug.Print tst.Type
        If tst.Type = "BUSINESS-PROCESS" Then
           Set objTest = tst
           Exit For
        End If
    Next tst
    'Set objTest = objTestFactory.Item(3)
    If objTest Is Nothing Then Exit Sub
    Set BPTest = objTest
    BPTest.Load
    Set components = BPTest.BPComponents
    Set Component = components.Item(1)
    Set iterations = Component.iterations
    Set iteration = iterations.Item(1)
    Set params = iteration.IterationParams
    Dim param1 As BPIterationParam
    Dim param2 As BPIterationParam
    Set param1 = params.Item(1)
    Set param2 = params.Item(2)
    MsgBox param1.Value
    MsgBox param2.Value
 End Sub


%%PageItemTitle%%

BPComponent Object

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

The results of calling the Post method are indeterminate. Use BusinessProcess.Save rather than Post.

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

BPComponent Object


%%PageItemTitle%% $$Members$$

BPGroup Overview

BPGroup Object Members

Public Methods

Public Method AddBPComponent | Adds the specified business component to the group.
Public Method BPComponents | The list of the BPComponents that belong to the group.
Public Method DeleteBPComponent | Removes the specified business component from the group.

Public Properties

Public Property ID The group ID.

See Also

BPGroup Overview


%%PageItemTitle%% $$Members$$

BPIteration Overview

BPIteration Object Members

Public Methods

Public Method AddParam | Add the specified BPParameter Object to the iteration.
Public Method DeleteIterationParams | Delete all the parameters from the iteration.
Public Method DeleteParam | Delete the specified BPParameter from the iteration.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property BPComponent | The BPComponent object of which this an iteration.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property IterationParams | The list of BPIterationParam objects associated with this iteration.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Order | The 0-based execution position of this iteration in the set of iterations of this component.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

BPIteration Overview


%%PageItemTitle%% $$Members$$

BPIterationParam Overview

BPIterationParam Object Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property BPParameter | The BPParameter object of which this is an instance.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Value | The value of the parameter for this iteration.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

BPIterationParam Overview


%%PageItemTitle%%

BPIterationParam Object

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

The results of calling the Post method are indeterminate. Use BusinessProcess.Save rather than Post.

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

BPIterationParam Object


%%PageItemTitle%%

BPIteration Object

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

The results of calling the Post method are indeterminate. Use BusinessProcess.Save rather than Post.

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

BPIteration Object


%%PageItemTitle%% $$Members$$

BPParameter Overview

BPParameter Object Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property BPComponent | The BPComponent object to which this parameter belongs.
Public Property ComponentParam | The ComponentParam object from which this BPParam was created.
Public Property ComponentParamIsOut | Indicates if the ComponentParam from which this BPParam was created is an output parameter. If False, it is an input parameter.
Public Property ComponentParamName | The name of the ComponentParam object from which this BPParam was created.
Public Property ComponentParamOrder | The position of the ComponentParam object from which this BPParam was created.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Reference | The output BPParameter object that is the source of the value for this parameter.
Public Property Type | The parameter type.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

BPParameter Overview


%%PageItemTitle%%

BPParameter Object

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

The results of calling the Post method are indeterminate. Use BusinessProcess.Save rather than Post.

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

BPParameter Object


%%PageItemTitle%% $$Members$$

BPStepParam Overview

BPStepParam Object Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The name of this parameter.
Public Property ReferencedParamID | The parameter ID of the referenced parameter.
Public Property StepID | The ID of the step in which this parameter occurs.
Public Property Type | The parameter type.
Public Property Value | The value of this parameter.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

BPStepParam Overview


%%PageItemTitle%% $$Members$$

BPStepParamFactory Overview

BPStepParamFactory Object Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

BPStepParamFactory Overview


%%PageItemTitle%% $$Members$$

BPStepParamFactory Object

IBaseFactory2 Implemented Interface Members

See Also

BPStepParamFactory Object


%%PageItemTitle%%

BPStepParam Object

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

The results of calling the Post method are indeterminate. Use BusinessProcess.Save rather than Post.

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

BPStepParam Object


%%PageItemTitle%% $$Members$$

Bug Overview

Bug Object Members

Public Methods

Public Method FindSimilarBugs | Searches the defect summaries for similarities to this defect.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Mail | Mails the IBaseFieldExMail field item.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AssignedTo | The name of the user to whom the defect is assigned.
Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property DetectedBy | The name of the user who detected the defect.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Priority | The defect priority.
Public Property Project | The testing project to which the defect belongs.
Public Property Status | The defect status.
Public Property Summary | A short description of the defect.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

Bug Overview


%%PageItemTitle%% $$Members$$

BugFactory Overview

BugFactory Object Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method BuildAgeGraph | Creates a graph that shows the lifetime of defects.
Public Method BuildProgressGraph | Creates a graph showing status at specific points: either defect accumulation or time to fix (estimated or actual).
Public Method BuildSummaryGraph | Creates a summary graph either of the number of defects or the time to fix (estimated or actual).
Public Method BuildTrendGraph | Creates a graph that shows the history of changes to specific Defect fields for each time interval displayed.
Public Method FindSimilarBugs | Searches defect summaries and descriptions for matches to Pattern.
Public Method Mail | Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

BugFactory Overview


%%ItemTitle%%

OTA COM Type Library

Creating links between defects

Source code

Sub LinkDefects()
'This example creates two defects and links them
    Dim BugF As BugFactory
    Dim Bug1 As Bug, Bug2 As Bug
' tdc is a TDConnection. The user is authenticated and
' connected to the project before this routine runs.
    Set BugF = tdc.BugFactory
    '
'Create two new defects
    Set Bug1 = BugF.AddItem(Null)
    Bug1.Summary = "Lydia Bennet is 15 years old."
    Bug1.Status = "New"
    Bug1.Priority = "3-High"
    Bug1.Field("BG_SEVERITY") = "3-High"
    Bug1.DetectedBy = c_qcUser
    Bug1.Field("BG_DETECTION_DATE") = Date
    Bug1.Post
    '
    Set Bug2 = BugF.AddItem(Null)
    Bug2.Summary = "Mr. Bennet hides in library."
    Bug2.Status = "New"
    Bug2.Priority = "3-High"
    Bug2.Field("BG_SEVERITY") = "3-High"
    Bug2.DetectedBy = c_qcUser
    Bug2.Field("BG_DETECTION_DATE") = Date
    Bug2.Post
    '
' Link the new defects
    Dim BugLinkF As LinkFactory
    Dim bugLink As Link
    Dim bgLinkable As ILinkable
'Cast Bug1 to ILinkable and get
' bug link factory for Bug1
    Set bgLinkable = Bug1
    Set BugLinkF = bgLinkable.BugLinkFactory
'Create a link between Bug1, the source entity,
' and Bug2, the target entity
    Set bugLink = BugLinkF.AddItem(Bug2)
    bugLink.LinkType = "Related"
    bugLink.Post
'Show the link definition
    Dim anObj As Object
    Set anObj = bugLink.SourceEntity
    Debug.Print anObj.Summary 'Lydia Bennet is 15 years old. (Bug1)
    Set anObj = bugLink.TargetEntity
    Debug.Print anObj.Summary 'Mr. Bennet hides in library. (Bug2)
End Sub


%%ItemTitle%%

OTA COM Type Library

Get Table Fields

Source code

Public Sub CheckValidValue(Optional TableName As String = "BUG")
    Dim BugFact As BugFactory
    Dim BugList As list
    Dim aField As TDField
    Dim fieldList As list
    Dim rc, ErrCode As Long
    Dim aBug As Bug
    Dim msg$
    Dim okCnt%, noNodeCnt%, errorCnt%, unknownCnt%
    Dim dataType As Long
'------------------------------------------------
' User BugFactory.Fields to get a list of TDField
' objects in the bug table.
' This example uses the BugFactory, but this can
' be done with any class that implements IBaseFactory
    'tdc is the global TDConnection object.
    Set BugFact = tdc.BugFactory
    Set fieldList = BugFact.Fields
'------------------------------------------
' Use List.Count to check how many items.
    Debug.Print: Debug.Print
    Debug.Print "There are " & fieldList.Count & _
        " fields in this table."
    Debug.Print "----------------------------------"
'Get any bug. To look at field attributes we
' need a valid object and since this example is
' not interested in the particular values of the object,
' it doesn't matter which bug.
    Set BugList = BugFact.NewList("")
    Set aBug = BugList(0)
'Walk through the list
    For Each aField In fieldList
        With aField
        'Quit when we have enough for this example
        If InStr(aField.Name, "BG_USER_10") > 0 Then Exit For
        ' For the DataTypeString() code,
        ' see example "Convert data types to string"
        Debug.Print .Name & ", " & .Property & ", Data type is " _
            & DataTypeString(.Type)
        On Error Resume Next
'----------------------------------------------------
'Use TDField.IsValidValue to confirm that a value can
'be used for a field.
' Get the correct data type and check validity of an
' arbitrary value.
' Save the error code immediately after IsValidValue call
' before another call can change the err object.
        dataType = aField.Type
        Select Case dataType
            Case TDOLE_LONG, TDOLE_ULONG
                aField.IsValidValue 5, aBug
                ErrCode = err.Number
            Case TDOLE_FLOAT
                aField.IsValidValue 5.5, aBug
                ErrCode = err.Number
            Case TDOLE_STRING
                aField.IsValidValue "Joe", aBug
                ErrCode = err.Number
            Case Else
            'These will be errors:
                aField.IsValidValue _
                    "String to non-string value", aBug
                ErrCode = err.Number
        End Select
'Output an error code message
        If ErrCode = 0 Then 'S_OK
            msg = "Valid Value"
            okCnt = okCnt + 1
        Else
             rc = ErrCode - vbObjectError
             Select Case rc
                Case FIELD_E_VERIFIED
                    msg = "Error: Invalid value for field"
                    errorCnt = errorCnt + 1
                Case TDOLE_NONODE
                    msg = "Error: Field can not be set to this value"
                    noNodeCnt = noNodeCnt + 1
                Case Else
                    msg = "Unrecognized error: " & rc _
                        & " , HRESULT = " & ErrCode
                    unknownCnt = unknownCnt + 1
            End Select
        End If
        Debug.Print vbTab & msg
        '
        End With 'aField
    Next aField
    Debug.Print "----------------------------------"
    Debug.Print "Number of fields with valid value = " & okCnt
    Debug.Print "Number of fields with invalid type = " & errorCnt
    Debug.Print "Number of fields with invalid value= " & noNodeCnt
    Debug.Print "Number of fields with unknown error = " & unknownCnt
    Debug.Print "----------------------------------"
End Sub


%%ItemTitle%%

OTA COM Type Library

Filtering defect records

Source code

Sub BugFilter()
    Dim BugFact As BugFactory
    Dim BugFilter As TDFilter
    Dim BugList As list
    Dim theBug As Bug
    Dim i%, msg$
'Get the bug factory filter
    'tdc is the global TDConnection object.
    Set BugFact = tdc.BugFactory
    Set BugFilter = BugFact.Filter
'Set the filter values
    BugFilter.Filter("BG_STATUS") = "Closed"
    BugFilter.Order("BG_PRIORITY") = 1
    MsgBox BugFilter.Text
'Create a list of defects from the filter
' and show a few of them
    Set BugList = BugFilter.NewList
    msg = "Number of defects = " & BugList.Count & Chr(13)
    For Each theBug In BugList
       msg = msg & theBug.ID & ", " & theBug.Summary & ", " _
        & theBug.Status & ", " & theBug.Priority & Chr(13)
       i = i + 1
       If i > 10 Then Exit For
    Next
    MsgBox msg
End Sub


%%ItemTitle%%

OTA COM Type Library

Getting the list of design tests used in a test set

Source code

Sub BugReqLink(aBug As Bug)
    Dim BugF As BugFactory, reqF As reqFactory
    Dim BugFilter As TDFilter, ReqFilter As TDFilter
    Dim aReq As Req, reqL As list
    Dim thisBug As Bug, bugL As list
'This example outputs all the requirements linked to the Bug
' passed as an input argument
'Set up the cross filter that specifies only this bug.
    'tdc is the global TDConnection object.
    Set BugF = tdc.BugFactory
    Set BugFilter = BugF.Filter
    BugFilter.Filter("BG_BUG_ID") = aBug.ID
    Set bugL = BugFilter.NewList
    For Each thisBug In bugL
        Debug.Print thisBug.ID, thisBug.Summary
    Next thisBug
'Set up the primary filter to get requirements.
' There is no Filter property set, so all requirements are returned.
    Set reqF = tdc.reqFactory
    Set ReqFilter = reqF.Filter
'Add the cross filter. The filter now means "Return
' all requirements associated with the bugs specifed
' by the cross filter, in this case, a single Bug.
    ReqFilter.SetXFilter "REQ-BUG", True, BugFilter.Text
    Set reqL = reqF.NewList(ReqFilter.Text)
'Check the results
    For Each aReq In reqL
        Debug.Print aReq.Name
    Next aReq
End Sub


%%PageItemTitle%% $$Members$$

BugFactory Object

IAlertableEntityFactory Implemented Interface Members

See Also

BugFactory Object


%%PageItemTitle%% $$Members$$

BugFactory Object

IBaseFactory2 Implemented Interface Members

See Also

BugFactory Object


%%PageItemTitle%% $$Members$$

BugFactory Object

ISearchableFactory Implemented Interface Members

See Also

BugFactory Object


%%PageItemTitle%% $$Members$$

BugFactory Object

ISupportCopyPaste2 Implemented Interface Members

See Also

BugFactory Object


%%ItemTitle%%

OTA COM Type Library

Accessing members of Additional Implemented Interfaces

Source code

Sub GetAdditionalInterface()
'This example shows how to access the members of
' additional implemented interfaces from the implementing object.
'This example uses the Bug object and the IFollowUpManager interface,
' but the technique applies to all objects that implement
' additional interfaces.
    Dim aFollowUp As IFollowUpManager
    Dim aBug As Bug
    Dim aList As list
'Get a bug object at random
    'tdc is the global TDConnection object.
    Set aList = tdc.BugFactory.NewList("")
    Set aBug = aList(0)
'Cast the Bug object to the type of
' the implemented interface, in this
' case, IFollowUpManager.
    Set aFollowUp = aBug
'Call a method of the implemented interface
    Debug.Print aFollowUp.HasFollowUp
End Sub


%%ItemTitle%%

OTA COM Type Library

Getting and setting bug properties

Source code

Sub BugProperties()
'This procedure gets and sets some bug properties
    Dim BugFact As BugFactory
    Dim theBug As Bug
'Get a bug object
    'tdc is the global TDConnection object.
    Set BugFact = tdc.BugFactory
    Set theBug = BugFact.Item(1)
'Print the properities
    Debug.Print theBug.Priority
    Debug.Print theBug.AssignedTo
    Debug.Print theBug.DetectedBy
    Debug.Print theBug.Project
    Debug.Print theBug.Status
    Debug.Print theBug.Summary
'3-High
'james_qc
'alice_qc
'Mercury Tours (HTML Edition)
'Open
'The list of flights is given even when past date set as Departing date
'
'Change the values
    theBug.Priority = "4-Very High"
    theBug.AssignedTo = "steves"
    theBug.DetectedBy = "alex_qc"
    theBug.Project = "Mercury Tours Administration"
    theBug.Status = "Fixed"
    theBug.Summary = "Amended: The list of flights is given even when past date set as Departing date"
'Commit to database
theBug.Post
'Check the new values
    Debug.Print theBug.Priority
    Debug.Print theBug.AssignedTo
    Debug.Print theBug.DetectedBy
    Debug.Print theBug.Project
    Debug.Print theBug.Status
    Debug.Print theBug.Summary
'4-Very High
'steves
'alex_qc
'Mercury Tours Administration
'Fixed
'Amended: The list of flights is given even when past date set as Departing date
End Sub


%%ItemTitle%%

OTA COM Type Library

Creating defects and links between defects

Source code

Sub LinkDefects()
'This example creates two defects and links them
    Dim BugF As BugFactory
    Dim Bug1 As Bug, Bug2 As Bug
' tdc is a TDConnection. The user is authenticated and
' connected to the project before this routine runs.
    Set BugF = tdc.BugFactory
    '
'Create two new defects
    Set Bug1 = BugF.AddItem(Null)
    Bug1.Summary = "Lydia Bennet is 15 years old."
    Bug1.Status = "New"
    Bug1.Priority = "3-High"
    Bug1.Field("BG_SEVERITY") = "3-High"
    Bug1.DetectedBy = c_qcUser
    Bug1.Field("BG_DETECTION_DATE") = Date
    Bug1.Post
    '
    Set Bug2 = BugF.AddItem(Null)
    Bug2.Summary = "Mr. Bennet hides in library."
    Bug2.Status = "New"
    Bug2.Priority = "3-High"
    Bug2.Field("BG_SEVERITY") = "3-High"
    Bug2.DetectedBy = c_qcUser
    Bug2.Field("BG_DETECTION_DATE") = Date
    Bug2.Post
    '
' Link the new defects
    Dim BugLinkF As LinkFactory
    Dim bugLink As Link
    Dim bgLinkable As ILinkable
'Cast Bug1 to ILinkable and get
' bug link factory for Bug1
    Set bgLinkable = Bug1
    Set BugLinkF = bgLinkable.BugLinkFactory
'Create a link between Bug1, the source entity,
' and Bug2, the target entity
    Set bugLink = BugLinkF.AddItem(Bug2)
    bugLink.LinkType = "Related"
    bugLink.Post
'Show the link definition
    Dim anObj As Object
    Set anObj = bugLink.SourceEntity
    Debug.Print anObj.Summary 'Lydia Bennet is 15 years old. (Bug1)
    Set anObj = bugLink.TargetEntity
    Debug.Print anObj.Summary 'Mr. Bennet hides in library. (Bug2)
End Sub


%%ItemTitle%%

OTA COM Type Library

Creating various entities and linking them

Source code

Sub LinkDefectsToEntities(FolderName As String, TestName As String)
'-----------------------------------------------------------
' This example creates a test and a test set with test steps.
' It then creates three defects and links them to the test,
' the run, and the test step.
'-----------------------------------------------------------
    Dim TestF As TestFactory
    Dim NewTest As test
    Dim StepF As DesignStepFactory
    Dim desStep As DesignStep
    Dim root As SubjectNode, folder As SubjectNode
    Dim TreeMgr As TreeManager
    Dim labTreeMgr As TestSetTreeManager
    Dim labFolder As SysTreeNode, labTreeRoot As SysTreeNode
    Dim BugF As BugFactory
    Dim Bug1 As Bug, Bug2 As Bug, bug3 As Bug
    Dim TestSetF As TestSetFactory
    Dim TstSet As TestSet
    Dim testInstanceF As TSTestFactory
    Dim tstInstance As TSTest
    Dim RunF As RunFactory
    Dim theRun As run
    Dim runStepF As StepFactory
    Dim runStep As Step, runStep2 As Step
    Dim TestId As String
    Dim lst As list, Item
    On Error GoTo LinkDefectsToEntitiesErr
'tdc is a TDConnection object. When this routine is run,
' the user is authenticated and connected to the project.
    Set TreeMgr = tdc.TreeManager
    Set TestF = tdc.TestFactory
    Set labTreeMgr = tdc.TestSetTreeManager
    Set BugF = tdc.BugFactory
'------------------------------------------
' Test Plan
'------------------------------------------
'Get or create test plan subject folder
    errmsg = "Subject tree error"
    Set root = TreeMgr.TreeRoot("Subject")
    On Error Resume Next
    Set folder = root.FindChildNode(FolderName)
    On Error GoTo LinkDefectsToEntitiesErr
    If folder Is Nothing Then _
        Set folder = root.AddNode(FolderName)
'Create a design test
    errmsg = "Design test error"
    'Get the test if it exists
    ' For the code of GetTest, see the Test object example
    ' "Get a test object with name and path"
    Set NewTest = GetTest(TestName, FolderName)
    'If it doesn't exist, create it
    If NewTest Is Nothing Then
        Set NewTest = TestF.AddItem(Null)
        NewTest.Name = TestName
        NewTest.Type = "MANUAL"
        'Put the test in the new subject folder
        NewTest.Field("TS_SUBJECT") = folder.NodeID
        NewTest.Post
    End If
'Get or create a design step from the factory of the new test
    errmsg = "Design step error"
    Set StepF = NewTest.DesignStepFactory
    Dim aFilter As TDFilter
    Set aFilter = StepF.Filter
    Dim StepName$
    StepName = TestName & "Step_1"
    aFilter.Filter("DS_STEP_NAME") = StepName
    Set lst = StepF.NewList(aFilter.Text)
    If lst.Count = 0 Then
        Set desStep = StepF.AddItem(Null)
        desStep.StepName = StepName
        desStep.StepDescription = "Step to be linked to defect."
        desStep.StepExpectedResult = "This step expected to be linked."
        desStep.Post
    Else
        Set desStep = lst.Item(1)
    End If
'-----------------------------------------
' Test Lab
'------------------------------------------
'Get or create a test set folder
    errmsg = "Lab node error"
    Dim tsFolder$, tsFolderPath$
    tsFolder = FolderName & "_TS"
    tsFolderPath = "Root\" & tsFolder
    On Error Resume Next
    Set labFolder = labTreeMgr.NodeByPath(tsFolderPath)
    On Error GoTo LinkDefectsToEntitiesErr
    If labFolder Is Nothing Then
        Set labTreeRoot = labTreeMgr.root
        Set labFolder = labTreeRoot.AddNode(tsFolder)
        labTreeRoot.Post
    End If
'Get or create a test set from the factory of the new folder
    errmsg = "Test set error"
    Dim tsName$
    tsName = TestName & "_TS"
    Set TestSetF = labFolder.TestSetFactory
    Set aFilter = TestSetF.Filter
    aFilter.Filter("CY_CYCLE") = tsName
    Set lst = TestSetF.NewList(aFilter.Text)
    If lst.Count = 0 Then
        Set TstSet = TestSetF.AddItem(Null)
        TstSet.Field("CY_CYCLE") = tsName
        TstSet.Post
    Else
        Set TstSet = lst.Item(1)
    End If
'Get or create a test instance from the factory of the new test set
    errmsg = "Test instance error"
    Set testInstanceF = TstSet.TSTestFactory
    Set aFilter = testInstanceF.Filter
    aFilter.Filter("TC_TEST_ID") = NewTest.ID
    Set lst = testInstanceF.NewList(aFilter.Text)
    If lst.Count = 0 Then
        Set tstInstance = testInstanceF.AddItem(Null)
    'Put the new test in the test set
        tstInstance.Field("TC_TEST_ID") = NewTest.ID
    Else
        Set tstInstance = lst.Item(1)
    End If
    tstInstance.Status = "No Run"
    tstInstance.Post
'Create a run of the test instance
    errmsg = "Run error"
    Dim runName$
    runName = TestName & "Linked_Run"
    Set RunF = tstInstance.RunFactory
    Set theRun = RunF.AddItem(runName)
    theRun.Status = "FAILED"
    theRun.Post
'Get the design step created above for the test
' to be associated with this test run
    errmsg = "Design steps error"
    theRun.CopyDesignSteps
    theRun.Post
'Add the steps to run and fail them
    Set runStepF = theRun.StepFactory
    Set lst = runStepF.NewList("")
    For Each Item In lst
     Set runStep2 = Item
     runStep2.Status = "Failed"
     runStep2.Post
    Next
'------------------------------------------
' Defect Module
'------------------------------------------
'Create new defects
    errmsg = "Create Bug1 error"
    Set Bug1 = BugF.AddItem(Null)
    Bug1.Summary = "Associated to " & TestName
    Bug1.Status = "New"
    Bug1.Priority = "3-High"
    Bug1.Field("BG_SEVERITY") = "3-High"
    Bug1.DetectedBy = c_qcUser
    Bug1.Field("BG_DETECTION_DATE") = Date
    Bug1.Post
    '
    errmsg = "Create Bug2 error"
    Set Bug2 = BugF.AddItem(Null)
    Bug2.Summary = "Associated to " & runName
    Bug2.Status = "New"
    Bug2.Priority = "3-High"
    Bug2.Field("BG_SEVERITY") = "3-High"
    Bug2.DetectedBy = c_qcUser
    Bug2.Field("BG_DETECTION_DATE") = Date
    Bug2.Post
    '
    errmsg = "Create Bug2 error"
    Set bug3 = BugF.AddItem(Null)
    bug3.Summary = "Associated to Run Step " & TestName & ":" & runStep2.Name
    bug3.Status = "New"
    bug3.Priority = "3-High"
    bug3.Field("BG_SEVERITY") = "3-High"
    bug3.DetectedBy = c_qcUser
    bug3.Field("BG_DETECTION_DATE") = Date
    bug3.Post
'
'Add associations between diffent entities and bugs
    Dim BugLinkF As LinkFactory
    Dim b2Test As Link, b2Run As Link, b2Step As Link
    Dim testL As ILinkable, runL As ILinkable, stepL As ILinkable
    Dim anObj As Object
'Cast test to Ilinkable and get bug link factory
    errmsg = "Error linking Bug1"
    Set testL = NewTest
    Set BugLinkF = testL.BugLinkFactory
'Create a link between Bug1 and the test
    Set b2Test = BugLinkF.AddItem(Bug1)
    b2Test.LinkType = "Related"
    b2Test.Post
'Show the link definition
    Set anObj = b2Test.LinkedByEntity
    Debug.Print TypeName(anObj), anObj.Name 'ITest LinkTest
    Set anObj = b2Test.SourceEntity
    Debug.Print TypeName(anObj), anObj.Name 'ITest LinkTest
    Set anObj = b2Test.TargetEntity
    Debug.Print TypeName(anObj), anObj.Summary 'IBug Associated to LinkTest
'Cast Bug2 to Ilinkable and get bug link factory
    errmsg = "Error linking Bug2"
    Set runL = theRun
    Set BugLinkF = runL.BugLinkFactory
'Create a link between Bug2 and the run
    Set b2Run = BugLinkF.AddItem(Bug2)
    b2Run.LinkType = "Related"
    b2Run.Post
'Show the link definition
    Set anObj = b2Run.LinkedByEntity
    Debug.Print TypeName(anObj), anObj.Name 'IRun2 LinkTestLinked_Run
    Set anObj = b2Run.SourceEntity
    Debug.Print TypeName(anObj), anObj.Name 'IRun2 LinkTestLinked_Run
    Set anObj = b2Run.TargetEntity
    Debug.Print TypeName(anObj), anObj.Summary 'IBug Associated to LinkTestLinked_Run
'Cast Bug3 to Ilinkable and get bug link factory
    errmsg = "Error linking Bug3"
    Set stepL = runStep2
    Set BugLinkF = stepL.BugLinkFactory
'Create a link between Bug3 and the run step
    Set b2Step = BugLinkF.AddItem(bug3)
    b2Step.LinkType = "Related"
    b2Step.Post
'Show the link definition
    Set anObj = b2Step.LinkedByEntity
    Debug.Print TypeName(anObj), anObj.Name 'IStep2 LinkTestStep_1
    Set anObj = b2Step.SourceEntity
    Debug.Print TypeName(anObj), anObj.Name 'IStep2 LinkTestStep_1
    Set anObj = b2Step.TargetEntity
    Debug.Print TypeName(anObj), anObj.Summary 'IBug Associated to Run Step LinkTest:LinkTestStep_1
'Show the link definition from the bug side.
'Note that source and target are reversed.
    Dim bugL As ILinkable, lList As list, aLink As Link
    Dim bugLF As LinkFactory
    Set bugL = bug3
    Debug.Print
    Set bugLF = bugL.LinkFactory
    Set lList = bugLF.NewList("")
    For Each aLink In lList
        Set anObj = aLink.LinkedByEntity
        Debug.Print TypeName(anObj), anObj.Name ' IStep2 LinkTestStep_1
        Set anObj = aLink.SourceEntity
        Debug.Print TypeName(anObj), anObj.Summary ' IBug Associated to Run Step LinkTest:LinkTestStep_1
        Set anObj = aLink.TargetEntity
        Debug.Print TypeName(anObj), anObj.Name 'IStep2 LinkTestStep_1
    Next aLink
Exit Sub
LinkDefectsToEntitiesErr:
ErrHandler err, "LinkDefectsToEntities", err.Description & vbCrLf & errmsg
'Resume Next
End Sub


%%ItemTitle%%

OTA COM Type Library

Get the bug description

Source code

Sub FindSimilarBugs()
'This routine outputs the number of matches and the
'similarity ratios of the first and last match.
'If you run the example, you'll see that the number of
'matches drops as the similarity ratio goes up.
'
    Dim BugFact As BugFactory
    Dim theBug As Bug
    Dim BugList As list
    Dim FactList As FactoryList
    Dim SimRatio As Integer, cnt%
    Dim DescField As TDField, Description$
    Dim FirstLoop As Boolean
    On Error GoTo FindSimilarBugsErr
' Get the bug factory and output the number of defects.
    'tdc is the global TDConnection object.
    Set BugFact = tdc.BugFactory
    Set BugList = BugFact.NewList("")
    cnt = BugList.Count
    Debug.Print "Total number of defects = " & cnt
' Get a bug object (not important which for this demo)
    Set theBug = BugFact.Item(1)
' Here's what we'll be looking for, Summary and Descriptions similar to these:
    Debug.Print "The Summary: " & vbCrLf & theBug.Summary
'-----------------------------------------
'Use Bug.Field to
'get the Description from the database field
    Description = theBug.Field("BG_DESCRIPTION")
    Debug.Print "The Description: " & vbCrLf & Description & vbCrLf
' Note that at the low ratios it might be hard to see why the defects match.
' At the higher ratios it is clearer.
    FirstLoop = True
    For SimRatio = 10 To 100 Step 20
'-----------------------------------------
'Use Bug.FindSimilarBugs
        Set FactList = theBug.FindSimilarBugs(SimRatio)
        Debug.Print "-----------------------------------------" & vbCrLf
        cnt = FactList.Count
        Debug.Print "Number of matches found for ratio of " & SimRatio & " = " & cnt
        If cnt = 0 Then Exit For
'-----------------------------------------
'Use FactoryList.Ratio and FactoryList.Item
        Debug.Print "------------"
        Debug.Print "First match ID: " & FactList.Item(1).ID
        Debug.Print "Ratio of first match = " & FactList.Ratio(1)
        Debug.Print "Summary:" & vbCrLf & FactList.Item(1).Summary
        Debug.Print "Description" & vbCrLf & FactList.Item(1).Field("BG_DESCRIPTION")
        Debug.Print "------------"
        Debug.Print "Last match ID: " & FactList.Item(cnt).ID
         'The last will always be the same item. Output text once.
        If FirstLoop Then
            Debug.Print "Ratio of last match = " & FactList.Ratio(cnt)
            Debug.Print "Summary:" & vbCrLf & FactList.Item(cnt).Summary
            Debug.Print "Description" & vbCrLf & FactList.Item(cnt).Field("BG_DESCRIPTION")
            FirstLoop = False
        End If
    Next SimRatio
Exit Sub
FindSimilarBugsErr:
    MsgBox err.Description
    Resume Next
End Sub


%%ItemTitle%%

OTA COM Type Library

Matches go down as similarity ratio goes up

Source code

Sub FindSimilarBugs()
'This routine outputs the number of matches and the
'similarity ratios of the first and last match.
'If you run the example, you'll see that the number of
'matches drops as the similarity ratio goes up.
'
    Dim BugFact As BugFactory
    Dim theBug As Bug
    Dim BugList As list
    Dim FactList As FactoryList
    Dim SimRatio As Integer, cnt%
    Dim DescField As TDField, Description$
    Dim FirstLoop As Boolean
    On Error GoTo FindSimilarBugsErr
' Get the bug factory and output the number of defects.
    'tdc is the global TDConnection object.
    Set BugFact = tdc.BugFactory
    Set BugList = BugFact.NewList("")
    cnt = BugList.Count
    Debug.Print "Total number of defects = " & cnt
' Get a bug object (not important which for this demo)
    Set theBug = BugFact.Item(1)
' Here's what we'll be looking for, Summary and Descriptions similar to these:
    Debug.Print "The Summary: " & vbCrLf & theBug.Summary
'-----------------------------------------
'Use Bug.Field to
'get the Description from the database field
    Description = theBug.Field("BG_DESCRIPTION")
    Debug.Print "The Description: " & vbCrLf & Description & vbCrLf
' Note that at the low ratios it might be hard to see why the defects match.
' At the higher ratios it is clearer.
    FirstLoop = True
    For SimRatio = 10 To 100 Step 20
'-----------------------------------------
'Use Bug.FindSimilarBugs
        Set FactList = theBug.FindSimilarBugs(SimRatio)
        Debug.Print "-----------------------------------------" & vbCrLf
        cnt = FactList.Count
        Debug.Print "Number of matches found for ratio of " & SimRatio & " = " & cnt
        If cnt = 0 Then Exit For
'-----------------------------------------
'Use FactoryList.Ratio and FactoryList.Item
        Debug.Print "------------"
        Debug.Print "First match ID: " & FactList.Item(1).ID
        Debug.Print "Ratio of first match = " & FactList.Ratio(1)
        Debug.Print "Summary:" & vbCrLf & FactList.Item(1).Summary
        Debug.Print "Description" & vbCrLf & FactList.Item(1).Field("BG_DESCRIPTION")
        Debug.Print "------------"
        Debug.Print "Last match ID: " & FactList.Item(cnt).ID
         'The last will always be the same item. Output text once.
        If FirstLoop Then
            Debug.Print "Ratio of last match = " & FactList.Ratio(cnt)
            Debug.Print "Summary:" & vbCrLf & FactList.Item(cnt).Summary
            Debug.Print "Description" & vbCrLf & FactList.Item(cnt).Field("BG_DESCRIPTION")
            FirstLoop = False
        End If
    Next SimRatio
Exit Sub
FindSimilarBugsErr:
    MsgBox err.Description
    Resume Next
End Sub


%%ItemTitle%%

OTA COM Type Library

Getting the requirements associated with a Bug

Source code

Sub BugReqLink(aBug As Bug)
    Dim BugF As BugFactory, reqF As reqFactory
    Dim BugFilter As TDFilter, ReqFilter As TDFilter
    Dim aReq As Req, reqL As list
    Dim thisBug As Bug, bugL As list
'This example outputs all the requirements linked to the Bug
' passed as an input argument
'Set up the cross filter that specifies only this bug.
    'tdc is the global TDConnection object.
    Set BugF = tdc.BugFactory
    Set BugFilter = BugF.Filter
    BugFilter.Filter("BG_BUG_ID") = aBug.ID
    Set bugL = BugFilter.NewList
    For Each thisBug In bugL
        Debug.Print thisBug.ID, thisBug.Summary
    Next thisBug
'Set up the primary filter to get requirements.
' There is no Filter property set, so all requirements are returned.
    Set reqF = tdc.reqFactory
    Set ReqFilter = reqF.Filter
'Add the cross filter. The filter now means "Return
' all requirements associated with the bugs specifed
' by the cross filter, in this case, a single Bug.
    ReqFilter.SetXFilter "REQ-BUG", True, BugFilter.Text
    Set reqL = reqF.NewList(ReqFilter.Text)
'Check the results
    For Each aReq In reqL
        Debug.Print aReq.Name
    Next aReq
End Sub


%%PageItemTitle%% $$Members$$

Bug Object

IAlertable2 Implemented Interface Members

See Also

Bug Object


%%PageItemTitle%% $$Members$$

Bug Object

IBaseField2 Implemented Interface Members

See Also

Bug Object


%%PageItemTitle%% $$Members$$

Bug Object

IFollowUpManager Implemented Interface Members

See Also

Bug Object


%%PageItemTitle%% $$Members$$

Bug Object

ILinkable Implemented Interface Members

See Also

Bug Object


%%ItemTitle%%

OTA COM Type Library

Mailing a bug

Source code

Sub MailADefect(MailTo As String, MailCC As String, _
            MailSubject As String, MailComment As String)
    Dim BugFact As BugFactory
    Dim theBug As Bug
    Dim BugList As list
On Error GoTo MailBugErr
    'tdc is the global TDConnection object.
    Set BugFact = tdc.BugFactory
    Set BugList = BugFact.NewList("")
    Debug.Print BugList.Count
    Set theBug = BugFact.Item(1)
    theBug.Mail MailTo, MailCC, TDMAIL_TEXT, MailSubject, MailComment
Exit Sub
MailBugErr:
ErrHandler err, "MailBug"
End Sub


%%ItemTitle%%

OTA COM Type Library

Modify a link between defects

Source code

Private Sub ModifyBugToBugLink()
    Dim linkF As LinkFactory
    Dim link As link
    Dim ilink As ILinkable
    Dim bugF As bugFactory
    Dim Bug As Bug
    Dim aFilter As TDFilter
    Dim list As list
    Dim bug1 As Bug
    Set bugF = tdc.bugFactory
    Set bug1 = bugF.Item(3)
    Set ilink = bug1
    Set linkF = ilink.BugLinkFactory
    Set aFilter = linkF.filter
    aFilter.filter("LN_ENTITY_ID") = 4
    aFilter.filter("LN_ENTITY_TYPE") = "BUG"
    Set list = linkF.NewList(aFilter.Text)
    Set link = list.Item(1)
    link.Comment = "comment_123"
    link.Post
    ' Disconnect tdc
End Sub


%%ItemTitle%%

OTA COM Type Library

Removing a link between defects

Source code

Private Sub RemoveBugToBugLink()
    Dim linkF As LinkFactory
    Dim link As link
    Dim ilink As ILinkable
    Dim bugF As BugFactory
    Dim Bug As Bug
    Dim aFilter As TDFilter
    Dim list As list
    Set bugF = tdc.BugFactory
    Set Bug = bugF.Item(6)
    Set ilink = Bug
    Set linkF = ilink.BugLinkFactory
    Set aFilter = linkF.filter
    aFilter.filter("LN_BUG_ID") = 12
    Set list = linkF.NewList(aFilter.Text)
    Set link = list.Item(1)
    linkF.RemoveItem (link.ID)
End Sub


%%PageItemTitle%% $$Members$$

BusinessProcess Overview

BusinessProcess Object Members

Public Methods

Public Method AddBPComponent | Adds the specified Component to the test.
Public Method AddGroup | Adds an empty group of components to the test.
Public Method AddRTParam | Adds a runtime parameter to the test.
Public Method CancelDownloadPictures | Cancels the download of the test component's pictures.
Public Method CoverRequirement | Adds the specified requirement to the list of requirements covered by this test.
Public Method DeleteBPComponent | Delete the specified BPComponent from the test.
Public Method DeleteGroup | Delete the specified BPGroup from the test.
Public Method DeleteRTParam | Delete the given RTParam from the test.
Public Method DownloadPictures | Download the snapshots attached to the components of the test to the clients cache.
Public Method DownloadPicturesProgress | Reports the status of DownloadPictures.
Public Method GetCoverList | Gets the list of all requirements covered by this test.
Public Method Load | Loads the BusinessProcess object and all of its dependencies into memory.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Mail | Mails the IBaseFieldExMail field item.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method RemoveCoverage | Removes a requirement from the list of requirements this test covers.
Public Method Save | Saves the BusinessProcess object and all of its dependencies.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property BPComponentByID | Gets a BPComponent from the test by its ID.
Public Property BPComponents | The list of BPComponents that belong to the test.
Public Property BPTHistory | The test's history object.
Public Property CheckoutPathIfExist | The checkout path for the test.
Public Property DesignStepFactory | The design steps factory for the current test.
Public Property DesStepsNum | The number of design steps in the test.
Public Property ExecDate | The test execution date and time.
Public Property ExecStatus | The test execution status.
Public Property ExtendedStorage | The Extended Storage object for the current test.
Public Property Field | The value of the specified field.
Public Property FullPath | The full file system path for the test.
Public Property GroupByID | Gets a BPGroup from the test by its ID.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property HasCoverage | Checks if the test covers at least one requirement.
Public Property HasParam | Checks if the test has at least one parameter.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property LastRun | The last Run object for this test.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The test name.
Public Property Params | The current test parameters.
Public Property RTParameters | The list of run time parameters for the test.
Public Property TemplateTest | Indicates if this test is a template test.
Public Property Type | The test type.
Public Property VCS | The VCS version control object for this test.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

BusinessProcess Overview


%%ItemTitle%%

OTA COM Type Library

Add component to test

Source code

Public Sub AddComponentToTest()
'Add component to test
    Dim testF As TDAPIOLELib.testFactory
    Dim BPTest1 As TDAPIOLELib.Test, tst As TDAPIOLELib.Test
    Dim tList As list
    Set testF = tdc.testFactory
    Set tList = testF.NewList("")
    'Get any Business Process test
    For Each tst In tList
        Debug.Print tst.Type
        If tst.Type = "BUSINESS-PROCESS" Then
           Set BPTest1 = tst
           Exit For
        End If
    Next tst
    If BPTest1 Is Nothing Then
        MsgBox "No business process tests in project"
        Exit Sub
    End If
    Dim compF As ComponentFactory
    Dim comp As Component
    Set compF = tdc.ComponentFactory
    Set comp = compF.Item(1)
    Dim BPT As BusinessProcess
    Set BPT = BPTest1
    BPT.AddBPComponent comp
End Sub


%%ItemTitle%%

OTA COM Type Library

Casting an object reference to get a reference to an inner interface

Source code

Sub GetAdditionalInterface()
'This example shows how to access the members of
' additional implemented interfaces from the implementing object.
'This example uses the Bug object and the IFollowUpManager interface,
' but the technique applies to all objects that implement
' additional interfaces.
    Dim aFollowUp As IFollowUpManager
    Dim aBug As Bug
    Dim aList As list
'Get a bug object at random
    'tdc is the global TDConnection object.
    Set aList = tdc.BugFactory.NewList("")
    Set aBug = aList(0)
'Cast the Bug object to the type of
' the implemented interface, in this
' case, IFollowUpManager.
    Set aFollowUp = aBug
'Call a method of the implemented interface
    Debug.Print aFollowUp.HasFollowUp
End Sub


%%ItemTitle%%

OTA COM Type Library

Creating an empty Business Process Test

Source code

Private Function BuildTestsTree() As Test
    Dim TestF As TestFactory
    Dim NewTest As Test
    Dim root As SubjectNode, folder As SubjectNode
    Dim TreeMgr As TreeManager
' This example creates a subject folder, which is a test folder
' in the test plan module,and places a new test of type
' Business Process Test in the folder.
' tdc is a TDConnection object. When this routine is run, the
' user is already authenticated and connected to the project.
    Set TreeMgr = tdc.TreeManager
' Create a test plan subject folder,
    Set root = TreeMgr.TreeRoot("Subject")
    Set folder = root.AddNode("myTestFolder2")
' Get a test factory from the new folder.
    Set TestF = folder.TestFactory
' Create the test,
    Set NewTest = TestF.AddItem(Null)
    NewTest.Name = "myBPTest1"
    NewTest.Type = "BUSINESS-PROCESS"
'Put the test in the new subject folder.
' Note that because since we got the TestFactory from the
' folder, we don't need to set the TS_SUBJECT field.
' Had we created the factory object from the TDConnection:
' Set TestF = tdc.TestFactory
' we would have to place the test in the folder:
' NewTest.Field("TS_SUBJECT") = folder.NodeID
' Save the test.
    NewTest.Post
' Note that the object returned is of class Test,
' not of class BusinessProcess, even though the
' Type property is BUSINESS-PROCESS.
' To use methods and properties of BusinessProcess,
' the calling routine must cast the returned object
' to BusinessProcess.
    Set BuildTestsTree = NewTest
End Function


%%PageItemTitle%% $$Members$$

BusinessProcess Object

IBaseField2 Implemented Interface Members

See Also

BusinessProcess Object


%%PageItemTitle%% $$Members$$

BusinessProcess Object

IBaseField3 Implemented Interface Members

See Also

BusinessProcess Object


%%PageItemTitle%% $$Members$$

Command Overview

Command Object Members

Public Methods

Public Method AddParam | Adds new parameter to Command object.
Public Method Cancel | Cancels execution of the ExecuteQuery command.
Public Method DeleteParam | Deletes the specified parameter from Command object.
Public Method DeleteParams | Deletes all parameters from Command object.
Public Method Execute | Executes the command in the CommandText property.

Public Properties

Public Property AffectedRows | The number of table rows that were affected by the command.
Public Property CommandText | The text of the command.
Public Property Count | Number of parameters in current command.
Public Property IndexFields | A comma-separated list of index fields for a SELECT command.
Public Property ParamIndex | The parameter index by parameter name.
Public Property ParamName | The parameter name by parameter index. The index is 0-based.
Public Property ParamType | The data type of the specified parameter. The index is 0-based.
Public Property ParamValue | The parameter value.

See Also

Command Overview


%%ItemTitle%%

OTA COM Type Library

Example of recordset properties and methods

Source code

Public Sub RecordSetExample()
    Dim com As Command
    Dim RecSet As Recordset, CloneSet As Recordset
    Dim i As Integer, RecCnt%, ColCnt%
    Dim OriginalSummary As String, CloneSummary$
    Dim TypeCode As Integer, TypeString As String
    On Error GoTo RecordSetExampleErr
' Set and execute the SQL statement to select defects
' that have tests associated with them and sort them
' by the defects’ summaries.
    'tdc is the global TDConnection object.
    Set com = tdc.Command
    com.CommandText = _
        "select bg_summary, ts_name, ts_exec_status, bg_responsible " _
       + "from bug, test where bg_test_reference = ts_test_id and " _
       + "bg_responsible IS NOT Null" _
       + " order by bg_summary"
'Execute the query and get the recordset
    Set RecSet = com.Execute
    ColCnt = RecSet.ColCount
    RecCnt = RecSet.RecordCount
    Debug.Print "Record Count = " & RecCnt _
        & ", Column Count = " _
        & ColCnt
'Got to the first record
    RecSet.First
    Debug.Print "Position is " & RecSet.Position ' Reports 0
'Save the summary field of the first record
    OriginalSummary = RecSet.FieldValue("BG_SUMMARY")
'Make a copy of the recordset
    Set CloneSet = RecSet.Clone
    CloneSet.First
    CloneSummary = CloneSet.FieldValue("BG_SUMMARY")
'Are they the same?
    Debug.Print "Are they the same ? " _
        & CStr(CloneSummary = OriginalSummary)
    Debug.Print CloneSummary
'Destroy the clone
    Set CloneSet = Nothing
'Go to the next in the original
    RecSet.Next
    Debug.Print "Before Recordset? " & RecSet.BOR 'Reports False
    Debug.Print "Record number is " & RecSet.Position ' Reports 1
'Describe the columns
    For i = 0 To ColCnt - 1
        TypeCode = RecSet.ColType(i)
        'For code of DataTypeString,
        ' see example 'Convert data types to string'
        TypeString = DataTypeString(TypeCode)
        Debug.Print "Column name " & RecSet.ColName(i) _
            & ", Type: " & TypeString & ", Size: " _
            & RecSet.ColSize(i)
    Next i
'Output the column names and values
    For i = 0 To ColCnt - 1
        Debug.Print "Column name and value: " _
            & RecSet.ColName(i) & ", " & RecSet.FieldValue(i)
    Next i
'Output the column index by name
    Debug.Print "The index of the summary column is " _
        & RecSet.ColIndex("BG_SUMMARY")
    Debug.Print "The index of the responsible column is " _
        & RecSet.ColIndex("BG_RESPONSIBLE")
'Go to the last record and output the column names and values
    RecSet.Last
    Debug.Print "Are we past the record set? " _
        & RecSet.EOR 'Reports False
    Debug.Print "Record number is " _
        & RecSet.Position ' Reports RecordCount - 1
    For i = 0 To ColCnt - 1
        Debug.Print "Column name and value: " _
            & RecSet.ColName(i) & ", " & RecSet.FieldValue(i)
    Next i
'Try to go past the last record
    RecSet.Next
    Debug.Print "Are we past the record set? " _
        & RecSet.EOR 'Reports True
    Debug.Print "Record number is " _
        & RecSet.Position ' Reports RecordCount exactly
    Debug.Print "The number of records is " & RecCnt
    On Error GoTo BadLoop
'This loop fails, as expected, since EOR is true
    For i = 0 To ColCnt - 1
        Debug.Print RecSet.ColName(i) & ", " & RecSet.FieldValue(i)
    Next i
BadLoop:
On Error GoTo RecordSetExampleErr
Debug.Print err.Description
'Now step back to the last record
    RecSet.Prev
    Debug.Print "Are we past the record set? " _
        & RecSet.EOR 'Reports True
    Debug.Print "Record number is " _
        & RecSet.Position ' Reports RecordCount - 1
'Go to the last record directly
    RecSet.Last
    Debug.Print "Are we past the record set? " _
        & RecSet.EOR 'Reports True
    Debug.Print "Record number is " _
        & RecSet.Position ' Reports RecordCount - 1
Exit Sub
RecordSetExampleErr:
    ErrorHandler err
End Sub


%%PageItemTitle%% $$Members$$

Component Overview

Component Object Members

Public Methods

Public Method BusinessProcesses | The list of associated BusinessProcess objects.
Public Method DeletePicture | Deletes the snapshot.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property ApplicationAreaID | The Component's linked application area ID.
Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property ComponentParamFactory | The component parameter factory.
Public Property ComponentStepFactory | The ComponentStepFactory for this component
Public Property ExtendedStorage | The ExtendedStorage object for this component.
Public Property Field | The value of the specified field.
Public Property Folder | The component's folder.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property HasPicture | Indicates if the component has a snapshot.
Public Property HasScript | Checks if the component is associated with a test script.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property IsObsolete | Checks if the component has been marked deleted by a user but is still in use in a test.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The Component's name.
Public Property ScriptType | The test script type.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

Component Overview


%%PageItemTitle%% $$Members$$

ComponentFactory Overview

ComponentFactory Object Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method IsComponentNameValid | Checks if the specified name is a valid name for a business component.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

ComponentFactory Overview


%%ItemTitle%%

OTA COM Type Library

Creating a new component

Source code

Private Function NewComponent(compName As String, _
        ParentFolder As ComponentFolder) _
    As Component
    Dim myComp As Component
    Dim compFactory As ComponentFactory
    On Error GoTo NewComponentErr
    ' Get a ComponentFactory
    Set compFactory = ParentFolder.ComponentFactory
    ' Add the component
    Set myComp = compFactory.AddItem(Null)
    Dim errString As String
    If (compFactory.IsComponentNameValid(compName, errString)) Then
        myComp.Name = compName
    Else
        myComp.Name = "DefaultValidName"
        MsgBox errString
    End If
    myComp.Post
    'Return the new component.
    Set NewComponent = myComp
Exit Function
NewComponentErr:
    MsgBox Err.Description
End Function


%%PageItemTitle%% $$Members$$

ComponentFactory Object

IBaseFactory2 Implemented Interface Members

See Also

ComponentFactory Object


%%PageItemTitle%% $$Members$$

ComponentFactory Object

IBaseFactory Implemented Interface Members

See Also

ComponentFactory Object


%%PageItemTitle%% $$Members$$

ComponentFactory Object

ISearchableFactory Implemented Interface Members

See Also

ComponentFactory Object


%%PageItemTitle%% $$Members$$

ComponentFactory Object

ISupportCopyPaste2 Implemented Interface Members

See Also

ComponentFactory Object


%%PageItemTitle%% $$Members$$

ComponentFolder Overview

ComponentFolder Object Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property ComponentFactory | The ComponentFactory object.
Public Property ComponentFolderFactory | The component's ComponentFolderFactory.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The component's folder name
Public Property Path | The component folder's path
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

ComponentFolder Overview


%%PageItemTitle%% $$Members$$

ComponentFolderFactory Overview

ComponentFolderFactory Object Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method FolderByPath | Gets a ComponentFolder by its path
Public Method FolderPath | Gets the path of the specified folder.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method Obsolete | Gets the Obsolete Components folder.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.
Public Method Root | Gets the business components root folder.
Public Method Templates | Gets the Templates folder (Quick Test only).

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

ComponentFolderFactory Overview


%%ItemTitle%%

OTA COM Type Library

Finding a component folder by name and creating a new subfolder

Source code

Private Function NewComponentsFolder(folderName As String, _
        Optional ParentFolder) _
        As ComponentFolder
    Dim generalComponentFolderFactory As ComponentFolderFactory
    Dim rootComponentFolderFactory As ComponentFolderFactory
    Dim cFolder As ComponentFolder, rootCFolder As ComponentFolder
' This example creates a new folder at the specified location.
' If no parent path is supplied, the folder is created at the highest level
' under the root.
    ' Get a ComponentFolderFactory from the TDConnection object
    Set generalComponentFolderFactory = tdc.ComponentFolderFactory
    ' Get the parent folder, either the root or the folder passed as
    ' the ParentFolder argument.
    If IsMissing(ParentFolder) Then
        ' Get the root folder
        Set rootCFolder = generalComponentFolderFactory.root
    Else
        'Example of path: "Components\myCompFolder"
        Set rootCFolder = generalComponentFolderFactory.FolderByPath(ParentFolder)
    End If
    ' Get a folders factory
    Set rootComponentFolderFactory = rootCFolder.ComponentFolderFactory
    ' Add the new folder
    Set cFolder = rootComponentFolderFactory.AddItem(Null)
    cFolder.Name = folderName
    ' Post to Server
    cFolder.Post
    ' Return the new folder
    Set NewComponentsFolder = cFolder
End Function


%%PageItemTitle%% $$Members$$

ComponentFolderFactory Object

IBaseFactory2 Implemented Interface Members

See Also

ComponentFolderFactory Object


%%PageItemTitle%% $$Members$$

ComponentFolderFactory Object

IBaseFactory Implemented Interface Members

See Also

ComponentFolderFactory Object


%%PageItemTitle%% $$Members$$

ComponentFolderFactory Object

ISupportCopyPaste2 Implemented Interface Members

See Also

ComponentFolderFactory Object


%%PageItemTitle%% $$Members$$

ComponentFolder Object

IBaseField2 Implemented Interface Members

See Also

ComponentFolder Object


%%PageItemTitle%% $$Members$$

ComponentFolder Object

IBaseField Implemented Interface Members

See Also

ComponentFolder Object


%%PageItemTitle%% $$Members$$

ComponentParam Overview

ComponentParam Object Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Component | The Component containing the parameter.
Public Property Desc | The parameter description.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property IsOut | Indicates if this is an output parameter. If False, this is an input parameter.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The component parameter's name.
Public Property Order | The position of the parameter in the set of parameters of the same component.
Public Property Value | The parameter's default value.
Public Property ValueType | The parameter type. For example Date, String, number, etc.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

ComponentParam Overview


%%PageItemTitle%% $$Members$$

ComponentParamFactory Overview

ComponentParamFactory Object Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

ComponentParamFactory Overview


%%ItemTitle%%

OTA COM Type Library

Adding a parameter and step to a component

Source code

Private Sub AddParamAndStep(ByRef myComponent)
    Dim compParamFactory As ComponentParamFactory
    Dim compParam1 As ComponentParam
    Dim compStepFactory As ComponentStepFactory
    Dim compStep1 As ComponentStep
' This example adds a parameter and step to the Component.
    Set compParamFactory = myComponent.ComponentParamFactory
    Set compStepFactory = myComponent.ComponentStepFactory
' Create a parameter and set the properties.
    Set compParam1 = compParamFactory.AddItem(Null)
    ' Output parameter. For ComponentParam.IsOut, 1 true and 0 is false
    compParam1.IsOut = 1
    compParam1.Name = "OutParam"
    compParam1.Desc = "Description for output parameter"
    compParam1.ValueType = "String"
    compParam1.Order = 1
    compParam1.Post
' Create a step
    Set compStep1 = compStepFactory.AddItem(Null)
    compStep1.StepName = "First Step"
' Add description and expected results that contain parameters.
    Dim pString As String
    'Input parameter. For this example, assume that InParam was previously created.
    ' pString ="Description can contain <<<InParam>>> that are verified by QC"
    pString = "<html><body>Description can contain " _
        & "<<<InParam>>>" _
        & "that are verified by QC</body></html>"
    compStep1.StepDescription = pString
    'Output parameter. OutParam was previously created. badParamName was not.
    ' pString ="Can also contain <<<OutParam>>> and <<<badParamName>>>"
    'Given that badParamName is not the name of any parameter,
    ' <<<badParamName>>> will be replaced by <badParamName>, so that
    ' the user can see in the user interface that it is not recognized.
    pString = "<html><body>Can also contain " _
        & "<<<OutParam>>>" _
        & "and <<<badParamName>>>" _
        & " </body></html>"
    compStep1.StepExpectedResult = pString
'Set the execution order
    compStep1.Order = 1
'Finish the step
    'Validate will throw an exception because of the badParamName.
    ' In real production code, you may wish to catch the exception
    ' and take action rather than continuing as this example does.
    'On Error GoTo myInvalidStepHandler
    On Error Resume Next
    compStep1.Validate
    compStep1.Post
    ' Save changes and unlock the component.
    myComponent.Post
End Sub


%%PageItemTitle%% $$Members$$

ComponentParamFactory Object

IBaseFactory2 Implemented Interface Members

See Also

ComponentParamFactory Object


%%PageItemTitle%% $$Members$$

ComponentParamFactory Object

ISupportCopyPaste2 Implemented Interface Members

See Also

ComponentParamFactory Object


%%PageItemTitle%% $$Members$$

ComponentParam Object

IBaseField2 Implemented Interface Members

See Also

ComponentParam Object


%%PageItemTitle%% $$Members$$

ComponentParam Object

IBaseField Implemented Interface Members

See Also

ComponentParam Object


%%PageItemTitle%% $$Members$$

ComponentParam Object

IBaseFieldEx Implemented Interface Members

See Also

ComponentParam Object


%%PageItemTitle%% $$Members$$

ComponentStep Overview

ComponentStep Object Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.
Public Method Validate | Validate the step.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Order | The 1-based position of the step in the order of execution of the steps of the component.
Public Property Parent | The parent Component
Public Property StepDescription | The description of the step.
Public Property StepExpectedResult | The expected result of the step.
Public Property StepName | The component step name.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

ComponentStep Overview


%%PageItemTitle%% $$Members$$

ComponentStepFactory Overview

ComponentStepFactory Object Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

ComponentStepFactory Overview


%%PageItemTitle%% $$Members$$

ComponentStepFactory Object

IBaseFactory2 Implemented Interface Members

See Also

ComponentStepFactory Object


%%PageItemTitle%% $$Members$$

ComponentStepFactory Object

IBaseFactory Implemented Interface Members

See Also

ComponentStepFactory Object


%%PageItemTitle%% $$Members$$

ComponentStepFactory Object

ISupportCopyPaste2 Implemented Interface Members

See Also

ComponentStepFactory Object


%%PageItemTitle%% $$Members$$

ComponentStep Object

IBaseField2 Implemented Interface Members

See Also

ComponentStep Object


%%PageItemTitle%% $$Members$$

ComponentStep Object

IBaseField Implemented Interface Members

See Also

ComponentStep Object


%%PageItemTitle%% $$Members$$

Component Object

IBaseField2 Implemented Interface Members

See Also

Component Object


%%PageItemTitle%% $$Members$$

Component Object

IBaseField Implemented Interface Members

See Also

Component Object


%%PageItemTitle%% $$Members$$

Condition Overview

Condition Object Members

Public Properties

Public Property Description | The Condition description.
Public Property ID | The Condition ID.
Public Property Source | For a run condition, the source condition ID. For a time condition, a date-time string.
Public Property Target | The target test instance number of the condition.
Public Property Value | The Condition status value.

See Also

Condition Overview


%%PageItemTitle%% $$Members$$

ConditionFactory Overview

ConditionFactory Object Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.
Public Method Save | Saves all conditions.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

ConditionFactory Overview


%%PageItemTitle%% $$Members$$

ConditionFactory Object

IBaseFactory2 Implemented Interface Members

See Also

ConditionFactory Object


%%PageItemTitle%% $$Members$$

ConditionFactory Object

ISupportCopyPaste2 Implemented Interface Members

See Also

ConditionFactory Object


%%PageItemTitle%% $$Members$$

Condition Object

IBaseField2 Implemented Interface Members

See Also

Condition Object


%%PageItemTitle%% $$Members$$

CoverageEntity Overview

CoverageEntity Object Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property CoverageType | The type of coverage. For example, Test or TSTest.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The name of the TargetEntity.
Public Property RequirementEntity | The Req object being covered.
Public Property Status | The execution result status of the TargetEntity.
Public Property TargetEntity | The entity object that covers the requirement.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

CoverageEntity Overview


%%PageItemTitle%% $$Members$$

CoverageEntity Object

IBaseField2 Implemented Interface Members

See Also

CoverageEntity Object


%%PageItemTitle%% $$Members$$

CoverageEntity Object

IBaseField3 Implemented Interface Members

See Also

CoverageEntity Object


%%PageItemTitle%% $$Members$$

CoverageFactory Overview

CoverageFactory Object Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

CoverageFactory Overview


%%PageItemTitle%% $$Members$$

CoverageFactory Object

IBaseFactory2 Implemented Interface Members

See Also

CoverageFactory Object


%%PageItemTitle%% $$Members$$

Customization Overview

Customization Object Members

Public Methods

Public Method Commit | Posts all customization data changes to the project database.
Public Method Load | Loads all customization data from the server into the client cache. This includes actions, fields, lists, modules, permissions, users, and user groups.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Rollback | Discards unsaved changes to properties and child objects.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Actions | The CustomizationActions object.
Public Property CustomizableEntitiesTables | Returns the list of the customizable entities' table names.
Public Property EntityDataTables | Returns the names of the data tables that have a user label defined as comma-separated pairs of table names and user labels.
Public Property ExtendedUDFSupport | Checks if the program can use the maximum allowable user-defined fields (99 user-defined fields and 3 memo fields).
Public Property Fields | The CustomizationFields object.
Public Property IsChanged | Checks if there has been at least one change to a property or child object that has not been saved.
Public Property IsLocked | Checks if object is locked.
Public Property Lists | The CustomizationLists object.
Public Property MailConditions | The CustomizationMailConditions Object.
Public Property Modules | The CustomizationModules object.
Public Property Permissions | The CustomizationPermissions object.
Public Property RBT | Returns the CustomizationRBT object.
Public Property Types | Returns the CustomizationTypes object.
Public Property Users | The CustomizationUsers object.
Public Property UsersGroups | The CustomizationUsersGroups object.

See Also

Customization Overview


%%PageItemTitle%% $$Members$$

CustomizationAction Overview

CustomizationAction Object Members

Public Methods

Public Method AddGroup | Adds a user group to the list of user groups for which the current action is allowed.
Public Method RemoveGroup | Removes the specified user group from the list of groups for which the current action is allowed.

Public Properties

Public Property Groups | A list of the user groups for which the current action is allowed.
Public Property IsGroupPermited | Checks if the group specified by the Group parameter has permission to perform the current action.
Public Property IsOwnerGroup | Checks if the user group specified by the Group parameter is the owner of the current action.
Public Property IsUserPermited | Checks if the user specified by the User parameter is permitted to perform the current action.
Public Property Name | The name of the action.
Public Property OwnerGroup | The user group that owns the action.
Public Property Updated | Indicates if the object has been modified since last synchronized with server.

See Also

CustomizationAction Overview


%%PageItemTitle%% $$Members$$

CustomizationActions Overview

CustomizationActions Object Members

Public Properties

Public Property Action | The CustomizationAction object representing the action specified by Name.
Public Property Actions | The list of CustomizationAction objects.

See Also

CustomizationActions Overview


%%ItemTitle%%

OTA COM Type Library

Audit an action

Source code

Public Sub UpdateActions()
'Update actions
    Dim allActions As CustomizationActions
    Dim action As CustomizationAction
    Set CustObj = tdc.Customization
    Set allActions = CustObj.Actions
    Set action = allActions.action("ac_modify_run")
    Dim a As Boolean
    a = action.AuditAction
    MsgBox "Audit event ac_modify_run as " & Str(a)
    action.AuditAction = Not a
    a = action.AuditAction
    MsgBox "Now audit event ac_modify_run " & Str(a)
    Set action = allActions.action("ac_delete_bug")
    a = action.AuditAction
    MsgBox "Audit event ac_delete_bug " & Str(a)
    action.AuditAction = Not a
    a = action.AuditAction
    MsgBox "Now audit event ac_delete_bug " & Str(a)
    CustObj.Commit
End Sub


%%PageItemTitle%% $$Members$$

CustomizationField Overview

CustomizationField Object Members

Public Properties

Public Property AuthorizedModifyForGroups | The list of groups whose members can modify this field.
Public Property AuthorizedOwnerSensibleForGroups | The list of CustomizationUsersGroup objects of the groups for which only the owner can modify the field.
Public Property AuthorizedVisibleForGroups | The list of CustomizationUsersGroup objects of the groups for which the field is visible in customization dialogs.
Public Property AuthorizedVisibleInNewBugForGroups | The list of CustomizationUsersGroup objects of the groups for which the field is visible in the new defect dialog.
Public Property CanMakeMultiValue | Checks if the field can be configured to store multiple values. If False, IsMultiValue cannot be set to True.
Public Property CanMakeSearchable | Checks if search can be enabled for the field.
Public Property ColumnName | The column name.
Public Property ColumnType | The database column type: char, date, memo, number, or time.
Public Property DefaultValue | The default value of the field.
Public Property EditMask | The input mask for string fields.
Public Property FieldSize | The size of the field in the database. For BLOB fields, the size is -1.
Public Property GrantModifyForGroup | Indicates whether members of the group can change the value of this field.
Public Property GrantModifyMask | The bit mask that indicates which user groups can modify the field.
Public Property IsActive | Indicates if the field is active. Inactive user-defined fields are not visible in the user interface.
Public Property IsByCode | Indicates if the field stores the Tree Node ID, rather than the passed value.
Public Property IsCanGroup | Indicates if items of this type can form groups with others of the same type.
Public Property IsCustomizable | Indicates if the field is displayed in the customization user interface.
Public Property IsEdit | Indicates if the field can be edited.
Public Property IsHistory | Indicates if change history is stored for the field.
Public Property IsMail | Indicates if Users on the list to be notified of changes are notified when this field is changed.
Public Property IsMultiValue | Indicates whether the field can store more than one value.
Public Property IsRequired | Checks if the field is required.
Public Property IsSearchable | Indicates whether the content of the field is searched by the Search method.
Public Property IsTransitionLogic | Indicates if the field has transition logic.
Public Property IsVerify | Indicates if the field requires verification.
Public Property IsVirtual | Checks if the field has a physical representation in the database. If True, there is no physical representation.
Public Property IsVisibleInNewBug | Indicates if the field is visible for the specified groups in a new defect form.
Public Property List | The CustomizationList assigned to the field.
Public Property NewCreated | Indicates if the field was created but not posted to the server.
Public Property OwnerSensibleForGroup | Indicates whether the field can be modified by the owner if the owner belongs to the specified group.
Public Property OwnerSensibleMask | The bit mask that indicates for which groups this field can be modified only by its owner.
Public Property RootId | If the field contains a list, the ID of the list root node. If not, RootId is NULL.
Public Property TableName | The name of the table that stores the active field.
Public Property Type | The Field type.
Public Property Updated | Indicates if the object has been modified since the last download from the server.
Public Property UserColumnType | The user column type: char, number, date, memo, or empty string.
Public Property UserLabel | A user-defined field label.
Public Property VersionControl | Indicates if the field is under version control.
Public Property VisibleForGroup | Indicates whether the field is visible in the New Defect dialog to the specified group.
Public Property VisibleForGroups | The bit mask that indicates which user groups can see this field.
Public Property VisibleInNewBugForGroup | Indicates whether the field is visible to the specified group in the new defect dialog.

See Also

CustomizationField Overview


%%PageItemTitle%% $$Members$$

CustomizationFields Overview

CustomizationFields Object Members

Public Methods

Public Method AddActiveField | Finds the first free, inactive field in the specified table, signs the field as active, and returns the CustomizationFields object representing the field.
Public Method AddActiveMemoField | Creates a new memo field in a table.

Public Properties

Public Property Field | The customization field object for the specified database table and field.
Public Property FieldExists | Checks if the specified database field exists.
Public Property Fields | A list of all fields in the specified table.

See Also

CustomizationFields Overview


%%ItemTitle%%

OTA COM Type Library

Add a user defined field

Source code

Public Sub AddUDF()
    Dim fields As CustomizationFields
    Dim field As CustomizationField
    Dim custom As Customization
    'Get an unused field for a defect.
    Set custom = tdc.Customization
    Set fields = custom.fields
    Set field = fields.AddActiveField("BUG")
    ' The name
    field.UserLabel = "Delay Reason"
    ' To use a list of values, make the field a tree node.
    field.Type = tagTDAPI_DATATYPES.TDOLE_TREENODE
    ' Enforce using only values from the list.
    field.IsVerify = True
    ' Make it a required field.
    field.IsRequired = True
    ' Attach the field to the custom list.
    Dim lists As CustomizationLists
    Dim list As CustomizationList
    Set lists = custom.lists
    Set list = lists.list("Delay_Reasons")
    field.list = list
    field.Updated = True
    custom.Commit
End Sub


%%ItemTitle%%

OTA COM Type Library

Get lists for custom fields

Source code

Public Sub CustomLists()
    Dim cust As Customization
    Dim custFields As CustomizationFields
    Dim aCustField As CustomizationField
    Dim custLists As CustomizationLists
    Dim aCustList As CustomizationList
    Dim listName$, cnt%
'---------------------------------------------------
'Get the customization object and CustomizationFields
    'tdc is the global TDConnection object.
    Set cust = tdc.Customization
    Set custFields = cust.Fields
    '
    msg = "Active Entities for requirement table : " & Chr(13)
'Walk through the fields of the bug table and output
' the some properties of the fields that are linked
' to custom lists.
    For Each aCustField In custFields.Fields("REQ")
        If aCustField.IsActive Then
            listName = ""
        'If the field is linked to a custom list, get the name
        ' of the list and the field properties.
            If Not (aCustField.list Is Nothing) Then
                cnt = cnt + 1
'-----------------------------------------
' Get the CustomizationList from
' CustomizationField.List
                Set aCustList = aCustField.list
                listName = _
                    " [Values from " & aCustList.Name & ".]"
                msg = msg & aCustField.ColumnName _
                    & ", " & aCustField.UserLabel _
                    & listName & Chr(13)
            End If
        End If
    Next
    '
    msg = msg & vbCrLf & "Count of fields with lists = " & CStr(cnt)
    MsgBox msg
End Sub


%%ItemTitle%%

OTA COM Type Library

Make a user-defined field searchable

Source code

Public Sub MakeUDFSearchable()
'Make a user-defined field searchable
    Dim custFields As CustomizationFields
    Dim aCustField As CustomizationField
    Dim cust As Customization
    'Get the customization fields object
    Set cust = tdc.Customization
    Set custFields = cust.fields
    'Output the list of potentially searchable fields
    Dim cFs As list
    Set cFs = custFields.fields("Test")
    For Each aCustField In cFs
        If aCustField.CanMakeSearchable Then
            Debug.Print aCustField.CanMakeSearchable & vbTab & aCustField.ColumnName
            Debug.Print aCustField.IsSearchable
        End If
    Next
    'Make a user-defined field searchable
    Set aCustField = custFields.field("Test", "TS_USER_01")
    If aCustField.CanMakeSearchable Then
        aCustField.IsSearchable = True
    Else
        MsgBox "Field cannot be made searchable"
    End If
End Sub


%%ItemTitle%%

OTA COM Type Library

Using the GroupingItem Object

Source code

Sub GetGroupItems()
    Dim aField As TDField
    Dim severityF As TDField, priorityF As TDField, statusF As TDField
    Dim fieldList As list
    Dim bFact As BugFactory
    'tdc is the global TDConnection object.
    Set bFact = tdc.BugFactory
    Set fieldList = tdc.Fields("BUG")
    For Each aField In fieldList
        Select Case aField.Name
            Case "BG_SEVERITY"
                Set severityF = aField
            Case "BG_PRIORITY"
                Set priorityF = aField
            Case "BG_STATUS"
                Set statusF = aField
        End Select
    Next aField
    Debug.Print
    Debug.Print "BG_SEVERITY can group = " + CStr(severityF.Property.IsCanGroup)
    Debug.Print "BG_PRIORITY can group = " + CStr(priorityF.Property.IsCanGroup)
    Debug.Print "BG_STATUS can group = " + CStr(statusF.Property.IsCanGroup)
' BG_SEVERITY can group = True
' BG_PRIORITY can group = True
' BG_STATUS can group = True
    Dim bf As IBaseFactory2
    Set bf = tdc.BugFactory
    Dim gm As IGroupingManager
    Set gm = bf.GroupingManager
    gm.Group("BG_SEVERITY") = 1
    gm.Group("BG_PRIORITY") = 2
    gm.Group("BG_STATUS") = 3
    gm.Refresh
    Dim GroupList As list
    Set GroupList = gm.GroupList
    Dim Group As GroupingItem
    Debug.Print
' GroupList is a list of groups at the first level
' under the one in which it was created
    For Each Group In GroupList
        Debug.Print "Name: " + Group.FieldName + " Value: " + Group.FieldValue
' Name: BG_SEVERITY Value: 1-Low
' Name: BG_SEVERITY Value: 2-Medium
' Name: BG_SEVERITY Value: 3-High
' Name: BG_SEVERITY Value: 4-Very High
' Name: BG_SEVERITY Value: 5-Urgent
    Next
'
    Debug.Print
    Dim itm As Bug, cnt As Integer
' ItemList is a list of the objects
' included in the group.
    For Each itm In gm.ItemList
      With itm
      Debug.Print .ID, .Field("BG_SEVERITY"), .Field("BG_PRIORITY"), .Field("BG_STATUS")
      End With
    Next
    Set Group = GroupList.Item(1)
    Debug.Print
    Debug.Print "Name: " + Group.FieldName + " Value: " + Group.FieldValue
    'Name: BG_SEVERITY Value: 1-Low
    Dim iList As list
    Set iList = Group.GroupList
    Dim sg As GroupingItem
    Debug.Print
    For Each sg In iList
        Debug.Print "Name: " + sg.FieldName + " Value: " + sg.FieldValue
' Name: BG_PRIORITY Value: 1-Low
' Name: BG_PRIORITY Value: 2-Medium
    Next
Exit Sub
GetGroupItemsErr:
    ErrHandler err, "GetGroupItems"
End Sub


%%PageItemTitle%%

CustomizationField Object

OwnerSensibleMask Property

Description

The bit mask that indicates for which groups this field can be modified only by its owner.

Property type

Read-write property

Syntax (Visual Basic)

Public Property OwnerSensibleMask() As Long

Remarks

This is an unsafe method of setting this property, and is supported only for backward compatibility.

Use the CustomizationPermissions Object, instead.

Owner Sensibility is the property of a field that determines whether the field can be modified by its owner .
OwnerSensibleMask controls for which groups Owner Sensibility is applies. A user belonging to a group with Owner Sensibility turned on can only change the field if that user owns the entity.
The owner of a field is the owner of the entity to which the field belongs. Each entity type has it's own rule defining the entity owner. For example, by default a Bug's owner is the user whose name appears in the 'Assigned To' field.
It's possible to change the owner definition by changing TB_OWNER_FIELD_NAME for the corresponding entry in the TABLES table.

See Also

CustomizationField Object


%%PageItemTitle%%

CustomizationField Object

VisibleForGroups Property

Description

The bit mask that indicates which user groups can see this field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property VisibleForGroups() As Long

Remarks

This is an unsafe method of setting this property, and is supported only for backward compatibility.

Use the CustomizationPermissions Object, instead.

See Also

CustomizationField Object


%%PageItemTitle%% $$Members$$

CustomizationList Overview

CustomizationList Object Members

Public Methods

Public Method Find Finds a CustomizationListNode of the current list by the node name or ID.

Public Properties

Public Property Deleted | If true, the node is marked for deletion, but the deletion is not yet committed.
Public Property Name | The name of the list.
Public Property RootNode | The root CustomizationListNode of the current list.

See Also

CustomizationList Overview


%%PageItemTitle%% $$Members$$

CustomizationListNode Overview

CustomizationListNode Object Members

Public Methods

Public Method AddChild | Adds a new sub-node to the current node.
Public Method RemoveChild | Removes the specified sub-node from the current node.

Public Properties

Public Property CanAddChild | Checks if sub-nodes can be added to the current node.
Public Property Child | Gets the specified sub-node.
Public Property Children | The list of CustomizationListNode objects that are sub-nodes of the current node.
Public Property ChildrenCount | The number of sub-nodes under the node.
Public Property Deleted | If true, the node is marked for deletion, but the deletion is not yet committed.
Public Property Father | Gets the CustomizationListNode object representing the current node's parent node, or sets a new father, thereby moving the node.
Private Property ID | The current node ID.
Public Property List | The CustomizationList object that contains the current node.
Public Property Name | The current node name.
Public Property Order | The order number of the node within its siblings.
Public Property ReadOnly | Checks if the current node is read-only.
Public Property Updated | Indicates if the node was modified since it was loaded from the server.

See Also

CustomizationListNode Overview


%%ItemTitle%%

OTA COM Type Library

Add items to a custom list

Source code

Public Sub AddItemsToCustomList()
    Dim custom As Customization
    Dim lists As CustomizationLists
    Dim list As CustomizationList
    Dim Node As CustomizationListNode
    'Get the custom list "list_02"
    Set custom = tdc.Customization
    Set lists = custom.lists
    Set list = lists.list("Delay_Reasons")
    'Get the tree node that represents list_02
    Set Node = list.RootNode
    'Add child nodes. They are the values of the list.
    Node.AddChild "TBD"
    Node.AddChild "Not Relevant"
    Node.AddChild "Out of Scope"
    custom.Commit
End Sub


%%PageItemTitle%% $$Members$$

CustomizationLists Overview | CustomizationList Object

CustomizationLists Object Members

Public Methods

Public Method AddList | Adds a new CustomizationList object.
Public Method RemoveList | Removes a CustomizationList object.

Public Properties

Public Property Count | The number of lists in the CustomizationLists object.
Public Property IsListExist | Checks if the specified customization list exists.
Public Property List | Gets the CustomizationList specified by name or ID.
Public Property ListByCount | Gets the CustomizationList specified by its index number.

See Also

CustomizationLists Overview | CustomizationList Object


%%ItemTitle%%

OTA COM Type Library

Add a customization list

Source code

Public Sub AddList()
    Dim custom As Customization
    Set custom = tdc.Customization
    Dim lists As CustomizationLists
    Set lists = custom.lists
    lists.AddList ("Delay_Reasons")
    custom.Commit
End Sub


%%ItemTitle%%

OTA COM Type Library

Delete a customization list

Source code

Public Sub DeleteCustomList()
    Dim custom As Customization
    Set custom = tdc.Customization
    Dim lists As CustomizationLists
    Set lists = custom.lists
    lists.RemoveList ("list_02")
    custom.Commit
End Sub


%%PageItemTitle%% $$Members$$

CustomizationMailCondition Overview

CustomizationMailCondition Object Members

Public Properties

Public Property ConditionText | The filter to determine when the notification is sent.
Public Property ConditionType | The type of condition.
Public Property Deleted | Indicates if the condition has been removed, but the deletion has not been posted to the server.
Public Property Name | The name of the mail recipient or the field containing the name.
Public Property Updated | Indicates if the condition object has changed locally since last synchronized with the server.

See Also

CustomizationMailCondition Overview


%%PageItemTitle%% $$Members$$

CustomizationMailConditions Overview

CustomizationMailConditions Object Members

Public Methods

Public Method AddCondition | Creates a new CustomizationMailCondition.
Public Method RemoveCondition | Deletes the specified CustomizationMailCondition.

Public Properties

Public Property Condition | Gets the CustomizationMailCondition specified by the name and type.
Public Property ConditionExist | Checks if the specified mail customization condition exists.
Public Property Conditions | Gets the list of CustomizationMailCondition objects.

See Also

CustomizationMailConditions Overview


%%PageItemTitle%% $$Members$$

CustomizationModules Overview

CustomizationModules Object Members

Public Properties

Public Property Description | The Module Description
Public Property GUID | The Module's globally unique ID.
Public Property IsVisibleForGroup | Indicates if the specified module is visible in the UI to the specified user group.
Public Property Module | Returns the module specified by the module ID.
Public Property Modules | The list of project module IDs.
Public Property Name | The Module Name.
Public Property Visible | A bit-mask that indicates for which groups the module is visible in the user interface.
Public Property VisibleForGroups | The list of the user groups to which the specified module is visible in the UI.

See Also

CustomizationModules Overview


%%PageItemTitle%% $$Members$$

CustomizationPermissions Overview

CustomizationPermissions Object Members

Public Properties

Public Property CanAddItem | Indicates if members of the specified group can add the specified type of entity.
Public Property CanAllowAttachment | Indicates if members owners of the specified group can handle the specified type of entity attachments.
Public Property CanModifyField | Indicates if members or owners of the specified group can modify the specified field.
Public Property CanModifyItem | Indicates if members of the specified group can modify the specified entity.
Public Property CanRemoveItem | Indicates if members or owners of the specified group can remove the specified type of entity.
Public Property CanUseOwnerSensible | Checks if the fields of the specified entity can be restricted for owner modifications only.
Public Property HasAttachmentField | Checks if the entity specified by the EntityName parameter can have attachments.
Public Property IsVisibleInNewBug | Indicates if the specified Bug field is visible for the specified group in a new defect form.
Public Property TransitionRules | The transition rules for the specified field and group.

See Also

CustomizationPermissions Overview


%%PageItemTitle%% $$Members$$

CustomizationRBT Overview

CustomizationRBT Object Members

Public Methods

Public Method AddBIQuestion | Creates a new Business Impact question.
Public Method AddFPQuestion | Creates a new Failure Probability question.
Public Method CalcBILevelByAnswersWeight | Calculate the business impact level from the sum of all the answers' weights.
Public Method CalcFPLevelByAnswersWeight | Calculate failure probability level ffrom the sum of all the answers' weights.
Public Method DeleteBIQuestion | Deletes the specified Business Impact question.
Public Method DeleteFPQuestion | Deletes the specified Failure Probability question.
Public Method TranslateBILevel | Translate BI from TDAPI_RBT_BI_LEVELS to its name in the database.
Public Method TranslateFPLevel | Translate FP from TDAPI_RBT_FP_LEVELS to its name in the database.
Public Method TranslateTestingLevel | Translate TL from TDAPI_RBT_TESTING_LEVELS to it's name in the database.

Public Properties

Public Property BILevelRiskLowerThreshold | The lower threshold of Risk assessment for each Business Impact level.
Public Property BIQuestionByID | Returns the Business Impact Question that has the specified ID.
Public Property BIQuestions | The list of Business Impact questions.
Public Property DisplayedTimeUnits | The time unit display string for calculations results.
Public Property FPLevelRiskLowerThreshold | The lower threshold of Risk assessment for each Failure Probability level.
Public Property FPLevelTestingEffortInHours | Hours needed to test a requirement with the given Failure Probability.
Public Property FPQuestionByID | Returns the Failure Probability Question that has the specified ID.
Public Property FPQuestions | The list of Failure Probability questions.
Public Property TestingLevelPercentage | Testing level percentage (of the full testing level).
Public Property TestingPolicyMatrix | Risk testing level matrix
Public Property Updated | Indicates if the RBT Customization has been modified since the last synchronization with the database.

See Also

CustomizationRBT Overview


%%PageItemTitle%% $$Members$$

CustomizationRBTAnswer Overview

CustomizationRBTAnswer Object Members

Public Properties

Public Property AnswerText | The answer's text.
Public Property AnswerWeight | The answer's weight.
Public Property ID | The CustomizationRBTAnswer unique ID.

See Also

CustomizationRBTAnswer Overview


%%PageItemTitle%% $$Members$$

CustomizationRBTQuestion Overview

CustomizationRBTQuestion Object Members

Public Methods

Public Method AddAnswer | Adds a new possible answer. Returns the new answer as a CustomizationRBTAnswer object
Public Method DeleteAnswer | Deletes a possible answer specified by id.

Public Properties

Public Property AnswerByID | Returns the specified Answer.
Public Property Answers | The IList of CustomizationRBTAnswer objects of all possible answers for this question.
Public Property ID | The CustomizationRBTQuestion unique ID.
Public Property QuestionDescription | The question's description.
Public Property QuestionOrder | The (non unique) question's order of display in UI.
Public Property QuestionText | The question's text.

See Also

CustomizationRBTQuestion Overview


%%PageItemTitle%% $$Members$$

CustomizationReqType Overview

CustomizationReqType Object Members

Public Methods

Public Method AddField | Adds a new CustomizationTypedField.
Public Method RemoveField | Removes the CustomizationTypedField specified by FieldName from this type.

Public Properties

Public Property Field | Gets the CustomizationTypedField specified by FieldName.
Public Property Fields | The list of CustomizationTypedField objects for this type.
Public Property HasDirectCoverage | Indicates if this requirement type supports direct coverage by tests or test instances.
Public Property Icon | The bitmap stream for type icon.
Public Property ID | The CustomizationType ID.
Public Property Name | The CustomizationType name.
Public Property RiskAnalysisType | The Type of the RBT Risk Analysis that is applicable to this requirement.

See Also

CustomizationReqType Overview


%%PageItemTitle%% $$Members$$

CustomizationTransitionRule Overview

CustomizationTransitionRule Object Members

Public Properties

Public Property DestinationValue | The destination value of the transition rule, that is, the value after the change.
Public Property SourceValue | The source value of the transition rule, that is, the value before the change.
Public Property Updated | Indicates if the object has been modified since last synchronized with server.

See Also

CustomizationTransitionRule Overview


%%PageItemTitle%% $$Members$$

CustomizationTransitionRules Overview | CustomizationTransitionRule Object

See Also OTA COM Type Library

CustomizationTransitionRules Object Members

Public Methods

Public Method AddTransitionRule | Adds a new CustomizationTransitionRule to the current object.
Public Method RemoveTransitionRule | Removes the specified transition rule from the current object.

Public Properties

Public Property Count | The number of CustomizationTransitionRule objects contained by the current object.
Public Property EntityName | The location (database table) of the field to which the transition rules in the current object are attached.
Public Property Field | The CustomizationField object to which the transition rules in the current object are attached.
Public Property Group | The CustomizationUsersGroup object to which the transition rules in the current object are attached.
Public Property TransitionRule | The CustomizationTransitionRule specified by its position in the list of transition rules.
Public Property Updated | Indicates if the object has been modified since the last synchronization with database.

See Also

CustomizationTransitionRules Overview | CustomizationTransitionRule Object


%%PageItemTitle%% $$Members$$

CustomizationTypedField Overview

CustomizationTypedField Object Members

Public Properties

Public Property Field | Gets the CustomizationField associated with this object.
Public Property IsRequired | Indicates whether the field is required for the specific type.
Public Property Type | Gets the CustomizationType associated with this object.

See Also

CustomizationTypedField Overview


%%PageItemTitle%% $$Members$$

CustomizationTypes Overview

CustomizationTypes Object Members

Public Methods

Public Method AddCustomizationType | Adds a new CustomizationType to the specified entity.
Public Method GetEntityCustomizationType | Gets the CustomizationType with the specified ID.
Public Method GetEntityCustomizationTypes | Gets the list of all CustomizationTypes for the specified entity.
Public Method RemoveCustomizationType | Removes the CustomizationType with the specified ID from the specified entity.

See Also

CustomizationTypes Overview


%%PageItemTitle%% $$Members$$

CustomizationUser Overview

CustomizationUser Object Members

Public Methods

Public Method AddToGroup | Adds this user to the specified user group.
Public Method GroupsList | The names of all the user groups to which this user belongs.
Public Method RemoveFromGroup | Removes this user from the specified user group.

Public Properties

Public Property Address | A text field that can be used to record user information as appropriate for the project.
Public Property Deleted | If true, this user is marked for deletion, but the deletion is not yet committed.
Public Property DomainAuthentication | The user credentials for LDAP authentication.
Public Property Email | The user's e-mail address.
Public Property FullName | The user's full name.
Public Property InGroup | Indicates if this user is a member of the specified group.
Public Property Name | A unique name by which to identify this user.
Public Property Password | Sets the user's password.
Public Property Phone | The user's telephone number.
Public Property Updated | Indicates if the user's data was updated since the last synchronization with the server.

See Also

CustomizationUser Overview


%%PageItemTitle%% $$Members$$

CustomizationUsers Overview

CustomizationUsers Object Members

Public Methods

Public Method AddSiteAuthenticatedUser | Adds site user with credentials for LDAP authentication.
Public Method AddSiteUser | Creates a new site user and adds it to the current project.
Public Method AddUser | Adds an existing site user to the current project.
Public Method RemoveUser | Removes a user from the collection.
Public Method UserExistsInSite | Checks whether the specified site user exists.

Public Properties

Public Property User | The CustomizationUser object representing the specified user.
Public Property Users | The list of customization users.

See Also

CustomizationUsers Overview


%%PageItemTitle%% $$Members$$

CustomizationUsersGroup Overview

CustomizationUsersGroup Object Members

Public Methods

Public Method AddUser | Adds a new user to the user group.
Public Method RemoveUser | Removes a user from the user group.
Public Method UsersList | A list of all members of the user group.

Public Properties

Public Property Deleted | If true, the object is marked for deletion, but the deletion has not been committed.
Public Property HideFilter | The data hiding filter for the entity specified by the FilterType parameter.
Public Property ID | The user group Id.
Public Property IsSystem | Checks if the user group is a built-in system user group.
Public Property Name | The user group name.
Public Property Updated | Indicates if the object has been modified since being downloaded from database.

See Also

CustomizationUsersGroup Overview


%%PageItemTitle%% $$Members$$

CustomizationUsersGroups Overview

CustomizationUsersGroups Object Members

Public Methods

Public Method AddGroup | Adds a new CustomizationUsersGroup to the collection.
Public Method IsNameValid | Checks whether another group has the specified name.
Public Method RemoveGroup | Removes a CustomizationUsersGroup object.

Public Properties

Public Property Group | Gets the specified user group.
Public Property Groups | The list of CustomizationUsersGroup objects.

See Also

CustomizationUsersGroups Overview


%%ItemTitle%%

OTA COM Type Library

Add a site user

Source code

Public Sub AddSiteUser()
    Dim custom As Customization
    Dim users As CustomizationUsers
    Dim UGroups As CustomizationUsersGroups
    Dim UGrp As CustomizationUsersGroup
    Set custom = tdc.Customization
    Set users = custom.users
    'Get the group to which the new user will belong.
    Set UGroups = custom.UsersGroups
    Set UGrp = UGroups.group("Developer")
    'Create the user
    users.AddSiteUser "Lancelot", _
        "Lancelot DuLac", "Lance@RoundTable.com", _
        "From far-off France I hear your call", _
        "(215)PA-6-5000", UGrp
    custom.Commit
End Sub


%%ItemTitle%%

OTA COM Type Library

Add a project user to a group

Source code

Sub AddProjectUser(NewProjectUser$, addToUserGroup$)
'Add an existing site user to the connected project
    Dim CustUsersGroups As CustomizationUsersGroups
    Dim CustGroup As CustomizationUsersGroup
'Get customization data into the local cache
' Customization Object
    'tdc is the global TDConnection object.
    tdc.Customization.Load
'The AddUser method adds a user to a project but not to the site.
'Therefore, if you restart the server, the user will disappear.
'Define the site user before using the AddUser method.
'Either use the Site Administration UI or create the site
' user in code:
'tdc.Customization.Users.AddSiteUser "Cheng", _
' "Cheng Ivanovitz Smith", _
' "Cheng@Pemberley.com", _
' "Description of Cheng", _
' "614-666-1234", _
' "QATester"
'Add user to the project with the CustomizationUsers Object
' referenced through TDConnection.Customization.Users
    tdc.Customization.Users.AddUser NewProjectUser
'Add the new user to a user group
    Set CustUsersGroups = tdc.Customization.UsersGroups
    'addToUserGroup is a group name, for example "QATester"
    Set CustGroup = CustUsersGroups.Group(addToUserGroup)
    'Add the user
    CustGroup.AddUser NewProjectUser
'Commit the changes to the project
    tdc.Customization.Commit
End Sub


%%ItemTitle%%

OTA COM Type Library

Add a project user

Source code

Sub AddProjectUser(NewProjectUser$, addToUserGroup$)
'Add an existing site user to the connected project
    Dim CustUsersGroups As CustomizationUsersGroups
    Dim CustGroup As CustomizationUsersGroup
'Get customization data into the local cache
' Customization Object
    'tdc is the global TDConnection object.
    tdc.Customization.Load
'The AddUser method adds a user to a project but not to the site.
'Therefore, if you restart the server, the user will disappear.
'Define the site user before using the AddUser method.
'Either use the Site Administration UI or create the site
' user in code:
'tdc.Customization.Users.AddSiteUser "Cheng", _
' "Cheng Ivanovitz Smith", _
' "Cheng@Pemberley.com", _
' "Description of Cheng", _
' "614-666-1234", _
' "QATester"
'Add user to the project with the CustomizationUsers Object
' referenced through TDConnection.Customization.Users
    tdc.Customization.Users.AddUser NewProjectUser
'Add the new user to a user group
    Set CustUsersGroups = tdc.Customization.UsersGroups
    'addToUserGroup is a group name, for example "QATester"
    Set CustGroup = CustUsersGroups.Group(addToUserGroup)
    'Add the user
    CustGroup.AddUser NewProjectUser
'Commit the changes to the project
    tdc.Customization.Commit
End Sub


%%PageItemTitle%% $$Members$$

Cycle Overview

Cycle Object Members

Public Methods

Public Method DaysLeft | Returns the number of days until the scheduled end of the cycle.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Mail | Mails the IBaseFieldExMail field item.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property EndDate | The cycle's end date.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The cycle's name.
Public Property Parent | The cycle's parent release.
Public Property ReleaseManagementInfo | Returns the cycle information.
Public Property StartDate | The cycle's start date.
Public Property Status | The cycle's status.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

Cycle Overview


%%PageItemTitle%% $$Members$$

CycleFactory Overview

CycleFactory Object Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method BuildCoverageGraph | Builds release cycle coverage graph.
Public Method Mail | Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

CycleFactory Overview


%%ItemTitle%%

OTA COM Type Library

Find cycles that match a condition

Source code

Public Sub FindCycles()
'Get the release cycles that match the filter.
Dim FieldName$
Dim CycFilterStr$
Dim filter As TDFilter
Dim listOfCycles As list
Dim cyc As cycle
Dim cycFactory As CycleFactory
    'tdc is the TDConnection object
    'To search through all release cycles in the project,
    ' get the cycle factory from TDConnection
    Set cycFactory = tdc.CycleFactory
    ''To search only in the cycles of a given release,
    '' get the cycle factory from the Release object,
    '' for example,
    'Set cycFactory = TheReleaseObj.CycleFactory
    'Get the Filter from cycleFactory
    ' and set the field and the filter string
    Set filter = cycFactory.filter
    FieldName = "RCYC_HAS_ATTACHMENTS"
    CycFilterStr = "Y"
    filter.filter(FieldName) = CycFilterStr
    'Get the list of matching release cycles
    Set listOfCycles = filter.NewList
    'extract the Cycle names
    For Each cyc In listOfCycles
        Debug.Print cyc.Name
    Next
    ' Get the complementary list
    CycFilterStr = "NOT Y"
    filter.filter(FieldName) = CycFilterStr
    Set listOfCycles = filter.NewList
    'extract the Cycle names
    For Each cyc In listOfCycles
        Debug.Print cyc.Name
    Next
    Set filter = Nothing
    Set listOfCycles = Nothing
    Set cyc = Nothing
    Set cycFactory = Nothing
End Sub


%%PageItemTitle%% $$Members$$

CycleFactory Object

IBaseFactory2 Implemented Interface Members

See Also

CycleFactory Object


%%PageItemTitle%% $$Members$$

CycleFactory Object

ISearchableFactory Implemented Interface Members

See Also

CycleFactory Object


%%ItemTitle%%

OTA COM Type Library

Set up release cycles

Source code

Public Sub SetupReleaseCycles()
' Create a Release with cycles:
'a. Create a Release folder
'b. Create a release
'c. Set release start date\end date for now and
' 3 months from now.
'd. Create 3 cycles, each one month long
'e. Use IReleaseManagementInfo to retrieve information
Dim releaseFolderFactory As IReleaseFolderFactory
Dim relFolder As ReleaseFolder
Dim rootReleaseFolder As ReleaseFolder
Dim relFac As IReleaseFactory
Dim rel As Release
Dim cyclFac As ICycleFactory
Dim cycle As cycle
Dim managementinfo As ReleaseManagementInfo
    ' Create a Release folder
    Set releaseFolderFactory = tdc.releaseFolderFactory
    Set rootReleaseFolder = releaseFolderFactory.root
    Set releaseFolderFactory = rootReleaseFolder.releaseFolderFactory
    Set relFolder = releaseFolderFactory.AddItem(Null)
    relFolder.Name = "Release Folder 1"
    relFolder.Post
    ' Create a release with a due
    ' date 90 days from now
    Set relFac = relFolder.ReleaseFactory
    Set rel = relFac.AddItem(Null)
    rel.Name = "Release 1"
    rel.StartDate = DateTime.Now
    rel.EndDate = DateTime.Now + 90
    rel.Post
    ' Divide the release into
    ' 3 development cycles of
    ' of one month each.
    Set cyclFac = rel.CycleFactory
    Set cycle = cyclFac.AddItem(Null)
    cycle.Name = "Cycle 1"
    cycle.StartDate = DateTime.Now
    cycle.EndDate = DateTime.Now + 30
    cycle.Post
    Set cycle = cyclFac.AddItem(Null)
    cycle.Name = "Cycle 2"
    cycle.StartDate = DateTime.Now + 31
    cycle.EndDate = DateTime.Now + 60
    cycle.Post
    Set cycle = cyclFac.AddItem(Null)
    cycle.Name = "Cycle 3"
    cycle.StartDate = DateTime.Now + 61
    cycle.EndDate = DateTime.Now + 90
    cycle.Post
    ' Use IReleaseManagementInfo to retrieve information
    Set managementinfo = rel.ReleaseManagementInfo
    Debug.Print "Days left for release: " & managementinfo.DaysLeft
    Debug.Print "Duration of the release is: " & managementinfo.Duration
    Debug.Print "Has release started? " & managementinfo.Started
    Debug.Print "Total test instances in release: " & _
        managementinfo.TotalTestInstances
    Debug.Print "Unexecuted test instances in release: " & _
        managementinfo.UnexecutedTestInstances
    Debug.Print "Days left in cycle: " & cycle.DaysLeft
End Sub


%%PageItemTitle%% $$Members$$

Cycle Object

IBaseField2 Implemented Interface Members

See Also

Cycle Object


%%PageItemTitle%% $$Members$$

Cycle Object

IBaseField3 Implemented Interface Members

See Also

Cycle Object


%%PageItemTitle%% $$Members$$

Cycle Object

ISysTreeNode2 Implemented Interface Members

See Also

Cycle Object


%%ItemTitle%%

OTA COM Type Library

Remove requirement target release cycle

Source code

Public Sub RemoveCycle()
' Remove one or all of a requirement's target release cycles
' If cycleToRemoveId is less than zero, all target cycles
' are removed.
' If cycleToRemoveId is a cycle ID, that cycle is removed
'This code can be adopted to remove target releases
' by using RQ_TARGET_REL as the requirement.field.
Dim rFactory As reqFactory
Dim requirement As req
Dim cyc As cycle
Dim listOfCycles As list
Dim strCyclesNames As String
Dim indx As Long
Dim requirementId As Long, cycleToRemoveId As Long
    requirementId = 10
    cycleToRemoveId = -1
    Set rFactory = tdc.reqFactory
    Set requirement = rFactory.Item(requirementId)
    Set listOfCycles = requirement.field("RQ_TARGET_RCYC")
    If (cycleToRemoveId <= 0) Then
        requirement.field("RQ_TARGET_RCYC") = ""
    Else
        Set listOfCycles = requirement.field("RQ_TARGET_RCYC")
        For indx = listOfCycles.Count To 1 Step -1
            Set cyc = listOfCycles.Item(indx)
            If (cyc.ID = cycleToRemoveId) Then
                listOfCycles.Remove (indx)
            End If
        Next
        'Set the modified list of Releases Cycles.
        requirement.field("RQ_TARGET_RCYC") = listOfCycles
    End If
    requirement.Post
    'Extract the names of the remaining cycles.
    strCyclesNames = "Cycles are: "
    For Each cyc In listOfCycles
        strCyclesNames = strCyclesNames & cyc.Name & "(" & cyc.ID & "), "
    Next
    Debug.Print strCyclesNames
    Set rFactory = Nothing
    Set requirement = Nothing
    Set cyc = Nothing
    Set listOfCycles = Nothing
End Sub


%%ItemTitle%%

OTA COM Type Library

Set the target release cycle of the descendents to that of the requirement

Source code

Public Sub PopulateCycle()
'Set the target release cycle of the descendents to that of the requirement
Dim rFactory As reqFactory
Dim requirement As req
Dim requirementId As Long
    Set rFactory = tdc.reqFactory
    requirementId = 1
    Set requirement = rFactory.Item(requirementId)
    'Apply the requirements target cycle to all descendents.
    'The changes are Posted by the function.
    requirement.PopulateTargetCycleToChildren
End Sub


%%PageItemTitle%% $$Members$$

DesignStep Overview

DesignStep Object Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property EvaluatedStepDescription | The design step description.
Public Property EvaluatedStepExpectedResult | The design step expected result string.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property LinkedParams | The linked test parameters.
Public Property LinkTest | A template test to be linked to the design step.
Public Property LinkTestID | The ID of the linked test.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Order | The order of the design step in the test procedure.
Public Property ParentTest | The test object to which the design step belongs.
Public Property StepDescription | The description of the design step.
Public Property StepExpectedResult | The expected results of the step.
Public Property StepName | The design step name.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

DesignStep Overview


%%PageItemTitle%% $$Members$$

DesignStepFactory Overview | DesignStep Object | Test Object

DesignStepFactory Object Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

DesignStepFactory Overview | DesignStep Object | Test Object


%%ItemTitle%%

OTA COM Type Library

Copy test

Source code

Private Sub CopyPasteTest(sourceFolderPath, destFolderPath, testName)
'Copy a test, including design steps and parameters.
' For example:
' CopyPasteTest "Subject\TestFolder1", "Subject\TestFolder2", "Test1"
' Copies Test1 to TestFolder2
     Dim sourceFolder As SubjectNode
     Dim destFolder As SubjectNode
     Dim treeMng As TreeManager
     Dim testF As testFactory
     Dim iscp As ISupportCopyPaste
     Dim clipboard As String
     Dim Filter As TDFilter
     Dim TestsList As list
     Dim Test As Test
     Set treeMng = tdc.TreeManager
     Set sourceFolder = treeMng.NodeByPath(sourceFolderPath)
     Set testF = sourceFolder.testFactory
     'find the test id
     Set Filter = testF.Filter
     Filter.Filter("TS_NAME") = testName
     Set TestsList = Filter.NewList()
     Set Test = TestsList.Item(1)
     'copy the source test
     Set iscp = testF
     clipboard = iscp.CopyToClipBoard(Test.ID, 0, "")
     'paste the test in the destination folder
     Set destFolder = treeMng.NodeByPath(destFolderPath)
     Set testF = destFolder.testFactory
     Set iscp = testF
     iscp.PasteFromClipBoard clipboard, destFolder.NodeID
     'clean up
     Set iscp = Nothing
     Set testF = Nothing
     Set treeMng = Nothing
     Set sourceFolder = Nothing
     Set destFolder = Nothing
     Set Filter = Nothing
     Set TestsList = Nothing
     Set Test = Nothing
End Sub


%%PageItemTitle%% $$Members$$

DesignStepFactory Object

IBaseFactory2 Implemented Interface Members

See Also

DesignStepFactory Object


%%PageItemTitle%% $$Members$$

DesignStepFactory Object

ISupportCopyPaste2 Implemented Interface Members

See Also

DesignStepFactory Object


%%PageItemTitle%% $$Members$$

DesignStep Object

IBaseField2 Implemented Interface Members

See Also

DesignStep Object


%%PageItemTitle%%

Enumerations Members

Enumerations Object

 | Copyright 2002-2007 Mercury Interactive Corporation.
For additional examples and examples in C# and C++, see the Knowledge Base. | Documentation comments or suggestions? Please send feedback to SW-Doc@hp.com


%%PageItemTitle%% $$Members$$

Enumerations Overview

Enumerations Object Members

See Also

Enumerations Overview


%%PageItemTitle%% $$Members$$

ExecEventActionParams Overview

ExecEventActionParams Object Members

Public Properties

Public Property OnExecEventSchedulerAction The action to be taken.

See Also

ExecEventActionParams Overview


%%PageItemTitle%% $$Members$$

ExecEventInfo Overview

ExecEventInfo Object Members

Public Properties

Public Property EventDate | The Execution Event Date.
Public Property EventTime | The Execution Event Time.
Public Property EventType | The type of Execution Event.

See Also

ExecEventInfo Overview


%%ItemTitle%%

OTA COM Type Library

Getting status information when running a test set

Source code

Public Sub RunTestSet(tsFolderName As String, tSetName As String, _
        HostName As String, runWhere As Integer)
' This example show how to run a test set in three different ways:
' Run all tests on the local machine (where this code runs)
' Run the tests on a specified remote machine
' Run the tests on the hosts as planned in the test set
    Dim TSetFact As TestSetFactory, tsList As list
    Dim theTestSet As TestSet
    Dim tsTreeMgr As TestSetTreeManager
    Dim tsFolder As TestSetFolder
    Dim Scheduler As TSScheduler
    Dim execStatus As ExecutionStatus
    On Error GoTo RunTestSetErr
    errmsg = "RunTestSet"
 ' Get the test set tree manager from the test set factory
    'tdc is the global TDConnection object.
    Set TSetFact = tdc.TestSetFactory
    Set tsTreeMgr = tdc.TestSetTreeManager
' Get the test set folder passed as an argument to the example code
    Dim nPath$
    nPath = "Root\" & Trim(tsFolderName)
    On Error Resume Next
    Set tsFolder = tsTreeMgr.NodeByPath(nPath)
    If tsFolder Is Nothing Then
        err.Raise vbObjectError + 1, "RunTestSet", "Could not find folder " & nPath
        GoTo RunTestSetErr
    End If
    On Error GoTo RunTestSetErr
' Search for the test set passed as an argument to the example code
    Set tsList = tsFolder.FindTestSets(tSetName)
    If tsList.Count > 1 Then
        MsgBox "FindTestSets found more than one test set: refine search"
    ElseIf tsList.Count < 1 Then
        MsgBox "FindTestSets: test set not found"
    End If
    Set theTestSet = tsList.Item(1)
    Debug.Print theTestSet.ID
'Start the scheduler on the local machine
    Set Scheduler = theTestSet.StartExecution("")
'Set up for the run depending on where the test instances
' are to execute.
    Select Case runWhere
        Case RUN_LOCAL
        'Run all tests on the local machine
            Scheduler.RunAllLocally = True
        Case RUN_REMOTE
        'Run tests on a specified remote machine
            Scheduler.TdHostName = HostName
            ' RunAllLocally must not be set for
            ' remote invocation of tests.
            ' Do not do this:
            ' Scheduler.RunAllLocally = False
        Case RUN_PLANNED_HOST
        'Run on the hosts as planned in the test set
            Dim TSTestFact As TSTestFactory, TestList As list
            Dim tsFilter As TDFilter
            Dim TSTst As TSTest
        'Get the test instances from the test set
            Set TSTestFact = theTestSet.TSTestFactory
            Set tsFilter = TSTestFact.Filter
            tsFilter.Filter("TC_CYCLE_ID") = theTestSet.ID
            Set TestList = TSTestFact.NewList(tsFilter.Text)
            Debug.Print "Test instances and planned hosts:"
        'For each test instance, set the host to run depending
        ' on the planning in the test set.
            For Each TSTst In TestList
                Debug.Print "Name: " & TSTst.Name & " ID: " & TSTst.ID & " Planned Host: " & TSTst.HostName
                Scheduler.RunOnHost(TSTst.ID) = TSTst.HostName
            Next TSTst
            Scheduler.RunAllLocally = False
    End Select
'Run the tests
    Scheduler.run
'Get the execution status object
    Set execStatus = Scheduler.ExecutionStatus
'Track the events and statuses
    Dim RunFinished As Boolean, iter As Integer, i As Integer
    Dim ExecEventInfoObj As ExecEventInfo, EventsList As list
    Dim TestExecStatusObj As TestExecStatus ', TestInstanceObj As ITSTest
    While ((RunFinished = False) And (iter < 100))
        iter = iter + 1
        execStatus.RefreshExecStatusInfo "all", True
        RunFinished = execStatus.Finished
        Set EventsList = execStatus.EventsList
        For Each ExecEventInfoObj In EventsList
            Debug.Print Tab; "Event: " & ExecEventInfoObj.EventDate & " " & _
                    ExecEventInfoObj.EventTime & " " & _
                    "Event Type: " & ExecEventInfoObj.EventType & " [Event types: " & _
                    "1-fail, 2-finished, 3-env fail, 4-timeout, 5-manual]"
        Next
        Debug.Print Tab; execStatus.Count & " exec status"
        For i = 1 To execStatus.Count
            Set TestExecStatusObj = execStatus.Item(i)
            Debug.Print Tab; "Iteration " & iter & " Status: " & _
                        " Test " & TestExecStatusObj.TestId & _
                        " ,Test instance " & TestExecStatusObj.TestInstance & _
                        " ,order " & TestExecStatusObj.TSTestId & " " & _
                        TestExecStatusObj.Message & ", status=" & _
                        TestExecStatusObj.Status
        Next i
        'Sleep() has to be declared before it can be used.
        'This is the module level declaration of Sleep():
        'Declare Sub Sleep Lib "kernel32" (ByVal dwMilliseconds As Long)
        Sleep (5000)
    Wend 'Loop While execStatus.Finished = False
    Debug.Print "Scheduler finished around " & CStr(Now)
    Debug.Print
Exit Sub
RunTestSetErr:
    ErrHandler err, err.Description, errmsg, False
End Sub


%%PageItemTitle%% $$Members$$

ExecEventNotifyByMailSettings Overview

ExecEventNotifyByMailSettings Object Members

Public Methods

Public Method Save Uploads the notification settings to the server.

Public Properties

Public Property EMailTo | The recipients' e-mail addresses.
Public Property Enabled | Indicates if mail is enabled for the specified event type.
Public Property UserMessage | The message body of the e-mail.

See Also

ExecEventNotifyByMailSettings Overview


%%PageItemTitle%% $$Members$$

ExecEventRestartActionParams Overview

ExecEventRestartActionParams Object Members

Public Properties

Public Property CleanupTest | The test ID of the test to run before each rerun.
Public Property NumberOfRetries | The number of retries if a test fails.
Public Property OnExecEventSchedulerAction | The action to be taken.

See Also

ExecEventRestartActionParams Overview


%%PageItemTitle%% $$Members$$

ExecSettings Overview

ExecSettings Object Members

Public Properties

Public Property OnExecEventSchedulerActionParams | The restart action parameters.
Public Property OnExecEventSchedulerActionType | The action type of the execution event.
Public Property PlannedExecutionDate | The planned test execution date.
Public Property PlannedExecutionTime | The planned test execution time.
Public Property PlannedRunDuration | The planned test run duration.

See Also

ExecSettings Overview


%%PageItemTitle%% $$Members$$

ExecutionStatus Overview

ExecutionStatus Collection Members

Public Methods

Public Method EventsList | Gets the list of the execution events.
Public Method RefreshExecStatusInfo | Refreshes the execution status from the execution controller.

Public Properties

Public Property _NewEnum | Gets an ATL.IEnumOnSTLImpl enumerator for the TestExecStatus objects. For information on the ATL Class and IEnumOnSTLImpl, see Microsoft documentation.
Public Property Count | The number of status elements in the object.
Public Property Finished | Checks if execution is finished or still in progress.
Public Property Item | Gets a TestExecStatus object by index (1-based).

See Also

ExecutionStatus Overview


%%PageItemTitle%% $$Members$$

ExtendedStorage Overview

ExtendedStorage Object Members

Public Methods

Public Method Cancel | Cancels the load or save action.
Public Method Delete | Deletes files locally or from the server.
Public Method GetLastError | Gets the last error that occurred during asynchronous load and save operations.
Public Method Load | Downloads the storage structure to the client file system.
Public Method LoadEx | Downloads the storage structure to the client file system.
Public Method Progress | Polls the progress of the last action (Load or Save).
Public Method Save | Uploads the storage structure to the server.
Public Method SaveEx | Uploads the storage structure to the server.

Public Properties

Public Property ActionFinished | Checks if the load or save action is finished.
Public Property ClientPath | The location on the client to which to download or from which to upload.
Public Property Root | The storage root.
Public Property ServerPath | The location on the server from which to download or to which to upload.

See Also

ExtendedStorage Overview


%%PageItemTitle%% $$Members$$

ExtendedStorageProxy Overview

ExtendedStorageProxy Object Members

Public Methods

Public Method Cancel | Cancels the load or save action.
Public Method Delete | Deletes files locally or from the server.
Public Method GetLastError | Gets the last error that occurred during asynchronous load and save operations.
Public Method Load | Downloads the storage structure to the client file system.
Public Method LoadEx | Downloads the storage structure to the client file system.
Public Method Progress | Polls the progress of the last action (Load or Save).
Public Method Save | Uploads the storage structure to the server.
Public Method SaveEx | Uploads the storage structure to the server.

Public Properties

Public Property ActionFinished | Checks if the load or save action is finished.
Public Property ClientPath | The location on the client to which to download or from which to upload.
Public Property Root | The storage root.
Public Property ServerPath | The location on the server from which to download or to which to upload.

See Also

ExtendedStorageProxy Overview


%%ItemTitle%%

OTA COM Type Library

Downloading a defect attachment with Extended Storage

Source code

Public Sub DownloadDefectAttachment()
' This routine downloads a defect attachment
' using the IExtendedStorage object, demonstrating
' the use of ClientPath and Load.
' Note that attachments can also be downloaded
' using the Attachment.Load method.
    Dim BugFact As BugFactory
    Dim bugObj As Bug
    Dim attachFact As AttachmentFactory
    Dim attachObj As Attachment
    Dim ExStrg As IExtendedStorage
    Dim defectSummary As String
    Dim BugList As list
    Dim FactList As FactoryList
    Dim AttachmentName As String
    On Error GoTo DownloadDefectAttachmentErr
'The summary of the bug we will use for the example.
    defectSummary = "The itinerary is booked when Credit Card number field is empty"
'Get the bug factory from the TDConnection
    Set BugFact = tdc.BugFactory
'Get the bug with the summary we want
    Set FactList = BugFact.FindSimilarBugs(defectSummary, 25)
' Get the best match
' The list is sorted ratio in ascending order by ratio
' so the last item in the list is the best match.
    Set bugObj = FactList.Item(FactList.Count)
    Debug.Print "Defect ID = " & bugObj.ID
' Get the bug attachment factory
    Set attachFact = bugObj.Attachments
' Get the list of all attachments of the defect.
    Dim lst As TDAPIOLELib.list
    Set lst = attachFact.NewList("")
' Find SampleAttachment.txt
    Dim pos%
    For Each attachObj In lst
        pos = InStr(attachObj.Name, "SampleAttachment.txt")
        If pos > 0 Then
            AttachmentName = attachObj.Name
Debug.Print _
"The attachment name for SampleAttachment.txt is " & AttachmentName
'The attachment name for SampleAttachment.txt is BUG_18_SampleAttachment.txt
'Note that the attachment name is not the original file name.
            Exit For
        End If
    Next
    Set lst = Nothing
    If attachObj Is Nothing Then
        MsgBox "Attachment SampleAttachment.txt not found"
        Exit Sub
    End If
    If pos = 0 Then
        MsgBox "Attachment SampleAttachment.txt not found"
        Exit Sub
    End If
    If Not (attachObj.FileSize > 0) Then
        MsgBox "Attachment SampleAttachment.txt has zero size."
        Exit Sub
    End If
' Get the attachment extended storage object
    Set ExStrg = attachObj.AttachmentStorage
'-----------------------------------------
'Use IExtendedStorage.ClientPath to
'specify the download path.
'Folder C does not exist. The Load call will create it.
    ExStrg.ClientPath = "D:\temp\C\"
'-----------------------------------------
'Use IExtendedStorage.Load to
'download the file
    ExStrg.Load AttachmentName, True
Exit Sub
DownloadDefectAttachmentErr:
    ErrHandler err, "DownloadDefectAttachment"
End Sub


%%ItemTitle%%

OTA COM Type Library

Operations on the test repository

Source code

Public Sub GetTestRepository()
    Dim TestFact As TestFactory
    Dim ExtStor As IExtendedStorage
    Dim DownLoadPath As String
    Dim FilePath As String
'------------------------------------
' Get an IExtendedStorage object using
' TestFactory.RepositoryStorage
' and examine the local download path
    'tdc is the global TDConnection object.
    Set TestFact = tdc.TestFactory
    Set ExtStor = TestFact.RepositoryStorage
With ExtStor
    Debug.Print .ClientPath
' The output will look something like this, except that
' the string "423af35f" will be different on your client.
'C:\DOCUME~1\<user name>\LOCALS~1\Temp\TD_80\423af35f\Test
'
'------------------------------------
' Clean old files with IExtendedStorage.Delete
' by recursively
' deleting the entire local copy of
' the repository.
' The "Test" directory and everything under it are deleted
    .Delete "-r", TDOLE_DELETE_LOCAL
'
'------------------------------------
' Use IExtendedStorage.Load
' to refresh the local copy with all new files
    DownLoadPath = .Load("*", True)
' Note that the download path is the IExtendedStorage
' object's Client Path:
    Debug.Print "The download path: " & DownLoadPath
'The download path: _
C:\DOCUME~1\<user name>\LOCALS~1\Temp\TD_80\423af35f\Test
    Debug.Print "The Extended Storage Client Path: " & .ClientPath
'The Extended Storage Client Path: _
C:\DOCUME~1\<user name>\LOCALS~1\Temp\TD_80\423af35f\Test
'
'------------------------------------
' Use IExtendedStorage.Delete
'------------------------------------
' Delete a specific file with
' The file path for deletion starts at
' the extended storage root, so the
' full file path to this file is
' DownLoadPath + \trip_typ\script.vbs
    FilePath = "trip_typ\script.vbs"
    .Delete FilePath, TDOLE_DELETE_LOCAL
'
'------------------------------------
' Delete all files named batch.bat anywhere
' in the local copy of the repository
    .Delete "-r batch.bat", TDOLE_DELETE_LOCAL
End With 'extstor
End Sub


%%PageItemTitle%% $$Members$$

FactoryList Overview

FactoryList Collection Members

Public Methods

Public Method Add | Adds a new item to the current list object.
Public Method IndexOfItem | Gets the index of the passed object.
Public Method Insert | Inserts a new item at the specified position.
Public Method Post | Posts changed data for all items in list.
Public Method Refresh | Reads saved list filter and data for all listed objects, overwriting values in memory.
Public Method Remove | Removes the specified item from the current list object.
Public Method Swap | Swaps the two list items specified by their positions.

Public Properties

Public Property _NewEnum | Gets an IEnumVARIANT enumerator. For information on the IEnumVARIANT, see Microsoft documentation.
Public Property Count | The number of items in the list.
Public Property Fields | Gets a list of fields available through this factory.
Public Property Item | Gets an item by index. The index is one-based.
Public Property Ratio | The similarity ratio for the specified item.

See Also

FactoryList Overview


%%ItemTitle%%

OTA COM Type Library

Getting the similarity ratio of lists created with FindSimilarBugs

Source code

Sub FindSimilarBugs()
'This routine outputs the number of matches and the
'similarity ratios of the first and last match.
'If you run the example, you'll see that the number of
'matches drops as the similarity ratio goes up.
'
    Dim BugFact As BugFactory
    Dim theBug As Bug
    Dim BugList As list
    Dim FactList As FactoryList
    Dim SimRatio As Integer, cnt%
    Dim DescField As TDField, Description$
    Dim FirstLoop As Boolean
    On Error GoTo FindSimilarBugsErr
' Get the bug factory and output the number of defects.
    'tdc is the global TDConnection object.
    Set BugFact = tdc.BugFactory
    Set BugList = BugFact.NewList("")
    cnt = BugList.Count
    Debug.Print "Total number of defects = " & cnt
' Get a bug object (not important which for this demo)
    Set theBug = BugFact.Item(1)
' Here's what we'll be looking for, Summary and Descriptions similar to these:
    Debug.Print "The Summary: " & vbCrLf & theBug.Summary
'-----------------------------------------
'Use Bug.Field to
'get the Description from the database field
    Description = theBug.Field("BG_DESCRIPTION")
    Debug.Print "The Description: " & vbCrLf & Description & vbCrLf
' Note that at the low ratios it might be hard to see why the defects match.
' At the higher ratios it is clearer.
    FirstLoop = True
    For SimRatio = 10 To 100 Step 20
'-----------------------------------------
'Use Bug.FindSimilarBugs
        Set FactList = theBug.FindSimilarBugs(SimRatio)
        Debug.Print "-----------------------------------------" & vbCrLf
        cnt = FactList.Count
        Debug.Print "Number of matches found for ratio of " & SimRatio & " = " & cnt
        If cnt = 0 Then Exit For
'-----------------------------------------
'Use FactoryList.Ratio and FactoryList.Item
        Debug.Print "------------"
        Debug.Print "First match ID: " & FactList.Item(1).ID
        Debug.Print "Ratio of first match = " & FactList.Ratio(1)
        Debug.Print "Summary:" & vbCrLf & FactList.Item(1).Summary
        Debug.Print "Description" & vbCrLf & FactList.Item(1).Field("BG_DESCRIPTION")
        Debug.Print "------------"
        Debug.Print "Last match ID: " & FactList.Item(cnt).ID
         'The last will always be the same item. Output text once.
        If FirstLoop Then
            Debug.Print "Ratio of last match = " & FactList.Ratio(cnt)
            Debug.Print "Summary:" & vbCrLf & FactList.Item(cnt).Summary
            Debug.Print "Description" & vbCrLf & FactList.Item(cnt).Field("BG_DESCRIPTION")
            FirstLoop = False
        End If
    Next SimRatio
Exit Sub
FindSimilarBugsErr:
    MsgBox err.Description
    Resume Next
End Sub


%%PageItemTitle%% $$Members$$

FieldProperty Overview

FieldProperty Object Members

Public Methods

Public Method GetRequiredByType Checks if the field is required according to the requirement type.

Public Properties

Public Property DBColumnName | The database column name.
Public Property DBColumnType | The database column type.
Public Property DBTableName | The database table name.
Public Property EditMask | The input mask for string fields.
Public Property EditStyle | The user interface control type used to edit this field.
Public Property FieldSize | The size of the field in the database (-1 for BLOB fields).
Public Property IsActive | Checks if the field is can be displayed in the user interface.
Public Property IsByCode | Checks if the field saves the Tree Node ID (True), or the passed value (False).
Public Property IsCanFilter | Checks if the field is displayed in the filter dialog box.
Public Property IsCanGroup | Checks if items of this type can form groups with others of the same type.
Public Property IsCustomizable | Checks if the field is displayed in the customization UI.
Public Property IsEdit | Checks if the field can be edited.
Public Property IsHistory | Checks if change history is stored for the field.
Public Property IsKeepValue | Checks if the last value for the field is stored.
Public Property IsKey | Checks if this is a database key field.
Public Property IsMail | Checks if e-mail is sent to the users on the notification list when this field changes.
Public Property IsModify | Checks if the user currently logged on the TDConnection is permitted to modify this field.
Public Property IsMultiValue | Checks if the field can store multiple values.
Public Property IsRequired | Checks if this is a required field.
Public Property IsSearchable | Checks if the content of the field is searched by the Search method.
Public Property IsSystem | Checks if this is a predefined system field.
Public Property IsToSum | Checks if this field is summed for graphs.
Public Property IsVerify | Checks if the field requires verification.
Public Property IsVersionControl | Checks if the field is under version control.
Public Property IsVisibleInNewBug | Checks if the field is visible in the New Bug form.
Public Property ReadOnly | Checks if this is a read-only field.
Public Property Root | The tree root connected to the field.
Public Property UserColumnType | The user column type: char, number, date, memo, or empty string.
Public Property UserLabel | The user-defined label.

See Also

FieldProperty Overview


%%ItemTitle%%

OTA COM Type Library

Compare TDField properties and FieldProperty properties

Source code

Public Sub GetFields(Optional TableName As String = "ALERT")
Dim aField As TDField
Dim fieldList As list
Dim FieldProp As FieldProperty
'----------------------------------
'Get a list of TDField objects from
'TDConnection.Fields
    'tdc is the global TDConnection object.
    Set fieldList = tdc.Fields(TableName)
'-------------------------------------------
'Use List.Count to check how many items
    Debug.Print "The number of field in the table is " _
        & fieldList.Count
    Debug.Print
'-------------------------------------------
' Use List.Item to get a TDField object
' Use the TDField name property to check
' what is the first item.
    Set aField = fieldList.Item(0)
    Debug.Print "The first item is " & aField.Name
'Walk through the list and output the properties
'Note that although the TDField and the FieldProperty objects
' are returning information on the same field, they are doing
' so from different perspectives and the information is slightly
' different in some cases.
'Run the example and study the output to see these differences.
    For Each aField In fieldList
        With aField
'-------------------------------------------
' Get the FieldProperty object
        Set FieldProp = aField.Property
        If True Then 'fieldProp.IsActive Then
            Debug.Print "---------------------------"
            Debug.Print "TDField.Name: " & .Name
            'TDField.Name: AT_ENTITY_TYPE
            Debug.Print vbTab & "FieldProperty.DBColumnName: " _
                & FieldProp.DBColumnName
            ' FieldProperty.DBColumnName: AT_ENTITY_TYPE
            Debug.Print vbTab & "TDField.Property: " & .Property
            ' FieldProperty.UserLabel: Entity
            Debug.Print vbTab & "FieldProperty.UserLabel: " _
                & FieldProp.UserLabel
            ' FieldProperty.UserLabel: Entity
            Debug.Print vbTab & "TDField.Type: " & .Type _
                & " = " & DataTypeString(.Type)
            ' TDField.Type: 3 = TDOLE_STRING
            Debug.Print vbTab & "FieldProperty.DBColumnType: " _
                & FieldProp.DBColumnType
            ' FieldProperty.DBColumnType: char
            Debug.Print vbTab & "FieldProperty.UserColumnType: " _
                & FieldProp.UserColumnType
            ' FieldProperty.UserColumnType: char
            If FieldProp.IsKey Then
                  Debug.Print vbTab _
                    & "Key Field - FieldProperty.KeyOrder: " _
                    & FieldProp.KeyOrder
                  ' Key Field - FieldProperty.KeyOrder: 0
            End If
            Debug.Print vbTab & "This field" _
                & IIf(FieldProp.IsActive, " is ", " is not ") _
                & "visible in the UI"
            ' This field is not visible in the UI
        End If
        End With
    Next aField
End Sub


%%PageItemTitle%% $$Members$$

FileData Overview

FileData Object Members

Public Methods

Public Method Items | The folder's child items.
Public Method ModifyDate | The file's modify date.
Public Method Size | The file size in Kbytes.
Public Method Type | The type of object for which data is stored.

Public Properties

Public Property Name The file or folder name.

See Also

FileData Overview


%%PageItemTitle%% $$Members$$

Graph Overview

Graph Object Members

Public Methods

Public Method DrillDown | Drills down to graph data.
Public Method MultiDrillDown | Gets detailed information about a graph area consisting of four sets of coordinates.

Public Properties

Public Property ColCount | The number of columns.
Public Property ColName | Gets the name of the specified column. Column numbers are zero-based.
Public Property ColTotal | The sum of the values in the specified graph data column. The column number is zero-based.
Public Property Data | The data in the specified cell. Column and Row numbers are zero-based.
Public Property GraphTotal | The total number of items represented in the graph.
Public Property MaxValue | The maximum value in the graph.
Public Property RowCount | The number of rows.
Public Property RowName | Gets the row name of the specified row. Row numbers are zero-based.
Public Property RowTotal | The sum of the values in the specified graph data row. The row number is zero-based.
Public Property StartDate | The start date for the graph.

See Also

Graph Overview


%%PageItemTitle%% $$Members$$

GraphBuilder Overview

GraphBuilder Object Members

Public Methods

Public Method BuildGraph | Build the graph.
Public Method BuildMultipleGraphs | Build several graphs.
Public Method CreateGraphDefinition | Create an IGraphDefinition object.

See Also

GraphBuilder Overview


%%PageItemTitle%% $$Members$$

GraphDefinition Overview

GraphDefinition Object Members

Public Properties

Public Property Filter | The filter sets the criteria for which data are included in the graph.
Public Property Module | The module specified when the graph definition was created.
Public Property Property | The value of the specified property.
Public Property Type | The graph type

See Also

GraphDefinition Overview


%%ItemTitle%%

OTA COM Type Library

Build a summary graph

Source code

Public Sub BuildTrendGraphOfTests()
    Dim testF As testFactory
    Dim graph1 As Graph
    Dim Filter As TDFilter
    Dim fRDate As String
    Set testF = tdc.testFactory
    Set Filter = testF.Filter
    Set graph1 = _
     testF.BuildSummaryGraph("TS_STATUS", "TS_STATUS", "", 0, Filter, False, False)
    MsgBox graph1.ColCount
    MsgBox graph1.GraphTotal
    MsgBox graph1.MaxValue
    MsgBox graph1.RowCount
End Sub


%%PageItemTitle%% $$Members$$

HierarchyFilter Overview

HierarchyFilter Object Members

Public Methods

Public Method Clear | Clears the current filter.
Public Method GetXFilter | Gets the cross filter specified by CrossEntities.
Public Method IsClear | Checks whether the filter is clear, including cross-filter settings
Public Method NewList | Creates a new list from current filter.
Public Method Refresh | Reads saved data and refreshes the fetched list according to the current filter, overwriting values in memory.
Public Method SetXFilter | Sets the filter for second entity, called a cross filter.

Public Properties

Public Property CaseSensitive | Indicates if the filter for the specified field is case sensitive. The default is False.
Public Property DataType | The filtered entity type.
Public Property Fields | The list of fields for the TDFilter's parent object.
Public Property Filter | The filter condition for the field specified by the FieldName.
Public Property KeepHierarchical | Indicates whether to include parent objects in list.
Public Property Order | The position of the specified field in the list of the sort fields. (zero-based)
Public Property OrderDirection | The sort order: TDOLE_ASCENDING or TDOLE_DESCENDING
Public Property Text | The full fields filter as text.
Public Property XFilter | The cross filter according to the entity type.

See Also

HierarchyFilter Overview


%%ItemTitle%%

OTA COM Type Library

Getting a filtered, sorted list of requirements

Source code

Public Sub GetSortedList()
    Dim reqF As reqFactory
    Dim hierFilter As HierarchyFilter
    Dim reqHierL As HierarchySupportList, reqL As list
    Dim rq As Req
    Dim i%
    On Error GoTo GetHListErr
    'tdc is the global TDConnection object.
    Set reqF = tdc.reqFactory
'Get "Son", "GrandSon", and "SubNode"
    Set hierFilter = reqF.Filter
    hierFilter("RQ_REQ_NAME") = "*Son* OR SubNode*"
'Get Emma or Mansfield Park projects.
' Note that Mansfield Park must be quoted because of the space
' between Mansfield and Park.
    hierFilter("RQ_REQ_PRODUCT") = "Emma OR 'Mansfield Park'"
    hierFilter.Order("RQ_REQ_PRODUCT") = 1
    hierFilter.Order("RQ_REQ_PRIORITY") = 2
'
'Get the parent nodes as well by setting KeepHierarchical = True.
' Note that this setting is required to get
' a HierarchySupportList. If KeepHierarchical
' is False or not set, HierarchyFilter.NewList
' returns a List, not a HierarchySupportList.
    hierFilter.KeepHierarchical = True
' This will fail if KeepHierarchical not set True:
    Set reqHierL = hierFilter.NewList
    For i = 1 To reqHierL.Count
        Set rq = reqHierL(i)
        With rq
            Debug.Print .Product & ", " & .Priority & ", " & .Name
        End With
    Next i
' Emma, 2-Medium, Req1
' Emma, 2-Medium, Son of Req1 1.2
' Emma, 3-High, GrandSon of Req1 1.2.1
' Emma, 3-High, Son of Req1 1.1
' Emma, 5-Urgent, GrandSon of Req1 1.1.1
' Emma, 5-Urgent, SubNode of Req 3 3.1
' Emma, 5-Urgent, GrandSon of Req2 2.1.1
' Mansfield Park, 2-Medium, GrandSon of Req1 1.1.2
' Mansfield Park, 2-Medium, GrandSon of Req1 1.2.2
' Mansfield Park, 3-High, req2
' Mansfield Park, 3-High, GrandSon of Req2 2.1.2
' Mansfield Park, 5-Urgent, SubNode of Req 3 3.2
' Mansfield Park, 5-Urgent, Son of Req2 2.1
Exit Sub
GetHListErr:
    ErrHandler err, "GetSortedList", err.Description, False
End Sub


%%ItemTitle%%

OTA COM Type Library

Getting a hierarchical list of requirements

Source code

Public Sub GetHierarchicalList()
    Dim reqF As reqFactory
    Dim hierFilter As HierarchyFilter
    Dim reqHierL As HierarchySupportList, reqL As list
    Dim rq As Req
    Dim i%
    On Error GoTo GetHListErr
    'tdc is the global TDConnection object.
    Set reqF = tdc.reqFactory
'Requirements as they appear in Requirements Tree
' when this routine is run:
' Req1
' Son of Req1 1.1
' GrandSon of Req1 1.1.1
' GrandSon of Req1 1.1.2
' Son of Req1 1.2
' GrandSon of Req1 1.2.1
' GrandSon of Req1 1.2.2
' Req2
' Son of Req2 2.1
' GrandSon of Req2 2.1.1
' GrandSon of Req2 2.1.2
' Req3
' SubNode of Req 3 3.1
' SubNode of Req 3 3.2
'Get "Son" and "GrandSon", but not "SubNode"
    Set hierFilter = reqF.Filter
    hierFilter("RQ_REQ_NAME") = "*Son*"
    hierFilter.Order("RQ_REQ_PATH") = 1
'
'Get the parent nodes as well by setting KeepHierarchical = True.
' Note that this setting is required to get
' a HierarchySupportList. If KeepHierarchical
' is False or not set, HierarchyFilter.NewList
' returns a List, not a HierarchySupportList.
    hierFilter.KeepHierarchical = True
' This will fail if KeepHierarchical not set True:
    Set reqHierL = hierFilter.NewList
    For i = 1 To reqHierL.Count
        Set rq = reqHierL(i)
        With rq
            If Not reqHierL.IsInFilter(i) Then Debug.Print "**** Not in Filter *****"
            Debug.Print "Path = " & .Field("RQ_REQ_PATH") & " : " & .Path & _
                 IIf(reqHierL.IsInFilter(i), "", vbCrLf & "****")
        End With
    Next i
'
' Output of this routine:
'
' **** Not in Filter *****
' Path = AAA: req2
' ****
' Path = AAAAAA : Req2\Son of Req2 2.1
' Path = AAAAAAAAA : Req2\Son of Req2 2.1\GrandSon of Req2 2.1.1
' Path = AAAAAAAAB : Req2\Son of Req2 2.1\GrandSon of Req2 2.1.2
' **** Not in Filter *****
' Path = AAB: Req1
' ****
' Path = AABAAA : Req1\Son of Req1 1.1
' Path = AABAAAAAA : Req1\Son of Req1 1.1\GrandSon of Req1 1.1.1
' Path = AABAAAAAB : Req1\Son of Req1 1.1\GrandSon of Req1 1.1.2
' Path = AABAAB : Req1\Son of Req1 1.2
' Path = AABAABAAA : Req1\Son of Req1 1.2\GrandSon of Req1 1.2.1
' Path = AABAABAAB : Req1\Son of Req1 1.2\GrandSon of Req1 1.2.2
Exit Sub
GetHListErr:
    ErrHandler err, "GetHierarchicalList", err.Description, False
End Sub


%%PageItemTitle%% $$Members$$

HierarchySupportList Overview

HierarchySupportList Collection Members

Public Methods

Public Method Add | Adds a new item to the current list object.
Public Method IndexOfItem | Gets the index of the passed object.
Public Method Insert | Inserts a new item at the specified position.
Public Method Post | Posts changed data for all items in list.
Public Method Refresh | Reads saved list filter and data for all listed objects, overwriting values in memory.
Public Method Remove | Removes the specified item from the current list object.
Public Method Swap | Swaps the two list items specified by their positions.

Public Properties

Public Property _NewEnum | Gets an IEnumVARIANT enumerator. For information on the IEnumVARIANT, see Microsoft documentation.
Public Property Count | The number of items in the list.
Public Property Fields | Gets a list of fields available through this factory.
Public Property IsInFilter | Checks if the item matches the filter criteria of the list to which it belongs.
Public Property Item | Gets an item by index. The index is one-based.
Public Property Ratio | The similarity ratio for the specified item.

See Also

HierarchySupportList Overview


%%PageItemTitle%% $$Members$$

History Overview

History Object Members

Public Methods

Public Method ClearHistory | Clears the history records selected by the filter.
Public Method NewList | Gets filtered list of history data records.

Public Properties

Public Property Filter The filter object for the history item.

See Also

History Overview


%%PageItemTitle%% $$Members$$

HistoryRecord Overview

HistoryRecord Object Members

Public Properties

Public Property ChangeDate | The change date according to database server.
Public Property Changer | The name of the user who made the change.
Public Property FieldName | The name of the changed field.
Public Property ItemKey | The item key for the changed item.
Public Property NewValue | The value after the change.
Public Property OldValue | The value before the change.

See Also

HistoryRecord Overview


%%PageItemTitle%% $$Members$$

Host Overview

Host Object Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Description | A description of the host server.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The name of the host server.
Public Property RexServer | The remote execution server name as it appears on the LAN.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

Host Overview


%%PageItemTitle%% $$Members$$

HostFactory Overview

HostFactory Object Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

HostFactory Overview


%%PageItemTitle%% $$Members$$

HostFactory Object

IBaseFactory2 Implemented Interface Members

See Also

HostFactory Object


%%PageItemTitle%% $$Members$$

HostFactory Object

ISupportCopyPaste2 Implemented Interface Members

See Also

HostFactory Object


%%PageItemTitle%% $$Members$$

HostGroup Overview

HostGroup Object Members

Public Methods

Public Method AddHost | Adds a host to the group.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method NewList | Gets a list of all hosts in the group.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method RemoveHost | Removes the specified host from the group.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | Gets the host group name.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

HostGroup Overview


%%PageItemTitle%% $$Members$$

HostGroupFactory Overview

HostGroupFactory Object Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveHost | Removes host from all groups.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

HostGroupFactory Overview


%%PageItemTitle%% $$Members$$

HostGroupFactory Object

IBaseFactory2 Implemented Interface Members

See Also

HostGroupFactory Object


%%PageItemTitle%% $$Members$$

HostGroupFactory Object

ISupportCopyPaste2 Implemented Interface Members

See Also

HostGroupFactory Object


%%ItemTitle%%

OTA COM Type Library

Getting and setting Host properties

Source code

Sub HostProperties()
'This procedure gets and sets some Host properties
    Dim HostFact As HostFactory
    Dim theHost As Host
    Dim HList As list
'Get a Host object
    'tdc is the global TDConnection object.
    Set HostFact = tdc.HostFactory
    Set HList = HostFact.NewList("")
    Debug.Print "The number of hosts in the project is " _
        & HList.Count
    Set theHost = HList.Item(1)
    On Error Resume Next
'Print the properities
    Debug.Print "ID """ & theHost.ID & """"
    Debug.Print "Description """ & theHost.Description & """"
    Debug.Print "Name """ & theHost.Name & """"
    Debug.Print "RexServer """ & theHost.RexServer & """"
    Debug.Print "Modified """ & theHost.Modified & """"
    Debug.Print "Virtual """ & theHost.Virtual & """"
'Change the Description
    theHost.Description = "AQT_HOST_1_Test"
'Commit to database
    theHost.Post
'Check the new value
    Debug.Print "Description """ & theHost.Description & """"
End Sub


%%PageItemTitle%% $$Members$$

Host Object

IBaseField2 Implemented Interface Members

See Also

Host Object


%%PageItemTitle%% $$Members$$

IActionPermission Overview

IActionPermission Interface Members

Public Properties

Public Property ActionEnabled Checks if the user has rights to perform the specified action.

See Also

IActionPermission Overview


%%PageItemTitle%% $$Members$$

IAlert Overview

IAlert Interface Members

Public Properties

Public Property AlertDate | The date that the alert was generated, based on the database server clock.
Public Property AlertType | The type of alert generated: Alert or Follow-up.
Public Property Description | The description of the alert.
Public Property ID | The alert or follow-up ID.
Public Property Subject | A short summary appropriate to be used as subject line of the Alert e-mail.
Public Property Unread | If true, the alert or follow-up has not yet been read.

See Also

IAlert Overview


%%PageItemTitle%% $$Members$$

IAlertable2 Overview

IAlertable2 Interface Members

Public Methods

Public Method AddAlert | Adds a new alert to the specified entity.
Public Method CleanAllAlerts | Removes all current object alerts from the database.
Public Method DeleteAlert | Removes an alert or alerts associated with the current object from the database.
Public Method GetAlert | Gets the alert specified by the alert ID.
Public Method GetAlertList | Gets a list of all alerts associated with the object.
Public Method HasAlerts | Checks if any alerts are associated with the object.
Public Method HasNewAlerts | New, unread alerts are associated with the object.

See Also

IAlertable2 Overview


%%PageItemTitle%% $$Members$$

IAlertable Overview

IAlertable Interface Members

Public Methods

Public Method CleanAllAlerts | Removes all current object alerts from the database.
Public Method DeleteAlert | Removes an alert or alerts associated with the current object from the database.
Public Method GetAlert | Gets the alert specified by the alert ID.
Public Method GetAlertList | Gets a list of all alerts associated with the object.
Public Method HasAlerts | Checks if any alerts are associated with the object.
Public Method HasNewAlerts | New, unread alerts are associated with the object.

See Also

IAlertable Overview


%%PageItemTitle%% $$Members$$

IAlertableEntityFactory Overview

IAlertableEntityFactory Interface Members

See Also

IAlertableEntityFactory Overview


%%PageItemTitle%% $$Members$$

IAlertManager Overview

IAlertManager Interface Members

Public Methods

Public Method CleanAllAlerts | Removes all current alerts from the database.
Public Method DeleteAlert | Removes an alert or alerts related to the current object from the database.

Public Properties

Public Property Alert | Gets the Alert object for the alert with the specified ID.
Public Property AlertList | The list of user alerts.

See Also

IAlertManager Overview


%%PageItemTitle%% $$Members$$

IAmarillusHash Overview

IAmarillusHash Interface Members

Public Methods

Public Method GenerateHash Gets a Hash generated from the input value.

See Also

IAmarillusHash Overview


%%PageItemTitle%% $$Members$$

IAttachment Overview

IAttachment Interface Members

Public Methods

Public Method Load | Downloads an attachment file to a client machine.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Rename | Renames the attachment on the server. The attachment must be uploaded before calling this method.
Public Method Save | Uploads a file to the server.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AttachmentStorage | The ExtendedStorage object of this attachment. Applies only to file attachments.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Data | If the attachment is a file, an array of bytes. If a reference to file, the path or URL.
Public Property Description | The attachment description.
Public Property DirectLink | The link or path to the attachment.
Public Property Field | The value of the specified field.
Public Property FileName | If a file, the file location. If a virtual file, the location for the attachment before it is uploaded to the server. If a URL, the link address.
Public Property FileSize | The attachment file size in bytes.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property LastModified | The last modified time.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The attachment name.
Public Property ServerFileName | The attachment file name on the server machine.
Public Property Type | The attachment type. Either File or URL.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

IAttachment Overview


%%PageItemTitle%% $$Members$$

IAttachmentFactory Overview

IAttachmentFactory Interface Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method FactoryProperties | Gets the owner type and key for the AttachmentFactory object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property AttachmentStorage | The ExtendedStorage object for downloading and uploading attachment files.
Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

IAttachmentFactory Overview


%%PageItemTitle%% $$Members$$

IAuditable Overview

IAuditable Interface Members

Public Properties

Public Property AuditPropertyFactory | The AuditPropertyFactory object to handle AuditProperty objects for the changed object.
Public Property AuditRecordFactory | The AuditRecordFactory object to handle AuditRecords for the changed object.

See Also

IAuditable Overview


%%PageItemTitle%% $$Members$$

IAuditProperty Overview

IAuditProperty Interface Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Action | The database activity that caused creation of this record. For example, INSERT, UPDATE, or DELETE.
Public Property ActionID | The ID of the associated AuditRecord object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property EntityID | The ID of the entity that changed.
Public Property EntityType | The type of the entity that changed. For example, BUG, REQ.
Public Property Field | The value of the specified field.
Public Property FieldName | The database definition name of field that was changed.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property NewValue | The new value after the change.
Public Property OldValue | The value before the change.
Public Property PropertyName | The custom label for the field that was changed.
Public Property SessionID | The Quality Center Session ID under which the action was performed.
Public Property TableName | The database table in which the change was recorded.
Public Property Time | The time stamp of the change according to the database server clock.
Public Property UserName | The username of the user who performed the action.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

IAuditProperty Overview


%%PageItemTitle%% $$Members$$

IAuditPropertyFactory Overview

IAuditPropertyFactory Interface Members

Public Methods

Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

IAuditPropertyFactory Overview


%%PageItemTitle%% $$Members$$

IAuditRecord Overview | AuditProperty Object

IAuditRecord Interface Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Action | The name of the action that caused the tracked change.
Public Property ActionID | The ID of the AuditRecord.
Public Property AuditPropertyFactory | The AuditPropertyFactory Object for the current AuditRecord.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Description | The description of the audited change.
Public Property EntityID | The ID of the entity that changed.
Public Property EntityType | The type of the entity that changed.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property SessionID | The Quality Center Session ID under which the action was performed.
Public Property Time | The time stamp of the change according to the database server clock.
Public Property UserName | The username of the user who performed the action.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

IAuditRecord Overview | AuditProperty Object


%%PageItemTitle%% $$Members$$

IAuditRecordFactory Overview

IAuditRecordFactory Interface Members

Public Methods

Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

IAuditRecordFactory Overview


%%PageItemTitle%% $$Members$$

IBaseFactory2 Overview

IBaseFactory2 Interface Members

Public Properties

Public Property GroupingManager | The GroupingManager for this factory.
Public Property GroupingSupported | Check whether the factory supports grouping.

See Also

IBaseFactory2 Overview


%%PageItemTitle%% $$Members$$

IBaseFactory Overview

IBaseFactory Interface Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

IBaseFactory Overview


%%PageItemTitle%% $$Members$$

IBaseFactoryEx Overview

IBaseFactoryEx Interface Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method Mail | Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

IBaseFactoryEx Overview


%%PageItemTitle%% $$Members$$

IBaseField2 Overview

IBaseField2 Interface Members

Public Properties

Public Property AutoUnlock | Indicates whether to make the item changeable to other users automatically after a Refresh or Post.
Public Property FieldMultiValue | The MultiValue object of the specified field.

See Also

IBaseField2 Overview


%%ItemTitle%%

OTA COM Type Library

Getting and assigning multiple values for a Bug record

Source code

Sub MultiBugFieldValues(bugObject As Bug, theField As String)
    Dim BugBaseField2 As IBaseField2
    Dim MultiV As MultiValue
    Dim MVList As TDAPIOLELib.list
    Dim aVal As Variant
' Cast the Bug object to get an IBaseField2 reference
' from which to get the MultiValue object
    Set BugBaseField2 = bugObject
    Set MultiV = BugBaseField2.FieldMultiValue(theField)
'Get the Text
    Debug.Print MultiV.Text
    ' Emma;Mansfield Park;Northanger Abbey
    '
'Get the List
    Set MVList = MultiV.list
    For Each aVal In MVList
        Debug.Print aVal
        ' Emma
        ' Mansfield Park
        ' Northanger Abbey
    Next
'Enter new values in the MultiValue object
    MultiV.Text = "Sense and Sensibility;Pride and Predjudice;Persuasion"
'Use the MultiValue object to assign the new values to the bug record.
    BugBaseField2.FieldMultiValue(theField) = MultiV
    bugObject.Post
    Debug.Print
'Get the modified list
    For Each aVal In MVList
        Debug.Print aVal
        ' Persuasion
        ' Pride and Predjudice
        ' Sense and Sensibility
    Next
End Sub


%%PageItemTitle%% $$Members$$

IBaseField3 Overview

IBaseField3 Interface Members

Public Methods

Public Method Post Writes all changed values to database.

See Also

IBaseField3 Overview


%%PageItemTitle%% $$Members$$

IBaseField Overview

IBaseField Interface Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

IBaseField Overview


%%PageItemTitle%% $$Members$$

IBaseFieldEx Overview

IBaseFieldEx Interface Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

IBaseFieldEx Overview


%%PageItemTitle%% $$Members$$

IBaseFieldExMail Overview

IBaseFieldExMail Interface Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Mail | Mails the IBaseFieldExMail field item.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

IBaseFieldExMail Overview


%%PageItemTitle%% $$Members$$

IBPComponent Overview

IBPComponent Interface Members

Public Methods

Public Method AddIteration | Adds an Iteration to the BPComponent.
Public Method DeleteIteration | Delete the specified BPIteration from the BPComponent.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property BPParams | The list of the BPComponents parameters.
Public Property Component | Get the Component object from which this BPComponent was created.
Public Property FailureCondition | Indicates the behavior of the business process test if this component fails.
Public Property Field | The value of the specified field.
Public Property Group | The BPGroup to which this component belongs.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Iterations | The list of the BPComponents Iterations.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The name of the component from which this BPComponent was created.
Public Property Order | The position of the BPComponent in the BusinessProcess (1-based).
Public Property Test | The parent business process test.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

IBPComponent Overview


%%PageItemTitle%%

IBPComponent Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

The results of calling the Post method are indeterminate. Use BusinessProcess.Save rather than Post.

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IBPComponent Interface


%%PageItemTitle%% $$Members$$

IBPGroup Overview

IBPGroup Interface Members

Public Methods

Public Method AddBPComponent | Adds the specified business component to the group.
Public Method BPComponents | The list of the BPComponents that belong to the group.
Public Method DeleteBPComponent | Removes the specified business component from the group.

Public Properties

Public Property ID The group ID.

See Also

IBPGroup Overview


%%PageItemTitle%% $$Members$$

IBPIteration Overview

IBPIteration Interface Members

Public Methods

Public Method AddParam | Add the specified BPParameter Object to the iteration.
Public Method DeleteIterationParams | Delete all the parameters from the iteration.
Public Method DeleteParam | Delete the specified BPParameter from the iteration.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property BPComponent | The BPComponent object of which this an iteration.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property IterationParams | The list of BPIterationParam objects associated with this iteration.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Order | The 0-based execution position of this iteration in the set of iterations of this component.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

IBPIteration Overview


%%PageItemTitle%% $$Members$$

IBPIterationParam Overview

IBPIterationParam Interface Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property BPParameter | The BPParameter object of which this is an instance.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Value | The value of the parameter for this iteration.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

IBPIterationParam Overview


%%PageItemTitle%%

IBPIterationParam Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

The results of calling the Post method are indeterminate. Use BusinessProcess.Save rather than Post.

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IBPIterationParam Interface


%%PageItemTitle%%

IBPIteration Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

The results of calling the Post method are indeterminate. Use BusinessProcess.Save rather than Post.

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IBPIteration Interface


%%PageItemTitle%% $$Members$$

IBPParam Overview

IBPParam Interface Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property BPComponent | The BPComponent object to which this parameter belongs.
Public Property ComponentParam | The ComponentParam object from which this BPParam was created.
Public Property ComponentParamIsOut | Indicates if the ComponentParam from which this BPParam was created is an output parameter. If False, it is an input parameter.
Public Property ComponentParamName | The name of the ComponentParam object from which this BPParam was created.
Public Property ComponentParamOrder | The position of the ComponentParam object from which this BPParam was created.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Reference | The output BPParameter object that is the source of the value for this parameter.
Public Property Type | The parameter type.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

IBPParam Overview


%%PageItemTitle%%

IBPParam Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

The results of calling the Post method are indeterminate. Use BusinessProcess.Save rather than Post.

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IBPParam Interface


%%PageItemTitle%% $$Members$$

IBPStepParam Overview

IBPStepParam Interface Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The name of this parameter.
Public Property ReferencedParamID | The parameter ID of the referenced parameter.
Public Property StepID | The ID of the step in which this parameter occurs.
Public Property Type | The parameter type.
Public Property Value | The value of this parameter.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

IBPStepParam Overview


%%PageItemTitle%%

IBPStepParam Interface

Post Method

Description

Posts all changed values into database.

Syntax

Public Sub Post()

Remarks

The results of calling the Post method are indeterminate. Use BusinessProcess.Save rather than Post.

Call Post after creating or changing an object and before the object is released. Objects are released in many ways, for example: by going out of scope, by ending the connection, or by being explicitly released in your code.

Objects of classes that implement IBaseField2 have an AutoUnlock property. If AutoUnlock is true the object is unlocked on a Post operation. If AutoUnlock is false, the object remains locked from the call to LockObject until a call to UnlockObject or until the connection is logged off the project.

By default, AutoUnlock is true.

See Also

IBPStepParam Interface


%%PageItemTitle%% $$Members$$

IBug Overview

IBug Interface Members

Public Methods

Public Method FindSimilarBugs | Searches the defect summaries for similarities to this defect.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Mail | Mails the IBaseFieldExMail field item.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AssignedTo | The name of the user to whom the defect is assigned.
Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property DetectedBy | The name of the user who detected the defect.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Priority | The defect priority.
Public Property Project | The testing project to which the defect belongs.
Public Property Status | The defect status.
Public Property Summary | A short description of the defect.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

IBug Overview


%%PageItemTitle%% $$Members$$

IBugFactory Overview

IBugFactory Interface Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method BuildAgeGraph | Creates a graph that shows the lifetime of defects.
Public Method BuildProgressGraph | Creates a graph showing status at specific points: either defect accumulation or time to fix (estimated or actual).
Public Method BuildSummaryGraph | Creates a summary graph either of the number of defects or the time to fix (estimated or actual).
Public Method BuildTrendGraph | Creates a graph that shows the history of changes to specific Defect fields for each time interval displayed.
Public Method FindSimilarBugs | Searches defect summaries and descriptions for matches to Pattern.
Public Method Mail | Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

IBugFactory Overview


%%PageItemTitle%% $$Members$$

IBusinessProcess Overview

IBusinessProcess Interface Members

Public Methods

Public Method AddBPComponent | Adds the specified Component to the test.
Public Method AddGroup | Adds an empty group of components to the test.
Public Method AddRTParam | Adds a runtime parameter to the test.
Public Method CancelDownloadPictures | Cancels the download of the test component's pictures.
Public Method CoverRequirement | Adds the specified requirement to the list of requirements covered by this test.
Public Method DeleteBPComponent | Delete the specified BPComponent from the test.
Public Method DeleteGroup | Delete the specified BPGroup from the test.
Public Method DeleteRTParam | Delete the given RTParam from the test.
Public Method DownloadPictures | Download the snapshots attached to the components of the test to the clients cache.
Public Method DownloadPicturesProgress | Reports the status of DownloadPictures.
Public Method GetCoverList | Gets the list of all requirements covered by this test.
Public Method Load | Loads the BusinessProcess object and all of its dependencies into memory.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Mail | Mails the IBaseFieldExMail field item.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method RemoveCoverage | Removes a requirement from the list of requirements this test covers.
Public Method Save | Saves the BusinessProcess object and all of its dependencies.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property BPComponentByID | Gets a BPComponent from the test by its ID.
Public Property BPComponents | The list of BPComponents that belong to the test.
Public Property BPTHistory | The test's history object.
Public Property CheckoutPathIfExist | The checkout path for the test.
Public Property DesignStepFactory | The design steps factory for the current test.
Public Property DesStepsNum | The number of design steps in the test.
Public Property ExecDate | The test execution date and time.
Public Property ExecStatus | The test execution status.
Public Property ExtendedStorage | The Extended Storage object for the current test.
Public Property Field | The value of the specified field.
Public Property FullPath | The full file system path for the test.
Public Property GroupByID | Gets a BPGroup from the test by its ID.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property HasCoverage | Checks if the test covers at least one requirement.
Public Property HasParam | Checks if the test has at least one parameter.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property LastRun | The last Run object for this test.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The test name.
Public Property Params | The current test parameters.
Public Property RTParameters | The list of run time parameters for the test.
Public Property TemplateTest | Indicates if this test is a template test.
Public Property Type | The test type.
Public Property VCS | The VCS version control object for this test.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

IBusinessProcess Overview


%%PageItemTitle%% $$Members$$

IColumnInfo Overview

IColumnInfo Interface Members

Public Properties

Public Property ColCount | Gets the number of columns in the current Recordset object.
Public Property ColIndex | Gets the index (zero-based) of a Recordset column specified by column name.
Public Property ColName | The name of the Recordset column specified by Index (zero-based).
Public Property ColSize | The physical size as defined in the database of the fields in the column specified by Index (zero-based).
Public Property ColType | The data type of column.

See Also

IColumnInfo Overview


%%PageItemTitle%% $$Members$$

ICommand Overview

ICommand Interface Members

Public Methods

Public Method AddParam | Adds new parameter to Command object.
Public Method DeleteParam | Deletes the specified parameter from Command object.
Public Method DeleteParams | Deletes all parameters from Command object.
Public Method Execute | Executes the command in the CommandText property.

Public Properties

Public Property AffectedRows | The number of table rows that were affected by the command.
Public Property CommandText | The text of the command.
Public Property Count | Number of parameters in current command.
Public Property IndexFields | A comma-separated list of index fields for a SELECT command.
Public Property ParamIndex | The parameter index by parameter name.
Public Property ParamName | The parameter name by parameter index. The index is 0-based.
Public Property ParamType | The data type of the specified parameter. The index is 0-based.
Public Property ParamValue | The parameter value.

See Also

ICommand Overview


%%PageItemTitle%% $$Members$$

IComponent Overview

IComponent Interface Members

Public Methods

Public Method BusinessProcesses | The list of associated BusinessProcess objects.
Public Method DeletePicture | Deletes the snapshot.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property ApplicationAreaID | The Component's linked application area ID.
Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property ComponentParamFactory | The component parameter factory.
Public Property ComponentStepFactory | The ComponentStepFactory for this component
Public Property ExtendedStorage | The ExtendedStorage object for this component.
Public Property Field | The value of the specified field.
Public Property Folder | The component's folder.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property HasPicture | Indicates if the component has a snapshot.
Public Property HasScript | Checks if the component is associated with a test script.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property IsObsolete | Checks if the component has been marked deleted by a user but is still in use in a test.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The Component's name.
Public Property ScriptType | The test script type.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

IComponent Overview


%%PageItemTitle%% $$Members$$

IComponentFactory Overview

IComponentFactory Interface Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method IsComponentNameValid | Checks if the specified name is a valid name for a business component.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

IComponentFactory Overview


%%PageItemTitle%% $$Members$$

IComponentFolder Overview

IComponentFolder Interface Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property ComponentFactory | The ComponentFactory object.
Public Property ComponentFolderFactory | The component's ComponentFolderFactory.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The component's folder name
Public Property Path | The component folder's path
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

IComponentFolder Overview


%%PageItemTitle%% $$Members$$

IComponentFolderFactory Overview

IComponentFolderFactory Interface Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method FolderByPath | Gets a ComponentFolder by its path
Public Method FolderPath | Gets the path of the specified folder.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method Obsolete | Gets the Obsolete Components folder.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.
Public Method Root | Gets the business components root folder.
Public Method Templates | Gets the Templates folder (Quick Test only).

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

IComponentFolderFactory Overview


%%PageItemTitle%% $$Members$$

IComponentParam Overview

IComponentParam Interface Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Component | The Component containing the parameter.
Public Property Desc | The parameter description.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property IsOut | Indicates if this is an output parameter. If False, this is an input parameter.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The component parameter's name.
Public Property Order | The position of the parameter in the set of parameters of the same component.
Public Property Value | The parameter's default value.
Public Property ValueType | The parameter type. For example Date, String, number, etc.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

IComponentParam Overview


%%PageItemTitle%% $$Members$$

IComponentStep Overview

IComponentStep Interface Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.
Public Method Validate | Validate the step.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Order | The 1-based position of the step in the order of execution of the steps of the component.
Public Property Parent | The parent Component
Public Property StepDescription | The description of the step.
Public Property StepExpectedResult | The expected result of the step.
Public Property StepName | The component step name.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

IComponentStep Overview


%%PageItemTitle%% $$Members$$

ICondition Overview

ICondition Interface Members

Public Properties

Public Property Description | The Condition description.
Public Property ID | The Condition ID.
Public Property Source | For a run condition, the source condition ID. For a time condition, a date-time string.
Public Property Target | The target test instance number of the condition.
Public Property Value | The Condition status value.

See Also

ICondition Overview


%%PageItemTitle%% $$Members$$

IConditionFactory Overview

IConditionFactory Interface Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.
Public Method Save | Saves all conditions.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

IConditionFactory Overview


%%PageItemTitle%% $$Members$$

ICoverable Overview

ICoverable Interface Members

Public Methods

Public Method CoverRequirementEx Adds the specified requirement to the list of requirements covered by this entity. Optionally, also adds child requirements.

Public Properties

Public Property CoverageFactory The CoverageFactory for the entity.

See Also

ICoverable Overview


%%PageItemTitle%% $$Members$$

ICoverableReq Overview

ICoverableReq Interface Members

Public Methods

Public Method AddSubjectToCoverage | Adds the tests from the specified subject that match the input filter to the list of tests that cover the current requirement.
Public Method AddTestInstanceToCoverage | Adds the test instance to the list of test instances that cover the current requirement.
Public Method AddTestsFromTestSetToCoverage | Adds the test instances from the specified test set that match the input filter to the list of test instances that cover the current requirement.
Public Method AddTestToCoverage | Adds the test to the list of tests that cover the current requirement.

Public Properties

Public Property RequirementCoverageFactory Get Requirement Coverage Factory

See Also

ICoverableReq Overview


%%ItemTitle%%

OTA COM Type Library

Add test plan folder to coverage

Source code

Private Sub AddTestPlanFolderToCoverage(reqid As Integer, FolderId As Integer)
'Add test plan folder to coverage
    Dim coverable As ICoverableReq
    Dim reqF As reqFactory
    Dim req As req
    Set reqF = tdc.reqFactory
    Set req = reqF.Item(reqid)
    Set coverable = req
    coverable.AddSubjectToCoverage FolderId, ""
    Set coverable = Nothing
    Set reqF = Nothing
    Set req = Nothing
End Sub


%%ItemTitle%%

OTA COM Type Library

Add tests to requirement coverage

Source code

Private Sub AddTestToCoverage(reqid As Integer, TestID As Integer)
'Add tests to requirement coverage
    Dim coverable As ICoverableReq
    Dim reqF As reqFactory
    Dim req As req
    Set reqF = tdc.reqFactory
    Set req = reqF.Item(reqid)
    Set coverable = req
    coverable.AddTestToCoverage TestID
    Set coverable = Nothing
    Set reqF = Nothing
    Set req = Nothing
End Sub


%%PageItemTitle%% $$Members$$

ICoverageEntity Overview

ICoverageEntity Interface Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property CoverageType | The type of coverage. For example, Test or TSTest.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The name of the TargetEntity.
Public Property RequirementEntity | The Req object being covered.
Public Property Status | The execution result status of the TargetEntity.
Public Property TargetEntity | The entity object that covers the requirement.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

ICoverageEntity Overview


%%PageItemTitle%% $$Members$$

ICoverageFactory Overview

ICoverageFactory Interface Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

ICoverageFactory Overview


%%PageItemTitle%% $$Members$$

ICustomization2 Overview

ICustomization2 Interface Members

Public Methods

Public Method Commit | Posts all customization data changes to the project database.
Public Method Load | Loads all customization data from the server into the client cache. This includes actions, fields, lists, modules, permissions, users, and user groups.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Rollback | Discards unsaved changes to properties and child objects.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Actions | The CustomizationActions object.
Public Property ExtendedUDFSupport | Checks if the program can use the maximum allowable user-defined fields (99 user-defined fields and 3 memo fields).
Public Property Fields | The CustomizationFields object.
Public Property IsChanged | Checks if there has been at least one change to a property or child object that has not been saved.
Public Property IsLocked | Checks if object is locked.
Public Property Lists | The CustomizationLists object.
Public Property MailConditions | The CustomizationMailConditions Object.
Public Property Modules | The CustomizationModules object.
Public Property Permissions | The CustomizationPermissions object.
Public Property Users | The CustomizationUsers object.
Public Property UsersGroups | The CustomizationUsersGroups object.

See Also

ICustomization2 Overview


%%PageItemTitle%% $$Members$$

ICustomization3 Overview

ICustomization3 Interface Members

Public Methods

Public Method Commit | Posts all customization data changes to the project database.
Public Method Load | Loads all customization data from the server into the client cache. This includes actions, fields, lists, modules, permissions, users, and user groups.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Rollback | Discards unsaved changes to properties and child objects.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Actions | The CustomizationActions object.
Public Property CustomizableEntitiesTables | Returns the list of the customizable entities' table names.
Public Property EntityDataTables | Returns the names of the data tables that have a user label defined as comma-separated pairs of table names and user labels.
Public Property ExtendedUDFSupport | Checks if the program can use the maximum allowable user-defined fields (99 user-defined fields and 3 memo fields).
Public Property Fields | The CustomizationFields object.
Public Property IsChanged | Checks if there has been at least one change to a property or child object that has not been saved.
Public Property IsLocked | Checks if object is locked.
Public Property Lists | The CustomizationLists object.
Public Property MailConditions | The CustomizationMailConditions Object.
Public Property Modules | The CustomizationModules object.
Public Property Permissions | The CustomizationPermissions object.
Public Property RBT | Returns the CustomizationRBT object.
Public Property Types | Returns the CustomizationTypes object.
Public Property Users | The CustomizationUsers object.
Public Property UsersGroups | The CustomizationUsersGroups object.

See Also

ICustomization3 Overview


%%PageItemTitle%% $$Members$$

ICustomization Overview

ICustomization Interface Members

Public Methods

Public Method Commit | Posts all customization data changes to the project database.
Public Method Load | Loads all customization data from the server into the client cache. This includes actions, fields, lists, modules, permissions, users, and user groups.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Actions | The CustomizationActions object.
Public Property ExtendedUDFSupport | Checks if the program can use the maximum allowable user-defined fields (99 user-defined fields and 3 memo fields).
Public Property Fields | The CustomizationFields object.
Public Property IsLocked | Checks if object is locked.
Public Property Lists | The CustomizationLists object.
Public Property MailConditions | The CustomizationMailConditions Object.
Public Property Modules | The CustomizationModules object.
Public Property Permissions | The CustomizationPermissions object.
Public Property Users | The CustomizationUsers object.
Public Property UsersGroups | The CustomizationUsersGroups object.

See Also

ICustomization Overview


%%PageItemTitle%% $$Members$$

ICustomizationAction Overview

ICustomizationAction Interface Members

Public Methods

Public Method AddGroup | Adds a user group to the list of user groups for which the current action is allowed.
Public Method RemoveGroup | Removes the specified user group from the list of groups for which the current action is allowed.

Public Properties

Public Property Groups | A list of the user groups for which the current action is allowed.
Public Property IsGroupPermited | Checks if the group specified by the Group parameter has permission to perform the current action.
Public Property IsOwnerGroup | Checks if the user group specified by the Group parameter is the owner of the current action.
Public Property IsUserPermited | Checks if the user specified by the User parameter is permitted to perform the current action.
Public Property Name | The name of the action.
Public Property OwnerGroup | The user group that owns the action.
Public Property Updated | Indicates if the object has been modified since last synchronized with server.

See Also

ICustomizationAction Overview


%%PageItemTitle%% $$Members$$

ICustomizationActions Overview

ICustomizationActions Interface Members

Public Properties

Public Property Action | The CustomizationAction object representing the action specified by Name.
Public Property Actions | The list of CustomizationAction objects.

See Also

ICustomizationActions Overview


%%PageItemTitle%% $$Members$$

ICustomizationField2 Overview

ICustomizationField2 Interface Members

Public Properties

Public Property AuthorizedModifyForGroups | The list of groups whose members can modify this field.
Public Property AuthorizedOwnerSensibleForGroups | The list of CustomizationUsersGroup objects of the groups for which only the owner can modify the field.
Public Property AuthorizedVisibleForGroups | The list of CustomizationUsersGroup objects of the groups for which the field is visible in customization dialogs.
Public Property AuthorizedVisibleInNewBugForGroups | The list of CustomizationUsersGroup objects of the groups for which the field is visible in the new defect dialog.
Public Property CanMakeMultiValue | Checks if the field can be configured to store multiple values. If False, IsMultiValue cannot be set to True.
Public Property CanMakeSearchable | Checks if search can be enabled for the field.
Public Property ColumnName | The column name.
Public Property ColumnType | The database column type: char, date, memo, number, or time.
Public Property DefaultValue | The default value of the field.
Public Property EditMask | The input mask for string fields.
Public Property FieldSize | The size of the field in the database. For BLOB fields, the size is -1.
Public Property GrantModifyForGroup | Indicates whether members of the group can change the value of this field.
Public Property GrantModifyMask | The bit mask that indicates which user groups can modify the field.
Public Property IsActive | Indicates if the field is active. Inactive user-defined fields are not visible in the user interface.
Public Property IsByCode | Indicates if the field stores the Tree Node ID, rather than the passed value.
Public Property IsCanGroup | Indicates if items of this type can form groups with others of the same type.
Public Property IsCustomizable | Indicates if the field is displayed in the customization user interface.
Public Property IsEdit | Indicates if the field can be edited.
Public Property IsHistory | Indicates if change history is stored for the field.
Public Property IsMail | Indicates if Users on the list to be notified of changes are notified when this field is changed.
Public Property IsMultiValue | Indicates whether the field can store more than one value.
Public Property IsRequired | Checks if the field is required.
Public Property IsSearchable | Indicates whether the content of the field is searched by the Search method.
Public Property IsTransitionLogic | Indicates if the field has transition logic.
Public Property IsVerify | Indicates if the field requires verification.
Public Property IsVirtual | Checks if the field has a physical representation in the database. If True, there is no physical representation.
Public Property IsVisibleInNewBug | Indicates if the field is visible for the specified groups in a new defect form.
Public Property List | The CustomizationList assigned to the field.
Public Property NewCreated | Indicates if the field was created but not posted to the server.
Public Property OwnerSensibleForGroup | Indicates whether the field can be modified by the owner if the owner belongs to the specified group.
Public Property OwnerSensibleMask | The bit mask that indicates for which groups this field can be modified only by its owner.
Public Property RootId | If the field contains a list, the ID of the list root node. If not, RootId is NULL.
Public Property TableName | The name of the table that stores the active field.
Public Property Type | The Field type.
Public Property Updated | Indicates if the object has been modified since the last download from the server.
Public Property UserColumnType | The user column type: char, number, date, memo, or empty string.
Public Property UserLabel | A user-defined field label.
Public Property VersionControl | Indicates if the field is under version control.
Public Property VisibleForGroup | Indicates whether the field is visible in the New Defect dialog to the specified group.
Public Property VisibleForGroups | The bit mask that indicates which user groups can see this field.
Public Property VisibleInNewBugForGroup | Indicates whether the field is visible to the specified group in the new defect dialog.

See Also

ICustomizationField2 Overview


%%PageItemTitle%%

ICustomizationField2 Interface

OwnerSensibleMask Property

Description

The bit mask that indicates for which groups this field can be modified only by its owner.

Property type

Read-write property

Syntax (Visual Basic)

Public Property OwnerSensibleMask() As Long

Remarks

This is an unsafe method of setting this property, and is supported only for backward compatibility.

Use the CustomizationPermissions Object, instead.

Owner Sensibility is the property of a field that determines whether the field can be modified by its owner .
OwnerSensibleMask controls for which groups Owner Sensibility is applies. A user belonging to a group with Owner Sensibility turned on can only change the field if that user owns the entity.
The owner of a field is the owner of the entity to which the field belongs. Each entity type has it's own rule defining the entity owner. For example, by default a Bug's owner is the user whose name appears in the 'Assigned To' field.
It's possible to change the owner definition by changing TB_OWNER_FIELD_NAME for the corresponding entry in the TABLES table.

See Also

ICustomizationField2 Interface


%%PageItemTitle%%

ICustomizationField2 Interface

VisibleForGroups Property

Description

The bit mask that indicates which user groups can see this field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property VisibleForGroups() As Long

Remarks

This is an unsafe method of setting this property, and is supported only for backward compatibility.

Use the CustomizationPermissions Object, instead.

See Also

ICustomizationField2 Interface


%%PageItemTitle%% $$Members$$

ICustomizationField Overview

ICustomizationField Interface Members

Public Properties

Public Property ColumnName | The column name.
Public Property ColumnType | The database column type: char, date, memo, number, or time.
Public Property DefaultValue | The default value of the field.
Public Property EditMask | The input mask for string fields.
Public Property FieldSize | The size of the field in the database. For BLOB fields, the size is -1.
Public Property GrantModifyMask | The bit mask that indicates which user groups can modify the field.
Public Property IsActive | Indicates if the field is active. Inactive user-defined fields are not visible in the user interface.
Public Property IsByCode | Indicates if the field stores the Tree Node ID, rather than the passed value.
Public Property IsCustomizable | Indicates if the field is displayed in the customization user interface.
Public Property IsEdit | Indicates if the field can be edited.
Public Property IsHistory | Indicates if change history is stored for the field.
Public Property IsMail | Indicates if Users on the list to be notified of changes are notified when this field is changed.
Public Property IsRequired | Checks if the field is required.
Public Property IsTransitionLogic | Indicates if the field has transition logic.
Public Property IsVerify | Indicates if the field requires verification.
Public Property IsVisibleInNewBug | Indicates if the field is visible for the specified groups in a new defect form.
Public Property List | The CustomizationList assigned to the field.
Public Property NewCreated | Indicates if the field was created but not posted to the server.
Public Property OwnerSensibleMask | The bit mask that indicates for which groups this field can be modified only by its owner.
Public Property RootId | If the field contains a list, the ID of the list root node. If not, RootId is NULL.
Public Property TableName | The name of the table that stores the active field.
Public Property Type | The Field type.
Public Property Updated | Indicates if the object has been modified since the last download from the server.
Public Property UserColumnType | The user column type: char, number, date, memo, or empty string.
Public Property UserLabel | A user-defined field label.
Public Property VersionControl | Indicates if the field is under version control.
Public Property VisibleForGroups | The bit mask that indicates which user groups can see this field.

See Also

ICustomizationField Overview


%%PageItemTitle%% $$Members$$

ICustomizationFields Overview

ICustomizationFields Interface Members

Public Methods

Public Method AddActiveField | Finds the first free, inactive field in the specified table, signs the field as active, and returns the CustomizationFields object representing the field.
Public Method AddActiveMemoField | Creates a new memo field in a table.

Public Properties

Public Property Field | The customization field object for the specified database table and field.
Public Property FieldExists | Checks if the specified database field exists.
Public Property Fields | A list of all fields in the specified table.

See Also

ICustomizationFields Overview


%%PageItemTitle%%

ICustomizationField Interface

OwnerSensibleMask Property

Description

The bit mask that indicates for which groups this field can be modified only by its owner.

Property type

Read-write property

Syntax (Visual Basic)

Public Property OwnerSensibleMask() As Long

Remarks

This is an unsafe method of setting this property, and is supported only for backward compatibility.

Use the CustomizationPermissions Object, instead.

Owner Sensibility is the property of a field that determines whether the field can be modified by its owner .
OwnerSensibleMask controls for which groups Owner Sensibility is applies. A user belonging to a group with Owner Sensibility turned on can only change the field if that user owns the entity.
The owner of a field is the owner of the entity to which the field belongs. Each entity type has it's own rule defining the entity owner. For example, by default a Bug's owner is the user whose name appears in the 'Assigned To' field.
It's possible to change the owner definition by changing TB_OWNER_FIELD_NAME for the corresponding entry in the TABLES table.

See Also

ICustomizationField Interface


%%PageItemTitle%%

ICustomizationField Interface

VisibleForGroups Property

Description

The bit mask that indicates which user groups can see this field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property VisibleForGroups() As Long

Remarks

This is an unsafe method of setting this property, and is supported only for backward compatibility.

Use the CustomizationPermissions Object, instead.

See Also

ICustomizationField Interface


%%PageItemTitle%% $$Members$$

ICustomizationList Overview

ICustomizationList Interface Members

Public Methods

Public Method Find Finds a CustomizationListNode of the current list by the node name or ID.

Public Properties

Public Property Deleted | If true, the node is marked for deletion, but the deletion is not yet committed.
Public Property Name | The name of the list.
Public Property RootNode | The root CustomizationListNode of the current list.

See Also

ICustomizationList Overview


%%PageItemTitle%% $$Members$$

ICustomizationListNode Overview

ICustomizationListNode Interface Members

Public Methods

Public Method AddChild | Adds a new sub-node to the current node.
Public Method RemoveChild | Removes the specified sub-node from the current node.

Public Properties

Public Property CanAddChild | Checks if sub-nodes can be added to the current node.
Public Property Child | Gets the specified sub-node.
Public Property Children | The list of CustomizationListNode objects that are sub-nodes of the current node.
Public Property ChildrenCount | The number of sub-nodes under the node.
Public Property Deleted | If true, the node is marked for deletion, but the deletion is not yet committed.
Public Property Father | Gets the CustomizationListNode object representing the current node's parent node, or sets a new father, thereby moving the node.
Private Property ID | The current node ID.
Public Property List | The CustomizationList object that contains the current node.
Public Property Name | The current node name.
Public Property Order | The order number of the node within its siblings.
Public Property ReadOnly | Checks if the current node is read-only.
Public Property Updated | Indicates if the node was modified since it was loaded from the server.

See Also

ICustomizationListNode Overview


%%PageItemTitle%% $$Members$$

ICustomizationLists Overview | CustomizationList Object

ICustomizationLists Interface Members

Public Methods

Public Method AddList | Adds a new CustomizationList object.
Public Method RemoveList | Removes a CustomizationList object.

Public Properties

Public Property Count | The number of lists in the CustomizationLists object.
Public Property IsListExist | Checks if the specified customization list exists.
Public Property List | Gets the CustomizationList specified by name or ID.
Public Property ListByCount | Gets the CustomizationList specified by its index number.

See Also

ICustomizationLists Overview | CustomizationList Object


%%PageItemTitle%% $$Members$$

ICustomizationMailCondition Overview

ICustomizationMailCondition Interface Members

Public Properties

Public Property ConditionText | The filter to determine when the notification is sent.
Public Property ConditionType | The type of condition.
Public Property Deleted | Indicates if the condition has been removed, but the deletion has not been posted to the server.
Public Property Name | The name of the mail recipient or the field containing the name.
Public Property Updated | Indicates if the condition object has changed locally since last synchronized with the server.

See Also

ICustomizationMailCondition Overview


%%PageItemTitle%% $$Members$$

ICustomizationMailConditions Overview

ICustomizationMailConditions Interface Members

Public Methods

Public Method AddCondition | Creates a new CustomizationMailCondition.
Public Method RemoveCondition | Deletes the specified CustomizationMailCondition.

Public Properties

Public Property Condition | Gets the CustomizationMailCondition specified by the name and type.
Public Property ConditionExist | Checks if the specified mail customization condition exists.
Public Property Conditions | Gets the list of CustomizationMailCondition objects.

See Also

ICustomizationMailConditions Overview


%%PageItemTitle%% $$Members$$

ICustomizationModules2 Overview

ICustomizationModules2 Interface Members

Public Properties

Public Property Description | The Module Description
Public Property GUID | The Module's globally unique ID.
Public Property IsVisibleForGroup | Indicates if the specified module is visible in the UI to the specified user group.
Public Property Name | The Module Name.
Public Property Visible | A bit-mask that indicates for which groups the module is visible in the user interface.
Public Property VisibleForGroups | The list of the user groups to which the specified module is visible in the UI.

See Also

ICustomizationModules2 Overview


%%PageItemTitle%% $$Members$$

ICustomizationModules3 Overview

ICustomizationModules3 Interface Members

Public Properties

Public Property Description | The Module Description
Public Property GUID | The Module's globally unique ID.
Public Property IsVisibleForGroup | Indicates if the specified module is visible in the UI to the specified user group.
Public Property Module | Returns the module specified by the module ID.
Public Property Modules | The list of project module IDs.
Public Property Name | The Module Name.
Public Property Visible | A bit-mask that indicates for which groups the module is visible in the user interface.
Public Property VisibleForGroups | The list of the user groups to which the specified module is visible in the UI.

See Also

ICustomizationModules3 Overview


%%PageItemTitle%% $$Members$$

ICustomizationModules Overview

ICustomizationModules Interface Members

Public Properties

Public Property Description | The Module Description
Public Property GUID | The Module's globally unique ID.
Public Property Name | The Module Name.
Public Property Visible | A bit-mask that indicates for which groups the module is visible in the user interface.

See Also

ICustomizationModules Overview


%%PageItemTitle%% $$Members$$

ICustomizationPermissions Overview

ICustomizationPermissions Interface Members

Public Properties

Public Property CanAddItem | Indicates if members of the specified group can add the specified type of entity.
Public Property CanAllowAttachment | Indicates if members owners of the specified group can handle the specified type of entity attachments.
Public Property CanModifyField | Indicates if members or owners of the specified group can modify the specified field.
Public Property CanModifyItem | Indicates if members of the specified group can modify the specified entity.
Public Property CanRemoveItem | Indicates if members or owners of the specified group can remove the specified type of entity.
Public Property CanUseOwnerSensible | Checks if the fields of the specified entity can be restricted for owner modifications only.
Public Property HasAttachmentField | Checks if the entity specified by the EntityName parameter can have attachments.
Public Property IsVisibleInNewBug | Indicates if the specified Bug field is visible for the specified group in a new defect form.
Public Property TransitionRules | The transition rules for the specified field and group.

See Also

ICustomizationPermissions Overview


%%PageItemTitle%% $$Members$$

ICustomizationRBT Overview

ICustomizationRBT Interface Members

Public Methods

Public Method AddBIQuestion | Creates a new Business Impact question.
Public Method AddFPQuestion | Creates a new Failure Probability question.
Public Method CalcBILevelByAnswersWeight | Calculate the business impact level from the sum of all the answers' weights.
Public Method CalcFPLevelByAnswersWeight | Calculate failure probability level ffrom the sum of all the answers' weights.
Public Method DeleteBIQuestion | Deletes the specified Business Impact question.
Public Method DeleteFPQuestion | Deletes the specified Failure Probability question.
Public Method TranslateBILevel | Translate BI from TDAPI_RBT_BI_LEVELS to its name in the database.
Public Method TranslateFPLevel | Translate FP from TDAPI_RBT_FP_LEVELS to its name in the database.
Public Method TranslateTestingLevel | Translate TL from TDAPI_RBT_TESTING_LEVELS to it's name in the database.

Public Properties

Public Property BILevelRiskLowerThreshold | The lower threshold of Risk assessment for each Business Impact level.
Public Property BIQuestionByID | Returns the Business Impact Question that has the specified ID.
Public Property BIQuestions | The list of Business Impact questions.
Public Property DisplayedTimeUnits | The time unit display string for calculations results.
Public Property FPLevelRiskLowerThreshold | The lower threshold of Risk assessment for each Failure Probability level.
Public Property FPLevelTestingEffortInHours | Hours needed to test a requirement with the given Failure Probability.
Public Property FPQuestionByID | Returns the Failure Probability Question that has the specified ID.
Public Property FPQuestions | The list of Failure Probability questions.
Public Property TestingLevelPercentage | Testing level percentage (of the full testing level).
Public Property TestingPolicyMatrix | Risk testing level matrix
Public Property Updated | Indicates if the RBT Customization has been modified since the last synchronization with the database.

See Also

ICustomizationRBT Overview


%%PageItemTitle%% $$Members$$

ICustomizationRBTAnswer Overview

ICustomizationRBTAnswer Interface Members

Public Properties

Public Property AnswerText | The answer's text.
Public Property AnswerWeight | The answer's weight.
Public Property ID | The CustomizationRBTAnswer unique ID.

See Also

ICustomizationRBTAnswer Overview


%%PageItemTitle%% $$Members$$

ICustomizationRBTQuestion Overview

ICustomizationRBTQuestion Interface Members

Public Methods

Public Method AddAnswer | Adds a new possible answer. Returns the new answer as a CustomizationRBTAnswer object
Public Method DeleteAnswer | Deletes a possible answer specified by id.

Public Properties

Public Property AnswerByID | Returns the specified Answer.
Public Property Answers | The IList of CustomizationRBTAnswer objects of all possible answers for this question.
Public Property ID | The CustomizationRBTQuestion unique ID.
Public Property QuestionDescription | The question's description.
Public Property QuestionOrder | The (non unique) question's order of display in UI.
Public Property QuestionText | The question's text.

See Also

ICustomizationRBTQuestion Overview


%%PageItemTitle%% $$Members$$

ICustomizationReqType Overview

ICustomizationReqType Interface Members

Public Methods

Public Method AddField | Adds a new CustomizationTypedField.
Public Method RemoveField | Removes the CustomizationTypedField specified by FieldName from this type.

Public Properties

Public Property Field | Gets the CustomizationTypedField specified by FieldName.
Public Property Fields | The list of CustomizationTypedField objects for this type.
Public Property HasDirectCoverage | Indicates if this requirement type supports direct coverage by tests or test instances.
Public Property Icon | The bitmap stream for type icon.
Public Property ID | The CustomizationType ID.
Public Property Name | The CustomizationType name.
Public Property RiskAnalysisType | The Type of the RBT Risk Analysis that is applicable to this requirement.

See Also

ICustomizationReqType Overview


%%PageItemTitle%% $$Members$$

ICustomizationTransitionRule Overview

ICustomizationTransitionRule Interface Members

Public Properties

Public Property DestinationValue | The destination value of the transition rule, that is, the value after the change.
Public Property SourceValue | The source value of the transition rule, that is, the value before the change.
Public Property Updated | Indicates if the object has been modified since last synchronized with server.

See Also

ICustomizationTransitionRule Overview


%%PageItemTitle%% $$Members$$

ICustomizationTransitionRules Overview | CustomizationTransitionRule Object

See Also OTA COM Type Library

ICustomizationTransitionRules Interface Members

Public Methods

Public Method AddTransitionRule | Adds a new CustomizationTransitionRule to the current object.
Public Method RemoveTransitionRule | Removes the specified transition rule from the current object.

Public Properties

Public Property Count | The number of CustomizationTransitionRule objects contained by the current object.
Public Property EntityName | The location (database table) of the field to which the transition rules in the current object are attached.
Public Property Field | The CustomizationField object to which the transition rules in the current object are attached.
Public Property Group | The CustomizationUsersGroup object to which the transition rules in the current object are attached.
Public Property TransitionRule | The CustomizationTransitionRule specified by its position in the list of transition rules.
Public Property Updated | Indicates if the object has been modified since the last synchronization with database.

See Also

ICustomizationTransitionRules Overview | CustomizationTransitionRule Object


%%PageItemTitle%% $$Members$$

ICustomizationType Overview

ICustomizationType Interface Members

Public Methods

Public Method AddField | Adds a new CustomizationTypedField.
Public Method RemoveField | Removes the CustomizationTypedField specified by FieldName from this type.

Public Properties

Public Property Field | Gets the CustomizationTypedField specified by FieldName.
Public Property Fields | The list of CustomizationTypedField objects for this type.
Public Property Icon | The bitmap stream for type icon.
Public Property ID | The CustomizationType ID.
Public Property Name | The CustomizationType name.

See Also

ICustomizationType Overview


%%PageItemTitle%% $$Members$$

ICustomizationTypedField Overview

ICustomizationTypedField Interface Members

Public Properties

Public Property Field | Gets the CustomizationField associated with this object.
Public Property IsRequired | Indicates whether the field is required for the specific type.
Public Property Type | Gets the CustomizationType associated with this object.

See Also

ICustomizationTypedField Overview


%%PageItemTitle%% $$Members$$

ICustomizationTypes Overview

ICustomizationTypes Interface Members

Public Methods

Public Method AddCustomizationType | Adds a new CustomizationType to the specified entity.
Public Method GetEntityCustomizationType | Gets the CustomizationType with the specified ID.
Public Method GetEntityCustomizationTypes | Gets the list of all CustomizationTypes for the specified entity.
Public Method RemoveCustomizationType | Removes the CustomizationType with the specified ID from the specified entity.

See Also

ICustomizationTypes Overview


%%PageItemTitle%% $$Members$$

ICustomizationUser Overview

ICustomizationUser Interface Members

Public Methods

Public Method AddToGroup | Adds this user to the specified user group.
Public Method GroupsList | The names of all the user groups to which this user belongs.
Public Method RemoveFromGroup | Removes this user from the specified user group.

Public Properties

Public Property Address | A text field that can be used to record user information as appropriate for the project.
Public Property Deleted | If true, this user is marked for deletion, but the deletion is not yet committed.
Public Property DomainAuthentication | The user credentials for LDAP authentication.
Public Property Email | The user's e-mail address.
Public Property FullName | The user's full name.
Public Property InGroup | Indicates if this user is a member of the specified group.
Public Property Name | A unique name by which to identify this user.
Public Property Password | Sets the user's password.
Public Property Phone | The user's telephone number.
Public Property Updated | Indicates if the user's data was updated since the last synchronization with the server.

See Also

ICustomizationUser Overview


%%PageItemTitle%% $$Members$$

ICustomizationUsers2 Overview

ICustomizationUsers2 Interface Members

Public Methods

Public Method AddSiteAuthenticatedUser | Adds site user with credentials for LDAP authentication.
Public Method AddSiteUser | Creates a new site user and adds it to the current project.
Public Method AddUser | Adds an existing site user to the current project.
Public Method RemoveUser | Removes a user from the collection.
Public Method UserExistsInSite | Checks whether the specified site user exists.

Public Properties

Public Property User | The CustomizationUser object representing the specified user.
Public Property Users | The list of customization users.

See Also

ICustomizationUsers2 Overview


%%PageItemTitle%% $$Members$$

ICustomizationUsers Overview

ICustomizationUsers Interface Members

Public Methods

Public Method AddSiteAuthenticatedUser | Adds site user with credentials for LDAP authentication.
Public Method AddSiteUser | Creates a new site user and adds it to the current project.
Public Method AddUser | Adds an existing site user to the current project.
Public Method RemoveUser | Removes a user from the collection.

Public Properties

Public Property User | The CustomizationUser object representing the specified user.
Public Property Users | The list of customization users.

See Also

ICustomizationUsers Overview


%%PageItemTitle%% $$Members$$

ICustomizationUsersGroup Overview

ICustomizationUsersGroup Interface Members

Public Methods

Public Method AddUser | Adds a new user to the user group.
Public Method RemoveUser | Removes a user from the user group.
Public Method UsersList | A list of all members of the user group.

Public Properties

Public Property Deleted | If true, the object is marked for deletion, but the deletion has not been committed.
Public Property HideFilter | The data hiding filter for the entity specified by the FilterType parameter.
Public Property ID | The user group Id.
Public Property IsSystem | Checks if the user group is a built-in system user group.
Public Property Name | The user group name.
Public Property Updated | Indicates if the object has been modified since being downloaded from database.

See Also

ICustomizationUsersGroup Overview


%%PageItemTitle%% $$Members$$

ICustomizationUsersGroups2 Overview

ICustomizationUsersGroups2 Interface Members

Public Methods

Public Method AddGroup | Adds a new CustomizationUsersGroup to the collection.
Public Method IsNameValid | Checks whether another group has the specified name.
Public Method RemoveGroup | Removes a CustomizationUsersGroup object.

Public Properties

Public Property Group | Gets the specified user group.
Public Property Groups | The list of CustomizationUsersGroup objects.

See Also

ICustomizationUsersGroups2 Overview


%%PageItemTitle%% $$Members$$

ICustomizationUsersGroups Overview

ICustomizationUsersGroups Interface Members

Public Methods

Public Method AddGroup | Adds a new CustomizationUsersGroup to the collection.
Public Method RemoveGroup | Removes a CustomizationUsersGroup object.

Public Properties

Public Property Group | Gets the specified user group.
Public Property Groups | The list of CustomizationUsersGroup objects.

See Also

ICustomizationUsersGroups Overview


%%PageItemTitle%% $$Members$$

ICycle Overview

ICycle Interface Members

Public Methods

Public Method DaysLeft | Returns the number of days until the scheduled end of the cycle.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Mail | Mails the IBaseFieldExMail field item.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property EndDate | The cycle's end date.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The cycle's name.
Public Property Parent | The cycle's parent release.
Public Property ReleaseManagementInfo | Returns the cycle information.
Public Property StartDate | The cycle's start date.
Public Property Status | The cycle's status.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

ICycle Overview


%%PageItemTitle%% $$Members$$

ICycleFactory Overview

ICycleFactory Interface Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method BuildCoverageGraph | Builds release cycle coverage graph.
Public Method Mail | Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

ICycleFactory Overview


%%PageItemTitle%% $$Members$$

IDesignStep Overview

IDesignStep Interface Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property EvaluatedStepDescription | The design step description.
Public Property EvaluatedStepExpectedResult | The design step expected result string.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property LinkedParams | The linked test parameters.
Public Property LinkTest | A template test to be linked to the design step.
Public Property LinkTestID | The ID of the linked test.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Order | The order of the design step in the test procedure.
Public Property ParentTest | The test object to which the design step belongs.
Public Property StepDescription | The description of the design step.
Public Property StepExpectedResult | The expected results of the step.
Public Property StepName | The design step name.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

IDesignStep Overview


%%PageItemTitle%% $$Members$$

IExecEventInfo Overview

IExecEventInfo Interface Members

Public Properties

Public Property EventDate | The Execution Event Date.
Public Property EventTime | The Execution Event Time.
Public Property EventType | The type of Execution Event.

See Also

IExecEventInfo Overview


%%PageItemTitle%% $$Members$$

IExecEventNotifyByMailSettings Overview

IExecEventNotifyByMailSettings Interface Members

Public Methods

Public Method Save Uploads the notification settings to the server.

Public Properties

Public Property EMailTo | The recipients' e-mail addresses.
Public Property Enabled | Indicates if mail is enabled for the specified event type.
Public Property UserMessage | The message body of the e-mail.

See Also

IExecEventNotifyByMailSettings Overview


%%PageItemTitle%% $$Members$$

IExecutionSettings Overview

IExecutionSettings Interface Members

Public Properties

Public Property OnExecEventSchedulerActionParams | The restart action parameters.
Public Property OnExecEventSchedulerActionType | The action type of the execution event.
Public Property PlannedExecutionDate | The planned test execution date.
Public Property PlannedExecutionTime | The planned test execution time.
Public Property PlannedRunDuration | The planned test run duration.

See Also

IExecutionSettings Overview


%%PageItemTitle%% $$Members$$

IExecutionStatus Overview

IExecutionStatus Collection Members

Public Methods

Public Method EventsList | Gets the list of the execution events.
Public Method RefreshExecStatusInfo | Refreshes the execution status from the execution controller.

Public Properties

Public Property _NewEnum | Gets an ATL.IEnumOnSTLImpl enumerator for the TestExecStatus objects. For information on the ATL Class and IEnumOnSTLImpl, see Microsoft documentation.
Public Property Count | The number of status elements in the object.
Public Property Finished | Checks if execution is finished or still in progress.
Public Property Item | Gets a TestExecStatus object by index (1-based).

See Also

IExecutionStatus Overview


%%PageItemTitle%% $$Members$$

IExtendedStorage Overview

IExtendedStorage Interface Members

Public Methods

Public Method Cancel | Cancels the load or save action.
Public Method Delete | Deletes files locally or from the server.
Public Method GetLastError | Gets the last error that occurred during asynchronous load and save operations.
Public Method Load | Downloads the storage structure to the client file system.
Public Method LoadEx | Downloads the storage structure to the client file system.
Public Method Progress | Polls the progress of the last action (Load or Save).
Public Method Save | Uploads the storage structure to the server.
Public Method SaveEx | Uploads the storage structure to the server.

Public Properties

Public Property ActionFinished | Checks if the load or save action is finished.
Public Property ClientPath | The location on the client to which to download or from which to upload.
Public Property Root | The storage root.
Public Property ServerPath | The location on the server from which to download or to which to upload.

See Also

IExtendedStorage Overview


%%PageItemTitle%% $$Members$$

IFactoryList Overview

IFactoryList Collection Members

Public Methods

Public Method Add | Adds a new item to the current list object.
Public Method IndexOfItem | Gets the index of the passed object.
Public Method Insert | Inserts a new item at the specified position.
Public Method Post | Posts changed data for all items in list.
Public Method Refresh | Reads saved list filter and data for all listed objects, overwriting values in memory.
Public Method Remove | Removes the specified item from the current list object.
Public Method Swap | Swaps the two list items specified by their positions.

Public Properties

Public Property _NewEnum | Gets an IEnumVARIANT enumerator. For information on the IEnumVARIANT, see Microsoft documentation.
Public Property Count | The number of items in the list.
Public Property Fields | Gets a list of fields available through this factory.
Public Property Item | Gets an item by index. The index is one-based.
Public Property Ratio | The similarity ratio for the specified item.

See Also

IFactoryList Overview


%%PageItemTitle%% $$Members$$

IFieldProperty2 Overview

IFieldProperty2 Interface Members

Public Properties

Public Property DBColumnName | The database column name.
Public Property DBColumnType | The database column type.
Public Property DBTableName | The database table name.
Public Property EditMask | The input mask for string fields.
Public Property EditStyle | The user interface control type used to edit this field.
Public Property FieldSize | The size of the field in the database (-1 for BLOB fields).
Public Property IsActive | Checks if the field is can be displayed in the user interface.
Public Property IsByCode | Checks if the field saves the Tree Node ID (True), or the passed value (False).
Public Property IsCanFilter | Checks if the field is displayed in the filter dialog box.
Public Property IsCanGroup | Checks if items of this type can form groups with others of the same type.
Public Property IsCustomizable | Checks if the field is displayed in the customization UI.
Public Property IsEdit | Checks if the field can be edited.
Public Property IsHistory | Checks if change history is stored for the field.
Public Property IsKeepValue | Checks if the last value for the field is stored.
Public Property IsKey | Checks if this is a database key field.
Public Property IsMail | Checks if e-mail is sent to the users on the notification list when this field changes.
Public Property IsModify | Checks if the user currently logged on the TDConnection is permitted to modify this field.
Public Property IsMultiValue | Checks if the field can store multiple values.
Public Property IsRequired | Checks if this is a required field.
Public Property IsSearchable | Checks if the content of the field is searched by the Search method.
Public Property IsSystem | Checks if this is a predefined system field.
Public Property IsToSum | Checks if this field is summed for graphs.
Public Property IsVerify | Checks if the field requires verification.
Public Property IsVersionControl | Checks if the field is under version control.
Public Property IsVisibleInNewBug | Checks if the field is visible in the New Bug form.
Public Property ReadOnly | Checks if this is a read-only field.
Public Property Root | The tree root connected to the field.
Public Property UserColumnType | The user column type: char, number, date, memo, or empty string.
Public Property UserLabel | The user-defined label.

See Also

IFieldProperty2 Overview


%%PageItemTitle%% $$Members$$

IFieldProperty3 Overview

IFieldProperty3 Interface Members

Public Methods

Public Method GetRequiredByType Checks if the field is required according to the requirement type.

Public Properties

Public Property DBColumnName | The database column name.
Public Property DBColumnType | The database column type.
Public Property DBTableName | The database table name.
Public Property EditMask | The input mask for string fields.
Public Property EditStyle | The user interface control type used to edit this field.
Public Property FieldSize | The size of the field in the database (-1 for BLOB fields).
Public Property IsActive | Checks if the field is can be displayed in the user interface.
Public Property IsByCode | Checks if the field saves the Tree Node ID (True), or the passed value (False).
Public Property IsCanFilter | Checks if the field is displayed in the filter dialog box.
Public Property IsCanGroup | Checks if items of this type can form groups with others of the same type.
Public Property IsCustomizable | Checks if the field is displayed in the customization UI.
Public Property IsEdit | Checks if the field can be edited.
Public Property IsHistory | Checks if change history is stored for the field.
Public Property IsKeepValue | Checks if the last value for the field is stored.
Public Property IsKey | Checks if this is a database key field.
Public Property IsMail | Checks if e-mail is sent to the users on the notification list when this field changes.
Public Property IsModify | Checks if the user currently logged on the TDConnection is permitted to modify this field.
Public Property IsMultiValue | Checks if the field can store multiple values.
Public Property IsRequired | Checks if this is a required field.
Public Property IsSearchable | Checks if the content of the field is searched by the Search method.
Public Property IsSystem | Checks if this is a predefined system field.
Public Property IsToSum | Checks if this field is summed for graphs.
Public Property IsVerify | Checks if the field requires verification.
Public Property IsVersionControl | Checks if the field is under version control.
Public Property IsVisibleInNewBug | Checks if the field is visible in the New Bug form.
Public Property ReadOnly | Checks if this is a read-only field.
Public Property Root | The tree root connected to the field.
Public Property UserColumnType | The user column type: char, number, date, memo, or empty string.
Public Property UserLabel | The user-defined label.

See Also

IFieldProperty3 Overview


%%PageItemTitle%% $$Members$$

IFieldProperty Overview

IFieldProperty Interface Members

Public Properties

Public Property DBColumnName | The database column name.
Public Property DBColumnType | The database column type.
Public Property DBTableName | The database table name.
Public Property EditMask | The input mask for string fields.
Public Property EditStyle | The user interface control type used to edit this field.
Public Property FieldSize | The size of the field in the database (-1 for BLOB fields).
Public Property IsActive | Checks if the field is can be displayed in the user interface.
Public Property IsByCode | Checks if the field saves the Tree Node ID (True), or the passed value (False).
Public Property IsCanFilter | Checks if the field is displayed in the filter dialog box.
Public Property IsCustomizable | Checks if the field is displayed in the customization UI.
Public Property IsEdit | Checks if the field can be edited.
Public Property IsHistory | Checks if change history is stored for the field.
Public Property IsKeepValue | Checks if the last value for the field is stored.
Public Property IsKey | Checks if this is a database key field.
Public Property IsMail | Checks if e-mail is sent to the users on the notification list when this field changes.
Public Property IsModify | Checks if the user currently logged on the TDConnection is permitted to modify this field.
Public Property IsRequired | Checks if this is a required field.
Public Property IsSystem | Checks if this is a predefined system field.
Public Property IsToSum | Checks if this field is summed for graphs.
Public Property IsVerify | Checks if the field requires verification.
Public Property IsVersionControl | Checks if the field is under version control.
Public Property IsVisibleInNewBug | Checks if the field is visible in the New Bug form.
Public Property ReadOnly | Checks if this is a read-only field.
Public Property Root | The tree root connected to the field.
Public Property UserColumnType | The user column type: char, number, date, memo, or empty string.
Public Property UserLabel | The user-defined label.

See Also

IFieldProperty Overview


%%PageItemTitle%% $$Members$$

IFileData Overview

IFileData Interface Members

Public Methods

Public Method Items | The folder's child items.
Public Method ModifyDate | The file's modify date.
Public Method Size | The file size in Kbytes.
Public Method Type | The type of object for which data is stored.

Public Properties

Public Property Name The file or folder name.

See Also

IFileData Overview


%%PageItemTitle%% $$Members$$

IFollowUpManager Overview

IFollowUpManager Interface Members

Public Methods

Public Method CancelFollowUp | Removes the current entity's follow-up.
Public Method GetFollowUp | Gets the date and description for the follow-up associated with the current object.
Public Method HasFollowUp | Checks if the object has at least one follow-up associated with it.
Public Method IsFollowUpOverdue | Checks if the date of the unsent follow-up is earlier than the current database server date.
Public Method SetFollowUp | Sets an alert for follow-up for the current object.

See Also

IFollowUpManager Overview


%%ItemTitle%%

OTA COM Type Library

Check if test has alert

Source code

Public Sub CheckIfTestHasFollowUpFlag()
'Check if test has alert
    Dim testF As testFactory
    Dim test1 As Test
    Dim followUp As IFollowUpManager
    Dim hasFlag As Boolean
    Set testF = tdc.testFactory
    Set test1 = testF.Item(1)
    'Test implements IFollowUpManager
    ' so this casting gets the IFollowUpManager
    ' for the test.
    Set followUp = test1
    hasFlag = followUp.HasFollowUp
    MsgBox hasFlag
    If hasFlag Then
        Dim fDate As Date, fDesc$
        followUp.GetFollowUp fDate, fDesc
        MsgBox fDesc & vbCrLf & fDate
    End If
End Sub


%%ItemTitle%%

OTA COM Type Library

Set alert on test

Source code

Public Sub SetFollowUpFlagToTest()
'Set alert on test
    Dim testF As testFactory
    Dim test1 As Test
    Dim followUp As IFollowUpManager
    Dim date1 As Date
    Set testF = tdc.testFactory
    Set test1 = testF.Item(3)
    Set followUp = test1
    followUp.SetFollowUp "05-Jul-07", "Check if test bank ready"
End Sub


%%PageItemTitle%% $$Members$$

IGraph Overview

IGraph Interface Members

Public Methods

Public Method DrillDown | Drills down to graph data.
Public Method MultiDrillDown | Gets detailed information about a graph area consisting of four sets of coordinates.

Public Properties

Public Property ColCount | The number of columns.
Public Property ColName | Gets the name of the specified column. Column numbers are zero-based.
Public Property ColTotal | The sum of the values in the specified graph data column. The column number is zero-based.
Public Property Data | The data in the specified cell. Column and Row numbers are zero-based.
Public Property GraphTotal | The total number of items represented in the graph.
Public Property MaxValue | The maximum value in the graph.
Public Property RowCount | The number of rows.
Public Property RowName | Gets the row name of the specified row. Row numbers are zero-based.
Public Property RowTotal | The sum of the values in the specified graph data row. The row number is zero-based.
Public Property StartDate | The start date for the graph.

See Also

IGraph Overview


%%PageItemTitle%% $$Members$$

IGraphBuilder Overview

IGraphBuilder Interface Members

Public Methods

Public Method BuildGraph | Build the graph.
Public Method BuildMultipleGraphs | Build several graphs.
Public Method CreateGraphDefinition | Create an IGraphDefinition object.

See Also

IGraphBuilder Overview


%%PageItemTitle%% $$Members$$

IGraphDefinition Overview

IGraphDefinition Interface Members

Public Properties

Public Property Filter | The filter sets the criteria for which data are included in the graph.
Public Property Module | The module specified when the graph definition was created.
Public Property Property | The value of the specified property.
Public Property Type | The graph type

See Also

IGraphDefinition Overview


%%PageItemTitle%% $$Members$$

IHierarchyFilter Overview

IHierarchyFilter Interface Members

Public Methods

Public Method Clear | Clears the current filter.
Public Method GetXFilter | Gets the cross filter specified by CrossEntities.
Public Method IsClear | Checks whether the filter is clear, including cross-filter settings
Public Method NewList | Creates a new list from current filter.
Public Method Refresh | Reads saved data and refreshes the fetched list according to the current filter, overwriting values in memory.
Public Method SetXFilter | Sets the filter for second entity, called a cross filter.

Public Properties

Public Property CaseSensitive | Indicates if the filter for the specified field is case sensitive. The default is False.
Public Property DataType | The filtered entity type.
Public Property Fields | The list of fields for the TDFilter's parent object.
Public Property Filter | The filter condition for the field specified by the FieldName.
Public Property KeepHierarchical | Indicates whether to include parent objects in list.
Public Property Order | The position of the specified field in the list of the sort fields. (zero-based)
Public Property OrderDirection | The sort order: TDOLE_ASCENDING or TDOLE_DESCENDING
Public Property Text | The full fields filter as text.
Public Property XFilter | The cross filter according to the entity type.

See Also

IHierarchyFilter Overview


%%ItemTitle%%

OTA COM Type Library

Getting a filtered,sorted list of requirements

Source code

Public Sub GetSortedList()
    Dim reqF As reqFactory
    Dim hierFilter As HierarchyFilter
    Dim reqHierL As HierarchySupportList, reqL As list
    Dim rq As Req
    Dim i%
    On Error GoTo GetHListErr
    'tdc is the global TDConnection object.
    Set reqF = tdc.reqFactory
'Get "Son", "GrandSon", and "SubNode"
    Set hierFilter = reqF.Filter
    hierFilter("RQ_REQ_NAME") = "*Son* OR SubNode*"
'Get Emma or Mansfield Park projects.
' Note that Mansfield Park must be quoted because of the space
' between Mansfield and Park.
    hierFilter("RQ_REQ_PRODUCT") = "Emma OR 'Mansfield Park'"
    hierFilter.Order("RQ_REQ_PRODUCT") = 1
    hierFilter.Order("RQ_REQ_PRIORITY") = 2
'
'Get the parent nodes as well by setting KeepHierarchical = True.
' Note that this setting is required to get
' a HierarchySupportList. If KeepHierarchical
' is False or not set, HierarchyFilter.NewList
' returns a List, not a HierarchySupportList.
    hierFilter.KeepHierarchical = True
' This will fail if KeepHierarchical not set True:
    Set reqHierL = hierFilter.NewList
    For i = 1 To reqHierL.Count
        Set rq = reqHierL(i)
        With rq
            Debug.Print .Product & ", " & .Priority & ", " & .Name
        End With
    Next i
' Emma, 2-Medium, Req1
' Emma, 2-Medium, Son of Req1 1.2
' Emma, 3-High, GrandSon of Req1 1.2.1
' Emma, 3-High, Son of Req1 1.1
' Emma, 5-Urgent, GrandSon of Req1 1.1.1
' Emma, 5-Urgent, SubNode of Req 3 3.1
' Emma, 5-Urgent, GrandSon of Req2 2.1.1
' Mansfield Park, 2-Medium, GrandSon of Req1 1.1.2
' Mansfield Park, 2-Medium, GrandSon of Req1 1.2.2
' Mansfield Park, 3-High, req2
' Mansfield Park, 3-High, GrandSon of Req2 2.1.2
' Mansfield Park, 5-Urgent, SubNode of Req 3 3.2
' Mansfield Park, 5-Urgent, Son of Req2 2.1
Exit Sub
GetHListErr:
    ErrHandler err, "GetSortedList", err.Description, False
End Sub


%%PageItemTitle%% $$Members$$

IHierarchySupportList Overview

IHierarchySupportList Collection Members

Public Methods

Public Method Add | Adds a new item to the current list object.
Public Method IndexOfItem | Gets the index of the passed object.
Public Method Insert | Inserts a new item at the specified position.
Public Method Post | Posts changed data for all items in list.
Public Method Refresh | Reads saved list filter and data for all listed objects, overwriting values in memory.
Public Method Remove | Removes the specified item from the current list object.
Public Method Swap | Swaps the two list items specified by their positions.

Public Properties

Public Property _NewEnum | Gets an IEnumVARIANT enumerator. For information on the IEnumVARIANT, see Microsoft documentation.
Public Property Count | The number of items in the list.
Public Property Fields | Gets a list of fields available through this factory.
Public Property IsInFilter | Checks if the item matches the filter criteria of the list to which it belongs.
Public Property Item | Gets an item by index. The index is one-based.
Public Property Ratio | The similarity ratio for the specified item.

See Also

IHierarchySupportList Overview


%%PageItemTitle%% $$Members$$

IHistory Overview

IHistory Interface Members

Public Methods

Public Method ClearHistory | Clears the history records selected by the filter.
Public Method NewList | Gets filtered list of history data records.

Public Properties

Public Property Filter The filter object for the history item.

See Also

IHistory Overview


%%PageItemTitle%% $$Members$$

IHistoryRecord2 Overview

IHistoryRecord2 Interface Members

Public Properties

Public Property ChangeDate | The change date according to database server.
Public Property Changer | The name of the user who made the change.
Public Property FieldName | The name of the changed field.
Public Property ItemKey | The item key for the changed item.
Public Property NewValue | The value after the change.
Public Property OldValue | The value before the change.

See Also

IHistoryRecord2 Overview


%%PageItemTitle%% $$Members$$

IHistoryRecord Overview

IHistoryRecord Interface Members

Public Properties

Public Property ChangeDate | The change date according to database server.
Public Property Changer | The name of the user who made the change.
Public Property FieldName | The name of the changed field.
Public Property ItemKey | The item key for the changed item.
Public Property NewValue | The value after the change.

See Also

IHistoryRecord Overview


%%PageItemTitle%% $$Members$$

IHost Overview

IHost Interface Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Description | A description of the host server.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The name of the host server.
Public Property RexServer | The remote execution server name as it appears on the LAN.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

IHost Overview


%%PageItemTitle%% $$Members$$

IHostGroup Overview

IHostGroup Interface Members

Public Methods

Public Method AddHost | Adds a host to the group.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method NewList | Gets a list of all hosts in the group.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method RemoveHost | Removes the specified host from the group.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | Gets the host group name.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

IHostGroup Overview


%%PageItemTitle%% $$Members$$

IHostGroupFactory Overview

IHostGroupFactory Interface Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveHost | Removes host from all groups.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

IHostGroupFactory Overview


%%PageItemTitle%% $$Members$$

ILink Overview

ILink Interface Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Comment | The link summary comment.
Public Property CreatedBy | The user who created the link.
Public Property CreationDate | The link creation date.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property LinkedByEntity | The entity that initiated the link.
Public Property LinkType | The link type.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property SourceEntity | The source entity object of the link.
Public Property TargetEntity | The target entity object of the link.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

ILink Overview


%%PageItemTitle%% $$Members$$

ILinkable Overview

ILinkable Interface Members

Public Properties

Public Property BugLinkFactory | The bug link factory that manages the links of the current object to its associated defects.
Public Property HasLinkage | Checks if the current object has at least one associated Bug.
Public Property HasOthersLinkage | Checks if the current Bug object has at least one associated object that is not another Bug object. Defined only for Bug objects.
Public Property LinkFactory | The link factory of the current defect object that enables viewing the links. Defined only for Bug objects.

See Also

ILinkable Overview


%%ItemTitle%%

OTA COM Type Library

Displaying links

Source code

Sub ViewLinks()
'------------------------------------------------------
' Output all bug links
    Dim BugF As BugFactory, bList As list
    Dim aBug As Bug
    Dim bugL As ILinkable, LinkList As list, linkF As LinkFactory
'tdc is the global TDConnection object.
    Set BugF = tdc.BugFactory
    Set bList = BugF.NewList("")
    For Each aBug In bList
'Cast the Bug object to an ILinkable reference
' to get the link factory
        Set bugL = aBug
        Set linkF = bugL.LinkFactory
        Set LinkList = linkF.NewList("")
        Dim SourceObj As Object, TargetObj As Object, InitObj As Object, lnk As Link
        Debug.Print: Debug.Print "---------------------------------"
        Debug.Print "Source Type"; Tab; "ID"; Tab; "Target Type"; _
            Tab; "ID"; Tab; "Initiated by"
        For Each lnk In LinkList
            With lnk
                Set SourceObj = .SourceEntity
                Set TargetObj = .TargetEntity
                Set InitObj = .LinkedByEntity
                Debug.Print TypeName(SourceObj); Tab; CStr(SourceObj.ID); _
                    Tab; TypeName(TargetObj); Tab; CStr(TargetObj.ID); _
                    Tab; TypeName(InitObj); Spc(3); InitObj.ID
            End With
        Next lnk
    Next aBug
End Sub


%%PageItemTitle%% $$Members$$

ILinkFactory Overview

ILinkFactory Interface Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property FullLinkage | Indicates that NewList returns child objects in addition to the current object.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

ILinkFactory Overview


%%PageItemTitle%% $$Members$$

IList Overview

IList Collection Members

Public Methods

Public Method Add | Adds a new item to the current list object.
Public Method Insert | Inserts a new item at the specified position.
Public Method Remove | Removes the specified item from the current list object.
Public Method Swap | Swaps the two list items specified by their positions.

Public Properties

Public Property _NewEnum | Gets an IEnumVARIANT enumerator. For information on the IEnumVARIANT, see Microsoft documentation.
Public Property Count | The number of items in the list.
Public Property Item | Gets an item by index. The index is one-based.

See Also

IList Overview


%%PageItemTitle%% $$Members$$

IMultiValue Overview

IMultiValue Interface Members

Public Properties

Public Property List | List of values. Each item is the string representation of a single value.
Public Property Text | Text representation of values list. Items are separated with a semicolon.

See Also

IMultiValue Overview


%%PageItemTitle%% $$Members$$

IObjectLockingSupport Overview

IObjectLockingSupport Interface Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property IsLocked Checks if object is locked.

See Also

IObjectLockingSupport Overview


%%PageItemTitle%% $$Members$$

IOnExecEventSchedulerActionParams Overview

IOnExecEventSchedulerActionParams Interface Members

Public Properties

Public Property OnExecEventSchedulerAction The action to be taken.

See Also

IOnExecEventSchedulerActionParams Overview


%%PageItemTitle%% $$Members$$

IOnExecEventSchedulerRestartParams Overview

IOnExecEventSchedulerRestartParams Interface Members

Public Properties

Public Property CleanupTest | The test ID of the test to run before each rerun.
Public Property NumberOfRetries | The number of retries if a test fails.
Public Property OnExecEventSchedulerAction | The action to be taken.

See Also

IOnExecEventSchedulerRestartParams Overview


%%PageItemTitle%% $$Members$$

IParam Overview

IParam Interface Members

Public Methods

Public Method AddParam | Adds new parameter to Command object.
Public Method DeleteParam | Deletes the specified parameter from Command object.
Public Method DeleteParams | Deletes all parameters from Command object.

Public Properties

Public Property Count | Number of parameters in current command.
Public Property ParamIndex | The parameter index by parameter name.
Public Property ParamName | The parameter name by parameter index. The index is 0-based.
Public Property ParamType | The data type of the specified parameter. The index is 0-based.
Public Property ParamValue | The parameter value.

See Also

IParam Overview


%%PageItemTitle%% $$Members$$

IProductInfo Overview

IProductInfo Interface Members

Public Properties

Public Property BPTVersion | The Business Process Test versions.
Public Property QCVersion | The build information for the installed version.

See Also

IProductInfo Overview


%%PageItemTitle%% $$Members$$

IRecordset Overview

IRecordset Interface Members

Public Methods

Public Method Clone | Creates a duplicate of this Recordset object.
Public Method First | Moves to the first record and makes it the current record.
Public Method Last | Moves to the last record and makes it the current record.
Public Method Next | Moves to the next record and makes it the current record.
Public Method Prev | Moves to the previous record and makes it the current record.
Public Method Refresh | Refreshes the Recordset, overwriting values in memory.

Public Properties

Public Property BOR | Checks if the record cursor is on the first record.
Public Property CacheSize | The number of records in the recordset that are cached locally in memory.
Public Property ColCount | Gets the number of columns in the current Recordset object.
Public Property ColIndex | Gets the index (zero-based) of a Recordset column specified by column name.
Public Property ColName | The name of the Recordset column specified by Index (zero-based).
Public Property ColSize | The physical size as defined in the database of the fields in the column specified by Index (zero-based).
Public Property ColType | The data type of column.
Public Property EOR | Checks if the record cursor is after the last record.
Public Property FieldValue | The value for the specified field.
Public Property Position | The current record position (0-based).
Public Property RecordCount | The number of records in the Recordset.

See Also

IRecordset Overview


%%PageItemTitle%% $$Members$$

IRelease Overview

IRelease Interface Members

Public Methods

Public Method DaysLeft | Returns the number of days until the scheduled release date.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Mail | Mails the IBaseFieldExMail field item.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property CycleFactory | The CycleFactory object for cycles of this release.
Public Property EndDate | The release's end date
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The release's name
Public Property Parent | The release's parent release folder
Public Property ReleaseManagementInfo | The release information.
Public Property StartDate | The release's start date
Public Property Status | The release's status
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

IRelease Overview


%%PageItemTitle%% $$Members$$

IReleaseFactory Overview

IReleaseFactory Interface Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method BuildCoverageGraph | Builds release coverage graph.
Public Method Mail | Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

IReleaseFactory Overview


%%PageItemTitle%% $$Members$$

IReleaseFolder Overview

IReleaseFolder Interface Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Mail | Mails the IBaseFieldExMail field item.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The release folder's name
Public Property Parent | The release folder's parent release folder, or null if root
Public Property ReleaseFactory | The ReleaseFactory object for direct children releases.
Public Property ReleaseFolderFactory | The ReleaseFolderFactory object for direct children release folders.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

IReleaseFolder Overview


%%PageItemTitle%% $$Members$$

IReleaseFolderFactory Overview

IReleaseFolderFactory Interface Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method Mail | Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.
Public Property Root | Gets the root release folder labled 'Releases'.

See Also

IReleaseFolderFactory Overview


%%PageItemTitle%% $$Members$$

IReleaseManagementInfo Overview

IReleaseManagementInfo Interface Members

Public Properties

Public Property DaysLeft | Returns the number of days remaining in the cycle or release.
Public Property Duration | Returns the duration of the cycle or release.
Public Property Started | Checks if the cycle or release has begun.
Public Property TotalTestInstances | Returns the total number of test instances in this cycle or release.
Public Property UnexecutedTestInstances | Returns the number of unexecuted test instances in this cycle or release.

See Also

IReleaseManagementInfo Overview


%%PageItemTitle%% $$Members$$

IReq2 Overview

IReq2 Interface Members

Public Methods

Public Method AddCoverage | Assigns a test to cover this requirement.
Public Method AddCoverageByFilter | Adds the tests from the specified subject that match the input filter to the list of tests that cover the current requirement.
Public Method AddCoverageEx | Assigns all the tests in the specified subject folder to cover this current requirement.
Public Method get_Icon | Returns the bitmap stream for the requirement's type.
Public Method GetCoverageTestsByReqFilter | Returns the list of tests that cover the current requirement and, optionally, cover those of its children that match the requirement filter.
Public Method GetCoverList | Gets a list of the tests that cover this requirement.
Public Method GetCoverListByFilter | Gets the list of all tests that cover the current requirement and match the filter.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Mail | Mails the IBaseFieldExMail field item.
Public Method Move | Moves a requirement to being a child of a specified father in the requirements tree.
Public Method PopulateTargetCycleToChildren | Assigns the target cycle of the requirement as the target cycle of all child requirements, recursively down the folder tree.
Public Method PopulateTargetReleaseToChildren | Assigns the target release of the requirement as the target release of all child requirements, recursively down the folder tree.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method RemoveCoverage | Removes a test from the list of tests that cover this requirement.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property Author | The name of the requirement author.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Comment | The comment associated with this requirement.
Public Property Count | The number of direct children.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property HasCoverage | The requirement is covered by at least one test.
Public Property HasReqTraceability | Checks if the current requirement has at least one associated requirement in the specified direction.
Public Property HasRichContent | Checks if the object has rich content.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The Requirement name as seen in the tree.
Public Property Paragraph | The paragraph number or numeration of the requirement.
Public Property ParentId | The Requirement's parent ID.
Public Property Path | The path of the node containing this requirement.
Public Property Priority | The requirement priority.
Public Property Product | The product name for which the requirement is set.
Public Property ReqTraceFactory | The requirement link factory that manages the traceability links of the current requirement to its associated requirements in the specified direction.
Public Property RequirementType | Gets the interface for getting the requirement types.
Public Property Reviewed | The review status.
Public Property Status | The status of the tests that cover this requirement.
Public Property Type | The requirement type.
Public Property TypeId | The Requirement's type name.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

IReq2 Overview


%%PageItemTitle%%

IReq2 Interface

HasRichContent Property

Description

Checks if the object has rich content.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasRichContent() As Boolean

Remarks

This property is available only for Quality Center version 9.2. Applications using the property will have to be changed in later versions.

See Also

IReq2 Interface


%%PageItemTitle%% $$Members$$

IReq Overview

IReq Interface Members

Public Methods

Public Method AddCoverage | Assigns a test to cover this requirement.
Public Method AddCoverageByFilter | Adds the tests from the specified subject that match the input filter to the list of tests that cover the current requirement.
Public Method AddCoverageEx | Assigns all the tests in the specified subject folder to cover this current requirement.
Public Method GetCoverList | Gets a list of the tests that cover this requirement.
Public Method GetCoverListByFilter | Gets the list of all tests that cover the current requirement and match the filter.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Mail | Mails the IBaseFieldExMail field item.
Public Method Move | Moves a requirement to being a child of a specified father in the requirements tree.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method RemoveCoverage | Removes a test from the list of tests that cover this requirement.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property Author | The name of the requirement author.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Comment | The comment associated with this requirement.
Public Property Count | The number of direct children.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property HasCoverage | The requirement is covered by at least one test.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The Requirement name as seen in the tree.
Public Property Paragraph | The paragraph number or numeration of the requirement.
Public Property Path | The path of the node containing this requirement.
Public Property Priority | The requirement priority.
Public Property Product | The product name for which the requirement is set.
Public Property Reviewed | The review status.
Public Property Status | The status of the tests that cover this requirement.
Public Property Type | The requirement type.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

IReq Overview


%%PageItemTitle%% $$Members$$

IReqCoverageFactory Overview

IReqCoverageFactory Interface Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property FullCoverage | Indicates if the actions of the factory are applied recursively to requirement's children.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

IReqCoverageFactory Overview


%%PageItemTitle%% $$Members$$

IReqFactory2 Overview

IReqFactory2 Interface Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method BuildPerfGraph | Builds Performance Graph.
Public Method BuildPerfGraphEx | Builds Performance Graph.
Public Method BuildProgressGraph | Builds Req progress graph.
Public Method BuildProgressGraphEx | Builds Requirement progress graph. Extends BuildProgressGraph with ability to display Null parent folders.
Public Method BuildSummaryGraph | Builds Req summary graph.
Public Method BuildSummaryGraphEx | Builds Req summary graph. Extends BuildSummaryGraph with ability to display Null parent folders.
Public Method BuildTrendGraph | Creates graph that shows the number of defect status changes over time.
Public Method BuildTrendGraphEx | Creates graph that shows the number of defect status changes over time.
Public Method Find | Gets a list of requirements containing the Pattern value in specified field.
Public Method GetChildrenList | Gets list of child requirements.
Public Method GetFilteredChildrenList | Gets a filtered list of child requirements.
Public Method Mail | Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

IReqFactory2 Overview


%%PageItemTitle%% $$Members$$

IReqFactory3 Overview

IReqFactory3 Interface Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method BuildPerfGraph | Builds Performance Graph.
Public Method BuildPerfGraphEx | Builds Performance Graph.
Public Method BuildProgressGraph | Builds Req progress graph.
Public Method BuildProgressGraphEx | Builds Requirement progress graph. Extends BuildProgressGraph with ability to display Null parent folders.
Public Method BuildSummaryGraph | Builds Req summary graph.
Public Method BuildSummaryGraphEx | Builds Req summary graph. Extends BuildSummaryGraph with ability to display Null parent folders.
Public Method BuildTrendGraph | Creates graph that shows the number of defect status changes over time.
Public Method BuildTrendGraphEx | Creates graph that shows the number of defect status changes over time.
Public Method Find | Gets a list of requirements containing the Pattern value in specified field.
Public Method GetChildrenList | Gets list of child requirements.
Public Method GetCoverageTestsByReqFilter | Returns the list of tests that cover the requirements that match the requirement filter.
Public Method GetFilteredChildrenList | Gets a filtered list of child requirements.
Public Method GetRequirementType | Returns the requirement customization type object specified by the type ID.
Public Method GetRequirementTypes | Returns the list of requirement customization types.
Public Method GetTracedList | Returns the list of requirements either traced directly from or directly to the specified requirement.
Public Method Mail | Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.
Public Method ReqTypeIdToName | Returns the name of the requirement type specified by the type ID.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

IReqFactory3 Overview


%%PageItemTitle%% $$Members$$

IReqFactory Overview

IReqFactory Interface Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method BuildPerfGraph | Builds Performance Graph.
Public Method BuildPerfGraphEx | Builds Performance Graph.
Public Method BuildProgressGraph | Builds Req progress graph.
Public Method BuildProgressGraphEx | Builds Requirement progress graph. Extends BuildProgressGraph with ability to display Null parent folders.
Public Method BuildSummaryGraph | Builds Req summary graph.
Public Method BuildSummaryGraphEx | Builds Req summary graph. Extends BuildSummaryGraph with ability to display Null parent folders.
Public Method BuildTrendGraph | Creates graph that shows the number of defect status changes over time.
Public Method BuildTrendGraphEx | Creates graph that shows the number of defect status changes over time.
Public Method Find | Gets a list of requirements containing the Pattern value in specified field.
Public Method GetChildrenList | Gets list of child requirements.
Public Method Mail | Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

IReqFactory Overview


%%PageItemTitle%% $$Members$$

IReqTraceFactory Overview

IReqTraceFactory Interface Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

IReqTraceFactory Overview


%%PageItemTitle%% $$Members$$

IReqType Overview

IReqType Interface Members

Public Properties

Public Property HasDirectCoverage | Indicates if this requirement type supports direct coverage by tests or test instances.
Public Property Icon | The bitmap stream representing this type.
Public Property ID | The CustomizationType ID.
Public Property Name | The CustomizationType name.
Public Property RiskAnalysisType | The type of risk analysis that is applicable to this requirement.

See Also

IReqType Overview


%%PageItemTitle%% $$Members$$

IRule2 Overview

IRule2 Interface Members

Public Methods

Public Method Post Saves the changes to the Rules object to the server.

Public Properties

Public Property Description | The rule description.
Public Property ID | The rule ID.
Public Property IsActive | Indicates if the rule is active.
Public Property Recipient | Returns the user name of the recipient of the alert email.
Public Property ToMail | Indicates if the alert is to be sent by e-mail.

See Also

IRule2 Overview


%%PageItemTitle%% $$Members$$

IRule Overview

IRule Interface Members

Public Methods

Public Method Post Saves the changes to the Rules object to the server.

Public Properties

Public Property Description | The rule description.
Public Property ID | The rule ID.
Public Property IsActive | Indicates if the rule is active.
Public Property ToMail | Indicates if the alert is to be sent by e-mail.

See Also

IRule Overview


%%PageItemTitle%% $$Members$$

IRuleManager Overview

IRuleManager Interface Members

Public Methods

Public Method GetRule Gets a traceability notification rule by its ID.

Public Properties

Public Property Rules A list of all the Rule objects.

See Also

IRuleManager Overview


%%PageItemTitle%% $$Members$$

IRun2 Overview

IRun2 Interface Members

Public Methods

Public Method CancelRun | Cancels the run.
Public Method CopyDesignSteps | Copies design steps into the test run of an executed test.
Public Method CopyStepsToTest | Copies all run execution steps, including new added steps, into the design steps of the corresponding planning test.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method ResolveStepsParameters | Updates the texts of the run's steps by resolving the parameter values at run time.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property BPStepParamFactory | The BPStepParamFactory for the current run.
Public Property ExtendedStorage | The ExtendedStorage object for the current run.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The run name.
Public Property Params | The step parameters of this run.
Public Property ResultLocation | The run result location, a UNC path.
Public Property Status | The run status.
Public Property StepFactory | The Step Factory for the current run.
Public Property TestId | The test ID of the test that has been run.
Public Property TestInstance | The number of this instance of the design test in the test set.
Public Property TestInstanceID | The ID of the test instance for the current run.
Public Property TestSetID | The ID of the test set to which the run belongs.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

IRun2 Overview


%%PageItemTitle%% $$Members$$

IRun Overview

IRun Interface Members

Public Methods

Public Method CancelRun | Cancels the run.
Public Method CopyDesignSteps | Copies design steps into the test run of an executed test.
Public Method CopyStepsToTest | Copies all run execution steps, including new added steps, into the design steps of the corresponding planning test.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method ResolveStepsParameters | Updates the texts of the run's steps by resolving the parameter values at run time.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property ExtendedStorage | The ExtendedStorage object for the current run.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The run name.
Public Property Params | The step parameters of this run.
Public Property ResultLocation | The run result location, a UNC path.
Public Property Status | The run status.
Public Property StepFactory | The Step Factory for the current run.
Public Property TestId | The test ID of the test that has been run.
Public Property TestInstance | The number of this instance of the design test in the test set.
Public Property TestSetID | The ID of the test set to which the run belongs.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

IRun Overview


%%PageItemTitle%% $$Members$$

IRunFactory Overview

IRunFactory Interface Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method DeleteDuplicateRuns | Removes duplicate runs for the current test set. Removal is immediate without Post.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.
Public Property UniqueRunName | Gets the run name. The name is unique in the current test and test set.

See Also

IRunFactory Overview


%%PageItemTitle%% $$Members$$

ISearchableFactory Overview

ISearchableFactory Interface Members

Public Methods

Public Method CreateSearchOptions | Creates a new SearchOptions object.
Public Method IsSearchable | Checks if the Search method can be called by this factory.
Public Method Search | Gets a list of objects matching the search query.

See Also

ISearchableFactory Overview


%%ItemTitle%%

OTA COM Type Library

Searching for tests that match a search string

Source code

Private Sub SearchForTests(TestF As TestFactory, _
        SearchString As String, _
        Optional StepsSearch As Boolean = False)
    Dim TestSearchF As ISearchableFactory
    Dim SearchOpts As SearchOptions
    Dim tList As list
    Dim oneTest As test
    Dim i, limit
On Error GoTo ErrorHandler
'Cast the TestFactory to get an ISearchableFactory reference
    Set TestSearchF = TestF
    Set SearchOpts = TestSearchF.CreateSearchOptions
'Set the option whether to search in test steps
    SearchOpts.Property(SEARCH_IN_STEPS) = StepsSearch
'Get the list of matches and output
    Set tList = TestSearchF.Search(SearchString, SearchOpts)
    limit = 30
    If (tList.Count < limit) Then limit = tList.Count
    For i = 1 To limit
        Set oneTest = tList.Item(i)
        Debug.Print oneTest.ID & " - " & oneTest.Name
    Next i
    Exit Sub
ErrorHandler:
    MsgBox err.Description
End Sub


%%PageItemTitle%% $$Members$$

ISearchOptions Overview

ISearchOptions Interface Members

Public Properties

Public Property Filter | Get filter
Public Property Property | The search configuration flag.

See Also

ISearchOptions Overview


%%PageItemTitle%% $$Members$$

ISequentialStream Overview

ISequentialStream Interface Members

Public Methods

Public Method RemoteRead | See Microsoft documentation.
Public Method RemoteWrite | See Microsoft documentation.

See Also

ISequentialStream Overview


%%PageItemTitle%% $$Members$$

ISequentialStream Interface

IUnknown Implemented Interface Members

See Also

ISequentialStream Interface


%%PageItemTitle%% $$Members$$

ISettings2 Overview

ISettings2 Interface Members

Public Methods

Public Method Close | Closes and updates the category.
Public Method DeleteCategory | Deletes the current settings folder.
Public Method DeleteValue | Deletes the specified item.
Public Method Open | Sets the category to be used in subsequent actions by the client.
Public Method Post | Posts the category to the server.
Public Method Refresh | Reads saved values, overwriting values in memory.

Public Properties

Public Property EnumItems | Returns the list of names of the setting's items.
Public Property IsSystem | Checks if the specified setting is built-in and read-only.
Public Property Value | The value of the specified item in the active category.

See Also

ISettings2 Overview


%%PageItemTitle%% $$Members$$

ISettings Overview

ISettings Interface Members

Public Methods

Public Method Close | Closes and updates the category.
Public Method DeleteCategory | Deletes the current settings folder.
Public Method DeleteValue | Deletes the specified item.
Public Method Open | Sets the category to be used in subsequent actions by the client.
Public Method Post | Posts the category to the server.
Public Method Refresh | Reads saved values, overwriting values in memory.

Public Properties

Public Property EnumItems | Returns the list of names of the setting's items.
Public Property Value | The value of the specified item in the active category.

See Also

ISettings Overview


%%ItemTitle%%

OTA COM Type Library

Custom user setting

Source code

Public Sub KeepValue(Value As String, _
    Optional ItemName As String = "KeepUserItem", _
    Optional Category As String = "KeepUserSetting")
'This example changes the value of a custom setting.
'If the category and item do not exist, they are created.
'The routine then outputs all existing entries in the category.
Dim uset As ISettings
Dim settingsList As list
On Error Resume Next
    'tdc is the global TDConnection object.
    Set uset = tdc.UserSettings
    'Open category
    uset.Open (Category)
    'Setting a value in the open category
    uset.Value(ItemName) = Value
    uset.Post
    Set settingsList = uset.EnumItems
    'Get all the values from the
    'server.
    Dim setName
    'This call is not required,
    'but makes the following loop more efficient
    setName = uset.Value("*")
    'Output the list of settings in the
    'open category
    For Each setName In settingsList
        Debug.Print setName, uset.Value(setName)
    Next
    uset.Close
End Sub


%%PageItemTitle%% $$Members$$

IStep2 Overview

IStep2 Interface Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property BPStepParamFactory | The BPStepParamFactory for the current step.
Public Property DesignStepSource | The test ID of the test from which this step run originates.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The run step name.
Public Property Run | Gets the Run object handling this step.
Public Property Status | The run step status.
Public Property TestSource | The test ID of the test from which this step run originates.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

IStep2 Overview


%%PageItemTitle%% $$Members$$

IStep Overview

IStep Interface Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property DesignStepSource | The test ID of the test from which this step run originates.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The run step name.
Public Property Status | The run step status.
Public Property TestSource | The test ID of the test from which this step run originates.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

IStep Overview


%%PageItemTitle%% $$Members$$

IStepParams Overview | DesignStep Object | Test Object | TSTest Object | Run Object

See Also OTA COM Type Library

IStepParams Interface Members

Public Methods

Public Method AddParam | Adds a new parameter to the object.
Public Method ClearParam | Clears the parameter value by setting it to null.
Public Method DeleteParam | Deletes the specified parameter.
Public Method Refresh | Refreshes the data from the database, discarding changes.
Public Method Save | Uploads the parameter definitions to the database.

Public Properties

Public Property Count | The number of parameters for the object.
Public Property ParamExist | Checks if a parameter of this name exists.
Public Property ParamName | The name of the parameter in the specified position in the StepParams collection (zero-based).
Public Property ParamValue | The value of the specified parameter.
Public Property Type | Gets the parameter type: predefined, null, or regular.

See Also

IStepParams Overview | DesignStep Object | Test Object | TSTest Object | Run Object


%%PageItemTitle%% $$Members$$

IStream Overview

IStream Interface Members

Public Methods

Public Method Clone
Public Method Commit
Public Method LockRegion
Public Method RemoteCopyTo
Public Method RemoteSeek
Public Method Revert
Public Method SetSize
Public Method Stat
Public Method UnlockRegion

See Also

IStream Overview


%%PageItemTitle%% $$Members$$

IStream Interface

ISequentialStream Implemented Interface Members

Methods

Public Implemented Method RemoteRead
Public Implemented Method RemoteWrite

See Also

IStream Interface


%%PageItemTitle%%

IStream Interface | ISequentialStream Implemented Interface

pv
cb
pcbRead
See Also OTA COM Type Library

RemoteRead Implemented Method

Syntax

Public Sub RemoteRead( _
   ByRef pv As Byte, _
   ByVal cb As ULong, _
   ByRef pcbRead As ULong _
)

Parameters

pv
cb
pcbRead

See Also

IStream Interface | ISequentialStream Implemented Interface


%%PageItemTitle%%

IStream Interface | ISequentialStream Implemented Interface

pv
cb
pcbWritten
See Also OTA COM Type Library

RemoteWrite Implemented Method

Syntax

Public Sub RemoteWrite( _
   ByRef pv As Byte, _
   ByVal cb As ULong, _
   ByRef pcbWritten As ULong _
)

Parameters

pv
cb
pcbWritten

See Also

IStream Interface | ISequentialStream Implemented Interface


%%PageItemTitle%% $$Members$$

IStringRepresentation Overview

IStringRepresentation Interface Members

Public Methods

Public Method ToString The string representation of the object.

See Also

IStringRepresentation Overview


%%PageItemTitle%% $$Members$$

ISubjectNode Overview

ISubjectNode Interface Members

Public Methods

Public Method AddNode | Adds a new child node.
Public Method FindChildNode | Finds a child node by node name.
Public Method FindChildren | Finds node children according to specified search pattern.
Public Method FindTests | Finds tests within the current subject folder whose name matches the specified text pattern.
Public Method Move | Moves the current tree mode to be under the specified parent.
Public Method NewList | Gets a list of the node's immediate children.
Public Method Post | Posts all changed values to the database.
Public Method Refresh | Reads the saved node data, overwriting values in memory.
Public Method RemoveSubjectNode | Removes the specified node from the subject tree.

Public Properties

Public Property Attachments | The AttachmentFactory for the subject folder.
Public Property Attribute | Gets the node attribute.
Public Property Child | Gets a sub-folder of the current folder.
Public Property Count | The number of child nodes.
Public Property DepthType | The sub-tree depth type.
Public Property Description | A description of the subject node.
Public Property Father | The current folder's parent folder.
Public Property HasAttachment | Checks if the SubjectNode has at least one attachment.
Public Property Name | The node name.
Public Property NodeID | The node ID number.
Public Property Path | The folder tree path starting from the tree root.
Public Property TestFactory | The TestFactory object for the subject folder.
Public Property ViewOrder | The position of the node in the tree as presented in the user interface.

See Also

ISubjectNode Overview


%%PageItemTitle%% $$Members$$

ISupportCopyPaste2 Overview

ISupportCopyPaste2 Interface Members

Public Properties

Public Property PasteToCurrentProject Checks if the paste target is in the same project from which the material was copied.

See Also

ISupportCopyPaste2 Overview


%%PageItemTitle%% $$Members$$

ISupportCopyPaste2 Interface

ISupportCopyPaste Implemented Interface Members

See Also

ISupportCopyPaste2 Interface


%%PageItemTitle%% $$Members$$

ISupportCopyPaste Overview

ISupportCopyPaste Interface Members

Public Methods

Public Method CopyToClipBoard | Copies data into clipboard.
Public Method PasteFromClipBoard | Pastes data from clipboard.

See Also

ISupportCopyPaste Overview


%%ItemTitle%%

OTA COM Type Library

Copy a requirement

Source code

Private Sub CopyPasteReq(IDSFilter, CopyMode, Path, TargetID, PasteMode, OrderID)
'Copy a requirement
    Dim iscp As ISupportCopyPaste
    Dim clipboard As String
    Set iscp = tdc.reqFactory
    clipboard = iscp.CopyToClipBoard(IDSFilter, CopyMode, Path)
    iscp.PasteFromClipBoard clipboard, TargetID, PasteMode, OrderID
    Set iscp = Nothing
End Sub


%%ItemTitle%%

OTA COM Type Library

Copy test plan folder

Source code

Private Sub CopyPasteTestPlanFolder(sourceFolderPath, destFolderPath)
'Copy test plan folder
'Copy a test plan folder.
' For example:
' CopyPasteTestPlanFolder "Subject\TestFolder1", "Subject\TestFolder2"
' Creates new folder, Subject\TestFolder2\TestFolder1 with all the
' contents of Subject\TestFolder1
    Dim treeMng As TreeManager
    Dim sourceFolder As SubjectNode
    Dim destFolder As SubjectNode
    Dim iscp As ISupportCopyPaste
    Dim clipboard As String
     Set treeMng = tdc.TreeManager
     Set sourceFolder = treeMng.NodeByPath(sourceFolderPath)
     Set destFolder = treeMng.NodeByPath(destFolderPath)
     Set iscp = sourceFolder
    clipboard = iscp.CopyToClipBoard(sourceFolder.NodeID, 0, sourceFolderPath)
    Set iscp = destFolder
    iscp.PasteFromClipBoard clipboard, destFolder.NodeID, 0, -1
    Set treeMng = Nothing
    Set sourceFolder = Nothing
    Set destFolder = Nothing
    Set iscp = Nothing
End Sub


%%ItemTitle%%

OTA COM Type Library

Copy test set folder

Source code

Private Sub CopyPasteTestSetFolder(sourceFolderPath, destFolderPath)
'Copy a test plan folder
'For example, CopyPasteTestSetFolder "Root\TestLabFolder1", "Root\TLabFolder2"
' Creates a new folder, Root\TLabFolder2\TestLabFolder1 having all the
' contents of Root\TestLabFolder1
     Dim treeMng As TestSetTreeManager
     Dim sourceFolder As testSetFolder
     Dim destFolder As testSetFolder
     Dim iscp As ISupportCopyPaste
     Dim clipboard As String
     Set treeMng = tdc.TestSetTreeManager
     Set sourceFolder = treeMng.NodeByPath(sourceFolderPath)
     Set destFolder = treeMng.NodeByPath(destFolderPath)
     Set iscp = sourceFolder
     clipboard = iscp.CopyToClipBoard(sourceFolder.NodeID, 0, sourceFolderPath)
     Set iscp = destFolder
     iscp.PasteFromClipBoard clipboard, destFolder.NodeID, 0, -1
     Set treeMng = Nothing
     Set sourceFolder = Nothing
     Set destFolder = Nothing
     Set iscp = Nothing
End Sub


%%ItemTitle%%

OTA COM Type Library

Copy test set

Source code

Private Sub CopyPasteTestSet(testsetid, CopyMode, destFolderID, PasteMode, OrderID)
'Copy test set
    Dim iscp As ISupportCopyPaste
    Dim clipboard As String
    Dim testSetF As testsetFactory
    Set testSetF = tdc.testsetFactory
    Set iscp = testSetF
    clipboard = iscp.CopyToClipBoard(testsetid, CopyMode, "")
    iscp.PasteFromClipBoard clipboard, destFolderID, PasteMode, OrderID
    Set iscp = Nothing
    Set testSetF = Nothing
End Sub


%%ItemTitle%%

OTA COM Type Library

Copy-paste: Copy a defect

Source code

Private Sub CopyPasteBug(IDSFilter, CopyMode, Path, TargetID, PasteMode, OrderID)
    Dim iscp As ISupportCopyPaste
    Dim clipboard As String
    ' Type cast
    Set iscp = tdc.BugFactory
    clipboard = iscp.CopyToClipBoard(IDSFilter, CopyMode, Path)
    iscp.PasteFromClipBoard clipboard, TargetID, PasteMode, OrderID
    Set iscp = Nothing
End Sub


%%PageItemTitle%% $$Members$$

ISupportEntityTypes Overview

ISupportEntityTypes Interface Members

Public Methods

Public Method GetTypedFields | The list of fields for the given type.
Public Method IsFieldRelevantToType | Indicates whether the field is used in this type.
Public Method IsFieldRequiredInType | Indicates whether the field is required in this type.

See Also

ISupportEntityTypes Overview


%%PageItemTitle%% $$Members$$

ISupportRBTAnalysisChild Overview

ISupportRBTAnalysisChild Interface Members

Public Properties

Public Property AnalyzedTestingEffortInHours | The testing effort determined by the last analysis, in hours.
Public Property AnalyzedTestingLevel | The testing level determined by the last analysis, from 'RBT Testing Levels' in ALL_LISTS.
Public Property CustomTestingEffortInHours | The custom testing effort, in hours.
Public Property CustomTestingLevel | The custom testing level supplied, from 'RBT Testing Levels' in ALL_LISTS.
Public Property IgnoreInAnalysis | Should this requirement be excluded in RBT analysis?
Public Property ParentRequirementForRBTAnalysis | The parent requirement for the current RBT Analysis.
Public Property RnDEstimatedEffortInHours | The R&D effort, in hours.
Public Property UseCustomTLAndTE | Does this requirement have a custom Testing Level and Testing Effort?.

See Also

ISupportRBTAnalysisChild Overview


%%PageItemTitle%% $$Members$$

ISupportRBTAnalysisParent Overview

ISupportRBTAnalysisParent Interface Members

Public Methods

Public Method AnalyzeAndSave | Do analysis, create analysis results and save testing levels to all children Reqs.
Public Method AnalyzeButDontSave | Do analysis, create analysis results, but do not save testing levels in children yet.
Public Method ApplyPolicyOnResultMatix | Use current policy matrix and re-apply it on the aggregated counts matrix to calculate total analyzed reqs duration in hours.
Public Method ResetPolicyToDefaults | Copy the policy from customization.

Public Properties

Public Property AnalysisFilter | The filter used for the Analysis.
Public Property AnalysisResultAggregatedRNDEffortsInHours | Time in hours it would take RnD to handle this requirement, as simple aggregative addition of RND efforts set in children that were visited in last analysis.
Public Property AnalysisResultAnalyzedDurationInHours | Time in hours it would take to test the reqs without CustomTestingLevel, i.e. the regular analyzed reqs, with this policy set in the related RBT Analysis setup.
Public Property AnalysisResultCountCustomizedRequirements | Count of all child requirements visited in last analysis that their Testing Efforts were customized (not set by analysis)
Public Property AnalysisResultCountIgnoredRequirements | Count of all child requirements ignored in last analysis
Public Property AnalysisResultCountNonCustomizedRequirements | For each possible risk (pair of BI and FP levels) - return the total Count of child requirements that were visited in last analysis and that are assessed to be in this Risk (Pair), and their Efforts were not customized
Public Property AnalysisResultCountUnanalyzableRequirements | Count of all child requirements visited in last analysis that could not be analyzed due to missing Assessment or incomplete custom effort
Public Property AnalysisResultCustomizedDurationInHours | Time in hours it would take to test the reqs with CustomTestingLevel with this policy set in the related RBT Analysis setup.
Public Property AnalysisResultLastAnalysisDate | The Date/Time of the last analysis done on this parent req
Public Property AvailableTimeInHours | Available hours for this RBT Analysis.
Public Property FPLevelTestingEffortInHours | Hours needed to test a requirement in the given Failure Probability.
Public Property IsAnalyzed | Is this Requirement (parent) RBT analyzed. Does it have valid result data
Public Property TestingEffortInHoursFromPolicyMatrix | Calculated Hours needed to test a requirement in the given Failure Probability and Business Impact, according to the current policy.
Public Property TestingLevelPercentage | Testing level percentage (of the full testing level).
Public Property TestingPolicyMatrix | Risk testing level matrix

See Also

ISupportRBTAnalysisParent Overview


%%PageItemTitle%% $$Members$$

ISupportRBTAssessment Overview

ISupportRBTAssessment Interface Members

Public Methods

Public Method AssessBILevel | Assess the Business Impact risk level for this requirement, according to the answers provided.
Public Method AssessFPLevel | Assess the Failure Probability risk level for this requirement, according to the answers provided.

Public Properties

Public Property AssessedBILevel | Business Impact risk level for this requirement, from the last time we called AssessBILevel.
Public Property AssessedFPLevel | Failure Probability risk level for this requirement, from the last time we called AssessFPLevel.
Public Property BIChosenAnswerForQuestion | The chosen Answer to this Business Impact question for this requirement.
Public Property CustomBILevel | Custom Business Impact level, overrides the assessed level.
Public Property CustomFPLevel | Custom Failure Probability level, overrides the assessed level.
Public Property EffectiveBILevel | Effective Business Impact level.
Public Property EffectiveFPLevel | Effective Failure Probability level.
Public Property FPChosenAnswerForQuestion | The chosen Answer to this Failure Probability question for this requirement.
Public Property UseCustomBILevel | Does this requirement have a custom Business Impact level?.
Public Property UseCustomFPLevel | Does this requirement have a custom Failure Probability level?.

See Also

ISupportRBTAssessment Overview


%%PageItemTitle%% $$Members$$

ISysTreeNode2 Overview

ISysTreeNode2 Interface Members

Public Methods

Public Method AddNode | Adds a new child node.
Public Method FindChildNode | Finds a child node by node name.
Public Method FindChildren | Finds node children according to specified search pattern.
Public Method NewList | Gets a list of the node's immediate children.
Public Method Post | Posts all changed values to the database.
Public Method Refresh | Reads the saved node data, overwriting values in memory.
Public Method RemoveNode | Deletes the specified node.

Public Properties

Public Property Attribute | Gets the node attribute.
Public Property Child | Gets a sub-folder of the current folder.
Public Property Count | The number of child nodes.
Public Property DepthType | The sub-tree depth type.
Public Property Father | The current folder's parent folder.
Public Property Name | The node name.
Public Property NodeID | The node ID number.
Public Property Path | The folder tree path starting from the tree root.
Public Property Type | The nodes's type.

See Also

ISysTreeNode2 Overview


%%PageItemTitle%% $$Members$$

ISysTreeNode Overview

ISysTreeNode Interface Members

Public Methods

Public Method AddNode | Adds a new child node.
Public Method FindChildNode | Finds a child node by node name.
Public Method FindChildren | Finds node children according to specified search pattern.
Public Method NewList | Gets a list of the node's immediate children.
Public Method Post | Posts all changed values to the database.
Public Method Refresh | Reads the saved node data, overwriting values in memory.
Public Method RemoveNode | Deletes the specified node.

Public Properties

Public Property Attribute | Gets the node attribute.
Public Property Child | Gets a sub-folder of the current folder.
Public Property Count | The number of child nodes.
Public Property DepthType | The sub-tree depth type.
Public Property Father | The current folder's parent folder.
Public Property Name | The node name.
Public Property NodeID | The node ID number.
Public Property Path | The folder tree path starting from the tree root.

See Also

ISysTreeNode Overview


%%PageItemTitle%% $$Members$$

ITableProperties Overview

ITableProperties Interface Members

Public Properties

Public Property Name | The DB name of the table.
Public Property UserLabel | The display name of the table.

See Also

ITableProperties Overview


%%PageItemTitle%% $$Members$$

ITDConnection Overview

ITDConnection Interface Members

Public Methods

Public Method ChangePassword | Changes the password for the currently logged in user.
Public Method ConnectProject | Connects to the specified project.
Public Method ConnectProjectEx | Connects to the specified project in the specified domain.
Public Method DisconnectProject | Disconnects from the project.
Public Method GetLicenses | Allocates multiple licenses types according to the LicensesType parameter.
Public Method GetLicenseStatus | The license status for the specified client type.
Public Method GetTDVersion | The major and minor versions of the OTA API.
Public Method InitConnectionEx | Initializes the connection.
Public Method PurgeRuns | Deletes the runs in this connection that match the input arguments.
Public Method ReleaseConnection | ReleaseConnection must be called for each call of an initialization method after finishing work with the Open Test Architecture API.
Public Method SendMail | Sends Mail.

Public Properties

Public Property ActionPermission | The ActionPermission object for this connection.
Public Property AlertManager | The AlertManager object for this connection.
Public Property BugFactory | The Bug Factory object for this connection.
Public Property CheckoutRepository | The path of the checkout repository.
Public Property Command | The Command object for this connection.
Public Property CommonSettings | The Settings object for all users in this connection.
Public Property Connected | Checks if the Open Test Architecture API server connection is initialized.
Public Property Customization | The Customization object for this connection.
Public Property DBName | The name of the database.
Public Property DBType | The database type.
Public Property DirectoryPath | The path of the server side repository directory for the database repository type.
Public Property DomainName | The current domain.
Public Property DomainsList | The domain names for this site.
Public Property ExtendedStorage | The ExtendedStorage object for this connection.
Public Property Fields | A list of fields for the table specified in the DataType argument.
Public Property HostFactory | The Hosts Factory object for this connection.
Public Property HostGroupFactory | The HostGroupFactory object for this connection.
Public Property IgnoreHtmlFormat | Indicates if formatted memo and description fields are returned as plain text without HTML tags.
Public Property MailConditions | The TDMailConditions object for this connection.
Public Property ProjectConnected | Checks if the TDConnection is connected to a project.
Public Property ProjectName | The name of the connected project.
Public Property ProjectProperties | The ProjectProperties object for this connection.
Public Property ProjectsList | The projects that are available in the domain to which Quality Center is connected.
Public Property ProjectsListEx | The projects available within the specified domain.
Public Property ReportRole | The report role of the connected user.
Public Property ReqFactory | The ReqFactory object for this connection.
Public Property Rules | The RuleManager object for this connection.
Public Property RunFactory | The RunFactory object for this connection.
Public Property ServerName | The name of the connected Open Test Architecture API server.
Public Property ServerTime | The time and date of the currently connected database server.
Public Property ServerURL | The URL of the connected server.
Public Property TDParams | Gets the value of the parameter whose name is specified by Request.
Public Property TestFactory | The Test Factory object for this connection.
Public Property TestRepository | The path of the tests directory of the connected project.
Public Property TestSetFactory | The Test Set Factory object for this connection.
Public Property TestSetTreeManager | The TestSetTreeManager object for this connection.
Public Property TextParam | The TextParser object.
Public Property TreeManager | The TreeManager object for the system tree.
Public Property UserGroupsList | The names of the user groups of the currently connected project.
Public Property UserName | The user connected to the project.
Public Property UserSettings | The Settings object for the logged-on user.
Public Property UsersList | The names of the users of the currently connected project.
Public Property UsingProgress | Indicates if a progress bar is displayed.
Public Property VCS | The Version Control System (VCS) object for this connection.
Public Property VcsDbRepository | The path of the VCS database of the connected project.

See Also

ITDConnection Overview


%%ItemTitle%%

OTA COM Type Library

A: Getting Started - A simple filter

Source code

Public Sub FilterReqsByType()
' Filter requirements by type
' Fetch all the requirements of certain type (e.g. Business).
Dim reqFactory As IReqFactory2
Dim list As IList
Dim filter As ITDFilter
Dim req As IReq
Dim RType As ReqType
Set reqFactory = tdc.reqFactory
Set filter = reqFactory.filter
'Value of predefined type is from TDAPI_PREDEFINED_REQ_TYPES
filter.filter("RQ_TYPE_ID") = REQ_TYPE_BUSINESS 'REQ_TYPE_UNDEFINED
''Value of custom type is the type ID, for example:
'filter.filter("RQ_TYPE_ID") = 101
Set list = filter.NewList
For Each req In list
    Debug.Print req.Name & " : " & CStr(req.TypeId) & " : " & req.RequirementType.Name
Next
End Sub


%%ItemTitle%%

OTA COM Type Library

A: Getting Started - Creating a new defect

Source code

Public Sub AddBug()
    Dim bugF As BugFactory
    Set bugF = tdc.BugFactory
    Dim bug1 As Bug
    Set bug1 = bugF.AddItem(Null)
    bug1.AutoPost = False
    bug1.AssignedTo = "steves"
    bug1.DetectedBy = "steves"
    bug1.Priority = "1-Low"
    bug1.Status = "New"
    bug1.Summary = "test bug summary"
    bug1.field("BG_DESCRIPTION") = "description of the bug"
    bug1.field("BG_DETECTION_DATE") = "2006-02-02 12:00:01"
    bug1.field("BG_SEVERITY") = "2-Medium"
    bug1.field("BG_REPRODUCIBLE") = "Y"
    bug1.field("BG_PRIORITY") = "2-Medium"
    bug1.field("BG_RESPONSIBLE") = "annab"
    bug1.field("BG_STATUS") = "New"
    bug1.field("BG_USER_01") = "123"
    bug1.field("BG_USER_02") = "abcd"
    bug1.field("BG_USER_03") = "item_1"
    bug1.field("BG_USER_04") = "sa"
    bug1.field("BG_USER_05") = "15-Feb-2006"
    bug1.Post
 End Sub


%%ItemTitle%%

OTA COM Type Library

A: Getting Started - Delete a defect

Source code

Private Sub DeleteBug(BugNum As Integer)
    Dim bugF As BugFactory
    Set bugF = tdc.BugFactory
    bugF.RemoveItem (BugNum)
End Sub


%%ItemTitle%%

OTA COM Type Library

A: Getting Started - Find tests that are not in any test set

Source code

Public Sub ListUnusedTests()
'Get the list of tests that are not in any test set
    Dim testSetF As testsetFactory
    Dim testF As testFactory
    Dim testSetFilter As TDFilter
    Dim TestFilter As TDFilter
    Dim aTest As Test
    Dim testL As list
    Set testSetF = tdc.testsetFactory
    Set testSetFilter = testSetF.filter
    'Exclude the default test set
    testSetFilter.filter("CY_CYCLE") = ">= 0"
    Set testF = tdc.testFactory
    Set TestFilter = testF.filter
    TestFilter.SetXFilter "TEST-TESTSET", False, testSetFilter.Text
    Set testL = testF.NewList(TestFilter.Text)
    Dim Item
    For Each Item In testL
        Debug.Print Item.Name
    Next Item
End Sub


%%ItemTitle%%

OTA COM Type Library

A: Getting Started - Find tests that do not cover any requirement

Source code

Public Sub UnneededTests()
' Get the list of tests that do not cover any requirement
    Dim reqF As reqFactory
    Dim testF As testFactory
    Dim ReqFilter As TDFilter
    Dim TestFilter As TDFilter
    Dim aTest As Test
    Dim testL As list
    Set reqF = tdc.reqFactory
    Set ReqFilter = reqF.filter
    'Exclude the top-level folder
    ReqFilter.filter("RQ_REQ_ID") = ">= 0"
    ' Set exclusive XFilter: Filter for items that
    ' match primary filter and do not match cross filter.
    Set testF = tdc.testFactory
    Set TestFilter = testF.filter
    TestFilter.SetXFilter "TEST-REQ", False, ReqFilter.Text
    Debug.Print TestFilter.Text
    Set testL = testF.NewList(TestFilter.Text)
    For Each aTest In testL
        Debug.Print aTest.ID & ": " & aTest.Name
    Next
' 'To get the tests that DO cover some requirement:
' TestFilter.SetXFilter "TEST-REQ", True, ReqFilter.Text
' Debug.Print TestFilter.Text
' Set testL = testF.NewList(TestFilter.Text)
'
' For Each aTest In testL
' Debug.Print aTest.ID & ": " & aTest.Name
' Next
End Sub


%%ItemTitle%%

OTA COM Type Library

A: Getting Started - Formatting time for use in filter

Source code

Public Function RetrieveModifiedRecords()
' List the requirements modified in the last 24 hours.
On Error GoTo ErrorHandler:
    Dim m_filter As TDAPIOLELib.TDFilter
    Dim reqFactory As TDAPIOLELib.reqFactory
    Dim ReqList As list
    Set reqFactory = tdc.reqFactory
    Debug.Assert Not reqFactory Is Nothing
    Set m_filter = reqFactory.filter
    Debug.Assert Not m_filter Is Nothing
    Dim sinceDate As Date, currentSyncDate As Date
    sinceDate = DateAdd("d", -1, Date) '24 hours ago
    currentSyncDate = Date ' Now
    ' Create the filter, formatting the Date type
    ' as the required string:
    ' RQ_VTS > "2007-04-15 00:00:00" AND <> "2007-04-16 00:00:00"
    m_filter.filter("RQ_VTS") = "> " _
        & Chr(34) & Format(sinceDate, "yyyy-mm-dd hh:mm:ss") & Chr(34) & _
        " AND <> " & _
        Chr(34) & Format(currentSyncDate, "yyyy-mm-dd hh:mm:ss") & Chr(34)
' ' Sort by parents before children.
' m_filter.Order("RQ_REQ_PATH") = 1
' m_filter.OrderDirection("RQ_REQ_PATH") = TDAPIOLELib.TDOLE_ASCENDING
    ' Sort by modification time.
    m_filter.Order("RQ_VTS") = 1
    m_filter.OrderDirection("RQ_VTS") = TDAPIOLELib.TDOLE_ASCENDING
    Set ReqList = m_filter.NewList
    Dim r As req
    For Each r In ReqList
        Debug.Print r.Name
    Next
    Exit Function
ErrorHandler:
    Err.Raise Err.Number, Err.Source, Err.Description
End Function


%%ItemTitle%%

OTA COM Type Library

Alerts: Adding a follow-up flag to a defect

Source code

Private Sub AddFollowUpFlagForBug(BugID)
    Dim bugF As BugFactory
    Dim Bug As Bug
    Dim followupbug As IFollowUpManager
    Set bugF = tdc.BugFactory
    Set Bug = bugF.Item(BugID)
    Set followupbug = Bug
    followupbug.SetFollowUp CDate("01/01/07"), "Check if fix documented"
End Sub


%%ItemTitle%%

OTA COM Type Library

Alerts: Check if a defect has a follow-up

Source code

Private Sub CheckIfBugHasFollowUp()
    Dim aFollowUp As IFollowUpManager
    Dim aBug As Bug
    Dim aList As list
    Dim bugF As BugFactory
    Set bugF = tdc.BugFactory
    'Set aBug = bugF.Item(4)
    Set aList = bugF.NewList("")
    Set aBug = aList(1)
    'Type cast:
    Set aFollowUp = aBug
    'Is follow-up flag set?
    MsgBox aFollowUp.HasFollowUp
  End Sub


%%ItemTitle%%

OTA COM Type Library

Alerts: Check values of follow-up

Source code

Private Sub CheckValuesOfBugFollowUpFlag()
    Dim bugF As BugFactory
    Dim Bug As Bug
    Dim followupbug As IFollowUpManager
    Dim Description As String
    Dim followUpDate As Date
    Set bugF = tdc.BugFactory
    Set Bug = bugF.Item(13)
    Set followupbug = Bug
    followupbug.GetFollowUp followUpDate, Description
    If followUpDate = "13-07-06" Then
        MsgBox "date ok"
    End If
    If Description = "" Then
'~~~~ ??
        MsgBox "Description ok"
    End If
End Sub


%%PageItemTitle%%

ITDConnection Interface

ProjectName
The name of the project in the Quality Center data base.
UserName
The user name defined in the Quality Center data base.
Password
The user's password.
See Also OTA COM Type Library

ConnectProject Method

Description

Connects to the specified project.

Syntax

Public Sub ConnectProject( _
   ByVal ProjectName As String, _
   ByVal UserName As String, _
   Optional ByVal Password As String = "" _
)

Parameters

ProjectName
The name of the project in the Quality Center data base.
UserName
The user name defined in the Quality Center data base.
Password
The user's password.

Remarks

This method is deprecated from version 9.0.

Use Login and Connect.

To continue to use this method after it is made obsolete, you must set the BACKWARD_SUPPORT_ALL_DOMAINS_PROJECTS flag in the site configuration. For details, see the Mercury Quality Center Administrator's Guide.

See Also

ITDConnection Interface


%%PageItemTitle%%

ITDConnection Interface

DomainName
The logical group of projects in the Quality Center data base.
ProjectName
The name of the project in the Quality Center data base.
UserName

The name of a user defined in the specified project.

Password

The user password.

See Also OTA COM Type Library

ConnectProjectEx Method

Description

Connects to the specified project in the specified domain.

Syntax

Public Sub ConnectProjectEx( _
   ByVal DomainName As String, _
   ByVal ProjectName As String, _
   ByVal UserName As String, _
   Optional ByVal Password As String = "" _
)

Parameters

DomainName
The logical group of projects in the Quality Center data base.
ProjectName
The name of the project in the Quality Center data base.
UserName

The name of a user defined in the specified project.

Password

The user password.

Remarks

This method is deprecated from version 9.0.

Use Login and Connect.

See Also

ITDConnection Interface


%%ItemTitle%%

OTA COM Type Library

Customization: Add a customization list

Source code

Public Sub AddList()
    Dim custom As Customization
    Set custom = tdc.Customization
    Dim lists As CustomizationLists
    Set lists = custom.lists
    lists.AddList ("Delay_Reasons")
    custom.Commit
End Sub


%%PageItemTitle%%

ITDConnection Interface

DisconnectProject Method

Description

Disconnects from the project.

Syntax

Public Sub DisconnectProject()

Remarks

This method is deprecated from version 9.0.

Use Disconnect and Logout.

To continue to use this method, you must set the BACKWARD_SUPPORT_ALL_DOMAINS_PROJECTS flag in the site configuration. For details, see the Mercury Quality Center Administrator's Guide.

See Also

ITDConnection Interface


%%PageItemTitle%%

ITDConnection Interface

DomainsList Property

Description

The domain names for this site.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DomainsList() As List

Remarks

This property is obsolete.

To continue to use this property, you must set the BACKWARD_SUPPORT_ALL_DOMAINS_PROJECTS flag in the site configuration. For details, see the Mercury Quality Center Administrator's Guide.

See Also

ITDConnection Interface


%%ItemTitle%%

OTA COM Type Library

Links: Adding a defect to a link

Source code

Private Sub AddBugToBugLink()
    Dim linkF As LinkFactory
    Dim link As link
    Dim ilink As ILinkable
    Dim bugF As BugFactory
    Dim Bug As Bug
    Dim linkedBug As Bug
    Set bugF = tdc.BugFactory
    Set Bug = bugF.Item(6)
    Set linkedBug = bugF.Item(12)
    Set ilink = Bug
    Set linkF = ilink.BugLinkFactory
    Set link = linkF.AddItem(12)
    link.Post
End Sub


%%ItemTitle%%

OTA COM Type Library

Links: Get link from defect to test

Source code

Private Sub LinkBugToReq()
    Dim linkF As LinkFactory
    Dim link As link
    Dim ilink As ILinkable
    Dim bugF As BugFactory
    Dim Bug As Bug
    Dim reqF As ReqFactory
    Dim req As req
    Set reqF = tdc.ReqFactory
    Set req = reqF.Item(11)
    Set bugF = tdc.BugFactory
    Set Bug = bugF.Item(1)
    Set ilink = req
    Set linkF = ilink.BugLinkFactory
    Set link = linkF.AddItem(Bug)
    link.Post
End Sub


%%ItemTitle%%

OTA COM Type Library

Links: Link a defect to a Run test step

Source code

Private Sub LinkBugToStep()
    Dim linkF As LinkFactory
    Dim link As link
    Dim ilink As ILinkable
    Dim bugF As BugFactory
    Dim Bug As Bug
    Dim stepsList As list
    Dim runF As RunFactory
    Dim run1 As Run
    Set runF = tdc.RunFactory
    Set run1 = runF.Item(71)
    Dim stepF As StepFactory
    Dim step1 As Step
    Dim filter As TDFilter
    Dim stepList As list
    Set stepF = run1.StepFactory
    Set filter = stepF.filter
    Set stepsList = filter.NewList
    Set step1 = stepsList.Item(1)
    Set bugF = tdc.BugFactory
    Set Bug = bugF.Item(26)
    Set ilink = step1
    Set linkF = ilink.BugLinkFactory
    Set link = linkF.AddItem(Bug)
    link.Post
    ' Disconnect tdc
End Sub


%%ItemTitle%%

OTA COM Type Library

Links: Removing a link between defects

Source code

Private Sub RemoveBugToBugLink()
    Dim linkF As LinkFactory
    Dim link As link
    Dim ilink As ILinkable
    Dim bugF As BugFactory
    Dim Bug As Bug
    Dim aFilter As TDFilter
    Dim list As list
    Set bugF = tdc.BugFactory
    Set Bug = bugF.Item(6)
    Set ilink = Bug
    Set linkF = ilink.BugLinkFactory
    Set aFilter = linkF.filter
    aFilter.filter("LN_BUG_ID") = 12
    Set list = linkF.NewList(aFilter.Text)
    Set link = list.Item(1)
    linkF.RemoveItem (link.ID)
End Sub


%%PageItemTitle%%

ITDConnection Interface

DomainName

The name of a domain of projects defined in the Quality Center site.

See Also OTA COM Type Library

ProjectsListEx Property

Description

The projects available within the specified domain.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ProjectsListEx( _
   ByVal DomainName As String _
) As List

Parameters

DomainName

The name of a domain of projects defined in the Quality Center site.

Remarks

This property is obsolete.

To continue to use this property, you must set the BACKWARD_SUPPORT_ALL_DOMAINS_PROJECTS flag in the site configuration. For details, see the Mercury Quality Center Administrator's Guide.

See Also

ITDConnection Interface


%%PageItemTitle%% $$Members$$

ITDField Overview

ITDField Interface Members

Public Methods

Public Method IsValidValue Checks if the input value is valid for the field.

Public Properties

Public Property Name | The database name of the current field.
Public Property Property | The FieldProperty object associated with the current field.
Public Property Type | The field database type.

See Also

ITDField Overview


%%PageItemTitle%% $$Members$$

ITDFilter2 Overview

ITDFilter2 Interface Members

Public Methods

Public Method Clear | Clears the current filter.
Public Method GetXFilter | Gets the cross filter specified by CrossEntities.
Public Method IsClear | Checks whether the filter is clear, including cross-filter settings
Public Method NewList | Creates a new list from current filter.
Public Method Refresh | Reads saved data and refreshes the fetched list according to the current filter, overwriting values in memory.
Public Method SetXFilter | Sets the filter for second entity, called a cross filter.

Public Properties

Public Property CaseSensitive | Indicates if the filter for the specified field is case sensitive. The default is False.
Public Property DataType | The filtered entity type.
Public Property Fields | The list of fields for the TDFilter's parent object.
Public Property Filter | The filter condition for the field specified by the FieldName.
Public Property Order | The position of the specified field in the list of the sort fields. (zero-based)
Public Property OrderDirection | The sort order: TDOLE_ASCENDING or TDOLE_DESCENDING
Public Property Text | The full fields filter as text.
Public Property XFilter | The cross filter according to the entity type.

See Also

ITDFilter2 Overview


%%PageItemTitle%% $$Members$$

ITDFilter Overview

ITDFilter Interface Members

Public Methods

Public Method Clear | Clears the current filter.
Public Method NewList | Creates a new list from current filter.
Public Method Refresh | Reads saved data and refreshes the fetched list according to the current filter, overwriting values in memory.

Public Properties

Public Property CaseSensitive | Indicates if the filter for the specified field is case sensitive. The default is False.
Public Property DataType | The filtered entity type.
Public Property Fields | The list of fields for the TDFilter's parent object.
Public Property Filter | The filter condition for the field specified by the FieldName.
Public Property Order | The position of the specified field in the list of the sort fields. (zero-based)
Public Property OrderDirection | The sort order: TDOLE_ASCENDING or TDOLE_DESCENDING
Public Property Text | The full fields filter as text.
Public Property XFilter | The cross filter according to the entity type.

See Also

ITDFilter Overview


%%PageItemTitle%% $$Members$$

ITDMailConditions Overview

ITDMailConditions Interface Members

Public Methods

Public Method Close | Closes and updates Mail Condition.
Public Method DeleteCondition | Deletes the Mail Condition.
Public Method Load | Loads Mail Conditions.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Condition | The defect-matching rule.
Public Property IsLocked | Checks if object is locked.
Public Property ItemList | Gets the list of Mail Condition Users.

See Also

ITDMailConditions Overview


%%PageItemTitle%% $$Members$$

ITest Overview

ITest Interface Members

Public Methods

Public Method CoverRequirement | Adds the specified requirement to the list of requirements covered by this test.
Public Method GetCoverList | Gets the list of all requirements covered by this test.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Mail | Mails the IBaseFieldExMail field item.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method RemoveCoverage | Removes a requirement from the list of requirements this test covers.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property CheckoutPathIfExist | The checkout path for the test.
Public Property DesignStepFactory | The design steps factory for the current test.
Public Property DesStepsNum | The number of design steps in the test.
Public Property ExecDate | The test execution date and time.
Public Property ExecStatus | The test execution status.
Public Property ExtendedStorage | The Extended Storage object for the current test.
Public Property Field | The value of the specified field.
Public Property FullPath | The full file system path for the test.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property HasCoverage | Checks if the test covers at least one requirement.
Public Property HasParam | Checks if the test has at least one parameter.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property LastRun | The last Run object for this test.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The test name.
Public Property Params | The current test parameters.
Public Property TemplateTest | Indicates if this test is a template test.
Public Property Type | The test type.
Public Property VCS | The VCS version control object for this test.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

ITest Overview


%%PageItemTitle%% $$Members$$

ITestExecStatus Overview

ITestExecStatus Interface Members

Public Properties

Public Property Message | The test execution message displayed in the Execution Controller grid.
Public Property Status | The test execution status.
Public Property TestId | The test Id.
Public Property TestInstance | The number of this instance of the design test in the test set.
Public Property TSTestId | The ID of the test instance for the current run.

See Also

ITestExecStatus Overview


%%PageItemTitle%% $$Members$$

ITestFactory Overview

ITestFactory Interface Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method BuildPerfGraph | Creates Performance Graph.
Public Method BuildProgressGraph | Creates graph showing number of tests in a test set executed over a period of time.
Public Method BuildProgressGraphEx | Creates graph showing number of tests in a test set executed over a period of time.
Public Method BuildSummaryGraph | Creates summary graph showing number of tests executed in a test set according to test and test run.
Public Method BuildTrendGraph | Creates graph that shows the number of defect status changes over time.
Public Method Mail | Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.
Public Property RepositoryStorage | An ExtendedStorage object connected by default to the test repository folder on the server side. Enables file system operations with a test repository.

See Also

ITestFactory Overview


%%PageItemTitle%% $$Members$$

ITestSet Overview

ITestSet Interface Members

Public Methods

Public Method BuildPerfGraph | Creates Performance Graph.
Public Method BuildProgressGraph | Builds test set progress graph.
Public Method BuildProgressGraphEx | Builds test set progress graph.
Public Method BuildSummaryGraph | Builds test set summary graph.
Public Method BuildTrendGraph | Creates graph that shows the test set changes over time.
Public Method CheckTestInstances | Gets information about the instances of the specified test in this test set.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method PurgeExecutions | Purges all the running executions within the test set.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method ResetTestSet | Sets the status of each test in the test set to 'No Run'.
Public Method StartExecution | Starts the execution controller.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property ConditionFactory | The condition factory object for the current test set.
Public Property ExecEventNotifyByMailSettings | Gets the execution mail notification settings for the current test set.
Public Property ExecutionSettings | Gets the execution settings for the test set.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The test set name.
Public Property Status | The test set status.
Public Property TestDefaultExecutionSettings | Gets default execution settings for tests.
Public Property TestSetFolder | The test set's parent node.
Public Property TSTestFactory | The factory object for the current test set.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

ITestSet Overview


%%PageItemTitle%% $$Members$$

ITestSetFactory Overview

ITestSetFactory Interface Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method BuildPerfGraph | Creates Performance Graph.
Public Method BuildProgressGraph | Creates graph showing number of tests in all test sets executed over a period of time.
Public Method BuildProgressGraphEx | Creates progress graph for specified test set.
Public Method BuildSummaryGraph | Creates a summary graph of test instances in a test set.
Public Method BuildTrendGraph | Creates graph showing the number of status changes over a time period.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

ITestSetFactory Overview


%%PageItemTitle%% $$Members$$

ITestSetFolder2 Overview

ITestSetFolder2 Interface Members

Public Methods

Public Method AddNode | Adds a new child node.
Public Method AddNodeDisp | Adds a new child node.
Public Method FindChildNode | Finds a child node by node name.
Public Method FindChildren | Finds node children according to specified search pattern.
Public Method FindTestInstances | Gets the list of test instances in all test sets in given folder and its subfolders that match the specified pattern.
Public Method FindTestSets | Gets the list of test sets contained in the folder that match the specified pattern.
Public Method Move | Moves folder node under new father.
Public Method NewList | Gets a list of the node's immediate children.
Public Method Post | Posts all changed values to the database.
Public Method Refresh | Reads the saved node data, overwriting values in memory.
Public Method RemoveNode | Deletes the specified node.
Public Method RemoveNodeEx | Deletes a test set folder node.

Public Properties

Public Property Attachments | The folder's AttachmentFactory object.
Public Property Attribute | Gets the node attribute.
Public Property Child | Gets a sub-folder of the current folder.
Public Property Count | The number of child nodes.
Public Property DepthType | The sub-tree depth type.
Public Property Description | The test set folder description.
Public Property Father | The current folder's parent folder.
Public Property FatherDisp | The parent node.
Public Property FatherID | The unique parent ID.
Public Property HasAttachment | Checks if this folder has at least one attachment.
Public Property Name | The node name.
Public Property NodeID | The node ID number.
Public Property Path | The folder tree path starting from the tree root.
Public Property SubNodes | The list of child nodes.
Public Property TestSetFactory | Gets the TestSetFactory for the folder.
Public Property ViewOrder | The index of this folder in its parent's list of sub-nodes.

See Also

ITestSetFolder2 Overview


%%PageItemTitle%% $$Members$$

ITestSetFolder3 Overview

ITestSetFolder3 Interface Members

Public Methods

Public Method AddNode | Adds a new child node.
Public Method AddNodeDisp | Adds a new child node.
Public Method FindChildNode | Finds a child node by node name.
Public Method FindChildren | Finds node children according to specified search pattern.
Public Method FindTestInstances | Gets the list of test instances in all test sets in given folder and its subfolders that match the specified pattern.
Public Method FindTestSets | Gets the list of test sets contained in the folder that match the specified pattern.
Public Method Move | Moves folder node under new father.
Public Method NewList | Gets a list of the node's immediate children.
Public Method Post | Posts all changed values to the database.
Public Method Refresh | Reads the saved node data, overwriting values in memory.
Public Method RemoveNode | Deletes the specified node.
Public Method RemoveNodeEx | Deletes a test set folder node.

Public Properties

Public Property Attachments | The folder's AttachmentFactory object.
Public Property Attribute | Gets the node attribute.
Public Property Child | Gets a sub-folder of the current folder.
Public Property Count | The number of child nodes.
Public Property DepthType | The sub-tree depth type.
Public Property Description | The test set folder description.
Public Property Father | The current folder's parent folder.
Public Property FatherDisp | The parent node.
Public Property FatherID | The unique parent ID.
Public Property FolderFields | Returns the list of fields of the test set folder.
Public Property HasAttachment | Checks if this folder has at least one attachment.
Public Property Name | The node name.
Public Property NodeID | The node ID number.
Public Property Path | The folder tree path starting from the tree root.
Public Property SubNodes | The list of child nodes.
Public Property TargetCycle | The cycle to which the folder is assigned.
Public Property TestSetFactory | Gets the TestSetFactory for the folder.
Public Property ViewOrder | The index of this folder in its parent's list of sub-nodes.

See Also

ITestSetFolder3 Overview


%%PageItemTitle%% $$Members$$

ITestSetFolder Overview

ITestSetFolder Interface Members

Public Methods

Public Method AddNode | Adds a new child node.
Public Method AddNodeDisp | Adds a new child node.
Public Method FindChildNode | Finds a child node by node name.
Public Method FindChildren | Finds node children according to specified search pattern.
Public Method FindTestSets | Gets the list of test sets contained in the folder that match the specified pattern.
Public Method Move | Moves folder node under new father.
Public Method NewList | Gets a list of the node's immediate children.
Public Method Post | Posts all changed values to the database.
Public Method Refresh | Reads the saved node data, overwriting values in memory.
Public Method RemoveNode | Deletes the specified node.
Public Method RemoveNodeEx | Deletes a test set folder node.

Public Properties

Public Property Attachments | The folder's AttachmentFactory object.
Public Property Attribute | Gets the node attribute.
Public Property Child | Gets a sub-folder of the current folder.
Public Property Count | The number of child nodes.
Public Property DepthType | The sub-tree depth type.
Public Property Description | The test set folder description.
Public Property Father | The current folder's parent folder.
Public Property FatherDisp | The parent node.
Public Property FatherID | The unique parent ID.
Public Property HasAttachment | Checks if this folder has at least one attachment.
Public Property Name | The node name.
Public Property NodeID | The node ID number.
Public Property Path | The folder tree path starting from the tree root.
Public Property SubNodes | The list of child nodes.
Public Property TestSetFactory | Gets the TestSetFactory for the folder.
Public Property ViewOrder | The index of this folder in its parent's list of sub-nodes.

See Also

ITestSetFolder Overview


%%PageItemTitle%% $$Members$$

ITestSetTreeManager Overview

ITestSetTreeManager Interface Members

Public Properties

Public Property NodeById | Gets the test set tree node object corresponding to the specified node Id.
Public Property NodeByPath | Gets the test set tree node from the specified tree path.
Public Property Root | The test set tree root node.
Public Property Unattached | Gets an unattached folder.

See Also

ITestSetTreeManager Overview


%%PageItemTitle%% $$Members$$

ITextParser Overview

ITextParser Interface Members

Public Methods

Public Method ClearParam | Clear the parameter - Set its value to null.
Public Method EvaluateText | Converts the parameters to their values.
Public Method Initialize | Initialization is generally performed by the infrastructure. Use this method after confirming the need with Mercury Support.

Public Properties

Public Property Count | Gets the number of parameters.
Public Property ParamExist | Checks if a parameter with the specified name exists.
Public Property ParamName | Gets the parameter name.
Public Property ParamType | Gets the user-defined Parameter Type.
Public Property ParamValue | The parameter value.
Public Property Text | The text to be parsed.
Public Property Type | Gets the Parameter Type - predefined, null, or regular.

See Also

ITextParser Overview


%%PageItemTitle%% $$Members$$

ITrace Overview

ITrace Interface Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Field | The value of the specified field.
Public Property FromReq | The requirement from which the association is defined.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property ToReq | The requirement to which the association is defined
Public Property TracedReq | The other requirement that the initiating requirement forms a trace with.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

ITrace Overview


%%PageItemTitle%% $$Members$$

ITreeManager Overview

ITreeManager Interface Members

Public Properties

Public Property NodeById | Gets the object having the specified node Id.
Public Property NodeByPath | Gets the node at the specified tree path.
Public Property NodePath | Gets the node path, slash separated.
Public Property RootList | Gets list of available trees in the specified range.
Public Property TreeRoot | The root node specified by the node name.

See Also

ITreeManager Overview


%%PageItemTitle%% $$Members$$

ITSScheduler Overview

ITSScheduler Interface Members

Public Methods

Public Method Run | Starts execution the test set or of the specified tests.
Public Method Stop | Stops execution of the test set or the specified tests.

Public Properties

Public Property ExecutionLog | The execution error or log message sent by the remote agent.
Public Property ExecutionStatus | The execution status object for the scheduler execution.
Public Property HostTimeOut | The time to wait for response before either sending test to another host in group or failing.
Public Property LogEnabled | Indicates if logging is enabled.
Public Property RunAllLocally | Indicates if all tests are to be run on the local host.
Public Property RunOnHost | The host on which to execute the test instance.
Public Property TdHostName | The host on which to run all tests in the current scheduler execution.

See Also

ITSScheduler Overview


%%PageItemTitle%% $$Members$$

ITSTest2 Overview | TestSet Object | Test Object

ITSTest2 Interface Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property ExecutionParams | The execution parameters for this test instance.
Public Property ExecutionSettings | The execution settings for this test instance.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property HasCoverage | Checks if the test instance covers at least one requirement.
Public Property HasSteps | Checks if the planning test specified by the Test property has design steps.
Public Property History | The History object for the object.
Public Property HostName | The name of the host planned to run this test instance.
Public Property ID | The item ID.
Public Property Instance | The instance number of this execution test, within the other instances of the same test.
Public Property IsLocked | Checks if object is locked.
Public Property LastRun | The Run object of the last run.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The name of this execution test. By convention, this is the test instance number and the test name.
Public Property Params | The step parameters for this execution test.
Public Property RunFactory | The Run Factory for this execution test.
Public Property Status | The execution test status.
Public Property Test | The planning test of which this execution test in an instance.
Public Property TestId | The ID of the design test of which this is an instance.
Public Property TestName | The name of the design test of which this is an instance.
Public Property TestSet | The test set to which the execution test belongs.
Public Property Type | The execution test type.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

ITSTest2 Overview | TestSet Object | Test Object


%%PageItemTitle%% $$Members$$

ITSTest Overview | TestSet Object | Test Object

ITSTest Interface Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property ExecutionParams | The execution parameters for this test instance.
Public Property ExecutionSettings | The execution settings for this test instance.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property HasSteps | Checks if the planning test specified by the Test property has design steps.
Public Property History | The History object for the object.
Public Property HostName | The name of the host planned to run this test instance.
Public Property ID | The item ID.
Public Property Instance | The instance number of this execution test, within the other instances of the same test.
Public Property IsLocked | Checks if object is locked.
Public Property LastRun | The Run object of the last run.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The name of this execution test. By convention, this is the test instance number and the test name.
Public Property Params | The step parameters for this execution test.
Public Property RunFactory | The Run Factory for this execution test.
Public Property Status | The execution test status.
Public Property Test | The planning test of which this execution test in an instance.
Public Property TestId | The ID of the design test of which this is an instance.
Public Property TestName | The name of the design test of which this is an instance.
Public Property TestSet | The test set to which the execution test belongs.
Public Property Type | The execution test type.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

ITSTest Overview | TestSet Object | Test Object


%%PageItemTitle%% $$Members$$

IVCS Overview

IVCS Interface Members

Public Methods

Public Method AddObjectToVcs | Adds an object to the Version control database.
Public Method CheckIn | Checks in an object.
Public Method CheckInEx | Checks in an object.
Public Method CheckOut | Checks out an object
Public Method DeleteObjectFromVCS | Deletes the object from the Version Control database.
Public Method LockVcsObject | Changes VCS object status from GET to CHECK-OUT. The object must be in a GET status to use this method.
Public Method Refresh | Refreshes the VCS object from the server to the client, overwriting values in memory.
Public Method SetCurrentVersion | This method is potentially destructive. Use only if necessary and with care. Sets the VCS object current version.
Public Method UndoCheckout | Undoes the check out operation, falling back to the current version on the server.

Public Properties

Public Property CheckoutInfo | A reference to a VersionItem object, containing the checkout information of the current object.
Public Property CurrentVersion | The current object latest version.
Public Property IsCheckedOut | Checks if the object is in CHECKED-OUT or GET status.
Public Property IsLocked | Checks if object is locked by the version control system.
Public Property LockedBy | The name of the locking user.
Public Property Version | The version the current user is viewing.
Public Property VersionInfo | A reference to a VersionItem object containing information about a specific version, specified by the Version argument.
Public Property Versions | A list of version strings, representing all the versions in the object.
Public Property VersionsEx | A list of IVersionItem references for accessing the details of each version in the object. .

See Also

IVCS Overview


%%PageItemTitle%% $$Members$$

IVersionItem Overview

IVersionItem Interface Members

Public Properties

Public Property Comments | The check-in comments.
Public Property Date | The check-in date.
Public Property IsLocked | Checks if the item is locked.
Public Property Time | The check-in time.
Public Property User | The user who performed the check-in.
Public Property Version | The version checked in.

See Also

IVersionItem Overview


%%PageItemTitle%% $$Members$$

Link Overview

Link Object Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Comment | The link summary comment.
Public Property CreatedBy | The user who created the link.
Public Property CreationDate | The link creation date.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property LinkedByEntity | The entity that initiated the link.
Public Property LinkType | The link type.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property SourceEntity | The source entity object of the link.
Public Property TargetEntity | The target entity object of the link.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

Link Overview


%%PageItemTitle%% $$Members$$

LinkFactory Overview

LinkFactory Object Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property FullLinkage | Indicates that NewList returns child objects in addition to the current object.
Public Property Item | Gets an object managed by the factory by its key.

See Also

LinkFactory Overview


%%ItemTitle%%

OTA COM Type Library

Getting a list of links from a Test Set

Source code

Public Sub TestSetLinks()
    Dim TSetFact As TestSetFactory
    Dim tsFact As TSTestFactory
    Dim aTestSet As TestSet
    Dim tsSets As list, Links As list
' Get the list of test sets from the test set factory
    'tdc is the global TDConnection object.
    Set TSetFact = tdc.TestSetFactory
    Set tsSets = TSetFact.NewList("")
' Get any test set (for demonstration purposes)
    Set aTestSet = tsSets.Item(1)
    Debug.Print aTestSet.ID, aTestSet.Name
' To get the BugLinkFactory,
' cast the test set variable to an ILinkable
' reference. Note that implemented interfaces are
' not directly accessible, so this won't work:
' Set LinkF = TestSet.BugLinkFactory
'
    Dim iLink As ILinkable
' The cast:
    Set iLink = aTestSet
' Get the factory from the iLinkable reference
    Dim linkF As LinkFactory
    Set linkF = iLink.BugLinkFactory
' Now use the factory
'
'-------------------------------------
' Application code
    Set Links = linkF.NewList("")
    Debug.Print Links.Count
    ' etc.
'-------------------------------------
End Sub


%%PageItemTitle%% $$Members$$

LinkFactory Object

IBaseFactory2 Implemented Interface Members

See Also

LinkFactory Object


%%PageItemTitle%% $$Members$$

Link Object

IBaseField2 Implemented Interface Members

See Also

Link Object


%%PageItemTitle%% $$Members$$

List Overview

List Collection Members

Public Methods

Public Method Add | Adds a new item to the current list object.
Public Method Insert | Inserts a new item at the specified position.
Public Method Remove | Removes the specified item from the current list object.
Public Method Swap | Swaps the two list items specified by their positions.

Public Properties

Public Property _NewEnum | Gets an IEnumVARIANT enumerator. For information on the IEnumVARIANT, see Microsoft documentation.
Public Property Count | The number of items in the list.
Public Property Item | Gets an item by index. The index is one-based.

See Also

List Overview


%%ItemTitle%%

OTA COM Type Library

Get Table Fields Count

Source code

Public Sub CheckValidValue(Optional TableName As String = "BUG")
    Dim BugFact As BugFactory
    Dim BugList As list
    Dim aField As TDField
    Dim fieldList As list
    Dim rc, ErrCode As Long
    Dim aBug As Bug
    Dim msg$
    Dim okCnt%, noNodeCnt%, errorCnt%, unknownCnt%
    Dim dataType As Long
'------------------------------------------------
' User BugFactory.Fields to get a list of TDField
' objects in the bug table.
' This example uses the BugFactory, but this can
' be done with any class that implements IBaseFactory
    'tdc is the global TDConnection object.
    Set BugFact = tdc.BugFactory
    Set fieldList = BugFact.Fields
'------------------------------------------
' Use List.Count to check how many items.
    Debug.Print: Debug.Print
    Debug.Print "There are " & fieldList.Count & _
        " fields in this table."
    Debug.Print "----------------------------------"
'Get any bug. To look at field attributes we
' need a valid object and since this example is
' not interested in the particular values of the object,
' it doesn't matter which bug.
    Set BugList = BugFact.NewList("")
    Set aBug = BugList(0)
'Walk through the list
    For Each aField In fieldList
        With aField
        'Quit when we have enough for this example
        If InStr(aField.Name, "BG_USER_10") > 0 Then Exit For
        ' For the DataTypeString() code,
        ' see example "Convert data types to string"
        Debug.Print .Name & ", " & .Property & ", Data type is " _
            & DataTypeString(.Type)
        On Error Resume Next
'----------------------------------------------------
'Use TDField.IsValidValue to confirm that a value can
'be used for a field.
' Get the correct data type and check validity of an
' arbitrary value.
' Save the error code immediately after IsValidValue call
' before another call can change the err object.
        dataType = aField.Type
        Select Case dataType
            Case TDOLE_LONG, TDOLE_ULONG
                aField.IsValidValue 5, aBug
                ErrCode = err.Number
            Case TDOLE_FLOAT
                aField.IsValidValue 5.5, aBug
                ErrCode = err.Number
            Case TDOLE_STRING
                aField.IsValidValue "Joe", aBug
                ErrCode = err.Number
            Case Else
            'These will be errors:
                aField.IsValidValue _
                    "String to non-string value", aBug
                ErrCode = err.Number
        End Select
'Output an error code message
        If ErrCode = 0 Then 'S_OK
            msg = "Valid Value"
            okCnt = okCnt + 1
        Else
             rc = ErrCode - vbObjectError
             Select Case rc
                Case FIELD_E_VERIFIED
                    msg = "Error: Invalid value for field"
                    errorCnt = errorCnt + 1
                Case TDOLE_NONODE
                    msg = "Error: Field can not be set to this value"
                    noNodeCnt = noNodeCnt + 1
                Case Else
                    msg = "Unrecognized error: " & rc _
                        & " , HRESULT = " & ErrCode
                    unknownCnt = unknownCnt + 1
            End Select
        End If
        Debug.Print vbTab & msg
        '
        End With 'aField
    Next aField
    Debug.Print "----------------------------------"
    Debug.Print "Number of fields with valid value = " & okCnt
    Debug.Print "Number of fields with invalid type = " & errorCnt
    Debug.Print "Number of fields with invalid value= " & noNodeCnt
    Debug.Print "Number of fields with unknown error = " & unknownCnt
    Debug.Print "----------------------------------"
End Sub


%%ItemTitle%%

OTA COM Type Library

Get Table Fields first item

Source code

Public Sub GetFields(Optional TableName As String = "ALERT")
Dim aField As TDField
Dim fieldList As list
Dim FieldProp As FieldProperty
'----------------------------------
'Get a list of TDField objects from
'TDConnection.Fields
    'tdc is the global TDConnection object.
    Set fieldList = tdc.Fields(TableName)
'-------------------------------------------
'Use List.Count to check how many items
    Debug.Print "The number of field in the table is " _
        & fieldList.Count
    Debug.Print
'-------------------------------------------
' Use List.Item to get a TDField object
' Use the TDField name property to check
' what is the first item.
    Set aField = fieldList.Item(0)
    Debug.Print "The first item is " & aField.Name
'Walk through the list and output the properties
'Note that although the TDField and the FieldProperty objects
' are returning information on the same field, they are doing
' so from different perspectives and the information is slightly
' different in some cases.
'Run the example and study the output to see these differences.
    For Each aField In fieldList
        With aField
'-------------------------------------------
' Get the FieldProperty object
        Set FieldProp = aField.Property
        If True Then 'fieldProp.IsActive Then
            Debug.Print "---------------------------"
            Debug.Print "TDField.Name: " & .Name
            'TDField.Name: AT_ENTITY_TYPE
            Debug.Print vbTab & "FieldProperty.DBColumnName: " _
                & FieldProp.DBColumnName
            ' FieldProperty.DBColumnName: AT_ENTITY_TYPE
            Debug.Print vbTab & "TDField.Property: " & .Property
            ' FieldProperty.UserLabel: Entity
            Debug.Print vbTab & "FieldProperty.UserLabel: " _
                & FieldProp.UserLabel
            ' FieldProperty.UserLabel: Entity
            Debug.Print vbTab & "TDField.Type: " & .Type _
                & " = " & DataTypeString(.Type)
            ' TDField.Type: 3 = TDOLE_STRING
            Debug.Print vbTab & "FieldProperty.DBColumnType: " _
                & FieldProp.DBColumnType
            ' FieldProperty.DBColumnType: char
            Debug.Print vbTab & "FieldProperty.UserColumnType: " _
                & FieldProp.UserColumnType
            ' FieldProperty.UserColumnType: char
            If FieldProp.IsKey Then
                  Debug.Print vbTab _
                    & "Key Field - FieldProperty.KeyOrder: " _
                    & FieldProp.KeyOrder
                  ' Key Field - FieldProperty.KeyOrder: 0
            End If
            Debug.Print vbTab & "This field" _
                & IIf(FieldProp.IsActive, " is ", " is not ") _
                & "visible in the UI"
            ' This field is not visible in the UI
        End If
        End With
    Next aField
End Sub


%%PageItemTitle%% $$Members$$

Module Overview

Module Object Members

Public Properties

Public Property Description | The module description.
Public Property GUID | The module GUID.
Public Property ID | The module ID.
Public Property Name | The module name.
Public Property NumericVisible | Updates visibility with numeric value for the specified user group.
Public Property Order | The module position in the framework sidebar.
Public Property Updated | Indicates if the object has been modified since being downloaded from database.
Public Property Visible | A bit-mask string that indicates for which groups the module is visible in the user interface.
Public Property VisibleForGroup | Updates visibility for the specified user group.

See Also

Module Overview


%%PageItemTitle%% $$Members$$

MultiValue Overview

MultiValue Object Members

Public Properties

Public Property List | List of values. Each item is the string representation of a single value.
Public Property Text | Text representation of values list. Items are separated with a semicolon.

See Also

MultiValue Overview


%%PageItemTitle%% $$Members$$

ProductInfo Overview

ProductInfo Object Members

Public Properties

Public Property BPTVersion | The Business Process Test versions.
Public Property QCVersion | The build information for the installed version.

See Also

ProductInfo Overview


%%PageItemTitle%% $$Members$$

ProjectProperties Overview

ProjectProperties Object Members

Public Properties

Public Property Count | The number of parameters in the project.
Public Property IsParam | Checks if a parameter of this name exists.
Public Property ParamName | Gets the parameter name.
Public Property ParamValue | The value of the parameter.

See Also

ProjectProperties Overview


%%ItemTitle%%

OTA COM Type Library

Print project properties

Source code

Private Sub ProjectProperties()
    Dim pProps As ProjectProperties
    Dim theName$
    Dim i%
'Get the collection of project properties
    'tdc is the global TDConnection object.
    Set pProps = tdc.ProjectProperties
' The index is zero-based, so the loop is 0 to count - 1
    For i = 0 To pProps.Count - 1
        theName = pProps.ParamName(i)
        Debug.Print CStr(i)
'Get the name and value by index
        Debug.Print pProps.ParamName(i), pProps.ParamValue(i)
'Get the value by parameter name
        Debug.Print theName, pProps.ParamValue(theName)
        Debug.Print "--------------------------"
    Next i
'Check if parameters exist
'This should be true. The name is the last parameter
'from the above loop.
    Debug.Print "Parameter " & theName & " exists = "; _
        pProps.IsParam(theName)
    Debug.Print "--------------------------"
'This should be false unless your system configurator
'likes Jabberwocky by Lewis Carol.
    theName = theName & "_SlithyToves"
    Debug.Print "Parameter " & theName & " exists = "; _
        pProps.IsParam(theName)
End Sub


%%PageItemTitle%% $$Members$$

ProjectRepository Overview

ProjectRepository Object Members

Public Methods

Public Method Cancel | Cancels the load or save action.
Public Method Delete | Deletes files locally or from the server.
Public Method GetLastError | Gets the last error that occurred during asynchronous load and save operations.
Public Method Load | Downloads the storage structure to the client file system.
Public Method LoadEx | Downloads the storage structure to the client file system.
Public Method Progress | Polls the progress of the last action (Load or Save).
Public Method Save | Uploads the storage structure to the server.
Public Method SaveEx | Uploads the storage structure to the server.

Public Properties

Public Property ActionFinished | Checks if the load or save action is finished.
Public Property ClientPath | The location on the client to which to download or from which to upload.
Public Property Root | The storage root.
Public Property ServerPath | The location on the server from which to download or to which to upload.

See Also

ProjectRepository Overview


%%PageItemTitle%% $$Members$$

Recordset Overview

Recordset Object Members

Public Methods

Public Method Clone | Creates a duplicate of this Recordset object.
Public Method First | Moves to the first record and makes it the current record.
Public Method Last | Moves to the last record and makes it the current record.
Public Method Next | Moves to the next record and makes it the current record.
Public Method Prev | Moves to the previous record and makes it the current record.
Public Method Refresh | Refreshes the Recordset, overwriting values in memory.

Public Properties

Public Property BOR | Checks if the record cursor is on the first record.
Public Property CacheSize | The number of records in the recordset that are cached locally in memory.
Public Property ColCount | Gets the number of columns in the current Recordset object.
Public Property ColIndex | Gets the index (zero-based) of a Recordset column specified by column name.
Public Property ColName | The name of the Recordset column specified by Index (zero-based).
Public Property ColSize | The physical size as defined in the database of the fields in the column specified by Index (zero-based).
Public Property ColType | The data type of column.
Public Property EOR | Checks if the record cursor is after the last record.
Public Property FieldValue | The value for the specified field.
Public Property Position | The current record position (0-based).
Public Property RecordCount | The number of records in the Recordset.

See Also

Recordset Overview


%%PageItemTitle%% $$Members$$

Release Overview

Release Object Members

Public Methods

Public Method DaysLeft | Returns the number of days until the scheduled release date.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Mail | Mails the IBaseFieldExMail field item.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property CycleFactory | The CycleFactory object for cycles of this release.
Public Property EndDate | The release's end date
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The release's name
Public Property Parent | The release's parent release folder
Public Property ReleaseManagementInfo | The release information.
Public Property StartDate | The release's start date
Public Property Status | The release's status
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

Release Overview


%%PageItemTitle%% $$Members$$

ReleaseFactory Overview

ReleaseFactory Object Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method BuildCoverageGraph | Builds release coverage graph.
Public Method Mail | Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

ReleaseFactory Overview


%%ItemTitle%%

OTA COM Type Library

Get releases under a specified folder that match a filter

Source code

Public Sub FindReleases()
'Get releases under a specified folder that match a filter
Dim FolderId As Long, RelName As String
Dim folderFactory As releaseFolderFactory
Dim relFactory As ReleaseFactory
Dim FolderFilter As TDFilter
Dim listOfReleases As list
Dim rel As TDAPIOLELib.Release
Dim folder As ReleaseFolder
    'Get ReleaseFolderFactory from TDConnection
    Set folderFactory = tdc.releaseFolderFactory
    'Get the folder in which to search
    FolderId = 102
    Set folder = folderFactory.Item(FolderId)
    'Since the release factory is from the folder,
    ' all objects created from it relate to the
    ' contents of that folder
    Set relFactory = folder.ReleaseFactory
    ' If the release factory were from the TDConnection,
    ' the objects would relate to all releases
    ''Set relFactory = tdc.ReleaseFactory
    Set FolderFilter = relFactory.filter
    RelName = "Release*" 'Release 1, Release to QA, Release1.1, etc
    'Get the list of the Releases in the folder that
    ' match "Release*"
    FolderFilter.filter("REL_NAME") = RelName
    Set listOfReleases = FolderFilter.NewList
    For Each rel In listOfReleases
        Debug.Print rel.Name
    Next
    Set folderFactory = Nothing
    Set relFactory = Nothing
    Set FolderFilter = Nothing
    Set listOfReleases = Nothing
    Set folder = Nothing
    Set rel = Nothing
End Sub


%%PageItemTitle%% $$Members$$

ReleaseFactory Object

IBaseFactory2 Implemented Interface Members

See Also

ReleaseFactory Object


%%PageItemTitle%% $$Members$$

ReleaseFactory Object

ISearchableFactory Implemented Interface Members

See Also

ReleaseFactory Object


%%PageItemTitle%% $$Members$$

ReleaseFolder Overview

ReleaseFolder Object Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Mail | Mails the IBaseFieldExMail field item.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The release folder's name
Public Property Parent | The release folder's parent release folder, or null if root
Public Property ReleaseFactory | The ReleaseFactory object for direct children releases.
Public Property ReleaseFolderFactory | The ReleaseFolderFactory object for direct children release folders.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

ReleaseFolder Overview


%%PageItemTitle%% $$Members$$

ReleaseFolderFactory Overview

ReleaseFolderFactory Object Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method Mail | Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.
Public Property Root | Gets the root release folder labled 'Releases'.

See Also

ReleaseFolderFactory Overview


%%ItemTitle%%

OTA COM Type Library

Find release folders by parent ID

Source code

Public Sub FindReleaseFoldersByParentId()
'Get the child release folders of a specified release folder
Dim folderFactory As releaseFolderFactory
Dim RelFolderFilter As TDFilter
Dim listOfFolders As list
Dim tempFolder As ReleaseFolder
'Get ReleaseFolderFactory from TDConnection
Set folderFactory = tdc.releaseFolderFactory
Set RelFolderFilter = folderFactory.filter
'Get the list of the ReleaseFolders under the
' specified node
Dim ParentId As Long
ParentId = 102
RelFolderFilter.filter("RF_PARENT_ID") = ParentId
Set listOfFolders = RelFolderFilter.NewList
For Each tempFolder In listOfFolders
    Debug.Print tempFolder.Name
Next
Set folderFactory = Nothing
Set RelFolderFilter = Nothing
Set listOfFolders = Nothing
Set tempFolder = Nothing
End Sub


%%PageItemTitle%% $$Members$$

ReleaseFolderFactory Object

IBaseFactory2 Implemented Interface Members

See Also

ReleaseFolderFactory Object


%%PageItemTitle%% $$Members$$

ReleaseFolderFactory Object

ISearchableFactory Implemented Interface Members

See Also

ReleaseFolderFactory Object


%%PageItemTitle%% $$Members$$

ReleaseFolder Object

IBaseField2 Implemented Interface Members

See Also

ReleaseFolder Object


%%PageItemTitle%% $$Members$$

ReleaseFolder Object

IBaseField3 Implemented Interface Members

See Also

ReleaseFolder Object


%%PageItemTitle%% $$Members$$

ReleaseManagementInfo Overview

ReleaseManagementInfo Object Members

Public Properties

Public Property DaysLeft | Returns the number of days remaining in the cycle or release.
Public Property Duration | Returns the duration of the cycle or release.
Public Property Started | Checks if the cycle or release has begun.
Public Property TotalTestInstances | Returns the total number of test instances in this cycle or release.
Public Property UnexecutedTestInstances | Returns the number of unexecuted test instances in this cycle or release.

See Also

ReleaseManagementInfo Overview


%%PageItemTitle%% $$Members$$

Release Object

IBaseField2 Implemented Interface Members

See Also

Release Object


%%PageItemTitle%% $$Members$$

Release Object

IBaseField3 Implemented Interface Members

See Also

Release Object


%%ItemTitle%%

OTA COM Type Library

Set target releases for requirement

Source code

Public Sub SetGetReleases()
'Set target releases for requirement.
'To set Target Cycles to Requirement, use requirement field RQ_TARGET_RCYC.
Dim rFactory As reqFactory
Dim requirement As req
Dim rel As Release
Dim outlistOfReleases As list
Dim strReleasesNames As String
Dim requirementId As Long, listOfReleases As list
    'listOfReleases can be a list of release ids or a list of Release objects.
    Set listOfReleases = New list
    listOfReleases.Add (2)
    listOfReleases.Add (3)
    listOfReleases.Add (4)
    requirementId = 9
    Set rFactory = tdc.reqFactory
    Set requirement = rFactory.Item(requirementId)
    'Set the target releases of this requirement
    requirement.field("RQ_TARGET_REL") = listOfReleases
    requirement.Post
    'Retrieve the releases
    Set outlistOfReleases = requirement.field("RQ_TARGET_REL")
    strReleasesNames = "Releases are: "
    For Each rel In outlistOfReleases
        strReleasesNames = strReleasesNames & rel.Name & ", "
    Next
    MsgBox strReleasesNames
End Sub


%%PageItemTitle%% $$Members$$

Req Overview

Req Object Members

Public Methods

Public Method AddCoverage | Assigns a test to cover this requirement.
Public Method AddCoverageByFilter | Adds the tests from the specified subject that match the input filter to the list of tests that cover the current requirement.
Public Method AddCoverageEx | Assigns all the tests in the specified subject folder to cover this current requirement.
Public Method get_Icon | Returns the bitmap stream for the requirement's type.
Public Method GetCoverageTestsByReqFilter | Returns the list of tests that cover the current requirement and, optionally, cover those of its children that match the requirement filter.
Public Method GetCoverList | Gets a list of the tests that cover this requirement.
Public Method GetCoverListByFilter | Gets the list of all tests that cover the current requirement and match the filter.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Mail | Mails the IBaseFieldExMail field item.
Public Method Move | Moves a requirement to being a child of a specified father in the requirements tree.
Public Method PopulateTargetCycleToChildren | Assigns the target cycle of the requirement as the target cycle of all child requirements, recursively down the folder tree.
Public Method PopulateTargetReleaseToChildren | Assigns the target release of the requirement as the target release of all child requirements, recursively down the folder tree.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method RemoveCoverage | Removes a test from the list of tests that cover this requirement.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property Author | The name of the requirement author.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Comment | The comment associated with this requirement.
Public Property Count | The number of direct children.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property HasCoverage | The requirement is covered by at least one test.
Public Property HasReqTraceability | Checks if the current requirement has at least one associated requirement in the specified direction.
Public Property HasRichContent | Checks if the object has rich content.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The Requirement name as seen in the tree.
Public Property Paragraph | The paragraph number or numeration of the requirement.
Public Property ParentId | The Requirement's parent ID.
Public Property Path | The path of the node containing this requirement.
Public Property Priority | The requirement priority.
Public Property Product | The product name for which the requirement is set.
Public Property ReqTraceFactory | The requirement link factory that manages the traceability links of the current requirement to its associated requirements in the specified direction.
Public Property RequirementType | Gets the interface for getting the requirement types.
Public Property Reviewed | The review status.
Public Property Status | The status of the tests that cover this requirement.
Public Property Type | The requirement type.
Public Property TypeId | The Requirement's type name.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

Req Overview


%%PageItemTitle%% $$Members$$

ReqCoverageFactory Overview

ReqCoverageFactory Object Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property FullCoverage | Indicates if the actions of the factory are applied recursively to requirement's children.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

ReqCoverageFactory Overview


%%PageItemTitle%% $$Members$$

ReqCoverageFactory Object

IBaseFactory2 Implemented Interface Members

See Also

ReqCoverageFactory Object


%%PageItemTitle%% $$Members$$

ReqFactory Overview

ReqFactory Object Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method BuildPerfGraph | Builds Performance Graph.
Public Method BuildPerfGraphEx | Builds Performance Graph.
Public Method BuildProgressGraph | Builds Req progress graph.
Public Method BuildProgressGraphEx | Builds Requirement progress graph. Extends BuildProgressGraph with ability to display Null parent folders.
Public Method BuildSummaryGraph | Builds Req summary graph.
Public Method BuildSummaryGraphEx | Builds Req summary graph. Extends BuildSummaryGraph with ability to display Null parent folders.
Public Method BuildTrendGraph | Creates graph that shows the number of defect status changes over time.
Public Method BuildTrendGraphEx | Creates graph that shows the number of defect status changes over time.
Public Method Find | Gets a list of requirements containing the Pattern value in specified field.
Public Method GetChildrenList | Gets list of child requirements.
Public Method GetCoverageTestsByReqFilter | Returns the list of tests that cover the requirements that match the requirement filter.
Public Method GetFilteredChildrenList | Gets a filtered list of child requirements.
Public Method GetRequirementType | Returns the requirement customization type object specified by the type ID.
Public Method GetRequirementTypes | Returns the list of requirement customization types.
Public Method GetTracedList | Returns the list of requirements either traced directly from or directly to the specified requirement.
Public Method Mail | Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.
Public Method ReqTypeIdToName | Returns the name of the requirement type specified by the type ID.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

ReqFactory Overview


%%ItemTitle%%

OTA COM Type Library

Find a specified requirement in a specified folder

Source code

Public Function GetReqByPath(fullPath$, _
    Optional delimChar As String = "\") _
        As Req
' This function returns a Req object specified by its
' full path.
' For example:
' Set r = GetReqByPath("SCRATCH\OTA_REQ_DEMO\OTA_S_O_1")
' will return the OTA_S_O_1 object.
' A requirement name is not unique in the project, but it is
' unique as a direct child of another requirement.
' Therefore, these routine works by walking down the
' requirement tree along the fullPath until the requirement
' is found at the end of the path.
' If a backslash is not used as the folder delimiter, any other
' character can be passed in the delimChar argurment.
    Dim rFact As reqFactory
    Dim theReq As Req, ParentReq As Req
    Dim reqList As list
    Dim NodeArray() As String, PathArray() As String
    Dim WorkingDepth As Integer
    On Error GoTo GetReqByPathErr
'Trim the fullPath and strip leading and trailing delimiters
    fullPath = Trim(fullPath)
    Dim pos%, ln%
    pos = InStr(1, fullPath, delimChar)
    If pos = 1 Then
        fullPath = Mid(fullPath, 2)
    End If
    ln = Len(fullPath)
    pos = InStr(ln - 1, fullPath, delimChar)
    If pos > 0 Then
        fullPath = Mid(fullPath, 1, ln - 1)
    End If
' Get an array of requirements, and the length
' of the path
    NodeArray = Split(fullPath, delimChar)
    WorkingDepth = LBound(NodeArray)
' Walk down the tree
    'tdc is the global TDConnection object.
    Set rFact = tdc.reqFactory
    For WorkingDepth = LBound(NodeArray) To UBound(NodeArray)
    'First time, find under the root (-1)
    'After that, under the previous requirement found: ParentReq.ID
        If WorkingDepth = LBound(NodeArray) Then
            Set reqList = rFact.Find(-1, "RQ_REQ_NAME", _
                    NodeArray(WorkingDepth), TDREQMODE_FIND_EXACT)
        Else
            Set reqList = rFact.Find(ParentReq.ID, "RQ_REQ_NAME", _
                    NodeArray(WorkingDepth), TDREQMODE_FIND_EXACT)
        End If
        ' Delete parent. Each loop has to find it again.
        Set ParentReq = Nothing
        Dim strItem, reqID&, strID$, thePath$
        For Each strItem In reqList
            ' The List returned from ReqFactory.Find is a List
            ' of strings of format ID,Name.
            ' For example "9,Products/Services On Sale"
            ' Extract the ID from the string by splitting the
            ' string at the comma.
            pos = InStr(strItem, ",")
            strID = Mid(strItem, 1, pos - 1)
            ' Convert the ID to a long, and get the object
            reqID = CLng(strID)
            Set theReq = rFact.Item(reqID)
            'Now check that the object is at the correct depth.
            'If so, we've found the requirement. On the next loop,
            'we'll look from here down.
            thePath = theReq.Path
            PathArray = Split(thePath, "\")
' Debug.Print "Number of elements is " & UBound(PathArray)
' Debug.Print theReq.ID, theReq.Name
            If UBound(PathArray) = WorkingDepth Then
                Set ParentReq = theReq
                Exit For
            End If
        Next strItem
        If ParentReq Is Nothing Then Exit For
    Next WorkingDepth
    Set GetReqByPath = ParentReq
Exit Function
GetReqByPathErr:
    ErrHandler err, "GetReqByPath"
    Set GetReqByPath = Nothing
End Function


%%ItemTitle%%

OTA COM Type Library

Find requirements modified in specified period

Source code

Public Function RetrieveModifiedRecords()
' List the requirements modified in the last 24 hours.
On Error GoTo ErrorHandler:
    Dim m_filter As TDAPIOLELib.TDFilter
    Dim reqFactory As TDAPIOLELib.reqFactory
    Dim ReqList As list
    Set reqFactory = tdc.reqFactory
    Debug.Assert Not reqFactory Is Nothing
    Set m_filter = reqFactory.filter
    Debug.Assert Not m_filter Is Nothing
    Dim sinceDate As Date, currentSyncDate As Date
    sinceDate = DateAdd("d", -1, Date) '24 hours ago
    currentSyncDate = Date ' Now
    ' Create the filter, formatting the Date type
    ' as the required string:
    ' RQ_VTS > "2007-04-15 00:00:00" AND <> "2007-04-16 00:00:00"
    m_filter.filter("RQ_VTS") = "> " _
        & Chr(34) & Format(sinceDate, "yyyy-mm-dd hh:mm:ss") & Chr(34) & _
        " AND <> " & _
        Chr(34) & Format(currentSyncDate, "yyyy-mm-dd hh:mm:ss") & Chr(34)
' ' Sort by parents before children.
' m_filter.Order("RQ_REQ_PATH") = 1
' m_filter.OrderDirection("RQ_REQ_PATH") = TDAPIOLELib.TDOLE_ASCENDING
    ' Sort by modification time.
    m_filter.Order("RQ_VTS") = 1
    m_filter.OrderDirection("RQ_VTS") = TDAPIOLELib.TDOLE_ASCENDING
    Set ReqList = m_filter.NewList
    Dim r As req
    For Each r In ReqList
        Debug.Print r.Name
    Next
    Exit Function
ErrorHandler:
    Err.Raise Err.Number, Err.Source, Err.Description
End Function


%%ItemTitle%%

OTA COM Type Library

Find tests that do not cover any requirement

Source code

Public Sub UnneededTests()
' Get the list of tests that do not cover any requirement
    Dim reqF As reqFactory
    Dim testF As testFactory
    Dim ReqFilter As TDFilter
    Dim TestFilter As TDFilter
    Dim aTest As Test
    Dim testL As list
    Set reqF = tdc.reqFactory
    Set ReqFilter = reqF.filter
    'Exclude the top-level folder
    ReqFilter.filter("RQ_REQ_ID") = ">= 0"
    ' Set exclusive XFilter: Filter for items that
    ' match primary filter and do not match cross filter.
    Set testF = tdc.testFactory
    Set TestFilter = testF.filter
    TestFilter.SetXFilter "TEST-REQ", False, ReqFilter.Text
    Debug.Print TestFilter.Text
    Set testL = testF.NewList(TestFilter.Text)
    For Each aTest In testL
        Debug.Print aTest.ID & ": " & aTest.Name
    Next
' 'To get the tests that DO cover some requirement:
' TestFilter.SetXFilter "TEST-REQ", True, ReqFilter.Text
' Debug.Print TestFilter.Text
' Set testL = testF.NewList(TestFilter.Text)
'
' For Each aTest In testL
' Debug.Print aTest.ID & ": " & aTest.Name
' Next
End Sub


%%ItemTitle%%

OTA COM Type Library

Getting those test instances that do, and those that do not, cover a requirement

Source code

Sub Set_X_Filter( _
        theTestSet As TestSet, Req1 As Req)
' This example demonstrates using a filter to find
' the test instances of a given test set that cover
' a given requirement, and then to find the the test
' instances that do not cover that requirement.
    On Error GoTo RQTest_Err
    Dim TestInstFilter As TDFilter, xFilter As TDFilter
    Dim aStr$
' Create the first clause of the filter
' Get the test instances that belong
' to the test set passed to this routine.
' No filter fields are specified, so all the test instances
' of the test set are included.
    Dim testInstanceF As TSTestFactory
    Set testInstanceF = theTestSet.TSTestFactory
    Set TestInstFilter = testInstanceF.Filter
    aStr = TestInstFilter.GetXFilter("TSTEST-REQ", True)
    Debug.Print aStr
    aStr = TestInstFilter.GetXFilter("TSTEST-REQ", False)
    Debug.Print aStr
'
' Create the second clause of the filter, the set of
' requirements containing the single requirement
' passed to the routine.
    Dim reqF As reqFactory
    Set reqF = tdc.reqFactory ' tdc is the TDConnection object.
    Set xFilter = reqF.Filter
    xFilter.Filter("RQ_REQ_NAME") = Req1.Name
' Now combine the two, creating the join criteria:
' Main clause: Get all the test instances of the given test set.
' Second clause: Get the Req objects where the name
' is "Req1"
' The result: Get all test instances in the given test set
' that are associated with (cover)the given requirement.
    TestInstFilter.SetXFilter "TSTEST-REQ", True, xFilter.Text
' Debug.Print
' Debug.Print "TestInstFilter.Text after xFilter set: "
' Debug.Print TestInstFilter.Text
'
' TestInstFilter.Text after xFilter set:
' [Filter]{
' FLT:[X],
' TYPE:TSTEST-REQ,
' EXISTS_IN_IDS:Y,
' IN_IDS:\0000006a\[Filter]{
' TableName:REQ,
' ColumnName:RQ_REQ_NAME,
' LogicalFilter:Req1,
' VisualFilter:Req1,
' NO_CASE:
' }
'
' }
' Output the results
    aStr = TestInstFilter.GetXFilter("TSTEST-REQ", True)
    Debug.Print "Inclusive is True:"
    Debug.Print aStr
    aStr = TestInstFilter.GetXFilter("TSTEST-REQ", False)
    Debug.Print "--------------------------------------"
    Debug.Print "Inclusive is False:"
    Debug.Print aStr
    Dim aList As list, ListMember As Variant, tmpinstance As TSTest
    Set aList = testInstanceF.NewList(TestInstFilter.Text)
    For Each ListMember In aList
        Set tmpinstance = ListMember
        Debug.Print tmpinstance.Name
    Next
' [1] Test_1
' [1] Test_3
' [2] Test_1
'
' Now use the same criteria, but set the "Inclusive" argument
' of SetXFilter to False.
' The filter now means, get all the test instances of the
' test set that do NOT cover the specified requirement
    TestInstFilter.SetXFilter "TSTEST-REQ", False, xFilter.Text
    Debug.Print "--------------------------------------"
    Debug.Print "TestInstFilter.Text:"
    Debug.Print TestInstFilter.Text
    Debug.Print
    Debug.Print "--------------------------------------"
    aStr = TestInstFilter.GetXFilter("TSTEST-REQ", True)
    Debug.Print "Inclusive is True:"
    Debug.Print aStr
    aStr = TestInstFilter.GetXFilter("TSTEST-REQ", False)
    Debug.Print "--------------------------------------"
    Debug.Print "Inclusive is False:"
    Debug.Print aStr
    Set aList = testInstanceF.NewList(TestInstFilter.Text)
    For Each ListMember In aList
        Set tmpinstance = ListMember
        Debug.Print tmpinstance.Name
    Next
' [1] Test_2
' [1] Test_4
' [2] Test_4
    Debug.Print "--------------------------------------"
    aStr = TestInstFilter.GetXFilter("TSTEST-REQ", True)
    Debug.Print "Inclusive is True:"
    Debug.Print aStr
Exit Sub
RQTest_Err:
    ErrHandler err, "Req_TestInstance_Coverage", err.Description
End Sub


%%PageItemTitle%% $$Members$$

ReqFactory Object

IAlertableEntityFactory Implemented Interface Members

See Also

ReqFactory Object


%%PageItemTitle%% $$Members$$

ReqFactory Object

IBaseFactory2 Implemented Interface Members

See Also

ReqFactory Object


%%PageItemTitle%% $$Members$$

ReqFactory Object

ISearchableFactory Implemented Interface Members

See Also

ReqFactory Object


%%PageItemTitle%% $$Members$$

ReqFactory Object

ISupportCopyPaste2 Implemented Interface Members

See Also

ReqFactory Object


%%PageItemTitle%% $$Members$$

ReqTraceFactory Overview

ReqTraceFactory Object Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

ReqTraceFactory Overview


%%PageItemTitle%% $$Members$$

ReqTraceFactory Object

IBaseFactory2 Implemented Interface Members

See Also

ReqTraceFactory Object


%%PageItemTitle%% $$Members$$

ReqType Overview

ReqType Object Members

Public Properties

Public Property HasDirectCoverage | Indicates if this requirement type supports direct coverage by tests or test instances.
Public Property Icon | The bitmap stream representing this type.
Public Property ID | The CustomizationType ID.
Public Property Name | The CustomizationType name.
Public Property RiskAnalysisType | The type of risk analysis that is applicable to this requirement.

See Also

ReqType Overview


%%ItemTitle%%

OTA COM Type Library

Covering a requirement with selected tests in a folder

Source code

Public Sub AddCoverageByFilter()
    Dim SubjectID As Variant
    Dim TestFact As TestFactory
    Dim TestFilter As TDFilter
    Dim aReq As Req
    On Error GoTo AddCoverageByFilterErr
'Get the requirement to be covered
    Dim reqPath$
    reqPath = "Mercury Tours Application" _
        & "\Online Travel Booking Services" _
        & "\Products/Services On Sale" _
        & "\Tours/Cruises"
    ' For the code of GetReqByPath, see example
    ' "Find a specified requirement in a specified folder"
    Set aReq = GetReqByPath(reqPath)
' Define the test filter:
' Tests in Design Status whose
' names begin with "Demo"
    'tdc is the global TDConnection object.
    Set TestFact = tdc.TestFactory
    Set TestFilter = TestFact.Filter
    TestFilter.Filter("TS_NAME") = "demo*"
    TestFilter.Filter("TS_STATUS") = "Design"
' Get the test subject node under which
' to look for the "Demo*" tests
    Dim SubjNode As SubjectNode, sPath$
    sPath = "OTA_DEMO_SUBJECT" _
        & "\OTA_SUBJECT_level1" _
        & "\OTA_SUB_1.2"
    ' For the code of GetSubjectNodeByPath, see example
    ' "Getting a test subject node by the node path"
    Set SubjNode = GetSubjectNodeByPath(sPath)
    SubjectID = SubjNode.NodeID
'-------------------------------------------------
' Use Req.AddCoverageByFilter to add all the
' Demo* tests in the subject folder to
' the List of tests covering the requirement
    aReq.AddCoverageByFilter _
        SubjectID, _
        TDPOSITION_LAST, _
        TestFilter.Text
Exit Sub
AddCoverageByFilterErr:
ErrHandler err, "AddCoverageByFilter", CStr(err.Number - vbObjectError)
End Sub


%%ItemTitle%%

OTA COM Type Library

Getting a test subject node by the node path

Source code

Public Function GetSubjectNodeByPath(ByVal fullPath As String, _
    Optional delimChar As String = "\") _
        As SubjectNode
' This function returns the Test SubjectNode object
' corresponding to the lowest level of a path.
' The path format is:
' "OTA_DEMO_SUBJECT\OTA_SUBJECT_level1\OTA_SUB_1.1\OTA_SUB_1.1.1\OTA_SUB_1.1.1.1"
' If a backslash is not used as the folder delimiter, any other
' character can be passed in the delimChar argurment.
    Dim TreeMgr As TreeManager
    Dim SubjRoot As SubjectNode
    Dim SubNode As SubjectNode
    Dim Trees As list
    Dim CurrentSubName As String
    On Error GoTo GetSubjectNodeByPathErr
'Get the list of subject root nodes from the tree manager.
'There is only one item in this list.
    'tdc is the global TDConnection object.
    CurrentSubName = "Set TreeMgr = tdc.TreeManager"
    Set TreeMgr = tdc.TreeManager
'----------------------------------------------------------
' Use TreeManager.RootList to get the Subject root.
    Set Trees = TreeMgr.RootList(TDOLE_SUBJECT)
'Get the name of the subject tree root in your project
    CurrentSubName = Trees.Item(1)
'----------------------------------------------------------
' Use TreeManager.TreeRoot to get the root node object
' from the tree manager by name
    Set SubjRoot = TreeMgr.TreeRoot(CurrentSubName)
'If fullPath is empty string, return the root.
    If Len(fullPath) = 0 Then
        Set GetSubjectNodeByPath = SubjRoot
        Exit Function
    End If
'Trim the fullPath and strip leading and trailing delimiters
    fullPath = Trim(fullPath)
    Dim pos%, ln%
    pos = InStr(1, fullPath, delimChar)
    If pos = 1 Then
        fullPath = Mid(fullPath, 2)
    End If
    pos = InStr(fullPath, CurrentSubName)
    If pos = 1 Then
        fullPath = Mid(fullPath, Len(CurrentSubName) + 2)
    End If
    ln = Len(fullPath)
    pos = InStr(ln - 1, fullPath, delimChar)
    If pos > 0 Then
        fullPath = Mid(fullPath, 1, ln - 1)
    End If
'Set up to walk the tree
    Set SubNode = SubjRoot
'Split the path into individual node names
    Dim subjectArray() As String
    subjectArray = Split(fullPath, delimChar)
' If path is not directly under root then
' walk down path
    If LBound(subjectArray) < UBound(subjectArray) Then
        Dim idx%
    ' Debug.Print LBound(subjectArray), UBound(subjectArray)
        For idx = LBound(subjectArray) To UBound(subjectArray) - 1
            CurrentSubName = subjectArray(idx)
' Debug.Print SubjRoot.Name & delimChar & CurrentSubName
'---------------------------------------------------------------
' Use SubjectNode.FindChildNode to get a specifed node.
            Set SubNode = SubjRoot.FindChildNode(CurrentSubName)
            Set SubjRoot = SubNode 'for next loop
        Next idx
    End If 'lbound < ubound
' Get the last node
    CurrentSubName = subjectArray(UBound(subjectArray))
    Debug.Print SubjRoot.Name & delimChar & CurrentSubName
    Set SubNode = SubjRoot.FindChildNode(CurrentSubName)
' Debug.Print subNode.Name
'Return the last node
    Set GetSubjectNodeByPath = SubNode
Exit Function
GetSubjectNodeByPathErr:
    On Error Resume Next
    Dim errmsg$
    errmsg = "Error processing " & vbCrLf & fullPath _
        & vbCrLf & "near " & CurrentSubName
    Set GetSubjectNodeByPath = Nothing
    ErrHandler err, "GetSubjectNodeByPath", errmsg, NON_FATAL_ERROR
End Function


%%ItemTitle%%

OTA COM Type Library

Add all tests under a subject folder to the requirement coverage

Source code

Public Sub AddCoverageEx()
    Dim SubNode As SubjectNode, SubjectID As Variant
    Dim theReqToCover As Req
    Dim TestFilter As TDFilter
    On Error GoTo AddCoverageExErr
    ' For code of GetSubjectNodeByPath, see example
    ' Getting a test subject node by the node path
    Set SubNode = GetSubjectNodeByPath("Flight Reservation")
    SubjectID = SubNode.NodeID
    Debug.Print SubjectID
' Get the requirement to cover: "Car Rentals"
' under "Products/Services On Sale"
' To see the code of GetReqByPath, see example
' "Find a specified requirement in a specified folder"
' under Req and ReqFactory
    Dim reqPath$
    reqPath = "Mercury Tours Application" _
            & "\Online Travel Booking Services" _
            & "\Products/Services On Sale" _
            & "\Car Rentals"
    Set theReqToCover = GetReqByPath(reqPath)
'-------------------------------------------------------
' Use Req.AddCoverageEx to create the coverage
    theReqToCover.AddCoverageEx SubjectID, TDPOSITION_LAST
    theReqToCover.Post
' See the covering tests that have not yet run
' Get a test filter and set the execution status to "No Run"
    'tdc is the global TDConnection object.
    Set TestFilter = tdc.TestFactory.Filter
' Note that the quote marks must be part of the string if
' the value contains spaces.
' "No Run" would be passed as the string (No Run)and would fail.
' """No Run""" is passed as ("No Run") as required.
    TestFilter.Filter("TS_EXEC_STATUS") = """No Run"""
    Dim CovList As list, aTest As ITest
'------------------------------------------------------
' Use Req.GetCoverListByFilter to
' get the filtered List of all tests, recursively, that
' cover the requirement.
    Set CovList = _
        theReqToCover.GetCoverListByFilter(TestFilter.Text, True)
    For Each aTest In CovList
        With aTest
            Debug.Print .Name, .execStatus, .Type
        End With
    Next
Exit Sub
AddCoverageExErr:
    ErrHandler err, "AddCoverageEx"
End Sub


%%ItemTitle%%

OTA COM Type Library

Add a test to the requirement coverage

Source code

Public Sub AddCoverage()
'This procedure locates a particular requirement and a
'particular test and adds the test to the requirement's coverage.
    Dim rFact As reqFactory
    Dim tfact As TestFactory
    Dim aTest As TDAPIOLELib.test
    Dim CoverList As list, TestList As list, reqList As list
    Dim theCoverTest As TDAPIOLELib.test
    Dim theReqToCover As Req
    Dim ReqFilter As TDFilter, TestFilter As TDFilter
    Dim idx% 'an index number
    On Error GoTo AddCoverageErr
'
'Get the requirement Factory.
    'tdc is the global TDConnection object.
    Set rFact = tdc.reqFactory
' Note that requirement names are not necessarily unique in
' the project.
' The demo project as delivered has only one 'Hotel Reservations',
' but another was created for this example.
    Set ReqFilter = rFact.Filter
    'Note double quote marks because of space in name.
    ReqFilter.Filter("RQ_REQ_NAME") = """Hotel Reservations"""
    Set reqList = rFact.NewList(ReqFilter.Text)
    Debug.Print "The number of requirements named Hotel Reservations = " & reqList.Count
    'The number of requirements named Hotel Reservations = 2
'
' Therefore, we'll limit our search to a single parent requirement
' folder, where requirement names are unique.
' To see the code of GetReqByPath, see example
' "Find a specified requirement in a specified folder"
' under Req and ReqFactory
    Dim reqPath$
    reqPath = "Mercury Tours Application" _
            & "\Online Travel Booking Services" _
            & "\Products/Services On Sale" _
            & "\Hotel Reservations"
    Set theReqToCover = GetReqByPath(reqPath)
' One alternative to the code in GetReqByPath is to
' read the Item ID from the user interface
' in the Requirements module.
    ' Set theReqToCover = RFact.Item(81)
                                    '
    With theReqToCover
    Debug.Print .Name, .Status, .Author
    'Hotel Reservations Failed alex_qc
    End With
                                    '
' Get a unique test by restricting selection to a specific subject node
    'tdc is the global TDConnection object.
    Set tfact = tdc.TestFactory
    Set TestFilter = tfact.Filter
    TestFilter.Filter("TS_NAME") = "Flight_Reservation_Stress"
    TestFilter.Filter("TS_SUBJECT") = """Subject\Flight Reservation"""
    ' There should only be one item in the List
    Set TestList = tfact.NewList(TestFilter.Text)
    Debug.Print TestList.Count ' output is 1
                                        '
    Set theCoverTest = TestList.Item(1)
    idx = theCoverTest.ID
    Debug.Print idx
'--------------------------------------------------------
' Use Req.GetCoverList to Check what coverage already exists.
' So that this example can run more than once, we
' remove the test we want to use if we find it.
' In production code, you'll probably exit if
' you find that the requirement is already covered
' by the test.
    Set CoverList = theReqToCover.GetCoverList
    Debug.Print CoverList.Count
    For Each aTest In CoverList
        With aTest
        Debug.Print .ID, .Name
        If .ID = idx Then
'--------------------------------------------------------
' Use Req.RemoveCoverage to remove the test from the List.
            theReqToCover.RemoveCoverage aTest
            theReqToCover.Post
        End If
        End With
    Next aTest
'--------------------------------------------------------
' Use Req.AddCoverage to add a test
' We now have the requirement and the test,
' so add the test to the requirement's coverage.
    theReqToCover.AddCoverage idx, TDPOSITION_LAST
' Now check again what coverage exists
    Set CoverList = theReqToCover.GetCoverList
    Debug.Print CoverList.Count
    For Each aTest In CoverList
        With aTest
        Debug.Print .ID, .Name
        End With
    Next aTest
' Save the change to the requirement object
' to the project database
    theReqToCover.Post
Exit Sub
AddCoverageErr:
ErrHandler err, "AddCoverage", CStr(err.Number - vbObjectError)
End Sub


%%ItemTitle%%

OTA COM Type Library

Filter requirements by type

Source code

Public Sub FilterReqsByType()
' Filter requirements by type
' Fetch all the requirements of certain type (e.g. Business).
Dim reqFactory As IReqFactory2
Dim list As IList
Dim filter As ITDFilter
Dim req As IReq
Dim RType As ReqType
Set reqFactory = tdc.reqFactory
Set filter = reqFactory.filter
'Value of predefined type is from TDAPI_PREDEFINED_REQ_TYPES
filter.filter("RQ_TYPE_ID") = REQ_TYPE_BUSINESS 'REQ_TYPE_UNDEFINED
''Value of custom type is the type ID, for example:
'filter.filter("RQ_TYPE_ID") = 101
Set list = filter.NewList
For Each req In list
    Debug.Print req.Name & " : " & CStr(req.TypeId) & " : " & req.RequirementType.Name
Next
End Sub


%%ItemTitle%%

OTA COM Type Library

Finding a unique requirement

Source code

Public Sub AddCoverage()
'This procedure locates a particular requirement and a
'particular test and adds the test to the requirement's coverage.
    Dim rFact As reqFactory
    Dim tfact As TestFactory
    Dim aTest As TDAPIOLELib.test
    Dim CoverList As list, TestList As list, reqList As list
    Dim theCoverTest As TDAPIOLELib.test
    Dim theReqToCover As Req
    Dim ReqFilter As TDFilter, TestFilter As TDFilter
    Dim idx% 'an index number
    On Error GoTo AddCoverageErr
'
'Get the requirement Factory.
    'tdc is the global TDConnection object.
    Set rFact = tdc.reqFactory
' Note that requirement names are not necessarily unique in
' the project.
' The demo project as delivered has only one 'Hotel Reservations',
' but another was created for this example.
    Set ReqFilter = rFact.Filter
    'Note double quote marks because of space in name.
    ReqFilter.Filter("RQ_REQ_NAME") = """Hotel Reservations"""
    Set reqList = rFact.NewList(ReqFilter.Text)
    Debug.Print "The number of requirements named Hotel Reservations = " & reqList.Count
    'The number of requirements named Hotel Reservations = 2
'
' Therefore, we'll limit our search to a single parent requirement
' folder, where requirement names are unique.
' To see the code of GetReqByPath, see example
' "Find a specified requirement in a specified folder"
' under Req and ReqFactory
    Dim reqPath$
    reqPath = "Mercury Tours Application" _
            & "\Online Travel Booking Services" _
            & "\Products/Services On Sale" _
            & "\Hotel Reservations"
    Set theReqToCover = GetReqByPath(reqPath)
' One alternative to the code in GetReqByPath is to
' read the Item ID from the user interface
' in the Requirements module.
    ' Set theReqToCover = RFact.Item(81)
                                    '
    With theReqToCover
    Debug.Print .Name, .Status, .Author
    'Hotel Reservations Failed alex_qc
    End With
                                    '
' Get a unique test by restricting selection to a specific subject node
    'tdc is the global TDConnection object.
    Set tfact = tdc.TestFactory
    Set TestFilter = tfact.Filter
    TestFilter.Filter("TS_NAME") = "Flight_Reservation_Stress"
    TestFilter.Filter("TS_SUBJECT") = """Subject\Flight Reservation"""
    ' There should only be one item in the List
    Set TestList = tfact.NewList(TestFilter.Text)
    Debug.Print TestList.Count ' output is 1
                                        '
    Set theCoverTest = TestList.Item(1)
    idx = theCoverTest.ID
    Debug.Print idx
'--------------------------------------------------------
' Use Req.GetCoverList to Check what coverage already exists.
' So that this example can run more than once, we
' remove the test we want to use if we find it.
' In production code, you'll probably exit if
' you find that the requirement is already covered
' by the test.
    Set CoverList = theReqToCover.GetCoverList
    Debug.Print CoverList.Count
    For Each aTest In CoverList
        With aTest
        Debug.Print .ID, .Name
        If .ID = idx Then
'--------------------------------------------------------
' Use Req.RemoveCoverage to remove the test from the List.
            theReqToCover.RemoveCoverage aTest
            theReqToCover.Post
        End If
        End With
    Next aTest
'--------------------------------------------------------
' Use Req.AddCoverage to add a test
' We now have the requirement and the test,
' so add the test to the requirement's coverage.
    theReqToCover.AddCoverage idx, TDPOSITION_LAST
' Now check again what coverage exists
    Set CoverList = theReqToCover.GetCoverList
    Debug.Print CoverList.Count
    For Each aTest In CoverList
        With aTest
        Debug.Print .ID, .Name
        End With
    Next aTest
' Save the change to the requirement object
' to the project database
    theReqToCover.Post
Exit Sub
AddCoverageErr:
ErrHandler err, "AddCoverage", CStr(err.Number - vbObjectError)
End Sub


%%ItemTitle%%

OTA COM Type Library

Get a List of all the covering tests that have not run

Source code

Public Sub AddCoverageEx()
    Dim SubNode As SubjectNode, SubjectID As Variant
    Dim theReqToCover As Req
    Dim TestFilter As TDFilter
    On Error GoTo AddCoverageExErr
    ' For code of GetSubjectNodeByPath, see example
    ' Getting a test subject node by the node path
    Set SubNode = GetSubjectNodeByPath("Flight Reservation")
    SubjectID = SubNode.NodeID
    Debug.Print SubjectID
' Get the requirement to cover: "Car Rentals"
' under "Products/Services On Sale"
' To see the code of GetReqByPath, see example
' "Find a specified requirement in a specified folder"
' under Req and ReqFactory
    Dim reqPath$
    reqPath = "Mercury Tours Application" _
            & "\Online Travel Booking Services" _
            & "\Products/Services On Sale" _
            & "\Car Rentals"
    Set theReqToCover = GetReqByPath(reqPath)
'-------------------------------------------------------
' Use Req.AddCoverageEx to create the coverage
    theReqToCover.AddCoverageEx SubjectID, TDPOSITION_LAST
    theReqToCover.Post
' See the covering tests that have not yet run
' Get a test filter and set the execution status to "No Run"
    'tdc is the global TDConnection object.
    Set TestFilter = tdc.TestFactory.Filter
' Note that the quote marks must be part of the string if
' the value contains spaces.
' "No Run" would be passed as the string (No Run)and would fail.
' """No Run""" is passed as ("No Run") as required.
    TestFilter.Filter("TS_EXEC_STATUS") = """No Run"""
    Dim CovList As list, aTest As ITest
'------------------------------------------------------
' Use Req.GetCoverListByFilter to
' get the filtered List of all tests, recursively, that
' cover the requirement.
    Set CovList = _
        theReqToCover.GetCoverListByFilter(TestFilter.Text, True)
    For Each aTest In CovList
        With aTest
            Debug.Print .Name, .execStatus, .Type
        End With
    Next
Exit Sub
AddCoverageExErr:
    ErrHandler err, "AddCoverageEx"
End Sub


%%ItemTitle%%

OTA COM Type Library

Get the List of tests that cover a requirement

Source code

Public Sub AddCoverage()
'This procedure locates a particular requirement and a
'particular test and adds the test to the requirement's coverage.
    Dim rFact As reqFactory
    Dim tfact As TestFactory
    Dim aTest As TDAPIOLELib.test
    Dim CoverList As list, TestList As list, reqList As list
    Dim theCoverTest As TDAPIOLELib.test
    Dim theReqToCover As Req
    Dim ReqFilter As TDFilter, TestFilter As TDFilter
    Dim idx% 'an index number
    On Error GoTo AddCoverageErr
'
'Get the requirement Factory.
    'tdc is the global TDConnection object.
    Set rFact = tdc.reqFactory
' Note that requirement names are not necessarily unique in
' the project.
' The demo project as delivered has only one 'Hotel Reservations',
' but another was created for this example.
    Set ReqFilter = rFact.Filter
    'Note double quote marks because of space in name.
    ReqFilter.Filter("RQ_REQ_NAME") = """Hotel Reservations"""
    Set reqList = rFact.NewList(ReqFilter.Text)
    Debug.Print "The number of requirements named Hotel Reservations = " & reqList.Count
    'The number of requirements named Hotel Reservations = 2
'
' Therefore, we'll limit our search to a single parent requirement
' folder, where requirement names are unique.
' To see the code of GetReqByPath, see example
' "Find a specified requirement in a specified folder"
' under Req and ReqFactory
    Dim reqPath$
    reqPath = "Mercury Tours Application" _
            & "\Online Travel Booking Services" _
            & "\Products/Services On Sale" _
            & "\Hotel Reservations"
    Set theReqToCover = GetReqByPath(reqPath)
' One alternative to the code in GetReqByPath is to
' read the Item ID from the user interface
' in the Requirements module.
    ' Set theReqToCover = RFact.Item(81)
                                    '
    With theReqToCover
    Debug.Print .Name, .Status, .Author
    'Hotel Reservations Failed alex_qc
    End With
                                    '
' Get a unique test by restricting selection to a specific subject node
    'tdc is the global TDConnection object.
    Set tfact = tdc.TestFactory
    Set TestFilter = tfact.Filter
    TestFilter.Filter("TS_NAME") = "Flight_Reservation_Stress"
    TestFilter.Filter("TS_SUBJECT") = """Subject\Flight Reservation"""
    ' There should only be one item in the List
    Set TestList = tfact.NewList(TestFilter.Text)
    Debug.Print TestList.Count ' output is 1
                                        '
    Set theCoverTest = TestList.Item(1)
    idx = theCoverTest.ID
    Debug.Print idx
'--------------------------------------------------------
' Use Req.GetCoverList to Check what coverage already exists.
' So that this example can run more than once, we
' remove the test we want to use if we find it.
' In production code, you'll probably exit if
' you find that the requirement is already covered
' by the test.
    Set CoverList = theReqToCover.GetCoverList
    Debug.Print CoverList.Count
    For Each aTest In CoverList
        With aTest
        Debug.Print .ID, .Name
        If .ID = idx Then
'--------------------------------------------------------
' Use Req.RemoveCoverage to remove the test from the List.
            theReqToCover.RemoveCoverage aTest
            theReqToCover.Post
        End If
        End With
    Next aTest
'--------------------------------------------------------
' Use Req.AddCoverage to add a test
' We now have the requirement and the test,
' so add the test to the requirement's coverage.
    theReqToCover.AddCoverage idx, TDPOSITION_LAST
' Now check again what coverage exists
    Set CoverList = theReqToCover.GetCoverList
    Debug.Print CoverList.Count
    For Each aTest In CoverList
        With aTest
        Debug.Print .ID, .Name
        End With
    Next aTest
' Save the change to the requirement object
' to the project database
    theReqToCover.Post
Exit Sub
AddCoverageErr:
ErrHandler err, "AddCoverage", CStr(err.Number - vbObjectError)
End Sub


%%PageItemTitle%%

Req Object

HasRichContent Property

Description

Checks if the object has rich content.

Property type

Read-only property

Syntax (Visual Basic)

Public Property HasRichContent() As Boolean

Remarks

This property is available only for Quality Center version 9.2. Applications using the property will have to be changed in later versions.

See Also

Req Object


%%PageItemTitle%% $$Members$$

Req Object

IAlertable2 Implemented Interface Members

See Also

Req Object


%%PageItemTitle%% $$Members$$

Req Object

IBaseField2 Implemented Interface Members

See Also

Req Object


%%PageItemTitle%% $$Members$$

Req Object

ICoverableReq Implemented Interface Members

See Also

Req Object


%%PageItemTitle%% $$Members$$

Req Object

IFollowUpManager Implemented Interface Members

See Also

Req Object


%%PageItemTitle%% $$Members$$

Req Object

ILinkable Implemented Interface Members

See Also

Req Object


%%ItemTitle%%

OTA COM Type Library

Get requirement properties

Source code

Public Sub RequirementProperties()
'This example outputs the first 10 requirements in the project
'and their properties to the output window.
    Dim rFact As reqFactory
    Dim myList As list
    Dim aTest As TDAPIOLELib.test, CoverList As list
    Dim Req As Req
    Dim aField As TDField, FieldsList As list
    Dim CustField As CustomizationField
    Dim i%
'
'Get the requirement Factory
    'tdc is the global TDConnection object.
    Set rFact = tdc.reqFactory
'Get the List of requirements
    Set myList = rFact.NewList("")
'
'Output the name and and some properties of
' the first ten requirements
    For Each Req In myList
        i = i + 1: If i > 10 Then Exit For
        With Req
            Debug.Print .Name & ": Numeration = " _
                & .Paragraph & ", Path = " & .Path
            Debug.Print "Type = " & .Type & " : Status = " _
                & .Status & " : Review Status = " & .Reviewed
            Debug.Print "------------------------------------"
        End With 'Req
    Next
End Sub


%%ItemTitle%%

OTA COM Type Library

Remove a test from the requirement coverage

Source code

Public Sub AddCoverage()
'This procedure locates a particular requirement and a
'particular test and adds the test to the requirement's coverage.
    Dim rFact As reqFactory
    Dim tfact As TestFactory
    Dim aTest As TDAPIOLELib.test
    Dim CoverList As list, TestList As list, reqList As list
    Dim theCoverTest As TDAPIOLELib.test
    Dim theReqToCover As Req
    Dim ReqFilter As TDFilter, TestFilter As TDFilter
    Dim idx% 'an index number
    On Error GoTo AddCoverageErr
'
'Get the requirement Factory.
    'tdc is the global TDConnection object.
    Set rFact = tdc.reqFactory
' Note that requirement names are not necessarily unique in
' the project.
' The demo project as delivered has only one 'Hotel Reservations',
' but another was created for this example.
    Set ReqFilter = rFact.Filter
    'Note double quote marks because of space in name.
    ReqFilter.Filter("RQ_REQ_NAME") = """Hotel Reservations"""
    Set reqList = rFact.NewList(ReqFilter.Text)
    Debug.Print "The number of requirements named Hotel Reservations = " & reqList.Count
    'The number of requirements named Hotel Reservations = 2
'
' Therefore, we'll limit our search to a single parent requirement
' folder, where requirement names are unique.
' To see the code of GetReqByPath, see example
' "Find a specified requirement in a specified folder"
' under Req and ReqFactory
    Dim reqPath$
    reqPath = "Mercury Tours Application" _
            & "\Online Travel Booking Services" _
            & "\Products/Services On Sale" _
            & "\Hotel Reservations"
    Set theReqToCover = GetReqByPath(reqPath)
' One alternative to the code in GetReqByPath is to
' read the Item ID from the user interface
' in the Requirements module.
    ' Set theReqToCover = RFact.Item(81)
                                    '
    With theReqToCover
    Debug.Print .Name, .Status, .Author
    'Hotel Reservations Failed alex_qc
    End With
                                    '
' Get a unique test by restricting selection to a specific subject node
    'tdc is the global TDConnection object.
    Set tfact = tdc.TestFactory
    Set TestFilter = tfact.Filter
    TestFilter.Filter("TS_NAME") = "Flight_Reservation_Stress"
    TestFilter.Filter("TS_SUBJECT") = """Subject\Flight Reservation"""
    ' There should only be one item in the List
    Set TestList = tfact.NewList(TestFilter.Text)
    Debug.Print TestList.Count ' output is 1
                                        '
    Set theCoverTest = TestList.Item(1)
    idx = theCoverTest.ID
    Debug.Print idx
'--------------------------------------------------------
' Use Req.GetCoverList to Check what coverage already exists.
' So that this example can run more than once, we
' remove the test we want to use if we find it.
' In production code, you'll probably exit if
' you find that the requirement is already covered
' by the test.
    Set CoverList = theReqToCover.GetCoverList
    Debug.Print CoverList.Count
    For Each aTest In CoverList
        With aTest
        Debug.Print .ID, .Name
        If .ID = idx Then
'--------------------------------------------------------
' Use Req.RemoveCoverage to remove the test from the List.
            theReqToCover.RemoveCoverage aTest
            theReqToCover.Post
        End If
        End With
    Next aTest
'--------------------------------------------------------
' Use Req.AddCoverage to add a test
' We now have the requirement and the test,
' so add the test to the requirement's coverage.
    theReqToCover.AddCoverage idx, TDPOSITION_LAST
' Now check again what coverage exists
    Set CoverList = theReqToCover.GetCoverList
    Debug.Print CoverList.Count
    For Each aTest In CoverList
        With aTest
        Debug.Print .ID, .Name
        End With
    Next aTest
' Save the change to the requirement object
' to the project database
    theReqToCover.Post
Exit Sub
AddCoverageErr:
ErrHandler err, "AddCoverage", CStr(err.Number - vbObjectError)
End Sub


%%PageItemTitle%% $$Members$$

RTParam Overview

RTParam Object Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Desc | The parameter description.
Public Property Field | The value of the specified field.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The component parameter's name.
Public Property Order | The position of the parameter in the set of parameters of the same component.
Public Property Value | The parameter's default value.
Public Property ValueType | The parameter type. For example Date, String, number, etc.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

RTParam Overview


%%PageItemTitle%% $$Members$$

Rule Overview

Rule Object Members

Public Methods

Public Method Post Saves the changes to the Rules object to the server.

Public Properties

Public Property Description | The rule description.
Public Property ID | The rule ID.
Public Property IsActive | Indicates if the rule is active.
Public Property Recipient | Returns the user name of the recipient of the alert email.
Public Property ToMail | Indicates if the alert is to be sent by e-mail.

See Also

Rule Overview


%%PageItemTitle%% $$Members$$

RuleManager Overview

RuleManager Object Members

Public Methods

Public Method GetRule Gets a traceability notification rule by its ID.

Public Properties

Public Property Rules A list of all the Rule objects.

See Also

RuleManager Overview


%%PageItemTitle%% $$Members$$

Run Overview

Run Object Members

Public Methods

Public Method CancelRun | Cancels the run.
Public Method CopyDesignSteps | Copies design steps into the test run of an executed test.
Public Method CopyStepsToTest | Copies all run execution steps, including new added steps, into the design steps of the corresponding planning test.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method ResolveStepsParameters | Updates the texts of the run's steps by resolving the parameter values at run time.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property BPStepParamFactory | The BPStepParamFactory for the current run.
Public Property ExtendedStorage | The ExtendedStorage object for the current run.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The run name.
Public Property Params | The step parameters of this run.
Public Property ResultLocation | The run result location, a UNC path.
Public Property Status | The run status.
Public Property StepFactory | The Step Factory for the current run.
Public Property TestId | The test ID of the test that has been run.
Public Property TestInstance | The number of this instance of the design test in the test set.
Public Property TestInstanceID | The ID of the test instance for the current run.
Public Property TestSetID | The ID of the test set to which the run belongs.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

Run Overview


%%PageItemTitle%% $$Members$$

RunFactory Overview

RunFactory Object Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method DeleteDuplicateRuns | Removes duplicate runs for the current test set. Removal is immediate without Post.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.
Public Property UniqueRunName | Gets the run name. The name is unique in the current test and test set.

See Also

RunFactory Overview


%%PageItemTitle%% $$Members$$

RunFactory Object

IBaseFactory2 Implemented Interface Members

See Also

RunFactory Object


%%PageItemTitle%% $$Members$$

RunFactory Object

ISupportCopyPaste2 Implemented Interface Members

See Also

RunFactory Object


%%PageItemTitle%% $$Members$$

Run Object

IBaseField2 Implemented Interface Members

See Also

Run Object


%%PageItemTitle%% $$Members$$

Run Object

ILinkable Implemented Interface Members

See Also

Run Object


%%PageItemTitle%% $$Members$$

SearchOptions Overview

SearchOptions Object Members

Public Properties

Public Property Filter | Get filter
Public Property Property | The search configuration flag.

See Also

SearchOptions Overview


%%PageItemTitle%% $$Members$$

Settings Overview

Settings Object Members

Public Methods

Public Method Close | Closes and updates the category.
Public Method DeleteCategory | Deletes the current settings folder.
Public Method DeleteValue | Deletes the specified item.
Public Method Open | Sets the category to be used in subsequent actions by the client.
Public Method Post | Posts the category to the server.
Public Method Refresh | Reads saved values, overwriting values in memory.

Public Properties

Public Property EnumItems | Returns the list of names of the setting's items.
Public Property IsSystem | Checks if the specified setting is built-in and read-only.
Public Property Value | The value of the specified item in the active category.

See Also

Settings Overview


%%ItemTitle%%

OTA COM Type Library

Get the Property for a Specific Field

Source code

Public Sub GetSettingsValues()
    Dim aSet As Settings
    Dim setItems As list
    Dim aSetItem
    Dim ItemName As String
    Dim aField As TDField
    Dim fieldList As list
'------------------------------------------------
' Get the Settings object for the logged-on user
' with TDConnection.UserSettings
    Set aSet = tdc.UserSettings
' Get the list of all the setting items
    Set setItems = aSet.EnumItems
' Print them out
    For Each aSetItem In setItems
        ItemName = aSetItem
        Debug.Print aSetItem
        Debug.Print "-----------------------"
        Debug.Print aSet.Value(ItemName)
        Debug.Print "======================="
    Next aSetItem
End Sub


%%PageItemTitle%% $$Members$$

Step Overview

Step Object Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property BPStepParamFactory | The BPStepParamFactory for the current step.
Public Property DesignStepSource | The test ID of the test from which this step run originates.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The run step name.
Public Property Run | Gets the Run object handling this step.
Public Property Status | The run step status.
Public Property TestSource | The test ID of the test from which this step run originates.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

Step Overview


%%PageItemTitle%% $$Members$$

StepFactory Overview

StepFactory Object Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

StepFactory Overview


%%PageItemTitle%% $$Members$$

StepFactory Object

IBaseFactory2 Implemented Interface Members

See Also

StepFactory Object


%%PageItemTitle%% $$Members$$

StepFactory Object

ISupportCopyPaste2 Implemented Interface Members

See Also

StepFactory Object


%%PageItemTitle%% $$Members$$

StepParams Overview | DesignStep Object | Test Object | TSTest Object | Run Object

See Also OTA COM Type Library

StepParams Object Members

Public Methods

Public Method AddParam | Adds a new parameter to the object.
Public Method ClearParam | Clears the parameter value by setting it to null.
Public Method DeleteParam | Deletes the specified parameter.
Public Method Refresh | Refreshes the data from the database, discarding changes.
Public Method Save | Uploads the parameter definitions to the database.

Public Properties

Public Property Count | The number of parameters for the object.
Public Property ParamExist | Checks if a parameter of this name exists.
Public Property ParamName | The name of the parameter in the specified position in the StepParams collection (zero-based).
Public Property ParamValue | The value of the specified parameter.
Public Property Type | Gets the parameter type: predefined, null, or regular.

See Also

StepParams Overview | DesignStep Object | Test Object | TSTest Object | Run Object


%%ItemTitle%%

OTA COM Type Library

Get attributes of step parameters

Source code

Public Sub TSTestParams()
    Dim TSetFact As TestSetFactory
    Dim tsFact As TSTestFactory
    Dim aTestSet As TestSet
    Dim theTest As TSTest
    Dim tsTests As list, tsSets As list
    Dim i%, rc
    Dim exParams As StepParams
'Get the list of test sets from the test set factory
    'tdc is the global TDConnection object.
    Set TSetFact = tdc.TestSetFactory
    Set tsSets = TSetFact.NewList("")
'Go through each test set and find the parameters for each test
For Each aTestSet In tsSets
    Set tsFact = aTestSet.TSTestFactory
    Set tsTests = tsFact.NewList("")
    '
    For Each theTest In tsTests
        If Not (theTest.Params Is Nothing) Then
            If theTest.Params.Count > 0 Then
'Output the parameters
                Set exParams = theTest.Params
                With exParams
                    Debug.Print _
                        "The number of items in the list is " _
                            & .Count
                    For i = 0 To .Count - 1
                        Debug.Print "Parameter name is " _
                            & Trim(.ParamName(i))
                        Debug.Print "Value and type : "
                        Debug.Print vbTab & "Value :" _
                            & Trim(.ParamValue(i))
                        Debug.Print vbTab & "Type :" _
                            & StepParamType(.Type(i))
                    Next i
                    rc = MsgBox("Continue to next test?", vbYesNo)
                    If rc = vbNo Then Exit Sub
                End With
            End If
        End If
    Next theTest
Next aTestSet
End Sub


%%PageItemTitle%% $$Members$$

Step Object

IBaseField2 Implemented Interface Members

See Also

Step Object


%%PageItemTitle%% $$Members$$

Step Object

IBaseField3 Implemented Interface Members

See Also

Step Object


%%PageItemTitle%% $$Members$$

Step Object

ILinkable Implemented Interface Members

See Also

Step Object


%%PageItemTitle%%

Structures Members

Structures Object

 | Copyright 2002-2007 Mercury Interactive Corporation.
For additional examples and examples in C# and C++, see the Knowledge Base. | Documentation comments or suggestions? Please send feedback to SW-Doc@hp.com


%%PageItemTitle%% $$Members$$

Structures Overview

Structures Object Members

See Also

Structures Overview


%%PageItemTitle%% $$Members$$

SubjectNode Overview

SubjectNode Object Members

Public Methods

Public Method AddNode | Adds a new child node.
Public Method FindChildNode | Finds a child node by node name.
Public Method FindChildren | Finds node children according to specified search pattern.
Public Method FindTests | Finds tests within the current subject folder whose name matches the specified text pattern.
Public Method Move | Moves the current tree mode to be under the specified parent.
Public Method NewList | Gets a list of the node's immediate children.
Public Method Post | Posts all changed values to the database.
Public Method Refresh | Reads the saved node data, overwriting values in memory.
Public Method RemoveSubjectNode | Removes the specified node from the subject tree.

Public Properties

Public Property Attachments | The AttachmentFactory for the subject folder.
Public Property Attribute | Gets the node attribute.
Public Property Child | Gets a sub-folder of the current folder.
Public Property Count | The number of child nodes.
Public Property DepthType | The sub-tree depth type.
Public Property Description | A description of the subject node.
Public Property Father | The current folder's parent folder.
Public Property HasAttachment | Checks if the SubjectNode has at least one attachment.
Public Property Name | The node name.
Public Property NodeID | The node ID number.
Public Property Path | The folder tree path starting from the tree root.
Public Property TestFactory | The TestFactory object for the subject folder.
Public Property ViewOrder | The position of the node in the tree as presented in the user interface.

See Also

SubjectNode Overview


%%ItemTitle%%

OTA COM Type Library

Add test

Source code

Public Sub AddTest(testName$)
'Add test
    Dim test1 As Test
    Dim folder As SubjectNode
    Dim testF As testFactory
    Dim treeM As TreeManager
    Set treeM = tdc.TreeManager
    Set folder = treeM.NodeByPath("Subject\TestFolder1")
    Set testF = folder.testFactory
    Set test1 = testF.AddItem(Null)
    test1.Name = testName
    test1.Type = "SYSTEM-TEST"
    test1.Post
End Sub


%%ItemTitle%%

OTA COM Type Library

Delete a test plan folder

Source code

Public Sub DeleteTestPlanFolder()
'Delete test plan folder
    Dim treeM As TreeManager
    Set treeM = tdc.TreeManager
    Dim root As SubjectNode
    Set root = treeM.TreeRoot("Subject")
    Dim folder As SubjectNode
    'Set folder = treeM.NodeById(137)
    Set folder = treeM.NodeByPath("Subject\ObsoleteFolder")
    root.RemoveSubjectNode folder, True
End Sub


%%ItemTitle%%

OTA COM Type Library

Get a test in a subject folder

Source code

Public Sub GetTestInstanceCount()
    Dim tsFilter As TDFilter
    Dim TSetFact As TestSetFactory
    Dim theTestSet As TestSet
    Dim tsTreeMgr As TestSetTreeManager
    Dim tsFolder As TestSetFolder
    Dim tsList As iList
' Get the test set tree manager from the test set factory
    'tdc is the global TDConnection object.
    Set TSetFact = tdc.TestSetFactory
    Set tsTreeMgr = tdc.TestSetTreeManager
'---------------------------------------------------------------
' Use TestSetTreeManager.NodeByPath
' to get the test set folder
    Set tsFolder = tsTreeMgr.NodeByPath("Root\OTA_Demo_TestSets")
'---------------------------------------------------------------
' Use TestSetFolder.FindTestSets
' to search for a particular test set
    Set tsList = tsFolder.FindTestSets("OTA_TS_2")
    If tsList.Count > 1 Then
        MsgBox "FindTestSets found more than one test set: refine search"
    ElseIf tsList.Count < 1 Then
        MsgBox "FindTestSets: test set not found"
    End If
    Set theTestSet = tsList.Item(1)
'
'Get a particular test in the set
    Dim rstr$, theTest As test, tList As list
    Dim testSubjectFolder As SubjectNode
'Get the subject folder for the test
    ' For the code of GetSubjectNodeByPath
    ' see example 'Getting a test subject node by the node path'
    Set testSubjectFolder = _
     GetSubjectNodeByPath _
      ("OTA_DEMO_SUBJECT\OTA_SUBJECT_level1\OTA_SUB_1.1\OTA_SUB_1.1.1\OTA_SUB_1.1.1.1")
'--------------------------------------------------------------------
' Use SubjectNode.FindTests
' to get a list of tests with exactly that name.
    Set tList = testSubjectFolder.FindTests("TEST1.1.1.1_A")
' There should be only one item in the list.
    If tList.Count > 1 Then
        MsgBox "FindTests found more than one test: refine search"
    ElseIf tsList.Count < 1 Then
        MsgBox "FindTests: test not found"
    End If
    Set theTest = tList.Item(1)
'---------------------------------------------------
' Use TestSet.CheckTestInstances to get information
' about instances of this test in this test set.
    rstr = theTestSet.CheckTestInstances(theTest.ID)
    Debug.Print rstr
'Output:
' {
' NUM_OF_INSTANCES:3,
' TS_TEST_ID:95,
' TS_NAME:TEST1.1.1.1_A,
' TS_TYPE:MANUAL,
' TS_STEPS:0,
' TS_TEMPLATE:
' }
End Sub


%%ItemTitle%%

OTA COM Type Library

Getting subject nodes

Source code

Public Sub SubjectList()
    Dim TreeMgr As TreeManager
    Dim SubjRoot As SubjectNode
    Dim ChildNode As SubjectNode
    Dim GrandChildNode As SubjectNode
    Dim LeafNode As SubjectNode
    Dim RootName As String
    Dim Trees As list
    Dim i%
'-----------------------------------------------------
'Use TreeManager.TreeRoot to get the list of subject
' root nodes from the tree manager.
'There is only one item in this list.
    'tdc is the global TDConnection object.
    Set TreeMgr = tdc.TreeManager
    Set Trees = TreeMgr.RootList(TDOLE_SUBJECT)
'Get the name of the subject tree root in your project
    RootName = Trees.Item(1)
'------------------------------------------------------
'Get the SubjectNode root node object from the
' tree manager by name
    Set SubjRoot = TreeMgr.TreeRoot(RootName)
    Debug.Print "Root node : Name = " & SubjRoot.Name _
        & ", Depth = " & SubjRoot.DepthType _
        & ", Path = " & SubjRoot.Path
' Root node : Name = Subject, Depth = 2, Path = Subject
    For i = 1 To SubjRoot.Count
        Debug.Print SubjRoot.Child(i).Name
    Next i
' Flight Reservation
' Profiling
' Itinerary
' Compiled Modules
' Cruises
' Mercury Tours Site
' f1
' BPT Resources
' alexk
    Debug.Print "------------------------"
' Get any child node for example. We'll just take the first.
    Set ChildNode = SubjRoot.Child(1)
    Debug.Print "Child node: Name = " & ChildNode.Name _
        & ", Depth = " & ChildNode.DepthType _
        & ", Path = " & ChildNode.Path
' Child node: Name = Flight Reservation, Depth = 2, _
    Path = Subject\Flight Reservation
    For i = 1 To ChildNode.Count
        Debug.Print ChildNode.Child(i).Name
    Next i
' Flight Finder
' Select Flight
' Book Flight
' Flight Confirmation
' Flight Cost
    Debug.Print "------------------------"
' Get a node one more level down.
    Set GrandChildNode = ChildNode.Child(1)
    Debug.Print "GrandChild : Name = " & GrandChildNode.Name _
        & ", Depth = " & GrandChildNode.DepthType _
        & ", Path = " & GrandChildNode.Path
' GrandChild : Name = Flight Finder, Depth = 1, _
    Path = Subject\Flight Reservation\Flight Finder
    For i = 1 To GrandChildNode.Count
        Debug.Print GrandChildNode.Child(i).Name
    Next i
'Son of Flight Finder
'
    If GrandChildNode.Count > 0 Then _
        Set LeafNode = GrandChildNode.Child(1)
'
' The "Son of Flight Finder" node is not part of the
' demonstration project. It was added for this example,
' so if you run this code on your site, the routine will exit here.
    If LeafNode Is Nothing Then Exit Sub
    Debug.Print "LeafNode : Name = " & LeafNode.Name _
        & ", Depth = " & LeafNode.DepthType _
        & ", Path = " & LeafNode.Path
' LeafNode : Name = Son of Flight Finder, Depth = 0, _
Path = Subject\Flight Reservation\Flight Finder\Son of Flight Finder
End Sub


%%PageItemTitle%% $$Members$$

SubjectNode Object

IBaseField2 Implemented Interface Members

See Also

SubjectNode Object


%%PageItemTitle%% $$Members$$

SubjectNode Object

IObjectLockingSupport Implemented Interface Members

See Also

SubjectNode Object


%%PageItemTitle%% $$Members$$

SubjectNode Object

ISupportCopyPaste2 Implemented Interface Members

See Also

SubjectNode Object


%%PageItemTitle%% $$Members$$

SysTreeNode Overview

SysTreeNode Object Members

Public Methods

Public Method AddNode | Adds a new child node.
Public Method FindChildNode | Finds a child node by node name.
Public Method FindChildren | Finds node children according to specified search pattern.
Public Method NewList | Gets a list of the node's immediate children.
Public Method Post | Posts all changed values to the database.
Public Method Refresh | Reads the saved node data, overwriting values in memory.
Public Method RemoveNode | Deletes the specified node.

Public Properties

Public Property Attribute | Gets the node attribute.
Public Property Child | Gets a sub-folder of the current folder.
Public Property Count | The number of child nodes.
Public Property DepthType | The sub-tree depth type.
Public Property Father | The current folder's parent folder.
Public Property Name | The node name.
Public Property NodeID | The node ID number.
Public Property Path | The folder tree path starting from the tree root.

See Also

SysTreeNode Overview


%%PageItemTitle%% $$Members$$

SysTreeNode Object

IBaseField2 Implemented Interface Members

See Also

SysTreeNode Object


%%PageItemTitle%% $$Members$$

TDConnection Overview

TDConnection Object Members

Public Methods

Public Method ChangePassword | Changes the password for the currently logged in user.
Public Method Connect | Connects the logged-in user to the specified project in the domain.
Public Method ConnectProject | Connects to the specified project.
Public Method ConnectProjectEx | Connects to the specified project in the specified domain.
Public Method Disconnect | Disconnects the user from the currently connected project.
Public Method DisconnectProject | Disconnects from the project.
Public Method GetLicenses | Allocates multiple licenses types according to the LicensesType parameter.
Public Method GetLicenseStatus | The license status for the specified client type.
Public Method GetTDParamsNames | Returns the names of the site's parameters.
Public Method GetTDVersion | The major and minor versions of the OTA API.
Public Method InitConnectionEx | Initializes the connection.
Public Method Login | Confirms that the user is authorized to use Quality Center. If authorized, the user is logged in and can connect to projects.
Public Method Logout | Terminates the user's session on this TDConnection.
Public Method PurgeRuns | Deletes the runs in this connection that match the input arguments.
Public Method ReleaseConnection | ReleaseConnection must be called for each call of an initialization method after finishing work with the Open Test Architecture API.
Public Method SendMail | Sends Mail.

Public Properties

Public Property ActionPermission | The ActionPermission object for this connection.
Public Property AlertManager | The AlertManager object for this connection.
Public Property ApplicationEntityFactory | The application entity factory object for this connection.
Public Property ApplicationEntityTreeManager | The application entity tree and related application entity folders factory for this connection.
Public Property AuditPropertyFactory | The global AuditProperty factory, not associated with a specific entity.
Public Property AuditRecordFactory | The global AuditRecord factory, not associated with a specific entity.
Public Property BugFactory | The Bug Factory object for this connection.
Public Property CheckoutRepository | The path of the checkout repository.
Public Property Command | The Command object for this connection.
Public Property CommonSettings | The Settings object for all users in this connection.
Public Property Connected | Checks if the Open Test Architecture API server connection is initialized.
Public Property Customization | The Customization object for this connection.
Public Property CycleFactory | The factory that manages cycles.
Public Property DBName | The name of the database.
Public Property DBType | The database type.
Public Property DirectoryPath | The path of the server side repository directory for the database repository type.
Public Property DomainName | The current domain.
Public Property DomainsList | The domain names for this site.
Public Property ExtendedStorage | The ExtendedStorage object for this connection.
Public Property Fields | A list of fields for the table specified in the DataType argument.
Public Property GraphBuilder | The GraphBuilder object for the connection.
Public Property HostFactory | The Hosts Factory object for this connection.
Public Property HostGroupFactory | The HostGroupFactory object for this connection.
Public Property IgnoreHtmlFormat | Indicates if formatted memo and description fields are returned as plain text without HTML tags.
Public Property IsSearchSupported | Checks if the search function is enabled for the project.
Public Property LoggedIn | Checks if a user is currently logged in on this TDConnection.
Public Property MailConditions | The TDMailConditions object for this connection.
Public Property ProductInfo | An IProductInfo reference pointing to the current build information.
Public Property ProjectConnected | Checks if the TDConnection is connected to a project.
Public Property ProjectName | The name of the connected project.
Public Property ProjectProperties | The ProjectProperties object for this connection.
Public Property ProjectsList | The projects that are available in the domain to which Quality Center is connected.
Public Property ProjectsListEx | The projects available within the specified domain.
Public Property ReleaseFactory | The factory that manages releases.
Public Property ReleaseFolderFactory | The factory that manages release folders.
Public Property ReportRole | The report role of the connected user.
Public Property ReqFactory | The ReqFactory object for this connection.
Public Property Rules | The RuleManager object for this connection.
Public Property RunFactory | The RunFactory object for this connection.
Public Property ServerName | The name of the connected Open Test Architecture API server.
Public Property ServerTime | The time and date of the currently connected database server.
Public Property ServerURL | The URL of the connected server.
Public Property ServiceChangeFactory | The service change factory object for this connection.
Public Property ServiceFactory | The service factory object for this connection.
Public Property ServiceFolderFactory | The service folder factory object for this connection.
Public Property ServiceGroupFactory | The service group factory object for this connection.
Public Property TDParams | Gets the value of the parameter whose name is specified by Request.
Public Property TestFactory | The Test Factory object for this connection.
Public Property TestRepository | The path of the tests directory of the connected project.
Public Property TestSetFactory | The Test Set Factory object for this connection.
Public Property TestSetTreeManager | The TestSetTreeManager object for this connection.
Public Property TextParam | The TextParser object.
Public Property TreeManager | The TreeManager object for the system tree.
Public Property TSTestFactory | The factory that manages test instances in test sets.
Public Property UserGroupsList | The names of the user groups of the currently connected project.
Public Property UserName | The user connected to the project.
Public Property UserSettings | The Settings object for the logged-on user.
Public Property UsersList | The names of the users of the currently connected project.
Public Property UsingProgress | Indicates if a progress bar is displayed.
Public Property VCS | The Version Control System (VCS) object for this connection.
Public Property VcsDbRepository | The path of the VCS database of the connected project.
Public Property VisibleDomains | The list of domain names that the current logged in user is permitted to view.
Public Property VisibleProjects | The list of projects in the specified domain that the current logged in user is allowed to connect to.

See Also

TDConnection Overview


%%ItemTitle%%

OTA COM Type Library

Changing the logged on user's password

Source code

Sub ChangeMyPassword()
' This example changes an initally empty password to
' a string.
' The change applies to the user logged on to the
' TDConnection and project in this OTA session.
'
' Please do not understand from this example that
' we are recommending "1234" as a secure password.
' With a little imagination, you can do much better.
'
    'tdc is the global TDConnection object.
    MsgBox tdc.username
    tdc.ChangePassword "", "1234"
End Sub


%%ItemTitle%%

OTA COM Type Library

Connect and Log on

Source code

Private Function makeConnection(ByVal qcHostName$, qcDomain$, qcProject$, _
    qcUser$, qcPassword$, Optional qcPort) As Boolean
'------------------------------------------------------------------------
' This routine makes the connection to the gobal TDConnection object,
' declared at the project level as Global tdc as TDConnection,
' and connects the user to the specified project.
'-----------------------------------------------------------------------
    Dim qcServer As String
    Const fName = "makeConnection" 'For error message
    On Error GoTo makeConnectionErr
    errmsg = ""
'Construct server argument of format "http://server:port/qcbin"
    qcServer = "http://" & qcHostName
    If Not (IsMissing(qcPort)) Then
        If Len(qcPort) > 0 Then qcServer = qcServer & ":" & qcPort
    End If
    qcServer = qcServer & "/qcbin"
''Check status (For illustrative purposes.)
' 'MsgBox tdc.LoggedIn 'Error: OTA Server is not connected
' MsgBox tdc.Connected 'False
' MsgBox tdc.ServerName 'Blank string
'Create the connection
    errmsg = "Failed to create TDConnection"
    If (tdc Is Nothing) Then Set tdc = New TDConnection
    If (tdc Is Nothing) Then GoTo makeConnectionErr
    errmsg = ""
    tdc.InitConnectionEx qcServer
''Check status.
' MsgBox tdc.LoggedIn 'False
' MsgBox tdc.Connected 'True
' MsgBox tdc.ServerName 'http://<qcServer>/qcbin/wcomsrv.dll
'Log on to server
    tdc.Login qcUser, qcPassword
''Check status.
' MsgBox tdc.LoggedIn 'True
' MsgBox tdc.ProjectName 'Empty String
' MsgBox tdc.ProjectConnected 'False
' Connect to the project and user
    tdc.Connect qcDomain, qcProject
' MsgBox tdc.ProjectName 'qcProject
' MsgBox tdc.ProjectConnected 'True
' Exit status
    makeConnection = SUCCESS
Exit Function
makeConnectionErr:
    ErrHandler err, fName, err.Description & vbCrLf & errmsg
    makeConnection = FAILURE
End Function


%%ItemTitle%%

OTA COM Type Library

Disconnect project and release connection

Source code

Public Sub ReleaseConnections()
    On Error Resume Next
    'tdc is the global TDConnection object.
    If tdc Is Nothing Then Exit Sub
''Check status (For illustrative purposes.)
' MsgBox tdc.LoggedIn 'True
' MsgBox tdc.Connected 'True
' MsgBox tdc.ServerName 'http://<qcServer>/qcbin/wcomsrv.dll
' MsgBox tdc.ProjectName '<QC Project name>
' MsgBox tdc.ProjectConnected 'True
'Disconnect from the project
    If tdc.Connected Then
        tdc.Disconnect
    End If
''Check status (For illustrative purposes.)
' MsgBox tdc.LoggedIn 'True
' MsgBox tdc.ProjectName 'Empty string
' MsgBox tdc.ProjectConnected 'False
' ' Note that TDConnection.Connected remains true
' ' as long as connection is live. It is not affected
' ' by disconnection from a project.
' MsgBox tdc.Connected 'True
'Log off the server
    If tdc.LoggedIn Then
        tdc.Logout
    End If
''Check status (For illustrative purposes.)
' MsgBox tdc.Connected 'True
' MsgBox tdc.LoggedIn 'False
'Release the TDConnection object.
    tdc.ReleaseConnection
''Check status (For illustrative purposes.)
' MsgBox tdc.LoggedIn 'Run time error: OTA Server is not connected
' MsgBox tdc.Connected 'False
    Set tdc = Nothing
End Sub


%%PageItemTitle%%

TDConnection Object

ProjectName
The name of the project in the Quality Center data base.
UserName
The user name defined in the Quality Center data base.
Password
The user's password.
See Also OTA COM Type Library

ConnectProject Method

Description

Connects to the specified project.

Syntax

Public Sub ConnectProject( _
   ByVal ProjectName As String, _
   ByVal UserName As String, _
   Optional ByVal Password As String = "" _
)

Parameters

ProjectName
The name of the project in the Quality Center data base.
UserName
The user name defined in the Quality Center data base.
Password
The user's password.

Remarks

This method is deprecated from version 9.0.

Use Login and Connect.

To continue to use this method after it is made obsolete, you must set the BACKWARD_SUPPORT_ALL_DOMAINS_PROJECTS flag in the site configuration. For details, see the Mercury Quality Center Administrator's Guide.

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

DomainName
The logical group of projects in the Quality Center data base.
ProjectName
The name of the project in the Quality Center data base.
UserName
The name of a user defined in the specified project.
Password
The user password.
See Also OTA COM Type Library

ConnectProjectEx Method

Description

Connects to the specified project in the specified domain.

Syntax

Public Sub ConnectProjectEx( _
   ByVal DomainName As String, _
   ByVal ProjectName As String, _
   ByVal UserName As String, _
   Optional ByVal Password As String = "" _
)

Parameters

DomainName
The logical group of projects in the Quality Center data base.
ProjectName
The name of the project in the Quality Center data base.
UserName
The name of a user defined in the specified project.
Password
The user password.

Remarks

This method is deprecated from version 9.0.

Use Login and Connect.

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

DisconnectProject Method

Description

Disconnects from the project.

Syntax

Public Sub DisconnectProject()

Remarks

This method is deprecated from version 9.0.

Use Disconnect and Logout.

To continue to use this method, you must set the BACKWARD_SUPPORT_ALL_DOMAINS_PROJECTS flag in the site configuration. For details, see the Mercury Quality Center Administrator's Guide.

See Also

TDConnection Object


%%PageItemTitle%%

TDConnection Object

DomainsList Property

Description

The domain names for this site.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DomainsList() As List

Remarks

This property is obsolete.

To continue to use this property, you must set the BACKWARD_SUPPORT_ALL_DOMAINS_PROJECTS flag in the site configuration. For details, see the Mercury Quality Center Administrator's Guide.

See Also

TDConnection Object


%%ItemTitle%%

OTA COM Type Library

Get list of fields in a table

Source code

Public Sub GetFields(Optional TableName As String = "ALERT")
Dim aField As TDField
Dim fieldList As list
Dim FieldProp As FieldProperty
'----------------------------------
'Get a list of TDField objects from
'TDConnection.Fields
    'tdc is the global TDConnection object.
    Set fieldList = tdc.Fields(TableName)
'-------------------------------------------
'Use List.Count to check how many items
    Debug.Print "The number of field in the table is " _
        & fieldList.Count
    Debug.Print
'-------------------------------------------
' Use List.Item to get a TDField object
' Use the TDField name property to check
' what is the first item.
    Set aField = fieldList.Item(0)
    Debug.Print "The first item is " & aField.Name
'Walk through the list and output the properties
'Note that although the TDField and the FieldProperty objects
' are returning information on the same field, they are doing
' so from different perspectives and the information is slightly
' different in some cases.
'Run the example and study the output to see these differences.
    For Each aField In fieldList
        With aField
'-------------------------------------------
' Get the FieldProperty object
        Set FieldProp = aField.Property
        If True Then 'fieldProp.IsActive Then
            Debug.Print "---------------------------"
            Debug.Print "TDField.Name: " & .Name
            'TDField.Name: AT_ENTITY_TYPE
            Debug.Print vbTab & "FieldProperty.DBColumnName: " _
                & FieldProp.DBColumnName
            ' FieldProperty.DBColumnName: AT_ENTITY_TYPE
            Debug.Print vbTab & "TDField.Property: " & .Property
            ' FieldProperty.UserLabel: Entity
            Debug.Print vbTab & "FieldProperty.UserLabel: " _
                & FieldProp.UserLabel
            ' FieldProperty.UserLabel: Entity
            Debug.Print vbTab & "TDField.Type: " & .Type _
                & " = " & DataTypeString(.Type)
            ' TDField.Type: 3 = TDOLE_STRING
            Debug.Print vbTab & "FieldProperty.DBColumnType: " _
                & FieldProp.DBColumnType
            ' FieldProperty.DBColumnType: char
            Debug.Print vbTab & "FieldProperty.UserColumnType: " _
                & FieldProp.UserColumnType
            ' FieldProperty.UserColumnType: char
            If FieldProp.IsKey Then
                  Debug.Print vbTab _
                    & "Key Field - FieldProperty.KeyOrder: " _
                    & FieldProp.KeyOrder
                  ' Key Field - FieldProperty.KeyOrder: 0
            End If
            Debug.Print vbTab & "This field" _
                & IIf(FieldProp.IsActive, " is ", " is not ") _
                & "visible in the UI"
            ' This field is not visible in the UI
        End If
        End With
    Next aField
End Sub


%%ItemTitle%%

OTA COM Type Library

Get the Property for a Specific Field

Source code

Public Sub GetSettings()
    Dim aSet As Settings
    Dim setItems As list
    Dim aSetItem
    Dim ItemName As String
    Dim aField As TDField
    Dim fieldList As list
'------------------------------------------------
' Get the Settings object for the logged-on user
' with TDConnection.UserSettings
    'tdc is the global TDConnection object.
    Set aSet = tdc.UserSettings
' Get the list of all the setting items
    Set setItems = aSet.EnumItems
' Print them out
    For Each aSetItem In setItems
        ItemName = aSetItem
        Debug.Print aSetItem
        Debug.Print "-----------------------"
        Debug.Print aSet.Value(ItemName)
        Debug.Print "======================="
    Next aSetItem
'------------------------------------------------
' Use TDConnection.Fields to get the user fields.
' Knowing from the output of the above that there is a "not PDF"
' condition for field "BG_USER_29" in the private favorite view,
' we look to see how the user field is used.
' The result is "BG_USER_29 To_Meeting"
'
    Set fieldList = tdc.Fields("BUG")
    For Each aField In fieldList
        If aField.Name = "BG_USER_29" Then
            Debug.Print aField.Name, aField.Property
            Exit For
        End If
    Next aField
'------------------------------------------------
'OUTPUT:
'* The first setting item output is the grid setup for the user.
'* The user views open defects assigned to user "steves"
'* Note that this setting has no name.
' -----------------------
' {
' grid: "1,0;64,BG_BUG_ID;64,BG_STATUS;64,BG_PRIORITY;64,BG_RESPONSIBLE;460,BG_SUMMARY;",
' filter: "[Filter]{
' TableName:BUG,
' ColumnName:BG_PRIORITY,
' SortOrder:1,
' SortDirection:0,
' NO_CASE:
' }
' {
' TableName:BUG,
' ColumnName:BG_RESPONSIBLE,
' LogicalFilter:steves,
' VisualFilter:\" steves \",
' NO_CASE:
' }
' {
' TableName:BUG,
' ColumnName:BG_STATUS,
' LogicalFilter:\"New Or Open Or Reopen\",
' VisualFilter:\" New Or Open Or Reopen \",
' NO_CASE:
' }
' ",
' show_rdcomment: "y",
' show_description: "y"
' }
'********************************************************************
'*** The second setting item output is a private Favorite view called
'*** "QC_Open_for_Steves"
'*** The Favorite is the same as the view above, but excludes items
'*** with a value of "PDF" in user field BG_USER_29
' =======================
' QC_Open_for_Steves
' -----------------------
' {
' grid: "1,0;64,BG_BUG_ID;64,BG_STATUS;64,BG_PRIORITY;64,BG_RESPONSIBLE;460,BG_SUMMARY;",
' filter: "[Filter]{
' TableName:BUG,
' ColumnName:BG_PRIORITY,
' SortOrder:1,
' SortDirection:0,
' NO_CASE:
' }
' {
' TableName:BUG,
' ColumnName:BG_RESPONSIBLE,
' LogicalFilter:steves,
' VisualFilter:\" steves \",
' NO_CASE:
' }
' {
' TableName:BUG,
' ColumnName:BG_STATUS,
' LogicalFilter:\"New Or Open Or Reopen\",
' VisualFilter:\" New Or Open Or Reopen \",
' NO_CASE:
' }
' {
' TableName:BUG,
' ColumnName:BG_USER_29,
' LogicalFilter:\"not \\\"PDF\\\"\",
' VisualFilter:\"not \\\"PDF\\\"\",
' NO_CASE:
' }
' "
' }
'
End Sub


%%ItemTitle%%

OTA COM Type Library

Get licence status

Source code

Private Sub ShowLicenseStatus()
    Dim numUsed&, maxLicAllowed As Long
    Dim Licenses As String
    Dim idx As Integer
    Dim tagTDAPI_LICENSE_Vals, tagTDAPI_LICENSE_Str
'Set up arrays of constant values and descriptors.
tagTDAPI_LICENSE_Vals = Array(LIC_DEFECT, _
                LIC_TEST_LAB, _
                LIC_REQUIREMENT, _
                LIC_OTA_CLIENT, _
                LIC_COLLABORATION, _
                LIC_DASHBOARD, _
                LIC_COMPONENTS)
tagTDAPI_LICENSE_Str = Array("LIC_DEFECT", _
                "LIC_TEST_LAB", _
                "LIC_REQUIREMENT", _
                "LIC_OTA_CLIENT", _
                "LIC_COLLABORATION ", _
                "LIC_DASHBOARD", _
                "LIC_COMPONENTS")
    For idx = LBound(tagTDAPI_LICENSE_Vals) To _
        UBound(tagTDAPI_LICENSE_Vals)
        On Error GoTo InvalidLicenseType
        Debug.Print tagTDAPI_LICENSE_Str(idx); _
            tagTDAPI_LICENSE_Vals(idx); _
            "(" & toBin(tagTDAPI_LICENSE_Vals(idx)) & ")"
'------------------------------------
'Get license status.
        'tdc is the global TDConnection object.
        tdc.GetLicenseStatus tagTDAPI_LICENSE_Vals(idx), numUsed, maxLicAllowed
        Debug.Print "The number used is " & CStr(numUsed)
        Debug.Print "The number licenced is " & CStr(numUsed)
ContinueLoop:
        Debug.Print
    Next idx
Exit Sub
InvalidLicenseType:
        Debug.Print "Show LicenseStatus Error" & vbCrLf & vbTab & err.Description
        Debug.Print CStr(tagTDAPI_LICENSE_Vals(idx)) & " is invalid for GetLicenseStatus"
        GoTo ContinueLoop
'The output from this procedure on a sample site is:
'LIC_DEFECT 1 (1)
'The number used is 1
'The number licenced is 1
'
'LIC_TEST_LAB 2 (10)
'The number used is 1
'The number licenced is 1
'
'LIC_REQUIREMENT 3 (11)
'The number used is 1
'The number licenced is 1
'
'LIC_OTA_CLIENT 4 (100)
'The number used is 0
'The number licenced is 0
'
'LIC_COLLABORATION 6 (110)
'The number used is 0
'The number licenced is 0
'
'LIC_DASHBOARD 12 (1100)
'The number used is 0
'The number licenced is 0
'
'LIC_COMPONENTS 13 (1101)
'The number used is 1
'The number licenced is 1
End Sub


%%ItemTitle%%

OTA COM Type Library

Get licence descriptions

Source code

Private Sub ShowLicenses()
    Dim Licenses As String
    Dim idx As Integer
    Dim tagTDLICENSE_CLIENT_Vals, tagTDLICENSE_CLIENT_Str
'Set up arrays of constant values and descriptors.
tagTDLICENSE_CLIENT_Vals = Array( _
                TDLICENSE_BUG, _
                TDLICENSE_LAB, _
                TDLICENSE_REQ, _
                TDLICENSE_COLLAB, _
                TDLICENSE_DASHBOARD, _
                TDLICENSE_COMPONENTS)
tagTDLICENSE_CLIENT_Str = Array( _
                "TDLICENSE_BUG", _
                "TDLICENSE_LAB", _
                "TDLICENSE_REQ", _
                "TDLICENSE_COLLAB", _
                "TDLICENSE_DASHBOARD", _
                "TDLICENSE_COMPONENTS")
    For idx = LBound(tagTDLICENSE_CLIENT_Vals) To UBound(tagTDLICENSE_CLIENT_Vals)
        Debug.Print tagTDLICENSE_CLIENT_Str(idx); _
            tagTDLICENSE_CLIENT_Vals(idx); _
            "(" & toBin(tagTDLICENSE_CLIENT_Vals(idx)) & ")"
'-----------------------------------------------
' Get licenses
        'tdc is the global TDConnection object.
        tdc.GetLicenses tagTDLICENSE_CLIENT_Vals(idx), Licenses
        Debug.Print Licenses
        Debug.Print
    Next idx
'*******************************************************
'The structure of the output is:
'Debug information:
' <The license type> <license code> <license code in hexidecimal>
'The output of the GetLicenses call:
' { MUID: "{The machine ID}",
' <Licence Code>:"<error code>,<error string>:
' MUID [{<The machine ID>}] Client Type[<License Code>]",....}
'
'*******************************************************
'The output from this procedure on a sample site is:
' TDLICENSE_BUG 1 (1)
' {
' MUID:"{1BCEF8E4-FD5E-4577-9D3E-A5F43C397FB9}",
' 1:"0,License Approved: MUID [{1BCEF8E4-FD5E-4577-9D3E-A5F43C397FB9}] Client Type [1]"
' }
'
' TDLICENSE_LAB 2 (10)
' {
' MUID:"{1BCEF8E4-FD5E-4577-9D3E-A5F43C397FB9}",
' 2:"0,License Approved: MUID [{1BCEF8E4-FD5E-4577-9D3E-A5F43C397FB9}] Client Type [2]"
' }
'
' TDLICENSE_REQ 4 (100)
' {
' MUID:"{1BCEF8E4-FD5E-4577-9D3E-A5F43C397FB9}",
' 3:"0,License Approved: MUID [{1BCEF8E4-FD5E-4577-9D3E-A5F43C397FB9}] Client Type [3]"
' }
'
' TDLICENSE_COLLAB 32 (100000)
' {
' MUID:"{1BCEF8E4-FD5E-4577-9D3E-A5F43C397FB9}",
' 6:"1056,License Denied: MUID [{1BCEF8E4-FD5E-4577-9D3E-A5F43C397FB9}] Client Type [6]"
' }
'
' TDLICENSE_DASHBOARD 2048 (100000000000)
' {
' MUID:"{1BCEF8E4-FD5E-4577-9D3E-A5F43C397FB9}",
' 12:"0,License Approved: MUID [{1BCEF8E4-FD5E-4577-9D3E-A5F43C397FB9}] Client Type [12]"
' }
'
' TDLICENSE_COMPONENTS 4096 (1000000000000)
' {
' MUID:"{1BCEF8E4-FD5E-4577-9D3E-A5F43C397FB9}",
' 13:"0,License Approved: MUID [{1BCEF8E4-FD5E-4577-9D3E-A5F43C397FB9}] Client Type [13]"
' }End Sub
End Sub


%%ItemTitle%%

OTA COM Type Library

Get API Version

Source code

Public Sub GetAPIVersion()
'
Dim majorVersion As String, minorVersion$
Dim msg$
    '
'Get the major and minor version of the OTA add-on
    'tdc is the global TDConnection object.
    tdc.GetTDVersion majorVersion, minorVersion
    '
    msg = "You are working with API version " & majorVersion & "." _
         & minorVersion
    MsgBox msg
End Sub


%%PageItemTitle%%

TDConnection Object

DomainName
The name of a domain of projects defined in the Quality Center site.
See Also OTA COM Type Library

ProjectsListEx Property

Description

The projects available within the specified domain.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ProjectsListEx( _
   ByVal DomainName As String _
) As List

Parameters

DomainName
The name of a domain of projects defined in the Quality Center site.

Remarks

This property is obsolete.

To continue to use this property, you must set the BACKWARD_SUPPORT_ALL_DOMAINS_PROJECTS flag in the site configuration. For details, see the Mercury Quality Center Administrator's Guide.

See Also

TDConnection Object

Example

Output the names of the projects in a domain


%%ItemTitle%%

OTA COM Type Library

Output the names of the projects in a domain

Source code

Sub ProjectList()
Dim pName
'tdc is the global TDConnection object.
For Each pName In tdc.ProjectsListEx("Default")
    Debug.Print pName
Next
End Sub


%%ItemTitle%%

OTA COM Type Library

List the projects for a connection

Source code

Public Sub ListProjects()
    Dim Project As Variant
    Dim msg As String
    On Error GoTo ListProjectsErrorHandler
    msg = "Projects for this connection:"
    'tdc is the global TDConnection object.
    For Each Project In tdc.ProjectsList
        msg = msg & vbCrLf & Project
    Next
    MsgBox msg
Exit Sub
ListProjectsErrorHandler:
    ErrHandler err
End Sub


%%ItemTitle%%

OTA COM Type Library

Purge runs from a single test set

Source code

Sub PurgeRuns()
'This procedure purges all tests more than
' two days old from test set f1_ts1, but keeps
' the last two runs of every test, even if they
' are older than two days.
    Dim TSetFact As TestSetFactory
    Dim tsFilter As TDFilter
    Dim KeepLastCount As Long
    Dim DateUnit As Variant
    Dim NumOfDateUnits As Long
    Dim PurgeStepsOnly As Boolean
' Get a test set factory filter
    'tdc is the global TDConnection object.
    Set TSetFact = tdc.TestSetFactory
    Set tsFilter = TSetFact.Filter
' Act only on test set "f1_ts1"
    tsFilter.Filter("CY_CYCLE") = """f1_ts1"""
    Debug.Print tsFilter.Text
' [Filter]{
' TableName:CYCLE,
' ColumnName:CY_CYCLE,
' LogicalFilter:"\"f1_ts1\"",
' VisualFilter:"\"f1_ts1\"",
' NO_CASE:
' }
    KeepLastCount = 2 'Keep at least 2 of each test's runs
    DateUnit = 1 'Days
    NumOfDateUnits = 2 'Purge starting 2 days ago
    PurgeStepsOnly = False ' Purge both the runs and steps.
'------------------------------------------------------
' Purge the runs
    tdc.PurgeRuns tsFilter.Text, _
        KeepLastCount, _
        DateUnit, _
        NumOfDateUnits, _
        PurgeStepsOnly
End Sub


%%ItemTitle%%

OTA COM Type Library

Sending a simple email between users

Source code

Private Sub TDSendMail()
'This example shows how to send a simple message
' to a user and a specified email address
' with subject "OTA API Documentation Feedback"
' and body "Call me about the new documentation.
' I have some suggestions."
'tdc is the global TDConnection object.
tdc.SendMail "QC_documentation_UserName", _
    "yourQC_UserName;FDarcy@Pemberley.co.uk", _
    "OTA API Documentation Feedback", _
    "Call me about the new documentation. I have some suggestions."
End Sub


%%ItemTitle%%

OTA COM Type Library

Get User Settings

Source code

Public Sub GetSettings()
    Dim aSet As Settings
    Dim setItems As list
    Dim aSetItem
    Dim ItemName As String
    Dim aField As TDField
    Dim fieldList As list
'------------------------------------------------
' Get the Settings object for the logged-on user
' with TDConnection.UserSettings
    'tdc is the global TDConnection object.
    Set aSet = tdc.UserSettings
' Get the list of all the setting items
    Set setItems = aSet.EnumItems
' Print them out
    For Each aSetItem In setItems
        ItemName = aSetItem
        Debug.Print aSetItem
        Debug.Print "-----------------------"
        Debug.Print aSet.Value(ItemName)
        Debug.Print "======================="
    Next aSetItem
'------------------------------------------------
' Use TDConnection.Fields to get the user fields.
' Knowing from the output of the above that there is a "not PDF"
' condition for field "BG_USER_29" in the private favorite view,
' we look to see how the user field is used.
' The result is "BG_USER_29 To_Meeting"
'
    Set fieldList = tdc.Fields("BUG")
    For Each aField In fieldList
        If aField.Name = "BG_USER_29" Then
            Debug.Print aField.Name, aField.Property
            Exit For
        End If
    Next aField
'------------------------------------------------
'OUTPUT:
'* The first setting item output is the grid setup for the user.
'* The user views open defects assigned to user "steves"
'* Note that this setting has no name.
' -----------------------
' {
' grid: "1,0;64,BG_BUG_ID;64,BG_STATUS;64,BG_PRIORITY;64,BG_RESPONSIBLE;460,BG_SUMMARY;",
' filter: "[Filter]{
' TableName:BUG,
' ColumnName:BG_PRIORITY,
' SortOrder:1,
' SortDirection:0,
' NO_CASE:
' }
' {
' TableName:BUG,
' ColumnName:BG_RESPONSIBLE,
' LogicalFilter:steves,
' VisualFilter:\" steves \",
' NO_CASE:
' }
' {
' TableName:BUG,
' ColumnName:BG_STATUS,
' LogicalFilter:\"New Or Open Or Reopen\",
' VisualFilter:\" New Or Open Or Reopen \",
' NO_CASE:
' }
' ",
' show_rdcomment: "y",
' show_description: "y"
' }
'********************************************************************
'*** The second setting item output is a private Favorite view called
'*** "QC_Open_for_Steves"
'*** The Favorite is the same as the view above, but excludes items
'*** with a value of "PDF" in user field BG_USER_29
' =======================
' QC_Open_for_Steves
' -----------------------
' {
' grid: "1,0;64,BG_BUG_ID;64,BG_STATUS;64,BG_PRIORITY;64,BG_RESPONSIBLE;460,BG_SUMMARY;",
' filter: "[Filter]{
' TableName:BUG,
' ColumnName:BG_PRIORITY,
' SortOrder:1,
' SortDirection:0,
' NO_CASE:
' }
' {
' TableName:BUG,
' ColumnName:BG_RESPONSIBLE,
' LogicalFilter:steves,
' VisualFilter:\" steves \",
' NO_CASE:
' }
' {
' TableName:BUG,
' ColumnName:BG_STATUS,
' LogicalFilter:\"New Or Open Or Reopen\",
' VisualFilter:\" New Or Open Or Reopen \",
' NO_CASE:
' }
' {
' TableName:BUG,
' ColumnName:BG_USER_29,
' LogicalFilter:\"not \\\"PDF\\\"\",
' VisualFilter:\"not \\\"PDF\\\"\",
' NO_CASE:
' }
' "
' }
'
End Sub


%%ItemTitle%%

OTA COM Type Library

List the users for a connection

Source code

Sub ListUsers()
    Dim User As Variant
    Dim msg As String
    On Error GoTo ErrorHandler
    msg = "Users for this connection:"
    'tdc is the global TDConnection object.
    For Each User In tdc.UsersList
        msg = msg & vbCrLf & User
    Next
    MsgBox msg
Exit Sub
ErrorHandler:
    ErrHandler err
End Sub


%%PageItemTitle%% $$Members$$

TDField Overview

TDField Object Members

Public Methods

Public Method IsValidValue Checks if the input value is valid for the field.

Public Properties

Public Property Name | The database name of the current field.
Public Property Property | The FieldProperty object associated with the current field.
Public Property Type | The field database type.

See Also

TDField Overview


%%ItemTitle%%

OTA COM Type Library

Checking valid values for fields

Source code

Public Sub CheckValidValue(Optional TableName As String = "BUG")
    Dim BugFact As BugFactory
    Dim BugList As list
    Dim aField As TDField
    Dim fieldList As list
    Dim rc, ErrCode As Long
    Dim aBug As Bug
    Dim msg$
    Dim okCnt%, noNodeCnt%, errorCnt%, unknownCnt%
    Dim dataType As Long
'------------------------------------------------
' User BugFactory.Fields to get a list of TDField
' objects in the bug table.
' This example uses the BugFactory, but this can
' be done with any class that implements IBaseFactory
    'tdc is the global TDConnection object.
    Set BugFact = tdc.BugFactory
    Set fieldList = BugFact.Fields
'------------------------------------------
' Use List.Count to check how many items.
    Debug.Print: Debug.Print
    Debug.Print "There are " & fieldList.Count & _
        " fields in this table."
    Debug.Print "----------------------------------"
'Get any bug. To look at field attributes we
' need a valid object and since this example is
' not interested in the particular values of the object,
' it doesn't matter which bug.
    Set BugList = BugFact.NewList("")
    Set aBug = BugList(0)
'Walk through the list
    For Each aField In fieldList
        With aField
        'Quit when we have enough for this example
        If InStr(aField.Name, "BG_USER_10") > 0 Then Exit For
        ' For the DataTypeString() code,
        ' see example "Convert data types to string"
        Debug.Print .Name & ", " & .Property & ", Data type is " _
            & DataTypeString(.Type)
        On Error Resume Next
'----------------------------------------------------
'Use TDField.IsValidValue to confirm that a value can
'be used for a field.
' Get the correct data type and check validity of an
' arbitrary value.
' Save the error code immediately after IsValidValue call
' before another call can change the err object.
        dataType = aField.Type
        Select Case dataType
            Case TDOLE_LONG, TDOLE_ULONG
                aField.IsValidValue 5, aBug
                ErrCode = err.Number
            Case TDOLE_FLOAT
                aField.IsValidValue 5.5, aBug
                ErrCode = err.Number
            Case TDOLE_STRING
                aField.IsValidValue "Joe", aBug
                ErrCode = err.Number
            Case Else
            'These will be errors:
                aField.IsValidValue _
                    "String to non-string value", aBug
                ErrCode = err.Number
        End Select
'Output an error code message
        If ErrCode = 0 Then 'S_OK
            msg = "Valid Value"
            okCnt = okCnt + 1
        Else
             rc = ErrCode - vbObjectError
             Select Case rc
                Case FIELD_E_VERIFIED
                    msg = "Error: Invalid value for field"
                    errorCnt = errorCnt + 1
                Case TDOLE_NONODE
                    msg = "Error: Field can not be set to this value"
                    noNodeCnt = noNodeCnt + 1
                Case Else
                    msg = "Unrecognized error: " & rc _
                        & " , HRESULT = " & ErrCode
                    unknownCnt = unknownCnt + 1
            End Select
        End If
        Debug.Print vbTab & msg
        '
        End With 'aField
    Next aField
    Debug.Print "----------------------------------"
    Debug.Print "Number of fields with valid value = " & okCnt
    Debug.Print "Number of fields with invalid type = " & errorCnt
    Debug.Print "Number of fields with invalid value= " & noNodeCnt
    Debug.Print "Number of fields with unknown error = " & unknownCnt
    Debug.Print "----------------------------------"
End Sub


%%PageItemTitle%% $$Members$$

TDFilter Overview

TDFilter Object Members

Public Methods

Public Method Clear | Clears the current filter.
Public Method GetXFilter | Gets the cross filter specified by CrossEntities.
Public Method IsClear | Checks whether the filter is clear, including cross-filter settings
Public Method NewList | Creates a new list from current filter.
Public Method Refresh | Reads saved data and refreshes the fetched list according to the current filter, overwriting values in memory.
Public Method SetXFilter | Sets the filter for second entity, called a cross filter.

Public Properties

Public Property CaseSensitive | Indicates if the filter for the specified field is case sensitive. The default is False.
Public Property DataType | The filtered entity type.
Public Property Fields | The list of fields for the TDFilter's parent object.
Public Property Filter | The filter condition for the field specified by the FieldName.
Public Property Order | The position of the specified field in the list of the sort fields. (zero-based)
Public Property OrderDirection | The sort order: TDOLE_ASCENDING or TDOLE_DESCENDING
Public Property Text | The full fields filter as text.
Public Property XFilter | The cross filter according to the entity type.

See Also

TDFilter Overview


%%ItemTitle%%

OTA COM Type Library

Setting filters on multiple fields

Source code

Sub SelectedDefects()
    Dim BugF As BugFactory
    Dim BgFilter As TDFilter
    Dim thisBug As Bug, bugL As list
    'tdc is the global TDConnection object.
    Set BugF = tdc.BugFactory
    Set BgFilter = BugF.Filter
    BgFilter.Filter("BG_RESPONSIBLE") = "alex_qc Or cecil_td"
    BgFilter.Filter("BG_DETECTION_DATE") = "[PreviousWeek]"
    BgFilter.Filter("BG_STATUS") = "New Or Open Or Rejected Or Reopen "
    Set bugL = BgFilter.NewList
    For Each thisBug In bugL
        Debug.Print thisBug.ID, thisBug.Summary
    Next thisBug
' BfFilter.Text:
' [Filter]{
' TableName:BUG,
' ColumnName:\00000011\BG_DETECTION_DATE,
' LogicalFilter:[PREVIOUSWEEK],
' VisualFilter:[PreviousWeek],
' NO_CASE:
' }
' {
' TableName:BUG,
' ColumnName:BG_RESPONSIBLE,
' LogicalFilter:\00000013\alex_qc Or cecil_td,
' VisualFilter:\00000015\alex_qc Or cecil_td,
' NO_CASE:
' }
' {
' TableName:BUG,
' ColumnName:BG_STATUS,
' LogicalFilter:\00000021\New Or Open Or Rejected Or Reopen,
' VisualFilter:\00000028\New Or Open Or Rejected Or Reopen ,
' NO_CASE:
' }
End Sub


%%ItemTitle%%

OTA COM Type Library

Find tests that are not in any test set

Source code

Public Sub ListUnusedTests()
'Get the list of tests that are not in any test set
    Dim testSetF As testsetFactory
    Dim testF As testFactory
    Dim testSetFilter As TDFilter
    Dim TestFilter As TDFilter
    Dim aTest As Test
    Dim testL As list
    Set testSetF = tdc.testsetFactory
    Set testSetFilter = testSetF.filter
    'Exclude the default test set
    testSetFilter.filter("CY_CYCLE") = ">= 0"
    Set testF = tdc.testFactory
    Set TestFilter = testF.filter
    TestFilter.SetXFilter "TEST-TESTSET", False, testSetFilter.Text
    Set testL = testF.NewList(TestFilter.Text)
    Dim Item
    For Each Item In testL
        Debug.Print Item.Name
    Next Item
End Sub


%%ItemTitle%%

OTA COM Type Library

Get filtered releases under a specified folder

Source code

Public Sub FindReleases()
'Get releases under a specified folder that match a filter
Dim FolderId As Long, RelName As String
Dim folderFactory As releaseFolderFactory
Dim relFactory As ReleaseFactory
Dim FolderFilter As TDFilter
Dim listOfReleases As list
Dim rel As TDAPIOLELib.Release
Dim folder As ReleaseFolder
    'Get ReleaseFolderFactory from TDConnection
    Set folderFactory = tdc.releaseFolderFactory
    'Get the folder in which to search
    FolderId = 102
    Set folder = folderFactory.Item(FolderId)
    'Since the release factory is from the folder,
    ' all objects created from it relate to the
    ' contents of that folder
    Set relFactory = folder.ReleaseFactory
    ' If the release factory were from the TDConnection,
    ' the objects would relate to all releases
    ''Set relFactory = tdc.ReleaseFactory
    Set FolderFilter = relFactory.filter
    RelName = "Release*" 'Release 1, Release to QA, Release1.1, etc
    'Get the list of the Releases in the folder that
    ' match "Release*"
    FolderFilter.filter("REL_NAME") = RelName
    Set listOfReleases = FolderFilter.NewList
    For Each rel In listOfReleases
        Debug.Print rel.Name
    Next
    Set folderFactory = Nothing
    Set relFactory = Nothing
    Set FolderFilter = Nothing
    Set listOfReleases = Nothing
    Set folder = Nothing
    Set rel = Nothing
End Sub


%%ItemTitle%%

OTA COM Type Library

Using GetXFilter

Source code

Sub Get_X_Filter(Req1 As Req, Test1 As test)
    On Error GoTo RQTest_Err
    Dim BugFilter As TDFilter, xFilter As TDFilter
    Dim aStr$, IsInclusive As Boolean
' Create the first clause of the filter
    Dim BugF As BugFactory
    'tdc is the global TDConnection object.
    Set BugF = tdc.BugFactory
    Set BugFilter = BugF.Filter
    Dim bList As list, aBug As Bug
    Debug.Print "--------------------------------------"
    Debug.Print "Before creation of XFilter"
    aStr = BugFilter.GetXFilter("BUG-REQ", IsInclusive)
    Debug.Print "Filter is inclusive = " & IsInclusive
    Debug.Print "Text of XFilter is " & Chr(34) & aStr & Chr(34)
' --------------------------------------
' Before creation of XFilter
' Filter is inclusive = True
' Text of XFilter is ""
' Create the second clause of the filter
    Dim reqF As reqFactory
    Set reqF = tdc.reqFactory ' tdc is the TDConnection object.
    Set xFilter = reqF.Filter
    xFilter.Filter("RQ_REQ_NAME") = Req1.Name
' Now combine the two
    BugFilter.SetXFilter "BUG-REQ", True, xFilter.Text
    Debug.Print "--------------------------------------"
    Debug.Print "After creation of Inclusive XFilter "
    aStr = BugFilter.GetXFilter("BUG-REQ", IsInclusive)
    Debug.Print "Text of XFilter is "
    Debug.Print aStr
    Debug.Print "Filter is inclusive = " & IsInclusive
    Debug.Print
' --------------------------------------
' After creation of Inclusive XFilter
' Text of XFilter is
' [Filter]{
' TableName:REQ,
' ColumnName:RQ_REQ_NAME,
' LogicalFilter:Req1,
' VisualFilter:Req1,
' NO_CASE:
' }
'
' Filter is inclusive = True
'
' Now use the same criteria, but set the "Inclusive" argument
' of SetXFilter to False.
    BugFilter.SetXFilter "BUG-REQ", False, xFilter.Text
    Debug.Print "--------------------------------------"
    Debug.Print "BugFilter.Text:"
    Debug.Print BugFilter.Text
    Debug.Print
    Debug.Print "--------------------------------------"
    Debug.Print "After setting XFilter not inclusive "
    aStr = BugFilter.GetXFilter("BUG-REQ", IsInclusive)
    Debug.Print "Text of XFilter is "
    Debug.Print aStr
    Debug.Print "Filter is inclusive = " & IsInclusive
' --------------------------------------
' BugFilter.Text:
' [Filter]{
' FLT:[X],
' TYPE:BUG-REQ,
' EXISTS_IN_IDS:N,
' IN_IDS:\0000006a\[Filter]{
' TableName:REQ,
' ColumnName:RQ_REQ_NAME,
' LogicalFilter:Req1,
' VisualFilter:Req1,
' NO_CASE:
' }
'
' }
'
'
' --------------------------------------
' After setting XFilter not inclusive
' Text of XFilter is
' [Filter]{
' TableName:REQ,
' ColumnName:RQ_REQ_NAME,
' LogicalFilter:Req1,
' VisualFilter:Req1,
' NO_CASE:
' }
'
' Filter is inclusive = False
Exit Sub
RQTest_Err:
    ErrHandler err, "Req_TestInstance_Coverage", err.Description
End Sub


%%PageItemTitle%% $$Members$$

TDFilter Object

ISupportEntityTypes Implemented Interface Members

See Also

TDFilter Object


%%ItemTitle%%

OTA COM Type Library

Retrieving sorted requirements

Source code

Private Function RetrieveOrderedRecords _
    (ByVal sinceDate As Date, _
     ByVal currentSyncDate As Date) _
        As TDAPIOLELib.list
On Error GoTo ErrorHandler:
    Dim m_filter As TDAPIOLELib.TDFilter
    Dim reqFactory As TDAPIOLELib.reqFactory
'tdc is a TDConnection object. The user is authenticated and
' connected to a project before this routine is run.
    Set reqFactory = tdc.reqFactory
    Debug.Assert Not reqFactory Is Nothing
    Set m_filter = reqFactory.Filter
    Debug.Assert Not m_filter Is Nothing
' Query criteria
    m_filter.Filter("RQ_VTS") = "> " & Chr(34) & Format(sinceDate, "yyyy-mm-dd hh:mm:ss") & Chr(34) & _
                    " AND <> " & Chr(34) & Format(currentSyncDate, "yyyy-mm-dd hh:mm:ss") & Chr(34)
' Sort by path to get parent requirements in list before children.
    m_filter.Order("RQ_REQ_PATH") = 1
    m_filter.OrderDirection("RQ_REQ_PATH") = TDAPIOLELib.TDOLE_ASCENDING
' Sort by version time stamp so earlier records output first
    m_filter.Order("RQ_VTS") = 2
    m_filter.OrderDirection("RQ_VTS") = TDAPIOLELib.TDOLE_ASCENDING
' Return the list
    Set RetrieveOrderedRecords = m_filter.NewList
    Exit Function
ErrorHandler:
    ErrHandler err, "RetrieveOrderedRecords"
End Function


%%ItemTitle%%

OTA COM Type Library

Listing defects associated with a requirement and requirements associated with a defect

Source code

Public Sub xFilter(reqID As Long)
'This sample demonstrates cross filters by "round-tripping".
' Get a list of defects associated with a requirement, then
' take one of those defects, find the list of associated requirements
' and find our original requirement.
    Dim ReqFilter As ITDFilter
    Dim BugFilter As ITDFilter
    Dim Bugs As iList, aBug As Bug
    Dim defectID As Long
    Dim Reqs As list, aReq As Req
' Get the filter objects
    'tdc is the global TDConnection object.
    Set ReqFilter = tdc.reqFactory.Filter
    Set BugFilter = tdc.BugFactory.Filter
'Set a simple requirement filter based on the ID.
    ReqFilter.Filter("RQ_REQ_ID") = reqID
    Debug.Print ReqFilter.Text
' [Filter]{
' TableName:REQ,
' ColumnName:RQ_REQ_ID,
' LogicalFilter:3,
' VisualFilter:3,
' NO_CASE:
' }
'
'Set the defect cross filter based on the requirement filter.
    BugFilter.xFilter("BUG-REQ") = ReqFilter.Text
    Debug.Print BugFilter.Text
' [Filter]{
' FLT:[X],
' FKEY:,
' TYPE:BUG-REQ,
' IN_IDS:"[Filter]{
' TableName:REQ,
' ColumnName:RQ_REQ_ID,
' LogicalFilter:3,
' VisualFilter:3,
' NO_CASE:
' }
' "
' }
'
' The Bugs list contains the defects associated with
' requirement ReqID.
    Set Bugs = tdc.BugFactory.NewList(BugFilter.Text)
    For Each aBug In Bugs
        Debug.Print aBug.ID, aBug.Summary
        'Save the defect ID of the last defect in the list
        ' for use in getting the xFilter in the other direction.
        defectID = aBug.ID
    Next aBug
' 20 Mercury Tours site crash during execution of load test for Welcome Page
' 21 Welcome page download time during the load exceeds 10 seconds
'
'Now do it the other way - requirements based on defects.
'Get clean filters without the settings from above.
    Set ReqFilter = Nothing
    Set BugFilter = Nothing
    Set ReqFilter = tdc.reqFactory.Filter
    Set BugFilter = tdc.BugFactory.Filter
'
'Set a simple defect filter based on the ID.
    BugFilter.Filter("BG_BUG_ID") = defectID
    Debug.Print BugFilter.Text
' [Filter]{
' TableName:BUG,
' ColumnName:BG_BUG_ID,
' LogicalFilter:21,
' VisualFilter:21,
' NO_CASE:
' }
'
'Set the requirement cross filter based on the defect filter.
    ReqFilter.xFilter("REQ-BUG") = BugFilter.Text
    Debug.Print ReqFilter.Text
' [Filter]{
' FLT:[X],
' FKEY:,
' TYPE:REQ-BUG,
' IN_IDS:"[Filter]{
' TableName:BUG,
' ColumnName:BG_BUG_ID,
' LogicalFilter:21,
' VisualFilter:21,
' NO_CASE:
' }
' "
' }
'
' The Reqs list contains the defects associated with defect.
    Set Reqs = tdc.reqFactory.NewList(ReqFilter.Text)
    For Each aReq In Reqs
        Debug.Print aReq.ID, aReq.Name
    Next aReq
'
' Note that the Reqs list included defect 3, which was used
' to create the simple requirement filter at the beginning.
'
' 3 Mercury Tours Application
' 96 Page Download Time
' 126 Connect To Site Transaction
End Sub


%%PageItemTitle%% $$Members$$

TDMailConditions Overview

TDMailConditions Object Members

Public Methods

Public Method Close | Closes and updates Mail Condition.
Public Method DeleteCondition | Deletes the Mail Condition.
Public Method Load | Loads Mail Conditions.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Condition | The defect-matching rule.
Public Property IsLocked | Checks if object is locked.
Public Property ItemList | Gets the list of Mail Condition Users.

See Also

TDMailConditions Overview


%%PageItemTitle%% $$Members$$

Test Overview

Test Object Members

Public Methods

Public Method CoverRequirement | Adds the specified requirement to the list of requirements covered by this test.
Public Method GetCoverList | Gets the list of all requirements covered by this test.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Mail | Mails the IBaseFieldExMail field item.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method RemoveCoverage | Removes a requirement from the list of requirements this test covers.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property CheckoutPathIfExist | The checkout path for the test.
Public Property DesignStepFactory | The design steps factory for the current test.
Public Property DesStepsNum | The number of design steps in the test.
Public Property ExecDate | The test execution date and time.
Public Property ExecStatus | The test execution status.
Public Property ExtendedStorage | The Extended Storage object for the current test.
Public Property Field | The value of the specified field.
Public Property FullPath | The full file system path for the test.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property HasCoverage | Checks if the test covers at least one requirement.
Public Property HasParam | Checks if the test has at least one parameter.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property LastRun | The last Run object for this test.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The test name.
Public Property Params | The current test parameters.
Public Property TemplateTest | Indicates if this test is a template test.
Public Property Type | The test type.
Public Property VCS | The VCS version control object for this test.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

Test Overview


%%PageItemTitle%% $$Members$$

TestExecStatus Overview

TestExecStatus Object Members

Public Properties

Public Property Message | The test execution message displayed in the Execution Controller grid.
Public Property Status | The test execution status.
Public Property TestId | The test Id.
Public Property TestInstance | The number of this instance of the design test in the test set.
Public Property TSTestId | The ID of the test instance for the current run.

See Also

TestExecStatus Overview


%%PageItemTitle%% $$Members$$

TestFactory Overview

TestFactory Object Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method BuildPerfGraph | Creates Performance Graph.
Public Method BuildProgressGraph | Creates graph showing number of tests in a test set executed over a period of time.
Public Method BuildProgressGraphEx | Creates graph showing number of tests in a test set executed over a period of time.
Public Method BuildSummaryGraph | Creates summary graph showing number of tests executed in a test set according to test and test run.
Public Method BuildTrendGraph | Creates graph that shows the number of defect status changes over time.
Public Method Mail | Mails the list of IBase Factory Items. 'Items' is a list of ID numbers.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.
Public Property RepositoryStorage | An ExtendedStorage object connected by default to the test repository folder on the server side. Enables file system operations with a test repository.

See Also

TestFactory Overview


%%ItemTitle%%

OTA COM Type Library

Delete test

Source code

Public Sub DeleteTest()
'Delete test
    Dim testF As testFactory
    Set testF = tdc.testFactory
    testF.RemoveItem (8)
End Sub


%%ItemTitle%%

OTA COM Type Library

Get a test object with name and path

Source code

Public Function GetTest(ByVal TestName As String, _
    ByVal SubjectPath As String, _
    Optional delimChar As String = "\") _
            As TDAPIOLELib.test
'This function gets a test name and path and
'returns a test object.
    Dim TestFact As TestFactory, TestList As list
    Dim TestFilter As TDFilter
    On Error GoTo GetTestErr
'--------------------------------------
' Check arguments
    If (Len(SubjectPath) = 0) _
        Or (Len(TestName) = 0) Then
        Set GetTest = Nothing
        Exit Function
    End If
'--------------------------------------
'Trim the SubjectPath and strip leading and trailing delimiters
    SubjectPath = Trim(SubjectPath)
    Dim pos%, ln%
    pos = InStr(1, SubjectPath, delimChar)
    If pos = 1 Then
        SubjectPath = Mid(SubjectPath, 2)
    End If
    ln = Len(SubjectPath)
    pos = InStr(ln - 1, SubjectPath, delimChar)
    If pos > 0 Then
        SubjectPath = Mid(SubjectPath, 1, ln - 1)
    End If
'--------------------------------------
' Path must start with "Subject"
    pos = InStr(SubjectPath, "Subject")
    If pos <> 1 Then
        SubjectPath = "Subject\" & SubjectPath
    End If
'--------------------------------------
' Get a TestFactory.Filter and define it
    'tdc is the global TDConnection object.
    Set TestFact = tdc.TestFactory
    Set TestFilter = TestFact.Filter
' The test name
    TestFilter.Filter("TS_NAME") = Trim(TestName)
' The test subject node
    TestFilter.Filter("TS_SUBJECT") = SubjectPath
' Debug.Print TestFilter.Text
'--------------------------------------
' Get the test object
' The filter defines a unique test, so we
' so we expect only one test in the list
    Set TestFact = tdc.TestFactory
    Set TestList = TestFact.NewList(TestFilter.Text)
    If TestList.Count = 0 Then
        Set GetTest = Nothing
    Else
        Set GetTest = TestList.Item(1)
    End If
Exit Function
GetTestErr:
    On Error Resume Next
    Set GetTest = Nothing
    ErrHandler err, "GetTest", "Failed to get " & TestName
End Function


%%PageItemTitle%% $$Members$$

TestFactory Object

IAlertableEntityFactory Implemented Interface Members

See Also

TestFactory Object


%%PageItemTitle%% $$Members$$

TestFactory Object

IBaseFactory2 Implemented Interface Members

See Also

TestFactory Object


%%PageItemTitle%% $$Members$$

TestFactory Object

ISearchableFactory Implemented Interface Members

See Also

TestFactory Object


%%PageItemTitle%% $$Members$$

TestFactory Object

ISupportCopyPaste2 Implemented Interface Members

See Also

TestFactory Object


%%PageItemTitle%% $$Members$$

TestSet Overview

TestSet Object Members

Public Methods

Public Method BuildPerfGraph | Creates Performance Graph.
Public Method BuildProgressGraph | Builds test set progress graph.
Public Method BuildProgressGraphEx | Builds test set progress graph.
Public Method BuildSummaryGraph | Builds test set summary graph.
Public Method BuildTrendGraph | Creates graph that shows the test set changes over time.
Public Method CheckTestInstances | Gets information about the instances of the specified test in this test set.
Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method PurgeExecutions | Purges all the running executions within the test set.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method ResetTestSet | Sets the status of each test in the test set to 'No Run'.
Public Method StartExecution | Starts the execution controller.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property ConditionFactory | The condition factory object for the current test set.
Public Property ExecEventNotifyByMailSettings | Gets the execution mail notification settings for the current test set.
Public Property ExecutionSettings | Gets the execution settings for the test set.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property History | The History object for the object.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The test set name.
Public Property Status | The test set status.
Public Property TestDefaultExecutionSettings | Gets default execution settings for tests.
Public Property TestSetFolder | The test set's parent node.
Public Property TSTestFactory | The factory object for the current test set.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

TestSet Overview


%%PageItemTitle%% $$Members$$

TestSetFactory Overview

TestSetFactory Object Members

Public Methods

Public Method AddItem | Creates a new item object.
Public Method BuildPerfGraph | Creates Performance Graph.
Public Method BuildProgressGraph | Creates graph showing number of tests in all test sets executed over a period of time.
Public Method BuildProgressGraphEx | Creates progress graph for specified test set.
Public Method BuildSummaryGraph | Creates a summary graph of test instances in a test set.
Public Method BuildTrendGraph | Creates graph showing the number of status changes over a time period.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

TestSetFactory Overview


%%ItemTitle%%

OTA COM Type Library

Add test set

Source code

Public Sub AddTestSet()
'Add a test set
    Dim testSetFolder As testSetFolder
    Dim testSetFolderF As TestSetTreeManager
    Dim testSetF As testsetFactory
    Dim testSet1 As TestSet
    Set testSetFolderF = tdc.TestSetTreeManager
    Set testSetFolder = testSetFolderF.NodeByPath("Root\TestSetFolder3")
    Set testSetF = testSetFolder.testsetFactory
    Set testSet1 = testSetF.AddItem(Null)
    testSet1.Name = "testSet_002"
    testSet1.Status = "Open"
    testSet1.Post
End Sub


%%PageItemTitle%% $$Members$$

TestSetFactory Object

IBaseFactory2 Implemented Interface Members

See Also

TestSetFactory Object


%%PageItemTitle%% $$Members$$

TestSetFactory Object

ISupportCopyPaste2 Implemented Interface Members

See Also

TestSetFactory Object


%%ItemTitle%%

OTA COM Type Library

Move test set

Source code

Private Sub CutPasteTestSet()
'Move test set
    Dim testSetF As testsetFactory
    Dim testSet1 As TestSet
    Dim testsetid%
    testsetid = 64
    Set testSetF = tdc.testsetFactory
    Set testSet1 = testSetF.Item(testsetid)
    testSet1.testSetFolder = 5
    testSet1.Post
End Sub


%%PageItemTitle%% $$Members$$

TestSetFolder Overview

TestSetFolder Object Members

Public Methods

Public Method AddNode | Adds a new child node.
Public Method AddNodeDisp | Adds a new child node.
Public Method FindChildNode | Finds a child node by node name.
Public Method FindChildren | Finds node children according to specified search pattern.
Public Method FindTestInstances | Gets the list of test instances in all test sets in given folder and its subfolders that match the specified pattern.
Public Method FindTestSets | Gets the list of test sets contained in the folder that match the specified pattern.
Public Method Move | Moves folder node under new father.
Public Method NewList | Gets a list of the node's immediate children.
Public Method Post | Posts all changed values to the database.
Public Method Refresh | Reads the saved node data, overwriting values in memory.
Public Method RemoveNode | Deletes the specified node.
Public Method RemoveNodeEx | Deletes a test set folder node.

Public Properties

Public Property Attachments | The folder's AttachmentFactory object.
Public Property Attribute | Gets the node attribute.
Public Property Child | Gets a sub-folder of the current folder.
Public Property Count | The number of child nodes.
Public Property DepthType | The sub-tree depth type.
Public Property Description | The test set folder description.
Public Property Father | The current folder's parent folder.
Public Property FatherDisp | The parent node.
Public Property FatherID | The unique parent ID.
Public Property FolderFields | Returns the list of fields of the test set folder.
Public Property HasAttachment | Checks if this folder has at least one attachment.
Public Property Name | The node name.
Public Property NodeID | The node ID number.
Public Property Path | The folder tree path starting from the tree root.
Public Property SubNodes | The list of child nodes.
Public Property TargetCycle | The cycle to which the folder is assigned.
Public Property TestSetFactory | Gets the TestSetFactory for the folder.
Public Property ViewOrder | The index of this folder in its parent's list of sub-nodes.

See Also

TestSetFolder Overview


%%ItemTitle%%

OTA COM Type Library

Add test set folder

Source code

Private Sub AddTestSetFolder()
 'Add test set folder
    Dim testSetF As TestSetTreeManager
    Set testSetF = tdc.TestSetTreeManager
    Dim root As testSetFolder
    Set root = testSetF.root
    Dim folder As testSetFolder
    Set folder = root.AddNode("test_vb")
    folder.Post
End Sub


%%ItemTitle%%

OTA COM Type Library

Find test instances

Source code

Public Sub TSSearch()
On Error GoTo TSSearchErr
'Find test instances
    Dim tsFolder As TestSetFolder
    Dim lst As TDAPIOLELib.list
    Dim TreeManager As TestSetTreeManager
    Set TreeManager = tdc.TestSetTreeManager
    Set tsFolder = TreeManager.root
    Set lst = tsFolder.FindTestInstances("No", False, "")
    Dim instance As TSTest
    Dim i%
    For i = 1 To lst.Count
        Set instance = lst.Item(i)
        Debug.Print "Instance name: " & instance.Name & " id: " & instance.ID
    Next i
Exit Sub
TSSearchErr:
    ErrHandler Err, "TSSearch", Err.Description, NON_FATAL_ERROR
End Sub


%%ItemTitle%%

OTA COM Type Library

Get a test set by name only

Source code

Public Sub GetTestInstanceCount()
    Dim tsFilter As TDFilter
    Dim TSetFact As TestSetFactory
    Dim theTestSet As TestSet
    Dim tsTreeMgr As TestSetTreeManager
    Dim tsFolder As TestSetFolder
    Dim tsList As iList
' Get the test set tree manager from the test set factory
    'tdc is the global TDConnection object.
    Set TSetFact = tdc.TestSetFactory
    Set tsTreeMgr = tdc.TestSetTreeManager
'---------------------------------------------------------------
' Use TestSetTreeManager.NodeByPath
' to get the test set folder
    Set tsFolder = tsTreeMgr.NodeByPath("Root\OTA_Demo_TestSets")
'---------------------------------------------------------------
' Use TestSetFolder.FindTestSets
' to search for a particular test set
    Set tsList = tsFolder.FindTestSets("OTA_TS_2")
    If tsList.Count > 1 Then
        MsgBox "FindTestSets found more than one test set: refine search"
    ElseIf tsList.Count < 1 Then
        MsgBox "FindTestSets: test set not found"
    End If
    Set theTestSet = tsList.Item(1)
'
'Get a particular test in the set
    Dim rstr$, theTest As test, tList As list
    Dim testSubjectFolder As SubjectNode
'Get the subject folder for the test
    ' For the code of GetSubjectNodeByPath
    ' see example 'Getting a test subject node by the node path'
    Set testSubjectFolder = _
     GetSubjectNodeByPath _
      ("OTA_DEMO_SUBJECT\OTA_SUBJECT_level1\OTA_SUB_1.1\OTA_SUB_1.1.1\OTA_SUB_1.1.1.1")
'--------------------------------------------------------------------
' Use SubjectNode.FindTests
' to get a list of tests with exactly that name.
    Set tList = testSubjectFolder.FindTests("TEST1.1.1.1_A")
' There should be only one item in the list.
    If tList.Count > 1 Then
        MsgBox "FindTests found more than one test: refine search"
    ElseIf tsList.Count < 1 Then
        MsgBox "FindTests: test not found"
    End If
    Set theTest = tList.Item(1)
'---------------------------------------------------
' Use TestSet.CheckTestInstances to get information
' about instances of this test in this test set.
    rstr = theTestSet.CheckTestInstances(theTest.ID)
    Debug.Print rstr
'Output:
' {
' NUM_OF_INSTANCES:3,
' TS_TEST_ID:95,
' TS_NAME:TEST1.1.1.1_A,
' TS_TYPE:MANUAL,
' TS_STEPS:0,
' TS_TEMPLATE:
' }
End Sub


%%ItemTitle%%

OTA COM Type Library

Get test sets with filter

Source code

Public Sub FindTestSets()
    Dim tsFilter As TDFilter
    Dim TSetFact As TestSetFactory
    Dim aTestSet As TestSet
    Dim tsTreeMgr As TestSetTreeManager
    Dim tsFolder As TestSetFolder
    Dim tsList As iList
'Get the test set tree manager from the test set factory
    'tdc is the global TDConnection object.
    Set TSetFact = tdc.TestSetFactory
    Set tsTreeMgr = tdc.TestSetTreeManager
'-------------------------------------------------------
' Use TestSetTreeManager.NodeByPath to
' get a test set folder with the path.
' The path can be copied from the UI.
' You can also get a particular folder by walking the tree
' starting from TestSetTreeManager.Root and using
' TestSetFolder.SubNodes
    Set tsFolder = tsTreeMgr.NodeByPath _
("Root\Mercury Tours (HTML Edition)\Version 1.0\Functionality And UI")
'
    Debug.Print "Test set Folder Name """ _
        & tsFolder.Name & """, Description """ _
        & tsFolder.Description & """"
'
' Set the conditions. CY_USER_01 is "Level" in the demo project.
    Set tsFilter = TSetFact.Filter
    tsFilter.Filter("CY_USER_01") = "Advanced"
    tsFilter.Filter("CY_STATUS") = "Open"
'-------------------------------------------------------------
' Use TestSetFolder.FindTestSets with the filter to
' get a list of Advanced, Open test sets in the folder.
    Set tsList = tsFolder.FindTestSets _
        ("Mercury", False, tsFilter.Text)
'Print them out.
    Debug.Print "Number of items in list = " & tsList.Count
    Debug.Print "The test sets that meet the criteria are: "
    For Each aTestSet In tsList
        With aTestSet
        Debug.Print .ID; .Name & ", Status = """ _
            & .Status & """, Level = """ _
            & .Field("CY_USER_01") & """"
        End With
    Next aTestSet
End Sub


%%PageItemTitle%% $$Members$$

TestSetFolder Object

IObjectLockingSupport Implemented Interface Members

See Also

TestSetFolder Object


%%PageItemTitle%% $$Members$$

TestSetFolder Object

ISupportCopyPaste2 Implemented Interface Members

See Also

TestSetFolder Object


%%PageItemTitle%% $$Members$$

TestSetTreeManager Overview

TestSetTreeManager Object Members

Public Properties

Public Property NodeById | Gets the test set tree node object corresponding to the specified node Id.
Public Property NodeByPath | Gets the test set tree node from the specified tree path.
Public Property Root | The test set tree root node.
Public Property Unattached | Gets an unattached folder.

See Also

TestSetTreeManager Overview


%%PageItemTitle%% $$Members$$

TestSetTreeManager Object

ISupportCopyPaste2 Implemented Interface Members

See Also

TestSetTreeManager Object


%%ItemTitle%%

OTA COM Type Library

Get a test set folder

Source code

Public Sub GetTestInstanceCount()
    Dim tsFilter As TDFilter
    Dim TSetFact As TestSetFactory
    Dim theTestSet As TestSet
    Dim tsTreeMgr As TestSetTreeManager
    Dim tsFolder As TestSetFolder
    Dim tsList As iList
' Get the test set tree manager from the test set factory
    'tdc is the global TDConnection object.
    Set TSetFact = tdc.TestSetFactory
    Set tsTreeMgr = tdc.TestSetTreeManager
'---------------------------------------------------------------
' Use TestSetTreeManager.NodeByPath
' to get the test set folder
    Set tsFolder = tsTreeMgr.NodeByPath("Root\OTA_Demo_TestSets")
'---------------------------------------------------------------
' Use TestSetFolder.FindTestSets
' to search for a particular test set
    Set tsList = tsFolder.FindTestSets("OTA_TS_2")
    If tsList.Count > 1 Then
        MsgBox "FindTestSets found more than one test set: refine search"
    ElseIf tsList.Count < 1 Then
        MsgBox "FindTestSets: test set not found"
    End If
    Set theTestSet = tsList.Item(1)
'
'Get a particular test in the set
    Dim rstr$, theTest As test, tList As list
    Dim testSubjectFolder As SubjectNode
'Get the subject folder for the test
    ' For the code of GetSubjectNodeByPath
    ' see example 'Getting a test subject node by the node path'
    Set testSubjectFolder = _
     GetSubjectNodeByPath _
      ("OTA_DEMO_SUBJECT\OTA_SUBJECT_level1\OTA_SUB_1.1\OTA_SUB_1.1.1\OTA_SUB_1.1.1.1")
'--------------------------------------------------------------------
' Use SubjectNode.FindTests
' to get a list of tests with exactly that name.
    Set tList = testSubjectFolder.FindTests("TEST1.1.1.1_A")
' There should be only one item in the list.
    If tList.Count > 1 Then
        MsgBox "FindTests found more than one test: refine search"
    ElseIf tsList.Count < 1 Then
        MsgBox "FindTests: test not found"
    End If
    Set theTest = tList.Item(1)
'---------------------------------------------------
' Use TestSet.CheckTestInstances to get information
' about instances of this test in this test set.
    rstr = theTestSet.CheckTestInstances(theTest.ID)
    Debug.Print rstr
'Output:
' {
' NUM_OF_INSTANCES:3,
' TS_TEST_ID:95,
' TS_NAME:TEST1.1.1.1_A,
' TS_TYPE:MANUAL,
' TS_STEPS:0,
' TS_TEMPLATE:
' }
End Sub


%%ItemTitle%%

OTA COM Type Library

Get test sets folder with the path

Source code

Public Sub FindTestSets()
    Dim tsFilter As TDFilter
    Dim TSetFact As TestSetFactory
    Dim aTestSet As TestSet
    Dim tsTreeMgr As TestSetTreeManager
    Dim tsFolder As TestSetFolder
    Dim tsList As iList
'Get the test set tree manager from the test set factory
    'tdc is the global TDConnection object.
    Set TSetFact = tdc.TestSetFactory
    Set tsTreeMgr = tdc.TestSetTreeManager
'-------------------------------------------------------
' Use TestSetTreeManager.NodeByPath to
' get a test set folder with the path.
' The path can be copied from the UI.
' You can also get a particular folder by walking the tree
' starting from TestSetTreeManager.Root and using
' TestSetFolder.SubNodes
    Set tsFolder = tsTreeMgr.NodeByPath _
("Root\Mercury Tours (HTML Edition)\Version 1.0\Functionality And UI")
'
    Debug.Print "Test set Folder Name """ _
        & tsFolder.Name & """, Description """ _
        & tsFolder.Description & """"
'
' Set the conditions. CY_USER_01 is "Level" in the demo project.
    Set tsFilter = TSetFact.Filter
    tsFilter.Filter("CY_USER_01") = "Advanced"
    tsFilter.Filter("CY_STATUS") = "Open"
'-------------------------------------------------------------
' Use TestSetFolder.FindTestSets with the filter to
' get a list of Advanced, Open test sets in the folder.
    Set tsList = tsFolder.FindTestSets _
        ("Mercury", False, tsFilter.Text)
'Print them out.
    Debug.Print "Number of items in list = " & tsList.Count
    Debug.Print "The test sets that meet the criteria are: "
    For Each aTestSet In tsList
        With aTestSet
        Debug.Print .ID; .Name & ", Status = """ _
            & .Status & """, Level = """ _
            & .Field("CY_USER_01") & """"
        End With
    Next aTestSet
End Sub


%%ItemTitle%%

OTA COM Type Library

Getting the list of design tests used in a test set

Source code

Public Sub TestsInTestSet(tsName As String, _
        tsFolderPath As String)
    Dim TestSetF As TestSetFactory, tsFilter As TDFilter
' This example shows how to get a list of all the tests in
' a test set. The input is a test set name and the full
' path of the test set, for example, "Root\MyXFilter\MyTestSets"
' Get the filter for the TestSet to be used in the XFilter
    Dim labTreeMgr As TestSetTreeManager
    Dim labFolder As SysTreeNode
' Get the node containing the test set
    'tdc is the global TDConnection object.
    Set labTreeMgr = tdc.TestSetTreeManager
    Set labFolder = labTreeMgr.NodeByPath(tsFolderPath)
' Get the factory object for the node
    Set TestSetF = labFolder.TestSetFactory
' Filter for the desired test set
    Set tsFilter = TestSetF.Filter
    tsFilter.Filter("CY_CYCLE") = tsName
' Debug.Print tsFilter.Text
' [Filter]{
' TableName:CYCLE,
' ColumnName:CY_CYCLE,
' LogicalFilter:TS1,
' VisualFilter:TS1,
' NO_CASE:
' }
'
' Get the Test filter object. This filter is unconditional,
' we want all the tests from the test set
    Dim TestF As TestFactory, TestFilter As TDFilter
    Set TestF = tdc.TestFactory
    Set TestFilter = TestF.Filter
' Set the cross filter: All tests associated with the
' test sets that meet the criteria - in this case, the
' one named test set
    TestFilter.SetXFilter "TEST-TESTSET", True, tsFilter.Text
' Debug.Print TestFilter.Text
' [Filter]{
' FLT:[X],
' TYPE:TEST-TESTSET,
' EXISTS_IN_IDS:Y,
' IN_IDS:\00000067\[Filter]{
' TableName:CYCLE,
' ColumnName:CY_CYCLE,
' LogicalFilter:TS1,
' VisualFilter:TS1,
' NO_CASE:
' }
'
'Get the list and output it.
    Dim TestList As list, tst As test
    Set TestList = TestFilter.NewList()
    For Each tst In TestList
        With tst
            Debug.Print .Name
        End With
    Next tst
End Sub


%%ItemTitle%%

OTA COM Type Library

Get details of a particular test in a test set

Source code

Public Sub GetTestInstanceCount()
    Dim tsFilter As TDFilter
    Dim TSetFact As TestSetFactory
    Dim theTestSet As TestSet
    Dim tsTreeMgr As TestSetTreeManager
    Dim tsFolder As TestSetFolder
    Dim tsList As iList
' Get the test set tree manager from the test set factory
    'tdc is the global TDConnection object.
    Set TSetFact = tdc.TestSetFactory
    Set tsTreeMgr = tdc.TestSetTreeManager
'---------------------------------------------------------------
' Use TestSetTreeManager.NodeByPath
' to get the test set folder
    Set tsFolder = tsTreeMgr.NodeByPath("Root\OTA_Demo_TestSets")
'---------------------------------------------------------------
' Use TestSetFolder.FindTestSets
' to search for a particular test set
    Set tsList = tsFolder.FindTestSets("OTA_TS_2")
    If tsList.Count > 1 Then
        MsgBox "FindTestSets found more than one test set: refine search"
    ElseIf tsList.Count < 1 Then
        MsgBox "FindTestSets: test set not found"
    End If
    Set theTestSet = tsList.Item(1)
'
'Get a particular test in the set
    Dim rstr$, theTest As test, tList As list
    Dim testSubjectFolder As SubjectNode
'Get the subject folder for the test
    ' For the code of GetSubjectNodeByPath
    ' see example 'Getting a test subject node by the node path'
    Set testSubjectFolder = _
     GetSubjectNodeByPath _
      ("OTA_DEMO_SUBJECT\OTA_SUBJECT_level1\OTA_SUB_1.1\OTA_SUB_1.1.1\OTA_SUB_1.1.1.1")
'--------------------------------------------------------------------
' Use SubjectNode.FindTests
' to get a list of tests with exactly that name.
    Set tList = testSubjectFolder.FindTests("TEST1.1.1.1_A")
' There should be only one item in the list.
    If tList.Count > 1 Then
        MsgBox "FindTests found more than one test: refine search"
    ElseIf tsList.Count < 1 Then
        MsgBox "FindTests: test not found"
    End If
    Set theTest = tList.Item(1)
'---------------------------------------------------
' Use TestSet.CheckTestInstances to get information
' about instances of this test in this test set.
    rstr = theTestSet.CheckTestInstances(theTest.ID)
    Debug.Print rstr
'Output:
' {
' NUM_OF_INSTANCES:3,
' TS_TEST_ID:95,
' TS_NAME:TEST1.1.1.1_A,
' TS_TYPE:MANUAL,
' TS_STEPS:0,
' TS_TEMPLATE:
' }
End Sub


%%ItemTitle%%

OTA COM Type Library

Get attributes of TestSets and TSTests

Source code

Public Sub TSTestProperties()
    Dim TestSetFact As TestSetFactory
    Dim TSTestFact As TSTestFactory
    Dim theTestSet As TestSet
    Dim theTSTest As TSTest
    Dim TestSetTestsList As list, TestSetsList As list
    Dim tsTreeMgr As TestSetTreeManager
    Dim tSetFolder As TestSetFolder
    Dim i%
On Error GoTo TSTestPropertiesErr
' Get the TDConnection.TestSetFactory
    Set TestSetFact = tdc.TestSetFactory
 ' Get the test set tree manager from the test set factory
    Set tsTreeMgr = tdc.TestSetTreeManager
' Get the test set folder
    Set tSetFolder = tsTreeMgr.NodeByPath("Root\OTA_Demo_TestSets")
' Because we are searching for the full name,
' the list will have only one entry
    Set TestSetsList = tSetFolder.FindTestSets("OTA_TS_2")
    Set theTestSet = TestSetsList.Item(1)
' Get the test set attributes
    With theTestSet
        Debug.Print "Test Set ID = " & .ID & ", Name = " _
            & .Name & ", TestSetFolder = " & .TestSetFolder
'Output:
'Test Set ID = 14, Name = OTA_TS_2, TestSetFolder = OTA_Demo_TestSets
    End With ' theTestSet
' Get the TSTest factory and list of TSTests
    Set TSTestFact = theTestSet.TSTestFactory
    Set TestSetTestsList = TSTestFact.NewList("")
    Dim sID$
    For Each theTSTest In TestSetTestsList
        i = i + 1: If i > 10 Then Exit For
        With theTSTest
            Debug.Print "TSTest Name: " & .Name, "ID: " & .ID, _
                "TestID: " & .TestId, "Instance: " & .Instance
            sID = theTSTest.ID 'Save the last ID
        End With
    Next theTSTest
'Output:
'TSTest Name: [1]TEST1.1.1.1_A ID: 95~1 TestID: 95 Instance: 1
'TSTest Name: [1]TEST1.1.1.1_B ID: 96~1 TestID: 96 Instance: 1
'TSTest Name: [2]TEST1.1.1.1_A ID: 95~2 TestID: 95 Instance: 2
'TSTest Name: [2]TEST1.1.1.1_B ID: 96~2 TestID: 96 Instance: 2
'TSTest Name: [3]TEST1.1.1.1_A ID: 95~3 TestID: 95 Instance: 3
    Debug.Print "Last TSTestID = " & sID
'Output:
'Last TSTestID = 95~3
' Set a specific TSTest by the ID
    Set theTSTest = TSTestFact.Item(sID)
    With theTSTest
    Debug.Print "TSTest by ID Name: " & .Name, "ID: " & .ID, _
        "TestID: " & .TestId, "Instance: " & .Instance
    End With
'Output:
'TSTest by ID Name: [3]TEST1.1.1.1_A ID: 95~3 TestID: 95 Instance: 3
Exit Sub
TSTestPropertiesErr:
    ErrHandler err, "TSTestProperties"
End Sub


%%PageItemTitle%% $$Members$$

TestSet Object

IBaseField2 Implemented Interface Members

See Also

TestSet Object


%%PageItemTitle%% $$Members$$

TestSet Object

ILinkable Implemented Interface Members

See Also

TestSet Object


%%ItemTitle%%

OTA COM Type Library

Running the test instances in a test set locally, remotely, or as planned

Source code

Public Sub RunTestSet(tsFolderName As String, tSetName As String, _
        HostName As String, runWhere As Integer)
' This example show how to run a test set in three different ways:
' Run all tests on the local machine (where this code runs)
' Run the tests on a specified remote machine
' Run the tests on the hosts as planned in the test set
    Dim TSetFact As TestSetFactory, tsList As list
    Dim theTestSet As TestSet
    Dim tsTreeMgr As TestSetTreeManager
    Dim tsFolder As TestSetFolder
    Dim Scheduler As TSScheduler
    Dim execStatus As ExecutionStatus
    On Error GoTo RunTestSetErr
    errmsg = "RunTestSet"
 ' Get the test set tree manager from the test set factory
    'tdc is the global TDConnection object.
    Set TSetFact = tdc.TestSetFactory
    Set tsTreeMgr = tdc.TestSetTreeManager
' Get the test set folder passed as an argument to the example code
    Dim nPath$
    nPath = "Root\" & Trim(tsFolderName)
    On Error Resume Next
    Set tsFolder = tsTreeMgr.NodeByPath(nPath)
    If tsFolder Is Nothing Then
        err.Raise vbObjectError + 1, "RunTestSet", "Could not find folder " & nPath
        GoTo RunTestSetErr
    End If
    On Error GoTo RunTestSetErr
' Search for the test set passed as an argument to the example code
    Set tsList = tsFolder.FindTestSets(tSetName)
    If tsList.Count > 1 Then
        MsgBox "FindTestSets found more than one test set: refine search"
    ElseIf tsList.Count < 1 Then
        MsgBox "FindTestSets: test set not found"
    End If
    Set theTestSet = tsList.Item(1)
    Debug.Print theTestSet.ID
'Start the scheduler on the local machine
    Set Scheduler = theTestSet.StartExecution("")
'Set up for the run depending on where the test instances
' are to execute.
    Select Case runWhere
        Case RUN_LOCAL
        'Run all tests on the local machine
            Scheduler.RunAllLocally = True
        Case RUN_REMOTE
        'Run tests on a specified remote machine
            Scheduler.TdHostName = HostName
            ' RunAllLocally must not be set for
            ' remote invocation of tests.
            ' Do not do this:
            ' Scheduler.RunAllLocally = False
        Case RUN_PLANNED_HOST
        'Run on the hosts as planned in the test set
            Dim TSTestFact As TSTestFactory, TestList As list
            Dim tsFilter As TDFilter
            Dim TSTst As TSTest
        'Get the test instances from the test set
            Set TSTestFact = theTestSet.TSTestFactory
            Set tsFilter = TSTestFact.Filter
            tsFilter.Filter("TC_CYCLE_ID") = theTestSet.ID
            Set TestList = TSTestFact.NewList(tsFilter.Text)
            Debug.Print "Test instances and planned hosts:"
        'For each test instance, set the host to run depending
        ' on the planning in the test set.
            For Each TSTst In TestList
                Debug.Print "Name: " & TSTst.Name & " ID: " & TSTst.ID & " Planned Host: " & TSTst.HostName
                Scheduler.RunOnHost(TSTst.ID) = TSTst.HostName
            Next TSTst
            Scheduler.RunAllLocally = False
    End Select
'Run the tests
    Scheduler.run
'Get the execution status object
    Set execStatus = Scheduler.ExecutionStatus
'Track the events and statuses
    Dim RunFinished As Boolean, iter As Integer, i As Integer
    Dim ExecEventInfoObj As ExecEventInfo, EventsList As list
    Dim TestExecStatusObj As TestExecStatus ', TestInstanceObj As ITSTest
    While ((RunFinished = False) And (iter < 100))
        iter = iter + 1
        execStatus.RefreshExecStatusInfo "all", True
        RunFinished = execStatus.Finished
        Set EventsList = execStatus.EventsList
        For Each ExecEventInfoObj In EventsList
            Debug.Print Tab; "Event: " & ExecEventInfoObj.EventDate & " " & _
                    ExecEventInfoObj.EventTime & " " & _
                    "Event Type: " & ExecEventInfoObj.EventType & " [Event types: " & _
                    "1-fail, 2-finished, 3-env fail, 4-timeout, 5-manual]"
        Next
        Debug.Print Tab; execStatus.Count & " exec status"
        For i = 1 To execStatus.Count
            Set TestExecStatusObj = execStatus.Item(i)
            Debug.Print Tab; "Iteration " & iter & " Status: " & _
                        " Test " & TestExecStatusObj.TestId & _
                        " ,Test instance " & TestExecStatusObj.TestInstance & _
                        " ,order " & TestExecStatusObj.TSTestId & " " & _
                        TestExecStatusObj.Message & ", status=" & _
                        TestExecStatusObj.Status
        Next i
        'Sleep() has to be declared before it can be used.
        'This is the module level declaration of Sleep():
        'Declare Sub Sleep Lib "kernel32" (ByVal dwMilliseconds As Long)
        Sleep (5000)
    Wend 'Loop While execStatus.Finished = False
    Debug.Print "Scheduler finished around " & CStr(Now)
    Debug.Print
Exit Sub
RunTestSetErr:
    ErrHandler err, err.Description, errmsg, False
End Sub


%%ItemTitle%%

OTA COM Type Library

Finding a unique test

Source code

Public Sub AddCoverage()
'This procedure locates a particular requirement and a
'particular test and adds the test to the requirement's coverage.
    Dim rFact As reqFactory
    Dim tfact As TestFactory
    Dim aTest As TDAPIOLELib.test
    Dim CoverList As list, TestList As list, reqList As list
    Dim theCoverTest As TDAPIOLELib.test
    Dim theReqToCover As Req
    Dim ReqFilter As TDFilter, TestFilter As TDFilter
    Dim idx% 'an index number
    On Error GoTo AddCoverageErr
'
'Get the requirement Factory.
    'tdc is the global TDConnection object.
    Set rFact = tdc.reqFactory
' Note that requirement names are not necessarily unique in
' the project.
' The demo project as delivered has only one 'Hotel Reservations',
' but another was created for this example.
    Set ReqFilter = rFact.Filter
    'Note double quote marks because of space in name.
    ReqFilter.Filter("RQ_REQ_NAME") = """Hotel Reservations"""
    Set reqList = rFact.NewList(ReqFilter.Text)
    Debug.Print "The number of requirements named Hotel Reservations = " & reqList.Count
    'The number of requirements named Hotel Reservations = 2
'
' Therefore, we'll limit our search to a single parent requirement
' folder, where requirement names are unique.
' To see the code of GetReqByPath, see example
' "Find a specified requirement in a specified folder"
' under Req and ReqFactory
    Dim reqPath$
    reqPath = "Mercury Tours Application" _
            & "\Online Travel Booking Services" _
            & "\Products/Services On Sale" _
            & "\Hotel Reservations"
    Set theReqToCover = GetReqByPath(reqPath)
' One alternative to the code in GetReqByPath is to
' read the Item ID from the user interface
' in the Requirements module.
    ' Set theReqToCover = RFact.Item(81)
                                    '
    With theReqToCover
    Debug.Print .Name, .Status, .Author
    'Hotel Reservations Failed alex_qc
    End With
                                    '
' Get a unique test by restricting selection to a specific subject node
    'tdc is the global TDConnection object.
    Set tfact = tdc.TestFactory
    Set TestFilter = tfact.Filter
    TestFilter.Filter("TS_NAME") = "Flight_Reservation_Stress"
    TestFilter.Filter("TS_SUBJECT") = """Subject\Flight Reservation"""
    ' There should only be one item in the List
    Set TestList = tfact.NewList(TestFilter.Text)
    Debug.Print TestList.Count ' output is 1
                                        '
    Set theCoverTest = TestList.Item(1)
    idx = theCoverTest.ID
    Debug.Print idx
'--------------------------------------------------------
' Use Req.GetCoverList to Check what coverage already exists.
' So that this example can run more than once, we
' remove the test we want to use if we find it.
' In production code, you'll probably exit if
' you find that the requirement is already covered
' by the test.
    Set CoverList = theReqToCover.GetCoverList
    Debug.Print CoverList.Count
    For Each aTest In CoverList
        With aTest
        Debug.Print .ID, .Name
        If .ID = idx Then
'--------------------------------------------------------
' Use Req.RemoveCoverage to remove the test from the List.
            theReqToCover.RemoveCoverage aTest
            theReqToCover.Post
        End If
        End With
    Next aTest
'--------------------------------------------------------
' Use Req.AddCoverage to add a test
' We now have the requirement and the test,
' so add the test to the requirement's coverage.
    theReqToCover.AddCoverage idx, TDPOSITION_LAST
' Now check again what coverage exists
    Set CoverList = theReqToCover.GetCoverList
    Debug.Print CoverList.Count
    For Each aTest In CoverList
        With aTest
        Debug.Print .ID, .Name
        End With
    Next aTest
' Save the change to the requirement object
' to the project database
    theReqToCover.Post
Exit Sub
AddCoverageErr:
ErrHandler err, "AddCoverage", CStr(err.Number - vbObjectError)
End Sub


%%PageItemTitle%% $$Members$$

Test Object

IAlertable2 Implemented Interface Members

See Also

Test Object


%%PageItemTitle%% $$Members$$

Test Object

IBaseField2 Implemented Interface Members

See Also

Test Object


%%PageItemTitle%% $$Members$$

Test Object

ICoverable Implemented Interface Members

See Also

Test Object


%%PageItemTitle%% $$Members$$

Test Object

IFollowUpManager Implemented Interface Members

See Also

Test Object


%%PageItemTitle%% $$Members$$

Test Object

ILinkable Implemented Interface Members

See Also

Test Object


%%ItemTitle%%

OTA COM Type Library

Unlock test

Source code

Public Sub UnLockTest()
'Unlock test
    Dim objTestFactory As testFactory
    Dim objTest As Test
    Set objTestFactory = tdc.testFactory
    Set objTest = objTestFactory.Item(3)
    objTest.LockObject
    MsgBox objTest.IsLocked
    objTest.UnLockObject
    MsgBox objTest.IsLocked
End Sub


%%PageItemTitle%% $$Members$$

TextParser Overview

TextParser Object Members

Public Methods

Public Method ClearParam | Clear the parameter - Set its value to null.
Public Method EvaluateText | Converts the parameters to their values.
Public Method Initialize | Initialization is generally performed by the infrastructure. Use this method after confirming the need with Mercury Support.

Public Properties

Public Property Count | Gets the number of parameters.
Public Property ParamExist | Checks if a parameter with the specified name exists.
Public Property ParamName | Gets the parameter name.
Public Property ParamType | Gets the user-defined Parameter Type.
Public Property ParamValue | The parameter value.
Public Property Text | The text to be parsed.
Public Property Type | Gets the Parameter Type - predefined, null, or regular.

See Also

TextParser Overview


%%PageItemTitle%% $$Members$$

Trace Overview

Trace Object Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property Field | The value of the specified field.
Public Property FromReq | The requirement from which the association is defined.
Public Property ID | The item ID.
Public Property IsLocked | Checks if object is locked.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property ToReq | The requirement to which the association is defined
Public Property TracedReq | The other requirement that the initiating requirement forms a trace with.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

Trace Overview


%%PageItemTitle%% $$Members$$

Trace Object

IBaseField2 Implemented Interface Members

See Also

Trace Object


%%PageItemTitle%% $$Members$$

TreeManager Overview

TreeManager Object Members

Public Properties

Public Property NodeById | Gets the object having the specified node Id.
Public Property NodeByPath | Gets the node at the specified tree path.
Public Property NodePath | Gets the node path, slash separated.
Public Property RootList | Gets list of available trees in the specified range.
Public Property TreeRoot | The root node specified by the node name.

See Also

TreeManager Overview


%%PageItemTitle%% $$Members$$

TreeManager Object

ISupportCopyPaste2 Implemented Interface Members

See Also

TreeManager Object


%%ItemTitle%%

OTA COM Type Library

Getting a root node object by name

Source code

Public Sub SubjectList()
    Dim TreeMgr As TreeManager
    Dim SubjRoot As SubjectNode
    Dim ChildNode As SubjectNode
    Dim GrandChildNode As SubjectNode
    Dim LeafNode As SubjectNode
    Dim RootName As String
    Dim Trees As list
    Dim i%
'-----------------------------------------------------
'Use TreeManager.TreeRoot to get the list of subject
' root nodes from the tree manager.
'There is only one item in this list.
    'tdc is the global TDConnection object.
    Set TreeMgr = tdc.TreeManager
    Set Trees = TreeMgr.RootList(TDOLE_SUBJECT)
'Get the name of the subject tree root in your project
    RootName = Trees.Item(1)
'------------------------------------------------------
'Get the SubjectNode root node object from the
' tree manager by name
    Set SubjRoot = TreeMgr.TreeRoot(RootName)
    Debug.Print "Root node : Name = " & SubjRoot.Name _
        & ", Depth = " & SubjRoot.DepthType _
        & ", Path = " & SubjRoot.Path
' Root node : Name = Subject, Depth = 2, Path = Subject
    For i = 1 To SubjRoot.Count
        Debug.Print SubjRoot.Child(i).Name
    Next i
' Flight Reservation
' Profiling
' Itinerary
' Compiled Modules
' Cruises
' Mercury Tours Site
' f1
' BPT Resources
' alexk
    Debug.Print "------------------------"
' Get any child node for example. We'll just take the first.
    Set ChildNode = SubjRoot.Child(1)
    Debug.Print "Child node: Name = " & ChildNode.Name _
        & ", Depth = " & ChildNode.DepthType _
        & ", Path = " & ChildNode.Path
' Child node: Name = Flight Reservation, Depth = 2, _
    Path = Subject\Flight Reservation
    For i = 1 To ChildNode.Count
        Debug.Print ChildNode.Child(i).Name
    Next i
' Flight Finder
' Select Flight
' Book Flight
' Flight Confirmation
' Flight Cost
    Debug.Print "------------------------"
' Get a node one more level down.
    Set GrandChildNode = ChildNode.Child(1)
    Debug.Print "GrandChild : Name = " & GrandChildNode.Name _
        & ", Depth = " & GrandChildNode.DepthType _
        & ", Path = " & GrandChildNode.Path
' GrandChild : Name = Flight Finder, Depth = 1, _
    Path = Subject\Flight Reservation\Flight Finder
    For i = 1 To GrandChildNode.Count
        Debug.Print GrandChildNode.Child(i).Name
    Next i
'Son of Flight Finder
'
    If GrandChildNode.Count > 0 Then _
        Set LeafNode = GrandChildNode.Child(1)
'
' The "Son of Flight Finder" node is not part of the
' demonstration project. It was added for this example,
' so if you run this code on your site, the routine will exit here.
    If LeafNode Is Nothing Then Exit Sub
    Debug.Print "LeafNode : Name = " & LeafNode.Name _
        & ", Depth = " & LeafNode.DepthType _
        & ", Path = " & LeafNode.Path
' LeafNode : Name = Son of Flight Finder, Depth = 0, _
Path = Subject\Flight Reservation\Flight Finder\Son of Flight Finder
End Sub


%%PageItemTitle%% $$Members$$

TSScheduler Overview

TSScheduler Object Members

Public Methods

Public Method Run | Starts execution the test set or of the specified tests.
Public Method Stop | Stops execution of the test set or the specified tests.

Public Properties

Public Property ExecutionLog | The execution error or log message sent by the remote agent.
Public Property ExecutionStatus | The execution status object for the scheduler execution.
Public Property HostTimeOut | The time to wait for response before either sending test to another host in group or failing.
Public Property LogEnabled | Indicates if logging is enabled.
Public Property RunAllLocally | Indicates if all tests are to be run on the local host.
Public Property RunOnHost | The host on which to execute the test instance.
Public Property TdHostName | The host on which to run all tests in the current scheduler execution.

See Also

TSScheduler Overview


%%PageItemTitle%% $$Members$$

TSTest Overview | TestSet Object | Test Object

TSTest Object Members

Public Methods

Public Method LockObject | Locks the object. Returns True if lock successful.
Public Method Post | Posts all changed values into database.
Public Method Refresh | Reads saved values, overwriting values in memory.
Public Method Undo | Undoes changes to field values that have not been posted.
Public Method UnLockObject | Unlocks the object.

Public Properties

Public Property Attachments | The Attachment factory for the object.
Public Property AutoPost | If true, the database is updated immediately when the field value changes.
Public Property ExecutionParams | The execution parameters for this test instance.
Public Property ExecutionSettings | The execution settings for this test instance.
Public Property Field | The value of the specified field.
Public Property HasAttachment | Checks if the object has one or more attachments.
Public Property HasCoverage | Checks if the test instance covers at least one requirement.
Public Property HasSteps | Checks if the planning test specified by the Test property has design steps.
Public Property History | The History object for the object.
Public Property HostName | The name of the host planned to run this test instance.
Public Property ID | The item ID.
Public Property Instance | The instance number of this execution test, within the other instances of the same test.
Public Property IsLocked | Checks if object is locked.
Public Property LastRun | The Run object of the last run.
Public Property Modified | Checks if the item has been modified since last refresh or post operation. If true, the field properties on the server side are not up to date.
Public Property Name | The name of this execution test. By convention, this is the test instance number and the test name.
Public Property Params | The step parameters for this execution test.
Public Property RunFactory | The Run Factory for this execution test.
Public Property Status | The execution test status.
Public Property Test | The planning test of which this execution test in an instance.
Public Property TestId | The ID of the design test of which this is an instance.
Public Property TestName | The name of the design test of which this is an instance.
Public Property TestSet | The test set to which the execution test belongs.
Public Property Type | The execution test type.
Public Property Virtual | Checks if this is a virtual item, that is, an item that does not have a corresponding database record.

See Also

TSTest Overview | TestSet Object | Test Object


%%PageItemTitle%% $$Members$$

TSTestFactory Overview

TSTestFactory Object Members

Public Methods

Public Method AddItem | Adds one or more tests to the test set.
Public Method NewList | Creates a list of objects according to the specified filter.
Public Method RemoveItem | Removes item from the database. Removal takes place immediately, without a Post.

Public Properties

Public Property FetchLevel | The Fetch level for a field.
Public Property Fields | The list of all available fields for the entity managed by the factory.
Public Property Filter | The TDFilter object for the factory.
Public Property History | The History object for this entity.
Public Property Item | Gets an object managed by the factory by its key.

See Also

TSTestFactory Overview


%%ItemTitle%%

OTA COM Type Library

Delete test instance

Source code

Private Sub DeleteTSTest()
'Delete test instance
    Dim tsTestF As TSTestFactory
    Set tsTestF = tdc.testsetFactory
    tsTestF.RemoveItem (17)
End Sub


%%PageItemTitle%% $$Members$$

TSTestFactory Object

IAlertableEntityFactory Implemented Interface Members

See Also

TSTestFactory Object


%%PageItemTitle%% $$Members$$

TSTestFactory Object

IBaseFactory2 Implemented Interface Members

See Also

TSTestFactory Object


%%PageItemTitle%% $$Members$$

TSTestFactory Object

ISupportCopyPaste2 Implemented Interface Members

See Also

TSTestFactory Object


%%PageItemTitle%% $$Members$$

TSTest Object

IAlertable2 Implemented Interface Members

See Also

TSTest Object


%%PageItemTitle%% $$Members$$

TSTest Object

IBaseField2 Implemented Interface Members

See Also

TSTest Object


%%PageItemTitle%% $$Members$$

TSTest Object

ICoverable Implemented Interface Members

See Also

TSTest Object


%%PageItemTitle%% $$Members$$

TSTest Object

IFollowUpManager Implemented Interface Members

See Also

TSTest Object


%%PageItemTitle%% $$Members$$

TSTest Object

ILinkable Implemented Interface Members

See Also

TSTest Object


%%PageItemTitle%% $$Members$$

VCS Overview

VCS Object Members

Public Methods

Public Method AddObjectToVcs | Adds an object to the Version control database.
Public Method CheckIn | Checks in an object.
Public Method CheckInEx | Checks in an object.
Public Method CheckOut | Checks out an object
Public Method DeleteObjectFromVCS | Deletes the object from the Version Control database.
Public Method LockVcsObject | Changes VCS object status from GET to CHECK-OUT. The object must be in a GET status to use this method.
Public Method Refresh | Refreshes the VCS object from the server to the client, overwriting values in memory.
Public Method SetCurrentVersion | This method is potentially destructive. Use only if necessary and with care. Sets the VCS object current version.
Public Method UndoCheckout | Undoes the check out operation, falling back to the current version on the server.

Public Properties

Public Property CheckoutInfo | A reference to a VersionItem object, containing the checkout information of the current object.
Public Property CurrentVersion | The current object latest version.
Public Property IsCheckedOut | Checks if the object is in CHECKED-OUT or GET status.
Public Property IsLocked | Checks if object is locked by the version control system.
Public Property LockedBy | The name of the locking user.
Public Property Version | The version the current user is viewing.
Public Property VersionInfo | A reference to a VersionItem object containing information about a specific version, specified by the Version argument.
Public Property Versions | A list of version strings, representing all the versions in the object.
Public Property VersionsEx | A list of IVersionItem references for accessing the details of each version in the object. .

See Also

VCS Overview


%%PageItemTitle%% $$Members$$

VersionItem Overview

VersionItem Object Members

Public Properties

Public Property Comments | The check-in comments.
Public Property Date | The check-in date.
Public Property IsLocked | Checks if the item is locked.
Public Property Time | The check-in time.
Public Property User | The user who performed the check-in.
Public Property Version | The version checked in.

See Also

VersionItem Overview